Marcado y acceso remotos : "Red digital de servicios integrados (ISDN), Señalización por canal asociado (CAS)"

Configuración de la interfaz de respaldo BRI con perfiles de marcado

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Esta configuración demuestra el uso de un circuito ISDN Basic Rate Interface (BRI) para respaldar una línea arrendada, una WAN o una conexión en serie.

Antes de comenzar

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

prerrequisitos

No hay requisitos previos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Teoría Precedente

El comando backup interface coloca a la interfaz en modo inactivo hasta que la interfaz primaria deja de funcionar. Para más información sobre la función de interfaz de respaldo, refiera a las evaluaciones de la interfaz de respaldo, a las Rutas estáticas flotantes, y al Monitoreo de marcado para el backup DDR.

Este ejemplo utiliza perfiles de marcador con la característica de interfaz de respaldo. Usando el comando backup interface fuerza la comprobación o la interfaz lógica configurada para estar en el modo de reserva. Con los perfiles del marcador, sólo el lógico (interfaz del marcador) se coloca en el modo en espera mientras que la interfaz física (BRI) todavía puede usarse para otras conexiones al convertirla en miembro de otros recursos compartidos. Si desea obtener más información sobre los perfiles de marcador, consulte Configuración de ISDN DDR con perfiles de marcador.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

La configuración de la copia de respaldo del Dial-on-demand Routing (DDR) consiste en tres pasos claros:

  1. Configuración DDR. Puede utilizar la DDR heredada (correspondencias de marcador) o el perfil de marcador. Esta configuración emplea los Perfiles de marcado. Verifique que su conexión DDR funcione correctamente antes de implementar la configuración de respaldo. Esto le permite verificar que el método de marcado utilizado, la negociación de Point-to-Point Protocol (PPP) y la autenticación sean satisfactorios antes de configurar la copia de respaldo. Para un mapa de marcado basado la configuración de respaldo, refiere al backup DDR del documento usando los BRI y el comando backup interface.

  2. Configure uno de los routers para iniciar la conexión DDR cuando falla el link primario. Esta configuración utiliza un comando de interfaz de copia de respaldo para activar el marcado de salida.

  3. Defina el tráfico interesante que activará la conexión de respaldo cuando el link primario falle.

Recomendamos que usted refiere a

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

/image/gif/paws/5721/bri-to-bri-backup.gif

Configuraciones

Esta configuración utiliza un circuito BRI para sostener un link serial. También utiliza el protocolo de routing Open Shortest Path First (OSPF) entre los dos routers. Una vez que se activa la conexión de respaldo, usted debe asegurarse de que la tabla de ruteo esté puesta al día para utilizar el nuevo link de backup. Solamente un lado (maui-soho-01) se configura para marcar hacia fuera. El otro lado (maui-nas-05) está configurado para aceptar la llamada solamente.

En esta configuración tenemos un Cisco 1604 Router conectado con un Cisco 3640 Router que usa una conexión en serie. Ambos routers están equipados con interfaces BRI que se utilizan para el link de respaldo. El Cisco 1604 está funcionando con el Software Release 12.1(5)T del ½ del ¿Â de Cisco IOSï y el Cisco 3640 está utilizando el Cisco IOS 12.1(2).

Nota: Configure la conexión DDR (marcador 1 con el BRI0) y verifiquela que está trabajando correctamente antes de que usted configure los comandos backup interface y backup delay. Esto le permitirá administrar efectivamente la solución de problemas de perfiles de marcador, ISDN, PPP y autenticación antes de configurar el respaldo.

maui-slt-01 (1600)
maui-soho-01#show running-config 
Building configuration...

Current configuration : 1687 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-soho-01
!
logging rate-limit console 10 except errors
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- Basic AAA configuration for ppp calls.

enable secret 5 <deleted>
!
username maui-nas-05 password 0 cisco

!--- Username for remote router (maui-nas-05) and shared secret(used for
!--- CHAP authentication).
!--- Shared secret must be the same on both sides.

ip subnet-zero
no ip finger
!
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.17.1.1 255.255.255.0

!--- The loopback address will be used by OSPF for the router ID.

!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0

!--- Primary Interface

 backup delay 10 30

!--- Backup link will be activated 10 seconds after primary link goes down.
!--- Backup link will be deactivated 30 seconds after primary link is restored.

 backup interface Dialer1

!--- Interface Dialer 1 will provide backup. Dialer 1 will be placed in Standby
!--- until the primary link goes down.

 ip address 192.168.10.2 255.255.255.252
 encapsulation ppp
 no fair-queue
 clockrate 64000
 ppp authentication chap
!
interface BRI0
 no ip address
 encapsulation ppp
 dialer pool-member 10

!--- Assign BRI0 as member of dialer pool 10.
!--- Dialer pool 10 is specified in interface Dialer 1.

 isdn switch-type basic-ni
 isdn spid1 51255511110101 5551111
 isdn spid2 51255511120101 5551112
 ppp authentication chap

!--- Use PPP CHAP authentication.

 ppp multilink
!
interface Dialer1

!--- Dialer 1 provides backup for the serial link.
!--- This interface will be in standby until the primary link is down.

 ip address 172.20.10.2 255.255.255.0

!--- Address for the dialer interface. 
!--- The remote side dialer interface is in the same subnet.

 encapsulation ppp
 dialer pool 10

!--- Defines Dialer pool 10.
!--- BRI 0 is a member of this pool.

 dialer remote-name maui-nas-05

!--- Specifies remote router name. 
!--- This name must match that used by the remote router to authenticate itself.

 dialer idle-timeout 900

!--- Idle timeout is set to 900 seconds (15 minutes).
!--- The link will be disconnected if there is no interesting traffic for 900 secs.
!--- Since OSPF hellos are interesting traffic, this will reset the idle timeout
!--- and cause the link to stay up until the primary link is restored and the dialer
!--- returns to standby mode.

 dialer string 5552222

!--- Defines the destination routers phone number.

 dialer load-threshold 80 outbound

!--- This sets the outbound load level for traffic at which 
!--- additional connections will be added to the MP bundle load level.
!--- Values range from 1 (unloaded) to 255 (fully loaded). The threshold
!--- in this case is 80/255=32%.

 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.

 ppp authentication chap

!--- Use PPP CHAP authentication.

 ppp multilink
!
router ospf 5

!--- OSPF configuration. You can use any routing protocol here without any other
!--- changes to the configuration.

 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0
 network 172.17.1.0 0.0.0.255 area 0
 network 172.20.10.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit

!--- All IP traffic is designated as interesting.
!--- This is applied to Interface Dialer 1 using dialer-group 1.
!--- OSPF hello packets will trigger the dial.

!
line con 0
 exec-timeout 0 0
 login authentication NO_AUTHEN
 transport input none
line vty 0 4
!
end

Observe las puntas siguientes en la configuración del maui-soho-01:

  • El link de respaldo utiliza perfiles de marcador. Esto permite que la interfaz de copia de respaldo (Marcador 1) permanezca en modo de espera mientras la interfaz física (BRI 0) no lo está. Esto permite que uno utilice la interfaz física (haciéndole a un miembro de diversos recursos compartidos de dialers) mientras que el link principal es activo. Para más información sobre los Perfiles de marcado, refiera a

  • El router utiliza el OSPF como el Routing Protocol. Usted puede utilizar cualquier otro Routing Protocol (por ejemplo, RIP, EIGRP) aquí también. Refiera a la guía de configuración del Routing Protocol apropiada IPC: Parte 2: IP Routing Protocol. Asegúrese de incluir la red de la interfaz principal y la de la interfaz de reserva en la configuración del protocolo de ruteo, de manera que éste pueda distribuir la información. Si usted desea utilizar las Static rutas en vez de un Routing Protocol, cree una Static ruta con el salto siguiente que es la interfaz del BRI remoto (usted puede tener que hacerle las Rutas estáticas flotantes dependiendo del escenario).

  • Cualquier tráfico de IP activará la marcación (basada en la lista de marcador 1 y en el grupo de marcador 1) Esto trabaja bien en un entorno del backup DDR de la Interfaz de respaldo puesto que el link de backup estará en el modo de reserva e incapaz de marcar cuando el primario está para arriba de todos modos. Dado que el link de respaldo requiere un tráfico interesante para marcarlo, compruebe que posea un origen de tráfico que genere tráfico interesante. En este ejemplo, los paquetes de saludo OSPF dispararán el marcado. Si no está usando un protocolo de ruteo, puede usar comandos ping ICMP para marcar el link de respaldo. Ajuste el tráfico interesante según sus necesidades.

maui-nas-05 (3640)
maui-nas-05#show running-config 
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-nas-05
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- Basic AAA configuration for ppp calls.

enable secret 5 <deleted>
!
username maui-soho-01 password 0 cisco

!--- Username for remote router (maui-soho-01) and shared secret
!---(used for CHAP authentication).
!--- Shared secret must be the same on both sides.

ip subnet-zero
!         
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.22.1.1 255.255.255.0

!--- The loopback address will be used by OSPF for the router ID.

!
interface Ethernet0/0
 ip address 172.22.53.105 255.255.255.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface BRI1/0
 ip unnumbered Loopback0

!--- Unnumbered to the Loopback 0 address.

 encapsulation ppp
 dialer pool-member 20

!--- Assign BRI0 as member of dialer pool 20.
!--- Dialer pool 20 is specified in interface Dialer 1.

 isdn switch-type basic-ni
 isdn spid1 51255522220101 5552222
 isdn spid2 51255522230101 5552223
 ppp authentication chap

!--- Use ppp chap authentication.

 ppp multilink
!

! <<-- Unused interface configurations have been removed.

!
interface Serial2/0

!--- Primary interface.

 ip address 192.168.10.1 255.255.255.252
 encapsulation ppp
 no fair-queue
 ppp authentication chap
!

! <<--Unused interface configurations have been removed.

!
interface Dialer1

!--- Dialer 1 provides backup for the serial link.
!--- Notice that there is no dialer string on this router. This prevents the NAS
!--- from attempting to dialout using the backup circuit when the primary is up.

 ip address 172.20.10.1 255.255.255.0

!--- Address for the dialer interface. 
!--- The remote side dialer interface is in the same subnet.

 encapsulation ppp
 dialer remote-name maui-soho-01

!--- Specifies remote router name. 
!--- This name must match that used by the remote router to authenticate itself.

 dialer pool 20

!--- Defines dialer pool 20.

 dialer idle-timeout 900

!--- Idle timeout is set to 900 seconds (15 minutes).
!--- This is equal to the idle timeout set on maui-soho-01.

 dialer max-call 4096
 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.

 ppp authentication chap

!--- Use ppp chap authentication.

 ppp multilink
!
router ospf 5
 network 172.20.10.0 0.0.0.255 area 0
 network 172.22.1.0 0.0.0.255 area 0
 network 172.22.53.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
 default-information originate

!--- Transmit ospf default information. 
!--- This may be required for remote router to use the BRI DDR link.

!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
no ip http server
!
dialer-list 1 protocol ip permit

!--- All IP traffic is designated as interesting.
!--- This is applied to Interface Dialer 1 using dialer-group 1.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
line 97 102
line aux 0
line vty 0 4
!
end

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

Verifique los siguientes puntos en la configuración del servidor maui-nas-05 (3640):

  • La configuración es similar a cualquier configuración de marcado de entrada. Por lo que el NAS el link de backup es apenas otra llamada entrante.

  • La interfaz del marcador no posee una cadena de marcado y, por lo tanto, no puede realizar el marcado de salida.

  • Todo el tráfico es interesante. Debido a que el link de respaldo no puede realizar un marcado de salida (consulte el anuncio anterior), esto es aceptable. Si usted hace el tráfico interesante más restrictivo (por ejemplo, el Routing Protocol es sin interés), después hay la posibilidad que el NAS podría desconectar la llamada si ningún tráfico interesante a través del link. En escenarios de respaldo es mejor dejar que un lado (ya sea el lado de marcado de salida o el lado de marcado de entrada) controle el link de respaldo para evitar la inestabilidad del link.

Prueba del link de respaldo

La Interfaz de respaldo requiere que el protocolo de la interfaz primaria esté abajo antes de que la Interfaz de respaldo incluso se ponga en evidencia del modo de reserva. Por lo tanto, no es posible probar el link de respaldo sin hacer caer físicamente el link principal. Las opciones son:

  • Utilice el comando shutdown de apagar la interfaz primaria. Sin embargo, no utilice el comando shutdown en el router con el comando backup interface configurado. Esto no hará el Cisco IOS Software marcar el link de backup. Puede activar la copia de seguridad cerrando la interfaz primaria del router que no tiene comando de copia de seguridad de interfaz. En nuestro escenario, el comando backup interface está configurado en maui-soho-01 (1600). Por lo tanto, la ejecución de un comando shutdown en la interfaz primaria del maui-nas-05 (3640) activará el link de backup.

  • Derribe físicamente la conexión primaria desenchufando los cables o un cierto método equivalente para sacar a colación la Interfaz de respaldo.

Comandos show

La herramienta del Output Interpreter soportan a los ciertos comandos show, que permite que usted vea una análisis de la salida del comando show.

  • isdn status de la demostración - Asegúrese de que el router esté comunicando correctamente con el switch ISDN. Verifique en el resultado que el estado de la capa 1 sea ACTIVE (Activo) y que aparezca MULTIPLE_FRAME_ESTABLISHED en la capa 2. Este comando muestra también el número de llamadas activas.

  • muestre la descripción de la interfaz del IP - Esto mostrará el marcador 1 (en el maui-soho-01) en el modo de reserva. El uso del marcador 1 como interfaz de respaldo indica que la interfaz física (BRI0) no está dedicada al respaldo. Por lo tanto, el BRI0 se puede utilizar para el DDR normal mientras que el link principal está para arriba.

Ejemplo de resultado del comando show

Los productos siguientes muestran la tabla de ruteo en el lado del cliente. La salida abajo muestra la tabla de ruteo con el active del link principal.

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.10.1 to network 0.0.0.0

     192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.10.0/30 is directly connected, Serial0
C       192.168.10.1/32 is directly connected, Serial0
     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/24 is subnetted, 1 subnets
O       172.20.10.0 [110/1849] via 192.168.10.1, 00:00:10, Serial0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/74] via 192.168.10.1, 00:00:11, Serial0
O       172.22.1.1/32 [110/65] via 192.168.10.1, 00:00:11, Serial0
O*E2 0.0.0.0/0 [110/1] via 192.168.10.1, 00:00:11, Serial0

La salida de la ruta de IP de la demostración (mostrada arriba) visualiza las OSPF rutas aprendidas del par que usa el link principal (serial0). Ahora déjenos derriban el link principal y activan el link de backup.

Después de que se active el link de backup, tabla OSPF se intercambia y las nuevas rutas usando el link de backup están instaladas. El tráfico ahora fluye a través del link de backup.

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.20.10.1 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.20.10.0/24 is directly connected, Dialer1
C       172.20.10.1/32 is directly connected, Dialer1
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/1572] via 172.20.10.1, 00:00:01, Dialer1
O       172.22.1.1/32 [110/1563] via 172.20.10.1, 00:00:02, Dialer1
O*E2 0.0.0.0/0 [110/1] via 172.20.10.1, 00:00:02, Dialer1

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Comandos de Debug

Antes de ejecutar un comando debug, consulte Información Importante sobre Comandos Debug.

  • debug dialer - Se utiliza para mostrar la información DDR sobre los paquetes recibidos en la interfaz del marcador.

  • debug isdn events - Esto se utiliza para ver la actividad de ISDN que tiene lugar en el lado del usuario de la interfaz de ISDN.

  • debug isdn q931: muestra la configuración de la llamada y cierra la conexión de red ISDN (Capa 3) entre el router y el switch ISDN.

  • debug ppp negotiation - Muestra la información sobre los intercambios y el tráfico de PPP mientras negocia los componentes del PPP que incluyen el LCP (Protocolo de control de link), la autenticación y el NCP. Una negociación PPP exitosa abrirá primero el estado LCP, luego realizará la autenticación y por último negociará el NCP.

  • debug ppp authentication – Muestra los mensajes del protocolo de autenticación PPP, entre ellos intercambio de paquetes de protocolo de autenticación por desafío mutuo (CHAP) e intercambios de protocolo de autenticación de contraseña (PAP). Si observa alguna falla, compruebe que el nombre de usuario chap y la contraseña sean correctos.

  • debug ppp error - Se utiliza para mostrar los errores de protocolo y las estadísticas de error relacionadas con la negociación y el funcionamiento de las conexiones PPP.

Solución de problemas de respaldo de DDR

Configure y verifique que la conexión DDR (Dialer1 y BRI0) está funcionando correctamente antes de que usted configure los comandos backup interface y backup delay. Esto le permite verificar si el perfil de marcador, ISDN, PPP y autenticación funciona correctamente antes de configurar el respaldo. Para resolver problemas el link DDR, refiera a la tecnología de marcación manual: Técnicas de resolución de problemas.

Ahora que usted ha verificado que la conexión DDR está funcionando correctamente, usted puede proceder a los pasos de Troubleshooting de reserva siguientes delineados abajo:

  • Reduzca el link principal. No utilice el comando shutdown en el router con el comando de interfaz de reserva configurado. Esto no hace que el software del IOS de Cisco marque el link de respaldo. Puede activar la copia de seguridad cerrando la interfaz primaria del router que no tiene comando de copia de seguridad de interfaz. En nuestro escenario, el comando backup interface está configurado en maui-soho-01 (1600). Por lo tanto, la ejecución de un comando shutdown en la interfaz primaria del maui-nas-05 (3640) activa el link de backup. También, usted puede derribar físicamente la conexión primaria desenchufando los cables o un cierto método equivalente para sacar a colación la Interfaz de respaldo.

  • Debería ver un mensaje de la consola que indique que la interfaz de respaldo (interfaz dialer 1) está en funcionamiento. Este mensaje aparece solamente después de la duración del intervalo especificada por el comando backup delay ha expirado. En esta configuración, el retardo de activación de respaldo es de 10 segundos. Si no ve este mensaje de la consola, verifique el temporizador de retraso de respaldo.

    *Mar  1 03:37:31.788: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    *Mar  1 03:37:42.719: %LINK-3-UPDOWN: Interface Dialer1, changed state to up
    
  • Use el comando show ip route para ver la tabla de ruteo con el link primario fuera de servicio. Usted debe observar una ruta conectada directamente al ping del marcador 1. la dirección IP de la interfaz del dialer del router remoto (que está en la misma subred como marcador de la interfaz 1). Debería ver la marcación de link y conectarse.

    • Si el link no marca, verifique que su definición de tráfico interesante permita ICMP (ping).

    • Si aparece el link, puede concluir que el problema se produjo debido a que no había tráfico destinado a esa subred. Sin embargo, no es realista obligar al link de respaldo a marcar basándose en un ping a un host particular. Para solucionar este problema podemos configurar una ruta estática flotante para el tráfico predeterminado.

      maui-soho-01(config)#ip route 0.0.0.0 0.0.0.0 172.20.10.1 200 
      

      La ruta predeterminado antedicha tiene una dirección del salto siguiente de una distancia administrativa del router remoto de la interfaz del dialer y de 200. Esta ruta flotante permite al router a los paquetes de Routes a la interfaz del dialer si no existe una mejor ruta predeterminado (es decir, con una distancia administrativa menor). Recuerde que verificamos previamente que los paquetes ruteados a la interfaz del dialer hagan el link marcar.

  • Si el router marca el link, pero no puede conectar, después es no más un problema del backup DDR y usted debe referir a la tecnología de marcación manual: Técnicas de Troubleshooting para Asistencia Adicional.

Refiera a la Interfaz de respaldo del troubleshooting de la sección en

Ejemplo de resultado del comando debug

La salida de los debugs siguiente (del cliente) muestra el fall del link principal y activar del link de backup:

Nota: Algunas líneas de salida de los debugs están rotas en las líneas múltiples para los propósitos de la impresión.

maui-soho-01#show debug

maui-soho-01#debug dialer
Dial on demand events debugging is on
maui-soho-01#debug isdn q931
ISDN Q931 packets debugging is on
maui-soho-01#debug ppp negotiation
PPP protocol negotiation debugging is on
maui-soho-01#debug ppp authentication 
PPP authentication debugging is on
maui-soho-01#
*Mar  1 01:09:24.872: %LINK-3-UPDOWN: Interface Serial0, changed state to down

!--- Primary link is unplugged.
!--- Refer to the section Testing the Backup Link for the appropriate procedure.

*Mar  1 01:09:24.880: Se0 IPCP: State is Closed
*Mar  1 01:09:24.884: Se0 CDPCP: State is Closed
*Mar  1 01:09:24.888: Se0 PPP: Phase is TERMINATING [0 sess, 0 load]
*Mar  1 01:09:24.892: Se0 LCP: State is Closed
*Mar  1 01:09:24.892: Se0 PPP: Phase is DOWN [0 sess, 0 load]
*Mar  1 01:09:24.908: Se0 IPCP: Remove route to 192.168.10.1
*Mar  1 01:09:24.916: %OSPF-5-ADJCHG: Process 5, Nbr 172.22.1.1 on Serial0
 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar  1 01:09:25.864: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0,
 changed state to down

!--- Primary interface line protocol is down. This must happen before the backup
!--- interface is brought out of standby.

*Mar  1 01:09:34.824: Di1 DDR is shutdown, could not clear interface.
*Mar  1 01:09:34.840: BR0 DDR: rotor dialout [priority]

!--- Note: The backup interface was activated 10 seconds after the primary
!--- link went down. This interval was defined with the backup delay command
!--- in maui-soho-01 (1600).

*Mar  1 01:09:34.848: BR0 DDR: Dialing cause ip (s=172.20.10.2, d=224.0.0.5)

!--- OSPF hellos cause the router to dial.

*Mar  1 01:09:34.852: BR0 DDR: Attempting to dial 5552222

!--- Phone number of the remote router that is dialed.

*Mar  1 01:09:34.876: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x0A
*Mar  1 01:09:34.888:         Bearer Capability i = 0x8890
*Mar  1 01:09:34.895:         Channel ID i = 0x83
*Mar  1 01:09:34.903:         Keypad Facility i = '5552222'
*Mar  1 01:09:35.169: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x8A
*Mar  1 01:09:35.177:         Channel ID i = 0x89
*Mar  1 01:09:35.415: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x8A

!--- Call is connected.

*Mar  1 01:09:35.439: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
*Mar  1 01:09:35.447: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1
*Mar  1 01:09:35.463: BR0:1 PPP: Treating connection as a callout

!--- PPP negotiation begins.

*Mar  1 01:09:35.467: BR0:1 PPP: Phase is ESTABLISHING, Active Open
 [0 sess, 0 load]
*Mar  1 01:09:35.479: BR0:1 LCP: O CONFREQ [Closed] id 14 len 34
*Mar  1 01:09:35.483: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.487: BR0:1 LCP:    MagicNumber 0x10BC0680 (0x050610BC0680)
*Mar  1 01:09:35.491: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.495: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130F016D6175692D736F686F2D3031)
*Mar  1 01:09:35.511: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x0A
*Mar  1 01:09:35.566: BR0:1 LCP: I CONFREQ [REQsent] id 6 Len 33
*Mar  1 01:09:35.570: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.574: BR0:1 LCP:    MagicNumber 0x30D37ABB (0x050630D37ABB)
*Mar  1 01:09:35.578: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.582: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130E016D6175692D6E61732D3035)
*Mar  1 01:09:35.590: BR0:1 LCP: O CONFACK [REQsent] id 6 Len 33
*Mar  1 01:09:35.598: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.602: BR0:1 LCP:    MagicNumber 0x30D37ABB (0x050630D37ABB)
*Mar  1 01:09:35.606: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.610: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130E016D6175692D6E61732D3035)
*Mar  1 01:09:35.618: BR0:1 LCP: I CONFACK [ACKsent] id 14 Len 34
*Mar  1 01:09:35.622: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.626: BR0:1 LCP:    MagicNumber 0x10BC0680 (0x050610BC0680)
*Mar  1 01:09:35.630: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.637: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130F016D6175692D736F686F2D3031)
*Mar  1 01:09:35.641: BR0:1 LCP: State is Open
*Mar  1 01:09:35.645: BR0:1 PPP: Phase is AUTHENTICATING, by both
 [0 sess, 1 load]

!--- PPP authentication begins.

*Mar  1 01:09:35.649: BR0:1 CHAP: O CHALLENGE id 6 Len 33 from "maui-soho-01"

!--- This is the username used for outgoing CHAP challenge. The remote router
!--- must have this username configured along with shared secret.

*Mar  1 01:09:35.657: BR0:1 CHAP: I CHALLENGE id 6 Len 32 from "maui-nas-05"

!--- This is the username for incoming CHAP challenge.
!--- This username must be locally configured.

*Mar  1 01:09:35.760: BR0:1 CHAP: O RESPONSE id 6 Len 33 from "maui-soho-01"
*Mar  1 01:09:35.804: BR0:1 CHAP: I SUCCESS id 6 Len 4
*Mar  1 01:09:35.808: BR0:1 CHAP: I RESPONSE id 6 Len 32 from "maui-nas-05"
*Mar  1 01:09:35.820: BR0:1 CHAP: O SUCCESS id 6 Len 4

!--- CHAP authentication is successful.

*Mar  1 01:09:35.828: BR0:1 PPP: Phase is VIRTUALIZED [0 sess, 1 load]
*Mar  1 01:09:35.844: Di1 DDR: Authenticated host maui-nas-05 with no matching
 dialer map
*Mar  1 01:09:35.848: Di1 PPP: Phase is UP [0 sess, 1 load]
*Mar  1 01:09:35.856: Di1 IPCP: O CONFREQ [Closed] id 6 Len 10
*Mar  1 01:09:35.860: Di1 IPCP:    Address 172.20.10.2 (0x0306AC140A02)
*Mar  1 01:09:35.872: Di1 CDPCP: O CONFREQ [Closed] id 6 Len 4
*Mar  1 01:09:35.876: BR0:1 MLP: maui-nas-05, multilink up, first link
*Mar  1 01:09:35.884: BR0:1 IPCP: MLP bundle interface is built,
 process packets now 
*Mar  1 01:09:35.887: BR0:1 IPCP: Redirect packet to Di1
*Mar  1 01:09:35.891: Di1 IPCP: I CONFREQ [REQsent] id 6 Len 10
*Mar  1 01:09:35.895: Di1 IPCP:    Address 172.20.10.1 (0x0306AC140A01)
*Mar  1 01:09:35.903: Di1 IPCP: O CONFACK [REQsent] id 6 Len 10
*Mar  1 01:09:35.907: Di1 IPCP:    Address 172.20.10.1 (0x0306AC140A01)
*Mar  1 01:09:35.911: BR0:1 CDPCP: MLP bundle interface is built,
 process packets now 
*Mar  1 01:09:35.915: BR0:1 CDPCP: Redirect packet to Di1
*Mar  1 01:09:35.919: Di1 CDPCP: I CONFREQ [REQsent] id 6 Len 4
*Mar  1 01:09:35.927: Di1 CDPCP: O CONFACK [REQsent] id 6 Len 4
*Mar  1 01:09:35.931: Di1 IPCP: I CONFACK [ACKsent] id 6 Len 10
*Mar  1 01:09:35.935: Di1 IPCP:    Address 172.20.10.2 (0x0306AC140A02)
*Mar  1 01:09:35.939: Di1 IPCP: State is Open

!--- IPCP state is open and route will be installed.

*Mar  1 01:09:35.951: Di1 CDPCP: I CONFACK [ACKsent] id 6 Len 4
*Mar  1 01:09:35.955: Di1 CDPCP: State is Open
*Mar  1 01:09:35.959: Di1 DDR: dialer protocol up
*Mar  1 01:09:35.971: Di1 IPCP: Install route to 172.20.10.1

!--- Route to remote side is installed.

*Mar  1 01:09:36.840: %LINK-3-UPDOWN: Interface Dialer1, changed state to up
*Mar  1 01:09:36.844: Di1 LCP: Not allowed on a Dialer Profile
*Mar  1 01:09:36.848: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
 changed state to up
*Mar  1 01:09:41.411: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5552222
 maui-nas-05

!--- Connection is up.

*Mar  1 01:09:44.931: %OSPF-5-ADJCHG: Process 5, Nbr 172.22.1.1 on
 Dialer1 from LOADING to FULL, Loading Done

!--- OSPF database exchange is complete.


Información Relacionada


Document ID: 5721