Marcado y acceso remotos : "Red digital de servicios integrados (ISDN), Señalización por canal asociado (CAS)"

Configuración de respaldo DDR mediante BRI y la función de control de discado

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento enseña el uso de una línea de Interfaz de velocidad básica (BRI) e ISDN para respaldar una línea alquilada, de WAN o una conexión en serie mediante la función de dialer match. Si desea obtener más información sobre las características de vigilancia de marcador, consulte Evaluación de interfaces de respaldo, rutas estáticas flotantes y vigilancia de marcador para respaldo de DDR.

Antes de comenzar

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

prerrequisitos

No hay requisitos previos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las versiones de software y hardware indicadas a continuación.

  • Un Cisco 1604 con 1 interfaz BRI U que funciona con el Software Release 12.1(5)T de Cisco IOS�.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Teoría Precedente

Este ejemplo utiliza el Legacy Dial-on-Demand Routing (DDR), que utiliza el comando dialer map para la conexión BRI. También, puede utilizar perfiles de marcador en vez de DDR heredada (mapas del marcador). Para obtener más información sobre los perfiles de marcador, consulte Configuración de DDR de ISDN con perfiles de marcador.

La configuración de respaldo de DDR incluye dos pasos diferentes:

  1. Configure el DDR ya sea con legacy DDR o con los perfiles dialer. Verifique que su conexión DDR funcione correctamente antes de implementar la configuración de respaldo. Esto le permitirá corroborar que el método de marcado utilizado, la negociación del Point-to-Point Protocol (PPP) y la autenticación sean exitosos antes de configurar el backup.

  2. Configuración del router para iniciar el respaldo de la conexión DDR cuando falla el link primario. Esta configuración utiliza la característica Dialer watch (Vigilancia de marcador) para activar el marcado de salida.

Para más información sobre los pasos necesarios para configurar el soporte, consulte el documento Configuración y resolución de problemas de respaldo DDR.

Función de vigilancia de programas ‘dialer’

Con la vigilancia de programas de marcado, el router monitorea la existencia de una ruta especificada y si esa ruta no está presente, comienza a marcar desde el link de respaldo. A diferencia de otros métodos de respaldo (como la interfaz de respaldo y las rutas estáticas flotantes), la vigilancia de programas de marcado no necesita que haya un tráfico interesante para disparar el marcado. A continuación se describe el proceso utilizado por la vigilancia de marcador :

  • Cuando se elimina una ruta vigilada, la vigilancia de programas dialer verifica al menos una ruta válida para cualquiera de las direcciones IP o de las redes vigiladas.

    • Si no hay una ruta válida, la línea primaria se considera desactivada e inutilizable.

      • La vigilancia de marcador inicia luego la llamada y los routers se conectan e intercambian información de ruteo. Todo el tráfico para la red remota ahora utilizará el link de respaldo.

    • Si hay una ruta válida para al menos una de las redes definidas y vigiladas de IP y la ruta señala a una interfaz que no es la interfaz de respaldo configurada para la vigilancia de programas dialer, el link primario se considera encendido y la vigilancia de programas dialer no inicia el link de respaldo.

  • Después de que empiece a funcionar el link de respaldo, se revisa nuevamente el link principal en el momento en que expira cada tiempo de espera inactivo. Si el link principal permanece sin funcionar, el temporizador ocioso se reinicia. Puesto que el router debe marcar periódicamente si se ha restablecido el link principal, configure un pequeño valor para el ocioso-descanso del marcador. Cuando se restablece el link primario, el protocolo de ruteo actualiza la tabla de ruteo y todo el tráfico debería volver a pasar al link primario. Dado que el tráfico ya no pasará por el link de respaldo, el tiempo de espera ocioso caducará y el router desactivará el link de respaldo.

    Nota: Al definir el tráfico interesante, niegue el tráfico del Routing Protocol para evitar que el hellos periódico reajuste el tiempo de inactividad.

  • Si el link principal se reactiva, el link de respaldo secundario se desconectará. Sin embargo, puede implementar un temporizador de inhabilitación para que haya un retraso antes de suprimirse el link de respaldo una vez que el link primario se recuperó. Este temporizador de retardo es activado cuando finaliza el temporizador de inactividad, y la ruta principal está activa. Este temporizador de retraso puede asegurar estabilidad, especialmente para interfaces flapping o que sufren cambios frecuentes de ruta.

Si desea obtener más información sobre las características de vigilancia de marcador, consulte Evaluación de interfaces de respaldo, rutas estáticas flotantes y vigilancia de marcador para respaldo de DDR.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

/image/gif/paws/5600/bri-backup-map-watch.gif

Configuraciones

Esta configuración emplea un circuito BRI para hacer una copia de seguridad de un link serial. Esta configuración también usa el protocolo de ruteo OSPF (Abrir la ruta más corta en primer lugar) entre los dos routers. Una vez activada la conexión de respaldo, debe cerciorarse de que la tabla de ruteo esté actualizada a fin de utilizar la nueva ruta de respaldo.

Para obtener más información sobre convenciones de comandos, consulte las Convenciones de Recomendaciones Técnicas de Cisco.

maui-slt-01 (1600)
maui-soho-01#show running-config 
Building configuration...

Current configuration : 1546 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname maui-soho-01
!
logging rate-limit console 10 except errors
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for ppp calls.

enable secret 5 <deleted>!
username maui-nas-05 password 0 cisco

!--- Username for remote router (maui-nas-05) and shared secret.
!--- Shared secret (used for CHAP) must be the same on both sides.

ip subnet-zero
no ip finger
!
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.17.1.1 255.255.255.0
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0

!--- Primary link

 ip address 192.168.10.2 255.255.255.252
 encapsulation ppp
 ppp authentication chap
!
interface BRI0
 ip address 172.20.10.2 255.255.255.0

!--- IP address for the BRI interface (backup link)

 encapsulation ppp
 dialer idle-timeout 30

!--- Idle timeout (in seconds) for this backup link.
!--- Dialer watch checks the status of the primary link every time the
!--- idle-timeout expires.

 dialer watch-disable 15

!--- Delays disconnecting the backup interface for 15 seconds after the
!--- primary interface is found to be up, that is 15 seconds after the idle 
!--- timeout expired after the primary link came UP.

 dialer load-threshold 1 outbound

!--- This sets the load level for traffic at which additional connections
!--- will be added to the Multilink PPP bundle.
!--- Load level values range from 1 (unloaded) to 255 (fully loaded).

 dialer map ip 172.20.10.1 name maui-nas-05 broadcast 5551111

!--- Dialer map for the BRI interface of the remote router.

 dialer map ip 172.22.53.0 name maui-nas-05 broadcast 5551111

!--- Map statement for the route/network being watched by the
!--- dialer watch-list command
!--- This address must exactly match the network configured with the
!--- dialer watch-list command.
!--- When the watched route disappears, this dials the specified
!--- phone number.  

 dialer watch-group 8

!--- Enable dialer watch on this backup interface.
!--- Watch the route specified with dialer watch-list 8.

 dialer-group 1

!--- Apply interesting traffic defined in dialer-list 1.

 isdn switch-type basic-ni
 isdn spid1 51255522220101 5552222
 isdn spid2 51255522230101 5552223

!--- SPID information. Contact your telco for the SPID format.
!--- In many parts of the world, SPIDs are not required. 
!--- In such cases, omit the above two commands.

 ppp authentication chap

!--- Use CHAP authentication.

 ppp multilink

!--- Enable Multilink.

!
router ospf 5
 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0
 network 172.17.1.0 0.0.0.255 area 0
 network 172.20.10.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
!
ip classless
no ip http server
!
dialer watch-list 8 ip 172.22.53.0 255.255.255.0

!--- This defines the route(s) to be watched.
!--- This exact route (including subnet mask) must exist in the 
!--- routing table. Use the dialer watch-group 8 command to apply this
!--- list to the backup interface.

access-list 101 remark Define Interesting Traffic
access-list 101 deny   ospf any any

!--- Mark OSPF as uninteresting.
!--- This will prevent OSPF hellos from keeping the link up.

access-list 101 permit ip any any
dialer-list 1 protocol ip list 101

!--- Interesting traffic is defined by access-list 101.
!--- This is applied to BRI0 using dialer-group 1.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
line vty 0 4
!         
end

maui-nas-05 (3640)
maui-nas-05#show running-config 
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname maui-nas-05
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for PPP calls.

enable secret 5 <deleted> !
username maui-soho-01 password 0 cisco

!--- Username for remote router (maui-soho-01) and shared secret.
!--- Shared secret(used for CHAP authentication) must be the same on
!--- both sides.

!
ip subnet-zero
!         
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.22.1.1 255.255.255.0
!
interface Ethernet0/0
 ip address 172.22.53.105 255.255.255.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface BRI1/0

!--- Interface for backup link.

 ip address 172.20.10.1 255.255.255.0
 encapsulation ppp
 dialer map ip 172.20.10.2 name maui-soho-01 broadcast

!--- This is the dialer map with IP address and authenticated username
!--- for the remote destination. The name should match the authentication
!--- username provided by the remote side. The dialer map statement is
!--- used even though this router is not dialing out
!--- (that is, the phone number is not specified).

 dialer-group 1

!--- Apply interesting traffic defined in dialer-list 1.

 isdn switch-type basic-ni
 isdn spid1 51255511110101 5551111
 isdn spid2 51255511120101 5551112

!--- SPID information. Contact your telco for the SPID format.
!--- In many parts of the world, SPIDs are not required.
!--- In such cases, omit the above two commands.

 ppp authentication chap
 ppp multilink
!

!--- Output removed.

!
interface Serial2/0

!--- Primary link.

 ip address 192.168.10.1 255.255.255.252
 encapsulation ppp
 clockrate 64000
 ppp authentication chap
!

!--- Output removed.

!
router ospf 5
 network 172.20.10.0 0.0.0.255 area 0
 network 172.22.1.0 0.0.0.255 area 0
 network 172.22.53.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
 default-information originate
!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
no ip http server
!
dialer-list 1 protocol ip permit

!--- This defines all IP traffic as interesting. OSPF does not need 
!--- to be marked uninteresting since this link does not dial out.
!--- Adjust the interesting traffic definition depending on your needs.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
line 97 102
line aux 0
line vty 0 4
!
end

Nota: La configuración de maui-nas-05 no incluye ningún respaldo relacionado comandos. Desde el punto de vista de maui-nas-05, el link de backup está apenas otro cliente de marcación de entrada. Esto puede simplificar la configuración del sitio central en las situaciones donde muchos dispositivos establecen un link de backup a la misma central sitio. En los escenarios de backup, es ideal tener solamente un iniciado del lado el dial, mientras que el otro lado valida solamente las llamadas.

Comandos de vigilancia de programas dialer

La siguiente es una lista de los comandos disponibles para la vigilancia de marcador. Algunos de estos comandos se han incluido en la configuración arriba, mientras que otros se proporcionan para la referencia.

  • IP del número de grupo de la reloj-lista del marcador máscara de dirección del IP address : Define el IP direccionamientos o redes que se mirarán. El direccionamiento o la red (con el correcto máscara) se configura que debe existir en la tabla de ruteo. Usted puede también mirar rutas del múltiplo con el comando dialer watch-list. Se muestra un ejemplo a continuación:

    dialer watch-list 1 ip 10.1.1.0 255.255.255.0
    dialer watch-list 1 ip 10.1.2.0 255.255.255.0
    dialer watch-list 1 ip 10.1.3.0 255.255.255.0       
    
    
  • dialer watch-group número de grupo : Monitoreo de marcado del permiso en Interfaz de respaldo. grupo número utilizado aquí hace juego número de grupo del marcador comando de la reloj-lista que define las rutas que se mirarán. El marcador el comando del reloj-grupo con un número de grupo determinado puede solamente estar configurado en una interfaz. Esto significa que el router no puede utilizar el múltiplo interfaces para proporcionar el respaldo para una ruta determinado. Sin embargo, una interfaz puede tenga comandos del reloj-grupo del dialer múltiple, con diversos números de grupo. Por lo tanto, una interfaz se puede utilizar para proporcionar el respaldo para las rutas múltiples.

  • reloj-neutralización del marcador segundos : Aplique un tiempo de retraso de la neutralización a la interfaz. Después de que la interfaz primaria se recupere, este retardo previene desconexión de la Interfaz de respaldo para el periodo de tiempo especificado. Este retardo se comienza el temporizador cuando expira el temporizador de inactividad, y el estatus del primario la ruta se marca y se encuentra para estar para arriba. Este retardo puede asegurar la estabilidad, especialmente para las interfaces inestables o las interfaces que experimentan la ruta frecuente cambios.

  • número de grupo de la reloj-lista del marcador segundos del delay route-check initial: Esto el comando permite al router para marcar si el ruta principal está para arriba después de el arranque inicial del router es completo y el temporizador (en los segundos) expira. Sin este comando, el Monitoreo de marcado se acciona solamente cuando es el ruta principal quitado de la tabla de ruteo. Si el link principal no puede subir durante el arranque inicial del router, la ruta nunca se agrega a la tabla de ruteo y por lo tanto no puede ser mirado. Por lo tanto, con este comando, el Monitoreo de marcado lo va a hacer marque el link de backup en caso de falla del link principal durante la inicial empiece para arriba del router.

Verificación

Para obtener más información, consulte El usar el comando show isdn status para el BRI Localización de averías.

Esta sección proporciona la información que usted puede utilizar para confirmar su la configuración está trabajando correctamente.

Los ciertos comandos show son soportados por El Output Interpreter tomó, de que permite que usted vea un análisis salida del comando show.

  • tipo del show dialer [interface número] - información de diagnóstico general de las visualizaciones para las interfaces configuradas para el DDR y visualizan la configuración del temporizador y tiempo antes del tiempo de conexión hacia fuera. Debe verificar los siguientes mensajes:

    • El estado del marcador es capa de link de datos en funcionamiento – El marcador funcionó correctamente.

      • “Capa física para arriba” - El Line Protocol subió, solamente la red El Control Protocol (NCP) no hizo.

    • “Marque la razón” que esto visualiza a las direcciones de origen y de destino de el paquete que inició la marca.

  • isdn status de la demostración - Asegure a eso el router está comunicando correctamente con el switch ISDN. Este comando también visualiza número de llamadas activas usted debe verificar los siguientes mensajes:

    • El estado de la capa 1 es ACTIVO",

    • Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED

Ejemplo de resultado del comando show

La tabla de ruteo del cliente, maui-soho-01 (1600), con el primario el funcionamiento del link se muestra abajo:

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - ISIS level-1, L2 - ISIS level-2, ia - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.10.1 to network 0.0.0.0

     192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.10.0/30 is directly connected, Serial0
C       192.168.10.1/32 is directly connected, Serial0
     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/24 is subnetted, 1 subnets
C       172.20.10.0 is directly connected, BRI0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/74] via 192.168.10.1, 02:48:10, Serial0
O       172.22.1.1/32 [110/65] via 192.168.10.1, 02:48:10, Serial0
O*E2 0.0.0.0/0 [110/1] via 192.168.10.1, 02:48:10, Serial0

La salida de la ruta de IP de la demostración mostrada arriba, visualiza las OSPF rutas aprendidas de los pares que usan el link principal (serial 0). Note que la ruta que es mirada (172.22.53.0 con la máscara 255.255.255.0) existe en la tabla de ruteo. Esto se debe verificar para que el Monitoreo de marcado funcione correctamente.

Ahora derribamos el link principal y activamos el link de backup. Después de se activa el link de backup, tabla OSPF se intercambia y las nuevas rutas usando el link de backup está instalado. El tráfico ahora pasa a través del link de backup.

A continuación, se muestra un ejemplo:

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, IA - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.20.10.1 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.20.10.0/24 is directly connected, BRI0
C       172.20.10.1/32 is directly connected, BRI0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/1572] via 172.20.10.1, 00:01:26, BRI0
O       172.22.1.1/32 [110/1563] via 172.20.10.1, 00:01:27, BRI0
O*E2 0.0.0.0/0 [110/1] via 172.20.10.1, 00:01:27, BRI0

La salida antedicha muestra que se ha puesto al día la tabla de ruteo y todos el tráfico utilizará el link de backup (el BRI0)

El comando show dialer puede ser utilizado a verifique que subiera la interfaz DDR correctamente. Note que la interfaz BRI fue marcado porque el router detectó que la ruta vigilada fue perdida.

maui-soho-01#  show dialer

BRI0 - dialer type = ISDN

Dial String      Successes   Failures    Last DNIS   Last status
5551111                 10          0    00:01:49       successful
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.

BRI0:1 - dialer type = ISDN
Idle timer (30 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: Dialing on watched route loss
Time until disconnect 11 secs
Connected to 5551111 (maui-nas-05)

BRI0:2 - dialer type = ISDN
Idle timer (30 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

Troubleshooting

Resolución de problemas de Dialer Watch

Configure y verifique que la conexión DDR está funcionando correctamente antes usted configura el Monitoreo de marcado. Esto le ayudará a aislar y a resolver problemas el DDR problemas antes de que usted aborde los problemas relacionados de reserva. Al configurar el Monitoreo de marcado se recomienza que usted utiliza el Software Release 12.1(7) o Posterior de Cisco IOS�. A continuación trataremos diversos problemas y sus posibles soluciones:

Problema: El router no marca el link de backup cuando el link principal va abajo.

Solución posible #1: Utilice el IP de la demostración el comando route de verificar que la ruta que usted está mirando existe adentro la tabla de ruteo. La ruta configurada para el Monitoreo de marcado debe hacer juego exactamente uno en la tabla de ruteo. Esto incluye verificar eso la red así como las máscaras son idénticas. Por ejemplo, si la tabla de ruteo muestra 10.0.0.0/8 y usted utiliza el IP 10.0.0.0 de la reloj-lista 1 del marcador 255.255.255.0 (que es 10.0.0.0/24), la función de vigilancia del dialer no pueda detectar que 10.0.0.0/8 está no más en la tabla de ruteo.

Solución posible #2: Verifique allí son el mapa de marcador dos declaraciones sobre la Interfaz de respaldo.

  • Debe haber una sentencia de correspondencia para la ruta/la red especificadas por el comando dialer watch-list

  • Debe haber una sentencia de correspondencia para la dirección IP del telecontrol la interfaz del router.

Solución posible #3: Configure el comando retardo del número de grupo de la reloj-lista del marcador segundos iniciales de la verificación de ruta . Consulte la sección comandos section dialer watch para más información.

Problema: Se establece el link de backup solamente ninguna encaminamiento la información se transmite a través del link de backup.

Posible solución: Verifique que el IP de la Interfaz de respaldo la red se incluye en la configuración del Routing Protocol

Problema: El link de backup no se desactiva cuando el link principal se recupera.

Nota: Con el Monitoreo de marcado, el tráfico interesante se utiliza solamente para controlar ocioso-descanso que a su vez controla el intervalo usado para sondear el estatus del ruta principal.

Solución posible #1: Baje el marcador ocioso-descanso. El valor por defecto es 120 segundos, pero usted puede desear a baje este valor dependiendo de sus necesidades.

Solución posible #2: Utilice la demostración no están reajustando al comando dialer de verificar el tiempo de inactividad.

Cambie su definición de tráfico interesante (configurada con comando dialer-list) de ser más restrictivo. Ruteo El tráfico de protocolo debe ser sin interés marcado.

Como último recurso, usted puede configurar todo el tráfico IP como sin interés usando el comando dialer-list 1 protocol ip deny. Con esta definición de tráfico interesante, el tiempo de inactividad nunca será reajustado, y el router marcará el estatus del link principal en especificado intervalo.

Solución posible #3: Marque para aseegurarse que el link de backup es menos deseable que el link principal desde la perspectiva del Routing Protocol funcionando. Esto es de modo que cuando el link principal se recupera, el Dynamic Routing Protocol preferirá sobre el link de backup y no el primario balanza de la carga a través de los dos links. El error hacer esto puede causar el link de backup para permanecer para arriba persistente. Utilice la ruta de IP de la demostración a determine si el router está utilizando ambos los link primario y de backup para rutear trafique entre el Routers. En tal caso el router mantendrá idéntico rutas duplicado; uno para el primario y uno para el link de backup que usted puede utilizar los métodos siguientes uces de los para asegurarse de que el link de backup sea menos deseable desde la perspectiva del Routing Protocol: ancho de banda, retardo, o distancia. Refiera al comando del Cisco IOS Software Referencia para más detalles.

Para las capas ISDN generales 1,2 y 3 que localizan averías refiera al documento Usando el isdn status de la demostración Comando para el Troubleshooting de BRI.

Comandos para resolución de problemas

Los ciertos comandos show son soportados por Herramienta del Output Interpreter, de la cual permite que usted vea un análisis salida del comando show.

Nota: Antes de publicar los comandos debug, vea por favor Información importante encendido Comandos Debug.

  • debug dialer - Esto se utiliza para visualizar el DDR información sobre los paquetes recibidos en una interfaz del dialer.

  • debug ISDN q931 - Esto muestra la configuración de la llamada y derribe de la conexión de red ISDN (capa 3) entre el router y Switch ISDN.

  • negociación ppp del debug - Esto visualizaciones información sobre el tráfico y los intercambios PPP mientras que negocia los componentes PPP incluyendo el (LCP), la autenticación, y el NCP del Link Control Protocol. Un acertado La negociación PPP primero abrirá el estado LCP, después lo autentica, y finalmente negocie el NCP.

  • autenticación PPP del debug - Esto visualizaciones los mensajes de protocolo de la autenticación PPP, incluyendo el apretón de manos del desafío Intercambios de paquetes y autenticación de contraseña del protocolo de autenticación (GRIETA) Intercambios del protocolo (PAP). Si usted observa un error para verificar que la grieta el nombre de usuario y contraseña se configura correctamente.

  • debug ppp error - Esto visualiza el protocolo errores y estadística de errore asociados a la negociación de la conexión PPP y operación.

Ejemplo de resultado del comando debug

La salida del debug dialer abajo muestra fall y Monitoreo de marcado del link principal que reconocen la ruta perdida. El router entonces inicia el link de backup. Después cada vez que expira el ocioso-descanso, controles del router si el link principal está abajo. Si el link principal se encuentra a esté para arriba, Monitoreo de marcado desconecta el link de backup después del temporizador de la neutralización expira. En los debugs, atención de la paga al grupo fecha/hora en cada mensaje como ellos puede proporcionar la información sobre los diversos temporizadores y tiempos de inactividad que son activo.

maui-soho-01#debug dialer
Dial on demand events debugging is on
maui-soho-01#
03:47:07: %LINK-3-UPDOWN: Interface Serial0, changed state to down

!--- Primary Link is brought down

03:47:07: %OSPF-5-ADJCHG: Process 5, Nbr 192.168.10.1 on Serial0 from FULL to DOWN,
 Neighbor Down: Interface down or detached
03:47:07: DDR: Dialer Watch: watch-group = 8

!--- Use dialer watch-group 8. 

03:47:07: DDR:    network 172.22.53.0/255.255.255.0 DOWN,
03:47:07: DDR:    primary DOWN

!--- The primary network is down.

03:47:07: DDR: Dialer Watch: Dial Reason: Primary of group 8 DOWN

!--- Dialing Reason is that the primary route is down.

03:47:07: DDR: Dialer Watch: watch-group = 8, 
03:47:07: DDR:    dialing secondary by dialer map 172.22.53.0 on BR0

!--- Indicates which dialer map statement is used for the dialout.

03:47:07: BR0 DDR: Attempting to dial 5551111
03:47:08: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
03:47:08: BR0:1 DDR: Dialer Watch: resetting call in progress
03:47:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state
 to down
03:47:08: BR0:1 DDR: dialer protocol up
03:47:09: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state
 to up
03:47:14: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5551111 maui-nas-05

!--- BRI link is connected.

03:47:17: %OSPF-5-ADJCHG: Process 5, Nbr 192.168.10.1 on BRI0 from LOADING to FULL,
 Loading Done
03:47:38: BR0:1 DDR: idle timeout

!--- Idle Timeout (30 seconds) expires.
!--- The router will check to see if the primary link has come up.

03:47:38: DDR: Dialer Watch: watch-group = 8
03:47:38: DDR:    network 172.22.53.0/255.255.255.0 UP,

!--- A route for the watched network exists (due to the active backup link).

03:47:38: DDR:    primary DOWN

!--- The primary network is still down.

03:48:08: BR0:1 DDR: idle timeout

!--- Next Idle Timeout (30 seconds) expires.
!--- The router will check to see if the primary link has come up.

03:48:08: DDR: Dialer Watch: watch-group = 8
03:48:08: DDR:    network 172.22.53.0/255.255.255.0 UP,
03:48:08: DDR:    primary DOWN

!--- The primary network is still down.

...
...
...
03:50:38: BR0:1 DDR: idle timeout

!--- Next Idle Timeout (30 seconds) expires.
!--- The router will check to see if the primary link has come up.

03:50:38: DDR: Dialer Watch: watch-group = 8
03:50:38: DDR:    network 172.22.53.0/255.255.255.0 UP,

!--- A route for the watched network exists (due to the active backup link).

03:50:38: DDR:    primary DOWN

!--- The primary network is still down.

03:50:44: %LINK-3-UPDOWN: Interface Serial0, changed state to up

!--- Primary link is re-established.

03:50:45: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state
 to up
03:50:54: %OSPF-5-ADJCHG: Process 5, Nbr 192.168.10.1 on Serial0 from LOADING
 to FULL, Loading Done
03:51:08: BR0:1 DDR: idle timeout

!--- Next Idle Timeout (30 seconds) expires.


!--- The router will check to see if the primary link has come up.

03:51:08: DDR: Dialer Watch: watch-group = 8
03:51:08: DDR:    network 172.22.53.0/255.255.255.0 UP,

!--- A route for the watched network exists. 

03:51:08: DDR:    primary UP

!--- The primary network is UP. Dialer watch will initiate a disconnect of


!--- the backup link.

03:51:08: BR0:1 DDR: starting watch disable timer

!--- Delays disconnecting the backup interface after the primary interface recovers.
!--- This timer is 15 seconds as configured with the dialer watch-disable 15 command

03:51:23: BR0:1 DDR: watch disable timeout

!--- 15 second disconnect delay expires. The link will be brought down.

03:51:23: BR0:1 DDR: disconnecting call

!--- Backup link is disconnected.

03:51:23: BR0:1 DDR: Dialer Watch: resetting call in progress
03:51:23: DDR: Dialer Watch: watch-group = 8
03:51:23: DDR:    network 172.22.53.0/255.255.255.0 UP,
03:51:23: DDR:    primary UP

!--- The primary network is UP.

03:51:23: %ISDN-6-DISCONNECT: Interface BRI0:1  disconnected from 5551111
 maui-nas-05, call lasted 255 seconds
03:51:23: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down
03:51:23: BR0:1 DDR: disconnecting call
03:51:23: DDR: Dialer Watch: watch-group = 8
03:51:23: DDR:    network 172.22.53.0/255.255.255.0 UP,
03:51:23: DDR:    primary UP
03:51:24: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
  changed state to down
maui-soho-01#

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 5600