Marcado y acceso remotos : Conexiones asíncronas

Configuración de un terminal/servidor de comunicaciones

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (23 Junio 2008) | Inglés (10 Noviembre 2015) | Comentarios


Contenido


Introducción

Una terminal o servidor de comunicación comúnmente proporciona acceso fuera de banda para dispositivos múltiples. Un servidor terminal es un router con varios puertos asíncronos de baja velocidad, que están conectados a otros dispositivos seriales, por ejemplo, módems o puertos de consola en routers o switches.

El servidor terminal le permite usar un único punto para acceder a los puertos de la consola de varios dispositivos. Un servidor terminal elimina la necesidad de configurar escenarios de respaldo como los módems en los puertos auxiliares de cada dispositivo. También puede configurar un único módem en el puerto auxiliar del servidor terminal para proporcionar el servicio de acceso telefónico a los otros dispositivos cuando falle la conectividad de red.

Este documento muestra cómo configurar un servidor terminal para acceder solo a los puertos de consola en otros routers mediante Telnet inversa. Telnet inversa le permite establecer una conexión Telnet de salida en el mismo dispositivo que utiliza para la conexión de entrada, pero en una interfaz diferente. Para más información sobre Telnet reverso refiera manejo de las sesiones telnets.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Cableado

Los routers de la serie Cisco 2509 - 2512 utilizan un conector de 68 pins y un cable de conexión. Este cable (CAB-OCTAL-ASYNC) proporciona ocho puertos asincrónicos para cable enrollado RJ-45 en cada conector de 68 pines. Puede conectar cada puerto RJ-45 asíncrono de cable enrollado al puerto de consola de un dispositivo. El router 2511 permite tener acceso de forma remota a un máximo de 16 dispositivos. Además, los módulos de red asíncronos de alta densidad NM-16A o NM-32A están disponibles para que los Cisco 2600 y 3600 Series Routers proporcionen la misma función. Para obtener más información sobre el cableado consulte Conectemos: su Guía de Cables Seriales y la Guía del Cableado para Puertos de Consola y Puertos AUX.

Nota: Los puertos asíncronos del conector de 68 pines son dispositivos de equipos de terminales de datos (DTE). Los dispositivos de DTE a DTE requieren un cable enrollado (módem nulo) y los dispositivos de DTE a equipos de terminación de circuitos de datos (DCE) requieren un cable de conexión directa. El cable CAB-OCTAL-ASYNC es enrollado. Por lo tanto, puede conectar cada cable directamente a los puertos de consola de los dispositivos con interfaces RJ-45. No obstante, si el puerto de consola del dispositivo al que se conecta es una interfaz de 25 pines (DCE), debe utilizar el adaptador de RJ-45 a 25 pines indicado como "Módem" (para invertir el "enrollado") a fin de finalizar la conexión.

Esta tabla muestra los tipos de puerto de los puertos auxiliares y de consola en los routers y switches de Cisco:

Tipo de interfaz Interfaz DB25 Interfaz RJ-45
Consola DCE DTE
AUX DTE DTE

Estrategia de diseño

Configure el servidor terminal de modo que pueda acceder al servidor terminal desde cualquier lugar. Para dejar accesible el servidor terminal, asigne una dirección de Internet pública registrada, y localice el servidor fuera del firewall. Al hacerlo, los problemas del firewall no interrumpen la conexión. Puede mantener siempre la conectividad con el servidor terminal y acceder a los dispositivos conectados. Si le preocupa la seguridad, configure listas de acceso para conceder acceso solamente al servidor terminal desde ciertas direcciones. Para lograr una solución de seguridad más sólida, también puede configurar la autenticación, autorización y contabilización (AAA) basada en servidor, por ejemplo, RADIUS o TACACS+. Para obtener más información sobre la AAA, consulte Autenticación, Autorización y Contabilización (AAA).

Puede configurar un módem en el puerto auxiliar del servidor terminal para el respaldo de marcado en el evento de desactivación de su conexión primaria (a través de Internet). Dicho módem elimina la necesidad de configurar un respaldo de marcado para cada dispositivo. El servidor terminal está conectado a través de sus puertos asíncronos a los puertos de consola de los otros dispositivos. Para obtener más información sobre cómo conectar un módem al puerto auxiliar, consulte la Guía para la Conexión del Módem-Router.

Use la declaración ip default gateway, y señale al router de salto siguiente en Internet. Este comando le permite tener conectividad al servidor terminal a través de Internet incluso si no está habilitado el ruteo. Por ejemplo, el servidor de la terminal está en modo monitor ROM (ROMMON) debido a un mal reinicio después de una interrupción de alimentación eléctrica.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

http://www.cisco.com/c/dam/en/us/support/docs/dial-access/asynchronous-connections/5466-Com-Srv.gif

Configuraciones

Este documento usa esta configuración:

  • Cisco 2511

Cisco 2511
aus-comm-server#show running-config
!
version 12.0

service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname aus-comm-server
!
enable secret  <deleted>
!
username cisco password <deleted>
!
ip subnet-zero
ip domain-list cisco.com
no ip domain-lookup

ip host 3600-3 2014 172.21.1.1

!--- The host 3600-3 is connected to port 14 of the comm server.


!--- Ensure that the IP address is that of an interface on the comm server.

ip host 3600-2 2013 172.21.1.1
ip host 5200-1 2010 172.21.1.1
ip host 2600-1 2008 172.21.1.1
ip host 2509-1 2007 172.21.1.1
ip host 4500-1 2015 172.21.1.1
ip host 3600-1 2012 172.21.1.1
ip host 2511-2 2002 172.21.1.1
ip host 2511-rj 2003 172.21.1.1
ip host 2511-1 2001 172.21.1.1
ip host 5200-2 2011 172.21.1.1
ip host 2520-1 2004 172.21.1.1
ip host 2520-2 2005 172.21.1.1
ip host 2600-2 2009 172.21.1.1
ip host 2513-1 2006 172.21.1.1
ip host pix-1 2016 172.21.1.1
!
!
process-max-time 200
!
interface Loopback1
 ip address 172.21.1.1 255.0.0.0

!--- This address is used in the IP host commands.


!--- Work with loopback interfaces, which are virtual and always available.

 no ip directed-broadcast
!
interface Ethernet0
 ip address 171.55.31.5 255.255.255.192

!---  Use a public IP address to ensure connectivity. 

No ip directed-broadcast
 no ip mroute-cache
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
!
ip default-gateway 171.55.31.1

!--- This is the default gateway when routing is disabled.


!--- For example, if the router is in boot ROM mode.

ip classless
ip route 0.0.0.0 0.0.0.0 171.55.31.1

!--- Set the default route for the external network.

no ip http server
!
line con 0
 transport input all
 line 1 16
 session-timeout 20

!--- The session times out after 20 minutes of inactivity. 

no exec

!--- Unwanted signals from the attached device do not launch.
 

!--- An EXEC session ensures that the line never becomes unavailable 


!--- due to a rogue EXEC process.

 exec-timeout 0 0

!--- This disables exec timeout transport input all.


!--- Allow all protocols to use the line.


!--- Configure lines 1 - 16 with at least transport input Telnet.

line aux 0

!--- Auxiliary port can provide dial backup to the network.


!--- Note: This configuration does not implement modem on AUX port modem InOut. 


!--- Allow auxiliary port to support dialout and dialin connections.

 transport preferred telnet
 transport input all
 speed 38400
 flowcontrol hardware
line vty 0 4
 exec-timeout 60 0
 password <deleted> 
login
!
end

Nota: Si utiliza el 3600 como servidor de acceso, consulte Cómo se Numeran las Líneas Asíncronas en los Routers de la Serie 3600 de Cisco para conocer los detalles del número de línea.

Resumen de Comandos

ip host: use este comando para definir el mapping de nombre a dirección del host estático en la memoria caché del host. para quitar el mapping de nombre a dirección, use la forma no de este comando.

  • ip host name [número de puerto tcp] dirección1 [dirección2...dirección8]

    • name: este campo indica el nombre del host. El campo de nombre no tiene porqué coincidir con el nombre real del router al que quiere conectar. Sin embargo, asegúrese de que ingresa un nombre que querría utilizar en Telnet inversa. Cuando utiliza este comando y el campo de nombre, no tiene porqué conocer el número de puerto real del dispositivo remoto.

    • tcp-port-number: este campo representa el número de puerto TCP al que quiere conectar cuando utiliza el nombre de host definido junto con un comando EXEC connect o telnet. En nuestro ejemplo de configuración, utilizamos Telnet inversa así que el número de puerto debe ser 2000+número de línea.

    • address1: este campo representa una dirección IP asociada. En nuestro ejemplo de configuración, utilizamos la dirección IP de loopback.

transport input: use este comando para definir los protocolos que desea utilizar al conectar a una línea específica del router.

  • transport input {all | lat | fregona | nasi | ninguno | pista | rlogin | telnet | v120}

    • all: selecciona todos los protocolos.

    • none: impide cualquier selección de protocolo en la línea. En este caso, el puerto se vuelve inutilizable para las conexiones entrantes.

    Nota:  en nuestro ejemplo de configuración, las líneas asíncronas utilizan la configuración mínima del comando transport input telnet. Puede comunicarse vía Telnet con los dispositivos en la línea asíncrona.

telnet: use este comando EXEC para iniciar una sesión en un host que soporte Telnet.

  • telnet host [puerto] [palabra clave]

    • host: este campo indica un nombre de host o una dirección IP. El host puede ser uno de los campos de nombre definidos en el comando ip host.

    • port: este campo indica un número de puerto TCP decimal. El puerto de router Telnet (decimal 23) en el host es el número de puerto TCP decimal predeterminado. Para Telnet inversa, el número de puerto debe ser 2000+número de línea. Los números de línea van del 1 al 16 en nuestra configuración. Utilice el comando EXEC show line para ver las líneas disponibles.

Intercambio entre Sesiones Activas

Siga estos pasos para alternar entre las sesiones activas:

  1. Use la secuencia de escape Ctrl-Shift-6 y a continuación x para salir de la sesión actual.

  2. Use el comando show sessions para mostrar todas las conexiones abiertas.

    aus-comm-server#show sessions 
    Conn Host      Address         Byte Idle  Conn Name
       1 2511-1    171.69.163.26   0     0     2511-1
       2 2511-2    171.69.163.26   0     0     2511-2
     * 3 2511-3    171.69.163.26   0     0     2511-3

    Nota: El asterisco (*) indica la actual sesión de terminal.

  3. Ingrese el número de sesión (conexión) para conectar al dispositivo correspondiente. Por ejemplo, para conectar con 2511-1 escriba 1, que es el número de conexión. Sin embargo si pulsa la tecla Return, conectará con la sesión de terminal actual, que en este caso es el router 2511-3.

Terminación de Sesiones Activas

Siga estos pasos para terminar una sesión Telnet determinada:

  1. Use la secuencia de escape Ctrl-Shift-6 y a continuación x para salir de la sesión Telnet actual.

    Nota: asegúrese de que puede utilizar la secuencia de escape de forma fiable para suspender una sesión Telnet. Algunos paquetes de emulador de terminal no pueden enviar la secuencia correcta, Ctrl-Shift-6 y a continuación X.

  2. Ejecute el comando show sessions para mostrar todas las conexiones abiertas.

  3. Ejecute el comando disconnect [connection] para desconectar la sesión requerida.

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • show ip interface brief: indica si la interfaz que utiliza para la sesión Telnet está activa.

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Procedimiento de Troubleshooting

Sigue estas instrucciones de resolver problemas su configuración.

Si no puede conectar con el router elegido con un nombre configurado en el comando ip host realice lo siguiente:

  1. Compruebe si la dirección de puerto está configurada correctamente.

  2. Verifique si la dirección (interfaz) usada para Telnet inversa está en el estado up/up. La salida del comando show ip interface brief proporciona esta información. Cisco recomienda utilizar loopbacks porque están siempre activos.

  3. Asegúrese de que tiene el tipo de cable correcto. Por ejemplo, no debe utilizar un cable de crossover para ampliar la longitud. Consulte la sección Cableado para obtener más información.

  4. Establezca una conexión Telnet al puerto de la dirección IP para probar la conectividad directa. Debe poder comunicarse vía Telnet desde un dispositivo externo y el servidor terminal. Por ejemplo, telnet 172.21.1.1 2003.

  5. Asegúrese de que el comando transport input telnet está debajo de la línea del dispositivo de destino. El dispositivo de destino es el dispositivo que está conectado al servidor terminal.

  6. Utilice una terminal tonta/PC para conectarse directamente a la consola del router de destino. El router de destino es el dispositivo conectado al servidor terminal. Este paso le ayuda a identificar si hay algún problema con el puerto.

  7. Si está desconectado, verifique los tiempos de espera. Puede quitar o ajustar los tiempos de espera.

    Nota: Si encuentra fallas de autenticación, recuerde que el servidor terminal realiza la primera autenticación (si está configurado), mientras que el dispositivo al que intenta conectar realiza la segunda autenticación (si está configurado). Verifique si la AAA está configurada correctamente en el servidor terminal y el dispositivo de conexión.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 5466