Módulos e interfaces de Cisco : Módulo de switching de contenido de Cisco

Configurar el modo seguro (del router) en el módulo content switching

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

El Módulo de conmutación de contenidos (CSM) provee un alto rendimiento en las conexiones entre usuarios de red y granjas de servidores basadas en la información de la Capa 4. Puede representar un grupo de servidores reales (bloque de servidores) como una instancia de un solo servidor (servidor virtual), equilibrar el tráfico hacia el bloque de servidores seleccionando uno de los métodos de balance de carga del servidor y limitar el tráfico a los servidores individuales (conexiones adheridas) y bloques de servidores (políticas). Esta configuración de muestra describe cómo configurar el Equilibrio de carga de servidores (SLB) en el Catalyst 6000 Family CS.

Usted no puede funcionar con el software SLB del � del Cisco IOS en el mismo Switch que el CS. Usted debe configurar al modo CSM publicando el slb mode del IP [csm | comando rp] antes de cualquier configuración. En el comando ip slb mode, el argumento rp es predeterminado.

Antes de comenzar

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

prerrequisitos

No hay requisitos previos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las versiones de software y hardware indicadas a continuación.

  • Supervisor de la versión 12.1(8)EX de IOS de la familia Catalyst 6000 para el supervisor Engine 1 con MSFC1 (c6sup11-jsv-mz.121-8.EX).

  • Versión de software CSM del Catalyst 6000 Family 2.1(0) (c6slb-apc.2-1-1.bin)

El CSM se ejecuta en la versión 12.1(6)E o posteriores del IOS de Cisco. Si usted está utilizando un Supervisor Engine 2, usted debe utilizar el Cisco IOS Release 12.1(8a)E o Posterior.

Modo de operación

Las conexiones del cliente y servidor con el CS pueden utilizar la capa 2 o el Layer 3 Switching. Los clientes conectan con el VLA N del lado del cliente, y los servidores conectan con el VLA N del lado del servidor. Los servidores y los clientes pueden existir en subredes diferentes. Los servidores pueden también ser localizados más de un salto lejos y conectar con el VLA N del lado del servidor a través del Routers. En este caso, el default gateway de los servidores y la encaminamiento a través de la red de los servidores al VLA N del lado del servidor CS deben dirigir todo el tráfico equilibrado carga de los servidores con el CS, o cliente serverfarm el NAT se debe configurar en el CS para todo el tráfico destinado a los servidores en el bloque de servidores. Un cliente envía una petición a un direccionamiento VIP, al � y al CS adelante la petición a un servidor que pueda satisfacer la petición. El servidor adelante la respuesta al CS, y el CS adelante la respuesta al cliente.

Cuando los VLA N del lado y del lado del servidor del cliente están en diversas subredes, usted puede configurar el CS en el modo seguro (del router). Esta configuración de muestra se centra en la configuración de modo segura (del router). Cuando los VLA N del lado y del lado del servidor del cliente están en la misma subred, usted puede configurar el CS para actuar en el modo de la subred única (Bridge). Refiera a las configuraciones de muestra abajo para más información.

Diagrama de la red

Los VLA N del lado y del lado del servidor del cliente están en diversas subredes en el modo seguro (del router). El diagrama muestra cómo se establece la configuración del modo seguro (del router).

csm_router.gif

Configuraciones

Complete estos pasos para configurar el CS para el modo seguro (de la subred múltiple):

  1. Seleccione el modo CSM.

    cat(config)# ip slb mode csm
    
  2. Cree el VLA N del cliente y servidor en la base de datos. Al salir el vlan database mode, los cambios de configuración son aplicados.

    cat# vlan database 
    cat(vlan)# vlan 100 
    VLAN 100 added: Name: VLAN0100 
    cat(vlan)# vlan 200 
    VLAN 200 added: Name: VLAN0200 
    cat(vlan)# exit 
    APPLY completed. 
    Exiting....
  3. Configure las interfaces físicas que conectan al cliente (link ascendente) con la VLAN correspondiente.

    cat(config)# inter fastEthernet 2/1 
    cat(config-if)# switchport 
    cat(config-if)# switchport access vlan 100 
    cat(config-if)# no shut
    
  4. Configure las interfaces físicas que conectan los servidores con el VLAN correspondiente.

    cat(config)# inter fastEthernet 2/3 
    cat(config-if)# switchport 
    cat(config-if)# switchport access vlan 200 
    cat(config-if)# no shutdown 
    cat(config)# inter fastEthernet 2/4 
    cat(config-if)# switchport 
    cat(config-if)# switchport access vlan 200 
    cat(config-if)# no shutdown
    
  5. Cree el VLA N y el gateway del lado del cliente.

    cat(config)# ip slb vlan 100 client 
    cat(config-slb-vlan-client)# ip address 172.17.63.217 255.255.255.192 
    cat(config-slb-vlan-client)# gateway 172.17.63.210
    
  6. Cree el VLA N del lado del servidor.

    cat(config)# ip slb vlan 200 server 
    cat(config-slb-vlan-server)# ip address 10.1.1.251 255.255.255.0 
    cat(config-slb-vlan-server)# alias 10.1.1.250 255.255.255.0
    
  7. Cree el serverfarm.

    cat(config)# ip slb serverfarm WWWFARM 
    cat(config-slb-sfarm)# real 10.1.1.3 
    cat(config-slb-real)# inservice 
    cat(config-slb-real)# real 10.1.1.5 
    cat(config-slb-real)# inservice
    
  8. Cree el vserver y asocie el serverfarm.

    cat(config)# ip slb vserver SERVER 
    cat(config-slb-vserver)# virtual 172.17.63.241 tcp www 
    cat(config-slb-vserver)# serverfarm WWWFARM 
    cat(config-slb-vserver)# inservice
    

Lo que sigue es una configuración de muestra del Server Load Balancing que utiliza el Cisco Catalyst 6500 y el CS.

Configuración corriente CS (WS-X6066-SLB-APC)
Current configuration : 3791 bytes 
! 
version 12.1 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname cat 
! 
boot buffersize 126968 
boot system flash slot0:c6sup11-jsv-mz.121-8.EX.bin 
! 
redundancy 
�main-cpu 
� auto-sync standard 
ip subnet-zero 
! 


!--- SLB mode. 

ip slb mode csm 
! 


!--- Client side VLAN configuration.� 
!--- Important: Gateway address pointing to interface VLAN 100.
 
ip slb vlan 100 client 
�ip address 172.17.63.217 255.255.255.192 
�gateway 172.17.63.210 
! 


!--- Server side VLAN configuration.�
 
ip slb vlan 200 server 
�ip address 10.1.1.251 255.255.255.0 
�alias 10.1.1.250 255.255.255.0 
! 


!--- Serverfarm configuration.
 
ip slb serverfarm WWWFARM 
�nat server� 
�no nat client 
real 10.1.1.3 
� inservice 
�real 10.1.1.5 
� inservice 
! 


!--- Vserver configuration.�
 
ip slb vserver SERVER 
�virtual 172.17.63.241 tcp www 
�serverfarm WWWFARM 
�inservice 
! 
interface GigabitEthernet1/1 
�no ip address 
�shutdown 
! 
interface GigabitEthernet1/2 
�no ip address 
�shutdown 
! 


!--- Client (uplink) connected to FastEthernet 2/1. 

interface FastEthernet2/1 
�no ip address 
�switchport 
�switchport access vlan 100 
�switchport mode access 
! 
interface FastEthernet2/2 
�no ip address 
�shutdown 
! 


!--- Servers connected to FastEthernet 2/3 and 2/4.
� 
interface FastEthernet2/3 
�no ip address 
�switchport 
�switchport access vlan 200 
�switchport mode access 
! 
interface FastEthernet2/4 
�no ip address 
�switchport 
�switchport access vlan 200 
�switchport mode access ... 
interface FastEthernet2/48 
�no ip address 
�shutdown 
! 
interface Vlan1 
�no ip address 
�shutdown 
! 
interface Vlan100 
�ip address 172.17.63.210 255.255.255.192 
! 
ip default-gateway 172.17.63.193 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.17.63.193 
no ip http server 
! 
line con 0 
line vty 0 4 
�login 
! 
end

Comandos show

Nota: La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Comando show ip slb status

El comando show ip slb status muestra el estado del módulo SLB. El módulo debe estar en línea.

cat6#show ip slb status�
SLB Module is online in slot 3.�
Configuration Download state: COMPLETE, SUCCESS

Comando show ip slb vserver

El comando show ip slb serverfarms muestra información sobre el servidor virtual. Usted también ve el estado del servidor virtual y son cuántas conexiones allí:

cat6#show ip slb vserver
slb vserver�� prot��� virtual������������� vlan�� state�������� conns����������
---------------------------------------------------------------------------
SERVER������� TCP���� 172.17.63.241/32:80� ALL��� OPERATIONAL�� 0

Comando show ip slb mode

El comando show ip slb reals visualiza la información para cada servidor real, tal como el bloque de servidores en donde reside cada servidor, el estado del servidor, los umbrales, y las conexiones.

cat6#show ip slb reals
real����������������� server farm����� weight� state��������� conns
-------------------------------------------------------------------
10.1.1.5������������� WWWFARM��������� 8������ OPERATIONAL��� 0��������
10.1.1.3������������� WWWFARM��������� 8������ OPERATIONAL��� 0

Comando show ip slb vlan

El comando show ip slb serverfarms muestra información sobre la granja de servidores. Este comando muestra el predictor usado para el balance de carga. Este ejemplo utiliza el valor por defecto, ordenamiento cíclico.

cat6#show ip slb serverfarm
server farm��� predictor��� nat�� reals�� redirect� bind id
-------------------------------------------------------------
WWWFARM������� RoundRobin�� S���� 2������ 0�������� 0

show ip slb vlan Command

El comando show ip slb vlan visualiza la información de VLAN para el cliente y el servidor.

cat6# show ip slb vlan
vlan�� IP address������ IP mask����������� type��
---------------------------------------------------
100��� 172.17.63.217��� 255.255.255.192��� CLIENT
200��� 10.1.1.251������ 255.255.255.0����� SERVER

Troubleshooting

Usted puede hacer ping solamente el servidor real del Catalyst 6500 usando el comando ping slb, como se muestra abajo.

cat6#ping slb 10.1.1.3�
IP address������ Reachable�
--------------------------�
10.1.1.3�������� Yes

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 5448