IP : Protocolo de puerta de enlace fronteriza (BGP)

Comprensión de la incorporación de rutas en BGP

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Border Gateway Protocol (BGP) permite el agregado de rutas específicas en un ruta con el uso del comando aggregate-address address mask [as-set] [summary-only] [suppress-map map-name] [advertise-map map-name] [attribute-map map-name]. Cuando ejecuta el comando aggregate-address sin argumento, no hay atributos heredados de la ruta individual (como AS_PATH o comunidad), lo que causa pérdida de granularidad. Este documento ilustra cómo manipular los diversos atributos cuando utiliza el comando aggregate-address y cómo incidir en la propagación.

prerrequisitos

Requisitos

Cisco recomienda que tenga conocimiento sobre estos temas:

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware. Sin embargo, la configuración en este documento fue probada con el Software Release 12.2(28) del ½ del ¿Â de Cisco IOSïÂ.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Diagrama de la red

/image/gif/paws/5441/aggregation1.gif

Agregado Sin el Argumento as-set

El uso del argumento del as-set crea a una dirección global con un conjunto matemático de los sistemas autónomos (ASs). Este argumento del as-set resume los atributos AS_PATH de todas las rutas individuales. Estas configuraciones de ejemplo le permiten examinar esta función y cómo este argumento ayuda al BGP a detectar y a evitar los loops.

router A
Current configuration: 

 hostname RouterA 
 ! 
 interface Serial1 
  ip address 2.2.2.2 255.0.0.0 
 !  
interface Loopback0
  ip address 160.20.1.1 255.255.0.0
 !
 router bgp 100 
  network 160.20.0.0 

!--- Router A advertises network 160.20.0.0/16.      

  neighbor 2.2.2.1 remote-as 300 
 ! 
 end

router B
Current configuration: 

 hostname RouterB 
 ! 
 interface Serial0 
  ip address 3.3.3.3 255.0.0.0 
 ! 
interface Loopback0
  ip address 160.10.1.1 255.255.0.0
 !
 router bgp 200 
  network 160.10.0.0 

!--- Router B advertises network 160.10.0.0/16.      

  neighbor 3.3.3.1 remote-as 300 
 ! 
 end

Router C
Current configuration: 

 hostname RouterC 
 ! 
 interface Serial0 
  ip address 2.2.2.1 255.0.0.0 
 ! 
 interface Serial1 
  ip address 3.3.3.1 255.0.0.0 
 ! 
 interface Serial2 
  ip address 4.4.4.1 255.0.0.0 
 ! 
 router bgp 300 
  neighbor 2.2.2.2 remote-as 100 
  neighbor 3.3.3.3 remote-as 200 
  neighbor 4.4.4.4 remote-as 400 
  aggregate-address 160.0.0.0 255.0.0.0 summary-only  

!--- The network is summarized, and Router C only
!--- advertises 160.0.0.0/8.

 ! 
 end  

Router D
Current configuration: 

 hostname RouterD
 ! 
 interface Serial0 
  ip address 4.4.4.4 255.0.0.0 
 ! 
 router bgp 400 
  neighbor 4.4.4.1 remote-as 300                     
 ! 
 end 

El router C (AS-300) agrega las rutas 160.20.0.0/16 y 160.10.0.0/16 que vienen del AS-100 y del AS-200, respectivamente. Esta acción ocurre porque ha configurado el argumento del summary-only en el router C. Router C anuncia solamente el agregado de 160.0.0.0/8 al router D. El agregado de 160.0.0.0/8 es la ruta del classless interdomain routing (CIDR). Se suprimen las rutas 160.10.0.0/16 y 160.20.0.0/16 más específicas, ya que esta tabla BGP en el Router C muestra:

RouterC# 
show ip bgp
 
BGP table version is 6, local router ID is 4.4.4.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 160.0.0.0/8      0.0.0.0                            32768 i
s> 160.10.0.0       3.3.3.3                  0             0 200 i
s> 160.20.0.0       2.2.2.2                  0             0 100 i

Aquí está la tabla BGP del Router D. Observe la información de trayectoria de la ruta agregada:

RouterD# 
show ip bgp

BGP table version is 6, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 160.0.0.0/8      4.4.4.1                                0 300 i

La ruta agregada 160.0.0.0/8 se considera haberse originado del AS-300 con el código de origen IGP. La ruta ha perdido toda la información AS_PATH específica de los prefijos individuales 160.10.0.0/16, de AS-200, y 160.20.0.0/16, de AS-100.

Agregado con el Argumento as-set

Ahora, configure el argumento as-set en el comando aggregate-address en el Router C. Aquí está la nueva configuración:

Router C
Current configuration: 

 hostname RouterC 
 ! 
 interface Serial0 
  ip address 2.2.2.1 255.0.0.0 
 ! 
 interface Serial1 
  ip address 3.3.3.1 255.0.0.0 
 ! 
 interface Serial2 
  ip address 4.4.4.1 255.0.0.0 
 ! 
 router bgp 300 
  neighbor 2.2.2.2 remote-as 100 
  neighbor 3.3.3.3 remote-as 200 
  neighbor 4.4.4.4 remote-as 400 
  aggregate-address 160.0.0.0 255.0.0.0 summary-only as-set

!--- With the as-set configuration command, the aggregate 
!--- inherits the attributes of the more-specific routes.

 ! 
 end 

Ahora, observe en cómo este argumento influye en el resultado show ip bgp en el Router D:

RouterD# 
show ip bgp

BGP table version is 2, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 160.0.0.0/8      4.4.4.1                                0 300 {200,100} i

Con el argumento as-set, la información de trayectoria en la tabla BGP para los cambios en la ruta agregada incluye un conjunto de 300 {200,100}. Este conjunto indica que el agregado resume realmente las rutas que han pasado por el AS-200 y el AS-100. La información del as-set llega a ser importante en la evitación de los loops de ruteo porque la información donde ha estado la ruta.

En cualquier red cerrada, esta información de agregado se propaga a través del BGP y de nuevo a uno de los AS que menciona el as-set. Esta propagación crea la posibilidad de un loop. El comportamiento de la detección del loop del BGP observa su número de AS en el as-set de la actualización de agregado y descarta el agregado. Esta acción previene un loop.

Nota: El argumento del as-set contiene información sobre cada ruta individual que el agregado resume. Los cambios en la ruta individual causan una actualización del agregado. En el ejemplo, si deja de funcionar 160.10.0.0/16, la información de trayectoria del agregado cambia de 300 {200,100} a 300 {200}. El agregado es actualizado. Si el agregado resume decenas o centenas de rutas y de rutas que forman el agregado tienen problemas, puede haber un flap constante.

Cambie los Atributos de Ruta Agregada

El Agregado con la sección de argumento as-set le muestra cómo utilizar el as-set para guardar los atributos AS_PATH con una ruta específica. En algunos casos, puede requerir un cambio en los atributos de la ruta agregada. Los ejemplos de tales atributos incluyen métrica, comunidad y origen.

Esta sección muestra cómo puede utilizar el argumento attribute-map para manipular los atributos de agregado-dirección. En este caso, configura una o más de las rutas agregadas específicas con el atributo de comunidad no-export. El Router A fija el atributo de comunidad no-export a la red 160.20.0.0/16 y anuncia la red al Router C. Esta sección muestra la configuración. El Router C hereda el atributo de comunidad no-export mientras que el router agrega 160.0.0.8. Por lo tanto, no hay anuncio de 160.0.0.0/8 al Router D. La configuración de los Routers B, C, y D no cambia. Aquí está la nueva configuración para el Router A:

router A
Current configuration: 

 hostname RouterA 

 ! 
 interface Serial1 
  ip address 2.2.2.2 255.0.0.0 
 !  
 router bgp 100 
  network 160.20.0.0 

!--- Router A advertises network 160.20.0.0/16.

  neighbor 2.2.2.1 remote-as 300 
  neighbor 2.2.2.1 send-community 
  neighbor 2.2.2.1 route-map SET_NO_EXPORT out 
 ! 
 access-list 1 permit 160.20.0.0 0.0.255.255 
 route-map SET_NO_EXPORT permit 10 
  match ip address 1 
  set community no-export 

!--- This sets the community attribute no-export.    

  at Router A for route 160.20.0.0/16 
 ! 
 end

Aquí está la tabla BGP del Router C para 160.0.0.0/8:

RouterC# show ip bgp 160.0.0.0
BGP routing table entry for 160.0.0.0/8, version 9
Paths: (1 available, best #1, not advertised to EBGP peer)
  Not advertised to any peer
  {200,100}, (aggregated by 300 4.4.4.1)
    0.0.0.0 from 0.0.0.0 (4.4.4.1)
      Origin IGP, localpref 100, weight 32768, valid, aggregated, local, atomic-
aggregate, best, ref 2
      Community: no-export

El atributo de comunidad no-export detiene el anuncio al Router C de la ruta agregada al Router Router D par. El Router D muestra que no ha aprendido 160.0.0.0 del Router C:

RouterD# show ip bgp 160.0.0.0
% Network not in table

Puede configurar el argumento attribute-map en el Router C para manipular el atributo de la comunidad de la ruta agregada de no-export a none. Esta configuración permite el anuncio del agregado al Router D.

Router C
Current configuration: 

 hostname RouterC 
 ! 
 interface Serial0 
  ip address 2.2.2.1 255.0.0.0 
 ! 
 interface Serial1 
  ip address 3.3.3.1 255.0.0.0 
 ! 
 interface Serial2 
  ip address 4.4.4.1 255.0.0.0 
 ! 
 router bgp 300 
  neighbor 2.2.2.2 remote-as 100 
  neighbor 3.3.3.3 remote-as 200 
  neighbor 4.4.4.4 remote-as 400 
  aggregate-address 160.0.0.0 255.0.0.0 
  as-set summary-only attribute-map Map 

!--- Use of the attribute-map argument allows
!--- you to change the community of the aggregate.
 
 ! 
 route-map Map permit 10 
  set community none 

!--- This sets the community of the aggregate to none.

 end

Ahora, observe la tabla BGP del Router C para 160.0.0.0/8. Debido a que no hay un conjunto de comunidades para la ruta agregada, el Router C anuncia 160.0.0.0/8 al Router D.

RouterC# show ip bgp 160.0.0.0
BGP routing table entry for 160.0.0.0/8, version 6
Paths: (1 available, best #1)
  Advertised to non peer-group peers:
  2.2.2.2 3.3.3.3 4.4.4.4
  {200,100}, (aggregated by 300 4.4.4.1)
    0.0.0.0 from 0.0.0.0 (4.4.4.1)
      Origin IGP, localpref 100, weight 32768, valid, aggregated, local, atomic-
aggregate, best, ref 2

El resultado show ip bgp 160.0.0.0 en el Router D muestra que el Router D ha aprendido la ruta agregada 160.0.0.0/8 del Router C.

RouterD# show ip bgp 160.0.0.0
BGP routing table entry for 160.0.0.0/8, version 10
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Not advertised to any peer
  300 {200,100}, (aggregated by 300 4.4.4.1)
    4.4.4.1 from 4.4.4.1 (4.4.4.1)
      Origin IGP, localpref 100, valid, external, best

Use advertise-map para Agregar un Subconjunto de Rutas Específicas

Si tiene control de los prefijos individuales que forman la ruta agregada, puede decidir más fácilmente qué atributos incluirá el agregado. Excluya el prefijo 160.20.0.0 del total de Routes en el ejemplo en el cambio los atributos de la sección de total de Routes. En este caso, el agregado 160.0.0.0/8 no hereda el atributo de comunidad no-export. Para realizar este cambio, configure el argumento advertise-map en el Router C.

Router C
Current configuration: 

 hostname RouterC 
 ! 
 interface Serial0 
  ip address 2.2.2.1 255.0.0.0 
 ! 
 interface Serial1 
  ip address 3.3.3.1 255.0.0.0 
 ! 
 interface Serial2 
  ip address 4.4.4.1 255.0.0.0 
 ! 
 router bgp 300 
  neighbor 2.2.2.2 remote-as 100 
  neighbor 3.3.3.3 remote-as 200 
  neighbor 4.4.4.4 remote-as 400 
  aggregate-address 160.0.0.0 255.0.0.0
  as-set summary-only advertise-map SELECT_SP_ROUTE   

!--- You exclude a particular prefix with the
!--- use of advertise-map.

 ! 
 access-list 1 permit 160.10.0.0 0.0.255.255 
 ! 
 route-map SELECT_SP_ROUTE permit 10 
  match ip address 1 
 ! 
 end

Ahora, observe la tabla BGP del Router C para 160.0.0.0/8:

RouterC# show ip bgp 160.0.0.0
BGP routing table entry for 160.0.0.0/8, version 15
Paths: (1 available, best #1)
  Advertised to non peer-group peers:
  2.2.2.2 4.4.4.4
  200, (aggregated by 300 2.2.2.1)
    0.0.0.0 from 0.0.0.0 (2.2.2.1)
      Origin IGP, localpref 100, weight 32768, valid, aggregated, local, atomic-
aggregate, best, ref 2

Solamente el AS-200 es parte de la información AS_PATH del agregado; el AS-100 no es parte de la información. Además, no hay herencia del atributo de comunidad no-export de 160.20.0.0/16. Por lo tanto, la ruta agregada se anuncia al Router D. El resultado show ip bgp 160.0.0.0 muestra el anuncio:

RouterD# show ip bgp 160.0.0.0
BGP routing table entry for 160.0.0.0/8, version 7
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Not advertised to any peer
  300 200, (aggregated by 300 4.4.4.1)
    4.4.4.1 from 4.4.4.1 (4.4.4.1)
      Origin IGP, localpref 100, valid, external, atomic-aggregate, best
ip bgp 160.0.0.0

Nota: Debido a que agregado as-set tiene AS-200 solamente, el Router A en el AS-100 acepta la ruta agregada e instala la ruta en la tabla de ruteo. El mecanismo de detección del loop BGP causa esta aceptación de la ruta. El mecanismo de detección del loop BGP no detecta su AS en el as-set.

RouterA# show ip bgp
BGP table version is 3, local router ID is 160.20.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 160.0.0.0/8      2.2.2.1                                0 300 200 i
*> 160.20.0.0       0.0.0.0                  0         32768 i

Impacto del Uso de suppress-map Con Otros Comandos de Configuración

El comando aggregate-address incluye otros comandos de configuración, tales como suppress-map. Para comprender el impacto del uso de todos los comandos de configuración en combinación, observe que aggregate-address hereda solamente los atributos de las rutas more-specific cuando utiliza el comando de configuración as-set. Los ejemplos de los atributos que puede heredar aggregate-address incluyen no-export y no-advertise.

  • Cuando utiliza el comando de configuración suppress-map junto con el comando de configuración del summary-only, el comando de configuración del summary-only no tiene ningún efecto. Con el uso el comando de configuración suppress-map , las rutas más específicas que el comando suppress-map eliminan no se anuncian. Sin embargo, las rutas que el mapa suprimir no cubre se hacen publicidad además de la ruta agregada. Por lo tanto, las notas en esta sección se aplican al uso de suppress-map con o sin el comando de configuración summary-only.

  • Cuando utiliza as-set con suppress-map, aunque las rutas eliminadas no se anuncien, la ruta agregada hereda los atributos de todas las rutas eliminadas. Pero puede anular los atributos heredados con el uso de otros comandos de configuración, como attribute-map. La sección Cambio de Atributos de la Ruta Agregada describe el uso de la attribute-map.

  • Cuando utiliza los comandos de configuración as-set y suppress-map con advertise-map, se crea el agregado. El agregado hereda los atributos sólo de las rutas que se seleccionan en advertise-map, independientemente de si suppress-map elimina la ruta. Consulte la sección Uso de advertise-map para Agregar a Subconjunto de Rutas Específicas .

  • Cuando usa advertise-map y attribute-map junto con as-set y otros comandos de configuración, el attribute-map anula los atributos que se seleccionan en advertise-map.

Generalmente, cuando usa advertise-map, sólo advertise-map influye en el agregado. En ausencia de advertise-map,el agregado hereda los atributos more-specific routes, eliminados y no eliminados En ambos los casos, puede utilizar el comando de configuración attribute-map para anular los atributos seleccionados.


Información Relacionada


Document ID: 5441