IP : Protocolo de puerta de enlace fronteriza (BGP)

Introducción a la redistribución de las rutas OSPF en el BGP

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Esta Nota Técnica explica el comportamiento de la redistribución Open Shortest Path First (OSPF) a Border Gateway Protocol (BGP) en los routers de Cisco routers. El comportamiento de la redistribución OSPF a BGP se describe en RFC 1403.leavingcisco.com

Hay varios tipos de rutas OSPF:

  • Intra-area — En una red OSPF del multiarea, las rutas, originadas dentro de un área, son sabidas por el Routers en la misma área que las rutas dentro de una zona. Estas rutas se indican con la O en el resultado del comando show ip route.

  • Inter-area — Cuando una ruta cruza a un Router del borde de la área OSPF (ABR), la ruta se conoce como OSPF Inter-Area Route. Estas rutas se indican con O IA en el resultado del comando show ip route.

    Las rutas Dentro del Área y Entre Áreas también se denominan rutas Internas OSPF, ya que son generadas por OSPF, cuando una interfaz se cubre con el comando ospf network.

  • Tipo 2 externo o tipo 1 externo — Rutea que fueron redistribuidos en el OSPF, tal como conectado, los parásitos atmosféricos, o el otro Routing Protocol, se conocen como el Tipo 2 externo o tipo 1 externo. Estas rutas se indican con O E2 o O E1 en el resultado del comando show ip route.

  • Tipo-2 externo NSSA o tipo 1 externo NSSA — cuando un área se configura como área del No-Tan-stub (NSSA), y las rutas se redistribuyen en el OSPF, las rutas se conocen como tipo 1 externo del tipo-2 NSSA o del externo NSSA. Estas rutas se indican con O N2 u O N1 en el resultado del comando show ip route.

    La descripción de las diferencias entre el externo y tipo-2 o 1 NSSA está fuera del alcance de este documento — refiera a la guía de diseño OSPF para más información.

El comportamiento predeterminado es no redistribuir ninguna ruta del OSPF al BGP. La redistribución debe ser configurada. Puede utilizar el comando route-map para filtrar rutas durante la redistribución de OSPF a BGP. Al redistribuir, las palabras claves específicas como internal, internal y nssa-external se requieren para redistribuir las rutas respectivas.

prerrequisitos

Requisitos

Se requieren conocimientos sobre los tipos de ruta OSPF antes de utilizar este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configuración de la red

Hay cuatro casos de redistribución de las rutas OSPF a BGP que se discuten a continuación. El diagrama de la red se aplica a los primeros tres casos. El diagrama y la configuración para el cuarto caso se pueden encontrar en la sección Redistribución de Rutas NSSA Externas OSPF en BGP.

/image/gif/paws/5242/bgp-ospf-redis1.jpg

Redistribución de rutas internas (dentro y entre áreas) OSPF únicamente en BGP

Si usted configura la redistribución del OSPF en el BGP sin las palabras claves, sólo el intra-area y las rutas interzonales OSPF se redistribuyen en el BGP, por abandono. Puede utilizar la palabra clave internal junto con el comando redistribute en router bgp para las rutas OSPF dentro y entre áreas.

Esta configuración es una nueva configuración del Router B que redistribuye solamente la ruta dentro de áreas (131.108.2.0/24) y la ruta entre áreas (131.108.1.0/24) en el BGP y solamente las rutas internas OSPF (entre y dentro de áreas) se redistribuyen en el BGP:

RTB
hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.3 255.255.255.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1
!
router bgp 100
 redistribute ospf 1


!-- This redistributes only OSPF intra- and inter-area routes into BGP.


 neighbor 3.3.3.2 remote-as 200
!
end

RTB# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Ethernet0/0
C    3.0.0.0/8 is directly connected, Serial1/0
O E2 200.1.1.0/24 [110/20] via 2.2.2.2, 00:16:17, Ethernet0/0
O E1 200.2.2.0/24 [110/104] via 2.2.2.2, 00:00:41, Ethernet0/0
     131.108.0.0/24 is subnetted, 2 subnets
O       131.108.2.0 [110/74] via 2.2.2.2, 00:16:17, Ethernet0/0
O IA    131.108.1.0 [110/84] via 2.2.2.2, 00:16:17, Ethernet0/0
RTB#

El Router B redistribuye solamente las rutas Interno OSPF:

RTB# show ip bgp
BGP table version is 10, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2.2.2.0/24       0.0.0.0                  0         32768 ?
*> 131.108.1.0/24   2.2.2.2                 84         32768 ?
*> 131.108.2.0/24   2.2.2.2                 74         32768 ?
RTB#

Router C que aprende estas rutas del BGP:

RTC# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
B       2.2.2.0 [20/0] via 3.3.3.1, 00:11:19
C    3.0.0.0/8 is directly connected, Serial0/0
     131.108.0.0/24 is subnetted, 2 subnets
B       131.108.2.0 [20/74] via 3.3.3.1, 00:03:56
B       131.108.1.0 [20/84] via 3.3.3.1, 00:03:28
RTC#

Redistribución de sólo rutas OSPF externas (tipo 1 y 2) en BGP

Utilice la palabra clave external junto con el comando redistribute en router bgp para redistribuir las rutas externas OSPF en el BGP. Con la palabra clave external, tiene tres opciones:

  • redistribuir las rutas externas tipo 1 y tipo 2 (Predeterminado)

  • redistribuir las rutas tipo 1

  • redistribuir las rutas tipo-2

Ingrese los comandos en el modo de configuración como se describe aquí:

RTB(config-router)# router bgp 100
RTB(config-router)# redistribute ospf 1 match external

En esta configuración del Router B, se redistribuyeron solamente las rutas Externas OSPF, Tipo 1 y Tipo-2:

RTB
hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.1 255.0.0.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1
!
router bgp 100
 redistribute ospf 1 match external 1 external 2


!--- This redistributes ONLY OSPF External routes, 
!--- but both type-1 and type-2.


 neighbor 3.3.3.3 remote-as 200
!
end

Nota: La configuración muestra match external 1 external 2 y el comando ingresado fue redistribute ospf 1 match external. Esto es normal porque el OSPF añade automáticamente el "external 1 external 2" a la configuración. Hace que las rutas OSPF externa 1 externa 2 coincidan y distribuye ambas rutas en el BGP.

El Router B redistribuye solamente las rutas Externos OSPF:

RTB# show ip bgp
BGP table version is 21, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 200.1.1.0        2.2.2.2                 20         32768 ?
*> 200.2.2.0        2.2.2.2                104         32768 ?
RTB#

El Router C aprende estas dos rutas externo OSPF del BGP:

RTC# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

B    200.1.1.0/24 [20/20] via 3.3.3.1, 00:01:43
B    200.2.2.0/24 [20/0] via 3.3.3.1, 00:01:43
C    3.0.0.0/8 is directly connected, Serial0/0

Redistribución Sólo de las RutasOSPF Externas Tipo 1 o Tipo 2 en el BGP

Ingrese este comando en router bgp 100 en el Router B para redistribuir solamente las rutasOSPF externas 1:

router bgp 100
 redistribute ospf 1 match external 1

La tabla BGP del Router B muestra que redistribuye solamente las rutas externas 1 en el BGP y el resto de las rutas OSPF no están redistribuidas en el BGP:

RTB# show ip bgp
BGP table version is 24, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 200.2.2.0        2.2.2.2                104         32768 ?
RTB#

De la misma manera, ingrese este comando en router bdg 100 en el Router B para redistribuir solamente las rutas OSPF externas 2:

router bgp 100
 redistribute ospf 1 match external 2

Redistribución de rutas OSPF internas y externas en BGP

En este caso, todas las rutas OSPF se redistribuyen en el BGP con las palabras clave internal y external, tal y como se muestra en esta configuración del Router B:

RTB
hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.1 255.0.0.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1
!
router bgp 100
 redistribute ospf 1 match internal external 1 external 2


!--- This redistributes all OSPF routes into BGP.


 neighbor 3.3.3.3 remote-as 200
!
end

Nuevamente, external es reemplazado por external 1 external 2 en la configuración. Esto es normal a menos que especifique qué rutas externas específicas desea redistribuir en el BGP. Después de realizar el cambio en la configuración, el Router B redistribuye todas las rutas OSPF y el Router C comienza a aprender todas las rutas del BGP:

RTB# show ip bgp
BGP table version is 30, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2.2.2.0/24       0.0.0.0                  0         32768 ?
*> 131.108.1.0/24   2.2.2.2                 84         32768 ?
*> 131.108.2.0/24   2.2.2.2                 74         32768 ?
*> 200.1.1.0        2.2.2.2                 20         32768 ?
*> 200.2.2.0        2.2.2.2                104         32768 ?
RTB#

RTC# sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
B       2.2.2.0 [20/0] via 3.3.3.1, 00:01:24
C    3.0.0.0/8 is directly connected, Serial0/0
B    200.1.1.0/24 [20/20] via 3.3.3.1, 00:01:24
B    200.2.2.0/24 [20/104] via 3.3.3.1, 00:01:24
     131.108.0.0/24 is subnetted, 2 subnets
B       131.108.2.0 [20/74] via 3.3.3.1, 00:01:24
B       131.108.1.0 [20/84] via 3.3.3.1, 00:01:24
RTC#

Redistribución de rutas externas OSPF NSSA en BGP

Éste es un caso especial en el cual solamente las rutas Not-So-Stubby Area (NSSA) se redistribuyen en el BGP. Este caso es muy similar al caso descrito en la sección Redistribución Solamente de RutasOSPF Externas (Tipo 1 y 2) la en el BGP. La única diferencia es que el BGP ahora coincide con las rutas NSSA externas y no sólo con las rutas externas. La tabla de ruteo del Router B muestra estas rutas OSPF NSSA externas:

RTB# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O N2 200.1.1.0/24 [110/20] via 2.2.2.1, 00:22:53, Ethernet0
O N1 200.2.2.0/24 [110/20] via 2.2.2.2, 00:22:53, Ethernet0
O IA 131.108.1.0/24 [110/20] via 2.2.2.2, 00:22:53, Ethernet0
O 131.108.2.0/24 [110/20] via 2.2.2.2, 00:22:53, Ethernet0
C    2.0.0.0/8 is directly connected, Ethernet0
C    3.0.0.0/8 is directly connected, Serial1

Este diagrama de la red se utiliza para este caso:

/image/gif/paws/5242/bgp-ospf-redis2.jpg

El diagrama de la red muestra que el Router B recibe las rutas OSPFN1 y N2. El comportamiento predeterminado es redistribuir las rutas N1 y N2 si solamente se utiliza la palabra clave nssa-external. Esta configuración del Router B permite que se redistribuyan las rutas OSPF N1 (200.1.1.0/24) y OSPF N2 (200.2.2.0/24) en el BGP:

RTB
hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.1 255.0.0.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1 
nssa

!
router bgp 100
 redistribute ospf 1 match nssa-external 1 nssa-external 2


!--- This redistributes only OSPF NSSA-external routes 
!--- Type-1 and Type-2 into BGP.


 neighbor 3.3.3.3 remote-as 200
!
end

Nota: Al igual que la configuración OSPF externa, la configuración anterior muestra match nssa-external 1 nssa-external 2 y el comando ingresado fue redistribute ospf 1 match nssa-external. Esto es normal porque el OSPF añade automáticamente "nssa-external 1 nssa-external 2" en la configuración. Hace coincidir las rutas OSPF N1 y OSPF N2 y redistribuye ambas rutas en el BGP.

Después del cambio de configuración en el Router B, el Router B redistribuye las rutas OSPF NSSA externas, y el Router C comienza a aprender las rutas OSPF NSSA externas del BGP:

RTB# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Ethernet0/0
C    3.0.0.0/8 is directly connected, Serial1/0
O N2 200.1.1.0/24 [110/94] via 2.2.2.1, 00:11:12, Ethernet0/0
O N1 200.2.2.0/24 [110/20] via 2.2.2.2, 00:12:23, Ethernet0/0
     131.108.0.0/24 is subnetted, 2 subnets
O       131.108.2.0 [110/74] via 2.2.2.2, 00:12:23, Ethernet0/0
O IA    131.108.1.0 [110/84] via 2.2.2.2, 00:12:11, Ethernet0/0
RTB#

RTB# show ip bgp 
BGP table version is 21, local router ID is 3.3.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 200.1.1.0        2.2.2.2                 94         32768 ?
*> 200.2.2.0        2.2.2.1                 20         32768 ?
RTB#

RTC# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    3.0.0.0/8 is directly connected, Serial0/0
B    200.1.1.0/24 [20/94] via 3.3.3.1, 00:02:06
B    200.2.2.0/24 [20/20] via 3.3.3.1, 00:02:06
RTC#

Al igual que con las rutas OSPF Externas, para redistribuir sólo las rutas OSPF N1, ingrese el siguiente comando en router BGP 100 en el Router B:

router bgp 100
 redistribute ospf 1 match nssa-external 1

!--- This redistributes only OSPF NSSA-external 
!--- Type-1 routes into BGP.

Para redistribuir solamente las rutas N2 OSPF, ingrese el siguiente comando en router BGP 100 en el Router B:

router bgp 100
 redistribute ospf 1 match nssa-external 2

!--- This redistributes only OSPF NSSA-external 
!--- Type-2 routes into BGP.

Nota: Las Ruta-correspondencias se pueden también utilizar para redistribuir el tipo OSPF el 1/2 en el BGP. Refiérase redistribuyen las rutas OSPF E2 en el BGP para más información.

Modificación de la Opción de Redistribución en el OSPF

Es importante comprender cómo el cambio sucesivo de la configuración puede alterar su configuración. Un comando nuevo con la opción match no anula el anterior pero si lo agrega. Comenzando sin redistribución, este ejemplo de configuración de secuencia de comandos muestra su impacto en la redistribución:

R4# conf t
R4(config)# router bgp 100
R4(config-router)# redistribute ospf 1 match internal
R4(config-router)# ^Z

!--- Initially, we redistribute internal OSPF routes into BGP 100.


R4# sh run | i redistribute ospf
 redistribute ospf 1 match internal
R4# conf t
R4(config)# router bgp 100
R4(config-router)# redistribute ospf 1 match external
R4(config-router)# ^Z

!--- With this second command, we tell BGP 
!--- to also redistribute external OSPF routes.


R4# sh run | i redistribute ospf
 redistribute ospf 1 match internal external 1 external 2
R4#
R4# conf t
R4(config)# router bgp 100
R4(config-router)# no redistribute ospf 1 match external 2
R4(config-router)# ^Z

!--- With this no command, we only disable the 
!--- redistribution of external type 2 into BGP. 
!--- All other types of routes previously configured remain.


R4# sh run | i redistribute ospf
 redistribute ospf 1 match internal external 1
 
!--- As you can see, internal and external type 1 remain.

R4# conf t
R4(config)# router bgp 100
R4(config-router)# no redistribute ospf 1 match internal external 1
R4(config-router)# ^Z 

!--- Now, with this no command, which includes all configured 
!--- keywords, it is important to note that we 
!--- still do not disable the redistribution fully.
!--- We only removed the keyword. After this, 
!--- the IOS still acts as default—redistributing
!--- internal routes only.


R4# sh run | i redistribute ospf
 redistribute ospf 1
R4# conf t
R4(config)# router bgp 100
R4(config-router)# no redistribute ospf 1 

!--- Always use this command in order to completely
!--- disable redistribution.

R4(config-router)# ^Z
R4# sh run | i redistribute ospf
R4#

No se Puede Redistribuir las Rutas Aprendidas en el iBGP en un IGP como EIGRP, , OSPF

Se usa la Redistribución de Rutas para propagar las rutas aprendidas con el uso de un protocolo, en otro protocolo de ruteo. Cuando el BGP se redistribuye en un IGP, sólo las rutas aprendidas del eBGP se redistribuyen. Las rutas aprendidas iBGP conocidas en el router no se introducen en el IGP para evitar el ruteo de loops de formación.

De forma predeterminada, la redistribución iBGP en IGP está inhabilitada. Ejecute el comando bgp redistribute-internal para habilitar la redistribución de rutas iBGP en el IGP. Deben tomarse precauciones para redistribuir las rutas específicas usando mapas de ruta en el IGP.

A continuación, se muestra un ejemplo de configuración para redistribuir las rutas del iBGP en el OSPF:

router bgp 65345 
bgp redistribute-internal
!
router ospf 100
redistribute bgp 65345 subnets

Nota: La redistribución de las rutas internas en el internal Border Gateway Protocol (iBGP) en un Interior Gateway Protocol puede provocar loops de ruteo dentro del Sistema Autónomo (SA). Esto no se recomienda. Deben establecerse filtros de la ruta para controlar la información, que se importa en el IGP.

Redistribuya las rutas predeterminado OSPF adentro al BGP

Para redistribuir las rutas predeterminado adentro al BGP, utilice la declaración de la red y la valor por defecto-información origina. En nuestro ejemplo, las rutas predeterminado OSPF se redistribuyen adentro al BGP. Esto se hace con la creación de un route-map y la distribución de la red predeterminada, que es permitida por el ACL estándar.

!
route-map map_default_only permit 10

 match ip address acl_default_only

!

ip access-list standard acl_default_only

 permit 0.0.0.0

!

router bgp 64601

network 0.0.0.0

 redistribute ospf 1 route-map map_default_only

 default-information originate

!--- distributes the default route in bgp

!

Después de la configuración, borre las sesiones BGP con el comando clear ip bgp *.


Información Relacionada


Document ID: 5242