Módulos e interfaces de Cisco : Módulo de switching de contenido de Cisco

Configuración del modo única subred (puente) en el CSM

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

El Módulo de conmutación de contenidos (CSM) provee un alto rendimiento en el Balance de carga del servidor (SLB) entre dispositivos de red y granjas de servidor basado en la Capa 4 a través de 7 paquetes de información. Bloques de servidores se representan que como los servidores virtuales pueden mejorar el scalability y la Disponibilidad de los servicios para su red. Puede agregar nuevos servidores y eliminar servidores existentes o con fallas en cualquier momento sin afectar la disponibilidad del servidor virtual.

Los clientes se conectan al CSM al proveer la dirección IP virtual (VIP) del servidor virtual. Cuando un cliente inicia una conexión al servidor virtual, el CSM elije un servidor real (un dispositivo físico asignado a una granja de servidores) para la conexión en base a algoritmos de equilibrio de carga y políticas (reglas de acceso) configurados. Las directivas manejan el tráfico definiendo donde enviar los pedidos de cliente para la información.

Antes de comenzar

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

prerrequisitos

No hay requisitos previos específicos para este documento.

Componentes Utilizados

Esta configuración se puede utilizar con cualquier versión de software y hardware que soporte el CS.

Teoría Precedente

Los clientes y servidores comunican con el CS usando tecnología del ½ del ¿Â de la capa 2 o de la capa 3ï en una configuración de VLAN específica. Los clientes se conectan con la VLAN del lado de los clientes y los servidores con la VLAN del lado de los servidores. Los servidores y los clientes pueden existir en subredes diferentes. Los servidores también se pueden ubicar a más de un salto de distancia y se pueden conectar a la VLAN del lado del servidor a través de los routers. Un cliente envía una petición a una de las direcciones VIP del módulo. El CS adelante esta petición a un servidor que puede responder a la petición. Luego, el servidor reenvía la respuesta al CSM y el CSM reenvía la respuesta al cliente.

Cuando las VLAN del lado del cliente y del lado del servidor se encuentran en la misma subred, puede configurar el CSM en modo única subred (puente). Este documento describe el modo de la subred única (Bridge).

Cuando los VLA N del client cara y del lado del servidor están en diversas subredes, usted puede configurar el CS para actuar en un modo seguro (del router). Para más información, refiera a configurar el modo seguro (del router) en el CS.

Configurar

Diagrama de la red

EL siguiente diagrama ilustra diferentes VLAN y diferentes subnet.

csm-bridge.gif

Configuraciones

Complete estos pasos:

  1. Cree la VLAN cliente y servidor en el MSFC.

    cat#conf t 
    cat(config)#vlan 100 
    cat(config-vlan)#exit 
    cat(config)#vlan 200 
    cat(config-vlan)#
  2. Configure las interfaces físicas que conectan al cliente (link ascendente) con la correspondiente VLAN.

    cat(config)#inter fastEthernet 2/1 
    cat(config-if)#switchport 
    cat(config-if)#switchport access vlan 100 
    cat(config-if)#no shut
    
  3. Configure las interfaces físicas que conecta los servidores con el VLAN correspondiente.

    cat(config)#inter fastEthernet 2/3 
    cat(config-if)#switchport
    cat(config-if)#switchport access vlan 200 
    cat(config-if)#no shutdown 
    cat(config)#inter fastEthernet 2/4 
    cat(config-if)#switchport 
    cat(config-if)#switchport access vlan 200 
    cat(config-if)#no shutdown
    
  4. Configure el CS.

    cat(config)#module csm 3 
    cat(config-module-csm)#
  5. Cree el VLAN del lado del cliente y el gateway.

    cat(config-module-csm)#vlan 100 client 
    cat(config-slb-vlan-client)#ip address 172.17.63.217 255.255.255.192 
    cat(config-slb-vlan-client)#gateway 172.17.63.214  
    cat(config-slb-vlan-client)#
  6. Cree el VLA N del lado del servidor.

    cat(config-module-csm)#vlan 200 server 
    cat(config-slb-vlan-server)#ip address 172.17.63.217 255.255.255.192
    
  7. Cree el bloque de servidores.

    cat(config-module-csm)#serverfarm wwwfarm
    cat(config-slb-sfarm)#real 172.17.63.215 
    cat(config-slb-real)#inservice 
    cat(config-slb-real)#real 172.17.63.216 
    cat(config-slb-real)#inservice
    
  8. Cree el vserver y asocie el bloque de servidores.

    cat(config-module-csm)#vserver server 
    cat(config-slb-vserver)#virtual 172.17.63.241 tcp www 
    cat(config-slb-vserver)#serverfarm wwwfarm 
    cat(config-slb-vserver)#inservice
    

Ésta es una configuración de muestra del SLB usando el Cisco Catalyst 6500 y el CS.

Config corrientes CS (WS-X6066-SLB-APC)
Building configuration... 

Current configuration : 3863 bytes 
! 
version 12.1 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname cat 
! 
boot system flash sup-bootflash:c6sup11-jsv-mz.121-11b.E 
! 
redundancy 
�main-cpu 
� auto-sync standard 
ip subnet-zero 
! 
mls qos statistics-export interval 300 
mls qos statistics-export delimiter | 
! 

!--- CSM located in slot 3. Module running as Active.�
 
! 
module ContentSwitchingModule 3� 
! 


!--- Client side CSM VLAN 100 
!--- Gateway pointing to the MSFC.

! 
�vlan 100 client 
� ip address 172.17.63.217 255.255.255.192 
� gateway 172.17.63.214 
! 

!--- Server side CSM VLAN 200.

! 
�vlan 200 server 
� ip address 172.17.63.217 255.255.255.192 
! 

!--- Server farm configuration.
 
! 
�serverfarm WWWFARM 
� nat server� 
� no nat client 
� real 172.17.63.215 
�� inservice 
� real 172.17.63.216 
�� inservice 
! 

!--- VServer configuration. 

! 
�vserver SERVER 
� virtual 172.17.63.241 tcp www 
� serverfarm WWWFARM 
� persistent rebalance 
� inservice 
! 
interface GigabitEthernet1/1 
�no ip address 
�shutdown 
! 
interface GigabitEthernet1/2 
�no ip address 
�shutdown 
! 

!--- Connection to upstream device.

! 
interface FastEthernet2/1 
�switchport 
�switchport access vlan 100 
�switchport mode access 
�no ip address 
! 
interface FastEthernet2/2 
�no ip address 
�shutdown 
! 

!--- Connection to Web servers.

! 
interface FastEthernet2/3 
�switchport 
�switchport access vlan 200 
�switchport mode access 
�no ip address 
! 
interface FastEthernet2/4 
�switchport 
�switchport access vlan 200 
�switchport mode access 
�no ip address 
! 
interface FastEthernet2/5 
�no ip address 
�shutdown 
! 

!--- MSFC VLAN 100.

! 
interface Vlan100 
�ip address 172.17.63.214 255.255.255.192 
! 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.17.63.193 
no ip http server 
! 
! 
line con 0 
line vty 0 4 
�login 
! 
end

Verificar (comandos show)

Comando show module csm # status

El comando show module csm - status visualiza el estatus del módulo SLB. El módulo tiene que estar conectado.

cat#show module csm 3 status
SLB Module is online in slot 3.
Configuration Download state: COMPLETE, SUCCESS

Comando show module csm # vserver name word detail

El comando show module csm - vservers name word detail visualiza la información detallada del servidor virtual. Usted también ve el estado del servidor virtual y son cuántas conexiones allí. Éste es el mejor comando de utilizar para conseguir la información del servidor virtual.

cat#show module csm 3 vservers name server detail�
SERVER, state = OPERATIONAL, v_index = 10
� virtual = 172.17.63.241/32:80, TCP, service = NONE, advertise = FALSE
� idle = 3600, replicate csrp = none, vlan = ALL, pending = 30
� max parse len = 600, persist rebalance = TRUE
� conns = 0, total conns = 4
� Default policy:
��� server farm = WWWFARM
��� sticky: timer = 0, subnet = 0.0.0.0, group id = 0
� Policy���������� Tot Conn���� Client pkts� Server pkts
� ------------------------------------------------------
� (default)������� 4����������� 56���������� 56

Comando show module csm # real detail

El comando show module csm # real detail muestra información para cada servidor real, por ejemplo, el bloque de servidores donde reside cada servidor y los estados, umbrales y conexiones de los servidores.

cat#show module csm 3 real detail
172.17.63.215, WWWFARM, state = OPERATIONAL
� conns = 0, maxconns = 4294967295, minconns = 0
� weight = 8, weight(admin) = 8, metric = 0, remainder = 0
� total conns established = 2, total conn failures = 2
172.17.63.216, WWWFARM, state = OPERATIONAL
� conns = 0, maxconns = 4294967295, minconns = 0
� weight = 8, weight(admin) = 8, metric = 0, remainder = 0
� total conns established = 2, total conn failures = 2
cat#show module csm 3 real detail

Comando show module csm # serverfarm name word detail

El comando show module csm # serverfarms name word detail muestra información sobre la granja de servidores. Este comando muestra el predictor usado para el balance de carga. En este ejemplo, se está utilizando el ordenamiento cíclico, que es predeterminado.

cat#show module csm 3 serverfarms name wwwfarm detail�
WWWFARM, predictor = RoundRobin, nat = SERVER
� virtuals inservice: 1, reals = 2, bind id = 0, fail action = none
� inband health config: <none>
� retcode map = <none>
� Real servers:
��� 172.17.63.215, weight = 8, OPERATIONAL, conns = 0
��� 172.17.63.216, weight = 8, OPERATIONAL, conns = 0
� Total connections = 0

Comando show module csm # vlan detail

El comando show module csm# vlan detail muestra la información de VLAN para el cliente y el servidor.

cat#show module csm 3 vlan detail�
vlan�� IP address������ IP mask��������� type������
---------------------------------------------------
100��� 172.17.63.217��� 255.255.255.192� CLIENT
� GATEWAYS
� 172.17.63.214����
200��� 172.17.63.217��� 255.255.255.192� SERVER
cat#

Troubleshooting

Usted debe poder hacer ping el servidor real y el gateway CSM del Catalyst 6500 publicando los comandos ping o ping module csm - reals.

cat#ping module csm 3 reals
IP address������ Reachable
--------------------------
172.17.63.215��� Yes
172.17.63.216��� Yes
cat#ping module csm 3 gateway�������������������������
IP address������ Reachable
--------------------------
172.17.63.214��� Yes

Otro buen comando de Troubleshooting es show module csm # arp. El CS aprenderá los direccionamientos. Aseegurese el gateway y el reals está apareciendo.

cat#show module csm 3 arp�
Internet Address� Physical Interface� VLAN����� Type������ Status
--------------------------------------------------------------------
�172.17.63.210��� 00-E0-B6-01-FA-49�� 100������ LEARNED��� up(0 misses)
�172.17.63.214��� 00-04-C0-C0-68-00�� 100������ GATEWAY��� up(0 misses)
�172.17.63.215��� 00-60-B0-87-DC-1A�� 200������ REAL������ up(0 misses)
�172.17.63.216��� 00-50-DA-BF-A1-7F�� 200������ REAL������ up(0 misses)
�172.17.63.217��� 00-30-F2-71-5D-2E�� 100/200�� --SLB--��� local
�172.17.63.222��� 00-02-B9-45-A2-91�� 100������ LEARNED��� up(0 misses)
�172.17.63.241��� 00-30-F2-71-5D-2D�� 0�������� VSERVER��� local

Información Relacionada


Document ID: 5217