Servicios de redes de aplicaciones : Cisco Content Engines de la serie 500

Configuración de redireccionamiento de medios transparentes y de proxy a través de ACNS 4.x

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento describe cómo configurar el Cisco Cache/Content Engine para transparente y el media del proxy que oculta usando la versión 4.x de Cisco ACNS de la versión 2. del protocolo web cache coordination (WCCP), incluye, como una opción, el RealProxy de RealNetworks, Inc.leavingcisco.com para soportar la secuencia que parte (las transmisiones en directo de distribución) y los medios de flujo continuo que ocultan (contenido a pedido) en el Real-Time Streaming Protocol (RTSP) - el fluir basado y otros formatos reales PNM (metarchivo de RealNetworks).

El Content Engine se puede configurar transparente para validar las peticiones RTSP reorientadas del router WCCP, así como las peticiones tradicionales del proxy-estilo RTSP del software de cliente de RealPlayer. El almacenamiento en memoria inmediata de los medios de flujo continuo proporciona el contenido a pedido al extender que, si un usuario ha visto ya un archivo de medios de flujo continuo ocultado, puede ser servido a los usuarios subsiguientes sin el requisito de conectar con el servidor de origen. Sea consciente que los broadcastes en vivo no pueden ser ocultados.

Para configurar el Content Engine para validar el tráfico RTSP, complete estos pasos:

  1. Publique el comando rtsp proxy en el modo de configuración global para ingresar el IP Address, el puerto, y la licencia usada en el RealProxy del Content Engine.

  2. Publique el comando wccp media-cache global configuration de registrar el Content Engine con cualquier Routers WCCP-habilitado.

Los objetos de los medios de flujo continuo se ocultan en las particiones de disco del sistema de archivos de media (mediafs) mientras que el software RealProxy se copia a la división del sistema del archivo del software (swfs) como parte del procedimiento de instalación. Publique el comando disk de crear las divisiones de los mediafs; publique el comando mediafs de mantener estas divisiones (refiera a mantener el almacenamiento del disco duro para más información sobre las particiones de disco). El software RealProxy se puede administrar con el ½ del ¿Â de RealAdministrator GUIï (acceder esta página, el nombre de usuario/contraseña predeterminado es admin/diamante).

Para configurar al Routers WCCP-habilitado, usted necesita publicar el comando del grupo de servicios 80 del wccp. Muestran la salida de comando en la sección de configuraciones.

Antes de comenzar

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

prerrequisitos

No hay requisitos previos específicos para este documento.

Requisitos

Quienes lean este documento deben tener conocimiento de los siguientes temas:

  • Content Engine que ejecuta la versión de software del ACNS 4.x o más adelante

  • Software RealProxy instalado con las divisiones de los mediafs montadas

Nota: Usted debe comprar una llave de la licencia para activar las características de RealProxy en el software del caché. Para ordenar en el cisco.com, refiera a ordenar.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Versión de software del ACNS de Cisco corriente del Cisco Content Engine 590 4.x o más adelante en un ambiente de laboratorio con las configuraciones despejadas

  • Cisco IOS Software Release 12.0.18(S) corriente del Cisco 7513 Router

Configurar

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

/image/gif/paws/4717/media_redir.jpg

Configuraciones

Cisco Cache Engine 560 (versión de software del ACNS del ½ del ¿Â de Ciscoï 4.x)
hostname disaster

!

ip domain-name cisco.com

!

interface FastEthernet 0/0

ip address 172.17.241.108 255.255.255.0

exit

interface FastEthernet 0/1

shutdown

exit

!

ip default-gateway 172.17.241.45

!

ip name-server 144.254.6.77

!

!

wccp router-list 1 172.17.241.29 172.17.241.31 172.17.241.45

wccp web-cache router-list-num 1

wccp media-cache router-list-num 1

wccp version 2

!

!

rtsp proxy media-real license-key <removed>

rtsp proxy media-real ip-address 172.17.241.108

rtsp proxy media-real enable�

rtsp proxy incoming 554�

rtsp proxy l4-switch enable

!

!

username admin password 1 Gn1nQzm/arxcI

username admin privilege 15

username cisco password 1 714DWnzYTRHC.

username cisco privilege 15

!

!
Building configuration...

Current configuration : 3071 bytes

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

no service single-slot-reload-enable

!

hostname lsd

!

ip subnet-zero

ip wccp web-cache

ip wccp 80

ip cef

no ip domain-lookup

ip domain-name cisco.com.

ip name-server 144.254.6.77

!

interface Ethernet5/0

�ip address 172.17.241.45 255.255.255.0

�no ip directed-broadcast

�ip wccp 80 redirect out

!

interface Ethernet5/1

�ip address 10.10.10.1 255.255.255.0

�no ip directed-broadcast

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.17.241.1

!

line con 0

�exec-timeout 0 0

line aux 0

line vty 0 4

�password <removed>

�login

!

end

Comandos debug y show

Antes de ejecutar un comando de depuración, consulte Información importante sobre comandos de depuración.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

disaster#show mediafs volumes

disk00/03 :    mounted  size: 10669934

disk01/00 :    mounted  size: 14226579

disk01/02 :   formatted  size: 7113289
disaster#show statistics mediacache real requests

                  Media Cache Statistics - Requests

                                                Total             % of Requests

                            ---------------------------------------------------

     Total Received Requests:                       5                         -

            Demand Cache Hit:                       3                      60.0

           Demand Cache Miss:                       2                      40.0

         Demand Pass-Through:                       0                       0.0

                  Live Split:                       0                       0.0

           Live Pass-Through:                       0                       0.0

disaster#show statistics mediacache real savings

             Media Cache Statistics - Savings

                        Requests                          Bytes

         -----------------------------------------------------------

  Total:                       5                       14617438

   Hits:                       3                        6458830

   Miss:                       2                        8158608

Savings:                    60.0 %                         44.2 %

disaster#show rtsp all

Media Types:

  Servicing Real Media

Real Proxy License Key:

  Installed

Media Specific Info:

  Real Proxy IP address: 172.17.241.108

Incoming Proxy-Mode:

  Servicing Proxy mode RTSP connections on port: 554

RTSP Transparent Proxy (WCCP):

  Configured for port: 554

RTSP Transparent Proxy (L4 Switch):

  Configured for port: 554
disaster#show wccp 80 detail



Service Details for Media Cache Service

        Service Enabled                    : Yes

        Service Priority                   : 200

        Service Protocol                   : 6

        Application                        : Streaming

        Service Flags (in Hex)             : 512

        Service Ports                      :    554     0     0     0

                                           :      0     0     0     0

        Security Enabled for Service       : No

        Multicast Enabled for Service      : No

        Weight for this Web-CE: 0
lsd#show ip wccp 80 detail

WCCP Cache-Engine information:

        IP Address:            172.17.241.108

        Protocol Version:      2.0

        State:                 Usable

        Redirection:           GRE

        Initial Hash Info:     00000000000000000000000000000000

                               00000000000000000000000000000000

        Assigned Hash Info:    FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

                               FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

        Hash Allotment:        256 (100.00%)

        Packets Redirected:    35

        Connect Time:          23:41:34
lsd#show ip wccp

Global WCCP information:

    Router information:

        Router Identifier:                   172.17.241.45

        Protocol Version:                    2.0



    Service Identifier: web-cache

        Number of Cache Engines:             1

        Number of routers:                   1

        Total Packets Redirected:            0

        Total Packets Fast Redirected:       0

        Total Packets CEF Redirected:        0

        Total Packets DCEF Redirected:       0

        Redirect access-list:                -none-

        Packets Denied Redirect (ACL):       0

        Packets Denied Redirect (Policy):    0

        Total Packets Unassigned:            0

        Group access-list:                   -none-

        Total Messages Denied to Group:      0

        Total Authentication failures:       0

        Policy Tag:                          0

        Policy Type:                         none



    Service Identifier: 80

        Number of Cache Engines:             1

        Number of routers:                   1

        Total Packets Redirected:            35

        Total Packets Fast Redirected:       0

        Total Packets CEF Redirected:        35

        Total Packets DCEF Redirected:       0

        Redirect access-list:                -none-

        Packets Denied Redirect (ACL):       0

        Packets Denied Redirect (Policy):    0

        Total Packets Unassigned:            0

        Group access-list:                   -none-

        Total Messages Denied to Group:      0

        Total Authentication failures:       0

        Policy Tag:                          0

        Policy Type:                         none

Comandos show de Cache Engine

‘Comando show’ Descripción
show wccp content-engines Información del Content Engine de las visualizaciones WCCP.
show wccp flows media-cache Visualiza los flujos de paquetes de los media servicio de almacenamiento en memoria caché.
show wccp routers Lista del router WCCP de las visualizaciones.
show wccp services Servicios de las visualizaciones WCCP configurados.
show wccp slowstart Comienzo lento de las visualizaciones WCCP.
show wccp status Muestra el estado de ejecución del WCCP.
show statistics mediacache real savings Visualiza las estadísticas de ahorro.
show statistics mediacache real requests Muestra de estadísticas de petición.
show rtsp all Visualiza toda la configuración RTSP.
show rtsp proxy Visualiza la configuración del modo proxy.
show mediafs volumes Visualiza los volúmenes de los mediafs.

Comandos debug del motor del caché

comando debug Descripción
debug wccp all Permisos WCCP para girar todo el debugging.
debug wccp events Habilita el evento WCCP.
debug wccp packets Información relacionada a paquetes de los permisos WCCP.

Comandos show de router

‘Comando show’ Descripción
show ip wccp 80 detail Estadísticas del motor y del router WCCP del caché de las visualizaciones para un grupo de servicio particular.
show ip wccp 80 view Información de la opinión del grupo de servicios de las visualizaciones

Comandos de depuración del router

comando debug Descripción
depuración de eventos IP WCCP Eventos wccp de las visualizaciones.
paquetes del wccp del IP del debug Información relacionada a paquetes de las visualizaciones WCCP.

Resumen de Comandos

Utilizaron a estos comandos cache engine en esta configuración:

  • versión {1 del wccp | 2}

  • Dirección de IP del número de lista de router wccp

  • router-list-num número del media-caché del wccp

  • clave media-real de la llave de la licencia del proxy rtsp

  • rtsp proxy media-real ip-address ip-address

  • permiso media-real del proxy rtsp

  • puerto entrante del proxy rtsp

Éstos son los comandos router que fueron utilizados en esta configuración:

  • wccp del IP {caché Web | número de servicio}

  • wccp del IP {caché Web | el número de servicio} reorienta hacia fuera


Información Relacionada


Document ID: 4717