Switches : Switches Cisco Catalyst de la serie 3750

Configurando y Analizando Agrupamiento en Switches

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (20 Octubre 2015) | Comentarios


Contenido


Introducción

Este documento describe los pasos de configuración básicos para formar un agrupamiento en Catalyst 1900/2820 y en los switches de configuración fija de Catalyst mediante el uso del Cluster Management Suite (CMS). Los switches de configuración fija de Catalyst que abarca este documento incluyen las series 2900/3500XL, 2940, 2950, 2955, 2970, 3550, 3560 y 3750. El objetivo de este documento es proporcionar conocimientos básicos sobre cómo funciona el clúster y proporcionar Troubleshooting básico y analizar los procedimientos con los comandos show y las salidas de los debugs. Este documento ofrece un ejemplo simple de una agrupación construida mediante una interfaz Web. También muestra los cambios de configuración automáticos, notables durante el proceso de creación del clúster.

prerrequisitos

Requisitos

Un documento de administración de la Web separado proporciona la información de cómo accesar al switch con el Cisco visual switch manager (VS) o CMS. El documento, resolviendo problemas el Cisco visual switch manager o Cluster Management Suite Access en el Catalyst 2900XL/3500XL/2950/3550 Switch, aborda estos problemas:

  • No se puede realizar la conexión con la página Web principal del switch

  • 404 errores no encontrados

  • Una pantalla de blanco cuando usted accede el VS o CMS

  • La Java no es pantalla habilitada

  • La interfaz Web pide continuamente el Nombre de usuario y la contraseña

  • Ninguna respuesta de los mensajes de dispositivo durante el link o la creación de gráficos de ancho de banda

Si tiene problemas de acceso con la Interfaz de administración basada en Web (VSM o CMS) o si observa algunos de estos síntomas, consulte Solución de problemas de acceso a Visual Switch Manager o a Cluster Management Suite de Cisco en switches Catalyst 2900 XL/3500 XL/2950/3550.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Notas importantes

La tecnología Cisco Switch Clustering es los conjuntos de características de software disponibles para todo el 2900/3500XL, 2940, 2950, 2955, 2970, 3550, 3560, y los 3750 Series Switch y el estándar y los switches de la edición para empresas del Catalyst 1900/2820. La tecnología de clúster habilita hasta un máximo de 16 switches interconectados para formar haber manejado, red del direccionamiento solo-IP. Es esencialmente un método para manejar un grupo de Switches sin la necesidad de asignar una dirección IP a cada Switch.

Los switches dentro de un agrupamiento tienen una de estas funciones:

  • Comando switch

  • Switches miembro

  • Switches candidatos

En cada agrupamiento, hay un switch maestro llamado switch de comandos. El resto del Switches sirve como switches miembros. El switch de comandos proporciona la interfaz de administración primaria para todo el agrupamiento. El switch de comando es típicamente el único dentro del agrupamiento de switches configurado con una dirección IP. Cada pedido de administración va al comando switch antes del cambio de dirección al switch miembro apropiado. Para la Redundancia, usted puede configurar un Switch del comando standby. El switch de comandos en espera debe ser del mismo modelo que el switch de comandos. Un switch miembro no se configura típicamente con una dirección IP y recibe los comandos management que el comando switch ha reorientado. Un Candidate Switch es un Switch que usted puede agregar al cluster del Switch como switch miembro.

Características del comando switch

Un Switch del comando catalyst debe cumplir estos requisitos:

  • El switch tiene una dirección IP

  • El switch tiene la versión 2 del Protocolo de detección de Cisco (CDPv2) habilitada (predeterminada).

  • El switch no es un comando o es un comando miembro de otro agrupamiento.

  • El switch está conectado a otros switches de comandos en espera a través de la VLAN de administración y a los switches miembro a través de una VLAN común.

En el agrupamiento, el switch con tecnología superior y apto para comandos debe ser el switch de comandos, según se detalla a continuación:

  • Si su cluster del Switch tiene un 3750 Switch, ese Switch debe ser el comando switch.

  • Si su cluster del Switch tiene 2900XL, 2940, la 2950, 2955, 3550, los 3560 y 3500XL Switch, los 3550 o los 3560 deben ser el comando switch.

  • Si su cluster del Switch tiene 2900XL, 2940, la 2950, 2955, y los 3500XL Switch, la 2950 o los 2955 deben ser el comando switch.

  • Si su cluster del Switch tiene 1900, 2820, 2900XL, y 3500XL Switch, el 2900XL o 3500XL debe ser el comando switch.

Características del switch de comando en espera

Un Switch del comando standby del Catalyst debe cumplir estos requisitos:

  • El switch tiene una dirección IP

  • El switch tiene CDPv2 habilitado.

  • El switch está conectado a otros switches de reserva a través de la VLAN de administración y a todos los switches miembro a través de una VLAN común.

  • El switch está redundantemente conectado al agrupamiento para mantener la conectividad con los switches miembros.

  • El switch no es un comando o es un comando miembro de otro agrupamiento.

El Switches del comando standby también debe cumplir estos requisitos:

  • Cuando el comando switch es el Switch a�3750, todo el Switches del comando standby debe el Switches be�3750.

  • Cuando el comando switch es el Switch a�3550, todo el Switches del comando standby debe el Switches be�3550.

  • Cuando el comando switch es el Switch a�2955, todo el Switches del comando standby debe el Switches be�2955.

  • Cuando el comando switch es Switch del Long Reach Ethernet (LRE) a�2950, todo el Switches del comando standby debe Switches be�2950 LRE.

  • Cuando el comando switch es un Switch non-LRE�2950 que funciona con el software Release�12.1(9)EA1 de Cisco IOS� o más adelante, todo el Switches del comando standby debe ser el Switches non-LRE�2950 que funciona con el Cisco IOS Software Release�12.1(9)EA1 o más adelante.

  • Cuando el comando switch es un Switch non-LRE�2950 que funciona con el Cisco IOS Software Release�12.1(6)EA2 o más adelante, todo el Switches del comando standby debe ser el Switches non-LRE�2950 que funciona con el Cisco IOS Software Release�12.1(6)EA2 o más adelante.

  • Cuando el comando switch funciona con el Cisco IOS Software Release�12.0(5)WC2 o anterior, el Switches del comando standby puede be�2900XL, non-LRE�2950, Switches and�3500XL.

El Switches del comando switch y del comando standby debe estar de la misma plataforma del switch seleccionar.

  • Con el comando switch a�3550, el Switches del comando standby si el Switches be�3550.

  • Con el comando switch a�2955, el Switches del comando standby si el Switches be�2955.

  • Con el comando switch a�2950 LRE, el Switches del comando standby si el Switches be�2950 LRE.

  • Con un comando switch non-LRE�2950, el Switches del comando standby debe ser el Switches non-LRE�2950.

  • Con el comando switch a�2900XL or�3500XL, el Switches del comando standby si el Switches be�2900XL and�3500XL.

Características del Candidate Switch y del switch miembro

Los Candidate Switch son el Switches cluster-capaz que todavía no se ha agregado a un cluster. Los switches miembros son el Switches que se ha agregado realmente a un cluster del Switch. Aunque no esté requerido, un candidato o un switch miembro pueda tener una dirección IP y una contraseña. (Para las consideraciones relacionadas, refiera a la sección de los IP Addresses y a la sección de las contraseñas de los clústeres de switches del documento.)

Para unirse a un agrupamiento, el switch candidato debe cumplir estos requisitos:

  • El switch actualmente ejecuta un software con capacidad de agrupamiento.

  • El switch tiene CDPv2 habilitado.

  • El switch no es un comando o es un comando miembro de otro agrupamiento.

  • El switch se conecta al switch de comando a través de, al menos, una VLAN común.

  • Si existe un grupo en espera del cluster, el Switch conecta con cada Switch del comando standby con por lo menos un VLA N común. La VLAN para cada switch de comando en espera puede variar.

Nota: Este el candidato y los switches miembros deben conectar con el Switches del comando switch y del comando standby con el VLAN de administración:

  • 1900 Switch

  • 2820 Switch

  • switches 2900XL

  • Switches non-LRE�2950 que funciona con actualmente una versión anterior que el Cisco IOS Software Release�12.1(9)EA1

  • 3500XL Switch

Nota: Este requisito no se aplica si usted tiene un comando switch 2950 del no LRE que funcione con actualmente el Cisco IOS Software Release�12.1(9)EA1 o más adelante, un comando switch 2950 LRE, un comando switch 2955, o el comando switch a�3550. El candidato y los switches miembros pueden conectar con cualquier VLA N en común con el comando switch.

Con CDPv2, todos los switches, incluso el switch de comando, descubren vecinos CDP y almacenan esta información en el caché vecino CDP respectivo. Switches que ejecuta el paso cluster-capaz del software la información sobre el Switches y los respectivos vecinos al comando switch. Para hacer esto, los switches usan el mecanismo de Comunicación dentro del agrupamiento (ICC), el cual se ejecuta por encima del Protocolo de datagrama de usuario (UDP). El switch de comando filtra la información y crea una lista de switches candidatos.

Para mostrar esta lista de candidatos, ejecute el comando show cluster candidates en el switch de comandos.

Nota: La lista puede no reflejar la tabla de vecinos CDP del comando switch. La tabla de vecino CDP sólo muestra información sobre los vecinos con conexión directa. Cualquier Switch que esté en la lista es un candidato a ser un switch miembro, o un Switch que el comando switch puede manejar. Un Candidate Switch debe satisfacer estos requisitos de unirse a un cluster:

  • El switch debe poseer capacidades de agrupamiento. Para verificar si el switch tiene capacidades de agrupamiento y si actualmente ejecuta la versión correcta del software, consulte la sección Modelos de switches Catalyst con capacidades de agrupamiento de este documento.

  • El switch tiene CDPv2 habilitado. (CDPv2 se activa como opción predeterminada.)

  • El switch no es un miembro activo o un switch de comando de otro agrupamiento.

  • El Switch conecta con un comando switch a través de los puertos que pertenecen al mismo VLAN de administración.

Nota: Un Candidate Switch puede tener una dirección IP, pero una dirección IP no es necesaria.

Nota: El comando switch IP address brinda acceso a todas las instalaciones de administración de tramos. El comando switch IP address siempre pertenece a la VLAN de administración (la predeterminada es VLAN1). Todo el Switches dentro del cluster del Switch debe tener el mismo VLAN de administración que el comando switch. A partir del Cisco IOS Software Release 12.0(5)XP para los 2900XL y 3500XL Switch, usted puede cambiar el VLAN de administración del valor por defecto del VLAN1. Además, el Cisco IOS Software Release 12.0(5)XU o Posterior permite que usted cambie el VLAN de administración para el cluster entero del Switch. El cambio requiere un único comando a través de la interfaz Web CMS. Para los detalles en cómo cambiar el VLAN de administración, refiera a estos documentos:

Detección a través de los puertos ruteados

Si el Switch del comando cluster tiene un puerto ruteado configurado, el Switch descubre el Switches solamente del candidato y del miembro de clúster en el mismo VLA N que el puerto ruteado. Para más información sobre los puertos ruteados, refiera a la sección de los puertos ruteados de la guía de configuración de software 3750 que configura las características de la interfaz.

Detección con diversos VLA N

Si el comando switch es a�3550, 3560, o el 3750 Switch, el cluster pueden tener switches miembros en diversos VLA N. Los switches miembros que son 3550 deben conectar con por lo menos un VLA N que el Switch tenga en común con el comando switch. Switches miembros que are�2900XL, 2950 del �are y ejecutado una versión anterior que el Cisco IOS Software Release�12.1(9)EA1, o are�3500XL debe conectar con el comando switch con el VLAN de administración. Para la información sobre la detección con los VLAN de administraciones, refiera a la detección a través de la misma sección de VLAN de administración y a la detección a través de diversa sección de los VLAN de administraciones de los clústeres de switches del documento. Para más información sobre los VLA N, refiera al documento que configura los VLA N.

Modelos de switches Catalyst con funciones de clústeres

La instalación de la versión del software Catalyst cluster-capaz alcanza las funciones del cluster. Todo el Switches cluster-compatible del Catalyst puede ser switches del comando. Puede actualizar los switches serie 8 MB 2900XL para que se comporten como switches de comando. No puede actualizar los switches de la serie 4 MB 2900XL para que presten servicios de switches de comando. También, este Switches puede actuar solamente como miembros de clúster si el Switches funciona con actualmente el Cisco IOS Software Release 11.2(8.x)SA6.

Antes de que usted cree los clusteres, usted necesita determinar que el Switches es cluster-capaz. También necesita determinar qué switches pueden actuar como un switch de comando. Para determinar si el switch puede actuar como un miembro de un agrupamiento o un switch de comandos, consulte esta tabla:

Catalyst 2900XL/3500XL, 2950, 2955, versiones mínimas de software 2970, 2940, 3550, 3560, y 3750 capacidades de clúster de los modelos y

Tipo del switch de Catalyst Cisco IOS Software Release� Capacidad de clúster
3750 Cisco IOS Software Release 12.1(11)AX o Posterior Miembro o comando switch
3560 Cisco IOS Software Release 12.1(19)EA1 o Posterior Miembro o comando switch
3550 Cisco IOS Software Release 12.1(4)EA1 o Posterior Miembro o comando switch
2970 Cisco IOS Software Release 12.1(11)AX o Posterior Miembro o comando switch
2950 Cisco IOS Software Release 12.0(5.2)WC(1) o Posterior Miembro o comando switch
2955 Cisco IOS Software Release 12.1(12c)EA1 o Posterior Miembro o comando switch
2950 LRE Cisco IOS Software Release 12.1(11)YJ o tarde Miembro o comando switch
2940 Cisco IOS Software Release 12.1(13)AY o Posterior Miembro o comando switch
3500XL Cisco IOS Software Release 12.0(5.1)XU o Posterior Miembro o comando switch
2900 LRE XL (Switches del 16 MB) Cisco IOS Software Release 12.0(5.1)WC1 o Posterior Miembro o comando switch
2900XL (switches de 8 MB) Cisco IOS Software Release 12.0(5.1)XU o Posterior Miembro o comando switch
2900XL (Switches del 4 MB) Cisco IOS Software Release 11.2(8.5)SA6 (recomendado) Switch miembro solamente1
1900 y 2820 Software 9.0 del Cisco IOS Release (- A o - EN) Switch miembro solamente

el Switches 1The 2900XL (4 MB) aparece en el panel de delante y las vistas de la topología de CMS. Sin embargo, el CMS no soporta la configuración o el monitor de estos switches.�To determina si su 2900XL Switch tiene el 4 MB o 8 MB del DRAM, y si el Switch necesita una actualización del software, publique el comando show version del usuario-nivel. Para más información sobre este comando, refiera a cómo determinar la cantidad de memoria en el Switch usando la sección de la interfaz de línea de comando de la actualización de software en los Catalyst 2900XL y 3500XL Switches usando la interfaz de línea de comando.

Nota:  Para ser compatible con los switches 1900 y 2820 como switches miembro, el switch de comando (3500XL o 8 MB 2900XL) debe ejecutar actualmente la versión 12.0(5)XP o posterior del sofware del IOS de Cisco. El comando switch 2950 debe funcionar con el Cisco IOS Software Release 12.0(5)WC(1) o Posterior.

Los switches 1900 y 2820 deben ejecutar la versión 9.00 del firmware (Edición estándar o para empresas) y no pueden funcionar como switches de comandos. Para otros detalles, refiera a los Release Note para el Switches de las Catalyst 1900 y Catalyst 2820 Series, versión 9.00.

Protocolo de administración de tramos

Al habilitar el agrupamiento del switch, se asigna al switch de comandos una dirección IP virtual conocida como Protocolo de administración de agrupamientos (CMP). Cuando siente bien un Switch a un miembro, el comando switch genera otro direccionamiento CMP para el nuevo switch miembro. Esta dirección es para cualquier ICC. El switch de comandos usa esta dirección CMP para enviar un mensaje "agregar" al switch candidato. El switch candidato se asegura de que no es parte de otro agrupamiento antes de que el switch extraiga la dirección CMP y la información de agrupamiento del mensaje de incorporación. La conmutación candidata luego responde al switch de comandos.

Nota: Los direccionamientos CMP que están para el ICC diferencian de la dirección IP que está para el Switch o la administración de grupo. Los direccionamientos CMP no responden a los ping. Esta falta de respuesta es debido a las entradas estáticas del Address Resolution Protocol (ARP) que existen para todos los direccionamientos CMP dentro del cluster del Switch pero es transparente al mundo exterior el cluster.

El CMP es una colección de tecnologías subyacentes que faciliten la Administración de los 16 Switch con el uso de una sola dirección IP. El CMP consiste en tres tecnologías claves:

  • Mecanismo de la asignación de dirección CMP

  • Mecanismo de transporte CMP/IP

  • Mecanismo del address resolution del Reverse Address Resolution Protocol (RARP) CMP

El mecanismo de adjudicación de dirección CMP brinda una forma de asignar dinámicamente direcciones CMP a los miembros de un agrupamiento y asegura que estas direcciones CMP no entren en conflicto con otras direcciones CMP e IP dentro del agrupamiento. El mecanismo de asignación de direcciones CMP también permite solucionar el conflicto de una dirección. El CMP/IP es el mecanismo de transporte que intercambia paquetes de administración entre el comando switch y switches miembro. Los paquetes CMP/IP son los paquetes del IP regulares que se encapsulan en una encabezado (RÁPIDA) del Subnetwork Access Protocol con el Identificador organizacional único (OUI) de Cisco y el Tipo de protocolo CMP. La identificación distingue estos paquetes de los paquetes TCP/IP Ethernet normales. El formato permite las aplicaciones actuales IP trabajen en el CMP/IP sin ningún cambio y permite que el cambio de dirección HTTP y del Simple Network Management Protocol (SNMP) ocurra. El CMP/RARP es una variación del RARP. Agrega y quita el Switches de un cluster, los parámetros del cluster de los conjuntos, y notifica el comando switch de los conflictos de dirección CMP.

La sección Depurar el agrupamiento IP de este documento explica más detalladamente el CMP con la ayuda de los comandos de depuración.

Comunicación dentro de un cluster ICC del Switch

La comunicación dentro de un cluster utiliza los direccionamientos CMP; El ICC la transporta. Cualquier externo de la comunicación al cluster utiliza los IP Addresses y el mecanismo de transporte TCP/IP. Para la comunicación de un dispositivo CMP-dirigido a un dispositivo direccionado por IP externo, el comando switch actúa como proxy y realiza la traducción entre los protocolos CMP y TCP/IP.

Como las menciones de la sección del protocolo cluster management, el comando switch asignan los IP Addresses llamados los direccionamientos CMP a todo el Switches dentro de un cluster. Cualquier momento la Administración PC utiliza el comando switch ip address de acceder los switches miembros, el comando switch utiliza los direccionamientos CMP para reorientar el tráfico.

Por ejemplo, en la creación de un cluster, el comando switch maneja el intercambio de los mensajes entre los switches miembros y una aplicación SNMP. El software de administración de agrupamiento agrega el número del switch miembro (@esN, en el cual N es el número de switch) a las primeras cadenas de comunidad configuradas como Lectura-escritura (RW) y Sólo lectura (RO) en el comando switch. Entonces los propaga al switch miembro. El comando switch utiliza las cadenas de comunidad para controlar el delantero de la petición get, del set request, y de los mensajes de la GET-siguiente-petición entre la estación de la administración de SNMP y los switches miembros.

Cuando usted maneja un switch miembro dentro de un cluster con el uso de CMS o del SNMP, la estación de administración envía los pedidos de administración al comando switch ip address. Las peticiones van al switch de comando porque normalmente un switch miembro no tiene una dirección IP. El pedido incluye un calificador (esN, en el que N es el número de switch). El calificador informa al switch de comando acerca del miembro al cual está destinada en última instancia la solicitud. El comando switch modifica el pedido de forma que éste parezca que viene desde el comando switch. Él entonces adelante la petición al switch miembro apropiado. El switch miembro recibe la solicitud de administración y ejecuta el comando en forma local. Como el switch miembro “piensa” que los paquetes de administración provienen del switch de comando, los reconocimientos van directamente al switch de comando. Finalmente, el comando switch modifica los acuses de recibo y los vuelve a enviar a la estación de administración.

Este organigrama demuestra cómo funciona el redireccionamiento SNMP

/image/gif/paws/4085/61-a.gif

Para otros detalles en la administración de SNMP en los switches de la serie XL, refiera a los documentos enumerados aquí:

Clúster de la configuración

Esta sección describe los procedimientos paso a paso para configurar el clúster en el Catalyst 2900XL/3500XL, 2940, 2950, 2955, 2970, 3550, 3560, y 3750 Switch con el uso de CMS. El desarrollo y la prueba de las configuraciones en esta sección ocurrieron con estas versiones de software y hardware:

‘Versiones de software’

  • 3500XL (3500XL-C3H2S-M) Versión 12.0(5.2)XU del software del IOS de Cisco, software interino de mantenimiento

  • Cisco IOS Software Release 12.0(5.2)XU 2900XL (los 2900XL-C3H2S-M), software interino de mantenimiento

  • Software Cisco IOS 2900XL (2900XL-HS-M), versión 11.2(8.6)SA6, software de mantenimiento provisorio

Versiones de hardware

  • Procesador de Cisco WS-C3524XL (PowerPC403) (Revision 0x01) con 8192 KB/1024 KB de la memoria

  • Procesador de Cisco WS-C3512XL (PowerPC403) (Revision 0x01) con 8192 KB/1024 KB de la memoria

  • Procesador de Cisco WS-C2924MXL (PowerPC403GA) (Revision 0x11) con 8192 KB/1024 KB de la memoria

  • Procesador de Cisco WS-C2916MXL (PowerPC403GA) (Revision 0x11) con 4096 KB/640 KB de la memoria

Escenarios de laboratorio

Diagrama 1

/image/gif/paws/4085/61-b.gif

Diagrama 2

/image/gif/paws/4085/61-c.gif

Diagrama 3: Topología en estrella

/image/gif/paws/4085/61-d.gif

Diagrama 4: Topología de la cadena margarita

61-e.gif

Cree los clusteres con el Cluster Management Suite

Esta sección describe el procedimiento paso a paso para crear un agrupamiento simple con el uso de CMS. Los ejemplos de configuración y el resultado en estos pasos utilizan los switches de la serie 2900XL y 3500XL. Sin embargo, usted puede substituir otros switches de configuración fija que soporten agrupar de CMS. También, la interfaz de usuario de un poco de Switches puede aparecer diferente que las ventanas que usted ve en esta sección. (Véase el cuadro 1 y las imágenes que siguen el cuadro 1.) esta diferencia depende de la versión del código que usted ha instalado en el Switch.

La manera más fácil de configurar un cluster está a través de la interfaz Web. Sin embargo, usted debe conocer en qué va “detrás de las escenas”. Esta sección proporciona las ventanas que muestran la configuración de clúster de la red así como los cambios a las configuraciones en el Switches que resulta.

Esta sección también utiliza un ejemplo para explicar el procedimiento para crear agrupamientos mediante el uso de CMS. En el ejemplo, usted ha atado con alambre junto cuatro Switches con el uso del gigabit y de los puertos Fast Ethernet. Inicialmente, usted crea un cluster con un comando switch y dos switches miembros. Más adelante, usted agrega otro Switch en el cluster, que demuestra cómo agregar a un nuevo miembro.

Nota: Este documento no enseña cómo configurar el clúster con el comando Command Line Interface (CLI). Para más información sobre el CLI, refiera a las secciones de configuración CLI de crear y manejo de los clusteres.

La implementación de las configuraciones en este documento ocurrió en un ambiente de laboratorio aislado, como usted ve en el diagrama 1 y el diagrama 2. esté seguro que usted entiende el impacto potencial de cualquier configuración o comando en su red antes de que usted la utilice. La ejecución del comando write erase eliminó las configuraciones de todos los dispositivos y se aseguró de que estos tuvieran una configuración predeterminada.

Nota: Este documento supone que puede obtener acceso a la CLI en los switches con el uso del puerto de la consola. Para los detalles en cómo acceder un switch XL con el puerto de la consola, refiera a acceder el Switch usando la sección del puerto de la consola de la actualización de software en los Catalyst 2900XL/3500XL Switch usando la interfaz de línea de comando.

  1. Marque que todo el Switches tiene una versión del código del comando either o del switch miembro que tiene soporte del cluster.

    Esto siempre sucede con switches serie 2940, 2950, 2970, 3550, 3560 y 3750 porque todas las versiones de código admiten agrupamientos.

    Para los detalles en las versiones de software y el Switches que soportan el clúster, vea los modelos del switch Catalyst con la sección de las capacidades de clúster de este documento. Para determinar si su Switch 2900XL/3500XL funciona con el software cluster-capaz, publique el comando show version del usuario-nivel en el Switch.

    Por ejemplo, un 2900XL o 3500XL Series Switch que funciona con el comando y el software del member capaz proporciona esta salida del comando show version:

    Switch> show version
    Cisco Internetwork Operating System Software
    IOS (TM) C3500XL Software (C3500XL-C3H2S-M), Version 12.0(5.2)XU, 
    MAINTENANCE INTERIM SOFTWARE
    Copyright (c) 1986-2000 by cisco Systems, Inc.
    Compiled Mon 17-Jul-00 18:29 by ayounes
    Image text-base: 0x00003000, data-base: 0x00301F3C
    
    ROM: Bootstrap program is C3500XL boot loader
    
    Switch uptime is 3 days, 1 hour, 45 minutes
    System returned to ROM by reload
    System image file is "flash:c3500XL-c3h2s-mz-120.5.2-XU.bin"
    
    
    cisco WS-C3524-XL (PowerPC403) processor (revision 0x01) with 8192K/1024K 
    bytes of memory.
    Processor board ID , with hardware revision 0x00
    Last reset from warm-reset
    
    Processor is running Enterprise Edition Software
    Cluster command switch capable
    Cluster member switch capable
    24 FastEthernet/IEEE 802.3 interface(s)
    2 Gigabit Ethernet/IEEE 802.3 interface(s)
    
    32K bytes of flash-simulated non-volatile configuration memory.
    Base ethernet MAC Address: 00:D0:58:68:F1:80
    Configuration register is 0xF
    

    Nota: En esta salida, el Switch del comando cluster capaces y demostración capaz del Switch del miembro de clúster que el Switch funciona con actualmente un software que sea comando y member capaz. Si el Switch funciona con solamente el software del member capaz, después solamente el Switch del miembro de clúster capaz aparece en la salida. Usted puede también configurar un Switch que funcione con el software comando-capaz como switch miembro; sin embargo, usted puede nunca configurar un Switch que funcione con solamente el software del member capaz como comando switch.

  2. Si usted encuentra en el paso 1 que el Switch no funciona con el software cluster-capaz, actualice el Switch al software correcto.

    El Switch funciona con una vez la imagen cluster-capaz, procede al paso 3.

  3. Telegrafíe el Switches de modo que el comando switch pueda descubrir los Candidate Switch que son capaces de la adición al cluster.

    Con el uso del CDPv2, el comando switch puede descubrir automáticamente el Switches en las topologías de la estrella o de la cadena margarita que son hasta tres dispositivos cluster-habilitados (tres saltos) lejos del borde del cluster. Con el código de la versión 12.0(5)XU, o posterior, de software del IOS de Cisco, puede configurar el comando switch para determinar qué switches se encuentran a una distancia de hasta siete dispositivos (siete saltos) con agrupamientos.

    Publique este comando en el comando switch si usted quiere habilitar la detección del Candidate Switch que es hasta siete saltos lejos:

    Switch(config)# cluster discovery hop-count 7
    

    Si un Switch soporta el CDP pero no soporta el clúster, y conecta con el comando switch, el cluster no puede descubrir a los candidatos que asocian a él. Por ejemplo, el creador de clúster no puede crear un cluster que incluya a los candidatos que conectan con un Catalyst 5500/5000 o las 6500/6000 Series conmutan que conecta con el comando switch.

    También, esté seguro que usted conecta todo el Switches con esos puertos que estén en el mismo VLAN de administración. El acceso a todas las instalaciones de administración de clústers está a través del comando switch ip address. El comando switch IP address siempre pertenece a la VLAN de administración (la predeterminada es VLAN1). Todo el Switches dentro del cluster del Switch debe tener el mismo VLAN de administración que el comando switch.

    Nota: A partir del Cisco IOS Software Release 12.0(5)XP para los 2900XL y 3500XL Switch, usted puede cambiar el VLAN de administración del valor por defecto (VLAN1). Además, el Cisco IOS Software Release 12.0(5)XU o Posterior permite que usted cambie el VLAN de administración para el cluster entero del Switch. El cambio requiere un único comando a través de la interfaz Web CMS. Para los detalles en cómo cambiar el VLAN de administración, refiera a estos documentos:

    Este ejemplo configura el switch central (3524XL) como el switch de comando. (Véase el diagrama 1.)

  4. Después de la determinación del comando switch, asigne una dirección IP.

    En este ejemplo, la dirección IP del switch de comando es 172.16.84.35. Utilice estos comandos de realizar la configuración inicial en el comando switch:

    Switch> enable
    Switch# configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)# enable password mysecret
    Switch(config)# interface vlan1
    Switch(config-if)# ip address 172.16.84.35 255.255.255.0
    Switch(config-if)# exit
    Switch(config)# ip default-gateway 172.16.84.1
    Switch(config)# ip http server(Enabling web access to the switch)
    Switch(config)# end
    Switch#
    %SYS-5-CONFIG_I: Configured from console by console
    Switch# write memory
    Building configuration...
    [OK]
    

    Nota: Ésta es una configuración inicial que debe configurar en el switch para tener acceso a el con la Web. La configuración de clúster no ha ocurrido en este momento. Si usted publica el comando show running-config en el Switch, usted no nota la adición de ninguna comandos cluster en el archivo de configuración.

  5. Para comenzar la interfaz Web, ingrese el comando switch ip address en su ventana del buscador.

    Utilice este sintaxis para ingresar el IP Address:

    http://x.x.x.x
    
    

    Nota: La variable x.x.x.x es la dirección IP del switch de comandos.

    Es posible que se le pida el inicio de sesión y la contraseña. Ingrese la contraseña de activación como nombre de usuario y contraseña En este ejemplo, el mysecret es la contraseña habilitada. Después de que usted ingrese el login y la contraseña, usted ve la página de acceso de Cisco, como usted ve en el cuadro 1. Si usted tiene problema con el acceso del Switch cuando usted utiliza al buscador Web, refiera al Cisco visual switch manager del troubleshooting o Cluster Management Suite Access en el Catalyst 2900XL/3500XL/2950/3550 Switch.

    Figura 1

    /image/gif/paws/4085/61-f.gif

    Nota: Versiones de software posteriores utilizan una página de acceso de Cisco como ésta:

    Figura 2

    /image/gif/paws/4085/61-g.gif

  6. Cluster Management Suite o Visual Switch Manager del tecleo en la página de acceso de Cisco.

    Esto hace que aparezca en la pantalla el logo de Visual Switch Manager, como se muestra en la figura 3. Se carga la página de inicio de Switch Manager (Administrador de switches), como puede ver en la Figura 4.

    Nota: Cuando accede al link Cluster Management Suite o Visual Switch Manager en la página de acceso de Cisco, lo primero que ve es el logotipo de Visual Switch Manager. Con la activación del agrupamiento, la pantalla Cluster Management Suite aparece luego de la pantalla del logotipo de Visual Switch Manager (al contrario de la Figura 4).

    Figura 3

    /image/gif/paws/4085/61-h.gif

    ‘Figura 4’

    /image/gif/paws/4085/61-i.gif

    Nota: Si usted tiene dificultad con el acceso al Home Page del Switch que usted ve en el cuadro 4, refiera al Cisco visual switch manager del troubleshooting o Cluster Management Suite Access en el Catalyst 2900XL/3500XL/2950/3550 Switch para resolver problemas el problema.

    Hasta ahora, no se ha realizado ninguna configuración de agrupamiento. Por lo tanto, no se producen cambios en la configuración de ninguno de los switches que se relacionan con el agrupamiento. En los pasos que siguen, usted agrega los comandos cluster en los archivos de configuración. El procedimiento discute cada comando.

  7. De la barra de menú, elija la configuración del cluster > del comando cluster.

    Como se ve en la figura 5, esto abre la ventana de Cluster Configuration (Configuración de agrupamiento).

    Figura 5

    /image/gif/paws/4085/61-j.gif

  8. En el campo de estatus del comando switch, elija el permiso.

  9. Escriba un nombre en el campo Nombre del grupo.

    Puede utilizar hasta 31 caracteres para denominar el cluster. Este ejemplo utiliza “engineering” (ingeniería) como el nombre del tramo:

    ‘Figura 6’

    /image/gif/paws/4085/61-k.gif

  10. Haga clic en OK.

    Esto permite el agrupamiento en el switch central y realiza una conmutación de comando. Cuando haga clic en OK (Aceptar), en la pantalla va a aparecer la información del agrupamiento, como se ve en la figura 7.

    Ahora la dirección de IP del comando y el Nombre del agrupamiento se encuentran visibles. Esta pantalla también se denomina Cluster Management Suite.

    Figura 7

    /image/gif/paws/4085/61-l.gif

    En este momento, la actualización de la configuración del Center Switch (3524XL) ha ocurrido con los comandos que aparecen en intrépido:

    !
    hostname Switch
    !
    enable password mysecret
    !
    ip subnet-zero
    cluster enable engineering 0
    !
    !
    !
    interface VLAN1
    ip address 172.16.84.35 255.255.255.0
    no ip directed-broadcast
    ip nat outside
    !
    !
    ip default-gateway 172.16.84.1
    ip Nat inside source list 199 interface VLAN1 overload
    access-list 199 dynamic Cluster-NAT permit ip any any
    
    !--- Full configuration output is suppressed.
    
    
    

    Cuando ejecuta el comando cluster enable engineering, habilita la funcionalidad del switch de comandos con el nombre de agrupamiento "engineering". Los comandos network address translation (nat) tienen agregado automático al archivo de configuración del comando switch. No quite estos comandos porque los comandos acceden los switches miembros. Cuando el comando switch maneja un switch miembro a través de la interfaz Web, el comando switch actúa como proxy y adelante el HTTP y la Java llama al switch miembro. Los direccionamientos interiores virtuales de las aplicaciones NAT del comando switch (también conocidos como direccionamientos CMP) para realizar esta acción. Para los detalles en cómo el CMP trabaja, vea la sección del protocolo cluster management de este documento.

  11. Elija el cluster > la administración de grupo.

    Una nueva ventana de la administración de grupo se abre. La ventana muestra el creador de clúster (correspondencia del Switches). Dentro de esta ventana, la ventana sugerida del candidato aparece, como usted ve en el cuadro 8. Usted puede mover o minimizar la ventana sugerida del candidato para ver la ventana del creador de clúster (correspondencia) claramente. El mapa muestra el comando y el switch candidato.

    El creador de clúster utiliza el CDP para descubrir los Candidate Switch que son capaces de la adición a un cluster. Con el CDP, el comando switch puede descubrir automáticamente el Switches en las topologías de la estrella o de la cadena margarita que son hasta tres dispositivos cluster-habilitados (tres saltos) lejos del borde del cluster. (Véase el paso 3 de esta sección.) Con el código de la versión 12.0(5)XU, o posterior, de software del IOS de Cisco, puede configurar el comando switch para determinar qué switches se encuentran a una distancia de hasta siete dispositivos (siete saltos) con agrupamientos.

    Nota: En la ventana sugerida del candidato, la demostración sugirió a los candidatos cada vez que se marca la casilla de verificación del comienzo del creador de clúster. Dependiendo de esta selección, usted puede o no puede ver la ventana sugerida del candidato, que se habilita por abandono.

    Figura 8

    /image/gif/paws/4085/61-m.gif

    Nota: Hay únicamente un switch candidato que aparece en el mapa. El comando switch aparece en el verde, y el Candidate Switch aparece en el azul. Los switches aparecen de esta manera porque hay dos switches que tienen el nombre de host predeterminado como Switch. Ahora, no se ha agregado ningunos de los Candidate Switch que aparecen en el azul en el cluster. El Cluster Manager sólo mostró un switch en el diagrama de topología de la figura 8 cuando en realidad hay dos.

    Puede observar el número correcto de los switches candidatos en la ventana Suggested Candidate (Candidato sugerido), como se ve en la Figura 8. También puede utilizar el CLI para corroborar el número correcto de switches candidatos que tienen potencial para ser switches miembros. Por ejemplo:

    Switch# show cluster candidates
                                                                 |---Upstream---|
    MAC Address      Name    Device Type    PortIf  FEC  Hops  SN    PortIf   FEC
    00e0.1e9f.50c0   Switch  WS-C2916M-XL   Fa0/1          1    0     Fa0/2
    00d0.5868.eb80   Switch  WS-C3512-XL    Gi0/2          1    0     Gi0/1
    
    
  12. Haga Click en OK en la ventana sugerida del candidato, y espera por cerca de 30 segundos.

    Se ve esta pantalla que muestra el número correcto de los switches miembros y el switch de comando:

    Figura 9

    /image/gif/paws/4085/61-n.gif

    En este diagrama, el Switch del Center Switch es el comando switch. El switch-1 y el switch-2 son los switches miembros. Ahora, todo el Switches es verde, que muestra que él está en el cluster con el nombre “ingeniería”.

    Puede verificar esta agrupación si ejecuta estos comandos en los switches miembro y de comandos:

    • Comando switch (Center Switch, 3524XL):

      Switch# show cluster
      Command switch for cluster "engineering"
           Total number of members:                3
           Status:                                 0 members are unreachable
           Time since last status change:          0 days, 0 hours, 7 minutes
           Redundancy:                             Disabled
           Heartbeat interval:                     8
           Heartbeat hold-time:                    80
           Extended discovery hop count:           3
      
      Switch# show cluster members
                                                               |---Upstream---|
      SN   MAC Address      Name      PortIf   FEC   Hops  SN  PortIf  FEC  State
      0    00d0.5868.f180   Switch                     0                    Up (Cmdr)
      1    00e0.1e9f.50c0   Switch-1   Fa0/1           1    0  Fa0/2        Up
      2    00d0.5868.eb80   Switch-2   Gi0/2           1    0  Gi0/1        Up
      
      Switch# show cluster view
                                                                 |---Upstream---|
      SN   MAC Address      Name       Device Type    PortIf FEC Hops  SN PortIf  FEC
      0    00d0.5868.f180   Switch     WS-C3524-XL                0
      1    00e0.1e9f.50c0   Switch-1   WS-C2916M-XL   Fa0/1       1     0   Fa0/2
      2    00d0.5868.eb80   Switch-2   WS-C3512-XL    Gi0/2       1     0   Gi0/1
      

      Los cambios que ocurren en el archivo de configuración del comando switch después de que usted realice el paso 12 aparecen aquí en intrépido:

      !
      ip subnet-zero
      cluster enable engineering 0
      cluster member 1 mac-address 00e0.1e9f.50c0
      cluster member 2 Mac-address 00d0.5868.eb80
      !
      !
      !
      
      !--- Full configuration output is suppressed.
      
      
      

      Nota: Cuando un switch candidato se convierte en un switch miembro, la configuración de switch del comando agrega la dirección MAC del switch miembro. También, la configuración del switch de miembro agrega el comando switch mac address.

    • Switch-1 del miembro (switch inferior, 2916MXL)

      Switch-1# show cluster
      Cluster member 1
      Cluster name: engineering
      Management ip address: 172.16.84.35
      Command device Mac address: 00d0.5868.f180
      Switch-1#

      La dirección de IP de administración es la dirección de IP del switch de comando. Esto define el concepto de agrupamiento, que es la administración de un grupo de switches que utilizan una única dirección IP.

      También, si usted tiene conexión de consola al Switch-1 del miembro, este mensaje aparece en la consola del switch miembro tan pronto como el cluster agregue el Switch:

      Switch#
      %CMP-CLUSTER_MEMBER_1-5-ADD: The Device is added to the cluster
      (Cluster Name: engineering, CMDR IP Address 172.16.84.35)
      Switch-1#

      Los cambios que ocurren en el archivo de configuración del comando switch después de que usted realice el paso 12 aparecen aquí en intrépido:

      !
      hostname Switch-1
      !
      enable password mysecret
      !
      !
      no spanning-tree vlan 1
      no ip domain-lookup
      !
      cluster commander-address 00d0.5868.f180
      
      !--- You may also see the member number and cluster name in the
      !--- above line. This depends on the version of code that you use.
      
      !
      interface VLAN1
      no ip address
      no ip route-cache
      
      !--- Full configuration output is suppressed.
      
      
      
    • Switch-2 del miembro (Switch superior, 3512XL)

      Switch-2# show cluster
      Member switch for cluster "engineering"
             Member number:                                2
             Management IP address:                        172.16.84.35
             Command switch Mac address:                   00d0.5868.f180
             Heartbeat interval:                           8
             Heartbeat hold-time:                          80
      Switch-2#

      La dirección de IP de administración es la dirección de IP del switch de comando.

      También, si usted tiene conexión de consola al switch-2 del miembro, este mensaje aparece en la consola del switch miembro tan pronto como el cluster agregue el Switch:

      Switch#
      %CMP-CLUSTER_MEMBER_2-5-ADD: The Device is added to the cluster
      (Cluster Name: engineering, CMDR IP Address 172.16.84.35)
      Switch-2#

      Los cambios que ocurren en el archivo de configuración del comando switch después de que usted realice el paso 12 aparecen aquí en intrépido:

      !
      hostname Switch-2
      !
      enable password mysecret
      !
      !
      ip subnet-zero
      !
      cluster commander-address 00d0.5868.f180 member 2 name engineering
      
      !--- If you run an older version of code, you may not see
      !--- the member number and cluster name in the above line.
      
      !
      interface VLAN1
      no ip address
      no ip directed-broadcast
      no ip route-cache
      
      !--- Full configuration output is suppressed.
      
      

      Si usted ve las salidas del Switch-1 del miembro y de las configuraciones del switch-2 del miembro, usted nota la herencia por los switches miembros de la contraseña habilitada y del nombre del host, añadidos al final del fichero con vario el comando switch.

      Si un nombre del host no fue asignado previamente al switch miembro (como en este ejemplo), el comando switch añade un número único del miembro al final del fichero al nombre del host del comando switch; el comando switch entonces asigna el número secuencialmente al Switch cuando el Switch se une al cluster. Este número indica que el orden en el cual el switch se unió al agrupamiento. En este ejemplo, el comando switch tiene el Switch predeterminado del nombre del host. El primer switch miembro (WS-C2916MXL) toma el Switch-1 del nombre del host. El segundo switch miembro (WS-C3512XL) toma el switch-2 del nombre del host.

      Nota: Si el switch miembro tiene ya un nombre del host, el Switch conserva ese nombre del host cuando se une al cluster. Si el switch miembro sale del cluster, sigue habiendo el nombre del host.

      El switch miembro también hereda el switch del comando enable secret o enable password cuando el switch se une al grupo. Conserva la contraseña cuando sale del cluster también. Si usted no ha configurado una contraseña del comando switch, el switch miembro hereda una contraseña nula.

  13. Elija las escrituras de la etiqueta de las opiniones > de la palanca para ver una información del clúster más detallada.

    La ventana muestra esta información adicional:

    • Dirección MAC de los switches miembros

    • Dirección IP del comando switch

    • Números de puerto y tipo de links (Fast Ethernet o Gigabit Ethernet)

    Figura 10

    /image/gif/paws/4085/61-o.gif

  14. Para ver una imagen de todo el Switches en el cluster, elija el cluster > van al administrador de clúster.

    El administrador de clúster aparece. Visualiza una vista del Switches en una forma del cluster:

    Figura 11

    /image/gif/paws/4085/61-p.gif

    Puede utilizar el Cluster Manager (Administrador de agrupamientos) para administrar y configurar los cambios dentro de un agrupamiento. Puede usarlo para supervisar y configurar puertos, cambiar la VLAN de administración y cambiar el nombre de host. La administración de grupo y cómo realizar diversas tareas de configuración con el administrador de clúster está fuera del alcance de este documento, sin embargo. Para estos detalles, refiera a los documentos:

Agregue a un miembro en un clúster existente

Esta sección describe cómo agregar un switch miembro a un cluster que exista ya. El ejemplo agrega un switch Catalyst 2924MXL en el grupo, como se muestra en la figura 10.

Complete estos pasos para agregar a otro miembro en el cluster con CMS:

  1. Conecte el Switch que usted quiere agregar a uno de los puertos en el comando o el switch miembro.

    En la sección de los escenarios de laboratorio de este documento, el nuevo Switch conecta con el FastEthernet 0/2 interfaz del comando switch. Esté seguro que los puertos que conectan el dos Switches pertenecen al mismo VLAN de administración o que los puertos son puertos troncales. También en los escenarios de laboratorio, todos los puertos pertenecen al VLAN1, que es el VLAN de administración por abandono.

    Nota: El acceso a todas las instalaciones de administración de clústers está a través del comando switch ip address. El comando switch IP address siempre pertenece a la VLAN de administración (la predeterminada es VLAN1). Todo el Switches dentro del cluster del Switch debe tener el mismo VLAN de administración que el comando switch. A partir del Cisco IOS Software Release 12.0(5)XP para los 2900XL y 3500XL Switch, usted puede cambiar el VLAN de administración del valor por defecto del VLAN1. Además, el Cisco IOS Software Release 12.0(5)XU o Posterior permite que usted cambie el VLAN de administración para el cluster entero del Switch. El cambio requiere un único comando a través de la interfaz Web CMS. Para los detalles en cómo cambiar el VLAN de administración, refiera a estos documentos:

  2. En su navegador, elija el cluster > la administración de grupo.

    La acción abre el Constructor de agrupamiento en una nueva ventana del navegador y lo muestra en la pantalla.

    Figura 12

    61-q.gif

    Puede observarse que la ventana de candidato sugerido lista el switch nuevo (2924MXL) como un candidato de switch. El cuadro 12 también muestra que hay un nuevo Switch, en el azul. El nuevo switch se conecta al switch central (switch de comando). Cuando este switch candidato se convierte en un miembro del agrupamiento, el color cambia a verde y el switch aparece como Switch-3.

  3. Para agregar el Candidate Switch al cluster y poner al día la correlación de la red, realice uno de estos pasos:

    • Haga Click en OK en la ventana sugerida del candidato y espera por algunos segundos.

      Esto muestra una actualización de la correlación de la red con el switch nuevo, Switch-3.

    • O haga clic en el switch del candidato, como se ve en la Figura 13, y luego elija Add to Cluster (Agregar al grupo).

    Figura 13

    /image/gif/paws/4085/61-r.gif

    Figura 14

    /image/gif/paws/4085/61-s.gif

  4. Elija las opiniones > las escrituras de la etiqueta de la palanca para ver más detalles en la correlación de la red.

    Figura 15

    /image/gif/paws/4085/61-t.gif

    Si usted quiere verificar este cluster, publique estos comandos en el comando switch y el nuevo switch miembro, switch-3:

    • Comando switch (Center Switch, 3524XL)

      Switch# show cluster
      Command switch for cluster "engineering"
            Total number of members:            4   
            Status:                             0 members are unreachable
            Time since last status change:      0 days, 0 hours, 7 minutes
            Redundancy:                         Disabled
            Heartbeat interval:                 8
            Heartbeat hold-time:                80
            Extended discovery hop count:       3
      
      Switch# show cluster members
                                                        |---Upstream---|
      SN  MAC Address      Name     PortIf   FEC  Hops SN PortIf FEC  State
      0   00d0.5868.f180   Switch                   0                 Up (Cmdr)
      1   00e0.1e9f.50c0   Switch-1 Fa0/1           1   0  Fa0/2      Up
      2   00d0.5868.eb80   Switch-2 Gi0/2           1   0  Gi0/1      Up
      3   00ee.1e9f.50c0   Switch-3 Fa0/1           1   0  Fa0/3      Up
      
      Switch# show cluster view
                                                               |---Upstream---|
      SN  MAC Address       Name      Device Type   PortIf  FEC Hops SN  PortIf FEC
      0   00d0.5868.f180    Switch    WS-C3524-XL                0 
      1   00e0.1e9f.50c0    Switch-1  WS-C2916M-XL  Fa0/1        1   0    Fa0/2
      2   0d0.5868.eb80     Switch-2  WS-C3512-XL   Gi0/2        1   0    Gi0/1
      3   00ee.1e9f.50c0    Switch-3  WS-C2924M-XL  Fa0/1        1   0    Fa0/3
      

      Los cambios que tienen lugar en el archivo de configuración del switch de comandos después que usted realiza el Paso 4 aparecen aquí en negrita:

      !
      ip subnet-zero
      cluster enable engineering 0
      cluster member 1 Mac-address 00e0.1e9f.50c0
      cluster member 2 Mac-address 00d0.5868.eb80
      cluster member 3 Mac-address 00ee.1e9f.50c0
      !
      !
      !
      
      !--- Full configuration output is suppressed.
      
      

      Nota: Cuando un switch candidato se convierte en un switch miembro, la configuración de switch del comando agrega la dirección MAC del switch miembro. También, la configuración del switch de miembro agrega el comando switch mac address.

    • Switch-3 del miembro (2924MXL)

      Switch-3# show cluster
      Member switch for cluster "engineering"
         Member number:     3
         Management IP address:     172.16.84.35
         Command switch Mac address:     00d0.5868.f180
         Heartbeat interval:     8
         Heartbeat hold-time:     80
      Switch-3#
      

      La dirección de IP de administración es la dirección de IP del switch de comando.

      Los cambios que tienen lugar en el archivo de configuración del switch de comandos después que usted realiza el Paso 4 aparecen aquí en negrita:

      !
      hostname Switch-3
      !
      enable password mysecret
      !
      !
      ip subnet-zero
      !
      cluster commander-address 00d0.5868.f180 member 3 name engineering
      !
      interface VLAN1
      no ip address
      no ip directed-broadcast
      no ip route-cache
      
      !--- Full configuration output is suppressed.
      
      
  5. Elija el cluster > van al administrador de clúster.

    El administrador de clúster aparece, como usted ve en el cuadro 16. Esta visión es actualizada del cuadro 11 y muestra el Switch nuevamente agregado (2924MXL) en la lista:

    Figura 16

    61-u.gif

Comandos debug y show

Ejemplo de Resultado del Comando show

show cluster y show cluster members

Use los comandos show cluster y show cluster members para verificar el estado del agrupamiento y de los miembros.

  • Comando switch (Center Switch, 3524XL)

    Switch# show cluster
    Command switch for cluster "engineering"
            Total number of members:        4
            Status:                         0 members are unreachable
            Time since last status change:  0 days, 0 hours, 7 minutes
            Redundancy:                     Disabled
            Heartbeat interval:             8
            Heartbeat hold-time:            80
            Extended discovery hop count:   3
    
    
    Switch# show cluster members 
                                                    |---Upstream---|
    SN MAC Address    Name         PortIf FEC Hops   SN PortIf  FEC  State
    0  00d0.5868.f180 Switch                   0                    Up   (Cmdr)
    1  00e0.1e9f.50c0 Switch-1     Fa0/1       1     0  Fa0/2       Up  
    2  00d0.5868.eb80 Switch-2     Gi0/2       1     0  Gi0/1       Up
    3  00ee.1e9f.50c0 Switch-3     Fa0/1       1     0  Fa0/3       Up
    
    

    Si uno de los switches miembros pierde la Conectividad al comando switch, la salida de los comandos show cluster y show cluster members refleja la pérdida.

    Por ejemplo, si el switch-2 del miembro pierde la Conectividad al comando switch, la salida de estos comandos es:

    Switch# show cluster       
    Command switch for cluster "engineering"
            Total number of members:        4
            Status:                         1 members are unreachable
            Time since last status change:  0 days, 0 hours, 0 minutes
            Redundancy:                     Disabled
            Heartbeat interval:             8
            Heartbeat hold-time:            80
            Extended discovery hop count:   3
    Switch#
    
    Switch# show cluster member
                                                    |---Upstream---|
    SN MAC Address    Name         PortIf FEC Hops   SN PortIf  FEC  State
    0  00d0.5868.f180 Switch                   0                    Up   (Cmdr)
    1  00e0.1e9f.50c0 Switch-1     Fa0/1       1     0  Fa0/2       Up  
    2  00d0.5868.eb80 Switch-2                 1                    Down
    3  00ee.1e9f.50c0 Switch-3     Fa0/1       1     0  Fa0/3       Up
    
    

    Nota: No ve inmediatamente los cambios que reflejan estos comandos. El comando switch tiene que esperar cierto intervalo (tiempo en espera del latido del corazón) antes de que el comando switch declare un switch miembro abajo. Por abandono, el tiempo de espera del latido es 80 segundos. Esto es un parámetro configurable. Puede cambiar el parámetro si emite el comando cluster holdtime 1-300 en el modo de configuración global.

  • Switch-1 del miembro (2916MXL)

    Switch-1# show cluster
    Cluster member 1
    Cluster name: engineering
    Management ip address: 172.16.84.35
    Command device Mac address: 00d0.5868.f180
    Switch-1#
  • Switch-2 del miembro (Switch superior, 3512XL)

    Switch-2# show cluster 
    Member switch for cluster "engineering"
            Member number:                  2
            Management IP address:          172.16.84.35
            Command switch Mac address:     00d0.5868.f180
            Heartbeat interval:             8
            Heartbeat hold-time:            80
    Switch-2#
  • Switch-3 del miembro (2924MXL)

    Switch-3# show cluster
    Member switch for cluster "engineering"
            Member number:                  3
            Management IP address:          172.16.84.35
            Command switch Mac address:     00d0.5868.f180
            Heartbeat interval:             8
            Heartbeat hold-time:            80
    Switch-3#

show cdp neighbors y show cdp neighbors detail

Como se debate en la sección de las características del Candidate Switch y del switch miembro de este documento, todo el Switches, incluyendo el comando switch, utiliza el CDPv2 para descubrir a los vecinos CDP. Los switches almacenan esta información en la memoria caché vecina respectiva. Cuando el switch de comando recibe la información, el switch filtra los caché CDP vecinos y crea una lista de switches candidatos.

Use los comandos show cdp neighbors y show cdp neighbors detail para verificar que los switches estén en la memoria caché del vecino CDP y que todos se ejecuten actualmente en CDPv2.

  • Comando switch (3524XL)

    Switch# show cdp neighbors
    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                      S - Switch, H - Host, I - IGMP, r - Repeater
    
    Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
    Switch-3         Fas 0/3            162         T S       WS-C2924M-Fas 0/1
    Switch-2         Gig 0/1            121         T S       WS-C3512-XGig 0/2
    Switch-1         Fas 0/2            136          S        WS-C2916M-Fas 0/1
    
    
    Switch# show cdp neighbors detail
    -------------------------
    Device ID: Switch-3
    Entry address(es):
    Platform: cisco WS-C2924M-XL, Capabilities: Trans-Bridge Switch
    Interface: FastEthernet0/3, Port ID (outgoing port): FastEthernet0/1
    Holdtime : 132 sec
    
    !--- Output suppressed.
    
    
    advertisement version: 2
    Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload len=25,
    value=0AA050C000000003010103FF00D05868F18000EE1E9F50C001
    VTP Management Domain: ''
    
    -------------------------
    Device ID: Switch-2
    Entry address(Es):
          IP address: 0.0.0.0
          IP address: 172.16.84.35
    Platform: cisco WS-C3512-XL, Capabilities: Trans-Bridge Switch
    Interface: GigabitEthernet0/1, Port ID (outgoing port): GigabitEthernet0/2
    Holdtime : 141 sec
    
    !--- Output suppressed.
    
    
    advertisement version: 2
    Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload Len=27,
    value=0A68EB8000000002010123FF00D05868F18000D05868EB80010001
    VTP Management Domain: ''
    Duplex: full
    
    -------------------------
    Device ID: Switch-1
    Entry address(Es):
          IP address: 172.16.84.35
    Platform: cisco WS-C2916M-XL, Capabilities: Switch
    Interface: FastEthernet0/2, Port ID (outgoing port): FastEthernet0/1
    Holdtime : 140 sec
    
    !--- Output suppressed.
    
    
    advertisement version: 2
    Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload Len=25,
    value=0A9F50C000000001010103FF00D05868F18000E01E9F50C001
    VTP Management Domain: ''
    
  • Switch-1 del miembro (2916MXL)

    Switch-1# show cdp neighbors 
    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                      S - Switch, H - Host, I - IGMP, r - Repeater
    
    Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
    Switch           Fas 0/1           139         T S       WS-C3524-XFas 0/2
    
    Switch-1# show cdp neighbors detail
    -------------------------
    Device ID: Switch
    Entry address(Es):
          IP address: 172.16.84.35
          IP address: 172.16.84.35
    Platform: cisco WS-C3524-XL, Capabilities: Trans-Bridge Switch
    Interface: FastEthernet0/1, Port ID (outgoing port): FastEthernet0/2
    Holdtime : 147 sec
    
    !--- Output suppressed.
    
    
    advertisement version: 2
    Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload Len=27,
    value=0A68F18000000000010123FF00D05868F18000D05868F180000001
    VTP Management Domain: ''
    
  • Switch-2 del miembro (3512XL)

    Switch-2# show cdp neighbors 
    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                      S - Switch, H - Host, I - IGMP, r - Repeater
    
    Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
    Switch           Gig 0/2            147         T S       WS-C3524-XGig 0/1
    
    
    Switch-2# show cdp neighbors detail
    -------------------------
    Device ID: Switch
    Entry address(Es):
          IP address: 172.16.84.35
          IP address: 172.16.84.35
    Platform: cisco WS-C3524-XL, Capabilities: Trans-Bridge Switch
    Interface: GigabitEthernet0/2, Port ID (outgoing port): GigabitEthernet0/1
    Holdtime : 141 sec
    
    
    !--- Output suppressed.
    
    advertisement version: 2 
    Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload Len=27, 
    value=0A68F18000000000010123FF00D05868F18000D05868F180000001 
    VTP Management Domain: '' Duplex: full 
  • Switch-3 del miembro (2924MXL)

    Switch-3# show cdp neighbors 
    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                      S - Switch, H - Host, I - IGMP, r - Repeater
    
    Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
    Switch           Fas 0/1            125         T S       WS-C3524-XFas 0/3
    
    
    Switch-3# show cdp neighbors detail
    -------------------------
    Device ID: Switch
    Entry address(Es):
          IP address: 172.16.84.35
          IP address: 172.16.84.35
    Platform: cisco WS-C3524-XL, Capabilities: Trans-Bridge Switch
    Interface: FastEthernet0/1, Port ID (outgoing port): FastEthernet0/3
    Holdtime : 179 sec
    
    !--- Output suppressed.
    
    
    advertisement version: 2
    Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload Len=27,
    value=0A68F18000000000010123FF00D05868F18000D05868F180000001
    VTP Management Domain: ''
    

Nota: Si usted no ve la versión del anuncio: 2 en la salida del comando show cdp neighbors detail para un Switch, ese Switch no pueden convertirse en un switch miembro.

Ejemplo de resultado de comando de depuración

Esta sección se refiere a los comandos de depuración que verifican la actividad de agrupamiento. Aquí, los comandos verify la actividad del clúster entre el comando switch (3524XL) y el switch-2 del miembro (3512XL). Puede usar los mismos comandos debug para verificar la actividad del agrupamiento entre el switch de comando y cualquiera de los switches miembros.

Nota: Siempre que se agregue o quite un miembro utilizando la interfaz Web, verá el registro de esta información:

%CMP-CLUSTER_MEMBER_2-5-REMOVE:
The Device is removed from the cluster (Cluster Name: engineering)

%CMP-CLUSTER_MEMBER_2-5-ADD:
The Device is added to the cluster(Cluster Name: engineering, 
CMDR IP Address 172.16.84.35)

debug cluster member, debug cluster neighbors y debug cluster events

Los dos primeros comandos de depuración en estos ejemplos, debug cluster member y debug cluster neighbors, muestran las actualizaciones de vecinos de tramos salientes desde un switch de comando o un switch miembro. El comando third debug, debug cluster events, muestra el hellos vecino entrante. Entre los comandos, los comentarios en el azul aumentan la visibilidad de ciertas salidas. También, esta visualización suprime la información innecesaria de la salida de los debugs completa.

  • Comando switch (3524XL)

    Switch# debug cluster members 
    Cluster members debugging is on
    Switch#
    23:21:47: Sending neighbor update...
    23:21:47: 
    Cluster Member: 00, active.
    
    !--- Member 00 means commander switch.
    
    23:21:47:       Unanswered heartbeats: 1
    23:21:47:       Hops to commander:     0
    23:21:47:       Assigned CMP address:  10.104.241.128
    
    !--- This is the commander CMP address.
    
    23:21:47:       Cmdr IP address:       172.16.84.35   
    23:21:47:       Cmdr CMP address:      10.104.241.128
    
    !--- This is the commander CMP address.
    
    23:21:47:       Auto update counter:   0
    23:21:47:       Cmdr MAC address:      00d0.5868.f180
    23:21:47:       Mbr  MAC address:      00d0.5868.f180
    23:21:47:       Command Port ID:       
    23:21:47:       Platform Name:         cisco WS-C3524-XL
    23:21:47:       Host Name:             Switch
    
    Switch# debug cluster neighbors
    Cluster neighbors debugging is on
    Switch#
    23:51:50:           Neighbor update from member 0
    
    !--- This is an update from the commander.
    
    23:51:50:           3 Cluster neighbors:
    
    !--- Information about member Switch-2 starts here.
    
    23:51:50:           00d0.5868.eb80 connected to Member 0 
                        on port GigabitEthernet0/2
    23:51:50:           Port Macaddr: 00d0.5868.eb8e
    23:51:50:           Hostname: Switch-2
    23:51:50:           Port ID: GigabitEthernet0/2
    23:51:50:           Neighbor FEC: 255
    23:51:50:           Member FEC: 255
    23:51:50:           Capabilities: 0A
    23:51:50:           Link Qualification: 0
    23:51:50:           Qualification Note: 21
    23:51:50:           Member 2 of stack with commander 0.104.187.140
    23:51:50:           CMP address: 10.104.235.128
    23:51:50:           Hops to Commander: 1
    23:51:50:           Management vlan: 1
    
    !--- Information about member Switch-2 ends here.
    
    
    
    !--- Information about member Switch-1 starts here.
    
    23:51:50:      00e0.1e9f.50c0 connected to Member 0 on port FastEthernet0/2
    23:51:50:      Port Macaddr: 00e0.1e9f.50c1
    23:51:50:      Hostname: Switch-1
    23:51:50:      Port ID: FastEthernet0/1
    23:51:50:      Neighbor FEC: 255
    23:51:50:      Member FEC: 255
    23:51:50:      Capabilities: 08
    23:51:50:      Link Qualification: 3
    23:51:50:      Qualification Note: 01
    23:51:50:      Member 1 of stack with commander 0.77.44.124
    23:51:50:      CMP address: 10.159.80.192
    23:51:50:      Hops to Commander: 1
    23:51:50:      Management vlan: 0
    
    !--- Information about member Switch-1 ends here.
    
    
    
    !--- Information about member Switch-3 starts here.
    
    23:51:50:       00ee.1e9f.50c0 connected to Member 0 on port FastEthernet0/3
    23:51:50:       Port Macaddr: 00ee.1e9f.50c1
    23:51:50:       Hostname: Switch-3
    23:51:50:       Port ID: FastEthernet0/1
    23:51:50:       Neighbor FEC: 255
    23:51:50:       Member FEC: 255
    23:51:50:       Capabilities: 0A
    23:51:50:       Link Qualification: 3
    23:51:50:       Qualification Note: 00
    23:51:50:       Member 3 of stack with commander 0.77.184.56
    23:51:50:       CMP address: 10.160.80.192
    23:51:50:       Hops to Commander: 1
    23:51:50:       Management vlan: 1
    
    !--- Information about member Switch-3 ends here.
    
    
    !--- The information that follows is from Switch-2, as seen on 
    !--- the command switch.
    !--- You can see the same information if you issue the
    !--- debug cluster events command on certain versions 
    !--- of codes.
    
    Cluster neighbor's Protocol Hello payload:
    23:52:00:           Sender Version: 1, Works with version 1 and later
    23:52:00:           Flags: 23, Number of hops to the commander: 1
    23:52:00:           Cluster member number: 2
    23:52:00:           Cluster Cmdr Mac Address: 00d0.5868.f180
    23:52:00:           Sender Mac address: 00d0.5868.eb80
    
    !--- This is the Switch-2 MAC address.
    
    
    23:52:00:           Sender CMP address: 10.104.235.128
    
    !--- This is the Switch-2 CMP address.
    
    23:52:00:           Upstream switch No: 0.0.0.0
    23:52:00:           FEC Number: 255
    23:52:00:           Management vlan: 1
    
    !--- Output suppressed.
    
    
  • Switch-2 del miembro (3512XL)

    Switch-2# debug cluster member
    Cluster members debugging is on
    Switch-2#
    23:22:51:     Sending neighbor update...
    23:22:51:     Switch 00d0.5868.f180 connected on port GigabitEthernet0/2
    
    !--- This is the command switch MAC address local port.
    
    23:22:51:     Port ID: GigabitEthernet0/2
    23:22:51:     Capabilities: 0A
    23:22:51:     Link Qualification: 5
    23:22:51:     Qualification Note: 20
    23:22:51:     Member 0 of stack with commander 00d0.5868.f180
    23:22:51:     CMP address: 10.104.241.128
    
    !--- This is the commander CMP address.
    
    23:22:51:     Hops to Commander: 0
    23:22:51:     Management vlan: 1*
    23:22:51:
    
    !--- Up to this point, the information is about the command switch.
    !--- The output that follows is the local switch information that goes to the 
    !--- neighbor (command) switch.
    
    Cluster Member: 02, active.
    23:22:51:    Unanswered heartbeats: 1
    23:22:51:    Hops to commander: 1
    23:22:51:    Assigned CMP address: 10.104.235.128
    23:22:51:    Cmdr IP address: 172.16.84.35
    23:22:51:    Cmdr CMP address: 10.104.241.128
    23:22:51:    Auto update counter: 0
    23:22:51:    Cmdr MAC address: 00d0.5868.f180
    23:22:51:    Mbr MAC address: 00d0.5868.eb80
    23:22:51:    Command Port ID: GigabitEthernet0/2
    
    !--- This is the port that connects to the commander.
    
    23:22:51:    Platform Name: cisco WS-C3512-XL
    23:22:51:    Host Name: Switch-2
    Switch-2#
    
    Switch-2# debug cluster neighbors
    Cluster neighbors debugging is on
    Switch-2#
    23:59:32: cmi_setCommandPort: setting ups mbr num to 0
    23:59:32: cmp_sendNeighborsToCmdr: skip neighbor 00d0.5868.f180
    Switch-2#
    23:59:42:
    
    !--- Information that follows is from the command switch.
    !--- You can see the same information if you issue the
    !--- debug cluster events command on certain versions 
    !--- of codes.
    
    Cluster neighbor's Protocol Hello payload:
    23:59:42:    Sender Version: 1, Works with version 1 and later
    23:59:42:    Flags: 23, Number of hops to the commander: 0
    23:59:42:    Cluster member number: 0
    23:59:42:    Cluster Cmdr Mac Address: 00d0.5868.f180
    23:59:42:    Sender Mac address: 00d0.5868.f180
    
    !--- This is the commander MAC address.
    
    23:59:42:    Sender CMP Address: 10.104.241.128
    
    !--- This is the commander CMP address.
    
    23:59:42:    Upstream switch No: 0.0.0.0
    23:59:42:    FEC Number: 255
    23:59:42:    Management vlan: 1

debug cluster ip

Un campo de dirección CMP aparece en el resultado del comando de debug. Mientras que la sección del protocolo cluster management explica, el comandante y los switches miembros comunican con el uso de estos direccionamientos CMP.

Si usted ve las salidas en el miembro de clúster del debug, los vecinos del cluster del debug, y la sección del debug cluster events, usted puede ver que son los direccionamientos CMP del Switches en este ejemplo:

  • Direccionamiento de comandante CMP: 10.104.241.128

  • Direccionamiento del Switch-1 CMP del miembro: 10.159.80.192

  • Direccionamiento del switch-2 CMP del miembro: 10.104.235.128

  • Direccionamiento del switch-3 CMP del miembro: 10.160.80.192

Mientras que la sección del protocolo cluster management discute, el CMP consiste en tres tecnologías claves. Una de ellas es el mecanismo CMP/RARP. El CMP/RARP también agrega y quita el Switches del cluster. El siguiente resultado de depuración muestra el registro de los mensajes CMP/RARP en el momento en que un miembro se agrega al agrupamiento.

Nota: Para mantener la coherencia con los comandos en la sección debug cluster member, debug cluster neighbors y debug cluster events, aquí debe ejecutar el comando debug cluster ip en el comandante (3524XL) y el segundo switch a agregar (Switch-2, 3512XL).

  • Comandante Switch (3524XL) (el switch-2 del agregado de miembro)

    Switch# debug cluster ip
    Cluster IP/transport debugging is on
    Switch#
    
    
    !--- The command switch generates the new CMP address.
    
    1d08h: cmdr_generate_cluster_ip_address: generated cluster,
    ip addr 10.104.235.128 for Mac 00d0.5868.eb80
    
    
    !--- The commander allocates the CMP address to member Switch-2.
    
    1d08h: cmdr_generate_and_assign_ip_address:
    setting addr for member 2 addr 10.104.235.128
    
    1d08h: cmdr_generate_and_assign_ip_address:
    adding static ARP for 10.104.235.128
    1d08h: cluster_send_rarp_reply:
    Sending reply out on Virtual1 to member 2
    1d08h: cmdr_process_rarp_request: received RARP req :
    1d08h: proto type : 0000
    1d08h: source Mac : 00d0.5868.eb80
    
    !--- This is the member MAC Address.
    
    1d08h: source ip : 10.104.235.128
    
    !--- This is the member CMP Address.
    
    1d08h: target Mac : 00d0.5868.f180
    
    !--- This is the commander MAC Address.
    
    1d08h: target ip : 10.104.241.128
    
    !--- This is the commander CMP Address.
    
    1d08h: cmdr_process_rarp_request: rcvd ACK for the bootstrap req
    
  • Switch-2 del miembro (3512XL) (que el comandante agrega)

    Switch# debug cluster ip
    Cluster IP/transport debugging is on
    Switch#
    
    
    !--- The member switch receives information from the command switch.
    
    00:01:24: cluster_process_rarp_reply: received RARP reply :
    00:01:24: source Mac : 00d0.5868.f180
    
    !--- This is the commander MAC Address.
    
    00:01:24: source ip : 10.104.241.128
    
    !--- This is the commander CMP Address.
    
    00:01:24: target Mac : 00d0.5868.eb80
    
    !--- This is the member MAC Address.
    
    00:01:24: target ip : 10.104.235.128
    
    !--- This is the member CMP Address.
    !--- The member switch extracts and implements the cluster information.
    
    00:01:24: cluster_process_rarp_reply:
    setting commander's MAC address: 00d0.5868.f180
    00:01:24: create_cluster_idb: creating HWIDB(0x0) for the cluster
    00:01:24: cluster_create_member_idb:
    creating cluster-idb 4D4378, cmp-addr: 10.104.235.128
    00:01:24: Authorizing the password string:
    00:01:24: cluster_send_rarp_request: Sending request out to cmdr
    00:01:24: cluster_process_rarp_reply:
    created hwidb and set IP address (10.104.235.128)
    00:01:24: cluster_process_rarp_reply:
    setting commander's addr (10.104.241.128) info
    00:01:24: cluster_process_rarp_reply:
    setting static ARP for cmdr addr 10.104.241.128
    00:01:24: cluster_set_default_gateway:
    setting default gw to cmdr's addr (10.104.241.128)
    00:01:24: setting hostname to Switch-2
    00:01:24: setting password to enable password 0 mysecret
    00:01:24: cluster_pick_defaultidb: picking cluster IDB to be default IDB
    00:01:24: This switch is added to the cluster
    00:01:24: Cluster Name : engineering ; Cmdr IP address: 172.16.84.35
    00:01:24: CMP address: 10.104.235.128 ; Cmdr CMP address: 10.104.241.128
    
    !--- At this point, the switch has been added to the cluster.
    
    00:01:24: %CMP-CLUSTER_MEMBER_2-5-ADD: The Device is added to the cluster
    (Cluster Name: engineering, CMDR IP Address 172.16.84.35)
    00:01:24: cluster_process_rarp_reply: bootstrap for the firsttime, start member
    00:01:24: cluster_process_rarp_reply: setting netsareup to TRUE
    

Uso de rcommand para administración remota de CLI

Esta última porción del análisis del debug explica cómo el CMP/IP trabaja. Pues la sección del protocolo cluster management de este documento discute, el CMP/IP es el mecanismo de transporte para intercambiar los paquetes de administración entre el comando switch y los switches miembros.

Un ejemplo es el uso del rcommand, que es realmente una sesión telnet del comando switch al switch miembro. Utiliza los mismos direccionamientos virtuales CMP.

  1. Establezca a una sesión telnet al comando switch.

  2. Del CLI en el comando switch, publique el rcommand para conseguir al CLI de los switches miembros uces de los.

    El comando rcommand es útil en situaciones en las que se desea resolver problemas o realizar cambios en las configuraciones en cualquiera de los switches miembro mediante el uso de la CLI.

    Este ejemplo demuestra el uso:

    Switch# rcommand 2
    
    !--- This accesses member Switch-2.
    
    Trying ... Open
    
    Switch-2#
    
    !--- Here, you establish a Telnet session with member Switch-2.
    
    Switch-2# exit
    
    !--- Use this command to end the Telnet session.
    
    
    [Connection closed by foreign host]
    Switch#
    

Al habilitar el comando debug ip packet desde el switch miembro y ejecutar rcommand desde el switch de comando a ese switch miembro, se pueden ver estos mensajes en la consola del switch miembro:

01:13:06: IP: s=10.104.241.128 (Virtual1), d=10.104.235.128, Len 44, rcvd 1

!--- This is a received request from the command switch.


01:13:06: IP: s=10.104.235.128 (local), d=10.104.241.128 (Virtual1), Len 44, sending

!--- A reply returns to the command switch.


Nota: Para ver esta salida en el switch miembro, primero debe establecer una conexión de consola directa con tal switch. Después de que usted establezca la conexión, publique el comando debug ip packet y después abra a una sesión rcommand del comando switch.

Apéndice

Configuraciones de muestra de agrupamiento

Esta sección enumera las configuraciones de muestra completas de todo el Switches que los escenarios de laboratorio utilizaron. Puede encontrar detalles sobre los pasos de configuración en las secciones Creación de agrupamientos con Cluster Management Suite (CMS) y Adición de un miembro en un agrupamiento existente, de este documento.

Switch de Comando

Switch# show running-config
Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
enable password mysecret
!
!
!
!
!
!
ip subnet-zero
cluster enable engineering 0
cluster member 1 Mac-address 00e0.1e9f.50c0
cluster member 2 Mac-address 00d0.5868.eb80
cluster member 3 Mac-address 00ee.1e9f.50c0
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
ip address 172.16.84.35 255.255.255.0
no ip directed-broadcast
ip Nat outside
!
ip default-gateway 172.16.84.1
ip Nat inside source list 199 interface VLAN1 overload
access-list 199 dynamic Cluster-NAT permit ip any any
!
line con 0
transport input none
stopbits 1
line vty 0 4
login
line vty 5 15
login
!
end

Switch-1 del miembro

Switch-1# show running-config
Building configuration...
Current configuration:
!
version 11.2
no service pad
no service udp-small-servers
no service tcp-small-servers
!
hostname Switch-1
!
enable password mysecret
!
!
no spanning-tree vlan 1
no ip domain-lookup
!
cluster commander-address 00d0.5868.f180
!
interface VLAN1
no ip address
no ip route-cache
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
!
line con 0
stopbits 1
line vty 0 4
login
line vty 5 15
login
!
end

Switch-2 del miembro

Switch-2# show running-config
Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch-2
!
enable password mysecret
!
!
!
!
!
!
ip subnet-zero
!
cluster commander-address 00d0.5868.f180 member 2 name engineering
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
no ip address
no ip directed-broadcast
no ip route-cache
!
!
line con 0
transport input none
stopbits 1
line vty 0 4
login
line vty 5 15
login
!
end

Switch-3 del miembro

Switch-3# show running-config
Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch-3
!
enable password mysecret
!
!
!
!
!
!
ip subnet-zero
!
cluster commander-address 00d0.5868.f180 member 3 name engineering
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface VLAN1
no ip directed-broadcast
no ip route-cache
!
!
!
line con 0
transport input none
stopbits 1
line vty 5 15
!
end

Información adicional

Para la información sobre cómo utilizar CMS después de la configuración inicial, refiera a la guía de configuración de software para su Switch Product:

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 4085