Servicios de redes de aplicaciones : Cisco LocalDirector de la serie 400

Servidores FTP del Equilibrio de carga con LocalDirector sin el uso del servicio FTP del proxy

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Cisco ha anunciado la fin-de-venta para el Cisco LocalDirector. Para más información, refiera al fin de vida de las 400 Series de LocalDirector y los avisos y los boletines de productos del Fin de la Venta.


Contenido


Introducción

Este documento explica cómo cargar los servidores del File Transfer Protocol (FTP) de la balanza con un LocalDirector sin el uso del servicio FTP del proxy.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Problemas y soluciones

Las dificultades principales de manejar el FTP a través de los dispositivos como el LocalDirector son sobre todo debido al canal de datos. Los siguientes son dos escenarios posibles:

  1. PUERTO FTP: también conocido como FTP activo. La conexión de datos es abierta por el puerto de servidor 20 al puerto del cliente que se pasa vía el comando port sobre el canal de control.

  2. PASO FTP: la conexión de datos es iniciada por el cliente. El servidor envía la dirección IP y el puerto el cliente tiene que abrir la conexión con sobre el canal de control.

Escenario 1

El problema en el escenario número 1, el PUERTO FTP, es que el LocalDirector tiene que ser dado instrucciones para crear una entrada del flujo para el tráfico iniciado del servidor interno.

Típicamente, la solución en este escenario es publicar el comando static. Para el tráfico FTP, sin embargo, el LocalDirector lo aplica automáticamente.

Escenario 2

Hay dos problemas con el escenario número 2, PASA EL FTP. El primer problema es que el balanceador de la carga tiene que ser dado instrucciones para contar con una conexión del cliente al puerto del TCP de destino que es diferente de los que está configurados en el virtuals.

La solución en este problema es crear no una configuración del límite del acceso tal como 172.17.241.254:0:0:tcp. Usando la ninguna solución del límite del acceso, el LocalDirector valida y crea los flujos para cada protocolo de la capa 4 (L4) que golpee a la dirección IP virtual. Con el FTP en el LocalDirector, sin embargo, esto no es necesario, incluso con una configuración del límite del acceso tal como 172.17.241.254:21:0:tcp.

El LocalDirector continúa mirando en las sesiones del control FTP para interceptar los comandos que accionarán la Transferencia de datos pasiva.

El segundo problema es que el LocalDirector tiene que tomar el cuidado de la traducción de la dirección IP enviada por el servidor al cliente en el modo FTP del PASO.

Esto se hace automáticamente, incluso sin proxy FTP el servicio. La dirección IP y el puerto con los cuales el cliente tendrá que conectar se muestran durante la sesión FTP siempre que se publique un comando que acciona una conexión de datos, como se muestra abajo.

> 227 Entering Passive Mode (172,17,241,254,95,57) 

Usted puede ver que el direccionamiento vuelto es el externo VIP y no la dirección real interna. Esto significa que el LocalDirector continúa mirando el payload de los paquetes del control de conexión. Vea el diagrama a continuación para más información.

lb_ftp_servers.gif

Proporcionan la salida del comando de ejemplo abajo.

[OK] 
localdirector# sho conf 
: Saved 
: LocalDirector 420 Version 4.2.2 
: Uptime is 0 weeks, 0 days, 3 hours, 0 minutes, 35 seconds 
syslog output 20.3 
no syslog console 
enable password 000000000000000000000000000000 encrypted 
hostname localdirector 
no shutdown ethernet 0 
no shutdown ethernet 1 
shutdown ethernet 2 
shutdown ethernet 3 
interface ethernet 0 10baset 
interface ethernet 1 10baset 
interface ethernet 2 100basetx 
interface ethernet 3 100basetx 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure? 0 
no secure? 1 
no secure? 2 
no secure? 3 
no ping-allow 0 
no ping-allow 1 
no ping-allow 2 
no ping-allow 3 
ip address 172.17.241.11 255.255.255.0 
arp timeout 30 
no rip passive 
rip version 1 
failover ip address 172.17.241.27 
no failover 
failover hellotime 30 
password dfeaf10390e560aea745ccba53e044ed encrypted 
snmp-server enable traps 
snmp-server community public 
no snmp-server contact 
no snmp-server location 
virtual 172.17.241.254:21:0:tcp is 
real 172.17.241.126:21:0:tcp is 
bind 172.17.241.254:21:0:tcp 172.17.241.126:21:0:tcp 

Abajo está el registro de la sesión FTP.

smarsill@bru-cse-126% ftp 172.17.241.254 
Connected to 172.17.241.254. 
220 CISCO FTP server (Version wu-2.6.1(1) Wed Aug 9 05:54:50 EDT 2000) ready. 
Name (172.17.241.254:smarsill): cisco 
331 Password required for cisco. 
Password: 
230 User cisco logged in. 
Remote system type is UNIX. 
Using binary mode to transfer files. 
ftp> ls 
227 Entering Passive Mode (172,17,241,254,95,57) 
150 Opening ASCII mode data connection for /bin/ls. 
total 24 
-rw-------??? 1 cisco??? cisco??????? 4088 Sep? 3 11:55 .bash_history 
-rw-r--r--??? 1 cisco??? cisco????????? 24 Feb 16? 2001 .bash_logout 
-rw-r--r--??? 1 cisco??? cisco???????? 230 Feb 16? 2001 .bash_profile 
-rw-r--r--??? 1 cisco??? cisco???????? 124 Feb 16? 2001 .bashrc 
-rw-r--r--??? 1 cisco??? cisco???????? 688 Feb 16? 2001 .emacs 
-rw-r--r--??? 1 cisco??? cisco??????? 3651 Feb 16? 2001 .screenrc 
226 Transfer complete. 
ftp> pass 
Passive mode off. 
ftp> ls 
200 PORT command successful. 
150 Opening ASCII mode data connection for /bin/ls. 
total 24 
-rw-------??? 1 cisco??? cisco??????? 4088 Sep? 3 11:55 .bash_history 
-rw-r--r--??? 1 cisco??? cisco????????? 24 Feb 16? 2001 .bash_logout 
-rw-r--r--??? 1 cisco??? cisco???????? 230 Feb 16? 2001 .bash_profile 
-rw-r--r--??? 1 cisco??? cisco???????? 124 Feb 16? 2001 .bashrc 
-rw-r--r--??? 1 cisco??? cisco???????? 688 Feb 16? 2001 .emacs 
-rw-r--r--??? 1 cisco??? cisco??????? 3651 Feb 16? 2001 .screenrc 
226 Transfer complete. 
ftp> 

Abajo está la salida del comando netstat -n después de que se haya publicado el comando más reciente.

cisco@localhost cisco]$ netstat -n 
Active Internet connections (w/o servers) 
Proto Recv-Q Send-Q Local Address?????????? Foreign Address???????? State 
tcp??????? 0????? 0 172.17.241.126:20?????? 144.254.3.201:40411???? TIME_WAIT?? 

!--- Data Active expired.
 
tcp??????? 0????? 0 172.17.241.126:24377??? 144.254.3.201:40410???? TIME_WAIT?? 

!--- Data Passive expired.

tcp??????? 0????? 0 172.17.241.126:21?????? 144.254.3.201:40408???? ESTABLISHED 

!--- Control.

tcp??????? 0??? 126 172.17.241.126:23?????? 144.254.3.201:40220???? ESTABLISHED 

!--- Telnet session. 

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 4068