Voz y Comunicaciones unificadas : Cisco Unified Border Element

Ejemplo de Configuración de Unified Border Element (CUBE) con Cisco Unified Communications Manager (CUCM)

28 Enero 2009 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (31 Octubre 2007) | Comentarios

Contenidos

Introducción
Prerrequisitos
      Requisitos
      Componentes Utilizados
      Convenciones
Configure
      Configuraciones
      Configuración del Agente de Usuario SIP
      Interconexión con Cisco Unified Communications Manager
      Transcodificación en el Cisco Unified Border Element
      Uso de Tcl IVR en el Cisco Unified Border Element
      Configuración Completa del Ejemplo
Verifique
Troubleshooting
      Comandos para Troubleshooting
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

El Cisco Unified Border Element facilita una conectividad rentable y sencilla entre las troncales de comunicaciones unificadas empresariales del Session Initiation Protocol (SIP) y la red de telefonía pública conmutada (PSTN) Diseñado para satisfacer las necesidades de los dispositivos Session Border Controller (SBC) de la empresas y el proveedor de servicio, el Cisco Unified Border Element (CUBE) es una aplicación integrada de Cisco IOS® Software que se ejecuta en:

  • Cisco 2800 Series Integrated Services Routers

  • Cisco 3800 Series Integrated Services Routers

  • Cisco 2600XM Series Multiservice Platforms

  • Cisco 3700 Series Routers

  • Cisco 7200VXR Routers

  • Cisco 7301 Routers

  • Cisco AS5400XM y AS5350XM Access Gateways

Las interconexiones IP directas entre redes de comunicaciones unificadas brindan mayor flexibilidad para soportar servicios emergentes en comparación con las interconexiones tradicionales de multiplexación por división de tiempo (TDM) de las redes de telefonía pública conmutada (PSTN).

El Cisco Unified Border Element ofrece un punto de interfaz red a red para:

  • Conexión entre redes de señalización: H.323, SIP

  • Conexión entre redes de medios: multifrecuencia de tono dual [DTMF], fax, módem y transcodificación de códec

  • Traducciones de direcciones y puertos: privacidad y ocultamiento de topología

  • Normalización de registros de facturación y detalles de llamadas (CDR)

  • Administración de Calidad de Servicio (QoS) y ancho de banda: marcado de QoS empleando un punto de código de servicios diferenciado [DSCP] o tipo de servicio (ToS), aplicación de ancho de banda utilizando Resource Reservation Protocol [RSVP] y filtrado de códec

Un Cisco Unified Border Element interactúa con muchos elementos de red diferentes, como gateways de voz, teléfonos IP, y servidores de control de llamadas en varios entornos de aplicación diferentes, desde servicios empresariales avanzados de voz y/o video con Cisco Unified Communications Manager o Cisco Unified Communications Manager Express, así como con aplicaciones más sencillas de transporte de voz sobre IP (VoIP) y desvío de llamadas de larga distancia (toll bypass).

El Cisco Unified Border Element proporciona a las organizaciones todas las funciones de controlador de borde integradas en la capa de red para interconectar arquitecturas de comunicaciones unificadas de voz y video del tipo empresa a prestador de servicio. El Cisco Unified Border Element es utilizado por empresas y organizaciones de pequeña y mediana magnitud para interconectar el acceso SIP PSTN con redes de comunicaciones unificadas empresariales SIP y H.323.

Prerrequisitos

Requisitos

No existen requisitos específicos para este documento.

Componentes Utilizados

La información incluida en este documento se basa en el Cisco Unified Border Element (CUBE).

La información de este documento se creó a partir de los dispositivos en un entorno específico de laboratorio. Todos los dispositivos que se utilizan en este documento se iniciaron con una configuración vacía (predeterminada). Si su red está en funcionamiento, asegúrese de comprender el posible efecto de los comandos.

Convenciones

Consulte las Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las convenciones del documento.

Configure

En esta sección, encontrará la información para configurar las funciones descritas en este documento.

Nota: Utilice la herramienta Command Lookup (sólo para clientes registrados) para obtener más información sobre los comandos utilizados en esta sección.

Configuraciones

Esta configuración habilita la funcionalidad básica del Cisco Unified Border Element en una plataforma. Esta funcionalidad finaliza una llamada VoIP entrante y vuelve a originarla mediante el uso de un dial-peer de VoIP saliente. Las llamadas pueden ser H.323 a SIP o SIP a SIP.

voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
allow-connections h323 to h323

Configure los dial-peers entrantes y salientes con el protocolo, el tipo de DTMF y la información de códec relevantes.

dial-peer voice 1 voip
session target ipv4:10.13.8.150
incoming called-number 8...
dtmf-relay h245-alphanumeric
codec g711ulaw
!
dial-peer voice 2 voip
destination-pattern 8...
session protocol sipv2
session target ipv4:10.13.8.16
dtmf-relay rtp-nte
codec g711ulaw

Configuración del Agente de Usuario SIP

Configure el Agente de Usuario (UA) SIP para el registro y la autenticación.

Agente de Usuario (UA) SIP

sip-ua
registrar ipv4:10.1.1.10
or
registrar dns:csps.cisco.com
authentication username xyz password xyz realm cisco.com

Interconexión con Cisco Unified Communications Manager

El Cisco Unified Communications Manager se puede interconectar con el Cisco Unified Border Element mediante el uso de una troncal de comunicaciones unificadas H.323 o SIP.

Troncal H.323 al Cisco Unified Border Element

Existen dos métodos para definir una troncal H.323 al Cisco Unified Border Element en el Cisco Unified Communications Manager:

  • Con gatekeeper: Configure una troncal H.225 (controlada por GK) hacia el Cisco Unified Border Element

  • Sin gatekeeper: Configure el Cisco Unified Border Element como una gateway H.323

Requisitos de Media Termination Point (MTP):

  • Si el Cisco Unified Border Element realiza llamadas H.323 a H.323, no es obligatorio contar con un MTP siempre que la versión del Cisco Unified Border Element sea 12.4(6)T o posterior y la versión del Cisco Unified Communications Manager sea 4.1 o posterior.

  • Un MTP de hardware o software puede corresidir en el mismo router que el Cisco Unified Border Element (en plataformas de routers que sean compatibles con MTP de CUCM, que incluyen ISR Cisco series 2800 y 3800).

Requisitos para H.323 Fast Start:

  • Si el Cisco Unified Border Element realiza conexiones entre redes H.323 a SIP para el Cisco Unified Communications Manager, la mayoría de los servidores proxy de SIP exigirá que la llamada SIP sea una Early Offer. Esto implica que el lado H.323 debe ser H.323 Fast Start. En consecuencia, se debe configurar el Cisco Unified Communications Manager para H.323 Fast Start entrante y saliente, lo que también exige la presencia de un MTP.

La Figura 1 muestra la configuración para un Cisco Unified Border Element definido como gateway H.323 en el Cisco Unified Communications Manager.

Figura 1. Configuración del Cisco Unified Border Element como una Gateway H.323 en el Cisco Unified Communications Manager

/image/gif/paws/99863/cube-config01.gif

cube-config02.gif

La Figura 2 muestra la configuración del Cisco Unified Border Element para que coincida con la configuración anterior del Cisco Unified Communications Manager.

Figura 2. Configuración del Cisco Unified Border Element para una Troncal H.323

cube-config03.gif

Troncal SIP al Cisco Unified Border Element

Para definir una troncal SIP de comunicaciones unificadas al Cisco Unified Border Element se requiere el Cisco Unified Communications Manager Versión 5.x o posterior.

Requisitos MTP:

  • Troncal SIP sin MTP: Configure una troncal SIP de comunicaciones unificadas sin MTP en caso de que sea aceptable un medio con retraso o un mensaje invite sin SDP.

  • Troncal SIP con MTP: Configure una troncal SIP de comunicaciones unificadas (con MTP) si se requieren medios anticipados (early media) o un mensaje invite con SDP (sólo llamadas G.711).

La Figura 3 muestra la configuración para un Cisco Unified Border Element definido con una troncal SIP de comunicaciones unificadas al Cisco Unified Communications Manager.

Figura 3. Configuración del Cisco Unified Border Element con una Troncal SIP al Cisco Unified Communications Manager

/image/gif/paws/99863/cube-config04.gif

La Figura 4 muestra la configuración del Cisco Unified Border Element para que coincida con la configuración anterior del Cisco Unified Communications Manager.

Figura 4. Configuración del Cisco Unified Border Element para una Troncal SIP

/image/gif/paws/99863/cube-config05.gif

MTP Corresidente con el Cisco Unified Border Element

Si la configuración del Cisco Unified Communications Manager requiere un MTP de software, ésta puede efectuarse desde el mismo router que utiliza el Cisco Unified Border Element.

Ésta es la configuración para un MTP en el Cisco Unified Border Element:

sccp local FastEthernet0/1

sccp ccm 15.5.34.1 identifier 1 version 4.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register MTP

!

dspfarm profile 1 mtp

codec g711ulaw

maximum sessions software 100

associate application SCCP

Transcodificación en el Cisco Unified Border Element

El Cisco Unified Border Element puede efectuar transcodificaciones entre G.711µ-law/a-law y varios tipos de G.729. Se puede invocar la transcodificación para cualquier llamada, independientemente de que se origine en el Cisco Unified Communications Manager y se dirija a la PSTN o que se origine en la PSTN y se dirija al Cisco Unified Communications Manager. El criterio principal es determinar si ambos segmentos del Cisco Unified Border Element tienen códecs diferentes, G.711 y G.729. La configuración de transcodificación del Cisco Unified Border Element requiere que los DSPs se encuentren disponibles en la plataforma.

Ésta es la configuración para transcodificación en el Cisco Unified Border Element:

voice-card 2

dspfarm

dsp services dspfarm

sccp local FastEthernet 0/0

sccp ccm 200.1.1.100 identifier 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register MTP123456782012

keepalive retries 5

switchover method immediate

switchback method immediate

switchback interval 15

!

dspfarm profile 1 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec gsmfr

codec g729r8

maximum sessions 5

associate application SCCP

telephony-service

load 7960-7940 P00303020214

max-ephones 48

max-dn 48

ip source-address 200.1.1.100 port 2000

sdspfarm units 1

sdspfarm transcode sessions 50

sdspfarm tag 1 MTP123456782012

create cnf-files version-stamp 7960 Jul 29 2002 13:50:03

Uso de Tcl IVR en el Cisco Unified Border Element

El Cisco Unified Border Element es soporta scripts Tcl, y se pueden configurar bajo los dial-peers de VoIP. No se necesita un DSP para utilizar la funcionalidad Tcl. El Cisco IOS Software ya cuenta con una algunas aplicaciones Tcl incorporadas que pueden emplearse para implementaciones del Cisco Unified Border Element. También puede utilizarse la funcionalidad de autenticación, autorización y contabilidad (AAA) de Cisco IOS junto con el scripting Tcl y el Cisco Unified Border Element para autenticar y autorizar llamadas.

aaa new-model

!

aaa authentication login h323 group radius

aaa authorization exec h323 local group radius

aaa accounting exec h323 start-stop group radius

!

application

service debitcard tftp://15.5.27.11/app_debitcard.2.0.2.8.tcl

paramspace english index 1

paramspace english language en

paramspace english location tftp://15.5.27.11/prompts/en/

param pid-len 4

paramspace english prefix en

param uid-len 6

!

gw-accounting aaa

!

radius-server host 15.5.27.11 auth-port 1645 acct-port 1646

radius-server timeout 10

radius-server key lab

radius-server vsa send accounting

radius-server vsa send authentication

Configuración Completa del Ejemplo

router#show run
Building configuration...
Current configuration : 1122 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IPIPGW-1
!
boot-start-marker
boot-end-marker
!
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
ip cef
!
! aaa nuevo modelo
!
aaa authentication login h323 group radius
aaa authorization exec h323 local group radius
aaa accounting exec h323 start-stop group radius
!
application
service debitcard tftp://15.5.27.11/app_debitcard.2.0.2.8.tcl
paramspace english index 1
paramspace english language en
paramspace english location tftp://15.5.27.11/prompts/en/
param pid-len 4
paramspace english prefix en
param uid-len 6
!
gw-accounting aaa
!
radius-server host 15.5.27.11 auth-port 1645 acct-port 1646
radius-server timeout 10
radius-server key lab
radius-server vsa send accounting
radius-server vsa send authentication
!
no ip domain lookup
no ftp-server write-enable
!
voice service voip
allow-connections h323 to sip

!--- comando clave

allow-connections sip to h323

!--- comando clave

allow-connections sip to sip

!--- comando clave

allow-connections h323 to h323

!--- comando clave

!
interface FastEthernet0/0
ip address 200.1.1.100 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 200.1.1.1
ip http server
!
control-plane
!
dial-peer voice 1 voip
application debitcard

!--- Aplicación TCL

session target ipv4:9.13.8.150
incoming called-number 8...
dtmf-relay h245-alphanumeric

!--- Config. de DTMF para h.245 alfanumérico

codec g711ulaw
!
dial-peer voice 2 voip
destination-pattern 8...
session protocol sipv2
session target ipv4:9.13.8.16
dtmf-relay rtp-nte

!--- Config. de DTMF para RFC2833

codec g711ulaw
!
gatekeeper
shutdown
sip-ua
registrar ipv4:200.1.1.10 or registrar dns:csps.cisco.com
authentication username xyz password xyz realm cisco.com
!
line con 0
line aux 0
line vty 0 4
login
!
end

Verifique

Actualmente, no hay ningún procedimiento de verificación disponible para esta configuración.

Troubleshooting

En esta sección, encontrará información que puede utilizar para resolver problemas de configuración.

Comandos para Troubleshooting

La herramienta Output Interpreter (sólo para clientes registrados) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis de los resultados de los comandos show.

Nota: Consulte Información Importante sobre Comandos Debug antes de utilizar los comandos debug.

  • logging: Es importante asegurarse de que el Cisco Unified Border Element esté preparado para el registro tal como se indica en este ejemplo y además para realizar la debugging durante las horas que no sean pico tanto como sea posible ya que los comandos debug son extensos.

    logging console informational
    logging buffer 200000 debug
    service sequence-number
    service timestamp debug date msec
  • show: Es una salida relevante:

    show version
    show run
    show voip rtp connection (once the call is up)
    show call active voice brief (once the call is up)
  • debug: Asegúrese de borrar el log antes de que se efectúe una llamada para debugging y de obtener la salida del comando show logging después de ejecutada la llamada.

    Situaciones H.323 a H.323

    debug h225 asn1
    debug h225 q931
    debug h225 events
    debug h245 asn1
    debug h245 events
    debug h225 q931
    debug cch323 all
    debug voip ipipgw
    debug voip ccapi inout

    Situaciones H.323 a SIP

    debug h225 asn1
    debug h225 q931
    debug h225 events
    debug h245 asn1
    debug h245 events
    debug cch323 all
    debug voip ipipgw
    debug voip ccapi inout
    debug ccsip all

    Situaciones SIP a SIP

    debug ccsip all
    debug voip ccapi inout
  • debug: Además de los comandos de debugging basados en las situaciones descritas anteriormente, se deberán habilitar estos comandos de debugging del transcodificador:

    debug dspfarm all
    debug sccp messages
  • debug voip rtp session named-events: Si se utiliza RFC2833 (dtmf-relay rtp-nte), también se deberá activar este comando debug.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 99863