IP : Servicios de direccionamiento IP

Balanceo de Carga NAT de IOS para Dos Conexiones ISP

25 Agosto 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (15 Noviembre 2007) | Comentarios

Contenido

Introducción
Prerrequisitos
      Requisitos
      Componentes Utilizados
      Convenciones
Configuración
      Diagrama de Red
      Configuraciones
Verificación
Troubleshooting
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

Este documento describe una configuración para un router de Cisco IOS® para conectar una red a Internet con Traducción de Direcciones de Red mediante dos conexiones ISP. La Traducción de Direcciones de Red (NAT) de Cisco IOS Software puede distribuir conexiones TCP y sesiones UDP subsecuentes a través de múltiples conexiones de red si hay disponibles rutas de igual costo para un destino determinado. Si no se puede utilizar una de las conexiones, se puede utilizar object-tracking, un componente de Optimized Edge Routing (OER), para desactivar la ruta hasta que la conexión esté disponible nuevamente. Esto garantiza la disponibilidad de la red a pesar de la inestabilidad o poca confiabilidad de una conexión a Internet.

ios-nat-2isp-1.gif

Prerrequisitos

Requisitos

En este documento se asume que usted posee conexiones LAN y WAN que están funcionando y no se brindan antecedentes sobre configuración o troubleshooting para establecer la conectividad inicial.

  1. Este documento, no se describe una manera de diferenciar rutas, por lo tanto, no es posible elegir una conexión más deseable antes que una conexión menos deseable.

  2. En este documento, se describe la configuración de OER para habilitar o desactivar cualquier ruta de Internet basada en la accesibilidad de los servidores DNS del ISP. Es necesario identificar hosts específicos que se puedan alcanzar mediante una sola de las conexiones ISP y que no puedan estar disponibles si esa conexión ISP no está disponible.

Componentes Utilizados

Esta configuración se desarrolló con un router Cisco 1811 con software 12.4(15)T Advanced IP Services. Si se utiliza una versión de software diferente, es posible que algunas funciones no estén disponibles o que los comandos de configuración difieran de los que se muestran en este documento. Hay configuraciones similares disponibles en todas las plataformas de router de Cisco IOS, aunque la configuración de la interfaz probablemente varíe en las diferentes plataformas.

La información de este documento se creó a partir de los dispositivos en un entorno específico de laboratorio. Todos los dispositivos que se utilizan en este documento se iniciaron con una configuración vacía (predeterminada). Si su red está en funcionamiento, asegúrese de comprender el posible efecto de los comandos.

Convenciones

Consulte Cisco Technical Tips Conventions para obtener más información sobre las convenciones del documento.

Configuración

Es posible que necesite agregar policy-based routing para tráfico específico de modo de asegurarse de que siempre se utilice una conexión ISP. Los ejemplos de tráfico que requieren este comportamiento incluyen clientes IPSec VPN, auriculares VoIP y cualquier otro tráfico que utilice sólo una de las opciones de conexión ISP para preferir la misma dirección IP, una velocidad más alta o una menor latencia en la conexión.

Nota: Utilice la herramienta Command Lookup (sólo para clientes registrados) para obtener más información sobre los comandos utilizados en este documento.

Diagrama de Red

En este documento, se utiliza la siguiente configuración de red:

ios-nat-2isp-2.gif

Configuraciones

Como se muestra en el diagrama de red, en este ejemplo de configuración se describe un router de acceso que utiliza una conexión IP configurada para DHCP a un ISP (como se muestra en FastEthernet 0) y una conexión PPPoE a través de la otra conexión ISP. Los tipos de conexión no tienen un impacto específico sobre la configuración, a menos que se deba utilizar object-tracking y OER o policy-based routing con una conexión a Internet asignada por DHCP. En esos casos, puede resultar muy difícil definir un next-hop router para policy-routing u OER.

Ejemplo de Configuración de Router

track timer interface 5
!
! Configure los temporizadores para el rastreo de ruta.
!
track 123 rtr 1 reachability
 delay down 15 up 10
!
track 345 rtr 2 reachability
 delay down 15 up 10
!
! Utilice “ip dhcp client route track [número]” 
   ! para supervisar la ruta en las interfaces DHCP.
! Defina las interfaces orientadas hacia el ISP con “ip nat outside”.
!
interface FastEthernet0
 ip address dhcp
 ip dhcp client route track 345
 ip nat outside
 ip virtual-reassembly
!
interface FastEthernet1
 no ip address
 pppoe enable
 no cdp enable
!
interface FastEthernet2
 no cdp enable
!
interface FastEthernet3
 no cdp enable
!
interface FastEthernet4
 no cdp enable
!
interface FastEthernet5
 no cdp enable
!
interface FastEthernet6
 no cdp enable
!
interface FastEthernet7
 no cdp enable
!
interface FastEthernet8
 no cdp enable
!
interface FastEthernet9
 no cdp enable
!
! Defina las interfaces orientadas hacia la LAN con “ip nat inside”.
!
interface Vlan1
 description LAN Interface
 ip address 192.168.108.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
! Defina las interfaces orientadas hacia el ISP con “ip nat outside”.
!
Interface Dialer 0
 description PPPoX dialer
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 ip tcp adjust-mss
!
ip route 0.0.0.0 0.0.0.0 dialer 0 track 123
!
! Configure NAT overload (PAT) para utilizar route-maps.
!
ip nat inside source route-map fixed-nat
   interface Dialer0 overload
ip nat inside source route-map dhcp-nat 
   interface FastEthernet0 overload
!
! Configure una entrada de seguimiento OER 
   ! para supervisar la primera conexión ISP.
!
ip sla 1
 icmp-echo 172.16.108.1 source-interface Dialer0
 timeout 1000
 threshold 40
 frequency 3
!
! Configure una segunda entrada de seguimiento OER 
   ! para supervisar la segunda conexión ISP.
!
ip sla 2
 icmp-echo 172.16.106.1 source-interface FastEthernet0
 timeout 1000
 threshold 40
 frequency 3
!
! Establezca la programación y la duración del SLA.
!
ip sla schedule 1 life forever start-time now
ip sla schedule 2 life forever start-time now
!
! Defina las ACL para el tráfico del cual 
   ! se traducirán las direcciones de red a las conexiones ISP.
!
access-list 110 permit ip 192.168.108.0 0.0.0.255 any
!
! Los route-maps asocian las ACL para NAT con un NAT 
   ! externa en las interfaces orientadas hacia el ISP.
!
route-map fixed-nat permit 10
 match ip address 110
 match interface Dialer0
!
route-map dhcp-nat permit 10
 match ip address 110
 match interface FastEthernet0 

Con rastreo de ruta asignada por DHCP:

Ejemplo de Configuración de Rastreo de Ruta Asignada por DHCP (Opcional)

interface FastEthernet0
 description Internet Intf
 ip dhcp client route track 123
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 speed 100
 full-duplex
 no cdp enable

Verificación

Utilice esta sección para confirmar que la configuración funciona correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis de los resultados de los comandos show.

  • show ip nat translation: Muestra la actividad NAT entre los hosts NAT internos y los hosts NAT externos. Este comando proporciona una verificación de que los hosts internos se traduzcan a ambas direcciones NAT externas.

    Router# sh ip nat tra
    Pro Inside global      Inside local       Outside local      Outside global
    tcp 172.16.108.44:54486 192.168.108.3:54486 172.16.104.10:22 172.16.104.10:22
    tcp 172.16.106.42:49620 192.168.108.3:49620 172.16.102.11:80 172.16.102.11:80
    tcp 172.16.108.44:1623 192.168.108.4:1623 172.16.102.11:445  172.16.102.11:445
    Router#
    
  • show ip route: Verifica que estén disponibles las rutas múltiples a Internet.

    Router# sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, 
           L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, 
           U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is 172.16.108.1 to network 0.0.0.0
    
    C    192.168.108.0/24 is directly connected, Vlan1
         172.16.0.0/24 is subnetted, 2 subnets
    C       172.16.108.0 is directly connected, 
            FastEthernet4
    C       172.16.106.0 is directly connected, Vlan106
    S*   0.0.0.0/0 [1/0] via 172.16.108.1
                   [1/0] via 172.16.106.1
    Router#
    

Troubleshooting

Si después de configurar el router de Cisco IOS con NAT, las conexiones no funcionan, asegúrese de lo siguiente:

  • NAT se aplica de manera apropiada en interfaces inside y outside.

  • La configuración de NAT está completa y las ACL muestran el tráfico que se debe traducir.

  • Hay disponibles rutas múltiples a Internet/WAN.

  • Si utiliza route-tracking para asegurarse de que las conexiones a Internet están disponibles, compruebe el estado del rastreo de ruta.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 99427