Módulos e interfaces de Cisco : Módulos de servicios de Cisco

Ejemplo de Configuración Básica de FWSM (Módulo de Servicios Firewall)

25 Agosto 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (5 Septiembre 2007) | Comentarios

Contenido

Introducción
Prerrequisitos
      Requisitos
      Componentes Utilizados
      Productos Relacionados
      Convenciones
Antecedentes
Configuración
      Diagrama de la Red
      Configuraciones
Verificación
Troubleshooting
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

Este documento describe cómo realizar la configuración básica del Firewall Services Module (FWSM - Módulo de Servicios Firewall) instalado en Cisco 6500 Series Switches o Cisco 7600 Series Routers. Esto incluye la configuración de la dirección IP, del ruteo predeterminado, del proceso de Traducción de Direcciones de Red (NAT) estática y dinámica, de las sentencias de las Listas de Control de Acceso (ACL) para permitir el tráfico deseado o bloquear el tráfico no deseado, de los servidores de aplicaciones como Websense para la inspección del tráfico de Internet desde la red interna y del Webserver para los usuarios de Internet.

Nota: En un escenario de alta disponibilidad (HA) del FWSM, el proceso de failover sólo puede sincronizarse correctamente cuando las claves de licencia son exactamente iguales entre los módulos. Por lo tanto, el failover no puede funcionar entre los FWSMs que tienen distintas licencias.

Prerrequisitos

Requisitos

No existen requisitos específicos para este documento.

Componentes Utilizados

La información de este documento se basa en las siguientes versiones de software y hardware:

1 El FWSM no soporta supervisora 1 ó 1A.

2 Cuando utiliza el OS Catalyst en la supervisora, puede utilizar cualquiera de estas versiones compatibles de Cisco IOS Software en la MSFC. Cuando utiliza el Cisco IOS software en el supervisor, debe utilizar la misma versión en la MSFC.

La información de este documento se creó a partir de los dispositivos en un entorno específico de laboratorio. Todos los dispositivos que se utilizan en este documento se iniciaron con una configuración vacía (predeterminada). Si su red está en funcionamiento, asegúrese de comprender el posible efecto de los comandos.

Productos Relacionados

Esta configuración también puede utilizarse para Cisco 7600 Series Routers, con los componentes necesarios como se muestra a continuación:

  • Supervisor engine con Cisco IOS software. Consulte la Tabla para conocer las versiones compatibles de Cisco IOS software y de supervisor engine.

  • MSFC 2 con Cisco IOS software. Consulte la Tabla para conocer las versiones compatibles de Cisco IOS Software.

Convenciones

Consulte las Cisco Technical Tips Conventions para obtener más información sobre las convenciones del documento.

Antecedentes

El FWSM es un módulo de alto rendimiento que ahorra espacio y proporciona servicios de stateful-firewall (firewall de estado completo). Se instala en los Catalyst 6500 Series Switches y Cisco 7600 Series Routers.

Los firewalls protegen las redes internas del acceso no autorizado por parte de usuarios de una red externa. El firewall también puede proteger las redes internas mutuamente, por ejemplo, si tiene una red de recursos humanos separada de una red de usuario. Si tiene recursos de red que deben estar disponibles para un usuario externo, tal como un servidor web o FTP, puede colocar estos recursos en otra red detrás del firewall, denominada zona desmilitarizada (DMZ). El firewall permite acceso limitado a la DMZ, pero dado que la DMZ incluye sólo los servidores públicos, un ataque allí afectaría solamente a los servidores y no a las demás redes internas. También se puede controlar cuándo los usuarios internos acceden a redes externas, por ejemplo, a Internet, si sólo permite salir a ciertas direcciones, solicita autenticación o autorización, o coordina con un servidor de filtrado de direcciones URL externo.

El FWSM incluye varias funciones avanzadas, tales como contextos de seguridad múltiples que son similares a firewalls virtualizados, operación de firewall transparente (capa 2) o ruteado (capa 3), cientos de interfaces y muchas funciones más.

En la discusión de las redes conectadas a un firewall, la red externa está delante del firewall, la red interna está protegida y detrás del firewall, y una DMZ, si bien está detrás del firewall, permite acceso limitado a usuarios externos. Debido a que el FWSM permite configurar varias interfaces con diversas políticas de seguridad, incluidas varias interfaces internas, varias DMZ e incluso varias interfaces externas si se desea, estos términos se utilizan sólo con un sentido general.

Configuración

En esta sección, encontrará la información para configurar las funciones descritas en este documento.

Nota: Utilice la herramienta Command Lookup (sólo para clientes registrados) para obtener más información sobre los comandos utilizados en esta sección.

Diagrama de Red

En este documento, se utiliza la siguiente configuración de red:

fwsm-basic-config.gif

Nota: Los esquemas de direccionamiento IP usados en esta configuración no son legalmente ruteables en Internet. Son direcciones RFC 1918 que se han utilizado en un entorno de laboratorio.

Configuraciones

En este documento, se utilizan las siguientes configuraciones:

Configuración de Catalyst 6500 Series Switch

  1. Puede instalar el FWSM en Catalyst 6500 Series Switches o en Cisco 7600 Series Routers. La configuración de ambas series es idéntica y, en este documento, se hace referencia genéricamente a las series como el switch.

    Nota: Debe configurar correctamente el switch antes de configurar el FWSM.

  2. Asignación VLANs al FWSM: En esta sección, se describe cómo asignar VLANs al FWSM. El FWSM no incluye interfaces físicas externas. En su lugar, utiliza las interfaces de las VLANs. El proceso para asignar VLANs al FWSM es similar al que se realiza para asignar una VLAN a un puerto de switch; el FWSM incluye una interfaz interna al Módulo de Fábrica del Switch, si existe, o al bus compartido.

    Nota: Consulte la sección Configuración de VLAN de la Guía de Configuración de Software de Catalyst 6500 Switches para obtener más información sobre cómo crear una VLAN y asignarla a los puertos de switch.

    1. Directrices de VLAN:

      1. Puede utilizar VLANs privadas con el FWSM. Asigne la VLAN primaria al FWSM; el FWSM procesa automáticamente el tráfico de la VLAN secundaria.

      2. No puede utilizar VLANs reservadas.

      3. No puede utilizar VLAN 1.

      4. Si utiliza failover del FWSM dentro del mismo chasis del switch, no asigne ningún puerto del switch a la o las VLANs que reservó para failover y/o failover link (stateful failover). Sin embargo, si utiliza failover entre chasis, debe incluir las VLANs en el puerto trunk entre ellos.

      5. Si no agrega las VLANs al switch antes de asignarlas al FWSM, éstas se almacenan en la base de datos del supervisor engine y se envían al FWSM cuando se agregan al switch.

      6. Asigne las VLANs al FWSM antes de asignarlas a la MSFC.

        Las VLANs que no cumplen con esta condición se descartan del rango de VLANs que intenta asignar al FWSM.

    2. Asignación de VLANs al FWSM en Cisco IOS Software:

      En Cisco IOS software, cree hasta 16 grupos de VLANs de firewall y asigne los grupos al FWSM. Por ejemplo, puede asignar todas las VLANs a un grupo, puede crear un grupo interno y un grupo externo, o puede crear un grupo para cada cliente. Cada grupo puede contener una cantidad ilimitada de VLANs.

      No puede asignar la misma VLAN a varios grupos de firewall; sin embargo, puede asignar varios grupos de firewall a un FWSM y puede asignar un solo grupo de firewall a varios FWSM. Las VLANs que desea asignar a varios FWSM, por ejemplo, pueden residir en un grupo distinto de las VLANs que son exclusivas de cada FWSM.

      1. Complete los pasos para asignar las VLANs al FWSM.

        Router(config)#firewall vlan-group firewall_group vlan_range
        

        El vlan_range puede ser una o más VLANs, por ejemplo, 2 a 1000 y de 1025 a 4094, identificadas con un solo número (n) como 5, 10, 15 o un rango (n-x) como 5-10, 10-20.

        Nota: Los puertos ruteados y los puertos WAN utilizan las VLANs internas, de modo que es posible que las VLANs del rango 1020-1100 ya estén en uso.

        Ejemplo:

        firewall vlan-group 1 10,15,20,25
        
      2. Complete los pasos para asignar los grupos de firewall al FWSM.

        Router(config)#firewall module module_number vlan-group firewall_group
        

        El firewall_group es uno o más números de grupos con un solo número (n) como 5 o un rango como 5-10.

        Ejemplo:

        firewall module 1 vlan-group 1
        
    3. Asignación de VLAN al FWSM en el Software del Sistema Operativo Catalyst: En el software del OS Catalyst, debe asignar una lista de VLAN al FWSM. Puede asignar la misma VLAN a varios FWSM si lo desea. La lista puede contener una cantidad ilimitada de VLANs.

      Complete los pasos para asignar las VLANs al FWSM.

      Console> (enable)set vlan vlan_list firewall-vlan mod_num
      

      La vlan_list puede ser una o más VLANs, por ejemplo, 2 a 1000 y de 1025 a 4094, identificadas con un solo número (n) como 5, 10, 15 o un rango (n-x) como 5-10, 10-20.

  3. Incorporación de Interfaces Virtuales Conmutadas a la MSFC: Una VLAN definida en la MSFC se denomina interfaz virtual conmutada (SVI). Si asigna la VLAN utilizada para la SVI al FWSM, la MSFC se rutea entre el FWSM y otras VLANs de capa 3.

    Por razones de seguridad, de forma predeterminada, sólo puede existir una SVI entre la MSFC y el FWSM. Por ejemplo, si configura erróneamente el sistema con varias SVI, puede permitir accidentalmente que el tráfico rodee el FWSM si asigna las VLANs interna y externa a la MSFC.

    Complete los pasos para configurar la SVI.

    Router(config)#interface vlan vlan_number
    Router(config-if)#ip address address mask
    

    Ejemplo:

    interface vlan 20
    ip address 192.168.1.1 255.255.255.0
    

Configuración de Catalyst 6500 Series Switch


!--- Salida omitida

firewall vlan-group 1 10,15,20,25
firewall module 1 vlan-group 1

interface vlan 20
ip address 192.168.1.1 255.255.255.0

!--- Salida omitida

Nota: Inicie sesión en el FWSM desde el switch con el comando correspondiente al sistema operativo de su switch:

  • Cisco IOS Software:

    Router#session slot <number> processor 1
    
  • Software del OS Catalyst:

    Console> (enable) session module_number
    

Configuración de FWSM

  1. Configuración de Interfaces para FWSM: Para permitir que el tráfico pase por el FWSM, primero debe configurar un nombre de interfaz y una dirección IP. También debe cambiar el nivel de seguridad predeterminado, que es 0. Si a una interfaz le pone el nombre inside, y no establece el nivel de seguridad explícitamente, el FWSM establece el nivel de seguridad en 100.

    Nota: Cada interfaz debe tener un nivel de seguridad de 0 (más bajo) a 100 (más alto). Por ejemplo, debe asignar el nivel 100 a su red más segura, tal como la red inside, mientras que la red outside conectada a Internet puede tener el nivel 0. Las otras redes, tal como las DMZ, pueden tener un nivel intermedio.

    Puede agregar cualquier Id. de VLAN a la configuración, pero el tráfico sólo puede pasar por las VLANs que el switch asigna al FWSM, por ejemplo, 10, 15, 20 y 25. Utilice el comando show vlan para ver todas las VLANs asignadas al FWSM.

    interface vlan 20
        nameif outside
        security-level 0
        ip address 192.168.1.2 255.255.255.0
    interface vlan 10 
        nameif inside
        security-level 100
        ip address 10.1.1.1 255.255.255.0
    interface vlan 15
        nameif dmz1
        security-level 60
        ip address 192.168.2.1 255.255.255.224
    interface vlan 25
        nameif dmz2
        security-level 50
        ip address 192.168.3.1 255.255.255.224
    

    Consejo: En el comando nameif <name>, el name es una cadena de texto de hasta 48 caracteres y no distingue entre mayúsculas y minúsculas. Puede cambiar el nombre si vuelve a ingresar este comando con un valor nuevo. No ingrese la opción no, ya que ese comando hace que se eliminen todos los comandos que se refieren a ese nombre.

  2. Configuración de la Ruta Predeterminada:

    route outside 0.0.0.0 0.0.0.0 192.168.1.1 
    

    Una ruta predeterminada identifica la dirección IP de la gateway (192.168.1.1) a la que el FWSM envía todos los paquetes IP de los cuales no tiene una ruta estática o aprendida. Una ruta predeterminada es simplemente una ruta estática con 0.0.0.0/0 como dirección IP de destino. Las rutas que identifican un destino específico tienen prioridad sobre la ruta predeterminada.

  3. La NAT Dinámico traduce un grupo de direcciones reales (10.1.1.0/24) a un pool de direcciones mapeadas (192.168.1.20-192.168.1.50) que son ruteables en la red de destino. El pool mapeado puede incluir menos direcciones que el grupo real. Cuando un host que usted desea traducir accede a la red de destino, el FWSM le asigna una dirección IP del pool mapeado. La traducción se agrega sólo cuando el host real inicia la conexión. La traducción existe sólo mientras dura la conexión, y un usuario determinado no conserva la misma dirección IP después de que se agota el tiempo de espera de la traducción.

    nat (inside) 1 10.1.1.0 255.255.255.0
    global (outside) 1 192.168.1.20-192.168.1.50 netmask 255.255.255.0
    access-list Internet extended deny ip any 192.168.2.0 255.255.255.0
    access-list Internet extended permit ip any any
    access-group Internet in interface inside
    

    Debe crear una ACL para impedir que el tráfico de la red inside 10.1.1.0/24 pase a la red DMZ1 (192.168.2.0) y permitir los otros tipos de tráfico a Internet a través de la aplicación de la ACL Internet a la interfaz inside en dirección inbound para el tráfico entrante.

  4. El NAT Estático crea una traducción fija de una dirección real a una dirección mapeada ó de un rango de direcciones reales a un rango de direcciones mapeadas. Con el NAT dinámico y la Traducción de Direcciones de Puertos (PAT), cada host utiliza una dirección o un puerto diferente para cada traducción subsecuente. Debido a que la dirección mapeada es la misma para cada conexión consecutiva con el NAT estático, y existe una regla de traducción que persiste, el NAT estático permite que los hosts de la red de destino inicien el tráfico hacia un host traducido, si hay una lista de acceso que lo permita.

    La principal diferencia entre el NAT dinámico y un rango de direcciones para NAT estático es que el NAT estático permite a un host remoto iniciar una conexión con un host traducido, siempre que exista una lista de acceso que lo permita, mientras que el NAT dinámico no lo permite. También necesita un número equivalente de direcciones mapeadas como direcciones reales con NAT estático.

    static (dmz1,outside) 192.168.1.6 192.168.2.2 netmask 255.255.255.255
    static (dmz2,outside) 192.168.1.10 192.168.3.2 netmask 255.255.255.255
    access-list outside extended permit tcp any host 192.168.1.10 eq http
    access-list outside extended permit tcp host 192.168.1.30 host 192.168.1.6 eq pcanywhere-data
    access-list outside extended permit udp host 192.168.1.30 host 192.168.1.6 eq pcanywhere-status
    access-group outside in interface outside
    

    Éstas son las dos sentencias de NAT estático que se muestran. La primera se utiliza para traducir la IP real 192.168.2.2 de la interfaz interna a la IP mapeada 192.168.1.6 de la subred externa, siempre que la ACL permita el tráfico de la IP de origen 192.168.1.30 a la IP mapeada 192.168.1.6 para acceder al servidor Websense en la red DMZ1. Del mismo modo, la segunda sentencia de NAT estático se utiliza para traducir la IP real 192.168.3.2 de la interfaz interna a la IP mapeada 192.168.1.10 de la subred externa, siempre que la ACL permita el tráfico de Internet a la IP mapeada 192.168.1.10 para acceder al Webserver en la red DMZ2.

  5. El comando url-server designa el servidor que ejecuta la aplicación de filtrado de direcciones URL Websense. El límite es de 16 servidores URL en el modo de contexto único y de 4 servidores URL en el modo múltiple, pero sólo puede utilizar una aplicación a la vez, ya sea N2H2 o Websense. Además, si cambia la configuración en el dispositivo de seguridad, no se actualizará la configuración en el servidor de aplicaciones. Esto debe hacerse por separado, según las instrucciones del proveedor.

    El comando url-server debe configurarse antes de ejecutar el comando filter para HTTPS y FTP. Si se eliminan todos los servidores URL de la lista de servidores, también se eliminan todos los comandos de filtrado relacionados con el filtrado de URL.

    Una vez que designó el servidor, habilite el servicio de filtrado de URL con el comando filter url.

    url-server (dmz1) vendor websense host 192.168.2.2 timeout 30 protocol TCP version 1 connections 5
    
    

    El comando filter url permite impedir el acceso de usuarios de salida de las direcciones URL de World Wide Web que usted designe con la aplicación de filtrado Websense.

    filter url http 10.1.1.0 255.255.255.0 0 0
    

Configuración de FWSM


!--- Salida omitida

interface vlan 20
    nameif outside
    security-level 0
    ip address 192.168.1.2 255.255.255.0
interface vlan 10 
    nameif inside
    security-level 100
    ip address 10.1.1.1 255.255.255.0
interface vlan 15
    nameif dmz1
    security-level 60
    ip address 192.168.2.1 255.255.255.224
interface vlan 25
    nameif dmz2
    security-level 50
    ip address 192.168.3.1 255.255.255.224
passwd fl0wer
enable password treeh0u$e
route outside 0 0 192.168.1.1 1
url-server (dmz1) vendor websense host 192.168.2.2 timeout 30 protocol TCP version 1 connections 5
url-cache dst 128
filter url http 10.1.1.0 255.255.255.0 0 0

!--- Cuando los usuarios internos acceden a un servidor HTTP, el FWSM consulta con un
!--- servidor Websense para determinar si se permite el tráfico.

nat (inside) 1 10.1.1.0 255.255.255.0
global (outside) 1 192.168.1.20-192.168.1.50 netmask 255.255.255.0

!--- NAT dinámico para usuarios internos que acceden a Internet

static (dmz1,outside) 192.168.1.6 192.168.2.2 netmask 255.255.255.255

!--- Un host de la subred 192.168.1.0/24 requiere acceso al servidor Websense 
!--- para la administración que utiliza pcAnywhere, por lo tanto, el servidor Websense 
!--- utiliza una traducción estática para su dirección privada.


static (dmz2,outside) 192.168.1.10 192.168.3.2 netmask 255.255.255.255

!--- Un host de Internet requiere acceso a Webserver, por lo tanto, Webserver 
!--- utiliza una traducción estática para su dirección privada.


access-list Internet extended deny ip any 192.168.2.0 255.255.255.0
access-list Internet extended permit ip any any
access-group Internet in interface inside

!--- Permite que todos los hosts internos accedan al exterior para todo el tráfico IP,
!--- pero les deniega el acceso a dmz1



access-list outside extended permit tcp any host 192.168.1.10 eq http

!--- Permite el tráfico de Internet con dirección IP de destino
!--- 192.168.1.10 y puerto de destino 80


access-list outside extended permit tcp host 192.168.1.30 host 192.168.1.6 eq pcanywhere-data
access-list outside extended permit udp host 192.168.1.30 host 192.168.1.6 eq pcanywhere-status


!--- Permite que el host de administración 192.168.1.30 utilice 
!--- pcAnywhere en el servidor Websense

access-group outside in interface outside


access-list WEBSENSE extended permit tcp host 192.168.2.2 any eq http
access-group WEBSENSE in interface dmz1

!--- Es necesario que el servidor Websense acceda al servidor actualizador Websense 
!--- en el exterior.
!--- Salida omitida

Verificación

Utilice esta sección para confirmar que la configuración funcione correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis de los resultados de los comandos show.

  1. Vea la información del módulo de acuerdo con su sistema operativo para verificar que el switch reconoce el FWSM y lo ha puesto en línea:

    • Cisco IOS Software:

      Router#show module
      Mod Ports Card Type                              Model              Serial No.
      --- ----- -------------------------------------- ------------------ -----------
        1    2  Catalyst 6000 supervisor 2 (Active)    WS-X6K-SUP2-2GE    SAD0444099Y
        2   48  48 port 10/100 mb RJ-45 ethernet       WS-X6248-RJ-45     SAD03475619
        3    2  Intrusion Detection System             WS-X6381-IDS       SAD04250KV5
        4    6  Firewall Module                        WS-SVC-FWM-1       SAD062302U4
      
    • Software del OS Catalyst:

      Console>show module [mod-num]
      The following is sample output from the show module command: 
      
      Console> show module 
      Mod Slot Ports Module-Type               Model               Sub Status
      --- ---- ----- ------------------------- ------------------- --- ------
      1   1    2     1000BaseX Supervisor      WS-X6K-SUP1A-2GE    yes ok
      15  1    1     Multilayer Switch Feature WS-F6K-MSFC         no  ok
      4   4    2     Intrusion Detection Syste WS-X6381-IDS        no  ok
      5   5    6     Firewall Module           WS-SVC-FWM-1        no  ok
      6   6    8     1000BaseX Ethernet        WS-X6408-GBIC       no  ok
      

    Nota: El comando show module muestra seis puertos para el FWSM. Éstos son puertos internos que están agrupados como un EtherChannel.

  2. Router#show firewall vlan-group
    Group vlans
    ----- ------
       1 10,15,20
       51 70-85
       52 100
    
  3. Router#show firewall module
    Module Vlan-groups
      5    1,51
      8    1,52
    
  4. Ingrese el comando de su sistema operativo para ver la partición de inicio actual:

    • Cisco IOS Software:

      Router#show boot device [mod_num]
      

      Ejemplo:

      Router#show boot device
      [mod:1 ]:
      [mod:2 ]:
      [mod:3 ]:
      [mod:4 ]: cf:4
      [mod:5 ]: cf:4
      [mod:6 ]:
      [mod:7 ]: cf:4
      [mod:8 ]:
      [mod:9 ]:
      
    • Software del OS Catalyst:

      Console> (enable) show boot device mod_num
      

      Ejemplo:

      Console> (enable) show boot device 6
      Device BOOT variable = cf:5
      

Troubleshooting

En esta sección, encontrará información que puede utilizar para resolver problemas de configuración.

  1. Configuración de la Partición de Inicio Predeterminada: De forma predeterminada, el FWSM se inicia desde la partición de aplicación cf:4. No obstante, puede optar por iniciarlo desde la partición de aplicación cf:5 o en la partición de mantenimiento cf:1. Para cambiar la partición de inicio predeterminada, ingrese el comando de su sistema operativo:

    • Cisco IOS Software:

      Router(config)#boot device module mod_num cf:n
      

      Donde n es 1 (mantenimiento), 4 (aplicación) o 5 (aplicación).

    • Software del OS Catalyst:

      Console> (enable) set boot device cf:n mod_num
      

      Donde n es 1 (mantenimiento), 4 (aplicación) o 5 (aplicación).

  2. Reinicio del FWSM en Cisco IOS Software: Para reiniciar el FWSM, ingrese el comando como se muestra a continuación:

    Router#hw-module module mod_num reset [cf:n] [mem-test-full]
    

    El argumento cf:n es la partición, ya sea 1 (mantenimiento), 4 (aplicación) o 5 (aplicación). Si no especifica la partición, se utiliza la partición predeterminada, que generalmente es cf:4.

    La opción mem-test-full ejecuta una prueba de memoria completa, que dura aproximadamente seis minutos.

    Ejemplo:

    Router#hw-mod module 9 reset
    Proceed with reload of module? [confirm] y
    % reset issued for module 9
    Router#
    00:26:55:%SNMP-5-MODULETRAP:Module 9 [Down] Trap
    00:26:55:SP:The PC in slot 8 is shutting down. Please wait ...
    

    Para software del OS Catalyst:

    Console> (enable) reset mod_num [cf:n]
    

    Donde cf:n es la partición, ya sea 1 (mantenimiento), 4 (aplicación) o 5 (aplicación). Si no especifica la partición, se utiliza la partición predeterminada, que generalmente es cf:4.

Nota: En FWSM, no se puede configurar el Network Time Protocol (NTP), ya que toma su configuración del Switch.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 98591