Switches : Switches Cisco Catalyst de la serie 3750

PIM Stub Routing en Catalyst 3750, y 3560 Series Switches

25 Agosto 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (4 Agosto 2011) | Comentarios

Contenido

Introducción
Prerrequisitos
      Requisitos
      Componentes Utilizados
      Productos Relacionados
      Convenciones
Configuración
      Diagrama de Red
      Configuraciones
      Configuración del Switch (mix_stack)
Verificación
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

Todos los routers de un entorno LAN siempre ven el tráfico del plano de control de multicast. El multicast IP Stub se utiliza para reducir y minimizar el tráfico de multicast innecesario que se ve en la capa de acceso de una LAN y con el fin de guardar el ancho de banda de los medios para reenviar el tráfico de multicast a la capa de flujo ascendente de distribución o de núcleo.

En los Catalyst 3750 Series Switches y Catalyst 3560 Series Switches, la función PIM Stub Multicast permite utilizar el ruteo de multicast entre la capa de distribución y la capa de acceso. Se permite utilizar dos tipos de interfaces PIM: Interfaces PIM de uplink e interfaces PIM pasivas. En particular, una interfaz ruteada configurada con el modo PIM pasivo no trasmite ni reenvía tráfico PIM del plano de control, sólo trasmite o reenvía tráfico IGMP.

Prerrequisitos

Requisitos

Asegúrese de cumplir los siguientes requisitos antes de utilizar esta configuración:

  • El router PIM stub no rutea el tráfico de tránsito entre los routers de distribución. El ruteo stub de unicast (EIGRP) refuerza este hecho. Para ayudar a este comportamiento del router PIM stub, se requiere configurar apropiadamente el ruteo stub de unicast. La función PIM stub no impide que el administrador del router que configura al RIP, las rutas estáticos o el PIM RP omitan esta restricción.

  • En los dominios de acceso de la capa 2, sólo se permiten receptores y fuentes de multicast (IGMP) conectados directamente. No se permite utilizar el protocolo PIM en los dominios de acceso.

  • No se permite utilizar la topología redundante de routers PIM stub.

Componentes Utilizados

La información de este documento se basa en los resultados obtenidos en un Catalyst 3750 Switch.

La información de este documento se creó a partir de los dispositivos en un entorno específico de laboratorio. Todos los dispositivos que se utilizan en este documento se iniciaron con una configuración vacía (predeterminada). Si su red está en funcionamiento, asegúrese de comprender el posible efecto de los comandos.

Productos Relacionados

Esta configuración también se puede utilizar con los siguientes tipos de switches:

  • Catalyst 3750 Series Switches y Catalyst 3560 Series Switches

Los switches Cisco Catalyst 3750 y 3560 permiten utilizar el PIM Stub Multicast Routing con versión de código 12.2(37)SE y posteriores.

Convenciones

Consulte las Cisco Technical Tips Conventions para obtener más información sobre las convenciones del documento.

Configuración

En esta sección, encontrará la información para configurar las funciones descritas en este documento.

El SSM de PIM se utiliza en los uplinks para establecer comunicación con el router de flujo ascendente. Los usuarios pueden utilizar cualquiera de los modos PIM (por ejemplo, denso o disperso).

Para obtener más información sobre la configuración del ruteo de multicast en 3750 Series Switches, consulte Configuración del Ruteo IP de Multicast

Nota: Utilice la herramienta Command Lookup (sólo para clientes registrados) para obtener más información sobre los comandos utilizados en esta sección.

Diagrama de Red

En este documento, se utiliza la siguiente configuración de red:

pim_stub-1.gif

Configuraciones

En este documento, se utilizan las siguientes configuraciones:

Siga los siguientes pasos para configurar el PIM Stub Routing:

  1. Emita el siguiente comando para activar el ruteo de multicast de manera global en el switch o en la pila del switch:

    mix_stack(config)#ip multicast-routing distributed
    
  2. Emita el siguiente comando para definir el intervalo de SSM de la IP address de multicast con el intervalo predeterminado del grupo:

    mix_stack(config)#ip pim ssm default
    
  3. Emita el siguiente comando para activar el SSM de PIM en el uplink:

    mix_stack(config)#interface GigabitEthernet3/0/25
    mix_stack(config-if)ip pim sparse-dense-mode
    
  4. Emita el siguiente comando para activar el PIM Stub Routing en la interfaz de VLAN:

    mix_stack(config)#interface vlan100
    mix_stack(config-if)ip pim passive
    

Configuración del Switch (mix_stack)

mix_stack#sho run
Building configuration...
 
Current configuration : 7810 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname mix_stack
!
!
switch 2 provision ws-c3750e-24pd
switch 3 provision ws-c3750g-24ts
switch 5 provision ws-c3750-24fs
switch 9 provision ws-c3750e-24pd
!
ip routing
!
!
ip multicast-routing distributed
!
!--- Salida omitida.
!
!
vlan 100
!
!
interface GigabitEthernet2/0/1
switchport access vlan 100
no keepalive
spanning-tree portfast
!
interface GigabitEthernet2/0/2
switchport access vlan 100
no keepalive
spanning-tree portfast
!
!
!--- Salida omitida.
!
!
interface GigabitEthernet3/0/25
no switchport
ip address 3.1.1.2 255.255.255.248
ip pim sparse-dense-mode
!
!
!--- Salida omitida.
!
!
interface GigabitEthernet9/0/24
no switchport
ip address 10.1.1.1 255.255.255.0
ip pim passive
no keepalive
!
!
!--- Salida omitida.
!
!
interface Vlan1
no ip address
!
interface Vlan100
ip address 100.1.1.1 255.255.255.0
ip pim passive
!
!
!--- Salida omitida.
!
! 
ip pim ssm default
!
!
!--- Salida omitida.
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
speed 115200
line vty 0 4
login
line vty 5 15
login
!
end

Verificación

Utilice esta sección para confirmar que la configuración funciona correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis de los resultados de los comandos show.

Emita el comando show ip pim interface para ver el PIM stub que está habilitado para cada interfaz.

mix_stack#show ip pim interface 

Address    Interface               Ver/    Nbr     Query   DR     DR
                                   Mode    Count   Intvl   Prior

3.1.1.2    GigabitEthernet3/0/25   v2/SD   1       30      1      3.1.1.2
100.1.1.1  Vlan100                 v2/P    0       30      1      100.1.1.1
10.1.1.1   GigabitEthernet9/0/24   v2/P    0       30      1      10.1.1.1

Emita show ip igmp detail para mostrar el cliente interesado que se conectó a la fuente o al grupo específico de multicast.

mix_stack#sho ip igmp group 232.0.0.9 det

Flags: L - Local, U - User, SG - Static Group, VG - Virtual Group,
SS - Static Source, VS - Virtual Source,
Ac - Group accounted towards access control limit

Interface: GigabitEthernet9/0/24
Group: 232.0.0.9
Flags: SSM 
Uptime: 00:00:10
Group mode: INCLUDE
Last reporter: 10.1.1.2
CSR Grp Exp: 00:02:57
Group source list: (C - Cisco Src Report, U - URD, R - Remote, S - Static,
V - Virtual, M - SSM Mapping, L - Local,
Ac - Channel accounted towards access control limit)
Source Address Uptime v3 Exp CSR Exp Fwd Flags
200.1.1.3 00:00:10 stopped 00:02:57 Yes CM

Interface: Vlan100
Group: 232.0.0.9
Flags: SSM 
Uptime: 01:42:08
Group mode: INCLUDE
Last reporter: 100.1.1.3
CSR Grp Exp: 00:02:00
Group source list: (C - Cisco Src Report, U - URD, R - Remote, S - Static,
V - Virtual, M - SSM Mapping, L - Local,
Ac - Channel accounted towards access control limit)
Source Address Uptime v3 Exp CSR Exp Fwd Flags
200.1.1.3 01:42:12 stopped 00:02:00 Yes CM
mix_stack#

Emita show ip igmp mroute para verificar que la secuencia de multicast reenvía desde el origen hacia los clientes interesados.

mix_stack#sho ip mroute 232.0.0.9
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report, 
Z - Multicast Tunnel, z - MDT-data group sender, 
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(200.1.1.3, 232.0.0.9), 01:44:23/00:02:52, flags: sTI
Incoming interface: GigabitEthernet3/0/25, RPF nbr 3.1.1.1
Outgoing interface list:
GigabitEthernet9/0/24, Forward/Sparse-Dense, 00:02:24/00:02:50
Vlan100, Forward/Sparse-Dense, 01:44:23/00:02:52

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 98289