MS Windows ネットワーキング

Windows ネットワーク設計実装ガイド

2005 年 8 月 30 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 30 日) | フィードバック

目次

概要
始める前に
      表記法
      前提条件
      使用するコンポーネント
Windows ネットワークとは
      ドメインとワークグループ
使用されるプロトコル
ダイナミック IP アドレッシング
      DHCP とは
      DHCP スコープ
      DHCP リレー
      DHCP オプション
      Cisco DHCP サーバ
名前解決
      NetBIOS 名キャッシュ
      IP サブネット ブロードキャスト
      LMHOSTS
      Windows Internet Name Service
      インターネット DNS
      名前検索の順序
Microsoft LAN サービス ブラウザ
      NetBIOS 名
      起動プロセス
      コンピュータの検索
      ネットワーク コンピュータの表示
      サブネット ブラウジング
      サブネットを越えたブロードキャスト ブラウジング
      WINS を使用した任意のドメインのブラウジング
      ブロードキャストの無効化
ネットワークの規模の拡張
      信頼されるドメイン
      単一ドメイン
      グローバル トラスト
      マスター ドメイン
      複数マスター ドメイン
      WINS の複製
モデムへのアクセス
ダイヤルオンデマンド ルーティング
ISDN へのアクセス
      Adtran
      Motorola BitSURFR
クライアント ソフトウェア
      CiscoRemote Lite

      例 1
      Cisco 4700 ルータのコンフィギュレーション
      Cisco 2511 アクセス サーバのコンフィギュレーション
      例 2
      例 3
      例 4
付録 A:ブロードキャスト名前解決の無効化
      Windows for Workgroups 3.11 を使用している場合
      Windows 95/98
      Windows NT 3.51
      Windows NT レジストリ エントリ
      不正なブラウズ マスターの特定
付録 B:WINS 名の DNS 解決の設定
      DNS ブート ファイル
      domain.com の DNS ファイル
関連するシスコ サポート コミュニティ ディスカッション

概要

用語「ネットワーキング」には広範にわたるテクノロジーが関係しており、それらを組み合せることによってコンピュータ同士が情報を共有できます。 ネットワーキングの構成要素は、エンドシステム アプリケーション、ネットワーク オペレーティング システム、およびネットワーク機器に区分できます。

ネットワーク オペレーティング システムは、相互接続されているすべてのシステムで動作するソフトウェアです。 たとえば、Novell NetWare、Sun の Network File System(NFS)、AppleShare、一般に Windows ネットワークと呼ばれる、Microsoft のネットワーク オペレーティング システムの実装などがそれに該当します。 現在では、Windows ネットワークが広範囲にわたって無数のノードに配備されています。

この設計ガイドは、Windows ネットワークの基本概念について説明し、このオペレーティング システムを最大限に活用するネットワーク設計方法(LAN および WAN)についての見識を示しています。 また、Windows ネットワークに関連するプロトコル、ネーミング、およびスケーリングの問題についても説明しています。

始める前に

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

前提条件

このドキュメントに適用される特定の前提条件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

Windows ネットワークとは

Windows ネットワークとは、次の Microsoft オペレーティング システムまたはサーバすべてに付属しているソフトウェアによって共有されるネットワーク システムを指します。

  • Microsoft LAN Manager

  • LAN Manager クライアントを含む MS-DOS

  • Windows for Workgroups

  • Windows 95、98、および ME

  • Windows NT および 2000

Microsoft LAN Manager、MS-DOS 用 LAN Manager クライアント、および Windows NT 3.1 は、過去の説明を除き、このドキュメントでは説明しません。

ドメインとワークグループ

Windows ネットワークには、関連するコンピュータのグループについて 3 つの概念があります。ワークグループ、ドメイン、およびドメイン階層です。 ワークグループはコンピュータの論理的な集合で、ネットワーク上にある任意のコンピュータを既存のワークグループに加入させたり、あるいはそれらのコンピュータによって新しいワークグループを作成したりできます。 ドメインはワークグループよりも本格的で、Windows NT または Windows 2000 で動作する Primary Domain Controller(PDC; プライマリ ドメイン コントローラ)プロセスによって作成および管理されます。 ドメインには、ワークグループにないセキュリティと管理に関するプロパティがあります。 各ドメインには少なくとも 1 台の NT または 2000 サーバが必要で、このサーバが PDC プロセス、ドメイン内のユーザ アカウント情報の管理、およびドメイン内のセキュリティを担当します。 Windows ネットワークのドメインは、Domain Name System(DNS; ドメイン ネーム システム)で使用されるインターネット ドメイン名とは異なります。 ドメイン階層または Active Directory 階層は、親子関係に編成されたドメインの集合です。 Windows 2000 で導入されたこの規定により、(数ある中の)1 つの問い合せで複数のドメイン内を容易に検索できます。 この階層は DNS 名前空間とよく似ています。

使用されるプロトコル

Windows 2000 が登場する以前は、Windows ネットワークは NetBIOS プロトコルを使用して、ファイル共有、プリンタ共有、メッセージング、認証、および名前解決を実現していました。 純粋な Windows 2000 インストレーションでは、フラットな NetBIOS 名前空間を使用する旧バージョンの Windows ネットワークとの相互運用性のためだけに NetBIOS を必要とします。 NetBIOS はセッション層プロトコルで、次のトランスポート プロトコルの上位で動作できます。

  • NetBEUI(NetBIOS over LLC2)

  • NWLink(NetBIOS over Internetwork Packet Exchange [IPX])

  • NetBIOS over TCP(NBT)

Microsoft では、最大限のパフォーマンスを得るために、クライアントがトランスポート プロトコルを一度に 1 つだけ使用することを推奨していますが、このセットアップがデフォルトになっているのは Windows 2000 だけです。したがって、ネットワーク全体で使用するプロトコル(TCP/IP が望ましい)を選択したら、それ以外のプロトコルをオフにする必要があります。これは、NetBIOS 名サービスではコンピュータ名に関する情報(名前空間)がトランスポートごとに別々に保持されるためです。 名前空間同士は情報を交換しません。各トランスポートは異なるネットワークとして動作します。

NetBEUI(NetBIOS over LLC2)はブリッジする必要があるため、3 つのプロトコルの中で最もスケーラビリティに劣っています。 NetBEUI は非常に古いサービス(LAN Manager の古いバージョンなど)をサポートするためだけに組み込まれています。 NetBEUI ではクライアントにアドレスを設定する必要はありません。 NetBEUI で扱うことのできる Windows クライアントの数に定められた制限はありませんが、このソリューションでは一般に、1 つのブリッジ グループのクライアント数が 50〜100 ユーザになるとパフォーマンスの問題が生じます。 トポロジがフラットであり、ブロードキャストに依存しているため、特にトラフィックが WAN リンクを経由する必要がある場合には拡張できません。

NWLink は、すでに IPX が動作していて、TCP/IP を使用するようにアップグレードできないネットワークの場合にのみ推奨されます。 NetBEUI と同様に、NWLink でもクライアントにアドレスを設定する必要はありません。 NWLink は IPX タイプ 20 パケットを使用して、登録情報とブラウジング情報を交換します。 Cisco ルータを経由してタイプ 20 IPX パケットを転送するには、ネットワーク上にあるすべてのルータの各インターフェイスで ipx type-20 propagation を設定する必要があります。

ほとんどのネットワークでは、NetBIOS over TCP(NBT)を利用することが推奨されます。特に WAN が含まれているネットワークでは必ず NBT を使用してください。 NBT は TCP/IP を使用するため、各コンピュータはスタティック IP アドレスを使用するように設定するか、または Dynamic Host Configuration Protocol(DHCP; ダイナミック ホスト コンフィギュレーション プロトコル)によって動的に IP アドレスをフェッチするように設定する必要があります。 ネットワーク管理の負荷を軽減するため、できるだけ DHCP を使用することをお勧めします。また、最適なネットワーク パフォーマンスを得るために、Windows Internet Name Service(WINS)サーバもあわせて使用することをお勧めします。 WINS サーバを使用すると、クライアントは毎回要求をブロードキャストしなくても、ブラウジング情報を取得できます。 ネットワーク内でのブロードキャストの数とネットワーク パフォーマンスとの間には直接的な相関関係があります。ブロードキャストはネットワークが機能するために必要ですが、これを最低限に抑えることが非常に重要です。

Cisco ではほとんどのお客様に対して、Windows ネットワーク用に TCP/IP を使用することをお勧めします。 この設計ガイドの大部分は NBT を使用した設計に焦点を合わせています。

ダイナミック IP アドレッシング

DHCP とは

TCP/IP クライアントのアドレスを手動で設定すると、時間がかかり、エラーが起こる可能性も高くなります。 この問題を解決するために、Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)によって Dynamic Host Configuration Protocol(DHCP)が策定されました。 DHCP は、クライアントに対して有効な IP アドレスと関連する設定情報を自動的に提供するよう設計されています(後述の「DHCP オプション」のセクションを参照)。 DHCP サーバが管理するアドレスのそれぞれの範囲のことをスコープと呼びます。

DHCP スコープ

DHCP アドレスを要求するクライアントが存在するすべての IP サブネットについて、アドレスの範囲を設定する必要があります。アドレスのそれぞれの範囲のことを DHCP スコープと呼びます。 DHCP サーバはクライアントと同じネットワークに物理的に接続している必要はないため、複数のスコープを供給するように DHCP サーバを設定できます。 DHCP サーバがクライアントと異なる IP サブネット上にある場合は、DHCP 要求を DHCP サーバに転送するために DHCP リレーを使用する必要があります。

DHCP リレー

DHCP リレーは一般にルータで動作し、Windows NT Server バージョン 4.0 および Windows 2000 Server でサポートされます。 Cisco 700 シリーズ ルータで DHCP リレーをオンにするには、set dhcp relay コマンドを使用します。 Cisco IOS ルータでは、DHCP クライアントの存在する各インターフェイスに ip helper-address と DHCP サーバのアドレスを設定することで、DHCP リレーをオンにできます。 ip helper-address コマンドでは、それ以外の各種 IP ブロードキャスト、たとえば DNS、Trivial File Transfer Protocol(TFTP; トリビアル ファイル転送プロトコル)、NetBIOS 名サービス パケットなども転送されます。 DHCP 要求のみを転送するには、次のコンフィギュレーション例を参照してください。 詳細については、『ネットワーク プロトコル コンフィギュレーション ガイド、パート I』の「ブロードキャスト処理の設定」のセクションを参照してください。

 no ip forward-protocol udp tftp
 
 no ip forward-protocol udp dns
 
 no ip forward-protocol udp time
 
 no ip forward-protocol udp netbios-ns
 
 no ip forward-protocol udp netbios-dgm
 
 no ip forward-protocol udp tacacs
 
 ip forward-protocol udp bootpc
 
 !
 
 interface ethernet 0
 
 ip helper-address 172.16.12.15
 
 interface ethernet 1
 
 ip helper-address 172.16.12.15
 

DHCP オプション

DHCP クライアントは、IP アドレスのほかに、サブネット マスク、デフォルト ゲートウェイ、DNS 情報などの TCP/IP 設定情報を DHCP サーバから取得できます。 これらの情報は DHCP オプションと呼ばれ、Windows NT または Windows 2000 DHCP サーバの DHCP Manager で設定できます。

winnt_d0.gif

図 1: Microsoft の DHCP Manager
※ 画像をクリックすると、大きく表示されます。

クライアントが名前解決(これについては後述します)のために Windows Internet Name Service(WINS)を使用している場合は、WINS サーバのアドレスと WINS ノード タイプを設定する必要があります。 「名前解決」のセクションにノード タイプの簡潔なリストがあります。 ノード タイプ p-node(0x2)を使用することを強くお勧めします。

Cisco DHCP サーバ

Cisco では現在、Windows NT、Windows 2000、および UNIX 用の統合された DHCP および DNS サーバを用意しています。このサーバはグラフィカル インターフェイスを備え、セカンダリ アドレッシングをサポートするほか、各種のエンタープライズ機能を装備しています。 Cisco 700 シリーズ ルータ(リリース 4.1 以降)および Cisco IOS ルータ(リリース 11.2(7)F 以降)にも、ローカル ネットワーク セグメントへのアドレスの割り当てが可能な DHCP サーバが組み込まれています。 どちらの方式のルータにも、ネットワークおよびポートレベルのアドレス変換機能があります。

名前解決

名前解決とは、ネットワーク アドレス(多くの場合、IP アドレス)にわかりやすい名前(FRED や fred.domain.com)を対応付けるプロセスを指します。 ここでの目的では、この説明は Windows ネットワークにおける NetBIOS の一意のワークステーション名(後述のセクションで WORKSTATION<00> と表現される)から IP アドレスへの解決方法に当てはまります。 このプロセスを、ブラウジング プロセス(別のタイプの NetBIOS 名を使用する)と混同しないでください。これらのプロセスは、関連はありますが異なるプロセスです。 Microsoft Windows 2000 がリリースされた時点で、Windows ネットワーク クライアントは最大で次の 5 通りの名前解決方法を使用します。

  • NetBIOS 名キャッシュ

  • IP サブネット ブロードキャスト

  • LMHOSTS

  • WINS

  • インターネット DNS

NetBIOS 名キャッシュ

Windows ネットワークでは、最近使用した NetBIOS 名と IP アドレスのマッピングを含む小さいキャッシュを保持しています。 これらのエントリは名前解決が正常に行われた後に追加され、一定時間が経過すると削除されます。 LMHOSTS ファイルに #PRE タグを付けたエントリを作成すれば、システム起動時に追加のエントリを前もってロードし、永続的に保持できます(後述の「LMHOSTS」セクションを参照)。

IP サブネット ブロードキャスト

IP サブネット ブロードキャストを名前解決に使用できます。 ブロードキャストはサブネット上のすべてのコンピュータで受信され、各コンピュータの処理時間が要求されます。 Windows ネットワークには代表ブラウズ マスターが存在し、サブネット上で使用可能なすべてのリソースのリストを管理しています。 このブラウズ マスターは、ブロードキャストを使用した選出プロセスによって決定されます。登録、ブラウザの選出、および名前問い合せはすべてブロードキャストを生成するため、ブロードキャストによる名前解決方法を使用することはお勧めできません。

LMHOSTS

Windows ネットワークでは、LMHOSTS ファイルに保存されたスタティック テーブルを照会できます。 この方法を使用するには、PDC が保持するスタティック リストに少なくとも自身のドメイン内にあるすべてのコンピュータとその IP アドレス、およびネットワーク内に存在する他のすべてのドメインの、PDC の名前とアドレスが含まれる必要があります。 さらにすべてのクライアントに、PDC の IP アドレスと、PDC 上にあるマスター LMHOSTS ファイルへのパスを記述した LMHOSTS ファイルを配置する必要があります。

Windows Internet Name Service

WINS が開発された目的は、異なる IP サブネット上のクライアントがブロードキャストを使用せずに、アドレスの解決、自身の登録、およびネットワークのブラウズを動的に実行することでした。 クライアントは well-known アドレスの付いた WINS サーバにユニキャスト パケットを送信します。 ただし、WINS を設定した場合でも、初期の Microsoft ネットワーク クライアントとの互換性のために、ブロードキャスト名前解決はデフォルトでオンになっています。

すでに述べたことの繰り返しですが、最適なネットワーク パフォーマンスを得るためにできるだけ WINS を使用することをお勧めします。 また、ネットワーク内でのブロードキャストの数とネットワーク パフォーマンスとの間には直接的な相関関係があります。ブロードキャストはネットワークが機能するために必要ですが、これを最低限に抑えることが非常に重要です。

インターネット DNS

固定の IP アドレスの付いたコンピュータの問い合せに応答するため、DNS サーバを静的に設定できます。 このシナリオは、ネットワーク内のコンピュータに固定の IP アドレスが付いている場合に役立ちます。 Windows システムが DHCP を使用して IP アドレスを取得し、WINS を使用して NetBIOS 名を登録している場合は、静的に入力されていない名前とアドレスを WINS サーバに照会するように Windows DNS サーバを設定できます。 どちらの場合でも、Windows と Windows 以外のシステムが IP アドレスを正しく解決できます。

管理者がそれぞれの Windows ネットワーク サーバにスタティック IP アドレスを設定している場合は、DNS システムに各サーバを登録し、名前解決に DNS を使用する方法が便利であることがあります。 場合によっては(たとえば、ダイヤルオンデマンド リンクを使用する場合など)、クライアントを WINS で登録し、DNS で照会する方法が便利です。 Microsoft NT 3.51 Resource Kit、Windows NT 4.0 Server、および Windows 2000 に組み込まれている DNS サーバはすべて、バックグラウンドで WINS サーバを照会することによって DNS 問い合せに応答できます。 このアーキテクチャの設定方法の詳細については、「付録 A」を参照してください。

Windows 2000 では、DNS サーバにアドレスと名前のマッピングも動的に設定できます。 DHCP クライアント、DHCP サーバ、および Dynamic DNS サーバが連携して動作し、DNS サーバ上の名前とアドレスのマッピングを更新します。 Windows 2000 以外の DHCP クライアントについては、DHCP サーバがこの更新を実行します。

winnt_d1.gif

図 2: Windows と Windows 以外のシステムの両方から、Warthog という名前の Windows NT サーバの DNS 検索が送信されます。 DNS サーバには Warthog のエントリがないため、WINS サーバに照会してから IP アドレスを返します。

名前検索の順序

Windows ネットワークの構成要素は、NetBIOS ノード タイプに応じて、異なる順序で名前解決問い合せを送信します。 システムが Windows NT 4.0 で、名前の長さが 15 文字を超える場合、Windows NT は DNS 問い合せのみを送信します。 ネットワークの他の構成要素とサービスも、名前解決を実行するためにコールされる API に応じて、異なる順序を使用する場合があります。 たとえば、gethostbyname() をコールするソケット アプリケーションは、名前解決方法として最初に DNS を使用します。 それ以外の場合、名前検索は次の順序で実行されます。

  • NetBIOS 名キャッシュをチェックする。

  • 現在の NetBIOS ノード タイプに応じて、ブロードキャスト問い合せ、または WINS 問い合せを送信する。

  • LMHOSTS ファイルをチェックする。

  • HOSTS ファイルをチェックする(「resolve using DNS」がチェックされている場合)。

  • インターネット DNS 問い合せを送信する(「resolve using DNS」がチェックされている場合)。

表 1: NetBIOS ノード タイプに応じて異なる NetBIOS 名の検索方法
NetBIOS ノード タイプ 名前検索の順序

b-node(0x1

ブロードキャストのみ

p-node(0x2

WINS のみ

m-node(0x4

ブロードキャスト、WINS の順

h-node(0x8

WINS、ブロードキャストの順


Microsoft LAN サービス ブラウザ

Windows ネットワークは当初、単一の LAN セグメントまたはブリッジされた(フラットな)ネットワークで動作するように設計されました。 その時点でサポートされていたのは、NetBEUI プロトコルのみです。

Microsoft は、ネットワーク上で使用できるすべてのコンピュータのリストをユーザがブラウズできるように、LAN サービス ブラウザを開発しました。 Windows ネットワーク クライアントはそれぞれ、ブロードキャストを送信することによって定期的に自身の NetBIOS 名を登録しました。

また、ネットワークのブラウズ マスターを選出するために、すべてのコンピュータがブロードキャストを送信する必要がありました。 ブラウズ マスター(および複数のバックアップ ブラウズ マスター)はコンピュータとそのアドレスのリストを管理していました。 ユーザがネットワークをブラウズすると、クライアントがブロードキャスト要求を送信し、ブラウズ マスターの 1 つがそれに応答しました。

その後 Microsoft は NetBIOS over IPX と NetBIOS over TCP/IP のサポートを追加しましたが、それでも Windows ネットワークはすべてのクライアントとサーバが同じ論理 IPX ネットワークまたは IP サブネット上に存在することを前提としていました。クライアントとサーバは、登録やネットワーク上のコンピュータの検索を行う際に依然としてブロードキャストを送信しました。

このアーキテクチャを実装することは簡単ですが、これによってネットワークと、ネットワーク上に存在する各クライアントの CPU は途方もなく大きな負担を強いられました。 このスケーラビリティの問題が原因で、Microsoft はブラウジングと名前解決に対して別の方法、つまり、ネットワーク上に存在する他のコンピュータの名前と IP アドレスをクライアントがマップする方法の提供を開始しました。 最終的に Microsoft は、ブロードキャストせずにブラウズと名前解決を実行する方法も提供しました。

このセクションの残りの部分では、各種環境でブラウジングがどのように動作するのかを説明します。 これまでのセクションで、個々の NetBIOS 名の解決方法について説明しました。 これら 2 つのアクティビティはよく似てはいますが、別個のものです。 ユーザがネットワークをブラウズするのは、Network Neighborhood(ネットワーク コンピュータ)を開いたとき、net view コマンドを使用したとき、または起動時に Windows NT ドメインにログインするときです。 名前解決は、すでに知っている名前、またはブラウジング時に見つかった名前を解決するプロセスです。 この説明は Web ブラウザには関係がない点に注意してください。

NetBIOS 名

NetBIOS 名は 15 文字から成る大文字の名前で、16 バイト目に特殊な識別情報が付加されています。 NetBIOS 名は 1 つの IP アドレス(一意)または複数の IP アドレス(グループ)に適用できます。 一意名またはグループ名になる名前タイプもあります。 これらの最後の文字のうち、最も一般的なものの一部を次の表に示します(値はすべて 16 進数で示されています)。

表 2: 特殊な NetBIOS 名とその説明(一部)
登録されている特殊名 説明

ユーザ名

<USERNAME><00>

現在ログインしているユーザの名前を WINS データベースに登録するために使用されます。これにより、このユーザは自身のユーザ名に送信された net send コマンドを受信できます。

コンピュータ名

<COMPUTER><00>

クラス 2 メールスロット要求を受信するために、Microsoft ネットワーク ワークステーションで使用されます。 どのワークステーションも、メールスロット要求を受信するためにこの名前を追加する必要があります。 これは、WINS クライアントによってワークステーション サービス用に登録されるコンピュータ名です。

<COMPUTER><03>

WINS クライアントであるコンピュータでメッセンジャー サービス用に登録されるコンピュータ名として使用されます。

<COMPUTER><20>

WINS クライアントである Windows 95 コンピュータでピア サーバ サービス用(または Windows NT コンピュータでサーバ サービス用)に登録される名前として使用されます。

<COMPUTER><Be>

ネットワーク モニタ エージェントがコンピュータで起動したときに登録される一意名として使用されます。

<COMPUTER><Bf>

ネットワーク モニタ エージェントがコンピュータで起動したときに登録されるグループ名として使用されます。 この名前の長さが 15 文字でない場合は、プラス(+)記号がパディングされます。

<COMPUTER><1f>

NetDDE サービスがコンピュータで起動したときに、Network Dynamic Data Exchange(DDE)用に登録される一意名として使用されます。

グループ名

<01><02>MSBROWSE<02><01>

ローカル サブネット上にドメインを定期的にアナウンスするために、マスター ブラウザ サーバによって使用されます。 このアナウンスメントには、ドメイン名と、ドメインのマスター ブラウザ サーバの名前が含まれています。 また、マスター ブラウザ サーバは、この名前に対するドメイン アナウンスメントを受信し、アナウンス側のコンピュータ名とともにこれらのドメイン アナウンスメントを内部ブラウズ リストに保持します。

<DOMAIN><00>

Microsoft LAN Manager をサポートするサーバ アナウンスメントを処理するために、ワークステーションとサーバによって使用されます。 Windows 95、Windows NT、Windows NT Server、および Windows for Workgroups が稼働しているサーバでは、サーバのプロパティで LMAnnounce オプションが有効になっていない限り、この名前のブロードキャストは行いません。

<DOMAIN><1b>

ドメイン マスター ブラウザ名を識別するために使用されます。これは Primary Domain Controller(PDC; プライマリ ドメイン コントローラ)のみが追加できる一意の名前です。PDC では、この名前での GetBrowserServerList 要求が処理されます。 WINS では、<1b> 文字付きのドメイン名で登録されているコンピュータが PDC と見なされます。

<DOMAIN><1c>

インターネット グループ名として使用され、ドメイン コントローラが登録します。 インターネット グループ名は、この名前を登録したコンピュータを最大で 25 台含む動的なリストです。 この名前は、パススルー認証を行う Windows NT コンピュータを検索するために使用されます。

<DOMAIN><1d>

マスター ブラウザ(ドメイン マスター ブラウザではありません)を識別するために使用されます。 マスター ブラウザは起動時にこの名前を一意の NetBIOS 名として追加します。 ワークステーションは自身の存在をこの名前にアナウンスするため、それを使用してマスター ブラウザはブラウズ リストを作成できます。 ワークグループの場合、この名前は <WORKGROUP><1d> の形式です。

<DOMAIN><1e>

Windows ネットワーク ワークグループまたは Windows NT Server ドメイン内のブラウザ サーバによって、すべてのワークグループまたはドメイン全体へのアナウンスメントのために使用されます。 この名前は、ワークグループまたはドメイン内のすべてのブラウザ サーバおよびサーバになる可能性のあるコンピュータによって追加されます。 ブラウザ選出パケットはすべてこの名前に送信されます。 ワークグループの場合、この名前は <WORKGROUP><1e> の形式です。


起動プロセス

ネットワークに接続されたシステムは起動時に、ネットワーク アドレスの検出、自身の登録、自身の認証、およびサービスの検出を行うために一連のパケットを送信します。 Windows NT ドメインにログインする Windows ネットワーク システムは、認証を受けるためにドメイン コントローラと通信する必要があります。 このプロセスは名前解決とブラウジングを使用します。

起動システムでは、最初にコンピュータ名(WORKSTATION<00>)を登録する必要があります。 LMAnnounce パラメータがオンの場合(LAN Manager サーバとの互換性のため)、システムでは DOMAIN<00> も登録されます。 次に、ログイン ドメインのドメイン コントローラを特定するために DOMAIN<1C> の解決が試行されます。 Windows 2000 が登場する以前は、この名前解決方法としてブロードキャスト、LMHOSTS、または WINS のみが使用されていました。 Windows 2000 では最初に DNS が試行されます。 次に、NetBIOS ベースのメールスロット メッセージを使用してドメイン コントローラへのログインが行われます。このメールスロット メッセージは User Datagram Protocol(UDP)ポート 138 に送信されます。最後に、ログインが成功した後、ログイン ユーザ(USERNAME<03>)が登録されます。これにより、メッセンジャ サービスでは、そのユーザの検索ができます。

コンピュータの検索

ユーザが名前によってコンピュータ上のリソースを要求すると(たとえば、net use \\fred\someshare の使用や FRED の検索など)、ローカル システムではコンピュータ名の解決が試行されます。 この照会は、タイプ <00> の一意な NetBIOS 名、DNS のエントリ、または HOSTS ファイルのエントリに対するものです。

ネットワーク コンピュータの表示

ユーザが Network Neighborhood(ネットワーク コンピュータ)を開いてドメインのリストを要求すると、システムはマスター ブラウザ名にブロードキャストを送信するか、またはドメイン マスター ブラウザに直接接続して(あるいはその両方を行って)、バックアップ ブラウザのリストの取得を試みます。 バックアップ ブラウザのリストが取得されたら、バックアップ ブラウザを選択してそのシステムに接続し、ドメインのリストを取得します。 それ以降、ドメイン内のサーバ宛ての要求は同じバックアップ ブラウザに転送されます。

サブネット ブラウジング

1980 年代には、ほとんどのネットワークが「フラット」であるか、または少数のサブネットがあるに過ぎませんでした。 NetBEUI と NWLink はこのモデルを使用しています。IP ブロードキャストはブリッジするか、または少数のサブネットを越えて伝搬できます。 次の説明はフラット ネットワークのケースを前提としています。

各サブネットにはドメインまたはワークグループごとにサブネット マスター ブラウザが存在し、複数のサブネット バックアップ ブラウザ(これもドメインまたはワークグループごと)が存在する場合もあります。 ブートアップ後、バックアップ ブラウザと非ブラウザは 1 分、2 分、4 分、8 分と間隔を広げながらブロードキャスト アナウンスメントを送信し、最終的に 12 分ごとにアナウンスメントをブロードキャストします。 サブネット マスター ブラウザはこれらのアナウンスメントを受信してブラウズ リストを作成します。

サブネット マスター ブラウザとバックアップ ブラウザには、他のコンピュータからのブラウズ問い合せに応答する役割があります。 マスター ブラウザはこれらの要求に対してブラウズ リストから直接応答できます。 バックアップ ブラウザもブラウズ リストを保持しています。バックアップ ブラウザは 15 分ごとにサブネット マスター ブラウザからブラウズ リストを取得します。

サブネットを越えたブロードキャスト ブラウジング

実際には、今日のほとんどのネットワークには複数のサブネットがあります。 多くの場合、ドメインの範囲はサブネットを越えており、サブネットに複数のドメインのシステムが含まれることもあります。 一部のシステムのブラウザ ソフトウェアはドメイン マスター ブラウザ(通常は PDC)と通信して多くのサブネットのブラウズ リストを交換できますが、そのためにはドメイン マスター ブラウザのユニキャスト アドレスを検知している必要があります。 サブネット マスター ブラウザでは、PDC のユニキャスト アドレスを LMHOSTS ファイル(詳細については「名前解決」のセクションを参照)または WINS(次のセクションを参照)から取得できます。

LMHOSTS はテキスト ファイルで、ブラウザ ソフトウェアは PDC のユニキャスト アドレスを特定するためにこのファイルを読み取ることができます。 サンプルを次に示します。 最初が PDC のユニキャスト IP アドレス、2 番目が PDC の NetBIOS 名(ENG_PDC)、3 番目が NetBIOS 名キャッシュにこの行を保存するタグ(#PRE)、最後がこのシステムを ENG ドメインのドメイン コントローラとしてマークするタグ(#DOM)です。

 10.1.3.4 ENG_PDC #PRE #DOM:eng
 

サブネット マスター ブラウザは、ドメイン マスター ブラウザのユニキャスト アドレスを検知している場合、IP ユニキャスト パケットを使用して 15 分ごとにブラウズ リストを交換します。 マスター ブラウザが参照されるため、クライアントはローカル サブネット(サブネット マスター ブラウザ)上にシステムがあるドメインのみをブラウズできます。 実際には、このシナリオは起動時にログイン サーバを検索するためには十分役立ちますが、ユーザが Network Neighborhood を使用してブラウズすることはできません。

重要な注意: Windows for Workgroups 3.11 および Windows 95 の一部のバージョンには不具合があるため、これらのシステムはサブネット マスター ブラウザまたはバックアップ ブラウザとして動作することはできません。 この不具合があるシステムでは、サブネット ブラウザはドメイン マスター ブラウザへ問い合せることができません。 この不具合は Windows 95 OSR(OEM Service Release)2 で修正されています。結果的に、サブネット上に Win31 または Win95 のマスターまたはバックアップ ブラウザがある場合、サブネット上でのブラウジングが失敗します。

WINS を使用した任意のドメインのブラウジング

複数のドメインがある組織では、これまでのセクションで概説した制約の中でネットワークを設計するのは適切ではありません。 WINS が動作している場合、サブネット ブラウザは WINS クライアントになり、任意のドメインのドメイン マスター ブラウザ(PDC)のユニキャスト IP アドレスを取得できます。 しかしそれでも、デフォルトでは、サブネット上に WINS 以外のクライアントがあることを想定して、ブロードキャストが頻繁に、かつ繰り返し送信されます(次のセクションの WINS ノード タイプを示した表を参照)。 ほとんどのネットワークにとって最適なソリューションは、ブロードキャスト ブラウジングを無効にすることです。

ブロードキャストの無効化

ブロードキャストを無効にするときの最大の問題は不正なブラウズ マスターの発生を防ぐことです。このブラウズ マスターはブラウジング プロセスを阻害するため、サブネットに混乱が生じます。

winnt_d2.gif

図 3: 不正なブラウズ マスター
※ 画像をクリックすると、大きく表示されます。

ブロードキャスト名前解決を無効にするには、BrowseMaster 設定を Disabled に設定します。 Windows for Workgroups 3.11 では、SYSTEM.INI ファイルにコマンドを追加することで、ブロードキャストが無効になります(詳細については「付録 B」を参照)。 Windows 95/98 では、Advanced File and Print Sharing プロパティの BrowseMaster 設定を Disabled に設定する必要があります。 Windows NT では、ほとんどの場合、ブラウジングを無効にする必要はありません。ただし、それが望ましい場合もあります。 Windows NT では、Hkey_local_machine\system\CurrentControlSet\Services\Browser\Parameters\MaintainServerList レジストリ キーを No に設定します。管理者は、適切な WINS ノード タイプ(p-node:0x2)を選択することで、DHCP クライアントによって送信されるブロードキャストを制御できます。 次のリストはすべての WINS ノード タイプを示しています。

表 3: WINS ノード タイプのリスト
WINS ノード タイプ 名前検索の順序

b-node(0x1

ブロードキャストのみ

p-node(0x2

WINS のみ

m-node(0x4

ブロードキャスト、WINS の順

h-node(0x8

WINS、ブロードキャストの順


ネットワークの規模の拡張

信頼されるドメイン

Windows ネットワークを計画するときには、どんなドメイン モデルを使用するかについて十分検討することが重要です。 以降の段落で、いくつかのドメイン モデルの利点と欠点について説明します。 複数のドメインがある場合、通常はネットワーク内の他のドメインとデータを交換します。 各ユーザを個別に管理せずに、ドメインへのアクセスを取得したり、付与したりする方法として、信頼関係があります。 それぞれの関係は一方向の信頼のみを許可します。 詳細については、『Windows NT 4.0 Server Resource Kit』第 2 巻、4 章を参照してください。

単一ドメイン

このドメイン モデルは最も単純で、ネットワークにはドメインが 1 つしかありません。 このセットアップは、WAN が含まれない中小規模のインストレーションに有効です。

グローバル トラスト

中心的な管理組織や IS 組織のない会社でネットワークを設計する場合、グローバル トラスト モデルは最も理解しやすく、同時に最も管理しにくいモデルです。 すべてのドメインが他のすべてのドメインを信頼します。

マスター ドメイン

このモデルでは、マスター ドメインは他のすべてのドメインによって信頼されますが、マスター ドメインはどのドメインも信頼しません。 このオプションは、各部門や事業部に対して独自のサービスに関する管理上の制御権を与えるものの、認証は集中的に行う場合に役立ちます。

複数マスター ドメイン

このモデルは、マスター ドメイン モデルをより大きなバージョンに拡張する場合に使用します。 複数のマスター ドメインすべてが互いに信頼し合い、それぞれのマスター ドメインは部門別の各ドメインによって信頼されます。

WINS の複製

冗長化のため、または WAN トラフィックを最適化するために、複数の WINS サーバを設置することが望ましい場合があります。 Windows NT および Windows 2000 サーバは、WINS データベースを一方向または両方向に複製または再同期化できます。 図 4 の大規模な多国籍企業は複数の WINS サーバを分散配置しているため、WINS 問い合せを、大陸を越えて送信する必要はありません。

winnt_d3.gif

図 4: WINS 複製の企業規模構成の例

モデムへのアクセス

Windows NT および Windows 2000 には Microsoft Remote-Access Server(RAS; リモート アクセス サーバ)が付属しており、これは Point-to-Point Protocol(PPP)を使用します。 Cisco アクセス サーバの方がダイヤルイン密度が高く、パフォーマンスが優れているため、ダイヤルイン プール用に NT RAS ではなく Cisco アクセス サーバを使用できます。

Windows では TCP/IP、IPX、および NetBEUI(PPP 用の IP Control Protocol [IPCP]、IPX Control Protocol [IPXCP]、および NetBIOS Frames Control Protocol [NBFCP] 制御プロトコル)がサポートされています。 NetBEUI のダイヤルイン サポートは、リリース 11.1 で Cisco IOS ソフトウェアに追加されました。 NetBEUI でダイヤルインする場合は、アクセス サーバの各非同期インターフェイス上、またはグループ非同期インターフェイス上で netbios nbf コマンドを使用します(次の例を参照)。

interface ethernet 0

netbios nbf

interface group-async 0

group-range 1 16

netbios nbf

IPX ダイヤルインを設定するには、アクセス サーバの各非同期インターフェイス上、またはグループ非同期インターフェイス上で ipx ppp-client コマンドを使用します(次の例を参照)。 このコマンドを使用する際は、ループバック インターフェイス上に IPX ネットワーク アドレスを設定する必要があります。 ダイヤルイン クライアントは Service Advertisement Protocol(SAP)メッセージを受信する必要がないため、ipx sap-interval 0 コマンドを使用して SAP メッセージを無効にする必要があります。

 Interface loopback 0
 
 ipx network <network number>
 
 interface group-async 0
 group-range 1 16
 ipx ppp-client loopback 0
 ipx sap-interval 0
 

Cisco アクセス サーバは、ダイヤルイン クライアントに IP アドレスを割り当てるために、ローカル アドレスのプールを使用するか、または DHCP サーバのプロキシとして動作できます。 アクセス サーバは DHCP サーバからアドレスを要求し、PPP ネゴシエーション中にそのアドレスを使用します。 クライアントも、自身の WINS サーバのアドレスをネゴシエートできます。

 ip dhcp-server n.n.n.n
 
 
 async-bootp nbns-server m.m.m.m
 
 
 async-bootp dns-serverp.p.p.p
 
 
 ip address-pool dhcp-proxy-client
 
 !
 
 interface group-async 0
 
 group-range 1 16
 
 peer default ip address dhcp
 

ダイヤルオンデマンド ルーティング

Dial-on-Demand Routing(DDR; ダイヤルオンデマンド ルーティング)は、Public Switched Telephone Network(PSTN; 公衆電話交換網)を経由したネットワーク接続を提供します。 従来の WAN 接続は、専用回線でした。 DDR は少量の間欠的なネットワーク接続を提供するため、オンデマンド サービスが可能になり、ネットワーク コストが減少します。 Integrated Services Digital Network(ISDN; サービス総合デジタル網)は回線交換テクノロジーです。 アナログ電話ネットワークと同様に ISDN も、通信する必要があるときにのみ接続が確立されます。

Cisco ルータは DDR を使用して、他のサイトへの接続が必要になる条件を判断します。 パケットは、プロトコル固有のアクセス リストとダイヤラ リストに基づいて、対象または非対象に分類されます。 非対象パケットはアクティブな DDR リンクを通じて伝送できますが、非対象パケットによってリンクがアップされることはなく、リンクがアップ状態のまま維持されることもありません。

ファイルまたはプリンタを共有している Windows for Workgroups および Windows 95/98 クライアントは、WINS サーバに対して 12 分または 15 分ごとにユニキャスト パケットを送信し(UDP ポート 137 - NetBIOS 名サービス ポート)、自身を WINS に登録します。

Windows NT システムもさまざまなパケットを定期的に送信することがあるため、WAN コストが増える要因になります。 定期的に送信されるパケットには、ブラウザ同期化、WINS 複製、SAM(ユーザ アカウント データベース)複製、プリンタ ブラウジング、DHCP などがあります。 これらのサービスの多くにはレジストリ キーがあり、ダイヤルオンデマンド接続の頻度を減らすためにレジストリ キーを調整できます。 詳細については、Microsoft サポート技術情報の記事:Q134985 を参照してください。 重要なレジストリ エントリを次に示します。

Hkey_local_machine\system\CurrentControlSet\Services\Browser\Parameters\MasterPeriodicity

Hkey_local_machine\system\CurrentControlSet\Services\Browser\Parameters\BackupPeriodicity

Hkey_local_machine\system\CurrentControlSet\Services\Replicator\Interval

Hkey_local_machine\system\CurrentControlSet\Services\Netlogon\PulseMaximum

Hkey_local_machine\system\CurrentControlSet\Services\Control\Print\DisableServerThread

winnt_d4.gif

図 5: 常時アップしているダイヤルオンデマンド リンク

WINS サーバにパケットを送信すると、通常はダイヤルオンデマンド リンクがアップします。 しかし、このポートが Cisco IOS ソフトウェア上で非対象と分類されている場合、ルータはリンクをアップせず、リンクをアップ状態のまま維持することもありません。

 Interface bri 0
 
 dialer-group 1
 !
 
 dialer-list 1 protocol ip list 101
 
 access-list 101 deny udp any any eq netbios-ns
 
 access-list 101 permit ip any any
 
winnt_d5.gif

図 6: UDP ポート 137 が非対象で、リンクはダウン

Cisco 700 シリーズでは、フィルタはリリース 4.1(2) から使用可能です。 Windows NT SAM トラフィックを非対象にするフィルタの例を次に示します。

 SET netbsp OFFSET 2 FROM TCPHDR PATTERN 00 8b 
 
 SET netbnsp OFFSET 2 FROM UDPHDR PATTERN 00 89 
 
 SET netbdgp OFFSET 2 FROM UDPHDR PATTERN 00 8a 
 
 SET refresh OFFSET 10 FROM UDPHDR PATTERN 40 00 
 
 SET netbsm OFFSET 20 FROM TCPHDR PATTERN 00 
 
 SET smb OFFSET 24 FROM TCPHDR PATTERN ff 53 4d 42 
 
 SET tcppat2 OFFSET 13 FROM TCPHDR PATTERN 02 
 
 SET netbsr OFFSET 20 FROM TCPHDR PATTERN 81 
 
 SET keepali OFFSET 20 FROM TCPHDR PATTERN 85 
 
 SET tcpres OFFSET 13 FROM TCPHDR PATTERN 04 
 
 SET IP FILTER OUT netbnsp refresh IGNORE
 
 SET IP FILTER OUT netbdgp IGNORE
 
 SET IP FILTER OUT netbsp netbsm smb IGNORE
 
 SET IP FILTER OUT netbsp tcppat2 IGNORE
 
 SET IP FILTER OUT netbsp tcpres IGNORE
 
 SET IP FILTER OUT netbsp netbsr IGNORE
 
 SET IP FILTER OUT netbsp keepali IGNORE
 

ISDN へのアクセス

このセクションでは、ISDN カードと Terminal Adapter(TA; ターミナル アダプタ)を取り上げます。 ISDN ルータで Windows ネットワークを使用する場合は、ダイヤルオンデマンド ルーティングに関するこれまでのセクションを参照してください。

Adtran

Adtran と Cisco は緊密な協力関係の下で相互運用性テストを行っているため、外部 TA を検討する場合は Adtran が有力な候補になります。 Adtran の TA は、Multilink PPP(MP)、Challenge Handshake Authentication Protocol(CHAP)、Password Authentication Protocol(PAP)、同期/非同期シリアル インターフェイス、および Automatic Service Profile Identifier(AutoSPID)コンフィギュレーションをサポートしています。

Motorola BitSURFR

PC に接続された BitSURFR を Cisco ルータと相互運用させる最も簡単な方法は、AT%A2=95 コマンドによって非同期/同期変換を有効にすることです(詳細については、BitSURFR マニュアルの P.7-1 を参照)。 BitSURFR Pro を使用していて、両方の B チャネルを使用する場合は、PAP 認証を使用する必要があります。 BitSURFR Pro は、第 2 B チャネルの起動時に送信される CHAP チャレンジに対して正しく応答できません。 2 つの B チャネルを使用してコールを発信するには、電話番号を 2 回入力する必要があります。 たとえば、電話番号が 555-1212 の場合は、ATD555-1212&555-1212 と入力します。次の表に、いくつかの接続タイプに対して入力するコマンドを示します。

表 4: Motorola BitSURFR 用の便利な設定コマンド
接続タイプ コマンド

PPP を使用した接続

%A2=95

両方の B チャネルを使用(MP)

@B0=2

PAP 認証の使用

@M2=P

Data Termination Equipment(DTE; データ端末機器)の速度(PC の COM ポート)

&M

64-kbps コールの発信

%A4=0

56-kbps コールの発信

%A4=1

音声コールの発信

%A98


クライアント ソフトウェア

CiscoRemote Lite

CiscoRemote Lite は、Windows 3.1 および Windows for Workgroups 用の無償の TCP/IP スタックおよびダイヤラ アプリケーションです。 CiscoRemote は PPP と Serial Line Internet Protocol(SLIP; シリアル ライン インターネット プロトコル)プロトコルをサポートします。

例 1

例 1 は、NWLink(NetBIOS over IPX)を使用した小規模な単一ドメイン ネットワークを示しています。 図 7 に、このセットアップを図示します。

winnt_d6.gif

図 7: NWLink を使用した小規模な単一ドメイン ネットワーク

Cisco 4700 ルータのコンフィギュレーション

 hostname 4700
 
 ipx routing
 
 !
 
 interface ethernet 0
 
 ipx network 50
 
 ipx type-20-propagation
 
 interface ethernet 1
 
 ipx network 60
 
 ipx type-20-propagation
 
 interface ethernet 2
 
 ipx network 7B
 
 ipx type-20-propagation
 
 interface ethernet 3
 
 ipx network 95
 
 ipx type-20-propagation
 

Cisco 2511 アクセス サーバのコンフィギュレーション

 hostname 2511
 
 ipx routing
 
 !
 
 interface ethernet 0
 
 ipx network 98
 
 interface loopback 0
 
 ipx network 163
 
 interface group-async 0
 
 group-member 1 16
 
 ipx ppp-client loopback 0
 
 ipx sap-interval 0
 
 encapsulation ppp
 
 async mode dedicated
 
 !
 
 line 1 16
 
 modem inout
 
 speed 115200
 
 flowcontrol hardware
 

例 2

例 2 は、NBT(NetBIOS over TCP)と静的名前解決(LMHOSTS)を使用した中規模のネットワークを示しています。 図 8 に、このセットアップを図示します。

winnt_d7.gif

図 8: NBT と LMHOSTS を使用した中規模のネットワーク
※ 画像をクリックすると、大きく表示されます。

Claude(Marketing ドメインのクライアント)の LMHOSTS コンフィギュレーション

1.2.1.8

mkt_PDC

#PRE

1.2.7.3

mkt_BDC

#PRE

#BEGIN ALTERNATE

#INCLUDE \\mkt_pdc\public\lmhosts

#INCLUDE \\mkt_bdc\public\lmhosts

#END ALTERNATE


mkt_PDC(Marketing ドメインのプライマリ ドメイン コントローラ)の LMHOSTS コンフィギュレーション

1.1.1.3

eng_PDC

#PRE #DOM:eng

1.1.4.5

sales_PDC

#PRE #DOM:sales

1.2.1.4

sleepy

-

1.2.1.5

sneezy

-

1.2.6.2

martin

-

1.2.6.78

theresa

-

1.2.6.89

claude

-


Cisco 7500 ルータのコンフィギュレーション

 hostname 7500
 
 ip forward-protocol udp bootpc
 
 !
 
 interface ethernet 0
 
 ip address 1.5.6.1 255.255.255.0
 
 ip helper-addressn.n.n.n
 
 
 ...
 
 interface ethernet 23
 
 ip address 1.5.56.1 255.255.255.0
 
 ip helper-addressn.n.n.n
 
 

スタック グループ内の AS5200 のコンフィギュレーション

 hostname as5200-1
 
 !
 
 controller t1 0
 
 framing esf
 
 linecode b8zs
 
 pri-group
 
 controller t1 1
 
 framing esf
 
 linecode b8zs
 
 pri-group
 
 !
 
 sgbp group as5200s
 
 sgbp member as5200-2
 
 sgbp member as5200-3
 
 username as5200s password stackpassword
 
 !
 
 ip dhcp-servern.n.n.n
 
 
 ip wins-serverm.m.m.m
 
 
 ip address-pool dhcp-proxy-client
 
 !
 
 interface ethernet 0
 
 ip address 192.168.2.1 255.255.255.0
 
 !
 
 interface group-async 0
 
 group-member 1 48
 
 peer default ip address dhcp
 
 !
 
 interface serial 0:23
 
 dialer rotary-group 1
 
 isdn incoming-voice modem
 
 interface serial 1:23
 
 dialer rotary-group 1
 
 isdn incoming-voice modem
 
 interface dialer 1
 
 ip unnumbered ethernet 0
 
 encapsulation ppp
 
 ppp multilink
 
 ppp authentication chap
 
 ppp use-tacacs
 
 dialer-group 1
 
 !
 
 dialer-list 1 protocol ip permit
 
 !
 
 line 1 48
 
 modem inout
 
 modem autoconfigure type microcom-hdms
 
 speed 115200
 
 flowcontrol hardware
 

Cisco 700 ルータのコンフィギュレーション

 set system 700
 
 cd LAN
 
 set ip address 1.4.3.1
 
 set ip netmask 255.255.255.248
 
 set ip routing on
 
 set ip rip update periodic
 
 CD
 
 set user as5200s
 
 set encapsulation ppp
 
 set ip framing none
 
 set ip routing on
 
 set number 5551212
 
 set ip route destination 0.0.0.0/0 gateway 0.0.0.0
 
 CD
 
 set active as5200s
 
 set bridging off
 

例 3

例 3 は、NBT(NetBIOS over TCP)と 1 台の WINS サーバを使用した中規模のネットワークを示しています。 図 9 に、このセットアップを図示します。

winnt_d8.gif

図 9: NBT(NetBIOS over TCP)と 1 台の WINS サーバを使用した中規模のネットワーク
※ 画像をクリックすると、大きく表示されます。

Cisco 1600 のコンフィギュレーション

 hostname 1600
 
 username as5200s password secret
 
 !
 
 interface ethernet 0
 
 ip address 1.4.3.1 255.255.255.248
 
 interface bri 0
 
 ip unnumbered ethernet 0
 
 encapsulation ppp
 
 ppp multilink
 
 dialer string 5551212
 
 dialer-group 1
 
 !
 
 dialer-list 1 protocol ip list 101
 
 access-list 101 deny udp any any eq netbios-ns
 
 access-list 101 permit ip any any
 

例 4

図 10 は、NBT(NetBIOS over TCP)を使用し、複数のマスター ドメインがあり WINS サーバが複製された大規模なネットワークを示しています。

winnt_d9.gif

図 10: NBT を使用し、複数のマスター ドメインがあり WINS サーバが複製された大規模なネットワーク
※ 画像をクリックすると、大きく表示されます。

付録 A: ブロードキャスト名前解決の無効化

Windows for Workgroups 3.11 を使用している場合

Windows for Workgroups 3.11 を使用しているときに、ブラウジングを正常に機能させるには、新しいブラウザ ファイル、VREDIR.386(Windows NT 3.5 に組み込まれている)を使用する必要があります。 Windows 95/98 にはすでに、この変更されたブラウザが組み込まれています。 VREDIR.386 ファイルは通常、C:\WINDOWS\SYSTEM ディレクトリにあります。

Windows for Workgroups クライアントは、SYSTEM.INI ファイルを次のように変更する必要があります。

; SYSTEM.INI

;

[Network]

MaintainServerList=No

Windows 95/98

winnt_10.gif

図 11: Windows 95/98 でのブラウズ マスターの無効化
※ 画像をクリックすると、大きく表示されます。

Windows NT 3.51

WINS 名前解決を実行するよう設定されている Windows NT 3.51 ワークステーションおよびサーバは、ネットワーク上の他のコンピュータがブラウザ選出を要求しない限り、ブロードキャストを送信しません。 したがって、特に対処する必要はありません。

Windows NT レジストリ エントリ

レジストリの hkey_local_machine\system\currentcontrolset\services\browser\parameters 領域にあるエントリについては、MaintainServerList を Yes、IsDomainMaster を False に設定する必要があります。 これらはデフォルト設定です。

MasterPeriodicity 設定(単位は秒)は、サブネット ブラウズ サーバがブラウズ リストを取得するためにどれくらいの頻度でドメイン マスターを照会するかを指定します。 サブネット ブラウズ サーバとドメイン マスターが低速リンクまたはパケット単位で課金されるリンクによって切り離されている場合は、これを 1 時間以上に設定できます。

不正なブラウズ マスターの特定

Windows 3.1 および Windows 95/98 ワークステーションは、NT サーバおよびドメイン情報を処理できないため、Windows NT ネットワークのブラウズ マスターとして動作することはできません。 困ったことに、デフォルトでは、Windows 95/98 はブラウズ マスターになろうと試みます。 ブラウズ マスターであると誤って主張している 1 台のワークステーションのために、そのサブネット全体にわたってすべてのコンピュータのブラウジングが妨害されます。 ブラウズ マスターになるためのプライオリティは高い方から PDC、BDC、NT Server、NT Workstation の順で、その次が Windows 95/98 です。このため、通常であればこの状況は起こりません。

Windows NT 4.0 Server Resource Kit には BROWSTAT というユーティリティが含まれています。 不正なブロードキャストを送信しているサブネット上のコンピュータを特定するための最も簡単な方法は、対象のサブネット上にある Windows NT コンピュータで BROWSTAT を実行することです。

付録 B: WINS 名の DNS 解決の設定

Windows NT 4.0 Server および Windows 2000 に組み込まれている DNS サーバはどちらも、バックグラウンドで WINS サーバを照会することによって DNS 問い合せに応答できます。 Windows 2000 DNS サーバでは、RFC 2136 に準拠した動的アップデートもサポートされています。WINS サーバと DNS サーバは、同じ Windows NT/2000 マシン上にある必要はありません。 サブドメイン(この例では wins.cisco.com)への DNS 問い合せはすべて、DNS/WINS サーバに委任されます。 ブート ファイルを使用して Windows NT/2000 DNS サーバを設定することは必須ではなく、Microsoft によって推奨されてもいません。 DNS Manager はサービスに対する豊富なインターフェイスを備えています。

DNS ブート ファイル

;BOOT

-

-

cache

.

CACHE

primary

domain.com

domain.dom

primary

8.17.1.in-addr.arpa

1-17-8.rev

domain.com の DNS ファイル

;domain.dom

@

IN

SOA

ns.domain.com.

rohan.domain.com. (

1

; シリアル番号

10800

; リフレッシュ [3h]

3600

; リトライ [1h]

604800

; 有効期限 [7d]

86400)

; 最小 [1d]

@

IN

WINS 1.1.4.6 1.2.7.4

wins-server

IN

A 1.1.4.6

wins-server2

IN

A 1.2.7.4

1Albitz, Paul and Cricket Liu. Sebastopol, CA: O'Reilly and Associates, 1992.


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 10624