Enterprise Mobility 4.1 デザイン ガイド Cisco Validated Design I
Cisco Unified Wireless のマルチキャ スト設計
Cisco Unified Wireless のマルチキャスト設計
発行日;2012/01/13 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 7MB) | フィードバック

目次

Cisco Unified Wireless のマルチキャスト設計

はじめに

Cisco Unified Wireless Network でのマルチキャスト転送の概要

無線マルチキャスト ローミング

アシンメトリック マルチキャスト トンネリング

マルチキャスト対応ネットワーク

LWAPP マルチキャスト予約ポートおよびアドレス

コントローラでのマルチキャスト転送の有効化

Ethernet Multicast Mode を有効にする CLI コマンド

マルチキャスト展開における考慮事項

LWAPP マルチキャスト アドレスの選択における推奨事項

断片化と LWAPP マルチキャスト パケット

すべてのコントローラの、同一 LWAPP マルチキャスト グループへの割り当て

標準のマルチキャスト技術を使用した、WLAN 上のマルチキャストの制御

コントローラの配置がマルチキャスト トラフィックおよびローミングに与える影響

その他の考慮事項

Cisco Unified Wireless のマルチキャスト設計

はじめに

この章では、IP マルチキャスト転送における Cisco Unified Wireless Network のマルチキャストについて説明し、無線環境でのマルチキャストの展開方法に関する情報を提供します。マルチキャスト パフォーマンス機能を使用するための前提条件として、マルチキャスト対応ネットワークが、コントローラと Access Point(AP; アクセス ポイント)間のすべてのルータに設定されていることが必要です。マルチキャストをサポートしないネットワークに備えて、コントローラでは元のユニキャスト パケット転送メカニズムも引き続きサポートされます。

IP マルチキャストは、情報を宛先グループに配信するためのプロトコルです。IP マルチキャストでは、ネットワークのそれぞれのリンク上で情報を配信する最も効果的な戦略を使用しています。宛先へのリンクが分かれる場合にのみコピーが作成され、ネットワークのそれぞれのホップで情報のコピーが 1 つだけ送信されます。通常、現在のネットワーク アプリケーションの多くはユニキャスト パケットを使用します。つまり 1 つの送信元に 1 つの宛先が対応します。しかし、複数の受信先に対して同じデータが必要な場合、個別のユニキャスト パケットとして、送信元からすべての受信先に対してデータを複製するとネットワークの負荷が増大します。IP マルチキャストによって、動的に形成された一連の受信先に一連の送信元から効率的にデータを転送できます。

現在は、ビデオなどの、受信先の大規模なグループに宛てた一方向のストリーミングメディアには、通常 IP マルチキャストが使用されています。多くのケーブル テレビ局、教育機関、および大企業では、コンテンツの配信に IP マルチキャストを展開しています。さらに、マルチキャストを使用してオーディオおよびビデオ会議に利用されています。大学構内および商業ネットワークでマルチキャストが広く使用されているその他の例として、ファイルの配信があります。特にオペレーティング システムのイメージおよびアップデートをリモート ホストに配信する場合などです。また、金融部門で株価情報表示および "hoot-n-holler" システムなどのアプリケーション用に IP マルチキャストが展開されています。

Cisco Unified Wireless Network でのマルチキャスト転送の概要

Cisco Unified Wireless Network Software Release 4.1 では、無線ネットワークで効率的にマルチキャストを使用するためのサポートが強化されています。3.1 以前のソフトウェア リリースでは、マルチキャスト用のパケットは、実際には無線ネットワーク上のユニキャストでした。マルチキャストのサポートは、3.2 で追加されましたが、必要なブロードキャストを有効にするためにはまだ設定の制限がありました。4.1 では、コントローラ ソフトウェア リリースによってブロードキャストとマルチキャストの個別のサポートが可能になり、ネットワークをマルチキャスト、ブロードキャスト、またはマルチキャストとブロードキャスト両方での使用のために設定できるようになりました。

図6-1 で示しているように、現在の Cisco Unified Wireless マルチキャスト サポートでは、コントローラで受信した、ファースト ホップ ルータに接続されている VLAN からの各マルチキャスト フレームはコピーされ、アソシエートされている AP のコントローラで設定されたマルチキャスト グループに送信されます。マルチキャスト パケットを含むマルチキャスト LWAPP パケットでは、WLAN ビットマップを使用します。WLAN ビットマップからは、パケットの転送に使用する必要がある WLAN の 着信 AP が通知されます。AP で LWAPP パケットが受信された場合、AP では外部 LWAPP カプセル化が取り除かれ、LWAPP WLAN ID ビットマスクで識別された(WLAN にアソシエートされているすべての無線上の)各 WLAN にマルチキャスト パケットが送信されました。

図6-1 4.1 以前のバージョンでのマルチキャスト転送メカニズム

 

LWAPP マルチキャスト グループは、各アクセス ポイントにマルチキャスト パケットを送信するために効率的に使用されます。これによって、ネットワーク内のルータで、標準のマルチキャスト技術を使用してマルチキャスト パケットを AP に複製して配信できるようになります。LWAPP マルチキャスト グループでは、コントローラがマルチキャストの送信元になり、AP がマルチキャストの受信先になります。


) 新しいマルチキャスト パフォーマンス機能を使用するための前提条件は、マルチキャスト対応ネットワークが、コントローラと AP 間のすべてのルータに設定されていることです。マルチキャストをサポートしないネットワークに備えて、コントローラでは元のユニキャスト パケット転送メカニズムも引き続きサポートされます。



) マルチキャストが有効になっていると、ファースト ホップ ルータからの VLAN 上で受信されたマルチキャスト パケットはその種類にかかわらず、HSRP hello パケット、ルータの EIGRP および PIM マルチキャスト パケットすべてを含め、無線ネットワーク経由で送信されます。


管理者がマルチキャストを有効にして(マルチキャスト モードはデフォルトで無効になっています)、LWAPP マルチキャスト グループを設定すると、アクセス ポイントで、コントローラへの通常の接続プロセス中(ブート時)に、コントローラの LWAPP マルチキャスト グループのアドレスがダウンロードされます。アクセス ポイントがコントローラに接続し、コントローラの設定をダウンロードした後、そのアクセス ポイントから、コントローラの LWAPP マルチキャスト グループへの Internet Group Management Protocol(IGMP)接続要求が発行されます。これによって、コントローラと AP 間のマルチキャスト対応ルータでマルチキャスト状態に対する通常のセットアップが開始します。マルチキャスト グループの送信元 IP アドレスは、コントローラの管理インターフェイスの IP アドレスであり、レイヤ 3 モードで使用される AP マネージャの IP アドレスではありません。AP がコントローラの LWAPP マルチキャスト グループに接続すると、クライアント マルチキャスト トラフィックのマルチキャスト アルゴリズムが次に示すように機能します。

マルチキャスト グループの送信元が有線 LAN 上にある場合

コントローラで、ファースト ホップ ルータに接続されているいずれかのクライアント VLAN からのマルチキャスト パケットが受信されると、受信されたパケットは、ベストエフォートの QoS 分類で管理インターフェイスを経由して LWAPP マルチキャスト グループに送信されます。LWAPP マルチキャスト パケットの QoS ビットは、最低レベルでハードコード化されており、ユーザが変更することはできません。

マルチキャスト対応ネットワークでは、LWAPP マルチキャスト パケットが、LWAPP マルチキャスト グループに接続されている各アクセス ポイントに配信されます。このとき、ルータでは、マルチキャスト パケットがすべての AP に到達するように、必要に応じて配信時にパケットを複製する通常のマルチキャスト メカニズムが使用されます(図6-1)。これによって、コントローラでマルチキャスト パケットを複製する必要がなくなります。

アクセス ポイントでは、他のマルチキャスト パケットを受信できますが、現在の接続先のコントローラから受信したマルチキャスト パケットだけが処理され、その他のコピーは破棄されます。複数の WLAN が、元のマルチキャスト パケットの送信元 VLAN インターフェイスにアソシエートされている場合、AP からそのマルチキャスト パケットが(LWAPP ヘッダーの WLAN ビットマップに従って)各 WLAN を経由して送信されます。また、WLAN が両方の無線(802.11g および 802.11a)に設定されている場合、WLAN にアソシエートされているクライアントがあれば、それらのクライアントがマルチキャスト トラフィックを要求しなかった場合でも、両方の無線から WLAN を使用してマルチキャスト パケットが送信されます。

マルチキャスト グループの送信元が無線クライアントである場合

マルチキャスト パケットは、標準の無線クライアント トラフィックと同様に、AP からコントローラへの LWAPP カプセル化されたユニキャストです。

コントローラでは、マルチキャスト パケットのコピーが 2 つ作成されます。1 つ目のコピーは、マルチキャスト パケットを受信した WLAN にアソシエートされている VLAN から送信され、これによって、有線 LAN 上の受信先でマルチキャスト ストリームを受信できるようになり、ルータで新しいマルチキャスト グループを認識できるようになります。パケットの 2 つ目のコピーは、無線クライアントでマルチキャスト ストリームを受信できるように、LWAPP カプセル化され、LWAPP マルチキャスト グループに送信されます。

無線マルチキャスト ローミング

無線環境でのマルチキャスト クライアントの重要な課題は、WLAN 内を移動するときにマルチキャスト グループ メンバシップを保持することです。AP 間の移動時に無線接続でパケットドロップすると、クライアントのマルチキャストアプリケーションが中断する原因となりえます。Internet Group Management Protocol(IGMP)は、動的なグループ メンバーシップ情報の保守において重要な役割を果たします。

IGMP の基本的な知識は、クライアントのマルチキャスト セッションがネットワーク内を移動するときに何が起こっているかを理解するのに重要です。レイヤ 2 ローミングでは、外部(foreign)AP が、正しく設定されていれば、既にそのマルチキャストグループに属しており、トラフィックがネットワーク上の別のアンカーポイントにトンネルされないという単純な理由で、セッションは維持されます。レイヤ 3 ローミング環境は、この方法およびコントローラに設定したトンネリング モードに応じて、これよりもやや複雑になります。無線クライアントから送信された IGMP メッセージが影響を受けます。コントローラ上のデフォルトのモビリティ トンネリング モードは、アシンメトリックです。 第 2 章「Cisco Unified Wireless のテクノロジーおよびアーキテクチャ」 で説明したように、これは、クライアントへのリターン トラフィックがアンカー WLC に送信されてから、アソシエートされているクライアント接続が配置されている外部 WLC に転送されることを意味します。アウトバウンド パケットは、外部 WLC インターフェイスに転送されます。シンメトリック モビリティ トンネリング モードでは、インバウンドおよびアウトバウンド トラフィックはアンカー コントローラにトンネルされます。モビリティ トンネリングの詳細は、 第 2 章「Cisco Unified Wireless のテクノロジーおよびアーキテクチャ」 を参照してください。

アシンメトリック マルチキャスト トンネリング

アシンメトリック マルチキャスト トンネリングで、クライアントが、別の WLC にアソシエートされた別のサブネット上の新しい AP に移動する場合、外部 WLC によってマルチキャスト グループ メンバシップが照会され、IGMP グループ メンバシップ レポートが送信されます。これにより、VLAN にアソシエートされた外部 WLC 動的インターフェイスに転送され、クライアントは外部サブネットを介してマルチキャスト ストリームに再接続します。図6-2 は、通常のデータとマルチキャスト データのトラフィック フローを示しています。

図6-2 アシンメトリック トンネリング

 


) クライアントが移動する場合、マルチキャスト セッションにわずかな中断が生じます。アプリケーションによっては、使用できない場合があります。


マルチキャスト対応ネットワーク

新しいマルチキャスト パフォーマンス機能を使用するための前提条件は、マルチキャスト対応ネットワークが、コントローラと AP 間のすべてのルータに設定されていることです。マルチキャスト対応ネットワークでは、パケットをネットワーク上の多数のホストに効率的な方法で配信できます。IP マルチキャストは、1 つの情報ストリームを企業の数千もの受信先に同時に配信することによってトラフィックを軽減する帯域幅節約技術の 1 つです。パケットは、ネットワーク内の各レイヤ 3 ポイントで必要に応じて複製されます。コントローラと AP 間に複数のルータがある場合は、PIM などのマルチキャスト ルーティング プロトコルが必要です。マルチキャスト対応ネットワークの設定の詳細は、次の URL http://www.cisco.com/go/multicast を参照してください。

LWAPP マルチキャスト予約ポートおよびアドレス

コントローラでは、宛先ポートが 12222 ~ 12224 のマルチキャスト グループに送信されるマルチキャスト パケットはすべてブロックされます。また、マルチキャスト グループ アドレスが、コントローラの LWAPP マルチキャスト グループ アドレスと同じパケットはすべてコントローラでブロックされます。これによって、断片化された LWAPP カプセル化パケットが、別のコントローラから再送信されることを防止できます(詳細は、 断片化と LWAPP マルチキャスト パケット を参照)。ネットワーク上のマルチキャスト アプリケーションで、これらの予約ポートまたは LWAPP マルチキャスト グループ アドレスを使用しないようにしてください。

コントローラでのマルチキャスト転送の有効化

コントローラ経由の IP マルチキャスト トラフィックはデフォルトで無効になっています。マルチキャスト トラフィックが無効な場合、WLAN クライアントではマルチキャスト トラフィックを受信できません。WLAN クライアントに対してマルチキャスト トラフィックを有効にする手順は、次のとおりです。


ステップ 1 マルチキャストが有効なネットワークがある場合、Ethernet Multicast Mode で multicast を選択して、ネットワークでパケットを複製する方法を使用します。

ステップ 2 マルチキャストが有効なネットワークがない場合、Ethernet Multicast Mode で unicast を選択して、コントローラでパケットを複製する方法を使用します。

ステップ 3 Controller General Web ページで、LWAPP Transport Mode が Layer 3 に設定されていることを確認します。マルチキャスト パフォーマンス機能は、このモードだけで動作します。

ステップ 4 Ethernet Multicast Mode のドロップダウン メニューから、Multicast を選択して、マルチキャスト グループ アドレスを入力します。図6-3 にこのオプションを示しています。

図6-3 GUI を使用して Ethernet Multicast Mode を有効にするコマンド

 


 

Ethernet Multicast Mode を有効にする CLI コマンド


ステップ 1 CLI コマンド:configure network multicast global enable を有効にします

ステップ 2 CLI コマンド: config network multicast mode multicast <IP アドレス> を有効にします

show network コマンドを使用して、コントローラでマルチキャスト モードになっていることを確認し、show lwapp mcast を使用して、AP のグループを確認します。他には、ルータで show ip mroute および show ip igmp membership を使用すると便利です。


 

マルチキャスト展開における考慮事項

LWAPP マルチキャスト アドレスの選択における推奨事項


注意 OSPF、EIGRP、PIM、HSRP、およびその他のマルチキャスト プロトコルで使用される予約済みリンク ローカル マルチキャスト アドレスを含め、任意のマルチキャスト アドレスを LWAPP マルチキャスト グループに割り当てることができますが、お勧めしません。

シスコでは、管理用スコープのブロック 239/8 からマルチキャスト アドレスを割り当てることをお勧めします。IANA では、プライベート マルチキャスト ドメインで使用するために、管理用スコープのアドレスとして 239.0.0.0 ~ 239.255.255.255 の範囲が予約されています(その他の制限については、次に示す注意を参照)。これらのアドレスは、RFC 1918 で定義されている予約済みのプライベート IP ユニキャストの範囲(10.0.0.0/8 など)と事実上よく似ています。ネットワーク管理者は、インターネット上での競合を気にすることなく、管理しているドメイン内でこの範囲のマルチキャスト アドレスを自由に使用できます。この管理用またはプライベートのアドレス空間は、企業内で使用する必要があり、Autonomous System(AS; 自律システム)を出入りしないようブロックする必要があります。


) 239.0.0.X または 239.128.0.X アドレス範囲を使用しないでください。これらの範囲のアドレスは、リンクのローカル MAC アドレスとオーバーラップしており、IGMP スヌーピングが有効になっている場合でもすべてのスイッチ ポートがフラッディングします。マルチキャスト MAC アドレスの重複の詳細は、次の URL を参照してください。
http://www.cisco.com/en/US/tech/tk828/technologies_white_paper09186a00802d4643.shtml#wp1002391


シスコでは、企業ネットワーク管理者がこのアドレス範囲を企業ネットワーク内のさらに細かい地理上の管理用スコープに分けて、特定のマルチキャスト アプリケーションのスコープを限定することをお勧めします。これによって、高レートのマルチキャスト トラフィックがキャンパス(帯域幅が十分)から出て WAN リンクを混雑させることを防止できます。また、高帯域幅のマルチキャストを効率的にフィルタリングすることによって、高帯域幅のマルチキャストがコントローラおよび無線ネットワークに到達することを防止できます。

マルチキャスト アドレスのガイドラインの詳細は、次の URL にあるドキュメントを参照してください。

http://www.cisco.com/en/US/tech/tk828/technologies_white_paper09186a00802d4643.shtml

断片化と LWAPP マルチキャスト パケット

コントローラで受信されたマルチキャスト パケットは、宛先アドレスとして LWAPP マルチキャスト グループを使用して LWAPP 内にカプセル化され、管理インターフェイス(送信元アドレス)経由で AP に転送されます。リンクの MTU を超えるパケットの場合は、コントローラによってパケットが断片化され、両方のパケットが LWAPP マルチキャスト グループに送信されます。別のコントローラが、この LWAPP カプセル化マルチキャスト パケットを有線ネットワーク経由で受信すると、パケットが再カプセル化される可能性があり、通常のマルチキャスト パケットのように処理されて、このコントローラの AP に転送されることになってしまいます。

これを防止するには、次の 2 つのオプションがあり、いずれのオプションもそれ自体で効果があります。1 つ目のオプションは、すべてのコントローラを同一の LWAPP マルチキャスト グループ アドレスに割り当てます。2 つ目のオプションは、標準のマルチキャスト フィルタリング技術を適用して、LWAPP カプセル化マルチキャスト パケットが他のコントローラに送信されないようにします。 表6-1 は、これら 2 つの技術の長所と短所を示しています。

 

表6-1 同一のマルチキャスト グループを使用する場合と異なるグループを使用する場合の長所と短所

長所
短所

すべてのコントローラの LWAPP マルチキャスト グループを同一にする

追加の断片化保護処理を施す必要がありません。

各コントローラのマルチキャスト トラフィックがネットワーク全体でフラッディングします(AP で、AP のコントローラ管理インターフェイスと同じ送信元 IP アドレスを持たないマルチキャスト パケットがドロップされます)。

標準のマルチキャスト技術を使用して LWAPP マルチキャスト フラグメントをブロックする

アドレス範囲を使用できるため、ネットワーク全体のフラッディングを防止できます。

マルチキャスト対応コントローラに設定されているすべての VLAN に接続されているファースト ホップ ルータに、ACL フィルタリングを適用する必要があります。

すべてのコントローラの、同一 LWAPP マルチキャスト グループへの割り当て

2 つ目のコントローラからこれらの LWAPP カプセル化パケットが再送信されないように、コントローラで、LWAPP マルチキャスト グループおよび LWAPP 予約ポート宛ての着信マルチキャスト パケットをブロックします。予約ポートをブロックすることによって、コントローラはカプセル化された LWAPP マルチキャスト パケットの断片化パケットの最初の部分をブロックします。ただし、2 つ目のパケットにはポート番号が含まれていないため、2 つ目のパケットは、マルチキャスト グループ アドレス(宛先アドレス)でフィルタするだけでブロックできます。コントローラは、宛先アドレスが、コントローラに割り当てられている LWAPP マルチキャスト グループ アドレスと同じになっているパケットをすべてブロックします。

ただし、各コントローラを同じ LWAPP マルチキャスト グループに割り当てると、別の問題が生じます。AP で LWAPP マルチキャスト グループへの接続に使用される IGMP バージョン 1 および 2 は、Any Source Multicast(ASM)であるため、AP では、ネットワーク内のマルチキャスト グループのすべての送信元からのマルチキャスト トラフィックを受信します。つまり、AP では、ネットワーク上のすべてのコントローラが同一のマルチキャスト グループ アドレスで設定されている場合も、それらのコントローラからのマルチキャスト パケットを受信し、マルチキャスト境界は適用されません。1 つのコントローラのマルチキャスト トラフィックが、ネットワーク全体のすべての AP にフラッディングし、各 AP では、ネットワーク全体の無線マルチキャスト クライアントから送信されているマルチキャスト トラフィックを受信します(送信元アドレスが AP のコントローラの管理アドレスとは異なる場合はドロップします)。ローカルから送信された、HSRP、PIM、および EIGRP などのクライアント VLAN からのマルチキャスト パケットおよび OSPF マルチキャスト パケットもネットワーク全体でフラッディングします。


) Cisco IOS AP(1240 など)では IGMPv2 が使用され、VxWorks AP(1030 など)では IGMPv1 が使用されます。


標準のマルチキャスト技術を使用した、WLAN 上のマルチキャストの制御

通常の境界技術をマルチキャスト対応ネットワークで使用する必要があります。これらの技術には、IP マルチキャスト トラフィックおよび Auto-RP メッセージをフィルタリングする ip multicast boundary インタフェースモードコマンドの使用が含まれます。


) マルチキャスト境界が適用されていない場合、ネットワーク内の任意の場所にある有線クライアントは、LWAPP マルチキャスト ストリームを要求して、すべての送信元からそのストリームを受信できます。マルチキャスト ストリームは、LWAPP マルチキャスト パケットにカプセル化されている場合は暗号化されていません。したがって、このようなアクセスを防ぐためにマルチキャスト境界を実装することをお勧めします。


以前は、IP マルチキャスト データグラムの Time To Live フィールドで、ttl-threshold コマンドを使用して、Auto-RP の管理用境界を作成していました。このタスクは、IP マルチキャスト トラフィックおよび Auto-RP メッセージをフィルタリングする ip multicast boundary interface mode コマンドの使用に代わってきています。シスコでは、新しいコマンドを使用することをお勧めします。

その他の有用なコマンドとして、ip multicast rate-limit インタフェースコマンドがあります。このコマンドでは、無線 VLAN で低レートが強制されます。このコマンドを使用しないと、ネットワーク エンジニアが高レート マルチキャスト アドレスをフィルタリングする場合でも、低レート マルチキャスト アドレスはそのレートを超過できません。

無線クライアント VLAN の一般的な例を次に示します。マルチキャスト対応ネットワークに使用するその他のマルチキャスト コマンドの詳細は、 http://www.cisco.com/go/multicast を参照してください。マルチキャスト対応トラフィックにフィルタリングを実行することによって、Sasser ワームなどの、マルチキャスト アドレスを使用した TCP および ICMP 転送に依存する特定ワームの伝搬を防ぐことができます。マルチキャスト グループ アドレスを使用してこれらのタイプのトラフィックをブロックしても、これらのアドレスでは通常、ストリーミングに UDP または TCP が使用されるため、ほとんどのアプリケーションに影響はありません。

次の例では、任意の送信元からのマルチキャスト グループ範囲 239.0.0.0 ~ 239.127.255.255 宛てのパケットのパケット レートが 128 Kbps に制限されます。この例では、下位の管理用スコープ アドレスには含まれないマルチキャスト アドレスすべてに境界が設定されます。また、Vlan40 を使用するホストは、239.0.0.0 ~ 239.127.255.255 の下位管理用グループだけに接続できるようになります。

 
mls qos
!
class-map match-all multicast_traffic
description Permit Low Rate Multicast Range of 239.0.0.0 to 239.127.0.0
match access-group 101
!
policy-map multicast
description Rate Limit Multicast traffic to 2.56mps with burst of 12800 bytes
class multicast_traffic
police cir 2560000 bc 12800 be 12800 conform-action transmit exceed-action drop
!
interface Vlan40
description To Wireless Clients
ip address 10.20.40.3 255.255.255.0
ip pim sparse-mode
ip multicast boundary 1
ip igmp access-group 30
standby 40 ip 10.20.40.1
standby 40 preempt
service-policy output multicast
!
access-list 1 remark Permit Low Rate Multicast Range of 239.0.0.0 to 239.127.0.0 for multicast boundary
access-list 1 permit 239.0.0.0 0.127.255.255
!
access-list 30 remark Only Allow IGMP joins to this Multicast Group Range
access-list 30 permit 239.0.0.0 0.127.255.255
!
access-list 101 remark Permit Low Rate Multicast Range of 239.0.0.0 to 239.127.0.0 for class-map
access-list 101 permit ip any 239.0.0.0 0.127.255.255

コントローラの配置がマルチキャスト トラフィックおよびローミングに与える影響


) 分散型と中央集中型のどちらの展開においても、マルチキャスト ストリームのレートは制限されず、ACL は保存できません。有効になると、マルチキャスト トラフィックは、HSRP、EIGRP、OSPF、および PIM パケットを含む無線に転送されます。


ここでは、分散型と中央集中型の 2 種類の展開について説明し、それぞれの展開がマルチキャスト クライアントのローミングに与える影響について示します。中央集中型の展開では、WLC WLAN インターフェイスは同じ VLAN/サブネットに接続され、マルチキャスト クライアントが WLC の AP から他の WLC のAP に移動する際にマルチキャスト ストリームは中断されません。中央集中型の展開では、フラットな WLC クライアント マルチキャスト ネットワークが作成されます。中央集中型の WLC がマルチキャスト ローミングに影響を与えることがない理由は、マルチキャスト ストリームが、特定の WLAN を使用する 1 つのマルチキャスト クライアントから要求されると、マルチキャスト トラフィックを要求したクライアントが 1 つも WLAN アクセス ポイントにアソシエートされていなくても、マルチキャスト ストリームが、この WLAN を使用する、すべての無線(802.11g および 802.11a)、すべての WLC に接続されているすべての AP に対して出力されるためです。VLAN にアソシエートされている WLAN が複数ある場合は、AP からマルチキャスト パケットが WLAN ごとに送信されます。ユニキャスト モードとマルチキャスト モードの LWAPP パケットには両方とも、パケットの転送で経由する必要のある WLAN を受信側 AP に伝える WLAN ビットマップが含まれます。

分散型の展開では、WLAN が同じでも、WLC が別の VLAN に接続されるため、このような問題はありません。これは、マルチキャスト クライアントが新しい WLC に移動するときに、WLC がクライアントのマルチキャスト グループ メンバシップについて最初に照会するということです。この時点で、クライアントはグループ メンバシップ レポートを送信し、WLC によって、ローカル VLAN にアソシエートされた VLAN 経由でこのメッセージが適切なマルチキャスト グループ アドレスに転送されます。これにより、クライアントは外部 WLC を介してマルチキャスト セッションを再開できます。

分散型展開では、WLAN SSID が同じであっても WLC は異なる VLAN に接続されているため、AP 上のマルチキャスト トラフィックの量が軽減されます。WLAN マルチキャスト トラフィックは、WLC の VLAN のクライアント要求によって異なります。 表6-2 は、分散型と中央集中型の展開の長所と短所を示しています。

 

表6-2 中央集中型 WLC および分散型 WLC の長所と短所

長所
短所

中央集中型のすべての WLC WLAN が同じ VLAN(サブネット)に接続されている

いずれのクライアント VLAN で開始したマルチキャスト トラフィックでもすべての AP に送信されるため、いずれの AP にローミングしてもクライアントはマルチキャスト ストリームを受信します。

1 つのクライアントだけがマルチキャスト トラフィックを要求した場合、すべてのコントローラに接続されているすべての AP がストリームを受信して、AP にアソシエートされているクライアントがある場合はそれらのクライアントがマルチキャスト ストリームを要求しなかった場合でも AP からストリームを送信します。

異なる VLAN およびサブネットに接続されている分散型 WLC

マルチキャスト ストリームは、対象のコントローラに接続されている AP に分離されます。

クライアントの移動後にマルチキャスト ストリームを確立したことによる中断

その他の考慮事項

マルチキャスト展開におけるその他の考慮すべき 2 つの分野は、AP グループの実装時、および H-REAP と REAP の実装時です。AP グループで、同じコントローラ上の AP は、同じ WLAN(SSID)を別の VLAN にマップできます。異なるグループの AP 間でのクライアントの移動は現在サポートされていないため、この操作をするとマルチキャスト セッションが正しく機能しません。現在、WLC は WLAN で設定された VLAN に対してのみマルチキャストを転送し、AP グループで設定された VLAN については考慮しません。

REAP および H-REAP AP を使用すると、WLAN のローカル終端が WLC ではなくネットワーク エッジで可能になり、マルチキャスト動作がそのエッジで制御されます。H-REAP WLAN が WLC で終端し、マルチキャストがその WLC で有効になっている場合に、H-REAP ネットワークが存在する場所まで LWAPP マルチキャストグループを拡張することが許可されているときは、マルチキャストは、その H-REAP WLAN に配信されます。

LWAPP マルチキャスト パケットをネットワーク経由で H-REAP に送信できない場合でも、これらはユニキャスト メッセージであるため、その H-REAP の WLAN クライアントは、WLC に接続されているネットワークに IGMP 接続要求を送信できます。