Enterprise Mobility 4.1 デザイン ガイド Cisco Validated Design I
Cisco Unified Wireless QoS
Cisco Unified Wireless QoS
発行日;2012/01/13 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 7MB) | フィードバック

目次

Cisco Unified Wireless QoS

QoS の概要

Wireless QoS の展開方式

QoS パラメータ

アップストリームおよびダウンストリーム QoS

QoS およびネットワークのパフォーマンス

802.11 DCF

フレーム間スペース

ランダム バックオフ

CWmin、CWmax、および再試行

Wi-Fi マルチメディア

WMM のアクセス

WMM の分類

WMM キュー

EDCA

U-APSD

TSpec アドミッション制御

WLAN インフラストラクチャ対応の QoS 拡張機能

IP 電話

アドミッション制御パラメータの設定

TSpec アドミッション制御の影響

802.11e、802.1P、および DSCP のマッピング

QoS ベースラインの優先度のマッピング

LWAPP ベースの AP への QoS 機能の展開

WAN QoS と H-REAP

無線 QoS 展開のガイドライン

スループット

LAN スイッチにおける QoS の設定例

AP スイッチの設定

WLC スイッチの設定

トラフィック シェーピング、Over-the-Air QoS、および WMM クライアント

WLAN 音声および Cisco 7921G と 7920

WAN 接続を介した LWAPP

LWAPP トラフィックの分類

LWAPP コントロール トラフィック

LWAPP 802.11 トラフィック

分類に関する考慮事項

LWAPP トラフィックの量

ルータ設定の例

Cisco Unified Wireless QoS

この章では、WLAN 実装の QoS(Quality of Service)について説明します。ここでは WLAN QoS 全般について説明します。セキュリティ、セグメンテーション、および Voice over WLAN(VoWLAN)などのトピックにも QoS コンポーネントが含まれますが、これらのトピックについてここでは詳しく取り上げません。また、Cisco Centralized WLAN アーキテクチャの機能についても説明します。

この章は、Cisco Unified Wireless テクノロジーを使用して企業の WLAN 展開の設計および実装に取り組んでいるユーザを対象としています。

QoS の概要

QoS とは、さまざまなネットワーク テクノロジーを介して、選択されたネットワーク トラフィックにディファレンシエーテッド サービスを提供するネットワークの機能のことです。QoS テクノロジーには、次の利点があります。

キャンパス、WAN、およびサービス プロバイダ ネットワークで使用されるビジネス マルチメディアおよび音声アプリケーションに基盤を提供します。

ネットワーク マネージャは、ネットワーク ユーザに対してサービス レベル契約(SLA)を制定できます。

ネットワーク リソースをさらに効率的に共有でき、ミッションクリティカルなアプリケーションの処理を効率化します。

時間依存型マルチメディアおよび音声アプリケーションのトラフィックを管理し、このトラフィックがベストエフォート型のデータ トラフィックよりも優先度が高く、帯域幅が大きく、かつ遅延が少なくなるようにします。

QoS を使用して、WLAN および WAN などの LAN 全体で帯域幅をより効率的に管理できます。QoS により、次の点で拡張された、信頼性のあるネットワーク サービスが提供されます。

重要なユーザおよびアプリケーションに対する専用の帯域幅のサポート

ジッタおよび遅延の制御(リアルタイムのトラフィックで必要)

ネットワーク輻輳の管理および最小化

トラフィック フローを円滑化するネットワーク トラフィックのシェーピング

ネットワーク トラフィックの優先度の設定

Wireless QoS の展開方式

従来、WLAN は主に低帯域幅のデータ アプリケーション トラフィックの伝達に使用されていました。現在では、WLAN は縦方向の環境(小売、金融、教育など)および企業環境に拡張され、時間依存型のマルチメディア アプリケーションと共に高帯域幅のデータ アプリケーションの伝達に使用されています。この要件に対応するために、無線 QoS が必要になりました。

シスコを含む複数のベンダーでは、音声アプリケーション対応の専用無線 QoS 方式をサポートしています。QoS の導入速度を速め、複数のベンダーの時間依存型アプリケーションに対応するには、無線 QoS に対する統一手法が必要です。IEEE 802.11 標準化委員会内の IEEE 802.11e グループにより、標準の定義は完了しています。しかし、802.11e 規格の採択は初期段階にあり、多くの標準と同じく、多数の任意の選択要素があります。802.11i の 802.11 セキュリティ規格の際と同様、Wi-Fi Alliance などの業界グループおよびシスコのような業界トップのメーカーは、認証プログラムを使用して主要な機能や互換性を確実に備えられるよう、WMM プログラムおよび Cisco Compatible Extensions プログラムを介して WLAN QoS の主要な要件を定義しています。

Cisco Unified Wireless 製品は、Wi-Fi Alliance が発表した IEEE 802.11e に基づく QoS システムである Wi-Fi MultiMedia(WMM)、WMM Power Save、および WMM Admission Control をサポートしています。

図5-1 は、Cisco Unified Wireless テクノロジーの機能に基づく Wireless QoS の展開例を示しています。

図5-1 QoS の展開例

 

QoS パラメータ

QoS は、通信の質およびサービスの可用性を反映した通信システムのパフォーマンスの基準として定義されています。サービスの可用性は、QoS の重要な要素です。QoS を正常に実装するには、ネットワーク インフラストラクチャがどのような状況下でも使用可能でなければなりません。ネットワークの通信の質は、遅延、ジッタ、および損失で決まります( 表5-1 を参照)。

 

表5-1 QoS パラメータ

通信の
説明

遅延

遅延とは、パケットが送信エンドポイントから伝送されて受信エンドポイントへ到達するまでにかかる時間を意味します。この間隔は、エンドツーエンド遅延と呼ばれ、次の 2 つの領域に分けることができます。

固定ネットワーク遅延 ― 符号化および復号化の時間(音声およびビデオ)、および電気パルスまたは光パルスがメディアを通過して送信先へ届くまでの限られた時間が含まれます。

可変ネットワーク遅延 ― 通常、伝送に必要な時間全体に影響を及ぼす可能性のあるキューイングや輻輳などのネットワークの状態を意味します。

ジッタ

ジッタ(遅延差異)は、パケット間のエンドツーエンド遅延の差です。たとえば、あるパケットが発信エンドポイントから送信先エンドポイントまでネットワークを通過するのに 100 ms かかり、次のパケットでは同じ伝送に 125 ms かかる場合、ジッタは 25 ms となります。

損失

損失(パケットの損失)は、伝送された総数が正常に送受信された場合のパケットの比較基準です。損失は、ドロップしたパケットの割合で示されます。

アップストリームおよびダウンストリーム QoS

図5-2 は、無線アップストリームおよびダウンストリーム QoS の定義を示しています。

図5-2 アップストリームおよびダウンストリーム QoS

 

図5-2 は、以下について示しています。

無線ダウンストリーム QoS ― AP から発信され WLAN クライアントまで伝送されるトラフィック。無線ダウンストリーム QoS が今なお最も一般的な展開であるため、この章で最も重要な焦点となっています。クライアントの無線アップストリーム QoS は、クライアントの実装によって異なります。

無線アップストリーム QoS ― WLAN クライアントから発信され AP まで伝送されるトラフィック。WMM では、WMM をサポートする WLAN クライアントのアップストリーム QoS が提供されます。

ネットワーク ダウンストリーム ― WLC から発信され AP まで伝送されるトラフィック。この時点で QoS を適用して、AP へのトラフィックの優先順位付けとレート制限を行えます。イーサネットのダウンストリーム QoS の設定は、この章では取り上げません。

ネットワーク アップストリーム ― AP から発信され WLC まで伝送されるトラフィック。AP は、その AP のトラフィック分類ルールに従って、AP からアップストリーム ネットワークまでのトラフィックを分類します。

QoS およびネットワークのパフォーマンス

QoS 機能の適用は、負荷の軽いネットワークでは容易に検出されないことがあります。メディアの負荷が軽いときに遅延、ジッタ、および損失が顕著な場合、それはシステム障害、ネットワーク設計の不備、またはアプリケーションの遅延、ジッタ、および損失の要件がネットワークと適合していないことを示しています。ネットワークの負荷が増大するにつれて、QoS 機能がアプリケーションのパフォーマンスに作用し始めます。QoS は、選択されたトラフィック タイプに対する遅延、ジッタ、および損失を許容できる限度内で維持するように作用します。AP から無線ダウンストリーム QoS のみが提供される場合、無線アップストリームのクライアント トラフィックはベストエフォートと認識されます。クライアントは、AP からのベストエフォート伝送に対しても、またアップストリーム伝送に対しても他のクライアントと競合します。特定の負荷状況下では、クライアントにアップストリームの輻輳が発生し、AP で QoS 機能を適用しても、QoS 依存型アプリケーションのパフォーマンスが許容不可能なまでに低下することがあります。理想的にアップストリームおよびダウンストリーム QoS を操作するには、AP と WLAN クライアントの両方で WMM を使用するか、WMM およびクライアントの独自の実装を使用します。


) WLAN クライアント上で WMM のサポートがなくても、Cisco Unified Wireless ソリューションはネットワークのアップストリームとダウンストリームの両方でネットワークの優先順位を付けることができます。



) WLAN クライアントの WMM へのサポートは、クライアント トラフィックが自動的に WMM の恩恵を得ているという意味ではありません。WMM の利点を求めるアプリケーションが適切な優先度の分類をそのトラフィックに割り当て、オペレーティング システムはその分類を WLAN インターフェイスに渡す必要があります。VoWLAN 端末などの専用デバイスでは、設計の一部としてこの機能があります。しかし、PC のような汎用プラットフォームに実装する場合、WMM 機能からよい結果を得るにはアプリケーション トラフィックの分類と OS のサポートを実装しておく必要があります。


802.11 DCF

802.11 のデータ フレームは、Distributed Coordination Function(DCF; 分散コーディネーション機能)を使用して送信されます。DCF は次の 2 つの主要コンポーネントで構成されています。

フレーム間スペース(SIFS、PIFS、および DIFS)。

ランダム バックオフ (コンテンション ウィンドウ)。DCF を 802.11 ネットワークで使用して RF メディアへのアクセスを管理します。

802.11e ベースの Enhanced Distributed Channel Access(EDCA; 拡張型分散チャネル アクセス)を展開するには、DCF の基本的な理解が必要です。DCF の詳細は、次の URL で IEEE 802.11 の仕様を参照してください。 http://ieeexplore.ieee.org/xpl/standardstoc.jsp?isnumber=14251&isYear=1997

フレーム間スペース

802.11 は、現在、次の 3 つのフレーム間スペース(IFS)を定義しています(図5-3 を参照)。

短いフレーム間スペース(SIFS)― 10µs

ポイント フレーム間スペース(PIFS)― SIFS + 1 x スロット タイム = 30µs

DCF フレーム間スペース(DIFS)― 50µs SIFS + 2 x スロット タイム = 50µs


) このフレーム間スペースの例で使用しているベース タイミングは、802.11b に基づいています。802.11g と 802.11a ではタイミングが異なりますが、同じ原則が適用されます。


フレーム間スペース(SIFS、PIFS、および DIFS)により、キャリア検知でチャネルの空きが示された後に、最初にチャネルにアクセスするトラフィックを 802.11 で制御できます。通常、802.11 の管理フレームとコンテンションを起こさないフレーム(フレーム シーケンスの一部であるフレーム)では SIFS が使用され、データ フレームでは DIFS が使用されます。 

図5-3 フレーム間スペース

 

ランダム バックオフ

DCF を使用しているデータ フレームが送信可能になると、そのデータ フレームは次の手順で処理を行います。

1. 0 ~最小コンテンション ウィンドウ(CWmin)の範囲のランダム バックオフ番号を生成します。

2. DIFS 間隔の間、チャネルが空くまで待機します。

3. チャネルがまだ空いている場合には、チャネルが空いているスロット タイム(20 µs)ごとの、ランダム バックオフ番号のデクリメントを開始します。

4. 別のステーションが先に 0 に達したなどでチャネルが使用中になると、デクリメントは停止し、手順 2 ~ 4 が繰り返されます。

5. ランダム バックオフ番号が 0 に達するまでチャネルが空いている状態のままであれば、フレームを送信できます。

図5-4は、DCF プロセスが実行される様子を示した簡単な例です。この簡易化 DCF プロセスでは、確認応答は示されず、断片化は発生しません。

図5-4 分散コーディネーション機能の例

 

図5-4 で示している DCF の手順は次のとおりです。

1. ステーション A は正常にフレームを送信します。他の 3 ステーションもフレームを送信しようとしていますが、ステーション A のトラフィックが完了するまで待つ必要があります。

2. ステーション A が伝送を完了した後も、すべてのステーションはなお DIFS の間待機する必要があります。DIFS が完了すると、フレームの送信を待機していたステーションが、スロット タイムごとに 1 度バックオフ カウンタのデクリメントを開始し、各フレームを送信できます。

3. ステーション B のバックオフ カウンタがステーション C および D の前に 0 に達したので、ステーション B がフレームの送信を開始します。

4. ステーション C および D はステーション B の送信を検知すると、バックオフ カウンタのデクリメントを停止し、ステーション B のフレームが送信され DIFS が過ぎるまで待機しなければなりません。

5. ステーション B がフレームを送信している間、ステーション E は送信するフレームを受信しますが、ステーション B が送信中のため、ステーション C および D と同じように待機しなければなりません。

6. ステーション B が送信を完了し、DIFS が過ぎると、送信すべきフレームを持つステーションがバックオフ カウンタのデクリメントを開始します。この場合、ステーション D のバックオフ カウンタが最初に 0 に達し、フレームの送信を開始します。

7. トラフィックが別のステーションに届くと、このプロセスが継続します。

CWmin、CWmax、および再試行

DCF はコンテンション ウィンドウ(CW)を使用して、ランダム バックオフのサイズを制御します。コンテンション ウィンドウは、次の 2 つのパラメータで定義されています。

aCWmin

aCWmax

ランダム バックオフで使用される初期のランダム番号は、0 ~ aCWmin です。初期ランダム バックオフがフレームを正常に送信せずに時間切れになった場合、ステーションまたは AP は再試行カウンタを増加し、ランダム バックオフ ウィンドウのサイズを倍加します。このサイズの倍加は、サイズが aCWmax と等しくなるまで続行します。再試行は、最大再試行回数または有効時間(TTL)に達するまで続行します。バックオフ ウィンドウを倍加するこのプロセスは、通常、バイナリ指数バックオフと呼ばれています。図5-5 はこれを示したもので、aCWmin が 2 5 -1 の場合 2 6 -1 に増加し、その後次のバックオフ レベルでは aCWmax 値である 2 10 -1 にまで増加しています。

図5-5 再試行に伴うランダム バックオフ範囲の増加

 


) これらの値は 802.11b に基づいており、別の物理レイヤの実装では異なります。


Wi-Fi マルチメディア

この項では、WMM の実装について説明します。

WMM のアクセス

WMM の省電力

アクセス コントロール

WMM のアクセス

WMM は、802.11e 草案の一連の機能に対応した Wi-Fi Alliance の認証です。この認証はクライアントと AP の両方を対象としており、WMM の操作を認定します。WMM は、主に、802.11e の EDCA コンポーネントの実装です。Wi-Fi の追加認証が、802.11e の別のコンポーネントを対象に計画されています。

WMM の分類

WMM では IEEE が開発した 802.1P 分類方式が使用されています(現在では 802.1D 分類の一部となっています)。

この分類方式には 8 つの優先度があり、WMM はこれを AC_BK、AC_BE、AC_VI、および AC_VO の 4 つのアクセス カテゴリにマッピングします。これらのアクセス カテゴリは、 表5-2 に示されているように WMM デバイスに必要な 4 つのキューにマッピングします。

 

表5-2 表 2 802.1P および WMM の分類

優先度
802.1P の優先度
802.1P の指示
アクセス カテゴリ
WMM の指示

最低

1

BK

AC_BK

バックグラウンド

2

-

0

BE

AC_BE

ベストエフォート

3

EE

4

CL

AC_VI

ビデオ

5

VI

6

VO

AC_VO

音声

最高

7

NC

図5-6 は、WMM データ フレーム形式を示しています。8 つの 802.1P 分類は WMM で 4 つのアクセス カテゴリにマッピングされますが、802.11D の分類はフレーム内で送信されます。


) WMM および IEEE 802.11e の分類はシスコのネットワークで推奨および使用されている分類とは異なります。シスコのネットワークで使用される分類は、IETF 推奨の分類に基づいています。分類の主な違いは、音声とビデオのトラフィックをそれぞれ 5 および 4 に変更している点です。これにより、6 つの分類をレイヤ 3 ネットワーク制御に使用できます。両方の標準に準拠するために、Cisco Unified Wireless ソリューションではトラフィックが無線と有線の境界を横切る際に、種々の分類標準間の変換が実行されます。


図5-6 WMM フレーム形式

 

WMM キュー

図5-7 は、WMM クライアントまたは AP で実行されるキューイングを示しています。4 つの個別キューが、各アクセス カテゴリに 1 つずつあります。これらのキューはそれぞれ、前述した DCF メカニズムに対するのと同様の方法で無線チャネルを確保するために競います。この際、各キューには異なるフレーム間スペース、CWmin、および CWmax の値が使用されます。異なるアクセス カテゴリからの複数のフレームが内部で衝突した場合、優先度の高いフレームが送信され、優先度の低いフレームはバックオフ パラメータをキューイング メカニズムの外部のフレームと衝突した場合と同様に調整します。このシステムは、Enhanced Distributed Channel Access(EDCA; 拡張型分散チャネル アクセス)と呼ばれています。

図5-7 WMM キュー

 

図5-8 は、EDCF の背後の原則を示しています。ここでは、異なるフレーム間スペースと CWmin および CWmax の値がトラフィックの分類ごとに適用されています(図内では、明確にするため Cwmax は省略)。異なるトラフィック タイプは各ランダム バックオフをカウント ダウンする前に異なるインターフェイス スペースを待機させることができ、ランダム バックオフ番号の生成に使用される CW 値もトラフィックの分類により異なります。たとえば、音声の CWmin[3] は 2 3 -1 で、ベストエフォート トラフィックの CWmin[5] は 2 5 -1 です。優先度が高いトラフィックではフレーム間スペースが小さく、CWmin 値も小さいため、ランダム バックオフが短くなるのに対し、ベストエフォート トラフィックではフレーム間スペースが長く、CWmin 値も大きくなるため、ランダム バックオフ数が平均して高くなります。

図5-8 アクセス カテゴリのタイミング

 

EDCA

図5-9 は、EDCA プロセスを示しています。

図5-9 EDCA の例

 

EDCA プロセスでは、次の順序で処理が行われます。

1. ステーション X がフレームを送信中に、他の 3 つのステーションでフレームを送信する必要があると判断されました。フレームはすでに送信中なので各ステーションは待機し、ランダム バックオフを生成します。

2. ステーション Voice には音声のトラフィック分類があるので、Arbitrated Interframe Space(AIFS; 調停フレーム間スペース)2 があり、初期 CWmin 3 を使用します。したがって、ランダム バックオフのカウントダウンを待機する必要があるのは 2 スロット タイムで、ランダム バックオフ値は短くなります。

3. ベストエフォートの CWmin 値は 5 なので、ベストエフォートには 3 の AIFS があり、ランダム バックオフ タイムは長くなります。

4. Voice には最短ランダム バックオフ タイムがあるので、最初に送信を開始します。Voice が送信を開始すると、他のすべてのステーションは待機します。

5. Voice ステーションが送信を終えると、すべてのステーションはそれぞれの AIFS の間待機し、その後再びランダム バックオフ カウンタのデクリメントを開始します。

6. 次にベストエフォートがランダム バックオフ カウンタのデクリメントを完了し、送信を開始します。他のすべてのステーションは待機します。送信を待機している Voice ステーションがある場合でも、このように進行します。これは、ランダム バックオフのデクリメント プロセスで最終的にはベストエフォート バックオフが高優先度トラフィックと同様のサイズにまで縮小されるため、音声トラフィックがベストエフォート トラフィックを絶対に必要だとしていないこと、およびランダム プロセスが、場合に応じて、ベストエフォート トラフィックに対して小さいランダム バックオフ番号を生成することを示しています。

7. 他のトラフィックがシステムに入ると、このプロセスが継続します。 表5-3 および 表5-4 に示されているアクセス カテゴリの設定は、デフォルトでは、802.11a 無線と同一で、WMM で定義されている式に基づいています。


表5-3 は、クライアントのパラメータ設定を示しています。この設定は、AP の設定とは多少異なっています。AP では、AC 音声およびビデオの AIFSN 値が高くなっています。


 

表5-3 WMM クライアント パラメータ

AC
CWmin
CWmax
AIFSN
TXOP 制限(802.11b)
TXOP 制限(802.11a/g)

AC_BK

aCWmin

aCWmax

7

0

0

AC_BE

aCWmin

4*(aCQmin+1)-1

3

0

0

AC_VI

(aCWmin+1)/2-1

aCWmin

1

6.016 ms

3.008 ms

AC_VO

(aCWmin+1)/4-1

(aCWmin+1)/2-1

1

3.264 ms

1.504 ms

 

表5-4 WMM AP パラメータ

アクセス
カテゴリ
CWmin
CWmax
AIFSN
TXOP 制限(802.11b)
TXOP 制限(802.11a/g)

AC_BK

aCWmin

aCWmax

7

0

0

AC_BE

aCWmin

4*(aCQmin+1)-1

3

0

0

AC_VI

(aCWmin+1)/2-1

aCWmin

2

6.016 ms

3.008 ms

AC_VO

(aCWmin+1)/4-1

(aCWmin+1)/2-1

2

3.264 ms

1.504 ms

異なる AIFS、CWmin、および CWmax 値が全体に及ぼす影響は、その影響が実際には統計に基づくことが多いため、タイミング ダイアグラムに示すことは困難です。AIFS とランダム バックオフ ウィンドウのサイズを比較する方が簡単です(図5-8 を参照)。

例の音声フレームとバックグラウンド フレームを比較すると、これらのトラフィック カテゴリの CWmin 値はそれぞれ 2 3 -1(7)、2 5 -1(31)で、AIFS は 2、7 です。そのため、フレームを送信するまでの遅延は、音声フレームでは平均 5(2+7/1)スロット タイム、バックグラウンド フレームでは平均 22(7+31/2)スロット タイムになります。したがって、音声フレームは統計的にはバックグラウンド フレームの前に送信される傾向がずっと強くなります。

図5-10 は、プローブ応答内の WMM 情報を示しています。この要素に含まれる WMM アクセス カテゴリ情報とは別に、クライアントはアドミッション制御を必要とする WMM カテゴリについても認識します。この例で明らかなように、音声 AC ではアドミッション制御が必須に設定されています。そのため、クライアントは要求を AP に送信し、受け入れられてからでないと、その AC を使用できません。アドミッション制御については、この章の後半で詳しく説明します。

図5-10 プローブ応答の WMM 要素情報

 

U-APSD

Unscheduled Automatic Power-Save Delivery(U-APSD; 不定期自動省電力配信)は、次の 2 つの主要な利点を持つ機能です。

U-APSD の第 1 の利点は、音声クライアントが AP との間で音声フレームの送受信を同期化できることです。それによって、クライアントは音声フレームの各タプルの送受信間に省電力モードになることができます。U-APSD をサポートしているアクセス カテゴリのフレームが WLAN クライアントから送信されると、AP はその WLAN クライアントに対してキューイングされているそのアクセス カテゴリのあらゆるデータ フレームの送信を開始します。U-APSD クライアントは、AP から End of Service Period(EOSP; サービス時間終了)ビット セットを含むフレームを受信するまで、AP の接続を待機し続けます。EOSP ビット セットによって、クライアントは省電力モードに戻れることを通知されます。このトリガー メカニズムでは、Delivery Traffic Indication Message(DTIM; 配信トラフィック通知メッセージ)間隔によって制御された間隔において、通常のビーコン方式の待機より、クライアントの電源の使用を効率化できると見なされています。なぜなら、通常の待機では、音声の遅延要件とジッタ要件から、WVoIP クライアントはコール中に省電力モードになれず、その結果通話時間が短縮されてしまうか、または DTIM 間隔が短くなり、その結果待機時間が短縮されてしまうからです。U-APSD の使用により、長時間の DTIM 間隔を使用して、コールの質を犠牲にせずにスタンバイ時間を最大限にできます。U-APSD 機能はアクセス カテゴリ全体で個別に適用できるため、AP で音声 AC に U-APSD を適用しながら、他の AC では標準の省電力機能を使用できます。

この機能の第 2 の利点は、コール キャパシティの増大です。AP からのデータ フレームをバッファされた伝送のカップリングには WLAN クライアントから取り込んだデータ フレームが含まれ、AP からのフレームはフレーム間スペースおよびランダム バックオフなしで送信できるので、コールによるコンテンションの発生を緩和します。

図5-11 は、標準 802.11 の省電力配信プロセスにおけるフレーム交換の例を示しています。

図5-11 標準のクライアント省電力

 

省電力モードにあるクライアントは、まず、AP ビーコンに TIM が存在することを検出して、AP でデータが待機していることを認識します。クライアントは、そのデータを取得するために AP を省電力ポーリング(PS-Poll)する必要があります。クライアントに送信されたデータが複数のフレームの送信を要求している場合、AP はこれを送信済みデータ フレーム内に示します。このプロセスで、クライアントは、バッファされたすべてのデータを取得するまで、AP に省電力ポーリングを送信し続ける必要があります。

これは 2 つの主要な問題点を提示しています。まず、このプロセスは、非常に非効率的で、PS ポーリングおよび通常のデータ交換を要求し、DCF に関連する標準アクセス遅延を発生します。第 2 の問題点は、音声トラフィックに対してより重大な側面となります。つまり、バッファ済みデータの取得が DTIM に依存しており、それが多様なビーコン間隔となります。標準のビーコン間隔は 100 ms であり、DTIM 間隔はこの整数の倍数となります。その結果、音声コールには通常は許容されないジッタ レベルが発生し、音声端末は、音声コールの進行中、省電力モードをフル送信に切り替えて動作を受信します。これにより、許容できる音声の質を確保できますが、バッテリの寿命は短くなります。Cisco Unified Wireless IP Phone 7921G では、ビーコンの TIM を待たずに PS ポーリング要求を生成できる PS ポーリング機能を提供することによって、この問題に対処しています。この機能により、7921G はフレームを送信したときにフレームのポーリングを実行し、その後、省電力モードに戻ることができます。この機能では U-APSD ほどの効率性は得られませんが、U-APSD を使用できない WLAN で 7921G のバッテリの寿命を伸ばすことができます。

図5-12 は、U-APSD を使用したトラフィック フローの例を示しています。この場合、トラフィックを取得するためのトリガーは AP へのクライアントのトラフィック送信です。AP は、フレームを確認すると、データがキューイングされ、待機していることをクライアントに伝えます。それにより AP はデータをクライアントへ通常は TXOP バーストとして送信します。この場合、最初のフレームだけに EDCF アクセス遅延が発生します。すべての後続のフレームは、その結果、確認応答フレームの後で直接送信されます。VoWLAN 実装では、AP でキューイングされている可能性があるフレームは 1 つだけであるため、VoWLAN クライアントはそのフレームを AP から受信した後はスリープ モードに入ることできます。

図5-12 U-APSD

 

この方法は、以前の方式の短所を両方とも克服し、はるかに効率的です。ポーリングのタイミングは、クライアント トラフィックにより制御されます。これは音声の場合には対称になるので、クライアントが 20 ms ごとにフレームを送信した場合、フレームの受信も 20 ms になると想定されます。それにより、発生する最大ジッタは、n * 100 ms ではなく 20 ms になります。

TSpec アドミッション制御

トラフィック仕様(TSpec)では、802.11e クライアントから AP にそのトラフィック要件に関する信号を送信できます。802.11e MAC 定義には、アクセスを優先させるための 2 つのメカニズムがあります。そのメカニズムとは、コンテンションベースの EDCA オプションおよび送信権(TXOP)により提供される制御されたアクセス オプションです。クライアントがそのクライアント自体のトラフィック特性を指定できる TSpec 機能とはどのようなものかを説明する場合、制御されたアクセス メカニズムが自動的に使用されるようになり、TSpec 要求に一致する特定の TXOP がクライアントに対して許可される、というのは簡単に思い浮かぶことです。しかし、それだけではありません。TSpec 要求は、EDCA のさまざまなアクセス カテゴリ(AC)の使用を制御するために使用できます。クライアントが特定の優先度タイプのトラフィックを送信できるようになる前に、TSpec メカニズムを使用してそれを要求しておく必要があります。たとえば、音声 AC を使用しようとしている WLAN クライアント デバイスは、まずその AC の使用を要求する必要があります。AC の使用を TSpec 要求で制御するかどうかは、TSpec要求により制御される音声 AC とビデオ AC では設定可能であり、ベストエフォート AC とバックグラウンド AC については TSpec 要求なしで使用できます。802.11e Hybrid Coordinated Channel Access(HCCA)ではなく EDCA AC を使用して TSpec 要求を満たすことも多くの状況で可能です。これは、トラフィック パラメータが非常に単純なため、特定の TXOP を作成してアプリケーションの要求を満たさなくても、キャパシティを割り当てることによってパラメータを満たせるためです。


) 7921G では TSpec をサポートしていますが、Cisco 7920 WVoIP 端末では TSpec アドミッション制御をサポートしていません。


Add Traffic Stream

Add Traffic Stream(ADDTS)機能は、WLAN クライアントが AP へのアドミッション要求を実行する方法です。アドミッション要求では、次の 2 つのいずれかの形式で TSpec 要求の信号が AP に送信されます。

ADDTS アクション フレーム ― これは AP にアソシエートされたクライアントが通話を開始または終了したときに発生します。ADDTS には TSpec が含まれており、Traffic Stream Rate Set(TSRS; トラフィック ストリーム レート セット)IE(Cisco Compatible Extensions v4 クライアント)が含まれる場合もあります。

アソシエーションおよび再アソシエーション メッセージ ― STA がトラフィック ストリームをアソシエーションの一部として確立しようとすると、アソシエーション メッセージには 1 つまたは複数の TSpec および 1 つの TSRS IE が含まれることがあります。STA が別の AP にローミングすると、再アソシエーション メッセージには 1 つまたは複数の TSpec および 1 つの TSRS IE が含まれることがあります。

ADDTS には、トラフィック要求を説明する TSpec 要素が含まれます。Cisco 7921 WLAN 端末と Cisco AP 間の ADDTS 要求と応答の例は、図5-13図5-14 を参照してください。データ レートおよびフレーム サイズなど、トラフィックの要件を説明する主要なデータとは別に、TSpec 要素もクライアント デバイスが使用する最小物理レートを AP に伝えます。これにより、そのステーションがどのくらいの時間を消費してこの TSpec を送受信できるかを算出でき、その結果 AP がその TSpec を満たすリソースがあるかどうかを算出できるようになります。TSpec アドミッション制御は、コールが開始されたときとローミングを要求中に WLAN クライアントにより使用されます(ターゲット クライアントは VoIP 端末)。ローミングの際には、TSpec 要求が再アソシエーション要求に追加されます。

図5-13 ADDTS 要求のデコード

 

図5-14 ADDTS 応答のデコード

 

WLAN インフラストラクチャ対応の QoS 拡張機能

Cisco Centralized WLAN アーキテクチャには、WMM サポート機能のほかに複数の QoS 機能があります。これらの機能のうち主要なものは、WLC の QoS プロファイルです。プラチナ、ゴールド、シルバー、およびブロンズの 4 つの QoS プロファイルを設定できます(図5-15 を参照)。

図5-15 QoS プロファイル オプション

 

図5-16 に示すプロファイルごとに、帯域幅の契約、RF 使用制御、および許可された最大の 802.1P 分類を設定できます。

図5-16 QoS プロファイルの設定

 

通常、ユーザごとの帯域幅契約の設定はデフォルト値のままにして、802.11 WMM 機能を使用してデファレンシエーテッド サービスを提供することをお勧めします。

特定のプロファイルを使用する WLAN に対しては、そのプロファイルの 802.1P 分類によって次の 2 つの重要な動作が制御されます。

WLC から送信されるパケットに使用する Class of Service(CoS; サービス クラス)値の決定

プロファイルに設定された CoS 値は、そのプロファイルを使用する WLAN のすべての LWAPP パケットのマーキングに使用されます。たとえば、プラチナ QoS プロファイルを使用している WLAN の場合、802.1P マークが 6 なら、コントローラの AP マネージャ インターフェイスから送信される LWAPP パケットは CoS 5 としてマーキングされます。CoS は、Cisco QoS ベースライン推奨事項に準拠するようにコントローラで調整されます。設定に IEEE CoS のマーキングを維持するのがなぜ重要かについては、次のポイントで説明します。WLC へのネットワーク接続で DSCP ではなく CoS を信頼するようにネットワークが設定されている場合、CoS 値によって AP が受信する LWAPP パケットの DSCP が決まり、さらに、この DSCP によって WLAN トラフィックの WMM 分類とキューイングが決まります(フレームの WLAN WMM 分類は、そのフレームを搬送する LWAPP パケットの DSCP 値から導出)。

その WLAN に接続したクライアントが使用できる最大 CoS 値の決定

802.1P 分類によって、そのプロファイルを使用する WLAN で許可される最大 CoS 値が設定されます。

WMM 音声トラフィックは CoS 6 で AP に着信し、CoS 6 に基づき、このトラフィックに対して CoS から DSCP へのマッピングが AP で自動的に実行されます。WLC 設定の CoS 値が 6 より小さい値に設定されている場合、この変更された値が AP の WLAN QoS プロファイルで使用されて、使用されている最大 CoS マーキングが設定され、それにより、使用する WMM AC が設定されます。

重要な点は、Unified Wireless Network では常に IEEE 802.11e 分類をベースにして考え、IEEE 分類と Cisco QoS ベースラインとの変換を Unified Wireless Network ソリューションで実行できるようにすることです。

WLAN はさまざまなデフォルト QoS プロファイルを使用して設定できます(図5-17 を参照)。各プロファイル(プラチナ、ゴールド、シルバー、およびブロンズ)は、代表的な使用に対して注釈が付けられます。さらに、クライアントには、AAA を使用して ID に基づいて QoS プロファイルを割り当てることができます。一般的な企業では、ユーザごとの帯域幅契約や Over-the-Air QoS などの WLAN 展開パラメータをデフォルト値のままにしておき、WMM および有線 QoS などの標準 QoS ツールを使用することによって、クライアントに最適な QoS を提供できます。

図5-17 WLAN QoS プロファイル

 

QoS プロファイル以外に、WLAN ごとの WMM ポリシーも制御できます(図5-18 を参照)。次の 3 つの WMM オプションがあります。

Disabled ― WLAN で WMM 機能はアドバタイズされず、WMM ネゴシエーションも許可されません。

Allowed ― WLAN で WMM クライアントと WMM 以外のクライアントが許可されます。

Required ― WMM 対応クライアントを WLAN にアソシエートできます。

図5-18 WLAN WMM ポリシー

 

IP 電話

図5-19 は、Cisco AP がアドバタイズする基本的な QoS Basis Service Set(QBSS; 基本サービス セット)情報要素(IE)を示しています。Load フィールドは、現在その AP のデータを送信するのに使用されている有効な一部の帯域幅を示しています。

図5-19 QBSS 情報要素

 

特定の状況でサポートする必要のある QBSS IE は、次の 3 つです。

旧 QBSS (草案 6 (先行標準))

新 QBSS (草案 13 802.11e(標準))

新規分散型 CAC 負荷の IE(シスコの IE)

使用する QBSS は WLAN 上の WMM および 7920 の設定に依存します。

7920 電話のサポートは、図5-18 に図示されているように、WLC WLAN 構成のコンポーネントです。これにより、AP にビーコンの適切な QBSS 要素を含めることができます。7920 や 7921G など、QoS 要件のある WLAN クライアントは、これらのアドバタイズされた QoS パラメータを使用して、アソシエートすべき最良の AP を決定します。

WLC は、クライアント Call Admission Control(CAC; コール アドミッション制御)制限または AP CAC 制限を使用して 7920 をサポートします。これらの機能は、次のとおりです。

クライアント CAC 制限 ― 7920 は、クライアントに設定されたコール アドミッション制御設定を使用します。これは、2.01 以前の旧 7920 コードをサポートします。

AP CAC 制限 ― 7920 は、WLAN アドバタイズメントから習得したコール アドミッション制御設定を使用します。

WMM、クライアント CAC 制限、および AP CAC 制限のさまざまな組み合わせにより、次のように異なった QBSS IE が送信されます。

WMM だけが有効な場合、IE 番号 2(802.11e 標準)QBSS Load IE がビーコン応答とプローブ応答で送信されます。

7920 クライアント CAC 制限がサポートされる場合、IE 番号 1(以前の標準 QBSS IE)が BG 無線のビーコン応答とプローブ応答で送信されます。

7920 AP CAC 制限がサポートされる場合、IE 番号 3 QBSS IE が BG 無線のビーコンとプローブ応答で送信されます。


) さまざまな QBSS IE が同一の ID を使用するので、これらの 3 つの QBSS は相互に排他的です。たとえば、ビーコン応答およびプローブ応答には 1 つの QBSS IE だけを含めることができます。


アドミッション制御パラメータの設定

図5-20 は、コントローラの音声パラメータ設定の設定画面の例を示しています。

図5-20 音声パラメータの設定

 

アドミッション制御パラメータは、無線が対応でき、通常の ADDTS 要求により VoWLAN コールを開始させることができる、最大 RF 帯域幅で構成されています。

Reserved Roaming Bandwidth は、その AP にローミングしようとしている通話中の VoWLAN クライアントに対して、アソシエーションまたは再アソシエーション時の ADDTS に応答できるようにどれだけのキャパシティを取っておくかを設定します。

これらのパラメータに基づいてアドミッション制御を有効にするには、Admission Control (ACM) チェックボックスをオンにします。それによって、AP のキャパシティに基づくアドミッション制御が有効化されますが、エリア内の他の AP のチャネル負荷の影響の可能性は考慮されません。キャパシティ計算にこの「チャネル負荷」を算入するには、Admission Control(ACM) チェックボックスと共に Load-Based AC チェックボックスをオンにします。

Metrics Collection オプションでは、音声コールまたはビデオ コールのデータを収集して、WCS で使用できるようにするかどうかを指定します。

図5-21 は、WCS で使用できる音声統計レポートの一例を示しています。レポート内容は、1 つの AP の無線で確立されたコールと、その AP にローミングしたコール数です。このレポートおよび他の音声統計は、スケジュール設定するか、または一時的に使用できるほか、グラフィック表示またはデータ ファイルとして公開が可能です。

図5-21 WCS の音声統計

 


) コール アドミッション制御は、音声およびビデオ QoS プロファイルのためにだけ実行されます。


TSpec アドミッション制御の影響

TSpec アドミッション制御の目的は、WLAN へのクライアント アクセスを拒否することではなく、優先度の高いリソースを保護することです。したがって、TSpec アドミッション制御を使用していないクライアントが、そのトラフィックをブロックされることはありません。トラフィックを送信しようとしたときに、単にトラフィックが再分類されるだけです(そのクライアントが保護された AC で WMM に準拠したトラフィック送信する場合は不適切)。

表5-5 表5-6 は、アクセス制御が有効化されている場合の分類への影響をトラフィック ストリームが確立されているかどうかに基づいて示しています。

 

表5-5 アップストリーム トラフィック

確立されたトラフィック ストリーム
トラフィック ストリームなし

アドミッション制御なし

動作に変化なく、パケットは従来どおりネットワークに送信されます。UP は max = WLAN QoS 設定に制限されます。

動作に変化なく、パケットは従来どおりネットワークに送信されます。UP は max = WLAN QoS 設定に制限されます。

アドミッション制御

動作に変化なく、パケットは従来どおりネットワークに送信されます。UP は max = WLAN QoS 設定に制限されます。

パケットが WMM クライアントのネットワークに入ってから、パケットについて BE(CoS および DSCP の両方)に対してリマークされます。WMM 以外のクライアントに対して、パケットは WLAN QoS と共に送信されます。

 

表5-6 ダウンストリーム トラフィック

確立されたトラフィック ストリーム
トラフィック ストリームなし

アドミッション制御なし

変化なし

変化なし

アドミッション制御

変化なし

UP について WMM クライアントの BE に対してリマークします。WMM 以外のクライアントに対して、WLAN QoS を使用します。

802.11e、802.1P、および DSCP のマッピング

Unified Wireless Network 内の WLAN データは LWAPP(IP UDP パケット)を介してトンネリングされます。WLAN フレームに適用された QoS 分類を維持するためには、DSCP と CoS 間の分類のマッピング プロセスが必要になります。

たとえば、WLAN クライアントから WMM で分類されたトラフィックが送信された場合、このトラフィック フレームには 802.1P 分類が含まれています。AP はこの分類を DSCP 値に変換する必要があります。それによって、このフレームを伝送する LWAPP パケットが WLC へ達するまでの間、適切な優先度で確実に処理されるようになります。AP に送信される LWAPP パケットの場合も、同様のプロセスが WLC で必要です。

WMM 以外のクライアントからのトラフィックを分類するメカニズムも必要です。それによって、WMM 以外のクライアントの LWAPP パケットにも AP および WLC によって適切な DSCP 分類が割り当てられます。

図5-22 は、LWAPP WLAN ネットワークのさまざまな分類メカニズムを示しています。

図5-22 WMM と 802.1P との関係

 

複数の分類メカニズムとクライアントの機能には、複数の戦略が必要です。

LWAPP 制御フレームには優先順位が必要です。LWAPP 制御フレームは CS6 の DSCP 分類でマーク付けされます。

WMM を有効化したクライアントは、WLC への LWAPP パケットに対する該当 DSCP 分類へマップされたフレームの分類が割り当てられています。このマッピングは、QoS ベースラインへの準拠に必要な変更を除いて、IEEE CoS から DSCP へのマッピングの標準に従っています。この DSCP 値は、WLC において、WLC インターフェイスから発信される 802.1Q フレーム上で CoS 値に変換されます。

WMM 以外のクライアントには、その WLAN のデフォルトの QoS プロファイルに一致するよう設定された LWAPP トンネルの DSCP があります。7920 電話をサポートする WLAN の QoS プロファイルがプラチナに設定されている場合、その WLAN からのデータ フレーム パケットについても EF の DSCP 分類となります。

WLC からの LWAPP データ パケットには、WLC へ送信された有線データ パケットの DSCP によって決定される DSCP 分類があります。AP から WMM クライアントへのフレーム送信時に使用される 802.11.e 分類は、DSCP 分類から WMM 分類へ変換する AP テーブルによって決定されます。


) AP から WLAN クライアントに送信されるトラフィックに使用される WMM 分類は、LWAPP パケットの DSCP 値に基づき、含まれている IP パケットの DSCP 値には基づきません。そのため、エンドツーエンドの QoS システムの整備が重要になります。


QoS ベースラインの優先度のマッピング

LWAPP AP と WLC で QoS ベースラインの変換が実行されることによって、 表5-7 に示す WMM 値は IEEE 値ではなく適切な QoS ベースライン DSCP 値にマッピングされます。

 

表5-7 アクセス ポイントの QoS 変換値

AVVID 802.1 UP ベースの
トラフィック タイプ
AVVID IP DSCP
AVVID 802.1p UP
IEEE 802.11e UP

ネットワーク制御

-

7

-

ネットワーク間制御(LWAPP 制御、802,11 管理)

48

6

7

音声

46(EF)

5

6

ビデオ

34(AF41)

4

5

音声制御

26(AF31)

3

4

バックグラウンド(ゴールド)

18(AF21)

2

2

バックグラウンド(ゴールド)

20(AF22)

2

2

バックグラウンド(ゴールド)

22(AF23)

2

2

バックグラウンド(シルバー)

10(AF11)

1

1

バックグラウンド(シルバー)

12(AF12)

1

1

バックグラウンド(シルバー)

14(AF13)

1

1

ベストエフォート

0(BE)

0

0, 3

バックグラウンド

2

0

1

バックグラウンド

4

0

1

バックグラウンド

6

0

1

LWAPP ベースの AP への QoS 機能の展開

WLAN QoS を AP に展開する場合には、次の事項を検討します。

有線 LWAPP AP は、レイヤ 2 CoS(802.1P)情報の読み書きを実行します。WLC と AP はレイヤ 3 分類(DSCP)情報に基づいて WLAN クライアントのトラフィック分類を伝達します。この DSCP 値は中間ルータによって変更される可能性があるため、宛先が受信する レイヤ 2 分類は、LWAPP トラフィックの送信元でマーキングされたレイヤ 2 分類を示していないことがあります。

AP では NULL VLAN ID は使用されなくなりました。そのため、L2 LWAPP は、事実上 QoS をサポートしていません。これは、AP が 802.1P/Q タグを送らず、L2 LWAPP にはフォールバックする外部 DSCP がないためです。

AP では、フレームを再分類するのではなく、CoS 値または WLAN プロファイルに基づいて優先度を決定します。

AP では、無線出力ポートでのみ EDCF のようなキューイングを実行します。

AP では、イーサネット出力ポートでのみ FIFO キューイングを実行します。

WAN QoS と H-REAP

WLC に転送されるデータ トラフィックがある WLAN の場合、動作は Hybrid Remote Edge Access Point(H-REAP; ハイブリッド リモート エッジ アクセス ポイント)以外の AP と同じです。WMM トラフィックがある、ローカルにスイッチされた WLAN の場合、AP でアップストリーム トラフィックに対して dot1q VLAN タグに dot1p 値がマーキングされます。これはタグ付き VLAN 上でだけ発生し、ネイティブ VLAN では発生しません。

ダウンストリーム トラフィックに対しては、H-REAP で、イーサネット側から受信した dot1q タグに基づき、ローカルにスイッチされた VLAN の無線で WMM 値のキューイングとマーキングが行われます。

WLAN QoS プロファイルはアップストリームとダウンストリームの両方のパケットに適用されます。ダウンストリームの場合、デフォルトの WLAN 値より高い 802.1P 値を受信したときには、デフォルトの WLAN 値が使用されます。クライアントがデフォルト WLAN 値より高い WMM 値を送信した場合、アップストリームでは、デフォルト WLAN 値が使用されます。WMM 以外のトラフィックの場合、AP からのクライアント フレームには CoS マーク付けはありません。


) 現在、バグ CSCsi78368 が WLC からのトラフィックの CoS マーキングに影響を及ぼしており、WLC から送信されたフレームにマーキングされている CoS が、QoS プロファイルによって設定された値を示し、クライアントがマーキングした WMM CoS を示していません。


無線 QoS 展開のガイドライン

有線ネットワークにおける QoS 展開のルールが、無線ネットワークの QoS 展開にも適用されます。QoS 展開でまず最も重要なガイドラインは、自分のトラフィックを理解することです。プロトコル、遅延に対するアプリケーションの影響度、およびトラフィックの帯域幅について理解してください。QoS によって帯域幅が増えるわけではありません。QoS では単に、帯域幅の割り当てに対する制御が強化されます。

スループット

802.11 QoS 展開で重要な検討事項は、ビット レートだけではなくフレーム サイズの視点から、提供されたトラフィックを理解することです。これは、802.11 スループットが提供されたトラフィックのフレーム サイズに敏感に反応するためです。

表5-8 は、フレーム サイズがスループットに及ぼす影響を示しています。パケットのサイズが小さくなると、スループットも減少します。たとえば、3Mbps のレートでトラフィックを提供するアプリケーションが 11 Mbps 802.11b ネットワーク上で展開されているときに、使用するフレーム サイズの平均が 300 バイトの場合、AP 上で QoS をどのように設定してもアプリケーションのスループット要件を達成できません。これは、802.11b が、そのスループットとフレーム サイズの組み合わせでは要求されたスループットをサポートできないからです。1,500 バイトのフレーム サイズを持つ、同じ量の提供されたトラフィックでは、この問題は発生しません。

 

表5-8 フレーム サイズで比較したスループット

300
600
900
1200
1500
フレーム サイズ(バイト)

11g - 54 Mbps

11.4

19.2

24.6

28.4

31.4

スループットの Mbps

11b - 11 Mbps

2.2

3.6

4.7

5.4

6

スループットの Mbps

LAN スイッチにおける QoS の設定例

AP スイッチの設定

AP スイッチの場合、AP から渡される LWAPP パケットの DSCP を信頼する必要があるため、AP スイッチでの QoS 設定は比較的単純です。AP から送られてくる LWAPP フレームには CoS のマーキングはありません。この設定の例を以下に示します。なお、この設定では分類のみ行っています。ローカルの QoS ポリシーに応じて、必要ならキューイング コマンドを追加してください。

interface GigabitEthernet1/0/1
switchport access vlan 100
switchport mode access
mls qos trust dscp
spanning-tree portfast
end
 

AP DSCP 値を信頼する点においては、アクセス スイッチは WLC によりそのスイッチに対して設定されたポリシーを単に信頼しているだけです。クライアント トラフィックに割り当てられた最大 DSCP 値は、その AP 上で WLAN に割り当てられた QoS ポリシーに基づきます。

WLC スイッチの設定

WLC 接続スイッチでの QoS 分類決定は、AP 接続スイッチの場合に比べて多少複雑です。これは、WLC から送られてくるとトラフィックの DSCP を信頼するか、CoS を信頼するかの選択が可能なためです。この決定では、以下の点を考慮する必要があります。

WLC から発信されるトラフィックは、アップストリーム(WLC またはネットワークに送信)か、またはダウンストリーム(AP および WLAN クライアントに送信)です。ダウンストリーム トラフィックは LWAPP でカプセル化されています。アップストリーム トラフィックは AP および WLAN クライアントからのトラフィックであり、WLC から発信された、LWAPP カプセル化またはカプセル開放された WLAN クライアント トラフィックです。

LWAPP パケットの DSCP 値は WLC 上の QoS ポリシーによって制御されます。LWAPP トンネル ヘッダーによってカプセル化された WLAN クライアント トラフィックに設定されている DSCP 値は、WLAN クライアントによって設定された値から変更されていません。

WLC から発信されるフレームの CoS 値は、アップストリーム/ダウンストリーム、カプセル化/カプセル開放の別にかかわらず、WLC の QoS ポリシーによって設定されます。

以下の例では、WLC の設定の CoS を信頼することを選択しています。この選択の理由は、この場合、WLAN QoS を集中管理できるため、WLC 設定の他に WLC スイッチ接続で追加のポリシーを管理する必要がないことです。より詳細な制御を必要とする場合は、WLAN クライアントの VLAN 上で QoS 分類ポリシーを実装してください。

interface GigabitEthernet1/0/13
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 11-13,60,61
switchport mode trunk
mls qos trust cos
end
 

トラフィック シェーピング、Over-the-Air QoS、および WMM クライアント

トラフィック シェーピングと Over-the-Air QoS は、WLAN WMM 機能がない場合には有用なツールですが、802.11 トラフィックの優先順位付けに直接対応しているわけではありません。WMM クライアントまたは 7920 端末をサポートする WLAN では、これらのクライアントの WLAN QoS メカニズムに頼ってください。これらの WLAN には、トラフィック シェーピングも Over-the-Air QoS も適用しないでください。

WLAN 音声および Cisco 7921G と 7920

Cisco 7921G と Cisco 7920 は Cisco の VoWLAN 端末です。WLAN に QoS を展開する一般的な理由の 1 つとして、これらの端末の使用があります。

それぞれの端末の詳細は、以下の資料を参照してください。

Cisco Unified Wireless IP Phone 7921G バージョン 1.0(2)―
http://www.cisco.com/en/US/products/hw/phones/ps379/products_data_sheet0900aecd805e315d.html

Cisco Unified Wireless IP Phone 7920 バージョン 3.0 ―
http://www.cisco.com/en/US/products/hw/phones/ps379/products_data_sheet09186a00801739bb.html

VoWLAN インフラストラクチャを展開する場合、単に WLAN に QoS を提供するだけでよいわけではありません。音声 WLAN では、サイト調査のカバレッジ要件、ユーザの挙動、ローミング要件、およびアドミッション制御について検討する必要があります。これらの要件については、以下のガイドで説明しています。

『Design Principles for Voice Over WLAN』―
http://www.cisco.com/en/US/solutions/collateral/ns340/ns394/ns348/net_implementation_white_paper0900aecd804f1a46.html

『Cisco Wireless IP Phone 7920 Design and Deployment Guide』―
http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/7920/5_0/english/design/guide/7920ddg.html

WAN 接続を介した LWAPP

この項では、LWAPP AP が 図5-23 のように WAN リンクを介して展開されているときの QoS 戦略について説明します。

図5-23 WAN 経由の LWAPP トラフィック

 

LWAPP トラフィックの分類

LWAPP AP は、通常、次の 2 つのタイプに分類されます。

LWAPP コントロール トラフィック ― UDP ポート 12223 によって識別

LWAPP 802.11 トラフィック ― UPD ポート 12222 によって識別

LWAPP コントロール トラフィック

LWAPP コントロール トラフィックは、通常、次の 2 つの追加タイプに分類されます。

初期化トラフィック ― LWAPP AP がブートして LWAPP システムに接続するときに生成されます。たとえば、コントローラの検出、AP 設定、AP ファームウェアの更新によって生成されるトラフィックなどです。


) コントローラからの LWAPP イメージ パケットはベストエフォートとしてマーキングされますが、その確認応答は CS6 としてマーキングされます。この場合、プロトコルのウィンドウ機能はなく、各追加パケットは確認応答を受信してからでないと送信されません。このタイプのハンドシェイクでは、WAN からのファイルのダウンロードの影響が最小化されます。


バックグラウンド トラフィック ― WLAN ネットワークのメンバとして動作している LWAPP AP によって生成されます。たとえば、LWAPP ハートビート、RRM、不正 AP 測定値などです。バックグラウンド LWAPP コントロール トラフィックは、CS6 としてマーキングされます。

図5-24図5-25 は、初期 LWAPP コントロール メッセージの例を示しています。図5-26図5-27、および 図5-28 は、バックグラウンド LWAPP コントロール メッセージの例を示しています。

初期 LWAPP コントロール メッセージの完全なリストには、次のものが含まれています。

LWAPP discovery メッセージ

LWAPP join メッセージ

LWAPP config メッセージ

初期 LWAPP RRM メッセージ

この項では AP イメージ ダウンロードについても触れていますが、通常、これは AP 初期化には含まれず、ファームウェアの変更時にのみ発生します。

図5-24 LWAPP 検出メッセージ

 

図5-25 LWAPP イメージ応答

 

図5-26 LWAPP ハートビート メッセージ

 

図5-27 LWAPP 統計

 

図5-28 LWAPP RRM

 

LWAPP 802.11 トラフィック

LWAPP 802.11 コントロール トラフィックは、通常、次の 2 つの追加タイプに分類されます。

802.11 管理フレーム ― プローブ要求やアソシエーション要求および応答などの 802.11 管理フレームは、自動的に DSCP CS6 として分類されます。

801.11 データ フレーム ― クライアント データとクライアントからの 802.1X データは、WLAN の QoS 設定に従って分類されますが、WLC から送られる 802.1X フレーム入りのパケットは CS4 としてマークキングされます。802.11 データ トラフィック分類は、WLAN 設定に適用されている QoS に依存します。また、自動設定はされません。WLAN データ トラフィックのデフォルトの分類はベストエフォートです。

分類に関する考慮事項

LWAPP コントロール トラフィックに使用される DSCP 分類は CS6 です。これは BGP(ボーダー ゲートウェイ プロトコル)、OSPF(Open Shortest Path First)、EIGRP(Enhanced IGRP)などの IP ルーティング プロトコルに使用される IP ルーティング クラスです。

現在の LWAPP DSCP 分類では、WLAN システムにとって最適な分類を表現していますが、各カスタマーの QoS ポリシーやニーズと一致しない可能性があります。

特に例を挙げると、WLAN ネットワークで生成される CS6 に分類されるトラフィックの量を最小化することを望むカスタマーもいます。このようなカスタマーは、プローブ要求などのクライアント アクティビティによる CS6 トラフィックの生成を停止させる必要がある場合があります。これを実行する最も簡単なメカニズムは、LWAPP 802.11 CS6 トラフィックを別の DSCP に再分類することです。LWAPP UDP の使用ポートが LWAPP データの使用ポートとは異なるため、deep packet inspection の助けを借りなくても DSCP のデフォルトのマーキングによって、このトラフィックをマーキングしなおすことができます。

また、カスタマーによっては、LWAPP 初期化トラフィックがルーティング トラフィックに絶対に影響しないようにする必要があることもあります。そのための最も簡単なメカニズムは、バックグラウンド レートを超えた LWAPP コントロール トラフィックに対して優先度を低くしたマーキングをすることです。

LWAPP トラフィックの量

Cisco のテストで、AP ごとのバックグラウンド トラフィックの平均はおよそ 305 ビット/秒であることがわかっています。

AP ごとの初期トラフィック平均の計算はもっと難しくなります。これは、それぞれの AP がリブートしてから稼働状態になるまでの時間が、WAN の速度および WLC と AP に依存するためです。実際には、この差はごくわずかです。ラボ テスト ネットワークでの最適な初期トラフィックの場合、18 秒間で平均 2614 ビット/秒になる可能性があります。RTT が 100 ms の WAN リンクでは、20.3 秒間で平均 2318 ビット/秒になります。

ルータ設定の例

この項では、CS6 のマーキング変更または LWAPP コントロール トラフィックの負荷に対処する場合のガイドラインとして使用できるルータ設定の例を示します。

この例では、192.168.101.0/24 サブネット上で LWAPP AP を使用し、AP マネージャを備える WLC を 192.168.60.11 と 192.168.62.11 で使用しています。

クライアントが生成した CS6 パケットのマーキング変更

次の例では、CS6 としてマーキングされた LWAPP データ パケットをより適切な値である CS3 にマーキングしなおすための設定例を示しています。このマーキング変更によって、ネットワーク制御のレベルではなくコール制御のレベルで、トラフィックの分類がより適切な分類に変更されます。

class-map match-all LWAPPDATACS6
match access-group 110
match dscp cs6
!
policy-map LWAPPDATACS6
class LWAPPDATACS6
set dscp cs3
!
interface FastEthernet0
ip address 192.168.203.1 255.255.255.252
service-policy input LWAPPDATACS6
!
access-list 110 remark LWAPP Data
access-list 110 permit udp 192.168.101.0 0.0.0.255 host 192.168.60.11 eq 12222
access-list 110 permit udp 192.168.101.0 0.0.0.255 host 192.168.62.11 eq 12222
access-list 111 remark LWAPP Control
access-list 111 permit udp 192.168.101.0 0.0.0.255 host 192.168.60.11 eq 12223
access-list 111 permit udp 192.168.101.0 0.0.0.255 host 192.168.62.11 eq 12223
 

定義済みのレートを超えた LWAPP コントロール トラフィックの DSCP の変更

次の例では、WAN サイトから送られる LWAPP コントロール トラフィックのレートを制限して、CS6 としてマーキングされたコントール トラフィックがルーティング トラフィックに及ぼす影響を最小化するための設定例を示しています。レート制限の設定では、非準拠のトラフィックが削除されるのではなく、単に再分類されます。


) この設定は例であり、推奨ではありません。普通の状況では、WAN 接続を介した AP 展開の設計ガイドラインに従っていれば、LWAPP コントロール トラフィックが WAN ルーティング プロトコル接続に影響する可能性はほとんどありません。


interface Serial0
ip address 192.168.202.2 255.255.255.252
rate-limit output access-group 111 8000 3000 6000 conform-action transmit exceed-action set-dscp-transmit 26
access-list 111 remark LWAPP Control
access-list 111 permit udp 192.168.101.0 0.0.0.255 host 192.168.60.11 eq 12223
access-list 111 permit udp 192.168.101.0 0.0.0.255 host 192.168.62.11 eq 12223
!

 

WLAN QoS と 802.11e の詳細は、『IEEE 802.11 Handbook, A designers companion (second edition)』(Bob O'Hara and Al Petrick 著)を参照してください。