ip msdp から M
ip msdp から M
発行日;2013/07/24   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

ip msdp から M

ip msdp default-peer

この発信元からのすべてのマルチキャスト発信元検出プロトコル(MSDP)Source-Active(SA)メッセージを受け入れるデフォルト ピアを定義するには、グローバル コンフィギュレーション モードで ip msdp default-peer コマンドを使用します。 デフォルト ピアを削除するには、このコマンドの no 形式を使用します。

ip msdp [ vrf vrf-name ] default-peer { peer-address | peer-name } [ prefix-list list ]

no ip msdp [ vrf vrf-name ] default-peer

構文の説明

vrf

(任意)マルチキャスト VPN ルーティングおよび転送(VRF)インスタンスをサポートします。

vrf-name

(任意)VRF に割り当てられた名前。

peer-address peer-name

MSDP デフォルト ピアの IP アドレスまたはドメイン ネーム システム(DNS)。

prefix-list list

(任意)list 引数で指定されたリスト内のプレフィックス専用のデフォルト ピアになるようにピアを指定するボーダー ゲートウェイ プロトコル(BGP)プレフィックス リストを指定します。 BGP プレフィックス リストは、この prefix-list list キーワードおよび引数が有効になるように設定する必要があります。

コマンド デフォルト

MSDP のデフォルト ピアは存在しません。

コマンド モード

グローバル コンフィギュレーション

コマンド履歴

リリース

変更内容

12.0(7)T

このコマンドが導入されました。

12.0(23)S

vrf キーワードと vrf-name 引数が追加されました。

12.2(13)T

vrf キーワードと vrf-name 引数が追加されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(18)SXE

このコマンドのサポートが Supervisor Engine 720 に追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

使用上のガイドライン

使用する MSDP ピアが BGP ピアにはならないように設定する場合は、ip msdp default-peer コマンドを使用します。

MSDP ピアが 1 つだけ設定されている場合(ip msdp peer コマンドにより)は、これがデフォルト ピアとして使用されます。 したがって、このコマンドにデフォルト ピアを設定する必要はありません。

prefix-list list キーワードと引数を指定しないと、設定したデフォルト ピアから受信したすべての SA メッセージが受け入れられます。

ip msdp default-peer コマンドで prefix-list list キーワードおよび引数を設定するつもりの場合は、必ず BGP プレフィクッス リストを設定してください。

prefix-list list キーワードおよび引数を指定した場合、prefix-list list キーワードおよび引数で指定されたランデブー ポイント(RP)から発信された SA メッセージは、設定したデフォルト ピアから受信されます。 prefix-list list キーワードおよび引数を指定する一方でプレフィックス リストが設定されていない場合、デフォルト ピアはすべてのプレフィックスに使用されます。

次のように、複数の ip msdp default-peer コマンドを prefix-list キーワードありで(またはなしで)入力できます。 ただし、すべてのコマンドでキーワードを付加するかまたは付加しないかを決める必要があります。

  • prefix-list キーワードが指定された ip msdp default-peer コマンドを複数使用すると、異なる RP プレフィックスに対してすべてのデフォルト ピアが同時に使用されます。 この構文は通常、スタブ サイト クラウドに接続されたサービス プロバイダー クラウドで使用されます。
  • 複数の ip msdp default-peer コマンドを prefix-list キーワードなしで使用すると、単一のアクティブ ピアを使用してすべての SA メッセージが受信されます。 このピアが停止すると、次の設定済みデフォルト ピアですべての SA メッセージが受信されます。 この構文は通常、スタブ サイトで使用されます。

次に、IP アドレス 192.168.1.3 のルータをローカル ルータのデフォルト ピアとして設定する例を示します。

ip msdp peer 192.168.1.3
ip msdp peer 192.168.3.5
ip msdp default-peer 192.168.1.3

次に、2 台のデフォルト ピアを設定する例を示します。

ip msdp peer 172.18.2.3
ip msdp peer 172.19.3.5
ip msdp default-peer 172.18.2.3 prefix-list site-c
ip prefix-list site-a permit 172.18.0.0/16
ip msdp default-peer 172.19.3.5 prefix-list site-a
ip prefix-list site-c permit 172.19.0.0/16

関連コマンド

コマンド

説明

ip msdp peer

MSDP ピアを設定します。

ip prefix-list

プレフィックス リストを作成します。

ip msdp description

マルチキャスト発信元検出プロトコル(MSDP)ピアの設定に説明文を追加するには、グローバル コンフィギュレーション モードで ip msdp description コマンドを使用します。 説明を削除するには、このコマンドの no 形式を使用します。

ip msdp [ vrf vrf-name ] description { peer-name | peer-address } text

no ip msdp [ vrf vrf-name ] description { peer-name | peer-address }

構文の説明

vrf

(任意)マルチキャスト VPN ルーティングおよび転送(VRF)インスタンスをサポートします。

vrf-name

(任意)VRF に割り当てられた名前。

peer-name peer-address

この説明を適用するピアの名前およびアドレス。

text

MSDP ピアの説明。

コマンド デフォルト

MSDP ピアに説明文は関連付けられていません。

コマンド モード

グローバル コンフィギュレーション

コマンド履歴

リリース

変更内容

12.0(7)T

このコマンドが導入されました。

12.0(23)S

vrf キーワードと vrf-name 引数が追加されました。

12.2(13)T

vrf キーワードと vrf-name 引数が追加されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(18)SXE

このコマンドのサポートが Supervisor Engine 720 に追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

使用上のガイドライン

MSDP ピアを識別しやすくするために、説明を設定します。 この説明は、show ip msdp peer コマンドの出力に表示されます。

次の例では、カスタマー A のルータであることを示す説明を付加して、IP アドレス 172.17.1.2 のルータを設定する方法を示します。

ip msdp description 172.17.1.2 router at customer a

関連コマンド

コマンド

説明

show ip msdp peer

MSDP ピアに関する詳細情報を表示します。

ip msdp filter-sa-request

グループからの新規加入者がアクティブになるときに Source-Active(SA)要求メッセージをマルチキャスト発信元検出プロトコル(MSDP)ピアに送信するようにルータを設定するには、グローバル コンフィギュレーション モードで ip msdp filter-sa-request コマンドを使用します。 このアクションを防止するには、このコマンドの no 形式を使用します。

ip msdp [ vrf vrf-name ] filter-sa-request { peer-address | peer-name } [ list access-list ]

no ip msdp [ vrf vrf-name ] filter-sa-request { peer-address | peer-name }

構文の説明

vrf

(任意)マルチキャスト VPN ルーティングおよび転送(VRF)インスタンスをサポートします。

vrf-name

(任意)VRF に割り当てられた名前。

peer-address | peer-name

グループの新規加入者がアクティブになった場合に、ローカル ルータが SA メッセージを要求する MSDP ピアの IP アドレスまたは名前。

list access-list

(任意)マルチキャスト グループ アドレスを説明する標準 IP アクセス リストの番号または名前を指定します。 アクセス リストが指定されなければ、すべての SA 要求メッセージが無視されます。

コマンド デフォルト

デフォルトでは、ルータはピアからのすべての SA 要求メッセージを受け入れます。 このコマンドが設定されていない場合は、すべての SA 要求メッセージが受け入れられます。 このコマンドが設定されてもアクセス リストが指定されない場合、すべての SA 要求メッセージは無視されます。

コマンド モード

グローバル コンフィギュレーション

コマンド履歴

リリース

変更内容

12.0(7)T

このコマンドが導入されました。

12.0(23)S

vrf キーワードと vrf-name 引数が追加されました。

12.2(13)T

vrf キーワードと vrf-name 引数が追加されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(18)SXE

このコマンドのサポートが Supervisor Engine 720 に追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

使用上のガイドライン

デフォルトでは、ルータはピアからのすべての SA 要求メッセージを受け入れます。 ルータがどの SA 要求メッセージを受け入れるのかを制御する場合は、このコマンドを使用します。

アクセス リストが指定されなければ、すべての SA 要求メッセージが無視されます。 アクセス リストが指定された場合、許可されたグループからの SA 要求メッセージだけが受け入れられ、他のすべての SA 要求メッセージは無視されます。

次の例では、172.16.2.2 の MSDP ピアからの SA 要求メッセージをフィルタリングするように、ルータを設定する方法を示します。 ネットワーク 192.168.22.0 にある送信元からの SA 要求メッセージはアクセス リスト 1 を通過して受け入れられます。それ他のすべてのメッセージは無視されます。

ip msdp filter-sa-request 172.16.2.2 list 1
access-list 1 permit 192.4.22.0 0.0.0.255

関連コマンド

コマンド

説明

ip msdp peer

MSDP ピアを設定します。

ip msdp mesh-group

マルチキャスト発信元検出プロトコル(MSDP)ピアがメッシュ グループのメンバとなるよう設定するには、グローバル コンフィギュレーション モードで ip msdp mesh-group コマンドを使用します。 メッシュ グループから MSDP ピアを削除するには、このコマンドの no 形式を使用します。

ip msdp [ vrf vrf-name ] mesh-group mesh-name { peer-address | peer-name }

no ip msdp [ vrf vrf-name ] mesh-group mesh-name { peer-address | peer-name }

構文の説明

vrf

(任意)マルチキャスト VPN ルーティングおよび転送(VRF)インスタンスをサポートします。

vrf-name

(任意)VRF に割り当てられた名前。

mesh-name

メッシュ グループ名。

peer-address | peer-name

メッシュ グループのメンバーとなる MSDP ピアの IP アドレスまたは名前。

コマンド デフォルト

MSDP ピアは、メッシュ グループに属しません。

コマンド モード

グローバル コンフィギュレーション

コマンド履歴

リリース

変更内容

12.0(7)T

このコマンドが導入されました。

12.0(23)S

vrf キーワードと vrf-name 引数が追加されました。

12.2(13)T

vrf キーワードと vrf-name 引数が追加されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(18)SXE

このコマンドのサポートが Supervisor Engine 720 に追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

使用上のガイドライン

メッシュ グループは MSDP スピーカーのグループであり、相互に完全メッシュ接続されています。 メッシュ グループ内のピアから受信された Source-Active(SA)メッセージは、同じメッシュ グループ内の他のピアに転送されません。

メッシュ グループは、次の 2 つの目的に使用されます。

  • SA メッセージ フラッディングを低減する
  • ピア リバース パス転送(RPF)フラッディングの単純化(MSDP ピア間でのボーダー ゲートウェイ プロトコル(BGP)またはマルチプロトコル BGP の実行は不要)

次に、internal という名前のメッシュ グループのメンバにするために、アドレス 192.168.1.3 の MSDP ピアを設定する方法を示します。

ip msdp mesh-group internal 192.168.1.3

ip msdp peer

マルチキャスト発信元検出プロトコル(MSDP)ピアを設定するには、グローバル コンフィギュレーション モードで ip msdp peer コマンドを使用します。 ピア関係を削除するには、このコマンドの no 形式を使用します。

ip msdp [ vrf vrf-name ] peer { peer-name | peer-address } [ connect-source interface-type interface-number ] [ remote-as as-number ]

no ip msdp [ vrf vrf-name ] peer { peer-name | peer-address }

構文の説明

vrf

(任意)マルチキャスト VPN ルーティングおよび転送(VRF)インスタンスをサポートします。

vrf-name

(任意)VRF に割り当てられた名前。

peer-name peer-address

MSDP ピアとなるルータのドメイン ネーム システム(DNS)名または IP アドレス。

connect-source interface-type interface-number

(任意)プライマリ アドレスが TCP 接続の送信元 IP アドレスとなるインターフェイスのタイプおよび番号を指定します。 このインターフェイスは、設定されるルータ上にあります。

remote-as as-number

(任意)MSDP ピアの自律システム番号を指定します。 このキーワードと引数は、表示目的だけに使用されます。

コマンド デフォルト

MSDP ピアは設定されていません。

コマンド モード

グローバル コンフィギュレーション

コマンド履歴

リリース

変更内容

12.0(7)T

このコマンドが導入されました。

12.0(23)S

vrf キーワードと vrf-name 引数が追加されました。

12.2(13)T

vrf キーワードと vrf-name 引数が追加されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(18)SXE

このコマンドのサポートが Supervisor Engine 720 に追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

使用上のガイドライン

指定されたルータは、BGP ネイバーとしても設定される必要があります。

interface-type は、設定されるルータ上にあります。

この MSDP ピアとともに BGP ピアリングも使用する場合は、BGP と同一の IP アドレスを MSDP に使用する必要があります。 ただし、MSDP ピア間に BGP または MBGP パスがある場合は、MSDP ピアとともに BGP またはマルチプロトコル BGP を実行する必要はありません。 パスがない場合は、ip msdp default-peer コマンドを設定する必要があります。

remote-as as-number キーワードおよび引数は、表示目的だけに使用されます。

あるピアで MSDP ピアリング セッションはあり BGP ピア セッションがない場合、このピアが他の自律システム(実際とは異なる)に存在するように表示される場合があります。 この場合、他の自律システムにより投入されたピアのプレフィックスは、ピアの AS 番号のように表示されます。

次に、IP アドレス 192.168.1.2 のルータをローカル ルータに対する MSDP ピアとして設定する例を示します。 ネイバーは、自律システム 109 に属しています。

ip msdp peer 192.168.1.2 connect-source ethernet 0/0
router bgp 110
 network 192.168.0.0
 neighbor 192.168.1.2 remote-as 109
 neighbor 192.168.1.2 update-source ethernet 0/0

次に、IP アドレス 192.168.1.3 のルータをローカル ルータに対する MSDP ピアとして設定する例を示します。

ip msdp peer 192.168.1.3

次に、IP アドレス 192.168.1.4 のルータを自律システム 109 の MSDP ピアとして設定する例を示します。 イーサネット インターフェイス 0/0 のプライマリ アドレスは、TCP 接続の送信元アドレスとして使用されます。

ip msdp peer 192.168.1.4 connect-source ethernet 0/0 remote-as 109

関連コマンド

コマンド

説明

ip msdp default-peer

すべての MSDP SA メッセージの受信元となるデフォルト ピアを定義します。

neighbor remote-as

エントリを BGP ネイバー テーブルに追加します。

ip msdp sa-filter out

指定したマルチキャスト発信元検出プロトコル(MSDP)ピアに送信された Source-Active(SA)メッセージの発信フィルタ リストを設定するには、グローバル コンフィギュレーション モードで ip msdp sa-filter out コマンドを使用します。 フィルタを削除するには、このコマンドの no 形式を使用します。

ip msdp [ vrf vrf-name ] sa-filter out { peer-address | peer-name } [ list access-list-name ] [ route-map map-name ] [ rp-list { access-list-range | access-list-name } ] [ rp-route-map route-map reference ]

no ip msdp [ vrf vrf-name ] sa-filter out { peer-address | peer-name }

構文の説明

vrf

(任意)マルチキャスト VPN ルーティングおよび転送(VRF)インスタンスを指定します。

vrf-name

(任意)VRF に割り当てられた名前。

peer-address | peer-name

SA メッセージがフィルタリングされる MSDP ピアの IP アドレスまたはドメイン ネーム システム(DNS)名。

list access-list-name

(任意)特定の送信元とグループのペアを通す IP アクセス リストを指定します。

route-map map-name

(任意)特定の送信元とグループのペアを通すルート マップの一致基準を指定します。

rp-list

(任意)発信元ルート プロセッサのアクセス リストを指定します。

access-list range

アクセス リストに割り当てられた番号。 指定できる範囲は 1 ~ 99 です。

access-list name

アクセス リストに割り当てられた名前。

rp-route-map route-map reference

(任意)ルート プロセッサを通過するためのルート マップとルート リファレンスを指定します。

コマンド デフォルト

発信メッセージはフィルタリングされません。受信したすべての SA メッセージはピアに転送されます。

コマンド モード

グローバル コンフィギュレーション(config)

コマンド履歴

リリース

変更内容

12.0(7)T

このコマンドが導入されました。

12.0(23)S

このコマンドが変更されました。 vrf キーワードと vrf-name 引数が追加されました。

12.2(13)T

このコマンドが変更されました。 vrf キーワードと vrf-name 引数が追加されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(18)SXE

このコマンドが変更されました。 このコマンドのサポートが Supervisor Engine 720 に追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

15.0(1)M

このコマンドが変更されました。 rp-list キーワードが追加されました。

使用上のガイドライン

アクセス リストの名前もルート マップに一致基準を指定せずに ip msdp sa-filter out コマンドを使用すると、ピアからのすべての送信元またはグループのペアがフィルタリングされます。 アクセス リスト名を指定すると、指定された MSDP ピアでは、拡張アクセス リストを通過する SA メッセージだけを通過させます。

route-map map-name キーワードと引数のペアを使用すると、指定した MSDP ピアでは、一致基準を満たす SA メッセージだけを通過させます。

listroute-map の両方のキーワードを使用すると、発信 SA メッセージ内のいずれかの送信元とグループのペアが通過するには、すべての条件に一致する必要があります。

すべての一致基準に当てはまる場合、ルート マップの permit キーワードがフィルタを通してルートを通過します。 deny キーワードが指定されていれば、ルートはフィルタリングされます。

次の例では、アクセス リスト 100 を通過する(S, G)ペアだけを、SA メッセージで IP アドレス 192.168.1.5 のピアに転送できるようにする方法を示します。

Router> enable
Router# configure terminal
Router(config)# ip msdp peer 192.168.1.5 connect-source ethernet 0/0
Router(config)# ip msdp sa-filter out 192.168.1.5 list 100
Router(config)# access-list 100 permit ip 172.1.0.0 0.0.255.255 224.2.0.0 0.0.255.255

関連コマンド

コマンド

説明

ip msdp peer

MSDP ピアを設定します。

ip msdp sa-filter in

指定の MSDP ピアから受信する SA メッセージの着信フィルタ リストを設定します。

ip msdp sa-limit

指定したマルチキャスト発信元検出プロトコル(MSDP)ピアから SA キャッシュに追加可能な Source Active(SA)メッセージの数を制限するには、グローバル コンフィギュレーション モードで ip msdp sa-limit コマンドを使用します。 MSDP SA リミッタによる制限を削除するには、このコマンドの no 形式を使用します。

ip msdp [ vrf vrf-name ] sa-limit { peer-address | peer-name } [ sa-limit ]

no ip msdp [ vrf vrf-name ] sa-limit { peer-address | peer-name } [ sa-limit ]

構文の説明

vrf vrf-name

(任意)MSDP SA リミッタが、vrf-name 引数に指定されたマルチキャスト バーチャル プライベート ネットワーク(MVPN)仮想ルーティングおよび転送(MVRF)インスタンスに関連付けられた MSDP ピアに適用されることを指定します。

peer-name peer-address

MSDP SA リミッタを適用する MSDP ピアのドメイン ネーム システム(DNS)名または IP アドレス。

sa-limit

指定されたピアから受け入れる(キャッシュする)ことができる SA メッセージの最大数。 値の範囲は 1 ~ 2147483646 です。

コマンド デフォルト

MSDP SA リミッタは MSDP ピアに設定されていません。

コマンド モード

グローバル コンフィギュレーション(config)

コマンド履歴

リリース

変更内容

12.1(7)

このコマンドが導入されました。

12.0(15)S

このコマンドが、Cisco IOS Release 12.0(15)S に統合されました。

12.0(23)S

vrf キーワードと vrf-name 引数が追加されました。

12.2(2)T

vrf キーワードと vrf-name 引数が追加されました。

12.2(3)

このコマンドが Cisco IOS Release 12.2(3) に統合されました。

12.2(13)T

このコマンドが、Cisco IOS Release 12.2(13)T に統合されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

MSDP 対応ルータで MSDP ピアから受け入れ可能(キャッシュ可能)な MSDP SA メッセージの数を制限する MSDP SA リミッタを設定するには、このコマンドを使用します。 このコマンドは、サービス拒否(DoS)攻撃から MSDP 対応ルータを保護する手段になります。

MSDP SA リミッタのメカニズム

  • MSDP SA リミッタを設定すると、ルータは、SA キャッシュに格納されている SA メッセージの数をピアごとに保持します。
  • MSDP ピアに設定されている制限を超えた SA メッセージは、無視されます。
  • 設定された制限を超える数の SA メッセージをルータが MSDP ピアから受信すると、キャッシュがクリアされるまで、次の形式の警告が生成されます(1 分に 1 回)。
%MSDP-4-SA_LIMIT: SA from peer <peer address or name>, RP <RP address> for <mroute> exceeded sa-limit of <configured SA limit for MSDP peer>

MSDP SA リミッタ設定のヒント

  • ルータ上のすべての MSDP ピアリングについて、MSDP SA リミッタを設定することをお勧めします。
  • 適度に低い MSDP SA 制限をスタブ MSDP リージョンとのピアリングに設定する必要があります(たとえば、さらにダウンストリーム ピアを持つが、インターネットの残りの部分で SA メッセージの中継として動作しない MSDP ピアなど)。
  • インターネット上の MSDP SA メッセージの中継として動作するすべての MSDP ピアリングに適度に高い SA 制限を設定する必要があります。

show ip msdp countshow ip msdp peer、および show ip msdp summary コマンドの出力には、SA キャッシュ内の各 MSDP ピアからの SA メッセージの数が表示されます。 ip msdp sa-limit コマンドが設定されている場合、show ip msdp peer コマンドの出力には、各 MSDP ピアの SA メッセージの制限値も表示されます。

次に、MSDP SA リミッタを設定する例を示します。 この例では、MSDP SA リミッタを、192.168.10.1 の MSDP ピアからの SA メッセージを 100 に制限するように設定します。

ip msdp sa-limit 192.168.10.1 100

関連コマンド

コマンド

説明

show ip msdp count

MSDP SA メッセージ内で発信された送信元とグループの数を表示します。

show ip msdp peer

MSDP ピアに関する詳細情報を表示します。

show ip msdp summary

MSDP ピアのステータスを表示します。

ip msdp sa-request


(注)  


Cisco IOS Release 12.0(27)S、12.2(20)S、12.2(18)SXE、12.3(4)T で有効な ip msdp sa-request は、Cisco IOS ソフトウェアで利用可能ではありません。


グループからの新規加入者がアクティブになるときに Source-Active(SA)要求メッセージをマルチキャスト発信元検出プロトコル(MSDP)に送信するようにルータを設定するには、グローバル コンフィギュレーション モードで ip msdp sa-request コマンドを使用します。 このアクションを防止するには、このコマンドの no 形式を使用します。

ip msdp [ vrf vrf-name ] sa-request { peer-address | peer-name }

no ip msdp [ vrf vrf-name ] sa-request { peer-address | peer-name }

構文の説明

vrf

(任意)マルチキャスト VPN ルーティングおよび転送(VRF)インスタンスをサポートします。

vrf-name

(任意)VRF に割り当てられた名前。

peer-address | peer-name

グループの新規加入者がアクティブになった場合に、ローカル ルータが SA メッセージを要求する MSDP ピアの IP アドレスまたは名前。

コマンド デフォルト

ルータは、SA 要求メッセージを MSDP ピアに送信しません。

コマンド モード

グローバル コンフィギュレーション(config)

コマンド履歴

リリース

変更内容

12.0(7)T

このコマンドが導入されました。

12.0(23)S

vrf キーワードと vrf-name 引数が追加されました。

12.0(27)S

このコマンドが Cisco IOS Release 12.0(27)S から削除されました。

12.2(13)T

このコマンドが、Cisco IOS Release 12.2(13)T に統合されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(20)S

このコマンドが Cisco IOS Release 12.2(20)S から削除されました。

12.2(18)SXE

このコマンドが Cisco IOS Release 12.2(18)SXE から削除されました。

12.3(4)T

このコマンドが Cisco IOS Release 12.3(4)T から削除されました。

使用上のガイドライン

デフォルトでは、新しいメンバがグループに加入してマルチキャスト トラフィックを受信する必要が生じた場合、ルータは MSDP ピアに SA 要求メッセージを送信しません。 新規メンバは、最終的に到達する任意の SA メッセージの受信を待機します。

グループに送信する接続された Protocol Independent Multicast Sparse Mode(PIM-SM)ドメイン内の現在のアクティブ マルチキャスト送信元を、グループの新メンバに学習させる場合は、このコマンドを使用します。 新メンバがグループに加入すると、ルータは、指定された MSDP ピアに SA 要求メッセージを送信します。 ピアは SA キャッシュ内の情報に応答します。 ピアにキャッシュが設定されていない場合、このコマンドを実行しても何も起こりません。

このコマンドの代替方法の 1 つとして、ip msdp cache-sa-state コマンドを使用して、ルータにメッセージをキャッシュさせる方法があります。

次の例は、IP アドレス 192.168.10.1 の MSDP ピアに SA 要求メッセージを送信するようにルータを設定する方法を示します。

ip msdp sa-request 192.168.10.1

関連コマンド

コマンド

説明

ip msdp cache-sa-state

ルータは SA ステートを作成することができます。

ip msdp peer

MSDP ピアを設定します。

ip msdp shutdown

設定されたマルチキャスト発信元検出プロトコル(MSDP)ピアを管理シャット ダウンするには、グローバル コンフィギュレーション モードで ip msdp shutdown コマンドを使用します。 ピアをアップに戻すには、このコマンドの no 形式を使用します。

ip msdp [ vrf vrf-name ] shutdown { peer-address | peer-name }

no ip msdp [ vrf vrf-name ] shutdown { peer-address | peer-name }

構文の説明

vrf

(任意)マルチキャスト VPN ルーティングおよび転送(VRF)インスタンスをサポートします。

vrf-name

(任意)VRF に割り当てられた名前。

peer-address | peer-name

シャット ダウンする MSDP ピアの IP アドレスまたは名前。

コマンド デフォルト

MSDP ピアをシャットダウンするアクションは実行されません。

コマンド モード

グローバル コンフィギュレーション

コマンド履歴

リリース

変更内容

12.0(7)T

このコマンドが導入されました。

12.0(23)S

vrf キーワードと vrf-name 引数が追加されました。

12.2(13)T

vrf キーワードと vrf-name 引数が追加されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(18)SXE

このコマンドのサポートが Supervisor Engine 720 に追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

次に、IP アドレス 192.168.7.20 の MSDP ピアをシャット ダウンする例を示します。

ip msdp shutdown 192.168.7.20

関連コマンド

コマンド

説明

ip msdp peer

MSDP ピアを設定します。

ip multicast boundary

管理用スコープの IPv4 マルチキャスト境界を設定するには、インターフェイス コンフィギュレーション モードで ip multicast boundary コマンドを使用します。 境界を削除するには、このコマンドの no 形式を使用します。

ip multicast boundary access-list [filter-autorp]

no ip multicast boundary access-list [filter-autorp]

Cisco IOS 12.3(11)T and Subsequent T and Mainline Releases

ip multicast boundary access-list [ filter-autorp | in | out ]

no ip multicast boundary access-list [ filter-autorp | in | out ]

Cisco IOS XE Release 3.2S and Later Releases

no ip multicast boundary

構文の説明

access-list

境界によって影響されるグループ アドレス範囲または(S, G)トラフィックを制御するアクセス コントロール リスト(ACL)を識別する番号または名前。

filter-autorp

(任意)境界 ACL によって拒否された自動ランデブー ポイント(Auto-RP)メッセージをフィルタリングします。

in

(任意)境界 ACL によって拒否されたインターフェイスに着信するソース トラフィックをフィルタリングします。

out

(任意)境界 ACL によって拒否されるグループまたはチャネルの Protocol Independent Multicast(PIM)join および Internet Group Management Protocol(IGMP)レポートをフィルタリングすることにより、インターフェイスでマルチキャスト ルート(mroute)ステートが作成されることを防止します。

コマンド デフォルト

ユーザ定義の境界は設定されていません。

コマンド モード

インターフェイス コンフィギュレーション(config-if)

仮想ネットワーク インターフェイス(config-if-vnet)

コマンド履歴

リリース

変更内容

11.1

このコマンドが導入されました。

12.0(22)S

filter-autorp キーワードが追加されました。

12.1(12c)E

filter-autorp キーワードが、Cisco IOS Release 12.1(12c)E に統合されました。

12.2(11)

filter-autorp キーワードが、Cisco IOS Release 12.2(11) に統合されました。

12.2(13)T

filter-autorp キーワードが、Cisco IOS Release 12.2(13)T に統合されました。

12.3(11)T

in キーワードと out キーワードが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 3.2S

このコマンドが変更されました。 仮想ネットワーク インターフェイス コンフィギュレーション モードにおけるこのコマンドのサポートが追加されました。 境界 ACL コンフィギュレーションを削除するために、access-list 引数および filter-autorp キーワードを、このコマンドの no 形式に指定する必要はなくなりました。

使用上のガイドライン

インターフェイスに着信する送信元トラフィックをフィルタリングして、mroute ステートがインターフェイス上に作成されなくするために、管理用スコープの(ユーザ定義)境界をインターフェイスに設定するには、ip multicast boundary コマンドを使用します。


(注)  


IP マルチキャスト境界があると、異なる管理ドメインで同じマルチキャスト グループ アドレスを再利用できます。


標準 ACL は、インターフェイスで許可または拒否されるグループ アドレスの範囲を定義するために、ip multicast boundary コマンドとともに使用されます。 拡張 ACL は、インターフェイスで許可または拒否される(S, G)トラフィックを定義するために、ip multicast boundary コマンドとともに使用されます。 拡張 ACL は、拡張 ACL を構成する permit ステートメントの送信元アドレスに host 0.0.0.0 を指定することによってインターフェイスで許可または拒否される(*, G)ステートを定義するためにも使用できます。

IP マルチキャスト境界が確実に適切に機能するように、Any Source Multicast(ASM)ネットワーク環境で(S, G)トラフィックの IP マルチキャスト境界を設定する際は、次のトラフィックを許可する拡張 ACL をランデブー ポイント ツリー(RPT)に沿ったルータに設定する必要があります。

  • permit ステートメントに送信元アドレスとグループ アドレスの範囲を指定することによる(S, G)トラフィック。
  • permit ステートメントで、送信元アドレスに host 0.0.0.0 を指定し、続けてグループ アドレスまたはグループ アドレス範囲を指定することによる(*, G)トラフィック。
  • (RP, G)の permit ステートメントを含めることによる、ランデブー ポイント(RP)に向かうトラフィック。ここでは、RP の IP アドレスを送信元に指定し、グループ アドレスまたはグループ アドレスの範囲を続けます。

ASM の IP マルチキャスト境界ガイドラインは、ラスト ホップ ルータから RP への RPT にあるルータにだけ適用されます。 RP から送信元へのブランチにあるルータに対しては、拡張 ACL に(S, G)トラフィックを定義する必要だけがあります(permit ステートメントに送信元アドレスとグループ アドレスの範囲を指定することによる)。

Source Specific Multicast(SSM)ネットワーク環境で(S, G)トラフィックの IP マルチキャスト境界を設定する場合は、インターフェイスで許可または拒否する(S, G)トラフィックを拡張 ACL に定義する必要だけがあります。

IP マルチキャスト境界は、データおよび、IGMP、PIM Join、Prune、Auto-RP メッセージなどのコントロール プレーン トラフィックをフィルタリングします。 次のメッセージは IP マルチキャスト境界によってフィルタリングされません。
  • PIM register メッセージはマルチキャストを使用して送信され、フィルタリングされません。
  • 224.0.0.13 に対する隣接関係のための PIM hello はフィルタリングされません。
  • リンク ローカル メッセージは影響を受けず、ローカル セグメント上の PIM hello はフィルタリングされません。 各リンクでの PIM 隣接の形成を禁止するには、インターフェイス コンフィギュレーション モードまたは仮想ネットワーク インターフェイス コンフィギュレーション モードで ip pim neighbor-filter コマンドを使用します。

filter-autorp キーワードを設定した場合、ユーザ定義の境界は Auto-RP 検出メッセージおよびアナウンス メッセージを調べ、境界 ACL によって拒否される Auto-RP パケットから Auto-RP グループ範囲アナウンスメントを削除します。 Auto-RP グループ範囲通知は、Auto-RP グループ範囲のすべてのアドレスが境界 ACL によって許可される場合に限り境界を通過できます。 許可されないアドレスがある場合は、グループ範囲全体がフィルタリングされ、Auto-RP メッセージが転送される前に Auto-RP メッセージから削除されます。


(注)  


Auto-RP announcement には送信元アドレスが含まれていないため、拡張 ACL は filter-autorp キーワードを指定して使用できません。


in キーワードおよび out キーワードをサポートしていない Cisco IOS ソフトウェア リリースでは、IP マルチキャスト境界によって、インターフェイスに着信する送信元トラフィックがフィルタリングされるとともに、インターフェイス上に mroute ステートが作成されなくなります。

in キーワードおよび out キーワードをサポートする Cisco IOS リリースでは、これらのキーワードは次のように使用されます。

  • in キーワードは、インターフェイスに着信する送信元トラフィックをフィルタリングするために使用されます。
  • out キーワードは、mroute ステートをインターフェイス上に作成しないために使用されます。つまり、ACL によって拒否されたグループおよびチャネルに対する mroute ステートが IGMP レポートおよび PIM join によって作成されないようになり、インターフェイスは発信インターフェイス リスト(OIL)に含まれなくなります。
  • ip multicast boundary コマンドに方向を指定していない場合は、IP マルチキャスト境界によって、インターフェイスに着信する送信元トラフィックがフィルタリングされるとともに、インターフェイス上に mroute ステートが作成されなくなります。

また、inout、および filter-autorp キーワードを指定して ip multicast boundary コマンドを使用した場合は、次のルールが適用されます。

  • in キーワードおよび out キーワードでは、(S, G)フィルタリングのための標準または拡張 ACL をサポートします。
  • in キーワードおよび out キーワードでは、SSM フィルタリングのための標準または拡張 ACL をサポートします。
  • 1 つのインターフェイスに in キーワードおよび out キーワードのインスタンスを 1 つ設定できます。
  • filter-autorp キーワードとともに使用できるのは標準 ACL だけです。

Cisco 7600 シリーズ ルータ:

  • 境界 ACL の末尾にある deny any ステートメントにより、範囲(224.0.0.0 ~ 224.0.0.255)のリンク ローカル アドレスを含むすべてのマルチキャスト境界がハードウェアでドロップされます。
  • 空の ACL を使用して ip multicast boundary access-list [filter-autorp] コマンドが設定されていると、ハードウェアでの Auto-RP の適切な動作に干渉します。 したがって、許可または拒否するアドレスをアクセスリストに指定することが重要です。

Cisco IOS XE Release 3.2S 以降のリリースでは、access-list 引数および filter-autorp キーワードは、このコマンドの no 形式では必要なくなりました。

Cisco IOS XE Release 3.1S 以前のリリースでは、ACL および filter-autorp を指定して no ip multicast boundary コマンドを使用して、境界 ACL 設定を削除する必要があります。

インターフェイスで ip multicast boundary コマンドのインスタンスを最大 3 個使用できます。in キーワードを指定したこのコマンドのインスタンスが 1 つ、out キーワードを指定したこのコマンドのインスタンスが 1 つ、filter-autorp キーワードの指定の有無を問わないこのコマンドのインスタンスが 1 つです。

次の例では、ユーザ定義 IPv4 マルチキャスト アドレス空間全体(239.0.0.0/8)の拒否によって、すべてのユーザ定義 IPv4 マルチキャスト アドレスの IP マルチキャスト境界を設定する方法を示します。 他のすべてのクラス D アドレスは許可されます(224.0.0.0/4)。

access-list 1 deny 239.0.0.0 0.255.255.255
access-list 1 permit 224.0.0.0 15.255.255.255
interface ethernet 0
 ip multicast boundary 1

次に、SSM ネットワーク環境に IP マルチキャスト境界を設定する方法を示します。 この例では、(172.16.2.201, 232.1.1.1) および (172.16.2.202, 232.1.1.1) に対する mroute ステートを許可するように IP マルチキャスト境界が設定されます。 他のすべての(S, G)トラフィックは、暗黙的に拒否されます。

ip access-list extended acc_grp1
permit ip host 172.16.2.201 host 232.1.1.1
permit ip host 172.16.2.202 host 232.1.1.1
interface ethernet 2/3
 ip multicast boundary acc_grp1 out

次に、ASM ネットワーク環境に IP マルチキャスト境界を設定する方法を示します。 この例では、ラスト ホップ ルータの IP マルチキャスト境界設定を示します。 この例のトポロジは示してありません。ただし、このシナリオの RP の IP アドレスは 10.1.255.104 であると想定されています。 IP マルチキャスト境界は、ファスト イーサネット インターフェイス 0/0 の出力 IP マルチキャスト トラフィックをフィルタリングするように設定されます。 このシナリオで IP マルチキャスト境界に使用する境界 ACL は 3 つの permit ステートメントを含んでいます。

  • 最初の permit ステートメントは、許可する(S, G)トラフィックを指定します。
  • 2 番目の permit ステートメントは、許可する(RP, G)トラフィックを指定します。
  • 3 番目の permit ステートメントは、許可する(*, G)トラフィックを指定します。

このインターフェイスの他の発信マルチキャスト トラフィックは、すべて暗黙的に拒否されます。

ip access-list extended bndry-asm-3
 permit ip host 10.1.248.120 239.255.0.0 0.0.255.255
 permit ip host 10.1.255.104 239.255.0.0 0.0.255.255
 permit ip host 0.0.0.0 239.255.0.0 0.0.255.255
interface FastEthernet0/0
	ip multicast boundary bndry-asm-3 out

関連コマンド

コマンド

説明

ip pim neighbor-filter

ルータが、Protocol Independent Multicast(PIM)に参加することを防止します。

ip multicast multipath

Equal Cost Multipath(ECMP)を介した IP マルチキャスト トラフィックのロード スプリットをイネーブルにするには、グローバル コンフィギュレーション モードで ip multicast multipath コマンドを使用します。 この機能をディセーブルにするには、このコマンドの no 形式を使用します。

ip multicast [ vrf vrf-name ] multipath [ s-g-hash { basic | next-hop-based } ]

no ip multicast [ vrf vrf-name ] multipath [ s-g-hash { basic | next-hop-based } ]

構文の説明

vrf vrf-name

(任意)vrf-name 引数で指定したマルチキャスト バーチャル プライベート ネットワーク(MVPN)ルーティングおよび転送(MVRF)インスタンスに関連付けられた IP マルチキャスト トラフィックに対する ECMP マルチキャスト ロード分割をイネーブルにします。

s-g-hash

(任意)ソース アドレスとグループ アドレス、またはソース アドレスとグループ アドレスとネクスト ホップ アドレスに基づいた ECMP マルチキャスト ロード分割をイネーブルにします。

IP マルチキャスト トラフィックのロード スプリットにオプションの s-g-hash キーワードを指定する場合は、次のキーワードのいずれかを指定することによって、等コスト パスの計算に使用するアルゴリズムを選択しなければなりません。

  • basic :ソース アドレスとグループ アドレスに基づいた単純なハッシュがイネーブルになります。 このアルゴリズムは、基本 S-G ハッシュ アルゴリズムと呼ばれます。
  • next-hop-based :ソース アドレス、グループ アドレス、およびネクスト ホップ アドレスに基づく複雑なハッシュをイネーブルにします。 このアルゴリズムはネクスト ホップ ベースの S-G ハッシュ アルゴリズムと呼ばれます。

コマンド デフォルト

複数の等コスト パスが存在する場合、マルチキャスト トラフィックはこれらのパス間でロード スプリットされません。

コマンド モード

グローバル コンフィギュレーション(config)

コマンド履歴

リリース

変更内容

12.0(8)T

このコマンドが導入されました。

12.0(5)S

このコマンドが Cisco IOS Release 12.0(5)S に統合されました。

12.0(23)S

このコマンドが変更されました。 vrf キーワードと vrf-name 引数が追加されました。

12.2(13)T

このコマンドが変更されました。 vrf キーワードと vrf-name 引数が追加されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(18)SXE

このコマンドがスーパーバイザ エンジン 720 に実装されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

このコマンドが変更されました。 S, G、およびネクスト ホップ機能を使用する等コスト マルチパス(ECMP)である IP マルチキャスト ロード分割をサポートするために、 s-g-hashbasic、および next-hop-based キーワードが追加されました。

15.0(1)M

このコマンドが変更されました。 S, G、およびネクスト ホップ機能を使用する等コスト マルチパス(ECMP)である IP マルチキャスト ロード分割をサポートするために、 s-g-hashbasic、および next-hop-based キーワードが追加されました。

15.0(1)S

このコマンドが、Cisco IOS Release 15.0(1)S に統合されました。

15.0(1)SY

このコマンドが、Cisco IOS Release 15.0(1)SY に統合されました。

15.1(1)SG

このコマンドが、Cisco IOS Release 15.1(1)SG に統合されました。

Cisco IOS XE Release 3.3SG

このコマンドが、Cisco IOS XE Release 3.3SG に統合されました。

使用上のガイドライン

複数の等コスト パス間で IP マルチキャスト トラフィックのロード分割をイネーブルにするには、ip multicast multipath コマンドを使用します。

ソースから 2 つ以上の等コスト パスが使用できる場合は、ユニキャスト トラフィックはそれらのパスの間でロード スプリットされます。 一方、マルチキャスト トラフィックは、デフォルトでは、複数の等コスト パスの間でロード スプリットすることはありません。 一般的に、マルチキャスト トラフィックは、Reverse Path Forwarding(RPF)ネイバーから伝送されます。 Protocol Independent Multicast(PIM)仕様に従うと、複数のネイバーが同じメトリックを持つ場合、このネイバーは最も大きい IP アドレスを持っていなければなりません。

ip multicast multipath コマンドでロード分割を設定すると、システムは、S ハッシュ アルゴリズムを使用して、ソース アドレスに基づいて、複数の等コスト パスの間でマルチキャスト トラフィックをロード分割します。 ip multicast multipath コマンドを設定していて、複数の等コスト パスが存在する場合、マルチキャスト トラフィックを伝送するパスは、ソース IP アドレスに基づいて選択されます。 異なる複数のソースからのマルチキャスト トラフィックが、異なる複数の等コスト パスの間でロード スプリットされます。 同一ソースから異なる複数のマルチキャスト グループに送信されたマルチキャスト トラフィックについては、複数の等コスト パスの間でロード スプリットは行われません。


(注)  


ip multicast multipath コマンドは、トラフィックのロード分割を行いますが、トラフィックのロード バランスは行いません。 ソースからのトラフィックは、そのトラフィックがその他のソースからのトラフィックよりはるかに多い場合でも、1 つのパスしか使用しません。


ip multicast multipath コマンドが s-g-hash キーワードで設定されており、複数の等コスト パスが存在する場合、ソース アドレスとグループ アドレス、またはソース アドレスとグループ アドレスとネクスト ホップ アドレスに基づいて、等コスト パスの間でロード スプリットが発生します。 IP マルチキャスト トラフィックのロード スプリットにオプションの s-g-hash キーワードを指定する場合は、次のキーワードのいずれかを指定することによって、等コスト パスの計算に使用するアルゴリズムを選択しなければなりません。

  • basic :ソース アドレスとグループ アドレスに基づいた単純なハッシュがイネーブルになります。 基本 S-G ハッシュ アルゴリズムは、ハッシュ値の計算にランダム化を一切使用しないため、予測可能です。 ただし、基本 S-G ハッシュ アルゴリズムは、特定のソースとグループについて、どのルータ上でそのハッシュが計算されたかに関係なく常に同じハッシュが得られるため、局在化する傾向があります。
  • next-hop-based :ソース アドレス、グループ アドレス、およびネクスト ホップ アドレスに基づく複雑なハッシュをイネーブルにします。 ネクスト ホップ ベースの S-G ハッシュ アルゴリズムは、ハッシュ値を出すためにランダム化を一切使用しないため、予測可能です。 S ハッシュ アルゴリズムや基本 S-G ハッシュ アルゴリズムと違って、ネクスト ホップ ベースのハッシュ メカニズムは局在化の傾向がありません。

次の例は、S ハッシュ アルゴリズムを使用した、ソース アドレスに基づく ECMP マルチキャスト ロード スプリットをルータ上でイネーブルにする方法を示します。

ip multicast multipath

次の例は、基本 S-G ハッシュ アルゴリズムを使用した、ソース アドレスとグループ アドレスに基づく ECMP マルチキャスト ロード スプリットをルータ上でイネーブルにする方法を示します。

ip multicast multipath s-g-hash basic

次の例は、ネクスト ホップ ベースの S-G ハッシュ アルゴリズムを使用した、ソース アドレス、グループ アドレス、およびネクスト ホップ アドレスに基づく ECMP マルチキャスト ロード スプリットをルータ上でイネーブルにする方法を示します。

ip multicast multipath s-g-hash next-hop-based

ip multicast rpf backoff

ルーティング テーブルの変更に伴って Protocol Independent Multicast(PIM)リバース パス転送(RPF)のフェールオーバーが起動される間隔を設定するには、グローバル コンフィギュレーション モードで ip multicast rpf backoff コマンドを使用します。 トリガー RPF チェックをデフォルト値に設定するには、このコマンドの no 形式を使用します。

ip multicast rpf backoff minimum maximum [disable]

no ip multicast rpf backoff minimum maximum [disable]

構文の説明

minimum

設定されたバックオフ間隔の最小値。 ルーティング変更なしでバックオフ間隔が期限切れになった場合、バックオフ間隔は、minimum 引数で設定されたミリ秒(ms)にリセットされます。 デフォルトは 500 ミリ秒(ms)です。

maximum

バックオフ間隔で許容される最大時間(ミリ秒単位)。 許容される時間の最大長は 5000 ms です。 デフォルトは 5000 ms です。

disable

(任意)トリガー RPF チェック機能をオフにします。

コマンド デフォルト

このコマンドは、デフォルトでイネーブルです。minimum:500 ms。maximum:5000 ms。

コマンド モード

グローバル コンフィギュレーション

コマンド履歴

リリース

変更内容

12.0(22)S

このコマンドが導入されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(15)T

このコマンドが、Cisco IOS Release 12.2(15)T に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

トリガー RPF チェックを使用するユニキャスト ルーティング環境が不安定な場合、この環境では、RPF チェックが常時トリガーされるおそれがあり、その結果、ルータのリソースに負荷がかかることがあります。 この問題を回避するには、ip multicast rpf backoff コマンドを使用して、設定した期間は、2 番目のトリガー RPF チェックが発生しないようにします。 つまり、PIM では、ユーザが設定した最小ミリ秒の期間は、別のトリガー RPF チェックから「バックオフ」します。

その後ルーティング テーブルの変更がなくバックオフ期間が期限切れになると、PIM がルーティング変更をスキャンし、それに従ってマルチキャスト RPF 変更を確立します。 一方、バックオフ期間に別のルーティング変更が行われた場合、PIM では、ルーティング テーブルが収束中に PIM RPF 変更によってルータがオーバーロードにならないように、バックオフ期間を倍にします。


(注)  


このコマンドはデフォルト値のままにしておくことをお勧めします。 デフォルト値の場合は、サブセカンド RPF フェールオーバーが可能です。


maximum 引数は、最大バックオフ間隔を設定するために使用されます。 ルーティング変更なしでバックオフ間隔全体が期限切れになると、バックオフ時間は minimum 引数で設定した時間にリセットされます。

maximum 引数のデフォルトでは、RPF 変更の動作が下位互換性を持ちます。これは、ルートが頻繁に変更される場合は RPF チェック間隔を 5 秒とし、計画されていないルーティング変更だけの安定したネットワークの場合は RPF チェック間隔を 500 ミリ秒とすることによります。 ip multicast rpf backoff コマンドが導入されるまで、PIM では、変更を確認するために 5 秒ごとにルーティング テーブルをポーリングしていました。

ルータで頻繁なルート変更がある場合(ダイヤルイン ルータなど)を除き、通常は、ip multicast rpf backoff コマンドのデフォルト値を変更する必要はありません。 デフォルトを変更すると、最大 RPF チェック間隔を狭めて、新たに確立されたルートの IP マルチキャストをすばやく使用できるようにしたり、最大 RPF チェック間隔を広げて、RPF チェックに起因する CPU 負荷を減削減したりできます。

次に、最小バックオフ間隔を 100 ミリ秒、最大バックオフ間隔を 2500 ms に設定する方法を示します。

ip multicast rpf backoff 100 2500 

ip multicast rpf interval

定期的なリバース パス転送(RPF)チェックの発生間隔を変更するには、グローバル コンフィギュレーション モードで ip multicast rpf interval コマンドを使用します。 デフォルトの間隔に戻すには、このコマンドの no 形式を使用します。

ip multicast rpf interval seconds [ list access-list | route-map route-map ]

no ip multicast rpf interval seconds [ list access-list | route-map route-map ]

構文の説明

seconds

間隔を設定する秒数。 デフォルトは 10 秒です。

list access-list

(任意)アクセス リストの定期 RPF チェックの間隔を定義します。

route-map route-map

(任意)ルート マップの定期 RPF チェックの間隔を定義します。

コマンド デフォルト

このコマンドは、デフォルトでイネーブルです。seconds:10

コマンド モード

グローバル コンフィギュレーション

コマンド履歴

リリース

変更内容

12.0(22)S

このコマンドが導入されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(15)T

このコマンドが、Cisco IOS Release 12.2(15)T に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

アクセス リストまたはルート マップを使用して、このコマンドの複数のインスタンスを設定できます。


(注)  


このコマンドはデフォルト値のままにしておくことをお勧めします。 デフォルト値の場合は、サブセカンド RPF フェールオーバーが可能です。


次に、定期的な RPF チェックの間隔を 10 秒に設定する例を示します。

ip multicast rpf interval 10

次の例では、アクセス リスト 10 によって定義されたグループの定期 RPF チェック間隔を 3 秒に設定する方法を示します。

ip multicast rpf interval 3 list 10

次の例では、ルート マップで指定されたマップによって定義されたグループの定期 RPF チェック間隔を 2 秒に設定する方法を示します。

ip multicast rpf interval 2 route-map map

関連コマンド

コマンド

説明

ip igmp query-interval

Cisco IOS ソフトウェアが IGMP ホスト hello メッセージを送信する頻度を設定します。

ip multicast-routing

IP マルチキャスト ルーティングをイネーブルにするには、グローバル コンフィギュレーション モードで ip multicast-routing コマンドを使用します。 IP マルチキャスト ルーティングをディセーブルにするには、このコマンドの no 形式を使用します。

ip multicast-routing [ vrf vrf-name ] [distributed]

no ip multicast-routing [ vrf vrf-name ]

Cisco IOS XE Release 3.3S

ip multicast-routing [ vrf vrf-name ] distributed

no ip multicast-routing [ vrf vrf-name ] distributed

構文の説明

vrf vrf-name

(任意)vrf-name 引数に指定されたマルチキャスト VPN ルーティングおよび転送(MVRF)インスタンスのための IP マルチキャスト ルーティングをイネーブルにします。

distributed

(任意)Multicast Distributed Switching(MDS)をイネーブルにします。

コマンド デフォルト

IP マルチキャスト ルーティングはディセーブルになっています。

コマンド モード

グローバル コンフィギュレーション(config)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

11.2(11)GS

distributed キーワードが追加されました。

12.0(5)T

このコマンドの効果が変更されました。 IP マルチキャスト マルチレイヤ スイッチング(MLS)がイネーブルになっている場合にこのコマンドの no 形式を使用すると、マルチキャスト マルチレイヤ スイッチング(MMLS)ルート プロセッサ(RP)の IP マルチキャスト ルーティングがディセーブルになり、MMLS-SE 上のすべてのマルチキャスト MLS キャッシュ エントリがパージされるようになりました。

12.0(23)S

vrf キーワードと vrf-name 引数が追加されました。

12.2(13)T

vrf キーワードと vrf-name 引数が追加されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(18)SXE

このコマンドのサポートが Supervisor Engine 720 に追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

Cisco IOS XE Release 3.2S

このコマンドが Cisco IOS XE Release 3.2S に統合されました。 distributed キーワードなしのこのコマンドが Cisco ASR 1000 シリーズ アグリゲーション サービス ルータに実装されました。

Cisco IOS XE Release 3.3S

このコマンドが変更されました。 Cisco IOS リリース 3.3S でこのコマンドを使用するには、distributed キーワードまたは vrf vrf-name distributed キーワードと引数の組み合わせが必要です。

15.2(3)T

このコマンドが Cisco IOS Release 15.2(3)T に統合されました。 distributed キーワードは、Cisco IOS Release 15.2(3)T ではサポートされません。

使用上のガイドライン

IP マルチキャスト ルーティングがディセーブルになっている場合、Cisco IOS ソフトウェアはどのマルチキャスト パケットも転送しません。

このコマンドのオプションの distributed キーワードは、Cisco IOS XE Release 3.2S ではサポートされません。

Cisco IOS XE Release 3.3S 以降のリリースでは、このコマンドの distributed キーワードまたは vrf vrf-name distributed キーワードと引数の組み合わせが必要です。


(注)  


IP マルチキャストの場合は、IP マルチキャスト ルーティングをイネーブルした後で、すべてのインターフェイスで PIM を設定する必要があります。 IP マルチキャスト ルーティングをディセーブルにしても、PIM は削除されません。PIM は、まだ、インターフェイス コンフィギュレーションから明示的に削除する必要があります。


次に、IP マルチキャスト ルーティングをイネーブルにする例を示します。

Router(config)# ip multicast-routing 

次に、特定の VRF の IP マルチキャスト ルーティングをイネーブルにする例を示します。

Router(config)# 
ip multicast-routing vrf vrf1

次に、IP マルチキャスト ルーティングをディセーブルにする例を示します。

Router(config)# 
no ip multicast-routing

次に、Cisco IOS XE Release 3.3S で特定の VRF の MDS をイネーブルにする例を示します。

Router(config)# 
ip multicast-routing vrf vrf1 distributed

関連コマンド

コマンド

説明

ip pim

インターフェイス上の PIM をイネーブルにします。

ip pim

インターフェイスの Protocol Independent Multicast(PIM)をイネーブルにするには、インターフェイス コンフィギュレーション モードまたは仮想ネットワーク インターフェイス コンフィギュレーション モードで ip pim コマンドを使用します。 インターフェイスの PIM をディセーブルにするには、このコマンドの no 形式を使用します。

ip pim { dense-mode [ proxy-register { list access-list | route-map map-name } ] | passive | sparse-mode | sparse-dense-mode }

no ip pim { dense-mode [ proxy-register { list access-list | route-map map-name } ] | passive | sparse-mode | sparse-dense-mode }

構文の説明

dense-mode

デンス モード動作をイネーブルにします。

proxy-register

(任意)指定ルータ(DR)に接続されていない送信元からのマルチキャスト トラフィックのために、DR(境界のデンス モード領域につながる)のインターフェイスでのプロキシ登録をイネーブルにします。

list access-list

(任意)拡張アクセス リストの番号または名前を定義します。

route-map map-name

(任意)ルート マップを定義します。

passive

パッシブ モード動作をイネーブルにします。

sparse-mode

スパース モード動作をイネーブルにします。

sparse-dense-mode

マルチキャスト グループの動作モードに従って、スパース モードまたはデンス モードでインターフェイスを処理します。

コマンド デフォルト

すべてのインターフェイスで PIM はディセーブルです。

コマンド モード

インターフェイス コンフィギュレーション(config-if)仮想ネットワーク インターフェイス コンフィギュレーション(config-if-vnet)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

11.1

このコマンドが変更されました。 sparse-dense-mode キーワードが追加されました。

12.0S

このコマンドが変更されました。 次のキーワードと引数が追加されました。

  • proxy-register
  • list access-list
  • route-map map-name

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

12.2(33)SRE

このコマンドが変更されました。 passive キーワードが追加されました。

Cisco IOS XE Release 3.2S

このコマンドが変更されました。 仮想ネットワーク インターフェイス コンフィギュレーション モードにおけるこのコマンドのサポートが追加されました。

15.2(3)T

このコマンドが Cisco IOS Release 15.2(3)T に統合されました。

使用上のガイドライン

インターフェイスの PIM をイネーブルにすると、そのインターフェイスでの Internet Group Management Protocol(IGMP)動作もイネーブルになります。 インターフェイスは、デンス モード、パッシブ モード、スパース モード、またはスパース - デンス モードのいずれかに設定できます。 モードは、Cisco IOS ソフトウェアがそのマルチキャスト ルーティング テーブルをどのように埋め、その直接接続されている LAN から受信したマルチキャスト パケットをどのように転送するかを表します。 デンス モード インターフェイスは、マルチキャスト ルーティング テーブルを埋める際に常にテーブルに追加されます。 スパース モード インターフェイスは、ダウンストリーム ルータから定期的な Join メッセージを受信した場合、およびインターフェイス上に直接接続されているメンバーがある場合にだけテーブルに追加されます。

Cisco IOS XE Release 3.2S 以降では、インターフェイスで PIM がイネーブルになっている一方で、ip multicast-routing コマンドが設定されていない場合、ip multicast-routing コマンドが設定されていないことおよびマルチキャスト パケットが転送されないことをユーザに通知する警告メッセージは表示されません。

デンス モード

最初、デンス モード インターフェイスは、ルータがグループ メンバーまたはダウンストリーム ルータが存在すると判断するか、またはダウンストリーム ルータからプルーン メッセージを受信するまでは、マルチキャスト パケットを転送します。 次に、デンス モード インターフェイスは、同じ状況が発生するまで、定期的にマルチキャスト パケットをインターフェイスから転送します。 デンス モードは、マルチキャスト グループ メンバーが存在することを前提としています。 デンス モード ルータは、決して Join メッセージを送信しません。 メンバーもダウンストリーム PIM ルータもないと判断すると、ただちにプルーン メッセージを送信します。 デンス モード インターフェイスは、デフォルトでマルチキャスト フラッディングの対象です。

プロキシ登録でのデンス モード

スパース モードまたはスパース - デンス モードで動作するように設定されている PIM スパース モード(PIM-SM)ドメイン内のルータについては、境界のデンス モード領域につながるインターフェイスに ip pim dense-mode proxy-register コマンドを設定する必要があります。 この設定は、スパース モード ドメイン内のランデブー ポイント(RP)にデンス モード領域からのトラフィックをルータが登録できるようにします。

Cisco IOS Release 12.0S の前までは、デンス モード領域のソースからのトラフィックについて RP が学習できるためには、デンス モード領域へと続く境界ルータで RP を実行する必要がありました。

このコマンドには、どのトラフィックをルータが RP に登録する必要があるかを指定する拡張アクセス リストまたはルート マップ引数が必要です。 このコマンドは、PIM ルータを介して到達できる送信元にだけ適用されます。 Cisco IOS ソフトウェアは、リモート ソースからのトラフィックがデンス モード インターフェイスに到達した場合、および送信元につながる Reverse Path Forwarding(RPF)ネイバーが PIM ルータではなく Distance Vector Multicast Routing Protocol ルータだった場合には、常にトラフィックを登録します。 この機能は、Cisco IOS Release 10.0 から存在していたもので、アクセス リストやルート マップでは変更(制限)できません。

パッシブ モード

パッシブ モードで設定されたインターフェイスにより、PIM コントロール プレーン トラフィックが渡されたり、転送されたりすることはなく、IGMP トラフィックのみが渡されるか、転送されます。 IP マルチキャストがイネーブルになっているインターフェイスにパッシブ モードが設定されている場合、ルータでは、このインターフェイス上で PIM メッセージを送信せず、他のルータからの PIM メッセージをこのインターフェイスで受け入れません。 ルータはネットワーク上で唯一の PIM ルータとして動作し、すべての双方向 PIM グループ範囲の指定ルータ(DR)および指定フォワーダ(DF)として動作します。

ip pim neighbor-filter コマンドと ip pim passive コマンドを同じインターフェイスに設定した場合、前者は効果がなく、後者が優先されます。

複数の IP マルチキャスト ルータが接続された LAN では、ip pim passive コマンドを使用しないでください。これは、このコマンドが設定されたすべてのルータは DR と DF になり、その結果、トラフィックの複製(PIM-SM、PIM-DM、PIM-SSM)やトラフィックのループ(Bidir-PIM)が発生するからです。 複数のルータを含む LAN の有効なルータとの PIM メッセージの送受信を制限するには、ip pim neighbor-filter コマンドを使用します

スパース モード

スパース モード インターフェイスは、ダウンストリーム ルータから Join メッセージを受信した場合、およびグループ メンバーが直接インターフェイスに接続されている場合にだけ、マルチキャスト転送に使用されます。 スパース モードでは、他のマルチキャスト グループ メンバーが一切存在しないことが前提となっています。 スパース モード ルータは、共有パスに加入したい場合は、定期的に RP に向けて Join メッセージを送信します。 スパース モード ルータは、ソース パスに加入したい場合は、そのソースに向けて定期的に Join メッセージを送信します。また、共有パスをなくすために、RP に向けて定期的なプルーン メッセージの送信も行います。

スパース-デンス モード

デンス モードだけまたはスパース モードだけを選択する場合の代替として、PIM を一部のグループに対して 1 つの領域内でスパース モードで実行し、他のグループに対してはデンス モードで実行します。

スパース-デンス モードでは、グループがデンス モードだった場合、インターフェイスはデンス モードとして扱われます。 グループがスパース モードだった場合は、インターフェイスはスパース モードで扱われます。 グループは、ルータがそのグループの RP について知っている場合に「スパース」です。

インターフェイスがデンス モードで扱われる場合、そのインターフェイスは、次の条件のいずれかが当てはまる場合にマルチキャスト ルーティング テーブルの発信インターフェイス リストに入れられます。

  • インターフェイス上にメンバまたは DVMRP ネイバーが存在する。
  • インターフェイス上の PIM ネイバーのいずれかが、そのグループに対してプルーンされていない。

インターフェイスがスパース モードで扱われる場合、そのインターフェイスは、次の条件のいずれかが当てはまる場合にマルチキャスト ルーティング テーブルの発信インターフェイス リストに入れられます。

  • インターフェイス上にメンバまたは DVMRP ネイバーが存在する。
  • インターフェイス上の PIM ネイバーが、明示的な Join メッセージを受信した。

次に、トンネル インターフェイス 0 での PIM-SM をイネーブルにし、RP ルータのアドレスを 226.0.0.8 に設定する例を示します。

ip pim rp-address 226.0.0.8
interface tunnel 0
 ip pim sparse-mode

次に、イーサネット インターフェイス 1 での PIM デンス モード(PIM-DM)をイネーブルにする例を示します。

interface ethernet 1
 ip pim dense-mode

次に、イーサネット インターフェイス 1 での PIM スパース-デンス モードをイネーブルにする例を示します。

interface ethernet 1
 ip pim sparse-dense-mode

次に、任意のソースおよび任意のマルチキャスト グループのトラフィックを登録する例を示します。

interface ethernet 0
 ip address 172.16.0.0 255.255.255.0
 description Ethernet interface toward the PIM sparse-mode domain
 ip pim sparse-dense-mode
!
interface ethernet 1
 ip address 172.44.81.5 255.255.255.0
 description Ethernet interface toward the PIM dense-mode region
 ip pim dense-mode proxy-register list 100
!
access-list 100 permit ip any any

関連コマンド

コマンド

説明

ip multicast-routing

IP マルチキャスト ルーティングまたはマルチキャスト分散スイッチングをイネーブルにします。

ip pim neighbor-filter

PIM メッセージをフィルタリングします。

ip pim rp-address

特定のグループの PIM RP のアドレスを設定します。

show ip pim interface

PIM に対して設定されたインターフェイスに関する情報を表示します。

ip pim autorp listener

2 つの Auto-RP グループ 224.0.1.39 および 224.0.1.40 の IP マルチキャスト トラフィックが、PIM スパース モードで動作するインターフェイスをまたがって Protocol Independent Multicast(PIM)デンス モード フラッディングされるようにするには、グローバル コンフィギュレーション モードで ip pim autorp listener コマンドを使用します。 この機能をディセーブルにするには、このコマンドの no 形式を使用します。

ip pim autorp listener

no ip pim autorp listener

構文の説明

このコマンドには引数またはキーワードはありません。

コマンド デフォルト

このコマンドは、デフォルトでディセーブルになっています。

コマンド モード

グローバル コンフィギュレーション

コマンド履歴

リリース

変更内容

12.2(7)

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

Auto-RP が PIM デンス モードで動作し、マルチキャスト トラフィックがスパース モード、双方向モード、または Source Specific Multicast(SSM)モードで動作可能なネットワーク構成を確立するようにするには、PIM スパース モード動作するように設定されたインターフェイスを指定して ip pim autorp listener コマンドを使用します。

次に、ルータの IP マルチキャスト ルーティングおよび Auto-RP リスナー機能をイネーブルにする例を示します。 また、マルチキャスト グループ 239.254.2.0 ~ 239.254.2.255 の候補 RP としてルータを設定します。

ip multicast-routing
ip pim autorp listener
ip pim send-rp-announce Loopback0 scope 16 group-list 1
ip pim send-rp-discovery Loopback1 scope 16
access-list 1 permit 239.254.2.0 0.0.0.255

ip pim dm-fallback

Protocol Independent Multicast(PIM)のデンス モード(DM)フォール バックをイネーブルにするには、グローバル コンフィギュレーション モードで ip pim dm-fallback コマンドを使用します。 PIM デンス モード フォール バックが発生しないようにするには、このコマンドの no 形式を使用します。

ip pim dm-fallback

no ip pim dm-fallback

構文の説明

このコマンドには引数またはキーワードはありません。

コマンド デフォルト

PIM デンス モード フォール バックは、ip pim dense-mode コマンドまたは ip pim sparse-dense-mode コマンドで設定されたルータのすべてのインターフェイスでイネーブルになります。

コマンド モード

グローバル コンフィギュレーション(config)

コマンド履歴

リリース

変更内容

12.3(4)T

このコマンドが導入されました。

12.0(28)S

このコマンドが、Cisco IOS Release 12.0(28)S に統合されました。

12.2(25)S

このコマンドが、Cisco IOS Release 12.2(25)S に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

使用上のガイドライン

ミッション クリティカルなネットワークで IP マルチキャストを使用する場合は、PIM-DM(デンス モード)の使用を回避する必要があります。

デンス モード フォール バックは、スパース モード(RP が必要)からデンス モード(RP を使用しない)に PIM モードが変更(フォール バック)されるイベントを示します。 デンス モード フォールバックは、RP 情報が失われると発生します。

スパース モード用に設定されたインターフェイス上ではデンス モード グループを作成できないため、 ip pim sparse-mode コマンドを使用してすべてのインターフェイスを設定している場合はデンス モード フォールバックは発生しません。

スパース - デンス インターフェイスで PIM DM フラッディングをディセーブルにするには、no ip pim dm-fallback コマンドを使用します。

デンス モード フォールバックの原因と結果

PIM は、マルチキャスト グループが PIM-DM モードで動作するか、PIM-SM モードで動作するかを、グループから RP へのマッピング キャッシュ内の RP 情報の存在だけに基づいて決定します。 Auto-RP を設定している場合やブートストラップ ルータ(BSR)を使用して RP 情報を配信する場合には、ネットワークの輻輳が原因ですべての RP、Auto-RP、またはグループの BSR に障害が発生すると RP 情報が失われる可能性があります。 この障害により、ネットワークの一部または全部が PIM-DM にフォールバックすることがあります。

ネットワークが PIM-DM にフォールバックした場合、AutoRP または BSR が使用されているときは、デンス モード フラッディングが発生します。 RP 情報が失われたルータがデンス モードにフォールバックし、障害が発生したグループに対して作成される必要がある新しいステートがデンス モードで作成されます。

デンス モード フォールバックを回避することによる効果

PIM-DM フォールバックを回避するまでは、グループから RP へのマッピングを使用しないすべてのマルチキャスト グループはデンス モードで処理されます。

PIM-DM フォールバックを回避すると、デンス モード フラッディングを回避するように PIM-DM フォールバック動作が変更されます。 デフォルトでは、(ip pim sparse-mode コマンドを使用して)すべてのインターフェイスが PIM スパース モードで動作するように設定する場合は、no ip pim dm-fallback no ip pim dm-fallback コマンドを設定する必要はありません(つまり、PIM-DM フォールバック動作がデフォルトでイネーブルになります)。 ip pim sparse-mode コマンド(たとえば、ip pim sparse-dense-mode コマンド)を使用して設定したインターフェイスがない場合は、no ip pim dm-fallback コマンドを使用して PIM-DM フォールバック動作を明示的にディセーブルにできます。

no ip pim dm-fallback コマンドを設定している場合、またはすべてのインターフェイス上で ip pim sparse-mode を設定している場合、スパース モードで実行されている既存のグループは引き続きスパース モードで動作しますが、0.0.0.0 に設定された RP を使用します。 RP アドレスが 0.0.0.0 に設定されたマルチキャスト エントリは、次のように動作します。

  • 既存の (S, G) ステートを維持します。
  • (*, G) または (S, G, RPbit) の PIM 加入またはプルーニング メッセージは送信しません。
  • 受信した (*, G) または (S, G, RPbit) 加入またはプルーニング メッセージは無視します。
  • 登録は送信せず、ファースト ホップのトラフィックはドロップします。
  • 受信した登録には、登録停止で応答します。
  • 資産は変更しません。
  • (*, G) 発信インターフェイス リスト(olist)は、インターネット グループ管理プロトコル(IGMP)ステートに対してのみ維持します。
  • RP 0.0.0.0 グループに対する Multicast Source Discovery Protocol(MSDP)Source-Active(SA)メッセージは、引き続き受信して転送します。

次に、PIM-DM フォールバックをディセーブルにする例を示します。

no ip pim dm-fallback

関連コマンド

コマンド

説明

ip pim dense-mode

インターフェイスで PIM デンス モードをイネーブルにします。

ip pim sparse-dense-mode

PIM がグループに応じて、スパース モードまたはデンス モードのいずれかで動作できるようにします。

ip pim query-interval

Protocol Independent Multicast(PIM)クエリー(hello)メッセージの頻度を設定するには、インターフェイス コンフィギュレーション モードで ip pim query-interval コマンドを使用します。 デフォルトの間隔に戻すには、このコマンドの no 形式を使用します。

ip pim query-interval period [msec]

no ip pim query-interval

構文の説明

period

PIM hello(クエリー)の間隔に設定できる数秒またはミリ秒(ms)数。 有効な範囲は 1 ~ 65535 です。

msec

(任意)period ピリオド引数で設定された間隔をミリ秒で解釈する必要があることを指定します。 msec キーワードに period 引数を付けなかった場合、間隔の範囲は秒単位であると見なされます。

コマンド デフォルト

PIM hello(クエリー)メッセージは 30 秒ごとに送信されます。

コマンド モード

インターフェイス コンフィギュレーション(config-if)仮想ネットワーク インターフェイス(config-if-vnet)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.0(22)S

msec キーワードが追加されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(15)T

このコマンドが、Cisco IOS Release 12.2(15)T に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(31)SB

このコマンドが Cisco IOS Release 12.2(31)SB に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 3.2S

このコマンドが変更されました。 仮想ネットワーク インターフェイス コンフィギュレーション モードにおけるこのコマンドのサポートが追加されました。

使用上のガイドライン

PIM ネイバー探索メッセージの頻度を設定するには、このコマンドを使用します。 このメッセージは、デフォルトでは 30 秒間に 1 回送信されます。 PIM バージョン 1(PIMv1)では、これらのメッセージは PIM クエリー メッセージと呼ばれます。PIM バージョン, Version 2(PIMv2)では、これらのメッセージは、PIM hello メッセージと呼ばれます。 デフォルトでは、ルータは、PIMv2 を実行し、PIM hello メッセージを送信します。 PIMv1 だけをサポートする隣接ルータを検出した場合、ルータは、PIMv1 に変わり(自動フォールバック)、PIM クエリー メッセージを送信します。 そのネイバー PIMv1 ルータがネットワークから削除されると、ルータは PIMv2 に戻ります。


(注)  


ルータは、ip pim version 1 コマンドを使用して、インターフェイスで PIMv1 を排他的に使用するように設定できます。



(注)  


PIM バージョン 2 では、PIM hello メッセージには、ネットワークの PIM ルータが PIM ネイバーの機能について学習できるようにするさまざまなオプションも含まれています。 これらの機能に関する詳細情報については、show ip pim neighbor コマンド ページを参照してください。


PIM ネイバー探索メッセージは、ネットワーク内のいずれのルータが、PIM スパース モード(PIM-SM)および Source Specific Multicast(SSM)の指定ルータ(DR)として機能しているのかを判別するために使用されます。 DR は、レシーバ(ホスト)が要求する送信元からのマルチキャスト トラフィックを受信する PIM-SM および SSM グループに参加します。 また、PIM-SM では、DR は、RP へのローカル ソースの登録も行います。 DR が失敗すると、バックアップ ルータが DR になり、続いて、ローカル レシーバのトラフィックの転送と、ローカル ソースの登録を行います。

period 引数は、PIM hello(クエリー)間隔を指定するために使用されます。 間隔は PIM hello(クエリー)メッセージが送信される頻度を指定します。


(注)  


PIM がイネーブルになっているインターフェイスが起動すると、PIM hello(クエリー)メッセージが即座に送信されます。 場合によっては、最初の PIM hello(クエリー)メッセージが失われることがあります。インターフェイスが最初に起動されるときに最初の PIM hello(クエリー)が送信されなかった場合は、初期化の遅延を確実に避けるために、PIM hello(クエリー)間隔に関係なく 3 秒後に送信されます。


設定した PIM hello 間隔によって、PIM ルータが使用する保持時間も決まります。 Cisco IOS ソフトウェアでは、次のように保持時間を計算します。

3 * period 引数に指定された間隔

デフォルトでは、PIM ルータは PIM hello(クエリー)メッセージに入れて保持時間をアナウンスします。保持時間が期限切れになり、別のルータがこのルータから別の hello(クエリー)メッセージ受信していない場合、そのルータでは PIM ネイバーをタイムアウトにします。 タイムアウト ルータが DR の場合は、このタイムアウトによって DR 選出がトリガーされます。 デフォルトでは、DR フェールオーバー間隔は 90 秒後(1 台の DR でデフォルトの保持時間の期限が切れる)に実行されます。 冗長ネットワークでは、すべてのルータで period 引数に小さい値を設定することにより、DR フェールオーバー時間を短縮できます。 設定できる最小の DR フェールオーバー時間(秒単位)は 3 秒です(period 引数に 1 秒が設定されている場合)。 msecs キーワードを指定した場合は、DR フェールオーバー時間を 3 秒未満に短縮できます。 msecs キーワードを指定して ip pim query-interval コマンドで使用すると、period 引数に指定した値は、秒単位ではなくミリ秒単位の値として解釈されます。 この機能を使用すると、ルータが PIM hello メッセージを頻繁に送信できるようにすることにより、応答しないネイバーをルータでより迅速に検出できるようになります。 その結果、ルータは、より効率的なフェールオーバー手順またはリカバリ手順を実装できます


(注)  


IGMP バージョン 1 がネットワークで使用されている場合、DR は、IGMP クエリアにもなります。少なくとも IGMP バージョン 2 が使用されている場合、最も小さい IP アドレスを持つルータが IGMP クエリアになります。


次に、PIM hello 間隔を 45 秒に設定する例を示します。

interface FastEthernet0/1
 ip pim query-interval 45

次に、PIM hello 間隔を 100 ミリ秒に設定する例を示します。

interface FastEthernet0/1
 ip pim query-interval 100 msec

関連コマンド

コマンド

説明

show ip pim neighbor

PIMv1 ルータ クエリー メッセージまたは PIMv2 hello メッセージで検出された PIM ネイバーに関する情報を表示します

ip pim register-rate-limit

パケット/秒または bps に基づいて Protocol Independent Multicast Sparse Mode(PIM-SM)レジスタ パケットをレート制限するには、グローバル コンフィギュレーション モードで ip pim register-rate-limit コマンドを使用します。 この制限をディセーブルにするには、このコマンドの no 形式を使用します。

Cisco IOS Releases Prior to Releases 12.2(33)SRE and 15.0(1)M

ip pim [ vrf vrf-name ] register-rate-limit packets-per-second

no ip pim [ vrf vrf-name ] register-rate-limit

Cisco IOS Releases 12.2(33)SRE, 15.0(1)M, and Cisco IOS XE Release 2.1, and Subsequent 12.2SR, 15.0 Mainline, T Releases, and Cisco IOS XE Releases

ip pim [ vrf vrf-name ] register-rate-limit bits-per-second

no ip pim [ vrf vrf-name ] register-rate-limit

構文の説明

vrf vrf-name

(任意)vrf-name 引数に指定されたマルチキャスト バーチャル プライベート ネットワーク(MVPN)仮想ルーティングおよび転送(MVRF)インスタンスに関連付けられている PIM-SM 登録パケットをレート制限します。

packets-per-second

ルータによって 1 秒あたりに送信される登録パケットの最大数。 範囲は 1 ~ 65535 秒です。 デフォルトでは、最大レートは設定されません。

bits-per-second

1 秒あたりに送信される登録ビットの最大数。 範囲は 8000 ~ 2000000000 ビットです。 デフォルトでは、最大レートは設定されません。

コマンド デフォルト

レート制限は、PIM-SM 登録パケットに設定されません。

コマンド モード

グローバル コンフィギュレーション(config)

コマンド履歴

リリース

変更内容

11.3T

このコマンドが導入されました。

12.0(23)S

このコマンドが変更されました。 vrf キーワードと vrf-name 引数が追加されました。

12.2(13)T

このコマンドが、Cisco IOS Release 12.2(13)T に統合されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(18)SXE

このコマンドがスーパーバイザ エンジン 720 に実装されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

Cisco IOS XE Release 2.1

このコマンドが変更されました。 PIM-SM 登録パケットのレート制限に指定できる値が、1 秒あたりのパケット数の値から、RP ごとの bps の値に変更されました。

15.0(1)M

このコマンドが変更されました。 PIM-SM 登録パケットのレート制限に指定できる値が、1 秒あたりのパケット数の値から、RP ごとの bps の値に変更されました。

12.2(33)SRE

このコマンドが変更されました。 PIM-SM 登録パケットのレート制限に指定できる値が、1 秒あたりのパケット数の値から、RP ごとの bps の値に変更されました。

使用上のガイドライン

このコマンドは、PIM-SM 登録パケットを 1 秒あたりのパケット数または bps に基づいてレート制限する場合に使用します。 このコマンドをイネーブルにすると、設定された制限を超えた登録パケットはドロップされるという代償を伴いますが、DR および RP への負荷は制限されます。 レシーバは、登録パケットがバースト性を持つ送信元から送信されてから最初の 1 秒間に、データ パケット損失を経験する可能性があります。

packets-per-second 引数の値を設定するために ip pim register-rate-limit コマンドを使用すると、すべての PIM-SM 登録にレート制限が設定されます。

bits-per-second 引数の値を設定するために ip pim register-rate-limit コマンドを使用すると、RP ごとに、PIM-SM 登録に関するレート制限が設定されます。

ip pim コマンドを設定するときに dense-mode キーワードと proxy-register キーワードを指定している場合は、デンス モード領域にある大量の送信元からスパース モード領域にデータが送信される可能性があるため(したがって、境界ルータに登録する必要があるため)、送信される PIM-SM 登録パケットの最大数に制限を設定する必要があります。

このコマンドは、スパース モード(S, G)マルチキャスト ルーティング エントリに対してだけ適用されます。

次に、1 秒あたり 2 レジスタ パケットを最大レートとする ip pim register-rate-limit コマンドを設定する例を示します。

ip pim register-rate-limit 2

次に、8000 ビット/秒を最大レートとする ip pim register-rate-limit コマンドを設定する例を示します。

ip pim register-rate-limit 8000

関連コマンド

コマンド

説明

ip pim

インターフェイス上の PIM をイネーブルにします。

ip pim rp-announce-filter

候補 RP(C-RP)から RP マッピング エージェントに送信される着信ランデブー ポイント(RP)announcement メッセージをフィルタリングするには、グローバル コンフィギュレーション モードで ip pim rp-announce-filter コマンドを使用します。 フィルタを削除するには、このコマンドの no 形式を使用します。

ip pim [ vrf vrf-name ] rp-announce-filter { group-list access-list | rp-list access-list [ group-list access-list ] }

no ip pim [ vrf vrf-name ] rp-announce-filter { group-list access-list | rp-list access-list [ group-list access-list ] }

構文の説明

vrf vrf-name

(任意) vrf-name 引数で指定したマルチキャスト バーチャル プライベート ネットワーク(MVPN)ルーティングおよび転送(MVRF)インスタンスに関連付けられた C-RP から送信された着信 RP メッセージにフィルタが適用されることを指定します。

group-list access-list

C-RP によって RP マッピング エージェントに送信された RP announcement から許可または拒否されるマルチキャスト グループを定義する標準アクセス リストの番号または名前を指定します。

rp-list access-list

RP マッピング エージェントによって RP announcement が許可または拒否される C-RP の IP アドレスを定義する標準アクセス リストの番号または名前を指定します。

コマンド デフォルト

すべての RP announcement がこの RP マッピング エージェントで受け入れられます。

コマンド モード

グローバル コンフィギュレーション(config)

コマンド履歴

リリース

変更内容

11.1

このコマンドが導入されました。

12.0(23)S

vrf キーワードと vrf-name 引数が追加されました。

12.2(13)T

vrf キーワードと vrf-name 引数が追加されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(18)SXE

このコマンドのサポートが Supervisor Engine 720 に追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

使用上のガイドライン

C-RP から RP マッピング エージェントに送信された着信 Auto-RP announcement メッセージをフィルタリングするには、 ip pim rp-announce-filter コマンドを使用します。 このコマンドは、RP マッピング エージェントでのみ設定する必要があります。

Auto-RP は、すべてのルータにスタティック RP を手動で設定する必要なしで、マルチキャスト ネットワーク内にグループから RP へのマッピングを配布する手段になります。 この配信を実現するために、Auto-RP では次のメカニズムを使用します。

  • C-RP では、マルチキャスト グループ 224.0.1.39 に RP announcement を送信します。
  • RP マッピング エージェントは、C-RP から RP announcement を受信し、最大 IP アドレスに基づいて、どの C-RP を特定のグループ(または複数グループ)の RP にするかを決定します。 次に、RP マッピング エージェントは、RP ディスカバリ メッセージによってすべてのマルチキャスト ルータにこの情報を配布します。このメッセージは、Auto-RP マルチキャスト グループ アドレス 224.0.1.40 に送信されます。
  • RP announcement と RP ディスカバリ メッセージの送信は、いずれも、デフォルトでは、保持時間 180 秒で 60 秒ごとに行われます。 RP が見つからない場合、各ルータは、続いて、スタティック RP マッピングをローカルで検索します。 スタティック RP マッピングが設定されていない場合、ルータは、デフォルトのデンス モードになります。

ip pim rp-announce filter コマンドを使用すると、そのマッピング エージェントによって RP announcement がフィルタリング(無視)される C-RP を定義する RP マッピング エージェントにポリシーを設定できます。 このコマンドを使用すると、特定の C-RP を許可または拒否することによって、特定または未知のルータからの RP announcement メッセージをフィルタリングするようにマッピング エージェントを設定できます。また、特定のグループ プレフィックスに対する候補 RP からの RP announcement メッセージをフィルタリングすることもできるため、RP マッピング エージェントでフィルタリングされない範囲専用の C-RP としてこのルータを制限できます。


注意    


複数の RP マッピング エージェントを使用する場合は、Auto-RP 動作での矛盾を避けるために、すべてのマッピング エージェントに同じフィルタを設定する必要があります。



注意    


ip pim rp-announce-filter コマンドの設定が不適切だと、RP announcement が無視されることがあります。 また、 ip pim rp-announce-filter コマンドは、マッピング エージェントでのみ設定する必要があります。そうでない場合は、非マッピング エージェントではグループ 224.0.1.39 をリッスンせず、必要なグループから RP へのマッピングを配布する方法がわからないためコマンドは失敗します。


RP マッピング エージェントで RP announcement が許可または拒否される C-RP の IP アドレスを定義する標準アクセス リストを指定するには、rp-list キーワードと access-list 引数を使用します。 C-RP から RP マッピング エージェントに送信された RP announcement から許可または拒否されるマルチキャスト グループを定義する標準アクセス リストを指定するには、group-list キーワードと access-list 引数を使用します。 rp-list キーワードで指定したアクセス リストに一致し、group-list キーワードで指定したアクセス リストに一致する受信 RP announcement メッセージは、この RP マッピング エージェントによってフィルタリングされます。

C-RP のリストを指定していない場合(rp-list キーワードおよび access-list 引数を使用)、このコマンドはすべての C-RP を許可します。 グループ リストを指定していない場合(group-list キーワードおよび access-list 引数を使用)、このコマンドはすべてのグループを拒否します。

ip pim rp-announce-filter コマンドが設定されていない場合、RP マッピング エージェントになることができるルータ(ip pim send-rp-discovery コマンドを使用)は、すべての C-RP からすべてのグループに対するすべての RP announcement を受け入れます。 不要な RP メッセージをフィルタリングするには、RP マッピング エージェントに 1 つまたは複数の ip pim rp-announce-filter コマンドを設定します。

次の例では、アクセス リスト 1 で定義されている C-RP からアクセス リスト 2 で定義されるグループ範囲に対する RP announcement を受け入れるようルータを設定する方法を示します。

ip pim rp-announce-filter rp-list 1 group-list 2
access-list 1 permit 10.0.0.1
access-list 1 permit 10.0.0.2
access-list 2 permit 224.0.0.0 15.255.255.255

関連コマンド

コマンド

説明

access-list(IP 標準)

標準 IP アクセス リストを定義します。

ip pim send-rp-discovery

ルータを RP マッピング エージェントとして設定します。

ip pim send-rp-announce

Auto-RP を使用して、ルータがランデブー ポイント(RP)として動作するグループを設定するには、グローバル コンフィギュレーション モードで ip pim send-rp-announce コマンドを使用します。 このルータを RP としている設定を解除するには、このコマンドの no 形式を使用します。

ip pim [ vrf vrf-name ] send-rp-announce { interface-type interface-number | ip-address } scope ttl-value [ group-list access-list ] [ interval seconds ] [bidir]

no ip pim [ vrf vrf-name ] send-rp-announce { interface-type interface-number | ip-address }

構文の説明

vrf

(任意)マルチキャスト バーチャル プライベート ネットワーク(VPN)ルーティングおよび転送(VRF)インスタンスをサポートします。

vrf-name

(任意)VRF に割り当てられた名前。

interface-type interface-number

RP アドレスを定義するのに使用されるインターフェイス タイプおよびインターフェイス番号。 タイプと番号の値の間に、スペースは不要です。

ip-address

グループの RP の IP アドレス。 この IP アドレスは、直接接続されたアドレスである必要があります。 この引数を指定してコマンドが設定されている場合、RP アナウンス メッセージはこの IP アドレスが接続されているインターフェイスによって参照されます(つまり、RP アナウンス メッセージの IP ヘッダーの送信元アドレスがそのインターフェイスの IP アドレスです)。

scope ttl-value

Auto-RP announcement 数を制限する存続可能時間(TTL)値を指定します。

group-list access-list

(任意)RP アドレスに関連してアドバタイズされるグループ プレフィックスを定義する標準 IP アクセス リストの番号または名前を指定します。 access-list 名には、スペースまたは引用符を含めることができず、番号付けされたアクセス リストと混乱しないように、英文字で始める必要があります。

interval seconds

(任意)RP announcement 間のインターバル(秒数)を指定します。 RP announcement の合計保持時間は、インターバル値の 3 倍に自動設定されます。 デフォルト インターバルは 60 秒です。

bidir

(任意)access-list 引数で指定されるマルチキャスト グループが、双方向モードで動作することを示します。 このキーワードなしでこのコマンドを設定した場合、指定したグループは Protocol Independent Multicast Sparse Mode(PIM-SM)で動作します。

コマンド デフォルト

Auto-RP はディセーブルです。seconds:60

コマンド モード

グローバル コンフィギュレーション

コマンド履歴

リリース

変更内容

11.1

このコマンドが導入されました。

12.1(2)T

このコマンドが変更されました。 次のキーワードと引数が追加されました。

  • interval seconds
  • bidir

12.0(23)S

このコマンドが変更されました。 vrf キーワードと vrf-name 引数が追加されました。

12.2(13)T

このコマンドが変更されました。 vrf キーワードと vrf-name 引数が追加されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.4(5)

このコマンドが変更されました。 ip-address 引数が追加されました。

12.3(17)

このコマンドが変更されました。 ip-address 引数が追加されました。

12.2(18)SXE

このコマンドのサポートが Supervisor Engine 720 に追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRE

このコマンドが変更されました。 ip-address 引数が追加されました。

15.0(1)S

このコマンドが Cisco IOS Release 15.0(1)S に統合されました。

15.1(1)SG

このコマンドが、Cisco IOS Release 15.1(1)SG に統合されました。

Cisco IOS XE Release 3.3SG

このコマンドが、Cisco IOS XE Release 3.3SG に統合されました。

使用上のガイドライン

このコマンドは RP にするルータで入力します。 Auto-RP を使用してグループから RP へのマッピングを分散すると、ルータはこのコマンドにより既知のグループ CISCO-RP-ANNOUNCE(224.0.1.39)に Auto-RP announcement メッセージを送信します。 このメッセージは、ルータがアクセス リストで規定される範囲内のグループに対する RP 候補であることを通知します。

このコマンドは、双方向転送を行う場合で、Auto-RP を使用してグループから RP へのマッピングを分散している場合に、bidir キーワードを指定して使用します。 他のオプションは、次のとおりです。

  • PIM バージョン 2 ブートストラップ ルータ(PIMv2 BSR)メカニズムによりグループから RP へのマッピングを分散する場合は、ip pim rp-candidate コマンドで bidir キーワードを使用します。
  • Auto-RP または PIMv2 BSR メカニズムのどちらによってもグループから RP へのマッピングを分散しない場合は、ip pim rp-address コマンドで bidir キーワードを使用します。

次の例では、最大 31 ホップまですべての Protocol Independent Multicast(PIM)対応インターフェイスに対して RP announcement を送信するようにルータを設定する方法を示します。 ルータで、RP として識別される必要のある IP アドレスは、イーサネット インターフェイス 0 に関連付けられた IP アドレスです。 アクセス リスト 5 はこのルータが RP として機能しているグループを示しています。

ip pim send-rp-announce ethernet0 scope 31 group-list 5
access-list 5 permit 224.0.0.0 15.255.255.255 

関連コマンド

コマンド

説明

access-list(IP 標準)

標準 IP アクセス リストを定義します。

ip pim rp-address

特定のグループの PIM RP のアドレスを設定します。

ip pim rp-candidate

ルータが自身を PIM バージョン 2 の候補 RP として BSR にアドバタイズするよう設定します。

ip pim send-rp-discovery

ルータをランデブー ポイント(RP)マッピング エージェントとして設定するには、グローバル コンフィギュレーション モードで ip pim send-rp-discovery コマンドを使用します。 RP マッピング エージェントとして動作するルータの設定を解除するには、このコマンドの no 形式を使用します。

ip pim [ vrf vrf-name ] send-rp-discovery [ interface-type interface-number ] scope ttl-value [ interval seconds ]

no ip pim [ vrf vrf-name ] send-rp-discovery

構文の説明

vrf vrf-name

(任意)指定したマルチキャスト バーチャル プライベート ネットワーク(VPN)ルーティングおよび転送(MVRF)インスタンスの RP マッピング エージェントとしてルータを設定します。

interface-type interface-number

(任意)RP マッピング エージェントの送信元アドレスとして使用されるインターフェイス タイプおよび番号。

scope ttl-value

Auto-RP 検出メッセージの存続可能時間(TTL)値を指定します。 範囲は 1 ~ 255 です。

interval seconds

(任意)Auto-RP 検出メッセージが送信される間隔を指定します。 範囲は 1 ~ 16383 です。

(注)     

デフォルトでは、Auto-RP 検出メッセージは 60 秒間隔か、RP マッピング エージェントが変更を検出したときに送信されます。

コマンド デフォルト

ルータは、RP マッピング エージェントとして設定されていません。

コマンド モード

グローバル コンフィギュレーション

コマンド履歴

リリース

変更内容

11.1

このコマンドが導入されました。

12.0(23)S

vrf キーワードと vrf-name 引数が追加されました。

12.2(13)T

vrf キーワードと vrf-name 引数が追加されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(18)SXE

このコマンドのサポートが Supervisor Engine 720 に追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.4(8)

interval キーワードと seconds 引数が追加されました。

12.4(9)T

interval キーワードと seconds 引数が追加されました。

12.2(33)SRB

interval キーワードと seconds 引数が追加されました。

12.2(18)SXF11

interval キーワードと seconds 引数が追加されました。

使用上のガイドライン

ルータを RP マッピング エージェントとして設定するには、ip pim send-rp-discovery コマンドを使用します。 RP マッピング エージェントは、Auto-RP announcement メッセージを受信し、ローカル グループから RP へのマッピング キャッシュに保存します。 RP マッピング エージェントは、Auto-RP announcement メッセージに含まれる情報を使用して RP を選択します。 RP マッピング エージェントは、最も大きい IP アドレスを持つ候補 RP をグループ範囲の RP として選択します。

Auto-RP 検出メッセージの IP ヘッダーに含まれる存続可能時間(TTL)値を指定するには、必須の scope キーワードと ttl-value 引数を使用します。


(注)  


scope キーワードと ttl-value 引数に、Protocol Independent Multicast(PIM)ドメインを対象とするのに十分な TTL を指定します。


オプションの interval キーワードと seconds 引数は、Auto-RP 検出メッセージが送信される間隔を指定するために使用します。 デフォルトでは、Auto-RP 検出メッセージは 60 秒間隔か、RP マッピング エージェントが変更を検出したときに送信されます。


(注)  


Auto-RP 検出メッセージが送信される間隔をデフォルト値の 60 秒から減らすと、グループから RP へのマッピングのより頻繁なフラッディングが発生します。 一部のネットワーク環境では、間隔を短縮する欠点(コントロール パケット オーバーヘッドの増加)が利点(グループと RP のマッピングのより頻繁な更新)を上回る場合があります。


Auto-RP が使用されている場合の動作は、次のとおりです。

  1. RP マッピング エージェントは、候補 RP から既知のグループ アドレス CISCO-RP-ANNOUNCE(224.0.1.39)に送信される Auto-RP announcement メッセージをリッスンします。
  2. RP マッピング エージェントは、Auto-RP announcement メッセージから学習した情報をローカル グループから RP へのマッピング キャッシュに保存します。
  3. RP マッピング エージェントは、最も大きい IP アドレスの候補 RP を RP として選択し、送信する Auto-RP 検出メッセージに入れてこの RP をアナウンスします。
  4. RP マッピング エージェントが既知のグループ CISCO-RP-DISCOVERY(224.0.1.40)に送信する Auto-RP 検出メッセージには、RP マッピング エージェントのグループから RP へのマッピング キャッシュから学習した、選択された RP が含まれています。この既知のグループは、Cisco ルータがデフォルトで参加するグループです。
  5. PIM 指定ルータは、224.0.1.40 に送信される Auto-RP 検出メッセージをリッスンして RP を学習し、この RP に関する情報をローカルのグループから RP へのマッピング キャッシュに保存します。

ルータが Auto-RP から学習したすべてのグループから RP へのマッピングを表示するには、show ip pim rp コマンドに mapping キーワードを指定して使用します。

次に、ルータを RP マッピング エージェントとして設定する例を示します。 この例で、RP マッピング エージェントは、Auto-RP メッセージの送信元アドレスとしてループバック 0 を使用するように設定されます。 RP マッピング エージェントから送信された Auto-RP 検出メッセージは、20 ホップの TTL で 50 秒間隔で送信するように設定されます。

ip pim send-rp-discovery loopback 0 scope 20 interval 50

関連コマンド

コマンド

説明

show ip pim rp

関連するマルチキャスト ルーティング エントリとともに、保管されているアクティブな RP を表示します。

ip pim spt-threshold

Protocol Independent Multicast(PIM)のリーフ ルータが、指定されたグループの最短パス送信元ツリーに接続する条件を設定するには、グローバル コンフィギュレーション モードで ip pim spt-threshold コマンドを使用します。 デフォルト値に戻すには、このコマンドの no 形式を使用します。

ip pim [ vrf vrf-name ] spt-threshold { kbps | infinity } [ group-list access-list ]

no ip pim [ vrf vrf-name ] spt-threshold { kbps | infinity } [ group-list access-list ]

Cisco IOS T-Train Release

ip pim [ vrf vrf-name ] spt-threshold { 0 | infinity } [ group-list access-list ]

no ip pim [ vrf vrf-name ] spt-threshold { 0 | infinity } [ group-list access-list ]

構文の説明

vrf vrf-name

(任意)マルチキャスト VPN ルーティング/転送(VRF)インスタンスに割り当てられている名前を指定します。

kbps

トラフィック レート。有効値は、0 ~ 4,294,967 kbps です。

infinity

指定されたグループのすべての送信元が共有ツリーを使用するようになります。

group-list access-list

(任意)しきい値が適用されるグループを指定します。 IP 標準アクセス リストの番号または名前である必要があります。 この値が 0 の場合、しきい値はすべてのグループに適用されます。

0

常に送信元ツリーに切り替えるように指定します。

コマンド デフォルト

このコマンドが使用されない場合は、最初のパケットが新しい送信元から到着するとすぐに、PIM リーフ ルータが最短パス ツリーに加入します。

コマンド モード

グローバル コンフィギュレーション(config)

コマンド履歴

リリース

変更内容

11.1

このコマンドが導入されました。

12.0(23)S

vrf キーワードと vrf-name 引数が追加されました。

12.2(13)T

vrf キーワードと vrf-name 引数が追加されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(18)SXE

このコマンドのサポートが Supervisor Engine 720 に追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

使用上のガイドライン

送信元がトラフィック レート(kbps 値)以上のレートで送信する場合、PIM join メッセージが送信元に向けてトリガーされ、送信元ツリーを構築します。

infinity キーワードを指定すると、指定されたグループのすべての送信元は共有ツリーを使用します。 group-list access-list を指定すると、しきい値が適用されるグループが示されます。

送信元からのトラフィック レートがしきい値のトラフィック レートを下回ると、リーフ ルータが共有ツリーにスイッチ バックして、送信元に向けて prune メッセージを送信します。

次に、しきい値を 4 kbps に設定する例を示します。 トラフィック レートがこのしきい値を上回ると、送信元からグループへのトラフィックによりルータはこの送信元への最短パス ツリーに切り替わります。

Router# configure terminal
Router(config)# ip pim spt-threshold 4

関連コマンド

コマンド

説明

ip pim bidir-neighbor-filter

指定フォワーダ選定にいずれの双方向対応ネイバーを参加させるのかを指定するように ACL を設定します。

ip pim ssm

IP マルチキャスト アドレスの Source Specific Multicast(SSM)範囲を定義するには、グローバル コンフィギュレーション モードで ip pim ssm コマンドを使用します。 SSM 範囲をディセーブルにするには、このコマンドの no 形式を使用します。

ip pim [ vrf vrf-name ] ssm { default | range access-list }

no ip pim [ vrf vrf-name ] ssm { default | range access-list }

構文の説明

vrf

(任意)マルチキャスト バーチャル プライベート ネットワーク(VPN)ルーティングおよび転送(VRF)インスタンスをサポートします。

vrf-name

(任意)VRF に割り当てられた名前。

default

SSM 範囲アクセス リストを 232/8 として定義します。

range access-list

SSM 範囲を定義する標準 IP アクセス リストの番号または名前を指定します。

コマンド デフォルト

このコマンドはディセーブルです。

コマンド モード

グローバル コンフィギュレーション

コマンド履歴

リリース

変更内容

12.1(3)T

このコマンドが導入されました。

12.0(23)S

vrf キーワードと vrf-name 引数が追加されました。

12.2(13)T

vrf キーワードと vrf-name 引数が追加されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(18)SXE

このコマンドのサポートが Supervisor Engine 720 に追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

使用上のガイドライン

IP マルチキャスト アドレスの SSM 範囲が ip pim ssm コマンドで定義されている場合、マルチキャスト発信元検出プロトコル(MSDP)の Source-Active(SA)メッセージは、この SSM 範囲で受け入れられることも、作成されることもありません。

次に、アクセス リスト 4 で定義される IP アドレス範囲の SSM サービスを設定する例を示します。

access-list 4 permit 224.2.151.141
ip pim ssm range 4 

関連コマンド

コマンド

説明

ip igmp v3lite

単一のインターフェイスで IGMP v3lite メンバーシップ レポートの受け入れと処理をイネーブルにします。

ip urd

インターフェイスで予約された URD ポート 659 に送信された TCP パケットの代行受信と URD チャネル加入レポートの処理をイネーブルにします。

ip pim state-refresh disable

Protocol Independent Multicast(PIM)ルータの PIM デンス モード ステート リフレッシュ制御メッセージの処理および転送をディセーブルにするには、グローバル コンフィギュレーション モードで ip pim state-refresh disable コマンドを使用します。 PIM デンス モード ステート リフレッシュ制御メッセージの処理および転送を再びイネーブルにするには、このコマンドの no 形式を使用します。

ip pim [ vrf vrf-name ] state-refresh disable

no ip pim [ vrf vrf-name ] state-refresh disable

構文の説明

vrf

(任意)マルチキャスト バーチャル プライベート ネットワーク(VPN)ルーティングおよび転送(VRF)インスタンスをサポートします。

vrf-name

(任意)VRF に割り当てられた名前。

コマンド デフォルト

PIM デンス モード ステート リフレッシュ制御メッセージの処理および転送は、PIM デンス モード ステート リフレッシュ機能をサポートする Cisco IOS ソフトウェア リリースが実行されている PIM ルータ上でイネーブルです。

コマンド モード

グローバル コンフィギュレーション

コマンド履歴

リリース

変更内容

12.1(5)T

このコマンドが導入されました。

12.0(23)S

vrf キーワードと vrf-name 引数が追加されました。

12.2(13)T

vrf キーワードと vrf-name 引数が追加されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(18)SXE

このコマンドのサポートが Supervisor Engine 720 に追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

使用上のガイドライン

このコマンドを設定すると、PIM hello メッセージから PIM デンス モード ステート リフレッシュ情報が削除されます。

次に、送信元ベースの IP マルチキャスト分散ツリーの下方の PIM デンス モード ステート リフレッシュ制御メッセージの定期的な転送をディセーブルにする例を示します。

ip pim state-refresh disable

関連コマンド

コマンド

説明

ip pim state-refresh origination-interval

PIM ルータに PIM デンス モード ステート リフレッシュ制御メッセージの生成および間隔を設定します。

show ip pim interface

PIM に対して設定されたインターフェイスに関する情報を表示します。

show ip pim neighbor

Cisco IOS ソフトウェアで検出された PIM ネイバーを示します。

ip pim state-refresh origination-interval

Protocol Independent Multicast(PIM)ルータで、PIM デンス モード ステート リフレッシュ制御メッセージの生成および間隔を設定するには、インターフェイス コンフィギュレーション モードで ip pim state-refresh origination-interval コマンドを使用します。 PIM デンス モード ステート リフレッシュ制御メッセージの生成を停止するには、このコマンドの no 形式を使用します。

ip pim state-refresh origination-interval [interval]

no ip pim state-refresh origination-interval [interval]

構文の説明

interval

(任意)PIM デンス モード ステート リフレッシュ制御メッセージ間の秒数。 デフォルトは 60 秒です。 使用可能な間隔の範囲は 4 ~ 100 秒です。

コマンド デフォルト

PIM デンス モード ステート リフレッシュ制御メッセージの生成はディセーブルです。 デフォルトでは、PIM デンス モード ステート リフレッシュをサポートする Cisco IOS ソフトウェア リリースを実行するすべての PIM ルータが、PIM デンス モード ステート リフレッシュ制御メッセージを処理および転送できます。

コマンド モード

インターフェイス コンフィギュレーション(config-if)仮想ネットワーク インターフェイス(config-if-vnet)

コマンド履歴

リリース

変更内容

12.1(5)T

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.1(1)S

このコマンドが変更されました。 PIM デンス モードがイネーブルになっていないインターフェイス上にこのコマンドを設定できるようになりました。

Cisco IOS XE Release 3.2S

このコマンドが変更されました。 仮想ネットワーク インターフェイス コンフィギュレーション モードにおけるこのコマンドのサポートが追加されました。

使用上のガイドライン

このコマンドは、最初のホップのインターフェイス、つまり、PIM-DM マルチキャスト グループの送信元に直接接続された PIM デンス モード ルータで設定します。

Cisco IOS Release 15.1(1)S 以降のリリースでは、このコマンドは、PIM スパース モードがイネーブルのインターフェイスで設定できます。

Cisco IOS Release 15.1(0)S 以前のリリースでは、このコマンドは、PIM デンス モード ステート リフレッシュがイネーブルの場合にだけ、インターフェイスで設定できます。 PIM スパース モードがイネーブルにされているインターフェイスでこのコマンドを設定しようとすると、次の警告メッセージが表示されます。

Warning: PIM State-Refresh cannot be configured on sparse interface

デフォルトでは、PIM デンス モード ステート リフレッシュ制御メッセージの処理および転送は、PIM デンス モード ステート リフレッシュをサポートする Cisco IOS ソフトウェア リリースが実行されている PIM ルータ上でイネーブルです。

次の例では、PIM デンス モード ルータのイーサネット インターフェイス 0 に、ステート リフレッシュ制御メッセージの 80 秒間隔での生成を設定します。

interface ethernet 0
 ip pim state-refresh origination-interval 80

関連コマンド

コマンド

説明

ip pim state-refresh disable

PIM ルータ上で PIM デンス モード ステート リフレッシュ機能制御メッセージの処理および転送をディセーブルにします。

show ip pim interface

PIM に対して設定されたインターフェイスに関する情報を表示します。

show ip pim neighbor

Cisco IOS ソフトウェアで検出された PIM ネイバーを示します。

ip rgmp

イーサネット、ファスト イーサネット、ギガビット イーサネット インターフェイスで Router-Port Group Management Protocol(RGMP)をイネーブルにするには、インターフェイス コンフィギュレーション モードで、ip rgmp コマンドを使用します。 インターフェイスの RGMP をディセーブルにするには、このコマンドの no 形式を使用します。

ip rgmp

no ip rgmp

構文の説明

このコマンドには引数またはキーワードはありません。

コマンド デフォルト

RGMP がディセーブルです。

コマンド モード

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更内容

12.0(10)S

このコマンドが導入されました。

12.1(1)E

このコマンドが Cisco IOS Release 12.1(1)E に統合されました。

12.1(5)T

このコマンドが、Cisco IOS Release 12.1(5)T に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

RGMP は、イーサネット、ファスト イーサネット、およびギガビット イーサネット インターフェイスでのみサポートされています。

RGMP をイネーブルにする前に、次の機能がルータでイネーブルにされている必要があります。

  • IP ルーティング
  • IP マルチキャスト
  • スパース モード、スパース - デンス モード、送信元固有モード、双方向モードの PIM

ルータが双方向グループに含まれている場合は、必ず、指定フォワーダ(DF)として動作しないインターフェイス上でのみ RGMP をイネーブルにしてください。 DF として動作するインターフェイス上で RGMP をイネーブルにすると、このインターフェイスでは、双方向共有ツリー上方のランデブー ポイント(RP)に、マルチキャスト パケットを転送しません。

スイッチで、次の機能がイネーブルである必要があります。

  • IP マルチキャスト
  • IGMP スヌーピング

次に、イーサネット インターフェイス 1/0 上で RGMP をイネーブルにする例を示します。

interface ethernet 1/0
 ip rgmp

関連コマンド

コマンド

説明

debug ip rgmp

RGMP 対応ルータによって送信されたデバッグ メッセージを記録します。

show ip igmp interface

インターフェイスのマルチキャスト関連情報を表示します。

manager

Multicast Routing Monitor(MRM)のマネージャとして機能するインターフェイスを指定し、テスト レシーバでリッスンするマルチキャスト グループ アドレスを指定するには、MRM マネージャ コンフィギュレーション モードで manager コマンドを使用します。 マネージャまたはグループ アドレスを削除するには、このコマンドの no 形式を使用します。

manager interface-type interface-number group ip-address

no manager interface-type interface-number group ip-address

構文の説明

interface-type interface-number

マネージャのインターフェイス タイプおよび番号。 このインターフェイスに関連付けられた IP アドレスはマネージャの送信元アドレスです。

group ip-address

テスト レシーバがリッスンする IP マルチキャスト グループ アドレスを指定します。

コマンド デフォルト

MRM マネージャは設定されていません。

コマンド モード

MRM マネージャ設定(config-mrm-manager)

コマンド履歴

リリース

変更内容

12.0(5)S

このコマンドが導入されました。

12.0(5)T

このコマンドが Cisco IOS Release 12.0(5)T に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

このコマンドは、マネージャとして機能するインターフェイスを識別し、したがって、MRM を実行するために必要です。

次の例では、マルチキャスト グループ 239.1.1.1 をリッスンするように、マネージャとしてのイーサネット インターフェイス 0 およびテスト レシーバを設定する方法を示します。

ip mrm manager test1
 manager ethernet 0 group 239.1.1.1

関連コマンド

コマンド

説明

beacon (multicast routing monitor)

MRM テスト中にマネージャがテスト センダーおよびテスト レシーバに送信するビーコン メッセージの頻度、期間、またはスコープを変更します。

ip mrm accept-manager

テスト センダーまたはテスト レシーバがアクセス リストを渡すマネージャから要求だけを受け入れるように設定します。

show ip mrm manager

MRM のテスト情報を表示します。