C から ip igmp
C から ip igmp
発行日;2013/07/24   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

C から ip igmp

clear ip cgmp

Catalyst スイッチのキャッシュからすべてのグループ エントリを削除するには、特権 EXEC モードで clear ip cgmp コマンドを使用します。

clear ip cgmp [ interface-type interface-number ]

構文の説明

interface-type interface-number

(任意)インターフェイス タイプおよび番号

コマンド モード

特権 EXEC

コマンド履歴

リリース

変更内容

11.1

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

このコマンドは、グループ アドレス 0000.0000.0000 およびユニキャスト アドレス 0000.0000.0000 を持つ Cisco Group Management Protocol(CGMP)の脱退メッセージを送信します。 このメッセージはキャッシュしているすべてのグループ エントリを削除するようにスイッチに指示します。

インターフェイス タイプと番号が指定されている場合、脱退メッセージはそのインターフェイスにのみ送信されます。 それ以外の場合は、すべての CGMP 対応インターフェイスに送信されます。

次に、CGMP キャッシュをクリアする例を示します。

Router# clear ip cgmp

関連コマンド

コマンド

説明

ip cgmp

Catalyst 5000 スイッチに接続されているルータのインターフェイスで CGMP をイネーブルにします。

clear ip msdp peer

指定したマルチキャスト発信元検出プロトコル(MSDP)ピアへの TCP 接続をクリアするには、特権 EXEC モードで clear ip msdp peer コマンドを使用します。

clear ip msdp [ vrf vrf-name ] peer { peer-address | peer-name }

構文の説明

vrf

(任意)マルチキャスト VPN ルーティングおよび転送(VRF)インスタンスをサポートします。

vrf-name

(任意)VRF に割り当てられた名前。

peer-address | peer-name

TCP 接続がクリアされる MSDP ピアの IP アドレスまたは名前。

コマンド デフォルト

このコマンドには、デフォルト設定がありません。

コマンド モード

特権 EXEC

コマンド履歴

リリース

変更内容

12.0(7)T

このコマンドが導入されました。

12.0(23)S

vrf キーワードと vrf-name 引数が追加されました。

12.2(13)T

vrf キーワードと vrf-name 引数が追加されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(18)SXE

このコマンドのサポートが Supervisor Engine 720 に追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

使用上のガイドライン

このコマンドによりピアへの TCP 接続はクローズされ、すべての MSDP ピアの統計情報はリセットされ、MSDP ピアでの入力/出力キューはクリアされます。

次に、10.3.32.154 にある MSDP ピアへの TCP 接続をクリアする方法を示します。

Router# clear ip msdp peer 10.3.32.154

関連コマンド

コマンド

説明

ip msdp peer

MSDP ピアを設定します。

clear ip msdp sa-cache

マルチキャスト発信元検出プロトコル(MSDP)の Source-Active(SA)キャッシュ エントリをクリアするには、特権 EXEC モードで clear ip msdp sa-cache コマンドを使用します。

clear ip msdp [ vrf vrf-name ] sa-cache [ group-address | group-name ]

構文の説明

vrf

(任意)マルチキャスト VPN ルーティングおよび転送(VRF)インスタンスをサポートします。

vrf-name

(任意)VRF に割り当てられた名前。

group-address | group-name

(任意)SA キャッシュから SA エントリがクリアされるマルチキャスト グループのアドレスまたは名前。

コマンド デフォルト

このコマンドには、デフォルト設定がありません。

コマンド モード

特権 EXEC

コマンド履歴

リリース

変更内容

12.0(7)T

このコマンドが導入されました。

12.0(23)S

vrf キーワードと vrf-name 引数が追加されました。

12.2(13)T

vrf キーワードと vrf-name 引数が追加されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(18)SXE

このコマンドのサポートが Supervisor Engine 720 に追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

使用上のガイドライン

キャッシュ内の任意の SA エントリをクリアするには、ip msdp cache-sa-state コマンドを使用して SA キャッシングがイネーブルにされている必要があります。

グループのアドレスまたは名前によりマルチキャスト グループが識別されない場合、すべての SA キャッシュ エントリがクリアされます。

次に、マルチキャスト グループ 10.3.50.152 の SA エントリをキャッシュからクリアする方法を示します。

Router# clear ip msdp sa-cache 10.3.50.152

関連コマンド

コマンド

説明

ip host

MSDP ピアを設定します。

ip msdp cache-sa-state

ルータは SA ステートを作成することができます。

show ip msdp sa-cache

MSDP ピアから学習した(S,G)状態を表示します。

clear ip msdp statistics

セッションをリセットせずに 1 組またはすべてのマルチキャスト発信元検出プロトコル(MSDP)ピアの統計情報カウンタをクリアするには、特権 EXEC モードで clear ip msdp statistics コマンドを使用します。

clear ip msdp [ vrf vrf-name ] statistics { peer-address | peer-name }

構文の説明

vrf

(任意)マルチキャスト VPN ルーティングおよび転送(VRF)インスタンスをサポートします。

vrf-name

(任意)VRF に割り当てられた名前。

peer-address | peer-name

(任意)統計情報カウンタ、リセット カウント、および入力/出力カウントがクリアされる MSDP ピアのアドレスまたは名前。

コマンド デフォルト

このコマンドには、デフォルト設定がありません。

コマンド モード

特権 EXEC

コマンド履歴

リリース

変更内容

12.0(7)T

このコマンドが導入されました。

12.0(23)S

vrf キーワードと vrf-name 引数が追加されました。

12.2(13)T

vrf キーワードと vrf-name 引数が追加されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(18)SXE

このコマンドのサポートが Supervisor Engine 720 に追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

次に、peer1 という名前のピアのカウンタをクリアする例を示します。

Router# clear ip msdp statistics peer1

関連コマンド

コマンド

説明

show ip msdp sa-cache

MSDP ピアから学習した(S,G)状態を表示します。

ip cgmp

Cisco Catalyst スイッチに接続されたルータのインターフェイスの Cisco Group Management Protocol(CGMP)をイネーブルにするには、インターフェイス コンフィギュレーション モードで ip cgmp コマンドを使用します。 CGMP ルーティングをディセーブルにするには、このコマンドの no 形式を使用します。

ip cgmp [ proxy | router-only ]

no ip cgmp

構文の説明

proxy

(任意)CGMP と CGMP プロキシ機能をイネーブルにします。

router-only

(任意)ルータは CGMP self-join メッセージおよび CGMP self-leave メッセージだけを送信できます。

コマンド デフォルト

CGMP はディセーブルです。

コマンド モード

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更内容

11.1

このコマンドが導入されました。

12.2

router-only キーワードが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

インターフェイスでイネーブルにされている場合、このコマンドにより CGMP join メッセージがトリガーされます。 このコマンドは、802 メディア(イーサネット、FDDI、またはトークン リング)または ATM のみで使用する必要があります。 no 形式のip cgmp コマンドが発行されている場合、トリガーされた CGMP 脱退メッセージは、グループ 0000.0000.0000(すべてのグループ)のインターフェイスの MAC アドレスに送信されます。 CGMP は、Protocol Independent Multicast(PIM)が同じインターフェイスで設定されている場合にだけ、インターフェイスで実行できます。

Cisco ルータは IGMP 対応メンバから Internet Group Management Protocol(IGMP)レポートを受け取ることに応じて CGMP join メッセージを送信します。 CGMP クエリアの Cisco ルータのみが、ホストに代わってこれらの CGMP join メッセージを送信します。

ip cgmp router-only コマンドは、VLAN のルータで CGMP self-join メッセージおよび CGMP self-leave メッセージのみを送信できるようにします。その他のタイプの CGMP メッセージは送信されません。 この機能により、他の CGMP 対応ルータでは、マルチキャスト ルータ ポートを学習できます。 ip cgmp router-only コマンドがネットワークで外部ルータのいずれにもない場合は、代わりに ip cgmp コマンドを使用できます。 ルータで ip cgmp コマンドを発行すると、このルータで、CGMP self-join メッセージと CGMP self-leave メッセージ、および他のタイプの CGMP メッセージを送信できるようになります。

proxy キーワードを指定すると、CGMP プロキシ機能もイネーブルになります。 つまり、CGMP に対応していないすべてのルータには、プロキシ ルータによってアドバタイズされます。 プロキシ ルータでは、非 CGMP 対応ルータの MAC アドレスおよびグループ アドレス 0000.0000.0000 が使用されている CGMP join メッセージを送信することによって、他の非 CGMP 対応ルータの存在がアドバタイズされます。

最初にサポートされるのは、ディスタンス ベクトル マルチキャスト ルーティング プロトコル(DVMRP)プロキシ処理です。 PIM ルータではないルータから DVMRP レポートを受信した場合、Cisco IGMP クエリアは、グループ アドレス 0000.0000.0000 の CGMP join メッセージに入れて、DVMRP ルータの MAC アドレスをアドバタイズします。

CGMP プロキシを実行するには、Cisco ルータは IGMP クエリアである必要があります。 ip cgmp proxy コマンドを設定する場合は、Cisco ルータの 1 台が IGMP クエリアになるように IP アドレスを手動で操作する必要があります。このルータは、ネットワークで動作中の IGMP のバージョンに応じて、IP アドレスが最大または最小のルータになります。 IGMP バージョン 2 クエリアは、インターフェイスで最小の IP アドレスを持つルータかどうかに基づいて選択されます。 IGMP バージョン 1 クエリアは、インターフェイスで使用されるマルチキャスト ルーティング プロトコルに基づいて選択されます。

複数の Cisco ルータがスイッチド ネットワークに接続されており、ip cgmp proxy コマンドを使用する必要がある場合は、すべてのルータを次のように設定することをお勧めします。

  • 同じ CGMP オプションを使用します。
  • IGMP クエリアになる優先順位をシスコ製以外のルータよりも高くします。

次に、CGMP をイネーブルにする例を示します。

ip cgmp

次に、CGMP と CGMP プロキシをイネーブルにする例を示します。

ip cgmp proxy

ip igmp access-group

標準 IP アクセス リストで許可されているマルチキャスト グループのみに参加するようにサブネットのホスト(レシーバ)を制限するか、拡張 IP アクセス リストによって許可されている(S,G)チャネルのみにサブネットのホスト(レシーバ)の加入を制限する場合は、インターフェイス コンフィギュレーション モードで、ip igmp access-group コマンドを使用します。 このコントロールをディセーブルにするには、このコマンドの no 形式を使用します。

ip igmp access-group access-list

no ip igmp access-group access-list

構文の説明

access-list

アクセス リストの番号または名前。

コマンド デフォルト

ディセーブル(受信側アクセス コントロールのためにアクセス リストは設定されません)。

コマンド モード

インターフェイス コンフィギュレーション(config-if)仮想ネットワーク インターフェイス(config-if-vnet)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.3(7)T

拡張アクセス リストのサポートが追加されました。

12.2(25)S

このコマンドが、Cisco IOS Release 12.2(25)S に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

Cisco IOS XE Release 3.2S

このコマンドが変更されました。 仮想ネットワーク インターフェイス コンフィギュレーション モードにおけるこのコマンドのサポートが追加されました。

使用上のガイドライン

標準のアクセス リストを使用して Internet Group Management Protocol(IGMP)レポートからグループをフィルタリングするか、拡張アクセス リストを使用して IGMPv3 レポートからソースおよびグループをフィルタリングするには、ip igmp access-group コマンドを使用します。 このコマンドは、標準 IP アクセス リストで許可されているマルチキャスト グループだけに加入するようにサブネットのホストを制限するか、拡張 IP アクセス リストによって許可されている(S,G)チャネルだけにサブネットのホストの加入を制限するために使用されます。

IGMP バージョン 3(IGMPv3)は、拡張アクセス リストに対応しています。これにより、IPv4 での Source Specific Multicast(SSM)の重要な利点である、ソース IP アドレスに基づくアクセスを活用できます。 この機能の導入前は、IGMP アクセス リストは標準アクセス リストだけを受け入れ、マルチキャスト グループ アドレスに基づくメンバーシップ レポートのフィルタリングだけが可能でした。

IGMPv3 では、マルチキャスト レシーバは、グループに加入できるだけでなく、ソースを含むグループまたは含まないグループに加入できます。 したがって、適切なアクセス コントロールを行うには、報告されるグループ アドレスのみによるのではなく、グループ アドレスとソース アドレスによる IGMPv3 メッセージのフィルタリングが可能である必要があります。 IGMP 拡張アクセス リストに、この機能が導入されました。 IGMP 拡張アクセス リストとともに SSM を使用すると、IGMPv3 レポートのソース S およびグループ G(S, G)を許可または拒否できるため、ソース アドレス、グループ アドレス、または両方に基づいて SSM トラフィックをフィルタリングできます。

ASM グループの IGMPv3 レポートのソース アドレス

また、IGMP 拡張アクセス リストを使用すると、(0.0.0.0, G)に基づいてトラフィックを許可またはフィルタリングできます。これは、Any Source Multicast(ASM)など SSM でないマルチキャストであり、IGMP レポートでは(*, G)です。


(注)  


(*, G)と同等の permit および deny ステートメントは、それぞれ permit host 0.0.0.0 host group-address および deny host 0.0.0.0 host group group-address です。


フィルタリングは、ASM グループと SSM グループの両方の IGMPv3 レポートに適用されますが、ASM グループの IGMPv3 レポートもあるソース アドレスは、マルチキャスト ルーティングで無視されるため、フィルタリングは、SSM グループにとって重要です。 ASM グループに対する IGMPv3 メンバーシップ レポートのソース アドレスは、IGMP キャッシュに保存されます(show ip igmp membership コマンドで表示)が、PIM ベース IP マルチキャスト ルーティングでは、レポートされる ASM グループのみが考慮に入れられます。 したがって、ASM グループのソース アドレスのフィルタリングを追加すると、ASM グループの IGMP キャッシュのみに影響します。

IGMP による拡張アクセス リストのチェック方法

インターフェイス上の ip igmp access-group コマンドで IGMP 拡張アクセス リストが参照される場合、拡張アクセス リストの permit ステートメントおよび deny ステートメントの(S, G)ペアは、このインターフェイスで受信した IGMP レポートの(S, G)ペアと照合されます。 拡張アクセス リスト節の最初の部分はソースを制御し、拡張アクセス リスト節の 2 番目の部分はマルチキャスト グループを制御します。

具体的には、(S1, S2...Sn, G) が使用されている IGMP レポートが受信されると、最初のグループ (0, G) が、アクセス リスト ステートメントに対してチェックされます。 グループが拒否された場合、その IGMP レポート全体が拒否されます。 グループが許可された場合は、個々の各(S, G)ペアがアクセス リストでチェックされます。 拒否されたソースは IGMP レポートから除外されるため、アクセス リストに一致するソースからグループへの送信が拒否されます。


(注)  


(0, G)という表記は(*, G)を意味し、これは、マルチキャスト グループ番号が使用されたワイルドカード ソースです。


次の例では、レシーバが加入できるインターフェイス上のグループをフィルタリングするように、標準のアクセス リストを設定する方法を示します。 この例では、226.1.0.0 ~ 226.1.255.255 の範囲のグループに対するレシーバの加入を制限するようにイーサネット インターフェイス 1/3 が設定されます。 レシーバはイーサネット インターフェイス 1/3 で他のすべてのグループに参加できます。

access-list 1 deny 226.1.0.0 0.0.255.255
access-list 1 permit any log
!
interface ethernet 1/3
 ip igmp access-group 1

(注)  


アクセス リストは非常に柔軟です。1 つのアクセス リストで、permit ステートメントと deny ステートメントのほとんど無限の組み合わせによって、マルチキャスト トラフィックをフィルタリングできます。 この項では、少しの例を示します。


次に、グループ G ですべての状態を拒否する例を示します。 この例では、IGMPv3 レポートの SSM グループ 232.2.2.2 に対するすべてのソースがフィルタリングされるよう、FastEthernet インターフェイス 0/0 が設定されます。これにより、このグループが効果的に拒否されます。

ip access-list extended test1
 deny igmp any host 232.2.2.2
 permit igmp any any
!
interface FastEthernet0/0
 ip igmp access-group test1
!

次に、ソース S ですべての状態を拒否する例を示します。 この例では、IGMPv3 レポートのソース 10.2.1.32 に対するすべてのグループがフィルタリングされるよう、イーサネット インターフェイス 1/1 が設定されます。これにより、このソースが効果的に拒否されます。

ip access-list extended test2
 deny igmp host 10.2.1.32 any
 permit igmp any any
!
interface Ethernet1/1
 ip igmp access-group test2

次に、グループ G ですべての状態を許可する例を示します。 この例では、IGMPv3 レポートの SSM グループ 232.1.1.10 に対するすべてのソースを受け入れるよう、イーサネット インターフェイス 1/1 が設定されます。これにより、このグループ全体を効果的に受け入れます。

ip access-list extended test3
 permit igmp any host 232.1.1.10
!
interface Ethernet1/1
 ip igmp access-group test3

次に、ソース S ですべての状態を許可する例を示します。 この例では、IGMPv3 レポートのソース 10.6.23.32 に対するすべてのグループが受け付けられるよう、イーサネット インターフェイス 1/2 が設定されます。これにより、このソース全体が効果的に受け付けられます。

!
ip access-list extended test4
 permit igmp host 10.6.23.32 any
!
interface Ethernet1/2
 ip igmp access-group test4
!

次に、グループ G で特定のソース S をフィルタリングする例を示します。 この例では、IGMPv3 レポートの SSM グループ 232.2.30.30 の発信元 232.2.2.2 をフィルタリングするよう、イーサネット インターフェイス 0/3 が設定されます。

ip access-list extended test5
 deny igmp host 10.4.4.4 host 232.2.30.30
 permit igmp any any
!
interface Ethernet0/3
 ip igmp access-group test5

ip igmp helper-address

このインターフェイスで受信したすべての Internet Group Management Protocol(IGMP)ホスト レポートおよび脱退メッセージを、指定した IP アドレスに転送するようにシステムを設定するには、インターフェイス コンフィギュレーション モードで ip igmp helper-address コマンドを使用します。 このような転送をディセーブルにするには、このコマンドの no 形式を使用します。

ip igmp helper-address ip-address

no ip igmp helper-address

構文の説明

ip-address

IGMP ホスト レポートと脱退メッセージの転送先 IP アドレス。 中央ルータのインターフェイスの IP アドレスを指定します。

コマンド デフォルト

IGMP ホスト レポートと脱退メッセージは転送されません。

コマンド モード

インターフェイス コンフィギュレーション(config-if)仮想ネットワーク インターフェイス(config-if-vnet)

コマンド履歴

リリース

変更内容

11.2 F

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 3.2S

このコマンドが変更されました。 仮想ネットワーク インターフェイス コンフィギュレーション モードにおけるこのコマンドのサポートが追加されました。

使用上のガイドライン

このコマンドと、ip pim neighbor-filter コマンドを組み合わせて、スタブ マルチキャスト ルーティングを可能にします。 IGMP ホスト レポートと脱退メッセージは、指定した IP アドレスに転送されます。 レポートでは、この IP アドレスへのネクスト ホップ インターフェイスから、このインターフェイスの送信元アドレスを含めて再送信されます。 このコマンドは一種の「dense-mode」join をイネーブルにするため、Protocol Independent Multicast(PIM)に参加していないスタブ サイトが IP マルチキャスト グループのメンバーシップを示せるようになります。

次に、ルータ A でスタブ マルチキャスト ルーティングをイネーブルにする例を示します。このルータには、IP アドレス 10.0.0.1 の発信インターフェイスがあります。 ルータ B は、アドレス 10.0.0.2 の着信インターフェイスを備えた中央ルータです。 アクセス リスト 1 は、送信元(スタブ ルータ A)からの PIM メッセージをフィルタリングします。

ip multicast-routing
 ip pim dense-mode
 ip igmp helper-address 10.0.0.2

ip multicast-routing
 ip pim dense-mode : or ip pim sparse-mode
 ip pim neighbor-filter 1
access-list 1 deny 10.0.0.1

関連コマンド

コマンド

説明

ip pim neighbor-filter

PIM へのルータの参加を禁止します(スタブ マルチキャスト ルーティングの設定など)。

ip igmp limit(グローバル)

Internet Group Management Protocol(IGMP)メンバーシップ レポート(IGMP joins)の結果として作成されたマルチキャスト ルート(mroute)ステートの数に関するグローバル制限を設定するには、グローバル コンフィギュレーション モードで ip igmp limit コマンドを使用します。 グローバル IGMP ステート リミッタによる制限を削除するには、このコマンドの no 形式を使用します。

ip igmp limit number

no ip igmp limit number

構文の説明

number

キャッシュできる IGMP メンバーシップ レポートの最大数。 範囲は 1 ~ 64000 です。

コマンド デフォルト

グローバルな IGMP ステート リミッタは設定されていません。

コマンド モード

グローバル コンフィギュレーション(config)

コマンド履歴

リリース

変更内容

12.2(14)S

このコマンドが導入されました。

12.2(15)T

このコマンドが、Cisco IOS Release 12.2(15)T に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

このコマンドは、IGMP メンバーシップ レポート(IGMP joins)の結果として作成される mroute ステートの数に対するグローバルな制限を設定するために使用します。 グローバルに設定した場合、制限はグローバル IGMP ステート リミッタと呼ばれます。 設定されている制限を超えたメンバーシップ レポートは、IGMP キャッシュに入れられません。 このコマンドは、DoS 攻撃を防ぐために使用できます。


(注)  


IGMP ステート リミッタは、IGMP、IGMP v3lite、および URL Rendezvous Directory(URD)メンバーシップ レポートから生じる route ステートの数に、グローバルまたはインターフェイスごとに制限をかけます。


IGMP メンバーシップ レポート(IGMP joins)の結果として作成される mroute ステートの数に関するインターフェイスごとの制限を設定するには、ip igmp limit (interface) コマンドを使用します。


(注)  


IGMP ステート リミッタを設定する場合は、ルータに対して 1 つのグローバル制限と、インターフェイスごとに 1 つの制限しか設定できません。


IGMP ステート リミッタのメカニズムは、次のとおりです。

  • 特定のグループまたはチャネルに対する IGMP メンバーシップ レポートをルータが受信するたびに、Cisco IOS ソフトウェアでは、グローバル IGMP ステート リミッタの制限またはインターフェイスごとの IGMP ステート リミッタの制限に到達しているかどうかをチェックします。
    • グローバル IGMP ステート リミッタだけが設定されていて、その制限に達していない場合は、IGMP メンバーシップ レポートは受け入れられます。 設定されている制限に達した場合は、以降の IGMP メンバーシップ レポートは無視され(ドロップされ)、次のいずれかの形式の警告メッセージが生成されます。
%IGMP-6-IGMP_GROUP_LIMIT: IGMP limit exceeded for <group (*, group address)> on <interface type number> by host <ip address>

または

%IGMP-6-IGMP_CHANNEL_LIMIT: IGMP limit exceeded for <channel (source address, group address)> on <interface type number> by host <ip address>
    • インターフェイスごとの IGMP ステート リミッタだけに達した場合、各制限はそれが設定されているインターフェイスに対してだけカウントされます。
    • グローバル IGMP ステート リミッタとインターフェイスごとの IGMP ステート リミッタの両方が設定されている場合、インターフェイスごとの IGMP ステート リミッタに設定されている制限も実施されますが、グローバル制限により制約されます。
  • ip igmp limit(interface)コマンドを使用してインターフェイスごとの IGMP ステート リミッタが設定されている場合、Cisco IOS ソフトウェアは(オプションの except キーワードおよび access-list 引数により)アクセス コントロール リスト(ACL)が指定されているかどうかもチェックして、インターフェイス制限に対してグループやチャネルはカウントされないようにします。
    • ACL が設定されており、IGMP メンバーシップ レポート内のグループまたはチャネルが一致する場合、IGMP メンバーシップのステートは、グローバルな制限に対してはカウントされますが、インターフェイス制限に対してはカウントされません。
    • ACL が設定されていない場合は、インターフェイスごとの IGMP ステート リミッタが、設定済みの制限を超えないすべての IGMP メンバーシップ レポートに計上されます。

次の例では、IGMP メンバーシップ レポートの結果として作成される mroute ステートの数を 300 に制限するグローバル IGMP ステート リミッタを設定する方法を示します。

ip igmp limit 300

関連コマンド

コマンド

説明

ip igmp limit(インターフェイス)

IGMP メンバーシップ レポートの結果として作成される、インターフェイスごとの mroute ステートの数を制限します。

show ip igmp groups

インターフェイス上の IGMP のステータスと設定およびマルチキャスト ルーティングに関する情報を表示します。

ip igmp limit(インターフェイス)

Internet Group Management Protocol(IGMP)メンバーシップ レポート(IGMP joins)の結果として作成されたマルチキャスト ルート(mroute)ステートの数に関するインターフェイスごとの制限を設定するには、インターフェイス コンフィギュレーション モードで ip igmp limit コマンドを使用します。 インターフェイスごとの IGMP ステート リミッタによって課せられる制限を削除するには、このコマンドの no 形式を使用します。

ip igmp limit number [ except access-list ]

no ip igmp limit number [ except access-list ]

構文の説明

number

ルータまたはインターフェイスで許可される IGMP ステートの最大数。 範囲は 1 ~ 64000 です。

except access-list

(任意)グループまたはチャネルが、インターフェイス制限に対してカウントされることを防止します。 標準または拡張アクセス コントロール リスト(ACL)を access-limit 引数に指定できます。

  • 標準 ACL は、(*, G) ステートがインターフェイスへの制限から除外されるように定義するのに使用できます。
  • 拡張 ACL は、(S, G) ステートがインターフェイスへの制限から除外されるように定義するのに使用できます。 拡張 ACL は、拡張アクセス リストを構成する permit ステートメントまたは deny ステートメントの中で送信元アドレスと送信元ワイルドカードに 0.0.0.0 を指定することにより((0, G)と見なされます)インターフェイスへの制限から除外される(*, G)ステートを定義するのにも使用できます。

コマンド デフォルト

インターフェイスごとの IGMP ステート リミッタは設定されません。

コマンド モード

インターフェイス コンフィギュレーション(config-if)仮想ネットワーク インターフェイス(config-if-vnet)

コマンド履歴

リリース

変更内容

12.2(14)S

このコマンドが導入されました。

12.2(15)T

このコマンドが、Cisco IOS Release 12.2(15)T に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 3.2S

このコマンドが変更されました。 仮想ネットワーク インターフェイス コンフィギュレーション モードにおけるこのコマンドのサポートが追加されました。

使用上のガイドライン

このコマンドは、IGMP メンバーシップ レポート(IGMP joins)の結果として作成される mroute ステートの数に対するインターフェイスごとの制限を設定するために使用します。 インターフェイスで設定する場合、この制限は、インターフェイスごとの IGMP ステート リミッタと呼びます。 インターフェイスに設定されている制限を超えたメンバーシップ レポートは、IGMP キャッシュに入れられません。 このコマンドにより、DoS 攻撃を防止したり、すべてのマルチキャスト フローがほぼ同量の帯域幅を使用するネットワーク環境でマルチキャスト Call Admission Control(CAC)メカニズムを提供することができます。


(注)  


IGMP ステート リミッタは、IGMP、IGMP v3lite、および URD メンバーシップ レポートから生じる route ステートの数に、グローバルにかまたはインターフェイスごとに制限をかけます。


必須の number 引数には、キャッシュできる IGMP メンバーシップ レポートの数に対する指定したインターフェイスへの制限を指定します。 範囲は 1 ~ 64000 です。

オプションの except access-list キーワードと引数を使用すれば、グループまたはチャネルがインターフェイス制限に対してカウントされることがなくなります。 標準 ACL または拡張 ACL を指定できます。

    • 標準 ACL は、(*, G) ステートがインターフェイスへの制限から除外されるように定義するのに使用できます。
    • 拡張 ACL は、(S, G) ステートがインターフェイスへの制限から除外されるように定義するのに使用できます。 拡張 ACL は、拡張アクセス リストを構成する permit ステートメントまたは deny ステートメントの中で送信元アドレスと送信元ワイルドカードに 0.0.0.0 を指定することにより((0, G)と見なされます)インターフェイスへの制限から除外される(*, G)ステートを定義するのにも使用できます。

IGMP メンバーシップ レポート(IGMP joins)の結果として作成される mroute ステートの数に関するグローバルな制限を設定するには、ip igmp limit(グローバル)コマンドを使用します。


(注)  


IGMP ステート リミッタを設定する場合は、ルータに対して 1 つのグローバル制限と、インターフェイスごとに 1 つの制限しか設定できません。


IGMP ステート リミッタのメカニズムは、次のとおりです。

  • 特定のグループまたはチャネルに対する IGMP メンバーシップ レポートをルータが受信するたびに、Cisco IOS ソフトウェアでは、グローバル IGMP ステート リミッタの制限またはインターフェイスごとの IGMP ステート リミッタの制限に到達しているかどうかをチェックします。
    • グローバル IGMP ステート リミッタだけが設定されていて、その制限に達していない場合は、IGMP メンバーシップ レポートは受け入れられます。 設定されている制限に達した場合は、以降の IGMP メンバーシップ レポートは無視され(ドロップされ)、次のいずれかの形式の警告メッセージが生成されます。
%IGMP-6-IGMP_GROUP_LIMIT: IGMP limit exceeded for <group (*, group address)> on <interface type number> by host <ip address>

または

%IGMP-6-IGMP_CHANNEL_LIMIT: IGMP limit exceeded for <channel (source address, group address)> on <interface type number> by host <ip address>
    • インターフェイスごとの IGMP ステート リミッタだけに達した場合、各制限はそれが設定されているインターフェイスに対してだけカウントされます。
    • グローバル IGMP ステート リミッタとインターフェイスごとの IGMP ステート リミッタの両方が設定されている場合、インターフェイスごとの IGMP ステート リミッタに設定されている制限も実施されますが、グローバル制限により制約されます。
  • ip igmp limit(interface)コマンドを使用してインターフェイスごとの IGMP ステート リミッタが設定されている場合、Cisco IOS ソフトウェアは(オプションの except キーワードおよび access-list 引数により)ACL が指定されているかどうかもチェックして、インターフェイス制限に対してグループやチャネルがカウントされないようにします。
    • ACL が設定されており、IGMP メンバーシップ レポート内のグループまたはチャネルが一致する場合、IGMP メンバーシップのステートは、グローバルな制限に対してはカウントされますが、インターフェイス制限に対してはカウントされません。
    • ACL が設定されていない場合は、インターフェイスごとの IGMP ステート リミッタが、設定済みの制限を超えないすべての IGMP メンバーシップ レポートに計上されます。

次の例では、ギガビット イーサネット インターフェイス 0/1 で、IGMP メンバーシップ レポートの結果として作成される mroute ステートの数を 100 に制限するインターフェイスごとのリミッタを設定する方法を示します。

interface GigabitEthernet 0/1
 ip igmp limit 100

関連コマンド

コマンド

説明

ip igmp limit(グローバル)

IGMP メンバーシップ レポート(IGMP joins)の結果である IGMP ステートの数をグローバルに制限します。

show ip igmp groups

ルータに直接接続されているレシーバと IGMP によって学習されたレシーバを持つマルチキャスト グループを表示します。

show ip igmp interface

インターフェイス上の IGMP のステータスと設定およびマルチキャスト ルーティングに関する情報を表示します。

ip igmp mroute-proxy

プロキシされた(*, G)マルチキャスト スタティック ルート(mroute)エントリの Internet Group Management Protocol(IGMP)レポート転送をイネーブルにするには、インターフェイス コンフィギュレーション モードで、ip igmp mroute-proxy コマンドを使用します。 このサービスをディセーブルにするには、このコマンドの no 形式を使用します。

ip igmp mroute-proxy interface-type interface-number

no ip igmp mroute-proxy interface-type interface-number

構文の説明

interface-type interface-number

インターフェイスのタイプと番号

コマンド デフォルト

このコマンドはディセーブルです。

コマンド モード

インターフェイス コンフィギュレーション(config-if)仮想ネットワーク インターフェイス(config-if-vnet)

コマンド履歴

リリース

変更内容

12.1(5)T

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 3.2S

このコマンドが変更されました。 仮想ネットワーク インターフェイス コンフィギュレーション モードにおけるこのコマンドのサポートが追加されました。

使用上のガイドライン

ip igmp proxy-service インターフェイス コマンドと組み合わせて使用した場合、このコマンドにより、マルチキャスト転送テーブルにあるこのインターフェイスに対するすべての(*, G)転送エントリのプロキシ サービス インターフェイスへの IGMP レポートの転送が可能になります。

次の例では、mroute テーブルにありイーサネット インターフェイス 1 に転送されるすべてのグループについて、IGMP レポートをループバック インターフェイス 0 に送信するよう要求するように、イーサネット インターフェイス 1 上で ip igmp mroute-proxy コマンドを設定する方法を示します。 次の例は、ip igmp mroute-proxy コマンドを使用して登録されているインターフェイスのすべてのグループに対するこのインターフェイスからの IGMP レポートの転送をイネーブルにするようにインターフェイス 0 で ip igmp proxy-service コマンドを設定する方法も示しています。

interface loopback 0
ip address 10.7.1.1 255.255.255.0
ip pim dense-mode
ip igmp helper-address udl ethernet 0
ip igmp proxy-service
!
interface ethernet 0
ip address 10.2.1.1 255.255.255.0
ip pim dense-mode
ip igmp unidirectional link
!
interface ethernet 1
ip address 10.1.1.1 255.255.255.0
ip pim sparse-mode
ip igmp mroute-proxy loopback 0

関連コマンド

コマンド

説明

ip igmp proxy-service

mroute プロキシ サービスをイネーブルにします。

ip igmp unidirectional-link

インターフェイスを単一方向に設定し、IGMP UDLR に対してイネーブルにします。

ip igmp proxy-service

mroute プロキシ サービスをイネーブルにするには、インターフェイス コンフィギュレーション モードで ip igmp proxy-service コマンドを使用します。 転送をディセーブルにするには、このコマンドの no 形式を使用します。

ip igmp proxy-service

no ip igmp proxy-service

構文の説明

このコマンドには引数またはキーワードはありません。

コマンド デフォルト

このコマンドはディセーブルです。

コマンド モード

インターフェイス コンフィギュレーション(config-if)仮想ネットワーク インターフェイス(config-if-vnet)

コマンド履歴

リリース

変更内容

12.1(5)T

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 3.2S

このコマンドが変更されました。 仮想ネットワーク インターフェイス コンフィギュレーション モードにおけるこのコマンドのサポートが追加されました。

使用上のガイドライン

Internet Group Management Protocol(IGMP)クエリー間隔に基づき、ルータでは、ip igmp mroute-proxy コマンドを使用して設定されているインターフェイスと一致する(*, G)転送エントリを確認するために、スタティック マルチキャスト ルート(mroute)テーブルを定期的にチェックします。 一致するエントリが存在する場合、IGMP レポートが 1 つ作成され、このインターフェイスで受信されます。 ip igmp proxy-service コマンドは、ip igmp helper-address(UDL)コマンドとともに使用することが意図されています。この場合、IGMP レポートはアップストリーム ルータに転送されます。

次の例では、mroute テーブルにありイーサネット インターフェイス 1 に転送されるすべてのグループについて、IGMP レポートをループバック インターフェイス 0 に送信するよう要求するように、イーサネット インターフェイス 1 上で ip igmp mroute-proxy コマンドを設定する方法を示します。 次の例は、ip igmp mroute-proxy コマンドを使用して登録されているインターフェイスのすべてのグループに対するこのインターフェイスからの IGMP レポートの転送をイネーブルにするようにインターフェイス 0 で ip igmp proxy-service コマンドを設定する方法も示しています。

interface loopback 0
ip address 10.7.1.1 255.255.255.0
ip pim dense-mode
ip igmp helper-address udl ethernet 0
ip igmp proxy-service
!
interface ethernet 0
ip address 10.2.1.1 255.255.255.0
ip pim dense-mode
ip igmp unidirectional link
!
interface ethernet 1
ip address 10.1.1.1 255.255.255.0
ip pim sparse-mode
ip igmp mroute-proxy loopback 0

関連コマンド

コマンド

説明

ip igmp helper-address(UDL)

IGMP UDLR に必要な IGMP ヘルパーを設定します。

ip igmp mroute-proxy

プロキシされた(*, G)mroute エントリの IGMP レポートの転送をイネーブルにします。

ip igmp unidirectional-link

インターフェイスを単一方向に設定し、IGMP UDLR に対してイネーブルにします。

ip igmp snooping

Internet Group Management Protocol(IGMP)スヌーピングをグローバルにイネーブルにするか、特定のインターフェイスでイネーブルにするには、グローバル コンフィギュレーション モード、インターフェイス コンフィギュレーション モード、またはブリッジ ドメイン コンフィギュレーション モードで ip igmp snooping コマンドを使用します。 IGMP スヌーピングをディセーブルにするには、このコマンドの no 形式を使用します。

ip igmp snooping

no ip igmp snooping

構文の説明

このコマンドには引数またはキーワードはありません。

コマンド デフォルト

IGMP スヌーピングは、グローバルにイネーブルです。

コマンド モード

グローバル コンフィギュレーション(config)

インターフェイス コンフィギュレーション(config-if)

ブリッジ ドメイン コンフィギュレーション(config-bdomain)

コマンド履歴

リリース

変更内容

12.0(5.2)WC(1)

このコマンドが導入されました。

12.2(15)ZJ

このコマンドが Cisco 2600 シリーズ、Cisco 3600 シリーズ、および Cisco 3700 シリーズのルータ プラットフォームに追加されました。

12.2(14)SX

このコマンドのサポートが Supervisor Engine 720 に実装されました。

12.3(4)T

このコマンドが、Cisco 2600 シリーズ、Cisco 3600 シリーズ、および Cisco 3700 シリーズ ルータ上の Cisco IOS Release 12.3(4)T に統合されました。

12.2(17d)SXB

このコマンドが Supervisor Engine 2 に実装されました。

Cisco IOS XE Release 3.5S

このコマンドが Cisco IOS XE Release 3.5S に統合されました。 このコマンドのサポートが、ブリッジ ドメイン コンフィギュレーション モードに追加されました。

15.2(4)S

このコマンドが Cisco IOS Release 15.2(4)S に統合されました。

使用上のガイドライン

IGMP スヌーピングがグローバルにイネーブルである場合は、IGMP スヌーピングはすべての既存 VLAN インターフェイスでイネーブルになります。 IGMP スヌーピングがグローバルにディセーブルである場合は、IGMP スヌーピングはすべての既存 VLAN インターフェイスでディセーブルになります。

IGMP スヌーピングがグローバルにディセーブルである場合は、IGMP スヌーピングはすべての既存ブリッジ ドメイン インターフェイスでディセーブルになります。 IGMP スヌーピングがグローバルにイネーブルになっている場合、IGMP スヌーピングが特定のブリッジ ドメイン インターフェイスで明示的にディセーブルにされていない限り、IGMP スヌーピングは、既存のすべてのブリッジ ドメイン インターフェイスでイネーブルです。 IGMP スヌーピングがグローバルおよび特定のブリッジ ドメイン インターフェイスでディセーブルの場合、IGMP スヌーピングをグローバルにイネーブルにしても、ブリッジ ドメイン インターフェイスのスヌーピングはイネーブルになりません。ブリッジ ドメイン インターフェイスで明示的にイネーブルにする必要があります。

IGMP 設定を検証するには、show ip igmp snooping 特権 EXEC コマンドを使用します。

設定は、NVRAM に保存されます。

Cisco 7600 シリーズ ルータの場合:Cisco 7600 シリーズ ルータの IGMP スヌーピングをイネーブルにする前に、マルチキャスト ルーティング用に VLAN インターフェイスを設定する必要があります。

次の例では、IGMP スヌーピングをグローバルにディセーブルにする方法および指定したブリッジ ドメイン インターフェイス上で IGMP スヌーピングをディセーブルにする方法を示します。

Router(config)# no ip igmp snooping
Router(config)# exit
Router# show running-config
.
.
.
no ip igmp snooping
Router(config)# bridge-domain1
Router(config-bdomain)# no ip igmp snooping
Router(config-bdomain)# end
Router# show running-config
.
.
.
bridge-domain 1 
 no ip igmp snooping
!
!

次の例では、明示的にディセーブルにした後で、IGMP スヌーピングをグローバルにイネーブルにする方法を示します。

Router(config)# ip igmp snooping

関連コマンド

コマンド

説明

ip igmp snooping fast-leave

IGMPv3 スヌーピングの高速脱退処理をイネーブルにします。

ip igmp snooping vlan

VLAN インターフェイス上で IGMP スヌーピングをイネーブルにします。

ip igmp snooping vlan immediate-leave

IGMP 即時脱退処理をイネーブルにします。

ip igmp snooping vlan mrouter

レイヤ 2 ポートをマルチキャスト ルータ ポートとして設定します。

ip igmp snooping vlan static

レイヤ 2 ポートをグループのメンバとして設定します。

show ip igmp snooping

IGMP スヌーピング設定を表示します。

ip igmp snooping last-member-query-interval

IGMP スヌーピングの最終メンバ クエリー インターバルを設定するには、インターフェイス コンフィギュレーション モードまたはブリッジ ドメイン コンフィギュレーション モードで ip igmp snooping last-member-query-interval コマンドを使用します。 デフォルト設定に戻すには、このコマンドの no 形式を使用します。

ip igmp snooping last-member-query-interval interval

no ip igmp snooping last-member-query-interval

構文の説明

interval

レポートを受信しない場合に、この時間の経過後にグループ レコードが削除される時間(ミリ秒単位)。 デフォルトは 1000 です。 詳細については、「使用上のガイドライン」の項を参照してください。

インターフェイスの場合、有効範囲は 100 ~ 999 にある 100 の倍数です。 100 の倍数でないインターバルを入力すると、100 未満の端数が切り捨てられます。 たとえば、999 と入力した場合、端数が切り捨てられて 900 ミリ秒になります。

ブリッジ ドメイン インターフェイスの場合、有効範囲は 100 ~ 32767 です。

コマンド デフォルト

デフォルトのインターバルは 1000 ミリ秒(1 秒)です。

コマンド モード

インターフェイス コンフィギュレーション(config-if)

ブリッジ ドメイン コンフィギュレーション(config-bdomain)

コマンド履歴

リリース

変更内容

12.2(14)SX

このコマンドが Supervisor Engine 720 に導入されました。

12.2(17d)SXB

このコマンドが、Release 12.2(17d)SXB に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

Cisco IOS XE Release 3.5S

このコマンドが Cisco IOS XE Release 3.5S に統合されました。 このコマンドのサポートが、ブリッジ ドメイン コンフィギュレーション モードに追加されました。

15.2(4)S

このコマンドが Cisco IOS Release 15.2(4)S に統合されました。

使用上のガイドライン

マルチキャスト ホストがグループから脱退すると、ホストは IGMP 脱退メッセージを送信します。 このホストがグループを脱退する最終ホストかどうかを確認するために、脱退が確認されタイマーが開始したときに IGMP クエリーが送信されます。 タイマーの期限が切れる前にレポートが受信されないと、グループ レコードは削除されます。

IGMP 脱退メッセージの受信に応答して IGMP クエリーを送信する頻度を指定するには、ip igmp snooping last-member-query-count コマンドを使用します。

interval は、Cisco 7600 シリーズ ルータがグループ固有のクエリーの応答を実際に待つ時間です。

100 の倍数でないインターバルを入力すると、100 未満の端数が切り捨てられます。 たとえば、999 と入力した場合、端数が切り捨てられて 900 ミリ秒になります。

IGMP 高速脱退処理をイネーブルにして、no igmp snooping last-member-query-interval コマンドを入力した場合、インターバルは 0 秒にセットされ、高速脱退処理が常に優先されます。

有効値の範囲は 100 ~ 1000 ミリ秒ですが、1000 の値は入力できません。 この値にする場合は、no ip igmp snooping last-member-query-interval コマンドを入力して、デフォルト値(1000 ミリ秒)に戻す必要があります。

次に、最終メンバー クエリー インターバルを 200 ミリ秒に設定する例を示します。

Router(config-if)# 
ip igmp snooping last-member-query-interval 200

関連コマンド

コマンド

説明

ip igmp snooping fast-leave

IGMP v3 スヌーピングの高速脱退処理をイネーブルにします。

ip igmp snooping last-member-query-count

送信スヌーピング クエリーの間隔を設定します。

show ip igmp interface

IGMP インターフェイスのステータス情報およびコンフィギュレーション情報を表示します。

ip igmp snooping report-suppression

IP IGMP スヌーピング レポート抑制をオンにするには、グローバル コンフィギュレーション モード、インターフェイス コンフィギュレーション モード、またはブリッジ ドメイン コンフィギュレーション モードで ip igmp snooping report-suppression コマンドを使用します。 レポート抑制をオフにするには、このコマンドの no 形式を使用します。

ip igmp snooping report-suppression

no ip igmp snooping report-suppression

構文の説明

このコマンドには引数またはキーワードはありません。

コマンド デフォルト

IGMP スヌーピング レポート抑制はディセーブルです。

コマンド モード

グローバル コンフィギュレーション(config)

インターフェイス コンフィギュレーション(config-if)

ブリッジ ドメイン コンフィギュレーション(config-bdomain)

コマンド履歴

リリース

変更内容

12.2(18)SXF

このコマンドのサポートが Supervisor Engine 720 に追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

Cisco IOS XE Release 3.5S

このコマンドが Cisco IOS XE Release 3.5S に統合されました。 このコマンドのサポートが、ブリッジ ドメイン コンフィギュレーション モードに追加されました。

15.2(4)S

このコマンドが Cisco IOS Release 15.2(4)S に統合されました。

使用上のガイドライン

このコマンドは、一般クエリーに応答するすべてのホスト レポートか、特定のインターフェイスまたは特定のブリッジ ドメインのすべてのホスト レポートのレポート抑制をイネーブルにする場合に使用します。

一般クエリーに応答するすべてのホスト レポートに対してレポート抑制をイネーブルにすると、IP IGMP スヌーピングは最初のレポートだけを転送し、残りのレポートを抑制して IGMP トラフィックをマルチキャスト ルータに制限します。

次の例では、IP IGMP スヌーピング レポート抑制をイネーブルにする方法を示します。

Router(config-if)# ip igmp snooping report-suppression

次の例では、IP IGMP スヌーピング レポート抑制をディセーブルにする方法を示します。

Router(config-bdomain)# no ip igmp snooping report-suppression

ip igmp snooping vlan

特定の VLAN で Internet Group Management Protocol(IGMP)スヌーピングをイネーブルにするには、グローバル コンフィギュレーション モードで ip igmp snooping vlan コマンドを使用します。 VLAN インターフェイス上で IGMP スヌーピングをディセーブルにするには、このコマンドの no 形式を使用します。

ip igmp snooping vlan vlan-id

no ip igmp snooping vlan vlan-id

構文の説明

vlan-id

VLAN ID 値。 範囲は 1 ~ 1001 です。 先行ゼロは入力しないでください。

コマンド デフォルト

デフォルトでは、IGMP スヌーピングは各 VLAN が作成されたときにイネーブルとなります。

コマンド モード

グローバル コンフィギュレーション

コマンド履歴

リリース

変更内容

12.0(5.2)WC(1)

このコマンドが導入されました。

12.2(15)ZJ

このコマンドが Cisco 2600 シリーズ、Cisco 3600 シリーズ、および Cisco 3700 シリーズのルータ プラットフォームに追加されました。

12.3(4)T

このコマンドが、Cisco 2600 シリーズ、Cisco 3600 シリーズ、および Cisco 3700 シリーズ ルータ上の Cisco IOS Release 12.3(4)T に統合されました。

使用上のガイドライン

このコマンドは、未設定の VLAN を自動的に設定します。 設定は、NVRAM に保存されます。

次に、VLAN 2 上で IGMP スヌーピングをイネーブルにする例を示します。

Router(config)# ip igmp snooping vlan 2

次に、VLAN 2 上で IGMP スヌーピングをディセーブルにする例を示します。

Router(config)# no
 ip igmp snooping vlan 2

関連コマンド

コマンド

説明

ip igmp snooping

IGMP スヌーピングをグローバルにイネーブルにします。 IGMP スヌーピングを VLAN 上でイネーブルにするには、グローバルにイネーブルにしておく必要があります。

ip igmp snooping vlan immediate-leave

IGMP 即時脱退処理をイネーブルにします。

ip igmp snooping vlan mrouter

レイヤ 2 ポートをマルチキャスト ルータ ポートとして設定します。

ip igmp snooping vlan static

レイヤ 2 ポートをグループのメンバとして設定します。

show ip igmp snooping

IGMP スヌーピング設定を表示します。

ip igmp snooping vlan immediate-leave

VLAN インターフェイスの Internet Group Management Protocol(IGMP)の即時脱退処理をイネーブルにするには、グローバル コンフィギュレーション モードで ip igmp snooping vlan immediate-leave コマンドを使用します。 VLAN インターフェイスの即時脱退処理をディセーブルにするには、このコマンドの no 形式を使用します。

ip igmp snooping vlan vlan-id immediate-leave

no ip igmp snooping vlan vlan-id immediate-leave

構文の説明

vlan-id

VLAN ID 値。 範囲は 1 ~ 1001 です。 先行ゼロは入力しないでください。

コマンド デフォルト

デフォルトでは、IGMP 即時脱退処理はディセーブルです。

コマンド モード

グローバル コンフィギュレーション

コマンド履歴

リリース

変更内容

12.0(5.2)WC(1)

このコマンドが導入されました。

12.2(15)ZJ

このコマンドが Cisco 2600 シリーズ、Cisco 3600 シリーズ、および Cisco 3700 シリーズのルータ プラットフォームに追加されました。

12.3(4)T

このコマンドが、Cisco 2600 シリーズ、Cisco 3600 シリーズ、および Cisco 3700 シリーズ ルータ上の Cisco IOS Release 12.3(4)T に統合されました。

使用上のガイドライン

即時脱退処理は、VLAN の各ポートに IP マルチキャスト レシーバが 1 つだけ存在するときだけ使用してください。 即時脱退設定は NVRAM に保存されます。

即時脱退処理は、IGMP バージョン 2 のホストについてだけサポートされます。

次に、VLAN 1 で IGMP 即時脱退処理をイネーブルにする例を示します。

Router(config)# ip igmp snooping vlan 1 immediate-leave

次に、VLAN 1 で IGMP 即時脱退処理をディセーブルにする例を示します。

Router(config)# no
 ip igmp snooping vlan 1 immediate-leave

関連コマンド

コマンド

説明

ip igmp snooping

IGMP スヌーピングをグローバルにイネーブルにします。 IGMP スヌーピングを VLAN 上でイネーブルにするには、グローバルにイネーブルにしておく必要があります。

ip igmp snooping vlan mrouter

レイヤ 2 ポートをマルチキャスト ルータ ポートとして設定します。

ip igmp snooping vlan static

レイヤ 2 ポートをグループのメンバとして設定します。

show ip igmp snooping

IGMP スヌーピング設定を表示します。

show mac-address-table multicast

VLAN のレイヤ 2 マルチキャスト エントリを表示します。

ip igmp snooping vlan mrouter

マルチキャスト ルータ ポートを追加し、マルチキャスト ルータの学習方式を設定するには、グローバル コンフィギュレーション モードで ip igmp snooping vlan mrouter コマンドを使用します。 設定を削除するには、このコマンドの no 形式を使用します。

ip igmp snooping vlan vlan-id mrouter { interface interface-id | learn pim-dvmrp }

no ip igmp snooping vlan vlan-id mrouter { interface interface-id | learn pim-dvmrp }

構文の説明

vlan-id

VLAN ID を指定します。 範囲は 1 ~ 1001 です。 先行ゼロは入力しないでください。

interface interface-id

スタティック ルータ ポートに設定されたメンバ ポートのインターフェイスを指定します。

learn pim-dvmrp

マルチキャスト ルータ スヌーピング PIM-DVMRP パケットのマルチキャスト ルータの学習方式を指定します。

コマンド デフォルト

デフォルトの学習方式は pim-dvmrp です。

コマンド モード

グローバル コンフィギュレーション

コマンド履歴

リリース

変更内容

12.0(5.2)WC(1)

このコマンドが導入されました。

12.2(15)ZJ

このコマンドが Cisco 2600 シリーズ、Cisco 3600 シリーズ、および Cisco 3700 シリーズのルータ プラットフォームに追加されました。

12.3(4)T

このコマンドが、Cisco 2600 シリーズ、Cisco 3600 シリーズ、および Cisco 3700 シリーズ ルータ上の Cisco IOS Release 12.3(4)T に統合されました。

使用上のガイドライン

設定された学習方式は、NVRAM に保存されます。

マルチキャスト ルータへのスタティック接続は、スイッチ ポートに限りサポートされます。

次に、マルチキャスト ルータ ポートとしてファスト イーサネット インターフェイス 0/6 を設定する例を示します。

Router(config)# ip igmp snooping vlan 1 mrouter interface fastethernet0/6

関連コマンド

コマンド

説明

ip igmp snooping

IGMP スヌーピングをグローバルにイネーブルにします。 IGMP スヌーピングを VLAN 上でイネーブルにするには、グローバルにイネーブルにしておく必要があります。

ip igmp snooping vlan

VLAN インターフェイス上で IGMP スヌーピングをイネーブルにします。

ip igmp snooping vlan immediate-leave

IGMP 即時脱退処理を設定します。

ip igmp snooping vlan static

レイヤ 2 ポートをグループのメンバとして設定します。

show ip igmp snooping mrouter

スタティックおよびダイナミックに学習したマルチキャスト ルータ ポートを表示します。

ip igmp snooping vlan static

マルチキャスト グループのメンバとしてレイヤ 2 ポートを追加するには、グローバル コンフィギュレーション モードで ip igmp snooping vlan static コマンドを使用します。 設定を削除するには、このコマンドの no 形式を使用します。

ip igmp snooping vlan vlan-id static mac-address interface interface-id

no ip igmp snooping vlan vlan-id static mac-address interface interface-id

構文の説明

vlan-id

VLAN ID を指定します。 指定できる範囲は 1 ~ 1001 です。 先行ゼロは入力しないでください。

mac-address

スタティック グループの MAC アドレスを指定します。

interface interface-id

スタティック ルータ ポートに設定されるインターフェイスを指定します。

コマンド デフォルト

レイヤ 2 ポートは設定されていません。

コマンド モード

グローバル コンフィギュレーション

コマンド履歴

リリース

変更内容

12.0(5.2)WC(1)

このコマンドが導入されました。

12.2(15)ZJ

このコマンドが Cisco 2600 シリーズ、Cisco 3600 シリーズ、および Cisco 3700 シリーズのルータ プラットフォームに追加されました。

12.3(4)T

このコマンドが、Cisco 2600 シリーズ、Cisco 3600 シリーズ、および Cisco 3700 シリーズ ルータ上の Cisco IOS Release 12.3(4)T に統合されました。

使用上のガイドライン

このコマンドは、IP マルチキャスト グループ メンバ ポートをスタティックに設定するために使用します。

スタティック ポートおよびグループは、NVRAM に保存されます。

マルチキャスト ルータへのスタティック接続は、スイッチ ポートに限りサポートされます。

レイヤ 2 マルチキャスト エントリを確認するには、show mac-address-table multicast 特権 EXEC コマンドを使用します。

次に、インターフェイスにホストをスタティックに設定する例を示します。

Router(config)# ip igmp snooping vlan 1 static 0100.5e02.0203 interface fastethernet0/6
Configuring port FastEthernet 0/6 on group 0100.5e02.0203

関連コマンド

コマンド

説明

ip igmp snooping

IGMP スヌーピングをグローバルにイネーブルにします。 IGMP スヌーピングを VLAN 上でイネーブルにするには、グローバルにイネーブルにしておく必要があります。

ip igmp snooping vlan

VLAN インターフェイス上で IGMP スヌーピングをイネーブルにします。

ip igmp snooping vlan immediate-leave

IGMP 即時脱退処理を設定します。

ip igmp snooping vlan mrouter

レイヤ 2 ポートをマルチキャスト ルータ ポートとして設定します。

show mac-address-table multicast

VLAN のレイヤ 2 マルチキャスト エントリを表示します。

ip igmp static-group

インターフェイスのスタティック グループ メンバーシップ エントリを設定するには、インターフェイス コンフィギュレーション モードで ip igmp static-group コマンドを使用します。 スタティック グループ メンバーシップ エントリを削除するには、このコマンドの no 形式を使用します。

ip igmp static-group { * | group-address [ source { source-address | ssm-map } ] | class-map class-map-name }

no ip igmp static-group { * | group-address [ source { source-address | ssm-map } ] | class-map class-map-name }

構文の説明

*

作成したすべてのマルチキャスト ルート(mroute)エントリにインターフェイスを配置します。

group-address

インターフェイスのスタティック グループ メンバとして設定する IP マルチキャスト グループ アドレス。

source

(任意)インターフェイスから(S, G)チャネルをスタティックに転送します。

source-address

(任意)マルチキャスト データ パケットの発信元システムの IP アドレス。

ssm-map

(任意)このグループに関連付けられたソースを決定するためにインターフェイスで使用する Source Specific Multicast(SSM)マッピングを設定します。 その結果得られる (S, G) チャネルは、静的に転送されます。

class-map class-map-name

Internet Group Management Protocol(IGMP)のスタティック グループ範囲クラス マップをインターフェイスにアタッチします。

コマンド デフォルト

スタティック グループ メンバーシップ エントリはインターフェイスに設定されていません。

コマンド モード

インターフェイス コンフィギュレーション(config-if)

仮想ネットワーク インターフェイス(config-if-vnet)

コマンド履歴

リリース

変更内容

11.2

このコマンドが導入されました。

12.3(2)T

このコマンドが変更されました。 ssm-map キーワードが追加されました。

12.2(18)S

このコマンドが変更されました。 ssm-map キーワードが追加されました。

12.2(18)SXD3

このコマンドが、Cisco IOS Release 12.2(18)SXD3 に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(18)SXF5

このコマンドが変更されました。 class-map キーワードおよび class-map-name 引数が追加されました。

15.0(1)M

このコマンドが変更されました。 class-map キーワードおよび class-map-name 引数が追加されました。

12.2(33)SRE

このコマンドが変更されました。 class-map キーワードおよび class-map-name 引数が追加されました。

Cisco IOS XE Release 2.6

このコマンドが Cisco IOS XE Release 2.6 に統合されました。

Cisco IOS XE Release 3.2S

このコマンドが変更されました。 仮想ネットワーク インターフェイス コンフィギュレーション モードにおけるこのコマンドのサポートが追加されました。

15.0(1)SY

このコマンドが、Cisco IOS Release 15.0(1)SY に統合されました。

15.1(1)SG

このコマンドが、Cisco IOS Release 15.1(1)SG に統合されました。

Cisco IOS XE Release 3.3SG

このコマンドが、Cisco IOS XE Release 3.3SG に統合されました。

使用上のガイドライン

インターフェイスのスタティック グループ メンバーシップ エントリを設定するには、ip igmp static-group コマンドを使用します。 このコマンドを設定すると、グループに対するパケットはファストスイッチングを使用してインターフェイスから送出されます(パケットが正しいリバース パス転送(RPF)インターフェイスで受信された場合)。 設定すると、スタティック グループ メンバーシップ エントリが、IGMP キャッシュおよび mroute テーブルに追加されます。

ip igmp static-group コマンドの設定は ip igmp join-group コマンドの設定とは異なります。後者では、ルータがマルチキャスト グループに参加できます。 ip igmp static-group コマンドのこの設定により、アップストリーム ルータでは、このグループへのマルチキャスト ルーティング テーブル情報を維持することになるため、このマルチキャスト グループへのすべてのパスがアクティブであることが保障されます。

ip igmp static-group コマンドと同じグループ アドレスに対して ip igmp join-group コマンドが設定されている場合、ip igmp join-group コマンドが優先され、グループはローカルに参加したグループのように動作します。

ラスト ホップ ルータ上に SSM マッピングによるスタティック トラフィック転送を設定するには、ip igmp static-group コマンドに ssm-map キーワードを指定して使用します。 スタティック トラフィック転送は、特定のグループへの SSM トラフィックをスタティックに転送するために、SSM マッピングとともに使用できます。 SSM マッピングを使用したスタティック トラフィック転送が設定されている場合、ラスト ホップ ルータでは、ドメイン ネーム システム(DNS)ベースの SSM マッピングを使用して、グループに関連付けられている送信元を判別します。 その結果得られる (S, G) チャネルは、静的に転送されます。

IGMP スタティック グループ クラス マップをインターフェイスにアタッチするには、ip igmp static-group class-map コマンドに class-map キーワードおよび class-map-name 引数を指定して使用します。 アタッチすると、クラス マップで定義されているすべてのグループ エントリがインターフェイスのスタティック メンバになり、IGMP キャッシュおよび mroute テーブルに追加されます。

Cisco IOS Release 15.1(1)T 以降の場合

MFIB は、デンス モード パケットを処理する(*, G/m)エントリを保守します。 最初のデンス モード パケットがルータに到達すると、(*, G/m)エントリと照合されます。 パケットは、次の 2 条件の少なくとも 1 つが満たされる場合に限りルート プロセッサにパントされます。つまり、パケットの送信元がこのルータに直接接続されているか、パケットを受信したインターフェイスに少なくとも 1 台の PIM ネイバーがある場合です。 この条件のいずれも満たされていない場合は、MFIB の(*, G/m)エントリによって、パントしないでパケットがドロップされます。 ラスト ホップ ルータのインターフェイスに PIM ネイバーがなく、レシーバが存在しない場合は、どのレシーバも参加しないうち(いずれの(*, G)ステートもルータ上に作成されないうち)に ip igmp static-group コマンドに * キーワードを指定して設定することにより、このインターフェイスのすべてのマルチキャスト グループ アドレスに対するレシーバの存在をシミュレートします。これにより、このインターフェイスが mroute エントリの olist に追加され、このインターフェイス上のデンス モード グループに対する着信ラスト ホップ ルータ トラフィックがドロップされなくなります。

次に、イーサネット インターフェイス 0 のグループ アドレス 239.100.100.101 を設定する例を示します。

interface ethernet 0
 ip igmp static-group 239.100.100.101

次の例では、イーサネット インターフェイス 0 で、静的に転送されたグループに SSM マッピングを使用するようにグループ アドレス 239.1.2.1 を設定する方法を示します。

interface ethernet 0
 ip igmp static-group 239.1.2.1 source ssm-map

次の例では、ギガビットイーサネット インターフェイス 1/1 に static1 という名前の IGMP スタティック グループ範囲クラス マップをアタッチする方法を示します。

interface GigabitEthernet1/1
 ip igmp static-group class-map static1

関連コマンド

コマンド

説明

class-map type multicast-flows

IGMP スタティック グループ クラス マップを作成または変更するには、マルチキャスト フロー クラス マップ コンフィギュレーション モードを開始します。

ip igmp join-group

ルータは、マルチキャスト グループに参加します。

ip igmp ssm-map enable

設定されている SSM 範囲で、グループの SSM マッピングをイネーブルにします。

ip igmp ssm-map query dns

DNS ベースの SSM マッピングを設定します。

ip igmp ssm-map static

スタティック SSM マッピングをイネーブルにします。

ip pim ssm

IP マルチキャスト アドレスの SSM 範囲を定義します。

ip igmp unidirectional-link

インターフェイスを単一方向に設定し、Internet Group Management Protocol(IGMP)の単方向リンク ルーティング(UDLR)でこれをイネーブルにするには、インターフェイス コンフィギュレーション モードで ip igmp unidirectional-link コマンドを使用します。 単方向リンク(UDL)をディセーブルにするには、このコマンドの no 形式を使用します。

ip igmp unidirectional-link

no ip igmp unidirectional-link

構文の説明

このコマンドには引数またはキーワードはありません。

コマンド デフォルト

UDLR は発生しません。

コマンド モード

インターフェイス コンフィギュレーション(config-if)仮想ネットワーク インターフェイス(config-if-vnet)

コマンド履歴

リリース

変更内容

12.0(3)T

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 3.2S

このコマンドが変更されました。 仮想ネットワーク インターフェイス コンフィギュレーション モードにおけるこのコマンドのサポートが追加されました。

使用上のガイドライン

このコマンドを設定する例として、衛星を介するトラフィックがある場合があります。

レシーバが少ない場合は、UDLR トンネルを設定することによって UDLR を実施することもできます。 tunnel udlr receive-only コマンドおよび tunnel udlr send-only コマンドの説明を参照してください。

次に、シリアル インターフェイス 0 に UDLR によるアップストリーム ルータを設定する例を示します。

ip multicast-routing
!
! Unidirectional link
!
interface serial 0
 description Unidirectional to downlink-rtr
 ip address 10.0.0.1 255.0.0.0
 ip pim sparse-dense-mode
 ip igmp unidirectional-link
 no keepalive

関連コマンド

コマンド

説明

ip igmp helper-address(UDL)

IGMP UDLR に必要な IGMP ヘルパーを設定します。

ip igmp mroute-proxy

プロキシされた(*, G)mroute エントリの IGMP レポートの転送をイネーブルにします。

ip igmp proxy-service

mroute プロキシ サービスをイネーブルにします。

ip multicast default-rpf-distance

IGMP UDLR を設定する場合のデフォルト RPF インターフェイスに指定された距離を変更します。

show ip igmp udlr

設定された UDL ヘルパー アドレスがあるインターフェイス上で、マルチキャスト グループに直接接続されている UDLR 情報を表示します。

tunnel udlr receive-only

メッセージを送信するように別のインターフェイスに UDLR が設定されている場合に、メッセージを受信できるバック チャネルとして動作するよう、単一方向の GRE トンネルを設定します。

tunnel udlr send-only

メッセージを受信するように別のインターフェイスに UDLR が設定されている場合に、メッセージを送信できるバック チャネルとして動作するよう、単一方向の GRE トンネルを設定します。

ip igmp version

ルータの使用している Internet Group Management Protocol(IGMP)のバージョンを設定するには、インターフェイス コンフィギュレーション モードで、ip igmp version コマンドを使用します。 デフォルト値に戻すには、このコマンドの no 形式を使用します。

ip igmp version { 1 | 2 | 3 }

no ip igmp version

構文の説明

1

IGMP バージョン 1。

2

IGMP バージョン 2。 これはデフォルトです。

3

IGMP バージョン 3。

コマンド デフォルト

バージョン 2

コマンド モード

インターフェイス コンフィギュレーション(config-if)仮想ネットワーク インターフェイス(config-if-vnet)

コマンド履歴

リリース

変更内容

11.1

このコマンドが導入されました。

12.1(5)T

キーワード 3 が追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 3.2S

IP マルチキャスト コマンドに対するこの帯域幅ベースのコール アドミッション制御が変更されました。 仮想ネットワーク インターフェイス コンフィギュレーション モードにおけるこのコマンドのサポートが追加されました。

15.0(1)SY

このコマンドが、Cisco IOS Release 15.0(1)SY に統合されました。

15.1(1)SG

このコマンドが、Cisco IOS Release 15.1(1)SG に統合されました。

Cisco IOS XE Release 3.3SG

このコマンドが、Cisco IOS XE Release 3.3SG に統合されました。

使用上のガイドライン

サブネット上のすべてのルータで、同じバージョンをサポートする必要があります。 ルータはバージョン 1 ルータを自動的に検出せず、先行リリースの Cisco IOS ソフトウェアにおける処理同様、バージョン 1 に切り替えます。 ホストでは 1、2、3 のいずれの IGMP バージョンでも使用でき、ルータはその存在を正しく検出して、適切にクエリーを送信します。

ip igmp query-max-response-time ip igmp query-timeout など一部のコマンドでは、IGMP バージョン 2 または 3 が必要です。

次に、IGMP バージョン 3 を使用するように、ルータを設定する例を示します。

ip igmp version 3

関連コマンド

コマンド

説明

ip igmp query-max-response-time

IGMP クエリーでアドバタイズされる最大応答時間を設定します。

ip igmp query-timeout

前のクエリアがクエリーを停止した後、ルータがインターフェイスのクエリアとして引き継ぐまでのタイムアウト時間を設定します。

show ip igmp groups

ルータに直接接続され、IGMP を通じて学習されたマルチキャスト グループを表示します。

show ip igmp interface

インターフェイスのマルチキャスト関連情報を表示します。