レイヤ 2(リンク集約)コンフィギュレーション ガイド、Cisco IOS XE Release 3SE(Cisco WLC 5700 シリーズ)
EtherChannel およびリンクステート トラッキングの設定
EtherChannel およびリンクステート トラッキングの設定

目次

EtherChannel およびリンクステート トラッキングの設定

機能情報の確認

IEEE 802.1x ポートベース認証は、不正なデバイス(クライアント)によるネットワーク アクセスを防止します。特に明記しない限り、スイッチという用語は、スタンドアロン スイッチおよびスイッチ スタックを指します。

(注)スタック構成をサポートしているのは、LAN Base イメージを実行している Catalyst 2960-Sスイッチだけです。

EtherChannel の制約事項

次に、EtherChannels の制約事項を示します。

  • EtherChannel のすべてのポートは同じ VLAN に割り当てるか、またはトランク ポートとして設定する必要があります。

  • LAN Base ライセンス フィーチャ セットを実行している場合は、レイヤ 3 EtherChannels はサポートされません。

EtherChannel について

EtherChannel の概要

EtherChannel は、スイッチ、ルータ、およびサーバ間にフォールトトレラントな高速リンクを提供します。 EtherChannel を使用して、ワイヤリング クローゼットとデータセンター間の帯域幅を増やすことができます。さらに、ボトルネックが発生しやすいネットワーク上のあらゆる場所に EtherChannel を配置できます。 EtherChannel は、他のリンクに負荷を再分散させることによって、リンク切断から自動的に回復します。 リンク障害が発生した場合、EtherChannel は障害リンクからチャネル内の他のリンクにトラフィックをリダイレクトします。

EtherChannel は、単一の論理リンクにバンドルする個別のイーサネット リンクで構成されます。

図 1. 一般的な EtherChannel 構成

EtherChannel は、スイッチ間またはスイッチとホスト間に、最大 8 Gb/s(ギガビット EtherChannel)または 80 Gb/s(10 ギガビット EtherChannel)の全二重帯域幅を提供します。

各 EtherChannel は、互換性のある設定のイーサネット ポートを 8 つまで使用して構成できます。

EtherChannel の数は 128 に制限されています。

各 EtherChannel 内のすべてのポートは、レイヤ 2 またはレイヤ 3 ポートのいずれかとして設定する必要があります。 EtherChannel レイヤ 3 ポートは、ルーテッド ポートで構成されます。 ルーテッド ポートは、no switchport インターフェイス コンフィギュレーション コマンドを使用してレイヤ 3 モードに設定された物理ポートです。

EtherChannel のモード

EtherChannel は、ポート集約プロトコル(PAgP)、Link Aggregation Control Protocol(LACP)、または On のいずれかのモードに設定できます。 EtherChannel の両端は同じモードで設定します。

  • EtherChannel の一方の端を PAgP または LACP モードに設定すると、システムはもう一方の端とネゴシエーションし、アクティブにするポートを決定します。 リモート ポートが EtherChannel とネゴシエーションができない場合、ローカル ポートは独立ステートになり、他の単一リンクと同様にデータ トラフィックを引き続き伝送します。 ポート設定は変更されませんが、ポートは EtherChannel に参加しません。

  • EtherChannel を on モードに設定すると、ネゴシエーションは実行されません。 スイッチは EtherChannel 内で互換性のあるすべてのポートを強制的にアクティブにします。 EtherChannel のもう一方の端(他のスイッチ上)も、同じように on モードに設定する必要があります。それ以外を設定した場合、パケットの損失が発生します。

Controllers上の EtherChannel

controller上、スタックの単一controller上、またはスタックの複数controllers上(クロススタック EtherChannel とも呼ぶ)で EtherChannel を作成できます。

図 2. シングル コントローラ EtherChannel



この図は、3 個のアクティブ リンクと 3 個のスタンバイ リンクがあるクロススタック EtherChannel 推奨設定を示します。

図 3. クロススタック EtherChannel

EtherChannel リンクのフェールオーバー

EtherChannel 内のリンクで障害が発生すると、それまでその障害リンクで伝送されていたトラフィックが EtherChannel 内の残りのリンクに切り替えられます。 スイッチでトラップがイネーブルになっている場合、スイッチ、EtherChannel、および失敗したリンクを区別したトラップが送信されます。 EtherChannel の 1 つのリンク上の着信ブロードキャストおよびマルチキャスト パケットは、EtherChannel の他のリンクに戻らないようにブロックされます。

チャネル グループおよびポートチャネル インターフェイス

EtherChannel は、チャネル グループとポートチャネル インターフェイスから構成されます。 チャネル グループはポートチャネル インターフェイスに物理ポートをバインドします。 ポートチャネル インターフェイスに適用した設定変更は、チャネル グループにまとめてバインドされるすべての物理ポートに適用されます。

図 4. 物理ポート、チャネル グループおよびポートチャネル インターフェイスの関係.

channel-group コマンドは、物理ポートおよびポートチャネル インターフェイスをまとめてバインドします。 各 EtherChannel には 1 ~ 128 までの番号が付いたポートチャネル論理インターフェイスがあります。 このポートチャネル インターフェイス番号は、channel-group インターフェイス コンフィギュレーション コマンドで指定した番号に対応しています。



  • レイヤ 2 ポートの場合は、channel-group インターフェイス コンフィギュレーション コマンドを使用して、ポートチャネル インターフェイスを動的に作成します。

    また、interface port-channel port-channel-number グローバル コンフィギュレーション コマンドを使用して、ポートチャネル論理インターフェイスを手動で作成することもできます。ただし、その場合、論理インターフェイスを物理ポートにバインドするには、channel-group channel-group-number コマンドを使用する必要があります。 channel-group-number port-channel-number と同じ値に設定することも、違う値を使用することもできます。 新しい番号を使用した場合、channel-group コマンドは動的に新しいポート チャネルを作成します。

  • レイヤ 3 ポートの場合は、interface port-channel グローバル コンフィギュレーション コマンド、およびそのあとに no switchport インターフェイス コンフィギュレーション コマンドを使用して、論理インターフェイスを手動で作成する必要があります。 その後、channel-group インターフェイス コンフィギュレーション コマンドを使用して、手動で EtherChannel にインターフェイスを割り当てます。

ポート集約プロトコル

ポート集約プロトコル(PAgP)はシスコ独自のプロトコルで、Cisco controllersおよび PAgP をサポートするベンダーによってライセンス供与されたcontrollersでのみ稼働します。 PAgP を使用すると、イーサネット ポート間で PAgP パケットを交換することにより、EtherChannel を自動的に作成できます。

controllerまたはcontroller スタックは PAgP を使用することによって、PAgP をサポートできるパートナーの識別情報、および各ポートの機能を学習します。 次に、設定が類似している(スタック内の単一controller上の)ポートを、単一の論理リンク(チャネルまたは集約ポート)に動的にグループ化します。 設定が類似しているポートをグループ化する場合の基準は、ハードウェア、管理、およびポート パラメータ制約です。 たとえば、PAgP は速度、デュプレックス モード、ネイティブ VLAN、VLAN 範囲、トランキング ステータス、およびトランキング タイプが同じポートをグループとしてまとめます。 リンクを EtherChannel にグループ化した後で、PAgP は単一controller ポートとして、スパニングツリーにそのグループを追加します。

PAgP モード

PAgP モードは、PAgP ネゴシエーションを開始する PAgP パケットをポートが送信できるか、または受信した PAgP パケットに応答できるかを指定します。

表 1 EtherChannel PAgP モード

モード(Mode)

説明

auto

ポートをパッシブ ネゴシエーション ステートにします。この場合、ポートは受信する PAgP パケットに応答しますが、PAgP パケット ネゴシエーションを開始することはありません。 これにより、PAgP パケットの送信は最小限に抑えられます。

desirable

ポートをアクティブ ネゴシエーション ステートにします。この場合、ポートは PAgP パケットを送信することによって、相手ポートとのネゴシエーションを開始します。

スイッチ ポートは、auto モードまたは desirable モードに設定された相手ポートとだけ PAgP パケットを交換します。 on モードに設定されたポートは、PAgP パケットを交換しません。

auto モードおよび desirable モードはともに、相手ポートとネゴシエーションして、ポート速度などの条件に基づいて、ポートで EtherChannel を形成できるようにします。 レイヤ 2 EtherChannel の場合は、トランク ステートおよび VLAN 番号に基づきます。

PAgP モードが異なっていても、モード間で互換性がある限り、ポートは EtherChannel を形成できます。 次に例を示します。

  • desirable モードのポートは、desirable モードまたは auto モードの別のポートとともに EtherChannel を形成できます。

  • auto モードのポートは、desirable モードの別のポートとともに EtherChannel を形成できます。

どのポートも PAgP ネゴシエーションを開始しないため、auto モードのポートは、auto モードの別のポートとは EtherChannel を形成できません。

サイレント モード

PAgP 対応のデバイスにスイッチを接続する場合、non-silent キーワードを使用すると、非サイレント動作としてスイッチ ポートを設定できます。 auto モードまたは desirable モードとともに non-silent を指定しなかった場合は、サイレント モードが指定されていると見なされます。

PAgP 非対応で、ほとんどパケットを送信しないデバイスにスイッチを接続する場合に、サイレント モードを使用します。 サイレント パートナーの例は、トラフィックを生成しないファイル サーバ、またはパケット アナライザなどです。 この場合、サイレント パートナーに接続された物理ポート上で PAgP を稼働させると、このスイッチ ポートが動作しなくなります。 ただし、サイレントを設定すると、PAgP が動作してチャネル グループにポートを結合し、このポートが伝送に使用されます。

PAgP 学習方式およびプライオリティ

ネットワーク デバイスは、PAgP 物理ラーナーまたは集約ポート ラーナーに分類されます。 物理ポートによってアドレスを学習し、その知識に基づいて送信を指示するデバイスは物理ラーナーです。 集約(論理)ポートによってアドレスを学習するデバイスは、集約ポート ラーナーです。 学習方式は、リンクの両端で同一の設定にする必要があります。

デバイスとそのパートナーが両方とも集約ポート ラーナーの場合、論理ポートチャネル上のアドレスを学習します。 デバイスは EtherChannel のいずれかのポートを使用することによって、送信元にパケットを送信します。 集約ポート ラーナーの場合、どの物理ポートにパケットが届くかは重要ではありません。

PAgP は、パートナー デバイスが物理ラーナーの場合およびローカル デバイスが集約ポート ラーナーの場合には自動検出できません。 したがって、物理ポートでアドレスを学習するには、ローカル デバイスに手動で学習方式を設定する必要があります。 また、負荷の分散方式を送信元ベース分散に設定して、指定された送信元 MAC アドレスが常に同じ物理ポートに送信されるようにする必要もあります。

グループ内の 1 つのポートですべての伝送を行うように設定して、他のポートをホット スタンバイに使用することもできます。 選択された 1 つのポートでハードウェア信号が検出されなくなった場合は、数秒以内に、グループ内の未使用のポートに切り替えて動作させることができます。 パケット伝送用に常に選択されるようにポートを設定するには、pagp port-priority インターフェイス コンフィギュレーション コマンドを使用してプライオリティを変更します。 プライオリティが高いほど、そのポートが選択される可能性が高まります。


(注)  


CLI(コマンドライン インターフェイス)で physical-port キーワードを指定した場合でも、controllerがサポートするのは、集約ポート上でのアドレス ラーニングのみです。 pagp learn-method コマンドおよび pagp port-priority コマンドは、controllerのハードウェアには作用しませんが、Catalyst 1900 スイッチなどの物理ポートによるアドレス ラーニングだけをサポートするデバイスと PAgP の相互運用性を確保するために必要です。

controllerのリンク パートナーが物理ラーナーである場合、pagp learn-method physical-port インターフェイス コンフィギュレーション コマンドを使用して物理ポート ラーナーとしてcontrollerを設定することを推奨します。 送信元 MAC アドレスに基づいて負荷の分散方式を設定するには、port-channel load-balance src-mac グローバル コンフィギュレーション コマンドを使用します。 すると、controllerは送信元アドレスを学習した EtherChannel 内の同じポートを使用して、物理ラーナーにパケットを送信します。 pagp learn-method コマンドは、このような場合のみ使用してください。


PAgP と他の機能との相互作用

ダイナミック トランキング プロトコル(DTP)および Cisco Discovery Protocol(CDP)は、EtherChannel の物理ポートを使用してパケットを送受信します。 トランク ポートは、番号が最も小さい VLAN 上で PAgP プロトコル データ ユニット(PDU)を送受信します。

レイヤ 2 EtherChannel では、チャネル内で最初に起動するポートが EtherChannel に MAC アドレスを渡します。 このポートがバンドルから削除されると、バンドル内の他のポートの 1 つが EtherChannel に MAC アドレスを提供します。 レイヤ 3 EtherChannel の場合は、(interface port-channel グローバル コンフィギュレーション コマンドを使用して)ポートが作成された直後に、アクティブなcontrollerによって MAC アドレスが割り当てられます。

PAgP が PAgP PDU を送受信するのは、PAgP が auto モードまたは desirable モードでイネーブルになっている、稼働状態のポート上だけです。

Link Aggregation Control Protocol

LACP は IEEE 802.3ad で定義されており、Cisco controllersが IEEE 802.3ad プロトコルに適合したcontrollers間のイーサネット チャネルを管理できるようにします。 LACP を使用すると、イーサネット ポート間で LACP パケットを交換することにより、EtherChannel を自動的に作成できます。

controllerまたはcontroller スタックは LACP を使用することによって、LACP をサポートできるパートナーの識別情報、および各ポートの機能を学習します。 次に、設定が類似しているポートを単一の倫理リンク(チャネルまたは集約ポート)に動的にグループ化します。 設定が類似しているポートをグループ化する場合の基準は、ハードウェア、管理、およびポート パラメータ制約です。 たとえば、LACP は速度、デュプレックス モード、ネイティブ VLAN、VLAN 範囲、トランキング ステータス、およびトランキング タイプが同じポートをグループとしてまとめます。 リンクをまとめて EtherChannel を形成した後で、LACP は単一controller ポートとして、スパニングツリーにそのグループを追加します。

LACP モード

LACP モードでは、ポートが LACP パケットを送信できるか、LACP パケットの受信のみができるかどうかを指定します。

表 2 EtherChannel LACP モード

モード(Mode)

説明

active

ポートをアクティブ ネゴシエーション ステートにします。この場合、ポートは LACP パケットを送信することによって、相手ポートとのネゴシエーションを開始します。

passive

ポートはパッシブ ネゴシエーション ステートになります。この場合、ポートは受信する LACP パケットに応答しますが、LACP パケット ネゴシエーションを開始することはありません。 これにより、LACP パケットの送信を最小限に抑えます。

active モードおよび passive LACP モードはともに、相手ポートとネゴシエーションして、ポート速度などの条件に基づいて(レイヤ 2 EtherChannel の場合は、トランク ステートおよび VLAN 番号などの基準に基づいて)、ポートで EtherChannel を形成できるようにします。

LACP モードが異なっていても、モード間で互換性がある限り、ポートは EtherChannel を形成できます。 次に例を示します。

  • active モードのポートは、active モードまたは passive モードの別のポートとともに EtherChannel を形成できます。

  • 両ポートとも LACP ネゴシエーションを開始しないため、passive モードのポートは、passive モードの別のポートと EtherChannel を形成することはできません。

LACP とリンクの冗長性

LACP ポートチャネルの最小リンクおよび LACP の最大バンドルの機能を使用して、LACP ポートチャネル動作、帯域幅の可用性およびリンク冗長性をさらに高めることができます。

LACP ポートチャネルの最小リンク機能:

  • LACP ポート チャネルでリンクし、バンドルする必要があるポートの最小数を設定します。

  • 低帯域幅の LACP ポート チャネルがアクティブにならないようにします。

  • 必要な最低帯域幅を提供する十分なアクティブ メンバ ポートがない場合、LACP ポート チャネルが非アクティブになるようにします。

LACP の最大バンドル機能:

  • LACP ポート チャネルのバンドル ポートの上限数を定義します。

  • バンドル ポートがより少ない場合のホット スタンバイ ポートを可能にします。 たとえば、5 個のポートがある LACP ポート チャネルで、3 個の最大バンドルを指定し、残りの 2 個のポートをホット スタンバイ ポートとして指定できます。

LACP と他の機能との相互作用

DTP および CDP は、EtherChannel の物理ポートを介してパケットを送受信します。 トランク ポートは、番号が最も小さい VLAN 上で LACP PDU を送受信します。

レイヤ 2 EtherChannel では、チャネル内で最初に起動するポートが EtherChannel に MAC アドレスを渡します。 このポートがバンドルから削除されると、バンドル内の他のポートの 1 つが EtherChannel に MAC アドレスを提供します。 レイヤ 3 EtherChannel の場合、interface port-channel グローバル コンフィギュレーション コマンドを経由してインターフェイスが作成された直後に、アクティブなcontrollerにより MAC アドレスが割り当てられます。

LACP が LACP PDU を送受信するのは、LACP が active モードまたは passive モードでイネーブルになっている稼働状態のポートとの間だけです。

EtherChannel の On モード

EtherChannel の on モードは、EtherChannel の手動設定に使用します。 on モードを使用すると、ポートはネゴシエーションせずに強制的に EtherChannel に参加します。 リモート デバイスが PAgP や LACP をサポートしていない場合にこの on モードが役立ちます。 on モードでは、リンクの両端のcontrollerson モードに設定されている場合のみ EtherChannel を使用できます。

同じチャネル グループの on モードで設定されたポートは、速度やデュプレックスのようなポート特性に互換性を持たせる必要があります。 on モードで設定されていたとしても、互換性のないポートは suspended ステートになります。


注意    


on モードの使用には注意が必要です。 これは手動の設定であり、EtherChannel の両端のポートには、同一の設定が必要です。 グループの設定を誤ると、パケット損失またはスパニングツリー ループが発生することがあります。


ロードバランシングおよび転送方式

EtherChannel は、フレーム内のアドレスに基づいて形成されたバイナリ パターンの一部を、チャネル内の 1 つのリンクを選択する数値に縮小することによって、チャネル内のリンク間でトラフィックのロード バランシングを行います。 MAC アドレス、IP アドレス、送信元アドレス、宛先アドレス、または送信元と宛先両方のアドレスに基づいた負荷分散など、複数の異なるロードバランシング モードから 1 つを指定できます。 選択したモードは、controller上で設定されているすべての EtherChannel に適用されます。

port-channel load-balance および port-channel load-balance extended グローバル コンフィギュレーション コマンドを使用して、ロードバランシングおよび転送方式を設定します。

MAC アドレス転送

送信元 MAC アドレス転送の場合、EtherChannel に転送されたパケットは、着信パケットの送信元 MAC アドレスに基づいてチャネル ポート間で分配されます。 したがって、ロード バランシングを行うために、送信元ホストが異なるパケットはそれぞれ異なるチャネル ポートを使用しますが、送信元ホストが同じパケットは同じチャネル ポートを使用します。

宛先 MAC アドレス転送の場合、EtherChannel に転送されたパケットは、着信パケットの宛先ホストの MAC アドレスに基づいてチャネル ポート間で分配されます。 したがって、宛先が同じパケットは同じポートに転送され、宛先の異なるパケットはそれぞれ異なるチャネル ポートに転送されます。

送信元および宛先 MAC アドレス転送の場合、EtherChannel に転送されたパケットは、送信元および宛先の両方の MAC アドレスに基づいてチャネル ポート間で分配されます。 この転送方式は、負荷分散の送信元 MAC アドレス転送方式と宛先 MAC アドレス転送方式を組み合わせたものです。特定のcontrollerに対して送信元 MAC アドレス転送と宛先 MAC アドレス転送のどちらが適切であるかが不明な場合に使用できます。 送信元および宛先 MAC アドレス転送の場合、ホスト A からホスト B、ホスト A からホスト C、およびホスト C からホスト B に送信されるパケットは、それぞれ異なるチャネル ポートを使用できます。

IP アドレス転送

送信元 IP アドレスベース転送の場合、パケットは、着信パケットの送信元 IP アドレスに基づいて EtherChannel ポート間で分配されます。 ロード バランシングを行うために、IP アドレスが異なるパケットはチャネルでそれぞれ異なるポートを使用しますが、IP アドレスが同じパケットはチャネルで同じポートを使用します。

宛先 IP アドレスベース転送の場合、パケットは着信パケットの宛先 IP アドレスに基づいて EtherChannel ポート間で分配されます。 ロード バランシングを行うために、同じ送信元 IP アドレスから異なる宛先 IP アドレスに送信されるパケットは、チャネルの異なるチャネル ポートに送信できます。 異なる送信元 IP アドレスから同じ宛先 IP アドレスに送信されるパケットは、常にチャネルの同じポートに送信されます。

送信元と宛先 IP アドレスベース転送の場合、パケットは着信パケットの送信元および宛先の両方の IP アドレスに基づいて EtherChannel ポート間で分配されます。 この転送方式は、送信元 IP アドレスベース転送方式と宛先 IP アドレスベース転送方式を組み合わせたもので、特定のcontrollerに対して送信元 IP アドレスベース転送と宛先 IP アドレスベース転送のどちらが適切であるか不明な場合に使用できます。 この方式では、IP アドレス A から IP アドレス B に、IP アドレス A から IP アドレス C に、および IP アドレス C から IP アドレス B に送信されるパケットは、それぞれ異なるチャネル ポートを使用できます。

ロードバランシングの利点

ロードバランシング方式には異なる利点があるため、ネットワーク内のcontrollerの位置、および負荷分散が必要なトラフィックの種類に基づいて特定のロードバランシング方式を選択する必要があります。

図 5. 負荷分散と転送. 下の図では、コントローラが EtherChannel リンク上で送信元 MAC ベースの転送を行い、 EtherChannel の複数のリンク上でトラフィックを均等に分散します。



設定で一番種類が多くなるオプションを使用してください。 たとえば、チャネル上のトラフィックが単一 MAC アドレスを宛先とする場合、宛先 MAC アドレスを使用すると、チャネル内の同じリンクが常に選択されます。 ただし、送信元アドレスまたは IP アドレスを使用した方が、ロードバランシングの効率がよくなる場合があります。

EtherChannel およびController スタック

EtherChannel に加入しているポートが含まれているスタック メンバに障害が発生したり、スタックを離れると、アクティブなcontrollerにより、障害が発生したスタック controller メンバ ポートが削除されます。 EtherChannel に残っているポートがある場合、接続は引き続き確保されます。

controllerが既存のスタックに追加されると、新しいcontrollerがアクティブなcontrollerから実行コンフィギュレーションを受信し、EtherChannel 関連のスタック コンフィギュレーションで更新されます。 スタック メンバでは、動作情報(動作中で、チャネルのメンバであるポートのリスト)も受信します。

2 つのスタック間で設定されている EtherChannel がマージされた場合、セルフループ ポートになります。 スパニングツリーにより、この状況が検出され、必要な動作が発生します。 権利を獲得したcontroller スタックにある PAgP 設定または LACP 設定は影響を受けませんが、権利を失った controller スタックの PAgP 設定または LACP 設定は、スタックのリブート後に失われます。

Controller スタックおよび PAgP

PAgP では、アクティブ controllerに障害が発生するか、スタックを離れた場合、スタンバイ controllerが新しいアクティブ controllerになります。 新しいアクティブ controllerはアクティブ controllerの該当項目にスタック メンバの設定を同期します。 PAgP 設定は、EtherChannel に古いアクティブ controller上にあるポートがない限り、アクティブ controllerの変更後も影響を受けません。

Controller スタックおよび LACP

LACP の場合、システム ID は、アクティブ controllerから取得したスタック MAC アドレスが使用されます。 アクティブ controllerに障害が発生したり、スタックを離れれ、スタンバイ controllerが新しいアクティブ controllerが変更になっても、LACP システム ID は変更されません。 デフォルトでは、LACP 設定はアクティブ controllerの変更後も影響を受けません。

EtherChannel のデフォルト設定

EtherChannel のデフォルト設定を、次の表に示します。

表 3 EtherChannel のデフォルト設定

機能

デフォルト設定

チャネル グループ

割り当てなし

ポートチャネル論理インターフェイス

未定義

PAgP モード

デフォルトなし。

PAgP 学習方式

すべてのポートで集約ポート ラーニング

PAgP プライオリティ

すべてのポートで 128

LACP モード

デフォルトなし。

LACP 学習方式

すべてのポートで集約ポート ラーニング

LACP ポート プライオリティ

すべてのポートで 32768

LACP システム プライオリティ

32768

LACP システム ID

LACP システムのプライオリティ、controllerまたはスタックの MAC アドレス。

ロード バランシング

controller上での負荷分散は着信パケットの送信元 MAC アドレスに基づきます。

EtherChannel 設定時の注意事項

EtherChannel ポートを正しく設定していない場合は、ネットワーク ループおよびその他の問題を回避するために、一部の EtherChannel インターフェイスが自動的にディセーブルになります。 設定上の問題を回避するために、次の注意事項に従ってください。

  • PAgP EtherChannel は、同じタイプのイーサネット ポートを 8 つまで使用して設定します。

  • 同じタイプのイーサネット ポートを最大で 16 個備えた LACP EtherChannel を設定してください。 最大 8 個をアクティブに、最大 8 個をスタンバイ モードにできます。

  • EtherChannel 内のすべてのポートを同じ速度および同じデュプレックス モードで動作するように設定します。

  • EtherChannel 内のすべてのポートをイネーブルにします。 shutdown インターフェイス コンフィギュレーション コマンドによってディセーブルにされた EtherChannel 内のポートは、リンク障害として扱われます。そのポートのトラフィックは、EtherChannel 内の他のポートの 1 つに転送されます。

  • グループを初めて作成したときには、そのグループに最初に追加されたポートのパラメータ設定値をすべてのポートが引き継ぎます。 次のパラメータのいずれかで設定を変更した場合は、グループ内のすべてのポートでも変更する必要があります。
    • 許可 VLAN リスト

    • 各 VLAN のスパニングツリー パス コスト

    • 各 VLAN のスパニングツリー ポート プライオリティ

    • スパニングツリー PortFast の設定

  • 1 つのポートが複数の EtherChannel グループのメンバになるように設定しないでください。

  • EtherChannel は、PAgP と LACP の両方のモードには設定しないでください。 PAgP および LACP を実行している EtherChannel グループはスタックの同一controller、または異なるcontrollersで共存できます。 個々の EtherChannel グループは PAgP または LACP のいずれかを実行できますが、相互運用することはできません。

  • EtherChannel の一部としてセキュア ポートを設定したり、セキュア ポートの一部として EtherChannel を設定したりしないでください。

  • アクティブまたはアクティブでない EtherChannel メンバであるポートを IEEE 802.1x ポートとして設定しないでください。 EtherChannel ポートで IEEE 802.1x をイネーブルにしようとすると、エラー メッセージが表示され、IEEE 802.1x はイネーブルになりません。

  • EtherChannel がcontroller インターフェイス上に設定されている場合、dot1x system-auth-control グローバル コンフィギュレーション コマンドを使用して、IEEE 802.1x をcontroller上でグローバルにイネーブルにする前に、EtherChannel の設定をインターフェイスから削除します。

レイヤ 2 EtherChannel 設定時の注意事項

レイヤ 2 EtherChannels を設定する場合は、次の注意事項に従ってください。

  • EtherChannel 内のすべてのポートを同じ VLAN に割り当てるか、またはトランクとして設定してください。 複数のネイティブ VLAN に接続されるポートは、EtherChannel を形成できません。

  • EtherChannel は、トランキング レイヤ 2 EtherChannel 内のすべてのポート上で同じ VLAN 許容範囲をサポートしています。 VLAN 許容範囲が一致していないと、PAgP が auto モードまたは desirable モードに設定されていても、ポートは EtherChannel を形成しません。

  • スパニングツリー パス コストが異なるポートは、設定上の矛盾がない限り、EtherChannel を形成できます。 異なるスパニングツリー パス コストを設定すること自体は、EtherChannel を形成するポートの矛盾にはなりません。

レイヤ 3 EtherChannel 設定時の注意事項

  • レイヤ 3 EtherChannel の場合は、レイヤ 3 アドレスをチャネル内の物理ポートでなく、ポートチャネル論理インターフェイスに割り当ててください。

EtherChannel の設定方法

EtherChannel の設定後、ポートチャネル インターフェイスに適用した設定変更は、そのポートチャネル インターフェイスに割り当てられたすべての物理ポートに適用されます。また、物理ポートに適用した設定変更は、設定を適用したポートだけに作用します。

レイヤ 2 EtherChannel の設定 (CLI)

2 EtherChannel を設定するには、channel-group インターフェイス コンフィギュレーション コマンドを使用して、チャネル グループにポートを割り当てます。 このコマンドにより、ポートチャネル論理インターフェイスが自動的に作成されます。

手順の概要

    1.    configure terminal

    2.    interface interface-id

    3.    switchport mode {access | trunk}

    4.    switchport access vlan vlan-id

    5.    channel-group channel-group-number mode {auto [non-silent] | desirable [non-silent ] | on } | { active | passive}

    6.    end


手順の詳細
     コマンドまたはアクション目的
    ステップ 1configure terminal


    例:
    
    Controller# configure terminal
    
    
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 2 interface interface-id


    例:
    Controller(config)# interface gigabitethernet2/0/1
    
    
     

    物理ポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

    指定できるインターフェイスは、物理ポートです。

    PAgP EtherChannel の場合、同じタイプおよび速度のポートを 8 つまで同じグループに設定できます。

    LACP EtherChannel の場合、同じタイプのイーサネット ポートを 16 まで設定できます。 最大 8 個をアクティブに、最大 8 個をスタンバイ モードにできます。

     
    ステップ 3 switchport mode {access | trunk}


    例:
    Controller(config-if)# switchport mode access
    
    
     

    すべてのポートをスタティックアクセス ポートとして同じ VLAN に割り当てるか、またはトランクとして設定します。

    ポートをスタティックアクセス ポートとして設定する場合は、ポートを 1 つの VLAN にのみ割り当ててください。 指定できる範囲は 1 ~ 4094 です。

     
    ステップ 4 switchport access vlan vlan-id


    例:
    Controller(config-if)# switchport access vlan 22
    
    
     

    ポートをスタティックアクセス ポートとして設定する場合は、ポートを 1 つの VLAN にのみ割り当ててください。 指定できる範囲は 1 ~ 4094 です。

     
    ステップ 5 channel-group channel-group-number mode {auto [non-silent] | desirable [non-silent ] | on } | { active | passive}


    例:
    Controller(config-if)# channel-group 5 mode auto
    
    
     

    チャネル グループにポートを割り当て、PAgP モードまたは LACP モードを指定します。

    channel-group-number の範囲は 1 ~ 128 です。

    mode には、次のキーワードのいずれか 1 つを選択します。

    • autoPAgP デバイスが検出された場合のみ、PAgP をイネーブルにします。 ポートをパッシブ ネゴシエーション ステートにします。この場合、ポートは受信する PAgP パケットに応答しますが、PAgP パケット ネゴシエーションを開始することはありません。このキーワードは、EtherChannel メンバがcontrollers スタックの異なるcontrollerのものである場合にはサポートされません

    • desirablePAgP を無条件でイネーブルにします。 ポートをアクティブ ネゴシエーション ステートにします。この場合、ポートは PAgP パケットを送信することによって、相手ポートとのネゴシエーションを開始します。 このキーワードは、EtherChannel メンバがcontrollers スタックの異なるcontrollerのものである場合にはサポートされません

    • on PAgP または LACP を使用せずにポートが強制的にチャネル化されます。 on モードでは、使用可能な EtherChannel が存在するのは、on モードのポート グループが、on モードの別のポート グループに接続する場合だけです。

    • non-silent (任意)controller が PAgP 対応のパートナーに接続されている場合、ポートが auto または desirable モードになると非サイレント動作を行うようにcontroller ポートを設定します。 non-silent を指定しないと、サイレントが想定されます。 サイレント設定は、ファイル サーバまたはパケット アナライザとの接続に適しています。 サイレントを設定すると、PAgP が動作してチャネル グループにポートを結合し、このポートが伝送に使用されます。

    • active:LACP デバイスが検出された場合に限り、LACP をイネーブルにします。 ポートをアクティブ ネゴシエーション ステートにします。この場合、ポートは LACP パケットを送信することによって、相手ポートとのネゴシエーションを開始します。

    • passiveポート上で LACP をイネーブルにして、ポートをパッシブ ネゴシエーション ステートにします。この場合、ポートは受信する LACP パケットに応答しますが、LACP パケット ネゴシエーションを開始することはありません。

     
    ステップ 6end


    例:
    Controller(config-if)# end
    
    
     

    特権 EXEC モードに戻ります。

     

    レイヤ 3 EtherChannel の設定 (CLI)

    レイヤ 3 EtherChannel にイーサネット ポートを割り当てるには、特権 EXEC モードで次の手順を実行します。 この手順は必須です。

    手順の概要

      1.    configure terminal

      2.    interface interface-id

      3.    no ip address

      4.    no switchport

      5.    channel-group channel-group-number mode { auto [ non-silent ] | desirable [ non-silent ] | on } | { active | passive }

      6.    end


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1configure terminal


      例:
      Controller# configure terminal
      
      
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 2 interface interface-id


      例:
      Controller(config)# interface gigabitethernet 1/0/2
      
      
       

      物理ポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

      有効なインターフェイスには、物理ポートが含まれます。

      PAgP EtherChannel の場合、同じタイプおよび速度のポートを 8 つまで同じグループに設定できます。

      LACP EtherChannel の場合、同じタイプのイーサネット ポートを 16 まで設定できます。 最大 8 個をアクティブに、最大 8 個をスタンバイ モードにできます。

       
      ステップ 3no ip address


      例:
      Controller(config-if)# no ip address
      
      
       

      物理ポートに割り当てられている IP アドレスがないことを確認します。

       
      ステップ 4no switchport


      例:
      Controller(config-if)# no switchport
      
      
       

      ポートをレイヤ 3 モードにします。

       
      ステップ 5 channel-group channel-group-number mode { auto [ non-silent ] | desirable [ non-silent ] | on } | { active | passive }


      例:
      Controller(config-if)# channel-group 5 mode auto
                     
      
       

      チャネル グループにポートを割り当て、PAgP モードまたは LACP モードを指定します。

      mode には、次のキーワードのいずれか 1 つを選択します。

      • auto:PAgP デバイスが検出された場合に限り、PAgP をイネーブルにします。 ポートをパッシブ ネゴシエーション ステートにします。この場合、ポートは受信する PAgP パケットに応答しますが、PAgP パケット ネゴシエーションを開始することはありません。 このキーワードは、EtherChannel メンバがcontroller スタックの異なるcontrollersのものである場合にはサポートされません。

      • desirable:PAgP を無条件でイネーブルにします。 ポートをアクティブ ネゴシエーション ステートにします。この場合、ポートは PAgP パケットを送信することによって、相手ポートとのネゴシエーションを開始します。 このキーワードは、EtherChannel メンバがcontroller スタックの異なるcontrollersのものである場合にはサポートされません。

      • on:PAgP や LACP を使用しないで、ポートを強制的にチャネル化します。 on モードでは、使用可能な EtherChannel が存在するのは、on モードのポート グループが、on モードの別のポート グループに接続する場合だけです。

      • non-silent:(任意)controllerが PAgP 対応のパートナーに接続されている場合、ポートが auto または desirable モードになると、非サイレント動作を行うようにcontroller ポートを設定します。 non-silent を指定しないと、サイレントが想定されます。 サイレント設定は、ファイル サーバまたはパケット アナライザとの接続に適しています。 サイレントを設定すると、PAgP が動作してチャネル グループにポートを結合し、このポートが伝送に使用されます。

      • active:LACP デバイスが検出された場合に限り、LACP をイネーブルにします。 ポートをアクティブ ネゴシエーション ステートにします。この場合、ポートは LACP パケットを送信することによって、相手ポートとのネゴシエーションを開始します。

      • passiveポート上で LACP をイネーブルにして、ポートをパッシブ ネゴシエーション ステートにします。この場合、ポートは受信する LACP パケットに応答しますが、LACP パケット ネゴシエーションを開始することはありません。

       
      ステップ 6end


      例:
      Controller(config-if)# end
      
      
       

      特権 EXEC モードに戻ります。

       

      EtherChannel ロードバランシングの設定(CLI)

      複数の異なる転送方式の 1 つを使用するように EtherChannel ロードバランシングを設定できます。

      このタスクはオプションです。

      手順の概要

        1.    configure terminal

        2.    port-channel load-balance { dst-ip | dst-mac | dst-mixed-ip-port | dst-port | extended [dst-ip | dst-mac | dst-port | ipv6-label | l3-proto | src-ip | src-mac | src-port ] | src-dst-ip | src-dst-mac src-dst-mixed-ip-port src-dst-portsrc-ip | src-mac | src-mixed-ip-port | src-port}

        3.    end


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1configure terminal


        例:
        Controller# configure terminal
        
        
         

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 2 port-channel load-balance { dst-ip | dst-mac | dst-mixed-ip-port | dst-port | extended [dst-ip | dst-mac | dst-port | ipv6-label | l3-proto | src-ip | src-mac | src-port ] | src-dst-ip | src-dst-mac src-dst-mixed-ip-port src-dst-portsrc-ip | src-mac | src-mixed-ip-port | src-port}


        例:
        Controller(config)# port-channel load-balance src-mac
        
        
         

        EtherChannel のロードバランシング方式を設定します。

        デフォルトは src-mac です。

        次のいずれかの負荷分散方式を選択します。

        • dst-ip:宛先ホストの IP アドレスを指定します。

        • dst-mac:着信パケットの宛先ホストの MAC アドレスを指定します。

        • dst-mixed-ip-port:ホストの IP アドレスおよび TCP/UDP ポートを指定します。

        • dst-port:宛先 TCP/UDP ポートを指定します。

        • extended:標準コマンドで使用可能なもの以外に、送信元および宛先の方式を組み合わせた、拡張ロード バランシング方式を指定します。

        • ipv6-label:IPv6 フロー ラベルを指定します。

        • l3-proto:レイヤ 3 プロトコルを指定します。

        • src-dst-ip:送信元および宛先ホストの IP アドレスを指定します。

        • src-dst-mac:送信元および宛先ホストの MAC アドレスを指定します。

        • src-dst-mixed-ip-port:送信元および宛先ホストの IP アドレスおよび TCP/UDP ポートを指定します。

        • src-dst-port:送信元および宛先 TCP/UDP ポートを指定します。

        • src-ip:送信元ホストの IP アドレスを指定します。

        • src-mac:着信パケットの送信元 MAC アドレスを指定します。

        • src-mixed-ip-port:送信元ホストの IP アドレスおよび TCP/UDP ポートを指定します。

        • src-port:送信元 TCP/UDP ポートを指定します。

         
        ステップ 3end


        例:
        Controller(config)# end
        
        
         

        特権 EXEC モードに戻ります。

         

        EtherChannel 拡張ロードバランシングの設定(CLI)

        ロードバランシング方式を組み合わせて使用する場合には、拡張ロードバランシングを設定します。

        このタスクはオプションです。

        手順の概要

          1.    configure terminal

          2.    port-channel load-balance extended [ dst-ip | dst-mac dst-port | ipv6-label | l3-proto | src-ip | src-mac | src-port ]

          3.    end


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1configure terminal


          例:
          Controller# configure terminal
          
          
           

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 2 port-channel load-balance extended [ dst-ip | dst-mac dst-port | ipv6-label | l3-proto | src-ip | src-mac | src-port ]


          例:
          Controller(config)# port-channel load-balance extended dst-ip dst-mac src-ip
          
          
          
           

          EtherChannel 拡張ロードバランシング方式を設定します。

          デフォルトは src-mac です。

          次のいずれかの負荷分散方式を選択します。

          • dst-ip:宛先ホストの IP アドレスを指定します。

          • dst-mac:着信パケットの宛先ホストの MAC アドレスを指定します。

          • dst-port:宛先 TCP/UDP ポートを指定します。

          • ipv6-label:IPv6 フロー ラベルを指定します。

          • l3-proto:レイヤ 3 プロトコルを指定します。

          • src-ip:送信元ホストの IP アドレスを指定します。

          • src-mac:着信パケットの送信元 MAC アドレスを指定します。

          • src-port:送信元 TCP/UDP ポートを指定します。

           
          ステップ 3end


          例:
          Controller(config)# end
          
          
           

          特権 EXEC モードに戻ります。

           

          PAgP 学習方式およびプライオリティの設定 (CLI)

          このタスクはオプションです。

          手順の概要

            1.    configure terminal

            2.    interface interface-id

            3.    pagp learn-method physical-port

            4.    pagp port-priority priority

            5.    end


          手順の詳細
             コマンドまたはアクション目的
            ステップ 1configure terminal


            例:
            Controller# configure terminal
            
            
             

            グローバル コンフィギュレーション モードを開始します。

             
            ステップ 2 interface interface-id


            例:
            Controller(config)# interface gigabitethernet 1/0/2
            
            
             

            伝送ポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

             
            ステップ 3 pagp learn-method physical-port


            例:
            Controller(config-if)# pagp learn-method physical port
            
            
             

            PAgP 学習方式を選択します。

            デフォルトでは、aggregation-port learning が選択されています。つまり、EtherChannel 内のポートのいずれかを使用して、controllerがパケットを送信元に送信します。 集約ポート ラーナーの場合、どの物理ポートにパケットが届くかは重要ではありません。

            物理ポート ラーナーである別のcontrollerに接続する物理ポートを選択します。 port-channel load-balance グローバル コンフィギュレーション コマンドを src-mac に設定してください。

            学習方式はリンクの両端で同じ方式に設定する必要があります。

             
            ステップ 4 pagp port-priority priority


            例:
            Controller(config-if)# pagp port-priority 200
            
            
             

            選択したポートがパケット伝送用として選択されるように、プライオリティを割り当てます。

            priority に指定できる範囲は 0 ~ 255 です。 デフォルト値は 128 です。 プライオリティが高いほど、ポートが PAgP 伝送に使用される可能性が高くなります。

             
            ステップ 5end


            例:
            Controller(config-if)# end
            
            
             

            特権 EXEC モードに戻ります。

             

            LACP ホット スタンバイ ポートの設定

            LACP がイネーブルの場合、ソフトウェアはデフォルトで、チャネルにおける LACP 互換ポートの最大数(最大 16 個のポート)の設定を試みます。 一度にアクティブにできる LACP リンクは 8 つだけです。残りの 8 個のリンクがホット スタンバイ モードになります。 アクティブ リンクの 1 つが非アクティブになると、ホット スタンバイ モードのリンクが代わりにアクティブになります。

            チャネルでアクティブ ポートの最大数を指定することでデフォルト動作を上書きできます。この場合、残りのポートがホット スタンバイ ポートになります。 たとえばチャネルで最大 5 個のポートを指定した場合、11 個までのポートがホット スタンバイ ポートになります。

            9 つ以上のリンクが EtherChannel グループとして設定された場合、ソフトウェアは LACP プライオリティに基づいてアクティブにするホット スタンバイ ポートを決定します。 ソフトウェアは、LACP を操作するシステム間のすべてのリンクに、次の要素(プライオリティ順)で構成された一意のプライオリティを割り当てます。

            • LACP システム プライオリティ

            • システム ID(controller MAC アドレス)

            • LACP ポート プライオリティ

            • ポート番号

            プライオリティの比較においては、数値が小さいほどプライオリティが高くなります。 プライオリティは、ハードウェア上の制約がある場合に、すべての互換ポートが集約されないように、スタンバイ モードにするポートを決定します。

            アクティブ ポートかホット スタンバイ ポートかを判別するには、次の(2 つの)手順を使用します。 まず、数値的に低いシステム プライオリティとシステム ID を持つシステムの方を選びます。 次に、ポート プライオリティおよびポート番号の値に基づいて、そのシステムのアクティブ ポートとホット スタンバイ ポートを決定します。 他のシステムのポート プライオリティとポート番号の値は使用されません。

            ソフトウェアのアクティブおよびスタンバイ リンクの選択方法に影響を与えるように、LACP システム プライオリティおよび LACP ポート プライオリティのデフォルト値を変更できます。

            LACP 最大バンドル機能の設定(CLI)

            ポート チャネルで許可されるバンドル化された LACP ポートの最大数を指定すると、ポート チャネル内の残りのポートがホット スタンバイ ポートとして指定されます。

            ポート チャネルの LACP ポートの最大数を設定するには、特権 EXEC モードで開始して、次の手順に従います。 この手順は任意です。

            手順の概要

              1.    configure terminal

              2.    interface port-channel channel-number

              3.    lacp max-bundle max-bundle-number

              4.    end


            手順の詳細
               コマンドまたはアクション目的
              ステップ 1configure terminal


              例:
              Controller# configure terminal
              
              
               

              グローバル コンフィギュレーション モードを開始します。

               
              ステップ 2 interface port-channel channel-number


              例:
              Controller(config)# interface port-channel 2 
              
              
               

              ポート チャネルのインターフェイス コンフィギュレーション モードを開始します。

              指定できる範囲は 1 ~ 128 です。

               
              ステップ 3lacp max-bundle max-bundle-number


              例:
              Controller(config-if)# lacp max-bundle 3
              
              
               

              ポートチャネル バンドルで LACP ポートの最大数を指定します。

              指定できる範囲は 1 ~ 8 です。

               
              ステップ 4end


              例:
              
              Controller(config)# end
              
              
               

              特権 EXEC モードに戻ります。

               
              関連コンセプト

              ポート チャネル最小リンク機能の設定(CLI)

              リンク アップ状態で、リンク アップ ステートに移行するポート チャネル インターフェイスの EtherChannel でバンドルする必要のあるアクティブ ポートの最小数を指定できます。

              ポート チャネルに必要なリンクの最小数を設定するには、特権 EXEC モードで開始して、次の手順に従います。 この手順は任意です。

              手順の概要

                1.    configure terminal

                2.    interface port-channel channel-number

                3.    port-channel min-links min-links-number

                4.    end


              手順の詳細
                 コマンドまたはアクション目的
                ステップ 1configure terminal


                例:
                Controller# configure terminal
                
                
                 

                グローバル コンフィギュレーション モードを開始します。

                 
                ステップ 2 interface port-channel channel-number


                例:
                Controller(config)# interface port-channel 2 
                
                
                 

                ポートチャネルのインターフェイス コンフィギュレーション モードを開始します。

                channel-number の範囲は 1 ~ 128 です。

                 
                ステップ 3port-channel min-links min-links-number


                例:
                Controller(config-if)# port-channel min-links 3
                
                
                 

                リンク アップ状態で、リンク アップ ステートに移行するポート チャネル インターフェイスの EtherChannel でバンドルする必要のあるメンバ ポートの最小数を指定できます。

                min-links-number の範囲は 2 ~ 8 です。

                 
                ステップ 4end


                例:
                
                Controller(config)# end
                
                
                 

                特権 EXEC モードに戻ります。

                 

                LACP システム プライオリティの設定(CLI)

                lacp system-priority グローバル コンフィギュレーション コマンドを使用して、LACP をイネーブルにしているすべての EtherChannel に対してシステム プライオリティを設定できます。 LACP を設定済みの各チャネルに対しては、システム プライオリティを設定できません。 デフォルト値を変更すると、ソフトウェアのアクティブおよびスタンバイ リンクの選択方法に影響します。

                show etherchannel summary 特権 EXEC コマンドを使用して、ホット スタンバイ モードのポートを確認できます(ポートステート フラグが H になっています)。

                LACP システム プライオリティを設定するには、特権 EXEC モードで次の手順を実行します。 この手順は任意です。

                手順の概要

                  1.    configure terminal

                  2.    lacp system-priority priority

                  3.    end


                手順の詳細
                   コマンドまたはアクション目的
                  ステップ 1configure terminal


                  例:
                  Controller# configure terminal
                  
                  
                   

                  グローバル コンフィギュレーション モードを開始します。

                   
                  ステップ 2 lacp system-priority priority


                  例:
                  Controller(config)# lacp system-priority 32000
                  
                  
                   

                  LACP システム プライオリティを設定します。

                  指定できる範囲は 1 ~ 65535 です。 デフォルト値は 32768 です。

                  値が小さいほど、システムプライオリティは高くなります。

                   
                  ステップ 3end


                  例:
                  Controller(config)# end
                  
                  
                   

                  特権 EXEC モードに戻ります。

                   

                  LACP ポート プライオリティの設定(CLI)

                  デフォルトでは、すべてのポートは同じポート プライオリティです。 ローカル システムのシステム プライオリティおよびシステム ID の値がリモート システムよりも小さい場合は、LACP EtherChannel ポートのポート プライオリティをデフォルトよりも小さい値に変更して、最初にアクティブになるホットスタンバイ リンクを変更できます。 ホット スタンバイ ポートは、番号が小さい方が先にチャネルでアクティブになります。 show etherchannel summary 特権 EXEC コマンドを使用して、ホット スタンバイ モードのポートを確認できます(ポートステート フラグが H になっています)。


                  (注)  


                  LACP がすべての互換ポートを集約できない場合(たとえば、ハードウェアの制約が大きいリモート システム)、EtherChannel 中でアクティブにならないポートはすべてホット スタンバイ ステートになり、チャネル化されたポートのいずれかが機能しない場合に限り使用されます。


                  LACP ポート プライオリティを設定するには、特権 EXEC モードで次の手順を実行します。 この手順は任意です。

                  手順の概要

                    1.    configure terminal

                    2.    interface interface-id

                    3.    lacp port-priority priority

                    4.    end


                  手順の詳細
                     コマンドまたはアクション目的
                    ステップ 1configure terminal


                    例:
                    Controller# configure terminal
                    
                     
                     

                    グローバル コンフィギュレーション モードを開始します。

                     
                    ステップ 2 interface interface-id


                    例:
                    Controller(config)# interface gigabitethernet 1/0/2
                    
                    
                     

                    設定するポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

                     
                    ステップ 3lacp port-priority priority


                    例:
                    Controller(config-if)# lacp port-priority 32000
                    
                    
                     

                    LACP ポート プライオリティを設定します。

                    指定できる範囲は 1 ~ 65535 です。 デフォルト値は 32768 です。 値が小さいほど、ポートが LACP 伝送に使用される可能性が高くなります。

                     
                    ステップ 4end


                    例:
                    Controller(config-if)# end
                    
                    
                     

                    特権 EXEC モードに戻ります。

                     

                    EtherChannel、PAgP、および LACP ステータスのモニタ

                    この表に記載されているコマンドを使用して EtherChannel、PAgP、および LACP ステータスを表示できます。

                    表 4 EtherChannel、PAgP、および LACP ステータスのモニタ用コマンド

                    コマンド

                    説明

                    clear lacp { channel-group-number counters | counters }

                    LACP チャネル グループ情報およびトラフィック カウンタをクリアします。

                    clear pagp { channel-group-number counters | counters }

                    PAgP チャネル グループ情報およびトラフィック カウンタをクリアします。

                    show etherchannel [ channel-group-number { detail | port | port-channel | protocol | summary }] [ detail | load-balance | port | port-channel | protocol | summary ]

                    EtherChannel 情報が簡潔、詳細に、1 行のサマリー形式で表示されます。 ロード バランシング方式またはフレーム配布方式、ポート、ポートチャネル、プロトコルの情報も表示されます。

                    show pagp [ channel-group-number ] { counters | internal | neighbor }

                    トラフィック情報、内部 PAgP 設定、ネイバー情報などの PAgP 情報が表示されます。

                    show pagp [ channel-group-number ] dual-active

                    デュアルアクティブ検出ステータスが表示されます。

                    show lacp [ channel-group-number ] { counters | internal  | neighbor | sys-id}

                    トラフィック情報、内部 LACP 設定、ネイバー情報などの LACP 情報が表示されます。

                    show running-config

                    設定エントリを確認します。

                    show etherchannel load-balance

                    ポート チャネル内のポート間のロード バランシング、またはフレーム配布方式を表示します。

                    EtherChannel の設定例

                    レイヤ 2 EtherChannel の設定:例

                    この例では、スタック内の 1 つのcontrollerに EtherChannel を設定する例を示します。 2 つのポートを VLAN 10 のスタティック アクセス ポートとして、PAgP モードが desirable であるチャネル 5 に割り当てます。

                    		Controller# configure terminal
                    		Controller(config)# interface range gigabitethernet2/0/1 -2
                    		Controller(config-if-range)# switchport mode access
                    		Controller(config-if-range)# switchport access vlan 10
                    		Controller(config-if-range)# channel-group 5 mode desirable non-silent
                    		Controller(config-if-range)# end
                    		
                    	

                    この例では、スタック内の 1 つのcontrollerに EtherChannel を設定する例を示します。 2 つのポートは VLAN 10 のスタティックアクセス ポートとして、LACP モードが active であるチャネル 5 に割り当てられます。

                    		Controller# configure terminal
                    		Controller(config)# interface range gigabitethernet2/0/1 -2 
                    		Controller(config-if-range)# switchport mode access
                    		Controller(config-if-range)# switchport access vlan 10
                    		Controller(config-if-range)# channel-group 5 mode active
                    		Controller(config-if-range)# end
                    		
                    	

                    次の例では、クロススタック EtherChannel を設定する方法を示します。 LACP passive モードを使用して、VLAN 10 内のスタティックアクセス ポートとしてスタック メンバ 1 のポートを 2 つ、スタック メンバ 2 のポートを 1 つチャネル 5 に割り当てます。

                    		Controller# configure terminal
                    		Controller(config)# interface range gigabitethernet2/0/4 -5 
                    		Controller(config-if-range)# switchport mode access
                    		Controller(config-if-range)# switchport access vlan 10
                    		Controller(config-if-range)# channel-group 5 mode passive 
                    		Controller(config-if-range)# exit
                    		Controller(config)# interface gigabitethernet3/0/3 
                    		Controller(config-if)# switchport mode access
                    		Controller(config-if)# switchport access vlan 10
                    		Controller(config-if)# channel-group 5 mode passive 
                    		Controller(config-if)# exit
                    		
                    

                    レイヤ 3 EtherChannel の設定:例

                    この例では、レイヤ 3 インターフェイスの設定方法を示します。 2 つのポートは、LACP モードが active であるチャネル 5 に割り当てられます。

                    		Controller# configure terminal 
                    		Controller(config)# interface range gigabitethernet2/0/1 -2 
                    		Controller(config-if-range)# no ip address 
                    		Controller(config-if-range)# no switchport
                    		Controller(config-if-range)# channel-group 5 mode active
                    		Controller(config-if-range)# end
                    		
                    		
                             

                    この例では、クロススタック レイヤ 3 EtherChannel の設定方法を示します。 スタック メンバー 2 の 2 つのポートとスタック メンバー 3 の 1 つのポートは、LACP active モードでチャネル 7 に割り当てられます。

                    		Controller# configure terminal 
                    		Controller(config)# interface range gigabitethernet2/0/4 -5 
                    		Controller(config-if-range)# no ip address 
                    		Controller(config-if-range)# no switchport 
                    		Controller(config-if-range)# channel-group 7 mode active 
                    		Controller(config-if-range)# exit
                    		Controller(config)# interface gigabitethernet3/0/3 
                    		Controller(config-if)# no ip address 
                    		Controller(config-if)# no switchport 
                    		Controller(config-if)# channel-group 7 mode active 
                    		Controller(config-if)# exit
                    		
                    		
                             

                    LACP ホット スタンバイ ポートの設定:例

                    この例では、少なくとも 3 個のアクティブ ポートがある場合にアクティブ化される EtherChannel を設定する例を示します(ポート チャネル 2)。これは、7 個のアクティブ ポートとホット スタンバイ ポートとしての最大 9 個の残りのポートから構成されます。

                    		Controller# configure terminal
                    		Controller(config)# interface port-channel 2
                    		Controller(config-if)# port-channel min-links 3 
                      Controller(config-if)# lacp max-bundle 7
                    		
                    		
                    	
                    関連コンセプト

                    EtherChannels の追加リファレンス

                    関連資料

                    関連項目 マニュアル タイトル
                    レイヤ 2 コマンド リファレンス Layer 2 Command Reference (Cisco WLC 5700 Series)

                    エラー メッセージ デコーダ

                    説明 Link

                    このリリースのシステム エラー メッセージを調査し解決するために、エラー メッセージ デコーダ ツールを使用します。

                    https:/​/​www.cisco.com/​cgi-bin/​Support/​Errordecoder/​index.cgi

                    標準および RFC

                    標準/RFC Title

                    なし

                    MIB

                    MIB MIB のリンク

                    本リリースでサポートするすべての MIB

                    選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットに関する MIB を探してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

                    http:/​/​www.cisco.com/​go/​mibs

                    テクニカル サポート

                    説明 Link

                    シスコのサポート Web サイトでは、シスコの製品やテクノロジーに関するトラブルシューティングにお役立ていただけるように、マニュアルやツールをはじめとする豊富なオンライン リソースを提供しています。

                    お使いの製品のセキュリティ情報や技術情報を入手するために、Cisco Notification Service(Field Notice からアクセス)、Cisco Technical Services Newsletter、Really Simple Syndication(RSS)フィードなどの各種サービスに加入できます。

                    シスコのサポート Web サイトのツールにアクセスする際は、Cisco.com のユーザ ID およびパスワードが必要です。

                    http:/​/​www.cisco.com/​support

                    EtherChannels の機能情報

                    リリース

                    変更内容

                    Cisco IOS XE 3.2SE

                    この機能が導入されました。

                    Cisco IOS XE 3.3SE

                    LACP 最大バンドル機能、ポート チャネルの最小リンク機能のサポートが追加されました。