ハイ アベイラビリティ構成ガイド、Cisco IOS XE Release 3SE(Cisco WLC 5700 シリーズ)
ハイ アベイラビリティの設定
ハイ アベイラビリティの設定
発行日;2013/12/17   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

ハイ アベイラビリティの設定

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されている機能がすべてサポートされていない場合があります。 最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、http:/​​/​​www.cisco.com/​​go/​​cfn にアクセスします。 Cisco.com のアカウントは必要ありません。

ハイ アベイラビリティに関する情報

ハイ アベイラビリティ機能は、コントローラがスタック ケーブルで接続され、Cisco StackWise-480 テクノロジーがイネーブルの場合、デフォルトでイネーブルになります。 これをディセーブルにすることはできません。ただし、コントローラ上でハイ アベイラビリティ機能を使用するために、コマンドライン インターフェイスを使用して手動グレースフル スイッチオーバーを開始できます。

アクセス ポイントのステートフル スイッチオーバーに関する情報

アクセス ポイント ステートフル スイッチオーバー(AP SSO)とは、すべてのアクセス ポイントがステートフルにスイッチオーバーし、ユーザ セッション情報がスイッチオーバー中も維持され、アクセス ポイントがネットワーク内でセッションを失うことなく動作継続することで、ネットワークの可用性が高まることを意味します。 スタックのアクティブ スイッチは、IP 機能やルーティング情報交換を含め、すべてのネットワーク機能を実行するよう装備されます。 コントローラは、1000 アクセス ポイントと 12000 クライアントをサポートします。

ただし、スイッチオーバー発生時に FlexConnect モードでローカルにスイッチされるクライアントを除き、すべてのクライアントが認証解除され新しいアクティブ コントローラに再度関連付けられる必要があります。

スタック内で冗長ペアが形成されると、ハイ アベイラビリティが実現します。これには、アクティブからスタンバイへのスイッチオーバーの間もアクセスポイントが接続された状態を維持することが含まれます。

(注)  


コントローラが冗長ペアを形成した後は、コントローラ スタック内で AP SSO をディセーブルにできません。

グレースフル スイッチオーバーの開始

手動スイッチオーバーを実行し、コントローラ上でハイ アベイラビリティ機能をイネーブルにするには、redundancy force-switchover コマンドを実行します。 このコマンドは、その時にアクティブなコントローラからスタンバイ コントローラへのグレースフル スイッチオーバーを開始します。

controller#redundancy force-switchover
System configuration has been modified. Save ? [yes/no] : yes
Building configuration …
Preparing for switchover …
Compressed configuration from 14977 bytes to 6592 bytes[OK]This will reload the active unit and force switchover to standby[confirm] : y
はじめる前に

EtherChannel の設定

LAG またはイーサチャネルは、スタンバイ ユニットとアクティブ ユニット両方の既存のポートをバンドルして単一の論理ポート( リンク )として、 60 Gbps の集約帯域幅を提供します。 EtherChannel の作成は、障害に対する保護を可能にします。 作成された Etherchannels または LAG は、アクセス ポイントのハイ アベイラビリティを確保するための冗長リンクに使用されます。

手順の概要

    1.    スタック ケーブルを使用して、電力がダウン状態の 2 台のコントローラを接続します。

    2.    両方のコントローラに同時に電源投入して起動するか、1 台のコントローラに電源投入して起動しします。

    3.    ユニットで EtherChannel または LAG を設定します。

    4.    設定された Etherchannel のステータスを表示するには、show etherchannel summary コマンドを実行します。

    5.    接続されたアクセス ポイントを確認するには、show ap uptime コマンドを実行します。


手順の詳細
    ステップ 1   スタック ケーブルを使用して、電力がダウン状態の 2 台のコントローラを接続します。
    ステップ 2   両方のコントローラに同時に電源投入して起動するか、1 台のコントローラに電源投入して起動しします。

    コントローラが正常起動し、ハイ アベイラビリティ ペアを形成します。

    ステップ 3   ユニットで EtherChannel または LAG を設定します。
    ステップ 4   設定された Etherchannel のステータスを表示するには、show etherchannel summary コマンドを実行します。

    設定が正常に終了すると、指定されたポートすべてが単一のチャネルにバンドルされ、show etherchannel summary コマンドでリストに出力されます。

    ステップ 5   接続されたアクセス ポイントを確認するには、show ap uptime コマンドを実行します。

    例:


    LACP の設定

    はじめる前に

    手順の概要

      1.    conf t

      2.    interface Port-channel number

      3.    lacp max-bundle number

      4.    lacp port-priority number

      5.    switchport backup interface Po2

      6.    end

      7.    show etherchannel summary

      8.    show interfaces switchport backup


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1conf t

      例:
      controller#conf t
       
      端末を設定します。  
      ステップ 2interface Port-channel number

      例:
      controller(config)#interface Port-channel Po2
       
      ポートチャネル インターフェイス コンフィギュレーション モードを開始します。  
      ステップ 3 lacp max-bundle number

      例:
      controller(config-if)# lacp max-bundle 6          
                      
       

      ポート チャネルで許可される、アクティブなバンドルされた LACP ポートの最大数を定義します。 値の範囲は 1 ~ 8 です。

       
      ステップ 4 lacp port-priority number


      例:
      controller(config-if)#lacp port-priority 4
       

      LACP を使用するポートに設定するポート プライオリティを指定します。 値の範囲は 0 ~ 65535 です。

       
      ステップ 5 switchport backup interface Po2

      例:
      controller(config-if)# switchport backup interface Po2
       

      バックアップ インターフェイスとしてインターフェイスを指定します。

       
      ステップ 6end   インターフェイスとコンフィギュレーション モードを終了します。  
      ステップ 7 show etherchannel summary

      例:
      controller# show etherchannel summary
       

      EtherChannel のプロパティの概要を表示します。

       
      ステップ 8 show interfaces switchport backup

      例:
      controller#show interfaces switchport backup
       

      バックアップ EtherChannel のプロパティの概要を表示します。

       

      ハイ アベイラビリティのトラブルシューティング

      スタンバイ コンソールへのアクセス

      スタック内のアクティブ コントローラのコンソールにのみアクセスできます。 スタンバイ コントローラ コンソールにアクセスするには、次のコマンドを使用します。ただし、シスコのサポートが指示した場合にのみこの機能を使用します。

      はじめる前に

      手順の概要

        1.    conf t

        2.    service internal

        3.    redundancy

        4.    main-cpu

        5.    standby console enable

        6.    exit


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1conf t

        例:
        Controller# configure terminal
         
        端末を設定します。  
        ステップ 2 service internal

        例:
        Controller(config)# service internal
         

        Cisco IOS デバッグ コマンドをイネーブルにします。

         
        ステップ 3redundancy

        例:
        Controller(config)# redundancy
         

         
        ステップ 4main-cpu

        例:
        Controller(config)# main-cpu
         

         
        ステップ 5standby console enable

        例:
        Controller(config)# standby console enable
        
         

        スタンバイ コンソールをイネーブルにします。

         
        ステップ 6exit

        例:
        Controller(config)# exit
        
         

        コンフィギュレーション モードを終了します。

         

        スイッチオーバー前

        スイッチオーバーは、アクティブ コントローラに障害が発生したときに発生します。ただし、手動スイッチオーバーの実行中、ここにリストされたコマンドを実行して、スイッチオーバーの開始が成功するかを確認できます。

        手順の概要

          1.    show redundancy states

          2.    show switch detail

          3.    show platform SES states

          4.    show ap summary

          5.    show CAPWAP detail

          6.    show dtls database-brief

          7.    show power inline


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1 show redundancy states

          例:
          controller#show redundancy states
           

          アクティブおよびスタンバイ スイッチのハイ アベイラビリティ ロールを表示します。

           
          ステップ 2show switch detail

          例:
          controller#show switch detail
           

          スタックの物理特性を表示します。 スタックの物理状態が「Ready」または「Port」かどうか確認します。

           
          ステップ 3show platform SES states

          例:
          controller#show platform SES states
           

          スタック マネージャのシーケンスを表示します。

           
          ステップ 4show ap summary

          例:
          controller#show ap summary
           

          アクティブおよびスタンバイ スイッチのすべてのアクセス ポイントを表示します。

           
          ステップ 5show CAPWAP detail

          例:
          controller#show CAPWAP detail
           

          アクティブおよびスタンバイ スイッチの CAPWAP トンネルの詳細を表示します。

           
          ステップ 6show dtls database-brief

          例:
          controller#show dtls database-brief
           

          アクティブおよびスタンバイ スイッチの DTLS の詳細を表示します。

           
          ステップ 7show power inline

          例:
          controller#show power inline
           

          Power over Ethernet の電源状態を表示します。

           

          スイッチオーバー後

          ここでは、アクティブからスタンバイ スイッチへのスイッチオーバーが実行されるのを保障するため、ユーザが実行する必要のある手順を定義します。 スタンバイ スイッチからアクティブへのスイッチオーバー成功後、アクティブへ接続されたすべてのアクセス ポイントはスタンバイ(その後アクティブ)スイッチに再参加する必要があります。

          手順の概要

            1.    show ap uptime

            2.    show wireless summary

            3.    show wcdb database all

            4.    show power inline


          手順の詳細
             コマンドまたはアクション目的
            ステップ 1show ap uptime


            例:
            controller#show ap uptime
             

            スイッチオーバー後のアクセス ポイントのアップタイムが十分に大きいかどうかを確認します。

             
            ステップ 2show wireless summary


            例:
            controller#show wireless summary
             

            アクティブ スイッチに接続されているクライアントを表示します。

             
            ステップ 3show wcdb database all


            例:
            controller#show wcdb database all
             

            クライアントがアップタイムに達したかを表示します。

             
            ステップ 4show power inline


            例:
            controller#show power inline
             

            Power over Ethernet の電源状態を表示します。

             

            コントローラ スタックのモニタリング

            表 1 スタック情報を表示するコマンド

            コマンド

            説明

            show switch

            割り当てられたスイッチやバージョン不一致モードのスイッチのステータスなど、スタックに関するサマリー情報を表示します。

            show switch stack-member-number

            特定のメンバーに関する情報を表示します。

            show switch detail

            スタックに関する詳細情報を表示します。

            show switch neighbors

            スタック ネイバーを表示します。

            show switch stack-ports [summary]

            スタックのポート情報を表示します。 スタックのケーブル長、スタックのリンク ステータス、およびループバック ステータスを表示するには、summary キーワードを使用します。

            show redundancy

            冗長システムと現在のプロセッサ情報を表示します。 冗長システムの情報にはシステム稼働時間、スタンバイ失敗、スイッチオーバー理由、ハードウェア、設定冗長モードおよび動作冗長モードが含まれます。 表示される現在のプロセッサ情報にはアクティブ位置、ソフトウェアの状態、現在の状態での稼働時間などが含まれます。

            show redundancy state

            アクティブおよびスタンバイ コントローラの冗長状態をすべて表示します。

            LACP の設定:例

            次に、LACP を設定して LACP バンドルの作成と状態を確認する例を示します。

            Controller(config)# !
            interface TenGigabitEthernet1/0/1
             switchport mode trunk
             channel-group 1 mode active
             lacp port-priority 10
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet1/0/2
             switchport mode trunk
             channel-group 1 mode active
             lacp port-priority 10
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet1/0/3
             switchport mode trunk
             channel-group 1 mode active
             lacp port-priority 10
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet1/0/4
             switchport mode trunk
             channel-group 1 mode active
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet1/0/5
             switchport mode trunk
             channel-group 1 mode active
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet1/0/6
             switchport mode trunk
             channel-group 1 mode active
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet2/0/1
             switchport mode trunk
             channel-group 1 mode active
             lacp port-priority 10
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet2/0/2
             switchport mode trunk
             channel-group 1 mode active
             lacp port-priority 10
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet2/0/3
             switchport mode trunk
             channel-group 1 mode active
             lacp port-priority 10
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet2/0/4
             switchport mode trunk
             channel-group 1 mode active
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet2/0/5
             switchport mode trunk
             channel-group 1 mode active
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet2/0/6
             switchport mode trunk
             channel-group 1 mode active
             ip dhcp snooping trust
            !
            interface Vlan1
             no ip address
             ip igmp version 1
             shutdown
            !
            
            		Controller#  show etherchannel summary
            		 
            		Flags:  D - down        P - bundled in port-channel
                    I - stand-alone s - suspended
                    H - Hot-standby (LACP only)
                    R - Layer3      S - Layer2
                    U - in use      f - failed to allocate aggregator
            
                    M - not in use, minimum links not met
                    u - unsuitable for bundling
                    w - waiting to be aggregated
                    d - default port
            
            
            Number of channel-groups in use: 1
            Number of aggregators:           1
            
            Group  Port-channel  Protocol    Ports
            ------+-------------+-----------+-----------------------------------------------
            1      Po1(SU)         LACP      Te1/0/1(P)  Te1/0/2(P)  Te1/0/3(P)
                                             Te1/0/4(H)  Te1/0/5(H)  Te1/0/6(H)
                                             Te2/0/1(P)  Te2/0/2(P)  Te2/0/3(P)
                                             Te2/0/4(H)  Te2/0/5(H)  Te2/0/6(H)
            
             
            		

            次に、スイッチのバックアップ インターフェイス ペアの例を示します。

            Controller# show interfaces switchport backup
            
            Switch Backup Interface Pairs:
            
            Active Interface        Backup Interface        State
            ------------------------------------------------------------------------
            Port-channel1             Port-channel2             Active Standby/Backup Up
            
            
             
            		

            次に、コントローラに設定された EtherChannel の概要の例を示します。

            Controller# show ethernet summary
            
            
            Flags:  D - down        P - bundled in port-channel
                    I - stand-alone s - suspended
                    H - Hot-standby (LACP only)
                    R - Layer3      S - Layer2
                    U - in use      f - failed to allocate aggregator
            
                    M - not in use, minimum links not met
                    u - unsuitable for bundling
                    w - waiting to be aggregated
                    d - default port
            
            
            Number of channel-groups in use: 2
            Number of aggregators:           2
            
            Group  Port-channel  Protocol    Ports
            ------+-------------+-----------+-----------------------------------------------
            1      Po1(SU)         LACP      Te1/0/1(P)  Te1/0/2(P)  Te1/0/3(P)
                                             Te1/0/4(P)  Te1/0/5(P)  Te1/0/6(P)
            2      Po2(SU)         LACP      Te2/0/1(P)  Te2/0/2(P)  Te2/0/3(P)
                                             Te2/0/4(P)  Te2/0/5(P)  Te2/0/6(P)
            
            
            
            		
             
            		

            Flex Link の設定:例

            次に、Flex Link を設定し、作成されたリンクの作成および状態を確認する例を示します。

            Controller(config)# !
            interface Port-channel1
             description Ports 1-6 connected to NW-55-SW
             switchport mode trunk
             switchport backup interface Po2
             switchport backup interface Po2 preemption mode forced
             switchport backup interface Po2 preemption delay 1
             ip dhcp snooping trust
            !
            interface Port-channel2
             description Ports 7-12connected to NW-55-SW
             switchport mode trunk
             ip dhcp snooping trust
            !
            interface GigabitEthernet0/0
             vrf forwarding Mgmt-vrf
             no ip address
             negotiation auto
            !
            interface TenGigabitEthernet1/0/1
             switchport mode trunk
             channel-group 1 mode on
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet1/0/2
             switchport mode trunk
             channel-group 1 mode on
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet1/0/3
             switchport mode trunk
             channel-group 1 mode on
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet1/0/4
             switchport mode trunk
             channel-group 1 mode on
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet1/0/5
             switchport mode trunk
             channel-group 1 mode on
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet1/0/6
             switchport mode trunk
             channel-group 1 mode on
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet2/0/1
             switchport mode trunk
             channel-group 2 mode on
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet2/0/2
             switchport mode trunk
             channel-group 2 mode on
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet2/0/3
             switchport mode trunk
             channel-group 2 mode on
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet2/0/4
             switchport mode trunk
             channel-group 2 mode on
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet2/0/5
             switchport mode trunk
             channel-group 2 mode on
             ip dhcp snooping trust
            !
            interface TenGigabitEthernet2/0/6
             switchport mode trunk
             channel-group 2 mode on
             ip dhcp snooping trust
            !
            interface Vlan1
             no ip address
            
            
            		Controller#  show etherchannel summary
            		 
            		Flags:  D - down        P - bundled in port-channel
                    I - stand-alone s - suspended
                    H - Hot-standby (LACP only)
                    R - Layer3      S - Layer2
                    U - in use      f - failed to allocate aggregator
            
                    M - not in use, minimum links not met
                    u - unsuitable for bundling
                    w - waiting to be aggregated
                    d - default port
            
            
            Number of channel-groups in use: 2
            Number of aggregators:           2
            
            Group  Port-channel  Protocol    Ports
            ------+-------------+-----------+-----------------------------------------------
            1      Po1(SU)          -        Te1/0/1(P)  Te1/0/2(P)  Te1/0/3(P)
                                             Te1/0/4(P)  Te1/0/5(P)  Te1/0/6(P)
            2      Po2(SU)          -        Te2/0/1(P)  Te2/0/2(P)  Te2/0/3(D)
                                             Te2/0/4(P)  Te2/0/5(P)  Te2/0/6(P)
            
            
             
            		

            冗長スイッチオーバー履歴の表示(GUI)


              ステップ 1   [Monitor] > [Controller] > [Redundancy > States] をクリックします。

              [Redundancy States] ページが表示されます。 次のパラメータの値がページに表示されます。

              パラメータ 説明
              Index 冗長ユニットのインデックス番号を表示します。
              Previous Active 以前にアクティブだったコントローラを表示します。
              Current Active 現在アクティブなコントローラを表示します。
              Switch Over Time スイッチオーバーが発生したシステム時刻が表示されます。
              Switch Over Reason スイッチオーバーの理由を表示します。
              ステップ 2   [Apply] をクリックします。


              スイッチオーバー状態の表示(GUI)


                ステップ 1   [Monitor] > [Controller] > [Redundancy > States] をクリックします。

                [Redundancy States] ページが表示されます。 次のパラメータの値がページに表示されます。

                パラメータ 説明
                My State アクティブ CPU Controller モジュールの状態を表示します。 表示される値は次のとおりです。
                • Active
                • Standby HOT
                • Disable
                Peer State ピア(またはスタンバイ)CPU Controller モジュールの状態を表示します。 表示される値は次のとおりです。
                • Standby HOT
                • Disable
                Mode 冗長ピアの現在の状態を表示します。 表示される値は次のとおりです。
                • Simplex:シングル CPU スイッチ モジュール
                • Duplex:2 台の CPU スイッチ モジュール
                Unit ID CPU スイッチ モジュールのユニット ID を表示します。
                Redundancy Mode (Operational) ユニットでサポートされる最新の動作冗長モードを表示します。
                Redundancy Mode (Configured) ユニットでサポートされる最新の設定冗長モードを表示します。
                Redundancy State ユニットの現在機能している冗長性状態を表示します。 表示される値は次のとおりです。
                • SSP
                • Not Redundant
                Manual SWACT 手動スイッチオーバーが force オプションなしでイネーブルかどうかを表示します。
                Communications 2 台の CPU Controller モジュール間での通信がアップかダウンかを表示します。
                Client Count RF クライアントとして登録されている冗長サブシステムの数を表示します。
                Client Notification TMR 内部 RF タイマーが RF クライアント サブシステムに通知するための時間をミリ秒単位で表示します。
                Keep Alive TMR RF マネージャがスタンバイ CPU スイッチ モジュールのピアにキープアライブ メッセージを送信する間隔をミリ秒単位で表示します。
                Keep Alive Count 送信された後にスタンバイ CPU Controller モジュールから応答がないキープアライブ メッセージの数を表示します。
                Keep Alive Threshold キープアライブ メッセージがイネーブルのときに(デフォルト状態)、プロセッサ間通信がダウンしていると宣言するしきい値を表示します。
                RF Debug Mask どのデバッグ モードがオンになっているか追跡するために RF が使用する内部マスクを表示します。
                ステップ 2   [Apply] をクリックします。