エンタープライズ モビリティ 7.3 デザイン ガイド Cisco Validated Design
Cisco Unified Wireless のマルチキャスト設計
Cisco Unified Wireless のマルチキャスト設計
発行日;2013/12/01 | 英語版ドキュメント(2013/09/27 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 10MB) | フィードバック

目次

Cisco Unified Wireless のマルチキャスト設計

概要

マルチキャスト転送の概要

無線マルチキャスト ローミング

非対称マルチキャスト トンネリング

マルチキャスト対応ネットワーク

CAPWAP マルチキャスト予約ポートおよびアドレス

コントローラでのマルチキャスト転送の有効化

Ethernet Multicast Mode を有効にする CLI コマンド

マルチキャストの配置に関する考慮事項

CAPWAP マルチキャスト アドレスを選択する際の推奨事項

断片化と CAPWAP マルチキャスト パケット

すべてのコントローラの CAPWAP マルチキャスト グループが同じになる

標準のマルチキャスト技術を使用した WLAN 上のマルチキャストの制御

コントローラの配置がマルチキャスト トラフィックとローミングに与える影響

その他の考慮事項

Cisco Unified Wireless のマルチキャスト設計

概要

この章では、IP マルチキャスト転送における Cisco Unified Wireless Network のマルチキャストについて説明し、無線環境でのマルチキャストの展開方法に関する情報を提供します。マルチキャスト パフォーマンス機能を使用するための前提条件として、マルチキャスト対応ネットワークが、コントローラとアクセス ポイント(AP)の間のすべてのルータに設定されていることが必要です。マルチキャストをサポートしないネットワークに対応するため、コントローラでは元のユニキャスト パケット転送メカニズムも引き続きサポートされます。

IP マルチキャストは、情報を宛先のグループに配信するためのプロトコルです。IP マルチキャストでは、ネットワークのそれぞれのリンク上で情報を配信する最も効果的な戦略を使用しています。ネットワークのそれぞれのホップで情報のコピーが 1 つだけ送信され、宛先へのリンクが分かれる場合にのみコピーが作成されます。通常、現在のネットワーク アプリケーションの多くはユニキャスト パケットを使用します。すなわち、1 つの送信元に 1 つの宛先が対応します。しかし、複数の受信先で同じデータが必要な場合、送信元からすべての受信先に対して個別のユニキャスト パケットとしてデータを複製すると、ネットワークの負荷が増大します。IP マルチキャストによって、動的に形成された一連の受信先に一連の送信元から効率的にデータを転送できます。

現在、受信先の大規模なグループに宛てた一方向のストリーミングメディア(ビデオなど)には、通常 IP マルチキャストが使用されています。多くのケーブル テレビ局、教育機関、および大企業では、コンテンツの配信のために IP マルチキャストが展開されています。さらに、マルチキャストを使用して音声およびビデオ会議に利用されています。その他、構内および商業ネットワークでマルチキャストが広く使用されている例として、ファイルの配信があります。特に、オペレーティング システムのイメージおよびアップデートをリモート ホストに配信する場合などです。また、金融部門において、株価情報表示および hoot-n-holler システムなどのアプリケーションのために IP マルチキャストが展開されています。

マルチキャスト転送の概要

Cisco Unified Wireless Network Software Release 4.1 では、無線ネットワークで効率的にマルチキャストを使用するためのサポートが強化されています。3.1 以前のソフトウェア リリースでは、マルチキャスト用のパケットは、実際には無線ネットワーク上のユニキャストでした。マルチキャストのサポートは、3.2 で追加されましたが、必要なブロードキャストを有効にするためにはまだ設定の制限がありました。4.1 では、コントローラ ソフトウェア リリースによってブロードキャストとマルチキャストの個別のサポートが可能になり、ネットワークをマルチキャスト、ブロードキャスト、またはマルチキャストとブロードキャスト両方で使用するために設定できるようになりました。

現在の Cisco Unified Wireless マルチキャスト サポートでは、ファースト ホップ ルータに接続されている VLAN からコントローラが受信した各マルチキャスト フレームがコピーされ、アソシエートされている AP のコントローラで設定されたマルチキャスト グループに送信されます(図 6-1 を参照)。マルチキャスト パケットを含むマルチキャスト CAPWAP パケットでは、WLAN ビットマップを使用します。WLAN ビットマップからは、パケットの転送に使用する必要がある WLAN の着信 AP が通知されます。AP が CAPWAP パケットを受信すると、AP は外部 CAPWAP カプセル化を解除し、CAPWAP WLAN ID ビットマスクで識別された(WLAN にアソシエートされているすべての無線上の)WLAN にマルチキャスト パケットを送信します。

図 6-1 4.1 以前のバージョンでのマルチキャスト転送メカニズム

 

CAPWAP マルチキャスト グループは実質上、各アクセス ポイントにマルチキャスト パケットを送信するために使用されます。これにより、ネットワーク内のルータは標準のマルチキャスト手法を使用してマルチキャスト パケットを複製し、AP に送信できるようになります。CAPWAP マルチキャスト グループの場合は、コントローラがマルチキャスト送信元になり、AP がマルチキャスト受信側になります。


) マルチキャスト パフォーマンス機能を使用するための前提条件として、マルチキャスト対応ネットワークが、コントローラと AP の間のすべてのルータに設定されます。マルチキャストをサポートしないネットワークに対応するため、コントローラでは元のユニキャスト パケット転送メカニズムも引き続きサポートされます。



) マルチキャストが有効になっていると、ファースト ホップ ルータからの VLAN 上で受信されたマルチキャスト パケットはその種類にかかわらず、HSRP hello パケット、すべてのルータ、EIGRP および PIM マルチキャスト パケットを含め、無線ネットワーク経由で送信されます。


管理者がマルチキャストを有効にして(マルチキャスト モードはデフォルトで無効になっています)、CAPWAP マルチキャスト グループを設定すると、コントローラへの通常の接続プロセス中(ブート時)に、アクセス ポイントがコントローラの CAPWAP マルチキャスト グループのアドレスをダウンロードします。アクセス ポイントがコントローラに接続し、コントローラの設定をダウンロードした後、その AP はコントローラの CAPWAP マルチキャスト グループに加わるための Internet Group Management Protocol(IGMP)Join 要求が発行されます。これにより、マルチキャスト対応ルータで、コントローラと AP の間のマルチキャスト ステートに対する通常のセットアップが開始されます。マルチキャスト グループの送信元 IP アドレスは、レイヤ 3 モードに使用される AP マネージャの IP アドレスではなく、コントローラ管理インターフェイスの IP アドレスです。AP がコントローラの CAPWAP マルチキャスト グループに参加すると、クライアントのマルチキャスト トラフィックのマルチキャスト アルゴリズムは次のように動作します。

マルチキャスト グループの送信元が有線 LAN 上にある場合

ファースト ホップ ルータ上の任意のクライアント VLAN からマルチキャスト パケットを受信した場合、コントローラでは、管理インターフェイスを介して、ベスト エフォートの QoS 分類で、CAPWAP マルチキャスト グループにパケットを送信します。CAPWAP マルチキャスト パケットの QoS ビットは、最低レベルでハードコード化されており、ユーザが変更することはできません。

マルチキャスト対応ネットワークでは、CAPWAP マルチキャスト パケットが、CAPWAP マルチキャスト グループに接続されている各アクセス ポイントに配信されます。このときルータでは、マルチキャスト パケットがすべての AP に到達するように、必要に応じて配信時にパケットを複製する通常のマルチキャスト メカニズムが使用されます(図 6-1 を参照)。これにより、コントローラでは、マルチキャスト パケットを複製する必要がなくなります。

アクセス ポイントでは他のマルチキャスト パケットを受信できますが、現在の接続先のコントローラから受信したマルチキャスト パケットだけが処理され、その他のコピーは破棄されます。元のマルチキャスト パケットの送信元である VLAN インターフェイスに複数の WLAN が関連付けられていた場合、AP は各 WLAN を使用してマルチキャスト パケットを送信します(CAPWAP ヘッダー内の WLAN ビットマップに従う)。さらに、WLAN が両方の無線(802.11g と 802.11a)上にある場合、関連付けられたクライアントがあれば、そのクライアントでマルチキャスト トラフィックを要求しなかった場合でも、両方の無線で WLAN SSID 宛てにマルチキャスト パケットが送信されます。

マルチキャスト グループの送信元がワイヤレス クライアント上にある場合

マルチキャスト パケットは、標準のワイヤレス クライアント トラフィック同様に、AP からコントローラへの(CAPWAP カプセル化された)ユニキャストです。

コントローラは、マルチキャスト パケットのコピーを 2 つ作成します。1 つ目のコピーは、マルチキャスト パケットを受信した WLAN に関連付けられている VLAN から送信されます。これにより、有線 LAN 上の受信先でマルチキャスト ストリームを受信できるようになり、ルータで新しいマルチキャスト グループを認識できるようになります。パケットの 2 つ目のコピーは、CAPWAP カプセル化され、ワイヤレス クライアントでマルチキャスト ストリームを受信できるように、CAPWAP マルチキャスト グループに送信されます。

無線マルチキャスト ローミング

無線環境のマルチキャスト クライアントでは、WLAN 内を移動するときのマルチキャスト グループ メンバーシップの維持が大きな課題となります。AP 間の移動時に無線接続でパケットがドロップすると、クライアントのマルチキャストアプリケーションが中断する場合があります。グループ メンバーシップ情報の動的メンテナンスでは、Internet Group Management Protocol(IGMP)が重要な役割を果たします。

IGMP の基本的な知識は、クライアントのマルチキャスト セッションがネットワーク内を移動するときに何が起こっているかを理解するために重要です。レイヤ 2 ローミングの場合、適切に設定されている外部 AP であればすでにそのマルチキャスト グループに属しており、トラフィックはネットワーク上の別のアンカー ポイントにトンネリングされないため、セッションはそのまま維持されます。レイヤ 3 ローミング環境では仕組みがもう少し複雑で、コントローラに設定したトンネリング モードによって異なっており、ワイヤレス クライアントから送信された IGMP メッセージに影響します。コントローラ上のデフォルトのモビリティ トンネリング モードは非対称です。 で説明したとおり、これは、クライアントへのリターン トラフィックがアンカー WLC に送信されてから、関連付けられたクライアント接続が配置されている外部 WLC に転送されることを意味します。発信パケットは、外部 WLC インターフェイスに向けて転送されます。同期モビリティ トンネリング モードでは、着信と発信の両方のトラフィックがアンカー コントローラまでトンネリングされます。モビリティ トンネリングの詳細については、を参照してください。

非対称マルチキャスト トンネリング

非対称マルチキャスト トンネリングでは、別の WLC にアソシエートされた別のサブネット上の新しい AP にクライアントが移動すると、外部 WLC によってマルチキャスト グループ メンバーシップが照会され、IGMP グループ メンバーシップ レポートが送信されます。IGMP グループ メンバーシップ レポートは VLAN に関連付けられた外部 WLC 動的インターフェイスに転送され、クライアントは外部サブネットを介してマルチキャスト ストリームに再接続します。図 6-2 では、通常のデータとマルチキャスト データのトラフィック フローを示します。

図 6-2 非対称トンネリング

 


) クライアントが移動する場合、マルチキャスト セッションにわずかな中断が生じるため、アプリケーションによっては使用に適していない場合があります。


マルチキャスト対応ネットワーク

新しいマルチキャスト パフォーマンス機能を使用するための前提条件として、マルチキャスト対応ネットワークが、コントローラと AP の間のすべてのルータに設定されます。マルチキャスト対応ネットワークでは、パケットをネットワーク上の多数のホストに効率的な方法で配信できます。IP マルチキャストは、単一の情報ストリームを企業の何千もの受信者に同時に送信することによってトラフィックを削減する技術であり、帯域幅を大量に消費します。パケットは、ネットワーク内の各レイヤ 3 ポイントで必要に応じて複製されます。コントローラと AP の間に複数のルータがある場合は、PIM などのマルチキャスト ルーティング プロトコルが必要です。マルチキャスト対応ネットワークの設定の詳細は、次の URL を参照してください。 http://www.cisco.com/go/multicast

CAPWAP マルチキャスト予約ポートおよびアドレス

コントローラでは、宛先ポートが 5246、5247、5248 のマルチキャスト グループに送信されるマルチキャスト パケットはすべてブロックされます。また、マルチキャスト グループ アドレスが、コントローラの CAPWAP マルチキャスト グループ アドレスと同じパケットは、すべてコントローラでブロックされます。これによって、断片化された CAPWAP カプセル化パケットが、別のコントローラから再送信されることを防止できます(詳細については 断片化と CAPWAP マルチキャスト パケット を参照)。ネットワーク上のマルチキャスト アプリケーションで、これらの予約ポートまたは CAPWAP マルチキャスト グループ アドレスを使用しないようにしてください。

コントローラでのマルチキャスト転送の有効化

コントローラ経由の IP マルチキャスト トラフィックはデフォルトで無効になっています。マルチキャスト トラフィックが無効な場合、WLAN クライアントはマルチキャスト トラフィックを受信できません。WLAN クライアントに対してマルチキャスト トラフィックを有効にするには、次の手順に従ってください。


ステップ 1 マルチキャストが有効なネットワークがある場合、Ethernet Multicast Mode で [multicast] を選択して、ネットワークでパケットを複製する方法を使用します。

ステップ 2 マルチキャストが有効なネットワークがない場合、Ethernet Multicast Mode で [unicast] を選択して、コントローラでパケットを複製する方法を使用します。

ステップ 3 コントローラの全般 Web ページで、CAPWAP トランスポート モードに [Layer 3] が設定されていることを確認します。マルチキャスト パフォーマンス機能は、このモードでのみ動作します。

ステップ 4 Ethernet Multicast Mode のドロップダウン メニューから [multicast] を選択して、マルチキャスト グループ アドレスを入力します。図 6-3 にオプションを示します。

図 6-3 GUI を使用して Ethernet Multicast Mode を有効にするコマンド

 


 

Ethernet Multicast Mode を有効にする CLI コマンド


ステップ 1 CLI コマンド configure network multicast global enable を有効にします。

ステップ 2 CLI コマンド config network multicast mode multicast <IP アドレス> を有効にします。

show network コマンドを使用してコントローラでマルチキャスト モードになっていることを確認し、show capwap mcast を使用して AP のグループを確認します。ルータで show ip mroute および show ip igmp membership を使用しても便利です。


 

マルチキャストの配置に関する考慮事項

CAPWAP マルチキャスト アドレスを選択する際の推奨事項


注意 お勧めはしませんが、OSPF、EIGRP、PIM、HSRP、およびその他のマルチキャスト プロトコルで使用される予約済みリンク ローカル マルチキャスト アドレスを含め、任意のマルチキャスト アドレスを CAPWAP マルチキャスト グループに割り当てることができます。

シスコでは、管理用スコープのブロック 239/8 からマルチキャスト アドレスを割り当てることを推奨します。IANA では、プライベート マルチキャスト ドメインで使用するために、管理用スコープのアドレスとして 239.0.0.0 ~ 239.255.255.255 の範囲を予約しています(その他の制限については下記を参照)。これらのアドレスは、RFC 1918 で定義されている予約済みのプライベート IP ユニキャストの範囲(10.0.0.0/8 など)と事実上よく似ています。ネットワーク管理者は、インターネット上での競合を気にすることなく、管理しているドメイン内でこの範囲のマルチキャスト アドレスを自由に使用できます。この管理用またはプライベートのアドレス空間は、企業内で使用する必要があり、自律システム(AS)を出入りしないようブロックする必要があります。


) アドレス範囲 239.0.0.X および 239.128.0.X は使用しないでください。これらの範囲のアドレスは、リンク ローカル MAC アドレスとオーバーラップし、IGMP スヌーピングがオンの場合でも、すべてのスイッチ ポートに向けてフラッディングします。


シスコでは、企業ネットワーク管理者がこのアドレス範囲を企業ネットワーク内のさらに細かい地理上の管理用スコープに分けて、特定のマルチキャスト アプリケーションの「スコープ」を限定することを推奨します。これによって、高レートのマルチキャスト トラフィックがキャンパス(帯域幅が十分)から出て WAN リンクを混雑させることを防止できます。高帯域幅のマルチキャストを効率的にフィルタリングすることによって、高帯域幅のマルチキャストがコントローラおよび無線ネットワークに到達することも防止できます。

マルチキャスト アドレスのガイドラインの詳細については、次の URL にあるドキュメントを参照してください。

http://www.cisco.com/en/US/tech/tk828/technologies_white_paper09186a00802d4643.shtml

断片化と CAPWAP マルチキャスト パケット

コントローラで受信されたマルチキャスト パケットは、宛先アドレスとして CAPWAP マルチキャスト グループを使用して CAPWAP 内にカプセル化され、管理インターフェイス(送信元アドレス)経由で AP に転送されます。パケットがリンクの MTU を超える場合は、コントローラによってパケットが断片化され、両方のパケットが CAPWAP マルチキャスト グループに送信されます。別のコントローラが、この CAPWAP カプセル化マルチキャスト パケットを有線ネットワーク経由で受信すると、パケットが再カプセル化され、通常のマルチキャスト パケットのように処理されて、このコントローラの AP に転送されます。

これを防止するオプションには次の 2 つがあり、いずれのオプションもそれ自体で効果があります。1 つ目は、すべてのコントローラを同じ CAPWAP マルチキャスト グループ アドレスに割り当てるオプションです。2 つ目は、標準のマルチキャスト フィルタリング技術を適用して、CAPWAP カプセル化マルチキャスト パケットが他のコントローラに送信されないようにするオプションです。 すべてのコントローラの CAPWAP マルチキャスト グループが同じになる で、これら 2 つの技術の長所と短所を示します。

図 6-4 同一のマルチキャスト グループを使用する場合と異なるグループを使用する場合の長所と短所

 

操作
PRO
CON

すべてのコントローラの CAPWAP マルチキャスト グループが同じになる

追加の断片化保護処理を行う必要がない

各コントローラのマルチキャスト トラフィックがネットワーク全体でフラッディングする(AP で、AP のコントローラ管理インターフェイスと同じ送信元 IP アドレスを持たないマルチキャスト パケットがドロップされる)

標準のマルチキャスト技術を使用して CAPWAP マルチキャスト フラグメントをブロックする

アドレス範囲を使用できるため、ネットワーク全体のフラッディングを防止できる

マルチキャスト対応コントローラに設定されているすべての VLAN 上のファースト ホップ ルータに ACL フィルタリングを適用する必要がある

すべてのコントローラの CAPWAP マルチキャスト グループが同じになる

2 つ目のコントローラからこれらの CAPWAP カプセル化パケットが再送信されないように、コントローラが CAPWAP マルチキャスト グループおよび CAPWAP 予約ポート宛ての着信マルチキャスト パケットをブロックします。予約ポートをブロックすることによって、コントローラはカプセル化された CAPWAP マルチキャスト パケットの断片化パケットの最初の部分をブロックします。ただし、2 つ目のパケットにはポート番号が含まれていないため、2 つ目のパケットは、マルチキャスト グループ アドレス(宛先アドレス)でフィルタするだけでブロックできます。コントローラは、コントローラに割り当てられている CAPWAP マルチキャスト グループ アドレスと宛先アドレスが同じになっているパケットをすべてブロックします。

ただし、各コントローラを同じ CAPWAP マルチキャスト グループに割り当てると、別の問題が発生します。CAPWAP マルチキャスト グループへ接続するために AP が使用する IGMP バージョン 1 および 2 は、Any Source Multicast(ASM)であるため、AP はネットワーク内のマルチキャスト グループのすべての送信元から送信されたマルチキャスト トラフィックを受信します。これは、ネットワーク上のすべてのコントローラが同一のマルチキャスト グループ アドレスで設定されている場合も、AP はすべてのコントローラからのマルチキャスト パケットを受信し、マルチキャスト境界は適用されないことを意味します。1 つのコントローラのマルチキャスト トラフィックが、ネットワーク全体のすべての AP にフラッディングし、各 AP はネットワーク全体の無線マルチキャスト クライアントから送信されているマルチキャスト トラフィックを受信します(送信元アドレスが AP のコントローラの管理アドレスとは異なる場合はドロップします)。また、ローカルで送信された HSRP、PIM、および EIGRP などのクライアント VLAN からのマルチキャスト パケットおよび OSPF マルチキャスト パケットも、ネットワーク全体でフラッディングします。


) Cisco IOS AP(1240 など)では IGMPv2 を使用し、VxWorks AP(1030 など)では IGMPv1 を使用します。


標準のマルチキャスト技術を使用した WLAN 上のマルチキャストの制御

通常の境界技術を、マルチキャスト対応ネットワークで使用する必要があります。これらの技術には、IP マルチキャスト トラフィックおよび Auto-RP メッセージをフィルタリングする ip multicast boundary インターフェイスモードコマンドの使用が含まれます。


) ネットワーク内の任意の場所にある有線クライアントは、CAPWAP マルチキャスト ストリームを要求して、すべての送信元からそのストリームを受信できます(マルチキャスト境界が適用されていない場合)。マルチキャスト ストリームが CAPWAP マルチキャスト パケットにカプセル化されている場合、マルチキャスト ストリームは暗号化されていません。したがって、このようなアクセスを防ぐためにマルチキャスト境界を実装することを推奨します。


これまでは、IP マルチキャスト データグラムの Time To Live フィールドで、ttl-threshold コマンドを使用して、Auto-RP の管理用境界を作成していました。この作業は、IP マルチキャスト トラフィックおよび Auto-RP メッセージをフィルタリングする ip multicast boundary インターフェイス モード コマンドの使用に取って代わられています。シスコは新しいコマンドを使用することを推奨します。

その他の便利なコマンドとして、ip multicast rate-limit interface コマンドがあります。このコマンドは、無線 VLAN に低レートを強制します。このコマンドを使用しないと、ネットワーク エンジニアが高レート マルチキャスト アドレスをフィルタリングしても、低レート マルチキャスト アドレスがそのレートを超過できなくなります。

無線クライアント VLAN の一般的な例は次のとおりです。マルチキャスト対応ネットワークに使用するその他のマルチキャスト コマンドの詳細は、 http://www.cisco.com/go/multicast を参照してください。マルチキャスト対応トラフィックでフィルタリングを実行することによって、マルチキャスト アドレスを使用した TCP および ICMP 転送に依存する特定ワーム(Sasser ワームなど)の伝搬を防ぐことができます。マルチキャスト グループ アドレスを使用してこれらのタイプのトラフィックをブロックしても、これらのアドレスでは通常、ストリーミングに UDP または TCP が使用されるため、ほとんどのアプリケーションに影響はありません。

次の例では、任意の送信元からのマルチキャスト グループ範囲 239.0.0.0 ~ 239.127.255.255 宛てのパケットのパケット レートが、128 Kbps に制限されます。この例では、下位の管理用スコープ アドレスには含まれないすべてのマルチキャスト アドレスにも境界が設定されます。また、Vlan40 を使用するホストは、239.0.0.0 ~ 239.127.255.255 の下位管理用グループだけに接続できるようになります。

mls qos
!
class-map match-all multicast_traffic
description Permit Low Rate Multicast Range of 239.0.0.0 to 239.127.0.0
match access-group 101
!
policy-map multicast
description Rate Limit Multicast traffic to 2.56mps with burst of 12800 bytes
class multicast_traffic
police cir 2560000 bc 12800 be 12800 conform-action transmit exceed-action drop
!
interface Vlan40
description To Wireless Clients
ip address 10.20.40.3 255.255.255.0
ip pim sparse-mode
ip multicast boundary 1
ip igmp access-group 30
standby 40 ip 10.20.40.1
standby 40 preempt
service-policy output multicast
!
access-list 1 remark Permit Low Rate Multicast Range of 239.0.0.0 to 239.127.0.0 for multicast boundary
access-list 1 permit 239.0.0.0 0.127.255.255
!
access-list 30 remark Only Allow IGMP joins to this Multicast Group Range
access-list 30 permit 239.0.0.0 0.127.255.255
!
access-list 101 remark Permit Low Rate Multicast Range of 239.0.0.0 to 239.127.0.0 for class-map
access-list 101 permit ip any 239.0.0.0 0.127.255.255

コントローラの配置がマルチキャスト トラフィックとローミングに与える影響


) 分散型と中央集中型のどちらの展開においても、マルチキャスト ストリームのレートは制限されず、ACL は保存できません。マルチキャスト トラフィックが有効になると、トラフィックは HSRP、EIGRP、OSPF、および PIM パケットを含む無線に転送されます。


ここでは、分散型と中央集中型の 2 つの異なる展開と、それぞれの展開がマルチキャスト クライアントのローミングに与える影響について示します。中央集中型の展開では、WLC WLAN インターフェイスは同じ VLAN/サブネットに接続され、マルチキャスト クライアントがある WLC の AP から他の WLC の AP に移動する際、マルチキャスト ストリームは中断されません。中央集中型の展開では、フラットな WLC クライアント マルチキャスト ネットワークが作成されます。中央集中型の WLC がマルチキャスト ローミングに影響を与えないのは、マルチキャスト ストリームが WLAN 上の 1 つのマルチキャスト クライアントから要求されると、マルチキャスト トラフィックを要求したクライアントが 1 つもアクセス ポイントの WLAN に関連付けられていなくても、この WLAN、すべての無線(802.11g および 802.11a)およびすべての WLC に接続されているすべての AP に対してマルチキャスト ストリームが出力されるためです。VLAN に関連付けられている WLAN が複数ある場合は、AP からマルチキャスト パケットが WLAN ごとに送信されます。ユニキャスト モードとマルチキャスト モードの CAPWAP パケットには両方とも、パケットの転送で経由する必要のある WLAN を受信側 AP に伝える WLAN ビットマップが含まれます。

分散型の展開では、WLAN が同じでも、WLC が別の VLAN に接続されるため、このような問題はありません。このことは、マルチキャスト クライアントが新しい WLC に移動するときに、WLC がクライアントのマルチキャスト グループ メンバーシップを最初に照会することを意味します。この時点で、クライアントはグループ メンバーシップ レポートを返信します。このメッセージは WLC によって、ローカル VLAN に関連付けられた VLAN 経由で適切なマルチキャスト グループ アドレスに転送されます。これにより、クライアントは外部 WLC を介してマルチキャスト セッションを再開できます。

分散型展開では、WLAN SSID が同じであっても WLC は異なる VLAN に接続されているため、AP 上のマルチキャスト トラフィックの量が軽減されます。WLAN マルチキャスト トラフィックは、WLC の VLAN のクライアント要求によって異なります。 表 6-1 で、分散型展開と中央集中型展開の長所と短所を示します。

表 6-1 中央集中型 WLC 展開および分散型 WLC 展開の長所と短所

導入
長所
短所

中央集中型のすべての WLC WLAN が同じ VLAN(サブネット)に接続されている

いずれのクライアント VLAN で開始したマルチキャスト トラフィックでもすべての AP に送信されるため、いずれの AP にローミングしてもクライアントはマルチキャスト ストリームを受信する

1 つのクライアントのみがマルチキャスト トラフィックを要求した場合、すべてのコントローラに接続されているすべての AP がストリームを受信し、AP に関連付けられているクライアントがある場合は、それらのクライアントがマルチキャスト ストリームを要求しなかった場合でも、その AP がストリームを送信する

異なる VLAN およびサブネットに接続されている分散型 WLC

マルチキャスト ストリームは、コントローラに接続されている AP に分離される

クライアントの移動後にマルチキャスト ストリームを確立したことによる中断

その他の考慮事項

マルチキャスト展開におけるその他の考慮すべき 2 つの分野は、AP グループの実装時、および FlexConnect と AP の実装時です。AP グループでは、同じコントローラ上の AP は、同じ WLAN(SSID)を別の VLAN にマップできます。異なるグループの AP 間でのクライアントが移動すると、マルチキャスト セッションが正しく機能しません。それは、この動作が現在サポートされていないためです。現在、WLC は WLAN で設定された VLAN に対してのみマルチキャストを転送し、AP グループで設定された VLAN については考慮しません。

FlexConnect AP を使用すると、WLAN のローカル終端が WLC ではなくネットワーク エッジで可能になり、マルチキャスト動作がそのエッジで制御されます。FlexConnect WLAN が WLC で終端し、マルチキャストがその WLC で有効になっている場合に、FlexConnect ネットワークの場所まで CAPWAP マルチキャストグループを拡張することが許可されているときは、マルチキャストは、その FlexConnect WLAN に配信されます。

CAPWAP マルチキャスト パケットがネットワークを FlexConnect AP に送信できない場合でも、これらのパケットはユニキャスト メッセージであるため、その FlexConnect AP 上の WLAN クライアントは、WLC に接続されているネットワークに IGMP 接続要求を送信できます。