Cisco Aironet 1300 シリーズ ワイヤレス ブリッジ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.2(15)JA
スパニング ツリー プロトコルの設定
スパニング ツリー プロトコルの設定
発行日;2012/01/14 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

スパニング ツリー プロトコルの設定

スパニング ツリー プロトコルの概要

STP の概要

350 シリーズ ブリッジの相互運用性

ブリッジ プロトコル データ ユニット

スパニング ツリー ルートの選択

スパニング ツリー タイマ

スパニング ツリー トポロジの作成

スパニング ツリーのインターフェイスの状態

ブロッキング状態

リスニング状態

ラーニング状態

転送状態

無効状態

STP 機能の設定

デフォルトの STP の設定

STP の設定

STP の設定例

VLAN が設定されていないルート ブリッジ

VLAN が設定されていない非ルート ブリッジ

VLAN が設定されているルート ブリッジ

VLAN が設定されている非ルート ブリッジ

スパニング ツリーの状態の表示

スパニング ツリー プロトコルの設定

この章では、ブリッジに Spanning Tree Protocol(STP; スパニング ツリー プロトコル)を設定する方法を説明します。この章の内容は、次のとおりです。

「スパニング ツリー プロトコルの概要」

「STP 機能の設定」

「スパニング ツリーの状態の表示」


) この章で使用されるコマンドの構文と使用方法の詳細は、このリリース用の『Cisco IOS Command Reference for Access Points and Bridges』を参照してください。


スパニング ツリー プロトコルの概要

この項では、スパニング ツリーの機能について説明します。内容は次のとおりです。

「STP の概要」

「ブリッジ プロトコル データ ユニット」

「スパニング ツリー ルートの選択」

「スパニング ツリー タイマ」

「スパニング ツリー トポロジの作成」

「スパニング ツリーのインターフェイスの状態」

STP の概要

STP はネットワークでのループを防ぎながらパスに冗長性を持たせるレイヤ 2 リンク管理プロトコルです。レイヤ 2 イーサネット ネットワークが適切に動作するように、2 つのステーション間にアクティブなパスを 1 つだけ設定できます。スパニング ツリーの処理はエンド ステーションに対して透過的に行われるため、エンド ステーションが単一セグメントの LAN に接続されているのか、複数セグメントの LAN に接続されているのかを検出することはできません。

フォールト トレラントのインターネットワークを作成する場合、ネットワーク内のすべてのノード間にループフリー パスを設定する必要があります。スパニング ツリー アルゴリズムでは、レイヤ 2 ネットワーク全体で最適なループフリー パスが計算されます。無線ブリッジやスイッチなどのインフラストラクチャ デバイスは、Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)というスパニング ツリー フレームを定期的に送受信します。インフラストラクチャ デバイスはこれらのフレームを転送せず、ループフリー パスを作成するために使用します。

エンド ステーション間にアクティブなパスが複数あると、ネットワーク内にループが生じます。ネットワークにループが存在する場合、エンド ステーションはメッセージを重複して受信することがあります。また、インフラストラクチャ デバイスは複数の レイヤ 2 インターフェイス上でエンドステーションの MAC アドレスを認識することもあります。このような状態はネットワークを不安定にします。

STP では、ルート ブリッジが指定されたツリー、およびルートからレイヤ 2 ネットワーク内のすべてのインフラストラクチャ デバイスへのループフリー パスが定義されます。


) STP では、次の 2 つの概念を説明するために、ルートという用語を使用します。ネットワークで、スパニング ツリーの中心点の役割を果たすブリッジはルート ブリッジと呼ばれます。各ブリッジで、ルート ブリッジに対して最も効率的なパスを提供するポートはルート ポートと呼ばれます。これらの意味するところは、ルートおよび非ルートのオプションを含む Role in radio network 設定とは異なります。Role in radio network 設定で Root Bridge になっているブリッジが、必ずしもスパニング ツリーのルート ブリッジになるとは限りません。この章では、スパニング ツリー内のルート ブリッジをスパニング ツリー ルートと呼びます。


STP は冗長データ パスをスタンドバイ(ブロックされた)状態にします。スパニング ツリーのネットワーク セグメントに障害が発生し、冗長パスが存在する場合、スパニング ツリー アルゴリズムでは、スパニング ツリー トポロジが再計算され、スタンドバイ パスがアクティブになります。

ブリッジ上の 2 つのインターフェイスがループの一部である場合、スパニング ツリー ポートの優先順位とパス コストの設定によって、転送状態にするインターフェイスとブロッキング状態にするインターフェイスが決定されます。ポート優先順位の値は、ネットワーク トポロジ内のインターフェイスの場所、およびこの場所がトラフィックの転送にどれほど適しているかを表します。パス コストの値は、メディアの速度を表します。

ブリッジは Per-VLAN Spanning-Tree(PVST)、および VLAN を使用しない単一の 802.1q スパニング ツリーの両方をサポートしています。ブリッジでは、複数の VLAN を単一インスタンスのスパニング ツリーにマッピングする 802.1s MST または 802.1d Common Spanning Tree を実行できません。

ブリッジは、ブリッジに設定されているアクティブな VLAN それぞれに対して別個のスパニング ツリー インスタンスを保持します。ブリッジの優先順位とブリッジの MAC アドレスで構成されるブリッジ ID は、各インスタンスにアソシエートされます。各 VLAN において、ブリッジ ID が最小値のブリッジがその VLAN のスパニング ツリー ルートとなります。

350 シリーズ ブリッジの相互運用性

Cisco Aironet 1300 と 350 シリーズのブリッジでは、STP が有効でかつ VLAN が設定されていない場合は相互運用が可能です。次の理由から、この設定が唯一の選択肢となります。

STP が無効な場合、350 シリーズのブリッジは 350 シリーズのアクセス ポイントとして動作し、非ルートの 350 および 1300 シリーズ ブリッジなどの非ルート ブリッジのアソシエーションを禁止します。

1300 シリーズのブリッジは非 VLAN 設定では単一の STP インスタンス、VLAN 設定では複数の STP インスタンスを持ちますが、350 シリーズのブリッジは非 VLAN と VLAN の両方の設定で 1 つの STP インスタンスしかサポートしません。

STP の単一インスタンスと複数インスタンス間の不一致によって、VLAN の設定時に一貫性のないトラフィックのブロックが生じる可能性があります。ネイティブ VLAN がブロックされると、ブリッジ フラッピングが生じることがあります。

したがって、STP の相互運用性を目的とした最適な設定とは、350 および 1300 シリーズのブリッジの STP 機能を有効にして、VLAN を設定しないというものです。


) 350 と 1300 シリーズのブリッジをワークグループ ブリッジとして設定した場合、これらのブリッジは STP を無効にすることで動作可能で、アクセス ポイントとのアソシエーションが可能となります。ただし、この設定は技術的にはブリッジ間のシナリオではありません。


ブリッジ プロトコル データ ユニット

ネットワークにおけるスパニング ツリー トポロジの安定性と有効性は、次の要素によって決定されます。

各無線ブリッジ上の各 VLAN にアソシエートされている一意のブリッジ ID(無線ブリッジの優先順位と MAC アドレス)

スパニング ツリー ルートへのスパニング ツリー パス コスト

各レイヤ 2 インターフェイスにアソシエートされているポート ID(ポートの優先順位と MAC アドレス)

ネットワークのブリッジに電源が投入されると、各ブリッジは STP ルートとして機能します。ブリッジはイーサネット ポートと無線ポートを介してコンフィギュレーション BPDU を送信します。BPDU はスパニング ツリー トポロジと通信してこれを計算します。各コンフィギュレーション BPDU が含む情報は次のとおりです。

送信元ブリッジがスパニング ツリー ルートとして識別する無線ブリッジの一意のブリッジ ID

ルートへのスパニング ツリー パス コスト

送信元ブリッジのブリッジ ID

メッセージの経過時間

送信元インターフェイスの ID

Hello、Forward-delay、および Maximum-age プロトコル タイマの値

上位の 情報(より小さい値のブリッジ ID やより低いパス コストなど)を含むコンフィギュレーション BPDU を受信すると、ブリッジはそのポートの情報を保存します。この BPDU をブリッジのルート ポートで受信すると、ブリッジは更新されたメッセージと共に、ブリッジが指定ブリッジとなっているすべての接続済み LAN にこの BPDU を転送します。

特定のポートに現在保存されている情報より 下位の 情報を含むコンフィギュレーション BPDU を受信すると、ブリッジはこの BPDU を破棄します。下位の BPDU の受信元の LAN にとっての指定ブリッジである場合、ブリッジはポートに保存されている最新情報を含む BPDU をその LAN に送信します。このようにして下位情報は破棄され、上位情報はネットワークに伝搬されます。

BPDU の交換によって、次のような処理が行われます。

1 つのブリッジがスパニング ツリー ルートとして選択されます。

ブリッジごとにルート ポートが選択されます(スパニング ツリー ルートを除く)。このポートは、ブリッジがパケットをスパニング ツリー ルートに転送する際に最低コストの最適パスを提供します。

スパニング ツリー ルートへの最短距離は、パス コストに基づいてブリッジ別に計算されます。

各 LAN セグメントの指定ブリッジが選択されます。指定ブリッジを使用すると、LAN からスパニング ツリー ルートへパケットを転送する際に、パス コストが最低になります。指定ブリッジを LAN に接続するために使用するポートは、指定ポートと呼ばれます。

スパニング ツリー インスタンスに含めるインターフェイスが選択されます。ルート ポートと指定ポートは転送状態に移行します。

スパニング ツリーに含まれないインターフェイスはすべてブロックされます。

スパニング ツリー ルートの選択

STP に参加しているレイヤ 2 ネットワークのすべてのブリッジは、BPDU データ メッセージを交換することでネットワークにおけるその他のブリッジに関する情報を収集します。このメッセージの交換によって、次のような処理が行われます。

各スパニング ツリー インスタンスの、一意のスパニング ツリー ルートの選択

各 LAN セグメントの指定ブリッジの選択

冗長リンクに接続されているレイヤ 2 インターフェイスをブロックすることによる、ネットワーク内のループの削除

各 VLAN については、最も高い優先順位(最小値の優先順位)を持つブリッジがスパニング ツリー ルートとして選択されます。すべてのブリッジがデフォルトの優先順位(32768)で設定されている場合、VLAN 内で最小値の MAC アドレスを持つブリッジがスパニング ツリー ルートとなります。ブリッジの優先順位の値は、ブリッジ ID で最も重要な部分です。

ブリッジの優先順位の値を変更すると、ブリッジがルート ブリッジとして選択される可能性が変わります。設定する値が高いほど可能性が低くなり、値が低いほど可能性が高くなります。

スパニング ツリー ルートはスパニング ツリー トポロジの論理上の中心です。スパニング ツリー ルートに到達する必要のないネットワーク内のパスはすべて、スパニング ツリー ブロッキング モードに入ります。

BPDU には、ブリッジ、MAC アドレス、ブリッジの優先順位、ポートの優先順位、パス コストなど、送信元ブリッジとそのポートに関する情報が含まれます。STP はこの情報を使用して、ネットワークのスパニング ツリー ルートとルート ポートを選択し、各 LAN セグメントのルート ポートと指定ポートを選択します。

スパニング ツリー タイマ

表 8-1 は、スパニング ツリーのパフォーマンス全体に影響するタイマを示しています。

 

表 8-1 スパニング ツリー タイマ

変数
説明

Hello timer

ブリッジがその他のブリッジにハロー メッセージをブロードキャストする頻度を決定します。

Forward-delay timer

インターフェイスが転送を開始する前に、リスニング ステートおよびラーニング ステートをそれぞれ継続する長さを決定します。

Maximum-age timer

ブリッジがインターフェイスで受信したプロトコル情報を保存する時間を決定します。

スパニング ツリー トポロジの作成

図 8-1 では、すべてのブリッジの優先順位がデフォルト(32768)に設定されており、Bridge 4 の MAC アドレスが最小値のため、Bridge 4 がスパニング ツリー ルートとして選択されます。ただし、トラフィック パターン、転送インターフェイスの数、またはリンク タイプにより、Bridge 4 が理想的なスパニング ツリー ルートとはならない場合があります。理想的なブリッジがスパニング ツリー ルートになるように、そのブリッジの優先順位を上げる(つまり数値を下げる)ことによって、スパニング ツリーの再計算を強制し、理想的なブリッジがスパニング ツリー ルートとして指定された新しいトポロジを作成します。

図 8-1 スパニング ツリー トポロジ

 

スパニング ツリーのインターフェイスの状態

プロトコル情報が無線 LAN を経由して転送される場合、伝搬遅延が生じることがあります。結果として、さまざまな時間に、ネットワーク内のさまざまな場所でトポロジの変更が行なわれる可能性があります。スパニング ツリー トポロジに参加していない状態から転送状態に直接移行する場合、インターフェイスは一時的なデータ ループを作成することがあります。インターフェイスはフレームの転送を開始する前に、新しいトポロジ情報の LAN 経由の伝搬を待機する必要があります。インターフェイスは古いトポロジを使用してきた転送フレームに対してフレームの有効期限の満了を許可する必要があります。

スパニング ツリーを使用するブリッジの各インターフェイスは、次のいずれかの状態になります。

ブロッキング:インターフェイスはフレーム転送に参加しません。

リスニング:スパニング ツリーがインターフェイスをフレーム転送に参加させることを決定する、ブロッキング状態後の最初の遷移状態です。

ラーニング:インターフェイスはフレーム転送の参加に備えます。

転送:インターフェイスはフレームを転送します。

無効:ポートがシャットダウンされている、ポートにリンクがない、またはポートでスパニング ツリー インスタンスが実行されていないために、インターフェイスはスパニング ツリーに参加していません。

インターフェイスは次の状態を遷移します。

初期化からブロッキングへ

ブロッキングからリスニング、または無効へ

リスニングからラーニング、または無効へ

ラーニングから転送、または無効へ

転送から無効へ

図 8-2 はインターフェイスの状態遷移を示しています。

図 8-2 スパニング ツリー インターフェイスの状態

 

ブリッジ上の STP を有効にすると、イーサネットと無線のインターフェイスはブロッキング状態から、遷移上のリスニングおよびラーニング状態になります。スパニング ツリーは、各インターフェイスを転送状態またはブロッキング状態に安定させます。

スパニング ツリー アルゴリズムがレイヤ 2 インターフェイスを転送状態にすると、次の処理が行われます。

1. インターフェイスをブロッキング状態に遷移するためにスパニング ツリーがプロトコル情報を待機する間、インターフェイスはリスニング状態になります。

2. 転送遅延タイマの期限切れを待つ間、スパニング ツリーはインターフェイスをラーニング状態に移し、転送遅延タイマをリセットします。

3. ラーニング状態では、転送データベースのエンド ステーションの場所情報をブリッジが認識するため、インターフェイスはフレーム転送をブロックし続けます。

4. 転送遅延タイマの期限が切れると、スパニング ツリーはインターフェイスを転送状態に移します。転送状態では、ラーニングとフレーム転送の両方が有効です。

ブロッキング状態

ブロッキング状態のインターフェイスは、フレーム転送に参加しません。初期化後、BPDU はブリッジのイーサネット ポートと無線ポートに送信されます。最初にブリッジは他のブリッジと BPDU を交換するまでの間、スパニング ツリー ルートとして機能します。この交換によって、ネットワーク内でスパニング ツリー ルートとなるブリッジが確立されます。ネットワークにブリッジが 1 つしかない場合は、交換が行われず、転送遅延タイマの期限が切れ、インターフェイスはリスニング状態に移行します。STP を有効にすると、インターフェイスは常にブロッキング状態に入ります。

ブロッキング状態のインターフェイスの動作は、次のとおりです。

ポート上で受信したフレームを破棄します。

アドレスを認識しません。

BPDU を受信します。


) ブリッジ ポートがブロックされた場合、一部のブロードキャストまたはマルチキャスト パケットがブリッジ上の転送ポートに到達し、ブロックされているポートにそれらのパケットが届く前に、ブロックされているポートをリスニング状態に一瞬切り替えるブリッジング ロジックが発生することがあります。


リスニング状態

リスニング状態はインターフェイスがブロッキング状態の後で最初に遷移する状態です。インターフェイスをフレーム転送に参加させる必要があると STP が判断すると、インターフェイスはリスニング状態に入ります。

リスニング状態のインターフェイスの動作は、次のとおりです。

ポート上で受信したフレームを破棄します。

アドレスを認識しません。

BPDU を受信します。

ラーニング状態

ラーニング状態のインターフェイスはフレーム転送の参加に備えます。インターフェイスはリスニング状態からラーニング状態に遷移します。

ラーニング状態のインターフェイスの動作は、次のとおりです。

ポート上で受信したフレームを破棄します。

アドレスを認識します。

BPDU を受信します。

転送状態

転送状態のインターフェイスはフレームを転送します。インターフェイスはラーニング状態から転送状態に遷移します。

転送状態のインターフェイスの動作は、次のとおりです。

ポート上でフレームを受信して、受信したフレームを転送します。

アドレスを認識します。

BPDU を受信します。

無効状態

無効状態のインターフェイスは、フレーム転送またはスパニング ツリーに参加しません。無効状態のインターフェイスは実稼動しません。

無効インターフェイスの動作は、次のとおりです。

ポート上で受信したフレームを破棄します。

アドレスを認識しません。

BPDU を受信しません。

STP 機能の設定

ブリッジに STP を設定するには、次の 3 つの主要な手順を実行します。

1. 必要に応じて、インターフェイスとサブインターフェイスをブリッジ グループに割り当てます。

2. 各ブリッジ グループに対して STP を有効にします。

3. 各ブリッジ グループに STP 優先順位を設定します。

スパニング ツリーの設定情報については、次の項を参照してください。

「デフォルトの STP の設定」

「STP の設定」

「STP の設定例」

デフォルトの STP の設定

STP はデフォルトで無効になっています。 表 8-2 は、STP を有効にした場合のデフォルトの STP の設定を示しています。

 

表 8-2 STP を有効にした場合の STP のデフォルト値

設定
デフォルト値

Bridge priority

32768

Bridge max age

20

Bridge hello time

2

Bridge forward delay

15

Ethernet port path cost

19

Ethernet port priority

128

Radio port path cost

33

Radio port priority

128

デフォルトでは、ブリッジ上の無線インターフェイスとイーサネット インターフェイス、およびネイティブ VLAN がブリッジ グループ 1 に割り当てられます。STP を有効にし、ブリッジ グループ 1 に優先順位を割り当てると、STP は無線インターフェイスとイーサネット インターフェイスおよびプライマリ VLAN 上で有効になり、それらのインターフェイスはブリッジ グループ 1 に割り当てられた優先順位を採用します。サブインターフェイス用にブリッジ グループを作成し、それらのブリッジ グループに別の STP 設定を割り当てることができます。

STP の設定

イネーブル EXEC モードから、次の手順に従ってブリッジに STP を設定します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル設定モードを開始します。

ステップ 2

interface { dot11radio number | fastethernet number }

無線またはイーサネットのインターフェイスまたはサブインターフェイスのインターフェイス設定モードを開始します。

ステップ 3

bridge-group number

インターフェイスをブリッジ グループに割り当てます。ブリッジ グループには 1 ~ 255 の範囲で番号を付けることができます。

ステップ 4

no bridge-group number spanning-disabled

ブリッジ グループに対して STP を自動的に無効にするコマンドを無効にします。bridge n protocol ieee コマンドを入力すると、インターフェイスで STP が有効になります。

ステップ 5

exit

グローバル設定モードに戻ります。

ステップ 6

bridge number protocol ieee

ブリッジ グループに対して STP を有効にします。bridge-group コマンドを使用して作成する各ブリッジ グループでは、STP を有効にする必要があります。

ステップ 7

bridge number priority priority

(オプション)ブリッジ グループに優先順位を割り当てます。優先順位が低くなると、ブリッジがスパニング ツリー ルートになる可能性が高くなります。

ステップ 8

end

イネーブル EXEC モードに戻ります。

ステップ 9

show spanning-tree bridge

入力内容を確認します。

ステップ 10

copy running-config startup-config

(オプション)コンフィギュレーション ファイルに入力内容を保存します。

STP の設定例

これらの設定例では、VLAN が設定されている、および設定されていないルート ブリッジと非ルート ブリッジにおいて STP を有効にする方法を示しています。

「VLAN が設定されていないルート ブリッジ」

「VLAN が設定されていない非ルート ブリッジ」

「VLAN が設定されているルート ブリッジ」

「VLAN が設定されている非ルート ブリッジ」

VLAN が設定されていないルート ブリッジ

次の例は、VLAN が設定されておらず、STP が有効になっているルート ブリッジの設定を示しています。

 
hostname master-bridge-south
ip subnet-zero
!
bridge irb
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid tsunami
authentication open
guest-mode
!
speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
rts threshold 2312
station-role root
no cdp enable
infrastructure-client
bridge-group 1
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1
!
interface BVI1
ip address 1.4.64.23 255.255.0.0
no ip route-cache
!
ip default-gateway 1.4.0.1
bridge 1 protocol ieee
bridge 1 route ip
bridge 1 priority 9000
!
line con 0
exec-timeout 0 0
line vty 0 4
login
line vty 5 15
login
!
end
 

VLAN が設定されていない非ルート ブリッジ

次の例は、VLAN が設定されておらず、STP が有効になっている非ルート ブリッジの設定を示しています。

 
hostname client-bridge-north
ip subnet-zero
!
bridge irb
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid tsunami
authentication open
guest-mode
!
speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
rts threshold 2312
station-role non-root
no cdp enable
bridge-group 1
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1 path-cost 40
!
interface BVI1
ip address 1.4.64.24 255.255.0.0
no ip route-cache
!
bridge 1 protocol ieee
bridge 1 route ip
bridge 1 priority 10000
!
line con 0
line vty 0 4
login
line vty 5 15
login
!
end
 

VLAN が設定されているルート ブリッジ

次の例は、VLAN が設定されており、STP が有効になっているルート ブリッジの設定を示しています。

 
hostname master-bridge-hq
!
ip subnet-zero
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
bridge irb
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid vlan1
vlan 1
infrastructure-ssid
authentication open
!
speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
rts threshold 2312
station-role root
no cdp enable
infrastructure-client
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no ip route-cache
no cdp enable
bridge-group 1
!
interface Dot11Radio0.2
encapsulation dot1Q 2
no ip route-cache
no cdp enable
bridge-group 2
!
interface Dot11Radio0.3
encapsulation dot1Q 3
no ip route-cache
bridge-group 3
bridge-group 3 path-cost 500
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
!
interface FastEthernet0.2
encapsulation dot1Q 2
no ip route-cache
bridge-group 2
!
interface FastEthernet0.3
encapsulation dot1Q 3
no ip route-cache
bridge-group 3
!
interface BVI1
ip address 1.4.64.23 255.255.0.0
no ip route-cache
!
ip default-gateway 1.4.0.1
bridge 1 protocol ieee
bridge 1 route ip
bridge 1 priority 9000
bridge 2 protocol ieee
bridge 2 priority 10000
bridge 3 protocol ieee
bridge 3 priority 3100
!
line con 0
exec-timeout 0 0
line vty 5 15
!
end

VLAN が設定されている非ルート ブリッジ

次の例は、VLAN が設定されており、STP が有効になっている非ルート ブリッジの設定を示しています。

 
hostname client-bridge-remote
!
ip subnet-zero
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
bridge irb
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid vlan1
vlan 1
authentication open
infrastructure-ssid
!
speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
rts threshold 2312
station-role non-root
no cdp enable
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no ip route-cache
no cdp enable
bridge-group 1
!
interface Dot11Radio0.2
encapsulation dot1Q 2
no ip route-cache
no cdp enable
bridge-group 2
!
interface Dot11Radio0.3
encapsulation dot1Q 3
no ip route-cache
no cdp enable
bridge-group 3
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
!
interface FastEthernet0.2
encapsulation dot1Q 2
no ip route-cache
bridge-group 2
!
interface FastEthernet0.3
encapsulation dot1Q 3
no ip route-cache
bridge-group 3
bridge-group 3 path-cost 400
!
interface BVI1
ip address 1.4.64.24 255.255.0.0
no ip route-cache
!
bridge 1 protocol ieee
bridge 1 route ip
bridge 1 priority 10000
bridge 2 protocol ieee
bridge 2 priority 12000
bridge 3 protocol ieee
bridge 3 priority 2900
!
line con 0
line vty 5 15
!
end

スパニング ツリーの状態の表示

スパニング ツリーの状態を表示するには、 表 8-3 のイネーブル EXEC コマンドを 1 つ以上使用します。

 

表 8-3 スパニング ツリーの状態を表示するためのコマンド

コマンド
目的

show spanning-tree

ネットワークのスパニング ツリーに関する情報を表示します。

show spanning-tree blocked-ports

このブリッジ上のブロックされたポートのリストを表示します。

show spanning-tree bridge

このブリッジの状態と設定を表示します。

show spanning-tree active

アクティブなインターフェイスのスパニング ツリー情報のみを表示します。

show spanning-tree root

スパニング ツリー ルートに関する詳細な情報を表示します。

show spanning-tree interface interface-id

指定されたインターフェイスのスパニング ツリー情報を表示します。

show spanning-tree summary [ totals ]

ポートの状態の概要を表示するか、STP 状態セクションの合計行数を表示します。

show spanning-tree イネーブル EXEC コマンドのその他のキーワードの詳細は、このリリースの『Cisco Aironet IOS Command Reference for Cisco Aironet Access Points and Bridges』を参照してください。