IP ルーティング:OSPF コンフィギュレーション ガイド Cisco IOS Release 15.1S
CE ルータでの OSPF マルチ VRF サポート
CE ルータでの OSPF マルチ VRF サポート
発行日;2012/01/31 | 英語版ドキュメント(2011/04/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

CE ルータでの OSPF マルチ VRF サポート

機能情報の確認

この章の構成

CE ルータでの OSPF マルチ VRF サポートについて

OSPF マルチ VRF サポートの利点

CE ルータでの OSPF マルチ VRF サポートの設定方法

OSPF ルーティングのためのマルチ VRF 機能の設定

前提条件

OSPF マルチ VRF 設定の確認

CE ルータでの OSPF マルチ VRF サポートの設定例

例:マルチ VRF 機能の設定

例:OSPF マルチ VRF 設定の確認

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

CE ルータでの OSPF マルチ VRF サポートの機能情報

用語集

CE ルータでの OSPF マルチ VRF サポート

CE ルータでの OSPF マルチ VRF サポート機能は、OSPF と BGP プロトコルの間でパケットを相互に再配布する場合にループの防止に必要な、プロバイダー エッジ(PE)のチェックを抑制する機能を提供します。PE ではないルータ(BGP を実行していないルータ)で、VPN ルーティングおよび転送(VRF)を使用する場合、チェックをオフにすると、VRF ルーティング テーブルに、IP プレフィクスへのルート情報を正常に書き込むことができます。

OSPF マルチ VRF では、ルータを複数の仮想ルータに分割し、各仮想ルータで固有のインターフェイス セット、ルーティング テーブル、およびフォワーディング テーブルを設定できます。

機能情報の確認

お使いのソフトウェア リリースが、この章で説明されている機能の一部をサポートしていないことがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「CE ルータでの OSPF マルチ VRF サポートの機能情報」を参照してください。

プラットフォーム サポートと Cisco ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

CE ルータでの OSPF マルチ VRF サポートについて

「OSPF マルチ VRF サポートの利点」

OSPF マルチ VRF サポートの利点

CE ルータでの OSPF マルチ VRF サポート機能は、OSPF と BGP プロトコルの間でパケットを相互に再配布する場合にループの防止に必要な、プロバイダー エッジ(PE)のチェックを抑制する機能を提供します。PE ではないルータ(BGP を実行していないルータ)で、VPN ルーティングおよび転送(VRF)を使用する場合、チェックをオフにすると、VRF ルーティング テーブルに、IP プレフィクスへのルート情報を正常に書き込むことができます。

OSPF マルチ VRF では、ルータを複数の仮想ルータに分割し、各仮想ルータで固有のインターフェイス セット、ルーティング テーブル、およびフォワーディング テーブルを設定できます。また、OSPF マルチ VRF によって、ネットワークをセグメントに分割し、各セグメントで、正しいルーティング情報を維持しながら特定の機能を実行するように設定できます。

CE ルータでの OSPF マルチ VRF サポートの設定方法

ここでは、次の各手順について説明します。

「OSPF ルーティングのためのマルチ VRF 機能の設定」

「OSPF マルチ VRF 設定の確認」

OSPF ルーティングのためのマルチ VRF 機能の設定

ここでは、OSPF ルーティングを行うようにマルチ VRF 機能を設定する方法について説明します。このタスクは、VRF がすでに設定されていることを前提にしています。VRF の設定例については、「例:マルチ VRF 機能の設定」を参照してください。

前提条件

CEF がネットワークで実行されている必要があります。

手順の概要

1. enable

2. show ip ospf [ process-id ]

3. configure terminal

4. router ospf process-id [ vrf vpn-name ]

5. capability vrf-lite

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードなど、高位の権限レベルをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

show ip ospf [ process-id ]

 

Router> show ip ospf 1

ルータのステータスを表示します。この表示に、PE ルータが VPN バックボーンに接続していることが示された場合は、 capability vrf-lite コマンドを使用して、PE ルータを VPN バックボーンから切り離します。

ステップ 3

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 4

router ospf process-id [ vrf vpn-name ]

 

Router(config)# router ospf 1 vrf grc

OSPF ルーティングをイネーブルにして、ルータ コンフィギュレーション モードを開始します。

process-id 引数は OSPF プロセスを示します。

vrf キーワードと vpn-name 引数を使用して VPN を指定します。

ステップ 5

capability vrf-lite

 

Router(config)# capability vrf-lite

OSPF プロセスにマルチ VRF 機能を適用します。

OSPF マルチ VRF 設定の確認

この機能に関連付けられた、特定の debug または show コマンドはありません。OSPF マルチ VRF 設定が正常に行われたことを確認するには、 show ip ospf [ process-id ] コマンドを使用して、ルータが VPN バックボーンに接続していないことを確認します。

show ip ospf process コマンドの出力から、現在 PE ルータがバックボーンに接続しているかどうかがわかります。

Router# show ip ospf 12
 
Routing Process "ospf 12" with ID 151.1.1.1 and Domain ID 0.0.0.12
Supports only single TOS(TOS0) routes
Supports opaque LSA
Connected to MPLS VPN Superbackbone
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
Number of external LSA 0. Checksum Sum 0x0
Number of opaque AS LSA 0. Checksum Sum 0x0
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 0. 0 normal 0 stub 0 nssa
External flood list length 0
 

router ospf コマンドに続いて、 capability vrf-lite コマンドで OSPF VRF プロセスを設定すると、「Connected to MPLS VPN Superbackbone」が表示されなくなります。

CE ルータでの OSPF マルチ VRF サポートの設定例

ここでは、次の設定例について説明します。

「例:マルチ VRF 機能の設定」

「例:OSPF マルチ VRF 設定の確認」

例:マルチ VRF 機能の設定

この例では、OSPF 基本ネットワークに grc という名前の VRF を設定します。 capability vrf-lite コマンドを実行して、PE チェックを抑制します。

!
ip cef
ip vrf grc
rd 1:1
 
interface Serial2/0
ip vrf forwarding grc
ip address 192.168.1.1 255.255.255.252
!
interface Serial3/0
ip vrf forwarding grc
ip address 192.168.2.1 255.255.255.252
...
 
!
router ospf 9000 vrf grc
log-adjacency-changes
capability vrf-lite
redistribute rip metric 1 subnets
network 192.168.1.0 0.0.0.255 area 0
!
router rip
address-family ipv4 vrf grc
redistribute ospf 9000 vrf grc
network network 192.168.2.0
no auto-summary
end
 
Router# show ip route vrf grc
 
Routing Table: grc
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
O IA 192.168.192.0/24 [110/138] via 192.168.1.13, 00:06:08, Serial2/0
[110/138] via 192.168.1.9, 00:06:08, Serial3/0
O IA 192.168.242.0/24 [110/74] via 192.168.1.13, 00:06:08, Serial2/0
O IA 192.168.193.0/24 [110/148] via 192.168.1.13, 00:06:08, Serial2/0
[110/148] via 192.168.1.9, 00:06:08, Serial3/0
O IA 192.168.128.0/24 [110/74] via 192.168.1.9, 00:06:08, Serial3/0
O IA 192.168.129.0/24 [110/84] via 192.168.1.9, 00:06:08, Serial3/0
O IA 192.168.130.0/24 [110/84] via 192.168.1.9, 00:06:08, Serial3/0
172.16.0.0/24 is subnetted, 2 subnets
O E2 172.16.9.0 [110/5] via 192.168.1.13, 00:06:08, Serial2/0
O E2 172.16.10.0 [110/5] via 192.168.1.13, 00:06:08, Serial2/0
O IA 192.168.131.0/24 [110/94] via 192.168.1.9, 00:06:20, Serial3/0
192.168.1.0/30 is subnetted, 4 subnets
C 192.168.1.8 is directly connected, Serial3/0
C 192.168.1.12 is directly connected, Serial2/0
O 192.168.1.0 [110/128] via 192.168.1.9, 00:06:20, Serial3/0
O 192.168.1.4 [110/128] via 192.168.1.13, 00:06:20, Serial2/0
 

例:OSPF マルチ VRF 設定の確認

ここでは、例を使用して、ルータに OSPF マルチ VRF を設定した後の show ip ospf process コマンドの出力表示について説明します。

Router# show ip ospf database external 172.16.0.0 self
 
OSPF Router with ID (10.0.0.1) (Process ID 100)
 
Type-5 AS External Link States
 
LS age: 175
Options: (No TOS-capability, DC)
LS Type: AS External Link
Link State ID: 172.16.0.0 (External Network Number )
Advertising Router: 10.0.0.1
LS Seq Number: 80000001
Checksum: 0xEA9E
Length: 36
Network Mask: /8
Metric Type: 2 (Larger than any link state path)
MTID: 0
Metric: 20
Forward Address: 0.0.0.0
External Route Tag: 0

その他の参考資料

関連資料

関連項目
参照先

OSPF の設定

Configuring OSPF

マルチプロトコル ラベル スイッチング(MPLS)

MPLS Multi-VRF (VRF Lite) Support

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco ソフトウェア リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能によってサポートされる新しい RFC または変更された RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

CE ルータでの OSPF マルチ VRF サポートの機能情報

表 1 に、この機能のリリース履歴を示します。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連のソフトウェア リリースのうち、特定の機能が初めて導入されたソフトウェア リリースだけが記載されています。その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。


 

表 1 CE ルータでの OSPF マルチ VRF サポートの機能情報

機能名
リリース
機能情報

CE ルータでの OSPF マルチ VRF サポート

12.0(21)ST
12.0(22)S
12.2(8)B
12.2(13)T
12.2(14)S
Cisco IOS XE 3.1.0 SG

CE ルータでの OSPF マルチ VRF サポート機能は、OSPF と BGP プロトコルの間でパケットを相互に再配布する場合にループの防止に必要な、Provider Edge(PE; プロバイダー エッジ)のチェックを抑制する機能を提供します。PE ではないルータ(BGP を実行していないルータ)で、VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)を使用する場合、チェックをオフにすると、VRF ルーティング テーブルに、IP プレフィクスへのルート情報を正常に書き込むことができます。

次に示すコマンドは、この章に記載されている機能において、新たに導入または変更されたものです。

capability vrf-lite

用語集

CE ルータ :カスタマー エッジ ルータ。C ネットワーク内のエッジ ルータで、P ルータに直接接続される C ルータとして定義されます。

C ネットワーク :カスタマー(企業またはサービス プロバイダー)のネットワーク。

C ルータ :カスタマー ルータ。C ネットワーク内のルータです。

LSA :Link-state Advertisement(LSA; リンクステート アドバタイズメント) リンクステート プロトコルで使用されるブロードキャスト パケット。ネイバーおよびパス コストの情報が含まれています。受信側ルータは、LSA を使用してルーティング テーブルのメンテナンスを行います。

PE ルータ :プロバイダー エッジ ルータ。P ネットワーク内のエッジ ルータで、C ルータに直接接続される P ルータとして定義されます。

P ネットワーク :MPLS 対応のサービス プロバイダーのコア ネットワーク。P ルータが MPLS を実行します。

P ルータ :プロバイダー ルータ。P ネットワーク内のルータです。

  1. SPF :Shortest Path First。最短パス スパニング ツリーを決定するためにパス長計算を繰り返すルーティング アルゴリズムです。
  2. VPN :Virtual Private Network(VPN; バーチャル プライベート ネットワーク)。ネットワーク間のトラフィックをすべて暗号化することにより、パブリック TCP/IP ネットワーク経由でも IP トラフィックをセキュアに転送できます。

VRF :VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)。