IP ルーティング:OSPF コンフィギュレーション ガイド Cisco IOS Release 15.1S
OSPF Shortest Path First スロットリング
OSPF Shortest Path First スロットリング
発行日;2012/01/31 | 英語版ドキュメント(2011/04/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

OSPF Shortest Path First スロットリング

この章の構成

OSPF SPF スロットリングについて

Shortest Path First の計算

OSPF SPF スロットリングの設定方法

OSPF SPF スロットリングの設定

SPF スロットル値の確認

OSPF SPF スロットリングの設定例

スロットル タイマーの例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

OSPF Shortest Path First スロットリング

OSPF Shortest Path First スロットリング機能により、SPF スケジューリングをミリ秒間隔で設定して、ネットワークが不安定な時に Shortest Path First(SPF)計算を遅らせることができます。トポロジ変化が発生した場合、Shortest Path Tree(SPT)を再計算するように SPF はスケジューリングされます。通常、トポロジ変化イベントが複数発生した後に、SPF が 1 回実行されます。

SPF 計算の実行間隔は、ネットワークのトポロジ変化の頻度に応じて動的に選択されます。ユーザ指定値の範囲内で、間隔は選択されます。SPF スロットリング機能は、ネットワーク トポロジが不安定な時に、トポロジが安定するまで、SPF スケジューリング間隔を長く算出します。

OSPF Shortest Path First スロットリングの機能仕様

機能の履歴
リリース
変更点

12.2(14)S

この機能が導入されました。

12.0(23)S

この機能は、Cisco IOS Release 12.0(23)S に統合されました。

12.2(15)T

この機能は、Cisco IOS Release 12.2(15)T に統合されました。

プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報の検索

プラットフォームのサポートおよび Cisco IOS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。Cisco.com 上のアカウントが必要です。アカウントを持っていないか、ユーザ名またはパスワードが不明の場合は、ログイン ダイアログボックスの [Cancel] をクリックし、表示される指示に従ってください。

OSPF SPF スロットリングについて

SPF スロットリングを使用するには、次の概念について理解しておく必要があります。

「Shortest Path First の計算」

Shortest Path First の計算

SPF の計算は、 timers throttle spf コマンドで設定した間隔で実行されます。待機期間とは、次の SPF 計算が実行される待機する時間のことです。計算を行うたびに、待機期間はその前の待機期間の 2 倍の長さになり、指定された最大待機期間に達するまでそれが行われます。

SPF タイミングについて、例を使用して説明します。この例では、開始時待機期間が 5 ミリ秒(ms)、待機期間が 1000 ミリ秒、最大待機期間が 90,000 ミリ秒に設定されています。

timers throttle spf 5 1000 90000
 

図 1 に、ある待機期間中に少なくとも 1 回のトポロジ変化イベントを受信する場合の、SPF 計算の実行間隔を示します。

図 1 timers throttle spf コマンドで設定される SPF の計算間隔

 

前の待機期間中に少なくとも 1 回のトポロジ変化イベントを受信すると、SPF 計算の待機期間が 2 倍になることに注意してください。最大待機期間に達すると、トポロジが安定し、待機期間中にイベントを受信しなくなるまで、待機期間が変化しなくなります。

現在の待機期間の経過後に、最初のトポロジ変化イベントを受信した場合は、開始時待機期間として指定されている時間だけ SPF 計算が遅延されます。その後の待機期間は、動的パターンに従います。

最大待機期間の開始後に、最初のトポロジ変化イベントが発生した場合、SPF 計算は開始時待機期間で再びスケジューリングされ、その後の待機期間は timers throttle spf コマンドで指定されたパラメータに従ってリセットされます。図 2 では、最大待機期間の開始後にトポロジ変化イベントを受信して、SPF 間隔がリセットされることに注意してください。

図 2 トポロジ変化イベント後のタイマー間隔のリセット

 

OSPF SPF スロットリングの設定方法

OSPF SPF スロットリングを設定するには、次のタスクを実行します。

「OSPF SPF スロットリングの設定」(必須)

「SPF スロットル値の確認」(任意)

OSPF SPF スロットリングの設定

手順の概要

1. enable

2. configure terminal

3. interface type slot / port

4. ip address ip-address mask [ secondary ]

5. exit

6. router ospf process-id

7. network network-number [ mask | prefix-length ]

8. timers throttle spf spf-start spf-hold spf-max-wait

9. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードなど、高位の権限レベルをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type slot / port

 

Router(config)# interface ethernet 1/1/1

指定したインターフェイスのインターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 192.168.0.2 255.255.255.0

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ステップ 5

exit

 

router# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 6

router ospf process-id

 

Router(config)# router ospf 1

OSPF ルーティング プロセスを設定します。

ステップ 7

network network-number [ mask | prefix-length ]

 

Router(config-router)# network 192.168.0.0 0.0.255.255 area 0

Cisco IOS DHCP サーバの DHCP アドレス プールに、サブネットの番号およびマスクを設定します。

ステップ 8

timers throttle spf spf-start spf-hold spf-max-wait

 

Router(config-router)# timers throttle spf 10 4800 90000

OSPF スロットリング タイマーを設定します。

ステップ 9

end

 

Router(config-router)# end

コンフィギュレーション モードを終了します。

SPF スロットル値の確認

SPF スロットル タイマー値を確認するには、 show ip ospf コマンドを使用します。これらの値は、「Initial SPF schedule delay...」、「Minimum hold time between two consecutive SPFs...」、および「Maximum wait time between two consecutive SPFs...」で始まる各行に表示されます。

Router# show ip ospf
 
Routing Process "ospf 1" with ID 10.10.10.2 and Domain ID 0.0.0.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
It is an autonomous system boundary router
Redistributing External Routes from,
static, includes subnets in redistribution
Initial SPF schedule delay 5 msecs
Minimum hold time between two consecutive SPFs 1000 msecs
Maximum wait time between two consecutive SPFs 90000 msecs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 4. Checksum Sum 0x17445
Number of opaque AS LSA 0. Checksum Sum 0x0
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 2
Area has no authentication
SPF algorithm last executed 19:11:15.140 ago
SPF algorithm executed 28 times
Area ranges are
Number of LSA 4. Checksum Sum 0x2C1D4
Number of opaque link LSA 0. Checksum Sum 0x0
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
 

表 1 に、 show ip ospf の表示フィールドと、各フィールドの説明を示します。

 

表 1 show ip ospf フィールドの説明

フィールド
説明

Routing process "ospf 201" with ID 192.42.110.200

プロセス ID および OSPF ルータ ID。

Supports ...

サポートされているサービスのタイプの数(タイプ 0 限定)。

It is ...

指定できるタイプは、内部、エリア境界、または自律システム境界です。

Summary Link update interval

アップデート間隔(時:分:秒)および次回アップデートまでの時間の要約が表示されます。

External Link update interval

外部のアップデート間隔(時:分:秒)および次回アップデートまでの時間の要約が表示されます。

Redistributing External Routes from

再配布されたルートのプロトコル別リスト。

SPF calculations

開始時待機期間、待機期間、および最大待機期間がミリ秒単位で表示されます。

Number of areas

ルータのエリアの数、エリア アドレスなど。

SPF algorithm last executed

トポロジ変化イベント レコードに応答して最後に SPF 計算を実行した時刻が表示されます。

Link State Update Interval

ルータおよびネットワークのリンクステート アップデート間隔(時:分:秒)と次回アップデートまでの時間が表示されます。

Link State Age Interval

最大エージに達したアップデートを削除する間隔、および次回のデータベース クリーンアップまでの時間(時:分:秒)が表示されます。

OSPF SPF スロットリングの設定例

ここでは、次の例について説明します。

「スロットル タイマーの例」

スロットル タイマーの例

この例では、ルータに、 timers throttle spf コマンドの開始時待機期間、待機期間、および最大待機期間として、それぞれ 5、1,000、および 90,000 ミリ秒を設定しています。

router ospf 1
router-id 10.10.10.2
log-adjacency-changes
timers throttle spf 5 1000 90000
redistribute static subnets
network 21.21.21.0 0.0.0.255 area 0
network 22.22.22.0 0.0.0.255 area 00

その他の参考資料

OSPF に関する詳細情報については、次の参考資料を参照してください。

「関連資料」

「規格」

「MIB」

「RFC」

「シスコのテクニカル サポート」

関連資料

関連項目
参照先

OSPF コマンド

Cisco IOS IP Routing: OSPF Command Reference

OSPF の設定タスク

Cisco IOS IP Routing Protocols Configuration Guide 』の「Configuring OSPF」の章

規格

規格
タイトル

この機能によってサポートされる新しい RFC または変更された RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

コマンド リファレンス

次に示すコマンドは、この章に記載されている機能において、新たに導入または変更されたものです。これらのコマンドの詳細については、『Cisco IOS IP Routing: OSPF Command Reference』を参照してください。Cisco IOS の全コマンドの詳細については、 http://tools.cisco.com/Support/CLILookup にあるコマンド検索ツールを使用するか、または『 Cisco IOS Master Command List 』を参照してください。

timers throttle spf

timer spf-interval