IP ルーティング:OSPF コンフィギュレーション ガイド Cisco IOS Release 15.1S
MPLS VPN のための OSPF 模造リンクの サポート
MPLS VPN のための OSPF 模造リンクのサポート
発行日;2012/01/31 | 英語版ドキュメント(2011/04/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

MPLS VPN のための OSPF 模造リンクのサポート

機能概要

PE-CE 間ルータ接続での OSPF の使用

模造リンクを使用した OSPF バックドア ルーティングの修正方法

模造リンクの設定例

利点

制約事項

関連機能およびテクノロジー

関連資料

サポートされているプラットフォーム

サポートされている規格、MIB、および RFC

前提条件

設定作業

模造リンクの作成

作成した模造リンクの確認

模造リンクのモニタリングと維持

設定例

コマンド リファレンス

用語集

MPLS VPN のための OSPF 模造リンクのサポート

機能の履歴

リリース
変更点

12.2(8)T

この機能が導入されました。

このマニュアルでは、Open Shortest Path First(OSPF)プロトコルを実行し、OSPF バックドア リンクを共有している各バーチャル プライベート ネットワーク(VPN)クライアント サイトを、マルチプロトコル ラベル スイッチング(MPLS)VPN コンフィギュレーション内で接続するための、模造リンクの設定方法と使用方法について説明します。

このマニュアルは次の項で構成されています。

「機能概要」

「サポートされているプラットフォーム」

「サポートされている規格、MIB、および RFC」

「前提条件」

「設定作業」

「設定例」

「コマンド リファレンス」

「用語集」

機能概要

PE-CE 間ルータ接続での OSPF の使用

MPLS VPN コンフィギュレーションにおいて、VPN バックボーン内でカスタマー エッジ(CE)ルータをサービス プロバイダー エッジ(PE)ルータに接続する方法の 1 つが OSPF プロトコルです。カスタマーにおける OSPF の一般的な用途は、OSPF をサイト内ルーティング プロトコルとして実行し、VPN サービスを利用し、MPLS VPN バックボーンで OSPF を使用して(移行時または常時)サイト間でルーティング情報を交換することです。

図 1 に、OSPF を実行する各 VPN クライアント サイトを、MPLS VPN バックボーンで接続する例を示します。

図 1 VPN クライアント サイトと MPLS VPN バックボーンとの間の OSPF 接続

OSPF を使用して PE ルータと CE ルータを接続するには、VPN サイトから学習したすべてのルーティング情報を、着信インターフェイスに関連付けられた VPN Routing and Forwarding(VRF)インスタンスに格納します。VPN に接続された PE ルータ間では、ボーダー ゲートウェイ プロトコル(BGP)を使用して、VPN ルートが交換されます。CE ルータはこの VPN 内の他のサイトへのルートを、自分が接続された PE ルータとのピアリングによって学習します。MPLS VPN スーパーバックボーンは、OSPF を実行する各 VPN サイトを内部接続するための追加のルーティング階層レベルを提供します。

OSPF ルートが MPLS VPN バックボーン全体に伝播されると、プレフィクスに関する追加情報が、BGP 拡張コミュニティ形式(ルート タイプ、ドメイン ID 拡張コミュニティ)で BGP アップデートに付加されます。このコミュニティ情報を使用して、受信した PE ルータは、BGP ルートを OSPF PE-CE プロセスに再配布するときに生成するリンクステート アドバタイズメント(LSA)のタイプを決定します。このようにして、同じ VPN に属し、VPN バックボーン全体にアドバタイズされる内部 OSPF ルートが、リモート サイト上でエリア内ルートとして認識されます。

MPLS VPN の基本的な設定方法については、次の URL を参照してください。

http://www.cisco.com/en/US/docs/ios/12_0t/12_0t5/feature/guide/VPN.html

模造リンクを使用した OSPF バックドア ルーティングの修正方法

OSPF PE-CE 接続は、MPLS VPN バックボーンを経由するパスが、2 つのクライアント サイトの間にある唯一のパスであることを前提にしていますが、VPN サイト間にバックドア パス(図 2 の灰色の線)も存在することがあります。これらのサイトが同じ OSPF エリアに属する場合、OSPF はエリア間パスよりもエリア内パスを優先するため、バックドア リンクのパスが常に選択されることになります(PE ルータは、VPN バックボーンで学習した OSPF ルートを、エリア間パスとしてアドバタイズします)。このため、ポリシーに基づいてルーティングを実行するには、VPN サイト間の OSPF バックドア リンクを考慮する必要があります。

図 2 OSPF クライアント サイト間のバックドア パス

 

たとえば、図 2 には 3 つのクライアント サイトがあり、それぞれにバックドア リンクがあります。各サイトは同じエリア 1 コンフィギュレーション内で OSPF を実行しているため、これら 3 つのサイト間のルーティングでは、常にバックドア リンクを経由するエリア内パスが使用され、MPLS VPN バックボーンは経由されません。

次の例は、図 2 の PE-1 ルータの BGP ルーティング テーブルにある、プレフィクス 10.3.1.7/32 のエントリを表示しています。このプレフィクスは Winchester CE ルータのループバック インターフェイスのものです。例中に太字で示すように、このループバック インターフェイスの情報は、BGP によって PE-2 と PE-3 から学習されています。また、PE-1 上の BGP への再配布によって生成されています。

PE-1# show ip bgp vpnv4 all 10.3.1.7
BGP routing table entry for 100:251:10.3.1.7/32, version 58
Paths: (3 available, best #2)
Advertised to non peer-group peers:
10.3.1.2 10.3.1.5
Local
10.3.1.5 (metric 30) from 10.3.1.5 (10.3.1.5)
Origin incomplete, metric 22, localpref 100, valid, internal
Extended Community: RT:1:793 OSPF DOMAIN ID:0.0.0.100 OSPF
RT:1:2:0 OSPF 2
Local
10.2.1.38 from 0.0.0.0 (10.3.1.6)
Origin incomplete, metric 86, localpref 100, weight 32768,
valid, sourced, best
Extended Community: RT:1:793 OSPF DOMAIN ID:0.0.0.100 OSPF
RT:1:2:0 OSPF 2
Local
10.3.1.2 (metric 30) from 10.3.1.2 (10.3.1.2)
Origin incomplete, metric 11, localpref 100, valid, internal
Extended Community: RT:1:793 OSPF DOMAIN ID:0.0.0.100 OSPF
RT:1:2:0 OSPF 2
 

このローカルで生成されたルート(10.2.1.38)が、BGP では最適ルートとして認識されています。一方、次の例に太字で示すように、VRF ルーティング テーブルでは OSPF によって学習され、ネクストホップが 10.2.1.38(Vienna CE ルータ)となるパスが選択されています。

PE-1# show ip route vrf ospf 10.3.1.7
Routing entry for 10.3.1.7/32
Known via "ospf 100", distance 110, metric 86, type intra area
Redistributing via bgp 215
Advertised by bgp 215
Last update from 10.2.1.38 on Serial0/0/0, 00:00:17 ago
Routing Descriptor Blocks:
* 10.2.1.38, from 10.3.1.7, 00:00:17 ago, via Serial0/0/0
Route metric is 86, traffic share count is 1
 

このパスが選択された理由は次のとおりです。

OSPF エリア内パスは、PE-1 ルータで生成されたエリア間パス(MPLS VPN バックボーン経由)よりも優先される。

OSPF ルートは、内部 BGP(同じ自律システム内のルータ間で実行される BGP)よりも管理ディスタンス(AD)が小さい。

サイト間のバックドア リンクを、バックアップ目的だけで使用し、VPN サービスに利用しない場合は、前の例に示すように、デフォルト ルート選択が不適切なものになります。MPLS VPN バックボーンに適切なパスを再確立するには、関連する PE ルータの入力 VRF と出力 VRF の間に、OSPF エリア内リンク(論理リンク)を追加作成する必要があります。このリンクは、模造リンクと呼ばれます。

模造リンクが必要なのは、同じ OSPF エリアに属し、OSPF バックドア リンクを共有する 2 つの VPN サイト間です。サイト間にバックドア リンクがない場合、模造リンクは不要です。

図 3 に、PE-1 と PE-2 との間の模造リンクの例を示します。模造リンクごとにコストが設定され、バックドア パスまたは模造リンク パスのどちらをトラフィックの送信に使用するか判断するために、それが使用されます。PE ルータ間に模造リンクを設定すると、PE は模造リンクから学習した OSPF ルートの情報を VRF ルーティング テーブルに書き込みます。

図 3 PE ルータ間の模造リンクを使用した OSPF クライアント サイトの接続

模造リンクは、PE ルータ間のエリア内リンクであるかのように認識されるため、このリンクを通じて(特定の OSPF プロセス用の)OSPF 隣接関係が確立され、データベース交換が行われます。これにより、PE ルータは、MPLS VPN バックボーンを介してサイト間で LSA をフラッディングすることができます。この結果、適切なエリア内接続が実現します。

「模造リンクの作成」 の項では、2 台の PE ルータ間に模造リンクを設定する方法について説明します。OSPF の設定方法の詳細については、次を参照してください。

Configuring OSPF

模造リンクの設定例

ここでは、例を使用して、PE ルータおよび CE ルータでの OSPF エリア内パス選択だけに影響するように模造リンクを使用する方法について説明します。PE ルータは MP-BGP から受信した情報も使用し、着信パケットの出ラベル スタックを設定して、どの出力 PE ルータ宛にパケットをラベル スイッチするか指定します。

図 4 に、模造リンク設定が必要となる MPLS VPN トポロジの例を示します。VPN クライアントには 3 つのサイトがあり、それぞれにバックドア リンクがあります。2 つの模造リンクが設定されており、1 つは PE-1 と PE-2 の間、もう 1 つは PE-2 と PE-3 の間です。この設定では、Vienna と Winchester のサイトはバックドア リンクを共有していないため、PE-1 と PE-3 の間の模造リンクは不要です。

図 4 模造リンクの例

次の例では、PE-1 が 10.3.1.7/32 プレフィクス(図 4 の Winchester CE ルータの loopback1 インターフェイス)をどのように認識するかという観点から、サイト間で行われるフォワーディングを示しています。

PE-1# show ip bgp vpnv4 all 10.3.1.7
BGP routing table entry for 100:251:10.3.1.7/32, version 124
Paths: (1 available, best #1)
Local
10.3.1.2 (metric 30) from 10.3.1.2 (10.3.1.2)
Origin incomplete, metric 11, localpref 100, valid, internal,
best
Extended Community: RT:1:793 OSPF DOMAIN ID:0.0.0.100 OSPF
RT:1:2:0 OSPF 2
 
PE-1# show ip route vrf ospf 10.3.1.7
Routing entry for 10.3.1.7/32
Known via "ospf 100", distance 110, metric 13, type intra area
Redistributing via bgp 215
Last update from 10.3.1.2 00:12:59 ago
Routing Descriptor Blocks:
10.3.1.2 (Default-IP-Routing-Table), from 10.3.1.7, 00:12:59 ago
 

次の例に示すフォワーディング情報では、ルートのネクストホップが、PE-2 ルータ(OSPF では最適パス)ではなく、10.3.1.2 の PE-3 ルータとなっています。この OSPF ルートが PE 上の BGP に再配布されなかった理由は、模造リンクの反対側のエンドポイントによって、すでに BGP に再配布されているため、重複して配布する必要がないからです。エリア内のパスの選択に影響を与えるためだけに、OSPF 模造リンクは使用されます。特定の宛先にトラフィックを送信する際、PE ルータは MP-BGP のフォワーディング情報を使用します。

PE-1# show ip bgp vpnv4 all tag | begin 10.3.1.7
10.3.1.7/32 10.3.1.2 notag/38
 
PE-1# show tag-switching forwarding 10.3.1.2
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
31 42 10.3.1.2/32 0 PO3/0/0 point2point
 
PE-1# show ip cef vrf ospf 10.3.1.7
10.3.1.7/32, version 73, epoch 0, cached adjacency to POS3/0/0
0 packets, 0 bytes
tag information set
local tag: VPN-route-head
fast tag rewrite with PO3/0/0, point2point, tags imposed: {42 38}
via 10.3.1.2, 0 dependencies, recursive
next hop 10.1.1.17, POS3/0/0 via 10.3.1.2/32
valid cached adjacency
tag rewrite with PO3/0/0, point2point, tags imposed: {42 38}
 

模造リンクを介してプレフィクスが学習され、模造リンクのパスが最適パスとして選択されると、PE ルータは、そのプレフィクスに関する MP-BGP アップデートを生成しません。ある模造リンクから、さらに別の模造リンクにはトラフィックをルーティングできません。

次の例では、プレフィクスに関する MP-BGP アップデートが生成されていないことを、PE-2 で示しています。太字で示すように、10.3.1.7/32 は、OSPF によって模造リンクを介して学習されていますが、BGP へのローカルでのルート生成は実行されていません。BGP テーブルの唯一のエントリは、PE-3(10.3.1.7/32 プレフィクスへの出力 PE ルータ)から受信した MP-BGP アップデートです。

PE-2# show ip route vrf ospf 10.3.1.7
Routing entry for 10.3.1.7/32
Known via "ospf 100", distance 110, metric 12, type intra area
Redistributing via bgp 215
Last update from 10.3.1.2 00:00:10 ago
Routing Descriptor Blocks:
* 10.3.1.2 (Default-IP-Routing-Table), from 10.3.1.7, 00:00:10 ago
Route metric is 12, traffic share count is 1
 
PE-2# show ip bgp vpnv4 all 10.3.1.7
BGP routing table entry for 100:251:10.3.1.7/32, version 166
Paths: (1 available, best #1)
Not advertised to any peer
Local
10.3.1.2 (metric 30) from 10.3.1.2 (10.3.1.2)
Origin incomplete, metric 11, localpref 100, valid, internal,
best
Extended Community: RT:1:793 OSPF DOMAIN ID:0.0.0.100 OSPF
RT:1:2:0 OSPF 2
 

PE ルータは MP-BGP から受信した情報を使用して、着信パケットの出ラベル スタックを設定し、どの出力 PE ルータ宛にパケットをラベル スイッチするか決定します。

利点

MPLS VPN バックボーン経由のクライアント サイト接続

模造リンクによって、エリア間ルート(PE から PE へ)の代わりに、VPN サイト間のエリア内バックドア ルートが選択されるという、OSPF のデフォルト動作が行われなくなります。模造リンクによって、バックドア リンクを共有する OSPF クライアント サイトが、MPLS VPN バックボーンを介して通信を行い、VPN サービスを利用するようになります。

MPLS VPN 設定での柔軟なルーティング

MPLS VPN 設定で模造リンクに対して設定する OSPF コストを使用して、OSPF クライアント サイトのトラフィックを、バックドア リンク経由にするか、または VPN バックボーン経由にするかを指定できます。

制約事項

PE ルータと CE ルータ間のプロトコルとして OSPF を使用する場合、VPN バックボーン全体にルートがアドバタイズされる際に、OSPF メトリックは保持されます。このメトリックを使用して、リモート PE ルータは適切なルートを選択します。このため、OSPF から BGP への再配布、および、BGP から OSPF への再配布において、メトリック値を変更すべきではありません。メトリック値を変更すると、ルーティング ループが発生する可能性があります。

関連機能およびテクノロジー

MPLS

OSPF

BGP

関連資料

『Cisco IOS IP Routing: OSPF Command Reference』

http://www.cisco.com/en/US/docs/ios/iproute_ospf/command/reference/iro_book.html

『MPLS Virtual Private Networks』

http://www.cisco.com/en/US/docs/ios/12_0t/12_0t5/feature/guide/VPN.html

「Configuring OSPF」

http://www.cisco.com/en/US/docs/ios/iproute_ospf/configuration/guide/iro_cfg.html

『Cisco IOS IP Routing: BGP Configuration Guide, Release 15.0』

http://www.cisco.com/en/US/docs/ios/iproute_bgp/configuration/guide/15_0/irg_15_0_book.html

RFC 1163「A Border Gateway Protocol」

RFC 1164「Application of the Border Gateway Protocol in the Internet」

RFC 2283「Multiprotocol Extensions for BGP-4」

RFC 2328「Open Shortest Path First, Version 2」

RFC 2547「BGP/MPLS VPNs」

サポートされているプラットフォーム

Cisco 1400 シリーズ

Cisco 1600

Cisco 1600R

Cisco 1710

Cisco 1720

Cisco 1721

Cisco 1750

Cisco 1751

Cisco 2420

Cisco 2600

Cisco 2691

Cisco 3620

Cisco 3631

Cisco 3640

Cisco 3660

Cisco 3725

Cisco 3745

Cisco 7100

Cisco 7200

Cisco 7500

Cisco 7700

URM

Cisco uBR7200

Cisco Feature Navigator を使用したプラットフォーム サポートの特定

Cisco IOS ソフトウェアは、特定のプラットフォームがサポートされている機能セットにパッケージングされています。この機能のプラットフォーム サポートに関連した更新情報を取得するには、Cisco Feature Navigator にアクセスします。新しいプラットフォーム サポートが機能に追加されると、Cisco Feature Navigator によって、サポートされているプラットフォームのリストが自動的に更新されます。

Cisco Feature Navigator は Web ベースのツールであり、特定の機能セットがサポートされている Cisco IOS ソフトウェア イメージ、および、特定の Cisco IOS イメージ内でサポートされている機能を素早く特定できます。機能またはリリースごとに検索できます。リリース セクションでは、各リリースを横に並べて比較し、各ソフトウェア リリースに固有の機能と共通機能の両方を表示できます。

Cisco Feature Navigator は定期的に更新されています(Cisco IOS ソフトウェアの主要なリリース時およびテクノロジー リリース時)。最新情報については、次の URL から Cisco Feature Navigator ホームページにアクセスしてください。

http://www.cisco.com/go/fn

サポートされている規格、MIB、および RFC

規格

この機能によってサポートされる新しい規格や変更された規格はありません。

MIB

この機能によってサポートされる新しい MIB または変更された MIB はありません。

プラットフォームおよび Cisco IOS ソフトウェア リリースによりサポートされている MIB のリストを入手し、MIB モジュールをダウンロードするには、Cisco.com の次のシスコ MIB Web サイトの URL にアクセスしてください。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

RFC

この機能によってサポートされる新しい RFC や変更された RFC はありません。

前提条件

MPLS VPN で模造リンクを設定する前に、次のようにして OSPF をイネーブルにしておく必要があります。

OSPF ルーティング プロセスを作成する。

ルーティング プロセスに関連付ける IP アドレス範囲を指定する。

IP アドレス範囲に関連付けるエリア ID を割り当てる。

これらの OSPF 設定手順の詳細については、次を参照してください。

http://www.cisco.com/en/US/docs/ios/iproute_ospf/command/reference/iro_book.html

設定作業

模造リンク機能の設定タスクについては、次の項を参照してください。一覧内の各作業は、必須と任意に分けています。

「模造リンクの作成」 (必須)

「作成した模造リンクの確認」 (任意)

模造リンクの作成

MPLS VPN の PE ルータ間に模造リンクを作成する前に、次の設定が完了している必要があります。

VPN バックボーンを介して模造リンクのリモート エンドに OSPF パケットを送信できるように、リモート PE 上に別の /32 アドレスを設定する。この /32 アドレスは、次の条件を満たす必要があります。

VRF に属する。

OSPF によってアドバタイズされない。

BGP によってアドバタイズされる。

この /32 アドレスは、他の模造リンクにも使用できます。

模造リンクを既存の OSPF エリアに関連付ける。

模造リンクを作成するには、EXEC モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router1# configure terminal

最初の PE ルータで、グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router1(config)# interface loopback interface-number

PE-1 で模造リンクのエンドポイントとして使用するループバック インターフェイスを作成し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Router1(config-if)# ip vrf forwarding vrf-name

ループバック インターフェイスに VRF を関連付けます。IP アドレスを削除します。

ステップ 4

Router1(config-if)# ip address ip-address mask

PE-1 のループバック インターフェイスの IP アドレスを再設定します。

ステップ 5

Router1(config-if)# end

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

Router1(config)# end

EXEC モードに戻ります。

ステップ 7

Router2# configure terminal

2 台目の PE ルータで、グローバル コンフィギュレーション モードを開始します。

ステップ 8

Router2(config)# interface loopback interface-number

PE-2 で模造リンクのエンドポイントとして使用するループバック インターフェイスを作成し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 9

Router2(config-if)# ip vrf forwarding vrf-name

2 番目のループバック インターフェイスに VRF を関連付けます。IP アドレスを削除します。

ステップ 10

Router2(config-if)# ip address ip-address mask

PE-2 のループバック インターフェイスの IP アドレスを再設定します。

ステップ 11

Router2(config-if)# end

グローバル コンフィギュレーション モードに戻ります。

ステップ 12

Router1(config)# end

EXEC モードに戻ります。

ステップ 13

Router1(config)# router ospf process-id vrf vrf-name

指定した OSPF プロセスに、PE-1 で模造リンク インターフェイスに関連付けた VRF を設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 14

Router1(config-if)# area area-id sham-link source-address destination-address cost number

PE-1 インターフェイス上の模造リンクを、指定した OSPF エリア内に設定します。エンドポイントとして各ループバック インターフェイスを IP アドレスで指定します。 cost number によって、PE-1 の模造リンク インターフェイスで IP パケットを送信する際の OSPF コストを設定します。

ステップ 15

Router2(config)# router ospf process-id vrf vrf-name

指定した OSPF プロセスに、PE-2 で模造リンク インターフェイスに関連付けた VRF を設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 16

Router2(config-if)# area area-id sham-link source-address destination-address cost number

PE-2 インターフェイス上の模造リンクを、指定した OSPF エリア内に設定します。エンドポイントとして各ループバック インターフェイスを IP アドレスで指定します。 cost number によって、PE-2 模造リンク インターフェイスで IP パケットを送信する際の OSPF コストを設定します。

作成した模造リンクの確認

模造リンクが正常に作成されたことを確認するには、EXEC モードで show ip ospf sham-links コマンドを使用します。

Router1# show ip ospf sham-links
 
Sham Link OSPF_SL0 to address 10.2.1.2 is up
Area 1 source address 10.2.1.1
Run as demand circuit
DoNotAge LSA allowed. Cost of using 40 State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40,
Hello due in 00:00:04
Adjacency State FULL (Hello suppressed)
Index 2/2, retransmission queue length 4, number of
retransmission 0
First 0x63311F3C(205)/0x63311FE4(59) Next
0x63311F3C(205)/0x63311FE4(59)
Last retransmission scan length is 0, maximum is 0
Last retransmission scan time is 0 msec, maximum is 0 msec
Link State retransmission due in 360 msec

模造リンクのモニタリングと維持

模造リンクをモニタするには、EXEC モードで次の show コマンドを使用します。

 

コマンド
目的

Router# show ip ospf sham-links

ルータに設定されているすべての模造リンクの動作状態を表示します。

Router# show ip ospf data router ip-address

2 台の PE ルータ間のアンナンバード ポイントツーポイント接続としてアドバタイズされる模造リンクの情報を表示します。

設定例

次の例は、2 台の PE ルータ間で模造リンクを設定する方法を示しています。

Router1(config)# interface loopback 1
Router1(config-if)# ip vrf forwarding ospf
Router1(config-if)# ip address 10.2.1.1 255.255.255.255
!
Router2(config)# interface loopback 1
Router2(config-if)# ip vrf forwarding ospf
Router2(config-if)# ip address 10.2.1.2 255.255.255.255
!
Router1(config)# router ospf 100 vrf ospf
Router1(config-if)# area 1 sham-link 10.2.1.1 10.2.1.2 cost 40
!
Router2(config)# router ospf 100 vrf ospf
Router2(config-if)# area 1 sham-link 10.2.1.2 10.2.1.1 cost 40

用語集

BGP :Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)到達可能性情報を他の BGP システムと交換するドメイン間ルーティング プロトコル。RFC 1163 で定義されています。

CE ルータ :カスタマー エッジ ルータ。カスタマー ネットワークに属し、プロバイダー エッジ(PE)ルータとのインターフェイスとなるルータ。CE ルータは、関連する VPN を認識しません。

CEF Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)。高度なレイヤ 3 IP スイッチング テクノロジーです。CEF は、大規模で動的なトラフィック パターンに対するネットワーク パフォーマンスとスケーラビリティを最適化します。

OSPF :Open Shortest Path First プロトコル。

IGP :Interior Gateway Protocol。自律システム内でルーティング情報の交換に使用するインターネット プロトコル。一般的な IGP の例として、IGRP、OSPF、および RIP があります。

LSA :Link-state Advertisement(LSA; リンクステート アドバタイズメント)。リンクステート プロトコルで使用されるブロードキャスト パケット。LSA にはネイバーおよびパス コストに関する情報が含まれ、受信側ルータがルーティング テーブルを維持するために使用します。

MPLS :Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)。タグ スイッチングの基礎となる新しい業界標準です。

PE ルータ :プロバイダー エッジ ルータ。サービス プロバイダー ネットワーク内にあり、カスタマー エッジ(CE)ルータに接続されたルータ。すべての VPN 処理は PE ルータで行われます。

SPF :Shortest Path First 計算。

VPN :Virtual Private Network(VPN; バーチャル プライベート ネットワーク)。1 つ以上の物理ネットワーク上でリソースを共有する、セキュアな IP ベースのネットワーク。VPN では地理的に離れているサイトが、共有バックボーンを通じてセキュアな通信を行えます。

VRF :VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンス。VRF は、IP ルーティング テーブル、取得された転送テーブル、その転送テーブルを使用する一連のインターフェイス、転送テーブルに登録されるものを決定する一連のルールおよびルーティング プロトコルで構成されています。一般に、VRF には、PE ルータに付加されるカスタマー VPN サイトが定義されたルーティング情報が格納されています。