IP ルーティング:OSPF コンフィギュレーション ガイド Cisco IOS Release 15.1S
OSPFv2 のインターフェイス モードにおける エリア コマンド
OSPFv2 のインターフェイス モードにおけるエリア コマンド
発行日;2012/01/31 | 英語版ドキュメント(2011/04/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

OSPFv2 のインターフェイス モードにおけるエリア コマンド

目次

OSPFv2 のインターフェイス モードにおけるエリア コマンドの前提条件

OSPFv2 のインターフェイス モードにおけるエリア コマンドの制約事項

OSPFv2 のインターフェイス モードにおけるエリア コマンドに関する情報

OSPFv2 機能のインターフェイス モードにおけるエリア コマンドの利点

OSPFv2 機能のインターフェイス モードにおけるエリア コマンドの設定ガイドライン

OSPFv2 のインターフェイス モードでエリア コマンドをイネーブルにする方法

インターフェイス上での OSPFv2 のイネーブル化

OSPFv2 機能のインターフェイス モードにおけるエリア コマンドの設定例

インターフェイス上での OSPFv2 のイネーブル化:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

OSPFv2 のインターフェイス モードにおけるエリア コマンドの機能情報

OSPFv2 のインターフェイス モードにおけるエリア コマンド

このマニュアルでは、インターフェイス単位で Open Shortest Path First バージョン 2(OSPFv2)をイネーブルにすることにより、番号が付いていないインターフェイスの設定を簡素化する方法について説明します。 ip ospf area コマンドを使用すると、インターフェイス上での OSPFv2 を明示的にイネーブルにできます。 ip ospf area コマンドは、 network area コマンドによって指定したアドレス範囲に一致するインターフェイスのアドレスを使用して OSPFv2 をイネーブルにするのに代わる方法になります。

この章で紹介する機能情報の入手方法

お使いの Cisco IOS ソフトウェアが、この章で説明されている機能の一部をサポートしていないことがあります。この章に記載されている機能に関するドキュメントへのリンク、および各機能がサポートされているリリースに関するリストについては、「OSPFv2 のインターフェイス モードにおけるエリア コマンドの機能情報」を参照してください。

プラットフォームと Cisco IOS および Catalyst OS ソフトウェア イメージのサポート情報の検索

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

OSPFv2 のインターフェイス モードにおけるエリア コマンドの前提条件

OSPFv2 がネットワークで実行されている必要があります。

OSPFv2 のインターフェイス モードにおけるエリア コマンドの制約事項

ip ospf area コマンドは、OSPFv2 においてのみサポートされます。

OSPFv2 のインターフェイス モードにおけるエリア コマンドに関する情報

ここでは、次の内容について説明します。

「OSPFv2 機能のインターフェイス モードにおけるエリア コマンドの利点」

「OSPFv2 機能のインターフェイス モードにおけるエリア コマンドの設定ガイドライン」

OSPFv2 機能のインターフェイス モードにおけるエリア コマンドの利点

インターフェイスのネットワーク アドレスが、ルータ コンフィギュレーション モードで実行した network area コマンドで指定したアドレス範囲と一致する場合、そのインターフェイスで OSPF がイネーブルになります。OSPFv2 をインターフェイスで明示的にイネーブルにするには、インターフェイス コンフィギュレーション モードで ip ospf area コマンドを使用します。この機能により、番号が付いていないインターフェイスをさまざまなエリアで簡単に設定できるようになります。

ip ospf area コマンドはインターフェイスに対して明示的に設定されるため、ネットワーク レベルで入力される network area コマンドの影響よりも優先され、 network area コマンドに対して指定されたアドレス範囲内に該当するアドレスを持つインターフェイスに影響します。

後で ip ospf area コマンドをディセーブルにしても、インターフェイスのネットワーク アドレスが、 network area コマンドで指定したアドレス範囲に一致する限り、そのインターフェイスは OSPFv2 を実行し続けます。

OSPFv2 機能のインターフェイス モードにおけるエリア コマンドの設定ガイドライン

インターフェイス コンフィギュレーション モードで ip ospf area コマンドを使用して、インターフェイス上の OSPFv2 をイネーブルにする場合は、次のガイドラインについて十分に理解しておくことが推奨されます。

同じエリアおよびプロセスを使用する network area コマンドにより、インターフェイスの OSPFv2 はすでにイネーブルになっている

network area コマンドにより OSPFv2 がイネーブルになっているインターフェイス上で ip ospf area コマンドを入力した場合、インターフェイスのプロセス ID およびエリア ID は変更されず、インターフェイスのステータスは変更されません。ただし、インターフェイスはインターフェイス コンフィギュレーション モードから設定されたとしてフラグ付けされ、設定データは Interface Description Block(IDB; インターフェイス記述ブロック)に保存されます。

異なるエリアおよびプロセスを使用する network area コマンドにより、インターフェイスはすでに設定されている

network area コマンドにより OSPFv2 がイネーブルになっているインターフェイス上で ip ospf area コマンドを入力した場合に、新しい設定情報が IDB に保存された後に、インターフェイスのプロセス ID およびエリア ID を変更して設定を変更した場合、インターフェイスは削除されてから再接続されます。したがって、インターフェイスは元のエリアおよびプロセスから削除され、新しいエリアおよびプロセスに追加されます。また、インターフェイスのステートもリセットされます。

インターフェイスが network area コマンドによって設定されていない

network area コマンドによりインターフェイスの OSPFv2 がイネーブルになっていない場合は、エリアおよび OSPF ルータ インスタンスが必要に応じて作成されます。ルータをリロードすると、システムの初期化が完了するまで OSPF プロセスの実行は開始されません。OSPF ルータ インスタンスを削除するには、 no router ospf コマンドを入力します。インターフェイス モードで ip ospf area コマンドを削除すると、OSPF ルータ インスタンスが削除されます。

interface enable コマンドの削除

interface enable コマンドを削除すると、インターフェイスがエリアから切断されます。接続されている他のインターフェイスがない場合、そのエリアは削除されます。インターフェイスのアドレスが network area コマンドの範囲に含まれている場合は、そのインターフェイスが存在するネットワークのエリアにおいて、インターフェイスが再びイネーブルになります。

新しいプロセス

router ospf コマンドまたは interface コマンドが設定されている場合に、OSPF プロセスがまだ存在しておらず、ルータ ID を選択できない場合は、Proximity Database(PDB; プロキシミティ データベース)とプロセスが作成されますが、プロセスは非アクティブになります。 router-id コマンドを使用してプロセスを明示的に設定するか、または IP アドレスが使用可能になったときに、ルータ ID が選択されると、プロセスはアクティブになります。ただし、ルータ ID を選択できなくても、 router ospf コマンドは受け入れられる状態になり、Command-Line Interface(CLI; コマンドライン インターフェイス)は OSPF 設定コンテキストになることに注意してください。したがって、IP アドレスが使用可能になる前に router-id コマンドが入力されます。プロセスがアクティブではなく、 show ip ospf コマンドが入力されていない場合は、「%OSPF: Router process X is not running, please provide a router-id」というメッセージが表示されます。

リンクステート アドバタイズメントと Shortest Path First

ステートの変更が interface enable コマンドの結果として発生した場合は、新しいルータの Link-State Advertisements(LSA; リンクステート アドバタイズメント)が(インターフェイスによってエリアが変更される場合は、古いエリアに対しても)生成され、古いエリアと新しいエリアの両方における Shortest Path First(SPF)の実行がスケジュールされます。

OSPFv2 のインターフェイス モードでエリア コマンドをイネーブルにする方法

ここでは、次の手順について説明します。

「インターフェイス上での OSPFv2 のイネーブル化」(必須)

インターフェイス上での OSPFv2 のイネーブル化

インターフェイス上での OSPFv2 をイネーブルにするには、次の作業を行います。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip ospf process-id area area-id [ secondaries none ]

5. end

6. show ip ospf interface [ interface-type interface-number ]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface FastEthernet 0/2

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip ospf process-id area area-id [ secondaries none ]

 

Router(config-if)# ip ospf 1 area 0 secondaries none

インターフェイスに対して OSPFv2 をイネーブルにします。

インターフェイス上のセカンダリ IP アドレスがアドバタイズされるのを防ぐため、任意の secondaries キーワードを入力し、その後ろに none キーワードを入力する必要があります。

ステップ 5

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 6

show ip ospf interface [ interface-type interface-number ]

 

Router# show ip ospf interface FastEthernet 0/2

OSPF 関連のインターフェイス情報を表示します。

インターフェイス上での OSPFv2 をイネーブルにすると、 show ip ospf interface コマンドを入力して設定を確認できます。

OSPFv2 機能のインターフェイス モードにおけるエリア コマンドの設定例

ここでは、次の設定例について説明します。

「インターフェイス上での OSPFv2 のイネーブル化:例」

インターフェイス上での OSPFv2 のイネーブル化:例

次に、イーサネット インターフェイス 0/0/0 上で OSPFv2 を明示的に設定する例を示します。

Router(config)# interface Ethernet 0/0/0
Router(config-if)# bandwidth 10000
Router(config-if)# ip address 172.16.1.1 255.255.255.0
Router(config-if)# ip ospf hello-interval 1
Router(config-if)# ip ospf 1 area 0
 

show ip ospf interface コマンドを入力すると、次のような出力により、OSPFv2 を実行するためにインターフェイス コンフィギュレーション モードでイーサネット インターフェイス 0/0/0 が設定されたことが示されます。また、インターフェイス上のセカンダリ IP アドレスもアドバタイズされます。

Router# show ip ospf interface Ethernet 0/0/0
 
Ethernet0/0/0 is up, line protocol is up
Internet Address 172.16.1.1/24, Area 0
Process ID 1, Router ID 172.16.11.11, Network Type BROADCAST, Cost: 10
Enabled by interface config, including secondary ip addresses
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 172.16.11.11, Interface address 172.16.1.1
Backup Designated router (ID) 172.16.22.11, Interface address 172.16.1.2
Timer intervals configured, Hello 1, Dead 4, Wait 4, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:00
Supports Link-local Signaling (LLS)
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 172.26.22.11 (Backup Designated Router)
Suppress hello for 0 neighbor(s)

その他の参考資料

ここでは、OSPFv2 機能のインターフェイス モードにおけるエリア コマンドに関する参考資料を紹介します。

関連資料

関連項目
参照先

OSPF コマンド

Cisco IOS IP Routing: OSPF Command Reference

OSPF の設定タスク

Configuring OSPF 」の章

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2328

「OSPF Version 2」

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

コマンド リファレンス

この章に記載されている 1 つ以上の機能で、次のコマンドが追加または変更されています。これらのコマンドの詳細については、『 Cisco IOS IP Routing: OSPF Command Reference 』を参照してください。Cisco IOS の全コマンドの詳細については、 http://tools.cisco.com/Support/CLILookup にあるコマンド検索ツールを使用するか、または『 Cisco IOS Master Command List 』を参照してください。

ip ospf area

OSPFv2 のインターフェイス モードにおけるエリア コマンドの機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していない限り、それ以降の一連の Cisco IOS ソフトウェア リリースでもその機能はサポートされます。


 

表 1 OSPFv2 のインターフェイス モードにおけるエリア コマンドの機能情報

機能名
リリース
機能情報

OSPFv2 のインターフェイス モードにおけるエリア コマンド

12.0(29)S
12.3(11)T
12.2(28)SB
12.2(33)SRB

このマニュアルでは、インターフェイス単位で Open Shortest Path First バージョン 2(OSPFv2)をイネーブルにすることにより、番号が付いていないインターフェイスの設定を簡素化する方法について説明します。 ip ospf area コマンドを使用すると、インターフェイス上での OSPFv2 を明示的にイネーブルにできます。 ip ospf area コマンドは、 network area コマンドによって指定したアドレス範囲に一致するインターフェイスのアドレスを使用して OSPFv2 をイネーブルにするのに代わる方法になります。