IP ルーティング:OSPF コンフィギュレーション ガイド Cisco IOS Release 15.1S
変換後のタイプ 5 LSA での OSPF フォワー ディング アドレス抑制
変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制
発行日;2012/01/31 | 英語版ドキュメント(2011/04/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制

機能情報の確認

この章の構成

変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制の前提条件

変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制について

変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制の利点

変換後のタイプ 5 LSA での OSPF フォワーディング アドレスの抑制

変換後のタイプ 5 LSA での OSPF フォワーディング アドレスの抑制方法

変換後のタイプ 5 LSA での OSPF フォワーディング アドレスの抑制

変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制の設定例

例:変換後のタイプ 5 LSA での OSPF フォワーディング アドレスの抑制

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制の機能情報

変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制

変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制機能では、Not-So-Stubby Area(NSSA)エリア境界ルータ(ABR)がタイプ 7 リンクステート アドバタイズメント(LSA)をタイプ 5 LSA に変換します。ただし、フォワーディング アドレスとして、タイプ 7 LSA で指定されたものではなく 0.0.0.0 が使用されます。この機能を使用すると、フォワーディング アドレスをバックボーンにアドバタイズしないよう設定されているルータが、転送されたトラフィックを、変換を行う NSSA ABR に渡すようになります。

機能情報の確認

お使いのソフトウェア リリースが、この章で説明されている機能の一部をサポートしていないことがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制の機能情報」 を参照してください。

プラットフォーム サポートと Cisco ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制の前提条件

このマニュアルは、OSPF がネットワーク デバイス上で設定されていることを前提としています。OSPF の設定手順は記載されていません。

変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制について

「変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制の利点」

「変換後のタイプ 5 LSA での OSPF フォワーディング アドレスの抑制」

変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制の利点

変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制機能では、NSSA ABR でタイプ 7 LSA がタイプ 5 LSA に変換されます。ただし、フォワーディング アドレスとして、タイプ 7 LSA で指定されたものではなく 0.0.0.0 が使用されます。この機能を使用すると、フォワーディング アドレスをバックボーンにアドバタイズしないよう設定されているルータが、転送されたトラフィックを、変換を行う NSSA ASBR に渡すようになります。

変換後のタイプ 5 LSA での OSPF フォワーディング アドレスの抑制

図 1 では、バックボーン(エリア 0)に導入されるルートの数を最小に抑えるため、エリア 0 からエリア 2 のアドレスをフィルタリングすることが有効です。ただし、 area range コマンドでエリア境界(エリア 2 のアドレスをフィルタリング)でルートを統合および要約しようとしても、エリア 2 アドレスに ASBR で生成されたタイプ 7 LSA 用のフォワーディング アドレスが含まれるため、機能しません。これらのタイプ 7 LSA フォワーディング アドレスがエリア 0 でフィルタリングされていると、バックボーン ルータは変換元のタイプ 5 LSA(自律システム外部 LSA)でアドバタイズされるプレフィクスに到達できません。

図 1 変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制

 

この問題は、フォワーディング アドレスを ABR で抑制し、タイプ 7 LSA から変換されたタイプ 5 LSA でフォワーディング アドレスを 0.0.0.0 に設定することで解決します。フォワーディング アドレスを 0.0.0.0 に設定すると、外部宛先のパケットを、アドバタイズ先の OSPF ルータ(ここでは変換先の NSSA ABR)に転送する必要があることが示されます。

この機能を設定するには、次の点に注意してください。


注意 この機能を設定すると、ルータが RFC 1587 に準拠しなくなります。また、宛先のフォワーディング アドレスに到達するためのさらによいパスが存在する可能性があるため、次善ルーティングとなる可能性があります。この機能は、慎重に検討し、ネットワーク トポロジを理解するまでは設定しないことを推奨します。

変換後のタイプ 5 LSA での OSPF フォワーディング アドレスの抑制方法

ここでは、次の手順について説明します。

「変換後のタイプ 5 LSA での OSPF フォワーディング アドレスの抑制」

変換後のタイプ 5 LSA での OSPF フォワーディング アドレスの抑制

このタスクでは、変換後のタイプ 5 LSA で OSPF フォワーディング アドレスを抑制する手順について説明します。この機能を設定するには、次の点に注意してください。


注意 この機能を設定すると、ルータが RFC 1587 に準拠しなくなります。また、宛先のフォワーディング アドレスに到達するためのさらによいパスが存在する可能性があるため、次善ルーティングとなる可能性があります。この機能は、慎重に検討し、ネットワーク トポロジを理解するまでは設定しないことを推奨します。

手順の概要

1. enable

2. configure terminal

3. router ospf process-id

4. area area-id nssa translate type7 suppress-fa

5. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードなど、高位の権限レベルをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router ospf process-id

 

Router(config)# router ospf 1

OSPF ルーティングをイネーブルにして、ルータ コンフィギュレーション モードを開始します。

process-id 引数は OSPF プロセスを示します。

ステップ 4

area area-id nssa translate type7 suppress-fa

 

Router(config-router)# area 10 nssa translate type7 suppress-fa

エリアを Not-So-Stubby-Area(NSSA)として設定し、変換後のタイプ 7 LSA でフォワーディング アドレスを抑制します。

ステップ 5

end

 

Router(config-router)# end

コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制の設定例

ここでは、次の設定例について説明します。

「例:変換後のタイプ 5 LSA での OSPF フォワーディング アドレスの抑制」

例:変換後のタイプ 5 LSA での OSPF フォワーディング アドレスの抑制

この例では、変換後のタイプ 5 LSA でフォワーディング アドレスを抑制しています。

interface ethernet 0
ip address 10.93.1.1 255.255.255.0
ip ospf cost 1
!
interface ethernet 1
ip address 10.94.1.1 255.255.255.0
!
router ospf 1
network 10.93.0.0 0.0.255.255 area 0.0.0.0
network 10.94.0.0 0.0.255.255 area 10
area 10 nssa translate type7 suppress-fa

その他の参考資料

「関連資料」

「規格」

「MIB」

「RFC」

「シスコのテクニカル サポート」

関連資料

関連項目
参照先

OSPF コマンド

Cisco IOS IP Routing: OSPF Command Reference

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco ソフトウェア リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制機能を設定すると、ルータが RFC 1587 に準拠しなくなります。

「The OSPF NSSA Option」

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制の機能情報

表 1 に、この機能のリリース履歴を示します。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連のソフトウェア リリースのうち、特定の機能が初めて導入されたソフトウェア リリースだけが記載されています。その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。


 

表 1 変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制の機能情報

機能名
リリース
機能情報

変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制

12.2(15)T
12.2(18)S
12.2(27)SBC
Cisco IOS XE 3.1.0 SG

変換後のタイプ 5 LSA での OSPF フォワーディング アドレス抑制機能では、Not-So-Stubby Area(NSSA)Area Border Routers(ABR; エリア境界ルータ)がタイプ 7 Link-State Advertisements(LSA; リンクステート アドバタイズメント)をタイプ 5 LSA に変換します。ただし、フォワーディング アドレスとして、タイプ 7 LSA で指定されたものではなく 0.0.0.0 が使用されます。この機能を使用すると、フォワーディング アドレスをバックボーンにアドバタイズしないよう設定されているルータが、転送されたトラフィックを、変換を行う NSSA ABR に渡すようになります。

次のコマンドが導入または変更されました。

area nssa translate

show ip ospf