IP ルーティング:OSPF コンフィギュレーション ガイド Cisco IOS Release 15.1S
OSPF の設定
OSPF の設定
発行日;2012/01/31 | 英語版ドキュメント(2011/04/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

OSPF の設定

機能情報の確認

目次

OSPF について

シスコの OSPF 実装

OSPF の設定方法

OSPF のイネーブル化

OSPF インターフェイス パラメータの設定

さまざまな物理ネットワークでの OSPF の設定

OSPF ネットワーク タイプの設定

ポイントツーマルチポイント ブロードキャスト ネットワークの設定

非ブロードキャスト ネットワークへの OSPF の設定

OSPF エリア パラメータの設定

OSPF NSSA の設定

実装の注意事項

OSPF エリア間のルート集約の設定

OSPF へのルート再配布時のルート集約の設定

仮想リンクの作成

デフォルト ルートの生成

DNS 名ルックアップの設定

ループバック インターフェイスによる強制的ルータ ID 選択

デフォルト メトリックの制御

OSPF 管理ディスタンスの変更

シンプレックス イーサネット インターフェイスでの OSPF の設定

ルート計算タイマーの設定

OSPF over On-Demand 回路の設定

実装の注意事項

ネイバーの起動と停止のロギング

LSA グループ ペーシングの変更

以前の LSA の動作

複数のタイマーを使用する LSA グループ ペーシング

OSPF LSA フラッディングのブロック

LSA フラッディングの低減

MOSPF LSA パケットの無視

OSPF アップデート パケットのペーシングの表示

OSPF のモニタリングと維持

設定の制約事項

OSPF の設定例

例:OSPF ポイントツーマルチポイント

例:OSPF ポイントツーマルチポイント、ブロードキャスト

例:OSPF ポイントツーマルチポイント、非ブロードキャスト

例:可変長サブネットマスク

例:OSPF NSSA

例:OSPF ルーティングおよびルート再配布

例:OSPF の基本設定

例:内部ルータ、ABR、および ASBR のOSPF の基本設定

例:複雑な内部ルータ、ABR、および ASBR

例:ABR の複雑な OSPF 設定

例:ルート マップ

例:OSPF 管理ディスタンスの変更

例:OSPF over On-Demand ルーティング

例:LSA グループ ペーシング

例:LSA フラッディングの防止

例:MOSPF LSA パケットの無視

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

OSPF の設定

この章では、Open Shortest Path First(OSPF)の設定方法について説明します。この章に記載されている OSPF コマンドの詳細については、『 Cisco IOS IP Routing Protocols Command Reference 』の「OSPF Commands」の章を参照してください。この章で使用されたその他のコマンドの詳細については、コマンド リファレンス マスタ インデックスを使用するか、オンラインで検索してください。

OSPF は、Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)の OSPF ワーキング グループによって開発された Internal Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)です。OSPF は特に IP ネットワーク向けに設計されており、IP サブネット化、および外部から取得したルーティング情報のタグ付けをサポートしています。OSPF を使用するとパケット認証も可能になり、パケットの送受信に IP マルチキャストが使用されます。

シスコでは、RFC 1253「 Open Shortest Path First (OSPF) MIB 」(1991 年 8 月)をサポートしています。OSPF MIB は、OSPF に関連する管理情報を提供し、Cisco ルータでサポートされる IP ルーティング プロトコルを定義します。

OSPF と連動するプロトコルに非依存の機能については、 「Configuring IP Routing Protocol-Independent Features」 の章を参照してください。

機能情報の確認

プラットフォーム サポートと Cisco ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

OSPF について

シスコの OSPF 実装

シスコの実装は、OSPF バージョン 2 仕様に準拠します。この詳細はインターネット RFC 2328 に記載されています。次の主要機能がシスコの OSPF 実装でサポートされます。

スタブ エリア:スタブ エリアの定義がサポートされています。

ルート再配布:任意の IP ルーティング プロトコルによって学習されたルートを、別の IP ルーティング プロトコルで再配布できます。ドメイン内レベルでは、OSPF は Interior Gateway Routing Protocol(IGRP)、Routing Information Protocol(RIP)、および Intermediate System-to-Intermediate System(IS-IS)で学習したルートをインポートできます。OSPF ルートを IGRP、RIP、および IS-IS にエクスポートすることもできます。ドメイン間レベルでは、OSPF は Exterior Gateway Protocol(EGP)および Border Gateway Protocol(BGP)で学習したルートをインポートできます。OSPF ルートは、BGP および EGP にエクスポートできます。

認証:エリア内の隣接ルータ間でのプレーン テキスト認証および Message Digest 5(MD5)認証がサポートされています。

ルーティング インターフェイス:パラメータ サポート対象で設定可能なパラメータには、インターフェイス出力コスト、再送信インターバル、インターフェイス送信遅延、ルータ プライオリティ、ルータのデッド インターバルおよび hello インターバル、認証キーなどがあります。

仮想リンク:仮想リンクがサポートされています。

Not so stubby area(NSSA):RFC 1587。

OSPF over demand circuit:RFC 1793。

OSPF の設定方法

通常、OSPF を使用するには、多くの内部ルータ、複数のエリアに接続された Area Border Routers(ABR; エリア境界ルータ)、および Autonomous System Boundary Routers(ASBR; 自律システム境界)間での調整が必要です。最小設定では、OSPF ベースのルータまたはアクセス サーバには、すべてのデフォルト パラメータ値、エリアに割り当てられたインターフェイスが使用され、認証は行われません。環境をカスタマイズする場合は、すべてのルータの設定を調整する必要があります。

また、ルート再配布を指定できます。この設定方法については「Configuring IP Routing Protocol-Independent Features」の章にあるタスク「Redistribute Routing Information」を参照してください。

OSPF を設定するには、ここで説明するタスクを実行します。最初の項にあるタスクは必須です。残りの項のタスクは任意ですが、ご使用のアプリケーションによっては必須の場合もあります。インターフェイスの最大数については、「設定の制約事項」の項を参照してください。

「OSPF のイネーブル化」 (必須)

「OSPF インターフェイス パラメータの設定」 (任意)

「さまざまな物理ネットワークでの OSPF の設定」 (任意)

「OSPF エリア パラメータの設定」 (任意)

「OSPF NSSA の設定」 (任意)

「OSPF エリア間のルート集約の設定」 (任意)

「OSPF へのルート再配布時のルート集約の設定」 (任意)

「仮想リンクの作成」 (任意)

「デフォルト ルートの生成」 (任意)

「DNS 名ルックアップの設定」 (任意)

「ループバック インターフェイスによる強制的ルータ ID 選択」 (任意)

「デフォルト メトリックの制御」 (任意)

「OSPF 管理ディスタンスの変更」 (任意)

「シンプレックス イーサネット インターフェイスでの OSPF の設定」 (任意)

「ルート計算タイマーの設定」 (任意)

「OSPF over On-Demand 回路の設定」 (任意)

「ネイバーの起動と停止のロギング」 (任意)

「LSA グループ ペーシングの変更」 (任意)

「OSPF LSA フラッディングのブロック」 (任意)

「LSA フラッディングの低減」 (任意)

「MOSPF LSA パケットの無視」 (任意)

「OSPF アップデート パケットのペーシングの表示」 (任意)

「OSPF のモニタリングと維持」 (任意)

「OSPF の設定例」 (任意)

OSPF のイネーブル化

他のルーティング プロトコルと同様に、OSPF をイネーブルにするには、OSPF ルーティング プロセスを作成し、ルーティング プロセスに関連付ける IP アドレスの範囲を指定して、この範囲に関連付けるエリア ID を割り当てる必要があります。そのためには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# router ospf process-id

OSPF ルーティングをイネーブルにして、ルータ コンフィギュレーション モードを開始します。

ステップ 2

Router(config-router)# network ip- address wildcard-mask area area-id

OSPF が動作するインターフェイス、およびそのインターフェイスのエリア ID を定義します。

OSPF インターフェイス パラメータの設定

シスコの OSPF 実装を使用すると、必要に応じてインターフェイス固有の OSPF パラメータを変更できます。これらのパラメータを変更する必要はありませんが、一部のインターフェイス パラメータについては、接続されたネットワーク内のすべてのルータで統一性を維持する必要があります。パラメータは ip ospf hello-interval ip ospf dead-interval 、および ip ospf authentication-key インターフェイス コンフィギュレーション コマンドで制御されます。したがって、これらのパラメータを設定する場合は、ネットワーク上のすべてのルータのコンフィギュレーションと互換性のある値にしてください。

ネットワークのインターフェイス パラメータを指定するには、必要に応じてインターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# ip ospf cost cost

OSPF インターフェイス上でパケットを送信する際のコストを明示的に指定します。

Router(config-if)# ip ospf retransmit-interval seconds

OSPF インターフェイスに属する隣接関係に対応するリンクステート アドバタイズメント(LSA)再送信間隔を秒数で指定します。

Router(config-if)# ip ospf transmit-delay seconds

リンクステート アップデート パケットを OSPF インターフェイスに送信するために必要な予測時間を秒数で設定します。

Router(config-if)# ip ospf priority number-value

ネットワークの OSPF 代表ルータを決定するときに役立つプライオリティを設定します。

Router(config-if)# ip ospf hello-interval seconds

Cisco IOS ソフトウェアがインターフェイス上で送信する hello パケットの間隔(秒単位)を指定します。

Router(config-if)# ip ospf dead-interval seconds

ネイバー OSPF ルータが hello パケットを受信しなくなったために、このルータがダウンしているとデバイスが判定するまでの待機時間を秒数で設定します。

Router(config-if)# ip ospf authentication-key key

OSPF 簡易パスワード認証を使用しているネットワーク セグメントに、隣接 OSPF ルータで使用されるパスワードを割り当てます。

Router(config-if)# ip ospf message-digest-key key-id md5 key

OSPF MD5 認証をイネーブルにします。 key-id 引数および key 引数 の値は、ネットワーク セグメントの他のネイバーに指定した値と一致している必要があります。

Router(config-if)# ip ospf authentication [ message-digest | null ]

インターフェイスの認証タイプを指定します。

さまざまな物理ネットワークでの OSPF の設定

OSPF は、デフォルトで次の 3 種類のネットワークにメディアを分類します。

ブロードキャスト ネットワーク(イーサネット、トークンリング、FDDI)

非ブロードキャスト マルチアクセス(NBMA)ネットワーク(Switched Multimegabit Data Service(SMDS)、フレームリレー、X.25)

ポイントツーポイント ネットワーク(High-Level Data Link Control(HDLC)、PPP)

ネットワークを、ブロードキャスト ネットワークまたは NBMA ネットワークとして設定できます。

X.25 およびフレーム リレーが提供する オプションのブロードキャスト機能をマップに設定すると、OSPF をブロードキャスト ネットワークとして実行できます。詳細については、『 Cisco IOS Wide-Area Networking Command Reference 』の x25 map コマンドおよび frame-relay map コマンドの説明を参照してください。

OSPF ネットワーク タイプの設定

デフォルトのメディア タイプと無関係に、OSPF ネットワーク タイプをブロードキャストまたは NBMA として設定できます。たとえば、ユーザのネットワーク内のルータがマルチキャスト アドレッシングをサポートしない場合に、この機能を使用してブロードキャスト ネットワークを NBMA ネットワークとして設定できます。NBMA ネットワーク(X.25、フレームリレー、SMDS など)もブロードキャスト ネットワークとして設定できます。この機能により、この章の 「非ブロードキャスト ネットワークへの OSPF の設定」 の項で説明するように、ネイバーの設定が不要になります。

NBMA マルチアクセス ネットワークをブロードキャストまたは非ブロードキャストとして設定する場合は、すべてのルータ間に仮想回線(VC)が存在するか、完全メッシュ ネットワークになっていることが前提となります。たとえば、コストの制約があったり、一部だけがメッシュ ネットワークになっている場合には設定できません。この場合は、OSPF ネットワークのタイプをポイントツーマルチポイント ネットワークとして設定できます。直接接続されていない 2 台のルータ間のルーティングでは、両方のルータへの VC を持つルータを経由してルーティングされます。この機能を使用する場合は、ネイバーを設定する必要はありません。

OSPF のポイントツーマルチポイント インターフェイスは、1 つまたは複数のネイバーを持つ番号付きポイントツーポイント インターフェイスとして定義されます。このインターフェイスは複数のホスト ルートを作成します。OSPF ポイントツーマルチポイント ネットワークには、NBMA やポイントツーポイント ネットワークと比較した場合、次のような利点があります。

ポイントツーマルチポイントはネイバー コマンドの設定が不要で、1 つの IP サブネットだけを使用し、代表ルータの選定も不要なため、設定が容易です。

完全メッシュ トポロジを必要としないため、コストを低く抑えられます。

VC の障害時も接続が維持されるため、信頼性が高くなります。

OSPF ネットワーク タイプを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# ip ospf network { broadcast | non-broadcast | { point-to-multipoint [ non-broadcast ] | point-to-point }}

指定したインターフェイスの OSPF ネットワーク タイプを設定します。

OSPF ポイントツーマルチポイント ネットワークの例については、この章の最後にある 「例:OSPF ポイントツーマルチポイント」 の項を参照してください。

ポイントツーマルチポイント ブロードキャスト ネットワークの設定

ポイントツーマルチポイント ブロードキャスト ネットワークでは、ネイバーの指定は不要です。ただし、 neighbor ルータ コンフィギュレーション コマンドでネイバーを指定できます。この場合は、そのネイバーにコストを指定する必要があります。

point-to-multipoint キーワードが ip ospf network インターフェイス コンフィギュレーション コマンドに追加される前は、一部の OSPF ポイントツーマルチポイント プロトコル トラフィックがマルチキャスト トラフィックとして扱われていました。マルチキャストによってトラフィックが処理されるため、 neighbor ルータ コンフィギュレーション コマンドが、ポイントツーマルチポイント インターフェイスに不要でした。hello、アップデート、確認応答の各メッセージは、マルチキャストを使用して送信されていました。特にマルチキャストの hello メッセージにより、すべてのネイバーが動的に検出されました。

ポイントツーマルチポイント インターフェイス(ブロードキャスト、非ブロードキャストを問わず)では、Cisco IOS ソフトウェアは各ネイバーへのコストが等しいと仮定していました。コストは ip ospf cost インターフェイス コンフィギュレーション コマンドを使用して設定されました。実際には、各ネイバーへの帯域幅が異なるため、コストは違うはずです。この機能を使用すると、各ネイバーへのコストを個別に設定できます。この機能はポイントツーマルチポイント インターフェイスだけに適用されます。

インターフェイスをポイントツーマルチポイント ブロードキャストとして処理し、コストを各ネイバーに割り当てるには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config-if)# ip ospf network point-to-multipoint

インターフェイスをブロードキャスト メディアのポイントツーマルチポイントとして設定します。

ステップ 2

Router(config-if)# exit

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# router ospf process-id

OSPF ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

ステップ 4

Router(config-router)# neighbor ip-address cost number

ネイバーを指定して、このネイバーにコストを割り当てます。

コストを指定するネイバーごとに、ステップ 4 を繰り返します。それ以外の場合、ネイバーは ip ospf cost インターフェイス コンフィギュレーション コマンドに基づいてインターフェイスのコストを推測します。

非ブロードキャスト ネットワークへの OSPF 設定

OSPF ネットワークには多くのルータが接続している場合があるため、 代表ルータ がこのネットワーク用に選択されます。ブロードキャスト機能が設定されていない場合、代表ルータの選択には特別なコンフィギュレーション パラメータが必要になります。

これらのパラメータは、代表ルータまたはバックアップ代表ルータ(ルータ プライオリティ値が 0 以外のルータ)になる資格のあるデバイスだけに設定する必要があります。

非ブロードキャスト ネットワークと相互接続するルータを設定するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-router)# neighbor ip-address [ priority number ] [ poll-interval seconds ]

非ブロードキャスト ネットワークに相互接続するルータを設定します。

次のネイバー パラメータを必要に応じて指定できます。

隣接ルータのプライオリティ

非ブロードキャストのポーリング間隔

ポイントツーマルチポイントの非ブロードキャスト ネットワークでは、 neighbor ルータ コンフィギュレーション コマンドを使用してネイバーを識別する必要があります。ネイバーへのコストの割り当てはオプションです。

Cisco IOS Release 12.0 以前のバージョンでは、一部のユーザは非ブロードキャスト メディア(classic IP over ATM など)でポイントツーマルチポイントを使用していました。そのため、ルートのネイバーを動的に検出できませんでした。この機能を使用すると、 neighbor ルータ コンフィギュレーション コマンドをポイントツーマルチポイント インターフェイスで使用できます。

ポイントツーマルチポイント インターフェイス(ブロードキャスト、非ブロードキャストを問わず)では、Cisco IOS ソフトウェアは各ネイバーへのコストが等しいと仮定していました。コストは ip ospf cost インターフェイス コンフィギュレーション コマンドを使用して設定されました。実際には、各ネイバーへの帯域幅が異なるため、コストは違うはずです。この機能を使用すると、各ネイバーへのコストを個別に設定できます。この機能はポイントツーマルチポイント インターフェイスだけに適用されます。

メディアがブロードキャストをサポートしない場合に、インターフェイスをポイントツーマルチポイント ブロードキャストとして処理するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config-if)# ip ospf network point-to-multipoint non-broadcast

インターフェイスを非ブロードキャスト メディアのポイントツーマルチポイントとして設定します。

ステップ 2

Router(config-if)# exit

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# router ospf process-id

OSPF ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

ステップ 4

Router(config-router)# neighbor ip-address [ cost number ]

ネイバーを指定して、このネイバーにコストを割り当てます。

コストを指定するネイバーごとに、ステップ 4 を繰り返します。それ以外の場合、ネイバーは ip ospf cost インターフェイス コンフィギュレーション コマンドに基づいてインターフェイスのコストを推測します。

OSPF エリア パラメータの設定

OSPF ソフトウェアでは複数のエリア パラメータを設定できます。次のタスク表に示すように、設定できるエリア パラメータには、認証、スタブ エリアの定義、デフォルトの要約ルートへのコストの割り当てがあります。 認証 により、エリアへの無許可アクセスをパスワードによって阻止できます。

スタブ エリア に外部ルートに関する情報は送信されません。代わりに、自律システムの外部の宛先のスタブ エリア内には、ARB によって生成されるデフォルトの外部ルートがあります。OSPF のスタブ エリア サポートを利用するには、そのスタブ エリアで デフォルトのルーティング が使用されている必要があります。スタブ エリアに送信される LSA の数をさらに削減するには、 area stub ルータ コンフィギュレーション コマンドの no-summary キーワードを ABR で設定して要約リンク アドバタイズメント(LSA タイプ 3)をスタブ エリアに送信しないようにします。

ネットワークのエリア パラメータを指定するには、必要に応じてルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-router)# area area-id authentication

OSPF エリアの認証をイネーブルにします。

Router(config-router)# area area-id authentication message-digest

OSPF エリアの MD5 認証をイネーブルにします。

Router(config-router)# area area-id stub [ no-summary ]

エリアをスタブ エリアとして定義します。

Router(config-router)# area area-id default-cost cost

特定のコストをスタブ エリアで使用するデフォルトの要約ルートに割り当てます。

OSPF NSSA の設定

OSPF not-so-stubby area(NSSA)機能は、RFC 1587 で規定されており、Cisco IOS Release 11.2 で初めて導入されました。NSSA は、既存のスタブ エリア機能のシスコ独自ではない拡張です。

OSPF を使用している中央サイトから別のルーティング プロトコルを使用しているリモート サイトに接続する必要があるインターネット サービス プロバイダー(ISP)またはネットワーク管理者は、NSSA を使用して管理を簡素化できます。

スタブ エリアにはリモート サイトのルートが再配布されないため、NSSA が実装される前は、企業サイトの境界ルータとリモート ルータ間の接続に OSPF スタブ エリアを利用できず、2 つのルーティング プロトコルを維持する必要がありました。一般的には RIP などの簡易プロトコルを使用し、再配布を行っていました。NSSA の実装により、企業ルータとリモート ルータ間のエリアを NSSA として定義することで、リモート接続にも OSPF を適用できます。

OSPF スタブ エリアと同様に、NSSA エリアはタイプ 5 LSA による配布ルートに注入されません。NSSA エリアへのルート再配布に使用できるのは、NSSA エリアだけに存在可能な、タイプ 7 と呼ばれる特殊なタイプのリンク ステート アドバタイズメント(LSA)だけです。NSSA の AS 境界ルータ(ASBR)はタイプ 7 LSA を生成し、ルートの再配布が可能となります。これらのタイプ 7 LSA は、NSSA の ABR によってタイプ 5 LSA に変換され、ルーティング ドメイン全体へフラッディングされます。変換時には、要約とフィルタリングがサポートされます。

図 1 に示すネットワーク図では、OSPF エリア 1 がスタブ エリアとして定義されています。スタブ エリアでは再配布が許可されていないため、EIGRP ルートを OSPF ドメインに伝播できません。ただし、OSPF エリア 1 を NSSA として定義すれば、タイプ 7 LSA を生成することで OSPF NSSA に EIGRP ルートを注入できます。

図 1 OSPF NSSA

 

NSSA はスタブ エリアを拡張したものであるため、RIP ルータから再配布されたルートは OSPF エリア 1 内に到達できません。タイプ 5 LSA が排除される点など、スタブ エリアの特性はそのまま残っています。

OSPF NSSA の設定に必要なエリア パラメータを指定するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-router)# area area -id nssa [ no-redistribution ] [ default-information-originate ]

エリアを NSSA として定義します。

タイプ 7 LSA のタイプ 5 LSA への要約とフィルタリングを制御するには、ASBR のルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-router)# summary address prefix mask [ not advertise ] [ tag tag ]

変換時の要約とフィルタリングを制御します。

実装の注意事項

この機能を実装する前に、次の注意事項を検討してください。

外部の宛先に到達するためのタイプ 7 デフォルト ルートを設定できます。この設定により、ルータはタイプ 7 デフォルト ルートを NSSA または NSSA の ABR に生成します。

同じエリア内のすべてのルータは、そのエリアが NSSA であることに合意している必要があります。合意していないと、ルータ間の通信ができません。

OSPF エリア間のルート集約の設定

ルート集約 とは、アドバタイズされたアドレスを統合することです。この機能により、ABR から他のエリアに、1 つの要約ルートだけをアドバタイズできます。OSPF では、ABR が 1 つのエリアのネットワークを別のエリアにアドバタイズします。1 つのエリア内のネットワーク番号が連続して割り当てられている場合、そのエリア内のすべてのネットワークが指定範囲内に収まる 1 つの要約ルートを生成し、そのルートだけがアドバタイズされるように、ABR を設定できます。

アドレス範囲を指定するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-router)# area area-id range ip- address mask [ advertise | not-advertise ][ cost cost]

1 つのルートがアドバタイズされるアドレス範囲を指定します。

OSPF へのルート再配布時のルート集約の設定

他のプロトコルからのルートが(「IP Routing Protocol-Independent Features」の章に記載されているように)OSPF に再配布される場合、各ルートは外部 LSA により個別にアドバタイズされます。ただし、ネットワーク アドレスとマスクの範囲を指定することにより、範囲内のすべての再配布ルートを含む単一ルートがアドバタイズされるように、Cisco IOS ソフトウェアを設定できます。この設定により、OSPF リンク ステート データベースのサイズを縮小できます。

指定したネットワーク アドレスとマスクの範囲内のすべての再配布ルートを 1 つの要約ルートとしてアドバタイズするには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-router)# summary-address {{ ip-address mask } | { prefix mask }} [ not-advertise ][ tag tag ]

再配布ルートをカバーするアドレスとマスクを指定します。1 つの要約ルートだけがアドバタイズされます。一連のルートをフィルタリングするには、任意指定の not-advertise キーワードを使用します。

仮想リンクの作成

OSPF では、すべてのエリアが 1 つのバックボーン エリアに接続されている必要があります。バックボーンが不連続である場合、またはバックボーンが意図的に分割されている場合は、 仮想リンク を確立できます。2 台の ABR を仮想リンクのエンドポイントとして設定できます。仮想リンクは両方のルータで設定される必要があります。各ルータの設定情報には、他の仮想エンドポイント(他の ABR)、および 2 台のルータに共通する非バックボーン リンク( 通過エリア )があります。仮想リンクはスタブ エリアからは設定できません。

仮想リンクを確立するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-router)# area area-id virtual-link router-id [ authentication [ message-digest | null ]] [ hello-interval seconds ] [ retransmit-interval seconds ] [ transmit-delay seconds ] [ dead-interval seconds ] [[ authentication-key key ] | [ message-digest-key key-id md5 key ]]

仮想リンクを確立します。

仮想リンクに関する情報を表示するには、 show ip ospf virtual-links EXEC コマンドを使用します。OSPF ルータのルータ ID を表示するには、 show ip ospf EXEC コマンドを使用します。

デフォルト ルートの生成

ASBR を設定し、強制的に OSPF ルーティング ドメインにデフォルト ルートを設定できます。OSPF ルーティング ドメイン内へのルート再配布を設定すると、常にルートは自動的に ASBR になります。ただし、ASBR は、デフォルトでは OSPF ルーティング ドメインに デフォルト ルート を生成しません。

ASBR を設定し、強制的にデフォルト ルートを生成するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-router)# default-information originate [ always ] [ metric metric-value ] [ metric-type type-value ] [ route-map map-name ]

自律システム境界ルータを設定し、デフォルト ルートを強制的に OSPF ルーティング ドメインに設定します。

(注) ルート マップを使用する場合、キーワード always には次の例外が含まれます。ルート マップを使用する場合、OSPF によるデフォルト ルートの送信は、ルーティング テーブル内にデフォルト ルートが存在するかどうかによって制限されません。

ルート再配分の詳細については、「Configuring IP Routing Protocol-Independent Features」の章を参照してください。

DNS 名ルックアップの設定

すべての OSPF show EXEC コマンド表示で使用する Domain Naming System(DNS)名のルックアップを行うよう、OSPF を設定できます。このコマンドを使用すると、ルータがルータ ID やネイバー ID ではなく名前で表示されるため、ルータを識別しやすくなります。

DNS 名ルックアップを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config)# ip ospf name-lookup

DNS 名ルックアップを設定します。

ループバック インターフェイスによる強制的ルータ ID 選択

OSPF は、インターフェイスに設定されている最大の IP アドレスをルータ ID として使用します。この IP アドレスに関連付けられているインターフェイスがダウンした場合、または削除された場合、OSPF プロセスは新しいルータ ID を再計算し、すべてのルーティング情報をそのルータのインターフェイスから再送信する必要があります。

ループバック インターフェイスが IP アドレスによって設定されているときは、より大きい IP アドレスが他のインターフェイスにある場合でも、Cisco IOS ソフトウェアはこの IP アドレスをルータ ID として使用します。ループバック インターフェイスに障害は発生しないため、ルーティング テーブルの安定性が増大します。

OSPF は他のインターフェイスよりもループバック インターフェイスを自動的に優先し、すべてのループバック インターフェイスの中で最大の IP アドレスを選択します。ループバック インターフェイスが存在しない場合は、ルータ内の最大の IP アドレスが選択されます。OSPF に、特定のインターフェイスの使用を指示することはできません。

ループバック インターフェイスに IP アドレスを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# interface loopback 0

ループバック インターフェイスを作成し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-if)# ip address ip-address mask

このインターフェイスに IP アドレスを割り当てます。

デフォルト メトリックの制御

Cisco IOS Release 10.3 およびそれ以降のリリースでは、デフォルトでインターフェイスの帯域幅に従ってインターフェイスの OSPF メトリックが計算されます。たとえば、64 Kbps のリンクのメトリックは 1562、T1 リンクのメトリックは 64 になります。

OSPF メトリックは ref-bw 値を 帯域幅 の値で割ったものとして計算され、デフォルトで ref-bw 値は 108 です。 帯域幅 の値は bandwidth インターフェイス コンフィギュレーション コマンドによって決まります。この計算により FDDI のメトリックは 1 となります。帯域幅が広いリンクが複数ある場合、これらのリンクのコストに差をつけるには、より大きい数値を使用する必要があります。そのためには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-router)# auto-cost reference-bandwidth ref-bw

帯域幅が広いリンクに差をつけます。

OSPF 管理ディスタンスの変更

管理ディスタンスは、個々のルータやルータのグループなど、ルーティング情報送信元の信頼性を表す数値です。数値的に、管理ディスタンスは 0 ~ 255 の整数です。通常、値が大きいほど信頼性は低下します。管理ディスタンス 255 は、ルーティング情報送信元をまったく信頼できないため、無視する必要があることを意味します。

OSPF は、intra-area(エリア内)、interarea(エリア間)、および external(外部)の 3 つの異なる管理ディスタンスを使用します。エリア内のルートは intra-area、別のエリアへのルートは interarea、再配布を通じて学習された別のルーティング ドメインからのルートは external です。各ルート タイプのデフォルト ディスタンスは 110 です。

OSPF ディスタンス値のいずれかを変更するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-router)# distance ospf {[ intra-area dist1 ] [ inter-area dist2 ] [ external dist3 ]}

OSPF ディスタンス値を変更します。

管理ディスタンスの変更例については、この章の最後にある 「例:OSPF 管理ディスタンスの変更」 の項を参照してください。

シンプレックス イーサネット インターフェイスでの OSPF の設定

イーサネット上の 2 つのデバイス間にあるシンプレックス インターフェイスは 1 つのネットワーク セグメントだけを表すため、OSPF では送信側インターフェイスをパッシブ インターフェイスになるように設定する必要があります。この設定により、OSPF が送信側インターフェイスの hello パケットを送信するのを防ぎます。いずれのデバイスも、受信側インターフェイスに生成される hello パケットを通じて、お互いを表示できます

シンプレックス イーサネット インターフェイスに OSPF を設定するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-router)# passive-interface interface-type interface-number

指定されたインターフェイスを通じた hello パケットの送信を抑止します。

ルート計算タイマーの設定

OSPF がトポロジ変更を受信してから Shortest Path First(SPF)計算を開始するまでの遅延時間を設定できます。また、2 つの SPF 計算の間のホールド タイムも設定できます。そのためには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-router)# timers spf spf-delay spf-holdtime

ルート計算タイマーを設定します。

OSPF over On-Demand 回路の設定

OSPF オンデマンド回路は OSPF プロトコルの拡張機能で、ISDN、X.25 Switched Virtual Circuit(SVC; 相手先選択接続)、ダイヤルアップ回線などのようなオンデマンド回路で効率的に操作が利用できるようになりました。この機能は RFC 1793「Extending OSPF to Support Demand Circuits」をサポートしています。

従来の規格では、OSPF の定期的 hello と LSA アップデートは、hello 情報や LSA 情報に変更が生じていなくても、オンデマンド リンクに接続しているルータ間で交換されていました。

この機能によって定期的 hello は抑制され、LSA の定期的リフレッシュはデマンド回線を通してフラッディングされません。これらのパケットが最初に交換されたときか、パケットに含まれる情報に変更が生じたときだけにリンクが発生します。この動作を使用すると、ネットワーク トポロジが安定している場合に、下位のデータリンク層を閉じることができます。

この機能は、在宅勤務者や支社を、中央にある OSPF バックボーンに接続する場合に有効です。このような場合、OSPF オンデマンド回路を使用すると、余計な接続コストをかけずにドメイン全体に OSPF の利点を適用できます。hello アップデート、LSA アップデート、および他のプロトコル オーバーヘッドの定期的リフレッシュは、送信する「実際の」データがない場合にオンデマンド回路をイネーブル化しなくなります。

hello や LSA などのオーバーヘッド プロトコルは、初期セットアップ時と、トポロジでの変更を反映するときだけ、オンデマンド回路を通じて転送されます。これにより、新しい SPF 計算を必要とするトポロジの重大な変更が、ネットワーク トポロジの整合性を維持するために送信されます。ただし、変更を含まない定期的リフレッシュはリンクにまたがって送信されません。

オンデマンド回路用に OSPF を設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# router ospf process-id

OSPF 動作をイネーブルにします。

ステップ 2

Router(config)# interface interface-type interface-number

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# ip ospf demand-circuit

オンデマンド回路の OSPF を設定します。

ルータがポイントツーポイント トポロジの一部を構成している場合、このコマンドに設定する必要があるのはデマンド回路の片方だけです。ただし、この機能はすべてのルータでロードされている必要があります。

ルータがポイントツーマルチポイント トポロジの一部を構成している場合、このコマンドに設定する必要があるのはマルチポイントだけです。

OSPF over an on-demand 回路の例は、この章の最後にある 「例:OSPF over On-Demand ルーティング」 の項を参照してください。

実装の注意事項

この機能を実装する前に、次の注意事項を検討してください。

トポロジの変更を含む LSA はオンデマンド回路を通してフラッディングされるため、OSPF スタブ エリア内や NSSA 内にデマンド回路を設置して、できるだけ多くのトポロジの変更から隔離しておくべきです。

スタブ エリアまたは NSSA 内でオンデマンド回路機能を利用するには、そのエリアのすべてのルータでこの機能がロードされている必要があります。この機能が 1 つの通常エリア内に実装される場合、タイプ 5 外部 LSA がすべてのエリアを通してフラッディングされるため、デマンド回線機能が反映される前に他のすべての通常エリアもこの機能をサポートする必要があります。

ハブ上にポイントツーマルチポイント(p2mp)OSPF インターフェイス タイプを備えたハブアンドスポーク ネットワーク トポロジは、必要なときにオンデマンド以外の回路に戻らない場合があります。デマンド回路モードから非デマンドモードへ戻る場合、p2mp セグメントのすべてのインターフェイスで、OSPF を同時に再設定する必要があります。

ブロードキャスト ベースのネットワーク トポロジではこの機能を実装しないでください。hello パケットや LSA パケットなどのオーバーヘッド プロトコルが正常に抑制できないためです。リンクはそのまま残ります。

非同期インターフェイスによる OSPF オンデマンド回路用ルータの設定はサポートされていません。回路の両側でダイヤル インターフェイスを使用する設定はサポートされています。詳細については、次の TAC URL を参照してください。

http://www.cisco.com/warp/public/104/dcprob.html#reason5

ネイバーの起動と停止のロギング

デフォルトでは、システムは OSPF ネイバーが起動または停止したときに syslog メッセージを送信します。この機能がオフになっていて、これをオンに戻す場合は、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-router)# log-adjacency-changes [ detail ]

OSPF ネイバーが起動または停止したときに syslog メッセージを送信します。

debug ip ospf adjacency EXEC コマンドを実行しないで、ネイバーが起動または停止したことを確認する必要がある場合に、このコマンドを設定します。 log-adjacency-changes ルータ コンフィギュレーション コマンドでは、少ない出力でピアの関係が高いレベルで表示されます。それぞれの状態変化メッセージを確認する場合は、 log-adjacency-changes detail を設定します。

LSA グループ ペーシングの変更

OSPF LSA グループ ペーシング機能により、ルータで OSPF LSA をグループ化し、リフレッシュ、チェックサム、およびエージングの各機能を同期することが可能となります。グループ ペーシングを利用すると、ルータをより効率的に使用することができます。

ルータは OSPF LSA をグループ化し、CPU およびネットワーク リソースの使用量の急激な増加を防ぐため、これらの機能をペーシングします。この機能は大規模な OSPF ネットワークで最も効力を発揮します。

OSPF LSA グループ ペーシングは、デフォルトではイネーブルです。リフレッシュ、チェックサム、およびエージングのグループ ペーシング インターバルは、通常、デフォルトの設定で十分なので、この機能を設定する必要がありません。

以前の LSA の動作

OSPF LSA には、LSA が有効であるかどうかを示すエージが設定されています。最大エージ(1 時間)に達した LSA は、廃棄されます。エージング プロセス中に、発信元ルータから 30 分ごとにリフレッシュ パケットが送信され、LSA がリフレッシュされます。リフレッシュ パケットは LSA の有効性を保持するために送信されるので、ネットワーク トポロジが変更されたかどうかは関係ありません。チェックサムはすべての LSA で 10 分おきに実行されます。ルータは、生成した LSA と、他のルータから受信した LSA を、継続的に追跡します。ルータが自分で生成した LSA はリフレッシュし、他のルータから受信した LSA はエージングします。

LSA グループ ペーシング機能が実装されるまで、Cisco IOS ソフトウェアでは、リフレッシュ用に 1 つのタイマーを使用し、チェックサムとエージング用にもう 1 つのタイマーを使用していました。たとえば、リフレッシュの場合には、30 分ごとにデータベース全体がスキャンされ、経過時間に関係なく、ルータが生成したすべての LSA がリフレッシュされます。図 2 に、すべての LSA の同時リフレッシュを示します。リフレッシュが必要なのはデータベースのごく一部であるにもかかわらず、このプロセスは、かなりの CPU リソースを消費しました。大型の OSPF データベース(千単位の LSA 数)では、エージの異なる何千もの LSA が存在することになります。単一タイマーを使用したリフレッシュでは、すべての LSA のエージが同期化されるので、CPU の処理量が一度に増加する結果になります。LSA 数が膨大な場合には、ネットワーク トラフィックが急増し、短時間の間に大量のネットワーク リソースが消費されます。

図 2 グループ ペーシングを使用しない単一タイマーによる OSPF LSA

 

複数のタイマーを使用する LSA グループ ペーシング

この問題は、各 LSA に個別のタイマーを設定することによって解決されます。リフレッシュの例を再び使用するため、他の LSA とは関係なく、30 分が経過した時点で各 LSA をリフレッシュします。したがって、CPU は必要な場合にのみ使用されます。ただし、LSA をランダムな間隔で頻繁にリフレッシュしたのでは、ルータがリフレッシュして送信しなければならない少数の LSA に対して多数のパケットが必要になり、帯域幅を効率的に使用できません。

そのためルータは、個々のタイマーが指定時間を経過したとき、すぐに LSA のリフレッシュを実行するのではなく、一定時間だけリフレッシュ機能を保留します。この時間に累積された LSA をグループ化し、リフレッシュを実行して、1 つまたは複数のパケットで送出します。その結果、リフレッシュ パケットは、チェックサムおよびエージングと同時にペーシングされます。ペーシングの間隔は設定可能ですが、デフォルトは 4 分間です。さらに、同時実行を避けるためにランダム化されます。

図 3 に、リフレッシュ パケットの場合を示します。最初のタイムラインは、個別の LSA タイマーを示しています。2 つ目のタイムラインは、個別の LSA タイマーにグループ ペーシングを適用したものです。

図 3 個別タイマーとグループ ペーシングを使用した OSPF LSA

 

グループ ペーシングの間隔は、ルータがリフレッシュ、チェックサム、およびエージングを行う LSA の数と反比例します。たとえば、LSA 数が約 10,000 の場合には、ペーシング間隔を短くしたほうが効果的です。データベースが非常に小規模(40 ~ 100 の LSA)の場合、ペーシング間隔は 10 ~ 20 分に引き伸ばされ、わずかですが利益を得ることができます。

LSA グループ ペーシングのデフォルト値は、240 秒(4 分)です。値の範囲は、10~1800 秒(30 分)です。LSA グループ ペーシングの間隔を変更するには、ルータ コンフィギュレーション モードでコマンドを使用します。

 

コマンド
目的

Router(config-router)# timers pacing lsa-group seconds

LSA の グループ ペーシングを変更します。

例については、この章の最後にある 「例:LSA グループ ペーシング」 の項を参照してください。

OSPF LSA フラッディングのブロック

デフォルトでは、OSPF では LSA が着信するインターフェイスを除き、同じエリア内のすべてのインターフェイスに新しい LSA をフラッディングします。確実なフラッディングを行うには、ある程度の冗長設定が必要になります。ただし、過度の冗長設定は帯域幅を浪費することになり、フルメッシュ型トポロジなどの特定のトポロジでは、リンク数と CPU 使用率の超過によりネットワークが不安定になることがあります。この例としては完全メッシュ トポロジがあります。

OSPF の LSA フラッディングは、ネットワークのタイプに応じて、2 つの方法でブロックすることができます。

ブロードキャスト、非ブロードキャスト、およびポイントツーポイントのネットワークでは、特定の OSPF インターフェイス上でフラッディングをブロックできます。

ポイントツーマルチポイント ネットワークの場合には、指定したネイバーに対してフラッディングをブロックできます。

ブロードキャスト、非ブロードキャスト、およびポイントツーポイントのネットワークで、OSPF の LSA フラッディングをブロックするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# ip ospf database-filter all out

インターフェイスへの OSPF LSA パケットのフラッディングをブロックします。

ポイントツーマルチポイント ネットワークで、OSPF の LSA フラッディングをブロックするには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-router)# neighbor ip-address database-filter all out

指定したネイバーへの OSPF LSA パケットのフラッディングをブロックします。

LSA フラッディングのブロック例については、この章の最後にある 「例:LSA フラッディングの防止」 の項を参照してください。

LSA フラッディングの低減

インターネットの急成長により、OSPF などの IGP のスケーラビリティが注目されています。設計上、OSPF では、3,600 秒後に期限切れになる LSA をリフレッシュする必要があります。一部の実装ではリフレッシュの頻度を 30 分から約 50 分に減らして、フラッディングを改善しようとしてきました。このソリューションにより、リフレッシュのトラフィック量は減りますが、LSA の期限が切れるまでに最低 1 度はリフレッシュが必要になります。OSPF フラッディングを低減するソリューションでは、既知の変更されていない情報に対する、不要なリフレッシュとフラッディングの抑制が行われます。この低減を実現するため、LSA は現在フラッディング時に上位ビットが設定されます。LSA は現在「do not age」と設定されています。

ネットワーク上で LSA の不要なリフレッシュとフラッディングを低減するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# ip ospf flood-reduction

安定したトポロジで LSA の不要なフラッディングを抑止します。

MOSPF LSA パケットの無視

Cisco ルータは、LSA タイプ 6 Multicast OSPF(MOSPF)をサポートしていません。ルータはこれらのパケットを受信すると、Syslog メッセージを生成します。ルータが多数の MOSPF パケットを受信している場合、パケットを無視するようにルータを設定して、大量の syslog メッセージが生成されないようにすることが必要な場合があります。そのためには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-router)# ignore lsa mospf

MOSPF LSA パケットを受信したとき、ルータが Syslog メッセージを生成しないように設定します。

MOSPF LSA パケットの抑制例については、この章の最後にある 「例:MOSPF LSA パケットの無視」 の項を参照してください。

OSPF アップデート パケットのペーシングの表示

アップデート パケットを送信する OSPF の従来の実装は、効率面に改善の余地があります。リンクが低速の状態でアップデート パケットの一部が失われたり、ネイバーがアップデートを十分すばやく受信できなくなったり、あるいは、ルータがバッファ スペースを使い切ってしまったりすることがあります。たとえば、次のいずれかのトポロジが存在した場合にパケットがドロップされる可能性があります。

高速のルータがポイントツーポイント リンクを介して低速のルータと接続している。

フラッディング中に、複数のネイバーから 1 台のルータに同時にアップデートが送信される。

OSPF アップデート パケットは自動的に同期されるようになり、33 ミリ秒未満の間隔で送信されます。ペーシングは、再送信間でも、送信効率を高めて再送信パケットの損失を最小にするために利用されます。インターフェイスへの送信を待機している LSA を表示することもできます。ペーシングの利点は、OSPF アップデートおよび再送信パケットの送信の効率をよくすることです。

この機能を設定するタスクはありません。自動的に行われます。

指定したインターフェイスを通したフラッディングを待機している LSA のリストを表示して OSPF パケットのペーシングを観察するには、次のコマンドを使用します。

 

コマンド
目的

Router# show ip ospf flood-list interface-type interface-number

インターフェイス上でのフラッディングを待機している LSA のリストを表示します。

OSPF のモニタリングと維持

IP ルーティング テーブルの内容、キャッシュの内容、およびデータベースの内容など、特定の統計情報を表示できます。提供される情報は、リソースの使用状況を判定してネットワークの問題を解決するために使用されます。また、ノードの到達可能性情報を表示して、デバイス パケットがネットワークを通過するときにとるルーティング パスを見つけることもできます。

さまざまなルーティング統計情報を表示するには、必要に応じて EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show ip ospf [ process-id ]

OSPF ルーティング プロセスに関する一般情報を表示します。

Router# show ip ospf border-routers

ABR および ASBR までの内部 OSPF ルーティング テーブル エントリを表示します。

Router# show ip ospf [ process-id [ area-id ]] database

 

Router# show ip ospf [ process-id [ area-id ]] database [ database-summary ]

 

Router# show ip ospf [ process-id [ area-id ]] database [ router ] [ self-originate ]

 

Router# show ip ospf [ process-id [ area-id ]] database [ router ] [ adv-router [ ip-address ]]

 

Router# show ip ospf [ process-id [ area-id ]] database [ router ] [ link-state-id ]

 

Router# show ip ospf [ process-id [ area-id ]] database [ network ] [ link-state-id ]

 

Router# show ip ospf [ process-id [ area-id ]] database [ summary ] [ link-state-id ]

 

Router# show ip ospf [ process-id [ area-id ]] database [ asbr-summary ] [ link-state-id ]

 

Router# show ip ospf [ process-id [ area-id ]] database [ external ] [ link-state-id ]

 

Router# show ip ospf [ process-id [ area-id ]] database [ nssa-external ] [ link-state-id ]

 

Router# show ip ospf [ process-id [ area-id ]] database [ opaque-link ] [ link-state-id ]

 

Router# show ip ospf [ process-id [ area-id ]] database [ opaque-area ] [ link-state-id ]

 

Router# show ip ospf [ process-id [ area-id ]] database [ opaque-as ] [ link-state-id ]

OSPF データベースに関連する情報のリストを表示します。

Router# show ip ospf flood-list interface interface-type

インターフェイス上でのフラッディングを待機している LSA のリストを表示します(OSPF パケット ペーシングの観察)。

Router# show ip ospf interface [ interface-type interface-number ]

OSPF 関連のインターフェイス情報を表示します。

Router# show ip ospf neighbor [ interface-name ] [ neighbor-id ] detail

OSPF ネイバー情報をインターフェイスごとに表示します。

Router# show ip ospf request-list [ neighbor ] [ interface ] [ interface-neighbor ]

ルータから要求されたすべての LSA のリストを表示します。

Router# show ip ospf retransmission-list [ neighbor ] [ interface ] [ interface-neighbor ]

再送信を待機しているすべての LSA のリストを表示します。

Router# show ip ospf [ process-id ] summary-address

OSPF プロセスで設定されているサマリー アドレスの、すべての再配布情報のリストを表示します。

Router# show ip ospf virtual-links

OSPF に関連する仮想リンク情報を表示します。

OSPF プロセスを再起動するには、EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# clear ip ospf [ pid ] { process | redistribution | counters [ neighbor [neighbor- interface ] [ neighbor-id ]] }

OSPF ルーティング プロセス ID に基づいて再配布をクリアします。 pid オプションを指定しなかった場合、すべての OSPF プロセスがクリアされます。

設定の制約事項

システムに数多くのインターフェイスがあると、ルータ リンクステート アドバタイズメント(LSA)でアドバタイズされるリンクの数により、リンクステート アップデート パケットが「huge」IOS バッファ サイズを超過することがあります。この問題を解決するには、OSPF リンクの数を増やすか、 buffers huge size size コマンドを入力して huge バッファ サイズを増やす必要があります。

ルータ LSA が含まれるリンクステート アップデート パケットは、通常 196 バイトの固定オーバーヘッドがあり、個々のリンクの説明に追加の 12 バイトが必要です。「huge buffer size」が 18024 バイトの場合、最大 1485 個のリンクの説明が用意できます。

IP パケットの最大サイズは 65535 バイトであるため、ルータに用意できるリンクの数の上限はまだ大きくできます。

OSPF の設定例

ここでは、OSPF の設定例を示します。

「例:OSPF ポイントツーマルチポイント」

「例:OSPF ポイントツーマルチポイント、ブロードキャスト」

「例:OSPF ポイントツーマルチポイント、非ブロードキャスト」

「例:可変長サブネットマスク」

「例:OSPF NSSA」

「例:OSPF ルーティングおよびルート再配布」

「例:ルート マップ」

「例:OSPF 管理ディスタンスの変更」

「例:OSPF over On-Demand ルーティング」

「例:LSA グループ ペーシング」

「例:LSA フラッディングの防止」

「例:MOSPF LSA パケットの無視」

例:OSPF ポイントツーマルチポイント

図 4 では、ルータ Mollie が Data-Link Connection Identifier(DLCI)201 を使用してルータ Neon と、DLCI 202 を使用してルータ Jelly と、DLCI 203 を使用してルータ Platty とそれぞれ通信しています。Neon は DLCI 101 を使用して Mollie と、DLCI 102 を使用して Platty と通信を行っています。Platty は Neon(DLCI 401)および Mollie(DLCI 402)と通信を行っています。Jelly は Mollie(DLCI 301)と通信しています。設例を図の次に示します。

図 4 OSPF ポイントツーマルチポイントの例

 

Mollie の設定

hostname mollie
!
interface serial 1
ip address 10.0.0.2 255.0.0.0
ip ospf network point-to-multipoint
encapsulation frame-relay
frame-relay map ip 10.0.0.1 201 broadcast
frame-relay map ip 10.0.0.3 202 broadcast
frame-relay map ip 10.0.0.4 203 broadcast
!
router ospf 1
network 10.0.0.0 0.0.0.255 area 0

Neon の設定

hostname neon
!
interface serial 0
ip address 10.0.0.1 255.0.0.0
ip ospf network point-to-multipoint
encapsulation frame-relay
frame-relay map ip 10.0.0.2 101 broadcast
frame-relay map ip 10.0.0.4 102 broadcast
!
router ospf 1
network 10.0.0.0 0.0.0.255 area 0

Platty の設定

hostname platty
!
interface serial 3
ip address 10.0.0.4 255.0.0.0
ip ospf network point-to-multipoint
encapsulation frame-relay
clock rate 1000000
frame-relay map ip 10.0.0.1 401 broadcast
frame-relay map ip 10.0.0.2 402 broadcast
!
router ospf 1
network 10.0.0.0 0.0.0.255 area 0

Jelly の設定

hostname jelly
!
interface serial 2
ip address 10.0.0.3 255.0.0.0
ip ospf network point-to-multipoint
encapsulation frame-relay
clock rate 2000000
frame-relay map ip 10.0.0.2 301 broadcast
!
router ospf 1
network 10.0.0.0 0.0.0.255 area 0

例:OSPF ポイントツーマルチポイント、ブロードキャスト

次に、ブロードキャストを行うポイントツーマルチポイント ネットワークの例を示します。

interface Serial0
ip address 10.0.1.1 255.255.255.0
encapsulation frame-relay
ip ospf cost 100
ip ospf network point-to-multipoint
frame-relay map ip 10.0.1.3 202 broadcast
frame-relay map ip 10.0.1.4 203 broadcast
frame-relay map ip 10.0.1.5 204 broadcast
frame-relay local-dlci 200
!
router ospf 1
network 10.0.1.0 0.0.0.255 area 0
neighbor 10.0.1.5 cost 5
neighbor 10.0.1.4 cost 10
 

次に、10.0.1.3 におけるネイバーの設定例を示します。

interface serial 0
ip address 10.0.1.3 255.255.255.0
ip ospf network point-to-multipoint
encapsulation frame-relay
frame-relay local-dlci 301
frame-relay map ip 10.0.1.1 300 broadcast
no shut
!
router ospf 1
network 10.0.1.0 0.0.0.255 area 0
 

最初の設定でのネイバーの出力は、次のとおりです。

Router# show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
172.16.1.1 1 FULL/ - 00:01:50 10.0.1.5 Serial0
172.16.1.4 1 FULL/ - 00:01:47 10.0.1.4 Serial0
172.16.1.8 1 FULL/ - 00:01:45 10.0.1.3 Serial0
 

最初の設定のルート情報は、次のとおりです。

Router# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR
Gateway of last resort is not set
C 1.0.0.0/8 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
O 10.0.1.3/32 [110/100] via 10.0.1.3, 00:39:08, Serial0
C 10.0.1.0/24 is directly connected, Serial0
O 10.0.1.5/32 [110/5] via 10.0.1.5, 00:39:08, Serial0
O 10.0.1.4/32 [110/10] via 10.0.1.4, 00:39:08, Serial0

例:OSPF ポイントツーマルチポイント、非ブロードキャスト

次に、非ブロードキャストのポイントツーマルチポイント ネットワークの例を示します。

interface Serial0
ip address 10.0.1.1 255.255.255.0
ip ospf network point-to-multipoint non-broadcast
encapsulation frame-relay
no keepalive
frame-relay local-dlci 200
frame-relay map ip 10.0.1.3 202
frame-relay map ip 10.0.1.4 203
frame-relay map ip 10.0.1.5 204
no shut
!
router ospf 1
network 10.0.1.0 0.0.0.255 area 0
neighbor 10.0.1.3 cost 5
neighbor 10.0.1.4 cost 10
neighbor 10.0.1.5 cost 15
 

次に、相手側のルータの設定例を示します。

interface Serial9/2
ip address 10.0.1.3 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint non-broadcast
no ip mroute-cache
no keepalive
no fair-queue
frame-relay local-dlci 301
frame-relay map ip 10.0.1.1 300
no shut
!
router ospf 1
network 10.0.1.0 0.0.0.255 area 0
 

最初の設定でのネイバーの出力は、次のとおりです。

Router# show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
172.16.1.1 1 FULL/ - 00:01:52 10.0.1.5 Serial0
172.16.1.4 1 FULL/ - 00:01:52 10.0.1.4 Serial0
172.16.1.8 1 FULL/ - 00:01:52 10.0.1.3 Serial0

例:可変長サブネットマスク

OSPF、スタティック ルート、および IS-IS は、VLSM をサポートします。VLSM により、異なるインターフェイスの同じネットワーク番号に別のマスクを使用できるため、IP アドレスを維持し、使用可能なアドレス空間をより効率的に使用できます。

次の例では、30 ビット サブネット マスクが使用され、2 ビットのアドレス空間はシリアル回線のホスト アドレス用に予約されています。ポイントツーポイント シリアル リンク上の 2 つのホスト エンドポイントには、十分なホスト アドレス空間があります。

interface ethernet 0
ip address 172.16.10.1 255.255.255.0
! 8 bits of host address space reserved for ethernets
 
interface serial 0
ip address 172.16.20.1 255.255.255.252
! 2 bits of address space reserved for serial lines
 
! Router is configured for OSPF and assigned AS 107
router ospf 107
! Specifies network directly connected to the router
network 172.16.0.0 0.0.255.255 area 0.0.0.0

例:OSPF NSSA

次の例では、OSPF スタブ ネットワークは 5 台のルータを使用して、OSPF エリア 0 と OSPF エリア 1 を組み込むように設定されています。OSPF エリア 1 は Not-so-stubby area(NSSA)として定義され、ルータ 3 は NSSA ASBR として設定され、ルータ 2 は NSSA ABR として設定されています。5 台のルータの設定ファイルは次のとおりです。

ルータ 1

hostname Router1
!
interface Loopback1
ip address 10.1.0.1 255.255.255.255
!
interface Ethernet0/0
ip address 192.168.0.1 255.255.255.0
ip ospf 1 area 0
no cdp enable
!
interface Serial10/0
description Router2 interface s11/0
ip address 192.168.10.1 255.255.255.0
ip ospf 1 area 1
serial restart-delay 0
no cdp enable
!
router ospf 1
area 1 nssa
!
end

ルータ 2

 
hostname Router2
!
!
interface Loopback1
ip address 10.1.0.2 255.255.255.255
!
interface Serial10/0
description Router1 interface s11/0
no ip address
shutdown
serial restart-delay 0
no cdp enable
!
interface Serial11/0
description Router1 interface s10/0
ip address 192.168.10.2 255.255.255.0
ip ospf 1 area 1
serial restart-delay 0
no cdp enable
!
interface Serial14/0
description Router3 interface s13/0
ip address 192.168.14.2 255.255.255.0
ip ospf 1 area 1
serial restart-delay 0
no cdp enable
!
router ospf 1
area 1 nssa
!
end

ルータ 3

hostname Router3
!
interface Loopback1
ip address 10.1.0.3 255.255.255.255
!
interface Ethernet3/0
ip address 192.168.3.3 255.255.255.0
no cdp enable
!
interface Serial13/0
description Router2 interface s14/0
ip address 192.168.14.3 255.255.255.0
ip ospf 1 area 1
serial restart-delay 0
no cdp enable
!
router ospf 1
log-adjacency-changes
area 1 nssa
redistribute rip subnets
!
router rip
version 2
redistribute ospf 1 metric 15
network 192.168.3.0
end

ルータ 4

hostname Router4
!
interface Loopback1
ip address 10.1.0.4 255.255.255.255
!
interface Ethernet3/0
ip address 192.168.3.4 255.255.255.0
no cdp enable
!
interface Ethernet4/1
ip address 192.168.41.4 255.255.255.0
!
router rip
version 2
network 192.168.3.0
network 192.168.41.0
!
end

ルータ 5

hostname Router5
!
interface Loopback1
ip address 10.1.0.5 255.255.255.255
!
interface Ethernet0/0
ip address 192.168.0.10 255.255.255.0
ip ospf 1 area 0
no cdp enable
!
interface Ethernet1/1
ip address 192.168.11.10 255.255.255.0
ip ospf 1 area 0
!
router ospf 1
!
end
 

図 5 に NSSA エリア 1 の OSPF スタブ ネットワークを示します。ルータ 4 が 2 つの RIP ネットワークから伝搬している再配布ルートは、NSSA ASBR ルータ 3 によってタイプ 7 LSA に変換されます。ルータ 2 は NSSA ABR として設定されており、タイプ 7 LSA をタイプ 5 に戻して、OSPF エリア 0 内の残りの OSPF ルータ ネットワークを経由してフラッディングされます。

図 5 NSSA ABR ルータと ASBR ルータの OSPF NSSA ネットワーク

 

show ip ospf コマンドがルータ 2 に入力されると、ルータは OSFP エリア 1 が NSSA エリアであることが確認されます。

Router2# show ip ospf
 
Routing Process "ospf 1" with ID 10.1.0.2
Start time: 00:00:01.392, Time elapsed: 12:03:09.480
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 0 normal 0 stub 1 nssa
Number of areas transit capable is 0
External flood list length 0
Area 1
Number of interfaces in this area is 2
! It is a NSSA area
Area has no authentication
SPF algorithm last executed 11:37:58.836 ago
SPF algorithm executed 3 times
Area ranges are
Number of LSA 7. Checksum Sum 0x045598
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
 
 
Router2# show ip ospf data
 
OSPF Router with ID (10.1.0.2) (Process ID 1)
 
Router Link States (Area 1)
 
Link ID ADV Router Age Seq# Checksum Link count
10.1.0.1 10.1.0.1 1990 0x80000016 0x00CBCB 2
10.1.0.2 10.1.0.2 1753 0x80000016 0x009371 4
10.1.0.3 10.1.0.3 1903 0x80000016 0x004149 2
 
Summary Net Link States (Area 1)
 
Link ID ADV Router Age Seq# Checksum
192.168.0.0 10.1.0.1 1990 0x80000017 0x00A605
192.168.11.0 10.1.0.1 1990 0x80000015 0x009503
 
Type-7 AS External Link States (Area 1)
 
Link ID ADV Router Age Seq# Checksum Tag
192.168.3.0 10.1.0.3 1903 0x80000015 0x00484F 0
192.168.41.0 10.1.0.3 1903 0x80000015 0x00A4CC 0
 

show ip ospf database data コマンドが入力されると、NSSA エリアに注入され、次に OSPF ネットワークからフラッディングされるルートのタイプ 5 LSA とタイプ 7 LSA 間の再配布に関する参考情報が表示されます。

Router2# show ip ospf database data
 
OSPF Router with ID (10.1.0.2) (Process ID 1)
 
Area 1 database summary
LSA Type Count Delete Maxage
Router 3 0 0
Network 0 0 0
Summary Net 2 0 0
Summary ASBR 0 0 0
Type-7 Ext 2 0 0
Prefixes redistributed in Type-7 0
Opaque Link 0 0 0
Opaque Area 0 0 0
Subtotal 7 0 0
 
Process 1 database summary
LSA Type Count Delete Maxage
Router 3 0 0
Network 0 0 0
Summary Net 2 0 0
Summary ASBR 0 0 0
Type-7 Ext 2 0 0
Opaque Link 0 0 0
Opaque Area 0 0 0
Type-5 Ext 0 0 0
Prefixes redistributed in Type-5 0
Opaque AS 0 0 0
Total 7 0 0
 

show ip ospf database nssa コマンドが入力されても、タイプ 7 からタイプ 5 への変換の詳細情報が表示されます。

Router2# show ip ospf database nssa
 
OSPF Router with ID (10.1.0.2) (Process ID 1)
 
Type-7 AS External Link States (Area 1)
 
Routing Bit Set on this LSA
LS age: 1903
Options: (No TOS-capability, Type 7/5 translation, DC)
LS Type: AS External Link
Link State ID: 192.168.3.0 (External Network Number )
Advertising Router: 10.1.0.3
LS Seq Number: 80000015
Checksum: 0x484F
Length: 36
Network Mask: /24
Metric Type: 2 (Larger than any link state path)
TOS: 0
Metric: 20
Forward Address: 192.168.14.3
External Route Tag: 0
Routing Bit Set on this LSA
LS age: 1903
! Options: (No TOS-capability, Type 7/5 translation, DC)
LS Type: AS External Link
Link State ID: 192.168.41.0 (External Network Number )
Advertising Router: 10.1.0.3
LS Seq Number: 80000015
Checksum: 0xA4CC
Length: 36
Network Mask: /24
Metric Type: 2 (Larger than any link state path)
TOS: 0
Metric: 20
Forward Address: 192.168.14.3
External Route Tag: 0
 

ルータ 3

show ip ospf コマンドを入力すると、ルータ 3 が ASBR として機能し、OSPF エリア 1 が NSSA エリアとして設定されることを確認する情報が表示されます。

Router3# show ip ospf
 
Routing Process "ospf 1" with ID 10.1.0.3
Start time: 00:00:01.392, Time elapsed: 12:02:34.572
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
!It is an autonomous system boundary router
Redistributing External Routes from,
rip, includes subnets in redistribution
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 0 normal 0 stub 1 nssa
Number of areas transit capable is 0
External flood list length 0
Area 1
Number of interfaces in this area is 1
! It is a NSSA area
Area has no authentication
SPF algorithm last executed 11:38:13.368 ago
SPF algorithm executed 3 times
Area ranges are
Number of LSA 7. Checksum Sum 0x050CF7
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
 

例:OSPF ルーティングおよびルート再配布

通常、OSPF では多くの内部ルータ、ABR、および ASBR 間での調整が必要です。OSPF ベースのルータは最低でも、すべてのデフォルト パラメータ値を使用し、認証なしで、インターフェイスをエリアに割り当てて設定できます。

次に、3 つのタイプの例を示します。

最初の例は、基本的な OSPF コマンドを示した簡単な設定です。

2 番目の例は、単一の任意に割り当てられた OSPF AS 内での内部ルータ、ABR、および ASBR の設定を示しています。

3 番目の例は、より複雑な設定と、OSPF ベースのルーティング環境の制御で使用できるさまざまなツールの用途を示しています。

例:OSPF の基本設定

次の例は、OSPF ルーティング プロセス 9000 をイネーブルにし、イーサネット インターフェイス 0 をエリア 0.0.0.0 に接続し、RIP から OSPF、または OSPF から RIP に再配布を行う簡単な OSPF の設定を示しています。

interface ethernet 0
ip address 10.93.1.1 255.255.255.0
ip ospf cost 1
!
interface ethernet 1
ip address 10.94.1.1 255.255.255.0
!
router ospf 9000
network 10.93.0.0 0.0.255.255 area 0.0.0.0
redistribute rip metric 1 subnets
!
router rip
network 10.94.0.0
redistribute ospf 9000
default-metric 1

例:内部ルータ、ABR、および ASBR のOSPF の基本設定

次の例では、4 つのエリア ID を 4 つの IP アドレス範囲に割り当てています。この例では、OSPF ルーティング プロセス 109 が起動し、4 つの OSPF エリア(10.9.50.0、2、3、0)が定義されています。エリア 10.9.50.0、2、および 3 では、特定のアドレス範囲をマスクし、エリア 0 は 他のすべての ネットワークで OSPF をイネーブルにします。

router ospf 109
network 192.168.10.0 0.0.0.255 area 10.9.50.0
network 192.168.20.0 0.0.255.255 area 2
network 192.168.30.0 0.0.0.255 area 3
network 192.168.40.0 255.255.255.255 area 0
!
! Interface Ethernet0 is in area 10.9.50.0:
interface ethernet 0
ip address 192.168.10.5 255.255.255.0
!
! Interface Ethernet1 is in area 2:
interface ethernet 1
ip address 192.168.20.5 255.255.255.0
!
! Interface Ethernet2 is in area 2:
interface ethernet 2
ip address 192.168.20.7 255.255.255.0
!
! Interface Ethernet3 is in area 3:
interface ethernet 3
ip address 192.169.30.5 255.255.255.0
!
! Interface Ethernet4 is in area 0:
interface ethernet 4
ip address 192.168.40.1 255.255.255.0
!
! Interface Ethernet5 is in area 0:
interface ethernet 5
ip address 192.168.40.12 255.255.0.0
 

network area ルータ コンフィギュレーション コマンドは逐次的に評価されるため、設定内のこれらのコマンドの順序は重要です。Cisco IOS ソフトウェアは、各インターフェイスの ip-address wildcard-mask ペアを次のように順次評価します。詳細については、『 Cisco IOS IP Routing Protocols Command Reference 』の「OSPF Commands」の章を参照してください。

最初の network area コマンドについて検討してみます。サブネット 192.168.10.0 が配置されているインターフェイスに、エリア ID 10.9.50.0 が設定されています。イーサネット インターフェイス 0 の一致が判断されたとします。イーサネット インターフェイス 0 はエリア 10.9.50.0 だけに接続されています。

次に、2 番目の network area コマンドを評価します。エリア 2 では、すべてのインターフェイス(イーサネット インターフェイス 0 を除く)に同じプロセスが適用されています。イーサネット インターフェイス 1 の一致が判断されたとします。OSPF はそのインターフェイスでイネーブルになり、イーサネット インターフェイス 1 はエリア 2 に接続されます。

すべての network area コマンドに対して、この OSPF エリアへのインターフェイスの接続プロセスが続けられます。この例の最後の network area コマンドは特殊なケースです。このコマンドにより、使用可能なすべてのインターフェイス(別のエリアに明示的に接続されていない)はエリア 0 に接続されています。

例:複雑な内部ルータ、ABR、および ASBR

次の例は、単一の OSPF AS 内の複数のルータの設定の概略を示しています。図 6 に、この設定例を示す一般的なネットワーク マップを示します。

図 6 OSPF 自律システム ネットワーク マップの例

 

この設定では、OSPF に 5 台のルータが設定されています。

ルータ A とルータ B は、いずれもエリア 1 内の内部ルータです。

ルータ C は OSPF ABR です。ルータ C では、エリア 1 は E3 に割り当てられ、エリア 0 は S0 に割り当てられていることに注意してください。

ルータ D は、エリア 0(バックボーン エリア)の内部ルータです。この場合、どちらの network ルータ コンフィギュレーション コマンドも同じエリア(エリア 0、つまりバックボーン エリア)を指定しています。

ルータ E は OSPF ASBR です。BGP ルートは OSPF に再配布され、これらのルートは OSPF によってアドバタイズされることに注意してください。


) AS のすべてのルータの設定に、OSPF AS のすべてのエリアの定義を含める必要はありません。直接接続されたエリアだけを定義する必要があります。次の例では、エリア 0 のルートは、ABR(ルータ C)がサマリー LSA をエリア 1 に挿入したときに、エリア 1 のルータ(ルータ A およびルータ B)によって学習されます。


BGP AS 109 内の OSPF ドメインは外部に接続され、BGP リンクを通じて IP アドレス 11.0.0.6 の外部ピアと接続しています。次に、設定例を示します。

次に、図 6 の一般的なネットワーク マップの設定例を示します。

ルータ A の設定:内部ルータ

interface ethernet 1
ip address 192.168.1.1 255.255.255.0
 
router ospf 1
network 192.168.0.0 0.0.255.255 area 1

ルータ B の設定:内部ルータ

interface ethernet 2
ip address 192.168.1.2 255.255.255.0
 
router ospf 202
network 192.168.0.0 0.0.255.255 area 1

ルータ C の設定:ABR

interface ethernet 3
ip address 192.168.1.3 255.255.255.0
 
interface serial 0
ip address 192.168.2.3 255.255.255.0
 
router ospf 999
network 192.168.1.0 0.0.0.255 area 1
network 192.168.2.0 0.0.0.255 area 0

ルータ D の設定:内部ルータ

interface ethernet 4
ip address 10.0.0.4 255.0.0.0
 
interface serial 1
ip address 192.168.2.4 255.255.255.0
 
router ospf 50
network 192.168.2.0 0.0.0.255 area 0
network 10.0.0.0 0.255.255.255 area 0

ルータ E の設定:ASBR

interface ethernet 5
ip address 10.0.0.5 255.0.0.0
 
interface serial 2
ip address 172.16.1.5 255.255.255.0
 
router ospf 65001
network 10.0.0.0 0.255.255.255 area 0
redistribute bgp 109 metric 1 metric-type 1
 
router bgp 109
network 192.168.0.0
network 10.0.0.0
neighbor 172.16.1.6 remote-as 110

例:ABR の複雑な OSPF 設定

次の設定例では、ABR の設定でいくつかのタスクを実行しています。これらのタスクは 2 つの一般カテゴリに分けられます。

基本的な OSPF 設定

ルートの再配布

この設定で概略を示した個々のタスクについて、次に簡単に説明します。図 7 に、ネットワーク アドレス範囲とインターフェイスのエリア割り当てを示します。

図 7 OSPF 設定例のインターフェイスとエリア仕様

 

この例の基本的な設定作業は、次のとおりです。

イーサネット インターフェイス 0 からイーサネット インターフェイス 3 までのアドレス範囲を設定します。

各インターフェイスで OSPF をイネーブルにします。

各エリアおよび各ネットワークに OSPF 認証パスワードを設定します。

リンクステート メトリックおよびその他の OSPF インターフェイス設定オプションを割り当てます。

エリア ID 36.0.0.0 の スタブ エリア を作成します( area ルータ コンフィギュレーション コマンドの authentication オプションと stub オプションは、別々の area コマンド入力で指定されますが、1 つの area コマンドにまとめることができます)。

バックボーン エリア(エリア 0)を指定します。

再配布に関連した設定タスクを次に示します。

さまざまなオプション( metric-type metric tag 、および subnet など)を設定して、RIP から OSPF への再配布を実行します。

OSPF から RIP への再配布を実行します。

次に、OSPF の設定例を示します。

interface ethernet 0
ip address 192.42.110.201 255.255.255.0
ip ospf authentication-key abcdefgh
ip ospf cost 10
!
interface ethernet 1
ip address 172.19.251.202 255.255.255.0
ip ospf authentication-key ijklmnop
ip ospf cost 20
ip ospf retransmit-interval 10
ip ospf transmit-delay 2
ip ospf priority 4
!
interface ethernet 2
ip address 172.19.254.2 255.255.255.0
ip ospf authentication-key abcdefgh
ip ospf cost 10
!
interface ethernet 3
ip address 10.56.0.0 255.255.0.0
ip ospf authentication-key ijklmnop
ip ospf cost 20
ip ospf dead-interval 80
 

次の設定では、OSPF はネットワーク 172.16.0.0 上にあります。

router ospf 201
network 10.10.0.0 0.255.255.255 area 10.10.0.0
network 192.42.110.0 0.0.0.255 area 192.42.110.0
network 172.16.0.0 0.0.255.255 area 0
area 0 authentication
area 10.10.0.0 stub
area 10.10.0.0 authentication
area 10.10.0.0 default-cost 20
area 192.42.110.0 authentication
area 10.10.0.0 range 10.10.0.0 255.0.0.0
area 192.42.110.0 range 192.42.110.0 255.255.255.0
area 0 range 172.16.251.0 255.255.255.0
area 0 range 172.16.254.0 255.255.255.0
redistribute igrp 200 metric-type 2 metric 1 tag 200 subnets
redistribute rip metric-type 2 metric 1 tag 200
 

次の設定では、IGRP AS 200 は 131.119.0.0 上にあります。

router igrp 200
network 172.31.0.0
!
! RIP for 192.168.110
!
router rip
network 192.168.110.0
redistribute igrp 200 metric 1
redistribute ospf 201 metric 1

例:ルート マップ

ここでは、ルート マップを使用した場合と、使用しない場合の再配布の例を示します。IP および Connectionless Network Service(CLNS)の両方のルーティング プロトコルの例が示されています。

次の例では、すべての OSPF ルートを IGRP に再配布しています。

router igrp 109
redistribute ospf 110
 

次の例では、ホップ カウントが 1 の RIP ルートを OSPF に再配布しています。これらのルートはメトリック 5、メトリック タイプがタイプ 1、タグが 1 の外部 LSA として OSPF に再配布されます。

router ospf 109
redistribute rip route-map rip-to-ospf
!
route-map rip-to-ospf permit
match metric 1
set metric 5
set metric-type type1
set tag 1
 

次の例では、OSPF で学習されたタグ 7 のルートを、RIP メトリック 15 として再配布しています。

router rip
redistribute ospf 109 route-map 5
!
route-map 5 permit
match tag 7
set metric 15
 

次の例では、ネクスト ホップ ルータがシリアル インターフェイス 0 の OSPF intra-area および interarea ルートを、INTER_AS メトリック 5 の BGP に再配布しています。

router bgp 109
redistribute ospf 109 route-map 10
!
route-map 10 permit
match route-type internal
match interface serial 0
set metric 5
 

次の例では、2 つのタイプのルートを(IP と CLNS のいずれもサポートする)統合 IS-IS ルーティング テーブルに再配布しています。最初のタイプはタグ 5 の OSPF 外部 IP ルートです。これらのルートはメトリック 5 のレベル 2 IS-IS LSP に挿入されます。2 番目のタイプは CLNS アクセス リスト 2000 と一致する ISO-IGRP から発生した CLNS プレフィクスです。これらのルートはメトリック 30 のレベル 2 IS-IS LSP に再配布されます。

router isis
redistribute ospf 109 route-map 2
redistribute iso-igrp nsfnet route-map 3
!
route-map 2 permit
match route-type external
match tag 5
set metric 5
set level level-2
!
route-map 3 permit
match address 2000
set metric 30
 

次の設定では、タグ 1、2、3、および 5 の OSPF 外部ルータがそれぞれメトリック 1、1、5、および 5 の RIP に再配布されています。タグ 4 の OSPF ルートは再配布されません。

router rip
redistribute ospf 109 route-map 1
!
route-map 1 permit
match tag 1 2
set metric 1
!
route-map 1 permit
match tag 3
set metric 5
!
route-map 1 deny
match tag 4
!
route map 1 permit
match tag 5
set metric 5
 

次の設定では、ネットワーク 160.89.0.0 に対して RIP で学習されたルートと、プレフィクス 49.0001.0002 の ISP-IGRP で学習されたルートが、メトリック 5 のレベル 2 IS-IS LSP に再配布されます。

router isis
redistribute rip route-map 1
redistribute iso-igrp remote route-map 1
!
route-map 1 permit
match ip address 1
match clns address 2
set metric 5
set level level-2
!
access-list 1 permit 192.168.0.0 0.0.255.255
clns filter-set 2 permit 49.0001.0002...
 

次の設定例では、 default-information ルータ コンフィギュレーション コマンドでルート マップを参照する手順を示しています。このタイプの参照は 条件付きデフォルト発信 と呼ばれます。OSPF は、140.222.0.0 がルーティング テーブルにある場合、タイプ 2、メトリック 5 のデフォルト ルート(ネットワーク 0.0.0.0)を発信します。


) 別個の OSPF プロセスから発生する非 OSPF ルートや OSPF ルートなどの OSPF プロセスに対する外部ルートだけがトラッキングに使用できます。


route-map ospf-default permit
match ip address 1
set metric 5
set metric-type type-2
!
access-list 1 permit 172.16.0.0 0.0.255.255
!
router ospf 109
default-information originate route-map ospf-default

例:OSPF 管理ディスタンスの変更

次の設定では、外部ディスタンスを 200 に変更し、信頼性を下げています。図 8 に例を示します。

図 8 OSPF 管理ディスタンス

 

ルータ A の設定

router ospf 1
redistribute ospf 2 subnet
distance ospf external 200
!
router ospf 2
redistribute ospf 1 subnet
distance ospf external 200

ルータ B の設定

router ospf 1
redistribute ospf 2 subnet
distance ospf external 200
!
router ospf 2
redistribute ospf 1 subnet
distance ospf external 200

例:OSPF over On-Demand ルーティング

次の設定により、オンデマンド回線上で OSPF が、図 9 に示すように使用できるようになります。オンデマンド回線は、ルータ A の BRI 0 サイドだけで定義されていることに注意してください。両サイドに設定する必要はありません。

図 9 OSPF over On-Demand 回路

 

ルータ A の設定

username RouterB password 7 060C1A2F47
isdn switch-type basic-5ess
ip routing
!
interface TokenRing0
ip address 192.168.50.5 255.255.255.0
no shut
!
interface BRI0
no cdp enable
description connected PBX 1485
ip address 192.168.45.30 255.255.255.0
encapsulation ppp
ip ospf demand-circuit
dialer map ip 140.10.10.6 name RouterB broadcast 61484
dialer-group 1
ppp authentication chap
no shut
!
router ospf 100
network 192.168.45.0 0.0.0.255 area 0
network 192.168.45.50 0.0.0.255 area 0
!
dialer-list 1 protocol ip permit

ルータ B の設定

username RouterA password 7 04511E0804
isdn switch-type basic-5ess
ip routing
!
interface Ethernet0
ip address 192.168.50.16 255.255.255.0
no shut
!
interface BRI0
no cdp enable
description connected PBX 1484
ip address 192.168.45.17 255.255.255.0
encapsulation ppp
dialer map ip 192.168.45.19 name RouterA broadcast 61485
dialer-group 1
ppp authentication chap
no shut
!
router ospf 100
network 192.168.45.0 0.0.0.255 area 0
network 192.168.45.50 0.0.0.255 area 0
!
dialer-list 1 protocol ip permit

例:LSA グループ ペーシング

次の例では、LSA グループ間の OSPF ペーシングを 60 秒に変更しています。

router ospf
timers pacing lsa-group 60

例:LSA フラッディングの防止

次に、イーサネット インターフェイス 0 経由で到達可能なブロードキャスト、非ブロードキャスト、ポイントツーポイント ネットワークに OSPF LSA がフラッディングされないようにする例を示します。

interface ethernet 0
ip ospf database-filter all out
 

次の例では、ポイントツーマルチポイント ネットワークの IP アドレス 1.2.3.4 を持つネイバーへの OSPF LSA のフラッディングを防止しています。

router ospf 109
neighbor 10.10.10.45 database-filter all out

例:MOSPF LSA パケットの無視

次に、ルータが MOSPF パケットを受信したときに syslog メッセージの送信を抑止する例を示します。

router ospf 109
ignore lsa mospf

その他の参考資料

関連資料

関連項目
参照先

OSPF で機能するプロトコル非依存の機能

Configuring IP Routing Protocol-Independent Features

OSPF コマンド

Cisco IOS IP Routing: OSPF Command Reference

『Cisco IOS Master Command List, All Releases』

Cisco IOS Master Command List, All Releases

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco ソフトウェア リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 1253

OSPF Version 2 Management Information Base 』(1991 年 8 月)。OSPF MIB は、OSPF に関連する管理情報を提供し、Cisco ルータでサポートされる IP ルーティング プロトコルを定義します。

RFC 1587

The OSPF NSSA Option 』(1994 年 3 月)

RFC 1793

Extending OSPF to Support Demand Circuits 』(1995 年 4 月)

RFC 2328

OSPF Version 2 』(1998 年 4 月)

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html