Cisco Aironet アクセス ポイント Cisco IOS ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.4(3g)JA/12.3(8)JEB
スパニング ツリー プロトコルの設定
スパニング ツリー プロトコルの設定
発行日;2012/01/11 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

スパニング ツリー プロトコルの設定

スパニング ツリー プロトコルの概要

STP の概要

350 シリーズ ブリッジの相互運用性

アクセス ポイント/ブリッジ プロトコル データ ユニット

スパニング ツリー ルートの選択

スパニング ツリー タイマー

スパニング ツリー トポロジの作成

スパニング ツリー インターフェイス ステート

ブロック ステート

リスニング ステート

ラーニング ステート

転送ステート

無効ステート

STP 機能の設定

デフォルトの STP 設定

STP 設定

STP の設定の例

VLAN なしのルート ブリッジ

VLAN なしの非ルート ブリッジ

VLAN ありのルート ブリッジ

VLAN ありの非ルート ブリッジ

スパニング ツリー ステータスの表示

スパニング ツリー プロトコルの設定

この章では、ご使用のアクセス ポイント/ブリッジに Spanning Tree Protocol (STP; スパニング ツリー プロトコル)を設定する方法について説明します。この章の内容は、次のとおりです。

「スパニング ツリー プロトコルの概要」

「STP 機能の設定」

「スパニング ツリー ステータスの表示」


) この章で使用されるコマンドの構文と使用方法の詳細は、このリリースの『Cisco Aironet アクセス ポイント/ブリッジ Cisco IOS コマンド リファレンス』を参照してください。



) STP はアクセス ポイントがブリッジ モードの場合にのみ使用できます。


スパニング ツリー プロトコルの概要

この項では、スパニング ツリー機能の動作について説明します。内容は次のとおりです。

「STP の概要」

「アクセス ポイント/ブリッジ プロトコル データ ユニット」

「スパニング ツリー ルートの選択」

「スパニング ツリー タイマー」

「スパニング ツリー トポロジの作成」

「スパニング ツリー インターフェイス ステート」

STP の概要

STP はレイヤ 2 のリンク管理プロトコルで、ネットワークにおけるループを回避する一方で、パスの冗長性を提供します。レイヤ 2 イーサネット ネットワークは 2 つのステーション間にアクティブ パスが 1 つだけ存在する場合に正しく機能します。スパニング ツリーの動作は端末に対して透過的に実行されるため、端末では単一の LAN セグメントと複数セグメントの LAN のいずれに接続されているかを検出することはできません。

耐障害力のあるインターネットワークを作成する際は、ネットワーク内のすべてのノード間にループのないパスを設定する必要があります。スパニング ツリー アルゴリズムでは、レイヤ 2 ネットワーク全体でループのない最良パスが計算されます。無線アクセス ポイント/ブリッジやスイッチなどのインフラストラクチャ デバイスによって、Bridge Protocol Data Unit (BPDU; ブリッジ プロトコル データ ユニット)と呼ばれるスパニング ツリー フレームが定期的に送受信されます。デバイスはこれらのフレームを転送するのではなく、ループのないパスの構築に使用します。

端末間に複数のアクティブ パスがあると、ネットワーク内でループが発生します。ネットワーク内にループが存在すると、端末でのメッセージの受信に重複が発生します。インフラストラクチャ デバイスでは、複数のレイヤ 2 インターフェイスで端末 MAC アドレスが記憶される場合もあります。このような状況ではネットワークが不安定になります。

STP は、レイヤ 2 ネットワークのルート ブリッジ、およびそのルートからすべてのインフラストラクチャ デバイスへのループのないパスで構成されるツリーを定義します。


) STP に関する説明で使用されるルートという用語は、次の 2 つの概念を意味しています。1 つは、ネットワークのスパニング ツリーにおけるセントラル ポイントとして機能するブリッジで、ルート ブリッジと呼ばれます。もう 1 つは各ブリッジ上のポートの中で最も効率的なパスをルート ブリッジに提供するもので、ルート ポートと呼ばれます。これらの意味は、ルートおよび非ルート オプションが含まれる無線ネットワーク設定のロールとは関連がありません。必ずしも、無線ネットワーク設定におけるロールがルート ブリッジであるブリッジが、スパニング ツリーにおけるルート ブリッジである必要はありません。この章では、スパニング ツリーのルートブリッジをスパニング ツリー ルートと呼びます。


STP は、強制的に冗長データ パスをスタンバイ(ブロック)ステートにします。スパニング ツリー内のネットワーク セグメントに障害が発生し、冗長パスが存在する場合は、スパニング ツリー アルゴリズムによってスパニング ツリー トポロジが再計算され、スタンバイ パスが有効になります。

特定のブリッジ上の 2 つのインターフェイスがループの構成部分である場合、スパニング ツリー ポートの優先順位およびパスのコスト設定によって、転送ステートにされるインターフェイスとブロック ステートにされるインターフェイスが決定されます。ポートの優先順位値は、ネットワーク トポロジにおける各インターフェイスの位置、およびトラフィック転送時の位置の有利性を表します。パス コスト値は、メディアの速度を表します。

アクセス ポイント/ブリッジは、Per-VLAN Spanning Tree (PVST)と VLAN のない単一の 802.1Q スパニング ツリーの両方をサポートします。アクセス ポイント/ブリッジでは、複数の VLAN を 1 インスタンスのスパニング ツリーにマッピングする 802.1S の MST や 802.1D の共通スパニング ツリーを実行することはできません。

アクセス ポイント/ブリッジでは、そこに設定されているアクティブな VLAN のそれぞれで個別のスパニング ツリー インスタンスが管理されます。ブリッジ優先順位で構成されるブリッジ ID およびアクセス ポイント/ブリッジの MAC アドレスが各インスタンスと関連付けられます。VLAN のそれぞれでは、最小値のアクセス ポイント/ブリッジ ID が設定されたアクセス ポイント/ブリッジがその VLAN のスパニング ツリー ルートになります。

350 シリーズ ブリッジの相互運用性

Cisco Aironet 1300 と 350 シリーズ ブリッジは、STP が有効で VLAN が設定されていない場合に相互運用が可能です。下記の理由により、これが唯一使用可能な設定になります。

STP が無効の場合、350 シリーズ ブリッジは 350 シリーズ アクセス ポイントとして機能し、350、1200、1240 シリーズのアクセス ポイントをはじめとした非ルート ブリッジのアソシエーションを禁止します。

350 シリーズ ブリッジでは、非 VLAN および VLAN の設定の双方で単一の STP インスタンスしかサポートされませんが、1300 シリーズ ブリッジの場合、非 VLAN 設定には単一の、VLAN 設定には複数の STP インスタンスがあります。

STP の単一インスタンスと複数インスタンスとの間の非互換性により、VLAN の設定時にトラフィックの不整合ブロックが発生する場合があります。ネイティブ VLAN がブロックされると、ブリッジのフラッピングが発生する場合があります。

このため、350 および 1300 シリーズ アクセス ポイント/ブリッジの STP 機能を有効にして、VLAN を設定しないことが、STP の相互運用性に関して最適な設定になります。


) 350 および 1300 シリーズの アクセス ポイント/ブリッジが、ワークグループ ブリッジとして設定された場合は、STP を無効にして運用し、アクセス ポイントとのアソシエーションを許可することができます。ただし、この設定は技術的にブリッジツーブリッジ シナリオではありません。


アクセス ポイント/ブリッジ プロトコル データ ユニット

ネットワークのスパニング ツリー トポロジの安定性と有効性は、下記の要素で決まります。

各無線アクセス ポイント/ブリッジ上の VLAN のそれぞれに関連付けられた一意のアクセス ポイント/ブリッジ ID (無線アクセス ポイント/ブリッジ優先順位および MAC アドレス)

スパニング ツリー ルートに対するスパニング ツリー パスのコスト

レイヤ 2 インターフェイスのそれぞれに関連付けられたポート ID(ポート優先順位および MAC アドレス)

ネットワーク内でアクセス ポイント/ブリッジに電源が投入されると、アクセス ポイント/ブリッジのそれぞれが STP ルートとして機能します。アクセス ポイント/ブリッジは、イーサネットおよび無線ポートを介して設定 BPDU を送信します。BPDU は、スパニング ツリー トポロジと通信して、その計算を行います。設定 BPDU のそれぞれに、以下の内容が組み込まれます。

送信アクセス ポイント/ブリッジがスパニング ツリー ルートとして識別する無線アクセス ポイント/ブリッジの一意のアクセス ポイント/ブリッジ ID

ルートに対するスパニング ツリー パスのコスト

送信アクセス ポイント/ブリッジのアクセス ポイント/ブリッジ ID

メッセージの経過時間

送信インターフェイスの ID

Hello、転送遅延、および最大経過時間プロトコルの各タイマーの値

アクセス ポイント/ブリッジが 上位 の情報(アクセス ポイント/ブリッジ ID が小さい、パス コストが低い、その他)が組み込まれた設定 BPDU を受信すると、そのポートに関する情報が格納されます。この BPDU がアクセス ポイント/ブリッジのルート ポートで受信されると、アクセス ポイント/ブリッジはこれに更新メッセージを追加して、そのアクセス ポイント/ブリッジが指定されたすべての接続 LAN に転送します。

アクセス ポイント/ブリッジが、現在そのポートに格納されている情報より 下位 の情報が組み込まれた設定 BPDU を受信した場合、その BPDU は廃棄されます。このアクセス ポイント/ブリッジが、受信した下位の BPDU の送信元の LAN に指定されているアクセス ポイント/ブリッジである場合は、そのポートに格納された最新情報が組み込まれた BPDU を LAN に送信します。このようにして、下位の情報が廃棄され、上位の情報がネットワークに伝播されます。

BPDU 交換では次のアクションが発生します。

スパニング ツリー ルートとして 1 つのアクセス ポイント/ブリッジが選択されます。

各アクセス ポイント/ブリッジにルート ポートが 1 つ選択されます(スパニング ツリー ルートを除く)。このポートによって、アクセス ポイント/ブリッジがパケットをスパニング ツリー ルートに転送する際に最適なパス(最小コスト)が提供されます。

パス コストを基準にしてアクセス ポイント/ブリッジのそれぞれに対してスパニング ツリー ルートへの最短距離が算出されます。

各 LAN セグメントに指定アクセス ポイント/ブリッジが選択されます。指定アクセス ポイント/ブリッジは、LAN からスパニング ツリー ルートにパケットを転送する際のパス コストが最小になります。指定アクセス ポイント/ブリッジを LAN に接続する際に使用されるポートは、指定ポートと呼ばれます。

スパニング ツリー インスタンスに含まれるインターフェイスが選択されます。ルート ポートと指定ポートは転送ステートに移行します。

スパニング ツリー インスタンスに含まれないインターフェイスはすべてブロックされます。

スパニング ツリー ルートの選択

STP に参加しているレイヤ 2 ネットワークのアクセス ポイント/ブリッジはすべて、BPDU データ メッセージの交換によってネットワーク内の他のアクセス ポイント/ブリッジに関する情報を収集します。このメッセージ交換では次のアクションが発生します。

スパニング ツリーインスタンスのそれぞれに対する一意のスパニング ツリー ルートの選択

すべての LAN セグメントの指定アクセス ポイント/ブリッジの選択

冗長リンクに接続されたレイヤ 2 インターフェイスをブロックすることによる、ネットワーク内のループの削除

VLAN のそれぞれに対して、最上位のアクセス ポイント/ブリッジ優先順位(優先順位値が最小数値)のアクセス ポイント/ブリッジがスパニング ツリー ルートとして選択されます。すべてのアクセス ポイント/ブリッジにデフォルトの優先順位(32768)が設定されている場合、VLAN の MAC アドレスが最小値のアクセス ポイント/ブリッジがスパニング ツリー ルートになります。アクセス ポイント/ブリッジの優先順位値は、アクセス ポイント/ブリッジ ID の最上位ビットを占有します。

アクセス ポイント/ブリッジの優先順位値を変更すると、そのアクセス ポイント/ブリッジがルート アクセス ポイント/ブリッジとして選択される確率を変更することになります。大きい値を設定すると確率が下がり、小さい値を設定すると確率が上がります。

スパニング ツリー ルートはスパニング ツリー トポロジの論理的な中心です。ネットワーク内のあらゆる場所からスパニング ツリー ルートへの到達に不要なパスのすべてに、スパニング ツリー ブロック モードが設定されます。

BPDU には、送信アクセス ポイント/ブリッジおよびそのポートに関する情報が、アクセス ポイント/ブリッジおよび MAC アドレス、アクセス ポイント/ブリッジ優先順位、ポート優先順位、およびパス コストも含めて格納されます。STP はこの情報を使用して、ネットワークのスパニング ツリー ルートとルート ポート、および各 LAN セグメントのルート ポートと指定ポートを選択します。

スパニング ツリー タイマー

表8-1 は、スパニング ツリーのパフォーマンス全体に影響するタイマーを示しています。

 

表8-1 スパニング ツリー タイマー

変数
説明

Hello タイマー

アクセス ポイント/ブリッジが他のアクセス ポイント/ブリッジに Hello メッセージをブロードキャストする頻度を決定します。

転送遅延タイマー

インターフェイスが転送を開始するまでのリスニング ステートおよびラーニング ステートのそれぞれの継続期間を決定します。

最大経過時間タイマー

アクセス ポイント/ブリッジがインターフェイスで受信したプロトコル情報を格納する時間を決定します。

スパニング ツリー トポロジの作成

図8-1 では、すべてのアクセス ポイント/ブリッジの優先順位がデフォルト(32768)に設定され、ブリッジ 4 に最小値の MAC アドレスが設定されているため、ブリッジ 4 がスパニング ツリー ルートに選択されます。ただし、トラフィック パターン、転送インターフェイス数、リンクタイプなどの面でブリッジ 4 が最適なスパニング ツリー ルートでない場合もあります。最適なブリッジがスパニング ツリー ルートになるように、その優先順位を上げることで(数値を小さくする)、スパニング ツリーの再計算を強制実行し、最適なブリッジがスパニング ツリー ルートに設定された新しいトポロジを構成します。

図8-1 スパニング ツリー トポロジ

 

スパニング ツリー インターフェイス ステート

プロトコル情報が無線 LAN を通過する際に伝播遅延が発生することがあります。これにより、ネットワーク内ではさまざまな時点および場所でトポロジの変更が実行される場合があります。特定のインターフェイスがスパニング ツリー トポロジで非参加の状態から転送ステートに直接移行すると、一時的なデータ ループが発生する場合があります。インターフェイスは、LAN を介して新しいトポロジ情報が伝播されるまで待機し、その後フレームの転送を開始します。古いトポロジを使用して転送されたフレームのフレーム有効期間を終了できるようにする必要があります。

スパニング ツリーを使用するアクセス ポイント/ブリッジ上のインターフェイスのそれぞれには、次のいずれかのステートが設定されます。

ブロック:インターフェイスはフレーム転送に参加しません。

リスニング:インターフェイスがフレーム転送に参加することがスパニング ツリーによって決定される、ブロック ステート後の最初の遷移状態です。

ラーニング:インターフェイスではフレーム転送への参加の準備が行われます。

転送:インターフェイスによってフレームが転送されます。

無効:ポートのシャットダウン、ポート上にリンクがない、ポート上でスパニング ツリー インスタンスが実行されていないなどの理由により、インターフェイスがスパニング ツリーに参加していません。

インターフェイスはこれらのステート間を次のように移動します。

初期化からブロックへ

ブロックからリスニングまたは無効へ

リスニングからラーニングまたは無効へ

ラーニングから転送または無効へ

転送から無効へ

図8-2 は、インターフェイスのステート間の移動を示しています。

図8-2 スパニング ツリー インターフェイス ステート

 

アクセス ポイント/ブリッジ上の STP を有効にすると、イーサネット インターフェイスおよび無線インターフェイスはブロック ステート、およびリスニングとラーニングの一時的なステートに移行します。スパニング ツリーは各インターフェイスを転送ステートまたはブロック ステートに安定させます。

スパニング ツリー アルゴリズムによってレイヤ 2 インターフェイスに転送ステートが設定されると、次のプロセスが発生します。

1. スパニング ツリーがインターフェイスをブロック ステートに移行するプロトコル情報を待っている間、そのインターフェイスはリスニング ステートになります。

2. スパニング ツリーは転送遅延タイマーの期限が切れるのを待っている間にインターフェイスをラーニング ステートに移行して、転送遅延タイマーをリセットします。

3. ラーニング ステートでは、アクセス ポイント/ブリッジによって転送データベースの端末の位置情報が記憶されるため、インターフェイスではフレーム転送のブロックが続行されます。

4. スパニング ツリーは転送遅延タイマーの期限が切れると、インターフェイスを転送ステートに移行し、ラーニングとフレーム転送の両方が有効化されます。

ブロック ステート

ブロック ステートのインターフェイスはフレーム転送に参加しません。初期化した後、BPDU がアクセス ポイント/ブリッジのイーサネットまたは無線ポートに送信されます。初期のアクセス ポイント/ブリッジは、他のアクセス ポイント/ブリッジと BPDU を交換するまでスパニング ツリー ルートとして機能します。この交換によって、ネットワーク内のどのアクセス ポイント/ブリッジがスパニング ツリー ルートであるかが確定されます。ネットワーク内にアクセス ポイント/ブリッジが 1 つしかない場合は、交換が行われず、転送遅延タイマーの期限が切れて、インターフェイスがリスニング ステートに移行します。STP を有効にすると常にインターフェイスがブロック ステートになります。

ブロック ステートのインターフェイスは、次のように機能します。

ポート上で受信したフレームを廃棄します。

アドレスのラーニングは行いません。

BPDU を受信します。


) アクセス ポイント/ブリッジポートがブロックされた場合、ブロードキャスト パケットまたはマルチキャスト パケットの一部がアクセス ポイント/ブリッジ上の転送ポートに到達し、ブリッジング ロジックによって一時的にブロック ポートをリスニング ステートに切り替えてから、ブロック ポートでパケットの廃棄が行われます。


リスニング ステート

リスニング ステートは、インターフェイスのブロック ステート後の最初のステートです。インターフェイスのフレーム転送への参加が STP によって決定されると、インターフェイスはこのステートになります。

リスニング ステートのインターフェイスは、次のように機能します。

ポート上で受信したフレームを廃棄します。

アドレスのラーニングは行いません。

BPDU を受信します。

ラーニング ステート

ラーニング ステートのインターフェイスはフレーム転送に参加する準備を行います。インターフェイスはリスニング ステートからラーニング ステートに移行します。

ラーニング ステートのインターフェイスは、次のように機能します。

ポート上で受信したフレームを廃棄します。

アドレスを記憶します。

BPDU を受信します。

転送ステート

転送ステートのインターフェイスは、フレームを転送します。インターフェイスはラーニング ステートから転送ステートに移行します。

転送ステートのインターフェイスは、次のように機能します。

ポート上で受信したフレームをの受信および転送を行います。

アドレスを記憶します。

BPDU を受信します。

無効ステート

無効ステートのインターフェイスはフレーム転送やスパニング ツリーに参加しません。無効ステートのインターフェイスは、動作しません。

無効インターフェイスは以下のように実行します。

ポート上で受信したフレームを廃棄します。

アドレスのラーニングは行いません。

BPDU を受信しません。

STP 機能の設定

アクセス ポイント/ブリッジで STP を設定するには、次の 3 つの主要手順を実行します。

1. 必要に応じて、インターフェイスおよびサブインターフェイスをブリッジ グループに割り当てます。

2. 各ブリッジ グループの STP を有効にします。

3. 各ブリッジ グループの STP 優先順位を設定します。

スパニング ツリーの設定情報は、次の項に記載されています。

「デフォルトの STP 設定」

「STP 設定」

「STP の設定の例」

デフォルトの STP 設定

STP はデフォルトで無効になっています。 表8-2 は、STP 有効化時のデフォルト STP 設定のリストです。

 

表8-2 STP 有効化時のデフォルト STP 値

設定
デフォルト値

ブリッジ優先順位

32768

ブリッジ最大経過期間

20

ブリッジ Hello 時間

2

ブリッジ転送遅延

15

イーサネットポートのパス コスト

19

イーサネット ポートの優先順位

128

無線ポートのパス コスト

33

無線ポートの優先順位

128

アクセス ポイント/ブリッジの無線インターフェイス、イーサネット インターフェイス、およびネイティブ VLAN は、デフォルトでブリッジ グループ 1 に割り当てられています。STP を有効にしてブリッジ グループ 1 に優先順位を割り当てると、無線インターフェイス、イーサネット インターフェイスおよびプライマリ VLAN の STP が有効になり、これらのインターフェイスでブリッジ グループ 1 に割り当てられた優先順位が採用されます。サブインターフェイスにブリッジ グループを作成して、これらのブリッジ グループに異なる STP 設定を割り当てることができます。

STP 設定

特権 EXEC モードから、次の手順に従ってアクセス ポイント/ブリッジの STP を設定します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface { dot11radio number | fastethernet number }

無線インターフェイス、イーサネット インターフェイス、またはサブインターフェイスのインターフェイス設定モードを開始します。

ステップ 3

bridge-group number

インターフェイスをブリッジ グループに割り当てます。ブリッジ グループには 1 ~ 255 の番号を設定できます。

ステップ 4

no bridge-group number spanning-disabled

ブリッジ グループの STP を自動的に無効にするコマンドを無効にします。STP は bridge n protocol ieee コマンドを入力するとインターフェイス上で有効になります。

ステップ 5

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

bridge number protocol ieee

ブリッジ グループの STP を有効にします。bridge-group コマンドで作成したブリッジ グループのそれぞれで、STP を有効にする必要があります。

ステップ 7

bridge number priority priority

(オプション)ブリッジ グループに優先順位を割り当てます。優先順位値が小さいブリッジは、スパニング ツリー ルートになる確率が高くなります。

ステップ 8

end

特権 EXEC モードに戻ります。

ステップ 9

show spanning-tree bridge

入力内容を確認します。

ステップ 10

copy running-config startup-config

(オプション)コンフィギュレーション ファイルに入力内容を保存します。

STP の設定の例

この設定例では、アクセス ポイント/ブリッジ上で STP を有効にする方法を紹介し、ルートの場合、非ルートの場合、VLAN ありの場合、なしの場合のそれぞれの例を示しています。

「VLAN なしのルート ブリッジ」

「VLAN なしの非ルート ブリッジ」

「VLAN ありのルート ブリッジ」

「VLAN ありの非ルート ブリッジ」

VLAN なしのルート ブリッジ

次は、VLAN の設定がなく、STP が有効のルート ブリッジの設定例です。

 
hostname master-bridge-south
ip subnet-zero
!
bridge irb
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid tsunami
authentication open
guest-mode
!
speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
rts threshold 2312
station-role root
no cdp enable
infrastructure-client
bridge-group 1
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1
!
interface BVI1
ip address 1.4.64.23 255.255.0.0
no ip route-cache
!
ip default-gateway 1.4.0.1
bridge 1 protocol ieee
bridge 1 route ip
bridge 1 priority 9000
!
line con 0
exec-timeout 0 0
line vty 0 4
login
line vty 5 15
login
!
end
 

VLAN なしの非ルート ブリッジ

次は、VLAN の設定がなく、STP が有効の非ルート ブリッジの設定例です。

 
hostname client-bridge-north
ip subnet-zero
!
bridge irb
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid tsunami
authentication open
guest-mode
!
speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
rts threshold 2312
station-role non-root
no cdp enable
bridge-group 1
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1 path-cost 40
!
interface BVI1
ip address 1.4.64.24 255.255.0.0
no ip route-cache
!
bridge 1 protocol ieee
bridge 1 route ip
bridge 1 priority 10000
!
line con 0
line vty 0 4
login
line vty 5 15
login
!
end
 

VLAN ありのルート ブリッジ

次は、VLAN が設定され、STP が有効のルート ブリッジの設定例です。

 
hostname master-bridge-hq
!
ip subnet-zero
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
bridge irb
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid vlan1
vlan 1
infrastructure-ssid
authentication open
!
speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
rts threshold 2312
station-role root
no cdp enable
infrastructure-client
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no ip route-cache
no cdp enable
bridge-group 1
!
interface Dot11Radio0.2
encapsulation dot1Q 2
no ip route-cache
no cdp enable
bridge-group 2
!
interface Dot11Radio0.3
encapsulation dot1Q 3
no ip route-cache
bridge-group 3
bridge-group 3 path-cost 500
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
!
interface FastEthernet0.2
encapsulation dot1Q 2
no ip route-cache
bridge-group 2
!
interface FastEthernet0.3
encapsulation dot1Q 3
no ip route-cache
bridge-group 3
!
interface BVI1
ip address 1.4.64.23 255.255.0.0
no ip route-cache
!
ip default-gateway 1.4.0.1
bridge 1 protocol ieee
bridge 1 route ip
bridge 1 priority 9000
bridge 2 protocol ieee
bridge 2 priority 10000
bridge 3 protocol ieee
bridge 3 priority 3100
!
line con 0
exec-timeout 0 0
line vty 5 15
!
end

VLAN ありの非ルート ブリッジ

次は、VLAN が設定され、STP が有効の非ルート ブリッジの設定例です。

 
hostname client-bridge-remote
!
ip subnet-zero
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
bridge irb
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid vlan1
vlan 1
authentication open
infrastructure-ssid
!
speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
rts threshold 2312
station-role non-root
no cdp enable
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no ip route-cache
no cdp enable
bridge-group 1
!
interface Dot11Radio0.2
encapsulation dot1Q 2
no ip route-cache
no cdp enable
bridge-group 2
!
interface Dot11Radio0.3
encapsulation dot1Q 3
no ip route-cache
no cdp enable
bridge-group 3
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
!
interface FastEthernet0.2
encapsulation dot1Q 2
no ip route-cache
bridge-group 2
!
interface FastEthernet0.3
encapsulation dot1Q 3
no ip route-cache
bridge-group 3
bridge-group 3 path-cost 400
!
interface BVI1
ip address 1.4.64.24 255.255.0.0
no ip route-cache
!
bridge 1 protocol ieee
bridge 1 route ip
bridge 1 priority 10000
bridge 2 protocol ieee
bridge 2 priority 12000
bridge 3 protocol ieee
bridge 3 priority 2900
!
line con 0
line vty 5 15
!
end

スパニング ツリー ステータスの表示

スパニング ツリー ステータスを表示するには、 表8-3 に示された特権 EXEC コマンドのいずれかを使用します。

 

表8-3 スパニング ツリー ステータスの表示コマンド

コマンド
目的

show spanning-tree

ネットワークのスパニング ツリー情報を表示します。

show spanning-tree blocked-ports

ブリッジ上のブロック ポートのリストを表示します。

show spanning-tree bridge

ブリッジのステータスおよび設定を表示します。

show spanning-tree active

アクティブ インターフェイスのみのスパニング ツリー情報を表示します。

show spanning-tree root

スパニング ツリー ルートの情報の詳細要約を表示します。

show spanning-tree interface interface-id

指定インターフェイスのスパニング ツリー情報を表示します。

show spanning-tree summary [ totals ]

ポート ステートの要約、または STP ステート部分の合計行を表示します。

show spanning-tree 特権 EXEC コマンドのその他のキーワードについては、このリリースの『Cisco Aironet アクセス ポイント/ブリッジ Cisco IOS コマンド リファレンス』を参照してください。