Cisco Unity Express CLI アドミニストレータ ガイド Cisco CallManager Release 2.1
Cisco Unity Express ソフトウェアの 設定
Cisco Unity Express ソフトウェアの設定
発行日;2012/01/10 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

Cisco Unity Express ソフトウェアの設定

前提条件

新規 Cisco Unity Express ソフトウェア パッケージの設定

Cisco Unity Express ソフトウェアへの IP 接続のアクティブ化

前提条件

次の作業

EXEC モードと設定モード

コマンド環境の開始

前提条件

次の作業

コマンド環境の終了

Cisco Unity Express ソフトウェアの設定

Cisco CallManager と Cisco Unity Express のすべてのハードウェアおよび Cisco CallManager ソフトウェアのインストールを完了したら、Cisco Unity Express ソフトウェアを設定します。この章では、次の設定情報と手順について説明します。

「前提条件」

「新規 Cisco Unity Express ソフトウェア パッケージの設定」

「Cisco Unity Express ソフトウェアへの IP 接続のアクティブ化」

「EXEC モードと設定モード」

「コマンド環境の開始」

「コマンド環境の終了」

前提条件

Cisco Unity Express の設定を開始する前に、Cisco CallManager システムをインストールしておく必要があります。Cisco CallManager のインストールを実行しなかった、または現在実行していない場合は、インストールの担当者、またはその他のサポート担当者に問い合せて次の手順が完了しているかどうかを確認してください。

1. (必須)Cisco CallManager および Cisco Unity Express のハードウェアをすべてインストールし、機能を検証します。

a. 電話機を接続して Cisco CallManager サーバに登録します。

b. Cisco CallManager サーバに、Network Module(NM; ネットワーク モジュール)の設定をサポートする Cisco IOS Release 12.3(4)T 以降のリリースまたは Advanced Integration Module(AIM; 拡張統合モジュール)の設定をサポートする Cisco IOS Release 12.3(7)T 以降のリリースが構成されていることを確認します。

c. NM の場合は、Enable LED が点灯していることを確認します。


) Cisco Unity Express モジュールが格納されているルータには、Uninterruptible Power Supply(UPS; 無停電電源)を接続することを強くお勧めします。信頼性の高い UPS ユニットを使用すると、ルータおよび Cisco Unity Express モジュールの運用を維持するための電力を継続的に得ることができます。電力消費は Cisco プラットフォームによって異なるため、ユニットのキャパシティおよび実行時間を考慮してください。UPS には、ルータにCisco Unity Express を正しくシャットダウンさせてからルータの電源を切るシグナリング メカニズムが備えられている必要があります。

次の設定がルータに追加されている場合、Cisco IOS Release 12.3(4)T は、UPS デバイスへの自動切り替えをサポートします。

line aux 0
privilege level 15
modem Dialin
autocommand service-module service-engine slot/0 shutdown no-confirm

ここで slot は Cisco Unity Express モジュールのスロット番号です。


2. (必須)Cisco CallManager ソフトウェアをインストールし、機能を検証します。

a. Cisco CallManager 設定 Web ページにアクセスできることが必要です。

b. service-engine インターフェイス上に ip unnumbered コマンドを設定するには、Cisco IOS ソフトウェアのコマンドをルータに対して実行して、Cisco Unity Express モジュールへのスタティック ルートを作成します。次に例を示します。

ip route 10.3.6.128 255.255.255.255 Service-Engine1/0
 

この例では、10.3.6.128 は Cisco Unity Express モジュールの IP アドレスで、Service-Engine1/0 は Cisco Unity Express モジュールのホストであるルータ スロットです。

c. NM の場合は、Cisco CallManager に 8 つの CTI ポートを設定します。AIM の場合は、Cisco CallManager に 4 つの CTI ポートを設定します。Cisco CallManager オプションの Device > Phones > Add new Phone を使用します。これらのポートは、通話を終了するために、Cisco Unity Express アプリケーション(ボイスメール、自動受付、および Administration via Telephone [AvT])に割り当てられます。


) Cisco CallManager に、過剰な CTI ポートを設定しないでください。過剰な CTI ポートを設定すると、Cisco CallManager のスケーラビリティに影響し、Cisco CallManager がサポートすることのできる他のデバイス数が制限されます。


d. Device > CTI Route Point オプションを使用して、Cisco CallManager に最低 2 つのルート ポイントを設定します。Cisco Unity Express のボイスメール アプリケーションが一方のルート ポイントを使用し、自動受付アプリケーションが他方のルート ポイントを使用します。Cisco Unity Express AvT を使用する予定の場合は、Cisco CallManager に 3 番目のルート ポイントを設定してください。


) Cisco CallManager に、過剰なルート ポイントを設定しないでください。過剰なルート ポイントを設定すると、Cisco CallManager のスケーラビリティに影響し、Cisco CallManager がサポートすることのできる他のデバイス数が制限されます。


e. User > Add new user オプションを使用して、Cisco CallManager の JTAPI ユーザを作成します。Device Association オプションを使用して、この JTAPI ユーザに CTI ポートとルート ポイントを関連付けます(JTAPI ユーザには、Cisco Unity Express ボイスメールボックスが割り当てられません。JTAPI ユーザは、Cisco CallManager への接続を確立するための Cisco Unity Express のプレースホルダーです)。Enable CTI Application Use チェックボックスが、この JTAPI ユーザに対してオンになっていることを確認します。

f. Cisco Unity Express ソフトウェアのインストール時に、Cisco Unity Express の管理者ユーザ ID とパスワードを作成し、DNS サーバと NTP サーバの IP アドレスを指定します。このユーザ ID とパスワードは、初期化ウィザードにログインするときに必要になります。

g. 通話の処理が効率的に行われるように、Cisco Unity Express ルータにアクセス リストを設定して、JTAPI トラフィックに優先順位を付けます。次の例を参考にしてください。

class-map match-all jtapi
match access-group 110
class-map match-all voice
match access-group 100
 
policy-map jtapi
class jtapi
set dscp cs3
bandwidth 20
class voice
set dscp af31
priority 320
class class-default
fair-queue
 
interface Serial0/1
ip address 192.168.10.0 255.255.255.0
service-policy output jtapi
clockrate 256000
no cdp enable
 
access-list 100 permit udp host 10.3.6.128 any range 16383 32727
access-list 110 permit tcp host 10.3.6.128 any eq 2748
 

ここで、10.3.6.128 は、Cisco Unity Express が格納されているモジュールの IP アドレスです。

show policy-map interface コマンドの出力は、マーク付きパケットの数が増加していることを指し示す必要があります。次の例を参考にしてください。

Match: access-group 110
QoS Set
dscp cs3
Packets marked 334 <-----This number should increase.
 

3. (必須)Cisco Unity Express と通信する FTP サーバは、パッシブ FTP 要求をサポートしている必要があります。この機能を FTP サーバに設定する方法については、FTP サーバのマニュアルを参照してください。

4. (オプション)Cisco CallManager インターフェイスにユーザが作成されていない場合、すべてのユーザ、グループ、およびユーザとグループの内線番号のリストを作成します。このリストにより、多くのユーザと内線番号を簡単に設定できます。

5. (オプション)自動受付アプリケーションのオプション初期メッセージを作成します。自動受付には、デフォルトの初期メッセージが用意されています。別のメッセージを .wav ファイルで作成し、そのファイルを自動受付の設定の一部としてインストールできます。詳細については、 自動受付グリーティングまたはプロンプト ファイルの録音を参照してください。

6. (オプション)ビジネスの要件に合せて自動受付プロンプトのシーケンスをカスタマイズします。詳細については、 自動受付スクリプトの設定を参照してください。

7. (必須)Cisco Unity Express モジュールの IP アドレスを記録します。システムを構成するために GUI にアクセスするには、この IP アドレスが必要です。

新規 Cisco Unity Express ソフトウェア パッケージの設定

Cisco Unity Express を注文すると、Cisco Unity Express ソフトウェアと購入済みライセンスがモジュールにインストールされた状態で工場から出荷されます。予備のモジュールも、ソフトウェアとライセンスがインストールされた状態で付属します。

新規にインストールした Cisco Unity Express を設定するには、次の手順を実行する必要があります。

1. モジュールとルータ間の IP アドレス指定を設定します。Cisco Unity Express ソフトウェアへの IP 接続のアクティブ化を参照してください。

2. Cisco Unity Express ソフトウェアの設定を開始します。 設定タスクを参照してください。

Cisco Unity Express ソフトウェアへの IP 接続のアクティブ化

Cisco Unity Express モジュールをインストールしたら、Cisco CallManager と Cisco Unity Express アプリケーション間の IP 通信リンクをアクティブにします。

前提条件

ソフトウェアをアクティブにするために必要な情報は次のとおりです。

Cisco Unity Express のホストである Cisco IOS ルータ上の Cisco Unity Express モジュールのスロット番号とユニット番号。

Cisco Unity Express のホストである Cisco IOS ルータの IP アドレスとサブネット マスク、または unnumbered インターフェイスのタイプと番号。

Cisco Unity Express モジュールの IP アドレス。この IP アドレスは、Cisco Unity Express のホストである Cisco IOS ルータと同じサブネット上にある必要があります。

Cisco Unity Express ルータのデフォルト ゲートウェイの IP アドレス。この IP アドレスは、Cisco Unity Express のホストである Cisco IOS ルータと同じ IP アドレスである必要があります。

概略手順

1. interface Service-Engine slot / unit

2. ip address router-ip-addr subnet-mask
または、
ip unnumbered type number

3. service-module ip address cue-side-ip-addr subnet-mask

4. service-module ip default-gateway gw-ip-addr

5. exit

詳細手順

 

コマンドまたは操作
目的

ステップ 1

interface Service-Engine slot / unit
 
Router(config)# interface Service-Engine 2/0

インターフェイス設定モードを開始します。

ステップ 2

ip address router-ip-addr subnet-mask
 
ip unnumbered type number
 
Router(config-if)# ip address 172.16.231.195 255.255.0.0
 

または、

 
Router(config-if)# ip unnumbered FastEthernet 0/0

Cisco Unity Express のホストである Cisco IOS ルータの IP アドレスとサブネットを指定します。

Cisco Unity Express のホストである Cisco IOS ルータのインターフェイス タイプと番号を指定します。

ステップ 3

service-module ip address cue-side-ip-addr subnet-mask
 
Router(config-if)# service-module ip address 172.16.231.190 255.255.0.0

Cisco Unity Express モジュール インターフェイスの IP アドレスを指定します。この IP アドレスは、Cisco Unity Express のホストである Cisco IOS ルータと同じサブネット上にある必要があります。

ステップ 4

service-module ip default-gateway gw-ip-add r
 
Router(config-if)# service-module ip default-gateway 172.16.231.195

Cisco Unity Express のホストである Cisco IOS ルータの IP アドレスを指定します。

ステップ 5

exit
 

Router(config-if)# exit

インターフェイス設定モードを終了します。

次の例は、IP 接続をアクティブにする手順を示しています。

Router(config)# interface Service-Engine 1/0
Router(config-if)# ip address 10.0.0.9 255.0.0.0
Router(config-if)# service-module ip address 10.0.0.10 255.0.0.0
Router(config-if)# service-module ip default-gateway 10.0.100.10
Router(config-if)# exit
 

次の作業

Cisco Unity Express モジュールへの接続を設定したら、Cisco Unity Express コマンド環境を開始し、アプリケーションの設定を開始します。コマンド環境の開始を参照してください。

EXEC モードと設定モード

Cisco Unity Express コマンドの EXEC モードおよび設定モードは、Cisco IOS CLI コマンドの EXEC モードおよび設定モードと同様に動作します。ただし、Cisco Unity Express EXEC モードでは一部のパラメータを設定または変更できますが、Cisco IOS EXEC モードでは許可されていません。この Cisco Unity Express 機能を使用して、設定したパラメータをフラッシュ メモリに保存できます。フラッシュ メモリへの保存により、ディスク クラッシュなどの深刻な障害が発生した場合に利用できる最小限の情報がシステムに保持されます。このマニュアルの各コマンドの説明では、コマンド モードを示しています。

コマンド環境の開始

Cisco Unity Express ソフトウェアをインストールし、アクティブにしたら、次の手順を実行してコマンド環境を開始します。

前提条件

Cisco Unity Express ソフトウェアの新規インストールの場合は、この手順を開始する前に、前提条件および Cisco Unity Express ソフトウェアへの IP 接続のアクティブ化を参照してください。

コマンド環境の開始に必要な情報は次のとおりです。

Cisco Unity Express モジュールが格納されているルータの IP アドレス

ルータにログインするためのユーザ名とパスワード

モジュールのスロット番号

概略手順

1. telnet セッションを開きます。

2. telnet ip-address

3. ルータのユーザ ID とパスワードを入力します。

4. service-module service-engine slot/port session

5. enable

詳細手順

 

コマンドまたは操作
目的

ステップ 1

telnet セッションを開きます。

DOS ウィンドウ、セキュア シェル、またはソフトウェア エミュレーション ツール(Reflection など)を使用します。

ステップ 2

telnet ip-address
 
C:\> telnet 172.16.231.195

Cisco CallManager ルータの IP アドレスを指定します。

ステップ 3

Username:
Password:

ルータに対するユーザ ID とパスワードを入力します。

ステップ 4

service-module service-engine slot/port session
 
Router# service-module service-engine 1/0 session

スロットとポートに配置されているモジュールを使用して、Cisco Unity Express コマンド環境を開始します。プロンプトが「se」に変わり、Cisco Unity Express モジュールの IP アドレスが表示されます。

メッセージ
「Trying ip-address slot/port ...
Connection refused by remote host
が表示された場合は、次のコマンドを入力します。
service-module service-engine slot/port session clear
次に、ステップ 4 を再実行します。

ステップ 5

enable
 

se-10-0-0-0# enable

Cisco Unity Express EXEC モードを開始します。これで、設定タスクを開始できます。

次の作業

設定タスクを参照してください。

コマンド環境の終了

Cisco Unity Express コマンド環境を離れ、ルータのコマンド環境に戻る必要がある場合は、以下の手順に従います。

概略手順

1. Cisco Unity Express EXEC モードに戻ります。

2. CTRL キー、 SHIFT キー、 6 キーを同時に押してから、小文字の x を入力します。

詳細手順

 

コマンドまたは操作
目的

ステップ 1

exit
 

se-10-0-0-0(config)# exit

se-10-0-0-0#

設定モードの exit コマンドを使用して、EXEC モードに戻ります。

ステップ 2

CTRL-SHIFT-6 x
 
se-10-0-0-0# CTRL-SHIFT-6 x
Router#

CTRL キー、 SHIFT キー、 6 キーを同時に押してから、小文字の x を入力します。


) Cisco IOS Release 12.3(11)T 以降の場合は、代わりに EXIT コマンドを使用します。