Cisco Unified SRST システム アドミニストレーション ガイド
ネットワークの設定
ネットワークの設定
発行日;2012/01/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

ネットワークの設定

内容

ネットワークの設定について

ネットワークの設定方法

IP ルーティングの有効化

MGCP ゲートウェイでの SRST の有効化

Cisco IOS Release 12.3(14)T 以前の MGCP ゲートウェイにおける SRST の設定

Cisco IOS Release 12.3(14)T 以降の MGCP ゲートウェイにおける SRST の設定

制約事項

Cisco IOS Release 12.3(14)T を使用する MGCP ゲートウェイで SRST を有効にする設定の例

Cisco Unified SRST Phone に対する DHCP の設定

単一の DHCP IP アドレス プールを定義する

各 Cisco Unified IP Phone に対する個別の DHCP IP アドレス プールを定義する

DHCP リレー サーバを定義する

キープアライブ インターバルの指定

電話機能をサポートするための Cisco Unified SRST の設定

Cisco Unified SRST が有効になっていることの確認

トラブルシューティング

関連情報

ネットワークの設定

Revised: July 11, 2008

この章では、Cisco Unified Survivable Remote Site Telephony(SRST)ルータが DHCP を実行し、Cisco Unified Communications Manager のフォールバック時に IP Phone と通信するように設定する方法について説明します。

ネットワークの設定について

WAN リンクに障害が発生した場合、Cisco Unified IP Phone は、Cisco Unified Communications Manager からキープアライブ パケットが受信されなくなったことを検出します。次に、Cisco Unified IP Phone はルータに登録します。Cisco Unified SRST ソフトウェアが自動的にアクティブになり、接続されている Cisco Unified IP Phone すべて(設定された最大数まで)のローカル データベースを作成します。IP Phone は、セントラル Cisco Unified Communications Manager がキープアライブ パケットに確認応答しない場合には、バックアップのコール処理ソースとしてルータに対して問い合せを行うように設定されます。これで、Cisco Unified SRST ルータが、コールの設定、処理、保持、および終了を実行するようになります。

Cisco Unified Communications Manager は、DHCP を使用して、Cisco Unified IP Phone に Cisco Unified Communications Manager の IP アドレスを提供します。リモートのブランチ オフィスでは、DHCP サービスは、通常、SRST ルータ自体または DHCP リレーを実行する Cisco Unified SRST ルータによって提供されます。DHCP を設定することは、ネットワーク通信を設定する 2 つの主要な作業の 1 つです。もう 1 つの作業は、Cisco Unified SRST ルータが特定の IP アドレスを通じて Cisco IP Phone からメッセージを受信するように設定することです。キープアライブ インターバルもこの段階で設定されます。

ネットワークの設定方法

ここでは、次の作業について説明します。

「IP ルーティングの有効化」(必須)

MGCP ゲートウェイでの SRST の有効化 (必須)

「Cisco Unified SRST Phone に対する DHCP の設定」(必須)

「キープアライブ インターバルの指定」(オプション)

「電話機能をサポートするための Cisco Unified SRST の設定」(必須)

「Cisco Unified SRST が有効になっていることの確認」(オプション)

IP ルーティングの有効化

IP ルーティングの有効化については、『 Configuring IP Addressing 』を参照してください。

MGCP ゲートウェイでの SRST の有効化

MGCP ゲートウェイで SRST をフォールバック モードとして使用するには、SRST および MGCP フォールバックの両方を同じゲートウェイに設定する必要があります。下記のように設定すると、SRST が、音声ポートの制御権と MGCP ゲートウェイでのコール処理の制御権を取得できるようになります。Cisco IOS Release 12.3(14)T でコマンドが変更されているため、インストールした Cisco IOS リリースに対応する設定作業を実行してください。


) 下記の設定に記載されているコマンドは、両方とも設定されている場合に限り有効となります。たとえば、ccm-manager fallback-mgcp コマンドだけを設定した場合、設定は動作しません。



) MGCP によって制御される PRI が SRST モードに移行した場合は、ルータ上で設定を変更したり、設定の変更を NVRAM に保存したりしないでください。SRST モードで設定を変更して保存した場合、通常の MGCP 動作が回復すると、MGCP によって制御される PRI に障害が発生します。


Cisco IOS Release 12.3(14)T 以前の MGCP ゲートウェイにおける SRST の設定

Cisco IOS Release 12.3(14)T 以前のソフトウェア リリースを使用している場合、MGCP ゲートウェイで SRST を有効にするには、次の作業を実行します。

要約手順

1. enable

2. configure terminal

3. ccm-manager fallback-mgcp

4. call application alternate [ application-name ]
または
service [ alternate | default ] service-name location

5. exit

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードを有効にします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

global コンフィギュレーション モードを開始します。

ステップ 3

ccm-manager fallback-mgcp

 

Router(config)# ccm-manager fallback-mgcp

ゲートウェイのフォールバック機能を有効にし、Cisco Unified Communications Manager が使用不能になった場合に、MGCP 音声ゲートウェイが SRST または他の設定済みアプリケーションを通じてコール処理サービスを提供できるようにします。

ステップ 4

call application alternate [ application-name ]

or

service [ alternate | default ] service-name location

 

Router(config)# call application alternate

or

Router(config)# service default

call application alternate コマンドは、MGCP アプリケーションが使用不能になった場合に、デフォルトの音声アプリケーションが処理を引き継ぐように指定します。 application-name 引数はオプションで、ダイヤル ピアのアプリケーションに障害が発生した場合に使用する特定の音声アプリケーションの名前を示します。特定のアプリケーション名が入力されていない場合、ゲートウェイは DEFAULT アプリケーションを使用します。

または

service コマンドは、ダイヤル ピアに特定のスタンドアロン アプリケーションをロードし、設定します。キーワードと引数は次のとおりです。

alternate (オプション)。ダイヤル ピアに設定されているサービスに障害が発生した場合に使用する代替サービス。

default (オプション)。代替サービスに障害が発生した場合に、ダイヤル ピアのデフォルト サービス(「DEFAULT」)が使用されるように指定します。

service-name :音声アプリケーションを識別する名前。

location :TCL スクリプトまたは VoiceXML ドキュメントの URL 形式のディレクトリおよびファイル名。たとえば、フラッシュ メモリ(flash:filename)、TFTP(tftp://../filename)、または HTTP サーバ(http://../filename)は有効なロケーションです。

ステップ 5

exit

 

Router(config)# exit

global コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

Cisco IOS Release 12.3(14)T 以降の MGCP ゲートウェイにおける SRST の設定

Cisco IOS Release 12.3(14)T 以降のバージョンを使用している場合、MGCP ゲートウェイで SRST を有効にするには、次の作業を実行します。

制約事項

Cisco IOS Release 12.3(14)T では、 call application alternate コマンドは service コマンドに置き換えられています。 service コマンドは、Cisco IOS Release 12.3(14)T 以降のすべてのリリースで使用できます。

要約手順

1. enable

2. configure terminal

3. ccm-manager fallback-mgcp

4. application [ application-name ]

5. global

6. service [ alternate | default ] service-name location

7. exit

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードを有効にします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

global コンフィギュレーション モードを開始します。

ステップ 3

ccm-manager fallback-mgcp

 

Router(config)# ccm-manager fallback-mgcp

ゲートウェイのフォールバック機能を有効にし、Cisco Unified Communications Manager が使用不能になった場合に、MGCP 音声ゲートウェイが SRST または他の設定済みアプリケーションを通じてコール処理サービスを提供できるようにします。

ステップ 4

application [ application-name ]

 

Router(config) application app-xfer

application-name 引数はオプションで、ダイヤル ピアのアプリケーションに障害が発生した場合に使用する特定の音声アプリケーションの名前を示します。特定のアプリケーション名が入力されていない場合、ゲートウェイは DEFAULT アプリケーションを使用します。

ステップ 5

global

 

Router(config)# global

global コンフィギュレーション モードを開始します。

ステップ 6

service [ alternate | default] service-name location

 

Router(config) service myapp https://myserver/myfile.vxml

ダイヤル ピアに特定のスタンドアロン アプリケーションをロードし、設定します。

alternate (オプション)。ダイヤル ピアに設定されているサービスに障害が発生した場合に使用する代替サービス。

default (オプション)。代替サービスに障害が発生した場合に、ダイヤル ピアのデフォルト サービス(「DEFAULT」)が使用されるように指定します。

service-name :音声アプリケーションを識別する名前。

location :TCL スクリプトまたは VoiceXML ドキュメントの URL 形式のディレクトリおよびファイル名。たとえば、フラッシュ メモリ(flash:filename)、TFTP(tftp://../filename)、または HTTP サーバ(http://../filename)は有効なロケーションです。

ステップ 7

exit

 

Router(config)# exit

global コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

Cisco IOS Release 12.3(14)T を使用する MGCP ゲートウェイで SRST を有効にする設定の例

次に、Cisco IOS Release 12.3(14)T 以降のバージョンを使用している場合の、MGCP ゲートウェイでの SRST の設定例を示します。

isdn switch-type primary-net5
!
!
ccm-manager fallback-mgcp
ccm-manager mgcp
ccm-manager config
mta receive maximum-recipients 0
!
controller E1 1/0
pri-group timeslots 1-12,16 service mgcp
!
controller E1 1/1
!

!
!
interface Ethernet0/0
ip address 10.48.80.9 255.255.255.0
half-duplex
!
interface Serial1/0:15
no ip address
no logging event link-status
isdn switch-type primary-net5
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!

!
!
call rsvp-sync
!
call application alternate DEFAULT

!--- For Cisco IOS® Software Release 12.3(14)T or later,
this command was replaced by the service command
in global application configuration mode.
application
global
service alternate Default


!
voice-port 1/0:15
!
mgcp
mgcp dtmf-relay voip codec all mode cisco
mgcp package-capability rtp-package
mgcp sdp simple
!
mgcp profile default
!
!
!
dial-peer cor custom
!
!
!
dial-peer voice 10 pots
application mgcpapp
incoming called-number
destination-pattern 9T
direct-inward-dial
port 1/0:15

!
!
call-manager-fallback
limit-dn 7960 2
ip source-address 10.48.80.9 port 2000
max-ephones 10
max-dn 32
dialplan-pattern 1 704.... extension-length 4
keepalive 20
default-destination 5002
alias 1 5003 to 5002
call-forward busy 5002
call-forward noan 5002 timeout 12
time-format 24
!
!
line con 0
exec-timeout 0 0
line aux

Cisco Unified SRST Phone に対する DHCP の設定

この作業を実行するには、ネットワークに DHCP を設定しておく必要があります。DHCP 設定の詳細については、『 Cisco IOS DHCP Server 』と Cisco Unified Communications Manager のマニュアルを参照してください。

Cisco IP Phone は、Cisco Unified SRST システムに接続されると、自動的に DHCP サーバに対して問い合せを行います。DHCP サーバは応答すると、Cisco IP Phone に IP アドレスを割り当て、DHCP オプション 150 を通じて TFTP サーバの IP アドレスを提供します。次に、電話機は Cisco Unified Communications Manager システム サーバに登録し、DHCP サーバから提供された Cisco Unified Communications Manager TFTP サーバ アドレスからコンフィギュレーション ファイルと電話機ファームウェア ファイルの取得を試みます。

ネットワークを設定する場合は、DHCP サーバをサイトのローカル側に設定します。SRST ルータを使用して DHCP サービスを提供することもできます(推奨)。DHCP サーバが WAN を介して配置されている場合、WAN の停止が長引くと、Cisco Unified IP Phone の DHCP リース期間が期限切れになる可能性があります。期限切れになると、電話機の IP アドレスが失われることがあります。その場合は、サービスが停止します。DHCP リースが期限切れになって DHCP サーバを使用できなくなった場合、電話機をリブートしても、電話機は再度アクティブにはなりません。これは、電話機が IP アドレスやその他の情報を取得できないためです。DHCP サーバをリモート サイトのローカル側に配置すると、WAN の障害が長引いた場合でも、電話機が IP アドレス リースを継続的に更新できることが保証されます。

Cisco Unified IP Phone に対する DHCP サービスを設定するには、次のいずれかの作業を選択します。

「単一の DHCP IP アドレス プールを定義する」 :この方法は、Cisco Unified SRST ルータが DHCP サーバであり、すべての DHCP クライアントに対して単一の共有アドレス プールを使用できる場合に使用します。

「各 Cisco Unified IP Phone に対する個別の DHCP IP アドレス プールを定義する」:この方法は、Cisco Unified SRST ルータが DHCP サーバであり、IP Phone 以外の電話機の DHCP クライアント用に別のプールが必要な場合に使用します。

「DHCP リレー サーバを定義する」:この方法は、Cisco Unified SRST ルータが DHCP サーバではなく、IP Phone からの DHCP 要求を別のルータの DHCP サーバにリレーする場合に使用します。

単一の DHCP IP アドレス プールを定義する

この作業では、IP アドレスの大規模な共有プールを作成します。このプールでは、すべての DHCP クライアントが、オプション 150 の TFTP サーバ IP アドレスを含む同一の情報を受信します。この方法を選択すると、設定する DHCP プールが 1 つだけで済みます。ただし、単一の DHCP IP アドレス プールを定義すると、一部の(IP Phone 以外の電話機の)クライアントが別の TFTP サーバ アドレスを使用することが必要になった場合に問題となる可能性があります。

要約手順

1. ip dhcp pool pool-name

2. network ip-address [ mask | prefix-length ]

3. option 150 ip ip-address

4. default-router ip-address

5. exit

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

ip dhcp pool pool-name

 

Router(config)# ip dhcp pool mypool

DHCP サーバ アドレス プールの名前を作成し、DHCP プール コンフィギュレーション モードを開始します。

ステップ 2

network ip-address [ mask | prefix-length ]

 
Router(config-dhcp)# network 10.0.0.0 255.255.0.0

DHCP アドレス プールの IP アドレスと、オプションのマスクまたはアドレス プレフィックスのビット数(前にスラッシュを付ける)を指定します。

ステップ 3

option 150 ip ip-address

 
Router(config-dhcp)# option 150 ip 10.0.22.1

Cisco IP Phone がイメージコンフィギュレーション ファイルをダウンロードする際のダウンロード元となる TFTP サーバ アドレスを指定します。このアドレスは、Cisco Unified Communications Manager の IP アドレスにする必要があります。

ステップ 4

default-router ip-address

 
Router(config-dhcp)# default-router 10.0.0.1

Cisco Unified IP Phone が直接接続されるルータを指定します。

このルータは、WAN の停止時に SRST サービスを取得するために使用されるデフォルト アドレスとなるため、Cisco Unified SRST ルータにする必要があります。Cisco IP Phone は、Cisco Unified SRST ルータに接続されている限り、必要なネットワークの詳細情報を取得できます。

ステップ 5

exit

 

Router(config-dhcp)# exit

DHCP プール コンフィギュレーション モードを終了します。

各 Cisco Unified IP Phone に対する個別の DHCP IP アドレス プールを定義する

この作業では、DHCP サーバ アドレス プールの名前を作成し、IP アドレスを指定します。この方法では、Cisco Unified IP Phone ごとにエントリを作成する必要があります。

要約手順

1. ip dhcp pool pool-name

2. host ip-address subnet-mas k

3. option 150 ip ip-address

4. default-router ip-address

5. exit

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

ip dhcp pool pool-name

 

Router(config)# ip dhcp pool pool2

DHCP サーバ アドレス プールの名前を作成し、DHCP プール コンフィギュレーション モードを開始します。

ステップ 2

host ip-address subnet-mask

 

Router(config-dhcp)# host 10.0.0.0 255.255.0.0

電話機で使用する IP アドレスを指定します。

ステップ 3

option 150 ip ip-address

 
Router(config-dhcp)# option 150 ip 10.0.22.1

Cisco IP Phone がイメージコンフィギュレーション ファイルをダウンロードする際のダウンロード元となる TFTP サーバ アドレスを指定します。このアドレスは、Cisco Unified Communications Manager の IP アドレスにする必要があります。

ステップ 4

default-router ip-address

 
Router(config-dhcp)# default-router 10.0.0.1

Cisco Unified IP Phone が直接接続されるルータを指定します。

このルータは、WAN の停止時に SRST サービスを取得するために使用されるデフォルト アドレスとなるため、Cisco Unified SRST ルータにする必要があります。Cisco IP Phone は、Cisco Unified SRST ルータに接続されている限り、必要なネットワークの詳細情報を取得できます。

ステップ 5

exit

 

Router(config-dhcp)# exit

DHCP プール コンフィギュレーション モードを終了します。

DHCP リレー サーバを定義する

この作業では、Cisco Unified IP Phone が接続される LAN インターフェイスに DHCP リレーを設定し、DHCP クライアント(電話機)からの要求を DHCP サーバにリレーするための Cisco IOS DHCP サーバ機能を有効にします。DHCP 設定の詳細については、『 Cisco IOS DHCP Server 』を参照してください。

デフォルトでは、Cisco IOS DHCP サーバ機能は、ルータで有効になっています。DHCP サーバが Cisco Unified SRST ルータで有効になっていない場合は、次の手順に従って有効にします。

要約手順

1. service dhcp

2. interface type number

3. ip helper-address ip-address

4. exit

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

service dhcp

 

Router(config)# service dhcp

ルータで Cisco IOS DHCP サーバ機能を有効にします。

ステップ 2

interface type number

 

Router(config)# interface serial 0

指定されたインターフェイスのインターフェイス コンフィギュレーション モードを開始します。詳細については、『 Cisco IOS Interface and Hardware Component Command Reference, Release 12.3T 』を参照してください。

ステップ 3

ip helper-address ip-address

 

Router(config-if)# ip helper-address 10.0.22.1

TFTP サーバおよび Domain Name System(DNS; ドメイン ネーム システム)の要求に対する、認識されないブロードキャストのヘルパー アドレスを指定します。サーバが別々のホスト上にある場合は、サーバごとに ip helper-address コマンドを使用する必要があります。また、複数のサーバに ip helper-address コマンドを使用すると、複数の TFTP サーバ ターゲットを設定できます。

ステップ 4

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

キープアライブ インターバルの指定

キープアライブ インターバルは、ネットワーク デバイスが送信するキープアライブ メッセージの時間間隔です。キープアライブ メッセージとは、ネットワーク デバイスが別のネットワーク デバイスに対し、2 者間の仮想回線が引き続きアクティブであることを通知するために送信するメッセージのことです。


) メッセージの時間間隔にデフォルトの 30 秒を使用する場合、この作業を実行する必要はありません。


要約手順

1. call-manager-fallback

2. keepalive seconds

3. exit

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

call-manager-fallback

 

Router(config)# call-manager-fallback

call-manager-fallback コンフィギュレーション モードを開始します。

ステップ 2

keepalive seconds

 

Router(config-cm-fallback)# keepalive 60

Cisco Unified IP Phone がルータに送信するキープアライブ メッセージの時間間隔を秒単位で設定します。

seconds :範囲は 10 ~ 65535 です。デフォルトは 30 です。

ステップ 3

exit

 

Router(config-cm-fallback)# exit

call-manager-fallback コンフィギュレーション モードを終了します。

次の例では、キープアライブ インターバルを 45 秒に設定します。

call-manager-fallback
keepalive 45
 

電話機能をサポートするための Cisco Unified SRST の設定


ヒント Cisco Unified SRST が有効になっている場合、Cisco Unified Communications Manager フォールバック モードになっているときは Cisco Unified IP Phone を再設定する必要はありません。これは、電話機が Cisco Unified Communications Manager に対して使用していた設定と同じものを保持するためです。


Cisco Unified IP Phone の機能をサポートするようにルータの Cisco Unified SRST を設定するには、global コンフィギュレーション モードを開始して、次のコマンドを使用します。

要約手順

1. call-manager-fallback

2. ip source-address ip-address [ port port ] [ any-match | strict-match ]

3. max-dn max-directory-numbers [ dual-line ] [ preference preference-order ]

4. max-ephones max-phones

5. limit-dn { 7910 | 7935 | 7940 | 7960 } max-lines

6. exit

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

call-manager-fallback

 

Router(config)# call-manager-fallback

call-manager-fallback コンフィギュレーション モードを開始します。

ステップ 2

ip source-address ip-address [ port port ] [ any-match | strict-match ]

 

Router(config-cm-fallback)# ip source-address 10.6.21.4 port 2002 strict-match

ルータが指定の IP アドレスを通じて Cisco IP Phone からのメッセージを受信できるようにし、IP アドレスの厳密な検証を行います。デフォルトのポート番号は 2000 です。

ステップ 3

max-dn max-directory-numbers [ dual-line ] [ preference preference-order ]

 

Router(config-cm-fallback)# max-dn 15 dual-line preference 1

ルータでサポートできる Directory Number(DN; 電話番号)または仮想音声ポートの最大数を設定し、二重回線モードをアクティブにします。

max-directory-numbers: ルータでサポートされる電話番号または仮想音声ポートの最大数。最大数は、プラットフォームによって異なります。デフォルトは 0 です。詳細については、「プラットフォームとメモリのサポート」を参照してください。

dual-line (オプション)。Cisco Unified
Communications Manager フォールバック モードの IP Phone が、2 つのチャネルを持つ仮想音声ポートを使用できるようにします。

preference preference-order (オプション)。プライマリ番号に関連付けられたすべての電話番号に対する VoIP ダイヤル ピアを作成する場合のグローバル プリファレンスを設定します。範囲は 0 ~ 10 です。デフォルトは 0(最高の優先順位)です。

alias コマンドにも、 alias コマンドのプリファレンス値を設定する preference キーワードが用意されています。 alias コマンドの preference キーワードを設定すると、 max-dn コマンドによるデフォルトのプリファレンス セットを上書きできます。 max-dn コマンドと alias コマンドの併用に関する詳細については、「コールの再ルーティングの設定」を参照してください。


) 電話番号または仮想音声ポートの最大数の設定後にその制限を引き下げるには、ルータをリブートする必要があります。


ステップ 4

max-ephones max-phones

 
Router(config-cm-fallback)# max-ephones 24

ルータがサポートできる Cisco IP Phone の最大数を設定します。デフォルトは 0 です。最大数は、プラットフォームによって異なります。詳細については、「プラットフォームとメモリのサポート」を参照してください。


) Cisco IP Phone の最大数の設定後にその制限を引き下げるには、ルータをリブートする必要があります。


ステップ 5

limit-dn { 7910 | 7935 | 7940 | 7960 } max-lines

 
Router(config-cm-fallback)# limit-dn 7910 2

Cisco Unified Communications Manager のフォールバック時における Cisco IP Phone の電話番号の回線数を制限します。


) このコマンドは、いずれかの電話機が実際に Cisco Unified SRST ルータに登録する前の、Cisco Unified SRST ルータの最初の設定時に設定する必要があります。ただし、回線数は後で変更できます。


回線の最大数の設定値は 1 ~ 6 のいずれかです。回線の最大数は、デフォルトで 6 に設定されています。アクティブな電話機の最後の回線番号がこの制限を超えた場合は、電話機のリセットに関する警告情報が表示されます。

ステップ 6

exit

 
Router(config-cm-fallback)# exit

call-manager-fallback コンフィギュレーション モードを終了します。

Cisco Unified SRST が有効になっていることの確認

Cisco Unified SRST 機能が有効になっていることを確認するには、次の手順を実行します。


ステップ 1 show running-config コマンドを入力して、設定を確認します。

ステップ 2 show call-manager-fallback all コマンドを入力して、Cisco Unified SRST 機能が有効になっていることを確認します。

ステップ 3 ネットワーク内の Cisco IP Phone の Settings 画面を使用して、電話機のデフォルト ルータの IP アドレスが Cisco Unified SRST ルータの IP アドレスと一致していることを確認します。

ステップ 4 いずれかの Cisco IP Phone の TCP ポート 2000 Skinny Client Control Protocol(SCCP)接続を一時的にブロックして、Cisco IP Phone に強制的に Cisco Unified Communications Manager への接続を切断させ、Cisco Unified SRST ルータに登録させるには、次の手順を実行します。

a. 適切な IP access-list コマンドを使用して、Cisco Unified IP Phone を Cisco Unified Communications Manager から一時的に切断します。

WAN 接続の障害時に、Cisco Unified SRST が有効になっている場合、Cisco Unified IP Phone には、電話機が Cisco Unified Communications Manager フォールバック モードで動作していることを通知するメッセージが表示されます。Cisco Unified Communications Manager フォールバック モードで動作している場合、Cisco IP Phone 7960 および Cisco IP Phone 7940 には「CM Fallback Service Operating」というメッセージが表示され、Cisco IP Phone 7910 には「CM Fallback Service」というメッセージが表示されます。Cisco Unified Communications Manager が回復すると、メッセージが消去され、Cisco IP Phone の機能がすべて回復します。

b. 適切な access-list コマンドの no 形式を入力して、電話機の通常のサービスを回復させます。

c. debug ephone register コマンドを使用して、Cisco Unified SRST ルータでの Cisco IP Phone の登録プロセスを監視します。

d. show ephone コマンドを使用して、Cisco Unified SRST ルータに登録された Cisco IP Phone を表示します。


 

トラブルシューティング

Cisco Unified SRST の設定のトラブルシューティングを行うには、次のコマンドを使用します。

Cisco IP Phone に関するキープアライブ デバッグを設定するには、 debug ephone keepalive コマンドを使用します。

Cisco IP Phone に関する登録デバッグを設定するには、 debug ephone register コマンドを使用します。

Cisco IP Phone に関する状態デバッグを設定するには、 debug ephone state コマンドを使用します。

Cisco IP Phone に関する詳細デバッグを設定するには、 debug ephone detail コマンドを使用します。

Cisco IP Phone に関するエラー デバッグを設定するには、 debug ephone error コマンドを使用します。

Cisco IP Phone に関するコール統計情報デバッグを設定するには、debug ephone statistics コマンドを使用します。

音声パケット レベルのデバッグを設定し、1024 個の音声パケットごとに 1 つの音声パケットの内容を表示するには、 debug ephone pak コマンドを使用します。

すべての SCCP メッセージについて未加工で低レベルのプロトコル デバッグを表示するには、 debug ephone raw コマンドを使用します。

その他のデバッグについては、Cisco IOS ソフトウェア リリースに適合する『 Cisco IOS Debug Command Reference 』を参照してください。このドキュメントを入手するには、 Cisco IOS Software Support Resources に移動し、適切なリリース バージョンをクリックしてから、 Command References をクリックします。

関連情報

次のステップでは、電話機を設定し、ダイヤル トーンを取得します。手順については、「 Cisco Unified IP Phone の設定 」の章を参照してください。

追加情報については、「Cisco Unified SRST の概要」の章の 「その他の資料」を参照してください。