Cisco IP テレフォニー QoS デザイン ガイド
ブランチ オフィスの構築
ブランチ オフィスの構築
発行日;2012/01/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

ブランチ オフィスの構築

推奨ブランチ オフィスの設計

ブランチ オフィスにある個別の音声サブネットおよびデータ サブネットのトランキングのための 802.1Q の使用

802.1Q トランキングを使用する Catalyst 3600 ブランチ オフィス ルータ

802.1Q トランキングを使用する Catalyst 4000

802.1Q トランキングを使用する Catalyst 3500

ブランチ オフィスにある個別の音声サブネットおよびデータ サブネットのためのセカンダリ IP アドレッシングの使用

ブランチ オフィスにおける VoIP 制御トラフィックの分類

ブランチ オフィスにある単一サブネットの使用

Cisco 1750 単一サブネット設定

Cisco 3500 単一サブネット設定

Catalyst 2600 単一サブネット(トランキングなし)設定

Cisco 4000 単一サブネット設定

要約

ブランチ オフィスの構築

この章では、お使いの Cisco AVVID ネットワークにブランチ オフィスを追加する際の設計に関する考慮事項、およびその推奨事項について説明します。

推奨ブランチ オフィスの設計

ユーザが 100 人までのブランチ オフィスを設計するときは、従来は、1 台のブランチ ルータと 1 台のイーサネット スイッチで構成しています。そのルータは、すべての IP ルーティングと WAN 接続を処理します。ローカル PC はすべて小規模のイーサネット スイッチに接続され、このスイッチもその 1 台のルータに接続されています。ブランチ オフィス内での音声品質については、次に示す重要な 2 つの課題があります。

WAN を介した音声品質

ブランチ オフィス内での音声品質

この章では、ブランチ オフィスの設計、IP アドレッシング、およびブランチ オフィス内での音声品質を説明します。WAN を介した音声品質を確保するための WAN QoS ツールの詳細は、第 5 章「ワイドエリア ネットワークの実装」で説明します。

図 4-1 では、ブランチ オフィス内で QoS が問題になることがある領域を示します。

図 4-1 ブランチ オフィス接続のための QoS に関する考慮事項

 

一般に、ブランチ オフィスを設計する場合、各オフィスに使用される IP サブネットは 1 つだけです。このサブネットを変更する設定は、現実的には行われていません。サブネットを変更すると、企業全体のルーティング方式に影響を与えてしまうからです。したがって、実際のブランチ オフィス設計では、IP 電話のオプションには次の 3 つの IP アドレッシングを検討する必要があります。

既存のリモート オフィス IP アドレス スペースをサブネットに分割することにより、VLAN を 2 つ設定し、ルータがトランキングをサポートする場合は 802.1Q を使用する。

既存のリモート オフィス IP アドレス スペースをサブネットに分割することにより、VLAN を 2 つ設定する。また、ルータのイーサネット インターフェイス上でセカンダリ IP アドレッシングを使用する(ルータがトランキングをサポートしている場合)。

各リモート オフィスについて単一の IP アドレス スペースと単一の VLAN を使用する。

この章で説明する各シナリオでは、ブランチ オフィス内で IP 電話を設置するのに単一のケーブルを使用します。これは、今日、最も一般的に行われている方法論であるためです。図 4-2 では、この章に説明しているブランチ オフィス設定の一般的なモデルを示します。

図 4-2 ブランチ オフィス接続のための一般的なモデル

 

ブランチ オフィスにある個別の音声サブネットおよびデータ サブネットのトランキングのための 802.1Q の使用

音声とデータには、ブランチ オフィスの既存の IP アドレス スペースをセグメント化するオプションがある場合は、必ず、音声とデータ用に個別の VLAN を使用してください。現在の Catalyst 3500 および 4000 シリーズなど、レイヤ 2 サービスのみをサポートするイーサネット スイッチは、ほとんどのブランチ オフィス設計で使用されています。この場合、ブランチ WAN ルータは、個別の VLAN をイーサネット スイッチからトランクします。これは、ルータおよびスイッチ上で 802.1Q トランキングを使用して行われます。

このガイドでは、イーサネット スイッチでの優先順位を提供するのには、802.1Q 標準ヘッダ内の 802.1p 部分にあるユーザ プライオリティ ビットが使用されます。これは、Cisco AVVID ネットワークを設計する際の重要な要素です。Cisco IOS リリース 12.1(5)T には、モジュラ CLI QoS コードが組み込まれています。これらコードが追加されたことにより、ブランチ オフィス Catalyst イーサネット スイッチ上で適切なキューイングが行われるように、WAN からのレイヤ 3 タグ付き VoIP パケットのマッピングを該当のレイヤ 2 の 802.1D ユーザ プライオリティ マーキングで分類することができます。

本社では、Catalyst 6000 が、すべてのレイヤ 3 の ToS 設定を入力インターフェイスにある正しいレイヤ 2 の CoS 値に関連付けます。

802.1Q トランキングを使用する Catalyst 3600 ブランチ オフィス ルータ

次の Catalyst 3600 設定には、着信音声パケット用のレイヤ 3 からレイヤ 2 への分類マッピングが組み込まれています。

class-map L3-to-L2_VoIP-RTP
match ip dscp ef
class-map L3-to-L2_VoIP-Cntrl
match ip dscp af31
policy-map output-L3-to-L2
class L3-to-L2_VoIP-RTP
set cos 5
class L3-to-L2_VoIP-Cntrl
set cos 3
!
interface FastEthernet1/0
description Catalyst 3500 Branch Office Switch
no ip address
ip route cache policy
no ip mroute-cache
load-interval 30
speed 100
full-duplex
!
interface FastEthernet1/0.50
description native subnet 10.1.50.0 data
encapsulation dot1Q 50
ip address 10.1.50.1 255.255.255.0
service-policy output output-L3-to-L2
ip route cache policy
no ip mroute-cache
!
interface FastEthernet1/0.150
description native subnet 10.1.150.0 voice
encapsulation dot1Q 150
ip address 10.1.150.1 255.255.255.0
ip helper-address 10.1.10.10
service-policy output output-L3-to-L2
ip route cache policy
no ip mroute-cache
 

802.1Q トランキングを使用する Catalyst 4000

次の例では、802.1Q トランキングを使用する Catalyst 4000 のためのブランチ オフィス設定を示します。

cat4k> (enable) set vlan 70 name data70
cat4k> (enable) set vlan 170 name voice170
cat4k> (enable) set vlan 70 2/1-48
cat4k> (enable) set port host 2/1-48
cat4k> (enable) set port auxiliaryvlan 2/1-48 170
cat4k> (enable) set port speed 2/1-49 100
cat4k> (enable) set port duplex 2/1-49 full
cat4k> (enable) set trunk 2/49 on dot1q 1-1005
 

802.1Q トランキングを使用する Catalyst 3500

次の例では、802.1Q トランキングを使用する Catalyst 3500 のためのブランチ オフィス設定を示します。

interface FastEthernet0/1
description DOT1Q port to IP Phone
switchport trunk encapsulation dot1q
switchport trunk native vlan 50
switchport mode trunk
switchport voice vlan 150
spanning-tree portfast
!
interface FastEthernet0/15
description Port to 3640 (supports Dot1q)
duplex full
speed 100
switchport trunk encapsulation dot1q
switchport trunk native vlan 50
switchport trunk allowed vlan 1,50,150
switchport mode trunk
 

ブランチ オフィスにある個別の音声サブネットおよびデータ サブネットのためのセカンダリ IP アドレッシングの使用

ブランチ ルータが 802.1Q トランキングをサポートしていない場合、それでも音声およびデータのための個別の VLAN をお奨めします。たとえば、Cisco 1750 ルータはトランキングをサポートしていませんが、それでも音声トラフィックとデータ トラフィックを論理的に分離することをお奨めします。トランキングに代わるのは、Cisco ルータ上でセカンダリ IP アドレッシングを使用することです。次の例では、ブランチ オフィスにある Cisco 1750 のためのこのタイプの設定を示します。

interface FastEthernet0
description to Catalyst 3500
mac-address 0000.1750.0001
ip address 10.1.40.1 255.255.255.128
ip address 10.1.40.129 255.255.255.128 secondary
ip helper-address 10.1.10.10
no ip mroute-cache
speed 100
full-duplex
 

ブランチ オフィスにおける VoIP 制御トラフィックの分類

リモート ブランチ ルータも、VoIP 制御トラフィックを分類して、ローカル サブネットを超えて、WAN を介して Cisco CallManager または VoIP ゲートウェイに向かう必要があります。この VoIP 制御トラフィックの分類は、入口イーサネット インターフェイス上でポリシー ベースのルーティングおよびルート マップを使用することによって行われます。


) リリース 3.0(5) から、Cisco CallManager には、Cisco CallManager、IP 電話、および Skinny プロトコル ゲートウェイ(AT および AS モデル アナログ ゲートウェイはこれには含まれません)からのすべての VoIP 制御および管理トラフィックについて CoS および ToS 値を設定する機能が組み込まれています。このユーザ設定可能な分類があれば、Skinny プロトコル VoIP 制御トラフィックにマークを付けるのにネットワーク要素アクセス リストはもう不要です。H.323 およびメディア ゲートウェイ コントロール プロトコル(MGCP)トラフィックでは、まだ数ヶ月間は、外部ネットワーク要素マーキングが必要です。


次の例では、ブランチ オフィスにおける VoIP 制御トラフィックのための設定を示します。

interface FastEthernet0
mac-address 0000.1750.0001
ip address 10.1.60.1 255.255.255.0
ip helper-address 10.1.10.10
! Attach the route-map to the FastEthernet interface
ip policy route-map Set-IP-QoS
no ip mroute-cache
load-interval 30
speed auto
full-duplex
!
! Match all Skinny, H.323 and MGCP Control Traffic
! Skinny marking is required only until
! Cisco CallManager Release 3.0(5).
access-list 101 permit tcp any any range 2000 2002
access-list 101 permit tcp any any eq 1720
access-list 101 permit tcp any any range 11000 11999
access-list 101 permit udp any any eq 2427
!
! Match all VoIP RTP Traffic
access-list 102 permit udp any any range 16384 32767
!
! Match all other traffic
access-list 103 permit ip any any
!
! Set all Skinny, H.323 and MGCP Control traffic, matched
! with ac 101 to IP Precedence 3
route-map Set-IP-QoS permit 10
match ip address 101
set ip precedence flash
!
! Just match VoIP RTP Traffic. Do not change the
! default classification of ToS=5
route-map Set-IP-QoS permit 20
match ip address 102
!
! Make sure all data traffic is set to IP Precedence 0
route-map Set-IP-QoS permit 30
match ip address 103
set ip precedence routine
 

ブランチ オフィスにある単一サブネットの使用

IP 電話用の追加の IP サブネットを割り当てるか、または既存の IP アドレス スペースを分割してリモート ブランチにある追加のサブネットに入れることが実際的でない場合は、ブランチ オフィスに単一の IP アドレス スペースを使用することが必要です。この場合、レイヤ 2 およびレイヤ 3 の両方で音声にデータより上位の優先順位を設定する必要があります。

第 2 章「IP 電話の接続」で説明のとおり、レイヤ 3 分類についてはすでに対処されています。電話はすべてのメディア ストリーム内のタイプ オブ サービス(ToS)ビットを 5 という IP Precedence 値に設定するためです。(Cisco CallManager リリース 3.0(5) では、このマーキングは、EF という差分サービス コード ポイント(DSCP;Differentiated Services Code Point)値に変更されました。)ただし、ブランチ オフィス スイッチ内の複数のキューに対する許可を得るためにレイヤ 2 分類が確実に存在するようにするには、電話は、レイヤ 2 の 802.1p ヘッダー内のユーザ優先度ビットを使用して、サービス クラス(CoS)マーキングを提供することも必要です。これは、ネイティブ VLAN 上でスイッチに 802.1p ヘッダーを検索させることによってのみ行えます。ほとんどのブランチ オフィス設計で採用されている 2 つのイーサネット スイッチ、Catalyst 3500 および 4000 では、次の項で説明されているとおり、これを実行するには、異なる設定コマンドを使用します。

Cisco 1750 単一サブネット設定

Cisco 1750 シリーズ ルータは、スイッチ間リンクまたは 802.1Q イーサネット トランキングのどちらもサポートしていません。次の例では、Cisco 1750 ルータの単一サブネット設定を示します。

interface FastEthernet0
mac-address 0000.1750.0001
ip address 10.1.40.1 255.255.255.0
ip helper-address 10.1.10.10
ip policy route-map Set-IP-QoS
no ip mroute-cache
load-interval 30
speed auto
full-duplex
 

Cisco 3500 単一サブネット設定

Catalyst 3500 は、補助 VLAN を設定するときに 802.1p 専用オプションの使用をサポートします。これにより、IP 電話は、ネイティブ VLAN 上で CoS 値の 5 を指定して VoIP パケットにタグを付けることができますが、すべての PC データ トラフィックはタグなしで送信されます。次の例では、Catalyst 3500 の単一サブネット設定を示します。

interface FastEthernet0/2
description Port to IP Phone in single subnet
switchport trunk encapsulation dot1q
switchport trunk native vlan 40
switchport mode trunk
switchport voice vlan dot1p
spanning-tree portfast
!
interface FastEthernet0/15
description Port to 1750 Router in single subnet
load-interval 30
duplex full
speed 100
switchport access vlan 40
 

Catalyst 2600 単一サブネット(トランキングなし)設定

次の例では、Catalyst 2600 の単一サブネット設定を示します。

interface FastEthernet1/0
mac-address 0000.2600.0001
ip address 10.1.60.1 255.255.255.0
ip helper-address 10.1.10.10
ip policy route-map Set-IP-QoS
no ip mroute-cache
load-interval 30
speed 100
full-duplex
 

Cisco 4000 単一サブネット設定

Catalyst 4000 は、Catalyst 3500 および 6000 とは異なり、補助 VLAN を設定するための dot1p 専用オプションをサポートしていません。次善策として、Catalyst 4000 に接続されている IP 電話を設定します。そうすると、補助 VLAN ID は、ポート VLAN ID(PVID)またはネイティブ VLAN ID と一致します。これにより、電話では、そのパケットを CoS 値 5 のタグ付きで送信できます。次の例は、Catalyst 4000 についてのこの構成を示しています。

cat4k> (enable) set vlan 60 name 171.69.60.0_data
cat4k> (enable) set vlan 60 2/1-49
cat4k> (enable) set port host 2/1-49
cat4k> (enable) set port auxiliaryvlan 2/1-48 60
 

要約

この章で説明のとおり、Cisco AVVID ネットワーク上にブランチ オフィスを設定する際には、以下の一般的なガイドラインおよび推奨事項が適用されます。

ブランチ WAN ルータは、Cisco AVVID ネットワークの拡張 QoS ツールをサポートする必要があります。

複数のキューをサポートするスイッチを使用します。

現在、ルータ内でレイヤ 3 の ToS 分類をレイヤ 2 の CoS に渡す方法はありません。ただし、Cisco IOS の今後のリリースには、これらのマッピングを可能にする追加の QoS 機能が含まれる予定です。