Cisco IP テレフォニー QoS デザイン ガイド
キャンパスの設計
キャンパスの設計
発行日;2012/01/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

キャンパスの設計

Cisco AVVID のためのキャンパス スイッチング設計

キュー スケジューリング

キューの数

マーキング制御および管理トラフィック

Skinny プロトコル

H.323 プロトコル

MGCP

Catalyst 6000 アクセス レイヤ

Catalyst 6000 ポート スケジューリングおよびキューイング スキーム

受信インターフェイス

送信インターフェイス

QoS パラメータの設定

IP 電話ポート キューイング

IP 電話アクセス ポート設定の検証

ディストリビューション スイッチへのアップリンク インターフェイス

MLS および Catalyst QoS 設定

Catalyst 6000 送信キュー設定

Catalyst 6000 CoS/ToS から DSCP へのマッピング設定

CoS/ToS から DSCP へのマッピングの検証

Catalyst 4000 アクセス レイヤ

Catalyst 4000 ポート スケジューリングおよびキューイング スキーム

受信インターフェイス

送信インターフェイス

Catalyst 4000 スイッチ全体の QoS

Catalyst 4000 キュー許可設定の検証

IP 電話ポート キューイング

ディストリビューション スイッチへのアップリンク インターフェイス

Catalyst 3500 アクセス レイヤ

Catalyst 3500 ポート スケジューリングおよびキューイング スキーム

受信インターフェイス

送信インターフェイス 10/100 ポート

送信インターフェイス ギガビット イーサネット ポート

IP 電話ポート キューイング

ディストリビューション スイッチへのアップリンク インターフェイス

Catalyst 6000 アクセス レイヤ

Catalyst 6000 ディストリビューション レイヤ VoIP 制御トラフィック送信キューの設定

Catalyst 6000-PFC アクセス レイヤを使用しての、Catalyst 6000 ディストリビューション レイヤ設定

レイヤ 3 アクセス スイッチからのトラスト DSCP

Catalyst 6000 ToS から DSCP へのマッピング設定

アクセス スイッチがレイヤ 2 についてのみイネーブルになっている Catalyst 6000 ディストリビューション レイヤ設定

レイヤ 2 アクセス スイッチからのトラスト CoS

Catalyst 6000 CoS から DSCP へのマッピング設定

VoIP 制御トラフィック分類用のレイヤ 3 アクセス リストの設定

Cisco 7200 WAN ルータへの接続の設定

Native IOS を実行する Catalyst 6000 ディストリビューション/コア

Native Cisco IOS Catalyst 6000 上での QoS の設定

VoIP 制御トラフィック用の送信キュー許可の設定

Catalyst 6000-PFC を使用した、Catalyst 6000 Native Cisco IOS ディストリビューション レイヤ設定

レイヤ 3 アクセス スイッチからのトラスト DSCP

レイヤ 3 アクセス スイッチ用の Native Cisco IOS の ToS から DSCP へのマッピング設定

アクセス スイッチがレイヤ 2 についてのみイネーブルになっている Catalyst 6000 Native Cisco IOS ディストリビューション レイヤ設定

レイヤ 2 アクセス スイッチからのトラスト CoS

レイヤ 2 アクセス スイッチ用の Native IOS の CoS から DSCP へのマッピング設定

VoIP 制御トラフィック分類用に QoS ポリシーおよびレイヤ 3 アクセス リストを設定する

要約

キャンパスの設計

この章では、キャンパス環境で Cisco AVVID ネットワークを実装するための設計に関する考慮事項とその推奨事項について説明します。

Cisco AVVID のためのキャンパス スイッチング設計

最近まで、サービス品質(QoS)では、ネットワーク トラフィックのバースト特性やバッファ オーバーフローの可能性は、企業キャンパスでは問題にならないとされていました。ところが、キャンパスでは帯域幅ではなく、バッファリングが問題であることがエンジニアの間で次第に知られるようになりました。したがって、QoS ツールは、損失、遅延、および遅延変動を最小限に抑えるようこれらのバッファを管理する必要があります。図 3-1 では、送信バッファが問題を引き起こす可能性のある領域を示します。

図 3-1 送信バッファに関する QoS の考慮事項

 

送信バッファは、データ ネットワークに大量の小さい伝送制御プロトコル(TCP)パケットと重なって生じるバーストにより、高速キャンパス ネットワークでその容量いっぱいになる傾向があります。出力バッファが満杯になると、入り口のインターフェイスは、新しいフロー トラフィックを出力バッファに入れることができません。入り口のバッファは、きわめて短時間でいっぱいになりますが、これが満杯になると、パケット ドロップが発生します。通常、これらのドロップは、どの所定のフローでも 1 つのパケットよりも多くなります。先に述べたとおり、パケット喪失があると、音声のクリッピングやスキップが発生します。現在の Cisco デジタル信号プロセッサ(DSP)アルゴリズムは、30 ms の喪失音声に対して修正が行えます。Cisco VoIP テクノロジでは、VoIP パケットあたり 20 ms サンプルの音声ペイロードを使用します。したがって、現在の DSP アルゴリズムでは、喪失が許されるのは、どの所定時間でも 1 つの音声リアルタイム転送プロトコル(RTP)パケットだけです。2 つの連続する音声パケットが喪失すると、音声品質は低下し始めます。図 3-2 では、この状況を示しています。

図 3-2 送信バッファが満杯時の音声品質の損失

 

VoIP トラフィックは、遅延パケットおよびドロップしたパケットの両方から影響を受けます。キャンパスがギガビット イーサネット トランクを使用している限り、キュー バッファのサイズに関係なく、遅延はファクタにはなりません。ギガビット イーサネット トランクは、シリアライゼーション時間がきわめて速いためです。ただし、ドロップは、必ず、キャンパス内の音声品質に影響します。バッファが 100% キャパシティで動作したためにトラフィックがドロップされる可能性を排除する唯一の方法は、送信インターフェイスで複数のキューを使用することです。音声とビデオ(どちらも遅延およびドロップに影響されます)を分離してそれぞれ固有のキューに入れることにより、データ送信バッファがフローでいっぱいになってきていても、入り口のインターフェイスでパケット フローのドロップを防止することができます。図 3-3 では、個々の音声バッファおよびデータ バッファの使用法を示します。

図 3-3 音声およびデータ用の別個の送信バッファの使用法

 


) Catalyst スイッチ上の QoS(複数のキュー)をイネーブルにする場合、フロー制御がディセーブルになっているか確認することが必要です。フロー制御は、キューイングがアクティブになる前にポート上で動作することにより、設定済みのキューイング動作に干渉します。フロー制御は、デフォルトではディセーブルとなっています。


キュー スケジューリング

スケジューラ プロセスは、様々な方式で各送信キュー(音声およびデータ)を処理できます。最も容易な方式は、ラウンドロビン(RR)アルゴリズムです。これは、キュー 1 から キュー N まで順番に処理します。この方式は、堅固なものではありませんが、きわめて単純で、効果的な方式であるため、支店やワイヤリング クローゼット スイッチ用に使用できます。ディストリビューション レイヤ スイッチは、加重ラウンドロビン(WRR)アルゴリズムを使用します。この場合、優先順位の高いトラフィックにスケジューリング「加重」が付けられます。

もう一つのオプションとしては、パケット遅延およびドロップに影響を受けやすいアプリケーションについてラウンドロビンまたは加重ラウンドロビン スケジューリングを優先順位のスケジューリングと組み合わせる方法があります。この方法では、キュー内にパケットがある場合に必ず最初に処理される優先度キュー(PQ)が使用されます。PQ にフレームがない場合、追加のキューは、RR または WRR を使用してスケジュールされます。

キューの数

キャンパス ネットワーク内の送信インターフェイス上で実際に必要となるキューの数については、これまで様々に論議されてきました。例えば、サービス クラス(CoS)値ごとにワイヤリング クローゼット スイッチにキューを追加する必要があるのか、ディストリビューション レイヤ スイッチに 8 個のキューを追加する必要があるのか、64 個の Differentiated Services Code Point(DSCP)値のそれぞれについてキューを追加する必要があるのか、といった問題があります。この項では、これらの問題に対処するガイドラインを示します。

第 1 に重要なことは、各ポートのバッファ メモリは有限であることを覚えておくことです。ある単一のキューでは、そのバッファ内のすべてのメモリ アドレスにアクセスが可能です。2 つ目のキューが追加されるとすぐに、合計の有限バッファ容量は、2 つの部分(各キューにつき 1 つずつで)に分割されます。ところで、スイッチに入ってくるパケットかたまりは、バッファ メモリがはるかに少ないので、コンテンションが発生してしまいます。トラフィックがピークに達すると、バッファは満杯になり、パケットは入り口インターフェイスでドロップしてしまいます。現在、使用されているネットワーク トラフィックは TCP ベースのため、パケットがドロップすると、再送信が行われるのでネットワーク輻輳はさらに増幅されます。したがって、キューイングは、慎重に使用し、かつ特定の優先順位トラフィックがパケット遅延およびドロップに影響される場合に限り使用してください。

ワイヤリング クローゼット スイッチには 2 つのキューで十分です。この場合、バッファ管理は、他のレイヤほど重要ではありません。これらのキューの処理方法(ラウンドロビン、加重ラウンドロビン、または優先度キューイング)は、バッファの数ほど重要ではありません。トラフィックの集約量に比べると、スケジューラ プロセスはきわめて高速であるためです。

ディストリビューション レイヤ スイッチは、そのレイヤでフロー集約が発生するために、はるかに複雑なバッファ管理を必要とします。優先度キューが必要であるだけでなく、標準キュー内でしきい値を指定することも必要です。Cisco は、インターフェイス キューの数を頻繁に増やす方ではなく、キュー内で複数のしきい値を使用する方を選びました。先に述べたとおり、キューが設定され、割り当てられるたびに、そのキューと関連付けられたすべてのメモリ バッファはキュー エントランス基準(queue entrance criteria)に適合するフレームでのみ使用されます。次の例は、この概念を示したものです。

Catalyst 4000 10/100 イーサネット ポートに 2 つのキューが設定されているとします。1 つは VoIP(VoIP ベアラおよび制御トラフィック)用で、もう 1 つはデフォルト キューです。これは、ハイパーテキスト転送プロトコル(HTTP)、電子メール、ファイル転送プロトコル(FTP)、ログイン、Windows NT Shares、およびネットワーク ファイル システム(NFS)用に使用されます。128-KB 音声キューは、7:1 の比率で送信と受信に分割されます。送信バッファ メモリは、さらに、4:1 の比率で高優先順位と低優先順位区画に分けられます。デフォルト トラフィック(Web、電子メール、およびファイル共有)がデフォルト キュー(これは 24 KB だけです)を占有し始めると、パケットは入り口インターフェイスでドロップし始めます。これは、VoIP トラフィックがそのキュー バッファのいずれを使用している場合でも発生します。TCP 指向アプリケーションのパケットがドロップすると、こういったアプリケーションはいずれもデータを再送信するため、ネットワークの輻輳した状態がさらに悪化します。1 つのキューで同じシナリオが設定されているが、輻輳を回避するために複数のしきい値が使用されている場合、デフォルト トラフィックは、VoIP 制御トラフィックとバッファ スペース全体を共有します。輻輳中に限り、バッファ メモリ全体が飽和状態に近づくと、優先順位の低いトラフィック(HTTP および電子メール)がドロップします。

この仮説は、Cisco AVVID で複数のキューが回避されることを意味するものではありません。先に述べたとおり、VoIP ベアラ ストリームは、パケット ドロップおよびパケット遅延が音声品質に与える悪影響を除外するために個別のキューを使用する必要があります。ただし、1 つの CoS 値または DSCP 値がそれぞれ固有のキューを取得しないようにしなくてはなりません。結果として生じるデフォルト キューのサイズが小さいため多数の TCP が再送信され、実際にはネットワーク輻輳が増幅するためです。

また、重み付けランダム早期検出(WRED)などの VoIP ベアラ チャネルは、キュー輻輳回避アルゴリズムとしては好ましくない選択肢です。キューしきい値は、事前設定しきい値が指定されている場合に、WRED アルゴリズムを使用してキュー輻輳を管理します。ランダム早期検出(RED)は、バッファ輻輳をモニタリングし、輻輳が増幅し始めると TCP パケットを廃棄することによって機能します。ドロップの結果として、送信エンドポイントがドロップされたトラフィックを検出し、ウィンドウ サイズを調整することによって TCP 送信速度を遅くします。WRED ドロップしきい値は、指定の CoS 値をもつトラフィックがドロップされるバッファ使用率のパーセンテージです。ドロップにより、このバッファは、高優先順位 CoS 値をもつトラフィックに使用できる状態のままにおかれます。ここで重要なことは、アルゴリズム名内の「Random」という単語です。重み付けが設定されていても、WRED はどのフロー内でもパケットを廃棄できます。統計的には、低位の CoS しきい値のパケットからドロップする可能性が高くなります。

マーキング制御および管理トラフィック

トラフィック負荷の高いネットワークでも、ユーザが VoIP を好意的に受け止められるようにしておくのは、制御トラフィックを送信する管理が重要です。このトラフィックの制御が効果を示す例は、Delay to Dial-Tone(DTT)時間に対してです。Cisco IP Phones は、Skinny Station プロトコルを使用して Cisco CallManager と通信します。Cisco IP Phone はオフフックになると、何をすればよいのか Cisco CallManager に「尋ね」ます。すると、Cisco CallManager は、Cisco IP Phone にダイヤル トーンを再生するよう指示します。この Skinny Client プロトコル管理および制御トラフィックがネットワーク内でドロップまたは遅延になると、ユーザの感触に悪影響が及びます。同じような考え方が、ゲートウェイおよび電話のすべてのシグナリング トラフィックにも当てはまります。

この制御および管理トラフィックに必ず「重要」(ただし、実際の RTP ストリームほど重要ではない)というマーキングがされるようにするために、アクセス制御リスト(ACL)を使用して、レイヤ 3/4 についてイネーブルな Catalyst 5000 および 6000 スイッチ上でこれらのストリームが分類されます。Cisco IOS ルータが最初のレイヤ 3 または 4 アクセス ポイントである設計では、ACL が使用されます。これらの設定の例を、第 5 章「ワイドエリア ネットワークの実装」に示してあります。

図 3-4 では、ディストリビューション レイヤにアクセスできるようにするアクセス レイヤ スイッチを持つ、一般的なサーバ ファーム設計を示します。

図 3-4 一般的なサーバ ファーム

 

Skinny プロトコル

Cisco CallManager は TCP ポート 2000 ~ 2002 を使用して IP 電話およびゲートウェイと通信します。次の例示コマンドは、IP 電話およびゲートウェイ(VLAN 110)と Cisco CallManager(4/2)からすべての Skinny プロトコル トラフィックを DSCP 26(IP Precedence 3 とバックワード コンパティビリティがある AF31)として分類します。


) リリース 3.0(5) から、Cisco CallManager には、Cisco CallManager、IP 電話、および Skinny プロトコル ゲートウェイ(AT および AS モデル アナログ ゲートウェイはこれには含まれません)からのすべての VoIP 制御および管理トラフィックについて CoS および ToS 値を設定する能力が組み込まれています。現在、このユーザ設定可能な分類があれば、Skinny プロトコル VoIP 制御トラフィックにマーキングするのにネットワーク要素アクセス リストは不要です。H.323 およびメディア ゲートウェイ コントロール プロトコル(MGCP)トラフィックでは、まだ今後数ヶ月間は、外部ネットワーク要素マーキングが必要です。


次に示すコマンドは、次の機能を実行します。

1. スイッチ全体の QoS をイネーブルにする。

2. アクセス制御リスト(ACL_IP-PHONES)を作成し、IP 電話および 26 という DSCP 値(AF31)を持つ Skinny プロトコル ゲートウェイからのすべての Skinny クライアントおよびゲートウェイ プロトコル トラフィックにマーキングする。

3. ACL_IP-PHONE アクセス リストに追加し、IP 電話からのすべての DSCP マーキングをトラストする。この場合、ToS=5 RTP トラフィックは再作成されません。

4. アクセス制御リスト(ACL_VOIP_CONTROL)を作成し、26 という DSCP 値(AF31)を持つ Cisco CallManager からのすべての Skinny クライアントおよびゲートウェイ プロトコル トラフィックにマーキングする。

5. 着信レイヤ 2 CoS 分類を受け入れる。(現在の 10/100 バージョン 「1」ライン カードは、たとえパーサがエラーを返した場合でも trust-cos がイネーブルになる必要があります。

6. ポートに対して、そのポートに関連付けられているすべての QoS が VLAN ベースで行われるように通知する。

7. IP 電話に対して、IP 電話イーサネット ASIC 内で CoS を PC から CoS=0 に作成し直すよう指示する。

8. Cisco CallManager ポート(4/2)に対して、そのポートと関連付けられたすべての QoS がポート ベースで行われることを通知する。

9. ハードウェアに対してアクセス制御リストを作成する。

10. ACL_IP-PHONE アクセス制御リストを補助 VLAN にマップする。

11. ACL_VOIP_CONTROL アクセス制御リストを Cisco CallManager ポートにマップする。

cat6k-access> (enable) set qos enable

cat6k-access> (enable) set qos acl ip ACL_IP-PHONES dscp 26 tcp any any range 2000 2002

cat6k-access> (enable) set qos acl ip ACL_IP-PHONES trust-cos ip any any

cat6k-access> (enable) set qos acl ip ACL_VOIP_CONTROL dscp 26 tcp any any range 2000 2002

cat6k-access> (enable) set port qos 5/1-48 trust trust-cos

cat6k-access> (enable) set port qos 5/1-48 vlan-based

cat6k-access> (enable) set port qos 5/1-48 trust-ext untrusted

cat6k-access> (enable) set port qos 4/2 port-based

cat6k-access> (enable) commit qos acl all

cat6k-access> (enable) set qos acl map ACL_IP-PHONES 110

cat6k-access> (enable) set qos acl map ACL_VOIP_CONTROL 4/2

 

H.323 プロトコル

Cisco CallManager は、TCP ポート 1720(H.225)および 11xxx(H.245)を使用して H.323 ゲートウェイと通信します。次のコマンドの例では、Cisco CallManager(4/2)および H.323 ゲートウェイ(4/3)から H.323 を DSCP 26(IP Precedence 3 とバックワード コンパティビリティがある AF31)として分類します。

cat6k-access> (enable) set qos acl ip ACL_VOIP_CONTROL dscp 26 tcp any any eq 1720

cat6k-access> (enable) set qos acl ip ACL_VOIP_CONTOL dscp 26 tcp any any range 11000 11999

cat6k-access> (enable) set port qos 4/2 port-based

cat6k-access> (enable) set port qos 4/3 port-based

cat6k-access> (enable) commit qos acl ACL_VOIP_CONTROL

cat6k-access> (enable) set qos acl map ACL_VOIP_CONTROL 4/2

cat6k-access> (enable) set qos acl map ACL_VOIP_CONTROL 4/3

 

MGCP

Cisco CallManager は、ユーザ データグラム プロトコル(UDP)ポート 2427 を使用してメディア ゲートウェイ コントロール プロトコルと通信します。次のコマンドの例では、Cisco CallManager(4/2)および MGCP ゲートウェイ(4/4)から MGCP 制御トラフィックを DSCP 26(IP Precedence 3 とバックワード コンパティビリティを持つ AF31)として分類します。

cat6k-access> (enable) set qos acl ip ACL_VOIP_CONTROL dscp 26 udp any any eq 2427

cat6k-access> (enable) set port qos 4/2 port-based

cat6k-access> (enable) set port qos 4/4 port-based

cat6k-access> (enable) commit qos acl ACL_VOIP_CONTROL

cat6k-access> (enable) set qos acl map ACL_VOIP_CONTROL 4/2

cat6k-access> (enable) set qos acl map ACL_VOIP_CONTROL 4/4

 

例3-1 では、アクセス制御リスト(ACL)が正しい VLAN およびポートに接続されていることを確認するためのコマンドとその関連出力を示します。

例3-1 ACL の確認

cat6k-access> (enable) sh qos acl map run all
 
ACL name Type Vlans
-------------------------------- ---- -------------------------------
ACL_IP-PHONES IP 110,111,112
ACL name Type Ports
-------------------------------- ---- -------------------------------
ACL_IP-PHONES IP
 
ACL name Type Vlans
-------------------------------- ---- -------------------------------
ACL_VOIP_CONTROL IP
ACL name Type Ports
-------------------------------- ---- -------------------------------
ACL_VOIP_CONTROL IP 4/2,4/3,4/4
 

Catalyst 6000 アクセス レイヤ

Cisco AVVID ソリューションの最もよく知られたキャンパス設定の 1 つとして、ワイヤリング クローゼットとディストリビューションおよびコア レイヤの両方で Catalyst 6000 スイッチを使用する設定があります。これには、次のような理由があります。

Catalyst 6000 は、インライン電源を IP 電話に供給できる。

Catalyst 6000 は、最高の成長潜在能力を提示する。

Catalyst 6000 は、Cisco 製品ラインで最高性能のレイヤ 2/3 キャンパス QoS ツールをサポートする。

図 3-5 では、本書で説明されている Catalyst 6000 QoS 設定の一般的なモデルを示します。

図 3-5 Catalyst 6000 QoS 設定の一般的なモデル

 

Catalyst 6000 は、ポリシー機能カード(PFC)ドーター カードの追加により、レイヤ 2、3、および 4 QoS 問題を本質的に扱うことができます。PFC を使用して、パケット分類とマーキング、スケジューリング、レイヤ 2 またはレイヤ 3 および 4 ヘッダー情報に基づく輻輳回避など、拡張 QoS ツールをイネーブルにできます。しきい値を持つ複数の受信および送信キューを設定し、スイッチに設定された QoS ポリシー ルールに従って使用できます。

Catalyst 6000 には、2 つのバージョンの Supervisor Engines、Sup1 と Sup1A があります。Catalyst 6000 ライン カードも 2 つのバージョンがあり、2 番目のものは「A」製品番号でも示されます。すべての Catalyst 6000 イーサネット モジュールは、4 つのしきい値と、それぞれ 2 つのしきい値を持つ 2 つの送信キューを使用して 1 つの受信キューをサポートします。「A」カードには、入り口のインターフェイスと出力インターフェイスの両方に対して追加の優先度キューを提供する拡張 QoS 機能が組み込まれています。これらのキューは、加重ラウンドロビン(WRR)方式で処理されます。ただし、優先度キューの場合は例外です。これは、フレームがキューに入るとすぐに処理されます。ポートがどのように設定されているのかを見るためには、 show port capabilities <mod/port> CatOS コマンドを出します。ポートのデフォルトの QoS ケイパビリティは、 set qos map <port_type> rx | tx <queue#> <threshold#> および set qos wred-threshold コマンドを使用して変更できます。キュー しきい値を変更する場合、優先順位の高いキューほど、大きな数値を持つことに注意してください。

Catalyst 6000 送信インターフェイスのスケジューリングは、WRR アルゴリズムによって管理されます。各キューには、ユーザ設定可能加重が与えられます。デフォルトでは、(優先順位の)「高い」キューにはスケジューラ時間の 98% が与えられ、「低い」キューには 2% が与えられます。この比率により、結果的に、低遅延トレランスを持つパケットはキュー内では遅延されないことになります。これもまた、(優先順位の)「低い」キューにインターフェイス バッファ全体の大部分のパーセンテージが与えられる理由です。優先度キュー(PQ)が設定されると、常に、それが最初に処理されます。PQ にフレームがない場合、WRR は他の 2 つのキューをスケジュールし始めます。

Catalyst 6000 ポート スケジューリングおよびキューイング スキーム

この項では、Catalyst 6000 上でのポート スケジューリングおよびキューイングのための推奨設定をいくつか示します。

受信インターフェイス

優先度キューが必要かにより、受信インターフェイスには、可能な設定が 2 つあります。

1Q4T

4 つのドロップしきい値を持つ 1 つの標準キュー。

10/100 Mbps 用の 8-KB の受信バッファ

1000 Mbps 用の 64-KB の受信バッファ

すべての 10/100/1000 Mbps モジュールで使用可能

ドロップしきい値のデフォルト値は、次のとおりです。

 

バッファ キャパシティの %
ドロップ CoS 値

50%

0-1

60%

2-3

80%

4-5

100%

6-7

1P1Q4T

1 つの優先度キュー(PQ)と、4 つのドロップしきい値を持つ 1 つの標準キュー。

ライン カードに応じて、10/100/1000 Mbps モジュールの特定のバージョンでのみ使用可能。

デフォルトでは、すべての CoS フレームは PQ に入れられます。この場合、厳密な優先順位スケジューリング アルゴリズムが使用されます。

標準キュー内のドロップしきい値のデフォルト値は、次のとおりです。

 

キュー #
バッファ キャパシティの %
ドロップ CoS 値

1

50%

0-1

1

60%

2-3

1

80%

4

1

100%

6-7

2

100%

5

送信インターフェイス

優先度キューが必要かどうかにより、送信インターフェイスには、可能な設定が 2 つあります。

2Q2T

2 つのドロップしきい値を持つ 2 つの標準キュー。高優先度キューには合計キュー サイズの 20% が割り当てられ、低優先度キューには合計キュー サイズの 80% が割り当てられます。

すべての 10/100/1000 Mbps モジュールで使用可能

ドロップしきい値のデフォルト値は、次のとおりです。

 

キュー #
バッファ キャパシティの %
ドロップ CoS 値

1 - 低優先順位 - 合計キュー サイズの 80%

40%

0-1

100%

2-3

2 - 高優先順位 - 合計キュー サイズの 20%

40%

4-5

100%

6-7

1P2Q2T

1 つの優先度キュー(PQ)と、2 つのドロップしきい値を持つ 2 つの標準キュー デフォルトでは、すべての CoS 5 フレームは PQ に入っています。この場合、この PQ が最初に処理され、PQ が空の場合、残りのキューでは WRR が使用されるという、厳密な優先順位スケジューリング アルゴリズムが使用されます。PQ には、高優先度キューの場合と同様、合計キュー サイズの 15 % が割り当てられます。低優先度キューには、合計キュー サイズの 70% が割り当てられます。

ライン カードに応じて、10/100/1000 Mbps モジュールの特定のバージョンでのみ使用可能

ドロップしきい値のデフォルト値は、次のとおりです。

 

キュー #
バッファ キャパシティの %
ドロップ CoS 値

1 - 低優先順位 - 合計キュー サイズの 70%

40%

0-1

100%

2-3

2 - 高優先順位 - 合計キュー サイズの 15%

40%

4

100%

6-7

3 - 優先度キュー - 合計キュー サイズの 15%

100%

5

QoS パラメータの設定

IP 電話をワイヤリング クローゼット スイッチに接続(第 2 章「IP 電話の接続」を参照)したら、スイッチで QoS パラメータを設定します。これには、すべてのポート上での複数のキューのセットアップ、キューへのアクセスの設定、トラフィック ドロップのしきい値の設定、およびディストリビューションまたはコア レイヤへのスイッチの接続が含まれます。次の項では、これらのステップについて詳しく説明します。

IP 電話ポート キューイング

図 3-6 に示されているとおり、IP 電話に接続するのに単一のケーブルを使用する場合、アクセス ポートは、接続されている PC ではなく、IP 電話をトラストするよう設定されます。ポートは、複数の送信キューも使用するよう設定されます。送信キューのうち、1 つは音声トラフィック用の優先度キューです。

図 3-6 単一ケーブルを使用しての IP 電話への接続

 

次のコマンドで、これらの機能を実行することにより、アクセス レイヤ Catalyst 6000 上で QoS をイネーブルにします。

1. スイッチ全体の QoS をイネーブルにする。

2. ポートと関連付けられているすべての QoS が VLAN ベースで行われることをポートに通知する。

3. IP 電話に、IP 電話イーサネット ASIC 内で CoS を PC から CoS=0 に作成し直すよう指示する。

4. 着信レイヤ 2 CoS 分類を受け入れる。(現在の 10/100 バージョン 「1」ライン カードは、たとえパーサがエラーを返した場合でも trust-cos がイネーブルになる必要があります。

5. 着信レイヤ 3 ToS 分類(10/100 ポートでのみ必要)を受け入れるアクセス リストを作成する。

6. ハードウェアに対してアクセス リストを作成する。

7. アクセス リストを補助 VLAN にマップする。

cat6k-access> (enable) set qos enable
cat6k-access> (enable) set port qos 5/1-48 vlan-based
cat6k-access> (enable) set port qos 5/1-48 trust-ext untrusted
cat6k-access> (enable) set port qos 5/1-48 trust trust-cos
cat6k-access> (enable) set qos acl ip ACL_IP-PHONES trust-cos any
cat6k-access> (enable) commit qos acl ACL_IP-PHONES
cat6k-access> (enable) set qos acl map ACL_IP-PHONES 110
 

QoS が Catalyst 6000 アクセス レイヤ スイッチ上でイネーブルになっていると、大幅な輻輳期間中に正常なコール制御を確保するために、次のコマンドを使用して、すべての CoS=3(VoIP 制御)トラフィックを小さいドロップしきい値で 2 番目の送信キューに入れることができます。すべての CoS=5(VoIP RTP ベアラ)トラフィックは、2 番目のキューに自動的に入れられます。

cat6k-access> (enable) set qos map 2q2t tx 2 1 cos 3
 

IP 電話アクセス ポート設定の検証

サービス品質(QoS)を実装する基本的なプロセスの 1 つとして、設定が予想通りに実際に実行しているかどうかを検証することができます。Catalyst 6000 アクセス レイヤ スイッチで、次のコマンドの出力を調べることにより、高輻輳期間中の設定性能を検証できます。

show port qos <mod/port>

このコマンドは、指定されたポートの QoS 設定を示します。例3-2 を参照してください。

show qos info runtime <mod/port>

このコマンドは、指定されたポートの QoS 実行時情報を示します。例3-3 を参照してください。

show mac <mod/port>

このコマンドは、指定されたポートのメディア アクセス制御(MAC)情報を示します。例3-4 を参照してください。

show qos statistics l3

このコマンドは、すべてのポートの要約 QoS 統計情報を示します。例3-5 を参照してください。

show qos stat <mod/port>

このコマンドは、指定されたポートの詳細な QoS 統計情報を示します。例3-6 を参照してください。

例3-2 QoS 設定の表示

cat6k-access> (enable) sh port qos 5/1

QoS is enabled for the switch

QoS policy source for the switch set to local.

 

Port Interface Type Interface Type Policy Source Policy Source

config runtime config runtime

----- -------------- -------------- ------------- -------------

5/1 vlan-based vlan-based COPS local

 

Port TxPort Type RxPort Type Trust Type Trust Type Def CoS Def CoS

config runtime config runtime

----- ------------ ------------ ------------ ------------- ------- -------

5/1 2q2t 1q4t trust-cos trust-cos* 0 0

 

Port Ext-Trust Ext-Cos

----- --------- -------

5/1 untrusted 0

 

(*)Runtime trust type set to untrusted.

 

Config:

Port ACL name Type

----- -------------------------------- ----

No ACL is mapped to port 5/1.

ACL is mapped to VLAN

Runtime:

Port ACL name Type

----- -------------------------------- ----

No ACL is mapped to port 5/1.

 

例3-3 QoS 実行時情報の表示

cat6k-access>(enable) sh qos info run 5/1
Run time setting of QoS:
QoS is enabled
Policy Source of port 5/1: Local
Current 10/100 "1" linecards support 2q2t/1q4t only
Tx port type of port 5/1 : 2q2t
Rx port type of port 5/1 : 1q4t
Interface type: vlan-based
ACL is mapped to VLAN
ACL attached:
The qos trust type is set to trust-cos.
Warning: Runtime trust type set to untrusted.
Default CoS = 0
Queue and Threshold Mapping for 2q2t (tx):
Queue Threshold CoS
----- --------- ---------------
1 1 0 1
1 2 2
2 1 3 4 5
2 2 6 7
Queue and Threshold Mapping for 1q4t (rx):
Queue Threshold CoS
----- --------- ---------------
1 1 0 1
1 2 2
1 3 3 4 5
1 4 6 7
. . .
 

例3-4 MAC 情報の表示

cat6k-access> (enable) sh mac 5/1

 

Port Rcv-Unicast Rcv-Multicast Rcv-Broadcast

-------- -------------------- -------------------- --------------------

5/1 267223 37 4

 

Port Xmit-Unicast Xmit-Multicast Xmit-Broadcast

-------- -------------------- -------------------- --------------------

5/1 28748894 5206 72

 

Port Rcv-Octet Xmit-Octet

-------- -------------------- --------------------

5/1 17178128 1840430081

 

"Out-Discards" are packets drooped due to congestion in the tx interface buffers

MAC Dely-Exced MTU-Exced In-Discard Out-Discard

-------- ---------- ---------- ---------- -----------

5/1 0 0 0 262140

 

例3-5 QoS 要約統計情報の表示

cat6k-access> (enable) sh qos stat l3

VoIP Control packets that have been re-written with CoS=3/DSCP=26 (AF31)

Packets dropped due to policing: 0

IP packets with ToS changed: 1885

IP packets with CoS changed: 781

Non-IP packets with CoS changed: 0

 

例3-6 QoS 詳細統計情報の表示

cat6k-access> (enable) sh qos stat 5/1
All packets dropped are in the 1st drop threshold of queue #1
Tx port type of port 5/1 : 2q2t
Q # Threshold #:Packets dropped
--- -----------------------------------------------
1 1:393210 pkts, 2:0 pkts
2 1:0 pkts, 2:0 pkts
Rx port type of port 5/1 : 1q4t
Q # Threshold #:Packets dropped
--- -----------------------------------------------
1 1:0 pkts, 2:0 pkts, 3:0 pkts, 4:0 pkts
 

ディストリビューション スイッチへのアップリンク インターフェイス

すべてのアクセス ポート キューイングを設定したら、ディストリビューション/コア スイッチへのアップリンク インターフェイスも設定する必要があります。これには、トランク ポート(この例では 1/1)に着信するイーサネット フレームについてトラストをイネーブルにし、CoS からキューへのマッピング入力基準を操作し、CoS 値および IP Precedence 値を適切な DSCP 値にマップすることが必要です。これを行う手順については、次の項で概説します。

MLS および Catalyst QoS 設定

IP 電話が Cisco CallManager とは別の VLAN に入っている場合、追加の設定が必要です。レイヤ 3 スイッチングのためにマルチレイヤ スイッチ フィーチャ カード(MSFC)にパケットが送信されたときにはいつでも、CoS は 0 に設定されます。ほとんどの設定は MSFC がディストリビューション レイヤ スイッチに入っているため、アクセス レイヤ スイッチは、ディストリビューション レイヤからのアップリンク トランク上のすべての DSCP タギングをトラストする必要があります。これにより、DSCP マーキングが保持され、ワイヤリング クローゼット スイッチ内の DSCP と CoS 間のレイヤ 3 分類に使用できます。レイヤ 2 アップリンクに trust-cos を、レイヤ 3 アップリンクに trust-dscp を使用します。たとえば、次のとおりに使用します。

cat6k-access> (enable) set port qos 1/1 trust trust-dscp
 

Catalyst 6000 送信キュー設定

すべての VoIP(CoS=5)トラフィックは、QoS をイネーブルすると即時に、1p2q2t インターフェイス上では出力インターフェイス優先度キューに、2q2t インターフェイス上ではキュー 2 に入れられます。ただし、CoS=3(VoIP 制御)トラフィックが必ず 2 番目のキューに入れられるように、Catalyst 6000 CoS キュー許可ルールを設定するという追加のステップを実行する必要があります。この設定を実行するには、次のコマンドを使用します。

cat6k-access> (enable) set qos map 1p2q2t tx 2 1 cos 3
cat6k-access> (enable) set qos map 2q2t tx 2 1 cos 3
 

Catalyst 6000 CoS/ToS から DSCP へのマッピング設定

シスコでは、VoIP コントロール プレーン トラフィックと VoIP ベアラまたはメディア プレーン トラフィックの両方について DSCP 分類値を設定するためのインターネット技術特別調査委員会(IETF)勧告に従っています。推奨設定は、VoIP コントロール プレーンについては DSCP=AF31、VoIP ベアラ プレーンについては DSCP=EF です。レイヤ 2 CoS およびレイヤ 3 IP Precedence 設定をこれらの DSCP 値に正しくマップするには、次のように、デフォルトの CoS/ToS から DSCP へのマッピングを修正する必要があります。

cat6k-distrib> (enable) set qos cos-dscp-map 0 8 16 26 32 46 48 56
cat6k-distrib> (enable) set qos ipprec-dscp-map 0 8 16 26 32 46 48 56
 

CoS/ToS から DSCP へのマッピングの検証

CoS および ToS 設定が DSCP 値に正しくマップされることを検証するには、次の 2 つのコマンド(それぞれの関連する出力と一緒に示されています)を使用します。

cat6k-distrib> (enable) sh qos map run cos-dscp-map
CoS - DSCP map:
CoS DSCP
--- ----
0 0
1 8
2 16
3 26 -> 26 = AF31
4 32
5 46 -> 46 = EF
6 48
7 56
 
cat6k-distrib> (enable) sh qos map run ipprec-dscp-map
IP-Precedence - DSCP map:
IP-Prec DSCP
------- ----
0 0
1 8
2 16
3 26 -> 26 = AF31
4 32
5 46 -> 46 = EF
6 48
7 56
 

Catalyst 4000 アクセス レイヤ

Cisco AVVID ネットワークのよく知られている別のキャンパス設定は、ワイヤリング クローゼットで Catalyst 2948G、2980G、および 4000 シリーズのスイッチを使用します。これには、次のような理由があります。

Catalyst 4006 は、インライン電源を IP 電話に供給できる。

Catalyst 4000 は、ポート当たりきわめて低価格を実現する。

これらのスイッチは、きわめてスケーラブルな高速スイッチングを提供する。

CatOS リリース 5.2 から、Catalyst 4000 ラインは、各インターフェイスで二重送信をサポートします。キューへの許可は、レイヤ 2 CoS マーキングに基づいており、802.1p ユーザ プライオリティのペアで設定可能です。

Catalyst 4000 ポート スケジューリングおよびキューイング スキーム

この項では、Catalyst 4000 上でのポート スケジューリングおよびキューイングのための推奨設定をいくつか示します。

受信インターフェイス

受信インターフェイスの推奨設定は、次のとおりです。

FIFO

1 つの標準 FIFO(先入れ先出し)キュー。

送信インターフェイス

送信インターフェイスの推奨設定は、次のとおりです。

2Q1T

1 つのしきい値を持つ 2 つの標準キュー。スケジューリングは、ラウンドロビン(RR)ベースで行われます。キューへの許可は、802.1p CoS 値に基づいており、ペアでユーザ設定可能です。QoS をイネーブルにするが、CoS から送信キューへのマッピングを修正しない場合、すべてのトラフィックがキュー 1 に割り当てられるため、スイッチ性能に影響する可能性があります。


) QoS が Catalyst 4000 でイネーブルになったら、新たに作成されたキューを利用するよう CoS マッピングを変更する必要があります。


Catalyst 4000 のデフォルトのキュー許可基準は、次のとおりです。

 

キュー #
キュー許可 CoS 値

1

0-7

2

ブロードキャスト、マルチキャスト、および不明のトラフィック

図 3-7 では、本書で説明されている Catalyst 4000 QoS 設定の一般的なモデルを示します。

図 3-7 Catalyst 4000 QoS 設定の一般的なモデル

 

Catalyst 4000 スイッチ全体の QoS

デフォルトでは、スイッチの Catalyst 4000 ラインでイネーブルになるキューは 1 つだけです。CatOS Release 5.5.1 内の 2 番目のキューを使用できるようにするには、 set qos map コマンドを使用します。VoIP 制御(CoS=3)フレームは、Catalyst 4000 の 2 番目のキューに入れる必要があります。Catalyst 4000 は最初の 2 つの CoS ビットのみを調べるため、これらのマップは、CoS 値のペアで設定する必要があります。たとえば、次のように設定します。

cat4k> (enable) set qos enable
cat4k> (enable) set qos map 2q1t 1 1 cos 0-1
cat4k> (enable) set qos map 2q1t 2 1 cos 2-3
cat4k> (enable) set qos map 2q1t 2 1 cos 4-5
cat4k> (enable) set qos map 2q1t 2 1 cos 6-7
 

Catalyst 4000 キュー許可設定の検証

Catalyst 4000 でのキュー許可設定を検証するには、次のコマンド(その関連出力と一緒に示されています)を使用します。

cat4k> (enable) show qos info runtime
Run time setting of QoS:
QoS is enabled
All ports have 2 transmit queues with 1 drop thresholds (2q1t).
Default CoS = 0
Queue and Threshold Mapping:
Queue Threshold CoS
----- --------- ---------------
1 1 0 1
2 1 2 3 4 5 6 7
 

IP 電話ポート キューイング

CatOS リリース 5.5.1 では、Catalyst 4000 ラインでは、拡張 IP 電話キューイング機能を提供していません。このため、Catalyst 4000 は、IP 電話でのデフォルトの CoS マーキングおよび強制に依存します。詳しくは、第 2 章「IP 電話の接続」を参照してください。

ディストリビューション スイッチへのアップリンク インターフェイス

リンクの Catalyst 4000 側(アクセス レイヤ Catalyst 4000 からディストリビューション レイヤ Catalyst 6000 まで)で特別なキューイングまたはスケジューリング コマンドを設定する必要はありません。QoS がイネーブルになっており、分類およびキュー許可が設定されると、キューイングは自動的にイネーブルになるためです。

Catalyst 4000 をレイヤ 3 エンジン(スイッチについて IP、IPX、および Multicast ルーティングをイネーブルにする WS-X4232)と一緒に使用している場合、その他のアップリンク設定を実行できます。レイヤ 3 エンジンは、Catalyst 4000 をイネーブルにして、2 ギガビット アップリンクにおける入力基準の IP 優先順位に基づいて 4 つの送信キューをサポートします。この 4 つのキューは、ユーザ設定可能 WRR アルゴリズムを使用してスケジュールされます。この場合、送信インターフェイス設定は、次のとおりです。

4Q1T

1 つのしきい値を持つ 4 つの標準キュー。スケジューリングは、ラウンドロビン(RR)ベースで行われます。キューへの許可は、802.1p CoS 値に基づいており、ペアでユーザ設定可能です。


) QoS が Catalyst でイネーブルになったら、新たに作成されたキューを利用するよう CoS マッピングを変更する必要があります。レイヤ 3 キューの番号付けはレイヤ 2 の番号付けの逆であることに注意してください。


Catalyst 4000 のデフォルトのレイヤ 3 1000-Mbps アップリンク キュー許可基準は、次のとおりです。

 

キュー #
キュー許可 IP Precedence 値

1

6-7

2

4-5

3

2-3

4

0-1

Catalyst 3500 アクセス レイヤ

Catalyst 2900 および Catalyst 3500 シリーズの Cisco AVVID 機能は、12.0(5)XU という最小限の Cisco IOS リリースがあると、IP 電話とのインタラクションを許可して、CoS マーキング ルールを拡張できるようになります。さらに、Catalyst 2900 XL および 3500 XL スイッチは、ポートごとにデフォルトの CoS 優先順位を設定することにより、入力ポートでタグなしパケットを分類できます。ただし、これらのスイッチ(3548 X を除く)は、タグ付きパケットを再分類することはできないため、802.1p 優先順位のみを有効とし、パケットを適切な送信キューに入れます。8 MB DRAM を備えたすべての Catalyst 3500 スイッチおよびすべての Catalyst 2900 XL スイッチは、これらの QoS 機能をサポートします。4 MB DRAM を備えた Catalyst 2900 XL は QoS 機能をサポートしません。

Catalyst 3500 ポート スケジューリングおよびキューイング スキーム

この項では、Catalyst 3500 上でのポート スケジューリングおよびキューイングのための推奨設定をいくつか示します。

受信インターフェイス

受信インターフェイスの推奨設定は、次のとおりです。

1Q-FIFO

1 つの標準 FIFO(先入れ先出し)キュー。

送信インターフェイス 10/100 ポート

10/100 ポート用の送信インターフェイスの推奨設定は、次のとおりです。

2Q1T

1 つのドロップしきい値を持つ 2 つの標準キュー。スケジューリングは、優先順位スケジューリング ベースで行われます。キューへの許可は 802.1p CoS またはポート優先順位 CoS 値に基づいており、ユーザ設定可能ではありません。

Catalyst 3500 のキュー許可基準は、次のとおりです。

 

キュー #
キュー許可 CoS 値

1

0-3

2

4-7

送信インターフェイス ギガビット イーサネット ポート

ギガビット イーサネット ポート用の送信インターフェイスの推奨設定は、次のとおりです。

8Q-FIFO

1 つのドロップしきい値を持つ 8 個の標準キュー。現在のところ、使用されるキューは 2 つだけです。スケジューリングは、優先順位スケジューリング ベースで行われます。キューへの許可は 802.1p またはポート優先順位 CoS 値に基づいており、ユーザ設定可能ではありません。

ギガビット イーサネット キュー許可基準は、次のとおりです。

 

キュー #
キュー許可 CoS 値

1

0-3

2

4-7

3-8

未使用

図 3-8 では、本書で説明されている Catalyst 3500 QoS 設定の一般的なモデルを示します。

図 3-8 Catalyst 3500 QoS 設定の一般的なモデル

 

IP 電話ポート キューイング

IP 電話を取り付けるのに単一のケーブルを使用する場合、アクセス ポートは、接続されている PC ではなく、IP 電話をトラストするよう設定されます。ポートは、すべてのインターフェイスで複数の送信キューを使用するように設定されます。

IP 電話ポート キューイングを設定するためのコマンドは、次のとおりです。

interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 12
switchport mode trunk
switchport voice vlan 112
switchport priority extend cos 0
spanning-tree portfast
 

ディストリビューション スイッチへのアップリンク インターフェイス

Catalyst 3500 XL シリーズ スイッチのワイヤリング クローゼット設定用の推奨設計は、Catalyst 3524 PWR XL が Catalyst 3508 に接続されたスタートポロジです。これには、ディストリビューション レイヤ Catalyst 6000 スイッチへの二重アップリンクがあります。これらのアップリンクは、アップリンク全体にまたがったギガビット イーサネット リンク負荷バランシング VLAN であり、高速レイヤ 2 輻輳用の UplinkFast を使用して設定されます。


) Catalyst 3500 シリーズ GigaStack 設定は、基本的に共有メディア アクセス モデルであるため、保証音声 QoS を提供できません。


この設定のためのコマンドは、次のとおりです。

interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
 

Catalyst 6000 アクセス レイヤ

アクセス スイッチを設定し、それをディストリビューション レイヤに接続した後で、ディストリビューション スイッチ上でサービス品質(QoS)をセットアップする必要があります。これには、ディストリビューション スイッチの設定に対して次のように変更することが必要です。

VoIP 制御トラフィック送信キューを設定する。

レイヤ 3 アクセス スイッチを使用してディストリビューション レイヤを設定する。

アクセス レイヤからトラスト ToS および DSCP をイネーブルにする。

ToS から DSCP へのマッピングを設定する。

レイヤ 2 アクセス スイッチを使用してディストリビューション レイヤを設定する。

アクセス レイヤからトラスト CoS および DSCP をイネーブルにする。

CoS から DSCP へのマッピングを設定する。

VoIP 制御トラフィック分類用にレイヤ 3 アクセス リストを設定する。

Cisco 7200 WAN ルータへの接続を設定する。

図 3-9 では、これらの Catalyst 6000 ディストリビューション レイヤ設定の一般的なモデルを示します。これらの設定については、次の項で説明します。

図 3-9 Catalyst 6000 ディストリビューション レイヤ設定の一般的なモデル

 

Catalyst 6000 ディストリビューション レイヤ VoIP 制御トラフィック送信キューの設定

QoS がイネーブルになると即時に、すべての VoIP(CoS=5)トラフィックは、(10/100 ライン カードのすべてのバージョン「1」について)1p2q2t インターフェイス上では出力インターフェイス優先度キューに、2q2t インターフェイス上ではキュー #2に入れられます。CoS=3 トラフィック フロー(VoIP 制御トラフィック)が必ず 2 番目のキューに入れられるように、Catalyst 6000 CoS キュー許可ルールを設定するという追加のステップも実行する必要があります。

この設定のためのコマンドは、次のとおりです。

cat6k-distrib> (enable) set qos map 1p2q2t tx queue 2 1 cos 3
cat6k-distrib> (enable) set qos map 2q2t tx queue 2 1 cos 3
 

Catalyst 6000-PFC アクセス レイヤを使用しての、Catalyst 6000 ディストリビューション レイヤ設定

ディストリビューション レイヤ スイッチ上で QoS をイネーブルにし、デフォルトのキュー許可を修正すると、レイヤ 3 についてイネーブルなアクセス レイヤ スイッチとの統合を完了するためにさらに 2 つの設定ステップを行う必要があります。

アクセス レイヤからトラスト DSCP をイネーブルにする。

ToS から DSCP へのマッピングを設定する。

レイヤ 3 アクセス スイッチからのトラスト DSCP

トラスト DSCP 値を隣接するレイヤ 3 アクセス スイッチからイネーブルにします。トランキング ポート上ではポート ベースの QoS を使用し、 trust-cos の代わりに trust-dscp を使用します。これは、 trust-cos は、マップされた CoS でレイヤ 3 DSCP を上書きするので、アクセス レイヤで分類が行われるまでこれを行う必要がないためです。

この設定のためのコマンドは、次のとおりです。

cat6k-distrib> (enable) set port qos 1/1 port-based
cat6k-distrib> (enable) set port qos 1/1 trust trust-dscp
 

Catalyst 6000 ToS から DSCP へのマッピング設定

シスコでは、VoIP コントロール プレーン トラフィックと VoIP ベアラまたはメディア プレーン トラフィックの両方について DSCP 分類値を設定するためのインターネット技術特別調査委員会(IETF)勧告に従っています。推奨設定は、VoIP コントロール プレーンについては DSCP=AF31、VoIP ベアラ プレーンについては DSCP=EF です。レイヤ3 IP Precedence 設定をこれらの DSCP 値に正しくマップするには、次のように、デフォルトの ToS から DSCP へのマッピングを修正する必要があります。

cat6k-distrib> (enable) set qos ipprec-dscp-map 0 8 16 26 32 46 48 56
 
cat6k-distrib> (enable) sh qos map run ipprec-dscp-map
IP-Precedence - DSCP map:
IP-Prec DSCP
------- ----
0 0
1 8
2 16
3 26 -> 26 = AF31
4 32
5 46 -> 46 = EF
6 48
7 56
 

アクセス スイッチがレイヤ 2 についてのみイネーブルになっている Catalyst 6000 ディストリビューション レイヤ設定

ディストリビューション レイヤ スイッチで QoS をイネーブルにし、デフォルトのキュー許可を修正したら、レイヤ 2 アクセス スイッチとの統合を完了するためにさらに 3 つの設定ステップを行う必要があります。

アクセス レイヤからトラスト CoS をイネーブルにする。

CoS から DSCP へのマッピングを設定する。

VoIP 制御トラフィック分類用にレイヤ 3 アクセス リストを設定する。(「マーキング制御および管理トラフィック」を参照)

レイヤ 2 アクセス スイッチからのトラスト CoS

CoS 値についてのトラストを隣接するレイヤ 2 アクセス スイッチからイネーブルにします。トランキング ポート上では vlan-based QoS を使用し、 trust-dscp の代わりに trust-cos を使用します。この設定は、アクセス レイヤ スイッチが、CoS 分類を行うレイヤ 2 装置にすぎない場合に使用されます。

この設定のためのコマンドは、次のとおりです。

cat6k-distrib> (enable) set port qos 1/2,3/2 vlan-based
cat6k-distrib> (enable) set port qos 1/2,3/2 trust trust-cos
 

Catalyst 6000 CoS から DSCP へのマッピング設定

シスコでは、VoIP コントロール プレーン トラフィックと VoIP ベアラまたはメディア プレーン トラフィックの両方について DSCP 分類値を設定するための IETF 勧告に従っています。推奨設定は、VoIP コントロール プレーンについては DSCP=AF31、VoIP ベアラ プレーンについては DSCP=EF です。レイヤ 2 設定をこれらの DSCP 値に正しくマップするには、次のように、デフォルトの CoS から DSCP へのマッピングを修正する必要があります。

cat6k-distrib> (enable) set qos cos-dscp-map 0 8 16 26 32 46 48 56
 
cat6k-distrib> (enable) sh qos map run cos-dscp-map
CoS - DSCP map:
CoS DSCP
--- ----
0 0
1 8
2 16
3 26 -> 26 = AF31
4 32
5 46 -> 46 = EF
6 48
 

VoIP 制御トラフィック分類用のレイヤ 3 アクセス リストの設定

VoIP 制御トラフィック分類用にレイヤ 3 アクセス制御リストを設定するには、次のコマンド(その関連出力と一緒に示されています)を使用します。「マーキング制御および管理トラフィック」からの ACL_IP-PHONES アクセス リストも使用してください。

cat6k-distrib> (enable) set port qos 1/2,3/2 vlan-based

cat6k-distrib> (enable) set qos acl map ACL_IP-PHONES 111

 

cat6k-distrib> (enable) sh qos acl map run ACL_IP-PHONES

ACL name Type Vlans

-------------------------------- ---- ---------------------------------

ACL_IP-PHONES IP 110,111,112

ACL name Type Ports

-------------------------------- ---- ---------------------------------

ACL_IP-PHONES IP

 

 

cat6k-distrib> (enable) sh qos acl info run ACL_IP-PHONES

 

set qos acl IP ACL_IP-PHONES

----------------------------------------------

1. dscp 26 tcp any any range 2000 2002

2. dscp 26 tcp any any eq 1720

3. dscp 26 tcp any any range 11000 11999

4. dscp 26 udp any any eq 2427

5. trust-cos any

 


) リリース 3.0(5) から、Cisco CallManager には、Cisco CallManager、IP 電話、および Skinny プロトコル ゲートウェイ(AT および AS モデル アナログ ゲートウェイはこれには含まれません)からのすべての VoIP 制御および管理トラフィックについて CoS および ToS 値を設定する能力が組み込まれています。このユーザ設定可能な分類があれば、Skinny プロトコル VoIP 制御トラフィックにマークを挿入するのにネットワーク要素アクセス リストは不要です。H.323 およびメディア ゲートウェイ コントロール プロトコル(MGCP)トラフィックでは、まだ今後数ヶ月間は、外部ネットワーク要素マーキングが必要となります。


Cisco 7200 WAN ルータへの接続の設定

Cisco 7200 WAN ルータへの接続を設定するには、次のコマンドを使用します。


) 現在の 10/100 バージョン「1」ライン カードは、パーサがエラーを返した場合でも、trust-ipprec がイネーブルになっている必要があります。


cat6k-distrib> (enable) set port qos 9/1 port-based

cat6k-distrib> (enable) set port qos 9/1 trust trust-ipprec

 

cat6k-distrib> (enable) set qos acl ip ACL_TRUST-WAN trust-ipprec any

cat6k-distrib> (enable) commit qos acl ACL_TRUST-WAN

cat6k-distrib> (enable) set qos acl map ACL_TRUST-WAN 9/1

 

cat6k-distrib> (enable) sh port qos 9/1

QoS is enabled for the switch.

QoS policy source for the switch set to local.

 

Port Interface Type Interface Type Policy Source Policy Source

config runtime config runtime

----- -------------- -------------- ------------- -------------

9/1 port-based port-based COPS local

 

Port TxPort Type RxPort Type Trust Type Trust Type Def CoS Def CoS

config runtime config runtime

--------------------------------------------------------------------

9/1 2q2t 1q4t trust-ipprec trust-ipprec 0 0

 

Port Ext-Trust Ext-Cos

----- --------- -------

9/1 untrusted 0

 

(*)Runtime trust type set to untrusted.

 

Config:

Port ACL name Type

----- -------------------------------- ----

9/1 ACL_TRUST-WAN IP

Runtime:

Port ACL name Type

----- -------------------------------- ----

9/1 ACL_TRUST-WAN IP

Native IOS を実行する Catalyst 6000 ディストリビューション/コア

アクセス スイッチを設定し、それをディストリビューション レイヤに接続した後で、ディストリビューション スイッチ上でサービス品質(QoS)をセットアップする必要があります。これには、ディストリビューション スイッチの設定に対して次のように変更することが必要です。

QoS を設定する。

VoIP 制御トラフィック送信キューを設定する。

レイヤ 3 アクセス スイッチを使用してディストリビューション レイヤを設定する。

アクセス レイヤからトラスト ToS および DSCP をイネーブルにする。

ToS から DSCP へのマッピングを設定する。

レイヤ 2 アクセス スイッチを使用してディストリビューション レイヤを設定する。

アクセス レイヤからトラスト CoS および DSCP をイネーブルにする。

CoS から DSCP へのマッピングを設定する。

VoIP 制御トラフィック分類用に QoS ポリシーおよびレイヤ 3 アクセス リストを設定する。

図 3-10 では、Catalyst 6000 ディストリビューション レイヤ スイッチ上で Native Cisco IOS を実行する設定の一般的モデルを示します。設定の詳細については、これ以降の項で説明します。

図 3-10 Catalyst 6000 ディストリビューション レイヤ スイッチ上で実行する Native Cisco IOS の一般的なモデル

 

Native Cisco IOS Catalyst 6000 上での QoS の設定

Native Cisco IOS を使用して Catalyst 6000 上で QoS をイネーブルにするには、次のコマンドを使用します。

mls qos
 

VoIP 制御トラフィック用の送信キュー許可の設定

QoS がイネーブルになると即時に、すべての VoIP(CoS=5)トラフィックは、(10/100 ライン カードのすべてのバージョン「1」について)1p2q2t インターフェイス上では出力インターフェイス優先度キューに、2q2t インターフェイス上ではキュー #2に入れられます。CoS=3 トラフィック フロー(VoIP 制御トラフィック)が必ず 2 番目のキューに入れられるように、Catalyst 6000 CoS キュー許可ルールを設定するという追加のステップも実行する必要があります。

この設定のためのコマンドは、次のとおりです。

int range gigabitEthernet 1/1 - 2
wrr-queue cos-map 1 2 2
wrr-queue cos-map 2 1 3 4
 

Catalyst 6000-PFC を使用した、Catalyst 6000 Native Cisco IOS ディストリビューション レイヤ設定

Native Cisco IOS ディストリビューション レイヤ スイッチ上で QoS をイネーブルにし、デフォルトのキュー許可を修正すると、レイヤ 3 についてイネーブルなアクセス レイヤ スイッチとの統合を完了するために、さらに 2 つの設定ステップを行う必要があります。

アクセス レイヤからトラスト DSCP をイネーブルにする。

ToS から DSCP へのマッピングを設定する。

レイヤ 3 アクセス スイッチからのトラスト DSCP

トラスト DSCP 値を隣接するレイヤ 3 アクセス スイッチからイネーブルにします。とランキング ポート上ではポート ベースの QoS を使用し( mls qos が設定された場合、ポート ベース QoS はデフォルトではイネーブルです)、CatOS trust-dscp の代わりに mls qos trust dscp を使用します。


) 分類は、必ず、このモデルのアクセス レイヤで設定されています。


この設定のためのコマンドは、次のとおりです。

interface GigabitEthernet2/1
description trunk port to PFC enabled cat6k-access
no ip address
wrr-queue cos-map 1 2 2
wrr-queue cos-map 2 1 3 4
mls qos trust dscp
switchport
switchport trunk encapsulation dot1q
switchport mode trunk

レイヤ 3 アクセス スイッチ用の Native Cisco IOS の ToS から DSCP へのマッピング設定

シスコでは、VoIP コントロール プレーン トラフィックと VoIP ベアラまたはメディア プレーン トラフィックの両方について DSCP 分類値を設定するための IETF 勧告に従っています。推奨設定は、VoIP コントロール プレーンについては DSCP=AF31、VoIP ベアラ プレーンについては DSCP=EF です。レイヤ3 IP Precedence 設定をこれらの DSCP 値に正しくマップするには、デフォルトの ToS から DSCP へのマッピングを修正する必要があります。


) 26 および 46 という Catalyst 6000 数値は、それぞれ DSCP=AF31 および DSCP=EF と相関関係があります。これは、グローバル設定モードで行われます。


この設定のためのコマンドは、次のとおりです。

mls qos map ip-prec-dscp 0 8 16 26 32 46 56 0
 

アクセス スイッチがレイヤ 2 についてのみイネーブルになっている Catalyst 6000 Native Cisco IOS ディストリビューション レイヤ設定

ディストリビューション レイヤ スイッチで QoS をイネーブルにし、デフォルトのキュー許可を修正したら、レイヤ 2 アクセス スイッチとの統合を完了するためにさらに 3 つの設定ステップを行う必要があります。

アクセス レイヤからトラスト CoS をイネーブルにする。

CoS から DSCP へのマッピングを設定する。

VoIP 制御トラフィック分類用にレイヤ 3 アクセス リストを設定する。(「マーキング制御および管理トラフィック」を参照)

レイヤ 2 アクセス スイッチからのトラスト CoS

CoS 値についてのトラストを隣接するレイヤ 2 アクセス スイッチからイネーブルにします。トランキング ポート上でポート ベース QoS を使用し、CatOS trust-cos の代わりに Native IOS コマンド mls qos trust cos を使用します。この設定は、アクセス レイヤ スイッチが、CoS 分類を行うレイヤ 2 装置にすぎない場合に使用されます。

この設定のためのコマンドは、次のとおりです。

interface GigabitEthernet2/2
description trunk port to layer 2-only cat4k
no ip address
wrr-queue cos-map 1 2 2
wrr-queue cos-map 2 1 3 4
mls qos vlan-based
mls qos trust cos
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet3/1
description trunk port to layer 2-only 3500
no ip address
wrr-queue cos-map 1 2 2
wrr-queue cos-map 2 1 3 4
mls qos vlan-based
mls qos trust cos
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
 

レイヤ 2 アクセス スイッチ用の Native IOS の CoS から DSCP へのマッピング設定

シスコでは、VoIP コントロール プレーン トラフィックと VoIP ベアラまたはメディア プレーン トラフィックの両方について DSCP 分類値を設定するための IETF 勧告に従っています。推奨設定は、VoIP コントロール プレーンについては DSCP=AF31、VoIP ベアラ プレーンについては DSCP=EF です。レイヤ 2 設定をこれらの DSCP 値に正しくマップするには、デフォルトの CoS から DSCP へのマッピングを修正する必要があります。


) 26 および 46 という Catalyst 6000 数値は、それぞれ DSCP=AF31 および DSCP=EF と相関関係があります。これは、グローバル設定モードで行われます。


この設定のためのコマンドは、次のとおりです。

mls qos map cos-dscp 0 8 16 26 32 46 56 0

VoIP 制御トラフィック分類用に QoS ポリシーおよびレイヤ 3 アクセス リストを設定する

Native Cisco IOS Catalyst 6000 の QoS 設定は、WAN ルータ Cisco IOS 設定ときわめてよく似ています。ただし、例外として、トラフィック フローにマーキングし、VLAN インターフェイスにサービス ポリシーを適用するためにはポリシー設定を使用します。物理ギガビット イーサネット アップリンク ポートは、 mls qos vlan-based Native Cisco IOS インターフェイス コマンドを使用して VLAN ベースの QoS を使用するよう設定されます。最終的に、 service-policy はアップリンク上のすべての VLAN トラフィック着信に適用されます。

次の例では、3 つのクラスが定義されます。1 つは VoIP メディア ストリーム用で、もう 1 つは制御トラフィック用、最後の 1 つはその他すべてのトラフィック用です。トラフィックは、レイヤ 3 または 4 発信元および宛先 IP アドレスおよびポートに基づいて、これらのクラスを求めてフィルタに掛けられます。これらのクラスはいずれも、 Voice-QoS ポリシー マップ内で参照されます。 policy-map ステートメントでは、ポリシー設定機能を使用して、 class-map アクセス リストと一致した入力基準に適合するすべてのトラフィックが分類されます。


) Catalyst 6000 Native Cisco IOS ソフトウェアは、set ip dscp コマンドをサポートしません。その代わり、トラフィックの分類にはポリシー設定アルゴリズムが使用されます。


このシナリオでは、ポリシー設定コードは、VoIP トラフィックについては AF31、VoIP メディア トラフィックについては EF、その他のパケットについては 0 という DSCP 値を持つトラフィック フローにタグを付けます。「8000」フローのサイズは小さいため、いずれのトラフィックも、構文 conform-action set-dscp-transmit 26 を使用したタギングが必要です。

class-map match-all VoIP-Control

match access-group 100

class-map match-all VoIP-RTP

match access-group 101

class-map match-all Routine

match access-group 102

!

!

policy-map Voice-QoS

class VoIP-Control

police 8000 8000 8000 conform-action set-dscp-transmit 26 exceed action transmit

class VoIP-RTP

police 8000 8000 8000 conform-action set-dscp-transmit 46 exceed-action transmit

class Routine

police 8000 8000 8000 conform-action set-dscp-transmit 0 exceed-action transmit

!

! access-list 100 looks for VoIP Control Traffic

access-list 100 permit tcp any any range 2000 2002

access-list 100 permit tcp any any eq 1720

access-list 100 permit tcp any any range 11000 11999

access-list 100 permit udp any any eq 2427

!

! access-list 101 looks for VoIP Bearer Traffic

access-list 101 permit udp any any range 16384 32767

!

! access-list 102 filters for routine traffic

access-list 102 permit ip any any

!

interface GigabitEthernet2/2

description trunk port to layer 2-only cat4k

no ip address

wrr-queue cos-map 1 2 2

wrr-queue cos-map 2 1 3 4

! inform the port that QoS will be VLAN-Based

mls qos vlan-based

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet3/1

description trunk port to layer 2-only 3500

no ip address

wrr-queue cos-map 1 2 2

wrr-queue cos-map 2 1 3 4

! inform the port that QoS will be VLAN-Based

mls qos vlan-based

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Vlan111

description voice vlan on cat4k

ip address 10.1.111.77 255.255.255.0

ip helper-address 10.1.10.10

no ip redirects

! apply the QoS policy as an inbound policy

service-policy input Voice-QoS

standby 111 ip 10.1.111.1

!

interface Vlan112

description voice vlan on 3500

ip address 10.1.112.77 255.255.255.0

ip helper-address 10.1.10.10

no ip redirects

! apply the QoS policy as an inbound policy

service-policy input Voice-QoS

standby 112 ip 10.1.112.1

 

 

 

ios6k#sh mls qos

QoS is enabled globally

Microflow policing is enabled globally

 

QoS is vlan-based on the following interfaces:

Vl111 V112 Gi2/2 Gi3/1 Gi3/2 Gi3/3

Gi3/4 Gi3/5 Gi3/6 Gi3/7 Gi3/8 Gi4/1 Gi4/2 Gi4/3 Gi4/4 Gi4/5

Gi4/6 Gi4/7 Gi4/8 Fa9/1 Fa9/2 Fa9/3 Fa9/4 Fa9/5 Fa9/6 Fa9/7

Fa9/8 Fa9/9 Fa9/10 Fa9/11 Fa9/12 Fa9/13 Fa9/14 Fa9/15 Fa9/16 Fa9/17

Fa9/18 Fa9/19 Fa9/20 Fa9/21 Fa9/22 Fa9/23 Fa9/24 Fa9/25 Fa9/26 Fa9/27

Fa9/28 Fa9/29 Fa9/30 Fa9/31 Fa9/32 Fa9/33 Fa9/34 Fa9/35 Fa9/36 Fa9/37

Fa9/38 Fa9/39 Fa9/40 Fa9/41 Fa9/42 Fa9/43 Fa9/44 Fa9/45 Fa9/46 Fa9/47

Fa9/48

 

QoS global counters:

Total packets: 16750372458300

Packets dropped by policing: 55930847232

IP packets with TOS changed by policing: 16750372458300

IP packets with COS changed by policing: 55945330688

Non-IP packets with COS changed by policing: 16750372458300

 

要約

この章で説明したとおり、次の一般的ガイドラインおよび推奨事項は、キャンパス環境で Cisco AVVID ネットワークを設定する場合に適用されます。

音声品質を保証するためにすべてのインターフェイス上で複数のキューが必要である。

高速輻輳をイネーブルにするには、Catalyst 2900 XL、3500、2948G、2980G、4000、および 6000 スイッチなど、複数の出力キューを持つワイヤリング クローゼット スイッチで UplinkFast を使用する。

すべての all Cisco AVVID 制御および管理トラフィックを、3 という最大 CoS および ToS 値に設定する。

PC アプリケーションが 4 ~ 7 の CoS または ToS 値でトラフィックを送信するのを許可しない。

ディストリビューション レイヤ スイッチは、レイヤ 3 ToS をレイヤ 2 CoS 値にマップする能力を持っている必要がある。