Cisco IP テレフォニー QoS デザイン ガイド
IP 電話の接続
IP 電話の接続
発行日;2012/01/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

IP 電話の接続

単一ケーブルを使用しての IP 電話の設置

スピードとデュプレックス設定

Catalyst 4000 および 6000

Catalyst 3500 XL および 2900 XL

IP アドレッシング

Catalyst 4000 および 6000

Catalyst 3500 XL および 2900 XL

IP 電話での分類およびキューイング

Catalyst 6000

Catalyst 2948G、2980G、および 4000

Catalyst 3500 XL および 2900 XL

複数ケーブルを使用しての IP 電話の設置

スピードとデュプレックス

IP アドレッシング

IP 電話での分類およびキューイング

Catalyst 6000

Catalyst 4000

Catalyst 3500 XL および 2900 XL

SoftPhone のインストール

スピードとデュプレックス

IP アドレッシング

IP 電話での分類およびキューイング

IP 電話に専用のアクセス レイヤ スイッチの使用

スピードとデュプレックス

IP アドレッシング

IP 電話での分類およびキューイング

要約

IP 電話の接続

この章では、IP 電話に関連するサービス品質(QoS)の課題について説明します。図 2-1 に示されているとおり、IP 電話をキャンパス ネットワークに接続する方法には、基本的に次の 4 通りがあります。単一ケーブルを使用する方法、複数のケーブルを使用する方法、PC 上で SoftPhone アプリケーションを使用する方法、音声およびデータ用に別々のスイッチを使用する方法です。これらの接続方式はどれも、音声品質を保証するには課題があります。この章では、音声品質に関する課題について説明します。課題の要約は、次のとおりです。

IP 電話の接続にはどのスピードで行われ、またどのデュプレックス設定が使用されるか。

どの VLAN および IP アドレッシング 方式を使用するか。

IP 電話上の Voice over IP(VoIP)フローのために分類およびキューイングをどのように処理するか。

図 2-1 IP 電話をネットワークに接続する方法

 

単一ケーブルを使用しての IP 電話の設置

多くの企業では、単一ケーブルを電話と PC に使用して Cisco AVVID ネットワークに IP 電話を設置しています。その理由として、設置の手軽さ、配線インフラストラクチャの節約、そしてワイヤリング クローゼットのスイッチ ポートのコスト節約などが挙げられます。これらのコスト節約には、特に QoS が関係する追加のスイッチ機能の要件が関係します。特に、この要件には、イーサネット リンク スピードおよびデュプレックスの適切な設定、レイヤ 2 クラス サービス(CoS)、およびIP 電話とワイヤリング クローゼット イーサネット スイッチの両方におけるキューイングが含まれます。

図 2-2 単一ケーブル接続を使用した場合の QoS に関する考慮事項

 

スピードとデュプレックス設定

Cisco IP Phones の 10/100 イーサネット ポートは、スピードとデュプレックスを設定するためのオートネゴシエーションをサポートします。これはユーザ設定ではありません。PC 内の NIC(ネットワーク インターフェイス カード)もオートネゴシエーションを使用しているにもかかわらず、多くのワイヤリング クローゼット スイッチと同様、イーサネット スイッチ ポートが 10BaseT 半二重用に設定されている場合、リンク スピードの不一致があると、インターフェイス バッファ オーバーフロー状況になる可能性があります。Cisco IP Phone とスイッチ間のこの半二重接続は、通常、問題となることはありませんが、100BaseT 全二重から 10BaseT 半二重に集約するときにバッファ輻輳が発生する可能性があります。きわめて大きなトラフィック(たとえば、非常に高速なビデオ ストリーム)の期間中、そのような接続では、半二重特性により、セグメント上の衝突が多発するので遅延しているパケットからパケットが喪失してしまうことがあります。Cisco IP Phone は、音声にプライオリティ キューを使用しますが、スイッチと Cisco IP Phone は両方とも、必ず、最初に音声トラフィックを送信します。ただし、高速ビデオ ストリームも、可能な限り多くのパケットを送信します。スイッチまたは電話のどちらか(ビデオ フローの進む方向による)が音声トラフィックを送信しようとした場合、伝送しようとしたときに衝突が発生し、その結果、音声パケットが保留されることがあります。

この多大なトラフィック損失の例は、通常の企業環境ではめったに発生することはありませんが、SmartBits を使用して MPEG ビデオ ストリームをシミュレーションするラボでは再現する可能性があります。この状態に対処する最良の方法は、すべての Cisco IP Phones 接続オプションについてスイッチ ポートをオートネゴシエーションに設定することです。ポートが静的に 100BaseT 全二重に設定されている場合、Cisco IP Phone は自動的にそのポートを 100BaseT 半二重に設定するため、デュプレックスの不一致が発生します。このデュプレックスの不一致が発生する理由の詳細については、次を参照してください。

http://www.cisco.com/warp/customer/473/3.html

オートネゴシエーションの使用は、IP 電話接続の推奨設定です。どのユーザも NIC 設定を変更し、100BaseT 全二重をイネーブルにできるためです。また、オートネゴシエーションを使用すると、100BaseT 全二重ポート スピードがイネーブルになり、それにより、高速ビデオ アプリケーションをサポートするのに必要なインフラストラクチャが作成されます。

さらに、CatOS PortFast メカニズムを使用することにより、電話アクセス ポートを転送状態に即時に移行するよう設定できるため、IP 電話ブート時間が短縮されます。この設定を実行するには、Catalyst 4000 および 6000 で set port host コマンドを使用するか、2900 XL and 3500 XL で spanning-tree portfast コマンドを使用します。これにより、ダイナミック トランキング プロトコル(DTP)およびポート集約プロトコル(PagP)がオフにされ、PortFast がイネーブルになります。この設定について詳しくは、この後の「Catalyst 4000 および 6000」および「Catalyst 3500 XL および 2900 XL」を参照してください。


) 電話ブート時間は、電話は常時電源が供給されている状態で、接続されているため、通常、問題にはなりません。


Catalyst 4000 および 6000

イーサネット スイッチの Catalyst 4000、2948G、2980G、および 6000 回線上で、次のコマンドを使用して、ポートを IP 電話用に適切に設定します。

cat6k-access> (enable) set port inlinepower 5/1-48 auto
cat6k-access> (enable) set port speed 5/1-48 auto
cat6k-access> (enable) set port host 5/1-48
 

) インライン電源は、電源対応イーサネット回線カードでのみ使用でき、デフォルトでは、イネーブルになっています。


Catalyst 3500 XL および 2900 XL

Catalyst 3500 XL および 2900 XL スイッチで、次のコマンドを使用して、ポートを IP 電話用に適切に設定します。

interface FastEthernet0/1
power inline auto
speed auto
spanning-tree portfast
 

IP アドレッシング

IP 電話のスピードおよびデュプレックス設定を設定した後で、IP アドレッシング問題を考慮する必要があります。IP 電話には、次の 3 つの IP アドレッシング オプションがあります。

新しいサブネットを作成し、別の IP アドレス スペース(登録済みまたは RFC 1918 アドレス スペース)にある IP 電話のためにそれを使用する。図 2-3 にこの方法を示します。

既存のデータ デバイス(PC またはワークステーション)と同じサブネット内で IP アドレスを提供する。

既存の IP アドレス スペース内で新しいサブネットを開始する。この場合、組織の一部またはすべての IP アドレッシング計画をやり直す必要性が生じる場合があります。

これらのオプションはすべて、DHCP(ダイナミック ホスト コンフィギュレーション プロトコル)または静的 IP アドレス設定を使用して設定できます。IP 電話を追加すると、IP アドレス スペースに対する必要性も倍加する可能性があります。このことが、問題にならない企業もありますが、一方では特定のサブネット内に、あるいは企業全体でも使用可能なアドレス スペースがないという企業もあります。IP アドレス スペースに関してこれらの問題があり、管理および QoS の観点から音声ネットワークとデータ ネットワークの分離が必要でもあることから、IP Phones 用に新しいサブネットを作成することをお奨めします。

図 2-3 音声用の個別のサブネットの使用

 


) 分離したサブネットと、潜在的に分離した IP アドレス スペースを使用することは、小規模の支店などには適さない場合があります。IP 電話とデータ デバイスの両方を接続するための単一アドレス スペース設定については、第 4 章「ブランチ オフィスの構築」で説明します。


Catalyst 4000 および 6000

set port auxiliaryvlan コマンドは、スイッチの Catalyst 2948G、2980G、4000、および 6000 ファミリー内で特定の IP 電話 802.1Q アクセス トランクを作成するための新しい CatOS コマンドです。次の例では、このコマンドを Catalyst 6000 で使用しています。

cat6k-access> (enable) set vlan 10 name 10.1.10.0_data
cat6k-access> (enable) set vlan 110 name 10.1.110.0_voice
cat6k-access> (enable) set vlan 10 5/1-48
cat6k-access> (enable) set port auxiliaryvlan 5/1-48 110
 

次の例では、このコマンドを Catalyst 4000 で使用します。

cat4k> (enable) set vlan 11 name 10.1.11.0_data
cat4k> (enable) set vlan 111 name 10.1.111.0_voice
cat4k> (enable) set vlan 11 2/1-48
cat4k> (enable) set port auxiliaryvlan 2/1-48 111
 

Catalyst 3500 XL および 2900 XL

Catalyst 3500 XL および 2900 XL シリーズで IP 電話 802.1Q アクセス トランクを作成するには、次のコマンドを使用します。

interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 12
switchport mode trunk
switchport voice vlan 112
spanning-tree portfast
vlan database
vlan 112
 

) トラブルシューティングを容易にするために、VLAN をサブネット アドレスに一致させるように設定できます。


IP 電話での分類およびキューイング

トラフィックを可能な限りネットワークのエッジに近いものとして分類、すなわちマーキングすることは、Cisco ネットワーク設計アーキテクチャの不可欠の部分です。単一ケーブルで接続されている場合、IP 電話が管理ネットワークのエッジとなります。そのため、IP 電話はトラフィック フローの分類が可能であり、また分類する必要もあるのです。

802.1Q ヘッダーの 802.1p 部分にある 3 つのユーザ プライオリティ ビットは、レイヤ 2 CoS 情報(図 1-2 を参照)のシグナリング用に使用されます。デフォルトでは、IP 電話からのすべての VoIP リアルタイム トランスポート プロトコル(RTP)ベアラ フローではレイヤ 2 CoS 値が 5 に、レイヤ 3 IP 優先順位値が 5 に設定されます。IP 優先順位の使用は、従来からのステップであり、すべての Cisco VoIP デバイスは、最終的にはレイヤ 3 分類用の Differentiated Services Code Point(DSCP)に移行します。そのときに、Cisco VoIP エンドポイント(IP 優先順位ではなく DSCP を使用)は、46 という DSCP 値、つまり緊急転送(EF)を使用します。分類とキューイングの両方が IP 電話および企業ネットワーク内の両方で行われる場合、これらの CoS およびタイプ オブ サービス(ToS)値が重要となります。

Cisco IP Phone の中心部に、3 ポートの 10/100 スイッチがあります。その 1 つのポート P0 は、電話の実際の音声電子機器を接続するために使用される内部ポートです。ポート P1 はデイジー チェーン PC を接続するのに使用され、ポート P2 はワイヤリング クローゼットのイーサネット スイッチにアップリンクするのに使用されます。各ポートには、単一スレッシュホールド(4Q1T 設定)を持つ 4 つのキューがあります。これらのキューの 1 つであるキュー 0 は、すべてのブリッジ プロトコル データ ユニット(BPDU)および CoS=5 トラフィックの高優先度キューです。これらのキューはすべて、高優先度キューで使用されるタイマーを使用したラウンド ロビン方式でサービスされます。キュー スケジューラが他のキューにサービスしている間にこのタイマーが満了すると、スケジューラは自動的に高優先度キューに戻り、そのバッファを空にして、音声品質を確保します。図 2-4 は、IP 電話に対するキューイング方式を示しています。

図 2-4 IP 電話のキューイング

 

IP 電話の高優先度キューはどのレイヤ 2 CoS=5 トラフィックにもアクセスできるため、IP 電話のアクセス ポートに接続されている PC もトラフィックを分類しないようにすることは重要です。これを確認する方法として、図 2-5 で示しているとおり、イーサネット スイッチのトラスト境界を IP 電話まで拡張(ただし、これを超えない)することをお奨めします。

図 2-5 IP 電話のトラスト境界

 

Catalyst 6000

Catalyst 6000 スイッチでは、トラスト境界拡張は Cisco CatOS リリース 5.5 の set port qos trust-ext コマンドを使用して行われます。このコマンドは、接続されている PC からのトラフィックに CoS=0 というマークを挿入するよう IP 電話に指示します。その IP 電話がこの CoS 値を扱うよう設定された場合、ポートが IP 電話の CoS 値を受け入れるよう設定することも必要です。現在の Catalyst 10/100 イーサネット回線カードでは、これを行うのに設定ステップの組み合わせが必要です。最初に、実際のポートは、IP 電話からレイヤ 2 イーサネット CoS 値をトラストするよう指示される必要があります。これは、 set port qos trust コマンドを使用して行います。回線カード ASIC 上の設定制限を乗り越えるには、IP 電話をトラストするようその他のアクセス制御リスト(ACL)を設定する必要があります。これを行う最良の方法としては、補助 VLAN 内のイーサネット ポート上のすべての CoS 分類をトラストするよう ACL を設定する方法があります。IP 電話で分類およびトラスト境界を設定するためのコマンドは、次のとおりです。

cat6k-access> (enable) set port qos 5/1-48 trust-ext untrusted

cat6k-access> (enable) set port qos 5/1-48 trust trust-cos

cat6k-access> (enable) set qos acl ip ACL_IP-PHONES trust-cos ip any any

cat6k-access> (enable) set port qos 5/1-48 vlan-based

cat6k-access> (enable) commit qos acl all

cat6k-access> (enable) set qos acl map ACL_IP-PHONES 110

 


) 追加の ACL 設定は、次世代の Catalyst 6000 10/100 回線カードでは不要になります。


Catalyst 2948G、2980G、および 4000

現在のところ、Catalyst 2948G、2980G、および 4000 は、 set port qos <mod/port> trust trust-ext コマンドを提供していません。したがって、これらのスイッチは IP 電話のデフォルト設定に依存する必要があります。このデフォルト設定では、すべての VoIP ストリームに CoS=5 が使用され、すべての PC トラフィック上の CoS は 0 に再分類されます。

Catalyst 3500 XL および 2900 XL

単一ケーブル モデルを使用して IP 電話を Catalyst 3500 XL および 2900 XL スイッチに接続する場合、これらのスイッチには Catalyst 6000 スイッチと同じ機能が必要です。CoS 設定をトラストしないよう PC から IP 電話を設定するには、次のコマンドを使用します。

interface FastEthernet0/1
switchport priority extend cos 0
 

複数ケーブルを使用しての IP 電話の設置

ご使用の Cisco IP テレフォニー ネットワークに次の条件のうち、どれかが該当する場合、IP 電話を接続するのに複数のケーブルを使用します。

PC を接続するための 2 つ目のイーサネット ポートを持たない IP 電話を接続する必要がある。

音声ネットワークとデータ ネットワークとの間を物理的に分離する必要がある。

データ インフラストラクチャをアップグレードせずに IP 電話にインライン電源を容易に提供する必要がある。

UPS 電源を必要とするスイッチの数を制限する必要がある。

ネットワークで必要な CatOS アップグレードの量を制限する必要がある。

ワイヤリング クローゼット スイッチ内の Spanning Tree 設定を制限する必要がある。

スピードとデュプレックス

複数のケーブルを使用している場合は IP 電話の背後に PC がないため、ポート スピードおよびデュプレックス設定は、単一ケーブルの場合ほど重要ではありません。単一ケーブル接続(PC のプラグが電話の 2 つ目のイーサネット ポートに差し込まれている場合)の場合と同じ設定を使用しても安全ですが、この設定は必要ありません。

IP アドレッシング

複数のケーブルを使用して、IP 電話を Cisco AVVID ネットワークに接続する推奨設定は、IP テレフォニー用に個別の IP サブネット 1 つと個別の VLAN を使用する設定です。


) 個別のサブネットと、できる限り個別化した IP アドレス スペースを使用することは、小規模の支店などには適さないことがあります。IP ルーティングが遠隔地の支店で追加のサブネットを扱える場合は、Cisco ネットワーク レジスタと 2 次アドレッシングを使用できます。第 4 章「ブランチ オフィスの構築」では、IP 電話とデータ デバイスの両方を接続するための単一アドレス スペース設定について説明します。


IP 電話での分類およびキューイング

IP 電話とデータ PC は別々の物理ケーブル上にあるため、IP 電話上のキューイングは必須ではありません。ただし、IP 電話は管理対象装置であるため、電話または入力アクセス スイッチ ポートで分類が行われる必要があります。この VoIP パケットの分類は、ワイヤリング クローゼット スイッチで使用されるハードウェアに応じて、さまざまな方法で取り扱えます。次の項では、各種タイプのスイッチについて様々なシナリオを示します。

Catalyst 6000

図 2-6 に示されている例では、Catalyst 6000 はワイヤリング クローゼット スイッチとして使用されます。ポート 3/1 ~ 24 は IP 電話に接続し、3/25 ~ 48 はデータ専用 PC に接続します。これは厳しく管理される環境であるため、Catalyst 6000 上ではすべてのレイヤ 2 CoS 設定が実施されます。

図 2-6 複数ケーブルを使用しての、Catalyst 6000 への IP 電話の接続

 

この設定を実装するためのコマンドは、次のとおりです。

cat6k-access> (enable) set port inlinepower 6/1-24 auto

cat6k-access> (enable) set port inlinepower 6/25-48 off

cat6k-access> (enable) set vlan 110 6/1-24

cat6k-access> (enable) set vlan 10 6/25-48

cat6k-access> (enable) set port auxialaryvlan 6/1-24 dot1p

cat6k-access> (enable) set port host 6/1-24

cat6k-access> (enable) set port qos 6/1-24 trust-ext untrusted

cat6k-access> (enable) set port qos 6/1-24 trusttrust-cos

cat6k-access> (enable) set qos acl ip ACL_IP-PHONES trust-cos ip any any

cat6k-access> (enable) set port qos 6/1-24 vlan-based

cat6k-access> (enable) commit qos acl all

cat6k-access> (enable) set qos acl map ACL_IP-PHONES 110

 

Catalyst 4000

現在のところ、Catalyst 2948G、2980G、および 4000 スイッチに対する
auxialaryvlan
コマンドの dot1p 拡張はありません。スイッチ QoS のために IP 電話の 802.1 分類を使用するには、ポート VLAN ID と同じ値を使って補助 VLAN を設定する必要があります。そうすると、IP 電話は、適切な CoS 設定を持つパケットにマーキングすることができます。

この設定を実装するためのコマンドは、次のとおりです。

cat4k> (enable) set vlan 11 2/25-48
cat4k> (enable) set vlan 111 2/1-24
cat4k> (enable) set port host 2/1-48
cat4k> (enable) set port auxiliaryvlan 2/1-24 111
 

Catalyst 3500 XL および 2900 XL

トラストを設定する際の別のオプションとして、ポート レベルで設定するという方法があります。Catalyst 3500 および 2900 XL シリーズ スイッチでは、802.1p またはポート ベースの CoS 設定をトラフィックの分類に使用できます。ポート ベースの設定は、図 2-7 に示されている設定と類似したものです。

図 2-7 複数ケーブルを使用しての、Catalyst 3500 XL または 2900 XL への IP 電話の接続

 

この設定を実装するためのコマンドは、次のとおりです。

interface FastEthernet0/1
description IP Phone port
spanning-tree portfast
switchport mode access
switchport access vlan 112
interface FastEthernet0/2
description Data-only PC port
switchport mode access
switchport access vlan 12

SoftPhone のインストール

企業の中には、Cisco SoftPhone アプリケーションを使用して IP テレフォニーを配置しています。また、PC ベースの VoIP アプリケーションを使用できるかその可能性を模索している企業も数多くあります。ほとんどの PC NIC(ネットワーク インターフェイス カード)は、現在のところ、802.1P CoS ビットをレイヤ 2 分類用に設定されていません。PC がレイヤ 2 フレーム マーキングを設定している場合でも、ネットワーク管理者の大多数は、ユーザの PC を「信頼する」ことを拒否してきました。このような事情で、Cisco SoftPhone は、現在のところ、レイヤ 3 IP ヘッダーでのみ音声パケットを分類しています。実際、Cisco SoftPhone アプリケーションから生じるすべての音声ベアラ パケットに IP 優先順位値 5 でマーキングされます。もちろん、このマーキングには、これらの音声パケットを正しくキューに入れるために、複数キューを持つレイヤ 3 対応のワイヤリング クローゼット イーサネット スイッチが必要です。このため、Cisco SoftPhone の設計では、ポリシー機能カード(PFC)が取り付けられた Catalyst 6000 スイッチに接続された PC に制限されます。

スピードとデュプレックス

SoftPhone で使用できるように、すべてのワイヤリング クローゼット スイッチ アクセス ポートを全二重 100BaseT に設定してください。PC の CPU は非常に高速であるため、データが半二重 10BaseT 接続で音声をオーバーランする可能性があります。Catalyst スイッチでのスピードとデュプレックスの設定について詳しくは、「単一ケーブルを使用しての IP 電話の設置」を参照してください。

IP アドレッシング

SoftPhone アプリケーションは PC 上で実行されるため、この場合、IP アドレッシングは、問題ではありません。

IP 電話での分類およびキューイング

Cisco SoftPhone は PC アプリケーションであり、現在のところ、レイヤ 3 IP ヘッダーでのみ音声トラフィックにマーキングを行います。振り分けレイヤへの最初のアップリンク前に音声トラフィックの優先順位を決定する必要があるため、これには、アクセス スイッチがレイヤ 3 を認識できるものであることが必要です。そのため、複数のキューを装着しているワイヤリング クローゼット スイッチの選択は、PFC が取り付けられている Catalyst 6000 に限定されます。


) スイッチは、PC 上の Cisco SoftPhone アプリケーションからの IP 優先順位値をトラストするように設定する必要があります。


次の例では、Catalyst 6000 はワイヤリング クローゼット スイッチとして使用されています。Catalyst 6000 のスーパーバイザ エンジンには、PFC ドーター カードが取り付けられており、このカードにより、レイヤ 3/4 QoS インテリジェンスが提供されます。PC に接続されるアクセス ポートは、PC からのすべての IP 優先順位値をトラストするよう設定されます。ACL、すなわち ACL_SOFTPHONE も、Catalyst 6000 10/100 回線カード上での現在の設定制限に対する予備手段として追加されます。この設定のためのコマンドは、次のとおりです。

cat6k-access> (enable) set qos enable

cat6k-access> (enable) set port qos 7/1-48 port-based

cat6k-access> (enable) set port qos 7/1-48 trust trust-ipprec

cat6k-access> (enable) set qos acl ip ACL_SOFTPHONE trust-ipprec ip any any

cat6k-access> (enable) commit qos acl ACL_SOFTPHONE

cat6k-access> (enable) set qos acl map ACL_SOFTPHONE 7/1-48

 

IP 電話に専用のアクセス レイヤ スイッチの使用

ワイヤリング クローゼット内に設置されている複数のスイッチに IP 電話を個々に接続することができます。このように接続することによって、現在使用中のデータ スイッチをアップグレードする必要がなくなり、音声ネットワークとデータ ネットワークを完全に分離した状態にしておくことができます。このタイプのレイヤ スイッチのインストレーションは、ワイヤリング クローゼット スイッチ上でのポートを個別に使用するシナリオと非常によく似ています。

スピードとデュプレックス

このタイプのインストレーションでは IP 電話の背後に PC がないため、ポート スピードおよびデュプレックス設定は、他のタイプのインストレーションの場合ほど重要ではありません。単一ケーブル接続(PC のプラグが電話の 2 つ目のイーサネット ポートに差し込まれている場合)の場合と同じ設定を使用しても安全ですが、この設定は必要ではありません。

IP アドレッシング

IP 電話を Cisco AVVID ネットワーク上の別々のアクセス レイヤ スイッチに接続するための推奨設定は、個別の IP アドレス スペースと別々の VLAN を IP 電話用に使用する設定です。この場合、2 つ目のスイッチ全体、すなわち、新たに取り付けられた VoIP 専用イーサネット スイッチは、単一の VLAN を実行します。IP 電話とイーサネット スイッチ間のトランキングは不要です。ただし、Cisco では、IP 電話からの VoIP パケットに「重要」というタグを付けるために 802.1p を使用することをお奨めします。

この設定を実装するためのコマンドは、次のとおりです。

cat4k> (enable) set port inlinepower 2/1-48 auto
cat4k> (enable) set port inlinepower 2/25-48 off
cat4k> (enable) set vlan 111 2/1-48
cat4k> (enable) set port host 2/1-48
cat4k> (enable) set port auxiliaryvlan 2/1-24 111
 

IP 電話での分類およびキューイング

このタイプのインストレーションでは、IP 電話とデータ PC は別々の物理ケーブル上にのせられるため、IP 電話でのキューイングは必要ありません。ただし、IP 電話は管理対象装置であるため、IP 電話で分類が行われる必要があります。この VoIP パケットの分類は、ワイヤリング クローゼット スイッチで使用されるハードウェアに応じて、さまざまな方法で取り扱えます。ワイヤリング クローゼット スイッチがレイヤ 2 処理のみを取り扱う装置である場合、IP 電話の CoS 設定は、アクセス レイヤでの分類に使用されて、振り分けレイヤに入れられます。次の例は、Catalyst 3500 XL または 2900 XL スイッチの場合のこのタイプの設定を示しています。

interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 112
switchport mode trunk
switchport voice vlan dot1p
spanning-tree portfast
 

要約

この章で説明のとおり、IP 電話を Cisco AVVID ネットワークに接続する際には、以下の一般的なガイドラインおよび推奨事項が適用されます。

ワイヤリング クローゼット スイッチ上のポート設定については、オートネゴシエーションを使用する。

IP 電話は個別の音声専用サブネット上に設置する。

PortFast を使用して IP 電話ブート時間を短縮する。

trust-ext コマンドを使用して、分類トラスト境界を電話まで拡張する。

PC アプリケーションが 5 ~ 7 の CoS または ToS 値でトラフィックを送信するのを許可しない。

SoftPhone ではレイヤ 3 または 4 ワイヤリング クローゼット スイッチのみを使用する。

さらに、以下の注意が適用されます。


) イーサネット ハブなど、シェアド メディア装置への IP 電話の接続はサポートされていません。



) IP 電話のカスケード(デイジー チェーン)のカスケードは、現在はサポートされていません。


企業 VoIP ネットワーク内で QoS を使用可能にする際に最初に行わなければならないステップは、IP 電話を正しく接続することです。ポート オートネゴシエーションを使用可能にし、CoS および ToS を分類することにより、IP 電話はインテリジェント企業ネットワークのエッジまたは境界として機能します。