Cisco CallManager Serviceability アドミニストレーション ガイド Release 5.0(1)
RTMTのトレース収集 とログ集中管理
RTMTのトレース収集とログ集中管理
発行日;2012/02/05 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 1MB) | フィードバック

目次

RTMTのトレース収集とログ集中管理

証明書のインポート

RTMT の Trace & Log Central オプションの表示

トレースの収集

Query Wizard の使用

トレース収集のスケジュール

トレース収集状況の表示とスケジュールされた収集の削除

クラッシュ ダンプの収集

Local Browse の使用

Remote Browse の使用

Q931 Translator の使用

QRT レポート情報の表示

Real Time Trace の使用

View Real Time Data

Monitor User Event

RTMT のトレース設定の更新

関連項目

RTMTのトレース収集とログ集中管理

Cisco CallManager Real-Time Monitoring Tool(RTMT)の Trace and Log Central 機能を使用すると、特定の日付範囲または絶対時間におけるオンデマンドのトレース収集を設定できます。指定した検索基準を含むトレース ファイルを収集して後で使用するためにトレース収集基準を保存したり、定期的なトレース収集をスケジュールしてトレース ファイルをネットワーク上の SFTP サーバにダウンロードしたり、クラッシュ ダンプ ファイルを収集したりできます。ファイルを収集したら、Real-Time Monitoring Tool 内の適切なビューアにそのファイルを表示できます。


) RTMT から、指定されたノードのトレースに関するトレースの設定を編集することもできます。トレースの設定を使用可能にするとシステム パフォーマンスが低下します。このため、トラブルシューティングを行う場合にだけトレースを使用可能にしてください。



) RTMT で Trace and Log Central 機能を使用するには、RTMT が Network Access Translation(NAT)を使用せずにクラスタ内のすべてのノードに直接アクセスできることを確認する必要があります。デバイスにアクセスするように NAT を設定した場合は、IP アドレスではなくホスト名を使用して Cisco CallManager を設定し、ホスト名とそのルータブル IP アドレスが DNS サーバ内またはホスト ファイル内にあることを確認します。



) 暗号化をサポートするデバイスの場合、SRTP 鍵関連情報はトレース ファイルに表示されません。


この章は、次の項で構成されています。

「証明書のインポート」

「RTMT の Trace & Log Central オプションの表示」

「トレースの収集」

「Query Wizard の使用」

「トレース収集のスケジュール」

「トレース収集状況の表示とスケジュールされた収集の削除」

「クラッシュ ダンプの収集」

「Local Browse の使用」

「Remote Browse の使用」

「Q931 Translator の使用」

「QRT レポート情報の表示」

「Real Time Trace の使用」

「RTMT のトレース設定の更新」

証明書のインポート

クラスタ内のサーバごとに認証局が提供するサーバ認証証明書をインポートできます。Trace and Log Central オプションを使用する前に、証明書をインポートすることをお勧めします。証明書をインポートしない場合、RTMT にログインして Trace and Log Central オプションを使用するたびに、クラスタ内のノードごとのセキュリティ証明書が表示されます。証明書に表示されるデータは変更できません。

証明書をインポートするには、 Tools > Trace > Import Certificate の順に選択します。

サーバ証明書のインポートが完了したことを示すメッセージが表示されます。 OK をクリックします。

RTMT の Trace & Log Central オプションの表示

開始する前に、「証明書のインポート」の説明に従って、セキュリティ証明書がインポートされていることを確認します。

Trace & Log Central ツリー階層を表示するには、次のいずれかの操作を実行します。

Quick Launch Channel で Tools タブをクリックし、 Trace および Trace & Log Central アイコンをクリックします。

Tools > Trace > Open Trace & Log Central の順に選択します。


ヒント ツリー階層に表示される任意のオプションから、トレースする対象のサービス/アプリケーションの指定、使用するログとサーバの指定、収集の時刻と日付のスケジュール、ファイルのダウンロード機能の設定、zip ファイルの設定、および収集したトレース ファイルの削除を行うことができます。


Real-Time Monitoring Tool の Trace & Log Central オプションが表示されたら、次のいずれかの操作を実行します。

クラスタ内の 1 台以上のサーバについて、サービス、アプリケーション、システム ログのトレースを収集します。「トレースの収集」を参照してください。

指定した検索基準を含むトレース ファイルを収集してダウンロードし、トレース収集基準を後で使用するために保存します。「Query Wizard の使用」を参照してください。

定期的なトレース収集をスケジュールし、トレース ファイルをネットワーク上の SFTP サーバにダウンロードします。「トレース収集のスケジュール」を参照してください。

1 台以上のサーバについて、クラッシュ ダンプ ファイルを収集します。「クラッシュ ダンプの収集」を参照してください。

収集したトレース ファイルを表示します。「Local Browse の使用」を参照してください。

サーバ上のすべてのトレース ファイルを表示します。「Remote Browse の使用」を参照してください。

アプリケーションごとに、サーバ上で現在書き込まれているトレース ファイルを表示します。トレース ファイルに検索文字列が書き込まれた場合、指定した操作を実行できます。「Real Time Trace の使用」を参照してください。

トレースの収集

Trace and Log Central 機能の Collect Traces オプションを使用すると、クラスタ内の 1 台以上のサーバについて、サービス、アプリケーション、システム ログのトレースを収集できます。トレースを収集する日時の範囲、トレース ファイルのダウンロード先のディレクトリ、サーバから収集したファイルを削除するかどうかなどを指定します。Trace and Log Central 機能を使用してトレースを収集する手順は、次のとおりです。


) アクティブにしていないサービスも表示されるため、そのサービスのトレースを収集できます。


指定した検索基準を含むトレース ファイルを収集する場合、または後で使用するために保存したトレース収集基準を使用する場合は、「Query Wizard の使用」を参照してください。

始める前に

次の 1 つ以上の操作を実行します。

Trace Configuration ウィンドウで、さまざまなサービスのトレース ファイルに記載する情報を設定します。 詳細については、「トレースの設定」を参照してください。

アラームをトレース ファイルに送信する場合は、Alarm Configuration ウィンドウで、アラームの宛先として SDI トレース ファイルまたは SDL トレース ファイルを選択します。 詳細については、「アラームの設定」を参照してください。

手順


ステップ 1 「RTMT の Trace & Log Central オプションの表示」の説明に従って、Trace & Log Central オプションを表示します。

ステップ 2 ツリー階層で、 Collect Files をダブルクリックします。

Select CallManager Services/Applications タブが表示されます。


) クラスタ内に使用できないサーバがある場合は、使用できないサーバを特定するメッセージがダイアログボックスに表示されます。使用できないサーバは、Trace & Log Central ウィンドウには表示されません。


ステップ 3 次のいずれかの操作を実行します。

クラスタ内のすべてのサーバ上の、すべてのサービスおよびアプリケーションのトレースを収集する場合は、 Select All Services on All Servers チェックボックスをオンにします。

特定のサーバ上のすべてのサービスおよびアプリケーションのトレースを収集する場合は、サーバの IP アドレスの横にあるチェックボックスをオンにします。

特定のサーバ上の、特定のサービスまたはアプリケーションのトレースを収集する場合は、該当するチェックボックスをオンにします。

サービスまたはアプリケーションのトレースを収集せずにトレース収集ウィザードを続行する場合は、ステップ 4 に進みます。


) アクティブにしていないサービスも表示されるため、そのサービスのトレースを収集できます。



) リストされている一部のサービス/アプリケーションは、クラスタ内の特定のノードにのみインストールできます。これらのサービス/アプリケーションのトレースを収集するには、サービス/アプリケーションをアクティブにしたサーバからトレースを収集することを確認します。


ステップ 4 Next をクリックします。

System Logs タブが表示されます。

ステップ 5 次のいずれかの操作を実行します。

クラスタ内のすべてのサーバ上の、すべてのシステム ログを収集する場合は、 Select All Logs on all Servers チェックボックスをオンにします。

特定のサーバ上の、すべてのシステム ログのトレースを収集する場合は、サーバの IP アドレスの横にあるチェックボックスをオンにします。

特定のサーバ上の特定のシステム ログのトレースを収集する場合は、該当するチェックボックスをオンにします。

システム ログのトレースを収集せずにトレース収集ウィザードを続行する場合は、ステップ 6 に進みます。

ステップ 6 Next をクリックします。

ステップ 7 Collection Time グループ ボックスで、トレースを収集する時間範囲を指定します。次のいずれかのオプションを選択します。

Absolute Range :トレースを収集する対象のサーバの時間帯と時間範囲(開始日時と終了日時)を指定します。

クライアント マシンの時間帯は、Select Reference Server Time Zone フィールドのデフォルト設定値です。Daylight Savings 設定値を持つすべての時間帯の個別のエントリ セットとともに、すべての標準時間帯が、Select Time Zone ドロップダウン リスト ボックスに表示されます。

選択した時間帯がサーバ(たとえば、Server 1)の時間帯設定と一致する場合は、その日付範囲内(開始日付と終了日付の間)の修正されたトレース ファイルが収集されます。同じ Cisco CallManager クラスタ内に別のサーバ(Server 2)が存在し、そのサーバが別の時間帯である場合、Server 2 の対応する日付範囲内の修正されたトレース ファイルが Server 2 から収集されます。

トレースを収集する日付範囲を設定する場合は、From Date/Time フィールドと To Date/Time フィールドでドロップダウン リストボックスを選択します。

Relative Range :現在時刻から遡ってトレースを収集する時間を(分、時間、日、週、月のいずれかの単位で)指定します。

ステップ 8 Select Partition ドロップダウン リスト ボックスから、トレースを収集する対象のログを含むパーティションを選択します。

Cisco CallManager Serviceability では、Cisco CallManager の最大 2 つの Linux ベースのバージョンについてログを保存します。Cisco CallManager Serviceability は、ユーザがログインしているバージョンの Cisco CallManager のログをアクティブなパーティションに保存し、他のバージョンの Cisco CallManager(インストールされている場合)のログをアクティブでないディレクトリに保存します。

したがって、Linux プラットフォームで実行されている Cisco CallManager の 1 つのバージョンから別のバージョンにアップグレードし、Linux プラットフォームで実行されている新しいバージョンの Cisco CallManager にログインすると、Cisco CallManager Serviceability は前バージョンのログをアクティブでないパーティションに移動し、新しいバージョンのログをアクティブなパーティションに保存します。ユーザが古いバージョンの Cisco CallManager にログインすると、Cisco CallManager Serviceability は新しいバージョンの Cisco CallManager のログをアクティブでないパーティションに移動し、古いバージョンのログをアクティブなディレクトリに保存します。


) Cisco CallManager Serviceability では、Windows プラットフォームで実行されている Cisco CallManager のバージョンのログは保存されません。


ステップ 9 トレース ファイルをダウンロードするディレクトリを指定するには、Download File Directory フィールドの横にある Browse ボタンをクリックし、該当するディレクトリに移動して Open をクリックします。デフォルトでは、C:\Program Files\Cisco\CallManager Serviceability\jrtmt\<サーバ IP アドレス>\<ダウンロード時刻> が指定されます。

ステップ 10 収集するトレース ファイルの zip ファイルを作成するには、 Zip File オプション ボタンを選択します。トレース ファイルを zip 圧縮せずにダウンロードするには、 Do Not Zip Files オプション ボタンを選択します。

ステップ 11 サーバから収集したログ ファイルを削除するには、 Delete Collected Log Files from the server チェックボックスをオンにします。

ステップ 12 Finish をクリックします。

ウィンドウにトレース収集の進行状況が表示されます。トレース収集を中止する場合は、 Cancel をクリックします。

トレース収集プロセスが完了すると、ウィンドウの下部に「Completed downloading for node <IP アドレス>」というメッセージが表示されます。

ステップ 13 収集したトレース ファイルを表示するには、トレース収集機能の Local Browse オプションを使用します。詳細については、「Local Browse の使用」を参照してください。


 

追加情報

「関連項目」を参照してください。

Query Wizard の使用

Trace Collection Query Wizard を使用すると、指定した検索基準を含むトレース ファイルを収集してダウンロードし、後で使用するためにトレース収集基準を保存することができます。Trace Collection Query Wizard を使用するには、次の手順を実行します。

始める前に

次の 1 つ以上の操作を実行します。

Trace Configuration ウィンドウで、さまざまなサービスのトレース ファイルに記載する情報を設定します。詳細については、「トレースの設定」を参照してください。

アラームをトレース ファイルに送信する場合は、Alarm Configuration ウィンドウで、アラームの宛先として SDI または SDL トレース ファイルを選択します。 詳細については、「アラームの設定」を参照してください。

手順


ステップ 1 「RTMT の Trace & Log Central オプションの表示」の説明に従って、Trace & Log Central オプションを表示します。

ステップ 2 ツリー階層で、 Query Wizard をダブルクリックします。


) クラスタ内に使用できないサーバがある場合は、使用できないサーバを特定するメッセージがダイアログボックスに表示されます。使用できないサーバは、Trace & Log Central ウィンドウには表示されません。


ステップ 3 開いたウィンドウで、次のオプション ボタンのいずれかをクリックします。

Saved Query

Browse ボタンをクリックし、使用するクエリーに移動します。クエリーを選択し、 Open をクリックします。

Single Node Generic Query を選択した場合は、RTMT の接続先のノードが Browse ボタンの横にチェックマーク付きで表示されます。追加のノードの横にチェックマークを入れると、該当するサーバに関するクエリーを実行できます。

All Node Generic Query を選択した場合は、すべてのノードが Browse ボタンの横にチェックマーク付きで表示されます。クエリーを実行する対象に含まれないサーバがある場合は、そのチェックマークを外すことができます。

Regular Query を選択した場合は、クエリーを保存するときに選択したすべてのノードがチェックマーク付きで表示されます。リストに表示される任意のサーバについて、チェックを入れるか外すことができます。新しいサーバを選択する場合は、ウィザードを使用してそのノードのサービスを選択する必要があります。

変更せずにクエリーを実行するには、 Run Query をクリックし、ステップ 17 に進みます。クエリーを変更するには、ステップ 4 に進みます。

Create Query

ステップ 4 Next をクリックします。

Select Cisco CallManager Services/Applications タブが表示されます。

ステップ 5 Saved Query オプション ボタンをクリックしてクエリーを選択した場合は、クエリーに指定した基準が表示されます。 必要に応じて、トレースを収集する対象のサービス/アプリケーションのリストを変更します。Create Query オプション ボタンをクリックした場合は、トレースを収集するすべてのサービス/アプリケーションを選択する必要があります。


ヒント クラスタ内のすべてのサーバ上の、すべてのサービスおよびアプリケーションのトレースを収集するには、Select All Services on All Servers チェックボックスをオンにします。特定のサーバ上の、すべてのサービスおよびアプリケーションのトレースを収集するには、サーバの IP アドレスの横にあるチェックボックスをオンにします。


) アクティブにしていないサービスも表示されるため、そのサービスのトレースを収集できます。



) リストされている一部のサービス/アプリケーションは、クラスタ内の特定のノードにのみインストールできます。これらのサービス/アプリケーションのトレースを収集するには、サービス/アプリケーションをアクティブにしたサーバからトレースを収集することを確認します。


ステップ 6 Next をクリックします。

ステップ 7 Select System Logs タブで、該当するすべてのチェックボックスをチェックします。


ヒント クラスタ内のすべてのサーバ上の、すべてのサービスおよびアプリケーションのシステム ログのトレースを収集するには、Select All Logs on All Servers チェックボックスをオンにします。特定のサーバ上の、すべてのサービスおよびアプリケーションのトレースを収集するには、サーバの IP アドレスの横にあるチェックボックスをオンにします。

ステップ 8 Next をクリックします。

ステップ 9 Collection Time グループ ボックスで、トレースを収集する時間範囲を指定します。次のいずれかのオプションを選択します。

All Available Traces :このオプションは、選択したサーバ上のサービスに関するすべてのトレースを収集する場合に選択します。

Absolute Range :トレースを収集する対象のサーバの時間帯と時間範囲(開始日時と終了日時)を指定します。

クライアント マシンの時間帯は、Select Reference Server Time Zone フィールドのデフォルト設定値です。Daylight Savings 設定値を持つすべての時間帯の個別のエントリ セットとともに、すべての標準時間帯が、Select Time Zone ドロップダウン リスト ボックスに表示されます。

選択した時間帯がサーバ(たとえば、Server 1)の時間帯設定と一致する場合は、その日付範囲内(開始日付と終了日付の間)の修正されたトレース ファイルが収集されます。同じ Cisco CallManager クラスタ内に別のサーバ(Server 2)が存在し、そのサーバが別の時間帯である場合、Server 2 の対応する日付範囲内の修正されたトレース ファイルが Server 2 から収集されます。

トレースを収集する日付範囲を設定する場合は、From Date/Time フィールドと To Date/Time フィールドでドロップダウン リストボックスを選択します。

Relative Range :現在時刻から遡ってトレースを収集する時間を(分、時間、日、週、月のいずれかの単位で)指定します。

ステップ 10 トレース ファイルに含まれる単語や句で検索するには、Search String フィールドに該当する単語または句を入力します。このツールは、入力した単語または句への完全一致を検索します。

ステップ 11 Select Impact Level ドロップダウン リスト ボックスから、文字列検索アクティビティがコール処理に与える影響のレベルを指定します。指定できるオプションには、Low、Medium、High があります。Low を選択すると、コール処理への影響は最小になりますが、時間がかかります。High を選択すると、コール処理への影響は最大になりますが、時間は短縮されます。

ステップ 12 次のいずれかのオプションを選択します。

クエリーを実行する場合は、 Run Query をクリックします。

Query Results フォルダが表示されます。クエリーが完了すると、クエリーの実行が完了したことを示すダイアログボックスが表示されます。 OK をクリックし、ステップ 17 に進みます。

クエリーを保存する場合は、 Save Query ボタンをクリックし、ステップ 13 に進みます。

ステップ 13 作成するクエリー タイプの横のチェックボックスをオンにします。

Generic Query :このオプションは、クエリーを作成したノード以外のノードで実行できるクエリーを作成する場合に選択します。Generic Query を作成できるのは、選択したサービスがシングル ノード上に存在する場合のみです。複数のノード上のサービスを選択すると、エラー メッセージが表示されます。この場合は、クエリーを Regular Query として保存するか、シングル ノード上のサービスを選択します。

次に、Single Node Query または All Node Query のいずれかのオプションを選択します。Single Node Query を選択すると、トレース収集ツールは、クエリーを実行するときにデフォルトで、クエリーを作成したサーバを選択します。All Node Query オプションを選択すると、トレース収集ツールは、クエリーを実行するときにデフォルトで、クラスタ内のすべてのサーバを選択します。


) クエリーを実行する前に、デフォルト以外のサーバを選択できます。


Regular Query :このオプションは、クエリーを作成したノードまたはクラスタ上でクエリーを実行する場合にのみ選択します。

ステップ 14 Finish をクリックします。

ステップ 15 クエリーを保存する場所に移動し、File Name フィールドにクエリーの名前を入力し、 Save をクリックします。

ステップ 16 次のいずれかの操作を実行します。

保存したクエリーを実行する場合は、 Run Query をクリックし、ステップ 17 に進みます。

作成したクエリーを実行せずに Query Wizard を終了する場合は、 Cancel をクリックします。

ステップ 17 クエリーの実行が完了したら、次の 1 つ以上の操作を実行します。

収集したファイルを表示する場合は、Query Results をダブルクリックし、<node> フォルダ(<node> はウィザードで指定したサーバの IP アドレスまたはホスト名を表す)をダブルクリックし、表示するファイルが含まれているフォルダをダブルクリックしてファイルに移動します。ファイルの場所に移動したら、そのファイルをダブルクリックします。ファイル タイプに対応した既定のビューアに、ファイルが表示されます。


) ファイルに Q931 メッセージが含まれる場合は、「Q931 Translator の使用」 に進み、Q931 メッセージを表示します。QRT Quality Report Tool(QRT)で生成されたレポートを表示する場合は、「QRT レポート情報の表示」を参照してください。


トレース ファイルとクエリーで収集したトレース ファイルのリストを含む結果のファイルをダウンロードします。そのためには、ダウンロードするファイルを選択して Download をクリックし、ダウンロードの基準を指定して Finish をクリックします。

トレース ファイルと結果のファイルをダウンロードするディレクトリを指定する場合は、Download all files フィールドの横にある Browse ボタンをクリックし、該当するディレクトリを表示して Open をクリックします。デフォルトでは、C:\Program Files\Cisco\CallManager Serviceability\jrtmt\<サーバ IP アドレス>\<ダウンロード時刻> が指定されます。

収集するトレース ファイルの zip ファイルを作成する場合は、 Zip File チェックボックスをオンにします。

サーバから収集したログ ファイルを削除する場合は、 Delete Collected Log Files from Server チェックボックスをオンにします。


ヒント トレース ファイルをダウンロードしたら、Trace and Log Central 機能の Local Browse オプションを使用してそれらのファイルを表示できます。詳細については、「Local Browse の使用」を参照してください。

クエリーを保存する場合は、 Save Query をクリックし、ステップ 13 からステップ 15 を実行します。


 

追加情報

「関連項目」を参照してください。

トレース収集のスケジュール

Trace and Log Central 機能の Schedule Collection オプションを使用すると、同時に最大 6 件の定期的なトレース収集をスケジュールしたり、ネットワーク上の SFTP サーバにトレース ファイルをダウンロードしたり、保存された別のクエリーを実行したり、syslog ファイルを作成したりできます。スケジュールされた収集をシステムに入力した後で変更するには、そのスケジュールされた収集を削除して新しい収集イベントを追加する必要があります。トレース収集をスケジュールするには、次の手順を実行します。


) 最大 10 件のトレース収集をスケジュールできますが、同時に実行できるのは 6 件までです。つまり、同時に実行中の状態にできるのは 6 件までです。


始める前に

次の 1 つ以上の操作を実行します。

Trace Configuration ウィンドウで、さまざまなサービスのトレース ファイルに記載する情報を設定します。 詳細については、「トレースの設定」を参照してください。

アラームをトレース ファイルに送信する場合は、Alarm Configuration ウィンドウで、アラームの宛先として SDI トレース ファイルまたは SDL トレース ファイルを選択します。 詳細については、「アラームの設定」を参照してください。

手順


ステップ 1 「RTMT の Trace & Log Central オプションの表示」の説明に従って、Trace & Log Central オプションを表示します。

ステップ 2 ツリー階層で、 Schedule Collection をダブルクリックします。

Select CallManager Services/Applications タブが表示されます。


) クラスタ内に使用できないサーバがある場合は、使用できないサーバを特定するメッセージがダイアログボックスに表示されます。使用できないサーバは、Trace & Log Central ウィンドウには表示されません。


ステップ 3 次のいずれかの操作を実行します。

クラスタ内のすべてのサーバ上の、すべてのサービスおよびアプリケーションのトレースを収集する場合は、 Select All Services on All Servers チェックボックスをオンにします。

特定のサーバ上のすべてのサービスおよびアプリケーションのトレースを収集する場合は、サーバの IP アドレスの横にあるチェックボックスをオンにします。

特定のサーバ上の、特定のサービスまたはアプリケーションのトレースを収集する場合は、該当するチェックボックスをオンにします。

サービスまたはアプリケーションのトレースを収集せずにトレース収集ウィザードを続行する場合は、ステップ 4 に進みます。


) アクティブにしていないサービスも表示されるため、そのサービスのトレースを収集できます。



) リストされている一部のサービス/アプリケーションは、クラスタ内の特定のノードにのみインストールできます。これらのサービス/アプリケーションのトレースを収集するには、サービス/アプリケーションをアクティブにしたサーバからトレースを収集することを確認します。


ステップ 4 Next をクリックします。

System Logs タブが表示されます。

ステップ 5 システム ログのトレースを収集するには、次のいずれかの操作を実行します。

クラスタ内のすべてのサーバ上の、すべてのシステム ログを収集する場合は、 Select All Logs on all Servers チェックボックスをオンにします。

特定のサーバ上の、すべてのシステム ログのトレースを収集する場合は、サーバの IP アドレスの横にあるチェックボックスをオンにします。

特定のサーバ上の、特定のシステム ログのトレースを収集する場合は、該当するチェックボックスをオンにします。

システム ログのトレースを収集せずにトレース収集ウィザードを続行する場合は、ステップ 6 に進みます。

ステップ 6 Next をクリックします。

ステップ 7 トレースを収集する対象のサーバの時間帯と時間範囲を指定します。

クライアント マシンの時間帯は、Select Reference Server Time Zone フィールドのデフォルト設定値です。Daylight Savings 設定値を持つすべての時間帯の個別のエントリ セットとともに、すべての標準時間帯が、Select Time Zone ドロップダウン リスト ボックスに表示されます。

ステップ 8 トレース収集を開始する日時を指定するには、Schedule Start Date/Time フィールドの横にある下向き矢印ボタンをクリックします。Date タブで、適切な日付を選択します。Time タブで、適切な時刻を選択します。

ステップ 9 トレース収集を終了する日時を指定するには、Schedule End Date/Time フィールドの横にある下向き矢印ボタンをクリックします。Date タブで、適切な日付を選択します。Time タブで、適切な時刻を選択します。


) トレース収集は、設定した終了時刻を過ぎても完了しますが、Trace and Log Central 機能はこの収集をスケジュールから削除します。


ステップ 10 Scheduler Frequency ドロップダウン リスト ボックスから、設定されたトレース収集を実行する頻度を選択します。

ステップ 11 Collect Files generated in the last ドロップダウン リスト ボックスから、現在時刻から遡ってトレースを収集する時間を(分、時間、日、週、月のいずれかの単位で)指定します。

ステップ 12 トレース ファイルに含まれる単語や句で検索するには、 Search String フィールドに該当する単語または句を入力します。このツールは、入力した単語または句への完全一致を検索し、検索基準に一致するファイルのみを収集します。

ステップ 13 収集するトレース ファイルの zip ファイルを作成するには、 Zip File チェックボックスをオンにします。

ステップ 14 サーバから収集したログ ファイルを削除するには、 Delete Collected Log Files from the Server チェックボックスをオンにします。

ステップ 15 次の 1 つ以上の操作を選択します。

Download Files

Run Another Query

Generate Syslog

ステップ 16 次のいずれかの操作を実行します。

Download Files または Run Another Query を選択した場合は、ステップ 17 に進みます。

Generate Syslog を選択した場合は、ステップ 19 に進みます。

ステップ 17 SFTP Server Parameters グループ ボックスで、Trace and Log Central 機能が結果をダウンロードするサーバのクレデンシャルを入力し、 Test Connection をクリックします。Trace and Log Central 機能が SFTP サーバへの接続を検証したら、 OK をクリックします。


Download Directory Path フィールドに、Trace and Log Central 機能が収集ファイルを保存するためのディレクトリを指定します。デフォルトでは、トレース収集機能は SFTP パラメータのフィールドに指定したユーザ ID を持つユーザのホーム ディレクトリ(/home/<ユーザ>/Trace)に収集ファイルを保存します。


ステップ 18 Run Another Query オプションを選択した場合は、 Browse ボタンをクリックして実行するクエリーを選択し、 OK をクリックします。


) Trace and Log Central 機能は、第 1 のクエリーの結果が生成された場合にのみ、指定されたクエリーを実行します。


ステップ 19 Finish をクリックします。

スケジュールされたトレースが正常に追加されたことを示すメッセージが表示されます。


) Real-Time Monitoring Tool が SFTP サーバにアクセスできない場合は、メッセージが表示されます。入力した IP アドレス、ユーザ名、パスワードが正しいことを確認します。


ステップ 20 OK をクリックします。

ステップ 21 スケジュールされた収集のリストを表示するには、Quick Launch Channel の Job Status アイコンをクリックします。


ヒント スケジュールされた収集を削除するには、収集イベントを選択し、Delete をクリックします。確認メッセージが表示されます。OK をクリックします。



 

追加情報

「関連項目」を参照してください。

トレース収集状況の表示とスケジュールされた収集の削除

トレース収集イベントの状況を表示し、スケジュールされたトレース収集を削除するには、次の手順を実行します。

手順


ステップ 1 「RTMT の Trace & Log Central オプションの表示」の説明に従って、Trace & Log Central オプションを表示します。

ステップ 2 Quick Launch Channel で、 Job Status アイコンをクリックします。

ステップ 3 Select a Node ドロップダウン リスト ボックスから、トレース収集イベントを表示または削除する対象のサーバを選択します。

スケジュールされたトレース収集のリストが表示されます。

ジョブ タイプには、Scheduled Job、OnDemand、RealTimeFileMon、RealTimeFileSearch があります。

状況には、Pending、Terminated、Running、Cancel、Terminated があります。

ステップ 4 スケジュールされた収集を削除するには、削除するイベントを選択し、 Delete をクリックします。


) 削除できるのは、状況が「Pending」または「Running」で、ジョブ タイプが「ScheduleTask」のジョブのみです。



 

追加情報

「関連項目」を参照してください。

クラッシュ ダンプの収集

トレース ファイルのコア ダンプを収集するには、次の手順を実行します。

手順


ステップ 1 「RTMT の Trace & Log Central オプションの表示」の説明に従って、Trace & Log Central ツリー階層を表示します。

ステップ 2 Collect Crash Dump をダブルクリックします。


) クラスタ内に使用できないサーバがある場合は、使用できないサーバを特定するメッセージがダイアログボックスに表示されます。使用できないサーバは、Trace & Log Central ウィンドウには表示されません。


ステップ 3 Select Core Files タブで、該当するサーバの Core Files チェックボックスをオンにします。

ステップ 4 Next をクリックします。

ステップ 5 Collection Time グループ ボックスで、トレースを収集する時間範囲を指定します。次のいずれかのオプションを選択します。

Absolute Range :トレースを収集する対象のサーバの時間帯と時間範囲(開始日時と終了日時)を指定します。

クライアント マシンの時間帯は、Select Reference Server Time Zone フィールドのデフォルト設定値です。Daylight Savings 設定値を持つすべての時間帯の個別のエントリ セットとともに、すべての標準時間帯が、Select Time Zone ドロップダウン リスト ボックスに表示されます。

選択した時間帯がサーバ(たとえば、Server 1)の時間帯設定と一致する場合は、その日付範囲内(開始日付と終了日付の間)の修正されたクラッシュ ファイルが収集されます。同じ Cisco CallManager クラスタ内に別のサーバ(Server 2)が存在するが、そのサーバが別の時間帯である場合、Server 2 の対応する日付範囲内の修正されたクラッシュ ファイルが Server 2 から収集されます。

クラッシュ ファイルを収集する日付範囲を設定する場合は、From Date/Time フィールドと To Date/Time フィールドでドロップダウン リストボックスを選択します。

Relative Range :現在時刻から遡ってクラッシュ ファイルを収集する時間を(分、時間、日、週、月のいずれかの単位で)指定します。

ステップ 6 Select Partition ドロップダウン リスト ボックスから、トレースを収集する対象のログを含むパーティションを選択します。

Cisco CallManager Serviceability では、Cisco CallManager の最大 2 つの Linux ベースのバージョンについてログを保存します。Cisco CallManager Serviceability は、ユーザがログインしているバージョンの Cisco CallManager のログをアクティブなパーティションに保存し、他のバージョンの Cisco CallManager(インストールされている場合)のログをアクティブでないディレクトリに保存します。

したがって、Linux プラットフォームで実行されている Cisco CallManager の 1 つのバージョンから別のバージョンにアップグレードし、Linux プラットフォームで実行されている新しいバージョンの Cisco CallManager にログインすると、Cisco CallManager Serviceability は前バージョンのログをアクティブでないパーティションに移動し、新しいバージョンのログをアクティブなパーティションに保存します。ユーザが古いバージョンの Cisco CallManager にログインすると、Cisco CallManager Serviceability は新しいバージョンの Cisco CallManager のログをアクティブでないパーティションに移動し、古いバージョンのログをアクティブなディレクトリに保存します。


) Cisco CallManager Serviceability では、Windows プラットフォームで実行されている Cisco CallManager のバージョンのログは保存されません。


ステップ 7 トレース ファイルのダウンロード先ディレクトリを指定するには、Download File Directory フィールドの横にある Browse ボタンをクリックし、該当するディレクトリに移動して Open をクリックします。デフォルトでは、C:\Program Files\Cisco\CallManager Serviceability\jrtmt\<サーバ IP アドレス>\<ダウンロード時刻> が指定されます。

ステップ 8 収集するクラッシュ ダンプ ファイルの zip ファイルを作成するには、 Zip File オプション ボタンを選択します。クラッシュ ダンプ ファイルを zip 圧縮せずにダウンロードするには、 Do Not Zip Files オプション ボタンを選択します。


) クラッシュ ダンプの zip ファイルが 2 ギガバイトを超える場合、そのファイルはダウンロードできません。


ステップ 9 収集されたクラッシュ ダンプ ファイルを削除するには、 Delete Collected Log Files from Server チェックボックスをオンにします。

ステップ 10 Finish をクリックします。

コア ダンプを収集しようとしていることを示すメッセージが表示されます。 Yes をクリックして続行します。


Zip File オプション ボタンを選択し、クラッシュ ダンプ ファイルが 2 ギガバイトを超えた場合、Zip File オプション ボタンを選択した状態ではこのサイズのクラッシュ ダンプ ファイルを収集できないことを示すメッセージが表示されます。 Do Not Zip Files オプション ボタンを選択してから、もう一度収集してください。



 

追加情報

「関連項目」を参照してください。

Local Browse の使用

トレース ファイルを収集して PC にダウンロードしたら、UNIX バリアント ライン ターミネータを処理できる WordPad のようなテキスト エディタを使用して、PC 上でトレース ファイルを表示できます。Real-Time Monitoring Tool 内のビューアで表示することもできます。

Trace and Log Central 機能で収集したログ ファイルを表示するには、次の手順を実行します。トレース ファイルを PC にダウンロードするときに zip 圧縮した場合は、これを解凍してから Real-Time Monitoring Tool 内のビューアで表示する必要があります。

始める前に

次のいずれかの項の説明に従って、トレース ファイルを収集します。

「トレースの収集」

「Query Wizard の使用」

「トレース収集のスケジュール」

手順


ステップ 1 「RTMT の Trace & Log Central オプションの表示」 の説明に従って、Trace & Log Central オプションを表示します。

ステップ 2 Local Browse をダブルクリックします。

ステップ 3 ログ ファイルを保存したディレクトリをブラウズし、表示するファイルを選択します。

ステップ 4 結果を表示するには、ファイルをダブルクリックするか、 Finish をクリックします。

Real-Time Monitoring Tool では、ファイル タイプに対応したビューアでファイルが表示されます。他に適切なビューアがない場合は、Generic Log Viewer でファイルが開きます。QRT Viewer の使用方法の詳細については、「QRT レポート情報の表示」を参照してください。QRT Translator の詳細については、「Q931 Translator の使用」を参照してください。


 

追加情報

「関連項目」を参照してください。

Remote Browse の使用

システムがトレース ファイルを生成したら、サーバで Real-Time Monitoring Tool 内のビューアにそのファイルを表示できます。Remote Browse 機能を使用して、トレースを PC にダウンロードすることもできます。

Trace and Log Central 機能でサーバ上のログ ファイルを表示またはダウンロードするには、次の手順を実行します。

始める前に

次のいずれかの項の説明に従って、トレース ファイルを収集します。

「トレースの収集」

「Query Wizard の使用」

「トレース収集のスケジュール」

手順


ステップ 1 「RTMT の Trace & Log Central オプションの表示」 の説明に従って、Trace & Log Central オプションを表示します。

ステップ 2 Remote Browse をダブルクリックします。

ステップ 3 適切なオプション ボタンを選択し、 Next をクリックします。Trace Files を選択する場合は、ステップ 4 に進みます。Crash Dump を選択する場合は、ステップ 8 に進みます。

ステップ 4 次のいずれかの操作を実行します。

クラスタ内のすべてのサーバ上の、すべてのサービスおよびアプリケーションのトレースを選択する場合は、 Select All Services on All Servers チェックボックスをオンにします。

特定のサーバ上のすべてのサービスおよびアプリケーションのトレースを選択する場合は、サーバの IP アドレスの横にあるチェックボックスをオンにします。

特定のサーバ上の、特定のサービスまたはアプリケーションのトレースを選択する場合は、該当するチェックボックスをオンにします。

サービスまたはアプリケーションのトレースを選択せずにリモート ブラウズ ウィザードを続行する場合は、ステップ 5 に進みます。


) アクティブにしていないサービスも表示されるため、そのサービスのトレースを選択できます。



) リストされている一部のサービス/アプリケーションは、クラスタ内の特定のノードにのみインストールできます。これらのサービス/アプリケーションのトレースを選択するには、サービス/アプリケーションをアクティブにしたサーバからトレースを選択することを確認します。


ステップ 5 Next をクリックします。

System Logs タブが表示されます。

ステップ 6 次のいずれかの操作を実行します。

クラスタ内のすべてのサーバ上の、すべてのサービスおよびアプリケーションのシステム ログを選択する場合は、 Select All Logs on all Servers チェックボックスをオンにします。

特定のサーバ上の、すべてのシステム ログのトレースを選択する場合は、サーバの IP アドレスの横にあるチェックボックスをオンにします。

特定のサーバ上の、特定のシステム ログのトレースを選択する場合は、該当するチェックボックスをオンにします。

システム ログのトレースを収集せずにリモート ブラウズ ウィザードを続行する場合は、ステップ 9 に進みます。

ステップ 7 ステップ 9 に進みます。

ステップ 8 次のいずれかの操作を実行します。

クラスタ内のすべてのサーバ上の、すべてのサービスおよびアプリケーションのクラッシュ ダンプ ファイルを選択する場合は、 Select All Services on All Servers チェックボックスをオンにします。

特定のサーバ上のすべてのサービスおよびアプリケーションのクラッシュ ダンプ ファイルを選択する場合は、サーバの IP アドレスの横にあるチェックボックスをオンにします。

特定のサーバ上の特定のサービスまたはアプリケーションのクラッシュ ダンプ ファイルを選択する場合は、該当するチェックボックスをオンにします。

ステップ 9 Finish をクリックします。

トレースが使用可能な場合は、メッセージが表示されます。 OK をクリックします。

ステップ 10 次のいずれかの操作を実行します。

結果を表示する場合は、ファイルをダブルクリックするか、 Finish をクリックします。

Real-Time Monitoring Tool では、ファイル タイプに対応したビューアでファイルが表示されます。他に適切なビューアがない場合は、Generic Log Viewer でファイルが開きます。QRT Viewer の使用方法の詳細については、「QRT レポート情報の表示」を参照してください。QRT Translator の詳細については、「Q931 Translator の使用」を参照してください。

トレース ファイルをダウンロードします。そのためには、ダウンロードするファイルを選択して Download をクリックし、ダウンロードの基準を指定して Finish をクリックします。

トレース ファイルをダウンロードするディレクトリを指定する場合は、Download all files フィールドの横にある Browse ボタンをクリックし、該当するディレクトリを表示して Open をクリックします。デフォルトでは、C:\Program Files\Cisco\CallManager Serviceability\jrtmt\<サーバ IP アドレス>\<ダウンロード時刻> が指定されます。

収集するトレース ファイルの zip ファイルを作成する場合は、 Zip File チェックボックスをオンにします。

サーバから収集したログ ファイルを削除する場合は、 Delete Files on server チェックボックスをオンにします。


ヒント トレース ファイルをダウンロードしたら、Trace and Log Central 機能の Local Browse オプションを使用してそれらのファイルを表示できます。詳細については、「Local Browse の使用」を参照してください。


 

追加情報

「関連項目」を参照してください。

Q931 Translator の使用

Cisco CallManager では、ISDN トレース ファイルを生成し、Cisco CallManager インストレーションの接続に関する問題の診断とトラブルシューティングに役立てています。このログ ファイルには、Q.931 タイプのメッセージ(ISDN レイヤ 3 プロトコル)が収集されています。

メッセージ変換の機能は、Cisco CallManager SDI ログ ファイルからの入力データをフィルタリングし、構文解析して Cisco IOS と同等のメッセージに変換することです。メッセージ変換プログラムでは、XML とテキスト ファイルをサポートしています。

シスコ サポート エンジニアは、メッセージ変換ツールを使用して、お客様から寄せられたデバッグ情報を Cisco IOS と同等の分かりやすいメッセージに変換します。

始める前に

次のいずれかの項の説明に従って、トレース ファイルを収集します。

「トレースの収集」

「Query Wizard の使用」

「トレース収集のスケジュール」

手順


ステップ 1 「Query Wizard の使用」 で説明する Query Wizard を使用するか、「Local Browse の使用」 で説明する Trace and Log Central 機能の Local Browse オプションを使用して、ログ ファイル エントリを表示します。


) CTIManager および Cisco CallManager SDI トレース ファイルには、Q931 メッセージを含めることができます。


ステップ 2 Q931 メッセージの変換を行うログ エントリをクリックします。

ステップ 3 Translate Q931 Messages をクリックします。

選択したトレース ファイルに ISDN メッセージがない場合、「No ISDN Messages in the File」というメッセージが表示されます。

選択したトレース ファイルに ISDN メッセージが含まれる場合、Q931 Translator ダイアログボックスには、メッセージのリストが表示されます。

ステップ 4 次のいずれかの操作を実行します。

特定のメッセージの詳細を表示する場合は、リストからそのメッセージを選択します。Detailed Message グループ ボックスに詳細が表示されます。

結果をフィルタリングする場合は、リストから Q931 メッセージを選択し、ドロップダウン リスト ボックスからオプション(filter by gateway など)を選択するか、Filter by Search String フィールドにテキストを入力します。フィルタを削除する場合は、Clear Filter をクリックします。フィルタを削除すると、すべてのログが表示されます。

Q931 Translator ダイアログボックスを閉じる場合は、 Close ボタンをクリックします。


追加情報

「関連項目」を参照してください。

QRT レポート情報の表示

QRT Viewer を使用すると、Quality Report Tool(QRT)によって生成された IP Phone Problem レポートを表示できます。QRT は、Cisco CallManager IP Phone に関する音声品質および一般問題のレポート ツールです。QRT Viewer を使用すると、生成された IP Phone Problem レポートのフィルタリング、フォーマット、および表示を実行できます。QRT Viewer を使用して Cisco CallManager IP Phone Problem レポートを一覧表示するには、次の手順を実行します。QRT の設定および使用方法については、『 Cisco CallManager 機能およびサービス ガイド 』を参照してください。

始める前に

次のいずれかの項の説明に従って、トレース ファイルを収集します。

「トレースの収集」

「Query Wizard の使用」

「トレース収集のスケジュール」

手順


ステップ 1 「Query Wizard の使用」 で説明する Query Wizard を使用するか、「Local Browse の使用」 で説明する Trace and Log Central 機能の Local Browse オプションを使用して、ログ ファイル エントリを表示します。

QRT Viewer ウィンドウが表示されます。


) QRT 情報は、Cisco Extended Functions サービスによるログ ファイルにのみ含まれています。QRT データを含むログ ファイル名の形式は、qrtXXX.xml です。


ステップ 2 Extension ドロップダウン リスト ボックスから、レポートに含める内線(複数可)を選択します。

ステップ 3 Device ドロップダウン リスト ボックスから、レポートに含めるデバイス(複数可)を選択します。

ステップ 4 Category ドロップダウン リスト ボックスから、レポートに含める問題カテゴリを選択します。

ステップ 5 List of Fields ドロップダウン リスト ボックスから、レポートに含めるフィールドを選択します。


) ここでフィールドを選択した順序で、QRT Report Result ペインにフィールドが表示されます。


ステップ 6 QRT Report Result ペインにレポートを表示するには、 Display Records をクリックします。


 

Real Time Trace の使用

RTMT の Trace and Log Central 機能の Real Time Trace オプションを使用すると、アプリケーションごとに、サーバ上で現在書き込まれているトレース ファイルを表示できます。システムがトレース ファイルへの書き込みを開始すると、リアルタイム トレースはトレース ファイルの先頭からではなく、モニタリングを開始したポイントからこのファイルの読み取りを開始します。以前の内容を読み取ることはできません。

リアルタイム トレースには、次のオプションがあります。

「View Real Time Data」

「Monitor User Event」

View Real Time Data

Trace and Log Central 機能の View Real Time Data オプションを使用すると、システムがデータを書き込むとおりにトレース ファイルを表示できます。Generic Log Viewer には、最大 10 個のサービスのリアルタイム トレース データを表示できます。シングル ノードについては 5 つのサービスまでです。ログ ビューアは 5 秒ごとに更新されます。トレースが新しいファイルに切り替わると、Generic Log Viewer はその内容をビューアに追加します。


) サービスが書き込むトレースの頻度によっては、View Real Time Data オプションを選択した場合に、Generic Log Viewer にデータを表示できるようになるまで遅延が発生することがあります。


手順


ステップ 1 「RTMT の Trace & Log Central オプションの表示」の説明に従って、Trace & Log Central ツリー階層を表示します。

ステップ 2 Real Time Trace をダブルクリックします。


) クラスタ内に使用できないサーバがある場合は、使用できないサーバを特定するメッセージがダイアログボックスに表示されます。使用できないサーバは、Trace & Log Central ウィンドウには表示されません。


ステップ 3 View Real Time Data をダブルクリックします。

Real Time Data ウィザードが表示されます。

ステップ 4 Nodes ドロップダウン リスト ボックスから、リアルタイム データを表示する対象のノードを選択し、 Next をクリックします。

ステップ 5 リアルタイム データを表示する対象のサービスとトレース ファイル タイプを選択し、 Finish をクリックします。


) アクティブにしていないサービスも表示されるため、そのサービスのトレースを収集できます。


選択したサービスのリアルタイム データが Generic Log Viewer に表示されます。

ステップ 6 カーソルをウィンドウの末尾に固定し、新しいトレースが生成されたときにそのトレースを表示する場合は、 Show New Data チェックボックスをオンにします。新しいトレースが表示されるときにカーソルをウィンドウの最下部に移動しない場合は、 Show New Data チェックボックスをオフにします。

ステップ 7 その他のサービスについても、この手順を繰り返します。最大 10 個のサービスのデータを表示できます。ただし、シングル ノードについては 5 つのサービスまでです。データを表示する対象のサービスが多すぎる場合、またはシングル ノード上のサービスが多すぎる場合は、メッセージが表示されます。

ステップ 8 リアルタイム データの表示を完了する場合は、Generic Log Viewer で Close をクリックします。


 

追加情報

「関連項目」を参照してください。

Monitor User Event

Trace and Log Central 機能の Monitor User Event オプションを使用すると、リアルタイム トレース ファイルがモニタされ、トレース ファイル内に検索文字列が見つかったときに指定された操作が実行されます。システムは、トレース ファイルを 5 秒ごとにポーリングします。ポーリング間隔内に検索文字列が複数回発生しても、システムが操作を実行するのは 1 回だけです。イベントごとに、1 つのノード上の 1 つのサービスをモニタできます。

始める前に

モニタ対象のトレース ファイル内に指定の検索文字列があるときにアラームを生成する場合は、TraceCollectionToolEvent アラートを有効にします。アラート有効化の詳細については、「アラート プロパティの設定」を参照してください。

手順


ステップ 1 「RTMT の Trace & Log Central オプションの表示」の説明に従って、Trace & Log Central ツリー階層を表示します。

ステップ 2 Real Time Trace をダブルクリックします。


) クラスタ内に使用できないサーバがある場合は、使用できないサーバを特定するメッセージがダイアログボックスに表示されます。使用できないサーバは、Trace & Log Central ウィンドウには表示されません。


ステップ 3 Monitor User Event をダブルクリックします。

Monitor User Event ウィザードが表示されます。

ステップ 4 次のいずれかの操作を実行します。

すでに設定されているモニタリング イベントを表示する場合は、 View Configured Events オプション ボタンを選択し、ドロップダウン リスト ボックスからサーバを選択し、 Finish をクリックします。

選択したサーバ用に設定されたイベントが表示されます。


) イベントを削除する場合は、イベントを選択し、Delete をクリックします。


新しいモニタリング イベントを設定する場合は、 Create Events オプション ボタンを選択し、 Next をクリックして ステップ 5 に進みます。

ステップ 5 Nodes ドロップダウン リスト ボックスから、システムがモニタするノードを選択し、 Next をクリックします。

ステップ 6 システムがモニタするサービスとトレース ファイル タイプを選択し、 Next をクリックします。


) アクティブにしていないサービスも表示されるため、そのサービスのトレースを収集できます。


ステップ 7 Search String フィールドに、トレース ファイル内でシステムが検索する単語または句を指定します。このツールは、入力した単語または句への完全一致を検索します。

ステップ 8 システムがトレース ファイルをモニタする対象のサーバの、時間帯と時間範囲(開始日時と終了日時)を指定します。

クライアント マシンの時間帯は、Select Reference Server Time Zone フィールドのデフォルト設定値です。Daylight Savings 設定値を持つすべての時間帯の個別のエントリ セットとともに、すべての標準時間帯が、Select Time Zone ドロップダウン リスト ボックスに表示されます。

選択した時間帯がサーバ(たとえば、Server 1)の時間帯設定と一致する場合は、その日付範囲内(開始日付と終了日付の間)の修正されたトレース ファイルがモニタされます。同じ Cisco CallManager クラスタ内に別のサーバ(Server 2)が存在し、そのサーバが別の時間帯である場合、Server 2 の対応する日付範囲内の修正されたトレース ファイルが Server 2 からモニタされます。

トレースをモニタする日付範囲を設定するには、From Date/Time フィールドと To Date/Time フィールドでドロップダウン リストボックスを選択します。

ステップ 9 Search String フィールドに指定した検索文字列が見つかった場合にシステムが実行する操作として、次の 1 つ以上の操作を選択します。

Alert:このオプションは、指定した検索文字列が見つかったときにアラームを生成する場合に選択します。システムがアラームを生成するには、TraceCollectionToolEvent アラートを有効にする必要があります。アラート有効化の詳細については、「アラート プロパティの設定」を参照してください。

Local Syslog:このオプションは、システムがアプリケーション ログ領域のエラーを SysLog Viewer に記録する場合に選択します。システムは、アラームと推奨処置に関する説明を記録します。SysLog Viewer には、RTMT からアクセスできます。

Remote Syslog:このオプションは、システムが syslog メッセージを syslog サーバに保存するのを可能にする場合に選択します。 Server Name フィールドに、syslog サーバ名を指定します。

Download File:このオプションは、指定した検索文字列を含むトレース ファイルをダウンロードする場合に選択します。SFTP Server Parameters グループ ボックスに、トレース ファイルをダウンロードするサーバのサーバ クレデンシャルを入力し、 Test Connection をクリックします。Trace and Log Central 機能が SFTP サーバへの接続を検証したら、 OK をクリックします。


) Download Directory Path フィールドには、Trace and Log Central 機能が収集ファイルを保存するためのディレクトリを指定します。デフォルトでは、トレース収集機能は SFTP パラメータのフィールドに指定したユーザ ID を持つユーザのホーム ディレクトリ(/home/<ユーザ>/Trace)に収集ファイルを保存します。



) システムはトレース ファイルを 5 秒ごとにポーリングし、検索文字列が見つかった場合は指定された操作を実行します。ポーリング間隔内に検索文字列が複数回発生しても、システムが操作を実行するのは 1 回だけです。


ステップ 10 Finish をクリックします。


 

追加情報

「関連項目」を参照してください。

RTMT のトレース設定の更新

Real-Time Monitoring プラグインのトレース設定を編集するには、 Edit > Trace Settings の順に選択し、該当するオプション ボタンをクリックします。システムにより、rtmt.log ファイルが、RTMT プラグインがインストールされているログ ディレクトリ(たとえば C:\Program Files\Cisco\CallManager Serviceability\jrtmt\log)に保存されます。


ヒント Error オプション ボタンはデフォルト設定です。


追加情報

「関連項目」を参照してください。