Cisco Unified Communications Manager Express システム アドミニストレータ ガイド
VRF サポートの設定
VRF サポートの設定
発行日;2013/04/10 | 英語版ドキュメント(2013/04/03 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 18MB) | フィードバック

目次

VRF サポートの設定

機能情報の確認

内容

VRF サポートの設定に関する前提条件

VRF サポートの設定に関する制約事項

VRF サポートについて

VRF-Aware CiscoUnifiedCME

VRF サポートの設定方法

VRF グループの作成

VRF グループへの CiscoUnifiedCME Phone の追加

前提条件

制約事項

VRF サポート設定の設定例

DHCP を使用した VRF への IP アドレス範囲のマッピング:例

VRF-Aware ハードウェア会議:例

グローバル音声 VRF 上の CiscoUnity Express:例

その他の参考資料

関連資料

標準

MIB

RFC

シスコのテクニカル サポート

VRF サポートの機能情報

VRF サポートの設定

Virtual Route Forwarding(VRF)では、物理ルータが複数の論理ルータに分割され、それぞれにインターフェイスとルーティングおよび転送テーブルの独自セットが割り当てられます。音声ネットワークでサポートされる VRF を使用すると、Cisco Unified Communications Manager Express(Cisco Unified CME)を、SIP エンドポイントおよび SCCP エンドポイントと、PC 上の TAPI ベース クライアント アプリケーションおよびソフトフォンに対する複数の仮想システムに分割できます。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「VRF サポートの機能情報」を参照してください。

プラットフォームのサポートおよび Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

VRF サポートの設定に関する前提条件

Cisco Unified CME 7.0(1) 以降のバージョンが、Cisco ルータで設定されていること。

次の設定を含めて、VRF-Aware H.323 および SIP が Cisco Unified CME ルータで設定されていること。

ip vrf コマンドを使用して、最大 5 つの VRF が Cisco Unified CME ルータで設定されていること。設定については、『 VRF-Aware H.323 and SIP for Voice Gateways 』を参照してください

グループの 1 つが voice vrf コマンドを使用して、グローバル音声 VRF(SIP トランク)として指定されていること。設定については、『 VRF-Aware H.323 and SIP for Voice Gateways 』を参照してください

例:

voice vrf voice-vrf
ip vrf data-vrf1
rd 801:1
route-target export 801:1
route-target import 1000:1
!
ip vrf data-vrf2
rd 802:1
route-target export 802:1
route-target import 1000:1
!
ip vrf voice-vrf
rd 1000:1
route-target export 1000:1
route-target import 801:1
route-target import 802:1
!

ルータ上のインターフェイスが、 ip vrf forwarding コマンドを使用して VRF 用に設定されていること。


) SIP 電話機は、グローバル音声 VRF から登録する必要があります。SIP トランク用にサポートされているのはグローバル音声 VRF だけです。


例:

interface GigabitEthernet0/0.301
encapsulation dot1Q 301
ip vrf forwarding data-vrf1
ip address 10.1.10.1 255.255.255.0
!
interface GigabitEthernet0/0.302
encapsulation dot1Q 302
ip vrf forwarding data-vrf1
ip address 10.2.10.1 255.255.255.0
!
interface GigabitEthernet0/0.303
encapsulation dot1Q 303
ip vrf forwarding voice-vrf
ip address 10.3.10.1 255.255.255.0

VRF が、DHCP を使用して IP アドレスにマッピングされていること。設定情報については、を参照してください。

例:

!<=== no ip dhcp command required only if “ip vrf forward” is specified under ip dhcp
no ip dhcp use vrf connected pool===>
!<=== Associate subnets with VRFs. Overlapping IP addresses are NOT supported.===>
ip dhcp pool vcme1
network 10.1.10.0 255.255.255.0
default-router 10.1.10.1
option 150 ip 10.1.10.1
class vcme1
address range 10.1.10.10 10.1.10.250
!
ip dhcp pool vcme2
network 10.2.10.0 255.255.255.0
default-router 10.2.10.1
option 150 ip 10.2.10.1
class vcme2
address range 10.2.10.10 10.2.10.250

設定例の詳細については、「DHCP を使用した VRF への IP アドレス範囲のマッピング:例」を参照してください。

H323 および SIP トランク用のダイヤルピアが、グローバル音声 VRF 経由でルーティングされていること。


) ダイヤルピアは音声 VRF に属するグローバル リソースであり、すべての VRF で共有され、すべての VRF からアクセス可能です。VRF ごとにダイヤルピアを設定する必要はありません。


VRF サポートの設定に関する制約事項

Cisco Unified CME の SIP 電話機:SIP プロキシおよびレジストラは、同じ VRF 内に存在する必要があります。

VRF 間の IP アドレスのオーバーラップはサポートされていません。

Cross-VRF ビデオはサポートされていません。

次のコール タイプは、音声 VRF でサポートされていません。

同じルータで設定された IP-to-IP ゲートウェイおよびゲートキーパー。

VRF が一方のコール レッグで設定され、別のコール レッグでは設定されていない IP-to-IP ゲートウェイ。

H.323 コール レッグに対してある VRF が設定され、SIP コール レッグに対して異なる VRF が設定された IP-to-IP ゲートウェイ。

H.323 コールでは、TCP だけがサポートされています。H.323 UDP シグナリングはサポートされていません。SIP コールでは、TCP と UDP の両方のシグナリングがサポートされています。

次の機能は、VRF でサポートされていません。

コールバック機能と RSVP 機能。

H.323 Annex E コール。

音声対応アクセス ルータの AAA コンポーネントと DNS コンポーネント。これらのルータは、デフォルト ルーティング テーブルを使用して、AAA および DNS と通信します。

グローバル音声 VRF が設定されていない場合、シグナリング パケットとメディア パケットは、デフォルト ルーティング テーブルを使用して送信されます。

SIP 電話機は、グローバル音声 VRF から登録する必要があります。SIP 電話機(SIP トランク)用にサポートされているのはグローバル音声 VRF だけです。

Cisco Unified CME ルータの Cisco Unity Express は、グローバル音声 VRF に属している必要があります。


) Service-Engine Service-Engine 1/0 セッション コマンドは非 VRF-Aware Cisco Unified CME だけを対象としているため、グローバル音声 VRF で Cisco Unity Express にアクセスするには、telnet を使用します。グローバル音声 VRF でボイスメール ユーザを定義するために Cisco Unity Express モジュールにアクセスするには、グローバル音声 VRF を通じて telnet を使用します。例:telnet 10.10.10.5 2066 /vrf vrf 詳細については、該当する『Cisco Unity Express Administrator Guide for Cisco Unified CME』の「Installing Cisco Unity Express Software」の章を参照してください。


VRF サポートについて

トランスコーディングのサポートを設定するには、次の概念を理解する必要があります。

「VRF-Aware Cisco Unified CME」

VRF-Aware Cisco Unified CME

VRF を実装すると、論理的に区分されたネットワークに音声通信を統合し、収束されたマルチメディア ネットワークで音声通信とデータ通信を分離できます。

Cisco Unified CME 7.0(1) 以降のバージョンでは、音声ネットワークで VRF を使用して、要件が異なる複数の非公開ユーザ グループ間で Cisco Unified CME を共有できます。実際のコール処理ルールは、VRF ごとに音声別に適用できます。各 VRF 上の仮想 Cisco Unified CME は、VRF を通じて Cisco Unified CME に登録した VRF グループ内の電話機のコレクションです。Cisco Unified CME に接続するすべての SCCP 電話機と SIP 電話機は、グローバル音声 VRF を通じて登録します。PC 上の TAPI ベース クライアント アプリケーションとソフトフォンは、データ VRF を通じて登録する必要があり、音声 VRF で電話機と通信できます。

Cisco Unified CME でサポートされる VRF は、音声ゲートウェイ機能のために VRF-Aware H.323 および SIP に対して次の拡張を提供します。

最大 5 つの VRF に対する回線側のサポート。

H323 または SIP トランク上のグローバル音声 VRF とのインターワーキング。

回線側の VRF を、グローバル音声 VRF にすることができる。

VRF は電話機ごとに割り当てられる。

Cross-VRF 共有回線のサポート。

設定については、「VRF サポートの設定方法」を参照してください

VRF サポートの設定方法

ここでは、次の作業について説明します。

「VRF グループの作成」(必須)

「VRF グループへの Cisco Unified CME Phone の追加」(必須)

VRF グループの作成

Cisco Unified CME のユーザと電話機に対して最大 5 つの VRF グループを設定するには、設定するグループごとに次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. telephony-service

4. group group-tag [ vrf vrfname ]

5. ip source-address ip-address [ port port ]

6. url { authentication | directories | idle | information | messages | proxy-server | services } url

7. service phone webAccess 0

8. end

手順の詳細

 
コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

telephony-service

 

Router(config)# telephony-service

telephony-service コンフィギュレーション モードを開始します。

ステップ 4

group group-tag [ vrf vrf name ]

 

Router(config-telephony)# group 1

Cisco Unified CME のユーザと電話機に対して VRF グループを作成します。

group-tag :設定する VRF グループの固有識別子。範囲:1 ~ 5。

(任意) vrf vrfname :このグループを関連付ける設定済み VRF の名前。

デフォルトでは、 vrf vrfname キーワードと引数の組み合わせを使用して特に指定しない限り、VRF グループはグローバル音声 VRF に関連付けられます。

ステップ 5

ip source-address ip-address [ port port ]

 

Router(conf-tele-group)# ip source-address 10.1.10.1 port 2000

Cisco Unified CME に VRF グループを関連付けます。

Cisco Unified IP Phone が Cisco Unified CME と通信する ip address port

ステップ 6

url { authentication | directories | idle | information | messages | proxy-server | services } url

 

Router(conf-tele-group)# url directories http://10.1.10.1/localdirectory

Cisco Unified CME に接続された Cisco Unified IP Phone に対して URL をプロビジョニングします。

ステップ 7

service phone webAccess 0

 

Router(conf-tele-group)# service phone webAccess 0

IP Phone の webAccess をイネーブルにします。9.x ファームウェアでは Web サーバがデフォルトでディセーブルになっているため、これは必須です。8.x 以前のファームウェアでは、Web サーバはデフォルトでイネーブルになっていました。

ステップ 8

end

 

Router(conf-tele-group)# end

特権 EXEC モードに戻ります。

次の show running-config コマンドの出力の一部は、Cisco Unified CME に対して 3 つの VRF グループを定義する方法を示しています。グループ 1 はグローバル音声 VRF 上にあり、その他の 2 つのグループは、データ VRF 上にあります。

telephony-service

sdspfarm conference mute-on # mute-off #

sdspfarm units 4

sdspfarm transcode sessions 10

sdspfarm tag 1 xcode101

sdspfarm tag 2 conf103

group 1

ip source-address 10.1.10.1 port 2000

url directories http://10.1.10.1/localdirectory

!

group 2 vrf data-vrf1

ip source-address 10.2.10.1 port 2000

!

group 3 vrf data-vrf2

ip source-address 10.3.10.1 port 2000

VRF グループへの Cisco Unified CME Phone の追加

Cisco Unified CME の SCCP Cisco Unified IP Phone、TAPI ベース クライアント、またはソフトフォンを VRF グループに追加するには、追加する電話機ごとに次の手順を実行します。

前提条件

VRF グループに追加するすべての ephone が、Cisco Unified CME で事前に設定されていること。設定情報については、を参照してください。

制約事項

Cisco Unified CME のすべての SCCP 電話機は、グローバル音声 VRF を通じて登録する必要があり、グローバル音声 VRF だけで VRF グループに追加する必要があります。

IOS ゲートウェイの FXS ポートに接続するアナログ電話機は、グローバル音声 VRF を通じて登録する必要があり、グローバル音声 VRF だけで VRF グループに追加する必要があります。

PC 上の TAPI ベース クライアント アプリケーションとソフトフォンは、データ VRF を通じて登録する必要があり、データ VRF だけで VRF グループに追加する必要があります。

VRF グループは、同一の IP アドレスまたは共有回線をサポートしていません。

手順の概要

1. enable

2. configure terminal

3. ephone phone-tag

4. description string

5. mac-address [ mac-address ]

6. group phone group-tag [ tapi group-tag ]

7. end

手順の詳細

 
コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ephone phone-tag

 

Router(config)# ephone 11

Cisco Unified IP Phone に対する ephone コンフィギュレーション モードを開始します。

ステップ 4

description string

 

Router(config-ephone)# description cme-2801 srst

(任意)インターフェイスの説明テキストを入力します。

ステップ 5

mac-address [ mac-address ]

 

Router(config-ephone)# mac-address 0012.8055.d2EE

Cisco Unified IP Phone の MAC アドレスを ephone 設定に関連付けます。

ステップ 6

group phone group-tag [ tapi group-tag ]

 

Router(config-ephone)# group phone 1

電話機、TAPI ベース クライアント、またはソフトフォンを VRF グループに追加します。

group-tag :telephony-service コンフィギュレーション モードで group コマンドを使用して以前に設定した VRF グループの一意の識別子。範囲:1 ~ 5。

このコマンドは、ephone テンプレート コンフィギュレーション モードで設定して、1 つ以上の電話機に適用することもできます。ephone コンフィギュレーションは、ephone テンプレート コンフィギュレーションよりも優先されます。

ステップ 7

end

 

Router(config-ephone)# end

特権 EXEC モードに戻ります。

次に、VRF グループに電話機を追加する例を示します。電話機 1 と 3 は、グローバル音声 VRF の VRF グループ 1 に属します。電話機 1 の TAPI クライアントおよびソフトフォン 3 は、data-vrf2 のグループ 1 に属します。電話機 3 の TAPI クライアントおよびソフトフォン 4 は、data-vrf 2 のグループ 3 に属します。

telephony-service

sdspfarm conference mute-on # mute-off #

sdspfarm units 4

sdspfarm transcode sessions 10

sdspfarm tag 1 xcode101

sdspfarm tag 2 conf103

group 1 vrf voice-vrf

ip source-address 10.1.10.1 port 2000

url directories http://10.1.10.1/localdirectory

!

group 2 vrf data-vrf1

ip source-address 10.2.10.1 port 2000

!

group 3 vrf data-vrf2

ip source-address 10.3.10.1 port 2000

!

.

.

ephone-template 1

group phone 1 tapi 2

ephone-template 2

group phone 2

...

ephone 1

ephone-template 1

ephone 2

ephone-template 2

ephone 3

group phone 1 tapi 3

ephone 4

group phone 3

ephone 201

group phone 1

type anl

VRF サポート設定の設定例

この項では、次の例について説明します。

「DHCP を使用した VRF への IP アドレス範囲のマッピング:例」

「VRF-Aware ハードウェア会議:例」

「グローバル音声 VRF 上の Cisco Unity Express:例」

DHCP を使用した VRF への IP アドレス範囲のマッピング:例


) VRF を指定するかどうかにかかわらず、重複する IP アドレスは、Cisco Unified CME 7.0(1) でサポートされていません。


DHCP アドレスを割り当てるには、グローバル アドレス割り当て、VRF ブール、または個々のホストの 3 つの方法があります。

グローバル アドレス割り当てスキームでは、 no ip dhcp use vrf connected コマンドを使用する必要があります。

no ip dhcp use vrf connected
!
ip dhcp pool vcme1
network 209.165.201.10 255.255.255.224
option 150 ip 209.165.201.9
default-router 209.165.201.9
class vcme1
address range 209.165.201.1 209.165.201.30
!

 

次に、VRF プール vcme1 からアドレスを割り当てる例を示します。

ip dhcp use vrf connected
!
ip dhcp pool vcme1
vrf data-vrf1
network 209.165.201.10 255.255.255.224
option 150 ip 209.165.201.9
default-router 209.165.201.9
class vcme1
address range 209.165.201.1 209.165.201.30
!

次に、個々のホスト別にアドレスを割り当てる例を示します。ホスト MAC アドレスの先頭にある 2 つの 16 進数の数値を 01 に置き換える必要があります。

ip dhcp pool phone3
host 209.165.201.15 255.255.255.224
client-identifier 0100.0ed7.4ce6.3d
default-router 209.165.201.11
option 150 ip 209.165.201.11
!

VRF-Aware ハードウェア会議:例

内部 DSP ファームでのハードウェア会議

内部 DSP ファームは、ローカル ループバック インターフェイスを通じて登録する必要があります。

ループバックによって、Cisco Unified CME はグローバル ルーティング テーブルのメディア パスにアクセスできます。

次の設定で太字のコマンドは、シグナリング パスとメディア パスがグローバル ルーティング テーブルを通じてアクセスされ、ループバック インターフェイスがデフォルト ルーティング テーブル内にあることを示しています。

interface Loopback5

ip address 12.5.10.1 255.255.255.255

!

sccp local Loopback5

sccp ccm 12.5.10.1 identifier 2 version 4.1

sccp

!

sccp ccm group 2

bind interface Loopback5

associate ccm 2 priority 1

associate profile 103 register conf103

associate profile 101 register xcode101

!

telephony-service

sdspfarm conference mute-on # mute-off #

sdspfarm units 4

sdspfarm transcode sessions 10

sdspfarm tag 1 xcode101

sdspfarm tag 2 conf103

group 1 vrf vrf1

ip source-address 10.1.10.1 port 2000

!

group 2 vrf vrf2

ip source-address 10.2.10.1 port 2000

!

group 3 vrf vrf3

ip source-address 10.3.10.1 port 2000

!

group 4 vrf vrf4

ip source-address 10.4.10.1 port 2000

!

group 5

ip source-address 12.5.10.1 port 2000

!

conference hardware

max-ephones 240

max-dn 480

voicemail 7710

max-conferences 8 gain -6

外部 DSP ファームによるハードウェア会議

Cisco ルータにおける通常の DSP ファームの設定

外部 DSP ファームは、グローバル音声 VRF に割り当てられたインターフェイスまたはサブインターフェイスを通じて Cisco Unified CME に登録する必要があります。接続パスが、音声 VRF を経由していることを確認します。

外部 DSP ファームを設定するルータは、VRF-Aware である必要はありません。

DSP ファームの設定の詳細については、を参照してください。

グローバル音声 VRF 上の Cisco Unity Express:例

voice vrf vrf2

ip vrf data-vrf2

rd 100:2

route-target export 100:2

route-target import 100:2

!

Interface loop back 0

ip vrf forwarding data-vrf2

Ip address 21.10.10.2

!<==The following config puts CUE in the voice vrf. Service-engine interface and service-module must have an IP address.===>

!

interface Service-Engine1/0

ip vrf forwarding voice-vrf3 ip address 21.10.10.5 255.255.255.0

service-module ip address 21.10.10.6 255.255.255.0

service-module ip default-gateway 21.10.10.2!

ip route 21.10.10.6 255.255.255.255 Service-Engine1/0

...

line 66

no activation-character

その他の参考資料

ここでは、Virtual Route Forwarding に関する関連資料について説明します。

関連資料

関連項目
参照先

VRF-Aware サービスのトラブルシューティング

『VRF-Aware System Message Logging』

IP アプリケーション サービスの設定

『Cisco IOS IP Application Services Configuration Guide 12.4』

IP アプリケーション サービスのコマンド リファレンス

『Cisco IOS IP Application Services Command Reference 12.4』

MPLS VPN

『MPLS Virtual Private Networks Configuration Guide 12.0(5)T』

MPLS コマンド リファレンス

『Cisco IOS Multiprotocol Label Switching Command Reference 12.4』

Cisco Unified CME コマンド リファレンス

『Cisco Unified Communications Manager Express Command Reference』

他のすべての Cisco IOS コマンド リファレンス ガイド

http://www.cisco.com/en/US/products/ps6350/prod_command_reference_list.html にさまざまな資料があります。

VRF-lite

『Catalyst 4500 Series Switch Cisco IOS Software Configuration Guide, 12.2(25)SG, Configuring VRF-Lite』

標準

標準
タイトル

H.323 Annex E

『Multiplexed call signaling over UDP』(H.323v4 以降)

MIB

MIB
MIB リンク

新しい MIB または変更された MIB はサポートされていません。また、既存の MIB に対するサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットに関する MIB を探してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

新しい RFC または変更された RFC はサポートされていません。また、既存の RFC に対するサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

VRF サポートの機能情報

表 143 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームを確認できます。Cisco Feature Navigator にアクセスするには、 http://www.cisco.com/go/cfn に移動します。Cisco.com のアカウントは必要ありません。


表 143 に、特定の Cisco IOS ソフトウェア リリース トレインの中で特定の機能のサポートが導入された Cisco IOS ソフトウェア リリースだけを示します。その機能は、特に断りがない限り、それ以降の一連の Cisco IOS ソフトウェア リリースでもサポートされます。


 

表 143 Virtual Route Forwarding の機能情報

機能名
Cisco Unified CME のバージョン
機能情報

Cisco Unified CME での VRF サポート

7.0(1)

VRF は、Cisco Unified CME、会議、トランスコーディング、および RSVP コンポーネントをサポートします。また、VRF によって、データ VRF リソース内のソフトフォンは、VRF 音声ゲートウェイ内の電話機と通信できます。