Cisco Unified Communications Manager Express システム アドミニストレータ ガイド
Cisco Unified CCX との相互運用性の設定
Cisco Unified CCX との相互運用性の設定
発行日;2013/04/10 | 英語版ドキュメント(2013/04/03 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 18MB) | フィードバック

目次

Cisco Unified CCX との相互運用性の設定

内容

CiscoUnified CCX との相互運用性について

CiscoUnified CCX との相互運用性の設定方法

CiscoUnifiedCCX との相互運用性のイネーブル化

前提条件

制約事項

SCCP:セッション マネージャのための CiscoUnifiedCME でのエージェント ディレクトリ番号の識別

前提条件

制約事項

CiscoUnifiedCME での登録とサブスクリプションの検証

CiscoUnifiedCME でのセッション マネージャの再作成

SIP エンドポイントとしての CiscoCRS ルート ポイントの再設定

前提条件

制約事項

CiscoUnifiedCCX との相互運用性の設定例

次の作業

その他の参考資料

関連資料

シスコのテクニカル サポート

CiscoUnifiedCCX との相互運用性の機能情報

Cisco Unified CCX との相互運用性の設定

この章では、Cisco Customer Response Solutions(CRS)と Cisco Unified Contact Center Express(Cisco Unified CCX)の組み合わせなどの外部機能サービスと、Cisco Unified CME との相互運用性を サポート する、 Cisco Unified Communications Manager Express(Cisco Unified CME) の機能について説明します。


) Microsoft Office Communicator(MOC)クライアントや、Cisco Unified CME CTI SDK を使用して開発したアプリケーションなど、コンピュータ ベースの CSTA クライアント アプリケーションのサポートを設定するには、を参照してください。


このモジュールで紹介する機能情報の入手方法

お使いの Cisco Unified CME のバージョンが、このモジュールで説明されている機能の一部をサポートしていないことがあります。 各機能がサポートされているバージョンのリストについては、「相互運用性機能の機能情報」を参照してください。

Cisco Unified CCX との相互運用性について

Cisco Unified CME 4.2 以降のバージョンは、拡張コール処理、デバイスおよびコール モニタリング、複数のコール センター エージェントへの不在コール転送および基本的なエクステンション モビリティ、および IP IVR アプリケーションを含めて、Cisco Unified CME と、Cisco Customer Response Solutions(CRS)と Cisco Unified Call Center Express(Cisco Unified CCX)の組み合わせとの間の相互運用性をサポートします。

Cisco Unified CCX アプリケーションは、CRS プラットフォームを使用してマルチメディア(音声、データ、および Web)を提供します。Cisco IP IVR 機能は Cisco Unified CCX で使用可能であり、プロンプト/コレクトおよびコール処理が含まれています。

Cisco Unified CME 4.2 以降のバージョンでは、次の機能が提供されます。

Cisco Unified CME で使用するための Cisco Unified CCX Cisco Agent Desktop のサポート

Cisco Unified CCX と Cisco Unified CME 間のコンフィギュレーション クエリーと更新

次を含めて、SIP ベースの単純かつ補足的なコール制御サービス

SIP ベースのルート ポイントを使用した、Cisco Unified CME と Cisco Unified CCX 間のコール ルーティング

SIP ベースの単純かつ補足的なコールのためのファーストパーティ コール制御

SIP Presence およびダイアログ イベント パッケージに基づくコール モニタリングとデバイス モニタリング

Cisco Unified CME の Cisco Unified CCX セッション管理

Cisco Unified CME 内のエージェント回線およびコール アクティビティの Cisco Unified CCX デバイスとコールのモニタリング

Cisco Unified CCX 内のプロビジョニング情報および設定情報は、Cisco United CME に自動的に提供されます。Cisco Unified CCX から設定が削除される場合や修正が必要な場合には、Cisco IOS コマンドによって同じ情報を Cisco Unified CME 内に設定できます。

ファーストパーティ コール制御の場合、Cisco CRS のルート ポイントは、SIP トランクを通した Cisco Unified CME へのピア デバイスです。コール センター電話機のターゲットである Cisco Unified CME への着信コールは、ルート ポイントを通して Cisco Unified CCX にルーティングされます。コールはキューに入れられ、Cisco Unified CCX によって最も適切なエージェントにリダイレクトされます。

Cisco Unified CCX によって、コール保留、ブラインド転送、半手動転送などの補足サービスが開始されます。ブラインド転送を除いて、既存の SIP ベースの単純な補足サービス フローが適用されます。Cisco Unified CCX が転送側となるブラインド転送では、転送ターゲットが応答するまで、Cisco Unified CCX はアクティブ状態のままとなります。この状態は、転送されたコールが正しく応答された後でのみ終了します。呼び出しがタイムアウトしたときに、転送ターゲットが応答しない場合、コールは Cisco Unified CCX によって回収され、別のエージェントに再ルーティングされます。このメカニズムは、転送ターゲットが自動転送(すべて)または無応答時コール転送で設定されている場合にも適用されます。ブラインド転送中は、転送設定が無視されます。

リダイレクト、転送、および会議のために Cisco Unified CCX と Cisco Unified CME の間でコールが移動する場合、SIP Call-ID が継続的に変化します。コール制御のため、Cisco Unified CME は、各発信コール レッグに対して一意のグローバル コール ID(Gcid)を発行します。Gcid は、システム内の同じコールのすべてのレッグに対して同じになり、リダイレクト イベント、転送イベント、およびコール センター電話機が会議ホストとして動作する場合の 3 者間電話会議を含めた会議イベントで有効です。

Cisco IOS Release 12.4(11)XW6 よりも前は、Cisco Unified CME 4.2 内のコール モニタリング モジュールが、B-ACD や TCL スクリプトなど、デフォルト以外のセッション アプリケーションに関連付けられたコールを検出した場合、そのモジュールはグローバルにディセーブルになりました。モジュールがディセーブルになった後、Cisco Unified CCX 管理者は、セッションが完了した後、コール モニタリング モジュールを手動で再度イネーブルにする必要があります。

Cisco IOS Release 12.4(11)XW6 以降のリリースでは、Cisco Unified CME 内のコール モニタリング モジュールは、打診転送および会議によってこのコールに取り込まれたすべてのコールを含めて、B-ACD や TCL スクリプトなど、デフォルト以外のセッション アプリケーションに関連付けられたコールをモニタしません。モジュールはディセーブルにならず、引き続き他のコールをモニタします。

表 137 に、Cisco Unified CME と Cisco Unified CCX の間の運用性をイネーブルにするのに必要なタスクのリストを、完了すべきタスクの順に示します。ここでは、この表内の最初の 2 つのステップで実行するタスクの情報と、ステップ 3 を完了するための手順を示します。

設定については、「Cisco Unified CCX との相互運用性の設定方法」を参照してください。

 

表 137 Cisco CRS と Cisco Unified CME の間の相互運用性の設定タスク

手順
タスク
ドキュメント名

1

ルータに適切な Cisco Unified Communications Manager Express(Cisco Unified CME)バージョンがインストールされていることを確認します。互換性については、『 Cisco Unified Contact Center Express (Cisco Unified CCX) Software and Hardware Compatibility Guide 』を参照してください。

--

2

Cisco Unified CME ルータを設定します。

ヒント Cisco Unified CME の XML ユーザ ID とパスワードおよびルータの IP アドレスを記録します。

「前提条件」

3

Cisco Unified CCX と相互運用できるよう、Cisco Unified CME を設定します。

「Cisco Unified CCX との相互運用性の設定方法」

4

Cisco Unified Contact Center Express(Cisco Unified CCX)を Cisco Unified CME 用にインストールします。

Cisco CRS Installation Guide 』( http://www.cisco.com/en/US/products/sw/custcosw/ps1846/prod_installation_guides_list.html )。

5

Cisco Unified CME 用に Cisco CRS の初期設定を行います。

ヒント セットアップが起動すると、Cisco CRS 内の AXL ユーザと呼ばれる、Cisco Unified CME で作成した XML ユーザ ID とパスワードの入力を求められます。また、ルータ IP アドレスも入力する必要があります。

6

Cisco Unified CME Telephony サブシステムを設定して、Cisco Unified CCX との相互運用性をイネーブルにします。

該当する『 Cisco CRS Administration Guide 』または『 Cisco Unified Contact Center Express Administration Guide 』の「Provisioning Unified CCX for Unified CME」の章( http://www.cisco.com/en/US/products/sw/custcosw/ps1846/products_installation_and_configuration_guides_list.html )。

7

Cisco CRS でユーザを作成し、エージェント機能を割り当てます。

Cisco Unified CCX との相互運用性の設定方法

ここでは、次の手順について説明します。

「Cisco Unified CCX との相互運用性のイネーブル化」(必須)

「SCCP:セッション マネージャのための Cisco Unified CME でのエージェント ディレクトリ番号の識別」(必須)

「Cisco Unified CME での登録とサブスクリプションの検証」(任意)

「Cisco Unified CME でのセッション マネージャの再作成」(任意)

「SIP エンドポイントとしての Cisco CRS ルート ポイントの再設定」(任意)

Cisco Unified CCX との相互運用性のイネーブル化

Cisco Unified CME を設定して、Cisco Unified CME と Cisco Unified CCX 間の相互運用性をイネーブルにするには、次の手順を実行します。


) 単一の Cisco Unified CME で複数のセッション マネージャをサポートできます。


前提条件

お使いの Cisco Unified CCX バージョンと互換性がある Cisco Unified CME バージョンおよび Cisco IOS リリース。互換性については、『 Cisco Unified Contact Center Express (Cisco Unified CCX) Software and Hardware Compatibility Guide 』を参照してください。

Cisco Unified CCX アクセス用の AXL ユーザ名を作成するよう、XML API が設定されていること。設定情報については、を参照してください。


) Cisco Unified CME 用の Cisco CRS の初期設定の間、thetelephony-service コンフィギュレーション モードで xml user コマンドを使用して設定した AXL ユーザ名とパスワードが必要になります。また、thetelephony-service コンフィギュレーション モードで ip source-address コマンドを使用して設定したルータ IP アドレスも必要になります。


Cisco Unified CME で接続されるエージェント電話機が、Cisco Unified CME で設定されていること。Cisco Unified CCX エージェント電話機の設定時には、 keep-conference endcall コマンドを使用して、会議を開始したユーザが会議コールを終了し、残りの参加者に対して会議を終了できるようにします。設定情報については、を参照してください

Cisco Unified CME ルータが、着信プレゼンス要求を受け入れるよう設定されていること。設定情報については、を参照してください

デスクトップ モニタリングと録音をサポートするには、telephony-service コンフィギュレーション モードで service phone SpanToPCPort 1 コマンドが設定されていること。設定情報については、を参照してください。

制約事項

サポートされる アクティブ Cisco Unified CCX エージェントの最大数:50。

マルチパーティ アドホック会議およびミートミー会議はサポートされません。

相互運用性機能の導入のために、着信コールとして、別の Cisco Unified CME からの SIP トランク コールおよび PSTN トランクからのすべてのコールがサポートされています。H.323 などの別のトランクは、通常どおり Cisco Unified CME でサポートされますが、Cisco Unified CCX へのカスタマー コール用にはサポートされません。

手順の概要

1. enable

2. configure terminal

3. voice call send-alert

4. voice service voip

5. callmonitor

6. gcid

7. allow-connections sip to sip

8. no supplementary-service sip moved-temporary

9. no supplementary-service sip refer

10. sip

11. registrar server [ expires [ max sec ] [ min sec ]

12. end

手順の詳細

 
コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

voice call send-alert

 

Router(config)# voice call send-alert

着信側ゲートウェイが、コール セットアップ メッセージを受信した後、進行状況メッセージの代わりにアラート メッセージを送信できるようにします。

ステップ 4

voice service voip

 

Router(config)# voice service voip

音声サービス コンフィギュレーション モードを開始し、Voice Over IP(VoIP)カプセル化を指定します。

ステップ 5

callmonitor

 

Router(config-voi-serv)# callmonitor

コール モニタリング メッセージング機能をイネーブルにします。

Cisco Unified CCX で、処理と報告のために使用されます。

ステップ 6

gcid

 

Router(config-voi-serv)# gcid

コール制御用として、グローバル コール ID(Gcid)をイネーブルにします。

Cisco Unified CCX で、コールのトラッキングのために使用されます。

ステップ 7

allow-connections sip to sip

 

Router(config-voi-serv)# allow-connections sip to sip

VoIP ネットワーク内の特定のエンドポイント タイプの間での接続を可能にします。

ステップ 8

no supplementary-service sip moved-temporary

 

Router(config-voi-serv)# no supplementary-service sip moved-temporary

ルータが、コール自動転送のためにリダイレクト応答を宛先に送信することを防止します。

ステップ 9

no supplementary-service sip refer

 

Router(config-voi-serv)# no supplementary-service sip refer

ルータが、コール転送のために REFER メッセージを宛先に転送することを防止します。

ステップ 10

sip

 

Router(config-voi-serv)# sip

SIP コンフィギュレーション モードを開始します。

ステップ 11

registrar server [ expires [ max sec ][ min sec ]]

 

Router(config-voi-sip)# registrar server expires max 600 min 60

Cisco Unified CME で SIP レジストラ機能をイネーブルにします。

expires:(任意)着信登録のアクティブ時間を設定します。

max sec :(任意)登録が期限切れになるまでの最大時間(秒単位)。範囲:600 ~ 86400。デフォルト:3600。推奨値:600。


) 登録の期限切れタイムアウトは、TCP からの切断を防止するために、必ず TCP 接続エージング タイムアウトよりも小さい値に設定します。


min sec :(任意)登録が期限切れになるまでの最小時間(秒単位)。範囲:60 ~ 3600。デフォルト:60。

ステップ 12

end

 

Router(config-voi-serv)# end

コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

SCCP:セッション マネージャのための Cisco Unified CME でのエージェント ディレクトリ番号の識別

Cisco Unified CCX エージェント電話機の電話回線に関連付けられるディレクトリ番号を指定するには、次の手順を実行します。

前提条件

Cisco Unified CME に最大 8 つのセッション マネージャが設定されていること。

Cisco Unified CCX エージェント電話機に関連付けるディレクトリ番号が、Cisco Unified CME で設定されていること。

Cisco Unified CME 4.2:エージェントが 1 つの電話回線ボタンを使用して、同時に 2 つのコール接続を作成できるようにするために、エージェント電話機のディレクトリ番号をデュアル回線として設定する必要があります。デュアル回線の 2 番めの回線がビジーの場合、ソリューション内の電話機間の転送イベントが完了しません。

Cisco Unified CME 4.3/7.0 以降のバージョン:転送イベントに対して同じディレクトリ番号で空き回線を確実に使用できるようにするためには、エージェント電話機のディレクトリ番号をオクトラインとして設定することを推奨します。

設定情報については、を参照してください。

制約事項

Cisco Unified CME でエージェント電話機として設定できるのは、SCCP 電話機だけです。Cisco VG224 Analog Phone Gateway およびアナログ電話機と SIP 電話機は、通常どおり Cisco Unified CME でサポートされますが、Cisco Unified CCX エージェント電話機としてはサポートされません。

Cisco Unified IP Phone 7931 は、Cisco Unified CME でエージェント電話機として設定できません。Cisco Unified IP Phone 7931s は、通常どおり Cisco Unified CME でサポートされますが、Cisco Unified CCX エージェント電話機としてはサポートされません。

共有ライン アピアランスは、エージェント電話機でサポートされません。ディレクトリ番号を、同時に 2 台以上の物理エージェント電話機に関連付けることはできません。

エージェント電話機では、オーバーレイ回線はサポートされません。2 つ以上のディレクトリ番号を、エージェント電話機の単一の回線ボタンに関連付けることはできません。

回線ボタンのモニタ モードは、エージェント電話機でサポートされません。エージェント電話機は、別の電話機でモニタできません。

Cisco Unified CCX は、別のディレクトリ番号を含むコール イベントをサポートしません。すべてのコール イベントは、プライマリ ディレクトリ番号を含む必要があります。単一回線ディレクトリ番号を持つ電話機間のコール転送では、コール モニタリングが失敗します。

手順の概要

1. enable

2. configure terminal

3. ephone-dn dn-tag

4. allow watch

5. session-server { session-tag [ ,... session-tag ]}

6. end

手順の詳細

 
コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ephone-dn dn-tag

 

Router(config)# ephone-dn 24

ephone-dn コンフィギュレーション モードを開始します。

dn-tag :すでに設定されているディレクトリ番号の一意の ID。このタグ番号は、このディレクトリ番号が最初に設定されたときに作成されたタグ番号に対応しています。

ステップ 4

session-server session-server-tag [ ,... session-server-tag ]

 

Router(config-ephone-dn)# session-server 1,2,3,4,6

設定中のディレクトリ番号をモニタするセッション マネージャを指定します。

session-server-tag :Cisco Unified CCX で設定され、Cisco Unified CME に自動的に提供される一意の ID セッション マネージャ。範囲:1 ~ 8。

の値がわからない場合は、1 を使用することを推奨します。

最大 8 つの session-server-tags を設定できます。各タグは、カンマ( , )で区切る必要があります。

各ディレクトリ番号は、最大 8 つのセッション マネージャで管理できます。各セッション マネージャは、2 つ以上のディレクトリ番号をモニタできます。

ステップ 5

allow watch

 

Router(config-ephone-dn)# allow watch

このディレクトリ番号に関連付けられた電話回線をプレゼンス サービスのウォッチャがモニタできるようにします。

このコマンドは、ephone-dn テンプレート コンフィギュレーション モードで設定して 1 つ以上の電話機に適用することもできます。ephone-dn コンフィギュレーションは ephone-dn テンプレート コンフィギュレーションよりも優先されます。

ステップ 6

end

 

Router(config-ephone-dn)# end

コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

Cisco Unified CME での登録とサブスクリプションの検証

システムを使用する前に、Cisco Unified CCX エンドポイントに関する登録とサブスクリプションを検証します。


ステップ 1 show sip status registrar コマンドを使用して、セッション マネージャと Cisco CRS ルート ポイントが登録されているか確認します。

ステップ 2 show presence subscription summary コマンドを使用して、Cisco CRS ルート ポイントと Cisco Unified CCX エージェント ディレクトリ番号がサブスクライブされているか確認します。

次に、 show presence subscription summary コマンドの出力例を示します。最初の 2 行は、2 つのルート ポイントのステータスを示しています。次の 2 行は、エージェント電話機用に記録されたものです。

Router# show presence subscription summary
 
Presence Active Subscription Records Summary: 15 subscription
Watcher Presentity SubID Expires SibID Status
======================== ======================== ====== ======= ====== ======
CRScontrol@10.4.171.81 8101@10.4.171.34 4 3600 0 idle
CRScontrol@10.4.171.81 8201@10.4.171.34 8 3600 0 idle
CRScontrol@10.4.171.81 4016@10.4.171.34 10 3600 0 idle
CRScontrol@10.4.171.81 4020@10.4.171.34 12 3599 0 idle
 


 

Cisco Unified CME でのセッション マネージャの再作成


) Cisco Unified CCX 内のプロビジョニング情報および設定情報は、Cisco United CME に自動的に提供されます。次のタスクは、Cisco Unified CCX からの設定が削除された場合、または修正する必要がある場合のみ必要になります。


Cisco Unified CME で Cisco Unified CCX 用にセッション マネージャを再作成するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. voice register session-server session-server-tag

4. register-id name

5. keepalive seconds

6. end

手順の詳細

 
コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

voice register session-server session-server-tag

 

Router(config)# voice register session-server 1

voice register session-server コンフィギュレーション モードを開始し、Cisco CRS システム上の Cisco Unified CCX アプリケーションなど、外部機能サーバ用にセッション マネージャをイネーブルにして設定します。

範囲:1 ~ 8。

単一の Cisco Unified CME で複数のセッション マネージャをサポートできます。

ステップ 4

register id name

 

Router(config-register-fs)# CRS1

(任意)Cisco Unified CCX の設定が削除された場合、または修正する必要がある場合のみ必要になります。

name :Cisco Unified CCX を識別する文字列。1 ~ 30 文字の英数字を使用できます。

ステップ 5

keepalive seconds

 

Router(config-register-fs)# keepalive 300

(任意)Cisco Unified CCX の設定が削除された場合、または修正する必要がある場合のみ必要になります。

登録が期限切れになる前に Cisco Unified CCX を再登録しない限り、経過後に登録が期限切れになるキープアライブ時間(秒単位)。

範囲:60 ~ 3600。デフォルト:300。

(注) Cisco Unified CCX でのデフォルトは 120 です。

ステップ 6

end

 

Router(config-register-fs)# end

コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

SIP エンドポイントとしての Cisco CRS ルート ポイントの再設定


) Cisco Unified CCX 内のプロビジョニング情報および設定情報は、Cisco United CME に自動的に提供されます。次のタスクは、Cisco Unified CCX からの設定が削除された場合、または修正する必要がある場合のみ必要になります。


Cisco Unified CME で Cisco CRS ルート ポイントを SIP エンドポイントとして再設定するには、次の手順を実行します。

前提条件

Cisco CRS ルート ポイントに関連付けられるディレクトリ番号が、Cisco Unified CME で設定されていること。SIP エンドポイントに関連付けられるディレクトリ番号の設定情報については、 を参照してください。

Cisco CRS ルート ポイントに関連付けられるディレクトリ番号が、ウォッチ対象としてイネーブルになっていること。設定情報については、を参照してください。

Cisco Unified CME で mode cme コマンドがイネーブルになっていること。

制約事項

各 Cisco CRS ルート ポイントは、1 つのセッション マネージャによってのみ管理できます。

各セッション マネージャは、2 つ以上の Cisco CRS ルート ポイントを管理できます。

手順の概要

1. enable

2. configure terminal

3. voice register dn dn-tag

4. number number

5. session-server { session-tag [ ,... session-tag ]}

6. allow watch

7. refer target dial-peer

8. exit

9. voice register pool pool-tag

10. number tag dn dn-tag

11. session-server session-tag

12. codec codec-type [ bytes ]

13. dtmf-relay sip-notify

14. end

手順の詳細

 
コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

voice register dn dn-tag

 

Router(config-register-global)# voice register dn 1

voice register dn コンフィギュレーション モードを開始して、SIP 電話機のディレクトリ番号、インターコム回線、音声ポート、またはメッセージ待機インジケータ(MWI)を定義します。

ステップ 4

number number

 

Router(config-register-dn)# number 2777

ディレクトリ番号に有効な番号を定義します。

ステップ 5

session-server session-server-tag [ ,... session-server-tag ]

 

Router(config-register-dn)# session-server 1

設定中のディレクトリ番号をモニタするセッション マネージャを指定します。

session-server-tag :Cisco Unified CCX で設定され、Cisco Unified CME に自動的に提供される一意の ID セッション マネージャ。範囲:1 ~ 8。

の値がわからない場合は、1 を使用することを推奨します。

最大 8 つの session-server-tags を設定できます。各タグは、カンマ( , )で区切る必要があります。

各ディレクトリ番号は、最大 8 つのセッション マネージャで管理できます。各セッション マネージャは、2 つ以上のディレクトリ番号をモニタできます。

ステップ 6

allow watch

 

Router(config-register-dn)# allow watch

このディレクトリ番号に関連付けられた電話回線をプレゼンス サービスのウォッチャがモニタできるようにします。

ステップ 7

refer target dial-peer

 

Router(config-register-dn)# refer target dial-peer

ウォッチャで、このディレクトリ番号からの SIP REFER メッセージを処理できるようにします。

target dial-peer :メッセージの Refer To 部分は、このディレクトリ番号のダイヤルピアからのアドレスに基づいています。

ステップ 8

exit

 

Router(config-register-dn)# exit

コンフィギュレーション モードを終了して、コンフィギュレーション モード階層で次に高いレベルのモードを開始します。

ステップ 9

voice register pool pool-tag

 

Router(config)# voice register pool 3

音声レジスタ プール コンフィギュレーション モードを開始して、Cisco CRS ルート ポイントのデバイス固有のパラメータを設定します。

Cisco Unified CCX 内の音声レジスタ プールは、最大 10 の個別の SIP エンドポイントを含むことができます。それ以降のプールは、追加の SIP 用に作成されます。

ステップ 10

number tag dn dn-tag

 

Router(config-register-pool)# number 1 dn 1

ディレクトリ番号を、設定するルート ポイントに関連付けます。

ステップ 11

session-server session-server-tag

 

Router(config-register-pool)# session-server 1

設定するルート ポイントの制御に使用するセッション マネージャを識別します。

session-server-tag :セッション マネージャに割り当てられる一意の番号。範囲:1 ~ 8。タグ番号は、 voice register session-server コマンドを使用して作成されたタグ番号に対応しています。

ステップ 12

codec g711ulaw

 

Router(config-register-pool)# codec g711ulaw

設定中のルート ポイント用に動的に作成されるダイヤルピアのコーデックを指定します。

codec-type :Cisco Unified CCX では g711ulaw が必要です。

ステップ 13

dtmf-relay sip-notify

 

Router(config-register-pool)# dtmf-relay sip-notify

設定中のルート ポイントで使用される DTMF リレー方式を指定します。

ステップ 14

end

 

Router(config-register-pool)# end

コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

Cisco Unified CCX との相互運用性の設定例

次の show running-configuration コマンドの出力は、Cisco Unified CCX と相互運用される Cisco Unified CME ルータの設定を示しています。

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname sb-sj3-3845-uut1
!
boot-start-marker
boot-end-marker
!
card type t1 0 2
card type t1 0 3
logging buffered 1000000
no logging console
enable password password
!
no aaa new-model
network-clock-participate wic 2
network-clock-participate wic 3
ip cef
!
!
no ip dhcp use vrf connected
!
!
ip dhcp excluded-address 192.0.2.250 192.0.2.254
!
ip dhcp pool ephones
network 192.0.2.0 255.255.255.0
option 150 ip 192.0.2.254
default-router 192.0.2.254
!
!
no ip domain lookup
!
isdn switch-type primary-5ess
voice-card 0
no dspfarm
!
!
!
!
voice service voip
gcid
callmonitor
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
sip
registrar server expires max 120 min 60
!
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
!
!
!
!
!
!
!
!
!
!
voice register global
mode cme
source-address 192.0.2.254 port 5060
max-dn 720
max-pool 240
authenticate presence
authenticate register
dialplan-pattern 1 511.... extension-length 4
voicemail 9001
create profile sync 0000347600391314
!
voice register session-server 1
keepalive 300
register-id SB-SJ3-UCCX1_1164774025000
!
voice register dn 1
session-server 1
number 8999
allow watch
refer target dial-peer
!
voice register dn 2
session-server 1
number 8001
allow watch
refer target dial-peer
!
voice register dn 3
session-server 1
number 8101
allow watch
refer target dial-peer
!
voice register dn 11
number 2011
name ep-sip-1-11
mwi
!
voice register dn 12
number 2012
name ep-sip-1-12
mwi
!
voice register dn 16
number 5016
name rp-sip-1-16
label SIP 511-5016
mwi
!
voice register dn 17
number 5017
name rp-sip-1-17
label SIP 511-5017
mwi
!
voice register dn 18
number 5018
name rp-sip-1-18
label SIP 511-5018
mwi
!
voice register pool 1
session-server 1
number 1 dn 1
number 2 dn 2
number 3 dn 3
dtmf-relay sip-notify
codec g711ulaw
!
voice register pool 11
id mac 1111.0711.2011
type 7970
number 1 dn 11
dtmf-relay rtp-nte
voice-class codec 1
username 5112011 password 5112011
!
voice register pool 12
id mac 1111.0711.2012
type 7960
number 1 dn 12
dtmf-relay rtp-nte
voice-class codec 1
username 5112012 password 5112012
!
voice register pool 16
id mac 0017.0EBC.1500
type 7961GE
number 1 dn 16
dtmf-relay rtp-nte
voice-class codec 1
username rp-sip-1-16 password pool16
!
voice register pool 17
id mac 0016.C7C5.0660
type 7971
number 1 dn 17
dtmf-relay rtp-nte
voice-class codec 1
username rp-sip-1-17 password pool17
!
voice register pool 18
id mac 0015.629E.825D
type 7971
number 1 dn 18
dtmf-relay rtp-nte
voice-class codec 1
username rp-sip-1-18 password pool18
!
!
!
!
!
!
!
controller T1 0/2/0
framing esf
clock source internal
linecode b8zs
pri-group timeslots 1-4,24
!
controller T1 0/2/1
framing esf
clock source internal
linecode b8zs
pri-group timeslots 1-4,24
!
controller T1 0/3/0
framing esf
clock source internal
linecode b8zs
ds0-group 0 timeslots 1-4 type e&m-immediate-start
!
controller T1 0/3/1
framing esf
clock source internal
linecode b8zs
ds0-group 0 timeslots 1-4 type e&m-immediate-start
vlan internal allocation policy ascending
!
!
!
!
interface GigabitEthernet0/0
ip address 209.165.201.1 255.255.255.224
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
ip address 192.0.2.254 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface Serial0/2/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-5ess
isdn protocol-emulate network
isdn incoming-voice voice
no cdp enable
!
interface Serial0/2/1:23
no ip address
encapsulation hdlc
isdn switch-type primary-5ess
isdn protocol-emulate network
isdn incoming-voice voice
no cdp enable
!
interface Service-Engine1/0
ip unnumbered GigabitEthernet0/0
service-module ip address 209.165.202.129 255.255.255.224
service-module ip default-gateway 209.165.201.1
!
ip route 192.0.0.30 255.0.0.0 192.0.0.55
ip route 209.165.202.129 255.255.255.224 Service-Engine1/0
ip route 192.0.2.56 255.255.255.0 209.165.202.2
ip route 192.0.3.74 255.255.255.0 209.165.202.3
ip route 209.165.202.158 255.255.255.224 192.0.0.55
!
!
ip http server
ip http authentication local
ip http path flash:
!
!
ixi transport http
response size 64
no shutdown
request outstanding 1
!
ixi application cme
no shutdown
!
!
!
control-plane
!
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/2/0:23
!
voice-port 0/3/0:0
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/2/1:23
!
voice-port 0/3/1:0
!
!
!
!
!
dial-peer voice 9000 voip
description ==> This is for internal calls to CUE
destination-pattern 9...
voice-class codec 1
session protocol sipv2
session target ipv4:209.165.202.129
dtmf-relay rtp-nte sip-notify
!
dial-peer voice 9001 voip
description ==> This is for external calls to CUE
destination-pattern 5119...
voice-class codec 1
session protocol sipv2
session target ipv4:209.165.202.129
dtmf-relay rtp-nte sip-notify
!
dial-peer voice 521 voip
destination-pattern 521....
voice-class codec 1
max-redirects 5
session protocol sipv2
session target ipv4:209.165.201.2
dtmf-relay rtp-nte sip-notify
!
dial-peer voice 531 voip
destination-pattern 531....
voice-class codec 1
max-redirects 5
session protocol sipv2
session target ipv4:209.165.201.3
dtmf-relay rtp-nte sip-notify
!
!
presence
presence call-list
watcher all
allow subscribe
!
sip-ua
mwi-server ipv4:209.165.202.128 expires 3600 port 5060 transport udp
presence enable
!
!
telephony-service
no auto-reg-ephone
xml user axluser password axlpass 15 <====AXL username and password for Cisco CRS
max-ephones 240
max-dn 720
ip source-address 192.0.2.254 port 2000 <====IP address of router
system message sb-sj3-3845-uut1
url services http://192.0.2.252:6293/ipphone/jsp/sciphonexml/IPAgentInitial.jsp
url authentication http:192.0.2.252:6293/ipphone/jsp/sciphonexml/IPAgentAuthenticate.jsp
cnf-file perphone
dialplan-pattern 1 511.... extension-length 4
voicemail 9001
max-conferences 8 gain -6
call-forward pattern .T
moh flash:music-on-hold.wav
multicast moh 239.10.10.1 port 2000
transfer-system full-consult
transfer-pattern .T
create cnf-files version-stamp 7960 Jun 18 2007 07:44:25
!
!
ephone-dn 1 dual-line
session-server 1
number 1001
name ag-1-1
allow watch
mwi sip
!
!
ephone-dn 2 dual-line
session-server 1
number 1002
name ag-1-2
allow watch
mwi sip
!
!
ephone-dn 3 dual-line
session-server 1
number 1003
name ag-1-3
allow watch
mwi sip
!
!
ephone-dn 4 dual-line
session-server 1
number 1004
name ag-1-4
allow watch
mwi sip
!
!
ephone-dn 5
session-server 1
number 1005
name ag-1-5
allow watch
mwi sip
!
!
ephone-dn 11 dual-line
number 3011
name ep-sccp-1-11
mwi sip
!
!
ephone-dn 12
number 3012
name ep-sccp-1-12
mwi sip
!
!
ephone-dn 16 dual-line
number 4016
label SCCP 511-4016
name rp-sccp-1-16
mwi sip
!
!
ephone-dn 17 dual-line
number 4017
label SCCP 511-4017
name rp-sccp-1-17
mwi sip
!
!
ephone-dn 18 dual-line
number 4018
label SCCP 511-4018
name rp-sccp-1-18
mwi sip
!
!
ephone-dn 19 dual-line
number 4019
label SCCP 511-4019
name rp-sccp-1-19
mwi sip
!
!
ephone-dn 20 dual-line
number 4020
label SCCP 511-4020
name rp-sccp-1-20
mwi sip
!
!
ephone-dn 21 dual-line
number 4021
label SCCP 511-4021
name rp-sccp-1-21
mwi sip
!
!
ephone-dn 22 dual-line
number 4022
label SCCP 511-4022
name rp-sccp-1-22
mwi sip
!
!
ephone 1
mac-address 1111.0711.1001
type 7970
keep-conference endcall
button 1:1
!
!
!
ephone 2
mac-address 1111.0711.1002
type 7970
keep-conference endcall
button 1:2
!
!
!
ephone 3
mac-address 1111.0711.1003
type 7970
keep-conference endcall
button 1:3
!
!
!
ephone 4
mac-address 1111.0711.1004
type 7970
keep-conference endcall
button 1:4
!
!
!
ephone 5
mac-address 1111.0711.1005
type 7970
keep-conference endcall
button 1:5
!
!
!
ephone 11
mac-address 1111.0711.3011
type 7970
keep-conference endcall
button 1:11
!
!
!
ephone 12
mac-address 1111.0711.3012
type 7960
keep-conference endcall
button 1:12
!
!
!
ephone 16
mac-address 0012.D916.5AD6
type 7960
keep-conference endcall
button 1:16
!
!
!
ephone 17
mac-address 0013.1AA6.7A9E
type 7960
keep-conference endcall
button 1:17
!
!
!
ephone 18
mac-address 0012.80F3.B013
type 7960
keep-conference endcall
button 1:18
!
!
!
ephone 19
mac-address 0013.1A1F.6282
type 7970
keep-conference endcall
button 1:19
!
!
!
ephone 20
mac-address 0013.195A.00D0
type 7970
keep-conference endcall
button 1:20
!
!
!
ephone 21
mac-address 0017.0EBC.147C
type 7961GE
keep-conference endcall
button 1:21
!
!
!
ephone 22
mac-address 0016.C7C5.0578
type 7971
keep-conference endcall
button 1:22
!
!
!
line con 0
exec-timeout 0 0
stopbits 1
line aux 0
stopbits 1
line 66
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120
line vty 0 4
password lab
login
!
scheduler allocate 20000 1000
!
end

次の作業

Cisco Unified CME で電話機のパラメータの修正が完了したら、新しいコンフィギュレーション ファイルを生成し、電話機を再起動します。を参照してください。

その他の参考資料

次の各項では、Cisco Unified CME 機能に関連するその他の資料について説明します。

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

Cisco Unified CCX との相互運用性の機能情報

表 138 に、このモジュールで説明した機能、およびバージョンごとの拡張機能を示します。

特定の Cisco Unified CME バージョンをサポートするための適切な Cisco IOS リリースを判断するには、 http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/requirements/guide/33matrix.htm にある『 Cisco Unified Communications Manager Express and Cisco IOS Software Version Compatibility Matrix 』を参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator では、特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームをサポートしている Cisco IOS ソフトウェア イメージを確認できます。Cisco Feature Navigator にアクセスするには、 http://www.cisco.com/go/cfn に移動します。Cisco.com のアカウントは必要ありません。


表 138 には、特定の機能に対するサポートを導入した Cisco Unified CME のバージョンが示されています。特に明記されていない限り、Cisco Unified CME ソフトウェアの後続のバージョンでもこの機能をサポートします。


 

表 138 相互運用性機能の機能情報

機能名
Cisco Unified CME のバージョン
変更箇所

Cisco Unified CCX との相互運用性

4.2

Cisco Unified IP IVR、拡張コール処理、デバイスおよびコール モニタリング、複数のコール センター エージェントへの不在コール転送および基本的なエクステンション モビリティなど、Cisco Unified CME と、Cisco Customer Response Solutions(CRS)5.0 以降のバージョンと Cisco Unified Contact Center Express(Cisco Unified CCX)の組み合わせのと間の相互運用が可能になりました。