Cisco Unified Communications Manager Express システム アドミニストレータ ガイド
コール制約規制
コール制約規制
発行日;2013/04/10 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 18MB) | フィードバック

目次

コール制約規制

機能情報の確認

内容

LPCOR の前提条件

LPCOR について

LPCOR の概要

LPCOR ポリシー グループとリソース グループ

デフォルトの LPCOR ポリシー

How LPCOR ポリシーをリソース グループに関連付ける方法

アナログ電話機

IP Phone

PSTN トランク

VoIP トランク

補足サービスの LPCOR サポート

LPCOR の電話機ディスプレイと警告トーン

LPCOR VSA

LPCOR の設定方法

LPCOR ポリシーの定義

LPCOR ポリシーとアナログ電話機または PSTN トランク コールとの関連付け

前提条件

LPCOR ポリシーと VoIP トランク コールの関連付け

前提条件

制約事項

LPCOR ポリシーと IP Phone または SCCP FXS 電話機コールとの関連付け

前提条件

制約事項

LPCOR と携帯電話コールとの関連付け

前提条件

制約事項

LPCOR 設定の確認

LPCOR の設定例

Cisco Unified CME 用の LPCOR:例

Cisco 3800 シリーズ サービス統合型ルータ:例

その他の参考資料

関連資料

標準

MIB

RFC

シスコのテクニカル サポート

LPCOR の機能情報

コール制約規制

 

この章では、Cisco Unified Communications Manager Express(Cisco Unified CME)の論理パーティショニング制限クラス(LPCOR)について説明します。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「LPCOR の機能情報」を参照してください。

プラットフォームのサポートおよび Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

LPCOR の前提条件

Cisco IOS Release 15.0(1)XA 以降のリリース。

Cisco Unified CME 8.0 以降のバージョン。

LPCOR について

LPCOR を設定するために、次の概念を理解しておく必要があります。

「LPCOR の概要」

「LPCOR ポリシー グループとリソース グループ」

「How LPCOR ポリシーをリソース グループに関連付ける方法」

「補足サービスの LPCOR サポート」

「LPCOR の電話機ディスプレイと警告トーン」

「LPCOR VSA」

LPCOR の概要

Telecom Regulatory Authority of India(TRAI)は、PSTN ネットワークと VoIP ネットワークとの間の音声トラフィックの混在を制限する規制を定めています。以前は、PSTN コールと VoIP コールの両方を取り扱うために、ユーザが電話機を 2 台持つ必要がありました。図 26 に示すように、1 台はオフィス内およびオフィス間の VoIP コール用に Electronic Private Automatic Branch Exchange(EPABX)に接続された IP Phone で、もう 1 台は PSTN コール用に PABX に接続された電話機です。

新しい規制では、PSTN および IP 専用回線間で論理パーティショニングを使用することにより、単一のネットワーク インフラストラクチャと単一の EPABX で、PSTN ネットワークと VoIP ネットワークの両方に接続できます。

論理パーティショニング制限クラス(LPCOR)機能では、Cisco Unified CME に登録された単一の IP Phone またはアナログ電話機により、TRAI 規制によって指定され接続制約に従って PSTN コールと VoIP コールの両方に接続できます。図 27 に示すように、Cisco Unified CME は、VoIP コールと PSTN コールの両方をサポートし、また PSTN ネットワークと VoIP ネットワークとの間の音声トラフィックの混在を制限するとともに、リモート ロケーションからの IP トランクを介した PSTN コールの接続を防止できます。

図 26 独立した PBX システムと EPABX システム

 

図 27 PSTN コールと VoIP コールがパーティショニングされた単一の EPAPX システム

 

LPCOR ポリシー グループとリソース グループ

Cisco Unified CME は、リソース(PSTN トランク、IP トランク、IP Phone、およびアナログ電話機)を異なるグループに論理的にパーティション可能にすることにより、高レベル クラスの制約をサポートします。各グループのリソースには、音声インターフェイス、トランク グループ、または IP アドレス サブネットに基づいた拡張性があります。一般的には、既存のダイヤル プランを修正して LPCOR 機能をサポートする必要はありません。LPCOR 機能を Cisco Unified CME に追加しても、ダイヤルピア制限クラス(COR)機能は変更されません。

LPCOR コントロールは、コールが発信または着信するリソースのロケーションに基づきます。Cisco Unified CME ルータのリソースを異なるリソース グループにパーティション化し、次にコール制約を適用する各グループに対して LPCOR ポリシーを作成する必要があります。

他のいずれかのリソース グループから発信されるコールを受け入れるか拒否するように LPCOR ポリシーを定義することにより、個別のリソース グループに対する LPCOR ポリシー マトリクスを作成します。各リソース グループに 1 つの LPCOR ポリシーを定義できます。

同じ LPCOR ポリシーが、同じリソースからの複数のディレクトリ番号に適用されます。たとえば、SCCP 電話機に複数のディレクトリ番号が定義される場合、SCCP 電話機上の異なるディレクトリ番号に対するすべてのコールに対して、同じ LPCOR ポリシーを強制的に適用する必要があります。

次の例では、Cisco Unified CME ルータに対する PSTN トランク、IP トランク(H.323 と SIP)、アナログ FXS 電話機、および IP Phone が 5 つの異なるリソース グループ(RG1 から RG5)にパーティショニングされます。

 

表 60 LPCOR ポリシー マトリクスの例

リソース グループ
RG1
RG2
RG3
RG4
RG5

RG1

Yes

No

Yes

No

Yes

RG2

Yes

Yes

No

Yes

No

RG3

Yes

Yes

Yes

Yes

No

RG4

No

No

No

Yes

Yes

RG5

No

Yes

Yes

Yes

No

設定された LPCOR ポリシー マトリクスに基づいて、対象宛先で LPCOR 検証が実行されます。次の例を参考にしてください。

RG1 からターゲット RG1 へのコールは許可される

RG2 からターゲット RG3 へのコールは許可されない

RG3 からターゲット RG2 へのコールは許可される

RG5 からターゲット RG5 へのコールは許可されない

デフォルトの LPCOR ポリシー

デフォルトの LPCOR ポリシーは、コール ソースとその対象宛先の間に制約がないことを意味しています。コールが対象宛先に提示されたときに、着信コールが LPCOR ポリシーに関連付けられていないか、または LPCOR ポリシーが対象宛先に対して定義されていない場合には、Cisco Unified CME は LPCOR 検証をバイパスします。

TRAI 規制では、Cisco Unified CME 内のローカル IP Phone または SCCP アナログ Foreign Exchange Station(FXS)電話機上の同じディレクトリ番号で、PSTN コールと VoIP コールの両方を処理できます。ローカルに接続された電話機は、いずれのリソース グループにも関連付ける必要はありません。

How LPCOR ポリシーをリソース グループに関連付ける方法

コール制約は、リソースのロケーションに基づいて LPCOR リソース グループに適用されます。次のタイプのリソースから発信または着信するコールに適用する、コール制約を定義する LPCOR ポリシーを作成します。

「アナログ電話機」

「IP Phone」

「PSTN トランク」

「VoIP トランク」

アナログ電話機

TRAI 規制では、アナログ FXS 電話機がローカルに Cisco Unified CME に登録されている場合、この電話機で PSTN コールと VoIP コールの両方を受け付けることができます。ローカルに接続された電話機は、いずれのリソース グループにも関連付ける必要はありません。デフォルトの LPCOR ポリシーが、この電話タイプに適用されます。

特定の LPCOR ポリシーを、音声ポートまたはトランク グループによって定義できます。設定については、「LPCOR ポリシーとアナログ電話機または PSTN トランク コールとの関連付け」を参照してください。

IP Phone

LPCOR は、SCCP IP Phone と SIP IP Phone の両方をサポートします。TRAI 規制では、IP Phone が LAN を通してローカルに Cisco Unified CME に登録されている場合、IP Phone で PSTN コールと VoIP コールの両方を受け付けることができます。IP Phone が WAN を通して Cisco Unified CME に登録されている場合、リモート IP Phone からの PSTN コールをブロックする必要があります。

IP Phone が常に同じローカル リージョンまたはリモート リージョンから Cisco Unified CME に登録される場合、その電話機はスタティック LPCOR ポリシーでプロビジョニングされます。設定については、「LPCOR ポリシーと IP Phone または SCCP FXS 電話機コールとの関連付け」を参照してください。

電話機が、エクステンション モビリティ電話機、Cisco IP Communicator Softphone、またはリモート テレワーカー電話機など、モバイル タイプの IP Phone であり、ローカル リージョンとリモート リージョンの間を移動する場合は、LPCOR ポリシーが、IP Phone の現在登録されている IP アドレスに基づいて動的にプロビジョニングされます。設定については、「LPCOR と携帯電話コールとの関連付け」を参照してください。

PSTN トランク

着信 LPCOR リソース グループは、音声ポートまたはトランク グループを通して PSTN トランク(デジタルまたはアナログ)に関連付けられます。

コールが PSTN ネットワークにルーティングされるときに、受け付けるように明示的に設定されいてないすべてのリソース グループからのコールを、ターゲット PSTN トランクの LPCOR ポリシーでブロックすることができます。PSTN トランクからの発信コールは、音声ポートとトランク グループのうち、発信 POTS ダイヤルピア内に設定されている方に基づいて、LPCOR ポリシーに関連付けられます。

設定については、「LPCOR ポリシーとアナログ電話機または PSTN トランク コールとの関連付け」を参照してください。

VoIP トランク

着信 VoIP トランク コール(H.323 または SIP)は、次のように、リモート IP アドレスに基づいて LPCOR ポリシーに関連付けられます。

着信 H.323 トランク コール

以前のハブまたは発信元ゲートウェイの IP アドレス

着信 SIP トランク コール

発信元ゲートウェイの IP アドレス

着信 INVITE メッセージの最古の Via ヘッダーからのホスト名 ホスト名がドメイン名形式の場合、名前を IP アドレスに解決するために、DNS クエリーが実行されます。

Cisco Unified CME は、解決されたホスト名または解決された IP アドレスを使用して、IP トランク サブネット テーブル内のエントリに基づいて LPCOR ポリシーを決定します。IP アドレスまたはホスト名で LPCOR ポリシーが見つからない場合、着信 H.323 または SIP トランク コールは、音声サービス コンフィギュレーション モードで着信 LPCOR ポリシーに関連付けられます。

VoIP ターゲットの LPCOR ポリシーは、発信 VoIP ダイヤルピアの設定で決定されます。発信 LPCOR ポリシーがターゲット VoIP ダイヤルピアに定義されいない場合、デフォルトの LPCOR ポリシーが VoIP ターゲットに適用されます。

設定については、「LPCOR ポリシーと VoIP トランク コールの関連付け」を参照してください。

補足サービスの LPCOR サポート

表 61 に、補足サービスを使用するコールの LPCOR サポートを示します。

 

表 61 LPCOR での補足サービスのサポート

機能
説明
SCCP 電話機
SIP 電話機

基本的なコール

着信コールと対象宛先の両方が LPCOR ポリシーに関連付けられている場合、Cisco Unified CME は、LPCOR ポリシー検証を起動します。

LPCOR ポリシー検証が失敗すると、原因コード 63(サービス使用不可)またはユーザ定義の原因コードがリモート スイッチに返されます。コールは、その次の宛先にハントできます。

Yes

Yes

コール自動転送

コールが新しい宛先に転送される場合、Cisco Unified CME は、ソースとフォワーディング ターゲットの間で LPCOR ポリシー検証を呼び出します。LPCOR ポリシーが制限されている場合、コールはターゲットに転送されません。

Yes

Yes

コール転送

被転送者と転送先の間で LPCOR ポリシー検証が失敗する場合、ブラインドおよびコンサルタティブ コール転送が制限されます。

コンサルタティブ コール転送では、リオーダー トーンが再生され、転送側の電話機にエラー メッセージが表示されます。コールは、被転送者と転送者の間で接続解除されません。

Yes

Yes

アドホック会議(ソフトウェア ベース、3 者間)

Cisco Unified CME は、会議に参加する各コールに対して LPCOR ポリシー検証を呼び出します。LPCOR ポリシー検証が失敗すると、コールは会議への参加をブロックされます。

リオーダー トーンが再生され、会議を開始した IP Phone に、会議を完了できないことを示すメッセージが表示されます。コールは、会議を開始した転送者によって再開されます。

(注) 会議ブリッジへのブラインド転送セットアップ中に LPCOR ポリシー検証が失敗すると、コールが解放されます。

(注) LPCOR 検証は、追加のコール転送のため、または 3 者間ソフトウェア電話会議からの会議操作用にはサポートされません。

Yes

No

アドホック会議(ハードウェア ベース)

Yes

Yes

ミートミー会議

新しいコールが会議に参加するときに、各会議参加者の LPCOR ポリシーが検証されます。LPCOR ポリシー検証が失敗すると、コールは会議への参加をブロックされます。

リオーダー トーンが再生され、ミートミー会議を開始した IP Phone に、会議を完了できない旨を示すメッセージが表示されます。

Yes

Yes
(参加のみ)

コール ピックアップ/グループ ピックアップ(Cisco Unified CME 7.1 以降のバージョン)

コール ピックアップとピックアップ グループでは、電話ユーザは、別の内線番号を呼び出しているコールに応答できます。コールとピックアップ電話機の間の LPCOR ポリシー検証が失敗すると、ピックアップがブロックされます。

リオーダー トーンが再生され、コール ピックアップを試行した IP Phone に、不明な番号のメッセージが表示されます。

Yes

Yes

コール パーク(Cisco Unified CME 7.1 以降のバージョン)

電話機ユーザは、特殊な内線番号でコールを保留して、他の電話機に着信するようにできます。

LPCOR ポリシー検証が失敗すると、電話機でパークされたコールの取得することはできません。リオーダー トーンが再生され、パークされたコールの取得を試行した IP Phone に、不明な番号のメッセージが表示されます。コールは、コールパーク スロットにパークされたままになります。

Yes

Yes

コール パーク取得

Yes

Yes

ハント グループ パイロット
(ephone ハント グループ)

シーケンシャルおよび最長のアイドル ハント グループ用にサポートされています。コールが ephone ハント グループを通して SCCP エンドポイントにダイレクトされる場合に、LPCOR ポリシー検証が実行されます。

Yes

No

ハント グループ パイロット
(音声ハント グループ)

パラレル ハント グループ専用にサポートされています。ハント ターゲットは、SCCP 電話機、SIP 電話機、VoIP トランク、または PSTN トランクにすることができます。コールとパイロット ハント ターゲットの間で、LPCOR ポリシー検証が実行されます。LPCOR ポリシーが制限されている場合、コールはターゲットからブロックされます。

Yes

Yes

シェアド ライン

共有ディレクトリ番号を持つ電話機は、同じ LPCOR ポリシーを持つ必要があります。

Yes

Yes

C 割込

ディレクトリ番号を共有する電話機ユーザは、共有回線のアクティブ コールに参加できます。電話機は、同じ LPCOR ポリシーを持つ必要があります。

Yes

Yes

サードパーティ コール制御

Cisco Unified CME は、リモート コール制御システムによる Out-of-dialog REFER(OOD-R)をサポートします。最初の発信コールが確立された後、2 番めの発信コールが設定される間に、LPCOR 検証が実行されます。最初の発信コールと 2 番めの発信コールの間の LPCOR ポリシーが制限されている場合には、OOD-R 要求が失敗します。

Yes

Yes

LPCOR の電話機ディスプレイと警告トーン

Cisco Unified CME は、LPCOR ポリシー認証が原因でコールをブロックする場合、発信者にリオーダー トーンを再生します。表 62 に、コールがブロックされたときに、電話機に表示されるメッセージを示します。

 

表 62 ブロックされた LPCOR コールのメッセージ表示

コール ブロックのタイプ
電話機ディスプレイのメッセージ
SCCP 電話機
SIP 電話機

コール転送

転送できません(Unable to Transfer)

転送が失敗しました(Transfer Failed)

会議

会議を完了できません(Cannot Complete Conference)

ミートミー会議

画面を更新できません(No Screen Display Update)

ピックアップ

不明な番号(Unknown Number)

パーク

不明な番号(Unknown Number)

LPCOR VSA

コールに関連付けられた LPCOR ポリシーの新しいベンダー固有属性(VSA)は、Remote Authentication Dial-in User Service(RADIUS)アカウンティングの Cisco Unified CME によって生成されたコール詳細レコード(CDR)に含まれます。ヌル値は、デフォルトの LPCOR 値である、関連付けられた LPCOR ポリシーを持たないコール レッグで使用されます。コールの着信または発信 LPCOR ポリシーは、RADIUS STOP レコードに追加されます。

表 63 に新しい VSA を示します。

 

表 63 Cisco 音声コールでサポートされる VSA

属性
VSA 番号 (10 進数)
値またはテキストの形式
値またはテキストの例
説明

in-lpcor-group

1

String

pstn_group

着信コールに関連付けられた論理パーティショニング制限クラス(LPCOR)リソース グループ ポリシー。

out-lpcor-group

1

String

voip_group

発信コールに関連付けられた LPCOR リソース グループ ポリシー。

LPCOR の設定方法

ここでは、次の作業について説明します。

「LPCOR ポリシーの定義」

「LPCOR ポリシーとアナログ電話機または PSTN トランク コールとの関連付け」

「LPCOR ポリシーと VoIP トランク コールの関連付け」

「LPCOR ポリシーと IP Phone または SCCP FXS 電話機コールとの関連付け」

「LPCOR と携帯電話コールとの関連付け」

「LPCOR 設定の確認」

LPCOR ポリシーの定義

LPCOR 機能をイネーブルにして、通話制限を必要とする各リソース グループのポリシーを定義するには、次の作業を実行します。各リソース グループに 1 つの LPCOR ポリシーを定義できます。通話制限を必要としないリソース グループには、LPCOR ポリシーを作成しないでください。LPCOR ポリシーを持たないターゲット リソース グループは、その他すべてのリソース グループからのコールを受け入れることができます。

手順の概要

1. enable

2. configure terminal

3. voice lpcor enable

4. voice lpcor call-block cause cause-code

5. voice lpcor custom

6. group number lpcor-group

7. exit

8. voice lpcor policy lpcor-group

9. accept lpcor-group

10. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

voice lpcor enable

 

Router(config)# voice lpcor enable

Cisco Unified CME ルータで LPCOR 機能をイネーブルにします。

ステップ 4

voice lpcor call-block cause cause-code

 

Router(config)# voice lpcor call-block cause 79

(任意)LPCOR 検証の失敗によってコールがブロックされたときに使用する、原因コードを定義します。

範囲:1 ~ 180。デフォルト:63(serv/opt-unavail-unspecified)。原因コードの説明を表示するには、 ? と入力します。

ステップ 5

voice lpcor custom

 

Router(config)# voice lpcor custom

Cisco Unified CME ルータ上の LPCOR リソース グループの名前と番号を定義します。

ステップ 6

group number lpcor-group

 

Router(cfg-lpcor-custom)# group 1 pstn_trunk

LPCOR リソース グループをカスタム リソース リストに追加します。

number :LPCOR エントリのグループ番号。範囲:1 ~ 64。

lpcor-group :LPCOR リソース グループを識別する文字列。

ステップ 7

exit

 

Router(cfg-lpcor-custom)# exit

LPCOR カスタム コンフィギュレーション モードを終了します。

ステップ 8

voice lpcor policy lpcor-group

 

Router(config)# voice lpcor policy pstn_trunk

リソース グループの LPCOR ポリシーを作成します。

lpcor-groupステップ 6 で定義したリソース グループの名前。

ステップ 9

accept lpcor-group

 

Router(cfg-lpcor-policy)# accept analog_phone

LPCOR ポリシーで、指定されたリソース グループに関連付けられたコールを受け付けます。

デフォルト:その他のグループ空のコールは拒否されます。同じリソース グループからのコールは受け付けられます。

このポリシーで受け付けるコールのリソース グループごとにこのコマンドを繰り返します。

ステップ 10

end

 

Router(cfg-lpcor-policy)# end

特権 EXEC モードに戻ります。

次に、リソースが 5 つのグループにパーティショニングされている LPCOR 設定の例を示します。3 つのリソース グループには、受け入れ可能なコールを制限する LPCOR ポリシーがあります。ipphone_local と analog_phone のその他 2 つのグループでは LPCOR ポリシーが定義されていないため、その他すべてのリソース グループからのコールを受け入れることができます。

voice lpcor enable

voice lpcor call-block cause invalid-number

voice lpcor custom

group 1 pstn_trunk

group 2 analog_phone

group 3 iptrunk

group 4 ipphone_local

group 5 ipphone_remote

!

voice lpcor policy pstn_trunk

accept analog_phone

accept ipphone_local

!

voice lpcor policy iptrunk

accept analog_phone

accept ipphone_local

accept ipphone_remote

!

voice lpcor policy ipphone_remote

accept iptrunk

accept analog_phone

accept ipphone_local

次に、リソースが次の 4 つのポリシー グループにパーティショニングされている LPCOR の設定例を示します。

siptrunk:すべての IP トランク コールを受け入れます。

h323trunk:すべての IP トランク コールを受け入れます。

pstn:すべての IP トランク コールおよびボイスメール コールをブロックします。

voicemail:IP トランク コールおよび PSTN コールの両方を受け入れます。

voice lpcor enable

voice lpcor custom

group 1 siptrunk

group 2 h323trunk

group 3 pstn

group 4 voicemail

!

voice lpcor policy siptrunk

accept h323trunk

accept voicemail

!

voice lpcor policy h323trunk

accept siptrunk

accept voicemail

!

voice lpcor policy pstn

!

voice lpcor policy voicemail

accept siptrunk

accept h323trunk

accept pstn

次に、自身に関連付けられたコールを拒否するように設定されているポリシーの例を示します。local_phone リソース グループに属するデバイスは、互いのコールを受け入れることができません。

voice lpcor policy local_phone

no accept local_phone

accept analog_phone

LPCOR ポリシーとアナログ電話機または PSTN トランク コールとの関連付け

アナログ電話機または PSTN トランクを発信側または着信側とするコールに LPCOR ポリシーを関連付けるには、次の作業を実行します。デフォルトの LPCOR ポリシーに関連付けないリモート アナログ電話機またはローカル アナログ電話機には、特定の LPCOR ポリシーを音声ポートまたはトランク グループを通して適用できます。


) LAN を通してローカルで Cisco Unified CME に登録されているアナログ FXS 電話機に関しては、「LPCOR ポリシーと IP Phone または SCCP FXS 電話機コールとの関連付け」を参照してください。


アナログ電話機または PSTN トランクからの着信コールは、次の設定に基づいて、リストされている順番で LPCOR リソース グループに関連付けられます。

1. 音声ポート

2. トランク グループ

アナログ電話機または PSTN トランクからの発信コールは、発信 POTS ダイヤルピア内の音声ポートまたはトランク グループの設定に基づいて、LPCOR ポリシーに関連付けられます。

発信ダイヤルピアが port コマンドによって設定されている場合、発信コールは音声ポートで指定された LPCOR ポリシーを使用します。

発信ダイヤルピアが trunkgroup コマンドによって設定されている場合、コールはトランク グループで指定された LPCOR ポリシーを使用します。

前提条件

LPCOR ポリシーが定義されていること。「LPCOR ポリシーの定義」を参照してください。

手順の概要

1. enable

2. configure terminal

3. trunk group name

4. lpcor incoming lpcor-group

5. lpcor outgoing lpcor-group

6. exit

7. voice-port port

8. lpcor incoming lpcor-group

9. lpcor outgoing lpcor-group

10. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

trunk group name

 

Router(config)# trunk group isdn1

トランクグループ コンフィギュレーション モードを開始して、トランク グループを定義します。

ステップ 4

lpcor incoming lpcor-group

 

Router(config-trunk-group)# lpcor incoming isdn_group1

着信コールに LPCOR リソース グループ ポリシーを関連付けます。

ステップ 5

lpcor outgoing lpcor-group

 

Router(config-trunk-group)# lpcor outgoing isdn_group1

発信コールに LPCOR リソース グループ ポリシーを関連付けます。

ステップ 6

exit

 

Router(config-trunk-group)# exit

LPCOR カスタム コンフィギュレーション モードを終了します。

ステップ 7

voice-port port

 

Router(config)# voice-port 0/1/0

音声ポート コンフィギュレーション モードを開始します。

Port 引数は、プラットフォームによって異なります。 ? を入力すると、 構文が表示されます。

ステップ 8

lpcor incoming lpcor-group

 

Router(config-voiceport)# lpcor incoming vp_group3

着信コールに LPCOR リソース グループ ポリシーを関連付けます。

ステップ 9

lpcor outgoing lpcor-group

 

Router(config-voiceport)# lpcor outgoing vp_group3

発信コールに LPCOR リソース グループ ポリシーを関連付けます。

ステップ 10

end

 

Router(config-voiceport)# end

特権 EXEC モードに戻ります。

PSTN トランク

次に、PSTN トランクの設定例を示します。ダイヤルピア 201 はトランク グループ isdn1 を使用して設定されているため、ダイヤルピア 201 からの発信コールは LPCOR ポリシー isdn_group1 を使用します。ダイヤルピア 202 は音声ポート 3/1:15 を使用して設定されているため、ダイヤルピア 202 からの発信コールは LPCOR ポリシー vp_group3 を使用します。ダイヤルピアは、音声ポートまたはトランク グループのいずれかで設定可能であり、それら両方を使用することはできません。

trunk group isdn1

lpcor incoming isdn_group1

lpcor outgoing isdn_group1

!

interface Serial2/0:15

isdn incoming-voice voice

trunk-group isdn1

...

voice-port 3/1:15

lpcor incoming vp_group3

lpcor outgoing vp_group3

!

!

dial-peer voice 201 pots

description TG outbound dial-peer

destination-pattern 201T

trunkgroup isdn1

!

dial-peer voice 202 pots

description VP outbound dial-peer

destination-pattern 202T

port 3/1:15

アナログ電話機

次に、アナログ電話機用の LPCOR の設定例を示します。

trunk group analog1

lpcor incoming analog_group1

lpcor outgoing analog_group1

!

voice-port 1/0/0

!

voice-port 1/0/1

!

voice-port 1/1/0

lpcor incoming vp_group1

lpcor outgoing vp_group1

!

dial-peer voice 100 pots

description VP dial-peer

destination-pattern 100

port 1/0/0

!

dial-peer voice 101 pots

description VP dial-peer

destination-pattern 101

port 1/0/1

!

dial-peer voice 110 pots

description VP dial-peer

destination-pattern 110

port 1/1/0

!

dial-peer voice 300 pots

description TG outbound dial-peer

destination-pattern 300

trunk-group analog1

LPCOR ポリシーと VoIP トランク コールの関連付け

VoIP トランク(H.323 または SIP)を発信側または着信側とするコールに LPCOR ポリシーを関連付けるには、次の作業を実行します。

着信 VoIP トランク コールは、次の設定に基づいて、リストされている順番で LPCOR ポリシーに関連付けられます。

1. IP トランク サブネット テーブル

2. 音声サービス VoIP コンフィギュレーション

発信 VoIP トランク コールは、次の設定に基づいて、リストされている順番で LPCOR ポリシーに関連付けられます。

1. 発信 VoIP ダイヤルピア

2. デフォルトの LPCOR ポリシー(LPCOR ポリシーは適用されません)

前提条件

LPCOR ポリシーが定義されていること。「LPCOR ポリシーの定義」を参照してください。

制約事項

LPCOR IP トランク サブネット テーブルは、IPv6 アドレスを使用したコールではサポートされていません。音声サービス コンフィギュレーション モードの lpcor incoming コマンドで指定された LPCOR ポリシーは、IPv6 トランク コールでサポートされています。

発信 VoIP ダイヤルピアが sip-server または ras キーワードを使用して session target コマンドで設定された場合は、単一の LPCOR ポリシーのみ発信 IP トランク コールに適用されます。

ダイヤルピア COR と LPCOR の両方がダイヤルピアで定義された場合は、ダイヤルピア COR 設定が LPCOR よりも優先されます。たとえば、ダイヤルピア COR がコールを制限し、LPCOR がコールを許可した場合は、LPCOR の定義が考慮される前にダイヤルピア COR の定義によってコールが失敗します。

手順の概要

1. enable

2. configure terminal

3. voice lpcor ip-trunk subnet incoming

4. index index-number lpcor-group { ipv4-address network-mask | hostname hostname }

5. exit

6. voice service voip

7. lpcor incoming lpcor-group

8. exit

9. dial-peer voice tag voip

10. lpcor outgoing lpcor-group

11. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

voice lpcor ip-trunk subnet incoming

 

Router(config)# voice lpcor ip-trunk subnet incoming

VoIP トランクからの着信コール用の LPCOR IP トランク サブネット テーブルを作成します。

ステップ 4

index index-number lpcor-group { ipv4-address network-mask | hostname hostname }

 

Router(cfg-lpcor-iptrunk-subnet)# index 1 h323_group1 172.19.33.0 255.255.255.0

LPCOR リソース グループを IP トランク サブネット テーブルに追加します。

ステップ 5

exit

 

Router(cfg-lpcor-iptrunk-subnet)# exit

LPCOR カスタム コンフィギュレーション モードを終了します。

ステップ 6

voice service voip

 

Router(config)# voice service voip

音声サービス コンフィギュレーション モードを開始し、VoIP カプセル化タイプを指定します。

ステップ 7

lpcor incoming lpcor-group

 

Router(conf-voi-serv)# lpcor incoming voip_trunk_1

着信コールに LPCOR リソース グループ ポリシーを関連付けます。

ステップ 8

exit

 

Router(conf-voi-serv)# exit

音声サービス コンフィギュレーション モードを終了します。

ステップ 9

dial-peer voice tag voip

 

Router(config)# dial-peer voice 233 voip

dial-peer コンフィギュレーション モードを開始して、VoIP コールのダイヤルピアを定義します。

ステップ 10

lpcor outgoing lpcor-group

 

Router(config-dial-peer)# lpcor outgoing h323_group1

発信コールに LPCOR リソース グループ ポリシーを関連付けます。

ステップ 11

end

 

Router(config-dial-peer)# end

特権 EXEC モードに戻ります。

次に、VoIP トランク用の LPCOR の設定例を示します。

voice lpcor ip-trunk subnet incoming

index 1 h323_group1 172.19.33.0 255.255.255.0

index 2 sip_group1 172.19.22.0 255.255.255.0

index 3 sip_group2 hostname sipexample

!

voice service voip

lpcor incoming voip_trunk_1

!

dial-peer voice 233 voip

description H323 trunk outbound dial-peer

destination-pattern 233T

session target ipv4:172.19.33.233

lpcor outgoing h323_group1

!

dial-peer voice 2255 voip

description SIP trunk outbound dial-peer

destination-pattern 255T

session protocol sipv2

session target ipv4:172.19.33.255

lpcor outgoing sip_group1

LPCOR ポリシーと IP Phone または SCCP FXS 電話機コールとの関連付け

ローカルまたはリモート IP Phone、またはローカル SCCP アナログ(FXS)電話機を発信側または着信側とするコールに LPCOR ポリシーを関連付けるには、次の作業を実行します。

TRAI 要件に応じて、IP Phone または SCCP FXS 電話が LAN を通して Cisco Unified CME にローカルに登録されている場合は、PSTN コールと VoIP コールの両方を受け入れることができます。電話機が WAN を通して Cisco Unified CME に登録されている場合は、リモート電話機から PSTN コールをブロックする必要があります。

前提条件

LPCOR ポリシーが定義されていること。「LPCOR ポリシーの定義」を参照してください。

SCCP FXS 電話機が、 type anl コマンドが設定されていること。

制約事項

ディレクトリ番号を共有する電話機は、同じ LPCOR ポリシーで設定する必要があります。同じディレクトリ番号を共有する IP Phone 間で異なる LPCOR ポリシーを設定しようとすると、警告メッセージが表示されます。

ローカル IP Phone とリモート IP Phone は、同じ LPCOR ポリシーを使用できません。

ソフトウェアベースの 3 者間アド ホック会議は、SIP 電話機ではサポートされていません。

ハードウェアベースのアド ホック会議は、SIP 電話機ではサポートされていません。

音声ゲートウェイが Cisco Unified Communications Manager に登録されている場合は、Cisco VG224 や Cisco Integrated Service Router などの音声ゲートウェイで、LPCOR 機能がサポートされません。Cisco Unified Communications Manager では LPCOR はサポートされていません。

サード パーティ モードのコール制御アプリケーションが Cisco Unified CME に 2 つの別個のコールを行い、その 2 つのコール間でメディア ブリッジを実行する場合は、Cisco Unified CME がブリッジに対応していないため、LPCOR 検証がサポートされません。

手順の概要

1. enable

2. configure terminal

3. ephone phone-tag
または
voice register pool phone-tag

4. lpcor type { local | remote }

5. lpcor incoming lpcor-group

6. lpcor outgoing lpcor-group

7. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ephone phone-tag

または

voice register pool phone-tag

 

Router(config)# ephone 2

または

Router(config)# voice register pool 4

ephone コンフィギュレーション モードを開始して、SCCP 電話機の電話機固有のパラメータを設定します。

または

音声レジスタ プール コンフィギュレーション モードを開始して、SIP 電話機の電話機固有パラメータを設定します。

phone-tag :電話機を識別する一意のシーケンス番号。範囲はバージョンとプラットフォームに依存します。範囲を表示するには、 ? と入力します。

ステップ 4

lpcor type { local | remote }

 

Router(config-ephone)# lpcor type remote

または

Router(config-register-pool)# lpcor type local

IP Phone の LPCOR タイプを設定します。

local :IP Phone は、常に LAN を通して Cisco Unified CME に登録されます。

remote :IP Phone は、常に WAN を通して Cisco Unified CME に登録されます。

このコマンドは ephone テンプレート コンフィギュレーション モードまたは音声レジスタ テンプレート コンフィギュレーション モードで設定し、1 台または複数の電話機に適用することができます。電話機の設定はテンプレートの設定よりも優先されます。

ステップ 5

lpcor incoming lpcor-group

 

Router(config-ephone)# lpcor incoming ephone_group1

または

Router(config-register-pool)# lpcor incoming remote_group3

着信コールに LPCOR リソース グループ ポリシーを関連付けます。

この電話機が別の電話機とディレクトリ番号を共有する場合は、もう一方の電話機の LPCOR ポリシーと同じ LPCOR ポリシーを電話機に設定する必要があります。

このコマンドは ephone テンプレート コンフィギュレーション モードまたは音声レジスタ テンプレート コンフィギュレーション モードで設定し、1 台または複数の電話機に適用することができます。電話機の設定はテンプレートの設定よりも優先されます。

ステップ 6

lpcor outgoing lpcor-group

 

Router(config-ephone)# lpcor outgoing ephone_group2

または

Router(config-register-pool)# lpcor outgoing remote_group3

発信コールに LPCOR リソース グループ ポリシーを関連付けます。

この電話機が別の電話機とディレクトリ番号を共有する場合は、もう一方の電話機の LPCOR ポリシーと同じ LPCOR ポリシーを電話機に設定する必要があります。

このコマンドは ephone テンプレート コンフィギュレーション モードまたは音声レジスタ テンプレート コンフィギュレーション モードで設定し、1 台または複数の電話機に適用することができます。電話機の設定はテンプレートの設定よりも優先されます。

ステップ 7

end

 

Router(config-ephone)# end

または

Router(config-register-pool)# end

特権 EXEC モードに戻ります。

SCCP

次に、2 台の SCCP 電話機の LPCOR の設定例を示します。ここでは、設定を直接電話機に適用する場合と、電話テンプレートを通して適用する場合の例を示します。

ephone-template 1

lpcor type local

lpcor incoming ephone_group1

lpcor outgoing ephone_group1

!

ephone 1

mac-address 00E1.CB13.0395

ephone-template 1

type 7960

button 1:1

!

ephone 2

lpcor type remote

lpcor incoming ephone_group2

lpcor outgoing ephone_group2

mac-address 001C.821C.ED23

type 7960

button 1:2

SIP

次に、2 台の SIP 電話機の LPCOR の設定例を示します。

voice register template 1

lpcor type local

lpcor incoming test_group

lpcor outgoing test_group

!

voice register pool 3

id mac 001B.D584.E80A

type 7960

number 1 dn 2

template 1

codec g711ulaw

!

voice register pool 4

lpcor type remote

lpcor incoming remote_group3

lpcor outgoing remote_group3

id mac 0030.94C2.9A55

type 7960

number 1 dn 2

dtmf-relay rtp-nt

SCCP FXS アナログ

次に、Cisco VG224 に接続され、Cisco Unified CME によって制御される 2 台の SCCP FXS 電話機の LPCOR の設定例を示します。

dial-peer voice 102 pots

service stcapp

port 1/0/2

!

ephone 5

lpcor type local

lpcor incoming analog_vg224

lpcor outgoing analog_vg224

mac-address F9E5.8B28.2402

ephone-template 1

max-calls-per-button 2

type anl

button 1:5

!

ephone 6

lpcor type local

lpcor incoming analog_vg224

lpcor outgoing analog_vg224

mac-address F9E5.8B28.2403

ephone-template 1

max-calls-per-button 2

type anl

button 1:6

!

図 28 に、Cisco Unified CME で管理された SCCP FXS 電話機のネットワークの例を示します。

図 28 Cisco Unified CME で管理される SCCP FXS 電話機

 

LPCOR と携帯電話コールとの関連付け

携帯タイプの電話機を発信側または着信側とするコールに LPCOR ポリシーを関連付けるには、次の作業を実行します。

携帯タイプの電話機は、LAN または WAN を通して Cisco Unified CME に登録できます。このような電話機には、エクステンション モビリティ電話機、Cisco IP Communicator ソフトフォン、リモート テレワーカー電話機などがあります。

携帯タイプの電話機への着信コールおよび発信コールは、次の設定に基づいて、リストされている順番で LPCOR ポリシーに関連付けられます。

1. IP Phone サブネット テーブル

2. 携帯タイプの電話機のデフォルトの LPCOR ポリシー

前提条件

LPCOR ポリシーが定義されていること。「LPCOR ポリシーの定義」を参照してください。

制約事項

LPCOR IP Phone サブネット テーブルは、IPv6 アドレスを使用したコールではサポートされていません。

手順の概要

1. enable

2. configure terminal

3. ephone phone-tag
または
voice register pool phone-tag

4. lpcor type mobile

5. exit

6. voice lpcor ip-phone subnet { incoming | outgoing }

7. index index-number lpcor-group { ipv4-address network-mask [ vrf vrf-name ] | dhcp-pool pool-name }

8. exit

9. voice lpcor ip-phone mobility { incoming | outgoing } lpcor-group

10. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ephone phone-tag

または

voice register pool phone-tag

 

Router(config)# ephone 1

または

Router(config)# voice register pool 1

ephone コンフィギュレーション モードを開始して、SCCP 電話機の電話機固有のパラメータを設定します。

または

音声レジスタ プール コンフィギュレーション モードを開始して、SIP 電話機の電話機固有パラメータを設定します。

phone-tag :電話機を識別する一意のシーケンス番号。範囲はバージョンとプラットフォームに依存します。範囲を表示するには、 ? と入力します。

ステップ 4

lpcor type mobile

 

Router(config-ephone)# lpcor type mobile

携帯タイプの電話機の LPCOR タイプを設定します。

このコマンドは ephone テンプレート コンフィギュレーション モードまたは音声レジスタ テンプレート コンフィギュレーション モードで設定し、1 台または複数の電話機に適用することができます。電話機の設定はテンプレートの設定よりも優先されます。

ステップ 5

exit

 

Router(config-ephone)# exit

電話機の設定を終了します。

ステップ 6

voice lpcor ip-phone subnet { incoming | outgoing }

 

Router(config)# voice lpcor ip-phone subnet incoming

携帯タイプの電話機へのコール、または携帯タイプの電話機からのコールに関して LPCOR IP-phone サブネット テーブルを作成します。

ステップ 7

index index-number lpcor-group { ipv4-address network-mask [ vrf vrf-name ] | dhcp-pool pool-name }

 

Router(cfg-lpcor-ipphone-subnet)# index 1 local_group1 dhcp-pool pool1

LPCOR グループを IP Phone サブネット テーブルに追加します。

ステップ 8

exit

 

Router(cfg-lpcor-ipphone-subnet)# exit

LPCOR IP-phone コンフィギュレーション モードを終了します。

ステップ 9

voice lpcor ip-phone mobility { incoming | outgoing } lpcor-group

 

Router(config)# voice lpcor ip-phone mobility incoming remote_group1

携帯タイプの電話機のデフォルトの LPCOR ポリシーを設定します。

ステップ 10

exit

 

Router(config)# exit

特権 EXEC モードに戻ります。

次に、3 台の携帯タイプの電話機の設定例を示します。

ephone 270

lpcor type mobile

mac-address 1234.4321.6000

type 7960

button 1:6

mtp

codec g729r8 dspfarm-assist

description teleworker remote phone

ephone 281

lpcor type mobile

mac-address 0003.4713.5554

type CIPC

button 1:5

...

voice register pool 6

lpcor type mobile

id mac 0030.94C2.9A66

type 7960

number 1 dn 3

dtmf-relay rtp-nte

次に、単一の共有 IP アドレス プールを使用する LPCOR IP-phone サブネット コンフィギュレーションの例を示します。DHCP pool1 からの共有 IP アドレスを使用する任意の携帯タイプの IP Phone は、ローカル IP Phone であると見なされ、local_group1 LPCOR ポリシーに関連付けられます。共有 IP アドレスを使用しないその他の携帯タイプの IP Phone は、リモート IP Phone であると見なされ、携帯タイプの電話機用のデフォルトの LPCOR ポリシーである、remote_group1 に関連付けられます。

ip dhcp pool pool1

network 10.0.0.0 255.255.0.0

option 150 ip 10.0.0.1

default-router 10.0.0.1

!

!

voice lpcor ip-phone subnet incoming

index 1 local_group1 dhcp-pool pool1

!

voice lpcor ip-phone subnet outgoing

index 1 local_group1 dhcp-pool pool1

!

voice lpcor ip-phone mobility incoming remote_group1

voice lpcor ip-phone mobility outgoing remote_group1

次に、別々の IP アドレス DHCP プールを使用する LPCOR IP-phone サブネット コンフィギュレーションの例を示します。別々の DHCP プールを使用する任意の携帯タイプの IP Phone は、ローカル IP Phone であると見なされ、local_group1 LPCOR ポリシーが割り当てられます。DHCP アドレスを使用しないその他の携帯タイプの IP Phone は、リモート IP Phone であると見なされ、remote_group1 LPCOR ポリシーが割り当てられます。

ip dhcp pool client1

network 10.0.0.0 255.255.0.0

mac-address 0003.4713.5554

option 150 ip 10.0.0.1

default-router 10.0.0.1

!

ip dhcp pool client2

network 10.0.0.0 255.255.0.0

mac-address 0030.94C2.9A66

option 150 ip 10.0.0.1

default-router 10.0.0.1

!

!

voice lpcor ip-phone subnet incoming

index 1 local_group1 dhcp-pool client1

index 2 local_group1 dhcp-pool client2

!

voice lpcor ip-phone subnet outgoing

index 1 local_group1 dhcp-pool client1

index 2 local_group1 dhcp-pool client2

!

voice lpcor ip-phone mobility incoming remote_group1

voice lpcor ip-phone mobility outgoing remote_group1

次に、IP アドレス ネットワーク マスクと単一の共有アドレス DHCP プールの両方を使用する LPCOR IP-phone サブネット コンフィギュレーションの例を示します。IP Phone サブネット テーブル内の IP アドレス ネットワーク マスクを照合することにより、IP Phone に特定の LPCOR ポリシーを関連付けることができます。LPCOR ポリシー local_group2 は、IP アドレス 10.0.10.23 を使用するローカル IP Phone に関連付けられます。LPCOR local_group2 は、DHCP プールの照合によってその他のローカル IP Phone に関連付けられます。

ip dhcp pool pool1

network 10.0.0.0 255.255.0.0

option 150 ip 10.0.0.1

default-router 10.0.0.1

!

!

voice lpcor ip-phone subnet incoming

index 1 local_g2 10.0.10.23 255.255.255.0 vrf vrf-group2

index 2 remote_g2 172.19.0.0 255.255.0.0

index 3 local_g1 dhcp-pool pool1

!

voice lpcor ip-phone subnet outgoing

index 1 local_g4 10.1.10.23 255.255.255.0 vrf vrf-group2

index 2 remote_g4 172.19.0.0 255.255.0.0

index 3 local_g5 dhcp-pool pool1

!

voice lpcor ip-phone mobility incoming remote_g1

voice lpcor ip-phone mobility outgoing remote_g1

LPCOR 設定の確認

次の show コマンドを使用して LPCOR 設定情報を表示し、コールに関連付けられた LPCOR ポリシーを確認します。

show call active voice :着信コール レッグおよび発信コール レッグ(VoIP、ephone、SIP、PSTN)に関する LPCOR 情報を表示します。

show call history voice :着信コール レッグおよび発信コール レッグ(VoIP、ephone、SIP、PSTN)に関する LPCOR 情報を表示します。また、LPCOR ポリシー検証のためにコールがブロックされた場合は、LPCOR コール ブロック原因コードを表示します。

show dial-peer voice :着信コールと発信コールの LPCOR 設定を含む、音声ダイヤルピアの設定値を表示します。

show trunk group :着信コールと発信コールの LPCOR 設定を含む、トランク グループの設定値を表示します。

show voice lpcor :各リソース グループとディレクトリ番号に関連付けられた LPCOR ポリシーを含む LPCOR コールに関する情報、および失敗したコールの統計情報を表示します。

show voice port :着信コールと発信コールの LPCOR 設定を含む、音声ポートの設定値を表示します。

LPCOR の設定例

ここでは、次の設定例について説明します。

「Cisco Unified CME 用の LPCOR:例」

「Cisco 3800 シリーズ サービス統合型ルータ:例」

Cisco Unified CME 用の LPCOR:例

図 29 に、LPCOR を使用した Cisco Unified CME ネットワークの例を示します。このネットワークは、次の 4 つの LPCOR リソース グループで構成されます。

local_group:ローカルで Cisco Unified CME に接続される携帯タイプの電話機を含む、アナログ電話機と IP Phone。

pstn_group:PSTN と Cisco Unified CME との間のトランク。

remote_group:携帯タイプの電話機を含む IP Phone、および WAN を通してリモートで Cisco Unified CME に接続される SIP プロキシ サーバ。

voice_mail_group:WAN を通してリモートで Cisco Unified CME に接続される Cisco Unity Express ボイスメール システム。

図 29 Cisco Unified CME ネットワークにおける LPCOR リソースのグループ化

 

図 30 に、次のコール要件を持つリソース グループ間のアクセス ポリシーを示します。

remote_group と pstn_group 間のコールをブロック

voice_mail_group から pstn_group および remote_group へのコールをブロック

local_group と remote_group 間のコールを許可

local_group と pstn_group 間のコールを許可

voice_mail_group へのすべてのコールを許可

図 30 LPCOR ポリシー ロジック

 

次に、この例の LPCOR 設定の出力例を示し、手順について説明します。設定に関するコメントは、出力に含まれています。

1. Cisco Unified CME で LPCOR 機能をイネーブルにし、カスタム LPCOR グループを定義します。

voice lpcor enable

!

voice lpcor custom

group 1 pstn_group

group 2 local_group

group 3 remote_group

group 4 voice_mail_group

!

#Allow calls only from local group to PSTN group

voice lpcor policy pstn_group

accept local_group

!

# Allow calls from PSTN, remote, and voice_mail groups to local group

voice lpcor policy local_group

accept pstn_group

accept remote_group

accept voice_mail_group

!

# Allow calls only from local group to remote group

voice lpcor policy remote_group

accept local_group

!

# Allow calls from PSTN, remote, and local groups to voice_mail group

voice lpcor voice_mail_group

accept pstn_group

accept local_group

accept remote_group

!

2. 電話機、トランク、および IP リソースに LPCOR を割り当てます。

# analog phone5

voice-port 1/0/0

lpcor incoming local_group

lpcor outgoing local_group

!

# analog phone6

voice-port 1/0/1

lpcor incoming local_group

lpcor outgoing local_group

!

# TDM trunks

voice-port 2/1:23

lpcor incoming pstn_group

lpcor outgoing pstn_group

!

!

# Specific LPCOR setting for incoming calls from voice_mail_group

voice lpcor ip-trunk subnet incoming

voice_mail_group 172.19.28.11 255.255.255.255

!

!

# Default LPCOR setting for any incoming VoIP calls

voice service voip

lpcor incoming remote_group

!

# Cisco Unified CME is DHCP server

ip dhcp pool client1

network 10.0.0.0 255.255.0.0

mac-address 0003.4713.5554

option 150 ip 10.0.0.1

default-router 10.0.0.1

!

# IP phone1 (local)

ephone 1

lpcor type local

lpcor incoming local_group

lpcor outgoing local_group

!

# IP phone2 (mobile)

ephone 2

lpcor type mobile

!

# IP phone3 (remote)

ephone 3

lpcor type remote

lpcor incoming remote_group

lpcor outgoing remote_group

!

# IP phone4 (mobile)

ephone 4

lpcor type mobile

!

# IP-phone subnet tables for mobile IP phones

voice lpcor ip-phone subnet incoming

local_group dhcp-pool pool1

!

voice lpcor ip-phone subnet outgoing

local_group dhcp-pool client1

!

# Default LPCOR policy for mobile IP phones that

# are not provisioned through IP-phone subnet tables

voice lpcor ip-phone mobility incoming remote_group

voice lpcor ip-phone mobility outgoing remote_group

!

3. 発信 VoIP コールの発信 LPCOR 設定を定義します。

# VoIP outbound dial-peer to Cisco Unity Express mail

dial-peer voice 1234 voip

destination-pattern 56800

session target ipv4:172.19.281.1

pcor outgoing voice_mail_group

!

# VoIP outbound dial-peer to SIP proxy

dial-peer voice 1255 voip

destination-pattern 1255T

session protocol sipv2

session target sip-server

lpcor outgoing remote

Cisco 3800 シリーズ サービス統合型ルータ:例

Router# show running-config

Building configuration...

Current configuration : 10543 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

card type t1 2 1

logging message-counter syslog

logging buffered 2000000

no logging console

!

no aaa new-model

network-clock-participate slot 2

!

ip source-route

ip cef

!

!

ip dhcp excluded-address 192.168.20.1

ip dhcp excluded-address 192.168.20.1 192.168.20.5

!

ip dhcp pool voice

network 192.168.20.0 255.255.255.0

option 150 ip 192.168.20.1

default-router 192.168.20.1

!

!

no ip domain lookup

no ipv6 cef

multilink bundle-name authenticated

!

!

isdn switch-type primary-5ess

!

voice-card 0

!

voice-card 2

!

!

voice service voip

notify redirect ip2pots

allow-connections sip to sip

sip

bind control source-interface GigabitEthernet0/1

bind media source-interface GigabitEthernet0/1

registrar server expires max 120 min 60

!

!

!

voice class custom-cptone leavetone

dualtone conference

frequency 400 800

cadence 400 50 200 50 200 50

!

voice class custom-cptone jointone

dualtone conference

frequency 600 900

cadence 300 150 300 100 300 50

!

!

voice iec syslog

voice register global

mode cme

source-address 192.168.20.1 port 5060

max-dn 20

max-pool 20

load 7970 SIP70.8-4-2S

load 7960-7940 P0S3-08-11-00

authenticate realm cisco.com

tftp-path flash:

telnet level 2

create profile sync 0000312474383825

!

voice register dn 1

number 4000

name cme-sip1

label 4000

!

voice register dn 2

number 4001

name cme-sip-2

label 4001

!

voice register dn 3

number 4002

name cme-remote

label 4002

!

voice register template 1

softkeys remote-in-use cBarge Barge Newcall

!

voice register pool 1

lpcor type local

lpcor incoming local_sip

lpcor outgoing local_sip

id mac 001B.D4C6.AE44

type 7960

number 1 dn 1

dtmf-relay rtp-nte

codec g711ulaw

!

voice register pool 2

lpcor type local

lpcor incoming local_sip

lpcor outgoing local_sip

id mac 001E.BE8F.96C1

type 7940

number 1 dn 2

dtmf-relay rtp-nte

codec g711ulaw

!

voice register pool 3

lpcor type remote

lpcor incoming remote_sip

lpcor outgoing remote_sip

id mac 001E.BE8F.96C0

type 7940

number 1 dn 3

dtmf-relay rtp-nte

codec g711ulaw

!

!

voice lpcor enable

voice lpcor call-block cause invalid-number

voice lpcor custom

group 1 voip_siptrunk

group 2 voip_h323trunk

group 3 pstn_trunk

group 4 cue_vmail_local

group 5 cue_vmail_remote

group 6 vmail_unity

group 7 local_sccp

group 8 local_sip

group 9 remote_sccp

group 10 remote_sip

group 11 analog_vg224

group 12 analog_fxs

group 13 mobile_phone

!

voice lpcor policy voip_siptrunk

accept cue_vmail_local

accept local_sccp

accept local_sip

accept analog_vg224

!

voice lpcor policy cue_vmail_local

accept voip_siptrunk

accept voip_h323trunk

accept local_sccp

accept local_sip

!

voice lpcor policy local_sccp

accept local_sip

accept remote_sccp

accept remote_sip

accept analog_vg224

accept analog_fxs

!

voice lpcor policy remote_sccp

accept local_sccp

accept local_sip

accept remote_sip

!

voice lpcor policy analog_vg224

accept local_sccp

accept local_sip

accept remote_sccp

accept remote_sip

!

voice lpcor policy analog_fxs

accept local_sccp

accept local_sip

!

voice lpcor ip-phone subnet incoming

index 1 local_sccp dhcp-pool voice

!

voice lpcor ip-phone subnet outgoing

index 1 local_sccp dhcp-pool voice

!

!

!

archive

log config

hidekeys

!

!

controller T1 2/0

cablelength short 133

pri-group timeslots 1-24

!

controller T1 2/1

!

!

interface Loopback1

ip address 192.168.21.1 255.255.255.0

ip ospf network point-to-point

!

interface GigabitEthernet0/0

ip address 192.168.160.1 255.255.255.0

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1

ip address 192.168.20.1 255.255.255.0

duplex auto

speed auto

media-type rj45

!

interface FastEthernet0/2/0

ip address 192.168.98.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/2/1

no ip address

duplex auto

speed auto

!

interface Service-Engine1/0

ip unnumbered Loopback1

service-module ip address 192.168.21.100 255.255.255.0

service-module ip default-gateway 192.168.21.1

!

interface Serial2/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-5ess

isdn incoming-voice voice

no cdp enable

!

router ospf 1

log-adjacency-changes

network 192.168.160.0 0.0.0.255 area 0

network 192.168.20.0 0.0.0.255 area 0

network 192.168.21.0 0.0.0.255 area 0

!

ip forward-protocol nd

ip route 192.168.21.100 255.255.255.255 Service-Engine1/0

!

!

no ip http server

!

!

tftp-server flash:term41.default.loads

tftp-server flash:term61.default.loads

tftp-server flash:SCCP41.8-3-1S.loads

tftp-server flash:apps41.8-3-0-50.sbn

tftp-server flash:cnu41.8-3-0-50.sbn

tftp-server flash:P003-08-11-00.bin

tftp-server flash:P003-08-11-00.sbn

tftp-server flash:P0S3-08-11-00.sb2

tftp-server flash:P0S3-08-11-00.loads

tftp-server flash:term71.default.loads

tftp-server flash:term70.default.loads

tftp-server flash:jar70sccp.8-2-2TR2.sbn

tftp-server flash:dsp70.8-2-2TR2.sbn

tftp-server flash:cvm70sccp.8-2-2TR2.sbn

tftp-server flash:apps70.8-2-2TR2.sbn

tftp-server flash:SCCP70.8-2-2SR2S.loads

!

control-plane

!

!

voice-port 0/1/0

lpcor incoming analog_fxs

lpcor outgoing analog_fxs

station-id name FXS-Phone

station-id number 3000

caller-id enable

!

voice-port 0/1/1

!

voice-port 2/0:23

!

ccm-manager fax protocol cisco

!

mgcp fax t38 ecm

!

!

!

dial-peer voice 2 voip

destination-pattern 2...

lpcor outgoing voip_siptrunk

session protocol sipv2

session target ipv4:192.168.97.1

codec g711ulaw

ip qos dscp cs5 media

ip qos dscp cs4 signaling

!

dial-peer voice 5050 voip

description *** VMAIL Dial-Peer ***

destination-pattern 5...

lpcor outgoing cue_vmail_local

session protocol sipv2

session target ipv4:192.168.21.100

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 30 pots

destination-pattern 3000

direct-inward-dial

port 0/1/0

!

!

sip-ua

mwi-server ipv4:192.168.21.100 expires 3600 port 5060 transport udp

registrar ipv4:192.168.21.1 expires 3600

!

!

telephony-service

em logout 0:0 0:0 0:0

max-ephones 15

max-dn 15

ip source-address 192.168.20.1 port 2000

service phone videoCapability 1

load 7941 SCCP41.8-3-1S

date-format dd-mm-yy

voicemail 5050

max-conferences 12 gain -6

transfer-system full-consult

transfer-pattern .T

transfer-pattern ....

fac standard

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

ephone-template 1

softkeys hold Join Newcall Resume Select

softkeys idle Cfwdall ConfList Dnd Join Newcall Pickup Redial RmLstC

softkeys seized Endcall Redial Cfwdall Pickup

!

!

ephone-template 2

lpcor type remote

lpcor incoming remote_sccp

lpcor outgoing remote_sccp

!

!

ephone-dn 1 dual-line

number 5000

call-forward busy 5050

call-forward noan 5050 timeout 10

mwi sip

!

!

ephone-dn 2 dual-line

number 5001

call-forward busy 5050

call-forward noan 5050 timeout 10

mwi sip

!

!

ephone-dn 3 dual-line

number 5010

description vg224-1/1

name analog-1

!

!

ephone-dn 4 dual-line

number 5011

description vg224-1/2

name analog-2

!

!

ephone-dn 5 dual-line

number 5012

description vg224-1/3

name analog-3

!

!

ephone-dn 6 dual-line

number 5013

description vg224-1/4

name analog-4

!

!

ephone-dn 7 dual-line

number 5020

name SCCP-Remote

mwi sip

!

!

ephone 1

lpcor type local

lpcor incoming local_sccp

lpcor outgoing local_sccp

mac-address 001E.7A26.EB60

ephone-template 1

type 7941

button 1:1

!

!

!

ephone 2

lpcor type local

lpcor incoming local_sccp

lpcor outgoing local_sccp

mac-address 001E.7AC2.CCF9

ephone-template 1

type 7941

button 1:2

!

!

!

ephone 3

lpcor type local

lpcor incoming analog_vg224

lpcor outgoing analog_vg224

mac-address F9E5.8B28.2400

ephone-template 1

max-calls-per-button 2

type anl

button 1:3

!

!

!

ephone 4

lpcor type local

lpcor incoming analog_vg224

lpcor outgoing analog_vg224

mac-address F9E5.8B28.2401

ephone-template 1

max-calls-per-button 2

type anl

button 1:4

!

!

!

ephone 5

lpcor type local

lpcor incoming analog_vg224

lpcor outgoing analog_vg224

mac-address F9E5.8B28.2402

ephone-template 1

max-calls-per-button 2

type anl

button 1:5

!

!

!

ephone 6

lpcor type local

lpcor incoming analog_vg224

lpcor outgoing analog_vg224

mac-address F9E5.8B28.2403

ephone-template 1

max-calls-per-button 2

type anl

button 1:6

!

!

!

ephone 7

mac-address 001B.D52C.DF1F

ephone-template 2

type 7970

button 1:7

!

!

alias exec cue ser ser 1/0 sess

!

line con 0

line aux 0

line 66

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120

line vty 0 4

login

!

exception data-corruption buffer truncate

scheduler allocate 20000 1000

end

その他の参考資料

ここでは、LPCOR 機能に関する関連資料について説明します。

標準

標準
タイトル

この機能によってサポートされる新しい標準または変更された標準はありません。またこの機能による既存標準のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットに関する MIB を探してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能によりサポートされた新規 RFC または改訂 RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

LPCOR の機能情報

表 64 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームを確認できます。Cisco Feature Navigator にアクセスするには、 http://www.cisco.com/go/cfn に移動します。Cisco.com のアカウントは必要ありません。


表 64 に、特定の Cisco IOS ソフトウェア リリース トレインの中で特定の機能のサポートが導入された Cisco IOS ソフトウェア リリースだけを示します。その機能は、特に断りがない限り、それ以降の一連の Cisco IOS ソフトウェア リリースでもサポートされます。


 

表 64 LPCOR の機能情報

機能名
Cisco Unified CME のバージョン
機能情報

Cisco Unified CME のコール制約規制

8.0

LPCOR 機能のサポートが導入されました。