Cisco Unified Communications Manager Express システム アドミニストレータ ガイド
CTI CSTA プロトコル スイートの設定
CTI CSTA プロトコル スイートの設定
発行日;2013/04/10 | 英語版ドキュメント(2013/04/03 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 18MB) | フィードバック

目次

CTI CSTA プロトコル スイートの設定

内容

CTI CSTA プロトコル スイートについて

CiscoUnifiedCME の CTI CSTA

CTI セッション

サポートされるサービスとイベント

CTI CSTA プロトコル スイートを設定する方法

CiscoUnifiedCME での CTI CSTA のイネーブル化

前提条件

次の作業

セッション マネージャの作成

CTI CSTA 動作用の番号またはデバイスの設定

前提条件

制約事項

CSTA クライアント アプリケーションと CiscoUnifiedCME 間のセッションのクリア

前提条件

CTI CSTA プロトコル スイートの設定例

MOC クライアント:例

セッション マネージャを必要とする CSTA クライアント アプリケーション:例

その他の参考資料

関連資料

標準

MIB

RFC

シスコのテクニカル サポート

CTI CSTA プロトコル スイートの機能情報

CTI CSTA プロトコル スイートの設定

このモジュールでは、 Cisco Unified Communications Manager Express(Cisco Unified CME)8.0 以降のバージョンで、Computer Telephony Integration(CTI)Computer Supported Telecommunications Applications(CSTA)プロトコル スイートを設定する方法について説明します。この設定によって、Microsoft Office Communicator(MOC)クライアントや Cisco Unified Communications Express(UC Express)Services Interface SDK を使用して開発されたアプリケーションなどのコンピュータベース CSTA クライアント アプリケーションが、Cisco Unified CME システムをモニタおよび制御し、Cisco Unified CME に登録された SCCP テレフォニー デバイスをプログラムによって制御できるようになります。


) Cisco Unified CME および Cisco Customer Response Solutions(CRS)と Cisco Unified Contact Center Express(Cisco Unified CCX)間の相互運用性のサポートを設定するには、を参照してください。


このモジュールで紹介する機能情報の入手方法

お使いの Cisco Unified CME のバージョンが、このモジュールで説明されている機能の一部をサポートしていないことがあります。 各機能がサポートされているバージョンのリストについては、「CTI CSTA プロトコル スイートの機能情報」を参照してください。

CTI CSTA プロトコル スイートについて

これらの新機能をイネーブルにするには、次の概念を理解しておく必要があります。

「Cisco Unified CME の CTI CSTA」

「CTI セッション」

「サポートされるサービスとイベント」

Cisco Unified CME の CTI CSTA

Cisco Unified CME 8.0 以降のバージョンの CTI CSTA プロトコル スイートは、 Microsoft Office Communications Server(OCS)および Cisco Unified CME CTI SDK を使用して作成されたアプリケーションを通じて、Microsoft Office Communicator(MOC)クライアントなどのコンピュータベース CSTA クライアント アプリケーションに対してサードパーティ コール制御機能を提供し、アプリケーションからのクリックツーダイヤルを可能にします

Cisco Unified CME 8.8 以降のバージョンの CTI CSTA プロトコル スイートによって、アプリケーションからの Dial-via-office 機能が使用可能になります。

CSTA クライアント アプリケーションの導入

一般的に、コンピュータベース アプリケーションは、CSTA を使用して、SIP CSTA ゲートウェイを通じて関連付けられた PBX 電話を制御します。このゲートウェイでは、SIP メッセージが終端され、PBX 固有のプロトコルとの間で ECMA-323 メッセージが変換されます。

Cisco Unified CME 8.0 以降のバージョンで、コンピュータベース CSTA クライアント アプリケーションは、Cisco Unified CME の CTI インターフェイスを通じて Cisco Unified CME と直接対話し、Cisco Unified CME に登録された IP Phone を制御およびモニタします。Cisco Unified CME は、一般的なアプリケーションと PBX の導入によって CSTA ゲートウェイと PBX を置き換え、クライアント アプリケーションからの SIP メッセージを終端させ、電話機を制御する回線側プロトコルに CSTA XML を変換します。

CTI セッション

必要な場合、CSTA クライアント アプリケーションは、Cisco Unified CME 8.0 以降のバージョンで CTI インターフェイスとの SIP ダイアログを確立することにより、セッションを作成します。電話機ユーザの論理名は、SIP の「From」ヘッダーに記述され、PBX 電話回線は、SIP の「To」ヘッダーに記述されます。ユーザと回線の設定は、アプリケーションで行います。

SIP INVITE 本文には、System Status サービス要求が含まれます。System Status 応答を含む SIP「OK」応答が、Cisco Unified CME から送信されます。アプリケーションは、想定された応答を受信した場合にだけ、引き続き実行されます。

想定された応答を受信した後に、クライアント アプリケーションは、サポートされる CSTA サービスおよびイベントのリストを Cisco Unified CME に要求する SIP メッセージを送信することにより、機能の交換を開始します。Cisco Unified CME は、サポートされるサービスとイベントのリストであるカプセル化 CSTA 機能応答を送信します。詳細については、「サポートされるサービスとイベント」を参照してください。

CSTA クライアント アプリケーションは、CSTA イベントによるコールと機能に対する変更を監視する前に、CSTA モニタを起動する必要があります。Cisco Unified CME で Call Monitor Module(CMM)を起動するために、アプリケーションはカプセル化されたサービス要求とともに SIP INFO メッセージを送信します。CTI インターフェイスは、この要求を承認し、カプセル化された ECMA-323 Monitor Start 応答とともに、SIP 200 OK 応答を返信します。その後、Cisco Unified CME は、アプリケーションに対する SIP INFO メッセージで後続のイベントの生成を開始します。

CTI セッション中に、CSTA クライアント アプリケーションは、INVITE メッセージでタイマー(デフォルト:30 分)を設定し、RE-INVITE メッセージでタイマーを更新します。Cisco Unified CME は、セッションの終了後に SIP ダイアログを削除します。

サポートされるサービスとイベント

表 139 に、Cisco Unified CME 8.0 以降のバージョンで CTI CSTA プロトコル スイートによってサポートされている CSTA サービスおよびイベントを示します。すべての CSTA クライアント アプリケーションが、すべての機能をサポートできるわけではありません。詳細については、CSTA クライアント アプリケーションのユーザ マニュアルを参照してください。

表 139 サポートされる CSTA サービスとイベント

機能
サポートされるサービスとイベント

コール制御

発信

Answer Call

Clear Connection

Reconnect

コールの保留

Retrieve Call(Resume)

Deflect Call(アラート状態のみ)

Single Step Transfer Call

Consultation Call

Transfer Call

Alternate Call Generate Digits(DTMF)

論理電話機能

Get Do Not Disturb

Set Do Not Disturb

Get CFwdALL

Set CFwdAll

Physical Device

Set MWI

Snapshot Services

Snapshot Device

CTI CSTA プロトコル スイートによってサポートされているサービスとイベントの詳細なリストについては、『 UCX-SI SDK Developer's guide 』(http://developer.cisco.com/web/ucxapi/docs)を参照してください。

CTI CSTA プロトコル スイートを設定する方法

表 140 に、コンピュータベース CSTA クライアント アプリケーションが、Cisco Unified CME で IP Phone を制御できるようにするために必要なタスクのリストを、完了すべきタスクの順に示します。このマニュアルには、この表の最初の 2 つの手順についてタスクの実行に関する情報と、ステップ 3 の実行手順を示します。

 

表 140 CSTA クライアント アプリケーションと Cisco Unified CME 間の相互運用性の設定タスク

手順
タスク
ドキュメント名

1

適切なバージョンの Cisco Unified Communications Manager Express(Cisco Unified CME)がルータにインストールされていることを確認します。

--

2

必要な場合は、コンピュータベース CSTA クライアント アプリケーション に対する AXL ユーザ名およびパスワードを含め、Cisco Unified CME を設定します。

ヒント アプリケーションの AXL ユーザ ID およびパスワードと Cisco Unified CME ルータの IP アドレスをメモします。 (注) AXL クレデンシャルは、MOC クライアントでは要求されません。

「前提条件」を参照してください。

3

CSTA クライアント アプリケーションとの相互運用性を実現するために、Cisco Unified CME を設定します。

以下のリストを参照してください。

4

CSTA クライアント アプリケーションをインストールします。

アプリケーションのマニュアルを参照してください。

5

CTI ゲートウェイ フロントエンドまたはクライアント アプリケーションの SIP URI を含め、Cisco Unified CME に対して CSTA クライアント アプリケーションを設定します。

ここでは、次の作業について説明します。

「Cisco Unified CME での CTI CSTA のイネーブル化」(必須)

「セッション マネージャの作成」(任意)

「CTI CSTA 動作用の番号またはデバイスの設定」(必須)

「CSTA クライアント アプリケーションと Cisco Unified CME 間のセッションのクリア」(任意)

Cisco Unified CME での CTI CSTA のイネーブル化

Cisco Unified CME と コンピュータベース CSTA クライアント アプリケーション 間の相互運用性を実現するために Cisco Unified CME を設定するには、次の手順を実行します。

前提条件

Cisco Unified CME 8.0 以降のバージョンが Cisco ルータにインストールされ、設定されていること。

(MOC クライアントでは不要)一部の CSTA クライアント アプリケーションへのアクセス用の AXL ユーザ名を作成する、XML API が設定されていること。アプリケーションに対して AXL ユーザ名が必要かどうかを判断するには、そのアプリケーションのマニュアルを参照してください。設定については、 を参照してください。


) CSTA クライアント アプリケーションの初期セットアップ中に、telephony-service コンフィギュレーション モードで ip source-address コマンドを使用して設定したルータ IP アドレスが必要です。一部のクライアント アプリケーションでは、telephony-service コンフィギュレーション モードで xml user コマンドを使用して設定した AXL ユーザ名およびパスワードが必要になることもあります。


手順の概要

1. enable

2. configure terminal

3. voice service voip

4. allow-connections sip-to-sip

5. no supplementary-service sip moved-temporary

6. no supplementary-service sip-refer

7. no cti shutdown

8. callmonitor

9. gcid

10. cti csta mode basic

11. cti message device-id suppress-conversion

12. sip

13. registrar server [ expires [ max sec ][ min sec ]

14. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

voice service voip

 

Router(config)# voice service voip

音声サービス コンフィギュレーション モードを開始し、Voice Over IP(VoIP)カプセル化を指定します。

ステップ 4

allow-connections sip-to-sip

 

Router(config-voi-serv)# allow-connections sip-to-sip

VoIP ネットワーク内の特定のエンドポイント タイプの間での接続を可能にします。

ステップ 5

no supplementary-service sip moved-temporary

 

Router(config-voi-serv)# no supplementary-service sip moved-temporary

コール自動転送のための補足サービスをディセーブルにします。

ステップ 6

no supplementary-service sip refer

 

Router(config-voi-serv)# no supplementary-service sip refer

ルータが、コール転送のために REFER メッセージを宛先に転送することを防止します。

ステップ 7

no cti shutdown

 

Router(config-voi-serv)# no cti shutdown

CTI 統合をイネーブルにします。

ステップ 8

callmonitor

 

Router(config-voi-serv)# callmonitor

(任意)処理とレポートのためのコール モニタリング メッセージング機能をイネーブルにします。

このコマンドは、MOC クライアントでは要求 されません

ステップ 9

gcid

 

Router(config-voi-serv)# gcid

(任意)コール制御の目的のために Global Call-ID(Gcid)をイネーブルにします。

このコマンドは、MOC クライアントでは要求 されません

ステップ 10

cti csta mode basic

 

Router(config-voi-serv)# cti csta mode basic

(任意)CTI メッセージの強化機能または拡張を抑制します。

MOC クライアントで要求されます。

ステップ 11

cti message device-id suppress-conversion

 

Router(config-voi-serv)# cti message device-id suppress-conversion

(任意)CTI メッセージで関連付けられたエンドポイントの内線番号の変換またはプロモーションを抑制します。

このコマンドは、MOC クライアントでは要求 されません

ステップ 12

sip

 

Router(config-voi-serv)# sip

SIP コンフィギュレーション モードを開始します。

Cisco Unified CME で SIP レジストラ機能をイネーブルにするために次の手順を実行する場合にだけ要求されます。

ステップ 13

registrar server [ expires [ max sec ][ min sec ]]

 

Router(config-voi-sip)# registrar server expires max 600 min 60

(任意)Cisco Unified CME で SIP レジストラ機能をイネーブルにします。

max sec :(任意)登録が期限切れになるまでの最大時間(秒単位)。範囲:600 ~ 86400。デフォルト:3600。推奨値:600。


) 登録の期限切れタイムアウトは、TCP からの切断を防止するために、必ず TCP 接続エージング タイムアウトよりも小さい値に設定します。


このコマンドは、MOC クライアントでは要求 されません

ステップ 14

end

 

Router(config-voi-sip)# end

音声サービス コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

次の例は、MOC クライアントとの対話をサポートするために必要な設定を示しています。

voice service voip
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
no cti shutdown
cti csta mode basic
!
!
!

次の作業

Cisco Unified CME でセッション サーバを必要とする CSTA クライアント アプリケーションを設定している場合は、「セッション マネージャの作成」に進みます

MOC クライアントと対話するために Cisco Unified CME を設定している場合は、「CTI CSTA 動作用の番号またはデバイスの設定」に進みます。

セッション マネージャの作成

CSTA クライアント アプリケーションに対して Cisco Unified CME でセッション マネージャを設定するには、次の手順を実行します。


) • このタスクは、MOC クライアントでは要求されません

単一の Cisco Unified CME で複数のセッション マネージャをサポートできます。


 

手順の概要

1. enable

2. configure terminal

3. voice register global

4. mode cme

5. exit

6. voice register session-server session-server-tag

7. cti-aware

8. register-id name

9. keepalive seconds

10. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

voice register global

 

Router(config)# voice register global

音声レジスタ グローバル コンフィギュレーション モードを開始します。

ステップ 4

mode cme

 

Router(voice-register-global)# mode cme

Cisco Unified CME で SIP デバイスをプロビジョニングするためのモードをイネーブルにします。

ステップ 5

exit

 

Router(voice-register-global)# configure terminal

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

voice register session-server session-server-tag

 

Router(config)# voice register session-server 1

音声レジスタ セッションサーバ コンフィギュレーション モードを開始し、セッション マネージャをイネーブルにし、設定します。

範囲:1 ~ 8。

単一の Cisco Unified CME で複数のセッション マネージャをサポートできます。

ステップ 7

cti-aware

 

Router(config-register-fs)# cti-aware

このセッション マネージャを CTI サブシステムにバインドし、CTI 固有の登録ハートビートをイネーブルにします。

ステップ 8

register-id name

 

Router(config-register-fs)# register app1

登録要求中に CSTA クライアント アプリケーションを明確に識別するための ID を作成します。

name :アプリケーションを識別するための文字列。1 ~ 30 文字の英数字を使用できます。

ステップ 9

keepalive seconds

 

Router(config-register-fs)# keepalive 60

登録が期限切れになる前にアプリケーションを再登録しない限り、経過後に登録が期限切れになるキープアライブ時間(秒単位)。

範囲:60 ~ 3600。デフォルト:300。

ステップ 10

end

 

Router(config-register-fs)# end

音声レジスタ セッションサーバ コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

!
voice register global
mode cme
source-address 10.0.0.1 port 5060
!
!
voice register session-server 1
keepalive 60
register-id app1
cti-aware
!

CTI CSTA 動作用の番号またはデバイスの設定

CTI CSTA 動作用にディレクトリ番号または IP Phone を設定するには、CSTA クライアント アプリケーションによってモニタおよび制御される各番号または電話機に対して次の手順を実行します。

前提条件

アプリケーションによって制御およびモニタされるディレクトリ番号または IP Phone が、Cisco Unified CME で設定されている。設定については、を参照してください。

アプリケーションによって制御およびモニタされるエクステンション モビリティ(EM)電話機が、必要なユーザ プロファイルを含め、Cisco Unified CME で設定されていること。詳細については、を参照してください。

制約事項

CSTA クライアント アプリケーションによって制御できるのは、SCCP IP Phone だけです。Cisco VG224 Analog Phone Gateway とアナログ電話機および SIP 電話機は、Cisco Unified CME で通常どおりサポートされていますが、CSTA クライアント アプリケーション向けの IP Phone としてはサポートされていません。

オーバーレイ DN は、CSTA クライアント アプリケーション向けの IP Phone ではサポートされていません。Cisco Unified CME の Call Monitor モジュールは、オーバーレイ設定の場合と同様に、同じディレクトリ番号に対する 2 つの着信コールが同じ電話機宛か、異なる電話機宛かを判断できません。オーバーレイ DN は、Cisco Unified CME で通常どおりサポートされていますが、CSTA クライアント アプリケーションによって制御またはモニタされる IP Phone ではサポートされていません。

すべての SCCP IP Phone が、CTI CSTA プロトコル スイートでプロンプト付き発信機能をサポートしているわけではありません。Cisco VG224 Analog Phone Gateway、Cisco ATAs、および Cisco ルータの SCCP 制御 FXS ポートは、CSTA クライアント アプリケーションからプロンプト付き発信要求をサポートしていません。Cisco Unified 792X および Cisco Unified 793X など、特定の Cisco Unified 電話モデルは、CSTA クライアント アプリケーションからプロンプト付き発信要求を完了できないことがあります。

プロンプト付き発信は、MOC クライアントに関連付けられた IP Phone ではサポートされていません。プロンプト付き発信は、Cisco Unified CME で通常どおりサポートされていますが、MOC クライアント アプリケーションによって制御される IP Phone ではサポートされていません。

共有回線は、MOC クライアントに関連付けられた IP Phone ではサポートされていません。共有回線は、Cisco Unified CME で通常どおりサポートされていますが、MOC クライアント アプリケーションによって制御される IP Phone ではサポートされていません。

MOC クライアントによって制御およびモニタされる電話機が、エクステンション モビリティ(EM)電話機である場合、MOC クライアントは、ユーザが EM 電話機に誰もログインしていないとき、または EM ユーザがログインした後に、EM ユーザ プロファイルのクレデンシャルを使用してその電話機にログインする必要があります。

手順の概要

1. enable

2. emadmin login name ephone-tag

3. emadmin logout name

4. configure terminal

5. ephone-dn tag

6. cti watch

7. cti notify

8. exit

9. telephony-service

10. em external

11. url services url root

12. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

emadmin login name ephone-tag

 

Router# emadmin login user204 2

(任意)エクステンション モビリティ用にイネーブルにする IP Phone にログインするため、アプリケーションをイネーブルにします。

name user (voice user-profile) コマンドで設定された EM ユーザ プロファイルのクレデンシャル。

ephone-tag :エクステンション モビリティのためにイネーブルにする IP Phone の識別子。

MOC クライアントによって設定する番号またはデバイスが制御される場合は、MOC クライアントに対して必要です。

ステップ 3

emadmin logout name

 

Router# emadmin logout user204

(任意)エクステンション モビリティ(EM)電話からアプリケーションをログアウトします。

name :エクステンション モビリティ(EM)電話にログインするためにアプリケーションが使用したエクステンション モビリティのクレデンシャル。

ステップ 4

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 5

ephone-dn tag

 

Router(config)# ephone-dn 1

ephone-dn コンフィギュレーション モードを開始します。

ステップ 6

cti watch

 

Router(config-ephone-dn)# cti watch

CSTA クライアント アプリケーションによるこのディレクトリ番号のモニタおよび制御を許可します。

このコマンドは、ephone-dn-template コンフィギュレーション モードでも設定できます。ephone-dn コンフィギュレーション モードで設定された値は、ephone-dn-template モードで設定された値よりも優先されます。

ステップ 7

cti notify

 

Router(config-ephone-dn)# cti notify

(任意)このディレクトリ番号での CIT 処理を許可するために、ephone-dn を常に「up」状態にします。

これは、モニタまたは制御する ephone-dn が物理デバイスに関連付けられていない場合に要求されます。

このコマンドは、ephone-dn-template コンフィギュレーション モードでも設定できます。ephone-dn コンフィギュレーション モードで設定された値は、ephone-dn-template モードで設定された値よりも優先されます。

ステップ 8

exit

 

Router(config-ephone-dn)# exit

ephone-dn コンフィギュレーション モードを終了します。

ステップ 9

telephony-service

 

Router(config)# telephony-service

telephony-service コンフィギュレーション モードを開始します。

IP Phone で [サービス(Services)] メニューを設定するために、ステップ 10ステップ 11 を実行する場合にだけ要求されます。

ステップ 10

em external

 

Router(config-telephony)# em external

(任意)IP Phone の [サービス(Services)] メニューからエクステンション モビリティのためのログイン ページを削除します。

ステップ 11

url services url root

 

Router(config-telephony)# url services http://my_application/menu.html root

(任意)IP Phone の [サービス(Services)] ボタンの下に、ルート電話サービスのメニューを提供します。

url :アプリケーションによって提供されるルート電話サービスの外部メニューの URL。

ステップ 12

end

 

Router(config-telephony)# end

telephony-service コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

!
voice logout-profile 1
number 203 type normal
!
voice user-profile 1
user user204 password psswrd
number 204 type normal
!
.
.
.
ephone-dn 1
number 201
cti watch
!
!
ephone-dn 2
number 202
cti watch
!
!
ephone-dn 3
number 203
cti watch
!
!
ephone-dn 4
number 204
cti notify
cti watch
!
!
ephone 1
mac-address 001E.4A34.A35F
type 7961
button 1:1
!
!
!
ephone 2
mac-address 000F.8FC7.B681
type 7960
button 1:2
!
!
!
ephone 3
mac-address 0019.E7FF.1E30
type 7961
logout-profile 1
 

CSTA クライアント アプリケーションと Cisco Unified CME 間のセッションのクリア

CSTA クライアント アプリケーションと Cisco Unified CME 間の CTI セッションを正しく破棄するには、次の手順を実行します。

前提条件

Cisco Unified CME 8.0 以降のバージョン。

show cti session コマンドを使用してセッション ID を調べます。

手順の概要

1. enable

2. clear cti session id session-tag

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

clear cti session id session-tag

 

Router# clear cti session id 3

CSTA クライアント アプリケーションと Cisco Unified CME の間のセッションをクリアします。

CTI CSTA プロトコル スイートの設定例

ここでは、次の設定例を示します。

「MOC クライアント:例」

「セッション マネージャを必要とする CSTA クライアント アプリケーション:例」

MOC クライアント:例

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname sdatar-2811s
!
boot-start-marker
boot system flash c2800nm-ipvoice-mz.oct_20090510
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
ip source-route
!
!
ip cef
!
ip dhcp pool test
network 10.0.0.0 255.255.255.0
option 150 ip 10.0.0.1
default-router 10.0.0.1
!
!
no ipv6 cef
multilink bundle-name authenticated
!
!
voice service voip
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
no cti shutdown
cti csta mode basic
!
!
!
!
voice logout-profile 1
number 203 type normal
!
voice user-profile 1
user user204 password psswrd
number 204 type normal
!
voice-card 0
!
!
!
archive
log config
hidekeys
!
!
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.0
duplex auto
speed auto
!
interface Service-Engine0/0
no ip address
shutdown
!
interface FastEthernet0/1
ip address 1.5.41.5 255.255.0.0
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.1.43.254
ip route 223.255.254.254 255.255.255.255 1.5.0.1
!
!
ip http server
!
!
ixi transport http
response size 64
no shutdown
request outstanding 1
request timeout 60
!
ixi application cme
no shutdown
!
!
!
control-plane
!
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
!
mgcp fax t38 ecm
!
!
!
sip-ua
!
!
telephony-service
em logout 1:0
max-ephones 10
max-dn 100
ip source-address 10.0.0.1 port 2000
cnf-file location flash:
cnf-file perphone
max-conferences 8 gain -6
transfer-system full-consult
create cnf-files version-stamp Jan 01 2002 00:00:00
!
ephone-dn 1
number 201
cti watch
!
!
ephone-dn 2
number 202
cti watch
!
!
ephone-dn 3
number 203
cti watch
!
!
ephone-dn 4
number 204
cti notify
cti watch
!
!
ephone 1
mac-address 001E.4A34.A35F
type 7961
button 1:1
!
!
!
ephone 2
mac-address 000F.8FC7.B681
type 7960
button 1:2
!
!
!
ephone 3
mac-address 0019.E7FF.1E30
type 7961
logout-profile 1

セッション マネージャを必要とする CSTA クライアント アプリケーション:例

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname sdatar-2811s
!
boot-start-marker
boot system flash c2800nm-ipvoice-mz.oct_20090510
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
ip source-route
!
!
ip cef
!
ip dhcp pool test
network 10.0.0.0 255.255.255.0
option 150 ip 10.0.0.1
default-router 10.0.0.1
!
!
no ipv6 cef
multilink bundle-name authenticated
!
!
voice service voip
no cti shutdown
csta cti mode basic
sip
registrar server expires max 120 min 60
!
voice register global
mode cme
source-address 10.0.0.1 port 5060
!
voice register session-server 1
keepalive 60
register-id apps
cti-aware
!
!
voice logout-profile 1
number 203 type normal
!
voice user-profile 1
user user204 password cisco
number 204 type normal
!
!
!
voice-card 0
!
!
!
archive
log config
hidekeys
!
!
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.0
duplex auto
speed auto
!
interface Service-Engine0/0
no ip address
shutdown
!
interface FastEthernet0/1
ip address 1.5.41.5 255.255.0.0
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.1.43.254
ip route 223.255.254.254 255.255.255.255 1.5.0.1
!
!
ip http server
!
!
ixi transport http
response size 64
no shutdown
request outstanding 1
request timeout 60
!
ixi application cme
no shutdown
!
!
!
control-plane
!
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
!
mgcp fax t38 ecm
!
!
!
!
sip-ua
!
!
telephony-service
em logout 1:0
max-ephones 10
max-dn 100
ip source-address 10.0.0.1 port 2000
cnf-file location flash:
cnf-file perphone
max-conferences 8 gain -6
transfer-system full-consult
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn 1
number 201
cti watch
!
!
ephone-dn 2
number 202
cti watch
!
!
ephone-dn 3
number 203
cti watch
!
!
ephone-dn 4
number 204
cti notify
cti watch
!
!
ephone 1
mac-address 001E.4A34.A35F
type 7961
button 1:1
!
!
!
ephone 2
mac-address 000F.8FC7.B681
type 7960
button 1:2
!
!
!
ephone 3
mac-address 0019.E7FF.1E30
type 7961
logout-profile 1
!
!
!

その他の参考資料

次の各項では、Cisco Unified CME 8.0 に関連するその他の資料について説明します。

関連資料

関連項目
参照先

Cisco Unified Communications Manager Express の設定

『Cisco Unified CME Command Reference』

『Cisco Unified CME Documentation Roadmap』

Cisco IOS の音声設定

『Cisco IOS Release 12.4T Configuration Documentation Roadmap』

『Cisco IOS Voice Command Reference』

SIP ゲートウェイの設定

『Cisco IOS SIP Configuration Guide』

標準

標準
タイトル

ECMA-269

『Services for Computer Supported Telecommunications Applications (CSTA) Phase III』

ECMA-323

『XML Protocol for Computer Supported Telecommunications Applications (CSTA) Phase III』

ECMA-348

『Web Services Description Language (WSDL) for CSTA Phase III』

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットに関する MIB を探してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2396

『URI Generic Syntax』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

CTI CSTA プロトコル スイートの機能情報

表 141 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームを確認できます。Cisco Feature Navigator にアクセスするには、 http://www.cisco.com/go/cfn に移動します。Cisco.com のアカウントは必要ありません。


表 141 に、特定の Cisco IOS ソフトウェア リリース トレインの中で特定の機能のサポートが導入された Cisco IOS ソフトウェア リリースだけを示します。その機能は、特に断りがない限り、それ以降の一連の Cisco IOS ソフトウェア リリースでもサポートされます。


表 141 CTI CSTA プロトコル スイートの機能情報

機能名
Cisco Unified CME のバージョン
機能情報

CTI CSTA プロトコル スイートの拡張機能

8.8

コンピュータベース CSTA クライアント アプリケーションからの Dial-via-office 機能に対応し、CSTA サービスおよびイベントのサポートが追加されました。

Cisco Unified CME の CTI CSTA プロトコル スイート

8.0

業界標準の Computer Telephony Integration(CTI)インターフェイスが導入され、コンピュータベース CSTA クライアント アプリケーションが、IP Phone をモニタまたは制御するために Cisco Unified CME と直接対話できるようになりました

この機能で新しく追加または変更されたコマンド: clear csta session cti-aware cti csta mode cti message device-id suppress-conversion cti notify cti shutdown cti watch debug cti debug cti callmon emadmin login emadmin logout em external show cti url (telephony-service)