Cisco Unified Communications Manager Express 4.3 システム アドミニストレータ ガイド
外部サービスとの相互運用性の設定
外部サービスとの相互運用性の設定
発行日;2012/01/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 11MB) | フィードバック

目次

外部サービスとの相互運用性の設定

内容

外部サービスとの相互運用性に関する情報

Unified CCX との相互運用性

外部サービスとの相互運用性の設定方法

Unified CCX との相互運用を可能にするための Cisco Unified CME の設定

前提条件

制約事項

SCCP:セッション マネージャに対する Cisco Unified CME 内のエージェント電話番号の特定

前提条件

制約事項

Cisco Unified CME での登録の確認

Cisco Unified CME でのセッション マネージャの再作成

Cisco Unified CME の SIP エンドポイントとしての Cisco CRS ルート ポイントの再設定

前提条件

制約事項

Unified CCX との相互運用性の設定例

関連情報

その他の資料

関連マニュアル

テクニカル サポート

外部サービスとの相互運用性に関する機能情報

外部サービスとの相互運用性の設定

Revised: January 11, 2008

 

この章では、Cisco Customer Response Solutions(CRS)と Cisco Unified Contact Center Express(Unified CCX)の組み合せなどの外部サービスと、Cisco Unified Communications Manager Express(Cisco Unified CME)との間の相互運用性のサポートを提供する、Cisco Unified CME の機能について説明します。

この章で説明する機能について

この章で説明している機能の一部は、ご使用のバージョンの Cisco Unified CME でサポートされていない場合があります。それぞれの機能がサポートされているバージョンの一覧については、「相互運用性機能に関する機能情報」を参照してください。

外部サービスとの相互運用性に関する情報

相互運用性を設定するには、次の概念を理解しておく必要があります。

「Unified CCX との相互運用性」

Unified CCX との相互運用性

Cisco Unified CME 4.2 以降のバージョンは、Cisco Unified CME と Cisco Customer Response Solutions(CRS)5.0 以降のバージョン(Cisco Unified Call Center Express(Unified CCX)を搭載)との相互運用をサポートしています。具体的には、拡張コール処理、デバイスとコールの監視、複数のコール センター エージェントへの不在コール転送と基本的なエクステンション モビリティ、IP IVR アプリケーションなどをサポートしています。

Unified CCX アプリケーションは、CRS プラットフォームを使用してマルチメディア(音声、データ、Web)を提供します。Cisco IP IVR の機能は Unified CCX で使用可能であり、プロンプトとコレクトおよびコール処理が含まれます。

次の機能が、Cisco Unified CME 4.2 以降のバージョンで提供されます。

Cisco Unified CME で使用する Unified CCX 用の Cisco Agent Desktop のサポート。

Unified CCX と Cisco Unified CME との間での設定の問い合せと更新。

次のような、SIP ベースの単純で補足的なコール制御サービス。

SIP ベースのルート ポイントを使用した、Cisco Unified CME と Unified CCX との間のコール ルーティング。

SIP ベースの単純で補足的なコールに対する第一者コール制御。

SIP のプレゼンスとダイアログ イベント パッケージに基づいたコール監視とデバイス監視。

Cisco Unified CME の Unified CCX セッション管理。

エージェント回線および Cisco Unified CME 内のコール アクティビティの、Unified CCX デバイス監視とコール監視。

Unified CCX におけるプロビジョニングと設定に関する情報は、Cisco United CME に自動的に提供されます。Unified CCX からの設定が削除されたか、あるいは変更が必要な場合、Cisco IOS コマンドを使用すると、Cisco Unified CME に同じ情報を設定することができます。

第一者コール制御の場合、Cisco CRS のルート ポイントは、SIP トランクを経由する Cisco Unified CME へのピア デバイスになります。コール センターの電話機をターゲットとする Cisco Unified CME への着信コールは、ルート ポイントから Unified CCX にルーティングされます。コールはキューに入れられ、Unified CCX によって最も適切なエージェントにリダイレクトされます。

コール保留、ブラインド転送、および準在席転送などの補足サービスは、Unified CCX から起動されます。ブラインド転送を除いて、既存の SIP ベースの単純で補足的なサービスのコール フローが適用されます。Unified CCX を転送元とするブラインド転送の場合、Unified CCX は転送相手が応答するまでアクティブ状態のままになります。転送されたコールに正しい応答があった場合のみ、ドロップアウトします。転送相手が応答しないまま呼出音がタイムアウトした場合、コールは Unified CCX によって戻され、別のエージェントへ再ルーティングされます。このメカニズムは、転送相手がすべてのコールの自動転送または無応答時のコール自動転送で設定されている場合にも適用されます。転送の設定は、ブラインド転送時に無視されます。

リダイレクト、転送、および会議によってコールが Unified CCX と Cisco Unified CME の間で移動すると、そのたびに SIP コール ID が変化します。コール制御のため、Cisco Unified CME は発信コール レッグごとに固有の Global Call ID(Gcid; グローバル コール ID)を発行します。システム内の同一コールであればすべてのレッグで Gcid が変化することはなく、リダイレクト、転送、および会議イベントに対して有効です。コール センターの電話機が会議ホストを務める場合の、3 者間会議も含まれます。

Cisco IOS Release 12.4(11)XW6 よりも前は、Cisco Unified CME 4.2 のコール モニタリング モジュールは、B-ACD や TCL スクリプトなどデフォルト以外のセッション アプリケーションに関連するコールを検出した場合、モジュールがグローバルに無効になりました。モジュールが無効になると、Unified CCX 管理者はセッションの完了後に、コール モニタリング モジュールを手動で再び有効にする必要がありました。

Cisco IOS Release 12.4(11)XW6 以降のリリースでは、Cisco Unified CME のコール モニタリング モジュールは、B-ACD または TCL スクリプトなどのデフォルト以外のセッション アプリケーションに関連するコール(打診転送や会議によってこのコールに結合されるすべてのコールを含む)を監視しません。モジュールは無効にならず、他のコールを監視し続けます。

表68 は、Cisco Unified CME と Unified CCX との相互運用を可能にするために必要な作業の一覧を、実行順に示しています。この項では、この表の最初の 2 つのステップの作業の実行と、ステップ 3 を完了するための手順について説明します。

設定については、「外部サービスとの相互運用性の設定方法」を参照してください。

 

表68 Cisco CRS と Cisco Unified CME との相互運用性の設定作業

ステップ
作業
マニュアル名

1

Cisco Unified Communications Manager Express(Cisco Unified CME)4.2 以降のバージョンが、ルータにインストールされていることを確認します。

2

Cisco Unified CME ルータを設定します。

ヒント AXL ユーザ ID、パスワード、およびルータの IP アドレスをメモしてください。

「前提条件」

3

Cisco Unified CME を設定し、Unified CCX との相互運用を可能にします。

「外部サービスとの相互運用性の設定方法」

4

Cisco Unified CME 用に Cisco Unified Contact Center Express(Unified CCX)をインストールします。

http://www.cisco.com/en/US/products/sw/custcosw/ps1846/prod_installation_guides_list.html の『 Cisco CRS Installation Guide

5

Cisco Unified CME 用に Cisco CRS を初期設定します。

ヒント 設定が始まると、Cisco Unified CME で作成した AXL ユーザ ID とパスワードの入力を求められます。ルータの IP アドレスも入力する必要があります。

6

CME Telephony Subsystem を設定し、Unified CCX との相互運用を可能にします。

http://www.cisco.com/en/US/products/sw/custcosw/ps1846/prod_maintenance_guides_list.html の『 Cisco CRS Administration Guide

7

ユーザを作成し、Cisco CRS のエージェント機能を割り当てます。

外部サービスとの相互運用性の設定方法

この項では、次の手順について取り上げます。

「Unified CCX との相互運用を可能にするための Cisco Unified CME の設定」(必須)

「SCCP:セッション マネージャに対する Cisco Unified CME 内のエージェント電話番号の特定」(必須)

「Cisco Unified CME での登録の確認」(オプション)

「Cisco Unified CME でのセッション マネージャの再作成」(オプション)

「Cisco Unified CME の SIP エンドポイントとしての Cisco CRS ルート ポイントの再設定」(オプション)

Unified CCX との相互運用を可能にするための Cisco Unified CME の設定

Cisco Unified CME を設定して、Cisco Unified CME と Unified CCX との相互運用を可能にするには、次の手順を実行します。


) 1 つの Cisco Unified CME で、複数のセッション マネージャをサポートできます。


前提条件

Cisco Unified CME 4.2 以降のバージョン。

互換性のある Cisco IOS リリース。詳細については、「 Cisco Unified CME and Cisco IOS Release Compatibility Matrix 」を参照してください。

XML API を設定し、Unified CCX アクセス用のユーザ名を作成する必要があります。設定については、 XML API の設定を参照してください。Cisco Unified CME 用の Cisco CRS の初期設定で使用する、ユーザ ID、パスワード、およびルータの IP アドレスをメモしてください。

Cisco Unified CME に接続する電話機が設定されている必要があります。Unified CCX エージェントの電話機の設定では、 keep-conference endcall コマンドを使用することで、会議開催者が会議コールを終了し、残りの通話相手に対して会議を終了できるようにします。設定については、 会議の設定を参照してください。

着信プレゼンス要求を受け入れるように、Cisco Unified CME ルータを設定する必要があります。設定については、 プレゼンス サービスの設定を参照してください。

制約事項

Cisco Unified CME と Unified CCX との相互運用性は、1 つの Cisco Unified CME ごとに 1 つの Unified CCX に制限されます。

サポートされる active Unified CCX エージェントの最大数は 50 です。

複数の通話相手とのアドホック会議とミートミー会議はサポートされません。

相互運用性機能の配置に関しては、PSTN トランクからの着信コールのみがサポートされます。SIP および H.323 などその他のトランクは、Cisco Unified CME で通常どおりサポートされますが、Unified CCX へのカスタマー コールではサポートされません。

要約手順

1. enable

2. configure terminal

3. voice call send-alert

4. voice service voip

5. callmonitor

6. gcid

7. allow-connections sip-to-sip

8. no supplementary-service sip moved-temporary

9. no supplementary-service sip refer

10. sip

11. registrar server [ expires [ max sec ] [ min sec ]

12. end

詳細手順

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードを有効にします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

global 設定モードを開始します。

ステップ 3

voice call send-alert

 

Router(config)# voice call send-alert

着信側ゲートウェイが、コール設定メッセージを受け取った後に、プログレス メッセージの代わりに警報メッセージを送信するようにします。

ステップ 4

voice service voip

 

Router(config)# voice service voip

voice-service 設定モードを開始し、voice-over-IP カプセル化を指定します。

ステップ 5

callmonitor

 

Router(config-voi-serv)# callmonitor

コール モニタリング メッセージング機能を有効にします。

処理および報告のために Unified CCX で使用されます。

ステップ 6

gcid

 

Router(config-voi-serv)# gcid

コール制御のためのグローバル コール ID(Gcid)を有効にします。

コールの追跡のために Unified CCX で使用されます。

ステップ 7

allow-connections sip-to-sip

 

Router(config-voi-serv)# allow-connections sip-to-sip

VoIP ネットワーク内の特定のタイプのエンドポイント間の接続を許可します。

ステップ 8

no supplementary-service sip moved-temporary

 

Router(config-voi-serv)# no supplementary-service sip moved-temporary

ルータがコール自動転送のためリダイレクト応答を宛先に送信することを防止します。

ステップ 9

no supplementary-service sip refer

 

Router(config-voi-serv)# no supplementary-service sip refer

ルータがコール転送のため REFER メッセージを宛先に送信することを防止します。

ステップ 10

sip

 

Router(config-voi-srv)# sip

SIP 設定モードを開始します。

ステップ 11

registrar server [ expires [ max sec ][ min sec ]]

 

Router(config-voi-sip)# registrar server expires max 600 min 60

Cisco Unified CME で SIP レジストラ機能を有効にします。

e xpires :(オプション)着信登録のアクティブ時間を設定します。

max sec :(オプション)登録の期限切れまでの最大時間(秒)。値の範囲は 600 ~ 86400 です。デフォルトは 3600 です。推奨値は 600 です。

min sec :(オプション)登録の期限切れまでの最小時間(秒)値の範囲は 60 ~ 3600 です。デフォルトは 60 です。

ステップ 12

end

 

Router(config-voi-serv)# end

設定モードを終了し、特権 EXEC モードを開始します。

SCCP:セッション マネージャに対する Cisco Unified CME 内のエージェント電話番号の特定

セッション マネージャが管理可能な、Unified CCX エージェントの電話機の電話回線に関連付けられた電話番号を指定するには、次の手順を実行します。

前提条件

Cisco Unified CME に、最大 8 つのセッション マネージャが設定されている必要があります。

Unified CCX エージェントの電話機に関連付けられた電話番号が設定されている必要があります。エージェントの電話機の電話番号は、二重回線として設定し、エージェントが電話機の 1 つの回線ボタンを使用して、同時に 2 つのコール接続を行えるようにする必要があります。設定については、 基本的なコールを発信するための電話機の設定を参照してください。

制約事項

Cisco Unified CME でエージェントの電話機として設定できるのは、SCCP 電話機のみです。Cisco VG224 Analog Phone Gateway とアナログおよび SIP 電話機は、Cisco Unified CME で通常どおりサポートされますが、Unified CCX エージェントの電話機としてはサポートされません。

Cisco Unified IP Phone 7931 は、Cisco Unified CME でエージェントの電話機として設定できません。Cisco Unified IP Phone 7931 は、Cisco Unified CME で通常どおりサポートされますが、Unified CCX エージェントの電話機としてはサポートされません。

共有回線表示は、エージェントの電話機でサポートされません。電話番号を、同時に複数の物理的なエージェントの電話機に関連付けることはできません。

オーバーレイ回線は、エージェントの電話機でサポートされません。エージェントの電話機の 1 つの回線ボタンに、複数の電話番号を関連付けることはできません。

回線ボタンの監視モードは、エージェントの電話機でサポートされません。エージェントの電話機は、別の電話機による監視の対象になりません。

コール自動転送とコール ピックアップでは、エージェントの電話番号を Cisco CRS ルート ポイントに転送できません。

要約手順

1. enable

2. configure terminal

3. ephone-dn dn-tag

4. allow watch

5. session-server { session-tag [ ,... session-tag ]}

6. end

詳細手順

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードを有効にします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

global 設定モードを開始します。

ステップ 3

ephone-dn dn-tag

 

Router(config)# ephone-dn 24

ephone-dn 設定モードを開始します。

dn-tag :設定済みの電話番号の固有の ID。タグ番号は、この電話番号を最初に設定したときに作成されたタグ番号に対応しています。

ステップ 4

session-server session-server-tag [ ,... session-server-tag ]

 

Router(config-ephone-dn)# session-server 1,2,3,4,6

設定対象の電話番号を監視するセッション マネージャを指定します。

session-server-tag :Unified CCX で設定され、Cisco Unified CME に自動的に提供される、固有の ID セッション マネージャ。値の範囲は 1 ~ 8 です。

ヒント session-server-tag の値が不明な場合は、1 を使用することをお勧めします。

最大 8 つの session-server-tag を設定できます。個々のタグは、カンマ( , )で区切る必要があります。

各電話番号は、最大 8 つのセッション マネージャで管理できます。各セッション マネージャは、複数の電話番号を監視できます。

ステップ 5

allow watch

 

Router(config-ephone-dn)# allow watch

このディレクトリ番号と関連付けられた電話回線を、プレゼンス サービス内のウォッチャで監視できるようにします。

このコマンドは ephone-dn template 設定モードでも設定することが可能で、1 台以上の電話機に適用できます。ephone-dn での設定は、ephone-dn template での設定よりも優先されます。

ステップ 6

end

 

Router(config-ephone-dn)# end

設定モードを終了し、特権 EXEC モードを開始します。

Cisco Unified CME での登録の確認

システムを使用する前に、Unified CCX エンドポイントの登録を確認します。


ステップ 1 show sip status registrar コマンドを使用して、セッション マネージャと Cisco CRS ルート ポイントが登録されているかどうかを確認します。

ステップ 2 show presence subscription summary コマンドを使用して、Cisco CRS ルート ポイントと Unified CCX エージェントの電話番号が登録されているかどうかを確認します。

次に、 show presence subscription summary コマンドからのサンプル出力を示します。最初の 2 行は、2 つのルート ポイントの状態を示しています。その次の 2 行は、エージェントの電話機に記録されます。

Router# show presence subscription summary
 
Presence Active Subscription Records Summary: 15 subscription
Watcher Presentity SubID Expires SibID Status
======================== ======================== ====== ======= ====== ======
CRScontrol@10.4.171.81 8101@10.4.171.34 4 3600 0 idle
CRScontrol@10.4.171.81 8201@10.4.171.34 8 3600 0 idle
CRScontrol@10.4.171.81 4016@10.4.171.34 10 3600 0 idle
CRScontrol@10.4.171.81 4020@10.4.171.34 12 3599 0 idle
 


 

Cisco Unified CME でのセッション マネージャの再作成


) Unified CCX におけるプロビジョニングと設定に関する情報は、Cisco United CME に自動的に提供されます。次の作業は、Unified CCX からの設定が削除されたか、あるいは変更する必要がある場合にのみ必要になります。


Cisco Unified CME で Unified CCX 用のセッション マネージャを再作成するには、次の手順を実行します。

要約手順

1. enable

2. configure terminal

3. voice register session-server session-server-tag

4. register-id name

5. keepalive seconds

6. end

詳細手順

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードを有効にします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

global 設定モードを開始します。

ステップ 3

voice register session-server session-server-tag

 

Router(config)# voice register session-server 1

voice register session-server 設定モードを開始し、Cisco CRS システムの Unified CCX アプリケーションなどの、外部機能サーバ用のセッション マネージャを有効にして設定します。

値の範囲は 1 ~ 8 です。

1 つの Cisco Unified CME で、複数のセッション マネージャをサポートできます。

ステップ 4

register id name

 

Router(config-register-fs)# CRS1

(オプション)Unified CCX からの設定が削除されたか、あるいは変更する必要がある場合にのみ必要です。

name :Unified CCX を識別するための文字列。1 ~ 30 文字の英数字を使用できます。

ステップ 5

keepalive seconds

 

Router(config-register-fs)# keepalive 300

(オプション)Unified CCX からの設定が削除されたか、あるいは変更する必要がある場合にのみ必要です。

登録のキープアライブ期間(秒)。登録の期限切れ前に Unified CCX が再登録した場合を除き、この期間を過ぎると登録が期限切れになります。

値の範囲は 60 ~ 3600 です。デフォルトは 300 です。


) Unified CCX のデフォルトは 120 です。


ステップ 6

end

 

Router(config-register-fs)# end

設定モードを終了し、特権 EXEC モードを開始します。

Cisco Unified CME の SIP エンドポイントとしての Cisco CRS ルート ポイントの再設定


) Unified CCX におけるプロビジョニングと設定に関する情報は、Cisco United CME に自動的に提供されます。次の作業は、Unified CCX からの設定が削除されたか、あるいは変更する必要がある場合にのみ必要になります。


Cisco CRS ルート ポイントを Cisco Unified CME の SIP エンドポイントとして再設定するには、次の手順を実行します。

前提条件

Cisco Unified CME で、Cisco CRS ルート ポイントに関連付けられた電話番号が設定されている必要があります。SIP エンドポイントに関連付けられた電話番号の設定については、 基本的なコールを発信するための電話機の設定 を参照してください。

Cisco CRS ルート ポイントに関連付けられた電話番号をウォッチできるようにする必要があります。設定については、 プレゼンス サービスの設定を参照してください。

Cisco Unified CME で mode cme コマンドを使用できるようにする必要があります。

制約事項

1 つの Cisco CRS ルート ポイントを管理できるセッション マネージャは 1 つのみです。

各セッション マネージャは、複数の Cisco CRS ルート ポイントを管理できます。

要約手順

1. enable

2. configure terminal

3. voice register dn dn-tag

4. number number

5. allow watch

6. refer target dial-peer

7. exit

8. voice register pool pool-tag

9. number tag dn dn-tag

10. session-server session-tag

11. codec codec-type [ bytes ]

12. dtmf-relay rtp-relay sip-notify

13. end

詳細手順

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードを有効にします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

global 設定モードを開始します。

ステップ 3

voice register dn dn-tag

 

Router(config-register-global)# voice register dn 1

voice register dn 設定モードを開始して、SIP 電話機、インターコム回線、音声ポート、またはメッセージ受信のインジケータ(MWI)のディレクトリ番号を定義します。

ステップ 4

number number

 

Router(config-register-dn)# number 2777

ディレクトリ番号用の有効な番号を定義します。

ステップ 5

allow watch

 

Router(config-register-dn)# allow watch

このディレクトリ番号と関連付けられた電話回線を、プレゼンス サービス内のウォッチャで監視できるようにします。

ステップ 6

refer target dial-peer

 

Router(config-register-dn)# refer target dial-peer

ウォッチャが、このディレクトリ番号からの SIP REFER メッセージを処理できるようにします。

target dial-peer :メッセージの Refer To 部分が、このディレクトリ番号のダイヤル ピアからのアドレスに基づいたものになります。

ステップ 7

exit

 

Router(config-register-dn)# exit

設定モードを終了し、設定モード階層の中で次に高いモードを開始します。

ステップ 8

voice register pool pool-tag

 

Router(config)# voice register pool 3

voice register pool 設定モードを開始し、Cisco CRS ルート ポイントのデバイス固有のパラメータを設定します。

Unified CCX の音声レジスタ プールには、最大 10 の個別 SIP エンドポイントを格納できます。追加の SIP エンドポイント用には、後続のプールが作成されます。

ステップ 9

number tag dn dn-tag

 

Router(config-register-pool)# number 1 dn 1

設定対象の SIP 電話機にディレクトリ番号を関連付けます。

ステップ 10

session-server session-server-tag

 

Router(config-register-pool)# session-server 1

設定対象のルート ポイントの制御に使用するセッション マネージャを識別します。

session-server-tag :セッション マネージャに割り当てる固有の番号です。値の範囲は 1 ~ 8 です。タグ番号は、 voice register session-server コマンドを使用して作成されたタグ番号に対応しています。

ステップ 11

codec g711ulaw

 

Router(config-register-pool)# codec g711ulaw

設定対象のルート ポイントに対して、動的に作成されたダイヤル ピアのコーデックを指定します。

codec-type :Unified CCX には g711ulaw が必要です。

ステップ 12

dtmf-relay sip-notify

 

Router(config-register-pool)# dtmf-relay sip-notify

設定対象のルート ポイントが使用する DTMF リレー方式を指定します。

ステップ 13

end

 

Router(config-register-pool)# end

設定モードを終了し、特権 EXEC モードを開始します。

Unified CCX との相互運用性の設定例

次の show running-configuration コマンドの出力は、Unified CCX と相互運用する Cisco Unified CME ルータの設定を示しています。

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname sb-sj3-3845-uut1
!
boot-start-marker
boot-end-marker
!
card type t1 0 2
card type t1 0 3
logging buffered 1000000
no logging console
enable password password
!
no aaa new-model
network-clock-participate wic 2
network-clock-participate wic 3
ip cef
!
!
no ip dhcp use vrf connected
!
!
ip dhcp excluded-address 192.0.2.250 192.0.2.254
!
ip dhcp pool ephones
network 192.0.2.0 255.255.255.0
option 150 ip 192.0.2.254
default-router 192.0.2.254
!
!
no ip domain lookup
!
isdn switch-type primary-5ess
voice-card 0
no dspfarm
!
!
!
!
voice service voip
gcid
callmonitor
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
sip
registrar server expires max 120 min 60
!
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
!
!
!
!
!
!
!
!
!
!
voice register global
mode cme
source-address 192.0.2.254 port 5060
max-dn 720
max-pool 240
authenticate presence
authenticate register
dialplan-pattern 1 511.... extension-length 4
voicemail 9001
create profile sync 0000347600391314
!
voice register session-server 1
keepalive 300
register-id SB-SJ3-UCCX1_1164774025000
!
voice register dn 1
session-server 1
number 8999
allow watch
refer target dial-peer
!
voice register dn 2
session-server 1
number 8001
allow watch
refer target dial-peer
!
voice register dn 3
session-server 1
number 8101
allow watch
refer target dial-peer
!
voice register dn 11
number 2011
name ep-sip-1-11
mwi
!
voice register dn 12
number 2012
name ep-sip-1-12
mwi
!
voice register dn 16
number 5016
name rp-sip-1-16
label SIP 511-5016
mwi
!
voice register dn 17
number 5017
name rp-sip-1-17
label SIP 511-5017
mwi
!
voice register dn 18
number 5018
name rp-sip-1-18
label SIP 511-5018
mwi
!
voice register pool 1
session-server 1
number 1 dn 1
number 2 dn 2
number 3 dn 3
dtmf-relay sip-notify
codec g711ulaw
!
voice register pool 11
id mac 1111.0711.2011
type 7970
number 1 dn 11
dtmf-relay rtp-nte
voice-class codec 1
username 5112011 password 5112011
!
voice register pool 12
id mac 1111.0711.2012
type 7960
number 1 dn 12
dtmf-relay rtp-nte
voice-class codec 1
username 5112012 password 5112012
!
voice register pool 16
id mac 0017.0EBC.1500
type 7961GE
number 1 dn 16
dtmf-relay rtp-nte
voice-class codec 1
username rp-sip-1-16 password pool16
!
voice register pool 17
id mac 0016.C7C5.0660
type 7971
number 1 dn 17
dtmf-relay rtp-nte
voice-class codec 1
username rp-sip-1-17 password pool17
!
voice register pool 18
id mac 0015.629E.825D
type 7971
number 1 dn 18
dtmf-relay rtp-nte
voice-class codec 1
username rp-sip-1-18 password pool18
!
!
!
!
!
!
!
controller T1 0/2/0
framing esf
clock source internal
linecode b8zs
pri-group timeslots 1-4,24
!
controller T1 0/2/1
framing esf
clock source internal
linecode b8zs
pri-group timeslots 1-4,24
!
controller T1 0/3/0
framing esf
clock source internal
linecode b8zs
ds0-group 0 timeslots 1-4 type e&m-immediate-start
!
controller T1 0/3/1
framing esf
clock source internal
linecode b8zs
ds0-group 0 timeslots 1-4 type e&m-immediate-start
vlan internal allocation policy ascending
!
!
!
!
interface GigabitEthernet0/0
ip address 209.165.201.1 255.255.255.224
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
ip address 192.0.2.254 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface Serial0/2/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-5ess
isdn protocol-emulate network
isdn incoming-voice voice
no cdp enable
!
interface Serial0/2/1:23
no ip address
encapsulation hdlc
isdn switch-type primary-5ess
isdn protocol-emulate network
isdn incoming-voice voice
no cdp enable
!
interface Service-Engine1/0
ip unnumbered GigabitEthernet0/0
service-module ip address 209.165.202.129 255.255.255.224
service-module ip default-gateway 209.165.201.1
!
ip route 192.0.0.30 255.0.0.0 192.0.0.55
ip route 209.165.202.129 255.255.255.224 Service-Engine1/0
ip route 192.0.2.56 255.255.255.0 209.165.202.2
ip route 192.0.3.74 255.255.255.0 209.165.202.3
ip route 209.165.202.158 255.255.255.224 192.0.0.55
!
!
ip http server
ip http authentication local
ip http path flash:
!
!
ixi transport http
response size 64
no shutdown
request outstanding 1
!
ixi application cme
no shutdown
!
!
!
control-plane
!
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/2/0:23
!
voice-port 0/3/0:0
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/2/1:23
!
voice-port 0/3/1:0
!
!
!
!
!
dial-peer voice 9000 voip
description ==> This is for internal calls to CUE
destination-pattern 9...
voice-class codec 1
session protocol sipv2
session target ipv4:209.165.202.129
dtmf-relay rtp-nte sip-notify
!
dial-peer voice 9001 voip
description ==> This is for external calls to CUE
destination-pattern 5119...
voice-class codec 1
session protocol sipv2
session target ipv4:209.165.202.129
dtmf-relay rtp-nte sip-notify
!
dial-peer voice 521 voip
destination-pattern 521....
voice-class codec 1
max-redirects 5
session protocol sipv2
session target ipv4:209.165.201.2
dtmf-relay rtp-nte sip-notify
!
dial-peer voice 531 voip
destination-pattern 531....
voice-class codec 1
max-redirects 5
session protocol sipv2
session target ipv4:209.165.201.3
dtmf-relay rtp-nte sip-notify
!
!
presence
presence call-list
watcher all
allow subscribe
!
sip-ua
mwi-server ipv4:209.165.202.128 expires 3600 port 5060 transport udp
presence enable
!
!
telephony-service
no auto-reg-ephone
xml user axluser password axlpass 15
max-ephones 240
max-dn 720
ip source-address 192.0.2.254 port 2000
system message sb-sj3-3845-uut1
url services http://192.0.2.252:6293/ipphone/jsp/sciphonexml/IPAgentInitial.jsp
url authentication http:192.0.2.252:6293/ipphone/jsp/sciphonexml/IPAgentAuthenticate.jsp
cnf-file perphone
dialplan-pattern 1 511.... extension-length 4
voicemail 9001
max-conferences 8 gain -6
call-forward pattern .T
moh flash:music-on-hold.wav
multicast moh 239.10.10.1 port 2000
transfer-system full-consult
transfer-pattern .T
create cnf-files version-stamp 7960 Jun 18 2007 07:44:25
!
!
ephone-dn 1 dual-line
session-server 1
number 1001
name ag-1-1
allow watch
mwi sip
!
!
ephone-dn 2 dual-line
session-server 1
number 1002
name ag-1-2
allow watch
mwi sip
!
!
ephone-dn 3 dual-line
session-server 1
number 1003
name ag-1-3
allow watch
mwi sip
!
!
ephone-dn 4 dual-line
session-server 1
number 1004
name ag-1-4
allow watch
mwi sip
!
!
ephone-dn 5
session-server 1
number 1005
name ag-1-5
allow watch
mwi sip
!
!
ephone-dn 11 dual-line
number 3011
name ep-sccp-1-11
mwi sip
!
!
ephone-dn 12
number 3012
name ep-sccp-1-12
mwi sip
!
!
ephone-dn 16 dual-line
number 4016
label SCCP 511-4016
name rp-sccp-1-16
mwi sip
!
!
ephone-dn 17 dual-line
number 4017
label SCCP 511-4017
name rp-sccp-1-17
mwi sip
!
!
ephone-dn 18 dual-line
number 4018
label SCCP 511-4018
name rp-sccp-1-18
mwi sip
!
!
ephone-dn 19 dual-line
number 4019
label SCCP 511-4019
name rp-sccp-1-19
mwi sip
!
!
ephone-dn 20 dual-line
number 4020
label SCCP 511-4020
name rp-sccp-1-20
mwi sip
!
!
ephone-dn 21 dual-line
number 4021
label SCCP 511-4021
name rp-sccp-1-21
mwi sip
!
!
ephone-dn 22 dual-line
number 4022
label SCCP 511-4022
name rp-sccp-1-22
mwi sip
!
!
ephone 1
mac-address 1111.0711.1001
type 7970
keep-conference endcall
button 1:1
!
!
!
ephone 2
mac-address 1111.0711.1002
type 7970
keep-conference endcall
button 1:2
!
!
!
ephone 3
mac-address 1111.0711.1003
type 7970
keep-conference endcall
button 1:3
!
!
!
ephone 4
mac-address 1111.0711.1004
type 7970
keep-conference endcall
button 1:4
!
!
!
ephone 5
mac-address 1111.0711.1005
type 7970
keep-conference endcall
button 1:5
!
!
!
ephone 11
mac-address 1111.0711.3011
type 7970
keep-conference endcall
button 1:11
!
!
!
ephone 12
mac-address 1111.0711.3012
type 7960
keep-conference endcall
button 1:12
!
!
!
ephone 16
mac-address 0012.D916.5AD6
type 7960
keep-conference endcall
button 1:16
!
!
!
ephone 17
mac-address 0013.1AA6.7A9E
type 7960
keep-conference endcall
button 1:17
!
!
!
ephone 18
mac-address 0012.80F3.B013
type 7960
keep-conference endcall
button 1:18
!
!
!
ephone 19
mac-address 0013.1A1F.6282
type 7970
keep-conference endcall
button 1:19
!
!
!
ephone 20
mac-address 0013.195A.00D0
type 7970
keep-conference endcall
button 1:20
!
!
!
ephone 21
mac-address 0017.0EBC.147C
type 7961GE
keep-conference endcall
button 1:21
!
!
!
ephone 22
mac-address 0016.C7C5.0578
type 7971
keep-conference endcall
button 1:22
!
!
!
line con 0
exec-timeout 0 0
stopbits 1
line aux 0
stopbits 1
line 66
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120
line vty 0 4
password lab
login
!
scheduler allocate 20000 1000
!
end

関連情報

Cisco Unified CME 内の電話機のパラメータを変更した場合は、新しい設定ファイルを生成してから電話機を再起動します。 電話機用の設定ファイルの生成を参照してください。

その他の資料

次の項では、Cisco Unified CME の機能に関連する参照資料を示します。

関連マニュアル

テクニカル サポート

説明
リンク

Cisco Support Web サイトでは、シスコ製品やシスコの技術に関するトラブルシューティングにお役立ていただけるように、マニュアルなどの豊富なオンライン リソースやツールを提供しています。Cisco Support Web サイトのほとんどのツールにアクセスするには、Cisco.com のユーザ ID とパスワードが必要です。サービス契約が有効で、ユーザ ID またはパスワードを取得していない場合は、Cisco.com で登録手続きを行ってください。

http://www.cisco.com/techsupport

外部サービスとの相互運用性に関する機能情報

表69 は、この章で説明した機能、およびバージョンごとの機能拡張を示しています。

特定の Cisco Unified CME バージョンをサポートする正確な Cisco IOS リリースについては、「 Cisco Unified Communications Manager Express and Cisco IOS Software Version Compatibility Matrix 」( http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/requirements/guide/33matrix.htm )を参照してください。

プラットフォームおよびソフトウェア イメージのサポートに関する情報を参照するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator では、特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートしている Cisco IOS ソフトウェアを確認できます。Cisco Feature Navigator にアクセスするには、 http://www.cisco.com/go/cfn に移動してください。Cisco.com のアカウントは必要ありません。


表69 は、所定の機能に対するサポートが導入された Cisco Unified CME のバージョンを示しています。特に断りのない限り、その機能は以降のバージョンの Cisco Unified CME ソフトウェアでもサポートされます。


 

表69 相互運用性機能に関する機能情報

機能名
Cisco Unified CME のバージョン
変更内容

外部サービスとの相互運用性

4.2

Cisco Unified CME と Cisco Customer Response Solutions(CRS)5.0 以降のバージョン(Cisco Unified Contact Center Express(Unified CCX)を搭載)との相互運用が可能です。具体的には、Cisco Unified IP IVR、拡張コール処理、デバイスとコールの監視、複数のコール センター エージェントへの不在コール転送と基本的なエクステンション モビリティなどが可能です。