Cisco Hosted Unified Communications Services プロビジョニング ガイド リリース 7.1(a)
レガシー PBX 情報
レガシー PBX 情報
発行日;2012/02/01 | 英語版ドキュメント(2010/08/12 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

レガシー PBX 情報

IOS ゲートウェイ コンフィギュレーションの例

PGW でサポートされる外部ノード タイプ

レガシー PBX 情報

このマニュアルでは、Hosted UCS Release 7.1(a) のレガシー PBX 情報について説明します。このマニュアルで取り上げる内容は次のとおりです。

「IOS ゲートウェイ コンフィギュレーションの例」

「PGW でサポートされる外部ノード タイプ」

IOS ゲートウェイ コンフィギュレーションの例

次に、MGCP 経由で PGW にバックホールされる PRI QSIG を使用して、メディア ゲートウェイを PBX に接続するコンフィギュレーションの例を示します。3825 ISR ルータが使用されて、NM-HDV2-2T1/E1 ネットワーク モジュール内の VWIC-2MFT-E1-DI インターフェイス カードを使用して PBX に接続されます。

e4qsig#sh ver
Cisco IOS Software, 3800 Software (C3825-IPVOICEK9-M), Version 12.4(15)T3, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2008 by Cisco Systems, Inc.
Compiled Thu 24-Jan-08 23:00 by prod_rel_team

 

ROM:システム ブートストラップ、バージョン 12.4(13r)T、リリース ソフトウェア(fc1)

e4qsig uptime is 19 weeks, 4 days, 21 hours, 52 minutes
System returned to ROM by power-on
System restarted at 10:34:07 BST Sun Sep 7 2008
System image file is "flash:c3825-ipvoicek9-mz.124-15.T3.bin"
.
.
.
Cisco 3825 (revision 1.2) with 224256K/37888K bytes of memory.
Processor board ID FCZ1139709Z
2 Gigabit Ethernet interfaces
31 Serial interfaces
2 Channelized E1/PRI ports
2 Channelized (E1 or T1)/PRI ports
DRAM configuration is 64 bits wide with parity enabled.
479K bytes of NVRAM.
62720K bytes of ATA System CompactFlash (Read/Write)
 

コンフィギュレーション レジスタは 0x2102

e4qsig#sh run
Building configuration...
 
Current configuration : 2863 bytes
!
! No configuration change since last restart
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname e4qsig
!
boot-start-marker
boot system flash:c3825-ipvoicek9-mz.124-15.T3.bin
boot-end-marker
!
!card type command needed for slot 1
logging buffered 51200 warnings
enable secret 5 $1$EyO2$rVgOzIpml6Fqo3NMmsy8T0
!
no aaa new-model
clock timezone GMT 0
clock summer-time BST recurring last Sun Mar 2:00 last Sun Oct 3:00
no network-clock-participate slot 1
ip cef
!
!
!
!
no ip domain lookup
ip domain name ipcbuemea.cisco.com
ip host pgw 10.120.4.11 10.121.4.11 10.120.4.12 10.121.4.12
multilink bundle-name authenticated
!
backhaul-session-manager
set QSIG client ft
group master set QSIG
group slave set QSIG
session group master 10.120.4.11 7007 10.190.4.40 7007 1
session group slave 10.120.4.12 7007 10.190.4.40 7007 1
session group master 10.121.4.11 7007 10.191.4.40 7007 2
session group slave 10.121.4.12 7007 10.191.4.40 7007 2
isdn switch-type primary-qsig
voice-card 0
no dspfarm
!
voice-card 1
no dspfarm
!
username cisco privilege 15 secret 5 $1$eLBA$jWOMg6jvjlUXeFW/9g7CC0
!
!
controller E1 1/0/0
framing NO-CRC4
pri-group timeslots 1-31 service mgcp
!
controller E1 1/0/1
!
!
!
!
interface GigabitEthernet0/0
ip address 10.190.4.40 255.255.255.0
duplex full
speed 100
media-type rj45
!
interface GigabitEthernet0/1
ip address 10.191.4.40 255.255.255.0
duplex full
speed 100
media-type rj45
!
interface Serial1/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-qsig
isdn timer T310 120000
isdn protocol-emulate network
isdn incoming-voice voice
isdn bind-l3 backhaul QSIG
no cdp enable
!
ip route 0.0.0.0 0.0.0.0 10.190.4.1
ip route 0.0.0.0 0.0.0.0 10.191.4.1 200
!
!
ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 23 permit 10.10.10.0 0.0.0.7
!
!
!
control-plane
!
!
!
voice-port 1/0/0:15
!
!
mgcp
mgcp call-agent pgw 2427 service-type mgcp version 1.0
mgcp dtmf-relay voip codec all mode nse
mgcp max-waiting-delay 1000
mgcp restart-delay 2
mgcp modem passthrough voip mode nse
mgcp codec g711alaw packetization-period 20
mgcp package-capability rtp-package
mgcp package-capability as-package
mgcp default-package gm-package
no mgcp timer receive-rtcp
mgcp bind control source-interface GigabitEthernet0/0
mgcp bind media source-interface GigabitEthernet0/0
!
mgcp profile default
!
!
!
!
!
line con 0
exec-timeout 0 0
password cisco
logging synchronous
login
stopbits 1
line aux 0
stopbits 1
line vty 0 4
exec-timeout 0 0
password cisco
login
transport input telnet
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet
!
scheduler allocate 20000 1000
ntp clock-period 17208472
ntp server 10.100.100.2
ntp server 10.100.100.3
!
end
 
back to Legacy PBX Support (Section 15)
 

PGW でサポートされる外部ノード タイプ

PGW でサポートされる外部ノード タイプを表示するには、PGW にログインして次を実行します。

cd /opt/CiscoMGC/etc
more extNodeTypes.dat

 

次に例を示します。

PGW-ENT2M% cd /opt/CiscoMGC/etc

PGW-ENT2M% more extNodeTypes.dat

C1751 MGCP IPFAS IUA BRI

C1751_OLD MGCP IPFAS IUA BRI

C1760 MGCP IPFAS IUA BRI

C1760_OLD MGCP IPFAS IUA BRI

C2600 SGCP MGCP IPFAS IUA BRI

C2600_OLD SGCP MGCP IPFAS IUA BRI

C2610XM MGCP IPFAS IUA BRI

C2610XM_OLD MGCP IPFAS IUA BRI

C2611XM MGCP IPFAS IUA BRI

C2611XM_OLD MGCP IPFAS IUA BRI

C2620XM MGCP IPFAS IUA BRI

C2620XM_OLD MGCP IPFAS IUA BRI

C2621XM MGCP IPFAS IUA BRI

C2621XM_OLD MGCP IPFAS IUA BRI

C2650XM MGCP IPFAS IUA BRI

C2650XM_OLD MGCP IPFAS IUA BRI

C2651XM MGCP IPFAS IUA BRI

C2651XM_OLD MGCP IPFAS IUA BRI

C2691 MGCP IPFAS IUA BRI

C2691_OLD MGCP IPFAS IUA BRI

C3600 SGCP MGCP IPFAS NAS IUA

C3640 MGCP IPFAS IUA BRI

C3640A MGCP IPFAS IUA BRI

C3660 SGCP MGCP IPFAS NAS IUA BRI

C3725 MGCP IPFAS IUA BRI

C3725_OLD MGCP IPFAS IUA BRI

C3745 MGCP IPFAS IUA BRI

C3745_OLD MGCP IPFAS IUA BRI

C2801 MGCP IPFAS IUA BRI

C2811 MGCP IPFAS IUA BRI

C2821 MGCP IPFAS IUA BRI

C2851 MGCP IPFAS IUA BRI

C3825 MGCP IPFAS IUA BRI

C3845 MGCP IPFAS IUA BRI

AS5200 IPFAS NAS

AS5300 SGCP MGCP IPFAS NAS IUA MGCPANNO MGCPIVR

AS5350 SGCP MGCP IPFAS NAS BSMV0 IUA MGCPANNO MGCPIVR

AS5400 SGCP MGCP IPFAS NAS BSMV0 IUA MGCPANNO MGCPIVR

AS5800 IPFAS NAS MGCPANNO

AS5850 IPFAS NAS MGCPANNO MGCP IUA MGCPIVR

AS7200 SGCP MGCP IPFAS NAS

CAT8510 MGCP SGCP

CAT8540 MGCP SGCP

MGC EISUP

MGX8260 MGCP IPFAS NAS

MGX8850 MGCP SGCP IPFAS

VISM MGCP SGCP IPFAS

VXSM MGCP SGCP IPFAS IUA H248 MGCPANNO M3UA IPANNO IPTONE CODEC DTMF UDP SCTP

LS1010 MGCP SGCP

SCP TCAPIP

TALISS7 SS7SG

MC3810 MGCP IPFAS

SLT BSMV0

H323 EISUP

UNKNOWN UNKNOWN

ITP M3UA SUA

LIMD LI

CCMCLUSTER N/A

RACLUSTER RA

C7200 H248 DTMF UDP TCP ETSI_NAPT ITU_IPNAPT EVPND

C7600 H248 DTMF UDP TCP ETSI_NAPT ITU_IPNAPT EVPND

C12000 H248 DTMF UDP TCP ETSI_NAPT ITU_IPNAPT EVPND

ASR1000 H248 DTMF UDP TCP ETSI_NAPT ITU_IPNAPT EVPND

CRS1 H248 DTMF UDP TCP ETSI_NAPT ITU_IPNAPT EVPND