Cisco ICM ソフトウェア WebView インストール ガイド Release 5.0
インストールの要件
インストールの要件
発行日;2012/01/15 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 976KB) | フィードバック

目次

インストールの要件

概要

Cisco ICM WebView ソフトウェアの AW 要件

システム要件

以前のバージョンの Cisco ICM WebView ソフトウェアからのアップグレード

サードパーティ ソフトウェアの要件

サードパーティ ソフトウェアのライセンス

サポートされている言語および文字コード セット

サポートされている Web ブラウザのインストール

ブラウザのキャッシュの更新

Internet Explorer バージョン 5.5 SP2 およびバージョン 6.0

Windows 2000 Service Pack 3 のインストール

WebView サードパーティ CD ソフトウェアのインストール

Jaguar 管理者パスワードの変更

Jaguar ログ ファイルのサイズの設定

Jaguar ログ ファイルの削除

サードパーティ ソフトウェアのアンインストール

インストールの要件

Cisco ICM WebView ソフトウェアをリアルタイム ディストリビュータ アドミン ワークステーションにインストールすると、WebView を企業イントラネットの Web サーバにすることができます。WebView 管理者および WebView スーパーバイザは、各自のコンピュータ上のブラウザから、この Web サーバ上の WebView にログインできます。

Cisco ICM WebView ソフトウェアの AW 要件

この項では、Cisco ICM WebView ソフトウェアに必要なハードウェアおよびソフトウェアをまとめて示します。


Cisco ICM WebView ソフトウェア製品をインストールするには、リアルタイム ディストリビュータ アドミン ワークステーションが置かれているドメインと同じ Cisco ICM ソフトウェア ドメインにおいて、管理者である必要があります。


システム要件

アドミン ワークステーションが次の条件を満たしていることを確認します。

クライアント(非ディストリビュータ)アドミン ワークステーションではなく、リアルタイム ディストリビュータ アドミン ワークステーションである。この確認方法の詳細は、『Cisco ICM Software Installation Guide』を参照してください。

Windows 2000 Service Pack 3 が実行されている。

128 MB の RAM およびサードパーティ ソフトウェアのアプリケーション用として、次の容量のディスク領域がある。

Sun JDK 1.3.1:35 MB

New Atlanta ServletExec ISAPI 4.1.1 patch 15:5 MB

Sybase EAServer 4.1.1(最終ディスク サイズ):450 MB

ドライブごとに、インストールするソフトウェア用に十分な領域があることを確認します。インストーラ ソフトウェアでは、実行時に約 10 MB の RAM および 1 MB のハード ディスク領域が使用されます。


) インストールの途中でドライブの空き領域がなくなった場合、EAServer は停止します。この場合は、Windows NT のタスク マネージャを使用してインストール処理を終了し、空き領域があるドライブ上でインストールを再度開始する必要があります。


300 MB 以上の空き領域があるフォルダが TEMP 環境変数として設定されている。この領域は EAServer のインストールに必要です。


ユーザ用の新規レポート テンプレートを(WebView プログラムで提供されているレポート テンプレートに加えて)作成する場合は、Cisco ICM ソフトウェアの Custom Screen Builder プログラムのバージョン 5.0 もインストールする必要があります。Custom Screen Builder プログラムを使用するには、Sybase の InfoMaker プログラム バージョン 8.0 が必要となります。


使用しているアドミン ワークステーションがこれらの要件を満たしているかどうかを確認する場合は、Cisco ICM ソフトウェア担当者にお問い合せください。

以前のバージョンの Cisco ICM WebView ソフトウェアからのアップグレード

インストール済みの Cisco ICM WebView ソフトウェアを ICM 4.6.2 以前のバージョンからアップグレードする場合は、その古いバージョンの WebView で使用されている ChartFX アプリケーションをアンインストールします。

ユーザ用の新規レポート テンプレートを(WebView プログラムで提供されているレポート テンプレートに加えて)作成する場合は、Cisco ICM ソフトウェアの Custom Screen Builder プログラムのバージョン 5.0 をインストールする必要があります。Custom Screen Builder プログラムをアップグレードする場合は、WebView をインストールする前に、Sybase の InfoMaker プログラム バージョン 8.0 をインストールする必要があります。

WebView 4.6.2 と WebView 5.0 の相違点

WebView 4.6.2 と WebView 5.0 にはいくつかの大きな相違点があり、既存の保存済みレポート ファイルに影響があります。最初の大きな相違点は、提供されているテンプレートに関するもので、第 2 の相違点は、保存済みレポート ファイルの保管に関するものです。

WebView 5.0 では、新しいテンプレートが追加されており、いくつかの既存のテンプレートが削除されています。削除されたテンプレートは、同じレポート カテゴリのテンプレートに置き換えられているか、別のレポート カテゴリのテンプレートに置き換えられているか、または代わりのテンプレートが用意されていないかのいずれかです。

詳細は、 付録 A 「以前のバージョンの ICM WebView からのアップグレード」 を参照してください。

WebView 4.6.2 では、保存済みレポートは WebView サーバ上のディレクトリに保管されていました。WebView 5.0 では、保存済みレポートは WebView データベースに保管されます。WebView のインストール中に、ほとんどの保存済みレポート ファイルはこの WebView データベースに移行されますが、次の 2 つの例外があります。

削除されて、別のレポート カテゴリのテンプレートに置き換えられたテンプレートを使用して作成された保存済みレポートは、データベースに移行されない。

削除されたが、代わりのテンプレートが用意されなかったテンプレートを使用して作成された保存済みレポートは、データベースに移行されない。

WebView でアクセスして使用できるのは、データベースに保管されている保存済みレポートだけです。

サードパーティ ソフトウェアの要件

Cisco ICM WebView ソフトウェアを使用可能にする前に、 表 2-1 に示すすべてのソフトウェアをすぐにインストールできるように用意しておいてください。

 

表 2-1 サードパーティ ソフトウェアの要件

サードパーティ ソフトウェア
ソース

Microsoft Windows 2000 Service Pack 3

Microsoft の CD、または Web ページ( http://www.microsoft.com/windows2000/downloads/servicepacks )からインストールします。

Sun JDK Release 1.3.1

Cisco ICM WebView サードパーティ ソフトウェア CD。

New Atlanta ServletExec ISAPI 4.1.1 patch15

Sybase EAServer 4.1.1

EAServer 4.1.1 は、ICM 4.6.2 で使用されていた Sybase Jaguar 3.6.1 のアップグレードです。

New Atlanta ServletExec ISAPI 4.1.1 patch 15 のライセンス

シスコでは、New Atlanta ServletExec ISAPI 4.1.1 patch 15 の 1 および 2-CPU ライセンスを配布しています。これらは、WebView をインストールするときに自動的にインストールされます。

ただし、WebView をインストールするサーバが 4 つ以上のプロセッサを搭載している場合は、4-CPU ライセンスまたはそれ以上を New Atlanta から入手する必要があります。

WebView のレポートを表示するためのブラウザ

サポートされているブラウザ:MicrosoftÆ Internet Explorer バージョン 5.5 SP2 およびバージョン 6.0

http://www.microsoft.com/windows/ie

Sybase InfoMaker 8.0(カスタム レポートを作成する場合)

ICM をインストールする前にインストールする必要があります。InfoMaker 8.0 をインストールした後、ICM セットアップを実行し、AW セットアップで Custom Screen Builder のオプションを選択します。詳細は、『Cisco ICM Software Installation Guide』を参照してください。

Sybase Inc.

WebView サーバとして使用するコンピュータには上記のソフトウェアがすべて必要ですが、WebView クライアントとして使用するコンピュータにはサポートされているブラウザのみ必要です。

サードパーティ ソフトウェアのライセンス

4 プロセッサ以上のサーバへの WebView のインストール

シスコでは、New Atlanta ServletExec ISAPI 4.1 の 1 および 2-CPU ライセンスを配布しています。これらは、WebView をインストールするときに自動的にインストールされます。WebView をインストールするサーバが 4 つ以上のプロセッサを搭載している場合は、4-CPU ライセンスまたはそれ以上を New Atlanta から入手する必要があります。

4-CPU 以上の New Atlanta ライセンスをインストールする方法


ステップ 1 WebView のサードパーティ ソフトウェアをインストールします。 WebView サードパーティ CD ソフトウェアのインストール を参照してください。WebView をインストールします。 第 3 章「Cisco ICM WebView ソフトウェアのインストールおよびユーザの設定」 を参照してください。

ステップ 2 New Atlanta からライセンスを取得していない場合は取得します。

ステップ 3 ファイル <NewAtlantaRoot>\ServletExec ISAPI\ServletExec Data\servers.properties を開きます。<NewAtlantaRoot> は New Atlanta がインストールされているディレクトリです(例:C:\Program Files\New Atlanta)。

ステップ 4 servletexec.serial=<old_license> の行(<old_license> は古いライセンス番号)を、servletexec.serial=<new_license> に変更します(<new_license> は新規のライセンス番号)。例: 1678290

ステップ 5 ファイルを元のディレクトリにテキスト ファイルとして保存します。

ステップ 6 変更を有効にするために、IIS Admin NT サービスを再起動します。


 

サポートされている言語および文字コード セット

WebView と ICM 5.0 では、英語を使用するコンピュータシステム、西欧で使用されるISO_1 文字コードセットを使用するコンピュータシステム(例:フランス、ドイツ、およびイタリア)、および日本語を使用するコンピュータシステムがサポートされています。

WebView は、ICM 5.0 をインストールしたコンピュータと同じオペレーティング システム文字コード セットを使用しているコンピュータにインストールする必要があります。

ISO_1 および日本語以外の文字コードセットを使用するコンピュータ システムに ICM WebView をインストールすると、WebViewのWebページやエージェント名と説明を含むレポートで、一部の文字が正しく表示されない場合があります。

サポートされている Web ブラウザのインストール

Cisco ICM WebView ソフトウェアのインストールをテストするには、次のいずれかのブラウザをアドミン ワークステーションにインストールする必要があります。

Microsoft Internet Explorer バージョン 6.0

Microsoft Internet Explorer バージョン 5.5 SP2

ブラウザをダウンロードできる Web サイトは、 サードパーティ ソフトウェアの要件 の項を参照してください。インストールするブラウザの Web サイトにあるダウンロードおよびインストールの手順に従ってください。

ブラウザのキャッシュの更新

レポート監視およびスクリプト監視の情報をリアルタイムでブラウザに表示するには、リアルタイムのレポート監視ページまたはスクリプト監視ページを表示するたびに、ブラウザのキャッシュ内にあるそのページのバージョンを、Cisco ICM WebView ソフトウェア アドミン ワークステーションの新しいバージョンと比較して更新するように、該当するブラウザの設定を有効にする必要があります。次に示す情報は、このマニュアルの記述時点では正しい内容ですが、使用しているブラウザのヘルプを参照すると、そのブラウザに適用する正しい手順を確認できます。

Internet Explorer バージョン 5.5 SP2 およびバージョン 6.0

リアルタイム レポートを新たに表示するたびにキャッシュが確実に更新されるように、次の手順に従ってください。

Internet Explorer でキャッシュを確実に更新する方法


ステップ 1 Internet Explorer ウィンドウで、[ツール]メニューの[インターネット オプション]を選択します。

ステップ 2 必要な場合は、[全般]タブをクリックして一般設定のページを表示します。

ステップ 3 一般設定のページの[インターネット一時ファイル]セクションで、[設定]をクリックします。

ステップ 4 [設定]ダイアログ ボックスで、[ページを表示するごとに確認する]オプションをオンにし、[OK]をクリックします。

ステップ 5 [OK]をクリックして、[インターネット オプション]ダイアログ ボックスを閉じます。


 

Windows 2000 Service Pack 3 のインストール

Windows 2000 Service Pack 3 およびインストール手順については、サービス パックに付属している ReadMe ファイルを参照してください。

WebView サードパーティ CD ソフトウェアのインストール

WebView サードパーティ ソフトウェア CD を使用して、次のプログラムをインストールします。

Sun JDK1.3.1 ソフトウェア

New Atlanta ServletExec ISAPI 4.1.1 patch 15

Sybase EAServer 4.1.1.


) EAServer 4.1.1 は Jaguar 3.6.1 ソフトウェアに置き換わります。EAServer 4.1.1 は Jaguar CTS 3.6.1 以上からしかアップグレードできません。

マシンにインストールされている Jaguar CTS のバージョンがこれより古い場合(3.5 など)は、最初にそのバージョンをアンインストールしてから、EAServer 4.1.1 をインストールする必要があります。


サードパーティ ソフトウェアをインストールする方法

サードパーティ CD から、トップ レベルの Setup.exe プログラムを実行します。このプログラムでは、最初にシステムに対してソフトウェア要件に関するいくつかのチェックが実行され、次に、インストールするサードパーティ ソフトウェア オプションおよびそのソフトウェアのインストール先を選択するように求められます。その後、ソフトウェアが自動的にインストールされます。マシンの処理速度およびマシンの使用可能なリソースによって、インストール手順は 30 ~ 40 分かかる場合があります。

インストール手順の概要は、次のとおりです。詳細は、サードパーティ CD に含まれている README.txt を参照してください。


ステップ 1 Jaguar 3.5 ソフトウェアがマシンにすでにインストールされているかどうかを確認します。

Jaguar 3.5 ソフトウェアがマシンにインストールされている場合は、コントロール パネルの[アプリケーションの追加と削除]を使用して、そのソフトウェアを削除します。

ステップ 2 サードパーティ CD に入っているトップ レベルの Setup.exe プログラムを実行します。画面に表示される手順に従ってください。

ステップ 3 セットアップ プログラムには、WebView に必要なサードパーティ ソフトウェアの一覧が表示されます。このダイアログ ボックスでは、システムにまだインストールされていないソフトウェアが自動的に選択され、グレー表示されます。システムにすでにインストールされているソフトウェアは、そのソフトウェア オプションの横にあるチェックボックスをオンにすることで、再インストールできます。

デフォルトでは、システムにすでにインストールされているソフトウェアは、そのバージョン番号が前回のサードパーティ CD のインストール以降変更されていない場合には、セットアップ プログラムによって再インストールされません。ただし、このソフトウェアを再インストールするように選択すると、セットアップ プログラムでは、インストールされている以前のバージョンを最初に削除してから、新しいバージョンがインストールされます。

自動的に選択されたすべてのソフトウェア オプションを確認します。選択されていないオプションを再インストールする場合は、アイコンを選択します。続いて[次へ]をクリックします。

ステップ 4 ファイルのインストール先となる場所を指定するように求められたら、ディレクトリの場所を選択または入力し、[次へ]をクリックします。以前にソフトウェアをインストールした場合、デフォルトのインストール先は以前のインストール先になります。デフォルトを選択することを推奨します。

新規インストール時のデフォルトのインストール先は、次のとおりです。

Sun JDK 1.3.1(35 MB)

C:\jdk1.3.1\

New Atlanta ServletExec ISAPI 4.1.1 patch 15:(5 MB)

C:\Program Files\New Atlanta\ServletExec ISAPI\

Sybase EAServer 4.1.1(450 MB)

C:\Program Files\Sybase\EAServer

セットアップ プログラムによってソフトウェアがインストールされている間、ステータス メッセージが表示されます。


) ある時点で、コンソールのコマンド ライン ウィンドウに次の 3 つの警告が表示されます。
"Server Name not specified.Defaulting to Jaguar.
JDK Version not specified.Defaulting to JDK 1.3.
-jvmtype not specified.Defaulting to client."

これらのメッセージは、セットアップ プログラムでデフォルトが使用されることを意味します。


これらのメッセージは、EAServer のインストールによって生成されるもので、予期されているメッセージです。

ステップ 5 プログラムがインストールされると、[Cisco WebView Third-Party Setup]ダイアログ ボックスが再度表示され、今すぐコンピュータを再起動するか、または後で再起動するかを選択するよう求められます。選択した後、[完了]をクリックします。

コンピュータを再起動した後、サードパーティ ソフトウェアのインストールが完了します。

ステップ 6 Jaguar NT サービスがインストールされ、開始されていることを確認します。

a. [スタート]メニューから、[プログラム]>[管理ツール]>[サービス]を選択します。

b. [サービス]ダイアログ ボックスで、[Jaguar]が一覧に表示されていて[開始]になっていることを確認します。

開始済みになっていない場合は、[Jaguar]を右クリックし、ポップアップ表示される選択ボックスから[開始]オプションを選択します。

インストールされていない場合は、コマンド ライン ウィンドウから次のコマンドを実行します。

"%JAGUAR%\bin\serverstart.bat" -install

次に、上記の手順に従ってサービスを開始します。

ステップ 7 WebView をインストールします。 第 3 章「Cisco ICM WebView ソフトウェアのインストールおよびユーザの設定」 を参照してください。


 

エラー レポート

インストーラは、診断の目的で、インストールの進捗とインストールのエラーを記録したログ ファイルを作成します。ログ ファイルは、C:\Temp ディレクトリに作成されます。ファイル名は WVThirdPartyInstaller.log です。

セットアップ時に発生したエラーはユーザに対して表示され、ログ ファイルに記録されます。ログ ファイルには、現在の統合インストーラのビルド番号、プログラム実行のさまざまな段階、ユーザに対して表示する必要のない重要でないエラー、システム設定など、その他の重要な情報も記録されます。ログ ファイル内の各エントリには、タイム スタンプが記録されます。

Jaguar 管理者パスワードの変更

Jaguar をインストールした後、セキュリティのために、デフォルトの Jaguar 管理者パスワードを変更する場合があります。ただし、この変更は必須ではありません。

Jaguar 管理者パスワードを変更する方法


ステップ 1 [スタート]メニューから、[プログラム]>[Sybase]>[EAServer 4.1.1]>[Jaguar Manager]を選択します。これにより、[Sybase Central Java Edition]ダイアログ ボックスが表示されます。

ステップ 2 [Sybase Central Java Edition]ダイアログ ボックスの[Tools]メニューから、[Connect]>[Jaguar Manager]を選択します。これにより、[Login]ダイアログ ボックスが表示されます。

ステップ 3 [Login]ダイアログ ボックスで、[Connect]をクリックします。ユーザ名フィールドが空であるというメッセージが表示された場合は、次のようにします。

a. [User Name]テキスト ボックスに jagadmin と入力します。

b. [Host Name]テキスト ボックスに <マシン名> を入力します。


) 以前のバージョンの Jaguar では、「localhost」を入力する必要がありました。ただし、EAServer 4.1.1 では、マシン名を入力する必要があります。

マシン名を確認するには、デスクトップ上の[マイ コンピュータ]アイコンを右クリックし、ポップアップ メニューから[プロパティ]を選択します。[システムのプロパティ]ダイアログ ボックスの[ネットワーク ID]タブにマシン名が表示されます。


c. [Port Number]テキスト ボックスは、デフォルト(9000)のままにできます。

d. [Connect]をクリックします。

ステップ 4 [Sybase Central Java Edition]ダイアログ ボックスのディレクトリ ツリーから、[Jaguar Manager]>[Servers]>[Jaguar]を選択します。

ステップ 5 メニュー バーから、[File]>[Server Properties]を選択します。

ステップ 6 [Server Properties:Jaguar]ダイアログ ボックスで、[Security]タブを選択します。

ステップ 7 [Administration]ボックスの[Setjagadmin Password]をクリックします。

ステップ 8 [Administrator Password]ダイアログ ボックスで、[New jagadmin Password]テキスト ボックスにパスワードを入力し、[Verify New jagadmin Password]テキスト ボックスに再入力します。

ステップ 9 [OK]をクリックします。[The password has been changed.]メッセージ ボックスで、もう一度[OK]をクリックします。さらにもう一度[OK]をクリックして[Administration]ボックスを閉じます。次に、メニュー バーから[File]>[Exit]を選択し、[Sybase Central Java Edition]ダイアログ ボックスを閉じます。


) この手順を実行すると、パスワードが変更されます。ただし、WebView で新しいパスワードが認識されるためには、この後の手順も実行する必要があります。


ステップ 10 テキスト エディタで、次のファイルを開きます。 %Jaguar%\html\classes\com\cisco\atg\jagconnection.properties%Jaguar% は、Jaguar(EAServer)ファイルのディレクトリ位置を示すシステム変数です。

ステップ 11 このファイルで、JAGCONNECT_JAGUAR_ADMIN_PWD= の後にパスワードを入力します。

jagconnection プロパティ ファイルの例

JAGCONNECT_CORBA_ORB_CLASS=com.sybase.CORBA.ORB
JAGCONNECT_JAGUAR_SERVER=localhost
JAGCONNECT_IIOP_PORT=9000
JAGCONNECT_JAGUAR_ADMIN=jagadmin
JAGCONNECT_JAGUAR_ADMIN_PWD=
JAGCONNECT_JAGUAR_SYS_BEAN=webview/n_icmsysinfo
JAGCONNECT_JAGUAR_DW_BEAN=webview/n_icmdw
 

ステップ 12 jagconnection.properties ファイルを保存します。


 

Jaguar ログ ファイルのサイズの設定

Jaguar ソフトウェアでは、情報を処理しながらログ ファイルに書き込みが行われます。デフォルトのログ ファイル サイズは 5 MB です。サイズを変更する必要がある場合は、次の手順に従います。

Jaguar ログ ファイルのサイズを設定する方法


ステップ 1 [スタート]メニューから、[プログラム]>[Sybase]>[EAServer 4.1.1]>[Jaguar Manager]を選択します。これにより、[Sybase Central Java Edition]ダイアログ ボックスが表示されます。

ステップ 2 [Sybase Central Java Edition]ダイアログ ボックスの[Tools]メニューから、
[Connect]>[Jaguar Manager]を選択します。これにより、[Login]ダイアログ ボックスが表示されます。

ステップ 3 [Login]ダイアログ ボックスで、次の手順を実行します。

a. [User Name]テキスト ボックスに jagadmin と入力します。

b. [Host Name]テキスト ボックスに <your_machine_name> を入力します。

c. [Port Number]テキスト ボックスは、デフォルト(9000)のままにできます。

d. [Connect]をクリックします。

ステップ 4 [Sybase Central Java Edition]ダイアログ ボックスのディレクトリ ツリー ボックスで、[Jaguar Manager]をクリックしてから[Servers]分岐をクリックします。

ステップ 5 ダイアログ ボックスの右側にある[Servers]カラムで[Jaguar]を右クリックし、ポップアップ メニューの[Server Properties]を選択します。

ステップ 6 [Server Properties]ダイアログ ボックスで、[Log /Trace]タブを選択します。

ステップ 7 [Log/ Trace]タブで、次の手順を実行します。

a. [Log File Size in bytes]テキスト ボックスに、ログ ファイルのサイズをバイト数単位で入力します(例:1000000)。デフォルトは 5000000 です。ログ ファイルが設定したサイズに達すると、現在の日時に .log というサフィクスの付いた新しいログ ファイルが作成されます。

b. [Truncate Log on Startup]チェックボックスをオフにします。

次の点に注意してください。

このボックスをオンにすると、Jaguar ログは、Jaguar サービスが開始されるたびに(WebView を再起動するたびに)削除されます。

このボックスをオフにすると、Jaguar ログは、手順 7a で指定したバイト数単位のログ ファイル サイズに達すると、名前が変更されて新しいログ ファイルが作成されます。

c. デフォルトのログ ファイル名は Jaguar.log です。ログ ファイル名は、変更する必要がない限り、デフォルトのままにしておくことができます。

d. [OK]をクリックします。

ステップ 8 [Sybase Central Java Edition]ダイアログ ボックスを閉じます。


 

Jaguar ログ ファイルの削除

ログ ファイルのサイズを設定すると、データが選択したサイズを超えるたびに、Jaguar によって新しいログ ファイルが作成されます。これにより、ログ ファイル数が増加することがあります。必要以上にシステムの領域を使用しないように、ときどき古いログ ファイルを削除する必要があります。

Jaguar ログ ファイルを削除する方法


ステップ 1 ログ ファイルが保存されている Jaguar のルート ディレクトリに移動します。このディレクトリのデフォルトの位置は、次のとおりです。

%JAGUAR%\bin

%JAGUAR% は、Windows で定義された環境変数です。

ステップ 2 日付の古いログ ファイルを選択して削除します。


 

サードパーティ ソフトウェアのアンインストール

Windows NT のコントロール パネルにある[アプリケーションの追加と削除]を使用すると、サードパーティ ソフトウェアをアンインストールできます。


) サードパーティ ソフトウェア ファイルを削除してから再インストールした場合は、WebView 使用時の問題を防ぐために、ICM セットアップ プログラムを[Upgrade All]モードで実行する必要があります。詳細は、付録 B 「トラブルシューティングのヒント」を参照してください。