Cisco AS5350XM / AS5400XM ユニバーサル ゲートウェイ ソフトウェア コンフィギュレーション ガイド
CLI を使用して行う基本設定
CLI を使用して行う基本設定
発行日;2012/01/15 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

CLI を使用して行う基本設定

ホスト名、パスワード、タイム スタンプの設定

設定手順

設定の確認

ローカル AAA セキュリティの設定

ログイン バナーの作成

ループバック インターフェイス、ギガビット イーサネット インターフェイス、および IP ルートの設定

非同期グループ インターフェイスの設定

設定手順

設定の確認

T1 および E1 フィーチャ カードの設定手順

コントローラの番号付け

設定手順

設定の確認

チャネライズド T3 フィーチャ カードの設定

コントローラの番号付け

設定手順

設定の確認

ISDN PRI の設定

Telco サービス プロバイダーへの PRI 回線およびスイッチ コンフィギュレーションの発注

コントローラの番号付け

設定手順

設定の確認

DS0 トランク グループ ダイヤル アウトの設定

TGRM

設定手順

PRI トランクの設定

設定の確認

ISDN シグナリングの D チャネルの設定

設定手順

設定の確認

ユニバーサル ポート カードおよびダイヤル専用フィーチャ カードの設定

SPE ファームウェア

設定手順

国別コードのデフォルト値へのリセット

設定の確認

VFC の設定

設定手順

設定の確認

クロックの設定

トランク フィーチャ カード ポート

外部クロック

フリーラン クロック

設定例

設定の確認

IP 基本設定のイネーブル化

非同期シェル接続のテスト

最終的な実行コンフィギュレーションの確認

変更したコンフィギュレーションの保存

設定手順

次の作業

CLI を使用して行う基本設定

この章の内容は、Cisco AS5350XM および Cisco AS5400XM ユニバーサル ゲートウェイ向けのものです。基本的なセットアップを確認したあと、データ コール処理に対応できるシステムを準備するための基本的な設定作業を開始できます。

この章では、Cisco IOS ソフトウェアの CLI(コマンドライン インターフェイス)を使用して、Cisco AS5350XM または Cisco AS5400XM ユニバーサル ゲートウェイが稼働するように設定する手順について説明します。説明する作業は次のとおりです。

「ホスト名、パスワード、タイム スタンプの設定」

「ローカル AAA セキュリティの設定」

「ログイン バナーの作成」

「ループバック インターフェイス、ギガビット イーサネット インターフェイス、および IP ルートの設定」

「非同期グループ インターフェイスの設定」

「T1 および E1 フィーチャ カードの設定手順」

「チャネライズド T3 フィーチャ カードの設定」

「ISDN PRI の設定」

「DS0 トランク グループ ダイヤル アウトの設定」

「ISDN シグナリングの D チャネルの設定」

「ユニバーサル ポート カードおよびダイヤル専用フィーチャ カードの設定」

「VFC の設定」

「クロックの設定」

「IP 基本設定のイネーブル化」

「非同期シェル接続のテスト」

「最終的な実行コンフィギュレーションの確認」

「変更したコンフィギュレーションの保存」

「次の作業」


ヒント Cisco IOS ソフトウェアの使用経験がある場合は、「次の作業」に記載されている設定関連の資料が参考になります。


ホスト名、パスワード、タイム スタンプの設定

最初に必要な設定作業は、Cisco AS5350XM または Cisco AS5400XM にホスト名を割り当て、暗号化パスワードを設定し、タイム スタンプをオンにすることです。この作業が必要な理由は、次のとおりです。

ホスト名を割り当てることにより、さまざまなネットワーク装置を識別できます。

コンフィギュレーション ファイルに暗号化パスワードを設定することにより、ゲートウェイ上のセキュリティが強化されます。

タイム スタンプは、接続をテストする目的でデバッグ出力を追跡するときに役立ちます。イベントがいつ発生したのかを正確に把握しなければ、バックグラウンド プロセスを検証できません。

設定手順

 

コマンド
目的

ステップ 1

Router> enable
Password: password
Router#

イネーブル モード(イネーブル EXEC モードとも呼ばれる)を開始します。パスワードを入力します。イネーブル モードが開始されると、プロンプトが Router# に変わります。

ステップ 2

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#

グローバル コンフィギュレーション モードを開始します。グローバル コンフィギュレーション モードが開始されると、プロンプトが Router(config)# に変わります。

ステップ 3

Router(config)# hostname AS5400
AS5400(config)#

ゲートウェイの名前を変更します。 AS5400 の代わりに使用するホスト名を入力します。

ステップ 4

AS5400(config)# enable secret guessme

イネーブル シークレット パスワードを入力します。このパスワードを使用してイネーブル EXEC モードを開始します。コンフィギュレーション モードにアクセスするには、EXEC プロンプト( AS5350> または AS5400> )で enable コマンドとともに、イネーブル シークレット パスワードを入力する必要があります。 guessme の代わりにイネーブル シークレット パスワードを入力してください。

ステップ 5

AS5400(config)# service password-encryption

パスワードの暗号化を適用します。

パスワードの暗号化がイネーブルの場合、 show configuration コマンド を入力すると、暗号化されたパスワードが表示されます。


) 暗号化パスワードは失われると回復できません。


ステップ 6

AS5400(config)# service timestamps debug datetime msec

タイム スタンプ デバッグ メッセージを開始し、日時スタンプにミリ秒単位を含めます。

ステップ 7

AS5400(config)# service timestamps log datetime msec

タイム スタンプ ロギング メッセージを開始し、日時スタンプにミリ秒単位を含めます。

ステップ 8

AS5400(config)# line con 0

ライン コンフィギュレーション モードを開始し、コンソール ポートを設定します。コンフィギュレーション モードが開始されると、プロンプトが AS5350(config-line)# または AS5400(config-line)# に変わります。

ステップ 9

AS5400(config-line)# exec-timeout 0 0

一定時間コンソール画面に入力がなくても、ゲートウェイの EXEC 機能がタイムアウトしないようにします。

ステップ 10

AS5400(config-line)# exit
AS5400(config)#

グローバル コンフィギュレーション モードを終了します。


enable password コマンドは廃止されました。使用しないでください。


設定の確認

有効なホスト名とパスワードが設定されているかどうかを確認するには、次のコマンドを使用します。

show configuration コマンドを入力します。

AS5400(config)# show configuration
Using 1888 out of 512000 bytes
!
version XX.X
.
.
!
hostname AS5400
!
enable secret 5 $1$60L4$X2JYOwoDc0.kqa1loO/w8/
.
 

コマンド出力の上部に表示されるホスト名および暗号化パスワードを確認します。

グローバル コンフィギュレーション モードを終了し、新しいイネーブル シークレット パスワードを使用してログインします。 show privilege コマンドを使用すると、現在のセキュリティ権限レベルが表示されます。

AS5400# exit
 
AS5400 con0 is now available
Press RETURN to get started.
AS5400> enable
Password:
AS5400# show privilege
Current privilege level is 15
AS5400#

ローカル AAA セキュリティの設定

ローカル ユーザ名データベースを使用してログイン認証を実行するように、Authentication, Authorization, Accounting(AAA; 認証、許可、アカウンティング)を設定します。 login キーワードにより、EXEC シェル ユーザが認証されます。さらに、 login キーワードによってセッションがまだ認証されていない場合は、ローカル データベースを使用するように PPP(ポイントツーポイント プロトコル)認証を設定します。

AAA(トリプル A)は、シスコ製のあらゆる装置で使用される Cisco IOS セキュリティ モデルです。AAA は、Cisco AS5350XM または Cisco AS5400XM ユニバーサル ゲートウェイ上でアクセス制御を設定するためのメイン フレームワークになります。

すべてのインターフェイスに同じ認証方式を使用します。ゲートウェイ上で設定されたローカル データベースを使用するものとして、AAA を設定します。このローカル データベースは、 username コンフィギュレーション コマンドを使用して作成します。


ステップ 1 グローバル コンフィギュレーション モードでローカル ログイン ユーザ名データベースを作成します。この例では、管理者のユーザ名は admin です。リモート クライアントのログイン ユーザ名は Harry です。

AS5400(config)# username admin password adminpasshere
AS5400(config)# username Harry password Harrypasshere

注意 この手順により、ゲートウェイからロックアウトされることがなくなります。万一、ロックアウトされた場合は、装置を再起動し、パスワードを回復しなければなりません。

ステップ 2 グローバル コンフィギュレーション モードでローカル AAA セキュリティを設定します。他の 2 つの認証コマンドを入力する前に、 aaa new-model コマンドを入力することが 必要 です。

AS5400(config)# aaa new-model
AS5400(config)# aaa authentication login default local
AS5400(config)# aaa authentication ppp default if-needed local
 

表3-1 で、この設定例について説明します。

 

表3-1 ローカル AAA コマンド

コマンド
目的
AS5400(config)# aaa new-model

AAA アクセス制御システムを開始します。このコマンドにより、ログインおよび PPP 認証がただちに禁止されます。

AS5400(config)# aaa authentication login default local

ローカル ユーザ名データベースを使用してログイン認証を実行するように、AAA を設定します。 login キーワードにより、EXEC シェル ユーザが認証されます。

AS5400(config)# aaa authentication ppp default if-needed local

login キーワードによってセッションがまだ認証されていない場合は、ローカル データベースを使用するように PPP 認証を設定します。

ステップ 3 自分のユーザ名およびパスワードを使用してログインします。

AS5400# login
 
User Access Verification
 
Username: admin
Password:
 
AS5400#
 

正常にログインできた場合は、ローカル ユーザ名が TTY または VTY 回線で有効であることを意味します。ログインできるまでは、セッションを切断しないでください。


 


) ダイヤルベース環境およびルータ環境に Cisco AAA ベースのセキュリティ環境を導入する詳細については、『Cisco AAA Implementation Case Study
http://www.cisco.com/univercd/cc/td/doc/cisintwk/intsolns/aaaisg/index.htm)を参照してください。


ログイン バナーの作成

バナーは、接続している装置(またはコンソール サーバの場合は接続で経由している装置)を示します。


ステップ 1 バナーを作成します。

AS5400(config)# banner login |
Enter TEXT message. End with the character '|'.
This is a secured device.
Unauthorized use is prohibited by law.
|
AS5400(config)# ^Z
AS5400#
 

ステップ 2 バナーをテストします。

AS5400# login
 
This is a secured device.
Unauthorized use is prohibited by law.
 
User Access Verification
 
Username: admin
Password:
 
AS5400#
 


 

ループバック インターフェイス、ギガビット イーサネット インターフェイス、および IP ルートの設定

基本的なダイヤル アクセス サービスを動作させるには、次の作業が必要です。

ループバック インターフェイスを 2 つ作成します。

ギガビット イーサネット インターフェイスをアクティブにします。

デフォルト ゲートウェイに IP ルートを追加します。


ステップ 1 次の例のように IP アドレスを割り当て、デフォルト ゲートウェイに IP ルートを設定します。

AS5400(config)# interface loopback 0
AS5400(config-if)# ip address 172.22.99.1 255.255.255.255
AS5400(config-if)# exit
AS5400(config)# interface loopback 1
AS5400(config-if)# ip address 172.22.90.1 255.255.255.0
AS5400(config-if)# exit
AS5400(config)# interface GigabitEthernet 0/0
AS5400(config-if)# ip address 172.28.186.55 255.255.255.240
AS5400(config-if)# no shutdown
AS5400(config-if)# exit
AS5400(config)# ip route 0.0.0.0 0.0.0.0 172.28.186.49
 

この例では

インターフェイス ループバック 0 ― 他と重複しない安定した IP アドレスを使用してユニバーサル ゲートウェイを識別します。共通アドレス ブロックに含まれる一意の IP アドレスを 1 つ、IP ネットワーク内の各デバイスに割り当てます。この方法により、Network Operation Center(NOC; ネットワーク オペレーション センター)でセキュリティ フィルタリングを実行しやすくなります。デバイス識別に使用する 1 つのクラス C サブネットで、一意のループバック アドレスを与えられた各デバイスを 254 までサポートできます。

インターフェイス ループバック 1 ― リモート ノードに IP アドレス プールを提供します。この方法では、254 のルートではなく 1 つのルートにまとめた形でバックボーンに伝達されます。ローカル アドレス プールに割り当てるアドレス範囲の中から、ループバック 1 用の IP アドレスを選択します。

ステップ 2 ギガビット イーサネット インターフェイスがアップであることを確認します。これを確認するには、デフォルト ゲートウェイで ping を実行します。

AS5400# ping 172.28.186.49
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.28.186.49, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/4 ms
 

この手順により、サブネット上の他のデバイスと IP 接続できるかどうかを確認できます。デフォルト ゲートウェイに対する ping を正常に実行できた場合は、バックボーンの DNS サーバに ping を実行してみます。バックボーン ルータがゲートウェイに到達するように設定しておく必要があります。設定しないと、ping がエラーになります。使用しているネットワークまでのルートをサポートするように、バックボーン ルータを設定してください。


 


) 外部デバイスに初めて ping を実行した場合、標準的な ping 成功率は 80% です。Cisco AS5350XM および Cisco AS5400XM ユニバーサル ゲートウェイには、外部デバイスに対応する Address Resolution Protocol(ARP; アドレス解決プロトコル)エントリがありません。次回、そのデバイスに ping を実行したときには、100% の成功率になります。


非同期グループ インターフェイスの設定

非同期グループ インターフェイスを使用すると、管理者は管理された 1 つのコピーからクローンを作成することによって、多数の非同期インターフェイスを容易に設定できます。この場合、個々の非同期インターフェイスのコンフィギュレーションを最低 1 つの非同期グループ インターフェイスに置き換えることができるので、コンフィギュレーションの行数も圧縮できます。非同期グループ インターフェイスに非同期インターフェイスを割り当てるには、ひとまとめにする非同期回線の数を調べます。この数は、実行コンフィギュレーションからわかります。

「初期実行コンフィギュレーションの確認」では、非同期回線に 0 ~ 107 の番号が与えられています。

設定手順

 

コマンド
目的

ステップ 1

AS5400> enable
Password: password
AS5400#

enable コマンドを入力します。パスワードを入力します。イネーブル EXEC モードが開始されると、プロンプトが AS5350# または AS5400# に変わります。

ステップ 2

AS5400# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
AS5400(config)#

グローバル コンフィギュレーション モードを開始します。グローバル コンフィギュレーション モードが開始されると、プロンプトが AS5350(config)# または AS5400(config)# に変わります。

ステップ 3

AS5400(config)# interface group-async 1
AS5400(config-if)#

インターフェイス コンフィギュレーション モードを開始し、すべての非同期インターフェイスを 1 つのグループに入れ、すべてのインターフェイスに同じパラメータを一度に設定できるようにします。

ステップ 4

AS5400(config-if)# group-range slot/port slot/port
Building configuration...
AS5400(config-if)#

インターフェイスのスロット/ポート グループ範囲を定義します。指定する範囲は、ゲートウェイ上の非同期インターフェイス数によって決まります。ゲートウェイに 108 の非同期インターフェイスがある場合、 group-range 1/1 1/107 を指定できます。

ステップ 5

AS5400(config-if)# Ctrl-Z
AS5400#

イネーブル モードに戻ります。

設定の確認

グループ インターフェイスの設定を確認するには、 show interface async コマンドを入力して、プロトコルがアップかどうかを確認します。

AS5400# show interface async 4/0
 
Async4/00 is down, line protocol is down
modem(slot/port)=4/0, state=IDLE
dsx1(slot/unit/channel)=NONE, status=VDEV_STATUS_UNLOCKED
Hardware is Async Serial
MTU 1500 bytes, BW 115 Kbit, DLY 100000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation SLIP, loopback not set
DTR is pulsed for 5 seconds on reset
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/10/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/32 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 86 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
 

問題がある場合、 show async status コマンドを入力し、エラー、ローカル アドレス、およびリモート アドレスを調べます。

AS5400# show async status
 
Async protocol statistics:
 
Int Local Remote Qd InPack OutPac Inerr Drops MTU
1/00 42.1.1.1 None 0 0 0 0 0 1500
1/01 192.168.10.100 None 0 0 0 0 0 1500
1/02 192.168.10.100 None 0 0 0 0 0 1500
1/03 192.168.10.100 None 0 0 0 0 0 1500
1/04 192.168.10.100 None 0 0 0 0 0 1500
1/05 192.168.10.100 None 0 0 0 0 0 1500
4/52 192.168.10.100 None 0 0 0 0 0 1500
.
.
.
*6/00 192.168.10.100 34.6.42.1 0 130 50 5 0 1500
*6/01 192.168.10.100 34.6.92.1 0 131 53 5 0 1500
*6/02 192.168.10.100 34.5.92.1 0 130 50 5 0 1500
*6/03 192.168.10.100 34.4.14.1 0 116 40 4 0 1500
.
.
.
*7/102 192.168.10.100 34.1.89.1 0 119 40 4 0 1500
*7/103 192.168.10.100 34.4.34.1 0 118 40 4 0 1500
*7/104 192.168.10.100 34.1.67.1 0 105 40 4 0 1500
7/105 192.168.10.100 None 0 0 0 0 0 1500
*7/106 192.168.10.100 34.4.90.1 0 119 40 4 0 1500
*7/107 192.168.10.100 34.1.42.1 0 119 40 4 0 1500
 
Rcvd: 25762 packets, 1052214 bytes
0 format errors, 891 checksum errors, 0 overrun
Sent: 8891 packets, 222264 bytes, 0 dropped

T1 および E1 フィーチャ カードの設定手順

Cisco AS5350XM または Cisco AS5400XM ユニバーサル ゲートウェイでは、チャネライズド T1 および E1 回線に次の方法で、使用可能なチャネルを割り当てることができます。

全チャネルが ISDN PRI(1 次群速度インターフェイス)をサポートするように設定します。

ISDN PRI が稼働していない場合、全チャネルが損失ビット シグナリング(別名Channel Associated Signaling[CAS; 個別線信号方式])をサポートするように設定します。

全チャネルを 1 つのチャネル グループとして設定します。

ISDN PRI をサポートするチャネル、チャネル グルーピングをサポートするチャネル、および CAS をサポートするチャネルを組み合わせることができます。

1 本の T1 回線上で、ISDN PRI をサポートするチャネル、チャネル グルーピングをサポートするチャネル、および損失ビット シグナリングをサポートするチャネルを組み合わせることができます。たとえば、同じチャネライズド T1 回線上で、 pri-group timeslots 1-10,24 コマンド、 channel-group 11 timeslots 11-16 コマンド、および ds0-group 17 timeslots 17-23 type e&m-fgb コマンドを設定できます。接続の両端でタイムスロットの範囲を正しく調整しなければならないため、このようなコンフィギュレーションはほとんどありません。


) 専用回線またはダイヤルを使用しない場合の設定情報については、使用するソフトウェア リリースに対応する『Cisco IOS Configuration Fundamentals Configuration Guide』を参照してください。



) 1 台の Cisco AS5350XM または Cisco AS5400XM シャーシに搭載できるのは、T1 フィーチャ カードが 2 つまで、E1 フィーチャ カードが 2 つまで、またはチャネライズド T3(CT3)フィーチャ カードが 1 つです。


コントローラの番号付け

T1 および E1 コントローラの番号付け規約は、CLI コマンドの slot/port と同じです。フィーチャ カード スロットの番号付けは、マザーボードから始まり、左から右へと数字が大きくなります。スロット 0 はマザーボード専用です。T1 または E1 フィーチャ カード スロットには、1~7が順に番号付けされます。ポートには0~7が番号付けされます。

設定手順

 

コマンド
目的

ステップ 1

AS5400> enable
Password: password
AS5400#

イネーブル モードを開始します。パスワードを入力します。イネーブル モードが開始されると、プロンプトが AS5350# または AS5400# に変わります。

ステップ 2

AS5400# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
AS5400(config)#

グローバル コンフィギュレーション モードを開始します。グローバル コンフィギュレーション モードが開始されると、プロンプトが AS5350(config)# または AS5400(config)# に変わります。

ステップ 3

AS5400(config)# controller [ t1 | e1 ] slot/port
AS5400(config-controller)#

コントローラ コンフィギュレーション モードを開始し、コントローラのスロットおよびポートを設定します。スロット値の範囲は 1 ~ 7 です。T1 および E1 の場合、ポート値の範囲は 0 ~ 7 です。

ステップ 4

AS5400(config-controller)# framing esf

Telco フレーミング タイプを入力します。esf または sf です。

ステップ 5

AS5400(config-controller)# linecode b8zs

Telco 回線符号タイプを入力します。ami または b8zs です。

ステップ 6

AS5400(config-controller)# Ctrl-Z
AS5400#

イネーブル モードに戻ります。

設定の確認

コントローラが起動し、アラームが発生していないことを確認するには、 show controller コマンドを入力し、コントローラ タイプ、スロット番号、およびポート番号を指定します。

AS5400# show controller t1 1/7
 
T1 1/7 is up.
No alarms detected.
Framing is ESF, Line Code is B8ZS, Clock Source is Line Primary.
Version info of slot 2: HW: 2, Firmware: 14, NEAT PLD: 13, NR Bus PLD: 19
Data in current interval (476 seconds elapsed):
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
Total Data (last 24 hours)
0 Line Code Violations, 0 Path Code Violations,
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
 

下記を確認してください。

コントローラが起動している

エラーが報告されていない

Time Division Multiplexing(TDM; 時分割多重)サブシステム トラブルシューティング コマンドは、システムが正常に動作しているときには使用しません。代わりに、Cisco IOS コマンドで TDM バックプレーンの現在のステータスおよび設定値を表示し、TDM プログラミング時にデバッグ出力をユーザに表示できるようにします。さらに、TDM パスの動作をテストできるように、一連のテスト コマンドを提供します。TDM コマンドは通常、シスコのテクニカル サポートがデータの連続性に関する問題のトラブルシューティングを行うときに使用します。


) TDM 機能の詳細については、Cisco IOS ソフトウェアのコンフィギュレーション ガイドおよびコマンド リファレンスを参照してください。これらの資料は、Documentation DVD およびインターネット上のシスコのホームページから入手できます。また、印刷資料も発注できます。「マニュアルの入手方法」を参照してください。


問題がある場合

問題が T1 または E1 回線にあるのか、特定のチャネル グループにあるのかを最初に判断します。特定のチャネル グループに問題がある場合は、インターフェイスに原因があると考えられます。T1 または E1 回線に問題がある、または全チャネル グループに問題がある場合は、コントローラに原因があると考えられます(ISDN PRI の設定を参照)。

E1 または T1 コントローラのトラブルシューティングでは、まず、コンフィギュレーションが正しいかどうかを確認してください。フレーミング タイプおよび回線コードは、サービス プロバイダーが指定しているものと一致しなければなりません。次にチャネル グループと PRI グループのコンフィギュレーションを調べ、タイムスロットおよび速度がサービス プロバイダーの指定と同じかどうかを確認します。この時点で、 show controller t1 または show controller e1 コマンドを使用して、T1/E1 エラーの有無を調べます。コマンドを数回使用し、エラー カウンタが増分しているか、または回線ステータスが継続的に変化しているかを判断します。このような場合は、サービス プロバイダーとの共同作業が必要になります。

また、 dial-tdm-clock priority の設定エラーが原因になることもよくあります。デフォルトの設定はフリーラン クロックですが、これが正しく設定されていないと、クロック スリップの問題が起きます(クロックの設定を参照)。

チャネライズド T3 フィーチャ カードの設定

チャネライズド T3(CT3)フィーチャ カードは、データのシリアル転送用に(T3 回線にバンドルされた)28 個の T1 チャネルを提供します。チャネライズド T3 リンクは、C ビット パリティ モードのメンテナンス データ リンク チャネルをサポートするほか、ペイロードおよびネットワーク ループバックにも対応しています。チャネライズド T3 リンク内で多重伝送される T1 は、Extended Super Frame(ESF; 拡張スーパ フレーム)フレーミングによるFacilities Data Link(FDL)をサポートします。

そのほか、T1 チャネルは、「T1 および E1 フィーチャ カードの設定手順」に記載されている方法で割り当てることができます。

コントローラの番号付け

チャネライズド T3 コントローラの番号付け規約は、CLI コマンドの slot/port と同じです。フィーチャ カード スロットの番号付けは、マザーボードから始まり、左から右へと数字が大きくなります。スロット 0 はマザーボード専用です。フィーチャ カード スロットには、1~7が順に番号付けされます。ポート番号値は常に0です。

チャネライズド T3 コントローラの下の T1 コントローラの番号付け規約は、CLI コマンドの slot/port:channel と同じです。ポート番号値の範囲は 1 ~ 28 です。

設定手順

 

コマンド
目的

ステップ 1

AS5400> enable
Password: password
AS5400#

イネーブル モードを開始します。パスワードを入力します。イネーブル モードが開始されると、プロンプトが AS5350# または AS5400# に変わります。

ステップ 2

AS5400# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
AS5400(config)#

グローバル コンフィギュレーション モードを開始します。グローバル コンフィギュレーション モードが開始されると、プロンプトが AS5350(config)# または AS5400(config)# に変わります。

ステップ 3

AS5400(config)# controller t3 1/0
AS5400(config-controller)#

コントローラ コンフィギュレーション モードを開始し、T3 コントローラをスロット 1、ポート 0 に設定します。スロット値の範囲は 1 ~ 7 です。ポート番号は常に 0 です。

ステップ 4

AS5400(config-controller)# framing c-bit

Telco フレーミング タイプを入力します。c-bit または m23 です。

ステップ 5

AS5400(config-controller)# clock source line

回線のクロック ソースを入力します。 internal または line です。

ステップ 6

AS5400(config-controller)# cablelength 450

ケーブル長を入力します。値の範囲は 0 ~ 450 フィートです。

ステップ 7

AS5400(config-controller)# t1 1-28 controller
 
または
 
AS5400(config-controller)# t1 1-10,15-20,23 controller

T1 コントローラを設定します。値の範囲は 1 ~ 28 です。この場合は、28 の T1 チャネルがすべて同時に設定されます。

または

指定された T1 コントローラを除外し、その他のコントローラを設定します。この場合は、T1 コントローラ 11 ~ 14、21、22、および 24 ~ 28 が除外されます。


) この CLI コマンドは、下位互換性しかありません。


ステップ 8

AS5400(config-controller)# Ctrl-Z
AS5400#

イネーブル モードに戻ります。

設定の確認

コントローラが起動し、アラームが発生していないことを確認するには、 show controller コマンドを入力し、コントローラ タイプ、スロット番号、およびポート番号を指定します。

AS5400# show controller t3 1/0
 
T3 1/0 is down.
Applique type is Channelized T3
Transmitter is sending remote alarm.
Receiver has loss of signal.
FEAC code received: No code is being received
Framing is M23, Line Code is B3ZS, Clock Source is Line
Data in current interval (330 seconds elapsed):
0 Line Code Violations, 0 P-bit Coding Violation
0 C-bit Coding Violation, 0 P-bit Err Secs
0 P-bit Severely Err Secs, 0 Severely Err Framing Secs
0 Unavailable Secs, 0 Line Errored Secs
0 C-bit Errored Secs, 0 C-bit Severely Errored Secs
Total Data (last 24 hours)
9944 Line Code Violations, 0 P-bit Coding Violation,
0 C-bit Coding Violation, 0 P-bit Err Secs,
0 P-bit Severely Err Secs, 0 Severely Err Framing Secs,
86400 Unavailable Secs, 0 Line Errored Secs,
0 C-bit Errored Secs, 0 C-bit Severely Errored Secs

ヒント 問題がある場合は、show controller コマンドの出力を調べ、アラームまたは違反が発生していないかどうかを確認してください。さらに、「T1 および E1 フィーチャ カードの設定手順」も参照してください。


ISDN PRI の設定

ISDN PRI インターフェイスは、8 ポートの T1 または E1 フィーチャ カード上、または CT3 フィーチャ カード上で設定できます。ISDN はシグナリングに D チャネル、ユーザ データに B チャネルを使用する帯域外シグナリングを提供します。

チャネライズド T1 ISDN PRI は、23 本の B チャネルと 1 本の D チャネルを提供します。チャネライズド E1 ISDN PRI は、30 本の B チャネルと 1 本の D チャネルを提供します。チャネル 24 は T1 用の D チャネル、チャネル 16 は E1 用の D チャネルです。

このセクションで説明するコマンドの詳細は、お使いのソフトウェア リリースの『 Cisco IOS Dial Technologies Command Reference 』を参照してください。

Telco サービス プロバイダーへの PRI 回線およびスイッチ コンフィギュレーションの発注

シスコ製ルータ上で ISDN PRI を設定する前に、通信サービス プロバイダーに正しく準備された ISDN PRI 回線を発注する必要があります。

このプロセスは、国内および海外どちらの場合にも、プロバイダーによって異なります。ただし、次のような一般的なガイドラインがあります。

発信 B チャネル コールが昇順か降順かを調べます。Cisco IOS ソフトウェアのデフォルトは降順ですが、サービス プロバイダーのスイッチが昇順の発信コールとして設定されている場合は、サービス プロバイダーのスイッチの設定に合わせてルータを設定できます。

呼び出し側回線 ID の送付を依頼します。プロバイダーによっては、これを CLI または Automatic Number Identification(ANI)と呼ぶ場合があります。

ゲートウェイを ISDN バス(その他の ISDN 機器も接続する)に接続する場合は、ポイントツーマルチポイント サービス(サブアドレッシングが必要)と音声データ回線を発注します。

表3-2 に、PRI スイッチに必要なチャネライズド T1 の設定属性の例を示します。

 

表3-2 チャネライズド T1 の設定属性

属性

回線形式

Extended Super Frame(ESF;拡張スーパ フレーム)形式

回線符号化方式

Binary 8-Zero Substitution(B8ZS; バイナリ 8 ゼロ置換)

コール タイプ

23 本の着信チャネルおよび 23 本の発信チャネル

速度

64 kbps

コールバイコール(call-by-call)機能

イネーブル

チャネル

B × 23 + D

トランク選択順序

昇順(1 ~ 23)または降順(23 ~ 1)

B + D グレア

Yield

ディレクトリ番号

サービス プロバイダーが割り当てるディレクトリ番号は 1 つだけ

SPID の必要性

なし

コントローラの番号付け

T1 または E1 コントローラの番号付け規約は、CLI コマンドの slot/port と同じです。フィーチャ カード スロットの番号付けは、マザーボードから始まり、左から右へと数字が大きくなります。スロット 0 はマザーボード専用です。T1 または E1 フィーチャ カード スロットには、1 ~ 7 が順に番号付けされます。ポートには 0 ~ 7 が番号付けされます。

チャネライズド T3 コントローラの番号付け規約は、CLI コマンドの slot/port と同じです。フィーチャ カード スロットの番号付けは、マザーボードから始まり、左から右へと数字が大きくなります。スロット 0 はマザーボード専用です。フィーチャ カード スロットには、1 ~ 7 が順に番号付けされます。ポート番号値は常に 0 です。

チャネライズド T3 コントローラの配下の T1 コントローラの番号付け規約は、CLI コマンドの slot/port:channel と同じです。ポート番号値の範囲は 1 ~ 28 です。

設定手順

 

コマンド
目的

ステップ 1

AS5400> enable
Password: password
AS5400#

イネーブル モードを開始します。パスワードを入力します。イネーブル モードが開始されると、プロンプトが AS5350# または AS5400# に変わります。

ステップ 2

AS5400# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
AS5400(config)#

グローバル コンフィギュレーション モードを開始します。グローバル コンフィギュレーション モードが開始されると、プロンプトが AS5350(config)# または AS5400(config)# に変わります。

ステップ 3

AS5400(config)# isdn switch-type switch-type

PRI に適したサービス プロバイダーのスイッチ タイプを選択します(サポートされるスイッチ タイプ キーワードについては 表3-3 を参照)。

ステップ 4

AS5400(config)# controller t1 1/0
 
 
 
 
 
または
 
AS5400(config)# controller e1 1/0

T1 フィーチャ カードのスロット、ポート番号、およびチャネルを指定します。CT3 フィーチャ カードでは、ポート番号の範囲は 1 28 です。T1 フィーチャ カードでは、ポート番号の範囲は 0 7 です。

または

E1 フィーチャ カードのスロット、ポート番号、およびチャネルを指定します。E1 フィーチャ カードでは、ポート番号の範囲は 0 7 です。


) T1 または E1 コントローラを設定すると、対応する D チャネル シリアル インターフェイスがただちに作成されます。D チャネルの設定方法については、「ISDN シグナリングの D チャネルの設定」を参照してください。


ステップ 5

AS5400(config-controller)# framing esf
 
 
または
 
AS5400(config-controller)# framing crc4

T1 または CT3 フィーチャ カードのフレーミング タイプを入力します。

または

E1 フィーチャ カードのフレーミング タイプを入力します。

ステップ 6

AS5400(config-controller)# linecode b8zs
 
 
または
 
AS5400(config-controller)# linecode hdb3

T1 または CT3 フィーチャ カードの回線符号を B8ZS として定義します。

または

E1 フィーチャ カードの回線符号を High-Density Bipolar 3(HDB3)として定義します。

ステップ 7

AS5400(config-controller)# pri-group [ timeslots range ]1

ISDN PRI を設定します。

タイムスロットを指定しなかった場合、23 本の B チャネルと 1 本の D チャネルでコントローラが設定されます。

ステップ 8

AS5400(config-controller)# Ctrl-Z
AS5400#

イネーブル モードに戻ります。

1.T1 では、タイムスロットの範囲は 1 ~ 24 です。非 PRI チャネル グループ用にその他のタイムスロットが使用されている場合、タイムスロットの範囲を指定できます(たとえば、pri-group timeslots 12-24)。

チャネライズド T1 ISDN PRI ― タイムスロットを省略すると、指定されたコントローラは 23 本の B チャネルおよび 1 本の D チャネルで設定されます。B チャネルの番号範囲は 1 23 です。チャネル 24 は T1 用の D チャネルです。対応するシリアル インターフェイスの番号範囲は 0 23 です。コマンドでは、D チャネルは interface serial slot/port :23 (たとえば、 interface serial 1/0:23 )です。

チャネライズド E1 ISDN PRI ― タイムスロットを省略すると、指定されたコントローラは 30 本の B チャネルおよび 1 本の D チャネルで設定されます。B チャネルの番号範囲は 1 31 です。チャネル 16 は E1 用の D チャネルです。対応するシリアル インターフェイスの番号範囲は 0 ~ 30 です。コマンドでは、D チャネルは interface serial slot/port :15 (たとえば、 interface serial 1/0:15 )です。

 

表3-3 ISDN サービス プロバイダーの PRI スイッチ タイプ

地域
キーワード
スイッチ タイプ

なし

なし

スイッチは定義されていない

オーストラリア

primary-ts014

豪州の PRI スイッチ

欧州

primary-net5

欧州、ニュージーランド、およびアジアの ISDN PRI スイッチ(Euro-ISDN E-DSS1 シグナリング システムおよび ETSI[欧州電気通信標準協会]に準拠)

日本

primary-ntt

日本の ISDN PRI スイッチ

北米

primary-4ess

AT&T 4ESS スイッチ タイプ(米国)

primary-5ess

AT&T 5ESS スイッチ タイプ(米国)

primary-dms100

NT DMS-100 スイッチ タイプ(米国)

primary-ni

National ISDN スイッチ タイプ

設定の確認

インターフェイスが正しく設定されているかどうかを確認するには、次のコマンドを使用します。

show controller t3 コマンドを入力し、スロット番号とポート番号を指定します。コントローラが起動し、エラーが過剰に発生していないことを確認します。エラーが多いと、コントローラが頻繁にダウンする可能性があります。その場合は、スイッチに問題があると考えられます。

AS5400# show controller t3 1/0
 
T3 1/0 is up.
Applique type is Channelized T3
No alarms detected.
MDL transmission is disabled
FEAC code received:No code is being received
Framing is C-BIT Parity, Line Code is B3ZS, Clock Source is Internal
Data in current interval (270 seconds elapsed):
0 Line Code Violations, 0 P-bit Coding Violation
0 C-bit Coding Violation, 0 P-bit Err Secs
0 P-bit Severely Err Secs, 0 Severely Err Framing Secs
0 Unavailable Secs, 0 Line Errored Secs
0 C-bit Errored Secs, 0 C-bit Severely Errored Secs
Total Data (last 32 15 minute intervals):
0 Line Code Violations, 0 P-bit Coding Violation,
0 C-bit Coding Violation, 0 P-bit Err Secs,
0 P-bit Severely Err Secs, 0 Severely Err Framing Secs,
0 Unavailable Secs, 0 Line Errored Secs,
0 C-bit Errored Secs, 0 C-bit Severely Errored Secs
 

show controller t1 コマンドを入力し、スロット番号とポート番号を指定します。

AS5400# show controller t1 1/0
 
T1 1/0 is up.
Applique type is Channelized T1
Cablelength is long gain36 0db
No alarms detected.
alarm-trigger is not set
Version info of slot 1: HW:768, PLD Rev:4
Framer Version:0x8
 
Manufacture Cookie Info:
EEPROM Type 0x0001, EEPROM Version 0x01, Board ID 0x041,
Board Hardware Version 3.0, Item Number 73-4089-03,
Board Revision 05, Serial Number JAB99432626,
PLD/ISP Version 0.1, Manufacture Date 11-Nov-1999.
 
Framing is ESF, Line Code is B8ZS, Clock Source is Line.
Data in current interval (264 seconds elapsed):
3 Line Code Violations, 1 Path Code Violations
5 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 1 Degraded Mins
5 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
.
.
.

show isdn status コマンドを入力し、レイヤ ステータス情報を表示します。

AS5400# show isdn status
 
Global ISDN Switchtype = primary-5ess
ISDN Serial1/0:1:23 interface
dsl 0, interface ISDN Switchtype = primary-5ess
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
Layer 3 Status:
0 Active Layer 3 Call(s)
Activated dsl 0 CCBs = 0
The Free Channel Mask: 0x807FFFFF
.
.
.
ISDN Serial1/0:28:23 interface
dsl 27, interface ISDN Switchtype = primary-5ess
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
Layer 3 Status:
0 Active Layer 3 Call(s)
Activated dsl 27 CCBs = 0
The Free Channel Mask: 0x807FFFFF
Total Allocated ISDN CCBs = 0
 

Serial1/0:1:23(メッセージの前半)について、次の事項を確認してください。

Layer 1 Status は [ACTIVE] である。

Layer 2 Status は [MULTIPLE_FRAME_ESTABLISHED] である(レイヤ 2 ステータスが表示されるまで数秒かかる場合があります)。

Layer 3 Status は [0 Active Layer 3 Call(s)] である。

メッセージの後半には、Serial1/0:28:23 の情報が表示される。

show isdn service コマンドを入力し、ISDN チャネルおよびサービスをモニタします。

AS5400# show isdn service
 
PRI Channel Statistics:
ISDN Se0:23, Channel (1-31)
Activated dsl 0
State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint)
2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 0 0 0 0 3 3 3 3 3 3 3 3
Channel (1-31) Service (0=Inservice 1=Maint 2=Outofservice)
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 2 2 2 2 2 2 2
ISDN Se1:23, Channel (1-31)
Activated dsl 1
State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint)
2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 0 3 3 3 3 3 3 3 3
Channel (1-31) Service (0=Inservice 1=Maint 2=Outofservice)
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 2 2 2 2 2 2 2
ISDN Se2:23, Channel (1-31)
Activated dsl 2
State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint)
2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 0 0 0 0 3 3 3 3 3 3 3 3
Channel (1-31) Service (0=Inservice 1=Maint 2=Outofservice)
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 2 2 2 2 2 2 2
ISDN Se3:23, Channel (1-31)
Activated dsl 3
State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint)
2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 3 3 3 3 3 3 3 3
Channel (1-31) Service (0=Inservice 1=Maint 2=Outofservice)
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 2 2 2 2 2 2 2
ISDN Se4:23, Channel (1-31)
Activated dsl 4
State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint)
2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 3 3 3 3 3 3 3 3
Channel (1-31) Service (0=Inservice 1=Maint 2=Outofservice)
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 2 2 2 2 2 2 2
ISDN Se5:23, Channel (1-31)
Activated dsl 5
State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint)
2 2 2 2 2 2 2 2 2 2 2 2 0 0 0 0 0 0 0 0 0 0 0 3 3 3 3 3 3 3 3
Channel (1-31) Service (0=Inservice 1=Maint 2=Outofservice)
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 2 2 2 2 2 2 2
ISDN Se6:23, Channel (1-31)
Activated dsl 6
State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint)
2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 0 3 3 3 3 3 3 3 3
Channel (1-31) Service (0=Inservice 1=Maint 2=Outofservice)
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 2 2 2 2 2 2 2
ISDN Se7:23, Channel (1-31)
Activated dsl 7
State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint)
2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 0 3 3 3 3 3 3 3 3
Channel (1-31) Service (0=Inservice 1=Maint 2=Outofservice)
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 2 2 2 2 2 2 2

) Cisco AS5350XM または Cisco AS5400XM ユニバーサル ゲートウェイは、1 つの入力トランク フィーチャ カードで合計 248 の ISDN チャネルをサポートします。チャネライズド T3 カードの個々の T1 チャネルをバックアップ リンク用またはシリアル バックホール接続用に設定する場合は、T1 チャネルをチャネル グループに設定する必要があります。各チャネル グループは 24 のタイムスロットまたはチャネルを使用します。たとえば、6 つの T1 チャネルを設定して(6 × 24 =)144 の ISDN チャネルが使用される場合、残りの(248 - 144 =)104 を ISDN に使用できます。「ISDN PRI の設定」を参照してください。


次の show running-config コマンドの例では、6 つの T1 チャネルがチャネル グループに設定されています。

AS5400# show running-config
 
Building configuration...
 
Current configuration:
!
! Last configuration change at 15:49:30 UTC Mon Apr 3 2000 by admin
! NVRAM config last updated at 01:35:05 UTC Fri Mar 17 2000 by admin
!
version 12.0
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
(テキスト出力は省略)
!
controller T3 1/0
framing m23
clock source line
t1 1-28 controller
!
controller T1 1/0:11
framing esf
channel-group 20 timeslots 1-24 speed 64
!
controller T1 1/0:12
framing esf
channel-group 20 timeslots 1-24 speed 64
!
controller T1 1/0:13
framing esf
channel-group 20 timeslots 1-24 speed 64
!
controller T1 1/0:14
framing esf
channel-group 20 timeslots 1-24 speed 64
!
controller T1 1/0:15
framing esf
channel-group 20 timeslots 1-24 speed 64
!
controller T1 1/0:16
framing esf
channel-group 20 timeslots 1-24 speed 64
 

問題がある場合

Layer 1 Status が [Deactivated] の場合は、ケーブルの接続が緩んでいないか、切断されていないかどうかを確認してください。このステータス メッセージは、物理レイヤに問題があることを意味します。

Telco またはフレーミングに問題があり、入力した回線符号タイプが Telco に合っていないという可能性があります。Layer 2 エラーは、ゲートウェイが Telco と通信できないことを意味します。データ リンク レイヤに問題があります。

DS0 トランク グループ ダイヤル アウトの設定

DS0 トランク グループ ダイヤル アウト機能は、発信コールに使用される個々の DS0 回線をユーザが制御できるようにして、発信コール ルーティング機能を拡張します。この機能が追加される以前は、発信 DS0 回線を DS1 回線とは別に設定することはできませんでした。DS1 回線のダイヤル アウト機能が、その DS1 回線の下にあるすべての DS0 回線に適用されていました。

現在、DS1 回線のトランク グループへのアグリゲーションは、Trunk Group Resource Manager(TGRM)を使用して行うようになっています。DS0 トランク グループ ダイヤル アウト機能により、DS0 回線のトランク グループへのアグリゲーションも TGRM サブシステムによって行われます。これらの DS0 トランク グループのダイヤル アウト機能の設定は、TGRM CLI を使用して直接 DS0 レベルで、Authentication, Authorization, Accounting(AAA;認証、許可、アカウンティング)属性を設定して行うことができます。

発信コールに関して DS0 回線を設定すると、ダイヤル オンデマンド機能により B チャネルの集合を使用してコールを発信することが可能になります。

DS0 ダイヤル アウト トランク グループは、Network Access Server(NAS)上に設定します。これらのグループは、デジタル コールと非同期コールの両方をサポートし、ISDN PRI 回線および Non-Facility Associated Signaling(NFAS)回線を使用するように設定できます。

トランク グループは、同じシグナリング特性を備えた複数の T1 または E1 インターフェイスの論理グループです。1 つのトランク グループに、最大 64 のトランクを含めることができます。各トランク グループはさまざまな DS0 回線で構成できますが、それぞれの DS0 回線は 1 つのトランク グループにしか所属できません。


) DS0 ダイヤル アウト トランク グループは、現時点ではダイヤル アウト用にのみプロビジョニング可能であり、ダイヤル ピアのターゲットとしてプロビジョニングすることはできません。



) DS0 ダイヤル アウト トランク グループは、音声インターフェイスをサポートしていません。


TGRM

Trunk Group Resource Manager(TGRM)を使用すると、1 つまたは複数のインターフェイスの論理グループ化、設定、および一括管理を行うことができます。TGRM を使用して、コンフィギュレーション情報を保管し、要求に応じてトランク グループからインターフェイスを受け入れるか選択します。

トランク グループは、AAA サーバ上でダイヤル ピアのターゲットまたはダイヤル アウト プロファイルとしてプロビジョニングし、着信または発信コールに使用するインターフェイスおよびチャネルは、TGRM によって透過的に選択されます。トランクの選択は、最も使用回数の少ないトランク(デフォルト設定)、または設定されたハント方式に基づいて行われます。

トランク グループを使用すると、ダイヤル ピアおよびインターフェイスの設定作業が簡易化されるだけでなく、アクセス サーバ上で必要に応じてインターフェイスを動的に選択できます。

1 つのトランク グループにインターフェイスを何個でも含めることができますが、1 つのトランク グループのすべてのインターフェイスが、同じタイプのシグナリングを使用する必要があります。

TGRM サブシステムが機能拡張され、トランク グループにフラクショナル トランクを追加できます。フラクショナル トランクは、特定のトランクの 1 つの DS0 回線または DS0 回線グループです。

設定手順

trunk-group コマンドを使用して、トランク グループの label パラメータを指定し、オプションで preference パラメータを設定することにより、トランク グループにトランクを割り当てます。

DS0 ダイヤル アウト トランク グループ機能に、次の 2 つの新しいオプション キーワードが追加されています。

timeslots list of timeslots

preference preference

timeslots キーワードを使用すると、特定のシグナリング チャネルから DS0 回線を選択的に追加できます。フラクショナル トランク グループの設定は、コントローラ コンフィギュレーション モードでのみ行います(1 つの PRI シリアル インターフェイスが、NFAS など複数のメンバー インターフェイスを表す場合があるので)。 timeslots オプションを指定しない場合、シグナリング チャネルのすべての DS0 がトランク グループに割り当てられます。

preference キーワードは、 timeslots オプションの後ろに指定します。このキーワードは timeslots オプションを使用した場合にのみ有効です。これにより、 list of timeslots 値と preference 値を差別化できます。

次に、 timeslots キーワードと preference キーワードを使用して、特定の DS0 回線を設定する構文の例を示します。

trunk-group label timeslot list of timeslots preference preference

次に、シグナリング チャネルのすべての DS0 回線を設定する構文の例を示します。

trunk-group label preference

構文パラメータの説明

 

label

トランク グループのラベル。長さは最大で 127 文字(英数字)です。

list of timeslots

シグナリング チャネルからトランク グループに追加するインターフェイスのリスト。範囲は 1 ~ 64 です。

preference

トランク グループにおけるトランク グループ メンバーのプライオリティ。範囲は 1(最高のプライオリティ)~ 64(最低のプライオリティ)です。preference 変数を使用して、トランクのリストを特定の順序にソートできます。preference 変数を指定しないトランクには、最高の優先順位が与えられます。

次に、PRI シグナリングを設定する例を示します。コントローラ T1 3 が、PRI を設定するトランクです。

PRI トランクの設定


ステップ 1 フレーミング、クロック ソース、DS0 グループなどを設定します。

AS5400(config)# controller T1 3
AS5400(config-controller)# framing esf
AS5400(config-controller)# clock source line secondary 3
AS5400(config-controller)# linecode b8zs
AS5400(config-controller)# pri-group timeslots 1-24
AS5400(config-controller)# !
 

ステップ 2 トランク グループ ラベルを設定します。

AS5400(config)# interface Serial3:23
AS5400(config-if)# no ip address
AS5400(config-if)# trunk-group PRI-TRUNK-GROUP

) シリアル インターフェイスが NFAS シリアル インターフェイスを表す場合があるので、timeslotsオプションは、シリアル インターフェイス コンフィギュレーション モードでは使用できません


ステップ 3 タイムスロットと優先順位を設定します。

AS5400(config)# controller T1 3
AS5400(config-controller)# framing esf
AS5400(config-controller)# clock source line secondary 3
AS5400(config-controller)# linecode b8zs
AS5400(config-controller)# pri-group timeslots 1-24
AS5400(config-controller)# trunk-group PRI-TRUNK-GROUP-1 timeslots 1-10
AS5400(config-controller)# trunk-group PRI-TRUNK-GROUP-2 timeslots 11-15
AS5400(config-controller)# trunk-group PRI-TRUNK-GROUP-3 timeslots 20-22 preference 10

) PRI または NFAS トランクの一部分をトランク グループに追加する場合は、timeslots キーワードが必須です。



 

設定の確認

show trunk group コマンドを使用して、特定のトランク グループに所属する DS0 回線を表示します。
さまざまなシグナリング チャネルの DS0 回線をトランク グループにすることができます。

AS5400#show trunk group pri-tg
Trunk group: pri-tg
Description:
trunk group label: pri-tg
 
Translation profile (Incoming):
Translation profile (Outgoing):
 
Hunt Scheme is least-used
Max Calls (Incoming): NOT-SET (Any) NOT-SET (Voice) NOT-SET (Data)
Max Calls (Outgoing): NOT-SET (Any) NOT-SET (Voice) NOT-SET (Data)
Retries: 0
 
Trunk 2/1:23 Preference 10
Channels : 1-23
Total channels available : 23
Data = 0, Voice = 0, Modem = 0, Pending = 0, Free = 23
Total calls for trunk group: Data = 0, Voice = 0, Modem = 0
Pend = 0, Free = 23
 
advertise_flag 0x00000040, capacity timer 25 sec tripl_config_mask 0x00000000
AC_curr 24, FD_curr 0, SD_curr 0
 
succ_curr 0 tot_curr 0
succ_report 0 tot_report 0
changed 0 replacement position 0

ISDN シグナリングの D チャネルの設定

ISDN D チャネルは、回線交換データ コールおよびアナログ モデム コールの両方について、ISDN コールの制御情報およびシグナリング情報を伝送します。

D チャネルは、シスコ製ゲートウェイまたはルータ上の特定のタイムスロットに着信コールを送信するように、セントラル オフィスのスイッチに通知します。B チャネルはそれぞれデータまたは音声を伝送します。D チャネルは、B チャネルに関するシグナリングを伝送します。D チャネルは、コールが回線交換デジタル コールなのか、アナログ モデム コールなのかを識別します。アナログ モデム コールはデコードされてから、オンボード モデムに送られます。回線交換デジタル コールは、ゲートウェイの ISDN プロセッサに直接リレーされます。

T1 または E1 コントローラ上で ISDN PRI を設定すると、PRI グループのタイムスロットに対応するシリアル インターフェイスが自動的に作成されます。このインターフェイスは、特定のコントローラに対応付けられている論理エンティティです。シリアル インターフェイスを作成してから、シグナリングを伝送する D チャネル シリアル インターフェイスを設定する必要があります。この設定は、その PRI グループのすべての PRI B チャネル(タイムスロット)に適用されます。

図3-1に、T1 ネットワーク構成で使用する ISDN PRI インターフェイスの論理コンテンツを示します。論理コンテンツは、B チャネル× 23、D チャネル× 1、タイムスロット× 24、仮想シリアル インターフェイス× 24(B の合計数 + D)が含まれます。

図3-1 ISDN PRI コンポーネントの論理関係(T1 の場合)

 


) NFAS バックアップ D チャネル用に T1 コントローラを設定すると、プライマリ D チャネルに障害が発生したときのみ自動的にシリアル インターフェイスが作成されます。


設定手順

 

コマンド
目的

ステップ 1

AS5400> enable
Password: password
AS5400#

イネーブル モードを開始します。パスワードを入力します。イネーブル モードが開始されると、プロンプトが AS5350# または AS5400# に変わります。

ステップ 2

AS5400# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
AS5400(config)#

グローバル コンフィギュレーション モードを開始します。グローバル コンフィギュレーション モードが開始されると、プロンプトが AS5350(config)# または AS5400(config)# に変わります。

ステップ 3

AS5400(config)# interface serial 1/0:23
AS5400(config-if)#

シリアル インターフェイス コンフィギュレーション モードを開始します。T1 コントローラを設定すると、対応する D チャネル シリアル インターフェイスがただちに作成されます。たとえば、シリアル インターフェイス1/0:23は、T1コントローラのDチャネルです。シリアル インターフェイスが着信シグナリングを受信し、発信シグナリングを送信するように設定する必要があります。


) チャネライズド E1 PRI 回線では、シリアル インターフェイスは 1/0:15 です。


ステップ 4

AS5400(config-if)# ip address 172.16.254.254 255.255.255.0

IP アドレスとサブネット マスクをインターフェイスに割り当てます。

ステップ 5

AS5400(config-if)# isdn incoming-voice modem

すべての着信音声コールを設定します。


) このコマンドで使用できるキーワードは、data および modem の 2 種類です。モデムと音声コールの両方をイネーブルにするには、modem キーワードを使用する必要があります。modem キーワードは、音声のベアラ能力を表します。


ステップ 6

AS5400(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

設定の確認

D チャネルの設定を確認するには、 show interface serial コマンドを入力し、回線プロトコルが起動しているか、正しい IP インターフェイスが使用されているかどうかを確認します。また、多数のエラーが発生していないかどうかを確認します。

AS5400# show interface serial 1/0:23
 
Serial1/0:23 is up, line protocol is up (spoofing)
Hardware is DSX1
Internet address is 172.16.254.254/16
MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
Last input 00:00:03, output never, output hang never
Last clearing of "show interface" counters 00:00:01
Queueing strategy:fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
1 minute input rate 0 bits/sec, 0 packets/sec
1 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
Timeslot(s) Used:24, Transmitter delay is 0 flags
AS5400#
 

問題がある場合

show interface serial コマンドを入力して、シリアル インターフェイスおよびプロトコルが起動しているかどうかを確認します。

IP アドレスをチェックします。

AS5400# show interface serial 1/0:23
 
Serial1/0:23 is up, line protocol is up (spoofing)
Hardware is DSX1
Internet address is 172.16.254.254/16
MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
Last input 00:00:07, output never, output hang never
Last clearing of "show interface" counters 00:00:06
Queueing strategy:fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
1 minute input rate 0 bits/sec, 0 packets/sec
1 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
Timeslot(s) Used:24, Transmitter delay is 0 flags
AS5400#
 

ユニバーサル ポート カードおよびダイヤル専用フィーチャ カードの設定

ユニバーサル ポート カードおよびダイヤル専用フィーチャ カードは、すべてのモデム規格および機能をサポートします。従来のような回線とモデムの 1 対 1 対応ではなく、複数の回線をユニバーサル ポート カードおよびダイヤル専用フィーチャ カードに配置された System Processing Engine(SPE)に対応付けます。対応する SPE ファームウェアは、Modem ISDN Channel Aggregation(MICA)テクノロジー モデムのモデム コードと同様の機能を実行します。


) ダイヤル専用フィーチャ カードはダイヤル サービスだけをサポートします。ダイヤル サービスに含まれるのはモデム コール(すべての変調)、ISDN デジタル コール、V.110 データ コール、および V.120 データ コールで、モデム パススルー コールは含まれません。


1 つの SPE で、6 つのポートにサービスを提供します。ビジーアウトおよびシャットダウンは、SPE レベルまたはポート レベルで設定可能です。

ユニバーサル ポート カード、およびダイヤル専用フィーチャ カードが実行する機能は、次の通りです。

Pulse Code Modulation(PCM; パルス符号変調)ビット ストリームをデジタル パケット データに変換します。

変換およびパケット化したデータをメイン プロセッサに転送します。メイン プロセッサはデータを調べ、バックホール出口インターフェイスに転送します。

すべてのモデム規格(V.34、V.42bisなど)および機能(ダイヤルイン、ダイヤルアウトなど)をサポートします。


) 詳細については、第 5 章「ユニバーサル ポート カードおよびダイヤル専用フィーチャ カードの管理およびトラブルシューティング」を参照してください。

ユニバーサル ポート カードおよびダイヤル専用フィーチャ カードでサポートされる CLI コマンドの詳細については、次の URL の『Monitoring Voice and Fax Services on the Cisco AS5350 and Cisco AS5400 Universal Gateways』を参照してください。
http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080080e60.html


SPE ファームウェア

システムを最初に起動したとき、またはシステムの動作中にユニバーサル ポート カードまたはダイヤル専用フィーチャ カードを挿入したときに、SPE ファームウェアが Cisco AS5350XM または Cisco AS5400XM ユニバーサル ゲートウェイからユニバーサル ポート カードまたはダイヤル専用フィーチャ カードに自動的にダウンロードされます。システムの動作中にフィーチャ カードを挿入すると、Cisco IOS イメージがフィーチャ カードを認識し、必要なファームウェアをフィーチャ カードにダウンロードします。

SPE ファームウェア イメージは、ゲートウェイの Cisco IOS イメージにバンドルされています。SPE ファームウェア イメージは、autodetect メカニズムを使用しているので、ユニバーサル ポート フィーチャ カードは複数のコール タイプを処理できます。SPE はコール タイプを検出し、動作できるよう自動的に自己設定します。このファームウェアは、Cisco IOS アップグレードとは無関係にアップグレードが可能であり、同じフィーチャ カード上の SPE ごとに異なるファームウェア バージョンを設定できます。

ユニバーサル ポート カードおよびダイヤル専用フィーチャ カードは、 表3-4 に示すモデム規格および機能をサポートします。

 

表3-4 モデム規格およびサポート対象の機能

機能
説明

キャリア プロトコル

ITU V.23 @ 75/1,200 bps

Telcordia Technologies 103 @ 300 bps

ITU V.21 @ 300 bps

ITU V.22 @ 1,200 bps

Telcordia 212A @ 1,200 bps

ITU V.22bis @ 2,400 bps

ITU V.32、最大 9,600 bps

ITU V.32bis、最大 14,400 bps

V.32 turbo、最大 19,200 bps

V.FC、最大 28,800 bps

V.34、最大 28,800 bps

V.34+、最大 33,600 bps

TIA/ITU V.90

K56flex

エラー訂正リンク アクセス プロトコル

V.42 LAPM、MNP 2-4

圧縮プロトコル

V.42bis(MNP 5 を含む)

コマンド インターフェイス

AT コマンド セットのスーパーセット

帯域内シグナリングまたはトーン生成
および検出

DTMF 生成

DTMF 検出

MF 生成

MF 検出

その他

管理用の帯域外アクセス

PPP および SLIP フレーミング

設定手順

ユーザがネットワークにダイヤルインできるように、回線およびポートを設定します。

 

コマンド
目的

ステップ 1

AS5400> enable
Password: password
AS5400#

enable コマンドを入力します。パスワードを入力します。イネーブル EXEC モードが開始されると、プロンプトが AS5350# または AS5400# に変わります。

ステップ 2

AS5400# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
AS5400(config)#

グローバル コンフィギュレーション モードを開始します。グローバル コンフィギュレーション モードが開始されると、プロンプトが AS5350(config)# または AS5400(config)# に変わります。

ステップ 3

AS5400(config)# spe country country name

フィーチャ カード パラメータ(国別コードおよびエンコーディングを含む)に対応する国を指定します。この設定はシステム レベルで適用されます。すべてのユニバーサル ポート カードまたはダイヤル専用フィーチャ カードで同じ国別コードが使用されます。ゲートウェイが T1 インターフェイスで設定されている場合、デフォルトは usa です。ゲートウェイが E1 インターフェイスで設定されている場合、デフォルトは e1-default です。国別コードをデフォルト( usa )に設定するには、このコマンドの no 形式を使用します。


) このコマンドを実行するには、全スロットの全ユニバーサル ポート カードまたはダイヤル専用フィーチャ カード上の全セッションがアイドル状態でなければなりません。


ステップ 4

AS5400(config)# line slot/port slot/port
AS5400(config-line)#

設定するポートの数を入力します。スロット 3 の 108 個のポートを設定する場合は、 line 3/00 3/107 と入力します。スロット 3 ~ 5 の 324 個のポートを設定する場合は、 line 3/00 5/107 と入力します。スロットごとに 108 個のポートが設定されます。

ステップ 5

AS5400(config-line)# transport input all

回線接続時に、全プロトコルの使用を許可します。

ステップ 6

AS5400(config-line)# autoselect ppp

PPP アプリケーションを実行しているリモート IP ユーザが、ダイヤルして EXEC 機能をバイパスし、ネットワークに直接接続できるようにします。

ステップ 7

AS5400(config-line)# modem inout

着信および発信コールをイネーブルにします。

ステップ 8

AS5400(config-line)# Ctrl-Z
AS5400#

イネーブル モードに戻ります。

モデムと回線の設定は、ISDN チャネルが動作可能で、POTS 電話コールがモデムに正常にルーティングされるようになってから行います。

各モデムは、ゲートウェイ内部の専用非同期回線に対応付けられます。 modem inout コマンドが回線に適用されると、ゲートウェイはモデム コールを受け付け可能な状態になります。

回線に AAA セキュリティを適用するには、 aaa new-model コマンドおよび aaa authentication login default local コマンドを使用します。AAA は、ローカル ユーザ名データベースを使用して、ログイン認証を実行します。 login キーワードにより、EXEC シェル ユーザが認証されます。AAA コマンドの詳細については、「ローカル AAA セキュリティの設定」を参照してください。


) 統合型モデムの場合、115,200 bps のモデム速度とハードウェア フロー制御がデフォルトの設定値です。


国別コードのデフォルト値へのリセット

モデムの国別コードをデフォルト値へリセットするには、グローバル コンフィギュレーション モードで no spe country コマンドを入力します。

設定の確認

SPE の設定を確認するには、次のコマンドを使用します。

show spe コマンドを入力し、全回線のサマリーを表示します。

AS5400# show spe
 
SPE settings:
==============
Country code configuration: default T1 (u Law)
Polling interval: 8 secs.
History log events: 50(per port)
Port legends:
============
Port state: (s)shutdown (t)test (r)recovery (d)download
(b)busiedout (p)busyout pending, (B)bad (a)active call
Call type: (m)modem (d)digital (f)fax-relay (v)voice (_)not in use
System resources summary:
======================
Total ports: 108, in use ports: 0, disabled ports: 0, free ports: 108
Total active calls: modem 0, voice 0, digital 0, fax-relay 0
 
SPE SPE SPE SPE Port Call
SPE# Port # State Busyout Shut Crash State Type
4/00 0000-0005 ACTIVE 0 0 0 ______ ______
4/01 0006-0011 ACTIVE 0 0 0 ______ ______
4/02 0012-0017 ACTIVE 0 0 0 ______ ______
4/03 0018-0023 ACTIVE 0 0 0 ______ ______
4/04 0024-0029 ACTIVE 0 0 0 ______ ______
.
.
.
 

show line number コマンドを入力し、特定の回線のサマリーを表示します。

AS5400# show line 1
 
Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int
1 AUX 9600/9600 - - - - - 0 0 0/0 -
Ready
 
Line 1, Location: "", Type: ""
Length: 24 lines, Width: 80 columns
Baud rate (TX/RX) is 9600/9600, no parity, 2 stopbits, 8 databits
Status: Ready
Capabilities: none
Modem state: Ready
Group codes: 0
Modem hardware state: noCTS noDSR DTR RTS
TTY NUMBER 1
Parity Error = 0 Framing Error = 0 Receive Error = 0 Overrun = 0
Outcount = 0 totalout = 39 incount = 0 totalin = 0
 
Special Chars: Escape Hold Stop Start Disconnect Activation
^^x none - - none
Timeouts: Idle EXEC Idle Session Modem Answer Session Dispatch
00:10:00 never none not set
Idle Session Disconnect Warning
never
Login-sequence User Response
 

問題がある場合は、回線接続用にプロトコルをオン( transport input all )にしたか、回線を着信および発信コール用( modem inout )に設定したかどうかを確認してください。

VFC の設定

Voice Feature Card(VFC; 音声フィーチャ カード)には 1 ~ 6 個の PVDM2-64 モジュールが搭載されており、サポートするポート密度がコーデックの複雑さによって異なります。


) VFC の CLI コマンドの詳細については、次の URL の『High-Density Packet Voice Feature Card for Cisco AS5350XM and AS5400XM Universal Gateways』を参照してください。

http://www.cisco.com/en/US/products/ps6706/products_feature_guide09186a008060df15.html


設定手順

VFC は、プラットフォーム上のソフトウェアの設定を個別に変更しなくても動作します。ただし使用するソフトウェアのリリースによっては、VFC のファームウェアをアップグレードする必要があります。

VFC のファームウェアをアップグレードする手順は次のとおりです。

 

コマンドまたは操作
目的

ステップ 1

AS5400> enable
Password: password
AS5400#

enable コマンドを入力します。パスワードを入力します。イネーブル EXEC モードが開始されると、プロンプトが AS5350# または AS5400# に変わります。

ステップ 2

AS5400# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
AS5400(config)#

グローバル コンフィギュレーション モードを開始します。グローバル コンフィギュレーション モードが開始されると、プロンプトが AS5350(config)# または AS5400(config)# に変わります。

ステップ 3

AS5400(config)# voice dsp slot [ / dsp ] [ slot [ / dsp ]]

voice dsp config モードを開始し、slot/dsp の位置または範囲を指定します。

slot 引数には VFC の位置を示す値を 1 ~ 7 で指定します。

dsp 引数には DSP の位置を示す値を 1 ~ 24 で指定します。

範囲を指定する場合は、まず範囲の最初の slot/dsp を示す引数を 2 つ指定します。次に範囲の最後の slot/dsp を示す引数を 2 つ指定します。

構文にスラッシュ記号(/)が示されている場合は、スラッシュ記号も必ず入力します。

ステップ 4

AS5400(config-voice-dsp)# firmware location flash: filename

ファームウェアがフラッシュ メモリに保存されていること、およびそのファイル名を指定します。

ステップ 5

AS5400(config-voice-dsp)# end

config-voicedsp モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 6

AS5400(config-voice-dsp)# Ctrl-Z
AS5400#

イネーブル モードに戻ります。

設定の確認

ファームウェアのアップグレードを確認するには、 show voice dsp version コマンドを使用します。

AS5400#show voice dsp version ?
 
IOS-Bundled Default Version Firmware-Type
========================== ======= =============
system:/bundled_fw_image 4.4.5 c5510
 
On-Flash Dspware-Filename Version Firmware-Type
========================= ======= =============
flash:dsp_c5510_flex.rbf 4.5.9051 c5510
flash:new_flex.rbf 4.4.5 c5510
flash:big.rbf 4.5.985x c5510
 
DSP# Type Version Filename
3/1 C5510 4.5.9051 flash:dsp_c5510_flex.rbf
3/2 C5510 4.4.5 system:/bundled_fw_image
3/3 C5510 4.4.5 system:/bundled_fw_image
3/4 C5510 4.4.5 system:/bundled_fw_image
3/5 C5510 4.4.5 system:/bundled_fw_image
3/6 C5510 4.4.5 system:/bundled_fw_image
3/7 C5510 4.4.5 system:/bundled_fw_image
3/8 C5510 4.4.5 system:/bundled_fw_image
3/9 C5510 4.4.5 system:/bundled_fw_image
3/10 C5510 4.4.5 system:/bundled_fw_image
3/11 C5510 4.4.5 system:/bundled_fw_image
 

クロックの設定

Cisco AS5350XM および Cisco AS5400XM ユニバーサル ゲートウェイのバックプレーンの TDM バスは、ゲートウェイの次の基本ソースの 1 つから入力クロックを受信できます。

T1、E1、および CT3 フィーチャ カード

マザーボード上の Building Integrated Timing Supply(BITS)インターフェイス ポートからの外部 T1 または E1 クロック ソース

発振器からのクロックを提供するフリーラン クロック


) BITS は、単一のビルディング マスターによるタイミング供給方式です。オフィス全体に DS1 および DS0 レベルのタイミングを供給します。北米では、BITS はワイヤライン ネットワークの下位レベルにタイミングを提供および分配するクロックです。


トランク フィーチャ カード ポート

TDM バスは、任意のトランク カードと同期を取ることができます。T1 または E1 フィーチャ カードの各ポートは、T1 または E1 回線からクロックを受信します。CT3 フィーチャ カードは、M13 マルチプレクサを使用して DS1 クロックを受信します。各トランク フィーチャ カード スロット上の各ポートには、デフォルトのクロック プライオリティが割り当てられています。クロック プライオリティは、 dial-tdm-clock priority CLI コマンドで設定することもできます。

外部クロック

TDM バスは、追加のネットワーク リファレンスとして使用できる外部クロック ソースと同期を取ることができます。クロックが何も設定されていない場合、システムはソフトウェア制御のデフォルト アルゴリズムによってプライマリ クロックを使用します。(BITS インターフェイスを介して)T1 または E1 クロックをプライマリ クロック ソースとして使用する場合は、 dial-tdm-clock priority CLI コマンドで設定する必要があります。外部クロックがデフォルトで選択されることはありません。

BITS インターフェイスには、1.544 MHz に設定された T1 回線コンポジット クロック リファレンス、および 2.048 MHz に設定された E1 回線コンポジット クロック リファレンスが必要です。

フリーラン クロック

トランク フィーチャ カードまたは外部クロック ソースから良好なクロックが得られない場合は、 dial-tdm-clock priority CLI コマンドを使用して、ローカルの発振器によるフリーラン クロックを選択します。

次の表に、TDM バスが使用するクロック ソースおよびクロック ソース プライオリティを設定するためのコマンドを示します。

 

コマンド
目的

ステップ 1

AS5400> enable
Password: password
AS5400#

イネーブル モードを開始します。パスワードを入力します。イネーブル モードが開始されると、プロンプトが AS5350# または AS5400# に変わります。

ステップ 2

AS5400# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
AS5400(config)#

グローバル コンフィギュレーション モードを開始します。この例では、端末コンフィギュレーション オプションを使用します。グローバル コンフィギュレーション モードが開始されると、プロンプトが AS5350(config)# または AS5400(config)# に変わります。

ステップ 3

 

コンフィギュレーションに応じて、次のいずれかのコマンドを入力します。

AS5400(config )# dial-tdm-clock priority priority # { external | freerun | slot/ds1 port }

クロック ソースを提供する T1 または E1 フィーチャ カードのクロック プライオリティ、スロット、およびポートを設定します。プライオリティ値の範囲は 1 ~ 99 です。フィーチャ カード スロット値は 1 ~ 7 です。DS1 ポート番号コントローラの値は 0 ~ 7 です。


) DS1 ポートは T1 ポートを指定します。


AS5400(config )# dial-tdm-clock priority priority# { external | freerun | slot/ds3 port : ds1 port }

クロック ソースを提供する CT3 フィーチャ カードのクロック プライオリティ、スロット、およびポートを設定します。プライオリティ値の範囲は 1 ~ 99 です。

フィーチャ カード スロットの値は 1 ~ 7 です。DS3 ポートは T3 ポートを指定します。DS1 ポート番号コントローラの値は 1 ~ 28 です。


) プライオリティ 100 のクロックは TDM クロックを駆動できません。


ステップ 4

AS5400(config)# Ctrl-Z
AS5400#

イネーブル EXEC モードに戻ります。

ステップ 5

AS5400 # copy running-config startup-config

変更した設定値を保存します。

設定例

次の例では、BITS クロックをプライオリティ 1 に設定しています。

AS5400(config)# dial-tdm-clock priority 1 external
AS5400(config)# exit
AS5400#
 

次の例では、T1 フィーチャ カードからのトランク クロックをプライオリティ 2 に設定し、スロット 4 および ds1 ポート(コントローラ)6 を使用しています。

AS5400(config)# dial-tdm-clock priority 2 4/6
AS5400(config)# exit
 

次の例では、CT3 フィーチャ カードからのトランク クロックをプライオリティ 2 に設定し、スロット 1、ds3 ポート 0、および ds1 ポート 19 を使用しています。

AS5400(config)# dial-tdm-clock priority 2 1/0:19
AS5400(config)# exit
 

次の例では、フリーラン クロックをプライオリティ 3 に設定しています。

AS5400(config)# dial-tdm-clock priority 3 free
AS5400(config)# exit

設定の確認

システムのプライマリ クロックおよびバックアップ クロックを確認し、すべてのトランク フィーチャ カード コントローラ クロックのステータスを確認できます。また、最近実行された TDM クロックの変更と、その原因となったイベントのヒストリを 20 個、表示することもできます。

show tdm clocks コマンドを使用して、デフォルトのシステム クロックおよびクロック ヒストリを確認します(次の例は T1 または E1 の場合)。

AS5400# show tdm clocks
 
Primary Clock:
--------------
TDM Bus Master Clock Generator State = HOLDOVER
 
Backup clocks for primary:
Source Slot Port DS3-Port Priority Status State
-------------------------------------------------------------
 
Trunk cards controllers clock health information
------------------------------------------------
Slot Type 7 6 5 4 3 2 1 0
1 T1 B B B B B B B B
 
 
CLOCK CHANGE HISTORY
--------------------------
 
CLOCK Event Time
----- ----- ----
1/1 Loss Of Signal (LOS) 00:00:22 UTC Tue Nov 30 1999
1/2 Loss Of Signal (LOS) 00:00:22 UTC Tue Nov 30 1999
1/3 Alarm Indication Signal (AIS) 00:00:22 UTC Tue Nov 30 1999
1/4 Alarm Indication Signal (AIS) 00:00:22 UTC Tue Nov 30 1999
1/5 Alarm Indication Signal (AIS) 00:00:22 UTC Tue Nov 30 1999
1/6 Alarm Indication Signal (AIS) 00:00:22 UTC Tue Nov 30 1999
1/7 Alarm Indication Signal (AIS) 00:00:22 UTC Tue Nov 30 1999
AS5400#
 

show tdm clocks コマンドを使用して、TDM クロック ヒストリを確認します(次の例はチャネライズド T3 の場合)。

AS5400# show tdm clocks
 
Primary Clock:
--------------
System primary is slot 7 ds3_port 0 ds1_port 1 of priority 1
TDM Bus Master Clock Generator State = NORMAL
 
Backup clocks for primary:
Source Slot Port DS3-Port Priority Status State
-------------------------------------------------------------
Trunk 7 8 YES 214 Good Default
Trunk 7 9 YES 215 Good Default
 
Trunk cards controllers clock health information
------------------------------------------------
CT3 2 2 2 2 2 2 2 2 2 1 1 1 1 1 1 1 1 1 1
Slot Port Type 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1
7 0 T3 G G G G G G G G G G G G G G G G G G G G G G G G G G G G
 
 
 
CLOCK CHANGE HISTORY
--------------------------
 
CLOCK Event Time
----- ----- ----
7/1 Signal recovered from LOS 00:03:29 UTC Sat Jan 1 2000
7/8 Alarm Indication Signal (AIS) 11:27:48 UTC Fri Feb 25 2000
7/1 Signal recovered from LOS 11:30:22 UTC Fri Feb 25 2000
AS5400#
 

show tdm clocks コマンドを使用して、ユーザが設定したトランク クロック選択を確認します。

AS5400# show tdm clocks
 
Primary Clock:
System primary is slot 2 port 0 of priority 15
TDM Bus Master Clock Generator State = NORMAL
Backup clocks for primary:
Source Slot Port DS3-Port Priority Status State
Trunk 2 1 NO 205 Good Default
Trunk cards controllers clock health information
Slot Type 7 6 5 4 3 2 1 0
2 T1 B B B B G G G G
 
CLOCK CHANGE HISTORY
 
CLOCK Event Time
2/1 Controller shutdown 23:23:06 UTC Tue Nov 30 1999
2/0 Change in CLI configuration 23:27:25 UTC Tue Nov 30 1999
AS5400#
 

show tdm clocks コマンドを使用して、フリーラン クロック選択を確認します。

AS5400# show tdm clocks
 
Primary Clock:
System primary is FREE RUNNING with priority 2
TDM Bus Master Clock Generator State = FREERUN
Backup clocks for primary:
Source Slot Port DS3-Port Priority Status State
Trunk 2 0 NO 204 Good Default
Trunk 2 1 NO 205 Good Default
Trunk cards controllers clock health information
Slot Type 7 6 5 4 3 2 1 0
2 T1 B B B B G G G G
CLOCK CHANGE HISTORY
 
CLOCK Event Time
Freerun Change in CLI configuration 23:27:25 UTC Tue Nov 30 1999
AS5400#
 

show tdm clocks コマンドを使用して、BITS クロック選択を確認します。

AS5400# show tdm clocks
 
Primary Clock:
System primary is external with priority 1
TDM Bus Master Clock Generator State = NORMAL
Backup clocks for primary:
Source Slot Port DS3-Port Priority Status State
Trunk 2 0 NO 204 Good Default
Trunk 2 1 NO 205 Good Default
Trunk cards controllers clock health information
Slot Type 7 6 5 4 3 2 1 0
2 T1 B B B B G G G G
CLOCK CHANGE HISTORY
 
CLOCK Event Time
External Change in CLI configuration 23:27:25 UTC Tue Nov 30 1999
AS5400#

ヒント クロック スリップ問題の原因として最も一般的なのが、dial-tdm-clock priority パラメータが適切に設定されていないことです。dial-tdm-clock priority パラメータのデフォルトの設定を、フリーラン クロックからシステム要件に適した設定に変更してください。


IP 基本設定のイネーブル化

EXEC シェル ユーザ用に IP ルーティング機能およびドメイン ネーム サービスを微調整するには、次の作業を行います。


ステップ 1 グローバル コンフィギュレーション モードで IP ルーティング機能を最適化します。

AS5400(config)# ip subnet-zero
AS5400(config)# no ip source-route
AS5400(config)# ip classless
AS5400(config)# ip domain-lookup
 

表3-5 で、この例で使用しているコマンドについて説明します。

 

表3-5 IP ルーティング コマンド

コマンド
目的
ip subnet-zero

172.22.0.0 を有効なサブネットとして指定します。

no ip source-route

IP ヘッダー パケットがゲートウェイを通過する独自のパスを定義できないようにして、セキュリティを強化します。

ip classless

IP ヘッダー パケットがゲートウェイを通過する独自のパスを定義できないようにして、セキュリティを強化します。

ip domain-lookup

IP ドメイン名検索をイネーブルにします。

ステップ 2 グローバル コンフィギュレーション モードで、EXEC シェル ユーザをサポートするドメイン ネーム サービス コマンドを入力します。

AS5400(config)# ip host mymap 172.22.53.101
AS5400(config)# ip domain-name mydomain.com
AS5400(config)# ip name-server 172.22.11.10
AS5400(config)# ip name-server 172.22.11.11
 

表3-6 で、この例で使用しているコマンドについて説明します。

 

表3-6 ドメイン ネーム コマンド

コマンド
目的
ip host mymap 172.22.53.101

名前とアドレスのローカル マップを作成します。ゲートウェイが DNS サーバに設定されていない場合、このマップが役立ちます。

ip domain-name mydomain.com

DNS 検索の限定方法をゲートウェイに指示します。この例では、各検索名の末尾に mydomain.com を加えています。

ip name-server 172.22.11.10
ip name-server 172.22.12.11

プライマリおよびセカンダリ ネーム サーバを指定します。 ip name-server コマンドは、名前を IP アドレスに対応付けるために使用します。


 

非同期シェル接続のテスト

次のコンポーネントが機能しているかどうかを確認する作業です。

物理非同期データ パス

基本モデム リンク

シェル セッションをサポートする基本 IP 機能

Cisco IOSソフトウェアには、EXEC という CLI が備わっていて、モデムを使用したダイヤル インでアクセスできます。EXEC は、次の作業を行うために端末シェル サービス(PPP なし)へのアクセスを提供します。

コンフィギュレーション ファイルの変更

パスワードの変更

モデム接続などの問題のトラブルシューティング

Telnet による他のネットワーク リソースへのアクセス

この作業中、管理者によっては PPP ベースの Web ブラウジングなど、複雑なサービスを動作させようとすることがありますが、先に進まないでください。ほかにも設定しなければならない要素が多数あります(PPP、IPCP など)。非同期シェル テストでは、クライアント モデムから EXEC のログイン プロンプトにアクセスできるかどうかを確認します。レイヤ方式でネットワークを構築することによって、問題を特定し、時間を節約できます。

非同期シェル接続をテストする手順は、次のとおりです。


ステップ 1 クライアント PC、クライアント モデム、およびアナログ回線を特定します。クライアント PC から端末エミュレーション プログラム(ダイヤルアップ ネットワーキングではなく、HyperTerminal など)を起動し、クライアント モデムに接続します。図3-2に、このテストに使用するネットワーク環境を示します。

図3-2 テスト環境

 

ステップ 2 端末エミュレーション プログラムから、クライアント モデムへの EIA/TIA-232 接続をテストします。at コマンドを入力します。モデムから OK プロンプトが戻ります。

at
OK
 

at コマンド セットの詳細については、Technical Assistance Center(TAC)Web サイト
http://www.cisco.com/pcgi-bin/Support/PSP/psp_view.pl?p=Internetworking:ASYNC&s=Implementation_and_Configuration)にある各種の参考資料を参照してください。


ステップ 3 ゲートウェイに割り当てられている PRI 電話番号(次の例では 5554100)をダイヤルします。モデムが正常に接続されると、CONNECT メッセージが表示されます。

atdt 5554100
CONNECT 33600/REL - LAPM
 

) 多くのモデムは、前回の at コマンドを呼び出す a/ コマンドをサポートしています。ath コマンドを使用すると、モデム コールが切断されます。前回の電話番号をダイヤルする場合は、atdl コマンドを使用します。


ステップ 4 (クライアント PC から)ゲートウェイ上の EXEC セッションにログインします。

This is a secured device.
Unauthorized use is prohibited by law.
 
User Access Verification
 
Username: Harry
Password:
 
AS5400>
 

ステップ 5 コールを受け付けた回線を特定します。次の例では、回線 TTY 216 がコールを受け付けています。このコールは 30 秒間アクティブになっています。

AS5400# show caller
Active Idle
Line User Service Time Time
con 0 admin TTY 00:39:09 00:00:00
tty 216 Harry TTY 00:00:30 00:00:07

AS5400# show caller user Harry
 
User: Harry, line tty 216, service TTY
Active time 00:00:42, Idle time 00:00:19
Timeouts: Absolute Idle Idle
Session Exec
Limits: - - 00:10:00
Disconnect in: - - 00:09:40
TTY: Line 1/00
DS0: (slot/unit/channel)=2/0/18
Line: Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits
Status: Ready, Active, No Exit Banner
Capabilities: No Flush-at-Activation, Hardware Flowcontrol In
Hardware Flowcontrol Out, Modem Callout, Modem RI is CD
Integrated Modem
Modem State: Ready
 

show caller コマンドは、Cisco IOS ソフトウェアの Cisco IOS Release 11.3 AA および Release 12.0 T で追加されました。使用しているソフトウェア リリースでこのコマンドがサポートされていない場合は、show user コマンドを使用してください。


ステップ 6 IP 機能がシェル セッションをサポートするかどうかをテストします。ゲートウェイからネットワーク内の別のデバイスに Telnet で接続します。

AS5400# telnet 171.68.186.49
Trying 171.68.186.49 ... Open
 
access-gw line 2
 
access-gw telnet smart
Translating "smart"...domain server (171.68.10.70) [OK]
Trying smart.cisco.com (171.68.191.135)... Open
 
UNIX(r) System V Release 4.0 (smart)
 
login: Router
Password:
No directory! Logging in with home=/
Last login: Fri Aug 18 13:50:07 from dhcp-aus-163-230
Sun Microsystems Inc. SunOS 5.5.1 Generic May 1996
 


 

最終的な実行コンフィギュレーションの確認

次に、最終的な実行コンフィギュレーションの例を示します。

AS5400# show running-config
 
Building configuration...
 
Current configuration : 6017 bytes
!
version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname AS5400
!
boot system tftp c5350-js-mz.xm.Feb19 171.69.20.20
no boot startup-test
no logging buffered
logging rate-limit console 10 except errors
enable secret 5 $1$ltzj$8lGJ1cGmyZRdXdPXncLAo/
!
!
resource-pool disable
!
!
voice-fastpath enable
ip subnet-zero
no ip finger
ip domain-name cisco.com
ip name-server 171.69.11.48
ip name-server 171.69.2.132
ip name-server 171.69.2.133
!
no ip dhcp-client network-discovery
!
!
fax interface-type modem
mta receive maximum-recipients 0
!
!
crypto mib ipsec flowmib history tunnel size 200
crypto mib ipsec flowmib history failure size 200
!
!
controller T1 1/0
framing sf
linecode ami
!
controller T1 1/1
framing sf
linecode ami
!
.
.
.
controller T1 1/7
framing sf
linecode ami
!
!
interface GigabitEthernet0/0
ip address 172.21.101.21 255.255.255.0
no ip route-cache
no ip mroute-cache
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
no ip route-cache
no ip mroute-cache
shutdown
clockrate 2000000
!
interface Serial0/1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
clockrate 2000000
!
interface Async4/00
no ip address
!
interface Async4/01
no ip address
!
interface Async4/02
no ip address
!
.
.
.
interface Async4/107
no ip address
!
interface Group-Async0
no ip address
no ip route-cache
no ip mroute-cache
no group-range
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.21.101.1
no ip http server
!
!
call rsvp-sync
!
!
line con 0
logging synchronous
transport input none
line aux 0
logging synchronous
line vty 0 4
password #1writer
login
line 4/00 4/107
no flush-at-activation
modem InOut
!
scheduler allocate 10000 400
end

変更したコンフィギュレーションの保存

ゲートウェイのコンフィギュレーションが失われないように、NVRAM(不揮発性 RAM)に保存します。

設定手順

 

コマンド
目的

ステップ 1

AS5400> enable
Password: password
AS5400#

イネーブル モード(別名、イネーブル EXEC モード)を開始し、パスワードを入力します。イネーブル モードが開始されると、プロンプトが AS5350# または AS5400# に変わります。

ステップ 2

AS5400# copy running-config startup-config

変更したコンフィギュレーションは、リセット、電源のオフ/オン、停電によって失われることがないように、NVRAM に保存します。

ステップ 3

AS5400(config-if)# Ctrl-Z
AS5400#

イネーブル モードに戻ります。

次の作業

次の作業に進んでください。

第 4 章「CLI を使用して行う設定作業の続き」 を参照して、基本機能のシステム コンフィギュレーション作業を続けます。

第 5 章「ユニバーサル ポート カードおよびダイヤル専用フィーチャ カードの管理およびトラブルシューティング」 を参照して、ゲートウェイ上のユニバーサル ポート カード接続およびダイヤル専用フィーチャ カード接続について、設定、管理、トラブルシューティングを行います。

第 6 章「音声フィーチャ カードの管理およびトラブルシューティング」 を参照して、ゲートウェイ上の VFC 接続について、設定、管理、トラブルシューティングを行います。

付録 C「総合的なコンフィギュレーション例」

Monitoring Voice and Fax Services on the Cisco AS5350 and Cisco AS5400 Universal Gateways
http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080080e60.html )を参照してください。

High-Density Packet Voice Feature Card for Cisco AS5350XM and AS5400XM Universal Gateways
http://www.cisco.com/en/US/products/ps6706/products_feature_guide09186a008060df15.html )を参照してください。

基本設定に関するその他の情報は、『 Cisco IOS Dial Technologies Configuration Guide 』および『 Cisco IOS Dial Technologies Command Reference 』を参照してください。さらに高度な設定については、使用している Cisco IOS ソフトウェア リリースに応じた Cisco IOS ソフトウェア コンフィギュレーション ガイド、フィーチャ モジュール、およびコマンド リファレンスを参照してください。

Cisco AAA ベースのセキュリティについては、『 Cisco AAA Implementation Case Study
http://www.cisco.com/univercd/cc/td/doc/cisintwk/intsolns/secsols/aaasols/ )を参照してください。

トラブルシューティング情報については、『 System Error Messages 』および『 Debug Command Reference 』を参照してください。