Cisco Internet Streamer CDS 2.0-2.2 Software コンフィギュレーション ガイド
CLI コマンド
CLI コマンド
発行日;2012/02/01 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

CLI コマンド

ポート チャネルの設定

冗長専用管理ポート

ラスト リゾート ルーティングの設定

その他の CLI コマンド

cdnfs cleanup

disk コマンド

cache content

CLI コマンド

この付録は、次の内容から構成されています。

「ポート チャネルの設定」

「ラスト リゾート ルーティングの設定」

「その他の CLI コマンド」

ポート チャネルの設定

EtherChannel を設定するには、 PortChannel インターフェイス コンフィギュレーション コマンドを使用します。ポート チャネルは EtherChannel とも呼ばれ、同じ速度のネットワーク インターフェイスを 4 つまで、1 つの仮想インターフェイスとしてグループ化できます。このグループ化機能によって、2、3、または 4 つのギガビット イーサネット インターフェイスからなる仮想インターフェイスを設定したり削除したりできます。EtherChannel は EtherChannel をサポートするシスコのルータ、スイッチ、またはその他のデバイスまたはホストとの相互運用性、ロード バランシング、各インターフェイスの現在のリンク ステータスに基づいた自動障害検出および回復機能も提供します。


) 最高のスループットを得るには、ラインカード上の 4 つのギガビット イーサネット ポートのポート チャネルを設定することを推奨します。


冗長専用管理ポート

SE または SR として設定された CDE-200 上には、6 つのギガビット イーサネット ポートがあります。いずれのポートも、Real Time Streaming Protocol(RTSP)などの配信トラフィックに使用できるとともに、Content Delivery System Manager(CDSM; コンテント デリバリ システム マネージャ)などの他の CDS デバイスと通信するシステム管理トラフィックに使用できます。すべての帯域幅が配信トラフィックに使用されてしまわないように、専用管理ポートの設定が通常は推奨されます。

単一ポートで物理障害が発生した場合に備え、配信トラフィックと管理トラフィックの両方について、複数のギガビット イーサネット ポートのチャネル ボンディングとして束ねる設定も推奨されます。


) デフォルト ゲートウェイを指定して設定されたポート チャネルは、配信トラフィック専用です。CDS ネットワーク上で最大の帯域幅要求は、配信トラフィックです。プライマリ インターフェイスとして設定されたポート チャネルが配信トラフィックを伝送します。



) アップストリーム ルータ/スイッチと SE 間のリアルタイム データ ストリーミングに EtherChannel(別名、ポート チャネル)を使用する場合は、アップストリーム スイッチ/ルータと SE の EtherChannel ロード バランス アルゴリズムをそれぞれ [src-ip] と [dst-ip] として設定する必要があります。この設定を使用することによって、クライアントの IP アドレスに基づいた、セッション スティッキ性と総合的に均衡の取れた不可分散が保証されます。さらに、ロード バランシング アルゴリズムが複数のポート間でのトラフィック分散で有効になるように、複数のサブネットにクライアント IP アドレス スペースを分散させます。


通常、マザーボード上の 2 つのギガビット イーサネット ポート(GigabitEthernet 1/0 および 2/0)を管理ポート チャネルとしてバンドルし、NIC(ネットワーク インターフェイス カード)上の 4 つのギガビット イーサネット ポート(GigabitEthernet 3/0、4/0、5/0、および 6/0)をトラフィック ポート チャネルとしてバンドルできます。

CLI(コマンドライン インターフェイス)を使用して冗長専用管理ポートを設定する手順は、次のとおりです。


ステップ 1 2 つのポート チャネルを設定します。1 つはアプリケーション トラフィック用に 4 つのギガビット イーサネット ポートを(portchannel 1)、もう 1 つには管理トラフィック用として 2 つのギガビット イーサネット ポートを設定します(portchannel 2)。

SE(config)# interface GigabitEthernet 1/0
SE(config-if)# channel-group 2
SE(config-if)# exit
SE(config)# interface GigabitEthernet 2/0
SE(config-if)# channel-group 2
SE(config-if)# exit
SE(config)# interface GigabitEthernet 3/0
SE(config-if)# channel-group 1
SE(config-if)# exit
SE(config)# interface GigabitEthernet 4/0
SE(config-if)# channel-group 1
SE(config-if)# exit
SE(config)# interface GigabitEthernet 5/0
SE(config-if)# channel-group 1
SE(config-if)# exit
SE(config)# interface GigabitEthernet 6/0
SE(config-if)# channel-group 1
SE(config-if)# exit
 

) 配信トラフィックを伝送するポート チャネルは、必ず、channel-group 1 とし、プライマリ インターフェイスとして設定します。


ステップ 2 両方のポート チャネルに 2 つの異なるサブネットを設定します。

SE(config)# interface PortChannel 1
SE(config-if)# ip address 3.1.7.73 255.255.255.0
SE(config-if)# exit
SE(config)# interface PortChannel 2
SE(config-if)# ip address 3.1.8.200 255.255.255.0
SE(config-if)# exit
 

ステップ 3 配信ポート チャネルをプライマリ インターフェイスとして設定します。

SE(config)# primary-interface PortChannel 1
 

ステップ 4 配信トラフィック用のデフォルト ゲートウェイを設定します。

SE(config)# ip default-gateway 3.1.7.1
 

ステップ 5 ロード バランシング アルゴリズムを宛先 IP アドレスに設定します。

SE(config)# port-channel load-balance dst-ip
 

ステップ 6 クライアントおよびサーバの準拠 TCP を RFC 1323 規格に設定します。

SE(config)# tcp client-satellite
SE(config)# tcp server-satellite
 

ステップ 7 CDSMへのスタティック ルート(4.0.5.5)を設定し、すべての管理トラフィックがこのインターフェイスを経由することを指定します。

SE(config)# ip route 4.0.5.5 255.255.255.255 3.1.8.1
 

ステップ 8 SE が直接接続するスイッチ上で、ポート チャネルおよび VLAN を設定します。

SW3750(config)# interface Port-channel1
SW3750(config-if)# switchport access vlan 201
SW3750(config-if)# exit
SW3750(config)# interface Port-channel2
SW3750(config-if)# switchport access vlan 202
SW3750(config-if)# exit
SW3750(config)# interface GigabitEthernet1/0/1
SW3750(config-if)# description Connected to portchannel2
SW3750(config-if)# switchport access vlan 202
SW3750(config-if)# switchport mode access
SW3750(config-if)# exit
SW3750(config)# interface GigabitEthernet1/0/2
SW3750(config-if)# description Connected to portchannel2
SW3750(config-if)# switchport access vlan 202
SW3750(config-if)# switchport mode access
SW3750(config-if)# exit
SW3750(config)# interface GigabitEthernet1/0/3
SW3750(config-if)# description connected to portchannel1
SW3750(config-if)# switchport access vlan 201
SW3750(config-if)# switchport mode access
SW3750(config-if)# exit
SW3750(config)# interface GigabitEthernet1/0/4
SW3750(config)-if# description connected to portchannel1
SW3750(config-if)# switchport access vlan 201
SW3750(config-if)# switchport mode access
SW3750(config-if)# exit
SW3750(config)# interface GigabitEthernet1/0/5
SW3750(config-if)# description connected to portchannel1
SW3750(config-if)# switchport access vlan 201
SW3750(config-if)# switchport mode access
SW3750(config-if)# exit
SW3750(config)# interface GigabitEthernet1/0/6
SW3750(config-if)# description connected to portchannel1
SW3750(config-if)# switchport access vlan 201
SW3750(config-if)# switchport mode access
SW3750(config-if)# exit
SW3750(config)# interface Vlan201
SW3750(config-if)# ip address 3.1.7.1 255.255.255.0
SW3750(config-if)# exit
SW3750(config)# interface Vlan202
SW3750(config-if)# ip address 3.1.8.1 255.255.255.0
SW3750(config-if)# exit
 

ステップ 9 ロード バランシング アルゴリズムを送信元 IP アドレスに設定します。

SW3750(config)# port-channel load-balance src-ip
 


 

アプリケーション トラフィックの送信前に設定を確認するには、下記を使用します。

SE# clear statistics all
SE# show interface portChannel 1
Interface PortChannel 1 (2 physical interface(s)):
GigabitEthernet 3/0 (active)
GigabitEthernet 4/0 (active)
GigabitEthernet 5/0 (active)
GigabitEthernet 6/0 (active)
---------------------
Type:Ethernet
Ethernet address:00:04:23:D8:86:02
Internet address:3.1.7.73
Broadcast address:3.1.7.255
Netmask:255.255.255.0
Maximum Transfer Unit Size:1500
Metric:1
Packets Received: 28
Input Errors: 0
Input Packets Dropped: 0
Input Packets Overruns: 0
Input Packets Frames: 0
Packet Sent: 40
Output Errors: 0
Output Packets Dropped: 0
Output Packets Overruns: 0
Output Packets Carrier: 0
Output Queue Length:0
Collisions: 0
Flags:UP BROADCAST RUNNING MASTER MULTICAST
 
SE# show interface portChannel 2
Interface PortChannel 2 (4 physical interface(s)):
GigabitEthernet 1/0 (active)
GigabitEthernet 2/0 (active)
---------------------
Type:Ethernet
Ethernet address:00:30:48:33:01:26
Internet address:3.1.8.200
Broadcast address:3.1.8.255
Netmask:255.255.255.0
Maximum Transfer Unit Size:1500
Metric:1
Packets Received: 6
Input Errors: 0
Input Packets Dropped: 0
Input Packets Overruns: 0
Input Packets Frames: 0
Packet Sent: 0
Output Errors: 0
Output Packets Dropped: 0
Output Packets Overruns: 0
Output Packets Carrier: 0
Output Queue Length:0
Collisions: 0
Flags:UP BROADCAST RUNNING MASTER MULTICAST
 

アプリケーション トラフィックの送信後に設定を確認するには、下記を使用します。

SE# show interface portChannel 1
Interface PortChannel 1 (4 physical interface(s)):
GigabitEthernet 3/0 (active)
GigabitEthernet 4/0 (active)
GigabitEthernet 5/0 (active)
GigabitEthernet 6/0 (active)
--------------------
Type:Ethernet
Ethernet address:00:04:23:D8:86:02
Internet address:3.1.7.73
Broadcast address:3.1.7.255
Netmask:255.255.255.0
Maximum Transfer Unit Size:1500
Metric:1
Packets Received: 1875
Input Errors: 0
Input Packets Dropped: 0
Input Packets Overruns: 0
Input Packets Frames: 0
Packet Sent: 5221
Output Errors: 0
Output Packets Dropped: 0
Output Packets Overruns: 0
Output Packets Carrier: 0
Output Queue Length:0
Collisions: 0
Flags:UP BROADCAST RUNNING MASTER MULTICAST
 
SE# show interface portChannel 2
Interface PortChannel 2 (2 physical interface(s)):
GigabitEthernet 1/0 (active)
GigabitEthernet 2/0 (active)
---------------------
Type:Ethernet
Ethernet address:00:30:48:33:01:26
Internet address:3.1.8.200
Broadcast address:3.1.8.255
Netmask:255.255.255.0
Maximum Transfer Unit Size:1500
Metric:1
Packets Received: 21
Input Errors: 0
Input Packets Dropped: 0
Input Packets Overruns: 0
Input Packets Frames: 0
Packet Sent: 0
Output Errors: 0
Output Packets Dropped: 0
Output Packets Overruns: 0
Output Packets Carrier: 0
Output Queue Length:0
Collisions: 0
Flags:UP BROADCAST RUNNING MASTER MULTICAST
 
SE# show statistics wmt streamstat
Detailed Stream Statistics
==========================
Incoming Streams:
=================
Stream-Id Type Source State Bytes_Recd Duration Bandwidth Url_Requested
Outgoing Streams:
=================
Client-IP Type Transport Source State Pkts_sent Bytes_sent Duration BW Server-IP Filename
2.224.22.50 VOD RTSPT LOCAL Play 5221 7312466 42 502 local 100kbps.wmv
 
SE# show cms info
CDN information :
Model = SE200
Node Id = 424
Device Mode = se
Current CDSM address = 4.0.5.5
Registered with CDSM = 4.0.5.5
Status = Online
Time of last config-sync = Thu May 3 16:56:54 2007
CMS services information :
Service cms_se is running
 

CDSM の Device Table ページ( Devices > Devices )で、SE または SR の Status が [Online] になるはずです。デバイスの IP アドレスには常に、プライマリ インターフェイスの IP アドレスが示されます。

ラスト リゾート ルーティングの設定

ラストリゾート ルーティングを適用できるのは、負荷ベースのルーティングがイネーブルになっているときに、すべてのService Engineがしきい値を超えるか、ドメインのすべてのService Engineがオフラインになっている場合です。サービス ルータは、クライアント ネットワーク リージョンを処理しているすべてのService Engineがオーバーロードした場合に、設定可能な代替ドメインに要求をリダイレクトできます。


) ラスト リゾート ドメインが設定されていないときに Service Engine のしきい値を超えた場合、要求は送信元サーバにリダイレクトされます。


ラスト リゾートのルーティングを設定するには、 service-router グローバル コンフィギュレーション コマンドを使用します。 domain はサービス ルーティング ドメイン名です。 alternate は要求のルーティング先です。次の例では、srfqdn.cisco.com がサービス ルーティング ドメイン名、www.cisco.com が代替ドメイン名です。

SR(config)# service-router ?
lastresort Configure lastresort domain
leastloaded Enable Load Based Routing
location-based-routing Configure location based routing
SR(config)# service-router lastresort ?
domain Configure domain
SR(config)# service-router lastresort domain srfqdn.cisco.com ?
alternate Configure alternate domain
SR(config)# service-router lastresort domain srfqdn.cisco.com alternate ?
WORD Configure alternate domain name
SR(config)# service-router lastresort domain srfqdn.cisco.com alternate www.cisco.com ?
<cr>
SE(config)# service-router lastresort domain srfqdn.cisco.com alternate www.cisco.com

その他の CLI コマンド

ここでは、その他の便利な CLI コマンドを紹介します。

cdnfs cleanup

CDS ネットワーク ファイル システム(cdnfs)を管理するには、 cdnfs EXEC コマンドを使用します。

cdnfs {browse | cleanup {info | start | stop} | delete-unused-ecdnfs-files

デフォルトの動作または値はありません。

browse

cdnfs ディレクトリおよびファイルを参照します。

cleanup

cdnfs の不要なエントリをクリーンアップします。

info

クリーンアップ プロセスを開始しないで、不要なエントリに関する情報を要約します。

start

cdnfs の不要エントリのクリーンアップを開始します。

stop

cdnfs の不要エントリのクリーンアップを中止します。

cdnfs cleanup コマンドは、EXEC コマンドです。

CDS ネットワーク ファイル システム(cdnfs)は、サポート対象のあらゆるプロトコルに基づいて、事前取得した CDS ネットワーク コンテンツを保管します。cdnfs cleanup コマンドは、取得配布データベースから削除されたチャネルのコンテンツをクリーンアップします。状況によって、削除された配信サービスについて、Centralized System(CMS)からContent Acquirerに通知がなく、Content Acquirer がすべての unified name space(UNS; 統合名前空間)を消去できない場合があります。このような場合、cdnfs cleanup EXEC コマンドを使用すると、削除された配信サービスに対応付けられたすべての UNS コンテンツをクリーンアップできます。


cdnfs cleanup start を使用すると、孤立コンテンツをクリーンアップできます。孤立コンテンツとは、Service Engineが加入しているどの配信サービスにも対応付けられていないコンテンツです。


cdnfs browse コマンドは、対話型のコマンドであり、次のコマンドを使用して、CDS ネットワーク ファイルおよびディレクトリを表示できます。

SE# cdnfs browse
------ CDNFS interactive browsing ------
dir, ls: list directory contents
cd,chdir: change current working directory
info: display attributes of a file
more: page through a file
cat: display a file
exit,quit: quit CDNFS browse shell
 

cdnfs cleanup コマンドは、取得および配布データベースの状態を cdnfs に保管されているコンテンツと同期させます。このコマンドは、故障したディスク ドライブの交換後に使用してください。

disk コマンド

EXEC モードで disk コマンドを使用すると、ディスク設定およびメンテナンス コマンドを実行できます。

disk mark diskname {bad | good}

disk recover-system-volumes

disk reformat diskname

disk unuse diskname

 

mark

ディスク ドライブを good(良好)または bad(不良)としてマーキングします。

diskname

追加するディスクの名前(disk01、disk02、以下同様)

recover-system-volumes

システム ディスクを回復します。

reformat

SCSI、IDE、または SATA ディスクの低レベル フォーマットを実行し、ディスク エラーを再マッピングします。

diskname

追加するディスクの名前(disk01、disk02、以下同様)

unuse

ディスク ドライブの使用をアプリケーションに中止させます。

diskname

追加するディスクの名前(disk01、disk02、以下同様)

disk コマンドは、EXEC コマンドです。

disk reformat diskname EXEC コマンドは、SCSI、IDE、または SATA ディスクの低レベル フォーマットを実行します。このコマンドによって、ディスク上のすべてのコンテンツが消去されます。

disk reformat コマンドの実行後も、ディスク ドライブが引き続き障害を報告する場合は、ディスク ドライブの交換が必要です。


注意 disk reformat diskname コマンドによって、指定されたディスクのすべてのコンテンツが削除されることになるので、十分注意して使用する必要があります。

disk unuse コマンドは、指定されたディスク ドライブ(disk02 [/local/local2]、disk03 など)を使用中のすべてのアプリケーションを停止して再起動し、指定されたディスク上のすべてのパーティションをアンマウントして削除します。このコマンドを使用すると、すべてのファイル システムがアンマウントされます。


) ディスクの交換については、「ディスクのメンテナンス」を参照してください。


cache content

CDS ネットワーク ファイル システム(cdnfs)のキャッシュ エントリ数を設定するには、cache content グローバル コンフィギュレーション コマンドを使用します。

cache content max-cached-entries 1-5000000

 

content

cdnfs ディレクトリおよびファイルを参照します。

max-cached-entries

cdnfs の不要なエントリをクリーンアップします。

1-5000000

クリーンアップ プロセスを開始しないで、不要なエントリに関する情報を要約します。

最大キャッシュ エントリは、デフォルトで 3000000 に設定されます。

CDS では、CDNFS で使用可能なスペースに関係なく、デフォルトで最大 300 万のキャッシュ エントリが認められます。このコマンドは、CDS の最大コンテンツ数を制限する場合に使用します。