Cisco Cable Modem Termination System (CMTS) の概要
Cisco CMTS の DOCSIS 1.1
Cisco CMTS の DOCSIS 1.1
発行日;2012/02/03 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

Cisco CMTS の DOCSIS 1.1

内容

DOCSIS 1.1 動作の前提条件

DOCSIS 1.1 動作の制限事項

DOCSIS 1.1 の概要

機能の概要

BPI+

連結

ダイナミック MAC メッセージ

拡張 QoS

フラグメンテーション

相互運用性

PHS

DOCSIS 1.1 QoS

サービス フロー

サービス クラス

パケット クラシファイア

PHS ルール

QoS の比較

利点

Cisco CMTS での DOCSIS 1.1 動作の設定方法

BPI の設定(任意)

前提条件

DOCSIS ルート認証の CMTS へのダウンロード(必須)

信頼のおける認証としての製造元認証の追加(任意)

CLI を使用して信頼できる認証としての認証を追加する

SNMP を使用して信頼できる認証としての認証を追加する

ホットリストへの製造元または CM 認証の追加(必須)

CLI を使用してホットリストに認証を追加する

SNMP コマンドを使用してホットリストに認証を追加する

連結のイネーブル化(任意)

DOCSIS フラグメンテーションのイネーブル化(任意)

DOCSIS 1.0 ケーブル モデムに対する ERBA サポートの使用

DOCSIS 1.0 ケーブル モデムのダウンストリーム ERBA の設定

PRE2 モジュールを搭載した Cisco uBR10012 ルータでの DOCSIS 1.1 最大ダウンストリーム伝送バーストのイネーブル化

DOCSIS 動作のモニタリング

DOCSIS ネットワークのモニタリング

ケーブル モデムのステータスの表示

ケーブル モデムのサマリー レポートの表示

ケーブル モデムの機能の表示

特定のケーブル モデムの詳細情報の表示

RF ネットワークおよびケーブル インターフェイスのモニタリング

MAC スケジューラに関する情報の表示

QoS パラメータ セットに関する情報の表示

サービス フローに関する情報の表示

SID に関する情報の表示

BPI+ 動作のモニタリング

ケーブル モデムの現在の BPI+ ステートの表示

CMTS の BPI+ タイマー値の表示

CMTS の認証リストの表示

コマンドの要約

DOCSIS 1.1 動作の設定例

Cisco uBR7246 VXR ルータ用の DOCSIS 1.1 コンフィギュレーション(BPI+ の設定なし)

Cisco uBR7246 VXR ルータ用の DOCSIS 1.1 コンフィギュレーション(BPI+ を設定)

Cisco uBR10012 ルータ用の DOCSIS 1.1 コンフィギュレーション(BPI+ を設定)

参考資料

関連資料

標準規格

MIB

RFC

テクニカル サポート

Cisco CMTS の DOCSIS 1.1

改訂: February 5, 2007, OL-1467-08-J

ここでは、Data-over-Cable Service Interface Specifications(DOCSIS; データオーバーケーブル サービス インターフェイス仕様)1.1 動作に対する Cisco Cable Modem Termination System(CMTS; ケーブル モデム終端システム)ルータの設定方法について説明します。

DOCSIS 1.1 動作の機能仕様

 

機能履歴
リリース
変更

12.1(4)CX

DOCSIS 1.1 サポートが Cisco uBR7200 シリーズ ルータ用に導入されました。

12.1(7)CX1

DOCSIS 1.1 仕様の変更を反映して、複数の DOCSIS 1.1 MIB が更新されました。DOCS-SUBMGT-MIB のアトリビュートのデフォルト値を設定するための cable submgmt default コマンドも追加されました。

12.2(4)XF1
12.2(4)BC1

Release12.2 BC トレインの Cisco uBR7100 シリーズ、Cisco uBR7200 シリーズ、および Cisco uBR10012 ルータ用に、DOCSIS 1.1 サポートが導入されました。

12.2(4)BC1b

DOCSIS 1.1 動作における N+1 冗長性が Cisco uBR10012 ルータでサポートされました。

12.2(8)BC2

show cable modem mac コマンドが、DOCSIS の機能および各ケーブル モデムのプロビジョニング ステートを表示するために強化されました。

12.2(11)BC1

DOCSIS 1.1 動作における N+1 冗長性が Cisco uBR7200 シリーズ ルータでサポートされました。

12.2(11)BC2

PacketCable 動作がイネーブルになった際に DOCSIS 1.1 ケーブル モデムが UGS サービス フローを使用できるようにするために、 packetcable authorize vanilla-docsis-mta コマンドがサポートされました。

12.3(13a)BC

次の新しいコンフィギュレーション コマンドを含め、show コマンドを強化するために、DOCSIS 1.0 ケーブル モデムに対する Enhanced Rate Bandwidth Allocation(ERBA)のサポートが追加されました。

cable qos pro max-ds-burst burst-size

show cable qos profile n [verbose]

「DOCSIS 1.0 ケーブル モデムに対する ERBA サポートの使用」を参照してください。

12.3(21)BC

Cisco uBR10012 ルータにおける ERBA の拡張バージョンのサポートが追加されました。「DOCSIS 1.0 ケーブル モデムに対する ERBA サポートの使用」を参照してください。

サポート対象プラットフォーム

Cisco uBR7100 シリーズ、Cisco uBR7200 シリーズ、Cisco uBR10012 ユニバーサル ブロードバンド ルータ

プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報

プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報を調べるには、Cisco Feature Navigator を使用します。Cisco Feature Navigator は、 http://www.cisco.com/go/fn からアクセスできます。Feature Navigator にアクセスするには、Cisco.com のアカウントが必要です。アカウントを登録していない場合、またはユーザ名とパスワードを忘れた場合には、ログイン ダイアログ ボックスで Cancel をクリックして表示される手順に従います。

DOCSIS 1.1 動作の前提条件

DOCSIS 1.1 動作をサポートするには、CMTS が Cisco IOS Release 12.1(4)BC1 以降の Cisco IOS 12.2 BC リリースを実行し、CM(ケーブル モデム)が DOCSIS 1.1 フィーチャ セットをサポートする必要があります。さらに、Cisco CMTS の電源を投入して設定する前に、以下の点をチェックしてください。

使用するネットワークが信頼性の高いブロードバンド データ伝送をサポートしていることを確認します。NTSC または該当する国際ケーブル プラント勧告に従って、プラントを点検し、バランスを調整し、認定を受ける必要があります。プラントがすべての DOCSIS ダウンストリームおよびアップストリーム RF 要件を満たしているかを確認します。

Cisco CMTS が適切な「ハードウェア インストレーション ガイド」の指示に従って設置されているかを確認します。シャーシには、少なくともバックボーン接続をサポートする 1 つのポート アダプタと、RF ケーブル TV インターフェイスとして動作する 1 つの Cisco ケーブル ライン カードが搭載されている必要があります。

必要なヘッドエンドまたは分散ハブ ルーティングおよびネットワーク インターフェイス機器がすべて(サポートするサービスに基づいて)設置され、設定され、運用できるようになっているかを確認します。これには、すべてのルータ、サーバ(DHCP、TFTP、ToD)、ネットワーク管理システム、および他の設定または課金システムが含まれます。また、ゲートキーパやゲートウェイを含む IP テレフォニー機器、Virtual Private Network(VPN; 仮想私設網)をサポートする場合のバックボーンやその他の機器、ダイヤルアップ アクセス サーバ、電話回線および接続、Telco リターンをサポートする場合のその他の機器なども含まれます。

Dynamic Host Configuration Protocol(DHCP)および DOCSIS のコンフィギュレーション ファイルが作成されて適切なサーバに適用され、各ケーブル モデムの初期化時に DHCP 要求を伝送し、IP アドレスを受信してTrivial File Transfer Protocol(TFTP; 簡易ファイル転送プロトコル)および Time-of-Day(ToD)サーバ アドレスを取得し、DOCSIS コンフィギュレーション ファイルをダウンロードできるようになっていることを確認します。さらに任意で、サーバが更新されたソフトウェア イメージを DOCSIS 1.0 および DOCSIS 1.1 ケーブル モデムにダウンロードできることを確認します。

Customer Premises Equipment(CPE; 顧客宅内機器)(ケーブル モデムまたはセットトップ ボックス、PC、電話、または FAX 機器)がネットワークおよびサービスの要件を満たしているかを確認します。

適切な周波数を割り当てるため、チャネル プランを理解します。ヘッドエンドまたは分散ハブに適用する場合、バンドルまたは VPN ソリューション セットの設定プランを検討します。VoIP サービスに H.323 を使用し、VoIP 対応のケーブル モデム コンフィギュレーション ファイルを設定する場合は、ダイヤル プランに関する情報が必要です。必要に応じて、パスワード、IP アドレス、サブネット マスク、およびデバイス名を取得してください。

Cisco CMTS と ToD サーバのシステム クロックが同期していることを確認します。同期していない場合、CM のクロックが Cisco CMTS のクロックと一致せず、Baseline Privacy Interface Plus(BPI+)動作に干渉する可能性があります。特に、CM のデジタル認証を適切に検査できなくなります。

これらの前提条件が満たされたら、Cisco CMTS の設定を開始します。最低限の作業として、Cisco CMTS にホスト名およびパスワードを設定し、ケーブル プラントおよびネットワーク バックボーン上で IP をサポートできるように Cisco CMTS を設定します。


注意 サービスクラスベースのプロビジョニングを使用することを計画している場合、ケーブル モデムが接続を試行する前にサービス クラスを Cisco CMTS で設定する必要があります。サービス クラスを設定するには、cable service class コマンドを使用します。

DOCSIS 1.1 動作の制限事項

DOCSIS 1.1 動作には、以下の制限事項があります。

BPI+ の要件

ケーブル モデムおよび CMTS の両方で BPI+ 暗号化および認証がサポートされ、イネーブルになっていなければなりません。さらに、ケーブル モデムには DOCSIS 1.1 および BPI+ 仕様に準拠するデジタル認証が含まれていなければなりません。

また、CMTS と ToD サーバのシステム クロックが同期していることを確認します。同期していない場合、CM のクロックが CMTS のクロックと一致せず、BPI+ 動作に干渉する可能性があります。特に、CM のデジタル認証を適切に検査できなくなります。


) CMTS と ToD サーバのシステム クロックが同期していることを確認します。同期していない場合、CM のクロックが CMTS のクロックと一致せず、BPI+ 動作に干渉する可能性があります。特に、CM のデジタル認証を適切に検査できなくなります。


BPI+ 暗号化マルチキャストが Cisco uBR10012 ルータでバンドルされているサブインターフェイスをサポートしない

現在の Cisco IOS リリースは、Cisco uBR10012 ルータ上のバンドルされているケーブル サブインターフェイスで BPI+ 暗号化マルチキャストをサポートしません。暗号化マルチキャストは、バンドルされているケーブル インターフェイスまたはバンドルされていないケーブル サブインターフェイスでサポートされていますが、サブインターフェイスが Cisco uBR10012 ルータでバンドルされている場合はサポートされません。この制限は、Cisco uBR7200 シリーズ ルータには適用されません。

BPI+ がハイ アベイラビリティ コンフィギュレーションでサポートされていない

現在の Cisco IOS リリースでは、インターフェイスが N+1(1:n)ハイ アベイラビリティまたは Remote Processor Redundancy Plus(RPR+)ハイ アベイラビリティ冗長性用にも設定されている場合、ケーブル インターフェイスで BPI+ 暗号化マルチキャストの使用をサポートしません。

さらに、BPI+ 暗号化が必要なケーブル インターフェイス コンフィギュレーションは、実行ケーブル インターフェイスと保護ケーブル インターフェイス間で自動的に同期しないので、実行ケーブル インターフェイスから保護ケーブル インターフェイスへスイッチオーバーしたあとに BPI+ は自動的にはサポートされません。これに対する次善策は、必要なコンフィギュレーションを使用して保護ケーブル インターフェイスを手動で設定することです。

ケーブル インターフェイス カード

DOCSIS 1.1 トラフィックは Cisco uBR-MC1XC および Cisco uBR-MC28C ケーブル インターフェイス ライン カードでサポートされています。Cisco uBR-MC11(FPGA)および Cisco uBR-MC16B ライン カードは DOCSIS 1.1 をサポートしません。

cable privacy hotlist CLI が Cisco uBR10012 ルータでサポートされない

cable privacy hotlist コマンドは、Cisco uBR10012 ルータでサポートされません。Cisco uBR10012 ルータのホットリストに製造元または CM の認証を追加するには、SNMP(簡易ネットワーク管理プロトコル)コマンドを使用して DOCS-BPI-PLUS-MIB に適切なアトリビュートを設定します。「SNMP コマンドを使用してホットリストに認証を追加する」を参照してください。

DOCSIS ルート認証

Cisco CMTS でサポートする DOCSIS ルート CA 認証は 1 つだけです。

最大バースト サイズ

これまで、無制限値を設定するために、最大連結バースト サイズ パラメータを 0 に設定していました。DOCSIS 1.1 環境では、このパラメータは非 0 値に設定する必要があり、また DOCSIS 1.0 ケーブル モデム用の最大値は 1522 バイトになります。

ケーブル モデムが最大連結バースト サイズを 0 に登録しようとすると、DOCSIS 1.1 CMTS はケーブル モデムがオンラインになることを拒否します。これにより、DOCSIS 1.0 ケーブル モデムが大容量のデータ パケットを送信することでアップストリームの音声トラフィックに干渉することを防げます。DOCSIS 1.0 がフラグメンテーションをサポートしていない場合、そのようなデータ パケットの伝送により音声トラフィックに不要なジッタが発生します。

さらに、DOCSIS 1.1 では最大送信バースト サイズを 1522 バイトまたは最大連結バースト サイズのどちらか大きい方に設定します。DOCSIS 1.0 ケーブル モデムに対して、最大連結バースト サイズを 1522 バイトを超える値に設定しないでください。


) この変更により、最大連結バースト サイズに 0 値を設定する DOCSIS コンフィギュレーション ファイルを変更する必要があります。フラグメンテーションがディセーブルでないかぎり、この制限は DOCSIS 1.1 ケーブル モデムには存在しません。


パフォーマンス

DOCSIS 1.0 ケーブル モデムには、非送信請求認可およびリアルタイム ポーリングなどの、拡張 DOCSIS 1.1 スケジューリング メカニズム用のスケジューリング パラメータを明示的に要求したり提供したりする能力がありません。同じアップストリーム チャネルの DOCSIS 1.1 ケーブル モデムは、拡張スケジューリング メカニズムを利用できます。また DOCSIS 1.1 CMTS は、DOCSIS 1.0 ケーブル モデムが同じアップストリーム チャネルにある場合でも、DOCSIS 1.1 ケーブル モデムからの音声トラフィックを適切にサポートできます。

プロビジョニング

DOCSIS 1.1 ケーブル モデム用の TFTP コンフィギュレーション ファイルのフォーマットおよび内容は、DOCSIS 1.0 ケーブル モデム用のファイルとは大きく異なります。DOCSIS 1.0 ケーブル モデム用の DOCSIS 1.0 スタイル コンフィギュレーション ファイル、および DOCSIS 1.1 ケーブル モデム用の DOCSIS 1.1 コンフィギュレーション ファイルを作成するには、デュアルモード コンフィギュレーション ファイル エディタを使用します。

登録

DOCSIS 1.1 CMTS は、DOCSIS 1.0 ケーブル モデムからの既存の登録 Type-Length-Value(TLV)パラメータと、DOCSIS 1.1 ケーブル モデムからの新しいタイプの TLV を処理する必要があります。DOCSIS 1.0 および DOCSIS 1.1 ケーブル モデムは、正常に同じ DOCSIS 1.1 CMTS に登録できます。

DOCSIS 1.1 ケーブル モデムは、明示的にサービス クラス パラメータを要求せずに、CMTS に静的に定義されるサービス クラスの間接的なリファレンスを作成するように設定できます。この登録要求が DOCSIS 1.1 CMTS で受信されると、登録応答で実際のサービス クラスのパラメータをエンコードして、ケーブル モデムからの DOCSIS 1.1 固有の登録確認応答 MAC メッセージを待機します。

DOCSIS 1.0 ケーブル モデムが DOCSIS 1.1 CMTS に登録する場合、登録要求では明示的に登録内のすべての非デフォルト サービスクラス パラメータが要求されます。間接サービス クラス リファレンスがないため、DOCSIS 1.1 TLV が不要で、ローカル登録確認応答待機状態を確立する必要がなくなります。

DOCSIS 1.1 CMTS が DOCSIS 1.0 ケーブル モデムから登録要求を受信すると、DOCSIS 1.0 スタイル登録応答で応答し、ケーブル モデムからの登録確認応答 MAC メッセージの送信を待機しません。

DOCSIS 1.1 の概要

「機能の概要」

「DOCSIS 1.1 QoS」

「利点」

機能の概要

DOCSIS 1.1 は、ケーブル ネットワーク用の初期 DOCSIS 1.0 規格における最初のメジャー リビジョンです。初期規格では、同軸ケーブル ネットワークでの高品質なデータ トラフィックを提供していましたが、音声やビデオなどのリアルタイム トラフィックに対する要望により、DOCSIS 仕様に大幅な変更が必要になりました。

DOCSIS 1.1 仕様では、DOCSIS 1.0 ネットワークに対して以下のような機能強化がなされました。

「BPI+」

「連結」

「ダイナミック MAC メッセージ」

「拡張 QoS」

「フラグメンテーション」

「相互運用性」

「PHS」

BPI+

DOCSIS 1.0 は、Baseline Privacy Interface(BPI)を採用していて、共有メディア ケーブル ネットワークでユーザ データのプライバシを保護し、ケーブル ネットワークにおける DOCSIS ベースのデータ トランスポート サービスで無許可のアクセスを防ぎます。BPI は、ケーブル モデムと CMTS 間の RF インターフェイス上のトラフィックを暗号化するもので、Authentication, Authorization, Accounting(AAA; 認証、許可、アカウンティング)機能も含まれています。

BPI は、Access Control List(ACL; アクセス制御リスト)、トンネル、フィルタリング、スプーフィングからの保護、および加入者による有効でない送信元 IP アドレスの使用を防ぐために RF サブネット上に送信元 IP フィルタリングを設定するコマンドをそれぞれサポートします。DOCSIS 1.1 は、BPI+ でこれらのセキュリティ機能を強化します。具体的な内容は次のとおりです。

X.509 デジタル認証は、セキュア ユーザ ID および認証を提供します。Cisco CMTS は、自己署名付き製造元認証と DOCSIS ルート CA 認証へ連鎖する認証の両方をサポートします。

鍵の暗号化では、ほとんどの機密アプリケーションに適した 168 ビット Triple DES(3DES)暗号化を使用します。

1024 ビット公開鍵と Pkcs#1 Version 2.0 暗号化

暗号化されたマルチキャスト ブロードキャストをサポートします。許可されたサービス フローのみが特定のマルチキャスト ブロードキャストを受信します。

セキュアなソフトウェア ダウンロードにより、サービス プロバイダーがケーブル モデムのソフトウェアをリモートでアップグレードでき、傍受、割り込み、変更の危険性がありません。


) BPI+ については、『DOCSIS Baseline Privacy Interface Plus Specification』(SP-BPI+-I08-020301)で説明されており、CableLabs DOCSIS Web サイト(http://www.cablemodem.com)から入手できます。


連結

連結により、ケーブル モデムが複数のアップストリーム パケットに対して単一のタイムスライス要求を作成し、アップストリームの単一大容量バーストですべてのパケットを送信することができます。連結は複数のアップストリーム パケットを 1 つの大きな MAC データ フレームの一部として送信できるので、ケーブル モデムは連結 MAC フレーム全体に対して 1 つのタイムスロット要求だけを作成すればよく、アップストリーム チャネルでのパケット伝送遅延を減らすことができます。これにより、TCP 確認応答パケットなどの、ごく小さなパケットを大量に送信した場合にアップストリーム帯域幅を無駄に消費することを防げます。

ダイナミック MAC メッセージ

ダイナミック サービス MAC メッセージにより、ケーブル モデムがサービス フローをオンデマンドでダイナミックに作成できます。これらのメッセージは、サービス フローを作成、削除、変更する高位レイヤ メッセージの DOCSIS リンク レイヤ バージョンです。

DOCSIS 1.1 ダイナミック サービス ステート マシンは以下のメッセージをサポートします。

Dynamic Service Add(DSA) ― このメッセージは、新しいサービス フローを作成するときに使用されます。

Dynamic Service Change(DSC) ― このメッセージは、既存のサービス フローのアトリビュートを変更するときに使用されます。

Dynamic Service Deletion(DSD) ― このメッセージは、既存のサービス フローを削除する時に使用されます。


) これらのメッセージは、まとめて DSX メッセージと呼ばれています。


拡張 QoS

DOCSIS 1.1 は、音声やビデオなどのリアルタイム トラフィックにプライオリティを与える拡張 Quality of Service(QoS; サービス品質)機能を提供します。

DOCSIS 1.0 QoS モデル(QoS プロファイルに関連した Service ID [SID; サービス ID])は、サービス フローおよびサービス クラス モデルに置き換わり、異なるタイプのトラフィックへの QoS パラメータの割り当てや、帯域幅の状態の変更に対する応答がより柔軟に実行できます。

ケーブル モデム単位で複数のサービス フローをサポートすることにより、単一のケーブル モデムがデータ、音声、およびビデオ トラフィックの組み合わせをサポートできるようになります。

単一方向サービス フローを使用して、ケーブル モデムごとにいずれかの方向における、よりきめ細かい QoS を提供します。

使用しているトラフィックとアプリケーションのタイプに応じて、アップストリーム サービス フローに次の QoS スケジューリング タイプのいずれかを割り当てられます。

Best-Effort(BE) ― 非保証 BE ベースで送信されるデータ トラフィックです。このタイプのサービス フローは、DOCSIS 1.0 ネットワークで使用する方式と類似しています。

Real-time Polling Service(rtPS) ― ユニキャストで可変サイズのパケットを一定間隔で作成する、ビデオなどのリアルタイムサービス フローです。

Non-real-time Polling Service(nrtPS) ― rtPS タイプと類似しており、ケーブル モデムが可変長のデータ バーストを要求する定期的な機会が保証されます。ただし、ネットワークでのトラフィック量と輻輳量に応じて CMTS がケーブル モデムのポーリング間隔を変えることができます。

Unsolicited Grant(UGS) ― 固定間隔で固定サイズのパケットを送信するという特徴のある、音声などの Constant Bit Rate(CBR; 固定ビット レート)または Committed Information Rate(CIR; 認定情報速度)トラフィックで、最小データ レートを保証します。

Unsolicited Grant with Activity Detection(USG-AD) ― UGS と rtPS を組み合わせたもので、(無音抑制を使用するような音声など)アクティブでない期間があるようなリアルタイム トラフィックに対応します。このサービス フローでは、アクティブの際に UGS 固定送信を行いますが、アクティブでない期間には rtPS ポーリングに切り替わって、未使用の帯域幅を無駄にしないようにします。

フラグメンテーション

DOCSIS フラグメンテーションにより、アップストリーム MAC スケジューラが大型のデータ要求を分割して UGS(音声スロット)間のスケジューリング ギャップに収まるようにします。これにより大型のデータ パケットが、音声やビデオなどのリアルタイム トラフィックに影響を与えないようにすることができます。

フラグメンテーションは、大容量のデータ送信によって USG スロットの送信が阻止されることにより発生するランタイム ジッタを減らすことができます。フラグメンテーションをディセーブルにすると、ランタイム ジッタが増加しますが、フラグメントされた MAC フレームのフラグメンテーション リアセンブリによるオーバーヘッドを減らすことができます。


) DOCSIS フラグメンテーションは、IP パケットのフラグメンテーションと混同しないでください。これは、パケットをより小さな Maximum Transmission Unit(MTU; 最大伝送ユニット)サイズのネットワーク セグメントに適合させるために実行するものです。DOCSIS フラグメンテーションはレイヤ 2 フラグメンテーションで、主に音声通話などのプライオリティが高いリアルタイム トラフィックを妨害せずにプライオリティの低いパケットを効率的に伝送することに主眼を置いています。IP フラグメンテーションはレイヤ 3 で実行され、主に異なる最大パケット サイズを使用するルータに対応するためのものです。


相互運用性

DOCSIS 1.1 ケーブル モデムは DOCSIS 1.0 および 1.0+ ケーブル モデムと同一ネットワーク内に共存できます。Cisco CMTS は、各ケーブル モデムに適したサービス レベルを提供します。

PHS

Payload Header Suppression(PHS; ペイロード ヘッダー抑制)を使用すると、アップストリームとダウンストリーム両方のトラフィック フローで反復または重複するパケット ヘッダーを抑制することによって、リンク レイヤの帯域幅を節約できます。PHS はサービス フロー単位でイネーブルまたはディセーブルにすることができ、各 サービス フローは抑制するヘッダー部を決定する PHS ルール セットを個別にサポートできます。これにより、各サービス フローおよび特定のタイプのアプリケーションに対して最も効率的な方法で PHS を確実に実行できます。

DOCSIS 1.1 QoS

DOCSIS 1.1 QoS フレームワークは、以下のものに基づいています。

サービス フロー ― DOCSIS リンクにおけるパケットの単一方向シーケンス。個別のサービス フローがアップストリームおよびダウンストリーム トラフィックで使用され、そのトラフィックの QoS パラメータを定義します。

サービス クラス ― そのサービス クラスに関連したサービス フローを割り当てられたケーブル モデムに対して、特定の QoS サービス階層を提供する、CMTS が保持する設定の集合です。

パケット クラシファイア ― パケットをクラシファイアが属するサービス フローに分類するために使用するパケット ヘッダー フィールド。CMTS は、パケットを適切なサービス フローと照合する際にパケット クラシファイアを使用します。

PHS ルール ― リンクで伝送する前にエンティティを送信することで抑制され、ヘッダー抑制フレーム伝送の受信後にエンティティを受信することで復元される、パケット ヘッダー フィールド。PHS は、伝送前に反復するパケット ヘッダーを削除することで、帯域幅効率を向上させます。

これらのコンポーネントの詳細については、次の各項を参照してください。

サービス フロー

DOCSIS 1.1 では、QoS の基本ユニットはサービス フローです。これは、ケーブル モデムと CMTS との間の RF インターフェイス上で送信されるパケットの単一方向シーケンスです。サービス フローは、レイテンシ、ジッタ、スループット保証などの QoS パラメータ セットを定義します。また、これらのパラメータはアップストリームおよびダウンストリーム トラフィック フローに対して個別に適用できます。これは、DOCSIS 1.0 ネットワークとの大きな違いで、1.0 では同一の QoS パラメータがダウンストリームおよびアップストリーム フローの両方に適用されます。


) DOCSIS 1.0 ネットワークでは、SID を使用して特定のフローに設定された QoS パラメータを識別します。DOCSIS 1.1 ネットワークでは、Service Flow ID(SFID; サービス フロー ID)を使用して特定のアップストリームまたはダウンストリームに割り当てられたサービス フローを識別します。DOCSIS 1.1 ネットワークでも引き続き SID という用語を使用していますが、アップストリーム サービス フローにのみ適用されます。


すべてのケーブル モデムで、アップストリームおよびダウンストリーム フローに対して個別の SFID を持つ、アップストリームおよびダウンストリーム方向のプライマリ サービス フローを設定します。プライマリ フローは、ケーブル モデムと CMTS との接続を維持します。これにより CMTS は MAC 管理メッセージを常にケーブル モデムに送信できます。

さらに、DOCSIS 1.1 ケーブル モデムは複数のセカンダリ サービス フローを設定できます。セカンダリ サービス フローは、(ケーブル モデムにダウンロードされる DOCSIS コンフィギュレーション ファイルに設定することで)固定的に作成することも、音声通話などのオンデマンド トラフィックのニーズに合うようにダイナミックに作成することもできます。固定サービス フローは使用されていなくても継続して有効ですが、ダイナミック サービス フローは必要なくなったときに削除されます。

どの時点でも、サービス フローは、いずれかのステート(プロビジョン [Provisioned]、許可 [Admitted]、アクティブ [Active])になっています。アクティブ フローのみが DOCSIS ネットワークでトラフィックを通過させることができます。すべてのサービス フローは SFID で識別されますが、許可およびアクティブ ステートのアップストリーム サービス フローには、さらにこれらに関連したレイヤ 2 SID があります。SID は、異なるサービス フローにタイム スロット スケジューリングを指定する際に MAC スケジューラが使用する識別子です。

サービス クラス

各サービス フローは、サービス クラスに関連付けられていて、特定のサービス クラスや、サービス フローの最大帯域幅やトラフィックのプライオリティなどの QoS 特性を定義します。サービス クラス アトリビュートは、事前設定された CMTS ローカル サービス クラス(クラスベース フロー)から継承されるか、またはケーブル モデムがダイナミックにサービス フローを要求して CMTS がそのサービス フローを作成する際に個別に指定できます。

DOCSIS 1.1 サービス クラスも、サービス フローの MAC レイヤ スケジューリング タイプを定義します。スケジューリング タイプは、ケーブル モデムが作成できるデータ バースト要求のタイプと、要求を実行する頻度を定義できます。サポートされるスケジューリング タイプは以下の通りです。

BE ― ケーブル モデムは帯域幅要求の作成で他のケーブル モデムと競合し、データを伝送する前に、CMTS によるこれらの要求の認可を待機しなければなりません。このタイプのサービス フローは、DOCSIS 1.0 ネットワークで使用する方式と類似しています。

rtPS ― ケーブル モデムは、他のケーブル モデムと競合せずに帯域幅要求を作成できる定期的なタイム スロットを与えられます。これにより、可変長のデータ バーストを持つリアルタイム伝送が可能になります。

nrtPS ― ケーブル モデムに、可変サイズのデータ バーストに対する帯域幅要求を定期的に作成する機会を提供します。このタイプのフローは rtPS タイプと類似しており、ケーブル モデムが可変長のデータ バーストを要求する定期的な機会を保証されます。ただし、ネットワークでのトラフィック量と輻輳量に応じて CMTS がケーブル モデムのポーリング間隔を変えることができます。

UGS ― ケーブル モデムは、保証最小データ レートと保証最大ジッタ レベルで固定データ バーストを伝送できます。このタイプのサービス フローは、Voice-over-IP(VoIP)通話などの、CIR が必要なトラフィックに適しています。

Unsolicited grant service with activity detection(UGS-AD) ― UGS タイプと類似していますが、(誰も話していないときの音声通話など)ケーブル モデムがサービス フローを使用していないときに CMTS がトラフィックをモニタする点が異なります。CMTS がサービス フローで無音状態を検出すると、CMTS は一時的にサービス フローを rtPS タイプに切り替えます。ケーブル モデムが再びフローを使用し始めると、CMTS はフローを UGS タイプに戻します。これにより、CMTS が VoIP 通話をより効率的にサポートできます。

各サービス フローは単一のサービス クラスを割り当てられますが、同じサービス クラスを複数のサービス フローに割り当てることもできます。また、ケーブル モデムに複数のサービス フローを割り当てることもできます。これにより、複数のトラフィック フロー が異なるサービス クラスを使用できるようになります。

パケット クラシファイア

DOCSIS 1.0 ネットワークでは、ケーブル モデムはすべてのトラフィックに対して QoS パラメータを 1 セットしか使用しないので、CMTS はパケットを該当するケーブル モデムへルーティングするだけでした。しかし DOCSIS 1.1 ネットワークでは、ケーブル モデムは複数のサービス フローを使用でき、各サービス フローに対して異なるサービス レベルを指定できます。アップストリームおよびダウンストリーム パケットに適切なサービス フローを迅速に割り当てるために、CMTS はパケット クラシファイアの概念を活用します。

各パケット クラシファイアは、送信元 MAC アドレス、宛先 IP アドレス、プロトコル タイプなどの、1 つまたは複数のパケット ヘッダー アトリビュートを指定します。またクラシファイアは、パケットが、この特定の組み合わせのヘッダーと一致した場合に使用するサービス フローを指定します。ダウンストリームおよびアップストリーム サービス フローにそれぞれ個別のクラシファイアを使用します。

CMTS がダウンストリームおよびアップストリーム パケットを受信すると、各パケットのヘッダーを各パケット クラシファイアと比較します。パケットとクラシファイアが一致した場合、CMTS が適切な SFID をパケットに割り当て、ケーブル モデムとの間でパケットをやりとりします。これにより、パケットには適切なサービス フローと適切な QoS パラメータが割り当てられます。

図7-1 に、パケット クラシファイアのマッピングを示します。

図7-1 MAC レイヤ内での分類

 

PHS ルール

多くのデータやリアルタイム アプリケーションがパケット ヘッダー フィールドに固定値を使用することもあるので、DOCSIS 1.1 では、セッション中にパケットのグループが伝送される際にパケット ヘッダーの重複部を抑制するための PHS をサポートしています。各サービス フローは抑制するヘッダー部を決定する PHS ルール セットを個別にサポートできます。

PHS が使用されている場合、送信 CMTS がサービス フローのすべてのパケットの指定されたヘッダーを抑制します。次に受信 CMTS は、最終宛先にパケットを転送する前に、欠落したヘッダーを復元します。

PHS を適切に使用すると、特に、VoIP トラフィックなど、他のプロトコルでカプセル化されたリアルタイム データなどの、パケット化による伝送の効率が増加します。

QoS の比較

このセクションでは、DOCSIS 1.0、DOCSIS 1.0+、および DOCSIS 1.1 ネットワークでの QoS の相違について要約します。


) Cisco IOS Release 12.1(4)CX 以降を実行している Cisco CMTS ルータは、DOCSIS 1.0、DOCSIS 1.0+ 拡張、または DOCSIS 1.1 を実行しているケーブル モデムとトランスペアレントに相互運用できます。ケーブル モデムがシステム初期化時に DOCSIS1.1 対応であることを示すと、Cisco CMTS ルータは DOCSIS 1.1 機能を使用します。ケーブル モデムが DOCSIS 1.1 に対応しておらず、DOCSIS 1.0+ QoS 拡張をサポートしている場合(たとえば Cisco IOS Release 12.1(1)T 以降のリリースを実行している Cisco uBR924 ケーブル アクセス ルータなど)、Cisco CMTS は自動的にダイナミック サービスに対するケーブル モデムの要求をサポートします。それ以外の場合、ケーブル モデムは DOCSIS 1.0 装置として扱われます。


DOCSIS 1.0

DOCSIS 1.0 は、ケーブル モデムにダウンロードされる DOCSIS コンフィギュレーション ファイルに事前プロビジョニングされている Class of Service(CoS; サービス クラス)に基づいたスタティック QoS モデルを使用します。CoS は双方向の QoS プロファイルで、アップストリームおよびダウンストリームの両方向に適用され、いずれかの方向のピーク レート制限、アップストリームの相対プライオリティなど、限定的な制御を行います。

DOCSIS 1.0 は、ネットワークで伝送可能なケーブル モデムを識別する SID の概念を定義します。DOCSIS 1.0 ネットワークでは、各ケーブル モデムが割り当てられる SID は、アップストリームおよびダウンストリームの両方向に対して 1 つだけで、ケーブル モデムと SID は 1 対 1 で対応していました。ケーブル モデムで発着信されるすべてのトラフィックはその特定の SID にマッピングされます。

通常、DOCSIS 1.0 ケーブル モデムには CoS が 1 つあり、すべてのトラフィックは同じように処理されます。つまり、ケーブル モデムのデータ トラフィックが進行中の音声通話の品質に支障を来す場合があります。しかし CMTS には、IP 優先 Type of Service(ToS; サービス タイプ)ビットに基づいて、ダウンストリーム トラフィックにプライオリティ付けを行う、限定的な機能しかありません。

たとえば、より高位の IP precedence ビットを使用する音声通話がより高位のキューイング プライオリティを得られます(しかし、帯域幅やサービス レートの保証はありません)。DOCSIS 1.0 ケーブル モデムでは、音声通話用に対して固定的に帯域幅を確保することにより、音声通話の品質を向上させることができますが、音声通話がない場合に帯域幅が無駄になります。

DOCSIS 1.0+

DOCSIS 1.0 ネットワークには音声通話などのリアルタイム トラフィックに対する処理に制限があるという声に応えて、シスコは DOCSIS 1.0+ 拡張を作成して、DOCSIS 1.1 で導入が予定されていた、より重要な QoS 拡張を提供しました。特に、DOCSIS 1.0+ 拡張は、DOCSIS リンクを介した基本 VoIP サービスを提供します。

Cisco DOCSIS 1.0+ 拡張には、以下の DOCSIS 1.1 機能が含まれています。

音声およびデータ フロー用に個別のサービス フローを作成する、ケーブル モデムごとの複数の SID。これにより、CMTS およびケーブル モデムは音声トラフィックにより高いプライオリティを与えることができ、データ トラフィックが音声通話の品質に影響しないようにすることができます。

ケーブル モデムから発信されるダイナミック MAC メッセージ ― DSA および DSD。これらのメッセージにより、ダイナミック SID をオンデマンドで作成または削除できるので、音声通話に必要な帯域幅を通話時に割り当てて、通話の終了時にその帯域幅を他での利用のために解放できます。

アップストリームでの UGS(CBR スケジューリング) ― これは、Cisco uBR925 ケーブル アクセス ルータなどの Integrated Telephony Cable Modem(ITCM)からの、アップストリーム VoIP パケットに高品質チャネルを提供するために役立ちます。

パケットの IP precedence 値に基づく、特定のケーブル モデムに個別のダウンストリーム レートを提供する機能。これは、レート シェーピングに対処するために、同じ ITCM に向かう音声信号とデータ トラフィックを分離するために役立ちます。

連結により、ケーブル モデムは、複数のパケットを 1 つの大型バーストで送信できるようになり、それぞれ個別の認可要求を作成する必要がなくなりました。


注意 すべての DOCSIS 1.0 拡張は、この拡張機能をサポートする(Cisco uBR924 ケーブル アクセス ルータなどの)ケーブル モデムおよび(Cisco uBR7200 シリーズ ユニバーサル ブロードバンド ルータなどの)CMTS を使用する場合のみ使用可能です。ケーブル モデムはダイナミック MAC メッセージを送信することで、この拡張の使用をアクティブにします。DOCSIS 1.0 ケーブル モデムに対しては、CMTS は引き続き DOCSIS 1.0 による処理を行います。

異なるバージョンの DOCSIS ネットワーク間の相互運用性

DOCSIS 1.1 ケーブル モデムには、従来の DOCSIS 1.0 および 1.0+ モデルに比べて機能が追加され、パフォーマンスも向上していますが、これら 3 種類のモデルは同じネットワーク内に共存できます。DOCSIS 1.0 および 1.0+ ケーブル モデムは DOCSIS 1.1 CMTS のパフォーマンスに悪影響を与えず、また DOCSIS 1.1 機能の動作に干渉しません。

表7-1 に、DOCSIS 1.1 CMTS と他のバージョンのケーブル モデムとの相互運用性を示します。

 

表7-1 DOCSIS 1.1 相互運用性

対象コンフィギュレーション
結果
DOCSIS 1.1 CMTS と DOCSIS 1.0 ケーブル モデム

DOCSIS 1.0 ケーブル モデムは、DOCSIS 1.0 の機能と能力を発揮できます。可能な場合 BPI がサポートされて、CMTS でイネーブルになります。

DOCSIS 1.1 CMTS と DOCSIS 1.0+ ケーブル モデム

DOCSIS 1.0+ ケーブル モデムは、基本 DOCSIS 1.0 サポートを受けます。可能な場合 BPI がサポートされて、CMTS でイネーブルになります。また、DOCSIS 1.0+ ケーブル モデムは、以下の DOCSIS 1.1 機能を発揮します。

ケーブル モデムごとの複数の SID

ケーブル モデムから発信されたダイナミック サービス MAC メッセージング

アップストリームにおける USG(CBR スケジューリング)

パケットの IP precedence 値に基づく、特定のケーブル モデムに対する個別のダウンストリーム レート

連結

DOCSIS 1.1 CMTS と DOCSIS 1.1 ケーブル モデム

DOCSIS 1.1 ケーブル モデムは、このマニュアルに記述されているすべての DOCSIS 1.1 機能を発揮します。可能な場合 BPI+ がサポートされて、CMTS でイネーブルになります。

利点

DOCSIS 1.1 には、ケーブル ネットワーク上のさまざまなタイプのトラフィック(音声、データ、ビデオ)に対して、高度で柔軟な QoS 機能を提供する豊富な機能群が含まれています。また、拡張されたセキュリティおよび認証機能もあります。

BPI+ 拡張

DOCSIS 1.1 の BPI+ には、パフォーマンスとシステム セキュリティを向上させる、MAC サブレイヤ内の拡張サービス群があります。デジタル認証は、各ケーブル モデムでのセキュアな認証が可能で、MAC および IP アドレス ベースの ID 盗難を防ぐことができます。高度な暗号化では、ケーブル モデムと CMTS との間にセキュア チャネルを提供し、セキュアなソフトウェア ダウンロードにより、サービス プロバイダーはソフトウェア コードの傍受、妨害、変更を恐れることなくケーブル モデムのソフトウェアをアップグレードできます。

ダイナミック サービス フロー

サービス フローをダイナミックに作成、変更、および削除できることにより、レイヤ 2 帯域幅リソースをオンデマンドで確保できます。現在 CMTS は、ケーブル モデムの登録時に行うリソースの静的プロビジョニングおよび予約とは異なり、音声通話やビデオ セッション中にケーブル モデムに対して特別な QoS をダイナミックに提供することができます。これにより、使用可能な帯域幅をより効率的に使用できます。

連結

ケーブル モデムは、複数のアップストリーム パケットを1つの大型 MAC データ フレームに連結して、パケットごとにタイム スロットを要求するのではなく、連結 MAC フレーム全体でタイムスロット要求を 1 つだけ作成するようにすることができます。これにより、パケット バースト アップストリームでの転送遅延が減ります。

拡張 QoS

幅広いスケジューリング パラメータにより、CMTS およびケーブル モデムは QoS 要件に関して通信を行い洗練された QoS をサービス フロー レベル単位で実行できます。

さまざまな新しいタイム スロット スケジューリングは、共有アップストリームでの遅延およびジッタの限界を保証するために役立ちます。アクティビティ検出は、非アクティブのサービス フロー用にタイム スロットを発行しないことで、リンク帯域幅の節約に役立ちます。節約された帯域幅は他のベスト エフォート型データ スロットに再利用できます。

パケット分類は、CMTS およびケーブル モデムが異なるタイプのトラフィックを異なる DOCSIS サービス フローに分離するために役立ちます。各フローは、CMTS から異なる QoS サービスを受け取れます。

フラグメンテーション

フラグメンテーションは、大型データ パケットを分割するので、UGS スロット間の小型のタイム スロットに適合させることができます。これは、大型のデータ パケットが共有アップストリーム チャネルで伝送されて音声用に使用される UGS スロットの送信を阻止することにより発生するジッタを低減します。

SID 単位の複数のサブフロー

この機能により、ケーブル モデムは単一ハードウェア キューで複数のコールを扱えます。この手法は、各音声通話用にケーブル モデムで個別の SID ハードウェア キューを必要とする場合に比べて拡張性が高くなります。

PHS

PHS により、CMTS およびケーブル モデムが DOCSIS リンクでパケットを伝送する前にパケットの反復する部分や重複部分を抑制できます。これは、特にヘッダー サイズが実際のパケットと同様の大きさになる場合もある音声のようなトラフィック タイプで、リンク帯域幅を節約します。

サービス クラス

サービス クラスを使用すると、DOCSIS 1.1 ネットワークでは次のような利点があります。

これにより、ケーブル事業者はサービス フローを設定する負担をプロビジョニング サーバから CMTS へ移動できます。ケーブル事業者は、サービス クラス名を持つモデムをプロビジョニングし、名前の実装は CMTS で設定されます。これによりケーブル事業者は、モデムのプロビジョニングを変更せずに、ローカル環境に対する特定のサービスの実装を変更できます。たとえば、同じサービスを提供するために、あるスケジューリング パラメータを 2 つの異なる CMTS に対して別々に設定する必要がある場合があります。他の例としては、サービス プロファイルを時間ごとに変更するような場合です。

これにより、サービス フローがクラス内で競合し、クラスが他のクラスと帯域幅を競合する場合に、CMTS ベンダーは必要に応じてクラスベースのキューイングを提供できます。

この場合、高位のレイヤ プロトコルがそのサービス クラス名でサービス フローを作成できます。たとえば、テレフォニー信号は、クラス G.711 の使用可能なプロビジョニングされたサービス フローをインスタンス化するようにケーブル モデムに指示します。


) サービス クラスは任意です。フロー スケジューリング仕様を常に完全に適用することもできますし、サービス フローをいかなるサービス クラスにも属さないようにすることもできます。CMTS 実装では、そのようなクラス化されていないフローを同じパラメータを持つクラス化されたフローと区別して取り扱うことができます


Cisco CMTS での DOCSIS 1.1 動作の設定方法

ここでは、DOCSIS 1.1 動作の設定作業について説明します。リストの作業ごとに、必須であるか任意であるかを指定しています。

「BPI の設定(任意)」

「DOCSIS ルート認証の CMTS へのダウンロード(必須)」

「信頼のおける認証としての製造元認証の追加(任意)」

「ホットリストへの製造元または CM 認証の追加(必須)」

「連結のイネーブル化(任意)」

「DOCSIS フラグメンテーションのイネーブル化(任意)」

「DOCSIS 1.0 ケーブル モデムに対する ERBA サポートの使用」


) ここでは、DOCSIS 1.1 動作に固有の設定作業についてのみ説明します。総合的な設定情報については、「参考資料」に記載されているソフトウェア コンフィギュレーション マニュアルを参照してください。


BPI の設定(任意)

BPI+ 暗号化では、デフォルトで 56 ビット DES 暗号化がすべてのケーブル インターフェイスでイネーブルです。BPI+ 暗号化がすでにディセーブルになっている場合、また CMTS のケーブル インターフェイスで BPI+ 暗号化を再設定したい場合、以下の手順を使用してください。


) ケーブル インターフェイスで BPI+ 暗号化がディセーブルで、ケーブル モデムが BPI+ 暗号化でそのインターフェイスに登録しようとした場合、CMTS は登録要求を拒否して
%UBR7200-4-SERVICE_PERMANENTLY_UNAVAILABLE エラー メッセージを表示します。また show cable modem コマンドも、このケーブル モデムが [reject(c)] MAC ステータスで拒否されたことを示します。


前提条件

BPI+ 暗号化は、ファイル名に「k1」、「k8」、または「k9」が含まれているか、フィーチャ セットの記述に BPI が含まれているすべての Cisco CMTS イメージでサポートされています。すべての BPI イメージは、40 ビットおよび 56 ビット DES 暗号化をサポートしています。

BPI+ 暗号化ではデフォルトで 56 ビット DES 暗号化がイネーブルです。また、ケーブル モデムが DOCSIS 1.1 ソフトウェアを実行中の場合、DOCSIS コンフィギュレーション ファイルのプライバシ イネーブル フィールド(TLV 29)を 0 に設定することでサービス プロバイダーが BPI+ 暗号化をディセーブルにしていないかぎり、BPI+ 暗号化はデフォルトでイネーブルです。すなわち、デフォルト設定を使用する場合、CMTS とケーブル モデムの両方で BPI+ を使用するように設定されます。

ステップの概略

1. enable

2. configure terminal

3. interface cable x/y

4. cable privacy

5. cable privacy 40-bit-des

6. cable privacy accept-self-signed-certificate


注意 このコマンドは DOCSIS BPI+ 認証をバイパスするので、未設定のままにしておくことを強く推奨します。未設定のままにしておかない場合、自己署名証明書によりケーブル モデムにワークアラウンド登録が行われますが、DOCSIS BPI+ 認証には準拠しません。この機能は、短期間のトラブルシューティング用または追加のセキュリティ対策のためにすぎません。

7. cable privacy authenticate-modem

8. cable privacy authorize-multicast

9. cable privacy mandatory

10. cable privacy oaep-support

11. cable privacy kek { grace-time seconds | life-time seconds }

12. cable privacy tek { grace-time seconds | life-time seconds }

13. exit

14. exit

ステップの詳細

 

コマンド
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface cable x/y

 

Router(config)# interface cable 6/0

Router(config-if)#

この特定のスロットにあるケーブル インターフェイス ライン カードに対してインターフェイス コンフィギュレーション モードを開始します。

ステップ 4

cable privacy

 

Router(config-if)# cable privacy

Router(config-if)#

(任意)このケーブル インターフェイスで 56 ビット DES 暗号化をイネーブルにします(デフォルト)。

ステップ 5

cable privacy 40-bit-des

 

Router(config-if)# cable privacy 48-bit-des

Router(config-if)#

(任意)ケーブル インターフェイスで 40 ビット DES 暗号化をイネーブルにします。40 ビット暗号化は 56 ビット DES または 168 ビット 3DES 暗号化アルゴリズムほど安全ではないので、シスコでは実稼働システムでこのオプションは推奨しません。

ステップ 6

cable privacy accept-self-signed-certificate

 

Router(config-if)# cable privacy accept-self-signed-certificate

Router(config-if)#

(任意)DOCSIS ルート認証と連鎖している製造元認証のみが使用可能なデフォルト設定に対して、ケーブル モデムが製造元自己署名付き認証を使用して登録できます。


注意 このコマンドは DOCSIS BPI+ 認証をバイパスするので、未設定のままにしておくことを強く推奨します。未設定のままにしておかない場合、自己署名証明書によりケーブル モデムにワークアラウンド登録が行われますが、
DOCSIS BPI+ 認証には準拠しません。この機能は、短期間のトラブルシューティング用または追加のセキュリティ対策のためにすぎません。

) デフォルトでは、CMTS は自己署名付き認証を受け付けません。デフォルト コンフィギュレーションでは、ケーブル モデムが自己署名付き認証で登録しようとすると、ケーブル モデムの登録を CMTS が拒否します。


ステップ 7

cable privacy authenticate-modem

 

Router(config-if)# cable privacy authenticate-modem

Router(config-if)#

(任意)ケーブル インターフェイスで BPI+ 暗号化をイネーブルにして、Cisco AAA サービスを BPI とともに使用して CM を認証します。

ステップ 8

cable privacy authorize-multicast

 

Router(config-if)# cable privacy authorize-multicast

Router(config-if)#

(任意)ケーブル インターフェイスで BPI+ 暗号化をイネーブルにして、AAA プロトコルを使用してすべてのマルチキャスト ストリーム(IGMP)加入要求を認証します。


) このコマンドを使用してマルチキャスト スト
リームを許可するには、cable privacy
authenticate-modem
コマンドを使用してケーブル インターフェイスで AAA サービスをイネーブルにする必要があります。


ステップ 9

cable privacy mandatory

 

Router(config-if)# cable privacy mandatory

Router(config-if)#

(任意)ケーブル インターフェイスで BPI+ 暗号化機能をイネーブルにして、すべての CM にベースライン プライバシを要求します。CM が DOCSIS コンフィギュレーション ファイルで BPI または BPI+ 暗号化をイネーブルにしない場合、CM はオンラインになれません。

ステップ 10

cable privacy oaep-support

 

Router(config-if)# cable privacy oaep-support

Router(config-if)#

(任意)ケーブル インターフェイスで BPI+ 暗号化機能をイネーブルにして、Optimal Asymmetric Encryption Padding(OAEP)をイネーブルにします。このオプションは、デフォルトでイネーブルです。このオプションをディセーブルにすると、パフォーマンスに影響します。

ステップ 11

cable privacy kek { grace-time seconds | life-time seconds }

 

Router(config-if)# cable privacy kek grace-time 480

Router(config-if)# cable privacy kek life-time 302400

Router(config-if)#

(任意)すべてのケーブル インターフェイスでの BPI+ 動作用の Key Encryption Key(KEK; 鍵暗号化鍵)に対する猶予時間および存続時間値を設定します。

grace-time seconds 1 ― (DOCSIS 1.0 BPI のみ)KEK 鍵の有効期限が切れて CM が新しい鍵の再ネゴシエートを開始するまでの時間。有効な範囲は 60 ~ 1800 秒で、デフォルト値は 600 秒(10 分)です。

life-time seconds ― KEK 鍵が有効になっている最大時間数(秒)。有効な範囲は 300 ~ 604,800 で、デフォルト値は 604,800 秒(7 日)です。

ステップ 12

cable privacy tek { grace-time seconds | life-time seconds }

 

Router(config-if)# cable privacy tek grace-time 1800

Router(config-if)# cable privacy tek life-time 86400

Router(config-if)#

(任意)すべてのケーブル インターフェイスでの BPI+ 動作用の Traffic Encryption Key(TEK; トラフィック暗号化鍵)に対する猶予時間および存続時間値を設定します。

grace-time seconds 1 ― (DOCSIS 1.0 BPI のみ)TEK 鍵の有効期限が切れて CM が新しい鍵の再ネゴシエートを開始するまでの時間。有効な範囲は 60 ~ 1800 秒で、デフォルト値は 600 秒(10 分)です。

life-time seconds ― KEK 鍵が有効になっている最大時間数(秒)。有効な範囲は 180 ~ 604,800 で、デフォルト値は 43,200 秒(12 時間)です。

ステップ 13

exit

 

Router(config-if)# exit

Router(config)#

インターフェイス コンフィギュレーション モードを終了します。


) 各ケーブル インターフェイスで ステップ 3ステップ 13 を繰り返します。


ステップ 14

exit

 

Router(config)# exit

Router#

グローバル コンフィギュレーション モードを終了します。

1.KEK および TEK 猶予時間値は、BPI 暗号化を使用する DOCSIS 1.0 ケーブル モデムのみに適用します。DOCSIS 1.1 ソフトウェアを実行しているケーブル モデムは、DOCSIS コンフィギュレーション ファイルに猶予時間値を設定して、それらの値は自動的に CMTS 設定を上書きします。DOCSIS 1.1 コンフィギュレーション ファイルが特に猶予時間値を含んでいない場合、ケーブル モデムはデフォルトの 600 秒に設定され、CMTS がこの値をモデムに対して使用します。

また、各ケーブル モデムの DOCSIS コンフィギュレーション ファイルに BPI+ 動作用の以下の追加タイマーを設定できます。一般的なルールとして、デフォルト値を変更する特別な理由がないかぎり、これらのタイマーを DOCSIS コンフィギュレーション ファイルに指定する必要はありません。

 

表7-2 個々のケーブル モデム BPI+ タイマー値

タイマー
説明

許可待機タイムアウト

KEK を最初にネゴシエートする際に、ケーブル モデムが CMTS からの応答を待機する時間

再許可待機タイムアウト

許可鍵(KEK)の存続時間がほぼ満了しているために新しいKEKをネゴシエートする際に、ケーブル モデムが CMTS からの応答を待機する時間

許可猶予タイムアウト

再許可の猶予期間(秒)

許可拒否待機タイムアウト

KEK の最初のネゴシエーションを CMTS が拒否した場合、新しいKEKをネゴシエートする前に、ケーブル モデムが待機しなければならない時間

動作待機タイムアウト

TEK を最初にネゴシエートする際に、ケーブル モデムが CMTS からの応答を待機する時間

再鍵待機タイムアウト

TEK の存続時間がほぼ満了しているために新しい TEK をネゴシエートする際に、ケーブル モデムが CMTS からの応答を待機する時間

DOCSIS ルート認証の CMTS へのダウンロード(必須)

DOCSIS 1.1 により、ケーブル モデムは DOCSIS ルート認証に連鎖している製造元の連鎖 X.509 デジタル認証を使用してモデム自体を識別できます。DOCSIS ネットワークでこれらのデジタル認証の使用をイネーブルにするには、Verisign の Web サイトから DOCSIS ルート認証をダウンロードして Cisco CMTS ルータのブートフラッシュにコピーする必要があります。


ヒント Verisign から提供される DOCSIS ルート認証に関する詳細については、次の URL にある情報を参照してください。

http://www.verisign.com/products/cable/index.html



) このマニュアルでは以前、Cisco CMTS がサポートするルート認証は 1 つだけであるとしていました。この情報は、Cisco IOS Release 12.3(9a)BC に対応して変更されました。12.3 BC トレインのこの IOS リリース以降のリリースでは、DOCSIS ルート認証と EuroDOCSIS または PacketCable ルート認証をロードできます。EuroDOCSIS PacketCable ルート認証をブートフラッシュにコピーすることを推奨します。

ただし、従来の Cisco IOS Release では、EuroDOCSIS または PacketCable 装置は自己署名付き製造元デジタル認証を使用している場合に、オンラインになると制限されていました。


ネットワークのケーブル モデムが連鎖認証を使用している場合に必要となる DOCSIS ルート認証を、Cisco CMTS にダウンロードするには、以下の手順に従います。


ステップ 1 DOCSIS 認証の署名者である Verisign から DOCSIS ルート認証をダウンロードします。このマニュアルを発行した時点では、DOCSIS ルート認証は以下の URL からダウンロードすることができます。

http://www.verisign.com/products/cable/root.html

ステップ 2 Verisign は、圧縮 Zip アーカイブ ファイルで DOCSIS ルート認証を配布しています。アーカイブから DOCSIS ルート認証を解凍して CMTS がアクセスできる TFTP サーバにコピーします。


ヒント 他の認証との混同を避けるために、TFTP サーバに保存する際に、「CableLabs_DOCSIS.509」 という名のファイル名をそのまま使用します。

ステップ 3 シリアル ポート接続または Telnet 接続のいずれかを使用して Cisco CMTS にログインします。 enable コマンドとパスワードを入力して特権 EXEC モードを開始します。

Router> enable
 
Password: <password>
 
Router#
 

ステップ 4 dir bootflash コマンドを使用してブートフラッシュに DOCSIS ルート認証用の十分な空き容量(約 1,000 バイトのディスク容量)があることを確認します。

Router# dir bootflash:
 
Directory of bootflash:/
 
1 -rw- 3229188 Dec 30 2002 15:53:23 ubr7200-boot-mz.122-11.BC2.bin
 
3407872 bytes total (250824 bytes free)
Router#
 

ヒント DOCSIS ルート認証用のスペースを確保するためにブートフラッシュからファイルを削除する場合、削除ファイルからの空きスペースを再利用するために squeeze コマンドを使用することを忘れないでください。

ステップ 5 copy tftp bootflash コマンドを使用して、DOCSIS ルート認証をルータのブートフラッシュ メモリにコピーします(ルート認証として認識するために、ファイル名は CMTS のブートフラッシュで [root-cert] とします)。

Router# copy tftp bootflash:
 
Address or name of remote host []? tftp-server-ip-address
Source filename []? CableLabs_DOCSIS.509
Destination filename [CableLabs_DOCSIS.509]? root-cert
Loading CableLabs_DOCSIS.509 from tftp-server-ip-address (via FastEthernet0/0): !
[OK - 996/1024 bytes]
 
996 bytes copied in 4.104 secs (249 bytes/sec)
Router#
 

ヒント Cisco IOS Release 12.2(4)BC1 以降のソフトウェア リリースを使用している場合、ルート認証を PCMCIA フラッシュ ディスク(disk0 または disk1)にもコピーできます。ただし、フラッシュ ディスクにはセキュリティがなくルータから簡単に取り外せるため、動作上およびセキュリティ上の理由からブートフラッシュのルート認証を保持しておくことを推奨します。

ステップ 6 DOCSIS ルート認証が正常にブートフラッシュ メモリにコピーされたことを確認します。

Router# dir bootflash:
 
Directory of bootflash:/
 
1 -rw- 3229188 Dec 30 2002 15:53:23 ubr7200-boot-mz.122-11.BC2.bin
2 -rw- 996 Mar 06 2002 16:03:46 root-cert
 
3408876 bytes total (248696 zxbytes free)
Router#
 

ステップ 7 (任意)最初のケーブル モデムが BPI+ を使用して登録したあと、 show crypto ca trustpoints コマンドを使用して CMTS が学習したルート認証を表示します。


) 少なくとも 1 つのケーブル モデムが BPI+ 暗号化を使用して CMTS に登録するまで、show crypto ca trustpointsコマンドは、ルート認証を表示しません。あるいは、特権 EXEC モードでサポートされていない test cable generate コマンドを使用して強制的に CMTS にルート認証を登録させることもできます。


Router# show crypto ca trustpoints
 
Root certificate
Status: Available
Certificate Serial Number: D54BB68FE934324F6B8FD0E41A65D867
Key Usage: General Purpose
Issuer:
CN = DOCSIS Cable Modem Root Certificate Authority
OU = Cable Modems
O = Data Over Cable Service Interface Specifications
C = US
Subject Name:
CN = "BPI Cable Modem Root Certificate Authority "
OU = DOCSIS
O = BPI
C = US
Validity Date:
start date: 07:00:00 UTC Mar 27 2001
end date: 06:59:59 UTC Jan 1 2007
 


 


ヒント CMTS を学習したすべての認証(ルート、製造元、CM)を表示するには、show crypto ca certificates コマンドを使用します。


信頼のおける認証としての製造元認証の追加(任意)

DOCSIS 仕様では、オペレータは信頼できるか信頼できないかをマークすることによって、どの製造元および CM 認証が各 CMTS で許可されるのかを制御できます。CLI(コマンドライン インターフェイス)コマンドまたは SNMP コマンドを使用して、Cisco CMTS の信頼される認証のリストに認証を追加できます。詳細については、以下の各項で説明します。

「CLI を使用して信頼できる認証としての認証を追加する」

「SNMP を使用して信頼できる認証としての認証を追加する」


) SNMP をケーブル モデムの設定に使用できない場合、または認証を追加する際に CLI を使用する必要のある特定のアプリケーションがあるような場合を除き、SNMP 方式を使用してケーブル モデムに認証を追加します。


CLI を使用して信頼できる認証としての認証を追加する

CMTS の信頼できる認証リストに製造元認証を追加するには、次の手順に従います。

ステップの概略

1. enable

2. configure terminal

3. cable privacy add-certificate manufacturer hex-data

4. exit

ステップの詳細

 

コマンド
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

cable privacy add-certificate manufacturer hex-data

 

Router(config)# cable privacy add-certificate manufacturer 0001020304050CFD0E0F0A01EB02BC0304

0F019E020D230C04CD050B060A07080AF102E30405

 

Router(config)#

(任意)信頼できる認証として追加するために、製造元 CA 認証の 16 進数データを指定します。 hex-data ストリングに実際の認証内容を 16 進数データで入力します。必要に応じて複数の行を入力し、ストリングの終わりに空白行を使用します。

ステップ 4

exit

 

Router(config)# exit

Router#

グローバル コンフィギュレーション モードを終了します。

SNMP を使用して信頼できる認証としての認証を追加する

SNMP マネージャを使用して認証を作成し、 DOCS-BPI-PLUS-MIB 内のテーブルおよびアトリビュートを操作して認証を信頼できる認証の CMTS リストに追加できます。製造元認証を追加するには、docsBpi2CmtsCACertTable テーブルにエントリを追加します。各エントリの以下のアトリビュートを指定します。

docsBpi2CmtsCACertStatusSet ― 4 に設定してロー エントリを作成します。

docsBpi2CmtsCACert ― 実際の X.509 認証用の X509 Certificate の値としての 16 進数データ

docsBpi2CmtsCACertTrust ― 認証の信頼状態を指定する 1 ~ 4 の整数値。(1 = 信頼、2 = 信頼しない、3 = 連鎖、4 = ルート)。1 を指定すると認証が信頼され、3 の場合は連鎖認証であってルート認証により検証されます。

同様に、CM 認証を信頼認証リストに追加し、docsBpi2CmtsProvisionedCmCertTable テーブルにエントリを追加します。各エントリの以下のアトリビュートを指定します。

docsBpi2CmtsProvisionedCmCertStatusSet ― 4 に設定してロー エントリを作成します。

docsBpi2CmtsProvisionedCmCert ― 実際の X.509 認証用の X509 Certificate の値としての 16 進数データ

docsBpi2CmtsProvisionedCmCertTrust ― 認証の信頼状態を指定する 1 ~ 2 の整数値。(1 = 信頼、2 = 信頼しない)。信頼される CM 認証に 1 を指定します。


ヒント 常に、実際の認証データをロードする前に CertStatus アトリビュートを設定してください。設定しない場合、CMTS は認証が連鎖しているとみなして即座に製造元およびルート認証で確認しようとします。


たとえば、UNIX コマンド ライン SNMP ユーティリティを使用して製造元認証を IP アドレス 192.168.100.134 にある CMTS の信頼される認証リストに追加するには、以下のコマンドを入力します( <index> 値の代わりにテーブル エントリの有効なインデックス ポインタを使用してください)。

% setany -v2c 192.168.100.134 private docsBpi2CmtsCACertStatus.<index> -i 4 docsBpi2CmtsCACert.<index> -o '<hex_data>' docsBpi2CmtsCACertTrust.<index> -i 1
 

CM 認証に対して同様の処理を実行するには、以下のコマンドを使用します。

% setany -v2c 192.168.100.134 private docsBpi2CmtsProvisionedCmCertStatus.<index> -i 4 docsBpi2CmtsProvisionedCmCert.<index> -o '<hex_data>' docsBpi2CmtsProvisionedCmCertTrust.<index> -i 1

ヒント ほとんどのオペレーティング システムは、認証を表す 16 進数の 10 進数ストリングを指定できるだけの長さの入力を受け付けません。このため、これらのアトリビュートを設定するにはグラフィカル SNMP マネージャを使用します。多くの認証に対して、利便性に応じてスクリプト ファイルも使用できます。



) 自己署名付き認証を追加する場合、CMTS が認証を受け付ける前に
cable privacy accept-self-signed-certificate コマンドを使用しなくてはなりません。


ホットリストへの製造元または CM 認証の追加(必須)

DOCSIS 仕様により、オペレータはデジタル製造元または CM 認証を CMTS にあるホットリスト(または Certificate Revocation List [CRL; 証明書失効リスト])に追加し、この特定の認証をこれ以上受け付けないことを指定できます。これは、ケーブル モデムが盗難されたとユーザから報告があった場合、またはサービス プロバイダーが特定の製造元のケーブル モデムをサポートしないことを決めた場合などに実行されます。

Cisco CMTS のホットリストに CLI コマンドまたは SNMP コマンドを使用して認証を追加できます。詳細は以下の各項で説明します。

「CLI を使用してホットリストに認証を追加する」

「SNMP コマンドを使用してホットリストに認証を追加する」


) SNMP をケーブル モデムの設定に使用できない場合、または認証を追加する際に CLI を使用する必要のある特定のアプリケーションがあるような場合を除き、SNMP 方式を使用してケーブル モデムに認証を追加します。Cisco uBR10012 ルータでは、ルータが CLI コマンドを受け入れるように見えても、CLI 方式では実際には Cisco uBR10012 ルータのホットリストは更新されないため、ホットリストに認証を追加するには SNMP 方式を使用する必要があります。


CLI を使用してホットリストに認証を追加する

Cisco uBR7100 シリーズまたは Cisco uBR7200 シリーズ ルータの認証ホットリストに製造元または CM 認証を追加するには、次の手順に従います。


) この手順は Cisco uBR10012 ルータではサポートされていません。Cisco uBR10012 ルータのホットリストに認証を追加するには、「SNMP コマンドを使用してホットリストに認証を追加する」を参照してください。


ステップの概略

1. enable

2. configure terminal

3. cable privacy hotlist cm mac-address

4. cable privacy hotlist manufacturer certificate-serial-number

5. exit

ステップの詳細

 

コマンド
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

cable privacy hotlist cm mac-address

 

Router(config)# cable privacy hotlist cm 00C0.0102.0304

Router(config)#

(任意)指定した MAC アドレスを持つ CM 認証を認証ホットリストに追加します。 mac-address は 6 桁の 16 進数のストリングで指定されます。

ステップ 4

cable privacy hotlist manufacturer certificate-serial-number

 

Router(config)# cable privacy hotlist manufacturer 010A0BC304DFEE1CA98371

Router(config)#

指定したシリアル番号を持つ製造元認証を認証ホットリストに追加します。 certificate-serial-number は、16 進数のストリングで指定されます。オプションで、桁の間に区切り文字としてスペースを使用できます。

ステップ 5

exit

 

Router(config)# exit

Router#

グローバル コンフィギュレーション モードを終了します。

ホットリスト内にあるものと一致する MAC アドレスまたは製造元認証を使用しているケーブル モデムは登録を許可されません。たとえば、以下のコマンドは MAC アドレス 0000.0C0A.0B0C の CM をホットリストに追加してケーブル インターフェイスで登録できないようにします。

Router# config terminal
Router(config)# cable privacy hotlist cm 00 00 0C 0a 0b 0c
Oct 31 13:06:29.112: Successfully added CM hotlist 0000.0C0A.0B0C
 
Router#
 

以下のコマンドは、指定したシリアル番号を持つ製造元認証をホットリストに追加して、その製造元認証を持つケーブル モデムが登録できないようにします。

Router(config)# cable privacy hotlist manufacturer 00 90 83 00 00 00 00 01
Oct 31 13:06:34.478: Successfully added MFG hotlist 00 90 83 00 00 00 00 01
 
Router(config)# exit
Router#
 

ホットリストからケーブル モデムまたは認証を削除するには、 no プレフィクスをコマンドに追加します。次に、表示例を示します。

Router# config terminal
Router(config)# no cable privacy hotlist cm 00 00 0C 0a 0b 0c
Router(config)# no cable privacy hotlist manufacturer 00 90 83 00 00 00 00 01
Router(config)# exit
Router#

SNMP コマンドを使用してホットリストに認証を追加する

SNMP マネージャを使用して認証を作成し、 DOCS-BPI-PLUS-MIB 内のテーブルおよびアトリビュートを操作して認証をホットリストに追加できます。製造元認証を追加するには、
docsBpi2CmtsCACertTable テーブルにエントリを追加します。各エントリの以下のアトリビュートを指定します。

docsBpi2CmtsCACertStatusSet ― 4 に設定してロー エントリを作成します。

docsBpi2CmtsCACert ― 実際の X.509 認証用の X509 Certificate の値としての 16 進数データ

docsBpi2CmtsCACertTrust ― 認証の信頼状態を指定する 1 ~ 4 の整数値。(1 = 信頼、2 = 信頼しない、3 = 連鎖、4 = ルート)。ホットリストに認証を追加する際、そのアトリビュートを 2(信頼しない)に設定します。

同様に、CM 認証をホットリストに追加し、docsBpi2CmtsProvisionedCmCertTable テーブルにエントリを追加します。各エントリの以下のアトリビュートを指定します。

docsBpi2CmtsProvisionedCmCertStatusSet ― 4 に設定してロー エントリを作成します。

docsBpi2CmtsProvisionedCmCert ― 実際の X.509 認証用の X509 Certificate の値としての 16 進数データ

docsBpi2CmtsProvisionedCmCertTrust ― 認証の信頼状態を指定する 1 ~ 2 の整数値。(1 = 信頼、2 = 信頼しない)。ホットリストに認証を追加する際、そのアトリビュートを 2(信頼しない)に設定します。


ヒント 常に、実際の認証データをロードする前に CertStatus アトリビュートを設定してください。設定しない場合、CMTS は認証が連鎖しているとみなして即座に製造元およびルート認証で確認しようとします。



) この手順は、「SNMP を使用して信頼できる認証としての認証を追加する」で説明した、信頼される認証として認証を追加する手順と同じですが、docsBpi2CmtsProvisionedCmCertTrust アトリビュートを 1 ではなく 2 に設定する点が異なります。


たとえば、UNIX コマンド ライン SNMP ユーティリティを使用して製造元認証を IP アドレス 192.168.100.113 にある CMTS のホットリストに追加するには、以下のコマンドを入力します( <index> 値の代わりにテーブル エントリの有効なインデックス ポインタを使用してください)。

% setany -v2c 192.168.100.113 private docsBpi2CmtsCACertStatus.<index> -i 4 docsBpi2CmtsCACert.<index> -o '<hex_data>' docsBpi2CmtsCACertTrust.<index> -i 2
 

CM 認証に対して同様の処理を実行するには、以下のコマンドを使用します。

% setany -v2c 192.168.100.113 private docsBpi2CmtsProvisionedCmCertStatus.<index> -i 4 docsBpi2CmtsProvisionedCmCert.<index> -o '<hex_data>' docsBpi2CmtsProvisionedCmCertTrust.<index> -i 2

ヒント ほとんどのオペレーティング システムは、認証を表す 16 進数の 10 進数ストリングを指定できるだけの長さの入力を受け付けません。このため、これらのアトリビュートを設定するにはグラフィカル SNMP マネージャを使用します。多くの認証に対して、利便性に応じてスクリプト ファイルも使用できます。


連結のイネーブル化(任意)

ケーブル インターフェイス内の1つまたは複数のアップストリームで連結をイネーブル(デフォルト設定)にするには、以下の手順に従います。

ステップの概略

1. enable

2. configure terminal

3. interface cable x/y

4. cable upstream n concatenation

5. exit

6. exit

ステップの詳細

 

コマンド
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface cable x/y

 

Router(config)# interface cable 6/0

Router(config-if)#

この特定のスロットにあるケーブル インターフェイス ライン カードに対してインターフェイス コンフィギュレーション モードを開始します。

ステップ 4

cable upstream n concatenation

 

Router(config-if)# cable upstream 0 concatenation

Router(config-if)# cable upstream 1 concatenation

Router(config-if)#

ケーブル インターフェイス上の指定したアップストリームで連結をイネーブルにします。


) インターフェイス内の各アップストリームでこのコマンドを繰り返します。


ステップ 5

exit

 

Router(config-if)# exit

Router(config)#

インターフェイス コンフィギュレーション モードを終了します。

ステップ 6

exit

 

Router(config)# exit

Router#

グローバル コンフィギュレーション モードを終了します。

DOCSIS フラグメンテーションのイネーブル化(任意)

ケーブル インターフェイス内の1つまたは複数のアップストリームで DOCSIS フラグメンテーションをイネーブル(デフォルト設定)にするには、以下の手順に従います。

ステップの概略

1. enable

2. configure terminal

3. interface cable x/y

4. cable upstream n fragmentation

5. cable upstream n unfrag-slot-jitter [ limit jitter | cac-enforce ]

6. exit

7. exit

ステップの詳細

 

コマンド
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface cable x/y

 

Router(config)#

Router(config-if)#

この特定のスロットにあるケーブル インターフェイス ライン カードに対してインターフェイス コンフィギュレーション モードを開始します。

ステップ 4

cable upstream n fragmentation

 

Router(config-if)# cable upstream 2 fragmentation

Router(config-if)# cable upstream 3 fragmentation

Router(config-if)#

ケーブル インターフェイス上の指定したアップストリームでフラグメンテーションをイネーブルにします。


) インターフェイス内の各アップストリームでこのコマンドを繰り返します。


ステップ 5

cable upstream n unfrag-slot-jitter [ limit jitter | cac-enforce ]

 

Router(config-if)# cable upstream 0 unfrag-slot-jitter limit 2000 cac-enforce

Router(config-if)#

(任意)非フラグメント可能スロットによりアップストリームで許容できるジッタの総量を指定します。 limit オプションは、許容可能な jitter 限界をミリ秒単位で指定します(0 ~ 4,294,967,295)。 cac-enforce オプションはアップストリームを設定し、分割可能なスロット ジッタよりも小さいサービス フロー要求ジッタを拒否します。


) デフォルトで、jitter の限界は 0 マイクロ秒に設定されていて、cac-enforce オプションはイネーブルになっています。


ステップ 6

exit

 

Router(config-if)# exit

Router(config)#

インターフェイス コンフィギュレーション モードを終了します。

ステップ 7

exit

 

Router(config)# exit

Router#

グローバル コンフィギュレーション モードを終了します。

DOCSIS 1.0 ケーブル モデムに対する ERBA サポートの使用

ここでは、次の手順および関連するコマンドについて説明します。

「DOCSIS 1.0 ケーブル モデムのダウンストリーム ERBA の設定」

PRE2 を搭載した Cisco uBR10012 ルータでの DOCSIS 1.1 最大ダウンストリーム伝送バーストのイネーブル化

Cisco IOS Release 12.3(13a)BC では、Cisco uBR7246VXR ルータにおける DOCSIS 1.0 ケーブル モデムの ERBA サポートが導入されました。Cisco IOS Release 12.3(21)BC では、Performance Routing Engine 2(PRE2)モジュールを搭載した Cisco uBR 10012 ルータに対するこのサポートが拡張されました。

ERBA 対応の DOCSIS 1.0 モデムでは、短時間であれば、一時的な通信速度を回線最高速度にバーストさせることができます。この機能により、QoS プロファイルの既存のサービス レベルを変更することなく、インターネット ダウンロードなどで発生する瞬間帯域要求に高い帯域幅を割り当てることができます。

この機能により、Multiple System Operator(MSO)は DOCSIS 1.0 ケーブル モデム バースト伝送し、Cisco CMTS のオーバーライド先 DOCSIS 1.1 QoS プロファイルにマッピングします。DOCSIS 1.0 ケーブル モデムは、対応する QoS プロファイルに登録する際に DOCSIS 1.0 パラメータを要求します。この機能によって最大ダウンストリーム回線速度を使用することができ、対応する QoS プロファイルに登録するすべてのケーブル モデムに ERBA 設定が適用されます。


) この機能をサポートする QoS 定義は Cisco CMTS ヘッドエンドにあらかじめ存在している必要があります。


DOCSIS 1.0 ケーブル モデムの ERBA は、次の新しいまたは拡張されたコマンドもしくはキーワードによりサポートされます。

cable qos pro max-ds-burst burst-size

show cable qos profile n [verbose]

DOCSIS 1.0 ケーブル モデムのダウンストリーム ERBA の設定

DOCSIS 1.0 ケーブル モデムでダウンストリームの ERBA を定義するには、グローバル コンフィギュレーション モードで cable qos promax-ds-burst コマンドを使用します。この ERBA 設定を QoS プロファイルから削除するには、このコマンドの no 形式を使用します。

cable qos pro max-ds-burst burst-size

no cable qos pro max-ds-burst

 
シンタックスの説明

burst-size

QoS プロファイルのダウンストリーム バースト サイズで、単位はバイトです。

DOCSIS 1.0 ケーブル モデムおよび Cisco CMTS の QoS プロファイルに適用された ERBA 設定を表示するには、特権 EXEC モードで show cable qos profile コマンドを使用します。

次の例はグローバル コンフィギュレーション モードの cable qos profile コマンドで、cable qos profile コマンドがどのように変わるかを示しています。ERBA 機能に関連する部分を太字で示します。

Router(config)# cable qos pro 10 ?
grant-interval Grant interval
grant-size Grant size
guaranteed-upstream Guaranteed Upstream
max-burst Max Upstream Tx Burst
max-ds-burst Max Downstream Tx burst (cisco specific)
max-downstream Max Downstream
max-upstream Max Upstream
name QoS Profile name string (cisco specific)
priority Priority
privacy Cable Baseline Privacy Enable
tos-overwrite Overwrite TOS byte by setting mask bits to value
 

次の show cable qos profile コマンドの例では最大ダウンストリーム バーストが定義されており、マネージメントが作成した QoS プロファイルとなっています。

Router# show cable qos pro
ID Prio Max Guarantee Max Max TOS TOS Create B IP prec.
upstream upstream downstream tx mask value by priv rate
bandwidth bandwidth bandwidth burst enab enab
1 0 0 0 0 0 0xFF 0x0 cmts(r) no no
2 0 64000 0 1000000 0 0xFF 0x0 cmts(r) no no
3 7 31200 31200 0 0 0xFF 0x0 cmts yes no
4 7 87200 87200 0 0 0xFF 0x0 cmts yes no
6 1 90000 0 90000 1522 0xFF 0x0 mgmt yes no
10 1 90000 0 90000 1522 0x1 0xA0 mgmt no no
50 0 0 0 96000 0 0xFF 0x0 mgmt no no
51 0 0 0 97000 0 0xFF 0x0 mgmt no no

次の例では、特権 EXEC モードで show cable qos prof verbose コマンドを使用した場合の QoS プロファイル 10 サンプルの最大ダウンストリーム バースト サイズを示しています。

Router# show cable qos pro 10 ver
Profile Index 10
Name
Upstream Traffic Priority 1
Upstream Maximum Rate (bps) 90000
Upstream Guaranteed Rate (bps) 0
Unsolicited Grant Size (bytes) 0
Unsolicited Grant Interval (usecs) 0
Upstream Maximum Transmit Burst (bytes) 1522
Downstreamam Maximum Transmit Burst (bytes) 100000
IP Type of Service Overwrite Mask 0x1
IP Type of Service Overwrite Value 0xA0
Downstream Maximum Rate (bps) 90000
Created By mgmt
Baseline Privacy Enabled no
 

 
使用上のガイドライン

Cisco CMTS の既存の QoS プロファイルのいずれかと一致する QoS プロファイルを使ってケーブル モデムを登録した場合、そのプロファイルで定義された最大ダウンストリーム バースト サイズが使用され、デフォルト DOCSIS QoS プロファイルの 1522 は使用されません。

たとえば、上の例の QoS プロファイル 10 と一致する DOCSIS 1.0 コンフィギュレーションの場合は次のようになります。

03 (Net Access Control) = 1
 
04 (Class of Service Encodings Block)
S01 (Class ID) = 1
S02 (Maximum DS rate) = 90000
S03 (Maximum US rate) = 90000
S06 (US burst) = 1522
S04 (US Channel Priority) = 1
S07 (Privacy Enable) = 0
 

最大ダウンストリーム バースト サイズ(および ToS 上書き値)は DOCSIS で定義されていないため、QoS コンフィギュレーション ファイルで明示的に定義されていません。ただし、この例では他のパラメータはすべてプロファイル 10 と完全に一致しているので、これらの QoS パラメータを使って登録するどのケーブル モデムにも 100000 バイトの最大ダウンストリーム バーストが適用されます。

これ以上の場合は、パケットが 100 pps で 1000 バイトの長さに設定されている場合を考えてみてください。合計速度は 1000 × 100 × 8 = 800 kbps になります。

設定を変更するには、複数のトラフィック プロファイルを指定された異なるダウンストリーム QoS 設定を使って定義します。 表7-3 に QoS プロファイルの例を 2 つ示します。

 

表7-3 異なる ERBA(最大ダウンストリーム)設定を使用した QoS プロファイルの例

QoS プロファイル設定
QoS プロファイル 101
QoS プロファイル 102

最大ダウンストリーム伝送バースト(バイト)

max-burst 4000

max-burst 4000

最大ダウンストリーム バースト(bps)

max-ds-burst 20000

max-ds-burst 5000

最大ダウンストリーム帯域

max-downstream 100

max-downstream 100

この例では、max-ds-burst サイズ以外の QoS プロファイルはまったく同じです。max-ds-burst サイズは、QoS プロファイル 101 では 20000、QoS プロファイル 102 では 5000 に設定されています。

DOCSIS 1.0 ダウンストリーム パワーバーストの最適設定

DOCSIS では、サービス フローごとに異なるトークン バケット パラメータが設定できます。これにはトークン バケット バースト サイズも含まれます。バースト サイズが 0 に近づくほど QoS が厳密に実行され、ネットワーク リソースの共有予測が立てやすくなり、結果としてネットワーク計画が容易になります。

バースト サイズが大きくなると個別フローは情報をより速く(あまり遅延せずに)送信できますが、遅延のばらつきは大きくなります。

個別フローにとっては、バースト サイズが大きい方がいいと考えられます。システムが輻輳しないかぎり、バースト サイズが大きければ 2 つのフローが同時に送信される可能性が減少します。どちらのバーストも送信する時間を少なくするからです。しかしチャネル帯域幅の使用量が増えるので、バースト トラフィックが大きければバッファ深度のしきい値を超えてしまい、遅延がトラフィックが十分にシェイプされている場合よりも長くなります。

cable qos profile コマンドおよび QoS プロファイルの設定について詳しくは、Cisco.com の次のマニュアルを参照してください。

Cisco Broadband Cable Command Reference Guide

http://www.cisco.com/en/US/products/hw/cable/ps2217/products_command_reference_book09186a0080108e88.html

PRE2 モジュールを搭載した Cisco uBR10012 ルータでの DOCSIS 1.1 最大ダウンストリーム伝送バーストのイネーブル化

Cisco IOS Release 12.3(21)BC では、PRE2 モジュールを搭載した Cisco uBR10012 CMTS における ERBA 機能が導入されました。Cisco IOS Release 12.3(21)BC の ERBA 機能は、次の拡張機能によって特徴付けられます。

cable ds-max-burst コンフィギュレーション コマンドを使用して、Cisco CMTS における DOCSIS 1.1 の Downstream Maximum Transmit Burst パラメータのサポートをイネーブルします。Cisco uBR7246VXR および Cisco uBR7100 シリーズ ルータは、このパラメータをデフォルトでサポートしているため、このコマンドは必要ありません。

DOCSIS 1.0 モデムを Cisco CMTS のオーバーライド先 DOCSIS 1.1 QoS プロファイルにマッピングすることにより、DOCSIS 1.0 モデムが DOCSIS 1.1 の Downstream Maximum Transmit Burst パラメータをサポートできるようになります。この機能では、 cable qos pro max-ds-burst コンフィギュレーション コマンドを使用します。

Cisco CMTS の cable ds-max-burst コマンドおよび cable qos pro max-ds-burst コマンドのコマンド リファレンスについては、Cisco.com で『 Cisco Broadband Cable Command Reference Guide 』を参照してください。

cable ds-max-burst

http://www.cisco.com/en/US/products/hw/cable/ps2217/products_command_reference_chapter09186a0080189802.html#wp1019568

cable qos pro max-ds-burst

http://www.cisco.com/en/US/products/hw/cable/ps2217/products_command_reference_chapter09186a0080189802.html#wp1019568

Cisco IOS Release 12.3(21)BC 以降のリリースで、PRE2 を搭載した Cisco uBR10012 ルータに ERBA を設定する場合は、次の手順を実行します。この手順および関連するコマンドは、このマニュアルで言及されている注意事項および制限事項の対象となります。

制限事項

cable ds-max-burst および関連コマンドは、PRE2 モジュールおよび Cisco IOS Release 12.3(21)BC 以降のリリースを搭載した Cisco uBR10012 ルータで完全にサポートされます。

ステップの概略

1. enable

2. configure terminal

3. [ no ] cable ds-max-burst [ burst-threshold threshold ]

4. Ctrl^Z

5. show cr10k-rp cable slot/subslot/port sid service-flow ds

ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードを開始します。

必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

[ no ] cable ds-max-burst [ burst-threshold threshold ]

 

Router(config)# cable ds-max-burst burst-threshold 2048

 

DOCSIS 1.1 の最大ダウンストリーム バーストのサポートをイネーブルにします。このコンフィギュレーションを削除するには、このコマンドの no 形式を使用します。

任意の burst-threshold threshold キーワードおよび値により、有効範囲 64 K バイト~ 2 GB のバーストしきい値(K バイト)が定義されます。この設定は、デフォルトで 1 MB です。この値は、DOCSIS 2.0 で定義されたサービス単位のフローの最大トラフィック バースト値と比較するのに使用されます。

ステップ 4

Ctrl^Z

 

Router(config)# Ctrl^Z

Router#

特権 EXEC モードに戻ります。

ステップ 5

show cr10k-rp cable slot/subslot/port sid service-flow ds

 

Router(config)# show cr10k-rp cable 6/1/0 sid service-flow ds

 

PRE2 を搭載した Cisco uBR10012 ルータ上のサービス フローを表示して、最大バーストがイネーブルであるサービス フローを識別します。

slot = 5 ~ 8

subslot = 0 または 1

port = 0 ~ 4(ケーブル インターフェイスによって異なる)

この機能がイネーブルである場合は、バースト サイズがバーストしきい値よりも大きい新しいサービス フローはサポートされます。ただし、既存のサービス フローは影響を受けません。

この機能がディセーブルである場合は、新しいサービス フローは cable ds-max-burst コマンド設定の Downstream Maximum Transmit Burst パラメータにより設定されません。ただし、既存のサービス フローは影響を受けません。

次に、Cisco IOS Release 12.3(21)BC を搭載した Cisco uBR10012 ルータにおける cable ds max-burst コマンドの例を示します。

Router(config)# cable ds-max-burst burst-threshold 2048
 

次に、指定したサービス フローに ERBA 最大バーストを設定する例を示します。

Router# sh cr10k-rp c7/0/0 1 service-flow ds
RP SFID LC SFID Conform Conform Exceed Exceed Total Total QID
Bytes Pkts Bytes Pkts Bytes Pkts
 
32781 4 538 1 0 0 538 1 279 #
32782 4 0 0 0 0 0 0 0
#: DS max burst enabled

DOCSIS 動作のモニタリング

以下の各項では、DOCSIS ネットワークおよびそのケーブル モデム、CMTS の RF ネットワークおよびケーブル インターフェイス、および BPI+ 動作に関する情報を提供するコマンドについて説明します。

「DOCSIS ネットワークのモニタリング」

「RF ネットワークおよびケーブル インターフェイスのモニタリング」

「BPI+ 動作のモニタリング」

DOCSIS ネットワークのモニタリング

show cable modem コマンドは、ケーブル モデムおよび DOCSIS ネットワークの現在の状態を表示する主要コマンドです。このコマンドには多くのオプションがあり、DOCSIS 動作についてさまざまな側面の情報を提供します。

「ケーブル モデムのステータスの表示」

「ケーブル モデムのサマリー レポートの表示」

「ケーブル モデムの機能の表示」

「特定のケーブル モデムの詳細情報の表示」


ヒント show cable modem コマンドおよびそのオプションの詳細については、『 Cisco Broadband Cable
Command Reference Guide
』の「Cisco Cable Modem Termination System Commands」の章を参照してください(参考資料を参照してください)。


ケーブル モデムのステータスの表示

次の show cable modem コマンドの出力例は、既知のケーブル モデムとその現在のステータスの一覧を示しています。

Router# show cable modems
MAC Address IP Address I/F MAC Prim RxPwr Timing Num BPI
State Sid (db) Offset CPE Enb
0010.9507.01db 144.205.151.130 C5/1/0/U5 online(pt) 1 0.25 938 1 Y
0080.37b8.e99b 144.205.151.131 C5/1/0/U5 online 2 -0.25 1268 0 N
0002.fdfa.12ef 144.205.151.232 C6/1/0/U0 online(pt) 13 -0.25 1920 1 Y
0002.fdfa.137d 144.205.151.160 C6/1/0/U0 online 16 -0.50 1920 1 N
0003.e38f.e9ab 144.205.151.237 C6/1/0/U0 online 3 -0.50 1926 1 N
0003.e3a6.8173 144.205.151.179 C6/1/1/U2 offline 4 0.50 1929 0 N
0003.e3a6.8195 144.205.151.219 C6/1/1/U2 online(pt) 22 -0.50 1929 1 Y
0006.28dc.37fd 144.205.151.244 C6/1/1/U2 online(pt) 61 0.00 1925 2 Y
0006.28e9.81c9 144.205.151.138 C6/1/1/U2 online(pt) 2 !0.75 1925 1 Y
0006.28f9.8bbd 144.205.151.134 C6/1/1/U2 #online 25 -0.25 1924 1 N
0002.fdfa.12db 144.205.151.234 C7/0/0/U0 online 15 -0.75 1914 1 N
0002.fdfa.138d 144.205.151.140 C7/0/0/U5 online 4 0.00 1917 1 N
0003.e38f.e85b 144.205.151.214 C7/0/0/U5 online 17 *0.25 1919 1 N
 
Router#
 

MAC アドレスや IP アドレスを show cable modem コマンドで指定することにより、特定のケーブル モデムを表示することもできます。CPE 装置用に MAC アドレスまたは IP アドレスを指定する場合、コマンドはその装置に関連したケーブル モデムの情報を表示します。


) CPE の IP アドレスに関連するケーブル モデムがない場合、show cable modem コマンドによりケーブル モデムの情報が表示されない場合があります。ケーブル モデムに関する CPE 装置の IP アドレスを表示するには、clear cable host ip-address コマンドを使用して、ルータのデータベースからモデムの IP アドレスを消去し、次に ping docsis mac-address コマンドを入力し、CM に DOCSIS ping を送信することにより MAC アドレスを解決します。


Router# show cable modem 0010.7bb3.fcd1
 
MAC Address IP Address I/F MAC Prim RxPwr Timing Num BPI
State Sid (db) Offset CPEs Enbld
0010.7bb3.fcd1 10.20.113.2 C5/0/U5 online 1 0.00 1624 0 yes
 
Router#
 

製造元に基づきソートされたケーブル モデムの一覧を表示するには、 vendor オプションを使用します。

Router# show cable modem vendor
 
Vendor MAC Address I/F MAC Prim RxPwr Timing Num BPI
State Sid (db) Offset CPE Enb
Thomson 0010.9507.01db C5/1/0/U5 online 1 0.00 938 1 N
Ericsson 0080.37b8.e99b C5/1/0/U5 online 2 -0.25 1268 0 N
Cisco 0002.fdfa.12ef C6/1/0/U0 online 13 0.00 1920 1 N
Cisco 0002.fdfa.137d C6/1/0/U0 online 16 -0.50 1920 1 N
Cisco 0003.e38f.e9ab C6/1/0/U0 online 3 -0.25 1926 1 N
Cisco 0003.e3a6.7f69 C6/1/0/U0 online 15 0.50 1927 1 N
Cisco 0003.e3a6.816d C6/1/0/U0 online 4 0.00 1929 1 N
Cisco 0006.28f9.8be5 C6/1/0/U0 online 12 0.75 1922 1 N
Cisco 0001.9659.519f C6/1/1/U2 online 26 0.25 1930 1 N
Cisco 0002.b96f.fdbb C6/1/1/U2 online 29 -0.75 1929 1 N
Cisco 0002.b96f.fdf9 C6/1/1/U2 online 39 -0.50 1931 1 N
Cisco 0002.fdfa.12e9 C6/1/1/U2 online 5 -0.25 1925 1 N
Motorola 0020.4005.3f06 C7/0/0/U0 online 2 0.00 1901 1 N
Motorola 0020.4006.b010 C7/0/0/U5 online 3 0.25 1901 1 N
Cisco 0050.7302.3d83 C7/0/0/U0 online 18 -0.25 1543 1 N
Cisco 00b0.6478.ae8d C7/0/0/U5 online 44 0.50 1920 21 N
Cisco 00d0.bad3.c0cd C7/0/0/U5 online 19 0.00 1543 1 N
 
Router#
 

各表示の MAC State フィールドには、ケーブル モデムの現在の状態が表示されます。

 

表7-4 MAC State フィールドの説明

MAC State 値
説明
登録およびプロビジョニング ステータス状況

init(r1)

CM が初期レンジングを送信しました。

init(r2)

CM がレンジング中です。CMTS が CM から初期レンジングを受信して、RF 出力、タイミング オフセット、および周波数調整を CM に送信しました。

init(rc)

レンジングが完了しました。

init(d)

DHCP 要求が受信されました。またこれは、最初の IP ブロードキャスト パケットが CM から受信されたことを示します。

init(i)

DHCP 応答が受信されて IP アドレスが割り当てられましたが、CM が IP パケットで応答していません。

init(o)

CM が TFTP を使用して、DHCP 応答で指定されたオプション ファイル(DOCSIS コンフィギュレーション ファイル)のダウンロードを開始しました。CM がこの状態のままである場合、ダウンロードに失敗したことを示します。

init(t)

ToD 交換が開始されました。

resetting

CM がリセット中であり、登録プロセスを短時間のうちにリスタートします。

非エラー ステータス状態

offline

CM がオフライン(切断または電源オフ)と見なされます。

online

CM が登録されてネットワークにデータを送信できます。

online(d)

CM が登録されましたが、CM のネットワーク アクセスが DOCSIS コンフィギュレーション ファイルでディセーブルになっています。

online(pk)

CM が登録され、BPI がイネーブルであり、KEK が割り当てられています。

online(pt)

CM が登録され、BPI がイネーブルであり、TEK が割り当てられています。BPI 暗号化が実行されています。

expire(pk)

CM が登録され、BPI がイネーブルであり、KEK が割り当てられましたが期限が切れました。

expire(pt)

CM が登録され、BPI がイネーブルであり、TEK が割り当てられましたが期限が切れました。

エラー ステータス状態

reject(m)

CM が登録を試行したものの、Message Integrity Check(MIC; メッセージ完全性チェック)値が不良であったため登録が拒否されました。また、DOCSIS コンフィギュレーション ファイル内の共有秘密鍵が、 cable shared-secret コマンドを使用して CMTS に設定された値と一致しないことも示します。

Cisco IOS Release 12.1(11b)EC1 および Cisco IOS Release 12.2(8)BC2 以降のリリースでは、登録前に CM が DOCSIS コンフィギュレーション ファイルの TFTP ダウンロードを試行することを要求するために cable tftp-enforce コマンドを使用したものの、CM がそれを実行しなかったことも示します。

reject(c)

CM が登録を試行したものの、以下のようなエラーの可能性があるため登録が拒否されました。

CM が、 cable upstream admission-control コマンドによって規定された制限を超過した最小保証アップストリーム帯域幅を登録しようとした。

CM がセキュリティ違反によってディセーブルになった。

DOCSIS コンフィギュレーション ファイルの Class of Service(CoS; サービス クラス)値が正しくない。

CM が新しい CoS コンフィギュレーションを作成しようとしたが、CMTS がそのような変更を許可しない設定になっている。

reject(pk)

KEK 鍵割り当てが拒否され、BPI 暗号化が設定されませんでした。

reject(pt)

TEK 鍵割り当てが拒否され、BPI 暗号化が設定されませんでした。

reject(ts)

CM が登録を試行したものの、CM 登録要求内の TFTP サーバ タイムスタンプが CMTS が保持するタイムスタンプと一致しなかったため、登録に失敗しました。これは、CM が前の登録試行で使用した古い DOCISIS コンフィギュレーション ファイルを再使用して登録を試行したことを示します。

reject(ip)

CM が登録を試行したものの、CM 要求内の IP アドレスが、CM に DOCSIS コンフィギュレーション ファイルを送信した際に TFTP サーバが記録した IP アドレスと一致しなかったため、登録に失敗しました。IP スプーフィングが発生する可能性があります。

reject(na)

CM が登録を試行したものの、CMTS によって送信された登録応答(REG-RSP)の応答で CM が登録確認応答(REG-ACK)メッセージを送信しなかったため、登録に失敗しました。登録否定確認応答(REG-NACK)とみなされます。

ケーブル モデムのサマリー レポートの表示

show cable modem コマンドは、 summary および total オプションとともに使用してサマリー レポートを提供することもできます。

Router# show cable modem summary
Interface Cable Modem
Total Registered Unregistered Offline
Cable5/1/0/U5 2 2 0 0
Cable6/1/0/U0 14 13 1 0
Cable6/1/1/U2 14 14 0 0
Cable7/0/0/U0 2 2 0 0
Cable7/0/0/U5 4 3 1 1
 
Router# show cable modem summary total
Interface Cable Modem
Total Registered Unregistered Offline
Cable5/1/0/U5 2 2 0 0
Cable6/1/0/U0 14 13 1 0
Cable6/1/1/U2 14 14 0 0
Cable7/0/0/U0 2 2 0 0
Cable7/0/0/U5 4 3 1 1
 
Total: 36 34 2 1
 
Router#
 

また summary および total オプションを使用して単一インターフェイスまたはインターフェイス範囲の情報を表示できます。

Router# show cable modem summary c5/0 total
 
Interface Total Active Registered
Modems Modems Modems
Cable5/0/U0 294 272 271
Cable5/0/U1 256 248 246
Cable5/0/U2 196 194 194
 
Total: 746 714 711
 
Router# show cable modem summary c6/1/1 c7/0/0 total
 
Interface Cable Modem
Total Registered Unregistered Offline
Cable6/1/1/U2 14 14 0 0
Cable7/0/0/U0 2 2 0 0
Cable7/0/0/U5 4 3 1 1
 
Total: 20 19 1 1

ケーブル モデムの機能の表示

ケーブル モデムの機能および現在の DOCSIS プロビジョニングを表示するには、 mac オプションを使用します。

Router# show cable modem mac
 
MAC Address MAC Prim Ver Prov Frag Concat PHS Priv DS US
State Sid Saids Sids
0010.64ff.e4ad online 1 DOC1.1 DOC1.0 yes yes yes BPI+ 0 4
0010.f025.1bd9 init(rc) 2 DOC1.0 DOC1.0 no no no BPI 0 0
0010.9659.4447 online(pt) 3 DOC1.0 DOC1.0 no yes no BPI 0 0
0010.9659.4461 online(pt) 4 DOC1.0 DOC1.0 no yes no BPI 0 0
0010.64ff.e459 online 5 DOC1.0 DOC1.0 no yes no BPI 0 0
0020.4089.7ed6 online 6 DOC1.0 DOC1.0 no no no BPI 0 0
0090.9607.3831 online(pt) 7 DOC1.0 DOC1.0 no no no BPI 0 0
0090.9607.3830 online(pt) 1 DOC1.0 DOC1.0 no no no BPI 0 0
0050.7366.12fb init(i) 2 DOC1.0 DOC1.0 no no no BPI 0 0
0010.fdfa.0a35 online(pt) 3 DOC1.1 DOC1.1 yes yes yes BPI+ 0 4
 
Router#
 

ケーブル モデムのサマリー レポートおよびその機能を表示するには、 mac オプションを summary および total オプションとともに使用します。

Router# show cable modem mac summary total
 
Cable Modem Summary
-------------------
Mac Version Provision Mode
Interface Total DOC1.1 DOC1.0 Reg/Online DOC1.1 DOC1.0
Cable5/1/0/U5 1 0 1 1 0 1
Cable6/1/0/U0 11 0 11 8 0 8
Cable6/1/1/U2 17 1 16 15 0 15
Cable7/0/0/U0 2 0 2 1 0 1
Cable7/0/0/U5 1 0 1 0 0 0
 
Total: 32 1 31 25 0 25
 
Router#

特定のケーブル モデムの詳細情報の表示

show cable modem コマンドのオプションの中には、(MAC アドレスで指定された)特定のケーブル モデムの詳細情報を表示するものがあります。 verbose オプションは、最も包括的な出力を表示します。

Router# show cable modem 0010.7bb3.fcd1 verbose
 
MAC Address : 0010.7bb3.fcd1
IP Address : 10.20.113.2
Prim Sid : 1
Interface : C5/0/U5
Upstream Power : 0 dBmV (SNR = 33.25 dBmV)
Downstream Power : 0 dBmV (SNR = ----- dBmV)
Timing Offset : 1624
Received Power : 0.25
MAC Version : DOC1.0
Capabilities : {Frag=N, Concat=N, PHS=N, Priv=BPI}
Sid/Said Limit : {Max Us Sids=0, Max Ds Saids=0}
Optional Filtering Support : {802.1P=N, 802.1Q=N}
Transmit Equalizer Support : {Taps/Symbol= 0, Num of Taps= 0}
Number of CPEs : 0(Max CPEs = 0)
Flaps : 373(Jun 1 13:11:01)
Errors : 0 CRCs, 0 HCSes
Stn Mtn Failures : 0 aborts, 3 exhausted
Total US Flows : 1(1 active)
Total DS Flows : 1(1 active)
Total US Data : 1452082 packets, 171344434 bytes
Total US Throughput : 0 bits/sec, 0 packets/sec
Total DS Data : 1452073 packets, 171343858 bytes
Total DS Throughput : 0 bits/sec, 0 packets/sec
 
Router#
 

connectivity および maintenance オプションも、特定のケーブル モデムにおける障害のトラブルシューティングに役立つ情報を得られます。

次に、特定の CM に関する maintenance オプションの出力例を示します。

Router# show cable modem 0010.7bb3.fcd1 connectivity
 
Prim 1st time Times %online Online time Offline time
Sid online Online min avg max min avg max
1 May 30 2000 4 99.85 48:20 11h34m 1d2h23m 00:01 00:59 03:00
 
Router# show cable modem 0010.7bb3.fcd1 maintenance
 
MAC Address I/F Prim SM Exhausted SM Aborted
Sid Count Time Count Time
0010.7bb3.fcd1 C5/0/U5 1 3 Jun 1 10:24:52 0 Jan 1 00:00:00
 
Router#

RF ネットワークおよびケーブル インターフェイスのモニタリング

show interface cable コマンドを使用して、CMTS の RF ネットワークおよびケーブル インターフェイスの動作に関する情報を表示できます。

「MAC スケジューラに関する情報の表示」

「QoS パラメータ セットに関する情報の表示」

「サービス フローに関する情報の表示」

「SID に関する情報の表示」


ヒント show cable interface コマンドおよびそのオプションの詳細については、『Cisco Broadband Cable
Command Reference Guide
』の「Cisco Cable Modem Termination System Commands」の章を参照してください(参考資料を参照してください)。


MAC スケジューラに関する情報の表示

各ケーブル インターフェイスの DOCSIS MAC レイヤ スケジューラに関する情報を表示するには、 show interface cable コマンドとともに mac-scheduler オプションを使用します。インターフェイスのすべてのアップストリームに関する情報を表示することも、インターフェイスの単一のストリームに関する情報を表示することもできます。

次に、特定のケーブル インターフェイスにある 2 番めのアップストリーム(U1)に関する情報を示します。

Router# show interface cable 3/0 mac-scheduler 1
 
DOCSIS 1.1 MAC scheduler for Cable3/0/U1
Queue[Rng Polls] 0/64, 0 drops
Queue[CIR Grants] 0/64, 0 drops
Queue[BE(7) Grants] 0/64, 0 drops
Queue[BE(6) Grants] 0/64, 0 drops
Queue[BE(5) Grants] 0/64, 0 drops
Queue[BE(4) Grants] 0/64, 0 drops
Queue[BE(3) Grants] 0/64, 0 drops
Queue[BE(2) Grants] 0/64, 0 drops
Queue[BE(1) Grants] 0/64, 0 drops
Queue[BE(0) Grants] 0/64, 0 drops
Req Slots 81256509, Req/Data Slots 0
Init Mtn Slots 568433, Stn Mtn Slots 68664
Short Grant Slots 2261, Long Grant Slots 2064698
Awacs Slots 0
Fragmentation count 6
Fragmentation test disabled
Avg upstream channel utilization : 1%
Avg percent contention slots : 97%
Avg percent initial ranging slots : 2%
Avg percent minislots lost on late MAPs : 0%
Sched Table Adm-State: Grants 1, Reqpolls 1, Util 20%
UGS : 0 SIDs, Reservation-level in bps 0
UGS-AD : 1 SIDs, Reservation-level in bps 412800
RTPS : 0 SIDs, Reservation-level in bps 0
NRTPS : Not Supported
BE : 8 SIDs, Reservation-level in bps 0
 
Router#

QoS パラメータ セットに関する情報の表示

ケーブル インターフェイスに定義された DOCSIS 1.1 QoS パラメータ セットに関する情報を表示するには、 show interface cable コマンドとともに qos paramset オプションを使用します。

Router# show interface cable 3/0 qos paramset
 
Index Name Dir Sched Prio MaxSusRate MaxBurst MinRsvRate
1 US BE 0 64000 0 0
2 DS BE 0 1000000 0 0
3 US BE 0 200000 1600 0
4 DS BE 0 1500000 1522 0
5 US BE 0 500000 1522 0
6 US UGS_AD
7 DS BE 0 2000000 1522 0
8 US BE 0 128000 1600 0
9 DS BE 0 1000000 1522 0
10 DS BE 0 100000 1522 50000
 
Router#
 

また、CoS 用の索引番号を verbose オプションで指定することにより、特定のパラメータ セットに関する詳細情報を表示できます。

Router# show interface cable 3/0 qos paramset 8 verbose
 
Index: 8
Name:
Direction: Upstream
Minimum Packet Size 64 bytes
Admitted QoS Timeout 200 seconds
Active QoS Timeout 0 seconds
Scheduling Type: Unsolicited Grant Service(AD)
Request/Transmission Policy: 0x1FF
Nominal Polling Interval: 10000 usecs
Tolerated Poll Jitter: 2000 usecs
Unsolicited Grant Size: 500 bytes
Nominal Grant Interval: 10000 usecs
Tolerated Grant Jitter: 2000 usecs
Grants per Interval: 1
IP ToS Overwrite [AND-mask,OR-mask]: 0xFF,0x0
Parameter Presence Bitfield: {0x0, 0x3FC000}
 
Router#

サービス フローに関する情報の表示

ケーブル インターフェイスに設定されているサービス フローおよび QoS パラメータ セットを表示するには、 show interface cable コマンドとともに service-flow オプションを使用します。

Router# show interface cable 3/0 service-flow
 
Sfid Sid Mac Address QoS Param Index Type Dir Curr Active
Prov Adm Act State Time
4 N/A 0001.9659.4447 4 4 4 prim DS act 1d0h39m
3 1 0001.9659.4447 3 3 3 prim US act 1d0h39m
6 N/A 0001.64ff.e4ad 6 6 6 prim DS act 1d0h39m
14 N/A 0006.2854.7319 9 9 9 prim DS act 1d0h2m
457 N/A 0006.2854.7319 10 10 0 sec(S) DS adm 00:00
13 6 0006.2854.7319 7 7 7 prim US act 1d0h2m
456 155 0006.2854.7319 8 8 8 sec(S) US act 21h31m
458 156 0006.2854.7319 0 11 11 dyn(S) US act 00:10
16 N/A 0050.7366.12fb 4 4 4 prim DS act 1d0h39m
15 7 0050.7366.12fb 3 3 3 prim US act 1d0h39m
19 N/A 0090.9607.3831 4 4 4 prim DS act 1d0h39m
23 10 0090.9607.3831 3 3 3 prim US act 1d0h39m
 
Router#
 

各サービス フローの主な QoS パラメータを表示するには、 qos オプションをこのコマンドに追加します。

Router# show interface cable 3/0 service-flow qos
 
Sfid Dir Curr Sid Sched Prio MaxSusRate MaxBrst MinRsvRate Throughput
State Type
 
14 DS act N/A BE 0 2000000 1522 0 8124
457 DS adm N/A BE 0 100000 1522 50000 0
13 US act 6 BE 0 500000 1522 0 0
456 US act 155 UGS_A 0 0 1522 0 57643
19 DS act N/A UGS 0 100000 1522 50000 68715
 
Router#
 

特定のサービス フローの全 QoS パラメータを表示するには、 qos および verbose オプションを使用します。これらのオプションは別々に使用することも同時に使用することもできます。

Router# show interface cable 3/0 service-flow 19 verbose
 
Sfid : 4
Mac Address : 0090.9607.3831
Type : Primary
Direction : Downstream
Current State : Active
Current QoS Indexes [Prov, Adm, Act] : [4, 4, 4]
Active Time : 21h04m
Sid : N/A
Traffic Priority : 0
Maximum Sustained rate : 100000 bits/sec
Maximum Burst : 1522 bytes
Minimum Reserved Rate : 0 bits/sec
Admitted QoS Timeout : 200 seconds
Active QoS Timeout : 0 seconds
Packets : 130
Bytes : 123096
Rate Limit Delayed Grants : 0
Rate Limit Dropped Grants : 0
Current Throughput : 68715 bits/sec, 9 packets/sec
Classifiers: NONE
 
Router# show interface cable 3/0 service-flow 19 qos verbose
 
Sfid : 19
Current State : Active
Sid : N/A
Traffic Priority : 0
Maximum Sustained rate : 100000 bits/sec
Maximum Burst : 1522 bytes
Mimimum Reserved rate : 50000 bits/sec
Minimum Packet Size : 100 bytes
Admitted QoS Timeout : 200 seconds
Active QoS Timeout : 0 seconds
Maximum Latency : 20000 usecs
Current Throughput : 68715 bits/sec, 9 packets/sec
 
Router#

SID に関する情報の表示

DOCSIS 1.1 ネットワークのアップストリームにのみ割り当てられる SID に関する情報を表示するには、 show interface cable コマンドとともに sid オプションを使用します。

Router# show interface cable 3/0 sid
 
Sid Prim MAC Address IP Address Type Age Admin Sched Sfid
State Type
1 0090.9607.3831 10.1.1.35 stat 22h26m enable BE 3
2 0001.9659.4447 10.1.1.36 stat 22h26m enable BE 5
3 0000.f025.1bd9 0.0.0.0 stat 22h26m enable BE 7
4 0001.64ff.e4ad 10.1.1.39 stat 22h26m enable BE 9
5 0006.2854.7319 10.1.1.41 stat 22h26m enable BE 11
6 0001.9659.4461 10.1.1.33 stat 22h26m enable BE 13
7 0001.64ff.e459 10.1.1.42 stat 22h26m enable BE 15
8 5 stat 22h26m enable UGS_AD 17
9 5 stat 22h26m enable BE 18
10 0050.7366.12fb 10.1.1.43 stat 22h26m enable BE 20
11 0020.4089.7ed6 10.1.1.40 stat 22h26m enable BE 22
12 5 dyn 22h26m enable UGS 24
13 5 dyn 22h26m enable BE 25
 
Router#
 

qos オプションを追加して、各 SID に関連した主な QoS パラメータを表示します。

Router# show interface cable 3/0 sid qos
 
Sid Pr MaxSusRate MinRsvRate Sched Grant Grant GPI Poll Thrput
Type Size Intvl Intvl
1 0 200000 0 BE 100 100000 1 100000 848
2 0 200000 0 BE 100 100000 1 100000 0
3 0 64000 0 BE 0 0 0 0 0
4 0 128000 0 BE 100 100000 1 100000 0
5 0 500000 0 BE 100 100000 1 100000 0
6 0 200000 0 BE 100 100000 1 100000 848
7 0 128000 0 BE 100 100000 1 100000 0
8 0 0 0 UGS_AD 500 10000 1 10000 3468
9 0 100000 0 BE 100 100000 1 100000 0
10 0 200000 0 BE 100 100000 1 100000 848
11 0 200000 0 BE 100 100000 1 100000 848
12 0 0 0 UGS 150 100000 1 100000 0
13 0 7000 0 BE 100 100000 1 100000 0
 
Router#
 

特定の SID および QoS パラメータに関する詳細情報を表示するには、 qos および verbose オプションを使用します。

Router# show interface cable 3/0 sid 1 qos verbose
 
Sid : 1
Traffic Priority : 0
Maximum Sustained Rate : 200000 bits/sec
Maximum Burst : 1600 bytes
Minimum Reserved Rate : 0 bits/sec
Minimum Packet Size : 64 bytes
Admitted QoS Timeout : 200 seconds
Active QoS Timeout : 0 seconds
Maximum Concatenated Burst : 1600 bytes
Scheduling Type : Best Effort
Nominal Grant Interval : 100000 usecs
Tolerated Grant Jitter : 2000 usecs
Nominal Polling Interval : 100000 usecs
Tolerated Polling Jitter : 2000 usecs
Unsolicited Grant Size : 100 bytes
Grants per Interval : 1
Request/Transmission Policy : 0x0
IP ToS Overwrite [AND-mask, OR-mask] : 0xFF, 0x0
Current Throughput : 863 bits/sec, 0 packets/sec
 
Router#

BPI+ 動作のモニタリング

CMTS および接続されているケーブル モデムの BPI 動作の状態をモニタするには、以下の各項を参照してください。

「ケーブル モデムの現在の BPI+ ステートの表示」

「CMTS の BPI+ タイマー値の表示」

「CMTS の認証リストの表示」

ケーブル モデムの現在の BPI+ ステートの表示

ケーブル モデムの現在の BPI+ ステートを表示するには、 show cable modem コマンドを使用します。オプションなしでこのコマンドを使用すると、すべてのインターフェイスのケーブル モデムのステートを表示します。CMTS の特定のケーブル インターフェイス、または特定のケーブル モデムの IP アドレスまたは MAC アドレスを指定することもできます。

Router# show cable modem [ip-address | interface | mac-address]
 

次に、すべてのインターフェイスのケーブル モデムに対する一般的な表示を示します。

Router# show cable modem
 
MAC Address IP Address I/F MAC Prim RxPwr Timing Num BPI
State Sid (db) Offset CPEs Enbld
0010.7b6b.58c1 0.0.0.0 C4/0/U5 offline 5 -0.25 2285 0 yes
0010.7bed.9dc9 0.0.0.0 C4/0/U5 offline 6 -0.75 2290 0 yes
0010.7bed.9dbb 0.0.0.0 C4/0/U5 online(pt) 7 0.50 2289 0 yes
0010.7b6b.58bb 0.0.0.0 C4/0/U5 reject(pk) 8 0.00 2290 0 yes
0010.7bb3.fcd1 10.20.113.2 C5/0/U5 online(pt) 1 0.00 1624 0 yes
0010.7bb3.fcdd 0.0.0.0 C5/0/U5 online(pk) 2 -20.00 1624 0 yes
0010.7b43.aa7f 0.0.0.0 C5/0/U5 reject(pt) 3 7.25 1623 0 yes
 
Router#
 

次に、特定のインターフェイスの Cisco uBR10012 ルータに対する一般的な表示を示します。

Router# show cable modems c7/0/0
 
MAC Address IP Address I/F MAC Prim RxPwr Timing Num BPI
State Sid (db) Offset CPE Enb
0002.fdfa.12db 144.205.151.234 C7/0/0/U0 offline 15 -0.75 1914 1 Y
0002.fdfa.138d 144.205.151.140 C7/0/0/U5 online(pk) 4 0.00 1917 1 Y
0003.e38f.e85b 144.205.151.214 C7/0/0/U5 reject(pk) 17 *0.25 1919 1 Y
0003.e38f.f4cb 144.205.151.238 C7/0/0/U5 online(pt) 16 0.00 !2750 1 Y
0003.e3a6.7fd9 144.205.151.151 C7/0/0/U5 online(pt) 1 0.25 1922 0 Y
0020.4005.3f06 144.205.151.145 C7/0/0/U0 online(pt) 2 0.00 1901 1 Y
0020.4006.b010 144.205.151.164 C7/0/0/U5 online(pt) 3 0.00 1901 1 Y
0050.7302.3d83 144.205.151.240 C7/0/0/U0 online(pt) 18 -0.25 1543 1 Y
00b0.6478.ae8d 144.205.151.254 C7/0/0/U5 online(pt) 44 0.25 1920 21 Y
00d0.bad3.c0cd 144.205.151.149 C7/0/0/U5 online(pk) 19 0.25 1543 1 Y
00d0.bad3.c0cf 144.205.151.194 C7/0/0/U0 online(pt) 13 0.00 1546 1 Y
00d0.bad3.c0d5 144.205.151.133 C7/0/0/U0 reject(pt) 12 *0.50 1546 1 Y
 
Router#
 

次に、特定のケーブル モデムに対する一般的な表示を示します。

Router# show cable modem 00C0.abcd.ef01
 
MAC Address IP Address I/F MAC Prim RxPwr Timing Num BPI
State Sid (db) Offset CPEs Enbld
00c0.abcd.ef01 10.20.113.2 C5/0/U5 online(pt) 1 0.00 1624 0 yes
 
Router#
 

MAC State カラムは、各ケーブル モデムの現在のステータスを表示します。次に、このフィールドで表示される可能性のある BPI 関連の値を示します。

 

表7-5 show cable modem コマンドにより表示される可能性のある BPI+ ステート

ステート
説明

online

ケーブル モデムがオンラインになり、また BPI+ を使用するように設定されている場合、このセッション用のプライバシ パラメータをネゴシエーションします。モデムが数分以上この状態のままの場合、オンラインですが BPI+ は使用していません。ケーブル モデムで DOCSIS 認定ソフトウェアを実行していて、BPI+ をイネーブルにする DOCSIS コンフィギュレーション ファイルを使用しているかどうかをチェックしてください。

online(pk)

ケーブル モデムがオンラインで、CMTS と KEK をネゴシエーションしました。BPI+ ネゴシエーションに成功した場合、このステートのあとすぐに online(pt) になります。

online(pt)

ケーブル モデムがオンラインで、CMTS と TEK をネゴシエーションしました。BPI+ セッションが確立されて、ケーブル モデムが CMTS で指定したプライバシ パラメータを使用してすべてのユーザ トラフィックを暗号化します。

reject(pk)

ケーブル モデムが CMTS で KEK ネゴシエーションに失敗しました。これは通常、ケーブル モデムが認証に失敗したためです。ケーブル モデムが適切に BPI+ 用に設定されていて、有効なデジタル認証を使用しているかをチェックします。CMTS が登録用に BPI+ を必要とする場合、ケーブル モデムはオフラインになって再登録する必要があります。ケーブル モデムが CMTS プロビジョニング システムに適切に登録されているかをチェックします。


) ケーブル モデムが BPI+ 認証に失敗した場合、以下のようなメッセージが CMTS ログに表示されます。


%UBR7200-5-UNAUTHSIDTIMEOUT: CMTS deleted BPI unauthorized Cable Modem 00c0.abcd.ef01

reject(pt)

ケーブル モデムが CMTS と TEK のネゴシエーションに失敗しました。CMTS が登録用に BPI+ を必要とする場合、ケーブル モデムは再登録する必要があります。


ヒント 他の MAC ステートもあります。詳細なリストについては、表7-4を参照してください。


CMTS の BPI+ タイマー値の表示

特定のケーブル インターフェイスにおける KEK および TEK 存続時間および猶予時間の値を表示するには、 show interface cable x/y privacy [ kek | tek ] コマンドを使用します。次に、表示例を示します。

Router# show interface cable 4/0 privacy kek
 
Configured KEK lifetime value = 604800
Configured KEK grace time value = 600
 
Router# show interface cable 4/0 privacy tek
 
Configured TEK lifetime value = 60480
Configured TEK grace time value = 600
 
Router#

CMTS の認証リストの表示

CMTS の既知の認証リストを表示するには、 show crypt ca certificates コマンドを使用します。次に、表示例を示します。

Router# show crypto ca certificates
 
Certificate
Status: Available
Certificate Serial Number: 7DBF85DDDD8358546BB1C67A16B3D832
Key Usage: General Purpose
Subject Name
Name: Cisco Systems
Validity Date:
start date: 00:00:00 UTC Sep 12 2001
end date: 23:59:59 UTC Sep 11 2021
 
Root certificate
Status: Available
Certificate Serial Number: 5853648728A44DC0335F0CDB33849C19
Key Usage: General Purpose
CN = DOCSIS Cable Modem Root Certificate Authority
OU = Cable Modems
O = Data Over Cable Service Interface Specifications
C = US
Validity Date:
start date: 00:00:00 UTC Feb 1 2001
end date: 23:59:59 UTC Jan 31 2031
 
Router#

コマンドの要約

表7-6 は、DOCSIS 1.1 動作用に Cisco CMTS を設定しモニタリングする際に使用するコマンドを要約したものです。

 

表7-6 DOCSIS 1.1 動作用の新規コマンドまたは変更されたコマンド

コマンド
説明

cable dci-response

ケーブル インターフェイスが、そのインターフェイス上のケーブル モデムの DCI-REQ メッセージに応答する方法を設定します。

cable dci-upstream-disable

ケーブル インターフェイスが DOCSIS 1.1 Upstream Transmitter Disable(UP-DIS)メッセージを特定のケーブル モデムに伝送するように、インターフェイスを設定します。

cable service class

ケーブル サービス クラス用のパラメータを設定します。

cable service flow inactivity-threshold

UGS-AD を使用してサービス フローの非アクティブしきい値を設定します。

cable submgmt default

加入者管理 MIB(DOCS-SUBMGT-MIB)のアトリビュートにデフォルト値を設定して、このデフォルト値がリスタート後も持続するようにします。

cable upstream fragmentation

ケーブル インターフェイスの DOCSIS 1.1 フラグメンテーションをイネーブルにします。

cable upstream unfrag-slot-jitter

非フラグメント可能スロットにより、対応するアップストリームで許容できるジッタの量を制御します。

debug cable dci

DOCSIS 1.1 Device Class Identification(DCI)メッセージに関する情報を表示します。

debug cable mac-scheduler

MAC スケジューラの管理制御アクティビティに関する情報を表示します。

debug cable phs

PHS ドライバのアクティビティを表示します。

debug cable tlvs

DOCSIS 1.1 TLV パーサーおよびエンコーダによって解析される TLV を表示します。これには、サービス フロー エンコーディング、クラシファイア エンコーディング、および PHS ルールの TLV などがあります。

show cable modem

登録および未登録ケーブル モデムの情報が表示されます。

show cable service-class

DOCSIS 1.1 ケーブル サービス クラス用のパラメータを表示します。

show interface cable downstream

ダウンストリーム パケット キューイングおよびスケジューリング ステートを表示します。

show interface cable mac-scheduler

現在のタイムスロット スケジューリング ステートおよび統計を表示します。

show interface cable qos paramset

サービス フロー QoS パラメータ セットのアトリビュートを表示します。

show interface cable service-flow

指定したケーブル インターフェイスの DOCSIS サービス フローのアトリビュートを表示します。

以下のコマンドは廃止され、DOCSIS 1.1 動作では使用されていません。

cable qos [ profile | permission ]

cable service-flow inactivity-timeout

show cable qos profile

DOCSIS 1.1 動作の設定例

ここでは、Cisco CMTS における DOCSIS 1.1 動作の設定例を示します。

「Cisco uBR7246 VXR ルータ用の DOCSIS 1.1 コンフィギュレーション(BPI+ の設定なし)」

「Cisco uBR7246 VXR ルータ用の DOCSIS 1.1 コンフィギュレーション(BPI+ を設定)」

「Cisco uBR10012 ルータ用の DOCSIS 1.1 コンフィギュレーション(BPI+ を設定)」

Cisco uBR7246 VXR ルータ用の DOCSIS 1.1 コンフィギュレーション(BPI+ の設定なし)

version 12.2
no service pad
service timestamps log datetime localtime
service password-encryption
service udp-small-servers max-servers no-limit
!
hostname 7246VXR
!
enable password 7 030A69CE09
!
cable qos profile 8
cable qos profile 10
cable qos profile 10 grant-size 1500
cable qos profile 12 guaranteed-upstream 100000
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable timeserver
!
cable config-file disable.cm
access-denied
service-class 1 max-upstream 1
service-class 1 max-downstream 1600
cpe max 1
timestamp
!
cable config-file platinum.cm
service-class 1 max-upstream 128
service-class 1 guaranteed-upstream 10
service-class 1 max-downstream 10000
service-class 1 max-burst 1600
cpe max 10
timestamp
!
clock timezone PDT -8
clock summer-time PDT recurring
clock calendar-valid
ip subnet-zero
ip cef
ip cef accounting per-prefix
no ip finger
ip tcp synwait-time 5
no ip domain-lookup
ip host vxr 192.100.168.103
ip domain-name cisco.com
ip name-server 192.100.168.70
ip name-server 192.100.168.132
ip name-server 192.100.168.250
no ip dhcp relay information check
!
!
!
ip dhcp pool cm-platinum
network 10.10.4.0 255.255.255.0
bootfile platinum.cm
next-server 10.10.4.1
default-router 10.10.4.1
option 7 ip 10.10.4.1
option 4 ip 10.10.4.1
option 2 hex ffff.8f80
lease 7 0 10
!
ip dhcp pool pcs-c4
network 192.100.168.0 255.255.255.224
next-server 192.100.168.1
default-router 192.100.168.1
dns-server 192.100.168.2
domain-name cisco.com
lease 7 0 10
!
!
interface Ethernet2/0
ip address 192.100.168.4 255.255.255.192
no ip mroute-cache
half-duplex
!
interface Cable4/0
ip address 192.100.168.1 255.255.255.224 secondary
ip address 10.10.4.1 255.255.255.0
no ip route-cache cef
no keepalive
cable downstream rate-limit token-bucket shaping
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream frequency 555000000
cable upstream 0 frequency 40000000
cable upstream 0 power-level 0
no cable upstream 0 shutdown
cable upstream 1 shutdown
cable upstream 2 shutdown
cable upstream 3 shutdown
cable upstream 4 shutdown
cable upstream 5 shutdown
cable dhcp-giaddr policy
!
!
router eigrp 202
redistribute connected
redistribute static
network 10.0.0.0
network 192.100.168.0
no auto-summary
no eigrp log-neighbor-changes
!
router rip
version 2
redistribute connected
redistribute static
network 10.0.0.0
network 192.100.168.0
no auto-summary
!
ip default-gateway 192.100.168.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.100.168.1
ip route 192.100.168.0 255.255.255.0 Ethernet2/0
ip http server
ip http authentication local
!
snmp-server engineID local 00000009020000E01ED77E40
snmp-server community public RO
snmp-server community private RW
tftp-server server
tftp-server slot0:silver.cm alias silver.cm
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
speed 19200
line vty 0 4
session-timeout 60
login
!
ntp clock-period 17179977
ntp server 192.100.168.51
end

Cisco uBR7246 VXR ルータ用の DOCSIS 1.1 コンフィギュレーション(BPI+ を設定)

version 12.2
no service pad
service password-encryption
service compress-config
!
hostname uBR7246VXR
!
logging queue-limit 100
enable password 7 03085A09
!
clock summer-time EDT recurring
clock calendar-valid
cable flap-list insertion-time 120
cable flap-list power-adjust threshold 5
cable flap-list aging 1440
cable modem max-cpe 2
cable modulation-profile 2 request 0 16 2 8 qpsk scrambler 152 no-diff 64 fixed uw8
cable modulation-profile 2 initial 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 2 station 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 2 short 5 91 14 8 qpsk scrambler 152 no-diff 72 shortened uw8
cable modulation-profile 2 long 8 239 0 8 qpsk scrambler 152 no-diff 80 shortened uw8
cable modulation-profile 3 request 0 16 2 8 qpsk scrambler 152 no-diff 64 fixed uw8
cable modulation-profile 3 initial 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 3 station 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 3 short 8 85 14 8 qpsk scrambler 152 no-diff 72 shortened uw8
cable modulation-profile 3 long 10 235 0 8 qpsk scrambler 152 no-diff 80 shortened uw8
cable modulation-profile 4 request 0 16 2 8 qpsk scrambler 152 no-diff 64 fixed uw8
cable modulation-profile 4 initial 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 4 station 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 4 short 10 8 6 8 8 16qam scrambler 152 no-diff 144 shortened uw16
cable modulation-profile 4 long 10 235 0 8 16qam scrambler 152 no-diff 160 shortened uw16
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable logging badipsource 2000000
cable time-server
!
!
ip subnet-zero
no ip source-route
!
!
ip cef
ip domain name sampleclient.com
ip dhcp smart-relay
ip dhcp relay information option
no ip dhcp relay information check
!
crypto ca trustpoint DOCSIS-ROOT-CERT
!
crypto ca certificate chain DOCSIS-ROOT-CERT
certificate ca 00A0730000000002
308202B7 30820220 A0030201 02020800 A0730000 00000230 0D06092A 864886F7
0D010105 05003081 9D310B30 09060355 04061302 5553310E 300C0603 55040A13
05436F6D 3231310F 300D0603 55040B13 06444F43 53495331 36303406 0355040B
132D4C4F 43303030 332C2037 35302054 61736D61 6E204472 6976652C 204D696C
70697461 732C2043 41203935 30333531 35303306 03550403 132C436F 6D323120
4361626C 65204D6F 64656D20 526F6F74 20436572 74696669 63617465 20417574
686F7269 7479301E 170D3030 30353038 30373030 30305A17 0D323530 35303830
37303030 305A3081 9D310B30 09060355 04061302 5553310E 300C0603 55040A13
05436F6D 3231310F 300D0603 55040B13 06444F43 53495331 36303406 0355040B
132D4C4F 43303030 332C2037 35302054 61736D61 6E204472 6976652C 204D696C
70697461 732C2043 41203935 30333531 35303306 03550403 132C436F 6D323120
4361626C 65204D6F 64656D20 526F6F74 20436572 74696669 63617465 20417574
686F7269 74793081 9F300D06 092A8648 86F70D01 01010500 03818D00 30818902
818100D9 C1A4199A 47D4FFAD B43F573C D1232742 748D2C91 B89E9FE9 94277008
FBA544C8 5CC4FE3F 754BA64B AEE5A362 32A41BFE B9FD03C2 99242D95 0508DC45
1A007021 FEC688F9 E57D9161 DE43E4EC 29379E9E 3AEB3563 455AF3B6 2C345A31
70F4FCF6 FB39FC6E 815F05CF EC6E618A 52562F26 098C5BE1 48FD46DE E07078A9
DD962902 03010001 300D0609 2A864886 F70D0101 05050003 8181001B DFAF32FD
38FF13E8 CD5063C6 4663D00A 2F3132FB 25D9F6DF 1CC67C1B 5CDB5F02 825F2DD2
72C07A3C 7EB0B138 F217E0BA CCBCF712 19AB117E 76193E86 3E7C8532 B44228A1
0E19643A B44D66B6 15F8F142 9ECF54F6 AFCA093E A6D59067 E3F9306C 5696BF5F
C34999A5 5F36F368 EAFAA8DD BAD93942 8620C59C 879EB625 88C3A1
quit
!
!
!
key chain ubr7246-rip
key 1
key-string 7 0600066C594C1B4F0E574345460133
!
!
interface FastEthernet0/0
ip address 192.168.10.130 255.255.255.0
duplex half
tag-switching ip
no cdp enable
!
interface Ethernet1/0
ip address 10.10.0.1 255.255.0.0
no ip redirects
no ip proxy-arp
ip pim dense-mode
no ip mroute-cache
duplex half
no keepalive
no cdp enable
!
interface Ethernet1/1
ip address 10.11.0.1 255.255.0.0
no ip redirects
no ip proxy-arp
ip pim dense-mode
duplex half
no keepalive
no cdp enable
!
interface Ethernet2/0
ip address 192.168.10.2 255.255.0.0
shutdown
duplex half
no cdp enable
!
interface Ethernet2/1
ip address 192.168.10.1 255.255.0.0
duplex half
no cdp enable
!
interface Cable3/0
ip address 192.168.10.77 255.255.255.0
ip mask-reply
no ip redirects
no ip proxy-arp
ip pim sparse-dense-mode
ip route-cache flow
ip igmp access-group 96
no ip mroute-cache
cable map-advance dynamic 400 1000
cable insertion-interval automatic 25 500
cable bundle 1 master
cable downstream annex B
cable downstream modulation 256qam
cable downstream interleave-depth 32
cable downstream channel-id 0
cable upstream 0 frequency 5008000
cable upstream 0 power-level 0
cable upstream 0 channel-width 1600000 1600000
cable upstream 0 minislot-size 4
cable upstream 0 modulation-profile 2
no cable upstream 0 shutdown
cable upstream 1 frequency 7008000
cable upstream 1 power-level 0
cable upstream 1 channel-width 1600000 1600000
cable upstream 1 minislot-size 4
cable upstream 1 modulation-profile 2
no cable upstream 1 shutdown
cable upstream 2 frequency 10000000
cable upstream 2 power-level 0
cable upstream 2 channel-width 1600000 1600000
cable upstream 2 minislot-size 4
cable upstream 2 modulation-profile 2
no cable upstream 2 shutdown
cable upstream 3 frequency 13008000
cable upstream 3 power-level 0
cable upstream 3 channel-width 1600000 1600000
cable upstream 3 minislot-size 4
cable upstream 3 modulation-profile 2
no cable upstream 3 shutdown
cable upstream 4 frequency 16000000
cable upstream 4 power-level 0
cable upstream 4 channel-width 1600000 1600000
cable upstream 4 minislot-size 4
cable upstream 4 modulation-profile 2
no cable upstream 4 shutdown
cable upstream 5 frequency 20000000
cable upstream 5 power-level 0
cable upstream 5 channel-width 1600000 1600000
cable upstream 5 minislot-size 4
cable upstream 5 modulation-profile 2
no cable upstream 5 shutdown
cable dhcp-giaddr policy
cable privacy accept-self-signed-certificate
cable privacy authenticate-modem
cable privacy authorize-multicast
cable privacy kek life-time 300
cable privacy tek life-time 180
no keepalive
!
interface Cable4/0
ip address 192.168.10.55 255.255.255.0
ip mask-reply
no ip redirects
no ip proxy-arp
ip multicast ttl-threshold 5
ip multicast boundary 15
ip route-cache flow
no ip mroute-cache
cable map-advance dynamic 400 1000
cable insertion-interval automatic 25 500
cable bundle 1
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream channel-id 1
cable upstream 0 frequency 30000000
cable upstream 0 power-level 0
cable upstream 0 channel-width 1600000 1600000
cable upstream 0 minislot-size 4
cable upstream 0 modulation-profile 3
no cable upstream 0 shutdown
cable upstream 1 frequency 31008000
cable upstream 1 power-level 0
cable upstream 1 channel-width 1600000 1600000
cable upstream 1 minislot-size 4
cable upstream 1 modulation-profile 3
no cable upstream 1 shutdown
cable upstream 2 frequency 32000000
cable upstream 2 power-level 0
cable upstream 2 channel-width 1600000 1600000
cable upstream 2 minislot-size 4
cable upstream 2 modulation-profile 3
no cable upstream 2 shutdown
cable upstream 3 frequency 33008000
cable upstream 3 power-level 0
cable upstream 3 channel-width 1600000 1600000
cable upstream 3 minislot-size 4
no cable upstream 3 shutdown
cable upstream 4 frequency 34000000
cable upstream 4 power-level 0
cable upstream 4 channel-width 1600000 1600000
cable upstream 4 minislot-size 4
cable upstream 4 modulation-profile 3
no cable upstream 4 shutdown
cable upstream 5 frequency 35008000
cable upstream 5 power-level 0
cable upstream 5 channel-width 1600000 1600000
cable upstream 5 minislot-size 4
cable upstream 5 modulation-profile 3
no cable upstream 5 shutdown
cable source-verify leasetimer 5
cable dhcp-giaddr policy
cable privacy accept-self-signed-certificate
cable privacy authenticate-modem
cable privacy authorize-multicast
cable privacy kek life-time 300
cable privacy tek life-time 180
no keepalive
!
!
router rip
version 2
redistribute bgp 222 metric transparent
network 10.10.0.0
no auto-summary
!
!
ip default-gateway 192.168.100.1
ip classless
no ip forward-protocol udp netbios-ns
no ip forward-protocol udp netbios-dgm
no ip http server
no ip http secure-server
!
!
!
!
snmp-server community private RW
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps config
snmp-server enable traps cable
snmp-server enable traps docsis-cmts
snmp-server enable traps syslog
!
line con 0
exec-timeout 0 0
password 7 070C285F4D06
stopbits 1
line vty 0 4
session-timeout 60
exec-timeout 0 0
password 7 0703204E
line vty 5 15
!
scheduler allocate 4000 200
end

Cisco uBR10012 ルータ用の DOCSIS 1.1 コンフィギュレーション(BPI+ を設定)

version 12.2
service timestamps log datetime msec localtime
service password-encryption
!
hostname uBR10012
!
redundancy
main-cpu
auto-sync standard
logging queue-limit 100
no logging buffered
no logging rate-limit
enable password my-enable-password
!
ipc cache 5000
card 1/1 2cable-tccplus
card 2/0 1gigethernet-1
card 2/1 2cable-tccplus
card 3/0 1gigethernet-1
card 4/0 1oc12pos-1
card 8/0 5cable-mc520s
card 8/1 5cable-mc520s
cable flap-list insertion-time 60
cable flap-list power-adjust threshold 4
cable flap-list aging 86400
cable modem vendor 00.50.F1 TI
cable spectrum-group 2 band 11000000 16000000
cable spectrum-group 21 band 17000000 25000000
cable spectrum-group 32 shared
cable spectrum-group 32 band 5000000 42000000
cable modulation-profile 2 request 0 16 0 8 qpsk scrambler 152 no-diff 64 fixed uw16
cable modulation-profile 2 initial 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 2 station 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 2 short 6 75 6 8 16qam scrambler 152 no-diff 144 shortened uw8
cable modulation-profile 2 long 8 220 0 8 16qam scrambler 152 no-diff 160 shortened uw8
cable modulation-profile 21 request 0 16 0 22 qpsk scrambler 152 no-diff 32 fixed
cable modulation-profile 21 initial 5 34 0 48 qpsk scrambler 152 no-diff 64 fixed
cable modulation-profile 21 station 5 34 0 48 qpsk scrambler 152 no-diff 64 fixed
cable modulation-profile 21 short 3 76 12 22 qpsk scrambler 152 no-diff 64 shortened
cable modulation-profile 21 long 7 231 0 22 qpsk scrambler 152 no-diff 64 shortened
cable modulation-profile 22 request 0 16 0 22 qpsk scrambler 152 no-diff 32 fixed
cable modulation-profile 22 initial 5 34 0 48 qpsk scrambler 152 no-diff 64 fixed
cable modulation-profile 22 station 5 34 0 48 qpsk scrambler 152 no-diff 64 fixed
cable modulation-profile 22 short 4 76 7 22 16qam scrambler 152 no-diff 128 shortened
cable modulation-profile 22 long 7 231 0 22 16qam scrambler 152 no-diff 128 shortened
cable modulation-profile 23 request 0 16 0 22 qpsk scrambler 152 no-diff 32 fixed
cable modulation-profile 23 initial 5 34 0 48 qpsk scrambler 152 no-diff 64 fixed
cable modulation-profile 23 station 5 34 0 48 qpsk scrambler 152 no-diff 64 fixed
cable modulation-profile 23 short 4 76 7 22 16qam scrambler 152 no-diff 128 shortened
cable modulation-profile 23 long 7 231 0 22 16qam scrambler 152 no-diff 128 shortened
cable qos profile 5 max-downstream 10000
cable qos profile 5 max-upstream 1000
cable qos profile 5 priority 7
cable qos profile 5 tos-overwrite 0x3 0x0
cable qos profile 5 name cm_no_priority
cable qos profile 6 max-downstream 10000
cable qos profile 6 max-upstream 5000
cable qos profile 6 priority 7
cable qos profile 6 tos-overwrite 0x3 0x0
cable qos profile 6 name cv_su
cable qos profile 7 max-downstream 128
cable qos profile 7 max-upstream 128
cable qos profile 7 priority 7
cable qos profile 8 max-downstream 10000
cable qos profile 8 max-upstream 1000
cable qos profile 8 priority 3
cable qos profile 8 tos-overwrite 0x3 0x0
cable qos profile 8 name ool_cm
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable event syslog-server 10.10.10.131
ip subnet-zero
!
!
interface FastEthernet0/0/0
ip address 10.10.32.21 255.255.0.0
no cdp enable
!
interface GigabitEthernet2/0/0
ip address 10.10.31.2 255.0.0.0
no ip redirects
no ip unreachables
no ip proxy-arp
load-interval 30
negotiation auto
no cdp enable
!
interface GigabitEthernet3/0/0
no ip address
ip pim sparse-mode
no ip route-cache cef
load-interval 30
shutdown
negotiation auto
no cdp enable
!
interface POS4/0/0
no ip address
crc 32
no cdp enable
pos ais-shut
!
!
interface Cable8/0/0
ip address 10.10.10.28 255.255.255.0
ip helper-address 1.10.10.133
cable bundle 2 master
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream frequency 669000000
cable downstream channel-id 0
no cable downstream rf-shutdown
cable downstream rf-power 45
cable upstream 0 connector 0
cable upstream 0 spectrum-group 32
cable upstream 0 power-level 0
cable upstream 0 channel-width 1600000
cable upstream 0 minislot-size 4
cable upstream 0 range-backoff 3 6
cable upstream 0 data-backoff 0 6
cable upstream 0 modulation-profile 23
no cable upstream 0 rate-limit
no cable upstream 0 shutdown
cable upstream 1 connector 1
cable upstream 1 spectrum-group 32
cable upstream 1 power-level 0
cable upstream 1 channel-width 1600000
cable upstream 1 minislot-size 4
cable upstream 1 data-backoff 0 6
cable upstream 1 modulation-profile 23
no cable upstream 1 shutdown
cable upstream 2 connector 2
cable upstream 2 spectrum-group 32
cable upstream 2 power-level 0
cable upstream 2 channel-width 1600000
cable upstream 2 minislot-size 4
cable upstream 2 data-backoff 3 6
cable upstream 2 modulation-profile 23
no cable upstream 2 shutdown
cable upstream 3 connector 3
cable upstream 3 spectrum-group 32
cable upstream 3 channel-width 1600000
cable upstream 3 minislot-size 4
cable upstream 3 modulation-profile 21
no cable upstream 3 shutdown
cable source-verify
cable privacy kek life-time 300
cable privacy tek life-time 180
no keepalive
!
interface Cable8/0/1
ip address 10.10.11.121
cable bundle 2
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream frequency 453000000
cable downstream channel-id 0
no cable downstream rf-shutdown
cable upstream max-ports 6
cable upstream 0 connector 4
cable upstream 0 spectrum-group 2
cable upstream 0 power-level 0
cable upstream 0 channel-width 1600000
cable upstream 0 minislot-size 4
cable upstream 0 range-backoff 3 6
cable upstream 0 data-backoff 0 6
cable upstream 0 modulation-profile 23 21
no cable upstream 0 rate-limit
cable upstream 0 shutdown
cable upstream 1 connector 5
cable upstream 1 channel-width 1600000
cable upstream 1 minislot-size 4
cable upstream 1 modulation-profile 21
cable upstream 1 shutdown
cable upstream 2 connector 6
cable upstream 2 channel-width 1600000
cable upstream 2 minislot-size 4
cable upstream 2 modulation-profile 21
cable upstream 2 shutdown
cable upstream 3 connector 7
cable upstream 3 channel-width 1600000
cable upstream 3 minislot-size 4
cable upstream 3 modulation-profile 21
cable upstream 3 shutdown
cable upstream 4 channel-width 1600000
cable upstream 4 minislot-size 4
cable upstream 4 modulation-profile 21
cable upstream 4 shutdown
cable upstream 5 channel-width 1600000
cable upstream 5 minislot-size 4
cable upstream 5 modulation-profile 21
cable upstream 5 shutdown
cable source-verify
cable privacy kek life-time 300
cable privacy tek life-time 180
no keepalive
!
!
ip classless
ip http server
no ip http secure-server
!
!
no cdp run
snmp-server community public RW
snmp-server community private RW
snmp-server enable traps cable
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
password my-telnet-password
login
length 0
!
end

参考資料

DOCSIS 1.1 動作に関連する情報については、次の参考資料を参照してください。

関連資料

関連項目
資料名

ケーブル コマンド リファレンス ガイド

この章で使用しているケーブル固有のコマンドの構文および使用方法については、次の URL で、『 Cisco Broadband Cable Command Reference Guide 』の「Cisco Cable Modem Termination System Commands」の章を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/cable/bbccmref/bbcmts.htm

DHCP の設定

Cisco CMTS に搭載された DHCP サーバを設定するには、次の URL で『 Cisco IOS IP and IP Routing Configuration Guide 』Release 12.2T の「IP Addressing and Services」の「Configuring DHCP」の章を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fipr_c/index.htm

すべての DHCP コマンドについては、次の URL で『 Cisco IOS IP Command Reference, Volume 1 of 3:Addressing and Services 』Release 12.2T の「DHCP Commands」の章を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fipras_r/index.htm

HCCP N+1 コンフィギュレーション

Cisco CMTS に N+1 冗長機能を設定するには、次の URL で『 Cisco CMTS Feature Guide 』の「 N+1 Redundancy for the Cisco Cable Modem Termination System 」を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/cable/cab_rout/cmtsfg/ufgnpls1.htm

NTP または SNTP の設定

Cisco CMTS を設定して Network Time Protocol(NTP)または Simple Network Time Protocol(SNTP)を使用し、システム クロックを設定するには、次の URL で『 Cisco IOS Configuration Fundamentals Configuration Guide 』Release 12.2T の「System Management」にある「Performing Basic System Management」の章を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/ffun_c/fcfprt3/fcf012.htm

ソフトウェア コンフィギュレーション ガイド

ケーブル動作に関する CMTS ルータの設定の情報については、使用しているルータの該当するソフトウェア コンフィギュレーション ガイドを参照してください。各ルータのガイドは次の URL に用意されています。

http://www.cisco.com/univercd/cc/td/doc/product/cable/index.htm

標準規格

2.サポートしている標準規格をすべて記載しているわけではありません。

MIB

MIB 3
MIB リンク

DOCS-BPI-PLUS-MIB

DOCS-CABLE-DEVICE-MIB(RFC 2669)

DOCS-CABLE-DEVICE-TRAP-MIB

DOCS-IF-EXT-MIB

DOCS-IF-MIB(RFC 2670)

DOCS-QOS-MIB

DOCS-SUBMGT-MIB

IGMP-STD-MIB(RFC 2933)

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

3.サポートしている MIB(管理情報ベース)をすべて記載しているわけではありません。

RFC

RFC 4
タイトル

RFC 2669

DOCS-CABLE-DEVICE-MIB

RFC 2670

DOCS-IF-MIB

RFC 2933

IGMP-STD-MIB

4.サポートしている Request for Comments(RFC)をすべて記載しているわけではありません。

テクニカル サポート

説明
リンク

TAC ホームページは、3 万ページの技術コンテンツが検索可能で、製品、技術、ソリューション、技術ヒント、ツールへのリンクが含まれています。Cisco.com 登録ユーザは、このページからログインしてさらに豊富なコンテンツにアクセスできます。

http://www.cisco.com/public/support/tac/home.shtml