Cisco Cable Modem Termination System (CMTS) の概要
Cisco Cable Modem Termination System(CMTS)の概要
Cisco Cable Modem Termination System(CMTS)の概要
発行日;2012/02/03 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

Cisco Cable Modem Termination System(CMTS)の概要

内容

の前提条件

の制限事項

の概要

機能の概要

内蔵 DHCP サーバ

DHCP フィールド オプション

DHCP セキュリティ オプション

複数の DHCP プール

外部 DHCP サーバ

ケーブル送信元確認機能

スマート リレー機能

giaddr フィールド

ToD サーバ

TFTP サーバ

利点

の設定方法

DHCP サービスの設定

ケーブル モデム用の DHCP アドレス プールの作成と設定

CPE 装置用の DHCP アドレス プールの作成と設定(任意)

ToD サービスの設定

前提条件

ToD サービスのイネーブル化

ToD サービスのディセーブル化

TFTP サービスの設定

基本オールインワン コンフィギュレーションの設定(任意)

拡張オールインワン コンフィギュレーションの設定(任意)

外部 DHCP サーバの使用の最適化

ケーブル送信元確認オプションの設定(任意)

制限事項

オプションの DHCP パラメータの設定(任意)

cable-source verify dhcp コマンドに設定する DHCP MAC アドレス除外リスト

設定例

DHCP サーバ例

ケーブル モデム用 DHCP プール

ケーブル モデムをディセーブルにする DHCP プール

CPE 装置用 DHCP プール

ToD サーバ例

TFTP サーバ例

基本オールインワン コンフィギュレーション例

拡張オールインワン コンフィギュレーション例

参考資料

関連資料

標準規格

MIB

RFC

テクニカル サポート

Cisco Cable Modem Termination System(CMTS)の概要

改訂: February 5, 2007, OL-1467-08-J

この章では、Cisco Cable Modem Termination System(CMTS; ケーブル モデム終端システム)プラットフォームを設定して、Data-over-Cable Service Interface Specifications(DOCSIS)ネットワークで使用される、Dynamic Host Configuration Protocol(DHCP)、Time-of-Day(ToD)、および Trivial File Transfer Protocol(TFTP; 簡易ファイル転送プロトコル)サービスを提供するオンボード サーバをサポートする方法について説明します。さらに、外部 DHCP サーバで使用可能なオプションの設定に関する情報についても取り上げます。

Cable Monitor and Interceptの機能仕様

機能履歴
リリース
変更

Release 11.3 NA

cable source-verify および ip dhcp コマンドが、現在、Cisco uBR7200 シリーズ ルータでサポートされています。

Release 12.0(4)XI

cable time-server コマンドが、現在、サポートされています。

Release 12.1(2)EC1

以下のコマンドが現在、Cisco IOS Release 12.1 EC トレインでサポートされています。

cable config-file

cable dhcp-giaddr

cable helper-address

cable source-verify コマンドが強化され、 dhcp キーワードが追加されました。

Release 12.1(5)EC1

現在、Cisco uBR7100 シリーズがサポートされています。

Release 12.2(4)BC1

現在、Cisco uBR7100 シリーズ、Cisco uBR7200 シリーズ、および Cisco uBR10012 ルータが上記コマンドをサポートしています。

Release 12.1(11b)EC1、Release 12.2(8)BC2

cable tftp-enforce コマンドが、現在、サポートされています。

Release 12.1(13)EC、Release 12.2(11)BC1

cable source-verify コマンドが強化され、 leasetimer キーワードが追加されました。

Release 12.3(13)BC

cable source-verify dhcp コマンドが強化され、MAC アドレスを除外できるようになりました。

Release 12.3(21)BC

cable helper-address コマンドが強化され、ケーブル モデム、MTA、STB、または他のケーブル デバイスのいずれかから送信されたかに基づいて DHCP パケットの転送先を指定できるようになりました。

cable dhcp-insert コマンドでは、オプション 82 を使用して DHCP パケットにディスクリプタを挿入するように CMTS を設定できます。それによって、DHCP サーバは、ケーブル モデムのクローンを検出し、地理的情報を抽出できます。

show cable modem docsis device-class コマンドが、現在、サポートされています。

サポート対象プラットフォーム

Cisco uBR7100 シリーズ、Cisco uBR7200 シリーズ、Cisco uBR10012 ユニバーサル ブロードバンド ルータ

プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報

プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報を調べるには、Cisco Feature Navigator を使用します。Cisco Feature Navigator は、 http://www.cisco.com/go/fn からアクセスできます。Feature Navigator にアクセスするには、Cisco.com のアカウントが必要です。アカウントを登録していない場合、またはユーザ名とパスワードを忘れた場合には、ログイン ダイアログ ボックスで Cancel をクリックして表示される手順に従います。

Cable Monitor and Intercept の前提条件

シスコでは、DOCSIS 1.0 動作用に、最新の Cisco IOS Release 12.1 EC ソフトウェア リリースを推奨します。また、DOCSIS 1.1 動作用に、最新の Cisco IOS Release 12.2 BC ソフトウェア リリースを推奨します。

Cisco CMTS ルータのオンボードの内蔵 DOCSIS コンフィギュレーション ファイル エディタは DOCSIS 1.0 コンフィギュレーション ファイルのみをサポートしているので、DOCSIS 1.1 コンフィギュレーション ファイルを構築するには別の DOCSIS コンフィギュレーション ファイル エディタが必要です。

単独または外部の ToD サーバと一緒に Cisco CMTS を ToD サーバとして使用するには、DHCP サーバを設定してケーブル モデムの有効な ToD サーバ(DHCP オプション 4)の 1 つとして Cisco CMTS に IP アドレスを提供します。

Cable Monitor and Intercept の制限事項

小型ケーブル プラント(約 2,500 のケーブル モデム、研究所環境、初期テスト、小規模展開、およびトラブルシューティング)以外の環境では、「オールインワン」コンフィギュレーションを唯一のサーバ セットとして使用しないでください。ただし、「オールインワン」コンフィギュレーションは、他の冗長およびバックアップ サーバを補完するために、より大規模なネットワークで使用できます。

DOCSIS 仕様に準拠するために、ToD サーバは UDP プロトコルを使用してください。

特に Baseline Privacy Interface Plus(BPI+)暗号化および認証を使用する DOCSIS 1.1 ネットワークなどの、DOCSIS ネットワークを適切に動作させるために、Cisco CMTS のシステム クロックを正確に設定してください。 set clock コマンドを使用して手動でこれを実行するか、Network Time Protocol(NTP)または Simple Network Time Protocol(SNTP)のいずれかを使用して CMTS を設定することでこれを実行します。

Cisco CMTS ルータのオンボードにある内蔵 DHCP サーバは cable source-verify コマンドをサポートしていません。

Cable Monitor and Intercept の概要

ここでは、Cable Monitor and Intercept機能と、個々のコンポーネントに関する以下の情報について説明します。

「機能の概要」

「内蔵 DHCP サーバ」

「外部 DHCP サーバ」

「ToD サーバ」

「TFTP サーバ」

機能の概要

すべての Cisco CMTS プラットフォームは、DOCSIS ケーブル ネットワークで使用される DHCP、ToD、および TFTP サービスを提供するオンボード サーバをサポートします。これらのサーバは DOCSIS 1.0 および 1.1 準拠のケーブル モデムで必要な登録サービスを提供します。

内蔵 DHCP サーバ ― IP アドレス、サブネット マスク、デフォルト ゲートウェイ、および他の IP 関連パラメータを持つケーブル モデムを提供します。ケーブル モデムは、最初に電源が投入されケーブル ネットワークにログオンする際に、DHCP サーバと接続します。

外部 DHCP サーバ ― オンボード DHCP サーバと同じ機能を提供しますが、外部 DHCP サーバは通常、大規模なケーブル ネットワークを管理する際に最適な統合プロビジョニング システムの一部です。

ToD サーバ RFC 868 準拠の ToD サービスを提供し、登録プロセス中にケーブル モデムが現在の日時を取得できます。IP アドレスおよび他の DHCP が提供する IP パラメータを取得した後に、ケーブル モデムは ToD サーバに接続します。

ケーブル モデムはオンラインになる前に ToD 要求を正常に完了する必要はありませんが、この作業を行うことによって正確なタイムスタンプをイベント ログに追加することができ、これらのログを CMTS で使用されているクロックと協調させることができます。さらに、ケーブル モデムが BPI+ 暗号化および認証で登録しようとする場合、正確な日付と時間が重要となります。

TFTP サーバ ― DOCSIS コンフィギュレーション ファイルをケーブル モデムにダウンロードします。DOCSIS コンフィギュレーション ファイルには、ケーブル モデム用の運用パラメータが含まれています。ケーブル モデムは、ToD サーバと接続した後にその DOCSIS コンフィギュレーション ファイルをダウンロードします。

各サーバを個別に設定して使用することができます。また、「オールインワン」コンフィギュレーションを設定して CMTS を DHCP、ToD、および TFTP サーバとして動作させることができます。このコンフィギュレーションを使用すれば追加のサーバは不要ですが、サーバを追加することによって追加サーバで冗長性、ロード バランシング、およびスケーラビリティが得られます。


) 追加サーバを設定する方法はいくつかあります。たとえば、ほとんどのケーブル事業者は Cisco Network Registrar(CNR)を使用して DHCP および TFTP サーバを提供しています。ToD サーバはほとんどのワークステーションおよび PC で自由に利用できます。追加サーバは 1 つのワークステーションまたは PC に設置することも、複数のワークステーションや PC に設置することもできます。


内蔵 DHCP サーバ

電源投入時に、DOCSIS ケーブル モデムは、ネットワークでの IP 接続用に必要な情報を提供する DHCP サーバを見つけるために、ケーブル インターフェイスを通じてブロードキャスト メッセージを送信します。ケーブル モデムがオンラインになった後、ケーブル モデムに接続された Customer Premises Equipment(CPE; 顧客宅内機器)装置も DHCP 要求を作成できます。すべての Cisco CMTS プラットフォームを、DOCSIS ケーブル モデムや CPE 装置で必要な IP アドレッシングおよび他のネットワーキング情報を提供する DHCP サーバとして動作するように設定できます。

DHCP フィールド オプション

DHCP 要求メッセージでは、ケーブル モデムは MAC ハードウェア アドレスで識別されます。応答では、DOCSIS 互換 DHCP サーバが、ケーブル ネットワークへのアクセスが許可されるケーブル モデムに応答する際に、少なくもと以下のフィールドを提供します。

yiaddr ― ケーブル モデムの IP アドレス

サブネット マスク(オプション 1) ― ケーブル モデム用の IP サブネット マスク

siaddr ― DOCSIS コンフィギュレーション ファイルを提供する TFTP サーバ用の IP アドレス

ファイル ― ケーブル モデムがダウンロードする必要がある DOCSIS コンフィギュレーション ファイルのファイル名

ルータ オプション(オプション 3) ― ケーブル モデム トラフィックを転送する 1 つまたは複数のゲートウェイ用 IP アドレス

タイム サーバ オプション(オプション 4) ― ケーブル モデムが現在の日付と時間を取得できる 1 つまたは複数の ToD サーバ

タイム オフセット(オプション 2) ― ケーブル モデムがローカル時間を計算するのに使用する Universal Coordinated Time(UTC; 協定世界時)

giaddr ― DHCP サーバがケーブル モデムと異なるネットワークにある場合の、DHCP リレー エージェントの IP アドレス

ログ サーバ オプション(オプション 7) ― ケーブル モデムがエラー メッセージやその他のロギング情報を送信する 1 つまたは複数の Syslog サーバの IP アドレス(任意)

IP アドレス リース時間(オプション 51) ― IP アドレスが有効である秒数で、この時間内にケーブル モデムは他の DHCP 要求を作成する必要があります。

ケーブル モデムに接続された CPE 装置にも IP アドレスを提供する場合、DHCP サーバは以下の情報も CPE 装置に提供する必要があります。

yiaddr ― CPE 装置用の IP アドレス

サブネット マスク(オプション 1) ― CPE 装置用の IP サブネット マスク

ルータ オプション(オプション 3) ― CPE トラフィックを転送する 1 つまたは複数のゲートウェイ用 IP アドレス

ドメイン ネーム サーバ オプション(オプション 6) ― ホスト名を解決して CPE 装置の IP アドレスに変換するDomain Name System(DNS; ドメイン ネーム システム)サーバの IP アドレス

ドメイン名(オプション 15) ― CPE 装置がホスト名に追加する、完全修飾ドメイン名

IP アドレス リース時間(オプション 51) ― IP アドレスが有効である秒数で、この時間内に CPE 装置は他の DHCP 要求を作成する必要があります。

Cisco CMTS の DHCP サーバは、ネットワーク運用に最低限必要となるよりも、多くのオプションを提供できます。基本的なコンフィギュレーションは、小規模なインストールや研究所および試験用のネットワークに最適です。

また CMTS を、DHCP プールの機能を使用するような複雑なコンフィギュレーションに設定できます。DHCP プールは、ネットワーク番号に従って階層型に構成されています。他のプールのネットワーク番号のサブセットであるネットワーク番号を持つ DHCP プールは、大きい方のプールの特性をすべて継承します。

DHCP セキュリティ オプション

DOCSIS 仕様では、ケーブル モデムは DHCP サーバから IP アドレスを取得する必要があるので、ケーブル ネットワークは、次のようなある種の設定エラーやサービスの窃盗攻撃の影響を受けやすくなっています。

2 つ以上のケーブル モデムまたは CPE 装置に割り当てられた、重複 IP アドレス

2 つ以上のケーブル モデムまたは CPE 装置から報告される、重複 MAC アドレス

DHCP 割り当て IP アドレスを固定スタティック アドレスとして使用する、IP アドレスの不正使用

他のユーザの有効な IP アドレスを乗っ取って異なるネットワーク デバイスで使用する、IP アドレスの乗っ取り

ケーブル セグメントで許可されていないネットワーク アドレスを持つ IP アドレスの設定

通常サービスの窃盗攻撃の一部として実行される、ケーブル セグメントの代理としての無許可の Address Resolution Protocol(ARP; アドレス解決プロトコル)要求

これらの攻撃に対抗する方法として、Cisco CMTS は、既知の CPE 装置の MAC および IP アドレスと、CPE 装置にネットワーク アクセスを提供するケーブル モデムとをリンクするデータベースを、動的に維持します。CMTS は、内蔵および外部 DHCP サーバからの情報を使用してこれらのデータベースを構築します。

内蔵 DHCP サーバを使用する場合、CMTS は自動的にサーバで処理される DHCP 要求および応答からデータベースを読み込みます。

外部サーバを使用する場合、ケーブル インターフェイス上にあるケーブル モデムおよび CPE 装置と DHCP サーバとの間のケーブル インターフェイスで送信された、すべてのブロードキャスト DCHP トランザクションを検査することで、CMTS がデータベースを読み込みます。


) また Cisco CMTS は、CPE 装置からの IP トラフィックをモニタして、IP および MAC アドレスと、インターネット接続を提供しているケーブル モデムとを関連づけます。


また CMTS は、DHCP リレー エージェント情報オプション(DHCP オプション 82)を使用して、MAC アドレスや、それが接続しているケーブル インターフェイスなどの、ケーブル モデムに関する特定の情報を送信できます。DHCP サーバでその情報とデータベースにあるケーブル モデムに属する情報とが一致しなかった場合、CMTS はその装置を CPE 装置と認識します。これにより、CMTS および DHCP サーバは、CPE 装置がどのケーブル モデムを使用していて、CPE 装置がネットワーク アクセスを許可されているか否かということについて、正確な情報を取得できます。

また、DHCP リレー エージェントを使用して、クローン モデムを識別したり、E911 や他のアプリケーションの地理的情報を収集したりできます。 cable dhcp-insert コマンドを使用して、DHCP パケットにダウンストリーム、アップストリーム、またはホスト名のディスクリプタを挿入するように、CMTS を設定します。その後、DHCP サーバは、この情報を利用して、クローン モデムを検出したり、地理的情報を抽出したりできます。最大リレー情報オプション サイズの範囲内で、複数タイプのストリングを設定できます。

複数の DHCP プール

IP アドレスの割り当てに使用する DHCP サーバ用の DHCP プールはいくつでも設定できます。単一のプールを基本コンフィギュレーションで使用することも、また、オプションでケーブル モデムと CPE 装置用に個別のプールを作成することもできます。また、スタティック IP アドレスなどの特殊なサービス用や、これらのサービスを有料で使用しているお客様用に DHCP アドレス プールを使用できます。

複数の DHCP プールを作成する場合、これらを個別に設定できます。またオプションで、ネットワーク番号に従って編成された階層構造のプールも作成できます。他のプールのネットワーク番号のサブセットであるネットワーク番号を持つ DHCP プールは、大きい方のプールの特性をすべて継承します。階層型の特性に加えて、任意の数のオプションを使用して各プールをさらにカスタマイズできます。

DHCP プールの利点は、特定のお客様やアプリケーションに対して、プールが共通に持つパラメータについて CLI(コマンドライン インターフェイス)コマンドの入力を繰り返すことなく、多くの異なる DHCP コンフィギュレーションを作成できることです。また他のプールのお客様に影響を与えることなく、あるプールの設定を変更できます。

外部 DHCP サーバ

Cisco CMTS ルータは、DOCSIS ケーブル ネットワークで使用している外部 DHCP サーバの動作とセキュリティを強化する、以下のオプションの設定を提供します。

「ケーブル送信元確認機能」

「スマート リレー機能」

「giaddr フィールド」

ケーブル送信元確認機能

サービスの窃盗攻撃に対抗するために、Cisco CMTS ルータのケーブル インターフェイスで cable source-verify コマンドをイネーブルにできます。この機能は、ルータの内部データベースを使用して CMTS がケーブル インターフェイスで受信する IP パケットの有効性を確認して、次の 3 つの保護レベルを提供するものです。

最も基本的な保護レベルでは、ケーブル送信元確認機能がすべてのアップストリーム IP パケットを検査して、ケーブル ネットワークで発生する重複 IP アドレスを防ぎます。重複が発生したら、DHCP サーバが IP アドレスを割り当てたデバイスからのパケットのみを CMTS は認識します。重複アドレスを持つデバイスはネットワーク アドレスを許可されません。また CMTS は、デバイスの IP アドレスが特定のケーブル セグメントで許可されていないネットワーク アドレスを持つ場合に、そのデバイスからのトラフィックを認識することを拒否します。

dhcp オプションを cable source-verify コマンドに追加することで、ユーザが現在未使用の IP アドレスをデバイスに静的に割り当てないようにして、より包括的な保護レベルを提供できます。Cisco CMTS がケーブル インターフェイスで未知の IP アドレスを持つパケットを受信すると、CMTS はパケットを廃棄しますが、DHCP LEASEQUERY メッセージを発行して DHCP サーバにそのデバイスの IP アドレスおよび MAC アドレスに関する情報を問い合わせます。DHCP サーバがそのデバイスに関する情報を何も返さなかった場合、CMTS はそのデバイスからのネットワーク アクセスのブロックを継続します。

dhcp オプションを使用する場合、 leasetimer オプションもイネーブルにできます。これは、リース時間が満了した IP アドレスについて、内部 CPE データベースを定期的にチェックするように CMTS に指示するものです。有効期限が切れた IP アドレスを使用する CPE 装置は、有効な DHCP サーバから IP アドレスを新たに取得するまでその後のネットワークへのアクセスを拒否されます。これにより、ユーザが DHCP 割り当て IP アドレスを取得してそれをスタティック アドレスとして CPE 装置に割り当てられないようにします。

スマート リレー機能

Cisco CMTS は、スマート リレー機能( ip dhcp smart-relay コマンド)をサポートします。これは、プライマリ DHCP サーバの IP アドレスがなくなったり IP アドレスの応答ができなくなったりした場合に、自動的にケーブル モデムや CPE 装置をセカンダリ DHCP サーバやアドレス プールに切り替えるものです。リレー エージェントは、プライマリ サーバへの DHCP 要求の転送を 3 回試みます。3 回の試行でプライマリから応答がなく失敗したあと、リレー エージェントは自動的にセカンダリ サーバに切り替えます。

cable dhcp-giaddr policy コマンドを使用して、CPE 装置がケーブル インターフェイスのセカンダリ アドレスに対応したセカンダリ DHCP プールを使用するように指定した場合、スマート リレー エージェントは使用可能なアドレス プールが見つかるまで自動的に使用可能なセカンダリ プールをラウンド ロビン式で循環させます。これにより、クライアントは、特定のプールが使い果たされることでネットワークから締め出されることがなくなります。

giaddr フィールド

ケーブル モデムと CPE 装置用に個別の IP アドレス プールを使用する場合、 cable dhcp-giaddr policy コマンドを使用して、ケーブル モデムがプライマリ プールからのアドレスを使用し、CPE 装置がセカンダリ プールからのアドレスを使用するように指定できます。デフォルトでは、CMTS がすべての DHCP 要求をプライマリ DHCP サーバに送信し、セカンダリ サーバはプライマリ サーバが応答しない場合にかぎって使用されるようになっています。

ToD サーバ

Cisco CMTS は、ケーブル インターフェイスに接続されたケーブル モデムおよび他の CPE 装置に現在の日付と時刻を提供する ToD サーバとして機能できます。これにより、ケーブル モデムと CPE 装置は、SNMP(簡易ネットワーク管理プロトコル)メッセージおよびエラー ログ エントリのタイムスタンプを正確に取得することができます。また同時にケーブル ネットワーク内のすべてのシステム クロックを同一システム時間で確実に同期できます。


ヒント Cisco CMTS の初期の ToD サーバは、互換性のないパケット フォーマットを使用する一部のケーブル モデムと連動して動作することができませんでした。この問題は、Cisco IOS Release 12.1(8)EC1 以降の 12.1 EC リリースと、Cisco IOS Release 12.2(4)BC1 以降の 12.2 BC リリースで解決されました。


現在の DOCSIS 1.0 および 1.1 仕様では、すべての DOCSIS ケーブル モデムが初期電源投入プロビジョニング中に送信する DHCP 要求で以下の時間関連フィールドを必要とします。

タイム オフセット(オプション 2) ― ケーブル モデムまたは CPE 装置のタイムゾーンを、装置のタイムスタンプがGMT(グリニッジ標準時)からずれている秒数で指定します。

タイム サーバ オプション(オプション 4) ― ToD サーバの 1 つまたは複数の IP アドレスを指定します。

ケーブル モデムが正常に DHCP リース時間を取得したら、DHCP サーバから提供されるリストにある ToD サーバの 1 つに接続しようとします。接続できた場合、ケーブル モデムは ToD サーバから受信したタイム オフセットおよびタイムスタンプを使用して、システム クロックを更新します。

ToD サーバにアクセスできなかった場合、または応答がなかった場合、ケーブル モデムはやがてタイムアウトし、CMTS にエラーがロギングされ、初期化プロセスを続けます。ケーブル モデムは ToD サーバの応答を受信しなくてもオンラインになることができますが、ToD 応答を正常に受信できるまで定期的に(少なくとも 5 分に 1 回)ToD サーバにアクセスする必要があります。ToD サーバに接続できるまで、ケーブル モデムはシステム クロックを 1970 年 1 月 1 日の午前 0 時(GMT)に初期化する必要があります。


) DOCSIS 1.0 仕様の最初のバージョンでは、ケーブル装置は ToD サーバから有効な応答を得ないかぎり、初期化プロセスを続けることができないと規定されていました。この要件は、リリース済みの DOCSIS 1.0 仕様および DOCSIS 1.1 仕様では削除されています。ただし、最初の DOCSIS 1.0 仕様に準拠した古いファームウェアで動作しているケーブル装置の場合、ToD サーバからの応答を受信できないと、オンラインにならないものがあります。


ケーブル モデムは ToD サーバからの応答を受信するまでサーバへの接続を繰り返し再試行するために、ヘッドエンドに他に 1 つまたは複数の ToD サーバがあっても、ToD サーバが Cisco CMTS でアクティブにするよう考慮してください。これにより、ネットワークの輻輳によって他のサーバがダウンしたり接続できなくても、オンラインのケーブル モデムが常に Cisco CMTS にある ToD サーバへ確実に接続できるようになり、ToD 要求を繰り返し送信しなくなります。


ヒント 単独または外部の ToD サーバと一緒に Cisco CMTS を ToD サーバとして使用するには、DHCP サーバを設定してケーブル モデムの有効な ToD サーバ(DHCP オプション 4)の 1 つとして Cisco CMTS に IP アドレスを提供する必要があります。詳細については、「ケーブル モデム用の DHCP アドレス プールの作成と設定」を参照してください。


さらに、DOCSIS 仕様では、ケーブル モデムはオンラインになる前に ToD サーバから応答を正しく受け取る必要はありませんが、次の場合、タイムスタンプを受け取らないとケーブル モデムはオンラインになることができません。

DOCSIS コンフィギュレーション ファイルにタイムスタンプが使用されている場合、ケーブル モデムがそのファイルをキャッシュし再生しないようにするために、ケーブル モデムおよび CMTS 上のクロックを同期させる必要があります。こうしないと、ケーブル モデムは DOCSIS コンフィギュレーション ファイルのタイムスタンプが正しいかどうかを判断できません。

Baseline Privacy Internet Plus(BPI+)の認証および暗号化を使用してケーブル モデムを登録する場合、ケーブル モデムおよび CMTS 上のクロックは必ず同期しなければなりません。これは、BPI+ 許可では、CMTS およびケーブル モデムは認証に使用しているデジタル認証のタイムスタンプを確認する必要があるからです。CMTS およびケーブル モデムのタイムスタンプが同期していない場合、ケーブル モデムは BPI+ 暗号化を使用してオンラインになることはできません。


) DOCSIS ケーブル モデムは、RFC 868 互換 ToD サーバを使用して現在のシステム時間を取得する必要があります。この目的で NTP や SNTP サービスを使用できません。ただし、Cisco CMTS は、NTP または SNTP サーバを使用して CMTS 自身のシステム クロックを設定し、その後 ToD サーバを使用することができます。そうしない場合、CMTS が起動するたびに clock set コマンドを使用して手動で CMTS のクロックを設定する必要があります。



ヒント ケーブル ヘッドエンドにインストールされているワークステーションや PC から追加のサーバを提供できます。通常 UNIX および Solaris システムには、オペレーティング システムの一部として ToD サーバが含まれていて、適切な設定行を inetd.conf ファイルに配置することでイネーブルにできます。Windows システムでは、Greyware や Tardis などのシェアウェア サーバを使用できます。DOCSIS 仕様では、ToD サーバは、パケットに対して TCP プロトコルの代わりに UDP プロトコルを使用する必要があります。


TFTP サーバ

すべての Cisco CMTS プラットフォームは、以下のタイプのファイルを DOCSIS ケーブル モデムに提供する TFTP サーバとして機能するように設定できます。

DOCSIS コンフィギュレーション ファイル ― DOCSIS ケーブル モデムが DHCP リースを取得して ToD サーバの接続を試行した後、ケーブル モデムは TFTP を使用して許可済みの TFTP サーバから DOCSIS コンフィギュレーション ファイルをダウンロードします。DHCP サーバには、DOCSIS コンフィギュレーション ファイル名と TFTP サーバの IP アドレスをケーブル モデムに提供する役割があります。

ソフトウェア アップグレード ファイル ― DOCSIS コンフィギュレーション ファイルで、ケーブル モデムが特定のバージョンのソフトウェアを実行しなければならないと指定されていて、ケーブル モデムがまだそのソフトウェアを実行していない場合、ケーブル モデムはそのソフトウェア ファイルをダウンロードする必要があります。セキュリティ上の理由から、ケーブル事業者は DOCSIS コンフィギュレーション ファイルと新しいソフトウェア ファイルのダウンロードにそれぞれ別の TFTP サーバを使用することができます。

Cisco IOS コンフィギュレーション ファイル ― シスコ ケーブル装置用の DOCSIS コンフィギュレーション ファイルでは、ケーブル モデムが CLI コンフィギュレーション コマンドを含む Cisco IOS コンフィギュレーション ファイルをダウンロードするように指定することもできます。通常、音声ポートや IPSec 暗号化などのプラットフォーム固有の機能を設定するためにこれを実行します。


) DOCSIS コンフィギュレーション ファイルと Cisco IOS コンフィギュレーション ファイルとを混同しないでください。DOCSIS コンフィギュレーション ファイルは DOCSIS 仕様で指定された特定のフォーマットのバイナリ ファイルで、各 DOCSIS ケーブル モデムはオンラインになる前に有効なファイルをダウンロードする必要があります。これに対して、Cisco IOS コンフィギュレーション ファイルは ASCII テキスト ファイルで、1 つまたは複数の Cisco IOS CLI コンフィギュレーション コマンドが含まれています。シスコ ケーブル装置のみが Cisco IOS ファイルをダウンロードできます。


すべての Cisco CMTS プラットフォームは、これらのファイルをケーブル モデムにアップロードできる TFTP サーバとして設定できます。ファイルは有効な装置内に常駐できますが、通常 Cisco CMTS のフラッシュ ディスク スロットに挿入されているフラッシュ メモリにコピーされます。

加えて、Cisco CMTS プラットフォームは、Cisco IOS Release 12.1(2)EC、Cisco IOS Release 12.2(4)BC1 以降のリリースの内蔵 DOCSIS コンフィギュレーション ファイル エディタをサポートしています。内蔵コンフィギュレーション ファイル エディタを使用して DOCSIS コンフィギュレーション ファイルを作成する場合、CMTS はコンフィギュレーション ファイルを CLI コマンドの形で保存します。ケーブル モデムが DOCSIS コンフィギュレーション ファイルを要求すると、CMTS がバイナリ バージョンのファイルを動的に作成してそれをケーブル モデムにアップロードします。


) 内蔵 DOCSIS コンフィギュレーション ファイル エディタは DOCSIS 1.0 コンフィギュレーション ファイルのみをサポートします。詳しくは次の URL の『Internal DOCSIS Configurator File Generator for the Cisco CMTS』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/cable/cab_rout/cmtsfg/ufgcfile.htm

DOCSIS 1.1 コンフィギュレーション ファイルを作成するには、Cisco DOCSIS Configurator ツールなど別のコンフィギュレーション エディタを使用する必要があります。Cisco DOCSIS Configurator ツールは、現時点では次の URL で入手できます。

http://www.cisco.com/cgi-bin/tablebuild.pl/cpe-conf


セキュリティを強化するために、Cisco CMTS プラットフォーム用の現行バージョンの Cisco IOS ソフトウェアには、「TFTP 強制」機能( cable tftp-enforce コマンド)が含まれていて、オンラインになる前にすべてのケーブル モデムがケーブル インターフェイスを介して TFTP ダウンロードを試行しなければならないようにすることができます。これにより、ハッカーがローカル ネットワークを再設定して、ローカル TFTP サーバが未許可の DOCSIS コンフィギュレーション ファイルをケーブル モデムにダウンロードするような、一般的なサービスの窃盗攻撃を防ぐことができます。これにより、ケーブル モデムは、使用を許可されたサービスを提供する DOCSIS コンフィギュレーション ファイルのみをダウンロードするようになります。

利点

「オールインワン」コンフィギュレーションにより、追加のサーバやソフトウェアに投資することなく基本ケーブル モデム ネットワークを設定できます。このコンフィギュレーションは、プラントやケーブル モデムの障害のトラブルシューティングに役立てることもできます。

DHCP コンフィギュレーションは、CMTS 内にある指定したアドレス プールからの IP アドレスを、ケーブル モデムおよびその CPE 装置へ効果的に割り当てて管理できます。

Cisco CMTS は、プライマリまたはバックアップ ToD サーバとして動作し、オンラインになる前にすべてのケーブル モデムが適切な日付と時間で同期することを保証します。また、オンラインになる前に ToD タイムアウト期間を待機する必要がないため、これによりケーブル モデムをより迅速にオンラインにすることができます。

Cisco CMTS の ToD サーバにより、ケーブル ネットワークに接続された全装置で、同じシステム クロックを使用することが保証されるので、多くのケーブル モデム、CPE 装置、Cisco CMTS、および他のサービスによって生成されたデバッグ出力またはエラー ログを分析する場合に、システムのトラブルシューティングが容易になります。

Cisco CMTS は、DOCSIS コンフィギュレーション ファイル、ソフトウェア アップグレード ファイル、および Cisco IOS コンフィギュレーション ファイル用の TFTP サーバとして機能できます。

DOCSIS コンフィギュレーション ファイルを作成して保存するための別のワークステーションや PC が不要です。

「TFTP 強制」機能により、許可された DOCSIS コンフィギュレーション ファイルのみをダウンロードし、最も一般的なサービスの窃盗攻撃を防ぐことが保証されます。

Cable Monitor and Intercept の設定方法

DHCP サービス、ToD サービス、および TFTP サービスを Cisco CMTS に設定するために必要な作業については、以下を参照してください。

「DHCP サービスの設定」

「ToD サービスの設定」

「TFTP サービスの設定」

「基本オールインワン コンフィギュレーションの設定(任意)」

「拡張オールインワン コンフィギュレーションの設定(任意)」

「外部 DHCP サーバの使用の最適化」

すべての手順は、(ネットワーク コンフィギュレーションおよびアプリケーションに応じて)任意と指定されている場合を除いてすべて必須です。

DHCP サービスの設定

DHCP サーバを Cisco CMTS に設定するには、以下の手順を使用して使用するサーバに必要なアドレス プールを作成します。必要に応じて、すべての DHCP 要求(ケーブル モデムおよび CPE 装置)に対して 1 つのプールを作成することも、ケーブル モデムと CPE 装置用にそれぞれ個別のプールを作成することもできます。

「ケーブル モデム用の DHCP アドレス プールの作成と設定」

「CPE 装置用の DHCP アドレス プールの作成と設定(任意)」

cable-source verify dhcp コマンドに設定する DHCP MAC アドレス除外リスト

ケーブル モデム用の DHCP アドレス プールの作成と設定

Cisco CMTS で DHCP サーバを使用するには、DHCP 要求を作成するケーブル モデムに与えられる IP アドレスおよび他のネットワーク パラメータを定義するアドレス プールを、少なくとも 1 つ作成する必要があります。アドレス プールを作成するには、EXEC モードから始めて次の手順に従います。必要に応じて追加のアドレス プールを作成する場合、この手順を繰り返してください。

ステップの概略

1. enable

2. configure terminal

3. ip dhcp pool name

4. network network-number [ mask ]

5. bootfile filename

6. next-server address [ address2 ... address8 ]

7. default-router address [ address2 ... address8 ]

8. option 2 hex gmt-offset

9. option 4 ip address [ address2 ... address8 ]

10. option 7 ip address [ address2 ... address8 ]

11. lease { days [ hours ][ minutes ] | infinite }

12. client-identifier unique-identifier

13. cable dhcp-insert { downstream-description | hostname | upstream-description }

14. exit

15. exit

ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp pool name

 

Router(config)# ip dhcp pool local

Router(dhcp-config)#

DHCP アドレス プールを作成して DHCP プール コンフィギュレーション ファイル モードを開始します。 name は、 service などの任意の文字列か、 1 などの数字のいずれかです。

ステップ 4

network network-number [ mask ]

 

Router(dhcp-config)# network 10.10.10.0 255.255.0.0

Router(dhcp-config)#

指定した network-number およびサブネット mask でアドレス プールを設定します。これは、それぞれ DHCP yiaddr フィールドおよびサブネット マスク(DHCP オプション 1)フィールドです。 mask 値を指定しない場合は、255.255.255.255 になります。


) 単一の IP アドレスでアドレス プールを作成するには、network コマンドではなく host コマンドを使用します。


ステップ 5

bootfile filename

 

Router(dhcp-config)# bootfile platinum.cm

Router(dhcp-config)#

このプールから IP アドレスを割り当てられたケーブル モデム用のデフォルトの DOCSIS コンフィギュレーション ファイル名(DHCP ファイル フィールド)を指定します。 filename は、TFTP サーバからのファイルを要求する際に使用する(パスを含む)完全名です。

ステップ 6

next-server address [ address2 ... address8 ]

 

Router(dhcp-config)# next-server 10.10.11.1

Router(dhcp-config)#

DHCP クライアントのブート プロセスにある次のサーバの IP アドレス(DHCP siaddr フィールド)を指定します。DOCSIS ケーブル モデムの場合、これが DOCSIS コンフィギュレーション ファイルを提供する TFTP サーバ用の IP アドレスです。少なくとも 1 つの IP アドレスを指定する必要がありますが、任意で最大 8 つの IP アドレスを優先順に指定できます。

ステップ 7

default-router address [ address2 ... address8 ]

 

Router(dhcp-config)# default-router 10.10.10.12

Router(dhcp-config)#

このアドレス プールにあるケーブル モデムのデフォルト ルータである、ルータ オプション(DHCP オプション 3)フィールドの IP アドレスを指定します。少なくとも 1 つの IP アドレスを指定する必要があり、また任意で最大 8 つの IP アドレスを指定できます。デフォルト ルータは優先順にリストされます( address が最優先のサーバで、 address2 が次に優先されるサーバ、と続きます)。


) 最初の IP アドレスは、DHCP プールを使用するケーブル モデムに接続されているケーブル インターフェイスの IP アドレスでなければなりません。


ステップ 8

option 2 hex gmt-offset

 

Router(dhcp-config)# option 2 hex FFFF.8F80

Router(dhcp-config)#

タイム オフセット フィールド(DHCP オプション 2)を指定します。これは、ローカル タイム ゾーンが、GMT からずれている秒数を 16 進数で指定したものです。 gmt-offset のサンプル値は以下の通りです。

FFFF.8F80 = -8 時間(-28800 秒、太平洋標準時)
FFFF.9D90 = -7 時間(山岳部標準時)
FFFF.ABA0 = -6 時間(中央標準時)
FFFF.B9B0 = -5 時間(東部標準時)

ステップ 9

option 4 ip address [ address2 ... address8 ]

 

Router(dhcp-config)# option 4 ip 10.10.10.13 10.10.11.2

Router(dhcp-config)#

タイム サーバ オプション フィールド(DHCP オプション 4)を指定します。これは、ケーブル モデムが現在の日付と時間を取得できる ToD サーバの IP アドレスです。

少なくとも 1 つの IP アドレスを指定する必要がありますが、任意で最大 8 つの IP アドレスを優先順に指定できます。


) Cisco CMTS を ToD サーバとして使用したい場合、IP アドレスをコマンドの一部として入力してください。


ステップ 10

option 7 ip address [ address2 ... address8 ]

 

Router(dhcp-config)# option 7 ip 10.10.10.13

Router(dhcp-config)#

(任意)ログ サーバ オプション フィールド(DHCP オプション 7)を指定します。これは、ケーブル モデムがエラー メッセージやその他のロギング情報を送信するシステムログ(Syslog)サーバの IP アドレスです。

任意で最大 8 つの IP アドレスを優先順に指定できます。

ステップ 11

lease { days [ hours ][ minutes ]| infinite }

 

Router(dhcp-config)# lease 0 12 30

Router(dhcp-config)#

IP アドレス リース時間(オプション 51)を指定します。これは、ケーブル モデムに割り当てられた IP アドレスのリース期間です。リース期間が満了する前に、ケーブル モデムはオンラインの状態を維持するために別の DHCP 要求を作成する必要があります。デフォルト値は 1 日です。

リース時間を次のように指定できます。

days = リース期間の日数を指定します(0 ~ 365)。

hours = リースの時間数(0 ~ 23、任意)。 hours 値を設定する前に days 値を指定してください。

minutes = リースの分数(0 ~ 59、任意)。 minutes 値を設定する前に days 値および hours 値を指定してください。

infinite = リース期間無制限


) ほとんどのケーブル ネットワークでは、リース期間が 3 分未満だとケーブル モデムはオンラインになれません。ほとんどのケーブル ネットワークで安定した運用を行うには、最低でもリース期間を 5 分にしてください。


ステップ 12

client-identifier unique-identifier

 

Router(dhcp-config)# client-identifier 0100.0C01.0203.04

Router(dhcp-config)#

(任意)このプールからのパラメータを受信する特定のケーブル モデムを識別する MAC アドレスを指定します。1 バイトのイーサネット ID(「01」)とケーブル モデムの 6 バイトの MAC アドレスを組み合わせて固有の ID を作成します。たとえば、MAC アドレスが 9988.7766.5544 のケーブル モデムを指定するには、 unique-identifier を 0199.8877.6655.44 にします。


) このオプションは、単一のケーブル モデムにスタティック アドレスを割り当てる DHCP プールにのみ使用します。


ステップ 13

cable dhcp-insert { downstream-description | hostname | upstream-description }

(任意)DHCP パケットに追加するディスクリプタを指定します。DHCP サーバは、次のディスクリプタを使用して、ケーブル モデム クローンを識別したり、地理的情報を抽出したりできます。

downstream-description = 受信した DHCP パケットにダウンストリーム ポート ディスクリプタを追加します。

hostname = 受信した DHCP パケットにルータ ホスト名を追加します。

upstream-description = 受信した DHCP パケットにアップストリーム ポート ディスクリプタを追加します。


) 最大リレー情報オプション サイズの範囲内で、複数タイプのディスクリプタを設定できます。


ステップ 14

exit

 

Router(dhcp-config)# exit

Router(config)#

DHCP コンフィギュレーション モードを終了します。

ステップ 15

exit

 

Router(config)# exit

Router#

グローバル コンフィギュレーション モードを終了します。

CPE 装置用の DHCP アドレス プールの作成と設定(任意)

ケーブル モデム用の IP アドレスを提供することに加えて、Cisco CMTS の DHCP サーバは任意で IP アドレスおよび他のネットワーク パラメータをネットワークのケーブル モデムに接続されている CPE 装置に提供できます。これを実行するには、EXEC モードで次の手順に従って、CPE 装置の DHCP アドレス プールを作成します。必要に応じて追加のアドレス プールを作成する場合、この手順を繰り返してください。


) ケーブル モデムおよび CPE 装置用に同じアドレス プールを使用できますが、個別のプールを使用することによりネットワーク管理が簡略化されます。


ステップの概略

1. enable

2. configure terminal

3. ip dhcp pool name

4. network network-number [ mask ]

5. default-router address [ address2 ... address8 ]

6. dns-server address [ address2 ... address8 ]

7. domain-name domain

8. lease { days [ hours ][ minutes ] | infinite }

9. client-identifier unique-identifier

10. exit

11. exit

ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp pool name

 

Router(config)# ip dhcp pool local

Router(dhcp-config)#

DHCP アドレス プールを作成して DHCP プール コンフィギュレーション ファイル モードを開始します。 name は、 service などの任意の文字列か、 1 などの数字のいずれかです。

ステップ 4

network network-number [ mask ]

 

Router(dhcp-config)# network 10.10.10.0 255.255.0.0

Router(dhcp-config)#

指定した network-number およびサブネット mask でアドレス プールを設定します。これは、それぞれ DHCP yiaddr フィールドおよびサブネット マスク(DHCP オプション 1)フィールドです。 mask 値を指定しない場合、デフォルトの 255.255.255.255 になります。


) 単一の IP アドレスでアドレス プールを作成するには、network コマンドではなく host コマンドを使用します。


ステップ 5

default-router address [ address2 ... address8 ]

 

Router(dhcp-config)# default-router 10.10.10.12

Router(dhcp-config)#

このアドレス プールにあるケーブル モデムおよび CPE 装置のデフォルト ルータである、ルータ オプション(DHCP オプション 3)フィールドの IP アドレスを指定します。少なくとも 1 つの IP アドレスを指定する必要があり、また任意で最大 8 つの IP アドレスを指定できます。デフォルト ルータは優先順にリストされます( address が最優先のサーバで、 address2 が次に優先されるサーバ、と続きます)。

ステップ 6

dns-server address [ address2 ... address8 ]

 

Router(dhcp-config)# dns-server 10.10.10.13

Router(dhcp-config)#

1 つまたは複数のドメイン ネーム サーバ オプション(DHCP オプション 6)フィールドの IP アドレスを指定します。ホスト名を解決して CPE 装置の IP アドレスに変換する DNS サーバの IP アドレスです。少なくとも 1 つの IP アドレスを指定する必要がありますが、任意で最大 8 つの IP アドレスを優先順に指定できます。

ステップ 7

domain-name domain

 

Router(dhcp-config)# domain-name cisco.com

Router(dhcp-config)#

ドメイン名(DHCP オプション 15)フィールドを指定します。これは、CPE 装置がホスト名を追加する、完全修飾ドメイン名です。 domain パラメータは、ケーブル ネットワークにあるデバイスのドメイン名です。

ステップ 8

lease { days [ hours ][ minutes ]| infinite }

 

Router(dhcp-config)# lease 0 12 30

Router(dhcp-config)#

IP アドレス リース時間(オプション 51)を指定します。CPE 装置に割り当てられた IP アドレスのリース期間です。リース期間が満了する前に、CPE 装置はオンラインの状態を維持するために別の DHCP 要求を作成する必要があります。デフォルト値は 1 日です。

リース時間を次のように指定できます。

days = リース期間の日数を指定します(0 ~ 365)。

hours = リースの時間数(0 ~ 23、任意)。 hours 値を設定する前に days 値を指定してください。

minutes = リースの分数(0 ~ 59、任意)。 minutes 値を設定する前に days 値および hours 値を指定してください。

infinite = リース期間無制限

ステップ 9

client-identifier unique-identifier

 

Router(dhcp-config)# client-identifier 0100.0C01.0203.04

Router(dhcp-config)#

(任意)このプールからのパラメータを受信する特定の CPE 装置を識別する MAC アドレスを指定します。1 バイトのイーサネット ID(「01」)とデバイスの 6 バイトの MAC アドレスを組み合わせて固有の ID を作成します。たとえば、MAC アドレスが 9988.7766.5544 の装置を指定するには、unique-identifier を 0199.8877.6655.44 にします。


) このオプションは、単一の CPE 装置にスタティック アドレスを割り当てる DHCP プールにのみ使用します。


ステップ 10

exit

 

Router(dhcp-config)# exit

Router(config)#

DHCP コンフィギュレーション モードを終了します。

ステップ 11

exit

 

Router(config)# exit

Router#

グローバル コンフィギュレーション モードを終了します。

ToD サービスの設定

ここでは、Cisco CMTS ルータで ToD サーバをイネーブルおよびディセーブルにする手順について説明します。

前提条件

単独または外部の ToD サーバと一緒に Cisco CMTS を ToD サーバとして使用するには、DHCP サーバを設定してケーブル モデムの有効な ToD サーバ(DHCP オプション 4)の 1 つとして Cisco CMTS に IP アドレスを提供する必要があります。内蔵 DHCP サーバを使用する際のこの設定の詳細については、「ケーブル モデム用の DHCP アドレス プールの作成と設定」を参照してください。

ToD サービスのイネーブル化

Cisco CMTS で ToD サーバをイネーブルにするには、特権 EXEC モードから始めて次の手順に従います。

ステップの概略

1. enable

2. configure terminal

3. service udp-small-servers max-servers no-limit

4. cable time-server

5. exit

ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

service udp-small-servers max-servers no-limit

 

Router(config)# service udp-small-servers max-servers no-limit

Router(config)#

UDP プロトコル(ToD、echo、chargen、discard など)を使用するマイナー サーバを使用できるようにします。

max-servers no-limit オプションを指定すると、ケーブル障害または停電によって多数のケーブル モデムがオフラインになった場合でも、多数のケーブル モデムが一度に ToD サーバを取得できます。問題の解決後、即座にケーブル モデムを再接続できます。

ステップ 4

cable time-server

 

Router(config)# cable time-server

Router(config)#

Cisco CMTS 上で ToD サーバをイネーブルにします。

ステップ 5

exit

 

Router(config)# exit

Router#

グローバル コンフィギュレーション モードを終了します。

ToD サービスのディセーブル化

ToD サーバをディセーブルにするには、EXEC モードから始めて次の手順に従います。

ステップの概略

1. enable

2. configure terminal

3. no cable time-server

4. no service udp-small-servers

5. exit

ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

no cable time-server

 

Router(config)# cable time-server

Router(config)#

Cisco CMTS 上で ToD サーバをディセーブルにします。

ステップ 4

no service udp-small-servers

 

Router(config)# no service udp-small-servers

Router(config)#

(任意)すべてのマイナー UDP サーバを使用不可にします。


) 他の DHCP または TFTP サーバもイネーブルにしている場合は、マイナー UDP サーバをディセーブルにしないでください。


ステップ 5

exit

 

Router(config)# exit

Router#

グローバル コンフィギュレーション モードを終了します。

TFTP サービスの設定

CMTS が TFTP サーバとして機能して DOCSIS コンフィギュレーション ファイルをケーブル モデムへダウンロードするように、TFTP サービスを Cisco CMTS 上に設定するには、以下の手順を実行します。

選択した DOICSIS コンフィギュレーション エディタを使用して DOCSIS コンフィギュレーション ファイルを作成します。また、Cisco CMTS にある内蔵 DOCSIS コンフィギュレーション ファイル エディタを使用しても DOCSIS コンフィギュレーション ファイルを作成できます。

すべての必要なファイル(DOCSIS コンフィギュレーション ファイル、ソフトウェア アップグレード ファイル、および Cisco IOS コンフィギュレーション ファイル)を Cisco CMTS のフラッシュ メモリ装置にコピーします。これは通常、まず外部 TFTP サーバにファイルを配置し、次に TFTP コマンドを使用してルータのフラッシュ メモリに転送することで実行されます。


) Cisco CMTS の内蔵 DOCSIS コンフィギュレーション エディタを使用して DOCSIS コンフィギュレーション ファイルを作成する場合、ファイルはすでにルータのコンフィギュレーションの一部なので、ファイルをフラッシュ メモリ装置にコピーする必要はありません。


tftp-server コマンドを使用して Cisco CMTS で TFTP サーバをイネーブルにします。

オプションで TFTP 強制機能をイネーブルにし、オンライン化が許可される前に、ケーブル モデムで CMTS のケーブル インターフェイスを介して DOCSIS コンフィギュレーション ファイルの TFTP ダウンロードを試行する必要があります。

任意と指定されている場合を除き、設定作業は必須です。


ステップ 1 show file systems コマンドを使用して、CMTS で使用可能なフラッシュ メモリ カードと、各カードの空き容量および各カードにアクセスするための適切な装置名を表示します。

Cisco CMTS プラットフォームのほとんどの設定では、リニア フラッシュおよびフラッシュ ディスク メモリ カードの両方をサポートしています。リニア フラッシュ メモリには、デバイス名 slot0 (または flash )および slot1 を使用してアクセスします。フラッシュ ディスク メモリには、 disk0 およびデバイス名 disk1 を使用してアクセスします。

たとえば、以下のコマンドは Cisco uBR7200 シリーズ ルータに 2 つのリニア フラッシュ メモリ カードがインストールされていることを示しています。カードには、デバイス名 slot0 (または flash )および slot1 でアクセスできます。

Router# show file systems
 
File Systems:
 
Size(b) Free(b) Type Flags Prefixes
48755200 48747008 flash rw slot0: flash:
16384000 14284000 flash rw slot1:
32768000 31232884 flash rw bootflash:
* - - disk rw disk0:
- - disk rw disk1:
- - opaque rw system:
- - opaque rw null:
- - network rw tftp:
522232 507263 nvram rw nvram:
- - network rw rcp:
- - network rw ftp:
- - network rw scp:
 
Router#
 

次に、Cisco uBR10012 ルータに 2 つのフラッシュ ディスク カードがインストールされている例を示しています。これらのカードには、デバイス名 disk0 および sec-disk0 を使用してアクセスします。

Router# show file systems
 
File Systems:
 
Size(b) Free(b) Type Flags Prefixes
- - flash rw slot0: flash:
- - flash rw slot1:
32768000 29630876 flash rw bootflash:
* 128094208 95346688 disk rw disk0:
- - disk rw disk1:
- - opaque rw system:
- - flash rw sec-slot0:
- - flash rw sec-slot1:
* 128094208 95346688 disk rw sec-disk0:
- - disk rw sec-disk1:
32768000 29630876 flash rw sec-bootflash:
- - nvram rw sec-nvram:
- - opaque rw null:
- - network rw tftp:
522232 505523 nvram rw nvram:
- - network rw rcp:
- - network rw ftp:
- - network rw scp:
 
Router#

ヒント Cisco uBR10012 ルータは、冗長プロセッサ(プライマリおよびセカンダリ)をサポートしていて、プロセッサごとにフラッシュ メモリ装置があります。通常、Cisco uBR10012 ルータはセカンダリ プロセッサをプライマリ プロセッサと同期させているので、ファイルを(sec プレフィクスがある)セカンダリ フラッシュ メモリ装置にコピーする必要はありません。


ステップ 2 必要なフラッシュ メモリ カードに、CMTS にコピーしたいすべてのファイル用の十分な空き容量があることを確認します。

ステップ 3 ping コマンドを使用して、必要なファイルを含むリモート TFTP サーバに接続できるかどうかを確認します。たとえば、次の例では ping コマンドを IP アドレスが 10.10.10.1 の外部 TFTP サーバに送ります。

Router# ping 10.10.10.1
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/6/6 ms
 

ステップ 4 copy tftp devname コマンドを使用して各ファイルを外部 TFTP サーバから CMTS 上の該当するフラッシュ メモリ カードにコピーします。ここで devname は宛先フラッシュ メモリ カードのデバイス名です。次に外部 TFTP サーバの IP アドレスおよび転送するファイルのファイル名を要求するプロンプトが表示されます。

次に、ファイル docsis.cm が IP アドレス 10.10.10.1 の外部 TFTP サーバから 1 つめのフラッシュ メモリ ディスク(disk0)に転送される例を示します。

Router# copy tftp disk0
 
Address or name of remote host []? 10.10.10.1
Source filename []? config-files/docsis.cm
Destination filename [docsis.cm]?
Accessing tftp://10.10.10.1/config-file/docsis.cm......
Loading docsis.cm from 10.10.10.1 (via Ethernet2/0): !!!
[OK - 276/4096 bytes]
 
276 bytes copied in 0.152 secs
 
Router#
 

ステップ 5 必要に応じてステップ 4を繰り返して、すべてのファイルを外部 TFTP サーバから Cisco CMTS にあるフラッシュ メモリ カードにコピーします。

ステップ 6 dir コマンドを使用して、フラッシュ メモリ カードにすべての転送ファイルがあることを確認します。

Router# dir disk0:
 
Directory of disk0:/
 
1 -rw- 10705784 May 30 2002 19:12:46 ubr10k-p6-mz.122-2.8.BC
2 -rw- 4772 Jun 20 2002 18:12:56 running.cfg.save
3 -rw- 241 Jul 31 2002 18:25:46 gold.cm
4 -rw- 225 Jul 31 2002 18:25:46 silver.cm
5 -rw- 231 Jul 31 2002 18:25:46 bronze.cm
6 -rw- 74 Oct 11 2002 21:41:14 disable.cm
7 -rw- 2934028 May 30 2002 11:22:12 ubr924-k8y5-mz.bin
8 -rw- 3255196 Jun 28 2002 13:53:14 ubr925-k9v9y5-mz.bin
 
128094208 bytes total (114346688 bytes free)
Router#
 

ステップ 7 configure terminal コマンドを使用してグローバル コンフィギュレーション モードを開始します。

Router# configure terminal
Router(config)#
 

ステップ 8 tftp-server コマンドを使用して、Cisco CMTS のオンボードにある TFTP サーバが転送できる特定のファイルを指定します。また、 alias オプションを使用して、DHCP サーバがファイルを参照するために使用できる別のファイル名を指定することができます。たとえば、以下のコマンドは、ステップ 6で示したコンフィギュレーション ファイルおよびソフトウェア アップグレード ファイルの TFTP 転送をイネーブルにします。

Router(config)# tftp-server disk0:gold.cm alias gold.cm
Router(config)# tftp-server disk0:silver.cm alias silver.cm
Router(config)# tftp-server disk0:bronze.cm alias bronze.cm
Router(config)# tftp-server disk0:ubr924-k8y5-mz.bin alias ubr924-codefile
Router(config)# tftp-server disk0:ubr925-k9v9y5-mz.bin alias ubr925-codefile
Router(config)#
 

) また tftp-server コマンドは、アクセス リストと一致した IP アドレスのみに特定のファイルへのアクセスを制限するよう、アクセス リストを指定するオプションをサポートしています。


ステップ 9 (任意)以下のコマンドを使用して UDP スモール サーバの使用をイネーブルにします。また一度に接続できる数を無制限にします。これにより、ケーブル障害または電力障害によってオフラインになった多くのケーブル モデムを迅速にオンラインに戻すことができます。

Router(config)# service udp-small-servers max-servers no-limit
Router(config)#
 

ステップ 10 (任意) cable tftp-enforce コマンドをインターフェイス コンフィギュレーション モードで使用して、オンライン化が許可される前に各ケーブル モデムで CMTS のケーブル インターフェイスを介して DOCSIS コンフィギュレーション ファイルの TFTP ダウンロードを実行しなければならないようにします。これにより、未許可のコンフィギュレーション ファイルをケーブル モデムにダウンロードするようローカル ネットワークを設定するといった、最も一般的なサービスの窃盗攻撃を防ぐことができます。

Router(config)# interface cable x/y
Router(config-if)# cable tftp-enforce
Router(config-if)#
 

また mark-only オプションを使用して、TFTP ダウンロードを試行せずにケーブル モデムをオンラインにすることができますが、ケーブル モデムが show cable modems コマンドでマークされるので、ネットワーク管理者は何らかの処理を行う前に状況を調査することができます。

Router(config)# interface cable x/y
Router(config-if)# cable tftp-enforce mark-only
Router(config-if)#
 


 

基本オールインワン コンフィギュレーションの設定(任意)

基本オールインワン コンフィギュレーションでは、以下の各項で説明しているように、DHCP、ToD、および TFTP サーバを設定する必要があります。

「DHCP サービスの設定」

「ToD サービスの設定」

「TFTP サービスの設定」

TFTP サーバで使用可能な DOCSIS コンフィギュレーション ファイルも必要になります。これを実行する方法には次の 2 通りがあります。

Cisco DOCSIS Configurator ツールを使用して DOCSIS コンフィギュレーション ファイルを作成して、次にこれをフラッシュ メモリ装置にコピーします。フラッシュ メモリへのコンフィギュレーション ファイルのコピー手順については、「TFTP サービスの設定」を参照してください。

cable config-file コマンドを使用して DOCSIS コンフィギュレーション ファイルを動的に作成します。この詳細については、『 Cisco CMTS Feature Guide 』の「 Internal DOCSIS Configurator File Generator for the Cisco CMTS 」の章を参照してください

基本オールインワン コンフィギュレーションの例については、「基本オールインワン コンフィギュレーション例」を参照してください。

拡張オールインワン コンフィギュレーションの設定(任意)

拡張オールインワン コンフィギュレーション サンプルは、DHCP プールの階層を使用することを除き、基本コンフィギュレーションと同じです。他のプールのネットワーク番号のサブセットであるネットワーク番号を持つ DHCP プールは、他のプールの特性をすべて継承します。これにより、複数の DHCP プール コンフィギュレーションで同じコマンドを繰り返す必要がなくなります。

必要な作業の情報については、このマニュアルの以下の各項を参照してください。

「DHCP サービスの設定」

「ToD サービスの設定」

「TFTP サービスの設定」

TFTP サーバで使用可能な DOCSIS コンフィギュレーション ファイルも必要になります。これを実行する方法には次の 2 通りがあります。

Cisco DOCSIS Configurator ツールを使用して DOCSIS コンフィギュレーション ファイルを作成して、次にこれをフラッシュ メモリ装置にコピーします。フラッシュ メモリへのコンフィギュレーション ファイルのコピー手順については、「TFTP サービスの設定」を参照してください。

cable config-file コマンドを使用して DOCSIS コンフィギュレーション ファイルを動的に作成します。この詳細については、『 Cisco CMTS Feature Guide 』の「 Internal DOCSIS Configurator File Generator for the Cisco CMTS」の章を参照してください(このコマンドは、DOCSIS 1.0 コンフィギュレーション ファイルのみを作成します)。

拡張オールインワン コンフィギュレーションの例については、「拡張オールインワン コンフィギュレーション例」を参照してください。

外部 DHCP サーバの使用の最適化

Cisco CMTS には、DOCSIS ケーブル ネットワークの外部 DHCP サーバの動作を最適化できる多くのオプションがあります。詳細については、次の各項を参照してください。すべての手順は、ネットワークおよびアプリケーション サーバのニーズにより、任意に行います。

「ケーブル送信元確認オプションの設定(任意)」

「オプションの DHCP パラメータの設定(任意)」

cable-source verify dhcp コマンドに設定する DHCP MAC アドレス除外リスト

ケーブル送信元確認オプションの設定(任意)

外部 DHCP サーバを使用する際にセキュリティを強化するために、EXEC モードから以下の手順を使用して任意でケーブル送信元確認機能を設定することができます。

制限事項

ケーブル送信元確認機能は、外部 DHCP サーバのみをサポートします。これは、内蔵 DHCP サーバで使用できません。

ステップの概略

1. enable

2. configure terminal

3. interface cable x/y

4. cable source-verify [ dhcp | leasetimer value ]

5. no cable arp

6. exit

7. ip dhcp relay information option

8. exit

ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface cable x/y

 

Router(config)# interface cable 4/0

Router(config-if)#

特定のケーブル インターフェイスに対して、ケーブル インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

cable source-verify [ dhcp | leasetimer value ]

 
Router(config-if)# cable source-verify dhcp

Router(config-if)# cable source-verify leasetimer 30

Router(config-if)#

(任意)CMTS がネットワーク アクセスを、このケーブル インターフェイスのデバイスに対して DHCP サーバが発行した IP アドレスにかぎって許可することを保証します。CMTS は、どの IP アドレスがどのインターフェイスで有効かを記述したデータベースを構築するために、ケーブル インターフェイスを通過する DHCP パケットを検査します。

dhcp =(任意)未知の IP アドレスを持つデバイスからのすべてのトラフィックを廃棄しますが、CMTS はさらに、DHCP サーバにデバイスに関する情報についてのクエリを送信します。デバイスが有効な IP アドレスを持っていることを DHCP サーバが CMTS に通知した場合、CMTS はネットワーク上でデバイスを許可します。

leasetimer value =(任意)ルータがリース時間を超過した IP アドレスに関する内部 CPE データベースをチェックする間隔を分単位で指定します。これにより、ユーザが DHCP 割り当て IP アドレスを取得してそれをスタティック アドレスとして CPE 装置に割り当てられないようにします。有効な値の範囲は 1 ~ 240 分で、デフォルトはありません。


leasetimer オプションは、dhcp オプションもインターフェイスで使用されている場合のみ有効になります。


ステップ 5

no cable arp

 
Router(config-if)# no cable arp

Router(config-if)#

(任意)ケーブル ネットワークのデバイスから発信された ARP 要求をブロックします。このコマンドを、
cable source-verify dhcp コマンドと共に使用して、IP アドレスの乗っ取りやスプーフィングを行おうとする特定のタイプのサービスの窃盗攻撃をブロックします。


) 必要なケーブル インターフェイスでステップ 3ステップ 5 を繰り返します。


ステップ 6

exit

 

Router(config-if)# exit

Router(config)#

インターフェイス コンフィギュレーション モードを終了します。

ステップ 7

ip dhcp relay information option

 

Router(config)# ip dhcp relay information option

Router(config)#

(任意)リレーしている DHCP パケットへの DHCP リレー情報(DHCP オプション 82)の挿入を CMTS でイネーブルにします。これにより、DHCP サーバはどの CPE 装置がどのケーブル モデムを使用しているかについての正確な情報を保存することができます。このコマンドは、
cable source-verify dhcp コマンドも使用している場合に使用します。


) Release 12.1(2)EC1 より前の Cisco IOS リリースでは、この目的で cable relay-agent-option コマンドを使用していましたが、最新のリリースでは ip dhcp relay information option コマンドを使用します。


ステップ 8

exit

 

Router(config)# exit

Router#

グローバル コンフィギュレーション モードを終了します。

オプションの DHCP パラメータの設定(任意)

外部 DHCP サーバを使用する場合、Cisco CMTS は特定のアプリケーションにおいてケーブル ネットワークの動作を強化するオプションを数多くサポートしています。これらのオプションを設定するには、EXEC モードから始めて次の手順に従います。

ステップの概略

1. enable

2. configure terminal

3. ip dhcp smart-relay

4. ip dhcp ping packet 0

5. ip dhcp relay information check

6. interface cable x/y

7. cable dhcp-giaddr policy

8. cable helper-address address [ cable-modem | host | mta | stb ]

9. cable dhcp-parse option- optnum (任意)

10. exit

11. exit

ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp smart-relay

 

Router(config)# ip dhcp smart-relay

Router(config)#

(任意)CMTS で DHCP リレー エージェントをイネーブルにして、プライマリ DHCP サーバが 3 回の正常な要求に応答しなかった場合に、ケーブル モデムまたは CPE 装置をセカンダリ DHCP サーバまたはアドレス プールへ自動的に切り替えます。複数のセカンダリ サーバが定義されている場合、リレー エージェントは DHCP 要求をラウンド ロビン方式でセカンダリ サーバへ転送します。

ステップ 4

ip dhcp ping packet 0

 

Router(config)# ip dhcp ping packet 0

Router(config)#

(任意)クライアントがすでにその IP アドレスを使用しているか否かをテストする ICMP ping を最初に送信せずに、DHCP サーバにプールから IP アドレスを割り当てるように指示します。ping オプションをディセーブルにすると、多くのモデムが同時に接続しようとする場合にアドレス割り当てを迅速化できます。ただし、ping オプションをディセーブルにすると、ユーザが未許可のスタティック IP アドレスを CPE 装置に割り当てる場合に重複 IP アドレスが使用されてしまう可能性があります。


) デフォルトでは、特定のアドレスを要求クライアントに割り当てる前に、DHCP サーバはプール アドレスに 2 回 ping を実行します。ping に返答がない場合、DHCP サーバはそのアドレスは使用されていないとみなし、要求クライアントにそのアドレスを割り当てます。


ステップ 5

ip dhcp relay information check

 

Router(config)# ip dhcp relay information check

Router(config)#

(任意)転送された BOOTREPLY メッセージ内のリレー エージェント情報オプションを確認するように DHCP サーバを設定します。無効なメッセージは廃棄されます。


ip dhcp relay information コマンドには、DHCP パケットの特殊な処理に便利な他の複数のオプションが含まれています。詳細については、Cisco IOS マニュアルのコマンド リファレンスを参照してください。


ステップ 6

interface cable x/y

 

Router(config)# interface cable 4/0

Router(config-if)#

特定のケーブル インターフェイスに対して、ケーブル インターフェイス コンフィギュレーション モードを開始します。

ステップ 7

cable dhcp-giaddr policy

 

Router(config-if)# cable dhcp-giaddr policy

Router(config-if)#

DHCP 要求パケットの DHCP giaddr フィールドに、ケーブル モデムのプライマリ アドレスと CPE 装置のセカンダリ アドレスを設定します。これにより、異なるクライアントに個別のアドレス プールを使用できるようになります。


) また cable dhcp-giaddr コマンドは、primary オプションをサポートしますが、通常これは EuroDOCSIS ケーブル モデムおよびセットトップ ボックスに使用します。


ステップ 8

cable helper-address address [ cable-modem | host | mta | stb ]

 

Router(config-if)# cable helper-address 10.10.10.13

Router(config-if)#

(任意)ケーブル インターフェイスまたはサブインターフェイスに基づいて異なる DHCP サーバを指定することで、ケーブル モデムおよび CPE 装置からの DHCP 要求のロードバランシングをイネーブルにします。また、ケーブル モデムと CPE 装置に対して個別のサーバを指定することもできます。

address = UDP ブロードキャスト パケットがユニキャスト パケットを介して送信される DHCP サーバの IP アドレス

cable-modem = このサーバがケーブル モデム パケットだけを受け入れるように指定します(任意)。

host = このサーバが CPE 装置のパケットのみを受け入れるように指定します(任意)。

mta = このサーバが MTA パケットのみを受け入れるように指定します(任意)。ステップ 9 も実行する必要があります。

stb = このサーバが STB パケットのみを受け入れるように指定します(任意)。ステップ 9 も実行する必要があります。


) オプションを指定しない場合、helper-address はすべてのケーブル デバイスをサポートし、関連付けられた DHCP サーバはすべてのケーブル デバイス クラスからの DHCP パケットを受け入れます。



) 1 つのオプションのみを指定すると、他のタイプのデバイス(ケーブル モデム、ホスト、mta、または stb)が DHCP サーバに接続できなくなります。それぞれ個別のコマンドを実行して、必要なオプションを指定する必要があります。



ヒント 各ケーブル インターフェイスで複数のヘルパー アドレスを指定する場合、このコマンドを繰り返し入力します。16 個を超えるヘルパー アドレスを指定できますが、Cisco IOS ソフトウェアは先頭から有効な 16 個のアドレスのみを使用します。

ip helper-address コマンドは cable helper-address と類似の機能を実行しますが、非ケーブル インターフェイスで使用されます。cable helper-address コマンドは、DOCSIS ネットワークの DHCP 要求の動作に最適化されているため、ケーブル インターフェイスで使用します。


ステップ 9

cable dhcp-parse option - optnum

 

Router(config-if)# cable dhcp-parse option-43

Router(config-if)#

(任意)特定の DHCP オプションの解析をイネーブルにします。

optnum = イネーブルにするオプションを指定します。有効値は 43 または 60 です。


ステップ 8mta オプションまたは stb オプションを指定した場合は、ケーブル デバイス クラスの抽出を可能にするために、DHCP パケットを解析する必要があります。



ヒント 事前に、SMTS が特定のオプションを使用しないことがわかっている場合は、no cable dhcp-parse option-optnum コマンドを使用して、解析をディセーブルにできます。

) 必要なケーブル インターフェイスでステップ 6ステップ 9 を繰り返します。


ステップ 10

exit

 

Router(config-if)# exit

Router(config)#

インターフェイス コンフィギュレーション モードを終了します。

ステップ 11

exit

 

Router(config)# exit

Router#

グローバル コンフィギュレーション モードを終了します。

cable-source verify dhcp コマンドに設定する DHCP MAC アドレス除外リスト

Cisco IOS Release 12.3(13)BC には、信頼できる MAC アドレスを標準 DHCP 送信元確認検査から除外する機能が導入されました。この機能は Cisco CMTS の以前の Cisco IOS リリースでもサポートされています。この機能では信頼できる MAC アドレスのパケットは転送できますが、それ以外のパケットは標準 DHCP 送信元確認検査で拒否されます。この機能は指定した MAC アドレスについては Cisco CMTS の cable source-verify コマンドを上書きしますが、標準のイネーブル化された DHCP 送信元確認プロセスはそのままサポートします。この機能は Cisco uBR10012 ルータ シャーシに搭載された Performance Routing Engine 1(PRE1)モジュールおよび PRE2 モジュールでサポートされます。

信頼された送信元の MAC アドレスのパケットを DHCP でイネーブルにするには、cable trust コマンドをグローバル コンフィギュレーション モードで使用します。信頼された MAC アドレスを MAC 除外リストから削除するには、このコマンドの no 形式を使用します。MAC アドレスを除外リストから削除すると、その送信元のすべてのパケットが標準 DHCP 送信元確認で検査されます。

cable trust mac-address

no cable trust mac-address

 
シンタックスの説明

mac-address

信頼された DHCP 送信元の MAC アドレス、およびパケットが標準 DHCP 送信元確認に準拠しない MAC アドレス

 
使用上のガイドライン

このコマンドと機能は、Cisco CMTS で Cable Source Verify 機能が最初にイネーブル化された環境でのみサポートされます。

ケーブル送信元確認に続いてこの機能をイネーブルにする場合、パケットの送信元が Cisco CMTS の MAC Exclude リストに含まれていることが必要です。パケットがこの除外チェックを受けると、IP アドレスは通常の ARP テーブルおよび従来サポートされていた送信元確認検査で確認されます。パケットの Service Identifier(SID; サービス ID)および送信元 IP アドレスが、Cisco CMTS の ARP ホスト データベースと一致する必要があります。パケット検査に合格すると、そのパケットは伝送されます。拒否されたパケットは 2 つの検査のいずれかで廃棄されます。

どの除外リストのどの信頼可能な送信元 MAC アドレスも、いつでも削除できます。MAC アドレスを削除すると信頼されていたパケットは信頼されない状態に戻り、Cisco CMTS の標準送信元確認検査に準拠します。

強化されたケーブル送信元確認 DHCP 機能の詳細および一般的な使い方のガイドラインについては、Cisco.com の次のマニュアルを参照してください。

IP Address Verification for the Cisco uBR7200 Series Cable Router

http://www.cisco.com/en/US/products/sw/iosswrel/ps1830/products_feature_guide09186a0080087b55.html

Filtering Cable DHCP Lease Queries

http://www.cisco.com/en/US/products/hw/cable/ps2217/products_feature_guide09186a008021b8fb.html

Cisco Broadband Cable Command Reference Guide

http://www.cisco.com/univercd/cc/td/doc/product/cable/bbccmref/bbcmtscf.htm#wp2619918

ホワイト ペーパー『Cable Source-Verify and IP Address Security』の「CABLE SECURITY」

http://www.cisco.com/en/US/tech/tk86/tk803/technologies_tech_note09186a00800a7828.shtml

設定例

ここでは、次の設定例を示します。

「DHCP サーバ例」

「ToD サーバ例」

「TFTP サーバ例」

「基本オールインワン コンフィギュレーション例」

「拡張オールインワン コンフィギュレーション例」

DHCP サーバ例

ここでは、ケーブル モデムおよび CPE 装置用の DHCP プールの設定例を取り上げます。

「ケーブル モデム用 DHCP プール」

「ケーブル モデムをディセーブルにする DHCP プール」

「CPE 装置用 DHCP プール」

ケーブル モデム用 DHCP プール

次に、ケーブル モデム用の一般的な DHCP プールの 3 つの例を示します。各プールには以下のフィールドが含まれます。

dhcp pool コマンドは、プール名となる固有の文字列を定義します。この場合、ケーブル モデムへダウンロードする DOCSIS コンフィギュレーション ファイルを識別します。

network コマンドは、各プールの IP アドレスの範囲を定義します。

bootfile コマンドは、ケーブル モデムへダウンロードする DOCSIS コンフィギュレーション ファイルを指定します。これらの例では、3 つの DOCSIS コンフィギュレーション ファイル(platinum.cm、gold.cm、silver.cm)が指定されています。

next-server コマンドは、TFTP サーバの IP アドレスを指定します。

default-router コマンドは、デフォルトのゲートウェイを指定します。

3 つの option コマンドは、タイム オフセット、ToD サーバ、およびログ サーバを指定します。

lease コマンドは、DHCP リースが 7 日、0 時間、10 分で満了すると指定しています(ケーブル モデムは通常このリースを、中間点の約 3 日と 12 時間で更新しようとします)。

!
ip dhcp pool cm-platinum
network 10.128.4.0 255.255.255.0
bootfile platinum.cm
next-server 10.128.4.1
default-router 10.128.4.1
option 2 hex ffff.8f80
option 4 ip 10.1.4.1
option 7 ip 10.1.4.1
lease 7 0 10
!
ip dhcp pool cm-gold
network 10.129.4.0 255.255.255.0
bootfile gold.cm
next-server 10.129.4.1
default-router 10.129.4.1
option 2 hex ffff.8f80
option 4 ip 10.1.4.1
option 7 ip 10.1.4.1
lease 7 0 10
!
ip dhcp pool cm-silver
network 10.130.4.0 255.255.255.0
bootfile silver.cm
next-server 10.130.4.1
default-router 10.130.4.1
option 2 hex ffff.8f80
option 4 ip 10.1.4.1
option 7 ip 10.1.4.1
lease 7 0 10

ケーブル モデムをディセーブルにする DHCP プール

次の例では、接続 CPE 装置のネットワーク アクセスをディセーブルにする、ケーブル モデム用の一般的な DHCP プール コンフィギュレーションを示します。このコンフィギュレーションでは、ケーブル モデムがオンラインになり CMTS と通信できるようになりますが、CPE 装置はケーブル ネットワークにアクセスできません。各プールには以下のフィールドが含まれます。

DHCP プール名は、ディセーブルになる各ケーブル モデム用の MAC アドレスを示す固有の文字列です。

host オプションは、単一のスタティック IP アドレスを指定します。

client-identifier オプションは、アクセスを拒否される特定のケーブル モデムを識別します。ケーブル モデムはイーサネット メディア コード(「01」)とケーブル モデムの MAC アドレスを組み合わせて識別されます。

bootfile オプションは、ネットワーク アクセスをディセーブルにする DOCSIS コンフィギュレーション ファイル(「disable.cm」)を指定します。

!
ip dhcp pool DisabledModem(0010.aaaa.0001)
host 10.128.1.9 255.255.255.0
client-identifier 0100.10aa.aa00.01
bootfile disable.cm
!
ip dhcp pool DisabledModem(0020.bbbb.0002)
host 10.128.1.10 255.255.255.0
client-identifier 0100.20bb.bb00.02
bootfile disable.cm
 
ip dhcp pool DisabledModem(1010.9581.7f66)
host 10.128.1.11 255.255.255.0
client-identifier 0100.1095.817f.66
bootfile disable.cm

CPE 装置用 DHCP プール

次に、CPE 装置用の一般的な DHCP プールの例を示します。各プールには以下のフィールドが含まれます。

network コマンドは、CPE 装置に割り当てられる IP アドレスの範囲を定義します。通常、このコマンドはケーブル インターフェイスのセカンダリ アドレス範囲のサブネットを指定します。

default-router コマンドは、デフォルトのゲートウェイを指定します。

dns-server コマンドは、CPE 装置が使用する DNS ネーム解決サーバの 1 つまたは複数の IP アドレスを指定します。

domain-name コマンドは、CPE 装置が使用する完全修飾ドメイン名を指定します。

lease コマンドは、DHCP リースが 7 日、0 時間、10 分で満了すると指定しています(CPE 装置は通常このリースを、中間点の約 3 日と 12 時間で更新しようとします)。

!
ip dhcp pool hosts
network 10.254.1.0 255.255.255.0
default-router 10.254.1.1
dns-server 10.254.1.1 10.128.1.1
domain-name ExamplesDomainName.com
lease 7 0 10
!
 

次に、特定の CPE 装置に固定のスタティック IP アドレスを割り当てる DHCP プールの例を示します。この例は、以下のコマンドを除いて前述のプールと同じです。

host コマンドは( network コマンドに代わって)CPE 装置に割り当てられる単一のスタティック IP アドレスを指定します。

client-identifier コマンドは、特定の CPE 装置を識別します。CPE 装置はイーサネット メディア コード(「01」)と装置の MAC アドレス(0001.dddd.0001)を組み合わせて識別されます。

!
ip dhcp pool staticPC(0001.dddd.0001)
host 10.254.1.12 255.255.255.0
client-identifier 0100.01dd.dd00.01
default-router 10.254.1.1
dns-server 10.254.1.1 10.128.1.1
domain-name ExamplesDomainName.com
lease 7 0 10

ToD サーバ例

次に、一般的な ToD サーバのコンフィギュレーション例を示します。

service udp-small-servers max-servers no-limit
cable time-server
 

これらのコマンドで ToD サーバをイネーブルにすることができます。

TFTP サーバ例

以下の行は、TFTP サーバを含むコンフィギュレーションから抜粋されたものです。 cable tftp-enforce コマンドは任意ですが、各ケーブル インターフェイスで使用することを推奨します。ご使用のシステムでの実際のファイルに合わせて、 tftp-server コマンドで指定するファイルを変更してください。

 
! Enable the user of unlimited small servers
service udp-small-servers max-servers no-limit
!
...
! Enable the TFTP Enforce feature on all cable interfaces
interface Cable3/0
cable tftp-enforce
interface Cable4/0
cable tftp-enforce
interface Cable5/0
cable tftp-enforce
!
!
...
! Enable the TFTP server and specify the files that can be
! downloaded along with their aliases
tftp-server disk0:gold.cm alias gold.cm
tftp-server disk0:silver.cm alias silver.cm
tftp-server disk0:bronze.cm alias bronze.cm
tftp-server disk0:ubr924-k8y5-mz.bin alias ubr924-codefile
tftp-server disk0:ubr925-k9v9y5-mz.bin alias ubr925-codefile
 

基本オールインワン コンフィギュレーション例

以下の基本「オールインワン コンフィギュレーション」サンプルは、「設定例」に示している例にあるすべてのコンポーネントを要約したものです。ここでは 5 つの DOCSIS コンフィギュレーションが使用可能です。内蔵 DOCSIS コンフィギュレーション ファイル エディタが、4 つのファイル(platinum.cm、gold.cm、silver.cm、disable.cm)の作成に使用され、5 番目のファイル(bronze.cm)は slot0 のフラッシュ メモリ装置にロードされています。disable.cm ファイルはケーブル モデムに接続されたすべての CPE 装置のネットワーク アクセスをディセーブルにし、他の 4 つのファイルは個別の Quality of Service(QoS; サービス品質)レベルを提供します。

コンフィギュレーションには、2 つの DHCP プールがあり、2 つの異なるアドレス スペースがあります。1 つのプールがケーブル モデムに対して IP アドレスとプラチナ レベルのサービスを供給し、もう 1 つのプールが CPE 装置に対して IP アドレスを供給します。

!
version 12.1
no service pad
! provides nice timestamps on all log messages
service timestamps debug datetime msec localtime
service timestamps log uptime
 
! turn service password-encryption on to encrypt passwords
no service password-encryption
 
! provides additional space for longer configuration file
service compress-config
 
! supports a large number of modems / hosts attaching quickly
service udp-small-servers max-servers no-limit
!
hostname Router
!
boot system disk0:
!
no cable qos permission create
no cable qos permission update
cable qos permission modems
 
! permits cable modems to obtain Time of Day (TOD) from uBR7100
cable time-server
 
!
! High performance DOCSIS config file, additional options may be added
! 10 Mbit/sec download, 128 Kbit/sec upload speed, 10 Kbit/sec guaranteed upstream
! NOTE: cable upstream 0 admission-control 150 will prevent modems from
! connecting after 150% of guaranteed-bandwidth has been allocated to
! registered modems. This can be used for peek load balancing.
! max-burst 1600 prevents a modem with concatenation turned on from consuming
! too much wire time, and interfering with VoIP traffic.
! cpe max 8 limits the modem to 8 hosts connected before the CMTS refuses
! additional host MAC addresses.
! Timestamp option makes the config file only valid for a short period of time.
!
cable config-file platinum.cm
service-class 1 max-upstream 128
service-class 1 guaranteed-upstream 10
service-class 1 max-downstream 10000
service-class 1 max-burst 1600
cpe max 8
timestamp
!
! Medium performance DOCSIS config file, additional options may be added
! 5 Mbit/sec download, 128 Kbit/sec upload speed
!
cable config-file gold.cm
service-class 1 max-upstream 64
service-class 1 max-downstream 5000
service-class 1 max-burst 1600
cpe max 3
timestamp
!
! Low performance DOCSIS config file, additional options may be added
! 1 Mbit/sec download, 64 Kbit/sec upload speed
!
cable config-file silver.cm
service-class 1 max-upstream 64
service-class 1 max-downstream 1000
service-class 1 max-burst 1600
cpe max 1
timestamp
!
! No Access DOCSIS config file, used to correctly shut down an unused cable modem
! 1 kbit/sec download, 1 Kbit/sec upload speed, with USB/ethernet port shut down.
!
cable config-file disable.cm
access-denied
service-class 1 max-upstream 1
service-class 1 max-downstream 1
service-class 1 max-burst 1600
cpe max 1
timestamp
!
ip subnet-zero
! Turn on cef switching / routing, anything but process switching (no ip route-cache)
ip cef
ip cef accounting per-prefix
 
! Disables the finger server
no ip finger
 
! Prevents CMTS from looking up domain names / attempting to connect to
! machines when mistyping commands
no ip domain-lookup
 
! Prevents issuance of IP address that is already in use.
ip dhcp ping packets 1
 
!
! DHCP reply settings for DOCSIS cable modems.
! All settings here are "default response settings" for this DHCP pool.
! DOCSIS bootfile (cable modem config-file) as defined above
! next-server = IP address of server which sends bootfile
! default-router = default gateway for cable modems, necessary to get DOCSIS files
! option 4 = TOD server IP address
! option 2 = Time offset for TOD, in seconds, HEX, from GMT, -28,000 = PST = ffff.8f80
! option 7 = Optional SYSLOG server
! Lease length, in days, hours, minutes
!
ip dhcp pool CableModems-Platinum
network 10.128.1.0 255.255.255.0
bootfile platinum.cm
next-server 10.128.1.1
default-router 10.128.1.1
option 2 hex ffff.8f80
option 4 ip 10.128.1.1
option 7 ip 10.128.1.1
lease 7 0 10
 
!
! DHCP reply settings for IP hosts behind DOCSIS cable modems.
! All settings here are "default response settings" for this DHCP pool.
! default-router = default gateway for cable modems, necessary to get DOCSIS files
! dns-server = IP address for DNS server, place up to 8 addresses on the same
! line as a list
! NOTE: changing the DNS-server on a Windows PC, Mac, or Unix box require
! reloading the OS, but changing it in the DHCP response is quick and easy.
! domain-name = default domain name for the host
! Lease length, in days, hours, minutes
!
ip dhcp pool hosts
network 10.254.1.0 255.255.255.0
default-router 10.254.1.1
dns-server 10.254.1.1 10.128.1.1
domain-name ExamplesDomainName.com
lease 1 0 10
!
!
!
interface FastEthernet0/0
ip address 10.17.123.1 255.255.255.0
no ip mroute-cache
no shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
no ip mroute-cache
shutdown
duplex auto
speed auto
!
! Primary address is for cable modems, use only one, so make it large enough!
! Secondary addresses are for hosts, use as many as necessary
! These addresses must match the remainder of the configuration file,
! or modems won't work.
! cable downstream frequency sets the upconverter frequency
! cable down rf-power 55, sets the upconverter output power in dBmV
! each upstream interface can have a description, use it!
! All four upstreams have been set to the same default frequency, don't
! connect wire them together while on the same frequency!
! cable upstream 0 admission-control 150: limits the number of modems
! which can connect with guaranteed-bandwidth.
! NOTE: will prevent some modems from connecting once this limit is hit.
!
! High security option:
! no cable arp: prevents the uBR7100 from ever arping towards the cable modems
! for any IP-mac address pairing. Forces EVERY host to use DHCP at least
! once every time the uBR7100 is reloaded, or the arp table is cleared out.
! Forces users to use DHCP release/renew cycle on their computers if
! ARP entry is ever lost.
! Makes it impossible for an end user to type in a static IP address,
! or steal somebody else's IP address.
!
! cable-source verify dhcp: -- Forces the CMTS to populate the arp table from
! the DHCP server
! If the DHCP server does not have a valid DHCP lease for that IP / MAC combination,
! the host is unreachable.
! cable dhcp-giaddr policy: use primary IP address for modems, secondary for
! hosts behind modems
!
!
interface Cable1/0
description Cable Downstream Interface
ip address 10.254.1.1 255.255.255.0 secondary
ip address 10.128.1.1 255.255.255.0
no keepalive
cable downstream rate-limit token-bucket shaping
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream frequency 851000000
cable down rf-power 55
cable upstream 0 description Cable upstream interface, North
cable upstream 0 frequency 37008000
cable upstream 0 power-level 0
cable upstream 0 admission-control 150
no cable upstream 0 shutdown
cable upstream 1 description Cable upstream interface, South
cable upstream 1 frequency 37008000
cable upstream 1 power-level 0
cable upstream 1 admission-control 150
no cable upstream 1 shutdown
cable upstream 2 description Cable upstream interface, East
cable upstream 2 frequency 37008000
cable upstream 2 power-level 0
cable upstream 2 admission-control 150
no cable upstream 2 shutdown
cable upstream 3 description Cable upstream interface, West
cable upstream 3 frequency 37008000
cable upstream 3 power-level 0
cable upstream 3 admission-control 150
no cable upstream 3 shutdown
no cable arp
cable source-verify dhcp
cable dhcp-giaddr policy
!
!
! default route to Fast ethernet 0/0, probably best to set
! this as an IP address so interface flaps don't create route flaps.
! IP http server: enables internal http server
!
ip classless
no ip forward-protocol udp netbios-ns
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip http server
!
!
! Enable TFTP downloads of the silver.cm file on the Flash device
! this DOCSIS config file is built using DOCSIS CPE Configurator.
tftp-server slot0:bronze.cm alias bronze.cm
!
! Aliases for frequently used commands
!
alias exec scm show cable modem
alias exec scf show cable flap
alias exec scp show cable qos profile
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
speed 19200
line vty 0 4
session-timeout 60
login
!
ntp clock-period 17179977
ntp server 192.168.35.51
end

拡張オールインワン コンフィギュレーション例

拡張オールインワン コンフィギュレーションはDHCP プールの階層構造を使用して、スタティックIPアドレスなどの固有の DHCP オプションを個々のケーブル モデムおよび CPE 装置に提供することを除いては、基本コンフィギュレーションと同じです。DHCP プールは、管理をしやすくするために固有の関連名を提供し、これらのプールを使用するケーブル モデムおよび CPE 装置は client-identifier コマンドで指定されます。

個々のケーブル モデムや CPE 装置用の DHCP プールは、親プールからオプションを継承するので、個別のプールに必要なオプションをすべて指定する必要がありません。その代わりに、新しいプールでは、 client-identifier などの親プールとは違うコマンドのみを指定する必要があります。

ケーブル モデムおよび CPE 装置に与えられたスタティック IP アドレスは 10.1.4.60 ~ 10.1.4.70 の範囲なので、 ip dhcp exclude コマンドを使用して、他のケーブル モデムや CPE 装置にこの範囲のアドレスを与えないように DHCP サーバに指示します。

!
version 12.1
no service pad
! provides nice timestamps on all log messages
service timestamps debug datetime msec localtime
service timestamps log uptime
 
! turn service password-encryption on to encrypt passwords
no service password-encryption
 
! provides additional space for longer configuration file
service compress-config
 
! supports a large number of modems / hosts attaching quickly
service udp-small-servers max-servers no-limit
!
hostname Router
!
boot system disk0:
!
no cable qos permission create
no cable qos permission update
cable qos permission modems
 
! permits cable modems to obtain Time of Day (TOD) from uBR7100
cable time-server
 
!
! High performance DOCSIS config file, additional options may be added
! 10 Mbit/sec download, 128 Kbit/sec upload speed, 10 Kbit/sec guaranteed upstream
! NOTE: cable upstream 0 admission-control 150 will prevent modems from
! connecting after 150% of guaranteed-bandwidth has been allocated to
! registered modems. This can be used for peek load balancing.
! max-burst 1600 prevents a modem with concatenation turned on from consuming
! too much wire time, and interfering with VoIP traffic.
! cpe max 8 limits the modem to 8 hosts connected before the CMTS refuses
! additional host MAC addresses.
! Timestamp option makes the config file only valid for a short period of time.
!
cable config-file platinum.cm
service-class 1 max-upstream 128
service-class 1 guaranteed-upstream 10
service-class 1 max-downstream 10000
service-class 1 max-burst 1600
cpe max 8
timestamp
!
! Medium performance DOCSIS config file, additional options may be added
! 5 Mbit/sec download, 128 Kbit/sec upload speed
!
cable config-file gold.cm
service-class 1 max-upstream 64
service-class 1 max-downstream 5000
service-class 1 max-burst 1600
cpe max 3
timestamp
!
! Low performance DOCSIS config file, additional options may be added
! 1 Mbit/sec download, 64 Kbit/sec upload speed
!
cable config-file silver.cm
service-class 1 max-upstream 64
service-class 1 max-downstream 1000
service-class 1 max-burst 1600
cpe max 1
timestamp
!
! No Access DOCSIS config file, used to correctly shut down an unused cable modem
! 1 kbit/sec download, 1 Kbit/sec upload speed, with USB/ethernet port shut down.
!
cable config-file disable.cm
access-denied
service-class 1 max-upstream 1
service-class 1 max-downstream 1
service-class 1 max-burst 1600
cpe max 1
timestamp
!
ip subnet-zero
! Turn on cef switching / routing, anything but process switching (no ip route-cache)
ip cef
ip cef accounting per-prefix
 
! Disables the finger server
no ip finger
 
! Prevents CMTS from looking up domain names / attempting to connect to
! machines when mistyping commands
no ip domain-lookup
 
! Prevents the issuance of IP addresses in this range, allows for use in
! static configurations.
ip dhcp excluded-address 10.128.1.60 10.128.1.70
 
! Prevents issuance of IP address that is already in use.
ip dhcp ping packets 1
 
!
! DHCP reply settings for DOCSIS cable modems.
! All settings here are "default response settings" for this DHCP pool.
! DOCSIS bootfile (cable modem config-file) as defined above
! next-server = IP address of server which sends bootfile
! default-router = default gateway for cable modems, necessary to get DOCSIS files
! option 4 = TOD server IP address
! option 2 = Time offset for TOD, in seconds, HEX, from GMT, -28,000 = PST = ffff.8f80
! option 7 = Optional SYSLOG server
! Lease length, in days, hours, minutes
!
ip dhcp pool CableModems-Platinum
network 10.128.1.0 255.255.255.0
bootfile platinum.cm
next-server 10.128.1.1
default-router 10.128.1.1
option 2 hex ffff.8f80
option 4 ip 10.128.1.1
option 7 ip 10.128.1.1
lease 7 0 10
 
!
! DHCP reply settings for IP hosts behind DOCSIS cable modems.
! All settings here are "default response settings" for this DHCP pool.
! default-router = default gateway for cable modems, necessary to get DOCSIS files
! dns-server = IP address for DNS server, place up to 8 addresses on the same
! line as a list
! NOTE: changing the DNS-server on a Windows PC, Mac, or Unix box require
! reloading the OS, but changing it in the DHCP response is quick and easy.
! domain-name = default domain name for the host
! Lease length, in days, hours, minutes
!
ip dhcp pool hosts
network 10.254.1.0 255.255.255.0
default-router 10.254.1.1
dns-server 10.254.1.1 10.128.1.1
domain-name ExamplesDomainName.com
lease 1 0 10
!
 
! DHCP reply settings for a static IP address for a PC and cable modems
! All settings here will override "default response settings" for this DHCP pool.
! client-identifier is the ethernet MAC address of the device, preceded by 01
! Thus, the Host with an mac address of 08.00.09.af.34.e2 will ALWAYS get the
! same IP address
! Lease length, in days, hours, minutes, set to infinite.
! Use a relevant name here, as there will be lots of these entries.
!
ip dhcp pool staticPC(0800.09af.34e2)
host 10.254.1.12 255.255.255.0
client-identifier 0108.0009.af34.e2
client-name staticPC(0800.09af.34e2)
lease infinite
 
ip dhcp pool cm-0050.04f9.efa0cm-
host 10.128.1.65 255.255.255.0
client-identifier 0100.107b.ed9b.45
bootfile disable.cm
!
ip dhcp pool cm-0030.d002.41f5
host 10.128.1.66 255.255.255.0
client-identifier 0100.107b.ed9b.23
bootfile silver.cm
!
! DHCP reply settings for a cable modem, to change from default provisioning
! All settings here will override "default response settings" for this DHCP pool.
! client-identifier is the ethernet MAC address of the device, preceded by 01
! Thus, the modem with a mac address of 00.10.95.81.7f.66 will ALWAYS get the
! same IP address
! This cable modem will get the gold.cm config file, and a consistent IP address
! some IP address within the DHCP pool for the cable downstream interface is
! required, or the reference correct config file will NOT be issued.
! Use a relevant name here, as there will be lots of these entries.
!
! WARNING: When changing config files for a modem, it is necessary to clear the
! address with “clear ip dhcp binding <ip-address>” and then reset the modem using
! "clear cable modem <mac-address> | <ip-address> reset"
!
ip dhcp pool goldmodem
host 10.128.1.67 255.255.255.0
client-identifier 0100.1095.817f.66
bootfile gold.cm
!
! DHCP reply settings for a disabled cable modem.
! This will prevent this cable modem user from accessing the network.
! client-identifier is the ethernet MAC address of the device, preceded by 01
! This cable modem will get the disable.cm config file, and a consistent IP address
! some IP address within the DHCP pool for the cable downstream interface is
! required, or the reference correct config file will NOT be issued.
! Use a relevant name here, as there will be lots of these entries.
!
! WARNING: When changing config files for a modem, it is necessary to clear the
! address with “clear ip dhcp binding <ip-address>” and then reset the modem using
! "clear cable modem <mac-address> | <ip-address> reset"
!
ip dhcp pool DisabledModem(0010.aaaa.0001)
host 10.128.1.68 255.255.255.0
client-identifier 0100.1095.817f.66
bootfile disable.cm
!
ip dhcp pool DisabledModem(0000.bbbb.0000)
client-identifier 0100.00bb.bb00.00
host 10.128.1.69 255.255.255.0
bootfile disable.cm
!
!
!
interface FastEthernet0/0
ip address 10.17.123.1 255.255.255.0
no ip mroute-cache
no shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
no ip mroute-cache
shutdown
duplex auto
speed auto
!
! Primary address is for cable modems, use only one, so make it large enough!
! Secondary addresses are for hosts, use as many as necessary
! These addresses must match the remainder of the configuration file,
! or modems won't work.
! cable downstream frequency sets the upconverter frequency
! cable down rf-power 55, sets the upconverter output power in dBmV
! each upstream interface can have a description, use it!
! All four upstreams have been set to the same default frequency, don't
! connect wire them together while on the same frequency!
! cable upstream 0 admission-control 150: limits the number of modems
! which can connect with guaranteed-bandwidth.
! NOTE: will prevent some modems from connecting once this limit is hit.
!
! High security option:
! no cable arp: prevents the uBR7100 from ever arping towards the cable modems
! for any IP-mac address pairing. Forces EVERY host to use DHCP at least
! once every time the uBR7100 is reloaded, or the arp table is cleared out.
! Forces users to use DHCP release/renew cycle on their computers if
! ARP entry is ever lost.
! Makes it impossible for an end user to type in a static IP address,
! or steal somebody else's IP address.
!
! cable-source verify dhcp: -- Forces the CMTS to populate the arp table from
! the DHCP server
! If the DHCP server does not have a valid DHCP lease for that IP / MAC combination,
! the host is unreachable.
! cable dhcp-giaddr policy: use primary IP address for modems, secondary for
! hosts behind modems
!
!
interface Cable1/0
description Cable Downstream Interface
ip address 10.254.1.1 255.255.255.0 secondary
ip address 10.128.1.1 255.255.255.0
no keepalive
cable downstream rate-limit token-bucket shaping
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream frequency 851000000
cable down rf-power 55
cable upstream 0 description Cable upstream interface, North
cable upstream 0 frequency 37008000
cable upstream 0 power-level 0
cable upstream 0 admission-control 150
no cable upstream 0 shutdown
cable upstream 1 description Cable upstream interface, South
cable upstream 1 frequency 37008000
cable upstream 1 power-level 0
cable upstream 1 admission-control 150
no cable upstream 1 shutdown
cable upstream 2 description Cable upstream interface, East
cable upstream 2 frequency 37008000
cable upstream 2 power-level 0
cable upstream 2 admission-control 150
no cable upstream 2 shutdown
cable upstream 3 description Cable upstream interface, West
cable upstream 3 frequency 37008000
cable upstream 3 power-level 0
cable upstream 3 admission-control 150
no cable upstream 3 shutdown
no cable arp
cable source-verify dhcp
cable dhcp-giaddr policy
!
!
! default route to Fast ethernet 0/0, probably best to set
! this as an IP address so interface flaps don't create route flaps.
! IP http server: enables internal http server on uBR7100
!
ip classless
no ip forward-protocol udp netbios-ns
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip http server
!
!
! Enable TFTP downloads of the silver.cm file on the Flash device
! this DOCSIS config file is built using DOCSIS CPE Configurator.
tftp-server slot0:bronze.cm alias bronze.cm
!
! Aliases for frequently used commands
!
alias exec scm show cable modem
alias exec scf show cable flap
alias exec scp show cable qos profile
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
speed 19200
line vty 0 4
session-timeout 60
login
!
ntp clock-period 17179977
ntp server 192.168.35.51
 

参考資料

モジュール機能に関連する情報については、次の参考資料を参照してください。

関連資料

関連項目
資料名

オールインワン コンフィギュレーション

「オールインワン コンフィギュレーション」で DHCP、ToD、および TFTP サーバとして動作するように、Cisco CMTS を設定する手順については、次の URL を参照してください。

http://www.cisco.com/warp/customer/109/all_in_one_config.shtml

DHCP の設定

ここで説明した最低限のオプション以外に、さらに追加オプションを使用して DHCP サーバを設定する手順については、次の URL で『 Cisco IOS IP and IP Routing Configuration Guide 』Release 12.2 の「IP Addressing and Services」の「Configuring DHCP」の章を参照してください。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fipr_c/index.htm

すべての DHCP コマンドの詳細については、次の URL で『 Cisco IOS IP Command Reference, Volume 1 of 3: Addressing and Services 』Release 12.2 の「DHCP Commands」の章を参照してください。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fipras_r/index.htm

TFTP サーバ コマンド

tftp-server コマンドの詳細については、次の URL で『 Cisco IOS Configuration Fundamentals Configuration Guide 』Release 12.2 の「Configuring Basic File-Transfer Services」を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/ffun_c/ffcprt2/index.htm

NTP または SNTP の設定

Cisco CMTS を設定して、NTP または SNTP を使用し、システム クロックを設定するには、次の URL で『 Cisco IOS Configuration Fundamentals Configuration Guide 』Release 12.2の「System Management」の「Performing Basic System Management」の章を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/ffun_c/fcfprt3/fcf012.htm

ケーブル送信元確認機能

ケーブル送信元確認コマンドの詳細な説明と、特定のタイプのサービス拒否攻撃を防ぐ方法については、Cisco.comの次のURLでテクニカル ノートを参照してください。
http://www.cisco.com/warp/public/109/source_verify.html

DHCP オプション 2 の 16 進数値の計算

DHCP タイム オフセット オプション(DHCP オプション 2)を設定するために使用する 16 進数の時間値を計算する方法については、次の URL を参照してください。

http://www.cisco.com/warp/public/109/calculate_hexadecimal_dhcp.html

内蔵 DOCSIS コンフィギュレーション ファイル エディタ

内蔵 DOCSIS コンフィギュレーション ファイル エディタの使用方法については、次の URL で『 Cisco CMTS Feature Guide 』の「Internal DOCSIS Configurator File Generator for the Cisco CMTS」の章を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/cable/cab_rout/cmtsfg/ufgcfile.htm

Cisco DOCSIS Configurator ツール

DOCSIS 1.1 コンフィギュレーション ファイルの作成方法の詳細情報は、Cisco DOCSIS Configurator ツールを使用して次の URL から入手できます。情報は、このマニュアルの発行時点から入手可能です。

http://www.cisco.com/cgi-bin/tablebuild.pl/cpe-conf

CMTS コマンド リファレンス

次の URL で『 Cisco Broadband Cable Command Reference Guide 』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/cable/bbccmref/index.htm

Cisco IOS Release 12.2 コマンド リファレンス

次の URL で『 Cisco IOS Release 12.2 Configuration Guides and Command References 』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/index.htm

Cisco uBR7100 シリーズ ユニバーサル ブロードバンド ルータのマニュアル

次の URL で『 Cisco uBR7100 Series Universal Broadband Router Hardware Installation Guide 』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/cable/ubr7100/hig7100/index.htm

次の URL で『 Cisco uBR7100 Series Universal Broadband Router Software Configuration Guide 』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/cable/ubr7100/scg7100/index.htm

Cisco uBR7200 シリーズ ユニバーサル ブロードバンド ルータのマニュアル

次の URL で『 Cisco uBR7200 Series Universal Broadband Router Hardware Installation Guide 』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/cable/cab_rout/cr72hig/index.htm

次の URL で『 Cisco uBR7200 Series Universal Broadband Router Software Configuration Guide 』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/cable/cab_rout/cr72scg/index.htm

Cisco uBR10012 ユニバーサル ブロードバンド ルータのマニュアル

次の URL で『 Cisco uBR10012 Universal Broadband Router Hardware Installation Guide 』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/cable/ubr10k/ubr10012/hig/index.htm

次の URL で『 Cisco uBR10012 Universal Broadband Router Software Configuration Guide 』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/cable/ubr10k/ubr10012/scg/index.htm

標準規格

標準規格 1
タイトル

ANSI/SCTE 22-1 2002
(旧 SP-RFI-C01-011119)

Data-Over-Cable Service Interface Specification DOCSIS 1.0 Radio Frequency Interface(RFI)( http://www.cablemodem.com

SP-RFIv1.1-I08-020301

Data-over-Cable Service Interface Specifications Radio Frequency Interface Specification DOCSIS 1.1( http://www.cablemodem.com

SP-BPI+-I08-020301

DOCSIS Baseline Privacy Interface Plus Specification( http://www.cablemodem.com

1.サポートしている標準規格をすべて記載しているわけではありません。

MIB

MIB 2
MIB リンク

DOCS-CABLE-DEVICE-MIB RFC 2669

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

2.サポートしている MIB(管理情報ベース)をすべて記載しているわけではありません。

テクニカル サポート

説明
リンク

TAC ホームページは、3 万ページの技術コンテンツが検索可能で、製品、技術、ソリューション、技術ヒント、ツールへのリンクが含まれています。Cisco.com 登録ユーザは、このページからログインしてさらに豊富なコンテンツにアクセスできます。

http://www.cisco.com/public/support/tac/home.shtml