Cisco Cable Modem Termination System (CMTS) の概要
Cisco CMTS での PPPoE の終端
Cisco CMTS での PPPoE の終端
発行日;2012/02/03 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

Cisco CMTS での PPPoE の終端

内容

の前提条件

の制限事項

の概要

機能の概要

利点

機能の設定方法

Cisco CMTS での VPDN のイネーブル化

Cisco CMTS での仮想テンプレートの設定

PPPoE セッション用 VPDN グループの設定

Cisco CMTS での L2TP トンネル開始用 VPDN グループの設定

ケーブル インターフェイス上での PPPoE のイネーブル化

LNS としての Cisco ルータの設定

PPPoE セッションのクリア

アクティブ PPPoE セッションに対する SNMP トラップのイネーブル化

機能のモニタ

PPPoE の終端の設定例

Cisco CMTS での PPPoE の終端(L2TP トンネリングなし)

Cisco CMTS での PPPoE の終端(L2TP トンネリングあり)

Cisco ルータ上での PPPoE クライアントの設定

LNS 用の PPPoE の設定

参考資料

関連資料

標準規格

MIB

RFC

テクニカル サポート

Cisco CMTS での PPPoE の終端

改訂: February 5, 2007, OL-1467-08-J

この章ではCable Monitor and Interceptについて説明します。この方法を使用すると、PPP パケットをイーサネット MAC フレームでカプセル化して、既存の PPP ダイヤルアップ プロビジョニング システムをケーブル ネットワークのユーザに展開できます。

Cable Monitor and Interceptの機能仕様

機能履歴
リリース
変更

Release 12.1(5)T

この機能が Cisco uBR7200 シリーズ ルータに導入されました。


) Cisco IOS Release 12.1T および 12.2T トレインは、Cisco uBR7200 シリーズ ルータでサポートされていません。


Release 12.2(4)BC1a

この機能が Cisco uBR7100 シリーズおよび Cisco uBR7246 VXR ルータの 12.2BC トレインでサポートされました。

Release 12.2(8)BC1

CISCO-PPPOE-MIB の SNMP(簡易ネットワーク管理プロトコル)サポートが追加されました。

Release 12.2(8)BC2

バンドルされたケーブル インターフェイスに対するサポートが追加されました。

サポート対象プラットフォーム

Cisco uBR7100 シリーズ、Cisco uBR7246 VXR ルータ


) Cable Monitor and Intercept機能は、Cisco IOS ソフトウェア リリースが稼働する Cisco uBR10012 ユニバーサル ブロードバンド ルータではサポートされません。また、Cable Monitor and Interceptは Cisco IOS Release 12.1 EC が稼働する Cisco Cable Modem Termination System(CMTS; ケーブル モデム終端システム)ルータでもサポートされません。


プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報

プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報を調べるには、Cisco Feature Navigator を使用します。Cisco Feature Navigator は、 http://www.cisco.com/go/fn からアクセスできます。Feature Navigator にアクセスするには、Cisco.com のアカウントが必要です。アカウントを登録していない場合、またはユーザ名とパスワードを忘れた場合には、ログイン ダイアログ ボックスで Cancel をクリックして表示される手順に従います。

Cable Monitor and Interceptの前提条件

Cable Monitor and Intercept機能には、次の前提条件があります。

Cable Monitor and Intercept機能がサポートされるのは、Cisco uBR7100 シリーズおよび Cisco uBR7246 VXR ユニバーサル ブロードバンド ルータだけです。

Cisco CMTS ルータでは、Cisco IOS Release 12.2(4)BC1 以上のリリースが稼働している必要があります。さらに、Cable Monitor and Intercept機能をサポートするために、ソフトウェア イメージ名に IP+ フィーチャ セットを含んでいる必要があります(ソフトウェア イメージ名に「i」および「s」の文字を含む)。

バンドルされたケーブル インターフェイスでCable Monitor and Interceptをサポートするには、Cisco CMTS ルータで Cisco IOS Release 12.2(8)BC2 以上のリリースが稼働している必要があります。

クライアント ソフトウェアがCable Monitor and Interceptプロトコルに対応している必要があります。コンピュータのオペレーティング システムがこのプロトコルに対応していない場合は、WinPoet などのクライアント ソフトウェアを使用します。

大量の Point-to-Point Protocol over Ethernet(PPPoE)セッションおよびトラフィックが見込まれる場合は、 hold-queue packet-size { in | out } コマンドを使用して、WAN インターフェイス(ATM、DPT、ギガビット イーサネットなど)のパケット ホールド キューのサイズを大きくします。次に、表示例を示します。

Router(config)# interface gigabitethernet 1/0
Router(config-if)# hold-queue 4096 in
Router(config-if)# hold-queue 4096 out
Router(config-if)#

Cable Monitor and Interceptの制限事項

Cable Monitor and Intercept機能には、次の制限事項があります。

Cable Monitor and Intercept機能がサポートされるのは、Cisco IOS Release 12.2(4)BC1a 以降のリリースが稼働している Cisco uBR7100 シリーズ ルータおよび Cisco uBR7246 VXR ルータだけです。Cisco uBR10012 ルータではサポートされません。

Cable Monitor and Interceptは、Cisco IOS Release 12.1 EC が稼働する Cisco CMTS ルータではサポートされません。

PPPoE 転送は、Cisco CMTS ではサポートされません。

表15-1 に、さまざまなプロセッサ カードを使用した場合に、Cisco uBR7100 シリーズ ルータおよび Cisco uBR7246 VXR ルータでサポートされる PPPoE の絶対最大数を示します。

 

表15-1 PPPoE セッションの絶対最大数

プロセッサ
PPPoE セッションの絶対最大数

Cisco uBR7100 シリーズ

4000

NPE-225

4000

NPE-300 1

4000

NPE-400

8000

NPE-G1

10000

1.NPE-300 プロセッサは 2001 年 8 月 15 日に使用期限が切れました。


) 同時にアクティブになる PPPoE セッションの最大数はずっと少なく(約 600 ~ 800)、プロセッサ カードに搭載されたメモリ容量、使用されているケーブル インターフェイス カードのタイプ、各ユーザが使用する帯域幅、およびルータの設定によって異なります。


Cable Monitor and Interceptの概要

ここでは、Cable Monitor and Intercept機能について説明します。

「機能の概要」

「利点」

機能の概要

PPPoE 機能は、ケーブル インターフェイス上で PPPoE をサポートするので、サービス プロバイダーは既存のダイヤルアップ プロビジョニング システムをケーブル ネットワーク上のユーザに広げることができます。Cable Monitor and Interceptがイネーブルの場合、CiscoCMTS は PPPoE セッション内で PPP パケットをイーサネット フレームでカプセル化します。

Cisco CMTS がユーザの PC が開始した PPPoE セッションから PPPoE トラフィックを受信すると、Cisco CMTS はケーブル インターフェイス上の PPPoE セッションを終了するか、またはセキュア トンネル接続を経由して PPPoE トラフィックを送信します。これは、Cisco CMTS の設定に左右されます。次に、最も標準的な設定を示します。

インターネット アクセス ― 基本的なインターネット アクセスだけを希望する住宅のカスタマーやその他のユーザの場合、トラフィックは WAN インターフェイスで標準的な IP パケットとして送信されます。サービス プロバイダーは、ダイヤルアップ ユーザおよび他のブロードバンド ユーザに対して使用しているのと同じプロビジョニング システムを使用できます。PPPoE セッションはケーブル モデムと Cisco CMTS の間だけに存在するので、ネットワークの管理と設定が容易になります。

企業のセキュア アクセス ― 企業および在宅勤務者の場合、トラフィックはポイントツーポイントの Layer 2 Tunneling Protocol(L2TP)トンネルで L2TP Network Server(LNS)に転送され、企業のイントラネットへのセキュア アクセスを可能にします。ケーブル モデム ユーザは、企業のネットワークに直接接続されている場合と同様に、企業のリソースにアクセスでき、ネットワーク セキュリティを犠牲にすることもありません。このトンネルは企業側で使用されているインターフェイスの種類(イーサネット、ATM など)に関係なく構築できます。

L2TP トンネルの設定を使用する場合、Cisco CMTS は L2TP Access Concentrator(LAC)またはNetwork Access Server(NAS)として機能します。トンネルのエンドポイントは LNS です。LNS には Cisco 6400 Carrier-Class Broadband Aggregator などのルータ使用できます。

ブリッジとして動作するケーブル モデムが PPPoE セッションのトラフィックを受信すると、ケーブル モデムはそのトラフィックをケーブル モデムに接続されたホストや他のカスタマー側装置に転送します。これらのホストやカスタマー側装置のユーザは、標準の PPP を使用してケーブル ネットワークにログオンし、IP アドレスと他のネットワーク情報を取得します。ユーザは PPPoE に対応したルータや WinPoet などの標準 PPPoE ソフトウェアを使用して、この手順を自動的に処理できます。

ユーザ名とパスワードは Cisco CMTS の設定に組み込むことができます。あるいは、サービス プロバイダーはダイヤルアップおよび Digital Subscriber Line(DSL; デジタル加入者線)ユーザに対して使用しているのと同じ Remote Authentication Dial-In User Service(RADIUS)認証サーバを使用することもできます。たとえば、Cisco Subscriber Registration Center(CSRC)では、RADIUS サーバ認証を行うアクセス レジストラが提供されます。

Cable Monitor and Intercept機能では、同じケーブル モデムで PPPoE クライアントと Dynamic Host Configuration Protocol(DHCP)クライアントを同時に使用できます。加入者は最初に PPPoE を使用してケーブル ネットワークにログオンし、次に DHCP を使用して他の PC やホストがネットワーク アクセス用の IP アドレスを取得できるようにします。


) Cisco CMTS ルータは PPPoE 転送(着信インターフェイスで PPPoE パケットを受信し、発信インターフェイスからそれらを転送)に対応していません。Cisco uBR7100 シリーズ ルータは、MxU ブリッジング モード(Cisco IOS Release 12.1 EC だけが対応)に設定すると、PPPoE トラフィックを自動転送しますが、これはブリッジングの設定によるもので、PPPoE に対応していることによるものではありません。


利点

サービス プロバイダーおよびそのパートナーやカスタマーに対するCable Monitor and Intercept機能の利点は、次のとおりです。

PPPoE はケーブル モデムで使用する標準的な Data-over-Cable Service Interface Specifications(DOCSIS)の登録および認証手順を補完しますが、干渉はしません。

PPPoE は、ブリッジ接続されたイーサネット LAN 上で PPP(ポイントツーポイント プロトコル)セッションを PC(ホスト)まで広げることにより、既存の Customer Premises Equipment(CPE; 顧客宅内機器)上で使用できます。

PPPoE はダイヤルアップ モデルで ISP が使用するポイントツーポイント セッションをそのまま使用するので、IP 通信プロトコルを間に使用する必要がありません。

サービス プロバイダーは、ケーブル ネットワーク上のユーザに対して既存のダイヤルアップ PPP プロビジョニングおよび認証システムを使用できます。

PPPoE は、PPP システムに組み込まれた Challenge Handshake Authentication Protocol(CHAP)および Password Authentication Protocol(PAP)などのセキュリティ機能をサポートしています。

サービス プロバイダーは、同じケーブル モデムで PPPoE クライアントと DHCP ベース ホストの両方をサポートできます。

Cable Monitor and Intercept機能の設定方法

ここでは、Cable Monitor and Intercept機能を導入するために必要な次の作業について説明します。これらの作業はすべて必須で、ルータの設定によって異なります。

「Cisco CMTS での VPDN のイネーブル化」

「Cisco CMTS での仮想テンプレートの設定」

「PPPoE セッション用 VPDN グループの設定」

「Cisco CMTS での L2TP トンネル開始用 VPDN グループの設定」

「ケーブル インターフェイス上での PPPoE のイネーブル化」

「LNS としての Cisco ルータの設定」

「PPPoE セッションのクリア」

「アクティブ PPPoE セッションに対する SNMP トラップのイネーブル化」

Cisco CMTS での VPDN のイネーブル化

LAC として機能する Cisco CMTS ルータで、Virtual Private Dialup Network(VPDN; 仮想私設ダイヤルアップ網)をイネーブルにするには、次のコマンドを使用して、ユーザ EXEC モードを開始します。この作業は、他の設定作業を行う前に実行する必要があります。


) また、この作業は LNS として機能する Cisco ルータ上で実行する必要があります。


ステップの概略

1. enable

2. configure terminal

3. buffers small { initial | max-free | permanent } 1024

4. vpdn enable

5. vpdn logging

6. username user-name password {0 | 7} password

7. exit

ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

buffers small { initial | max-free | permanent } 1024

 

Router(config)# buffers small initial 1024

Router(config)# buffers small max-free 1024

Router(config)# buffers small permanent 1024

Router(config)#

(任意)スモール パケットに使用されるルータのバッファ サイズを増やして、PPPoE セッション中に送信されるより多くのキープアライブ パケットに対応します。


) 各種のスモール パケット バッファに対してこのコマンドを繰り返します。


ステップ 4

vpdn enable

 

Router(config)# vpdn enable

Router(config)#

VPDN をイネーブルにします。

ステップ 5

vpdn logging

 

Router(config)# vpdn logging

Router(config)#

(任意)VPDN のロギングをイネーブルにします。VPDN をイネーブルにすると、デフォルト( no vpdn logging )でロギングは自動的にディセーブルになります。ロギングをイネーブルにするには、このコマンドを使用します。

ステップ 6

username user-name password [ level ] password

 

Router(config)# username pppoe-user1@client.com password 0 pppoepassword

Router(config)#

PPPoE アクセスを許可された各ユーザのユーザ名とパスワードを指定します。

user-name = ユーザがログインするためのユーザ名。

level =(任意)パスワードの暗号レベル。有効値は 0(デフォルト、パスワードは暗号化されない)および 7(パスワードは暗号化される。通常、このオプションは他のルータから設定をカットアンドペーストした場合にだけ使用)です。

password = 上記のユーザがログインして PPPoE セッションを設定するのに使用するパスワード。


) ユーザ認証に RADIUS などの外部サーバを使用している場合、このステップは必要ありません。


ステップ 7

exit

 

Router(config)# exit

Router#

グローバル コンフィギュレーション モードを終了します。

Cisco CMTS での仮想テンプレートの設定

LAC として動作している Cisco CMTS ルータで仮想テンプレートの作成と設定を行うには、次のコマンドを使用して、ユーザ EXEC モードを開始します。Cisco CMTS は仮想テンプレートを使用して、個々の PPPoE セッション対して用意する仮想インターフェイスを設定するので、この作業は必須です。


) ケーブル モデム ユーザからの PPPoE セッションをサポートするには、少なくとも 1 つの仮想テンプレートをルータ上に作成する必要があります。


ステップの概略

1. enable

2. configure terminal

3. interface virtual-template number

4. ip unnumbered interface

5. ip mtu 1492

6. keepalive [ period [ retries ]]

7. peer default ip address pool name

8. ppp authentication { chap | ms-chap | pap }

9. ppp timeout authentication response-time

10. ppp timeout retry timeout

11. no logging event link-status

12. no cdp enable

13. exit

14. exit

ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface virtual-template number

 

Router(config)# interface virtual-template 1

Router(config-if)#

設定する仮想テンプレート インターフェイスの番号を選択して、インターフェイス コンフィギュレーション モードを開始します。


) 各ルータには最大 200 の仮想インターフェイスを作成できます。


ステップ 4

ip unnumbered interface

 

Router(config-if)# ip unnumbered Ethernet2/0

Router(config-if)#

各仮想インターフェイスに固有の IP アドレスを割り当てるのではなく、指定したインターフェイスの IP アドレスを使用して、IP パケットを処理する仮想テンプレート インターフェイスをイネーブルにします。

ステップ 5

ip mtu 1492

 

Router(config-if)# ip mtu 1492

Router(config-if)#

Maximum Transmission Unit(MTU; 最大伝送ユニット)サイズを 1492 バイトに設定し、PPP および PPPoE のカプセル化で 8 バイトの追加ヘッダーを使用できるようにします。

ステップ 6

keepalive period [ retries ]

 

Router(config-if)# keepalive 60 10

Router(config-if)#

(任意)トンネル プロトコルを停止して特定の PPPoE セッションを終了する前に、仮想インターフェイス上でルータが応答を受信せずにキーブアライブ メッセージを送信する間隔および回数を指定します。

period = ルータがキープアライブ メッセージを送信し、応答を待つ時間(秒)を指定します。有効範囲は 0 ~ 32,767 秒で、デフォルトは 10 です。

retries =(任意)ルータが応答を受信せずにキープアライブ パケットを再送する回数を指定します。有効範囲は 1 ~ 255 で、デフォルトは 5 です。


) 多数の PPPoE セッションに対応する際には、
キープアライブ間隔とリトライ回数を大きくしなければならない場合があります。


ステップ 7

peer default ip address pool name [ name2 ...]

 

Router(config-if)# peer default ip address pool local

Router(config-if)#

(任意)PPPoE クライアントに IP アドレスを割り当てる際に使用する 1 つまたは複数のアドレス プールを定義します。

ステップ 8

ppp authentication { chap | ms-chap | pap }

 

Router(config-if)# ppp authentication chap

Router(config-if)#

PPPoE セッションで使用する認証方式を定義します。

chap = Challenge Handshake Authentication Protocol

ms-chap = CHAP の Microsoft バージョン

pap = Password Authentication Protocol

ステップ 9

ppp timeout authentication response-time

 

Router(config-if)# ppp timeout authentication 10

Router(config-if)#

(任意)ルータが PPP 認証パケットに対する応答を待つ最大時間(秒)を指定します。有効範囲は 0 ~ 255 秒で、デフォルトは 10 秒です。


) タイムアウト エラーが原因で PPPoE セッションが切れるようになったらタイムアウトを大きくします。


ステップ 10

ppp timeout retry timeout

 

Router(config-if)# ppp timeout retry 5

Router(config-if)#

(任意)ルータが PPP ネゴシエーション中に応答を待つ最大時間(秒)を指定します。有効範囲は 1 ~ 255 秒で、デフォルトは 2 秒です。


) タイムアウト エラーが原因で PPPoE セッションが切れるようになったらタイムアウトを大きくします。


ステップ 11

no logging event link-status

 

Router(config-if)# no logging event link-status

Router(config-if)#

(任意)不要なリンク アップおよびリンク ダウン イベント メッセージをルータのイベント ログに送信しないようにします。これらのメッセージは、PPPoE セッションの開始および終了の度に送信されます。

ステップ 12

no cdp enable

 

Router(config-if)# no cdp enable

Router(config-if)#

(任意)仮想インターフェイス上での Cisco Discovery Protocol(CDP)の使用をディセーブルにします。このプロトコルは PPPoE セッションの仮想インターフェイスでは必要ありません。

ステップ 13

exit

 

Router(config-if)# exit

Router(config)#

インターフェイス コンフィギュレーション モードを終了します。

ステップ 14

exit

 

Router(config)# exit

Router#

グローバル コンフィギュレーション モードを終了します。

PPPoE セッション用 VPDN グループの設定

LAC として機能する Cisco CMTS ルータで、VPDN グループの作成と設定を行うには、次のコマンドを使用して、ユーザ EXEC モードを開始します。ルータは VPDN グループを使用して、ケーブル モデム ユーザ用に作成された PPPoE セッションを設定します。Cisco CMTS では、この作業は必須です。


) PPPoE セッションをサポートするには、VPDN グループを 1 つだけ作成します。


ステップの概略

1. enable

2. configure terminal

3. vpdn-group number

4. accept-dialin

5. protocol pppoe

6. virtual-template number

7. exit

8. lcp renegotiation { always | on-mismatch }

9. pppoe limit per-mac number

10. pppoe limit max-sessions number-of-sessions [ threshold-sessions number ]

11. exit

12. exit

ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

vpdn-group name

 

Router(config)# vpdn-group 1

Router(config-vpdn)#

指定した名前または番号を使用して VPDN グループを作成し、VPDN グループ コンフィギュレーション モードを開始します。

ステップ 4

Router(config-vpdn)# accept-dialin

 

Router(config-vpdn)# accept-dialin

Router(config-vpdn-acc-in)#

LAC からのトンネル化された PPP/PPPoE 接続を受け入れるようにルータを設定して、VPDN アクセプト ダイヤルイン コンフィギュレーション モードを開始します。

ステップ 5

Router(config-vpdn)# protocol pppoe

 

Router(config-vpdn)# protocol pppoe

Router(config-vpdn-acc-in)#

PPPoE を使用するように VPDN グループを設定します。

ステップ 6

virtual-template number

 

Router(config-vpdn-acc-in)# virtual-template 1

Router(config-vpdn-acc-in)#

PPPoE セッションを設定する際に使用する仮想インターフェイスのテンプレートの数を指定します。


) これは、「Cisco CMTS での仮想テンプレートの設定」で定義される仮想インターフェイスのテンプレートと同じになる必要があります。


ステップ 7

exit

 

Router(config-vpdn-acc-in)# exit

Router(config-vpdn)#

VPDN アクセプト ダイヤルイン コンフィギュレーション モードを終了します。

ステップ 8

lcp renegotiation { always | on-mismatch }

 

Router(config-vpdn)# lcp renegotiation always

Router(config-vpdn)#

(任意)LNS として動作する Cisco CMTS が LAC として動作するルータと PPP Link Control Protocol(LCP; リンク制御プロトコル)をネゴシエートできるかどうかを指定します。

always = Cisco CMTS が常に接続を再度ネゴシエートできるようにします。

on-mismatch = LNS と LAC の間に設定の不一致が見つかった場合だけ、Cisco CMTS が接続を再度ネゴシエートできるようにします。

デフォルトでは、LNS は接続を再度ネゴシエートできません。

ステップ 9

pppoe limit per-mac number

 

Router(config-vpdn)# pppoe limit per-mac 1

Router(config-vpdn)#

(任意)各 MAC アドレスから開始できる PPPoE セッションの最大数を指定します。有効範囲は 1 ~ 5000 で、デフォルトは 100 です。ケーブル ユーザの場合、MAC アドレスごとの PPPoE セッションの最大数を 1 に設定することを推奨します。


) このコマンドは、ステップ 5で PPPoE プロトコルのグループを設定したあとでないと使用できません。


ステップ 10

pppoe limit max-sessions number-of-sessions [ threshold-sessions number ]

 

Router(config-vpdn)# pppoe limit max-sessions 1000 threshold-sessions 750

Router(config-vpdn)#

(任意)ルータでサポートされる PPPoE セッションの数を指定します。

number = ルータ上で一時に使用できる PPPoE セッションの最大数を指定します。有効範囲は 1 ~ 5000 で、デフォルトは 100 です。

threshold-sessions number =(任意)アクティブな PPPoE セッションのしきい値を指定します。セッション数がこの値を超えると、SNMP トラップが送信されます。有効範囲は 1 ~ 5000 で、デフォルトは number-of-sessions の値と同じです。


) このコマンドは、ステップ 5で PPPoE プロトコルのグループを設定したあとでないと使用できません。


ステップ 11

exit

 

Router(config-vpdn)# exit

Router(config)#

VPDN グループ コンフィギュレーション モードを終了します。

ステップ 12

exit

 

Router(config)# exit

Router#

グローバル コンフィギュレーション モードを終了します。

Cisco CMTS での L2TP トンネル開始用 VPDN グループの設定

LAC として動作する VPDN の作成と設定を行い、LNS を使用して L2TP トンネルを作成するには、次のコマンドを使用して、ユーザ EXEC モードを開始します。


) PPPoE セッションで L2TP トンネリングを使用する場合、この作業は必須です。この設定では、PPPoE セッションをサポートするために VPDN グループを少なくとも 1 つ作成する必要があり、L2TP トンネルをサポートするために別の VPDN グループを少なくとも 1 つ作成する必要があります。


ステップの概略

1. enable

2. configure terminal

3. vpdn-group number

4. request-dialin

5. protocol l2tp

6. domain domain-name

7. exit

8. initiate-to ip ip-address

9. local name pppoe-username

10. no l2tp tunnel authentication

11. exit

12. exit

ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

vpdn-group number

 

Router(config)# vpdn-group 2

Router(config-vpdn)#

指定した番号を使用して VPDN グループを作成し、VPDN グループ コンフィギュレーション モードを開始します。

ステップ 4

Router(config-vpdn)# request-dialin

 

Router(config-vpdn)# request-dialin

Router(config-vpdn-req-in)#

L2TP トンネル要求を開始するようにルータを設定して、VPDN リクエスト ダイヤルイン コンフィギュレーション モードを開始します。

ステップ 5

protocol l2tp

 

Router(config-vpdn-req-in)# protocol l2tp

Router(config-vpdn-req-in)#

L2TP プロトコルの VPDN グループを設定します。

ステップ 6

domain domain-name

 

Router(config-vpdn-req-in)# domain client.com

Router(config-vpdn-req-in)#

指定したドメイン名からアクセスを要求するクライアントに対して PPPoE セッションを確立するために、この VPDN グループを使用することを指定します。

ステップ 7

exit

 

Router(config-vpdn-req-in)# exit

Router(config-vpdn)#

VPDN リクエスト ダイヤルイン コンフィギュレーション モードを終了します。

ステップ 8

initiate-to ip ip-address

 

Router(config-vpdn)# initiate-to ip 10.10.10.2

Router(config-vpdn)#

この VPDN グループを使用している PPPoE クライアントが使用する L2TP トンネルの終端ポイントの IP アドレスを設定します。

ステップ 9

local name pppoe-username

 

Router(config-vpdn)# local name PpPoE-UsER

Router(config-vpdn)#

VPDN グループ上で認証に使用するユーザ名を指定します。

ステップ 10

no l2tp tunnel authentication

 

Router(config-vpdn)# no l2tp tunnel authentication

Router(config-vpdn)#

L2TP トンネルの確立に使用する認証をディセーブルにします(ただし、個々のユーザ セッションの認証が継続します)。

ステップ 11

exit

 

Router(config-vpdn)# exit

Router(config)#

VPDN グループ コンフィギュレーション モードを終了します。

ステップ 12

exit

 

Router(config)# exit

Router#

グローバル コンフィギュレーション モードを終了します。

ケーブル インターフェイス上での PPPoE のイネーブル化

LAC として機能する Cisco CMTS ルータの特定のケーブル インターフェイス上で PPPoE をイネーブルにするには、次のコマンドを使用して、ユーザ EXEC モードを開始します。

ステップの概略

1. enable

2. configure terminal

3. interface cable x/y

4. pppoe enable

5. hold-queue n in

6. hold-queue n out

7. exit

8. exit

ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface cable x/y

 

Router(config)# interface cable 4/0

Router(config-if)#

特定のケーブル インターフェイスに対して、ケーブル インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

pppoe enable

 

Router(config-if)# pppoe enable

Router(config-if)#

インターフェイス上で PPPoE をイネーブルにし、そのインターフェイスを使用して PPPoE セッションを確立できるようにします(VPDN をイネーブルにするまで pppoe enable コマンドは使用できません。VPDN をイネーブルにするには、「Cisco CMTS での VPDN のイネーブル化」の手順に従って vpdn enable コマンドを使用します)。


) 特定のケーブル インターフェイス上で PPPoE をイネーブルにすると、すべてのサブインターフェイス上でも PPPoE が自動的にイネーブルになります。


ステップ 5

hold-queue n in

 

Router(config-if)# hold-queue 1000 in

Router(config-if)#

(任意)PPPoE セッション中に入力キューに保管できるデータ パケットの最大数を指定します。有効範囲は 0 ~ 65,535 パケットで、デフォルトは 75 です。


) 同時に多数の PPPoE セッションをサポートするには、入力キューの値を 1000 以上に設定してパケットが廃棄されないようにします。


ステップ 6

hold-queue n out

 

Router(config-if)# hold-queue 1000 out

Router(config-if)#

(任意)PPPoE セッション中に出力キューに保管できるデータ パケットの最大数を指定します。有効範囲は 0 ~ 65,535 パケットで、デフォルトは 40 です。


) 同時に多数の PPPoE セッションをサポートするには、出力キューの値を 1000 以上に設定してパケットが廃棄されないようにします。



) PPPoE セッションをサポートする各ケーブル インターフェイスに対してステップ 3ステップ 6を繰り返します。


ステップ 7

exit

 

Router(config-if)# exit

Router(config)#

インターフェイス コンフィギュレーション モードを終了します。

ステップ 8

exit

 

Router(config)# exit

Router#

グローバル コンフィギュレーション モードを終了します。

LNS としての Cisco ルータの設定

Cisco 6400 などの Cisco ルータをイネーブルにし、LNS として動作するように設定して、LAC として動作する Cisco CMTS ルータが開始した L2TP トンネルを終端できるようにするには、次のコマンドを使用してユーザ EXEC モードを開始します。


) LNS のルータ上でこの作業を行う前に、「Cisco CMTS での VPDN のイネーブル化」の手順に従って VPDN をイネーブルにする必要があります。さらに、「Cisco CMTS での仮想テンプレートの設定」の手順を使用して、仮想インターフェイスのテンプレートの作成と設定を行う必要があります。


ステップの概略

1. enable

2. configure terminal

3. vpdn-group number

4. accept-dialin

5. protocol l2tp

6. virtual-template number

7. exit

8. terminate-from hostname hostname

9. no l2tp tunnel authentication

10. exit

11. virtual-template number pre-clone number

12. exit

ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

vpdn-group number

 

Router(config)# vpdn-group 1

Router(config-vpdn)#

VPDN グループ番号を選択して、VPDN グループ コンフィギュレーション モードを開始します。

ステップ 4

accept-dialin

 

Router(config-vpdn)# accept-dialin

Router(config-config-vpdn-acc-in)#

ダイヤルイン通話を受け付けるようにルータを設定して、VPDN アクセプト ダイヤルイン コンフィギュレーション モードを開始します。

ステップ 5

protocol l2tp

 

Router(config-vpdn-acc-in)# protocol pppoe

Router(config-vpdn-acc-in)#

PPPoE サーバにアクセスできるように、L2TP プロトコルの VPDN グループを作成します。

ステップ 6

virtual-template number

 

Router(config-vpdn-acc-in)# virtual-template 1

Router(config-vpdn-acc-in)#

PPPoE セッションを設定する際に使用する仮想インターフェイスのテンプレートの数を指定します。


「Cisco CMTS での仮想テンプレートの設定」の手順を使用して作成された仮想インターフェイスのテンプレートの数を指定します。


ステップ 7

exit

 

Router(config-vpdn-acc-in)# exit

Router(config-vpdn)#

VPDN アクセプト ダイヤルイン コンフィギュレーション モードを終了します。

ステップ 8

terminate-from hostname hostname

 

Router(config-vpdn)# terminate-from hostname ciscocmts-router

Router(config-vpdn)#

指定したホスト名からの L2TP トンネルを終端するように、このグループを設定します。 hostname は PPPoE の終端用に設定された Cisco CMTS のホスト名にする必要があります。

ステップ 9

no l2tp tunnel authentication

 

Router(config-vpdn)# no l2tp tunnel authentication

Router(config-vpdn)#

L2TP トンネルの確立に使用する認証をディセーブルにします(ただし、個々のユーザ セッションの認証が継続します)。

ステップ 10

exit

 

Router(config-vpdn)# exit

Router(config)#

VPDN グループ コンフィギュレーション モードを終了します。

ステップ 11

virtual-template number pre-clone number

 

Router(config)# virtual-template 1 pre-clone 2000

Router(config)#

(任意)指定した数の仮想インターフェイスを事前に作成します。これにより、多数のセッションが同時にオンラインになった場合に、個々のセッションの起動を高速化し、ルータのプロセッサへの負荷を軽減できます。

number = 事前に作成する仮想インターフェイスの数。この値はルータがサポートする PPPoE セッションの見込総数と一致する必要があります。


) 仮想サブインターフェイスを使用する場合は、この設定は推奨しません。


ステップ 12

exit

 

Router(config)# exit

Router#

グローバル コンフィギュレーション モードを終了します。

PPPoE セッションのクリア

特定の MAC アドレスの PPPoE セッションをすべてクリアするには、 clear cable host コマンドを使用します。

Router# clear cable host mac-address
Router#
 

特定のホストの PPPoE セッションをクリアする例を示します。

Router# show interface c3/0 modem 0
 
SID Priv bits Type State IP address method MAC address
1 00 modem offline 3.18.1.5 dhcp 0030.80bc.2303
1 00 host offline pppoe 0010.2937.b254
 
Router# clear cable host 0010.2937.b254
 
Router# show interface c3/0 modem 0
 
SID Priv bits Type State IP address method MAC address
1 00 modem offline 3.18.1.5 dhcp 0030.80bc.2303
 
Router#

アクティブ PPPoE セッションに対する SNMP トラップのイネーブル化

Cisco IOS Release 12.2(8)BC1 以降のリリースで、アクティブ PPPoE セッションの数がしきい値の値を超えた場合に通知を受けるには、次の手順を使用して SNMP トラップをイネーブルにします。


) PPPoE セッションの VPDN グループを設定する際に pppoe limit max-sessions コマンドの
threshold-sessions
オプションを使用してしきい値の値を設定します。PPPoE トラップの詳細については、CISCO-PPPOE-MIB を参照してください。


ステップの概略

1. enable

2. configure terminal

3. snmp-server enable traps pppoe

4. exit


) SNMP トラップをイネーブルにするには、SNMP セッションをサポートするようにルータを設定して、SNMP トラップを受信する SNMP マネージャを最低 1 つ指定する必要があります。


ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

snmp-server enable traps pppoe

 

Router(config)# snmp-server enable traps pppoe

Router(config)#

SNMP トラップをイネーブルにします。SNMP トラップは、アクティブなセッション数がユーザ指定のしきい値を超えた場合に送信されます。

ステップ 4

exit

 

Router(config)# exit

Router#

グローバル コンフィギュレーション モードを終了します。

Cable Monitor and Intercept機能のモニタ

PPPoE を使用する Cisco CMTS に登録されているユーザを表示するには、 show interface cable modem コマンドを使用します。

Router# show interface cable 3/0 modem 0
 
SID Priv bits Type State IP address method MAC address
1 00 host unknown pppoe 00e0.f7a4.5171
1 00 modem up 10.100.2.35 dhcp 0050.7302.3d81
2 00 modem up 10.100.2.34 dhcp 0050.7302.3d85
 
Router#
 

PPPoE クライアントが使用している仮想テンプレートのインターフェイス番号を表示するには、 show vpdn session コマンドを使用します。

Router# show vpdn session
 
L2TP Tunnel and Session Information Total tunnels 1 sessions 1
 
LocID RemID Remote Name State Remote Address Port Sessions
34854 14116 R7732-07-ISP1 est 135.1.1.1 1701 1
 
LocID RemID TunID Intf Username State Last Chg Fastswitch
2 56 34854 Vi1 ppp1@isp1.com est 00:02:11 enabled
 
%No active L2F tunnels
%No active PPTP tunnels
PPPoE Tunnel and Session Information Total tunnels 1 sessions 1
 
PPPoE Tunnel Information
Session count: 1
PPPoE Session Information
SID RemMAC LocMAC Intf VASt OIntf VLAN/
VP/VC
1 0050.da80.c13e 0005.00e0.8c8b Vi1 UP Ca8/0/1
 
Router#
 

現在の VPDN ドメインを表示するには、 show vpdn domain コマンドを使用します。

Router# show vpdn domain
 
Tunnel VPDN Group
------ ----------
domain:isp1.com 2 (L2TP)
 
Router#
 

PPPoE の終端の設定例

ここでは、Cable Monitor and Intercept機能の設定例を紹介します。

「Cisco CMTS での PPPoE の終端(L2TP トンネリングなし)」

「Cisco CMTS での PPPoE の終端(L2TP トンネリングあり)」

「Cisco ルータ上での PPPoE クライアントの設定」

「LNS 用の PPPoE の設定」

Cisco CMTS での PPPoE の終端(L2TP トンネリングなし)

Cisco CMTS を設定して PPPoE を終端する例を示します。ケーブル モデム ユーザからのトラフィックが IP パケットとしてルータの WAN インターフェイスに送出され、基本的なインターネット アクセスが許可されています。

version 12.2
!
hostname ubr-pppoe
!
ip cef
no ip domain-lookup
ip domain-name client.com
vpdn enable
no vpdn logging
!
! VPDN group 1 configures the router to accept PPPoE connections and specifies the
! virtual template to be used to configure the virtual interfaces that are created
! for each PPPoE session.
!
vpdn-group 1
accept-dialin
protocol pppoe
virtual-template 1
pppoe limit per-mac 100
!
! Increase size of small buffers to account for keepalive packets for PPPoE sessions
buffers small permanent 1024
buffers small max-free 1024
buffers small initial 1024
!
interface Ethernet1/0
ip address 10.100.0.1 255.255.255.0
ip route-cache flow
half-duplex
!
! “pppoe enable” command must be configured on each cable interface that is to accept
! PPPoE sessions, but you do not need to configure this command on subinterfaces
interface Cable6/0
no ip address
no keepalive
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream frequency 589250000
no cable upstream 0 shutdown
cable upstream 1 frequency 35008000
cable upstream 1 power-level 0
no cable upstream 1 shutdown
no cable upstream 2 shutdown
pppoe enable
!
interface Cable6/0.1
ip address 10.1.1.1 255.255.255.0 secondary
ip address 10.10.1.1 255.255.255.0
cable helper-address 10.100.0.100
no cable proxy-arp
cable dhcp-giaddr policy
!
interface Cable6/0.2
ip address 10.1.2.1 255.255.255.0 secondary
ip address 10.10.2.1 255.255.255.0
cable dhcp-giaddr policy
cable helper-address 10.100.0.100
!
interface Cable6/0.3
ip address 10.1.3.1 255.255.255.0
cable source-verify
cable dhcp-giaddr policy
cable helper-address 10.100.0.100
!
! Virtual Template 1 configures the virtual interfaces that will be used
! for PPPoE sessions
interface Virtual-Template1
ip unnumbered Ethernet1/0
ip mtu 1492
ip pim sparse-mode
peer default ip address pool default
ppp authentication chap
no logging event link-status
no cdp enable
!

Cisco CMTS での PPPoE の終端(L2TP トンネリングあり)

Cisco CMTS を設定して PPPoE を終端する例を示します。ケーブル モデム ユーザから受信したトラフィックが、L2TP ネットワーク サーバとして動作するルータに向けて L2TP トンネルに送信されます。

version 12.2
!
hostname ubr-pppoe-l2tp
!
! User name/password sent to LNS to create the L2TP tunnel.
username cmts-user password 0 cmts-password
! User name/password used by LNS to authenticate tunnel creation
username lns-user password 0 lns-password
! User name/password for a PPPoE user - typically this information
! is configured on the RADIUS authentication servers.
username pppoe-user@client.com password 0 user-password
ip cef
no ip domain-lookup
ip domain-name client.com
vpdn enable
no vpdn logging
!
! VPDN group 1 configures the router to accept PPPoE connections and specifies the
! virtual template to be used to configure the virtual interfaces that are created
! for each PPPoE session.
!
vpdn-group 1
accept-dialin
protocol pppoe
virtual-template 1
pppoe limit per-mac 100
!
! VPDN group 2 configures the group to be used for the L2TP tunnel to the
! LNS (at the IP address of 10.10.15.2) which will be used for PPPoE
! sessions from clients using the domain name as "client.com".
vpdn-group 2
request-dialin
protocol l2tp
domain client.com
initiate-to ip 10.10.15.2
local name ubr-pppoe-l2tp
no l2tp tunnel authentication
!
! Increase size of small buffers to account for keepalive packets for PPPoE sessions
buffers small permanent 1024
buffers small max-free 1024
buffers small initial 1024
!
interface Ethernet1/0
ip address 10.100.0.1 255.255.255.0
ip route-cache flow
half-duplex
!
! “pppoe enable” command must be configured on each cable interface that is to accept
! PPPoE sessions, but you do not need to configure this command on subinterfaces
interface Cable6/0
no ip address
no keepalive
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream frequency 589250000
no cable upstream 0 shutdown
cable upstream 1 frequency 35008000
cable upstream 1 power-level 0
no cable upstream 1 shutdown
no cable upstream 2 shutdown
pppoe enable
!
interface Cable6/0.1
ip address 10.1.1.1 255.255.255.0 secondary
ip address 10.10.1.1 255.255.255.0
cable helper-address 10.100.0.100
no cable proxy-arp
cable dhcp-giaddr policy
!
interface Cable6/0.2
ip address 10.1.2.1 255.255.255.0 secondary
ip address 10.10.2.1 255.255.255.0
cable dhcp-giaddr policy
cable helper-address 10.100.0.100
!
interface Cable6/0.3
ip address 10.1.3.1 255.255.255.0
cable source-verify
cable dhcp-giaddr policy
cable helper-address 10.100.0.100
!
! Virtual Template 1 configures the virtual interfaces that will be used
! for PPPoE sessions
interface Virtual-Template1
ip unnumbered Ethernet1/0
ip mtu 1492
ip pim sparse-mode
peer default ip address pool default
ppp authentication chap
no logging event link-status
no cdp enable

Cisco ルータ上での PPPoE クライアントの設定

PPPoE をサポートする Cisco ルータを、PPPoE クライアントとして動作するように設定する例を示します。このルータはケーブル モデムに接続されており、PPPoE を終端する Cisco CMTS と PPPoE の認証を行います。


) この設定は Cisco 1600 ルータ用で、他のタイプのルータを使用する場合はそのインターフェイスに合わせて調整する必要があります。


!
vpdn enable
no vpdn logging
!
vpdn-group 1
request-dialin
protocol pppoe
!
!
interface Ethernet0
no ip address
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
ppp chap hostname joeuser@client.com
ppp chap password 7 12139CA0C041104
!
ip nat inside source list 1 interface Dialer1 overload
 
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 1 permit any

LNS 用の PPPoE の設定

LNS として動作するように設定された Cisco ルータの例を示します。このルータは Cisco CMTS からの L2TP トンネルを終端し、PPPoE セッションからのトラフィックを企業のネットワークに転送します。

!
hostname lns-router
!
! User name/password for the LNS itself
username lns-user password 0 lns-password
! User name/password for the Cisco CMTS
username cmts-user password 0 cmts-password
! Username and password for the PPPoE client - typically this information is
! configured on the RADIUS authentication servers
username pppoe-user@client.com password 0 user-password
!
ip subnet-zero
ip cef
ip domain-name client.com
!
vpdn enable
no vpdn logging
!
vpdn-group 1
accept-dialin
protocol l2tp
virtual-template 1
terminate-from hostname ubr-pppoe-l2tp
no l2tp tunnel authentication
!
! Allows the LNS to preconfigure virtual templates
! for the PPPoE sessions, allowing the sessions to come up faster
virtual-template 1 pre-clone 2000
!
interface loopback 0
ip address 9.10.7.1 255.255.255.0
!
!
interface Virtual-Template1
ip unnumbered loopback 0
ip mroute-cache
ip mtu 1492
peer default ip address pool pool-1 pool-2
!
ip local pool pool-1 9.10.7.3 9.10.7.254
ip local pool pool-2 9.10.8.1 9.10.8.254
 

参考資料

Cisco CMTS 上でのCable Monitor and Intercept設定の詳細については、次の資料を参照してください。

関連資料

関連項目
資料名

PPPoE の設定

次の URL で『 Cisco IOS Wide-Area Networking Configuration Guide 』Release 12.2 の「Configuring Broadband Access: PPP and Routed Bridge Encapsulation」を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fwan_c/wcfppp.htm

PPPoE のアクティブ セッションに対する SNMP トラップのイネーブル化

次の URL で『 PPPoE Session-Count MIB 』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t8/ftpscmib.htm

VPN の設定

次の URL で『 Cisco IOS Dial Service Configuration Guide: Network Services 』Release 12.1 の「Configuring Virtual Private Networks」を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/dialns_c/index.htm

CMTS コマンド リファレンス

次の URL で『 Cisco Broadband Cable Command Reference Guide 』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/cable/bbccmref/index.htm

Cisco IOS Release 12.2 コマンド リファレンス

次の URL で『 Cisco IOS Release 12.2 Configuration Guides and Command References 』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/index.htm

標準規格

標準規格 2
タイトル

SP-RFIv1.1-I08-020301

Data-Over-Cable Service Interface Specifications Radio Frequency Interface Specification, version 1.1( http://www.cablemodem.com

2.サポートしている標準規格をすべて記載しているわけではありません。

MIB

MIB 3
MIB リンク

CISCO-PPPOE-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

3.サポートしている MIB(管理情報ベース)をすべて記載しているわけではありません。

RFC

RFC 4
タイトル

RFC 1483

Multiprotocol Encapsulation over ATM Adaptation Layer 5

RFC 2516

A Method for Transmitting PPP Over Ethernet(PPPoE)

RFC 2865

Remote Authentication Dial In User Service(RADIUS)

RFC 2866

RADIUS Accounting

4.サポートしている Request for Comments(RFC)をすべて記載しているわけではありません。

テクニカル サポート

説明
リンク

TAC ホームページは、3 万ページの技術コンテンツが検索可能で、製品、技術、ソリューション、技術ヒント、ツールへのリンクが含まれています。Cisco.com 登録ユーザは、このページからログインしてさらに豊富なコンテンツにアクセスできます。

http://www.cisco.com/public/support/tac/home.shtml