Cisco uBR7200 ユニバーサル ブロードバンド ルータ ソフトウェア コンフィギュレーション ガイド 12.3BC 12.2BC 12.2CX 12.1EC
コンフィギュレーション ファイル例の 表示
コンフィギュレーション ファイル例の表示
発行日;2012/01/10 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

コンフィギュレーション ファイル例の表示

基本的なインターネット アクセスの例

一般例

BPI の例

EuroDOCSIS 動作の例

VPN の例

GRE トンネルの例

IP テレフォニーの例

一般例

クロック サポートの例

Telco リターンの例

コンフィギュレーション ファイル例の表示

この付録では、Cisco uBR7200 シリーズ ユニバーサル ブロードバンド ルータのコンフィギュレーション ファイル例を紹介します。Cisco uBR7200 シリーズ ルータの現在のコンフィギュレーションを表示するには、EXEC モードまたは特権 EXEC モードで、CLI プロンプトに show running-config コマンドを入力します。

基本的なインターネット アクセスの例

一般例

ここでは、Cisco uBR7246に対応する Cisco Release12.0(5)T のコンフィギュレーション ファイル例を、16 QAM のスペクトル管理および変調プロファイルの設定を含めて紹介します。

version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname uBR7246
!
boot system flash slot0:ubr7200-p-mz.120-5.T
boot system flash
!
cable spectrum-group 1 frequency 40000000
cable spectrum-group 1 frequency 20000000 2
cable modulation-profile 3 request 0 16 1 8 16qam scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 3 initial 5 34 0 48 16qam scrambler 152 no-diff 256 fixed uw16
cable modulation-profile 3 station 5 34 0 48 16qam scrambler 152 no-diff 256 fixed uw16
cable modulation-profile 3 short 5 75 6 8 16qam scrambler 152 no-diff 144 fixed uw8
cable modulation-profile 3 long 8 220 0 8 16qam scrambler 152 no-diff 160 fixed uw8
no cable qos permission create
no cable qos permission update
cable qos permission modems
ip subnet-zero
ip dhcp relay information option
!
interface FastEthernet0/0
ip address 10.1.70.2 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
!
!
interface Ethernet2/3
ip address 1.3.59.1 255.255.0.0
no ip directed-broadcast
!
interface Cable5/0
ip address 172.1.71.1 255.255.255.0 secondary
ip address 10.1.71.1 255.255.252.0
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
no keepalive
no cable proxy-arp
 
cable helper-address 10.1.70.30
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable upstream 0 spectrum-group 1
cable upstream 0 modulation-profile 3
cable downstream frequency 531000000
cable upstream 0 frequency 28000000
cable upstream 0 power-level 0
no cable upstream 0 shutdown
cable upstream 1 shutdown
cable upstream 2 shutdown
cable upstream 3 shutdown
cable upstream 4 shutdown
cable upstream 5 shutdown
!
!
router eigrp 100
network 10.0.0.0
!
ip classless
no ip http server
!
!
!
line con 0
password cisco
login
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end
 

コンフィギュレーション ファイル例の中の cable spectrum-group という文字列で始まるコマンドラインには、コンフィギュレーション全体に対してスペクトル管理を設定するために不可欠な要素が含まれています。

cable spectrum-group 1 frequency 40000000
cable spectrum-group 1 frequency 20000000 2
 

この例では、スペクトル管理グループ番号 [1] をアップストリーム チャネルで使用可能なように設定してあります。上の 2 行のコマンドラインで定義されているように、アップストリーム用に「優先される」選択は、40 MHz チャネルでの動作です。使用可能な伝送スキームにそのチャネルが適していない場合、アップストリームは自動的に 20 MHz での伝送に移行し、受信パワー率を 2 dB 上げます。

コンフィギュレーション ファイル例の中の cable modulation-profile という文字列で始まるコマンドラインには、コンフィギュレーション全体に対して変調プロファイルを設定するために不可欠な要素が含まれています。

cable modulation-profile 3 request 0 16 1 8 16qam scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 3 initial 5 34 0 48 16qam scrambler 152 no-diff 256 fixed uw16
cable modulation-profile 3 station 5 34 0 48 16qam scrambler 152 no-diff 256 fixed uw16
cable modulation-profile 3 short 5 75 6 8 16qam scrambler 152 no-diff 144 fixed uw8
cable modulation-profile 3 long 8 220 0 8 16qam scrambler 152 no-diff 160 fixed uw8
 

この例では、変調プロファイル番号 [3] を(適用されるように設定済みの場合)アップストリーム チャネルで使用可能なように設定してあります。なお、この変調プロファイルは、16 QAM 変調スキームで動作するように設定済みです。デフォルトの変調スキームは、どのアップストリーム プロファイルの場合も(16 QAM に設定されていない場合)、QPSK です。

コンフィギュレーション ファイル例の後ろの方では、スロット 5 に搭載されているCable Modem(CM; ケーブル モデム)カード上の upstream 0 ポートが、例で設定されているスペクトル管理と変調プロファイルの両方を利用しています。

cable upstream 0 spectrum-group 1
cable upstream 0 modulation-profile 3
 

ここでは、Cisco Release 12.0(8)SC のコンフィギュレーション ファイル例を使用して、Cisco IOS Release 12.0(5)T イメージとほぼ同じ機能を紹介します。

version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname newtown01-7246
!
boot system flash slot0:ubr7200-k1ps-mz.120-8.SC.bin
boot system flash slot0:
boot config slot0:C7246
boot bootldr slot0:ubr7200-boot-mz.120-8.SC.bin
enable secret 5 <removed>
enable password 7 <removed>
!
cable flap-list size 4000
cable flap-list power-adjust threshold 3
cable flap-list aging 86400
cable spectrum-group 1 hop threshold 15
cable spectrum-group 1 frequency 26000000
cable spectrum-group 1 frequency 24000000 1
cable spectrum-group 1 frequency 22000000 2
no cable qos permission create
no cable qos permission update
cable qos permission modems
!
!
!
!
clock timezone GMT 0
ip subnet-zero
no ip source-route
no ip finger
ip telnet source-interface FastEthernet0/0
!
!
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.0 secondary
ip address 209.187.212.2 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
full-duplex
no cdp enable
!
interface Cable3/0
description Sunnyvale, CA
ip address 209.187.213.1 255.255.255.0 secondary
ip address 10.8.0.1 255.255.0.0
no ip directed-broadcast
no ip mroute-cache
no keepalive
cable spectrum-group 1
cable dhcp-giaddr policy
cable helper-address 209.187.212.12
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream frequency 687000000
cable upstream 0 description Sunnyvale 1-5
cable upstream 0 power-level 0
no cable upstream 0 shutdown
cable upstream 1 description Sunnyvale 6-10
cable upstream 1 power-level 0
no cable upstream 1 shutdown
cable upstream 2 description Sunnyvale 1-6
cable upstream 2 power-level 0
no cable upstream 2 shutdown
cable upstream 3 description Sunnyvale 7-11
cable upstream 3 power-level 0
no cable upstream 3 shutdown
cable upstream 4 description Sunnyvale 12-17
cable upstream 4 power-level 0
no cable upstream 4 shutdown
cable upstream 5 description Sunnyvale 18-23
cable upstream 5 power-level 0
no cable upstream 5 shutdown
!
interface Cable4/0
description Santa Clara, CA
ip address 207.252.148.1 255.255.255.0 secondary
ip address 10.9.0.1 255.255.0.0
no ip directed-broadcast
no ip mroute-cache
no keepalive
cable spectrum-group 1
cable dhcp-giaddr policy
cable helper-address 209.187.212.12
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream frequency 687000000
cable upstream 0 description Santa Clara 1-8
cable upstream 0 power-level 0
cable upstream 0 shutdown
cable upstream 1 description Santa Clara 1-7
cable upstream 1 power-level 0
no cable upstream 1 shutdown
cable upstream 2 description Santa Clara 8-13
cable upstream 2 power-level 0
no cable upstream 2 shutdown
cable upstream 3 description Santa Clara14-19
cable upstream 3 power-level 0
no cable upstream 3 shutdown
able upstream 4 description Santa Clara 20-26
cable upstream 4 power-level 0
no cable upstream 4 shutdown
cable upstream 5 description Santa Clara 27-33
cable upstream 5 power-level 0
no cable upstream 5 shutdown
!
interface Cable5/0
description San Jose, CA
ip address 207.252.149.1 255.255.255.0 secondary
ip address 10.10.0.1 255.255.0.0
no ip directed-broadcast
no ip mroute-cache
no keepalive
cable spectrum-group 1
cable dhcp-giaddr policy
cable helper-address 209.187.212.12
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream frequency 687000000
cable upstream 0 description Willow Glen 1-8
cable upstream 0 power-level 0
no cable upstream 0 shutdown
cable upstream 1 description Willow Glen 9-16
cable upstream 1 power-level 0
no cable upstream 1 shutdown
cable upstream 2 description Willow Glen 17-24
cable upstream 2 power-level 0
no cable upstream 2 shutdown
cable upstream 3 description Willow Glen 25-32
cable upstream 3 power-level 0
no cable upstream 3 shutdown
cable upstream 4 description Evergreen 1-8
cable upstream 4 power-level 0
no cable upstream 4 shutdown
able upstream 5 description Evergreen 9-17
cable upstream 5 power-level 0
no cable upstream 5 shutdown
!
interface Cable6/0
description Morgan Hill, CA
ip address 209.187.214.1 255.255.255.0 secondary
ip address 10.11.0.1 255.255.0.0
no ip directed-broadcast
no ip mroute-cache
no keepalive
cable spectrum-group 1
cable dhcp-giaddr policy
cable helper-address 209.187.212.12
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream frequency 687000000
cable upstream 0 description Santa Theresa 1-5
cable upstream 0 power-level 0
cable upstream 0 shutdown
cable upstream 1 description Santa Theresa 6-10
cable upstream 1 power-level 0
cable upstream 1 shutdown
cable upstream 2 description Santa Theresa 11-14
cable upstream 2 power-level 0
cable upstream 2 shutdown
cable upstream 3 description Santa Theresa 1-5
cable upstream 3 power-level 0
no cable upstream 3 shutdown
cable upstream 4 description Santa Theresa 6-11
cable upstream 4 power-level 0
no cable upstream 4 shutdown
cable upstream 5 description Santa Theresa 12-17
cable upstream 5 power-level 0
no cable upstream 5 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 209.187.212.1
ip route 0.0.0.0 0.0.0.0 Null0 255
!
> no cdp run
> snmp-server engineID local 0000000902000030190E0900
snmp-server community <removed> RO
snmp-server location San Jose, CA
snmp-server contact Jim Smith
snmp-server chassis-id 01
!
banner login ^C Warning! Unauthorized use of this system is prohibited. =
You will be prosecuted to the fullest extent of =
the law.^C
alias exec qos show cable qos profile
alias exec scm show cable modem
alias exec noise show cable modem detail
!
line con 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
password 7 <removed>
login
!
ntp clock-period 17179915
ntp update-calendar
ntp max-associations 2000
ntp server 129.7.1.66 source FastEthernet0/0 prefer
end

BPI の例

Cisco uBR7200 シリーズは、56 ビットおよび 40 ビットの暗号化/復号化をサポートしています。デフォルトは 56 ビットです。Cisco uBR7200 シリーズの場合、Baseline Privacy Interface(BPI; ベースライン プライバシー インターフェイス)をサポートする CMTS イメージを選択すると、BPI がデフォルトでイネーブルになります。Cisco uBR7200 シリーズのコンフィギュレーション ファイルで使用され、暗号化/復号化のサポートを示す主要なコマンドは、次のとおりです。

int cable 2/0
cable privacy kek grace-time 800
cable privacy kek life-time 750000
cable privacy tek grace-time 800
cable privacy tek life-time 56000
cable privacy enable
cable privacy mandatory

) CM でも、暗号化/復号化をサポートしなければなりません。


ベースライン プライバシーがイネーブルの場合、Cisco uBR7200 シリーズはホストまたはピアから別のホストまたはピアへ、暗号化/復号化パケットをルーティングします。BPI は、Key Encryption Key(KEK; 鍵暗号化鍵)および Traffic Encryption Key(TEK; トラフィック暗号化鍵)を指定して設定します。KEK は CM の SID(サービス ID)に基づいて CM に割り当てられ、ベースライン プライバシーがアクティブなときに、その CM は Cisco uBR7200 シリーズ ルータに接続することが許可されます。TEK は対応する KEK が設定されているときに、CM に割り当てられます。TEK は、CM と Cisco uBR7200 シリーズ ルータ間でデータ トラフィックを暗号化する目的で使用します。

KEK および TEK は、猶予期間または有効期間の値に基づいて満了するように設定できます。猶予期間鍵は、ネットワークにアクセスする CM に、一時的な鍵を割り当てる場合に使用します。有効期間鍵は、より持続性のある鍵を CM に割り当てる場合に使用します。有効期間鍵が割り当てられている各 CM は、現在の鍵の有効期限が切れる前に、新しい有効期間鍵を Cisco uBR7200 シリーズ ルータに要求します。


ヒント show cable modem コマンドを使用すると、CM で暗号化/復号化がイネーブルかどうかを調べることができます。このコマンドから online(pk) が出力された場合、CM は BPI がイネーブルとして登録されていて、KEK が割り当てられています。このコマンドから online(pt) が出力された場合、CM は BPI がイネーブルとして登録されていて、TEK が割り当てられています。


Cisco uBR7200 シリーズのデフォルトの設定である 56 ビットの暗号化/復号化を 40 ビットに変更する場合は、[40-bit-des] オプションを使用します。

CMTS(config-if)#cable privacy ?
40-bit-des select 40 bit DES
^^^^^^^^^^
authenticate-modem turn on BPI modem authentication
authorize-multicast turn on BPI multicast authorization
kek KEK Key Parms
mandatory force privacy be mandatory
tek TEK Key Parms
 

次にソフトウェアが 40 ビット DES 鍵を生成します。生成されて戻された DES 鍵は、56 ビット鍵の最初の 16 ビットをマスクし、ソフトウェア内で 0 にします。40 ビットに変更したあとで、56 ビットの暗号化/復号化に戻すには、[40-bit-des] オプションの直前に no コマンドを入力します。


注意 BPI をサポートする Cisco uBR7200 シリーズの Telco リターン イメージは、Telco リターン パスでの暗号化/復号化をサポートしません。

EuroDOCSIS 動作の例

Cisco uBR7200 シリーズは、MC16E ケーブル インターフェイス ラインカードを使用する場合、EuroDOCSIS チャネル計画をサポートします。Cisco uBR7200 シリーズのコンフィギュレーション ファイルで使用され、EuroDOCSIS 動作を示す主要なコマンドは、次のとおりです。

cable downstream annex A ― Annex A は、EuroDOCSIS 動作専用です(DOCSIS NTSC 動作には Annex B を使用)。MC16E を使用している場合は、デフォルトで Annex A が選択されます。

cable upstream 0 frequency <5008000> ― EuroDOCSIS のアップストリーム有効範囲は 5,000,000 ~ 65,000,000 Hz です。ここで値を選択できます。


) 次の Cisco IOS リリースが、MC16E ケーブル インターフェイス ラインカードを使用して EuroDOCSIS 動作をサポートします。12.0(7)T、12.0(7)XR2、12.1 Mainline、12.1(1a)T1 以上、12.0(8)SC、12.0(9)SC 以上などの SC 系統イメージ。



ヒント ダウンストリーム変調およびインターリーブの深度を設定する他のケーブル インターフェイス ラインカードと異なり、MC16E の場合、ダウンストリーム インターリーブ深度は決まっていて、変更できません。MC16E はさらに、拡張スペクトル管理をサポートしません。


EuroDOCSIS コンフィギュレーション ファイルの例を示します。

!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R7732-06-uBR7246-CE
!
!
cable modulation-profile 1 request 0 16 1 8 16qam scrambler 152
no-diff 128 fixed uw16
cable modulation-profile 1 initial 5 34 0 48 16qam scrambler 152
no-diff 256 fixed uw16
cable modulation-profile 1 station 5 34 0 48 16qam scrambler 152
no-diff 256 fixed uw16
cable modulation-profile 1 short 6 75 6 8 16qam scrambler 152 no-diff
144 fixeduw8
cable modulation-profile 1 long 8 220 0 8 16qam scrambler 152 no-diff
160 fixeduw8
cable modulation-profile 2 request 0 16 1 8 qpsk scrambler 152 no-diff
64 fixeduw8
cable modulation-profile 2 initial 5 34 0 48 qpsk scrambler 152
no-diff 128 fixed uw16
cable modulation-profile 2 station 5 34 0 48 qpsk scrambler 152
no-diff 128 fixed uw16
cable modulation-profile 2 short 5 75 6 8 qpsk scrambler 152 no-diff
72 fixed uw8
cable modulation-profile 2 long 8 220 0 8 qpsk scrambler 152 no-diff
80 fixed uw8
!
no cable qos permission create
no cable qos permission update
cable qos permission modems
!
!
!
!
ip subnet-zero
ip host abrick 223.255.254.254
!
!
!
interface Loopback0
ip address 222.2.4.1 255.255.255.255
no ip directed-broadcast
!
interface Loopback2
ip address 111.0.4.2 255.255.255.255
no ip directed-broadcast
!
interface FastEthernet0/0
ip address 1.8.93.9 255.255.0.0
no ip directed-broadcast
!
interface Cable3/0
ip address 3.214.1.1 255.255.255.0
no ip directed-broadcast
load-interval 30
no keepalive
cable spectrum-group 1
cable helper-address 1.8.93.100
cable downstream annex A
cable downstream modulation 64qam
cable downstream frequency 669000000
cable upstream 0 frequency 5008000
cable upstream 0 power-level 0
no cable upstream 0 shutdown
cable upstream 1 frequency 10000000
cable upstream 1 power-level 0
no cable upstream 1 shutdown
cable upstream 2 frequency 15008000
cable upstream 2 power-level 0
no cable upstream 2 shutdown
cable upstream 3 frequency 20000000
cable upstream 3 power-level 0
no cable upstream 3 shutdown
cable upstream 4 frequency 55008000
cable upstream 4 power-level 0
no cable upstream 4 shutdown
cable upstream 5 frequency 60000000
cable upstream 5 power-level 0
no cable upstream 5 shutdown
!
ip default-gateway 1.8.0.1
ip classless
ip route 223.255.254.254 255.255.255.255 1.8.0.1
!
snmp-server engineID local 00000009020000D0BA1EED00
snmp-server community public RO
snmp-server community private RW
!
alias exec scm show cable modem
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
password lab
login
!
end

VPN の例

Virtual Private Network(VPN; バーチャル プライベート ネットワーク)機能により、MSO および ISP は、在宅勤務者、またはその他のビジネス型ユーザに私設網接続を提供できます。次のコンフィギュレーション例では、次の 2 つの終端点の間に VPN を設定しています。

一方はリモートの CM 上

他方は会社のファイアウォールの VPN ゲートウェイ上


ヒント 暗号化/復号化トラフィックを正しく送受信するには、VPN 内の各ピアが暗号化/復号化をアクティブにし、一致するアクセス キー ストリングを使用する必要があります。



) Cisco uBR7200 シリーズを使用すると、ケーブル ネットワーク(およびインターネット)に暗号化トラフィックを流すことができます。コンフィギュレーション ファイル内のルーティング テーブル セットアップに基づいて、1 つのピアから別のピアへ伝送されます。


GRE トンネルの例

次の例では、Cisco uBR7200 シリーズを使用して、2 つの支店ネットワークそれぞれを、GRE トンネルによって本社に接続しています。


) 各支店ネットワークは、ケーブル インターフェイスで Cisco uBR7200 シリーズに接続します。カスタマーごとに、物理ケーブル インターフェイス上で別々のサブインターフェイスが割り当てられています。


ケーブル インターフェイス番号 3 は、2 つのサブインターフェイスを指定して設定されています。各サブインターフェイスは、カスタマーの Small Office Home Office(SOHO)CM に接続します。

!
interface Cable3/0
no ip address
no ip directed broadcasr
no keepalive
ip route-cache policy
!(To configure policy based route-cache on subinterfaces. This command not available on subinterfaces.)
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable upstream 0 power-level 0
no cable upstream 0 shutdown
!(While configuring the physical interface IP address and IP helper address parameters must not be entered.)
interface c3/0.1
ip address 172.100.1.1 255.255.255.0
cable helper address 11.0.0.2
ip policy route-map customer1
no ip directed-broadcast
no cable proxy-arp
no cable ip-multicast-echo
 
interface c3/0.2
ip address 174.100.1.1 255.255.255.0
ip helper address 11.0.0.2
ip policy route-map customer2
no ip directed-broadcast
no cable proxy-arp
no cable ip-multicast-echo
 
interface serial 0
ip address 151.145.1.1 255.255.255.0
interface tunnel 0
ip address 172.100.3.1 255.255.255.252
tunnel source s0
tunnel destination 151.145.2.1
 
interface tunnel 1
ip address 174.100.3.1 255.255.252
tunnel source s0
tunnel destination 151.145.3.1
 
! configure route maps to forward traffic coming over c3/0.1 and c3/0.2 to go over the tunnel 0 and
! tunnel 1 respectively.
route-map customer1 permit 10
match ip address 101
set ip next-hop 11.1.1.1
route-map customer1 permit 20
match ip address 102
set ip next-hop 172.100.3.2
route-map customer2 permit 10
match ip address 101
set ip next-hop 11.1.1.1
!(traffic to go over the interface that connects to DHCP/DNS/TFTP Server)
route-map customer2 permit 20
match ip address 102
set ip next-hop 174.100.3.2
access-list 101 permit ip any 11.1.1.0 0.0.0.255
!(matches traffic destined for DHCP/DNS/TFTP server)
access-list 102 permit ip any any
!(any other traffic that is not meant for DHCP/DNS/TFTP server)
ip route 151.145.0.0 255.255.0.0 s0 <- static route to connect to IP Cloud.
 

) set ip default next-hop a.b.c.d を設定すると、アクセス リストを 2 つ設定しなくてすみます。set ip default next-hop a.b.c.d を使用すると、すべての IP トラフィックと route-map コマンドを一致させることができます。これは、キャッシュベースの高速スイッチングではなく、CEF およびプロセス スイッチングで有効です。パケットは最初、ルーティング テーブルを使用して通常通りにルーティングされます。ルートがなかった場合は、トンネルの反対側終端の IP アドレスである a.b.c.d に転送されます。


ルータ #1 のコンフィギュレーション

interface ethernet0
ip address 172.100.2.1 255.255.255.0
 
interface serial 0
ip address 151.145.2.1 255.255.255.0
 
interface tunnel 0
ip address 172.100.3.2 255.255.255.252
tunnel source s0
tunnel destination 151.145.1.1
 
ip route 151.145.0.0 255.255.0.0 s0
!(static route to connect to IP Cloud)
 

ルータ #2 のコンフィギュレーション

interface ethernet0
ip address 174.100.2.1 255.255.255.0
interface serial 0
ip address 151.145.3.1 255.255.255.0
interface tunnel 0
ip address 174.100.3.2 255.255.255.252
tunnel source s0
tunnel destination 151.145.1.1
ip route 151.145.0.0 255.255.0.0 s0
!(static route to connect to IP Cloud)
exec-timeout 0 0
login
transport input none
line aux 0
line vty 0 4
password lab
login
!
scheduler allocate 988 200
end

IP テレフォニーの例

一般例

IP テレフォニーをサポートするには、Voice over IP(VoIP)通信をサポートする CM が加入者サイトになければなりません。


注意 一部の国では、インターネット経由の音声テレフォニーのプロビジョニングまたはこれらの製品の使用が禁止されていたり、通信機器の使用に関する法規制など、特定の法規制に準拠することが義務付けられていたりします。これらの製品を使用する場合には、適用される各国の法律に従う必要があります。

次に、Cisco uBR7246用の VoIP コンフィギュレーション例を示します。

!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname twoslot
!
enable password ****
!
!
ip subnet-zero
no ip domain-lookup
ip host abrick 223.255.254.254
ip host muck 255.255.255.255
ip host keyer 223.255.254.254
ip host bell 223.255.254.253
!
!
!
interface FastEthernet0/0
ip address 2.2.2.2 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
shutdown
!
interface Ethernet1/0
ip address 1.11.8.1 255.255.0.0
ip broadcast-address 1.11.255.255
ip helper-address 223.255.254.254
no ip directed-broadcast
no ip mroute-cache
!
interface Ethernet1/1
ip address 10.20.122.2 255.255.255.192
ip helper-address 10.0.0.2
no ip directed-broadcast
!
interface Ethernet1/2
no ip address
no ip directed-broadcast
shutdown
!
interface Ethernet1/3
no ip address
no ip directed-broadcast
shutdown
!
interface Cable2/0
ip address 20.20.20.20 255.255.255.0
no ip directed-broadcast
no keepalive
cable downstream modulation 64qam
cable upstream 0 frequency 10000000
cable upstream 0 power-level 0
no cable upstream 0 shutdown
cable upstream 1 frequency 10000000
cable upstream 1 power-level 0
no cable upstream 1 shutdown
cable upstream 2 shutdown
cable upstream 3 shutdown
cable upstream 4 shutdown
cable upstream 5 shutdown
!
ip default-gateway 1.11.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.20.122.1
ip route 223.255.254.254 255.255.255.255 1.11.0.1
ip http server
!
!
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
login
line vty 5 11
login
!
end

クロック サポートの例

クロック サポートにより、Cisco uBR7246 VXR ルータは、外部タイミング リファレンスに同期し、Cisco MC16S および MC16E ケーブル インターフェイス ラインカードにクロックを配信できます。その後、同期した DOCSIS タイム スタンプがダウンストリームのすべての CM に与えられます。


) クロック サポートは、同期タイミングが音声品質の維持に不可欠な、VoIP のケーブル ネットワーク用です。クロック機能がサポートされるのは、クロック カードが搭載されていて、Cisco IOS Release 12.1(1a)T1 以上を使用している Cisco uBR7246 VXR シャーシに限られます。CM が VoIP およびクロック モードをサポートしていることも必要です。



ヒント クロック カードは Cisco uBR7246 VXR に搭載後、設定しなくても使用できます。クロック カードは搭載されると、ミッドプレーンの TDM クロック リファレンス ソースになります。


Cisco uBR7246 VXR のコンフィギュレーション ファイルで使用され、クロック サポートを示す主要なコマンドは、次のとおりです。

cable clock source-midplane
no cable clock force primary
no cable clock force secondary

Telco リターンの例

Telco リターンをサポートする Cisco IOS Release CMTS ソフトウェア イメージは、ファイル名に [t] が含まれています。Telco リターンをサポートするには、DOCSIS 準拠 Telco リターン CM を加入者サイトに設置し、Telco リターン パスをサポートする必要があります。

CM で次の設定が必要かどうかを調べます。

ダイヤル オンデマンド機能 ― Cisco uBR7200 シリーズのコンフィギュレーション ファイルに cable telco-return spd number dial-timer seconds コマンドを組み込みます。このコマンドは、ダイヤル タイマー情報を TCD メッセージに組み込みます。TCD メッセージは、定期的にリモートの CM に送信され、最終的には非アクティブなアップストリーム接続を CM が切断します。

同じダウンストリーム チャネルを通して、Telco リターンと双方向 CM の両方に対応する CNR の設定。


) ベンダーによっては、双方向データ システム上で稼働している CM と同じダウンストリーム チャネル上ではトラフィックを受信できない Telco リターンの CM もあります。このような場合、複数のダウンストリーム チャネルを使用できるように、ケーブル プラントを分割してください。


Telco リターン ネットワークには、次の要素を設定する必要があります。

Authentication, Authorization, Accounting(AAA; 認証、許可、アカウンティング)の設定、および特定の RADIUS ダイヤル サーバ情報

Telco リターンに固有の設定

SNMP サーバに固有の設定

次に、Telco リターンをサポートする Cisco uBR7200 シリーズ コンフィギュレーション ファイルの例を示します。

!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname uBR7246
!
boot system flash slot0:ubr7200-p-mz.**********
boot system flash
logging buffered 100000 debugging
aaa new-model
aaa authentication login default radius enable
aaa authentication login vty line
aaa accounting update newinfo
aaa accounting exec default start-stop radius
aaa accounting commands 15 default start-stop radius
aaa accounting network default start-stop radius
aaa accounting system default start-stop radius
enable secret guess_my_password_ha_ha_ha.
!
no cable qos permission create
no cable qos permission update
cable qos permission modems
ip subnet-zero
no ip finger
no ip domain-lookup
!
!
!
interface Loopback0
ip address 24.1.2.246 255.255.255.0
no ip directed-broadcast
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
shutdown
media-type MII
full-duplex
!
interface Hssi1/0
ip unnumbered Loopback0
no ip directed-broadcast
!
interface Cable3/0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
cable helper-address 24.1.1.84
no keepalive
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream frequency 687000000
cable upstream 0 frequency 13008000
no cable upstream 0 shutdown
cable upstream 1 shutdown
cable upstream 2 shutdown
cable upstream 3 shutdown
cable upstream 4 shutdown
cable upstream 5 shutdown
!
interface Cable6/0
ip address 172.16.1.1 secondary
ip address 10.1.1.1
no ip directed-broadcast
cable helper-address 24.1.1.84
no keepalive
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream frequency 687000000
cable upstream 0 frequency 13008000
no cable upstream 0 shutdown
cable telco-return enable
cable telco-return spd 1 factory-default
cable telco-return spd 1 dhcp-authenticate
cable telco-return spd 1 dhcp-server 24.1.1.84
cable telco-return spd 1 ppp-authenticate chap
cable telco-return spd 1 phonenum 918005555555
cable telco-return spd 1 phonenum 18005555555
cable telco-return spd 1 username test
cable telco-return spd 1 password test
!
router ospf 100
network 10.0.0.0 0.255.255.255 area 0
network 24.1.0.0 0.0.255.255 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 24.1.2.21
!
logging 24.1.1.78
snmp-server community public RO
snmp-server community favorite_server_community RW
snmp-server location favorite_location
!
radius-server host 24.1.1.78 auth-port 1645 acct-port 1646
radius-server key radius_server_key
!
line con 0
password No need to change; this is encrypted already.
transport input none
flowcontrol software
line aux 0
password No need to change; this is encrypted already.
flowcontrol hardware
line vty 0 4
password No need to change; this is encrypted already.
login authentication vty
!
end
 

コンフィギュレーション ファイル例の中の aaa という文字列で始まるコマンドラインには、AAA セットアップに関する重要な要素が含まれています。

aaa new-model
aaa authentication login default radius enable
aaa authentication login vty line
aaa accounting update newinfo
aaa accounting exec default start-stop radius
aaa accounting commands 15 default start-stop radius
aaa accounting network default start-stop radius
aaa accounting system default start-stop radius
 

コンフィギュレーション ファイル例の中の cable telco-return という文字列で始まるコマンドラインには、Telco リターン ネットワークの最小設定に不可欠な要素が含まれています。

cable telco-return enable
cable telco-return spd 1 factory-default
cable telco-return spd 1 dhcp-authenticate
cable telco-return spd 1 dhcp-server 24.1.1.84
cable telco-return spd 1 ppp-authenticate chap
cable telco-return spd 1 phonenum 918005555555
cable telco-return spd 1 phonenum 18005555555
cable telco-return spd 1 username test
cable telco-return spd 1 password test
 

最初に、enable キーワードで Telco リターン機能をアクティブにします。次に、DHCP 認証をアクティブにし、DHCP サーバの場所を識別し、ダイヤルイン アクセス用に 3 つまでの電話番号を入力し、アップストリーム伝送用に PPP 認証のタイプを指定し、ダイヤルアップ ネットワークへのログインを許可するためのユーザ名とパスワードを指定します。


) PPP は、リモートの CM とダイヤルアップ アクセス サーバとの間に提供される唯一のアップストリーム通信媒体です。ただし、Challenge Handshake Authentication Protocol(CHAP)、Password Authentication Protocol(PAP)、または両方の認証方式をアップストリーム データ伝送用に設定できます。


コンフィギュレーション ファイル例の中の snmp-server という文字列で始まるコマンドラインには、SNMP サーバの最小設定に不可欠な要素が含まれています。

logging 24.1.1.78
snmp-server community public RO
snmp-server community favorite_server_community RW
snmp-server location favorite_location
 

コンフィギュレーション ファイル例の中の radius-server という文字列で始まるコマンドラインには、RADIUS ダイヤル サーバの最小設定に不可欠な要素が含まれています。

radius-server host 24.1.1.78 auth-port 1645 acct-port 1646
radius-server key radius_server_key
 

) AAA、Telco リターン、SNMP サーバ、および RADIUS ダイヤル サーバ ソフトウェア機能の詳細は、WWW(http://www.cisco.comhttp://www.cisco.com/jphttp://www-china.cisco.com、または
http://www-europe.cisco.com)にアクセスして、Cisco IOS ソフトウェア コンフィギュレーション マニュアルを参照してください。