Cisco uBR10012 ユニバーサル ブロードバンド ルータ ソフトウェア コンフィギュレーション ガイド Cisco IOS Software - 12.3 BC 12.2 BC 12.2 CY
Cisco uBR10012 ルータ のケーブル インターフェイス機能の設定
Cisco uBR10012 ルータのケーブル インターフェイス機能の設定
発行日;2012/01/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

Cisco uBR10012 ルータのケーブル インターフェイス機能の設定

インターフェイスの管理上のシャットダウンと再起動

ダウンストリーム ケーブル インターフェイスの設定

ダウンストリーム ケーブル ARP 要求のアクティブ化

ARP 要求の確認

ダウンストリーム ポートのアクティブ化

ダウンストリーム ポートの確認

ダウンストリーム チャネル ID の割り当て

ダウンストリーム チャネル ID の確認

ダウンストリーム ヘルパー アドレスの設定

ダウンストリーム ヘルパー アドレスの確認

ダウンストリーム インターリーブ深度の設定

ダウンストリーム インターリーブ深度の確認

ダウンストリーム変調方式の設定

ダウンストリーム変調方式の確認

ダウンストリーム MPEG フレーミング フォーマットの設定

ダウンストリーム MPEG フレーミング フォーマットの確認

ダウンストリーム レート制限およびトラフィック シェーピングの設定

ダウンストリーム トラフィック シェーピングの確認

アップストリーム ケーブル インターフェイスの設定

アップストリーム アドミッション制御のアクティブ化

アップストリーム アドミッション制御の確認

アップストリーム ディファレンシャル エンコーディングのアクティブ化

アップストリーム ディファレンシャル エンコーディングの確認

アップストリーム FEC のアクティブ化

アップストリーム FEC の確認

アップストリーム ポートのアクティブ化

アップストリーム ポートの確認

アップストリーム電力調整のアクティブ化

アップストリーム電力調整の確認

アップストリーム スクランブラのアクティブ化

アップストリーム スクランブラの確認

アップストリーム タイミング調整のアクティブ化

アップストリーム タイミング調整の確認

アップストリーム バックオフ値の設定

アップストリーム データ バックオフの確認

アップストリーム チャネル幅の設定

アップストリーム チャネル幅の確認

アップストリーム周波数の設定

アップストリーム周波数の確認

アップストリーム入力パワーレベルの設定

アップストリーム入力パワーレベルの確認

アップストリーム ミニスロット サイズの指定

アップストリーム ミニスロット サイズの確認

アップストリーム レート制限およびトラフィック シェーピングの設定

ダウンストリーム トラフィック シェーピングの確認

トラブルシューティング用のヒント

オプションのケーブル インターフェイス機能の設定

ホスト間通信(プロキシ ARP)のアクティブ化

ケーブルプロキシ ARP 要求のアクティブ化

パケットインターセプト機能のアクティブ化

ペイロード ヘッダーの抑制および復元の設定

オプションのブロードキャストおよびケーブル IP マルチキャスト エコーの設定

IP マルチキャスト エコーの設定

IP マルチキャストエコーの確認

アクセス リストおよび cable ip-multicast echo コマンド

IP ブロードキャスト エコーの設定

IP ブロードキャストエコーの確認

ケーブル インターフェイスの設定例

Cisco uBR10012 ルータのケーブル インターフェイス機能の設定

Cisco uBR10012 ルータのケーブル インターフェイスは、ダウンストリーム信号およびアップストリーム信号をサポートするケーブル TV Radio Frequency(RF; 高周波)インターフェイスとして動作します。ダウンストリ-ムは、外部アップコンバータでの使用に適した Intermediate-Frequency(IF;中間周波数)信号としての出力です。ケーブル プラントで、どのCisco uBR10000 series ケーブル インターフェイス、ネットワーク アップリンク ライン カード、および他のコンポーネントを使用すべきかは、予定および既存の加入者ベース、提供サービス、外部ネットワーク接続に基づいて決定する必要があります。

シャーシには、最大 8 つの Cisco ラインカード(ケーブル インターフェイス ライン カードとLine Card Processor[LCP] の組み合わせ)を搭載できます。

ケーブル インターフェイス ライン カードは、ダウンストリームとアップストリームの様々なポートをサポートしています。概要は、「Cisco vBR10012 ルータでサポートされるハードウェア」を参照してください。

Hybrid Fiber-Coaxial(HFC)ケーブルネットワークで適切な運用ができるようにシスコ ケーブル インターフェイス ライン カードを設定するには、Cisco IOS ソフトウェアの Command-Line Interface(CLI; コマンドライン インターフェイス)を使用します。この章では、Cisco ケーブル インターフェイスの設定作業について説明します。

 

セクション
目的

「インターフェイスの管理上のシャットダウンと再起動」

シャットダウンが必要なインターフェイス設定とともに使用するインターフェイス シャットダウンと再起動について説明します。

「ダウンストリーム ケーブル インターフェイスの設定」

必須のアップストリーム設定作業の手順について説明します。

「アップストリーム ケーブル インターフェイスの設定」

オプションのケーブル インターフェイス設定手順について説明します。

「オプションのケーブル インターフェイス機能の設定」

オプションのケーブル インターフェイス設定手順について説明します。

「ケーブル インターフェイスの設定例」

この章で前述した手順のケーブル インターフェイス 設定例を示します。

Cisco uBR10000 シリーズ Cable Modem Termination System(CMTS; ケーブル モデム ターミネーション システム)に関連したその他のインターフェイスおよびルータの設定については、『 Cisco Cable Modem Termination System Feature Guide
http://www.cisco.com/univercd/cc/td/doc/product/cable/cab_rout/cmtsfg/ )を参照してください。

インターフェイスの管理上のシャットダウンと再起動

インターフェイスは、シャットダウンすることによりディセーブルにできます。インターフェイスのシャットダウンにより、指定されたインターフェイスでのすべての機能がディセーブルになり、そのインターフェイスは、すべてのモニタリング コマンドの表示で使用不可能としてマーク付けされます。この情報は、すべてのダイナミック ルーティング プロトコルを通して、他のネットワーク サーバに伝えられます。そのインターフェイスは、ルーティング アップデートから外されます。シリアル インターフェイスでは、インターフェイスのシャットダウンにより、Dedicated Token Ring(DTR; 専用トークン リング)信号が廃棄されます。トークン リング インターフェイスでは、インターフェイスのシャットダウンにより、インターフェイスがリングから外されます。Fiber Distributed Data Interface(FDDI; ファイバ分散データ インターフェイス)では、インターフェイスのシャットダウンにより、光バイパス スイッチ(ある場合)がバイパス モードになります。

インターフェイスをシャットダウンしてから再起動するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

shutdown

インターフェイスをシャットダウンします。

no shutdown

ディセーブルにされたインターフェイスをイネーブルにします。

インターフェイスがディセーブルかどうかをチェックするには、特権 EXEC モードで show interfaces コマンドを使用します。シャットダウンされたインターフェイスは、show interfaces コマンド表示で管理上のダウンとして表示されます。

インターフェイスをシャットダウンする理由の 1 つとして、電気インターフェイスのタイプまたはポート オンラインのモードを変更する場合が挙げられます。たとえば、シリアル アダプタ ケーブルを交換し、ソフトウェア コマンドを使用してインターフェイスを再起動し、必要に応じて、新しいインターフェイスにポートを再設定します。

システムの起動または再起動時に、Fast Serial Interface Processor(FSIP; ファスト シリアル インターフェイス プロセッサ)がインターフェイスをポーリングし、各ポートの電気インターフェイスのタイプを決定します(接続しているポート アダプタ ケーブルのタイプによる)。ただし、アダプタ ケーブルをオンラインで変更する場合、再びインターフェイスをポーリングする必要はありません。

システムで新しいインターフェイス タイプを認識させるには、shutdown コマンドを使用してインターフェイスをシャットダウンし、ケーブルの変更後にインターフェイスをイネーブルにします。詳細については、ハードウェアのマニュアルを参照してください。

次の例では、ポート 4 のスロット 2 で、イーサネット インターフェイスをオフにします。

interface ethernet 2/4
shutdown
 

次の例では、インターフェイスを再起動します。

interface ethernet 2/4
no shutdown

ダウンストリーム ケーブル インターフェイスの設定

以下の設定は必須です。シスコ ケーブル インターフェイス設定時の第一段階の手順は、ダウンストリーム ケーブル インターフェイスを設定することです。ダウンストリーム ケーブル インターフェイス設定は、次の手順で構成されます。

 

作業
説明

「ダウンストリーム ケーブル ARP 要求のアクティブ化」

ケーブル インターフェイス上で ARP 要求をアクティブにすることによって、Cisco uBR10000 シリーズ CMTSがダウンストリーム パス上で IP アドレス解決を実行できるようにする手順について説明します。

「ダウンストリーム ポートのアクティブ化」

HFC ネットワーク経由でのデジタル データ伝送用に、ケーブル インターフェイス カード上のダウンストリーム ポートをアクティブにして確認する手順について説明します。

「ダウンストリーム チャネル ID の割り当て」

シスコ ケーブル インターフェイス ライン カード上のダウンストリーム ポートに数値チャネル ID を割り当て、確認する手順について説明します。

「ダウンストリーム ヘルパー アドレスの設定」

UDP ブロードキャスト パケットの送信先となる DHCP サーバの IP アドレスを指定する手順について説明します。

「ダウンストリーム インターリーブ深度の設定」

シスコ ケーブル インターフェイス ライン カード上のダウンストリーム ポートに対してダウンストリーム インターリーブ深度(ミリ秒単位)を設定する手順について説明します。

「ダウンストリーム変調方式の設定」

ダウンストリーム方向で加入者の CM にデータを送信するときの速度(シンボル/秒)を定義する手順について説明します。

「ダウンストリーム MPEG フレーミング フォーマットの設定」

ダウンストリーム方向の MPEG フレーミング フォーマットを設定して確認する手順について説明します。このフォーマットは、DOCSIS 仕様に準拠し、ローカル ケーブル プラントの運用に適合している必要があります。

「ダウンストリーム レート制限およびトラフィック シェーピングの設定」

トラフィック シェーピング オプションを指定したトークンバケット ポリシング アルゴリズムまたは重み付き廃棄アルゴリズムを使用して、設定帯域幅を超過したパケットをバッファリング、シェーピング、または廃棄する手順について説明します。


) 通常、これらの設定作業に使用するコマンドは、デフォルト値によってCisco uBR10012 ルータを適切に設定することができます。デフォルト値を変更する場合を除き、各パラメータを指定する必要はありません。


その他の設定オプションについては、『 Cisco Broadband Cable Command Reference Guide 』( http://www.cisco.com/univercd/cc/td/doc/product/cable/bbccmref/ )および Documentation CD-ROM を参照してください。

ダウンストリーム ケーブル ARP 要求のアクティブ化

この設定は必須です。Address Resolution Protocol(ARP)は、ネットワークに組み込まれているコンピュータまたは他の機器上の MAC アドレスに IP アドレスをマッピングする場合に使用する、インターネット プロトコルです。ケーブル インターフェイス上で ARP 要求をアクティブにすることによって、Cisco uBR10000 シリーズ CMTSがダウンストリーム パス上で IP アドレス解決を実行できるようにする必要があります。


) この設定手順で使用するコマンドは、通常、デフォルト値でCisco uBR10000 シリーズ CMTSを最適に設定できます。


ARP 要求をアクティブにするには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的
Router(config-if)# cable arp

ARP をイネーブルにします。これがデフォルトの設定です。

ARP 要求の確認

ケーブル ARP がアクティブに設定されているかどうかを確認するには、 more system: running-configコマンドを入力し、ケーブル インターフェイスの設定情報を調べます。ARP がアクティブの場合、出力には表示されません。ARP がアクティブではない場合は、次のように、出力に [no cable arp] が表示されます。

Router# more system:running-config
Building configuration...
 
Current configuration:
!
interface cable5/0/0
ip address 1.1.1.1 255.255.255.0
no keepalive
no cable arp
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream symbol-rate 5056941
cable upstream 0 frequency 15008000
no cable upstream 0 shutdown
 

ヒント 確認できない場合には、ARP をアクティブにしたとき、および show interface cable コマンドの入力時に、正しいポートおよびケーブル インターフェイス ライン カード スロット番号を入力しているかどうかを確認してください。


ダウンストリーム ポートのアクティブ化

HFC ネットワーク上でデジタル データ伝送を行うために、Cisco uBR7200 シリーズ ケーブル インターフェイス カードのダウンストリーム ポートをアクティブにするには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router> enable
Password: password
Router#

イネーブル(特権 EXEC)モードを開始します。

パスワードを入力します。

特権 EXEC モードになると、プロンプトに(#)記号が表示されます。

ステップ 2

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#

グローバル コンフィギュレーション モードを開始します。グローバル コンフィギュレーション モードになると、プロンプトに (config)# が表示されます。

このコマンドの省略形は、config tまたは conf t です。

ステップ 3

Router(config)# interface cable5/0/0
Router(config-if)#

ケーブル インターフェイス コンフィギュレーション モードを開始します。

この例では、Cisco uBR10000 シリーズ CMTSのスロット 1 に搭載されたケーブル インターフェイス カードのダウンストリーム ポート 0 のインターフェイスを指定しています。

ステップ 4

Router(config-if)# cable downstream if-output



Router(config-if)# no cable downstream if-output

デフォルトです。Cisco uBR10012 ルータからのダウンストリーム デジタル データをアクティブにします。

ダウンストリーム デジタル データを非アクティブにします。このコマンドは、ケーブル インターフェイス カードの IF 出力を表示せず、インターフェイスをシャットダウンします。

ステップ 5

Router(config-if)# no shutdown

ダウンストリーム ポートを [admin up] ステートにします。

ステップ 6

Router(config-if)# end
Router#

%SYS-5-CONFIG_I:Configured from console by console

特権 EXEC モードに戻ります。

このメッセージは正常であり、エラーを意味するものではありません。

ダウンストリーム ポートの確認

ダウンストリーム キャリアがアクティブ(アップ)に設定されているかを確認するには、 show controllers cable コマンドを使用し、設定したダウンストリーム ポートを指定します。次に、National Television Standards Committee(NTSC; 全米テレビ放送規格委員会)6 MHz 動作の例を示します。

Router# show controllers cable5/0/0 downstream
Cable5/0/0 Downstream is up
Frequency=96000000, Channel Width 6 MHz, 64-QAM, Symbol Rate 5.056941 Msps
FEC ITU-T J.83 Annex B, R/S Interleave I=32, J=4
 

ダウンストリーム チャネル ID の割り当て

シスコ ケーブル インターフェイス ライン カード上のダウンストリーム ポートに数字でチャネル ID を割り当てるには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドを使用します。有効値は、0 ~ 255 です。

Router(config-if)# cable downstream channel-id id
 

) cable downstream channel-id コマンドは、次のコマンドと共に使用します。
cable downstream frequency 54000000-1000000000 broadcast frequency - h


これらのコマンドは、同じケーブル インターフェイス ラインカード上のアップストリーム ポートだけに接続できる CM が設置された 1 つの領域に対し、複数のダウンストリーム周波数を送信する場合に使用します。CM が受信する各ダウンストリームについて、固有のチャネル ID を設定する必要があります。ダウンストリーム周波数の設定値は、アップコンバータ上の設定値と一致していなければなりません。


注意 固有のダウンストリーム ID を設定したら、CM が正しく動作するかをテストします。この機能を使用する場合には、CM コードの各ソフトウェアリリースについて再テストを実施し、正しく動作するかを確認し、新しいインストレーションのために十分な時間を確保することを推奨します。これらのコマンドの併用や CM テストの実施を行わなかった場合は、長期にわたりカスタマーサービスが停止することがあります。

ダウンストリーム チャネル ID の確認

ダウンストリーム チャネル ID を確認するには、設定したダウンストリーム ポートに対して、 show controllers cable コマンドを入力します。次に例を示します。

Router# show controllers cable5/0/0 downstream
Cable5/0/0 Downstream is up
Frequency=96000000, Channel Width 6 MHz, 64-QAM, Symbol Rate 5.056941 Msps
FEC ITU-T J.83 Annex B, R/S Interleave I=32, J=4
Downstream channel ID: 1
 

ダウンストリーム ヘルパー アドレスの設定

User Datagram Protocol(UDP)ブロードキャスト パケットの送信先となる Dynamic Host Configuration Protocol(DHCP)サーバの IP アドレスを指定します。ケーブル インターフェイスからの UDP ブロードキャスト パケットに対応する DHCP サーバ、およびホストからの UDP ブロードキャスト パケットに対応する DHCP サーバを指定できます。ダウンストリーム ヘルパー アドレスを設定するには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config-if)# cable helper-address 10 .x.x.x cable-modem

ケーブル モデムからの UDP ブロードキャスト パケットに対応するダウンストリーム ヘルパー アドレスを、IP アドレス 10. x.x.x の DHCP サーバに設定します。


) DHCP サーバの IP アドレスを使用します。10.x.x.xおよび 172.56.x.xは、どちらもプライベート範囲です。


ステップ 2

Router(config-if)# cable helper-address 172.56 .x.x host

ダウンストリームのヘルパーアドレスに、ホストからの UDP ブロードキャスト パケットの送信先 DHCP サーバの IP アドレス 172.56. x.x を設定します。

ダウンストリーム ヘルパー アドレスの確認

ダウンストリーム ヘルパー アドレスの設定を確認するには、 show running-configコマンドを入力し、ケーブル インターフェイスの設定情報で cable helper-address を調べます。

Router# show running-config
Building configuration...
 
Current configuration:
!
interface cable5/0/0
ip address 10.254.254.254 255.0.0.0
no ip directed-broadcast
cable helper-address 192.168.1.1
no keepalive
 

確認できない場合には、次の作業を行ってください。


ステップ 1 ケーブル インターフェイスがダウンストリーム信号を検出していない場合には、ケーブル、アップコンバータ、RF レベル、および周波数を確認します。

ステップ 2 ケーブル インターフェイスがダウンストリーム信号を検出し、アップストリーム信号を検出していない場合には、ケーブル、RF レベル、およびアップストリーム周波数を確認し、no shut コマンドを入力します。

ステップ 3 次の要領でプロビジョニング サーバを確認します。

送信元 IP アドレスオプション(ケーブル インターフェイスのプライマリ IP アドレス)を使用して DHCP サーバに対して ping を実行します。

ケーブル インターフェイスに RF アップストリーム/ダウンストリーム ロックがかかっていても持続しない場合は、IP ルーティングを確認します。

ステップ 4 次の要領で DHCP オプションと Time-of-Day(ToD)サーバの IP アドレスを確認します。

送信元 IP アドレスオプションを使用して ToD サーバに対して ping を実行します。

IP ルーティングを確認します。

TFTP ファイル名が正しいかどうかを確認します。

TFTP ファイルが TFTP サーバの正しいディレクトリにあるかどうかを確認します。

TFTP ファイルに読み取り権限が設定されているかどうかを確認します。

送信元 IP アドレスオプションを使用して TFTP サーバに ping を実行します。さらに、ケーブル インターフェイスに RF と DHCP が適用されていても、ToD または TFTP で障害が発生する場合は IP ルーティングを確認します。


 

ダウンストリーム インターリーブ深度の設定

シスコ ケーブル インターフェイス ラインカード上のダウンストリーム ポートに、インターリーブ深度を設定します。インターリーブ深度を大きくするほど、HFC ネットワーク上のノイズ バーストに対する保護力が高まりますが、ダウンストリーム遅延も大きくなります。


) 有効値は、8、16、32(デフォルト)、64、および 128 です。


ダウンストリーム インターリーブ深度をミリ秒単位で指定するには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

Router(config-if)# cable downstream interleave-depth {8|16|32 |64|128}
 

ダウンストリーム インターリーブ深度の確認

ダウンストリーム インターリーブ深度の設定を確認するには、設定したダウンストリーム ポートに対して、 show controllers cable コマンドを入力します。

Router# show controllers cable5/0/0 downstream
Cable5/0/0 Downstream is up
Frequency=96000000, Channel Width 6 MHz, 64-QAM, Symbol Rate 5.056941 Msps
FEC ITU-T J.83 Annex B, R/S Interleave I=32, J=
 

確認できない場合には、次の作業を行ってください。


ステップ 1 ケーブル接続がゆるんでいたり、切断されていないかどうかを確認します。

ステップ 2 ケーブル インターフェイス ライン カードがシャーシスロットに確実に装着されているかどうかを確認します。

ステップ 3 非脱落型ネジが締まっているかどうかを確認します。

ステップ 4 正しいスロット番号およびポート番号を入力しているかどうかを確認します。

ステップ 5 cable downstream if-outputコマンドを使用して、ダウンストリーム キャリアがアクティブになっているかどうかを確認します。


 

ダウンストリーム変調方式の設定

ダウンストリーム変調方式を設定するには、ダウンストリーム方向で加入者の CM にデータを送信するときの速度(シンボル/秒)を指定します。シンボルは変調の基本単位です。Quadrature Phase Shift Key(QPSK;4 位相偏移変調)は 1 シンボルにつき 2 ビットを符号化します。Quadrature Amplitude Modulation(QAM;直交振幅変調)16 は 1 シンボルにつき 4 ビット、QAM 64 は 1 シンボルにつき 6 ビット、QAM 256 は 1 シンボルにつき 8 ビットを符号化します。


) ダウンストリーム変調レートを QAM 256 に設定する場合は、加入者のケーブル インターフェイスで、QAM 64 よりも約 6 dB 高い Signal-to-Noise Ratio(SNR; 信号対雑音比)を設定する必要があります。QAM 256 では信頼性がなくなる可能性のあるネットワークには、QAM 64 を適用してください。また、データの重要性を考慮してください。


ダウンストリーム変調方式を設定するには、ケーブル インターフェイス コンフィギュレーション モードで、次の作業を行います。DOCSIS の標準変調レート(およびシスコシステムズのデフォルト設定)は、QAM 64 です。

Router(config-if)# cable downstream modulation 64qam
 

ダウンストリーム変調方式の確認

ダウンストリーム変調の設定を確認するには、設定したダウンストリーム ポートに対して、 show controllers cable コマンドを入力します。次に例を示します。

Router# show controllers cable5/0/0 downstream
Cable5/0/0 Downstream is up
Frequency=96000000, Channel Width 6 MHz, 64-QAM, Symbol Rate 5.056941 Msps
FEC ITU-T J.83 Annex B, R/S Interleave I=32, J=4
 

確認できない場合には、次の作業を行ってください。


ステップ 1 ケーブル接続がゆるんでいたり、切断されていないかどうかを確認します。

ステップ 2 ケーブル インターフェイス ライン カードがシャーシスロットに確実に装着されているかどうかを確認します。

ステップ 3 非脱落型ネジが締まっているかどうかを確認します。

ステップ 4 正しいスロット番号およびポート番号を入力しているかどうかを確認します。

ステップ 5 cable downstream if-outputコマンドを使用して、ダウンストリーム キャリアがアクティブになっているかどうかを確認します。

ステップ 6 必要な変調方式が不明な場合、デフォルト値が選択されているかどうかを確認します。


 

ダウンストリーム MPEG フレーミング フォーマットの設定

MPEG フレーミング フォーマットは、DOCSIS 仕様( http://www.cablemodem.com/specifications.html を参照)に準拠し、ローカル ケーブル プラントの運用に適合している必要があります。


ヒント Annex B は、北米用の DOCSIS MPEG フレーミング フォーマット規格です。



) シスコ ケーブル インターフェイス ライン カードを設定すると、Annex B フレーミング フォーマットが自動的に設定されます。ケーブル インターフェイス ライン カードのダウンストリーム ポートとネットワーク上の接続先 CM には同じ MPEG フレーミング フォーマットを設定し、適切な DOCSIS 動作をサポートする必要があります。


Cisco uBR10012 ルータのコンフィギュレーション ファイルで Annex B 動作を指定するには、次のコマンドを使用します。このコマンドにより、ダウンストリーム MPEG フレーミング フォーマットを設定します。

Router(config-if)# cable downstream annex {B}
 

ダウンストリーム MPEG フレーミング フォーマットの確認

ダウンストリーム MPEG フレーミング フォーマットの設定を確認するには、設定したダウンストリーム ポートに対して、 show controllers cable コマンドを入力します。次に例を示します。

router# show controllers cable5/0/0 downstream
Cable5/0/0 Downstream is up
Frequency=96000000, Channel Width 6 MHz, 64-QAM, Symbol Rate 5.056941 Msps
FEC ITU-T J.83 Annex B, R/S Interleave I=32, J=4
Downstream channel ID: 0
 

ダウンストリーム レート制限およびトラフィック シェーピングの設定

ダウンストリーム トラフィック シェーピングにより、トラフィック シェーピング オプションを指定したトークンバケット ポリシング アルゴリズムまたは重み付き廃棄アルゴリズムを使用して、設定帯域幅を超過したパケットをバッファリング、シェーピング、または廃棄することができます。ダウンストリーム トラフィック シェーピングは、デフォルトではディセーブルに設定されます。

シスコ ケーブル インターフェイス ライン カード上のダウンストリーム ポートに対して、ダウンストリーム トラフィック シェーピングをイネーブルにするには、ケーブル インターフェイス コンフィギュレーション モードで、次のいずれかのコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config-if)# cable downstream rate-limit token-bucket




Router(config-if)# cable downstream rate-limit token-bucket shaping



Router(config-if)# cable downstream rate-limit token-bucket shaping granularity 8




Router(config-if)# cable downstream rate-limit token-bucket shaping max-delay 256

トークンバケット ポリシング アルゴリズムによるダウンストリーム ポート上でのトラフィック シェーピングをイネーブルにします。このコマンドを使用すると、Cisco uBR10012 ルータは、許容帯域幅を超えるパケットを自動的に廃棄します。

トラフィック シェーピングを指定したトークンバケット ポリシング アルゴリズムを使用して、ダウンストリーム ポート上でのトラフィック シェーピングをイネーブルにします。

特定のトラフィック シェーピング時間単位を指定したトークンバケット ポリシング アルゴリズムを使用して、ダウンストリーム ポート上でのトラフィック シェーピングをイネーブルにします。有効値は 1、2、4、8、または 16 ミリ秒です。

特定の最大トラフィック シェーピング バッファ遅延を指定したトークンバケット ポリシング アルゴリズムを使用して、ダウンストリーム ポート上でのトラフィック シェーピングをイネーブルにします。有効値は 128、256、512、または 1028 ミリ秒です。

ステップ 2

Router(config-if)# cable downstream rate-limit weighted-discard 3

重み付きパケット廃棄アルゴリズムによるダウンストリーム ポート上でのトラフィック シェーピングをイネーブルにして、平均損失率の指数変動を表すウエイトを割り当てます。有効値は、1 ~ 4 です。

ステップ 3

Router(config-if)# ^Z
Router#

EXEC モードに戻り、手順を確認します。

ダウンストリーム トラフィック シェーピングの確認

ダウンストリーム トラフィック シェーピングが設定され、アクティブになっているかどうかを確認するには、 show running-configコマンドを入力し、ケーブル インターフェイスの設定情報を調べます。ダウンストリーム トラフィック シェーピングが設定され、イネーブルになっている場合は、出力にトラフィック シェーピングのエントリが含まれます。ダウンストリーム トラフィック シェーピングがディセーブルの場合、トラフィック シェーピング エントリは表示されません。

Router# show running-config
Building configuration...
Current configuration:
!
interface cable5/0/0
ip address 10.254.254.254 255.0.0.0
no ip directed-broadcast
cable helper-address 192.168.1.1
no keepalive
cable downstream annex B
cable downstream modulation 64qam
 

確認できない場合には、次の作業を行ってください。


ステップ 1 ケーブル接続がゆるんでいたり、切断されていないかどうかを確認します。

ステップ 2 ケーブル インターフェイス ライン カードがシャーシスロットに確実に装着されているかどうかを確認します。

ステップ 3 非脱落型ネジが締まっているかどうかを確認します。

ステップ 4 正しいスロット番号およびポート番号を入力しているかどうかを確認します。

ステップ 5 必要な変調方式が不明な場合、デフォルト値が選択されているかどうかを確認します。

ステップ 6 cable downstream if-outputコマンドを使用して、ダウンストリーム キャリアがアクティブになっていることを確認します。


 

アップストリーム ケーブル インターフェイスの設定

以下の設定は必須です。アップストリーム ケーブル インターフェイス コマンドで、アップストリーム信号の周波数および入力パワーレベル、さらにアップストリーム信号のエラー検知および訂正を設定します。アップストリーム ケーブル インターフェイスの設定は、ケーブルプラントの特性によって異なります。

アップストリーム ケーブル インターフェイスを設定するには、次の作業を行います。


) これらの作業には、デフォルト値によって適切に設定できるものもあります。


作業
説明

「アップストリーム アドミッション制御のアクティブ化」

アップストリーム アドミッション制御機能について説明し、アップストリーム アドミッション制御をアップストリーム チャネル容量のパーセンテージとして設定する手順を示します。

「アップストリーム ディファレンシャル エンコーディングのアクティブ化」

アップストリーム上のディファレンシャル エンコーディングをアクティブにする手順について簡単に説明します。ディファレンシャル エンコーディングはデジタル エンコーディング技法の 1 つで、バイナリ値が特定の信号レベルではなく信号変更によって示されます。

「アップストリーム FEC のアクティブ化」

FEC をアクティブにする手順について説明します。Cisco uBR10000 シリーズ CMTSは、FEC を使用して、破損している可能性のあるアップストリーム データの修復を試みます。

「アップストリーム ポートのアクティブ化」

アップストリーム ポートをアクティブにする手順について説明します。HFC ネットワーク上の CM からCisco uBR10000 シリーズ CMTSにアップストリームのデータ伝送を行うには、各アップストリーム ポートをアクティブに設定する必要があります。

「アップストリーム電力調整のアクティブ化」

アップストリーム電力調整をイネーブルにする手順について説明します。この機能は、レンジングステータスを継続できる最小電力調整を dB 単位で設定します。

「アップストリーム スクランブラのアクティブ化」

アップストリーム RF キャリア上のスクランブラをアクティブにする手順について説明します。このスクランブラにより、HFC ネットワーク上の CM は内蔵スクランブラ回路を使用してアップストリーム データ伝送を行うことができます。

「アップストリーム タイミング調整のアクティブ化」

特定のケーブル インターフェイス上でアップストリーム タイミング調整をアクティブにする手順について説明します。この機能は、レンジングステータスを継続できる最小タイミング調整を設定します。

「アップストリーム バックオフ値の設定」

アップストリーム チャネルでデータまたは要求を送信する CM 間のコンテンション解消を定義する、DOCSIS 準拠の手順について説明します。コンテンション解消は、切り捨て型バイナリ指数バックオフ値を使用して行います。

「アップストリーム チャネル幅の設定」

アップストリーム チャネル幅をヘルツ(Hz)単位で入力する手順について説明します。また、NTSCスペクトル パラメータおよびスペクトル管理プロセスについても説明します。

「アップストリーム周波数の設定」

シスコ ケーブル インターフェイス ライン カードで予想される入力周波数に合わせて、RF 出力のアップストリーム チャネル周波数を設定する手順について説明します。

「アップストリーム入力パワーレベルの設定」

dBmV(デシベル/ミリボルト)でアップストリーム入力パワーレベルを設定する手順について説明します。また、Cisco uBR10000 シリーズ CMTSの CM の出力パワーレベル制御の詳細についても説明します。

「アップストリーム レート制限およびトラフィック シェーピングの設定」

アップストリーム上のトラフィック シェーピングをアクティブにする手順について説明します。DOCSIS アップストリーム チャネルで使用可能なアップストリーム トラフィック シェーピングは、アップストリーム パケットのスケジューリングを遅らせ、これにより、パケットを廃棄するのではなくケーブル CPE デバイス上のバッファに保管します。

「アップストリーム ミニスロット サイズの指定」

特定のアップストリーム ケーブル インターフェイスにミニスロットサイズ(チック単位)を指定する手順について説明します。ミニスロットサイズとチャネル幅はある程度関連しますが、強い結びつきはありません。

アップストリーム アドミッション制御のアクティブ化

アップストリーム アドミッション制御は、アップストリーム インターフェイス上の CM によって予約された保証最小アップストリーム スループットの総量を計算します。合計が許容レベルを超えると、保証された最小アップストリーム レートを必要とする CM は、それ以上アップストリーム ポートでオンラインでいることが許可されません。

Cisco CMTS アドミッション制御はデフォルト設定でオフになっており、アクティブにしなければなりません。アップストリーム アドミッション制御をアップストリーム チャネル容量のパーセンテージとして設定するには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドを使用します。アドミッション制御は、指定されたアップストリーム チャネル容量のパーセンテージとして設定します。指定できる範囲は、10 ~ 1000% です。

Router(config-if)# cable upstream usport admission-control percentage
 

たとえば、次のように入力します。

7246VXR(config-if)# cable upstream 0 admission-control ?
Max Reservation Limit As Percentage of Raw Channel Capacity
 

 
シンタックスの説明

usport

アドミッション制御がイネーブルになっているアップストリーム ポート。

percentage

オプションのpercentageパラメータは、保証可能な帯域幅を決定する際、使用されるオーバーブッキング レートを指定します。


) percentageパラメータを空白のままにするか、または 100% に設定すると、CMTS は、実際に利用可能な帯域幅の合計まで保証できるようにします。パーセンテージを最大値の 1000 に設定すると、実際のインターフェイス帯域幅の最大 10 倍まで「保証される」こともあります。


アップストリーム アドミッション制御の確認

アップストリーム アドミッション制御が設定され、アクティブになっていることを確認するには、特権 EXEC モードでshow running-configコマンドを入力し、ケーブル インターフェイスの設定情報を調べます。アップストリーム アドミッション制御が設定され、イネーブルになっている場合は、show running-configコマンドの出力にアドミッション制御エントリが表示され、ユーザが定義したアップストリーム チャネル許容容量のパーセンテージが示されます。アップストリーム アドミッション制御がディセーブルの場合は、出力にアドミッション制御エントリは含まれません。

確認できない場合には、次の作業を行ってください。


ステップ 1 ケーブル接続がゆるんでいたり、切断されていないかどうかを確認します。

ステップ 2 ケーブル インターフェイス ライン カードがシャーシスロットに確実に装着されているかどうかを確認します。

ステップ 3 非脱落型ネジが締まっているかどうかを確認します。

ステップ 4 正しいスロット番号およびポート番号を入力しているかどうかを確認します。

ステップ 5 ルータに有効な周波数が選択されていることを確認します。


 

アップストリーム ディファレンシャル エンコーディングのアクティブ化

アップストリーム上のディファレンシャル エンコーディングはデジタル エンコーディング技法の 1 つで、バイナリ値が特定の信号レベルではなく信号変更によって示されます。特定のケーブル インターフェイスに対するアップストリーム トラフィックのディファレンシャル エンコーディングをイネーブルにするには、ケーブル インターフェイス コンフィギュレーション モードで、次のコマンドを使用します。アップストリーム ディファレンシャル エンコーディングは、デフォルトではイネーブルに設定されます。

Router(config-if)# cable upstream usport differential-encoding
 

アップストリーム ディファレンシャル エンコーディングの確認

アップストリーム ディファレンシャル エンコーディングがアクティブに設定されているかどうかを確認するには、 show running-configコマンドを入力し、ケーブル インターフェイスの設定情報を調べます。アップストリーム ディファレンシャル エンコーディングがイネーブルの場合は、show running-config の出力にディファレンシャル エンコーディングのエントリが表示されます。アップストリーム ディファレンシャル エンコーディングがディセーブルの場合は、出力にディファレンシャル エンコーディングのエントリは含まれません。

確認できない場合には、次の作業を行ってください。


ステップ 1 ケーブル接続がゆるんでいたり、切断されていないかどうかを確認します。

ステップ 2 ケーブル インターフェイス ライン カードがシャーシスロットに確実に装着されているかどうかを確認します。

ステップ 3 非脱落型ネジが締まっているかどうかを確認します。

ステップ 4 正しいスロット番号およびポート番号を入力しているかどうかを確認します。

ステップ 5 ルータに有効な周波数が選択されていることを確認します。


 

アップストリーム FEC のアクティブ化

Cisco uBR10000 シリーズ CMTSは、Forward Error Correction(FEC; 前進型誤信号訂正)を使用して、破損している可能性のあるアップストリーム データの修復を試みます。FEC がアクティブの場合、ネットワーク上のすべての CM の FEC がアクティブに設定されます。


) アップストリームの FEC は任意設定ですが、アップストリームの FEC もアクティブにすることを推奨します。FEC はデフォルトでアクティブに設定されます。FEC はディセーブルにしないでください。


アップストリームの FEC をアクティブにし、FEC をイネーブルに設定するには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

Router(config-if)# cable upstream usport fec
 

アップストリーム FEC の確認

FEC がアクティブに設定されているかどうかを確認するには、more system:running-configコマンドを入力し、ケーブル インターフェイスの設定情報を調べます。FEC がイネーブルに設定されていると、show running-configコマンドの出力に FEC エントリが表示されます。FEC がディセーブルの場合、出力に FEC エントリは表示されません。

確認できない場合には、次の作業を行ってください。


ステップ 1 ケーブル接続がゆるんでいたり、切断されていないかどうかを確認します。

ステップ 2 ケーブル インターフェイス ライン カードがシャーシスロットに確実に装着されているかどうかを確認します。

ステップ 3 非脱落型ネジが締まっているかどうかを確認します。

ステップ 4 正しいスロット番号およびポート番号を入力しているかどうかを確認します。

ステップ 5 ルータに有効な周波数が選択されていることを確認します。


 

アップストリーム ポートのアクティブ化

HFC ネットワーク上の CM からCisco uBR10000 シリーズ CMTSにアップストリームのデータ伝送を行うには、各アップストリーム ポートをアクティブに設定する必要があります。


) アップストリーム ケーブル インターフェイスは、固定アップストリーム周波数を設定するか、スペクトル グループを作成して設定するまで動作しません。「アップストリーム周波数の設定」 を参照してください。


アップストリーム ポートをアクティブにするには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# interface cable slot/port

ケーブル インターフェイスを指定して、ケーブル インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-if)# no cable upstream usport shutdown

アップストリーム データ トラフィックをイネーブルにします。

アップストリーム ポートの確認

アップストリーム ポートがアクティブかどうかを確認するには、設定したアップストリーム ポートを指定し、 show interface cable コマンドを入力します。

Router# show interface cable5/0/0
Cable5/0/0 is up, line protocol is up
Hardware is BCM3210 FPGA, address is 00e0.1e5f.7a60 (bia 00e0.1e5f.7a60)
Internet address is 1.1.1.3/24
MTU 1500 bytes, BW 27000 Kbit, DLY 1000 usec, rely 255/255, load 1/255
Encapsulation, loopback not set, keepalive not set
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:25, output 00:00:00, output hang never
Last clearing of “show interface” counters never
Queuing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sea, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
10878 packets input, 853740 bytes, 0 no buffer
Received 3679 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
5401 packets output, 645885 bytes, 0 underruns
0 output errors, 0 collisions, 9 interface resets
0 output buffer failures, 0 output buffers swapped out
 

アップストリーム電力調整のアクティブ化

特定のケーブル インターフェイスに対するアップストリーム電力調整をイネーブルにするには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドのいずれかを使用します。

 

コマンド
目的
Router(config-if)# cable upstream usport power-adjust continue db

レンジングステータスを継続できる最小電力調整を dB 単位で設定します。有効値は、2 ~ 15 dB です。デフォルト値は、2 dB です。

Router(config-if)# cable upstream usport power-adjust noise percentage

アップストリーム パワー レートを変更するために必要な最小電力調整パケット数(%)を設定します。有効値は、10 ~ 100% です。デフォルト値は、30% です。

Router(config-if)# cable upstream 0 power-adjust threshold db

電力調整スレッシュホールドを dB 単位で設定します。有効値は、0 ~ 2 dB です。デフォルト値は、1 dB です。

Router(config-if)# end
Router#

イネーブル(特権 EXEC)モードに戻ります。

アップストリーム パワー自動調整のレンジング値をデフォルトの 2 dB に戻すには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドを入力します。

Router(config-if)# no cable upstream usport power-adjust continue

アップストリーム電力調整のノイズ値をデフォルトの 30% に戻すには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドを入力します。

Router(config-if)# no cable upstream usport power-adjust noise
 

アップストリーム電力調整のスレッシュホールド値をデフォルトの 1 dB に戻すには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドを入力します。

Router(config-if)# no cable upstream usport power-adjust threshold

アップストリーム電力調整の確認

アップストリーム電力調整が設定され、アクティブになっているどうかを確認するには、 show running-configコマンドを入力し、ケーブル インターフェイスの設定情報を調べます。アップストリーム電力調整がイネーブルの場合、continue、noise、およびthresholdという 3 つの電力調整エントリのいずれか、または全部がshow running-configコマンドの出力に表示されます。3 つのアップストリーム電力調整がすべてディセーブルの場合、show running-configコマンドの出力に電力調整エントリは表示されません。

アップストリーム スクランブラのアクティブ化

アップストリーム RF キャリア上のスクランブラにより、HFC ネットワーク上の CM は内蔵スクランブラ回路を使用してアップストリーム データ伝送を行うことができます。このスクランブラ回路によって、ケーブル インターフェイス ライン カード上のアップストリーム レシーバの信頼性が向上します。


注意 アップストリーム スクランブラは、デフォルトでアクティブに設定されます。通常の環境ではディセーブルにしないでください。ディセーブルにすると、パケットが壊れる可能性があります。ディセーブルにするのは、アップストリーム スクランブラをサポートしていないプロトタイプのモデムの場合だけです。

アップストリーム スクランブラをアクティブにするには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドを使用します。アップストリーム スクランブラは、デフォルトではイネーブルに設定されます。

Router(config-if)# cable upstream usport scrambler

アップストリーム スクランブラの確認

アップストリーム スクランブラがアクティブに設定されているかどうかを確認するには、 more system: running-configコマンドを入力し、ケーブル インターフェイスの設定情報を調べます。確認できない場合には、次の作業を行ってください。


ステップ 1 ケーブル接続がゆるんでいたり、切断されていないかどうかを確認します。

ステップ 2 ケーブル インターフェイス ライン カードがシャーシスロットに確実に装着されているかどうかを確認します。

ステップ 3 非脱落型ネジが締まっているかどうかを確認します。

ステップ 4 正しいスロット番号およびポート番号を入力しているかどうかを確認します。

ステップ 5 ルータに有効な周波数が選択されていることを確認します。


 

アップストリーム タイミング調整のアクティブ化

特定のケーブル インターフェイスに対するアップストリーム タイミング調整をイネーブルにするには、ケーブル インターフェイス コンフィギュレーション モードで次のいずれかのコマンドを使用します。

 

コマンド
目的
Router(config-if)# cable upstream usport time-adjust continue seconds

レンジングステータスを継続できる最小タイミング調整を設定します。有効値は、2 ~ 64 秒です。デフォルト値は、2 秒です。

Router(config-if)# cable upstream usport time-adjust threshold seconds

タイミング調整スレッシュホールドを秒単位で設定します。有効値は、1 ~ 32 秒です。デフォルト値は、1 秒です。

Router(config-if)# end
Router#

イネーブル(特権 EXEC)モードに戻ります。

アップストリーム タイム調整のレンジング値をデフォルトの 2 秒に戻すには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドを入力します。

Router(config-if)# no cable upstream usport time-adjust continue
 

アップストリーム タイミング調整のスレッシュホールド値をデフォルトの 1 秒に戻すには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドを入力します。

Router(config-if)# no cable upstream usport time-adjust threshold

アップストリーム タイミング調整の確認

アップストリーム タイミング調整が設定され、アクティブになっているかどうかを確認するには、show running-configコマンドを入力し、ケーブル インターフェイスの設定情報を調べます。アップストリーム タイミング調整がイネーブルの場合、continueおよびthresholdというタイミング調整エントリのいずれか、または両方がshow running-configコマンドの出力に表示されます。continueおよびthresholdというアップストリーム タイミング調整が両方ともディセーブルの場合、show running-configコマンドの出力にタイミング調整エントリは表示されません。


ヒント 確認できない場合には、次の作業を行ってください。



ステップ 1 ケーブル接続がゆるんでいたり、切断されていないかどうかを確認します。

ステップ 2 ケーブル インターフェイス ライン カードがシャーシスロットに確実に装着されているかどうかを確認します。

ステップ 3 非脱落型ネジが締まっているかどうかを確認します。

ステップ 4 正しいスロット番号およびポート番号を入力しているかどうかを確認します。


 

アップストリーム バックオフ値の設定

アップストリーム チャネルでデータまたは要求を送信する CM 間のコンテンションを解消する方式として、DOCSIS で指定されているのは、切り捨て型バイナリ指数バックオフ値で、CMTS が初期バックオフ ウィンドウおよび最大バックオフ ウィンドウを制御します。Cisco uBR10000 シリーズ CMTSでは、データおよび初期レンジングの両方について、バックオフ ウィンドウ値を指定し、それらの値を Bandwidth Allocation Map(MAP)MAC メッセージの一部に組み込んで、ダウンストリーム方向に送信します。

この値は 2 の累乗で、Cisco uBR7200 シリーズのソフトウェアで設定できます。たとえば、4 という値は、0 ~ 15 のウィンドウを意味し、10 という値は 0 ~ 1023 を意味します。アップストリーム ポート上のデータ バックオフについて、固定開始/終了値を設定したり、アップストリーム ポートを自動データ バックオフとして設定することができます。レンジングバックオフについても同じです。どちらのバックオフ ウィンドウの場合も、デフォルトの開始値は 0、デフォルトの終了値は 4 です。有効値は 0 ~ 15 です。


) できるだけ、デフォルト値を調整せずに、自動ダイナミック バックオフ アルゴリズムをイネーブルにしてください。「ダイナミック コンテンション アルゴリズム(ケーブル挿入時間、レンジ、およびデータバックオフ)の設定」を参照してください。


アップストリーム ポートにデータまたはレンジングバックオフ値を設定するには、ケーブル インターフェイス コンフィギュレーション モードで、次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config-if)# cable upstream usport data-backoff start end


または


Router(config-if)# cable upstream usport data-backoff automatic
 

automatic 設定は、各アップストリーム ポートについて最大 250 のケーブル インターフェイスに対して最適化されます。各アップストリーム ポートあたり 250 を超えるケーブル インターフェイスで動作する場合に限って、データ バックオフ ウィンドウに対して手動で値を設定します。

デフォルトのバックオフ ウィンドウ値の 0 および 4 を設定します。

ステップ 2

Router(config-if)# cable upstream usport range start end

または

Router(config-if)# cable upstream usport range automatic
 

automatic 設定は、各アップストリーム ポートについて最大 250 のケーブル インターフェイスに対して最適化されます。各アップストリーム ポートあたり 250 を超えるケーブル インターフェイスで動作する場合に限って、データ バックオフ ウィンドウに対して手動で値を設定します。

デフォルトのバックオフ ウィンドウ値の 0 および 4 を設定します。

バックオフ値の調整が必要かどうかを検討する場合は、下記を考慮してください。

電力停止後のケーブル インターフェイス再接続時間は、次の要因に関連します。

DHCP、ToD、TFTP の各サーバは、通常の環境では 1% 未満の負荷で十分正常に動作しますが、電力停止後は 100% 以上に跳ね上がることがあります。

バックオフを大きい値に調整すると、ケーブル インターフェイスの再接続を遅らせ、サーバの負荷が軽減されます。

バックオフが小さすぎると、ケーブル インターフェイスでアップストリーム RF のレベルが正しく調整され、最大パワーにサイクリングするレンジに入るので、接続時間が長くなり、ネットワーク パフォーマンスが低下します。

バックオフが大きすぎると、大規模なサービスの停止後の復旧時間が長引きます。

ケーブル インターフェイスの再起動時間に関して、ケーブル インターフェイスの性能には(ブランド間で)かなり差があります。

すべてのケーブル インターフェイスは、すべてのサービスの復旧後(Cisco uBR10012 ルータ、RF トランスポート、DHCP、TFTP、ToD サーバ)、0 ~ 10 分で回復するはずです。10 分以上かかる CM の場合、CM、CMTS の設定、または DOCSIS プロビジョニング サーバに問題がある可能性があります。


) 比較的多数(1600 以上など)のケーブル インターフェイスに対応しているアップストリーム セグメントは、回復に 10 分以上かかる場合があります。


アップストリーム データ バックオフの確認

バックオフウィンドウの設定値を確認するには、設定したアップストリーム ポートに対して、 show controllers cable コマンドを入力します。

Router# show controllers cable5/0/0 u0
Cable5/0/0 Upstream 0 is up
Frequency 24.016 MHz, Channel Width 1.600 MHz, QPSK Symbol Rate 1.280 Msps
Spectrum Group is overridden
SNR 33.2560 dB
Nominal Input Power Level 0 dBmV, Tx Timing Offset 2288
Ranging Backoff automatic (Start 0, End 3)
Ranging Insertion Interval automatic (60 ms)
Tx Backoff Start 0, Tx Backoff End 4
Modulation Profile Group 1
part_id=0x3137, rev_id=0x03, rev2_id=0xFF
nb_agc_thr=0x0000, nb_agc_nom=0x0000
Range Load Reg Size=0x58
Request Load Reg Size=0x0E
Minislot Size in number of Timebase Ticks is = 8
Minislot Size in Symbols = 64
Bandwidth Requests = 0xFE
Piggyback Requests = 0xD
Invalid BW Requests= 0x2
Minislots Requested= 0x2963
Minislots Granted = 0x2963
Minislot Size in Bytes = 16
Map Advance = 4000 usecs
UCD Count = 32964
DES Ctrl Reg#0 = C000C043, Reg#1 = 0
 

アップストリーム チャネル幅の設定

アップストリーム チャネル幅をヘルツ(Hz)単位で入力するには下記のコマンドを使用します。NTSC の場合、有効な値は 200,000 Hz(160 キロシンボル/秒 [ksps])、400,000 Hz(320 ksps)、800,000 Hz(640 ksps)、1,600,000 Hz(1,280 ksps)、および 3,200,000 Hz(2,560 ksps)です。デフォルト値は 1,600,000 Hz です。

指定された幅で適切なチャネルがない場合、スペクトル管理カードは、次に利用できる大きいチャネル幅を探して、アップストリーム スペクトルのスキャンを自動的に開始します。たとえば、スペクトル管理カードが 1.6 MHz で使用できるアップストリーム チャネルを見つけられなかった場合、800 kHz で使用できるチャネルの検索を自動的に開始します。


注意 シンボルレートが高いほど、RF ノイズおよび干渉を受けやすくなります。HFC ネットワークの能力を超えるようなシンボルレートまたは変調フォーマットを使用すると、パケットが失われたり、ケーブル インターフェイスの接続能力が低下することがあります。


) 400 kHz(320 ksps)以上の QAM -16 チャネル幅の場合、ロング データおよびショート データに QAM -16 変調を使用し、要求、初期、およびステーション通信に QPSK を使用することを推奨します。200 kHz(160 ksps)の QAM -16 チャネル幅の場合、すべての通信で QAM -16 を使用できる必要があります。160 ksps の QAM -16 では、アップストリーム チャネルに特別な Signal-to-noise Ratio(SNR)が必要になるためです。400 kHz を超えるチャネル幅で、要求、初期、およびステーション メンテナンス メッセージに QAM -16 を使用する場合、QPSK フォーマットに比べて、QAM -16 プリアンブルおよびメッセージ データの伝送に時間がかかります。



) アップストリーム チャネル幅を設定するには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドを使用します。


 

コマンド
目的

ステップ 1

Router(config-if)# cable upstream usport channel-width width

アップストリーム RF キャリアのチャネル幅を Hz 単位で入力します。

ステップ 2

Router(config-if)# no cable upstream usport channel-width

チャネル幅をデフォルト値の 1,600,000 Hz に戻します。

チャネル幅およびミニスロットサイズの詳細については、『 Cable Radio Frequency (RF) FAQs 』( http://www.cisco.com/warp/public/109/cable_faq_rf.html )を参照してください。

アップストリーム チャネル幅の確認

アップストリーム チャネル幅の現在値を確認するには、設定したアップストリーム ポートに対して、 show controllers cable コマンドを入力します。次に例を示します。

Router# show controllers cable5/0/0 u0
Cable5/0/0 Upstream 0 is up
Frequency 24.016 MHz, Channel Width 0.800 MHz, QPSK Symbol Rate 0.640 Msps
Spectrum Group is overridden
SNR 33.2560 dB
Nominal Input Power Level 0 dBmV, Tx Timing Offset 2288
Ranging Backoff automatic (Start 0, End 3)
Ranging Insertion Interval automatic (60 ms)
Tx Backoff Start 0, Tx Backoff End 4
Modulation Profile Group 1
 

確認できない場合には、次の作業を行ってください。


ステップ 1 変調方式(QPSK/QAM -16)、ミニスロットサイズ、周波数の有効な組み合わせを使用し、no shutdownコマンドを実行します。

ステップ 2 推奨する変調プロファイル、またはテスト済みの変調プロファイルを使用してください。ケーブル インターフェイスとヘッドエンド間の通信が不可能な変調プロファイルが作成されることもあります。各メッセージ タイプを個別に指定するので、一部のメッセージが無効になることがあります。

ステップ 3 長さの異なる(64 ~ 1500 バイト)IP ping パケットを使用して確認します。ヘッドエンドからケーブル インターフェイスに ping を実行します。

ステップ 4 CM のソフトウェアが DOCSIS 1.0 および拡張に完全に準拠しているかどうかを、ケーブル インターフェイスのベンダーに確認します。


 

アップストリーム周波数の設定

シスコ ケーブル インターフェイス ラインカードで予想される入力周波数に合わせて、RF 出力のアップストリーム チャネル周波数を設定する必要があります。アップストリーム チャネル周波数を設定するには、次のいずれかの作業を行います。

NTSC 動作用の 5 ~ 42 MHz の固定周波数を設定し、アップストリーム ポートをイネーブルにします。

グローバル スペクトル グループを作成し、それにインターフェイスを割り当て、アップストリーム ポートをイネーブルにします。


) 特定の固定値を設定しないデフォルトを選択することもできます。



) アップストリーム ポートは、周波数により大きな影響を受けます。スペクトル グループを定義しておくと、インターフェイスがアップに設定され、トラフィックが伝送されている状態でも、周波数を変更できます。


変調プロファイルは、初期メンテナンス、長期許可、要求/データ、要求、短期許可、およびステーション メンテナンスなど、各種アップストリーム バーストの物理レイヤ特性テーブルで構成されます。


) アップストリーム ケーブル インターフェイスは、固定アップストリーム周波数を設定するか、スペクトル グループを作成して設定するまで動作しません。

固定アップストリーム周波数を設定する場合、選択した周波数が、ケーブル プラントで稼働している他のアップストリーム アプリケーションの周波数に干渉しないように注意してください。


固定アップストリーム周波数を設定するには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config-if)# cable upstream usport frequency up-freq-hz

アップストリーム RF キャリアの固定中心周波数を Hz 単位で入力します。

ステップ 2

Router(config-if)# no cable upstream usport shutdown

アップストリーム ポートを [admin up] ステートにします。


ヒント NTSC 動作の場合、有効範囲は 5,000,000 ~ 42,000,000 Hz です。



注意 一部のケーブルシステムでは、帯域境界に近い周波数を確実に伝送できません。アップストリーム チャネル幅が広いほど(MHz 単位)、問題が起こりやすくなります。問題が起きた場合は、20 ~ 38 MHz の中心周波数を入力してください。


) 特定の固定値を設定しないデフォルトを選択することもできます。Cisco uBR7200 シリーズ ソフトウェアでは、ケーブル インターフェイスはこの周波数を中心周波数として使用します。


アップストリーム周波数の確認

アップストリーム周波数の現在値を確認するには、設定したアップストリーム ポートに対して、 show controllers cable コマンドを入力します。

Router# show controllers cable5/0/0 u0
Cable5/0/0 Upstream 0 is up
Frequency 24.016 MHz, Channel Width 1.600 MHz, QPSK Symbol Rate 1.280 Msps
Spectrum Group is overridden
SNR 33.2560 dB
Nominal Input Power Level 0 dBmV, Tx Timing Offset 2288
Ranging Backoff automatic (Start 0, End 3)
Ranging Insertion Interval automatic (60 ms)
Tx Backoff Start 0, Tx Backoff End 4
Modulation Profile Group 1

show controllers cableコマンド出力として表示されるアップストリーム周波数は、アップストリーム周波数の設定時に入力した周波数と一致しない場合があります。Cisco uBR10000 シリーズ CMTSは、入力した周波数の近辺で、より優れたパフォーマンスが得られるアップストリーム周波数を選択します。Cisco uBR10000 シリーズ CMTSは、使用可能な最も近い周波数を選択します。


確認できない場合には、次の作業を行ってください。


ステップ 1 ケーブル接続がゆるんでいたり、切断されていないかどうかを確認します。

ステップ 2 ケーブル インターフェイス ライン カードがシャーシスロットに確実に装着されているかどうかを確認します。

ステップ 3 非脱落型ネジが締まっているかどうかを確認します。

ステップ 4 正しいスロット番号およびポート番号を入力しているかどうかを確認します。

ステップ 5 ルータに有効な周波数が選択されているかどうかを確認します。


 

アップストリーム入力パワーレベルの設定

Cisco uBR10012 ルータは、適切なアップストリーム入力パワーレベルに適合するように、CM の出力パワーレベルを制御します。アップストリーム RF キャリアの公称入力パワーレベルは、dBmV(デシベル/ミリボルト)単位で指定します。デフォルト値の 0 dBmV がアップストリーム パワー レベルには最適です。

入力パワーレベルの有効範囲は、データレートによって異なります。1.6 MHz の場合、有効値は、-10 ~ 25 dBmV です。パワーレベルが有効な最大レベルより高い場合は、インラインの減衰器を使用して、パワーレベルを有効範囲内に引き下げてください。


注意 入力パワーレベルを引き上げると、HFC ネットワーク上の CM の送信パワーレベルが上がります。その結果、ネットワーク上の Carrier-to-Noise ratio(C/N; 搬送波対雑音比)が上がりますが、同時に、ひずみの値も大きくなります。C/N が 1 dB 上がるごとに、Composite Second Order Beat(CSO)および Composite Triple Beat(CTB)の値が 2 dB ずつ悪化します。リターンパスのレーザー光がノンリニアモードで侵入すると、クリッピングと呼ばれる状態になり、すべての通信の信頼性が失われます。多数のリターン レーザー光がクリッピング スレッシュホールドより上のショート バーストを送信し、長いバーストや連続バーストが送信されなくなります。

30 秒間に 5 dB 以上、入力パワーレベルを調整しないでください。30 秒以内に 5 dB 以上パワーレベルを上げると、ネットワーク上のケーブル インターフェイス サービスが停止します。30 秒以内に 5 dB 以上パワーレベルを下げると、ネットワーク上のケーブル インターフェイスが強制的にオフラインになります。


) cable upstream 0 power-levelコマンドを実行する場合、隣接チャネルに大きな変動を与えないようにしてください。最大入力パワー変動の推奨値は 5 ~ 6 dBmV です。


アップストリーム入力パワーレベルを dBmV 単位で設定するには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドを使用します。デフォルト値は 0 dBmV です。

Router(config-if)# cable upstream usport power-level dbmv
 

アップストリーム入力パワーレベルの確認

アップストリーム入力パワーレベルの現在値を確認するには、設定したアップストリーム ポートに対して、 show controllers cable コマンドを入力します。

Router# show controllers cable5/0/0 u0
Cable5/0/0 Upstream 0 is up
Frequency 24.016 MHz, Channel Width 0.800 MHz, QPSK Symbol Rate 0.640 Msps
Spectrum Group is overridden
SNR 33.2560 dB
Nominal Input Power Level 0 dBmV, Tx Timing Offset 2288
Ranging Backoff automatic (Start 0, End 3)
Ranging Insertion Interval automatic (60 ms)
Tx Backoff Start 0, Tx Backoff End 4
Modulation Profile Group 1

確認できない場合には、次の作業を行ってください。

1. 光ファイバノードの基準入力ポイントに挿入された最適 RF キャリアのアップストリーム振幅が、(ノード間およびポート間で)一定レベルでケーブル インターフェイス ライン カードの入力ポイントに到達しているかどうかを確認します。

2. 設置時の絶対レベルが、Cisco uBR10000 シリーズ CMTSの設計およびソフトウェア設定の両方に適しているかどうかを確認します。


) 1 ~ 3 dB のソフトウェア調整を使用すると、測定値の小さい変動を調整したり、ポート間の調整差を設定したりすることができます。特に限界状況では、このような調整により、ケーブル インターフェイスのパフォーマンスを大幅に改善できます。大幅な調整は、ヘッドエンドまたは分散ハブでのスペクトル アナライザ サポートと組み合わせて行ってください。


アップストリーム ミニスロット サイズの指定

特定のアップストリーム ケーブル インターフェイスにミニスロットサイズ(チック単位)を指定するには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドを使用します。有効値は、2、4、8、16、32、64、および 128 です。デフォルト値は 8 です。

Router(config-if)# cable upstream usport minislot-size size
 

チャネル幅およびミニスロットサイズの詳細については、『Cable Radio Frequency (RF) FAQs』( http://www.cisco.com/warp/public/109/cable_faq_rf.html )を参照してください。

アップストリーム ミニスロット サイズの確認

アップストリーム ミニスロット サイズを確認するには、設定したアップストリーム ポートを指定して、 show controllers cable コマンドを入力します。

Router# show controllers cable5/0/0 u0
Cable5/0/0 Upstream 0 is up
Frequency 24.016 MHz, Channel Width 1.600 MHz, QPSK Symbol Rate 1.280 Msps
Spectrum Group is overridden
SNR 33.2560 dB
Nominal Input Power Level 0 dBmV, Tx Timing Offset 2288
Ranging Backoff automatic (Start 0, End 3)
Ranging Insertion Interval automatic (60 ms)
Tx Backoff Start 0, Tx Backoff End 4
Modulation Profile Group 1
part_id=0xFFFF, rev_id=0xFF, rev2_id=0xFF
nb_agc_thr=0x0000, nb_agc_nom=0x0000
Range Load Reg Size=0x58
Request Load Reg Size=0x0E
Minislot Size in number of Timebase Ticks is = 8
Minislot Size in Symbols = 64
Bandwidth Requests = 0xFE
Piggyback Requests = 0xD
Invalid BW Requests= 0x2
Minislots Requested= 0x2963
Minislots Granted = 0x2963
Minislot Size in Bytes = 16
Map Advance = 4000 usecs
UCD Count = 32964
DES Ctrl Reg#0 = C000C043, Reg#1 = 0
 

確認できない場合には、次の作業を行ってください。


ステップ 1 ケーブル接続がゆるんでいたり、切断されていないかどうかを確認します。

ステップ 2 ケーブル インターフェイス ライン カードがシャーシスロットに確実に装着されているかどうかを確認します。

ステップ 3 非脱落型ネジが締まっているかどうかを確認します。

ステップ 4 正しいスロット番号およびポート番号を入力しているかどうかを確認します。

ステップ 5 ルータに有効な周波数が選択されていることを確認します。


 

アップストリーム レート制限およびトラフィック シェーピングの設定

DOCSIS アップストリーム チャネルで使用可能なアップストリーム トラフィック シェーピングは、アップストリーム パケットのスケジューリングを遅らせ、これにより、パケットを廃棄するのではなくケーブル CPE デバイス上のバッファに保管します。TCP/IP スタックは、アプリケーション トラフィックと適切に速度を合わせ、加入者の定義済み Quality of Service(QoS; サービス品質)レベルに相当するスループットを達成します。

CM は、TCP 関連のタイムアウトや再送信を招くことなくバッファリングされます。その結果、CMTS は、加入者 CPE の全体的な TCP パフォーマンスを下げずに、各 CM のアップストリーム最大レートを適用できます。アップストリーム認可シェーピングは、ケーブル インターフェイス(Service ID[SID])ごとに設定できます。

シェーピングを使用するトークンバケット ポリシングは、CMTS で設定するアップストリーム単位のデフォルトレート制限です。シェーピングは、トークンバケット アルゴリズムでイネーブルまたはディセーブルに設定できます。

シスコ ケーブル インターフェイス ライン カード上のアップストリーム ポートに対して、アップストリーム トラフィック シェーピングをイネーブルにするには、ケーブル インターフェイス コンフィギュレーション モードで、次のいずれかのコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config-if)# cable upstream usport rate-limit


 

Router(config-if)# cable upstream usport rate-limit token-bucket






Router(config-if)# cable upstream usport rate-limit token-bucket shaping

指定されたアップストリーム ケーブル インターフェイスに対するトラフィック シェーピングをイネーブルにします。

トークンバケット ポリシング アルゴリズムを採用しているアップストリーム ケーブル インターフェイスに対して、トラフィック シェーピングをイネーブルにします。このコマンドを使用すると、Cisco uBR10000 シリーズ CMTSは、許容アップストリーム帯域幅を超えるパケットを自動的に廃棄します。

デフォルト。トラフィック シェーピングを指定したトークンバケット ポリシング アルゴリズムを採用しているアップストリーム ケーブル インターフェイスに対して、トラフィック シェーピングをイネーブルにします。

ステップ 2

Router(config-if)# ^Z
Router#

EXEC モードに戻り、アップストリーム トラフィック シェーピングを確認します。

アップストリーム ポートに対してアップストリーム トラフィック シェーピングをディセーブルにするには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドを入力します。

Router(config-if)# no cable upstream usport rate-limit
 

ソフトウェアがサポートしている機能は、次のとおりです。

汎用カレンダ キューイング ルーチン

新しいトークンバケット ポリシング機能

カレンダ キューの認可シェーピング アプリケーション

token bucketキーワードに対するアップストリーム レートシェーピング オプション

1 秒のバーストポリシングからシェーピングを伴うトークンバケットへのデフォルトステートの変化


ヒント アップストリーム認可シェーピングは、CM(SID)ごとに設定できます。シェーピングは、トークンバケット アルゴリズムでイネーブルまたはディセーブルに設定できます。



) この機能が追加されるまでは、設定されたアップストリーム最大レートを超えると、CMTS は CM からの帯域要求を廃棄していました。このような要求の廃棄は、FTP、TCP、SNMP などの IP ベース プロトコルのスループット パフォーマンスに影響します。この機能では、CMTS はアップストリーム最大レートを超えた CM の認可をシェーピング(バッファ)できるので、帯域要求を廃棄する必要がありません。


Router# show interface c5/0/0 sid 1 counters
00:02:23: %ENVM-3-LASTENV: Cannot save environmental data
Sid Req-polls BW-reqs Grants Packets Frag Concatpkts
issued received issued received complete received
1 0 22 22 22 0 0
2 0 3 3 2 0 0
3 0 0 0 0 0 0
 

ダウンストリーム トラフィック シェーピングの確認

アップストリーム トラフィック シェーピングが設定され、アクティブになっているかどうかを確認するには、 show running-configコマンドを入力し、ケーブル インターフェイスの設定情報を調べます。アップストリーム トラフィック シェーピングが設定され、イネーブルになっている場合は、show running-config の出力にトラフィック シェーピングのエントリが表示されます。アップストリーム トラフィック シェーピングがディセーブルの場合は、出力に no cable upstream rate-limit が表示されます。

また、次の作業によって、アップストリーム チャネル上でトラフィック シェーピングがイネーブルになっているかを確認することができます。


ステップ 1 CM の QoS プロファイルで、その CM の上限と下限のアップストリーム レート制限を設定します。CLI によるモデムの QoS プロファイル変更、またはモデムの TFTP コンフィギュレーション ファイルの編集については、フィーチャ モジュール『 DOCSIS 1.1 for Cisco uBR7200 Series Universal Broadband Routers 』( http://www.cisco.com/univercd/cc/td/doc/product/cable/cab_r_sw/docsis11.htm )を参照してください。

ステップ 2 レートシェーピングを実行しない標準のレート制限アルゴリズムを使用し、その CM が最大アップストリーム レートを超過したときに、CM からの余分な帯域要求が廃棄されることを確認します。

show interface cx/y sid counters verbose コマンドを使用して、帯域要求の廃棄を調べます。帯域要求の廃棄によって発生したタイムアウトおよびバックオフが原因で、モデムに与えられたアップストリーム レートが設定ピークレートを実際に下回っているかどうかを確認します。
show interface cx/y service flow qos
コマンドを入力して、CMTS の入力レート(bps)を調べます。

ステップ 3 token-bucket algorithm CLI コマンドの新しい shaping キーワード エクステンションを使用して、アップストリーム チャネル上で認可シェーピングをイネーブルにします。

ステップ 4 アップストリーム トラフィックを発生させることによって、CM が最大アップストリーム レートを超過するようにして、CMTS での認可バッファリング(シェーピング)の作用を確認します。CM と CMTS 間で ping を使用すると、ping の周波数が大幅に減少します。

CMTS で平均が落ち着くまで時間をかけて ping を実行し、そのモデムが受けるアップストリーム レートをモニタします。 show interface cx/y コマンドを使用して、入力レート(bps)を調べます。この値は、モデムの最大アップストリーム レートに近くなるはずです。さらに、 show interface sid counters コマンドを使用することによって、モデムの SID に対応する廃棄カウントを調べ、CMTS がその CM からの帯域要求を廃棄しなくなったことを確認します。

アップストリーム レート シェーピングを使用している場合、帯域要求廃棄カウントは、(前回の非シェーピングテストから)変化せず、CMTS で実際にそのモデムの認可をシェーピング(バッファリング)していることを示します。(レートを超過した 1 台の CM から)CMTS での入力レートが 128 Kbps という設定最大レート近くで安定しているかどうかを確認します。


 

トラブルシューティング用のヒント

確認できない場合には、次の作業を行ってください。


ステップ 1 ケーブル接続がゆるんでいたり、切断されていないかどうかを確認します。

ステップ 2 ケーブル インターフェイス ライン カードがシャーシスロットに確実に装着されているかどうかを確認します。

ステップ 3 非脱落型ネジが締まっているかどうかを確認します。

ステップ 4 正しいスロット番号およびポート番号を入力しているかどうかを確認します。

ステップ 5 ルータに有効な周波数が選択されていることを確認します。


 

オプションのケーブル インターフェイス機能の設定

このセクションは、この章で前述した必須ケーブル インターフェイス機能に基づいています。ここでは、オプションのケーブル インターフェイスの設定手順について説明します。これらのインターフェイスの機能は、パフォーマンスとセキュリティ手段を向上させるためのものです。


) システムのオプション機能の設定には、通常、デフォルトの設定で十分です。デフォルト設定を変更する場合には、あらかじめ十分に調べてください。


 

セクション
目的

「ホスト間通信(プロキシ ARP)のアクティブ化」

Cisco uBR10012 ルータは、同じケーブル ネットワーク サブネット上の CM のために、ケーブル ARP 要求を発行できます。

「パケットインターセプト機能のアクティブ化」

インターセプト機能をアクティブにするケーブルネットワーク上の MAC アドレスを指定します。

「ペイロード ヘッダーの抑制および復元の設定」

Payload Header Suppression(PHS; ペイロードヘッダー抑制)機能をセットアップするためのコマンドについて説明します。この PHS 機能によって、DOCSIS リンクでの伝送前に、パケットヘッダーの反復または冗長部分を抑制します。

「オプションのブロードキャストおよびケーブル IP マルチキャスト エコーの設定」

IP パラメータを追加設定することにより、アップストリーム データのダウンストリーム エコーが可能になります。

ホスト間通信(プロキシ ARP)のアクティブ化

ケーブルプロキシ ARP により、Cisco uBR10012 ルータは同じケーブル ネットワーク サブネット上の CM のために、ケーブル ARP 要求を発行できます。


) ダウンストリームとアップストリームは別々のインターフェイスなので、モデムはケーブルプラントの他のモデムに対して直接 ARP を実行することはできません。



) この設定作業で使用するコマンドは、通常、デフォルト値でCisco uBR10012 ルータを最適に設定できます。


ケーブルプロキシ ARP 要求のアクティブ化

ホスト間通信用にケーブルプロキシ ARP をアクティブにするには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的
Router(config-if)# cable proxy-arp

ケーブル インターフェイス上でプロキシ ARP をイネーブルにします。これがデフォルトの設定です。

ケーブルプロキシ ARP 要求の確認

ケーブルプロキシ ARP がアクティブかどうかを確認するには、 more system:running-configコマンドを入力し、ケーブル インターフェイスの設定情報を調べます。ケーブルプロキシ ARP がアクティブになっている場合は、出力に示されません。ケーブルプロキシ ARP が非アクティブの場合には、コマンド出力に no cable proxy-arp が表示されます。

Router# more system:running-config
Building configuration...
 
Current configuration:
!
interface cable5/0/0
 
ip address 1.1.1.1 255.255.255.0
no keepalive
no cable proxy-arp
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream symbol-rate 5056941
cable upstream 0 frequency 15008000
no cable upstream 0 shutdown

ヒント 確認できない場合には、ケーブルプロキシ ARP をアクティブにしたときに、有効なポートおよびケーブル インターフェイス ライン カードのスロット番号を指定したかどうかを確認してください。


パケットインターセプト機能のアクティブ化

パケットインターセプト機能をアクティブにするには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的
Router(config-if)# cable intercept xxxx.xxxx.xxxx

インターセプト機能をアクティブにするケーブルネットワーク上の MAC アドレスを指定します。MAC アドレスの上限は 10 です。

Router(config-if)# no cable intercept xxxx.xxxx.xxxx

イネーブルになっているインターセプトをディセーブルにします。

ペイロード ヘッダーの抑制および復元の設定

PHS は、DOCSIS 1.1 MAC ドライバの新機能です。PHS 機能は、DOCSIS リンクを伝送する前にパケットヘッダーの反復または冗長部分を抑制します。現在アップストリーム受信ドライバは CM によって抑止されたヘッダーを回復することができ、ダウンストリーム ドライバはパケットヘッダーの特定フィールドを抑止してからフレームを CM に転送できます。

 

コマンド
目的
show interface cable x/0/0 service-flow [ sfid ] phs

ケーブル インターフェイス情報を表示します。

debug cable error

ケーブル MAC プロトコルで発生するエラーを表示します。デバッグ出力をディセーブルにするには、このコマンドのno形式を使用します。

debug cable phs

PHS と復元ドライバのアクティビティを表示します。このコマンドのno形式を使用すると、デバッグ出力がディセーブルになります。

オプションのブロードキャストおよびケーブル IP マルチキャスト エコーの設定

IP パラメータを追加設定することにより、アップストリーム データのダウンストリーム エコーが可能になります。ここでは、このオプションの IP パラメータ設定の 2 つの手順について説明します。

「IP マルチキャスト エコーの設定」

「IP ブロードキャスト エコーの設定」


) この設定手順で使用するコマンドは、通常、デフォルト値でCisco uBR10012 ルータを最適に設定できます。


IP マルチキャスト エコーの設定

Cisco uBR10012 ルータは、デフォルトで IP マルチキャスト パケットをエコーします。すでにディセーブルに設定された IP マルチキャストをアクティブにするには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的
Router(config-if)# cable ip-multicast-echo

IP マルチキャストエコーをイネーブルにします。これがデフォルトの設定です。

IP マルチキャストエコーをディセーブルにするには、ケーブル インターフェイス コンフィギュレーション モードで no cable ip-multicast-echo コマンドを入力します。

IP マルチキャストエコーの確認

IP マルチキャストエコーがアクティブ、または非アクティブに設定されているかどうかを確認するには、 more system: running-configコマンドを入力し、ケーブル インターフェイスの設定情報を調べます。IP マルチキャストエコーがアクティブになっている場合、デフォルトの設定なので、出力には表示されません。IP マルチキャストエコーが非アクティブの場合は、出力に次のように表示されます。

Router# more system:running-config
Building configuration...
 
Current configuration:
!
interface cable5/0/0
 
ip address 1.1.1.1 255.255.255.0
no keepalive
no cable ip-multicast-echo
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable upstream 0 frequency 15008000
no cable upstream 0 shutdown

ヒント 確認できない場合には、ケーブル インターフェイス コンフィギュレーション モードで、正しいスロット番号およびポート番号を入力したかどうかを確認してください。


アクセス リストおよび cable ip-multicast echo コマンド

cable ip-multicast-echo コマンドは、Cisco uBR10012 ルータではデフォルトでイネーブルになっています。そのため、Cisco CMTS のアップストリームに到達するマルチキャスト IP パケットは、適切なダウンストリーム ポートに転送され、ネットワークのそのセグメント上の他の CM および CPE デバイスに送信されます。これにより、ケーブル ネットワークは、マルチキャスト IP トラフィックの処理という点では、標準イーサネット ネットワークと同様に動作します。

ただし、Cisco uBR10012 ルータでは、入力アクセス リストは、各ダウンストリームでエコーされるマルチキャスト トラフィックに適用されません。したがって、エコーされたマルチキャスト トラフィックを制御するには、出力アクセス リストを設定し、それを各ダウンストリーム インターフェイスに適用する必要があります。

アクセス リストおよびマルチキャスト エコーの詳細については、Cisco.com の『Cisco Broadband Cable Command Reference Guide』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/cable/bbccmref/index.htm

IP ブロードキャスト エコーの設定

デフォルトの設定では、Cisco uBR10012 ルータは IP ブロードキャスト パケットをエコーしません。IP ブロードキャストエコーをアクティブにするには、ケーブル インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的
Router(config-if)# cable ip-broadcast-echo

IP ブロードキャストエコーをイネーブルにします。

イネーブルになっている IP ブロードキャストエコーをディセーブルにするには、ケーブル インターフェイス コンフィギュレーション モードで no cable ip-broadcast-echo コマンドを入力します。

IP ブロードキャストエコーの確認

IP ブロードキャストエコーがアクティブまたは非アクティブになっているかどうかを確認するには、more system:running-configコマンドを入力し、ケーブル インターフェイスの設定情報を調べます。

Router# more system:running-config
Building configuration...
 
Current configuration:
!
interface cable5/0/0

 

ip address 1.1.1.1 255.255.255.0
no keepalive
cable ip-broadcast-echo
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable upstream 0 frequency 15008000
no cable upstream 0 shutdown

ケーブル インターフェイスの設定例

ここでは、次の設定例を示します。

「サブインターフェイスの設定例」

「ケーブル インターフェイス バンドル例」

「ケーブル インターフェイス バンドル マスタの設定例」

「PE ルータの設定例」

「P ルータの設定例」

「BGP ルーティング セッションの設定例」

「PE 間ルーティング セッションの設定例」

「BGP PE/CE ルーティング セッションの設定例」

「RIP PE/CE ルーティング セッションの設定例」

「スタティックルート PE/CE ルーティング セッションの設定例」

サブインターフェイスの設定例

次の例では、cable5/0/0 でのサブインターフェイスの定義方法を示します。

interface cable5/0/0
! No IP address
! MAC level configuration only
 
! first subinterface
interface cable5/0/0.1
description Management Subinterface
ip address 10.255.1.1 255.255.255.0
cable helper-address 10.151.129.2
 
! second subinterface
interface cable5/0/0.2
ip address 10.279.4.2 255.255.255.0
cable helper-address 10.151.129.2
 
! third subinterface
interface cable5/0/0.3
ip address 10.254.5.2 255.255.255.0
cable helper-address 10.151.129.2
 

ケーブル インターフェイス バンドル例

次の例では、物理インターフェイス グループのバンドル方法を示します。次の例では、インターフェイス int c5/0/0 および int c4/0/0 がバンドルされます。

int c5/0/0
ip address 209.165.200.225 255.255.255.0
ip address 209.165.201.1 255.255.255.0 secondary
cable helper-address 10.5.1.5
! MAC level configuration
cable bundle 1 master
int c4/0/0
! No IP address
! MAC layer configuration only
cable bundle 1
 

バンドル マスタでのサブインターフェイスの定義例

次の例では、バンドル マスタでのサブインターフェイスの定義方法と各サブインターフェイスのレイヤ 3 設定の定義方法を示します。例では、インターフェイス int c5/0/0 および int c4/0/0 がバンドルされます。

int c5/0/0
! No IP address
! MAC level configuration only
cable bundle 1 master
 
int c4/0/0
! No IP address
! MAC layer configuration
cable bundle 1
 
! first subinterface
int c5/0/0.1
ip address 10.22.64.0 255.255.255.0
cable helper-address 10.4.1.2
 
! second subinterface
int c5/0/0.2
ip address 10.12.39.0 255.255.255.0
cable helper-address 10.4.1.2
 
! third subinterface
int c5/0/0.3
ip address 10.96.3.0 255.255.255.0
cable helper-address 10.4.1.2
 

ケーブル インターフェイス バンドル マスタの設定例

次の例では、ケーブル インターフェイス バンドルの設定方法を示します。

Displaying the contents of the bundle
Router(config-if)# cable bundle ?
<1-255> Bundle number
Router(config-if)# cable bundle 25 ?
master Bundle master
<cr>
Router(config-if)# cable bundle 25 master ?
<cr>
Router(config-if)# cable bundle 25 master
Router(config-if)#
07:28:17: %uBR10000-5-UPDOWN: Interface Cable5/0/0 Port U0, changed state to down
07:28:18: %uBR10000-5-UPDOWN: Interface Cable5/0/0 Port U0, changed state to up
 

PE ルータの設定例

この例(システム情報表示)では、インストールされている Cisco IOS ソフトウェアのバージョンを識別し、PE 設定を表示します。

! Defines the hostname of the Cisco uBR10012
hostname region-1-ubr
!
! Describes where the system is getting the software image it is running. In
! this configuration example, the system is loading a Cisco uBR10012 image named
! AdamSpecial from slot 0.
boot system flash slot0:uBR10000-p-mz.AdamSpecial
!
! Creates the enable secret password.
enable secret xxxx
enable password xxxx
!
! Sets QoS per modem for the cable plant.
no cable qos permission create
no cable qos permission update
cable qos permission modems
!
! Allows the system to use a full range of IP addresses, including subnet zero, for
! interface addresses and routing updates.
ip subnet-zero
!
! Enables Cisco Express Forwarding.
ip cef
!
! Configures a Cisco IOS Dynamic Host Configuration Protocol (DHCP) server to insert the
! DHCP relay agent information option in forwarded BOOTREQUEST messages.
ip dhcp relay information option
!
! Enters the virtual routing forwarding (VRF) configuration mode and maps a VRF table to
! the virtual private network (VPN) called MGMT-VPN. The VRF table contains the set of
! routes that points to or gives routes to the CNR device, which provisions the cable
! modem devices. Each VRF table defines a path through the MPLS cloud.
ip vrf MGMT-VPN
!
! Creates the route distinguisher and creates the routing and forwarding table of the
! router itself.
rd 100:1
!
! Creates a list of import and/or export route target communities for the VPN.
route-target export 100:2
route-target export 100:3
!
! Maps a VRF table to the VPN called ISP1-VPN.
ip vrf ISP1-VPN
!
! Creates the route distinguisher and creates the routing and forwarding table of the
! router itself.
rd 100:2
!
! Creates a list of import and/or export route target communities for the VPN.
route-target import 100:1
!
! Maps a VRF table to the VPN called ISP2-VPN.
ip vrf ISP2-VPN
!
! Creates the route distinguisher and creates the routing and forwarding table of the
! router itself.
rd 100:3
!
! Creates a list of import and/or export route target communities for the VPN.
route-target import 100:1
!
! Maps a VRF table to the VPN called MSO-isp. Note: MSO-isp could be considered ISP-3; in
! this case, the MSO is competing with other ISPs for other ISP services.
ip vrf MSO-isp
!
! Creates the route distinguisher and creates the routing and forwarding table of the
! router itself.
rd 100:4
!
! Creates a list of import and/or export route target communities for the VPN.
route-target import 100:1
!
! Builds a loopback interface to be used with MPLS and BGP; creating a loopback interface ! eliminates unnecessary updates (caused by physical interfaces going up and down) from
! flooding the network.
interface Loopback0
ip address 10.0.0.0 255.255.255.0
no ip directed-broadcast
!
! Assigns an IP address to this Fast Ethernet interface. MPLS tag-switching must be
! enabled on this interface.
interface FastEthernet0/0/0
description Connection to MSO core.
ip address 10.0.0.0 255.255.255.0
no ip directed-broadcast
full-duplex
tag-switching ip
!
! Enters cable interface configuration mode and configures the physical aspects of the
! 5/0/0 cable interface. Please note that no IP addresses are assigned to this interface;
! they will be assigned instead to the logical subinterfaces. All other commands for
! this cable interface should be configured to meet the specific needs of your cable RF
! plant and cable network.
interface Cable5/0/0
no ip address
ip directed-broadcast
no ip mroute-cache
load-interval 30
no keepalive
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream frequency 855000000
cable upstream 0 frequency 30000000
cable upstream 0 power-level 0
no cable upstream 0 shutdown
cable upstream 1 shutdown
cable upstream 2 shutdown
cable upstream 3 shutdown
cable upstream 4 shutdown
cable upstream 5 shutdown
!
! Configures the physical aspects of the 5/0/0.1 cable subinterface. If cable modems have
! not been assigned IP addresses, they will automatically come on-line using the settings
! for subinterface X.1.
interface Cable5/0/0.1
description Cable Administration Network
!
! Associates this interface with the VRF and MPLS VPNs that connect to the MSO cable
! network registrar (CNR). The CNR provides cable modems with IP addresses and other
! initialization parameters.
ip vrf forwarding MSO
!
! Defines a range of IP addresses and masks to be assigned to cable modems not yet associated with an ISP.
ip address 10.0.0.0 255.255.255.0
!
! Disables the translation of directed broadcasts to physical broadcasts.
no ip directed-broadcast
!
! Defines the DHCP server for cable modems whether they are associated with an ISP or
! with the MSO acting as ISP.
cable helper-address 10.4.1.2 cable-modem
!
! Defines the DHCP server for PCs that are not yet associated with an ISP.
cable helper-address 10.4.1.2 host
!
! Disables cable proxy Address Resolution Protocol (ARP) and IP multicast echo on this
! cable interface.
no cable proxy-arp
no cable ip-multicast-echo
!
! Configures the physical aspects of the 5/0/0.2 cable subinterface.
interface Cable5/0/0.2
description MSO as ISP Network
!
! Assigns this subinterface to the MPLS VPN used by the MSO to supply service to
! customers擁n this case, MSO-isp.
ip vrf forwarding MSO-isp
!
! Defines a range of IP addresses and masks to be assigned to cable modems associated
! with the MSO as ISP network.
ip address 10.1.0.0 255.255.255.0 secondary
!
! Defines a range of IP addresses and masks to be assigned to host devices associated
! with the MSO as ISP network.
ip address 10.1.0.0 255.255.255.0
!
! Disables the translation of directed broadcasts to physical broadcasts.
no ip directed-broadcast
!
! Defines the DHCP server for cable modems whether they are associated with an ISP or
! with the MSO acting as ISP.
cable helper-address 10.4.1.2 cable-modem
!
! Defines the DHCP server for PC host devices.
cable helper-address 10.4.1.2 host
!
! Disables cable proxy Address Resolution Protocol (ARP) and IP multicast echo on this
! cable interface.
no cable proxy-arp
no cable ip-multicast-echo
!
! Configures the physical aspects of the 5/0.3 cable subinterface
interface Cable5/0/0.3
description ISP1's Network
!
! Makes this subinterface a member of the MPLS VPN.
ip vrf forwarding isp1
!
! Defines a range of IP addresses and masks to be assigned to cable modems associated
! with the MSO as ISP network.
ip address 10.1.1.1 255.255.255.0 secondary
!
! Defines a range of IP addresses and masks to be assigned to host devices associated
! with the MSO as ISP network.
ip address 10.0.1.1 255.255.255.0
!
! Disables the translation of directed broadcasts to physical broadcasts.
no ip directed-broadcast
!
! Disables cable proxy Address Resolution Protocol (ARP) and IP multicast echo on this
! cable interface.
no cable proxy-arp
no cable ip-multicast-echo
!
! Defines the DHCP server for cable modems whether they are associated with an ISP or
! with the MSO acting as ISP.
cable helper-address 10.4.1.2 cable-modem
!
! Defines the DHCP server for PC host devices.
cable helper-address 10.4.1.2 host
!
! Configures the physical aspects of the 5/0/0.4 cable subinterface
interface Cable5/0/0.4
description ISP2's Network
!
! Makes this subinterface a member of the MPLS VPN.
ip vrf forwarding isp2
!
! Defines a range of IP addresses and masks to be assigned to cable modems associated
! with the MSO as ISP network.
ip address 10.1.2.1 255.255.255.0 secondary
!
! Defines a range of IP addresses and masks to be assigned to host devices associated
! with the MSO as ISP network.
ip address 10.0.1.1 255.255.255.0
!
! Disables the translation of directed broadcasts to physical broadcasts.
no ip directed-broadcast
!
! Disables cable proxy Address Resolution Protocol (ARP) and IP multicast echo on this
! cable interface.
no cable proxy-arp
no cable ip-multicast-echo
!
!
cable dhcp-giaddr policy
!
!! Defines the DHCP server for cable modems whether they are associated with an ISP or
! with the MSO acting as ISP.
cable helper-address 10.4.1.2 cable-modem
!
! Defines the DHCP server for PC host devices.
cable helper-address 10.4.1.2 host
!
!
end

P ルータの設定例

この例(システム情報表示)では、インストールされている Cisco IOS ソフトウェアのバージョンを識別し、PE 設定を表示します。

Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R7460-7206-02
!
enable password xxxx
!
ip subnet-zero
ip cef
ip host brios 223.255.254.253
!
interface Loopback0
ip address 10.2.1.3 255.255.255.0
no ip directed-broadcast
!
interface Loopback1
no ip address
no ip directed-broadcast
no ip mroute-cache
!
interface FastEthernet0/0/0
ip address 1.7.108.2 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
shutdown
full-duplex
no cdp enable
!
router ospf 222
network 10.0.1.0 255.255.255.0 area 0
network 10.0.2.0 255.255.255.0 area 0
network 10.0.3.0 255.255.255.0 area 0
network 10.0.4.0 255.255.255.0 area 0
network 20.2.1.3 255.255.255.0 area 0
!
ip classless
no ip http server
!
!
map-list test-b
no cdp run
!
tftp-server slot0:master/120/ubr10k-p6-mz.122-2.XF
!
line con 0
exec-timeout 0 0
password xxxx
login
transport input none
line aux 0
line vty 0 4
password xxxx
login
!
no scheduler max-task-time
end

BGP ルーティング セッションの設定例

プロバイダー ネットワークに BGP ルーティング セッションを設定するには、PE ルータに対してルータ コンフィギュレーション モードで次の作業を行います。


ステップ 1 自律システム番号を指定し、BGP ルーティングプロセスを設定します。

Router(config)# router bgp 42
 

ステップ 2 近接の IP アドレスまたは BGP ピアグループを指定し、ローカルの自律システムに対して明確にします。

Router(config-router)# neighbor 200.28.28.40
Activate the advertisement of the IPv4address family.
Router(config-router)# neighbor 200.28.28.40 activate
 


 

PE 間ルーティング セッションの設定例

プロバイダー ネットワークに PE 間ルーティング セッションを設定するには、PE ルータに対してルータ コンフィギュレーション モードで次の作業を行います。


ステップ 1 VPNv4 Network-Layer Reachability Information(NLRI; ネットワーク レイヤ到着可能性情報)交換用 internal Border Gateway Protocol(iBGP; 内部 Border Gateway Protocol)パラメータを定義します。

Router(config-router)# address-family vpnv4 unicast
 

ステップ 2 VPNv4 NLRI の交換を行う IBGP セッションを定義します。

Router(config-router-af)# neighbor 200.28.28.45 remote-as 48
Router(config-router-af)# exit
 

ステップ 3 IPv4 アドレス ファミリーのアドバタイズをアクティブにします。

Router(config-router)# neighbor 200.28.28.45 activate
 


 

BGP PE/CE ルーティング セッションの設定例

BGP PE/CE ルーティング セッションを設定するには、PE ルータに対してルータ コンフィギュレーション モードで次の作業を行います。


ステップ 1 PE/CE ルーティング セッションの external Border Gateway Protocol(eBGP; 外部 Border Gateway Protocol)パラメータを定義します。

Router(config-router)# address-family ipv4 unicast vrf
go_fast_internet_company
 

ステップ 2 PE ルータと CE ルータの間に eBGP セッションを定義し、IPv4 アドレス ファミリーのアドバタイズをアクティブにします。

Router(config-router-af)# neighbor 200.28.28.46 remote-as 49
Router(config-router-af)# neighbor 200.28.28.46 activate
 


 

RIP PE/CE ルーティング セッションの設定例

RIP PE/CE ルーティング セッションを設定するには、PE ルータに対してルータ コンフィギュレーション モードで次の作業を行います。


ステップ 1 RIP をイネーブルにし、PE/CE ルーティング セッションに RIP パラメータを定義して、PE/CE リンクで RIP をイネーブルにします。

Router(config)# router rip
Router(config-router)# address-family ipv4 unicast vrf
go_fast_internet_company
Router(config-router-af)# network 200.28.28.47
 


 

スタティックルート PE/CE ルーティング セッションの設定例

スタティックルート PE/CE ルーティング セッションを設定するには、PE ルータに対してルータ コンフィギュレーション モードで次の作業を行います。


ステップ 1 各 PE/CE セッションと各 BGP PE/CE ルーティング セッションのスタティック ルート パラメータを定義します。

Router(config)# ip route vrf go_fast_internet_company 200.28.28.46
255.255.255.0 200.28.28.50
Router(config-router)# address-family ipv4 unicast vrf
go_fast_internet_company
 

ステップ 2 VRF スタティックルートと直接接続ネットワークを VRF BGP テーブルに再配信します。

Router(config-router-af)# redistribute static
Router(config-router-af)# redistribute static connected